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Items Supplied
Agilent 14565B Quick Start Guide
This guide provides a Quick overview of the operation of the 14565B
Device Characterization Software. For complete operating details, refer to
the on-line Help document that is included on the CD-ROM or can be
accessed from within the 14565B application.
Software Entitlement Certificate
This certificate is only provided with the full or upgrade version of the
14565B software.
One of the following CD-ROMs
Agilent 14565B Device Characterization Software
This is the full version of the software. A software license is required.
Agilent 14565U Device Characterization Software
This is the upgrade version of the software. It requires a previous
version (Agilent 14565A) of the software installed on the computer.
A software license is required.
Agilent 14565E Device Characterization Software
The evaluation version of the software. This version will only run for 30
days from when the software is first run. At the end of the evaluation
period the software will stop working. A software license is NOT
required.

System Requirements
Computer

Pentium 233 MHz (minimum) with 64 Mbytes RAM

Platforms

Windows 2000
Windows XP

Interface
Cards and
Libraries

Agilent 82350A and 82341C card with
Agilent IO Library version K.01.00 or later
or
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National Instruments GPIB card with
National Instruments VISA Run-time Engine version 2.6
2

Requires NI-488.2 (Win32) version 1.6 or later

Agilent 66309B/D3
Agilent 66311A/B/D3
Agilent 66312A/66332A3
Agilent 66319B/D; 66321B/D

Supported
dc Source
Models
3

Does not support CCDF measurements and long term data logging.
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Description
The Agilent Technologies 14565B Device Characterization Software is an easyto-use graphical user interface for the Agilent 66300-series dc sources. With it,
you can:
Control output and measurement functions from a single window.
View output measurements on an oscilloscope-like display.
Copy, save, or print captured waveforms.
Recall saved waveforms for on-screen comparison with live waveforms.
Adjust horizontal and vertical markers to perform measurements on a
selected section of the waveform.
Operate in either simulation mode (no hardware required), or in instrument
control mode.
Long-term voltage and current data logging.

•

1

Generate CCDF graphs of battery current drain.

1

1

Available on 66319B/D and 66321B/D dc sources with firmware version A.03.00 or later.
Firmware upgrade p/n = 5182-9091.Refer to the on-line help for firmware upgrade instructions.

NOTE: The Agilent 14565B Device Characterization Software does not control
instruments other than the supported Agilent dc sources. Drivers for
other GPIB instruments are not provided.

Automation Interface
The Agilent 14565B Automation Interface lets you automate, or control the
Agilent 14565B Device Characterization functions from another program. The
Agilent 14565B Automation Interface is supported by programming languages
or applications that can use COM components for communication.
The following programming environments are presently supported:
Agilent Wireless Test Manager (WTM).
Microsoft Excel.
National Instruments LabView.
Visual C++ using MFC.
Visual Basic 6.0
Visual C# .NET.
Visual Basic .NET
Visual Basic for Applications (VBA)
NOTE: Refer to the Agilent 14565B Automation Programming Guide for
complete information on using the Agilent 14565B Device
Characterization software within the listed programming environments.
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Installing and Running the Software
NOTE: Before running the Agilent 14565B application, you must have installed
and connected the dc source to a computer with the appropriate interface
cable. You must also have the appropriate interface card installed and
configured. If you are using an Agilent interface card, you must have the
appropriate SICL or VISA library drivers installed.
1.
2.

3.

Place the CD-ROM in the CD-ROM drive and run Agilent14565B install.
Follow the directions on the screen to install the software. The Readme.txt
file contains product updates or corrections that are not documented in the
on-line help file. Use any text editor to open and read this file.
To run the Agilent 14565B application from the Start menu, click:
Programs | Agilent 14565B

Additional information about the Agilent 14565B application is available in
the on-line help document that can be accessed from the application.

Configuring the I/O
This step is necessary to establish communication with the dc source. Make sure
that the dc source is turned on. To configure the I/O, select I/O Configuration
command in the Source menu. The I/O configuration screen comes up
automatically when you turn Simulation mode off in the Source menu. Note that
VISA is the required I/O type for the Data Logging and CCDF functions.
Select I/O type.
(HP-IB, GPIB,
VISA, or serial)

Serial port only.
Specifies the comm
port on the PC.
Serial port only. Dc
source must match
these Baud rate,
Parity and Flow
control settings.

Address must
match setting of
instrument.
(HPIB/GPIB only)
For HP-IB cards
only. Must match
SICL name used
in GPIB card’s
configuration.

Click to automatically
search for any dc
source on the
interface.

If there seems to be no communication between the Agilent 14565B application
and the dc source, select Auto Detect to detect any dc sources connected to your
computer. If you still cannot communicate with the dc source and you wish to
exit the application, select Simulation mode in the IO type field. Then exit the
application.
NOTE: If you program the unit from its front panel while the Agilent 14565B
application is running, you must refresh or update the application. Go to
the View menu and select the Reread Instrument State command.
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Performing Basic Operations
The Main window appears when you run the Agilent 14565B application. From
this window you can control the output of the dc source and view output
measurements.
NOTE:

Not all controls are displayed when you initially run the Agilent
14565B application. Output 2 controls are only available on Agilent
66309B/D and 66319B/D. DVM controls are only available on
Agilent 66311D/66309D and 66319D/66321D.
Click V to
measure voltage;
Click A to
measure current.

Turn on
output 1.

Click to make a
measurement.
This overwrites
the previous
waveform.

Enter voltage
and current
for output 1.
Output 2 and
DVM controls
not available
on all models.
Use View menu
to display.

Adjust values to
vary sample rate
and vertical scale.
Can be done
before or after
measurement.

To display a sample waveform:
Select the Load Waveform command in the File menu, and then select
DemoWaveform1.txt.
Select Active Waveform in the Load Waveform Location dialog box. The
waveform should match the one shown in the above figure.
To set the voltage, current, and resistance levels:
Click in the field labeled Voltage, type in the desired output voltage and
press Enter.
Enter a current limit value in the field labeled Current.
For units that have programmable output resistance, enter a resistance value
in the field labeled Resistance.
To turn on the output:
Enable the dc source output by moving the slide switch to ON. On some
models, each output has its own output control. If the message OVLD
appears in the display, set the Current Measurement control to the Hi Range.
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To make a measurement:
Click the A button to select current measurements; click the V button to
select voltage measurements.
Click the Measure button to make the measurement.
Adjust the time/div and amps/div fields to adjust the sample rate and vertical
scale. Click Auto Scale to fit the display to the acquired waveform.
To view the output 2 controls and the DVM display:
If your dc source has a second output or a DVM input, go to the View menu
and check the item that you wish to display.
✔ Second Output
✔ Digital Voltmeter
If the item is grayed out, your dc source does not have this feature.

Display Area
The display area displays the output measurement after the Measure button is
pressed. Only measurements from the main output can be displayed. The
following figure describes the various measurements displayed in the window.
Maximum
measured
value.
Average high
level.

Vertical axis
displays
amplitude.

Average low
level.

Minimum
measured
value.
Displays the
measurements
calculated from
the waveform.

The values in the measurement area at the bottom of the display are calculated
from the all of the data that is captured in the display. If horizontal markers have
been set, measurements are calculated only from the data between the markers.
Refer to Performing Measurements on Waveforms.
Calculated measurements at the bottom of the display may not agree exactly with
values shown on the front panel of the instrument if the sample rate of the
display differs significantly from the instrument’s front panel sample rate.
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Making Triggered Measurements
Triggered measurements let you control when the measurement trigger will
occur. The following figure describes the various trigger controls.
NOTE:

If you do not know where to set the trigger level, you can make a
measurement with the trigger set to Auto Trig. Then view the
measurement to see where to place the trigger level. Set the trigger
controls and make another measurement.

Click to
initialize a
triggered
measurement

Move slide
to specify
the trigger
level.

Trigger level
is identified by
a red line.

Set up the
triggered
measurement

Trigger point
is identified by
a vertical red
line.

Move slide to
specify a
trigger offset.

Specifies a
hysteresis band
around the
trigger level.

Specify the # of
sweeps. Refer
to the on-line
help.

Click the A button to select current measurements; click the V button to
select voltage measurements.
•

Set the time/div control to a value that is appropriate for the load’s transient
timing.

•

Set up the measurement trigger. Choose from Auto, Pos Slope, Neg Slope,
or Either Slope. External lets you apply an external trigger signal to the
Output Port connector. Refer to the User’s Guide for more information.

•

Adjust the Level slide control until the trigger level is at the point where the
trigger should occur. The trigger level is displayed as a red horizontal line
on the display.

NOTE:
•

The trigger level cannot go negative. Set the trigger control to Auto
Trig to trigger negative waveforms.

Use the Pre-Trigger control to show pre-trigger waveform information.
When this control is used, the trigger point will be displayed as a short
vertical red line on the bottom of the waveform display graph.
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•

Use the Num. Sweeps control to more accurately average the High level of
multiple current pulses. Refer to the on-line help for more information.

•

To prevent signal noise from triggering a measurement, you can adjust the
Hysteresis slide control to create a hysteresis band around the trigger level.
The hysteresis band is shown in yellow. Triggers cannot occur inside the
hysteresis band.

•

Click the Measure button to initiate the triggered measurement. Note that if
no trigger signal is received, the unit will eventually time-out.

•

The display should now show the voltage or current waveform starting at the
trigger level.

•

Change the amps/div control to adjust the vertical scale or press the Auto
Scale button to maximize the displayed waveform size.

Performing Measurements on Waveforms
Use the marker controls to make precise waveform measurements.
To view the horizontal and vertical markers, click on the marker buttons on
the toolbar. Use the mouse to position the marker.
To display
markers, click
on

Move Y2
marker to top
of waveform.
Move Y1 marker
to bottom of
waveform.

Move X2
marker to left
side of area
of interest.

Move X1 marker
to right side of
area of interest.

Calculated
values are based
on data between
X1 and X2
markers.

Displays the
location of all
markers and
the difference
between them.

You can also zoom in on a specific area of the waveform. Zooming in only rescales the display, no calculations are performed in the zoom area.
To zoom in on a specific area on the display, use either the zoom in button
on the toolbar or use the mouse to draw a rectangle on the display.
To zoom out, use either the zoom out button or place the cursor in the
display area and right-click on the mouse. Then select Zoom Out.
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To zoom,
either click on

Indicates
location of
mouse.

or draw a
rectangle with
the mouse in the
area of interest.

None of these
measurements
are affected by
the zoom
controls.

Placing a Waveform on the Display
Up to two reference waveforms can be shown on the display along with the
measured or active waveform. This is useful if you want to compare waveform
measurements to a “standard” or reference waveform to make a pass/fail
determination on the measurement. Waveforms are displayed in different colors,
which can be edited by selecting Edit/Preferences. Measurement calculations can
only be done on active waveforms, not reference waveforms.
Select the Load Waveform command in the File menu to load a waveform.
Enter the filename of the waveform in the Open dialog box. The default
location is C:\Program Files\Agilent Technologies\14565B DCS.
Select Active Waveform in the Select Waveform Location dialog box only
if you want to perform measurements on the loaded waveform. Note that
data logging and CCDF waveforms cannot be loaded as active waveforms,
only reference waveforms.
Marker calculations can only
be made on active waveforms.
Loading and active waveform
overwrites the display.
Marker calculations cannot be
made on reference waveforms.
Loading a reference waveform
does not overwrite the display.

Use the Remove Waveform command in the File menu to remove a loaded
waveform from the display.

Removing a
waveform does not
delete the waveform
file.
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Generating CCDF Graphs
NOTE:

The CCDF measurement capability is only available on Agilent
66319B/D and 66321B/D dc sources that have firmware version
A.03.00 and up.

Complimentary Cumulative Distribution Function (CCDF) graphs are used to
concisely summarize short and long-term battery drain measurements for
analysis and comparison. It is a cumulative distribution of the amplitude versus
the frequency (or percent) of occurrence. This is especially useful for analyzing
signals that are random over time. CCDF graphs can be made for output 1
voltage, output 1 current, or the DVM input.
Once the measurement is started, the current or voltage is continuously sampled
at the desired sampling rate. The software then creates a histogram comprised of
2048 elements or buckets. Each sampled value is placed into one of the buckets
according to its amplitude. Each time a measurement sample is placed in a
bucket, the value of the bucket is incremented by one. The value in each bucket
only represents the number of times a measurement sample that corresponds to
the bucket's amplitude has been detected. If any samples fall outside the range of
the histogram, the values are clipped and placed in the end buckets.
As the measurement proceeds, all histogram values are normalized, summed, and
then reordered from 100% to 0% to generate the CCDF graph.
Click the

button to select the CCDF measurement window.

Select a current
range and type.
Pulse is preferred.

Click to start
the CCDF
measurement

Select the kind of
measurement.

Horizontal and
vertical markers
displayed.

Specify the
duration of the
acquisition.

Y axis indicates
% occurrence of
the data.

Displays the
remaining time of
the acquisition.

X axis Indicates
the amplitude of
current/voltage.

Select the Measurement mode on the left side of the screen. Select Current,
Voltage, or DVM.
For Current measurements, select a range. Select High, Medium, or Low.
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For Current measurements, also select a Type. The preferred type is Pulse
because it provides the best accuracy for waveform measurements.
Select the Acquisition Period (the duration of the CCDF measurement).
Enter the time in hours, minutes, and seconds (hhhh:mm:ss). This controls a
timer that tells the application when to stop the measurement.
Click the Measure button to start the CCDF measurement.
The display will now update periodically until the acquisition period is
complete. The Remaining Period field indicates how much time has elapsed
since the beginning of the test.
NOTE: If you use the front panel controls on the left side of the window to
change any settings during the acquisition, this changes the conditions
under which the data is collected and may invalidate the data.
To prevent unauthorized access of the application during long tests,
enable the password-protect feature of your computer's screen saver.

Long Term Data Logging
NOTE:

The long-term data logging capability is only available on Agilent
66319B/D and 66321B/D dc sources that have firmware version
A.03.00 and up.

Long-term data logging, for hours to days, of the current and voltage of the
device under test is fundamental in measuring its power consumption and
determining its battery operating time. Long-term data logging measurements
can be made for output 1 current, output 1 current and voltage, or output 1
current and DVM input.
Once the measurement is started, the current or voltage is continuously
integrated over the acquisition period. Current measurements are captured over a
5-millisecond to 1-second integration time at a 15.6 microsecond sampling rate.
Three values are returned - dc, maximum, and minimum. The dc value is
calculated by averaging all samples taken over the duration of the integration
period. The highest sample is the maximum value; the lowest sample is the
minimum value. If selected, voltage measurements are also taken at regular
intervals during the acquisition period. Data acquisition is continuous - unless it
is stopped or until the end of the measurement period is reached.
The graph displays three separate current waveforms; maximum, minimum and
dc, each in a different color. If Grey Band is selected as the current graph type,
the graph displays the minimum and maximum values as a gray band behind a
red line. The red line indicates the dc value. If selected, voltage values are
displayed as a blue line on the top of the display. The data appears as the
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measurements are made. When the data fills the display, the display is resized to
a larger resolution to allow more room for the data to be displayed.
Click the

button to access the Data Logging measurement window.

Select a current
range and type.
Pulse is preferred.

Click to start
long-term
data logging.

Select the kind of
measurement.

Voltage
amplitude.

Specify the
duration of the
acquisition.

Maximum
current.

Displays the
remaining time of
the acquisition.

DC current.

Minimum
current.

Select which
measurements to
graph.

Select the Measurement mode on the left side of the screen. Select Current,
Voltage + Current, or DVM + Current.
Select the Current Measurement Range. Select High, Medium, or Low.
Select the Current Measurement Type. The preferred type is Pulse because
it provides the best accuracy for waveform measurements.
Select the Acquisition Period (the duration of the data logging). Enter the
time in hours, minutes, and seconds (hhh:mm:ss). This controls a timer that
tells the application when to stop the measurement. The timer has a
minimum resolution of 3 seconds.
Select which current measurements to graph. Select Max, DC, Min, or Gray
Band. (Max, Dc, and Min. shown).
Press the Measure button to start the data logging.
The display will now update periodically until the acquisition period is
complete. The Remaining Period field indicates how much time has elapsed
since the beginning of the test. When the test completes, you are prompted
to specify a filename in which to save the data in binary format.
NOTE: If you use the front panel controls on the left side of the window to
change any settings during the acquisition, this changes the conditions
under which the data is collected and may invalidate the data.
To prevent unauthorized access of the application during long tests,
enable the password-protect feature of your computer's screen saver.
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Saving and Printing Measurement Data
Use the Save Waveform to ASCII command in the File menu to save the
voltage or current measurement data to an ASCII text file that you specify in
the Save As dialog box.
Displays the
present directory.
Displays all files in
the present
directory.

Enter the
filename.
Specify the
file type.

Voltage or current waveforms are saved in a 2-column Time/Voltage or
Time/Current format. CCDF measurements are saved in a 2-column Amplitude
and %Occurrence format. This text information can be imported into a database
or spreadsheet, or edited by a text editor.
Data logging entries are saved in a binary file while the data logger is running.
When the data is saved to an ASCII file, it is first partitioned and averaged to fit
into the maximum of 4096 entries for ASCII files. ASCII data is saved in a 5column format: Time, CurrentMax, CurrentDC, CurrentMin, and Voltage.
The Agilent 14565B application supports printing and print previewing of the
display. Use the Print Preview command in the File menu to preview the
display. Use the Print command to print the display to your default printer.

Advanced Controls
To configure the protection settings of the dc source:
Select the Source Settings command in the Source menu.
Enables
overcurrent
protection and sets
overcurrent
Displays overvoltage
limit settings.
Specify a compensation
mode based on wiring
and output bandwidth.
Refer to the on-line help
for more information.

Save or recall
instrument states
in non-volatile
memory.
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To configure output measurements:
Select the Measurement Settings command in the Source menu.
Selects the
windowing function
for measurement
calculations. Refer to
the on-line help for
more information.

Selects the current
type. Use Pulse for
waveforms. Refer to
the on-line help for
more information.
Selects low, medium,
or high current range
measurements.

To configure display preferences:
Select the Preferences command in the Edit menu.
Displays Min, Max,
High and Low
waveform markers.

Returns the settings
to the factory
default values.

Displays gridlines.

Specify the update
rate of the voltage
and current meters

Use these controls to
select and change
waveform colors.
Specify whether
specific prompts will
appear on display.

Use these controls to
select a different
directory.

Location of
temporary
waveform files.
Location of data
logging files.

To configure CCDF settings:
Select the CCDF Settings command in the Source menu. All parameters
can also be set in the CCDF measurement window.
Displays total
acquisition time in
hours, minutes
and seconds.

Displays the present
sample point for
which data is being
collected.

Selects the
measurement
input.

Selects a current
measurement
range.

Displays the
sample time in
seconds.

Selects a current type.
Pulse is preferred.
The high and low
limit of the current
range.

Displays the initial
histogram size.
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To configure Data Logging settings:
Select the Data Logging Settings command in the Source menu. All
parameters except the integration time and the file saved directory can also
be set in the Data Logging measurement window.
Displays total # of
acquisitions that
will be made and
resultant file size.

Displays total
acquisition time in
hours, minutes and
seconds.

Selects a current
measurement range.

Selects the type of
measurement.

Selects a current type.
Pulse is preferred.

The location of
binary data file in
which data is
saved.

Specify which current
measurements to
graph.

Selects present
integration time in
seconds. Refer to
the on-line help for
more information.

To create data logging event tags for specific areas of the data log:
Select the Data Logging Event Tags command in the Source menu. This
command is active only when the Measure Data Logging command or icon
has been selected.

Existing event
tags list.

Add an Event tag.
Edit the selected
Event tag.
Delete an Event tag.

Select Add to add a new event tag.
Specify a time
stamp for the
event tag.

Sample
event tag.

Specify a
meaningful
label to
describe the
event tag.
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To convert data log binary files to CCDF graphs:
Select the Convert Data Log to CCDF command in the File menu. This is
useful for using the CCDF graph to analyze all or a specific portion of a
previously captured data log binary file. Note that this command is only
active when the application is in CCDF graph mode.
Select the
binary data file
that you wish
to convert.

Displays
information
about selected
binary file.
Select either the
entire file or a
portion of the file
to export.

Specify the end
point of the
partial period.

Specify the start
point of the
partial period.
Processing
time to convert
data.

Number of
data points in
the export file.

To export data log binary files to a Microsoft Excel or a text file:
Select the Export Data Log to Excel/Text command in the File menu. This
is useful if you need to export the binary data from this application to other
software applications.
Select the
binary data file
that you wish
to export.

Displays
information
about selected
binary file.
Select either the
entire file or a
portion of the file
to export.

Specify the end
point of the
partial period.

Specify the start
point of the
partial period.

Export either
to an Excel
spreadsheet
or a text file.

Number of
data points in
the export file.

Specify a % of
data reduction if
the export file is
too large.

Processing
time for
exporting data.
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Sample Waveforms
Several sample waveforms are provided with the Agilent 14565B application. If
you do not have a dc source connected to your computer, you can still become
familiar with the application by trying out the various display functions using the
sample waveforms. Use the Load Waveform command in the File menu to load
one of the sample waveforms.
DemoWaveform1.txt
This waveform is a single transmit current pulse from a cellular phone. It clearly
shows the location of the Max, High, Min, and Low measurement points.
DemoWaveform2.txt
This waveform is also a single transmit current pulse from a cellular phone. Its
main features are the multiple low-level signals. Note that the High and Low
levels of the waveform are based on the two portions of the measurement (out of
a total of 1024 equally divided portions), that have the most high or low points and that include at least 1.25% of the total measurement points.
DemoWaveform3.txt
This waveform includes three transmit current pulses from a cellular phone. Note
that in this case, the High and Max values are the same. This is because no
portion of the measurement above the 50% point includes at least 1.25% of the
total measurement points.
DemoWaveform4.txt
This waveform is a sample CCDF measurement. The step in the middle of the
graph indicates the point in which a shift occurs - from listen mode to talk mode,
for example.
DemoWaveform5.txt
This waveform is a sample data logging measurement. Three current levels are
shown; maximum, dc, and minimum. The voltage amplitude is also shown.
Data Log(15 Hours).bin
This waveform is a 15 hour sample data logging measurement. Use the zoom
control to zoom in on any portion of the data log.
Data Log(30 seconds).bin
This waveform is a 30 second sample data logging measurement. It illustrates the
current waveforms of a cell phone being used manually.
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Licensing
A software license is associated with a single Agilent 663xx power supply, not
your computer. The licenses can be stored on your local PC or a network drive.
This allows you to install the Agilent 14565B software on multiple PCs and be
able to connect each PC to the Agilent 663xx power supply.
Obtaining the License:
1.

To obtain an Agilent 14565B license for an Agilent 663xx power supply
you will need:
a.

A 14565B full-version or 14565U upgrade-version of the software.
Purchasing one of these software versions entitles you to obtain a
license.

b.

The serial number of the 663xx power supply that you will be
controlling with the software. The serial number is a 10-character
string in the format MY12345678. There are various ways to retrieve
the serial number:

c.
d.
2.

•

Query the power supply with the *IDN? Command.

•

On the front panel, press Address and scroll to the SN: item.

•

From the Agilent 14565B application, select Help then Licensing.
Your email address.

Your Order number and Certificate number. These appear in the
upper right corner of the Software Entitlement Certificate.

To get the license file go to: http://www.agilent.com/find/softwarelicense
and follow the on-screen directions.
a.

Enter the Order number and Certificate number. Click Next.

b.

Under Request License(s) for, check the box labeled “A single product
on one or more instruments or host computers”.
Under Please Choose a Product, select “14565B” for the full-version
or “14565U” for the upgrade-version. Click Next.

c.

Enter the model number and serial number of the Agilent 663xx power
supply you wish to license for the Agilent 14565B software. Click Add,
then Next.

d.

Review your selections. Click Next.

e.

Enter your e-mail address, confirm and Submit.

After finishing the license request procedure, a license file will be emailed to you
shortly. Follow the instructions under “Installing the License”.
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Installing the License:
A license file was emailed to you after you completed the procedure under
“Obtaining the License”. The email attachment is the license file.
1.

Save the license file (*.lic) in the default license folder located at
C:\Program Files\Agilent\14565B\Licenses.
You may also chose a network drive folder.

2.

Run the Agilent 14565B software and try connecting to the power
supply you purchased the license for. The License Main window
should appear and give you the status of the license. To access the
License Main window at any time, click on the Licensing command in
the Help menu. If a license for the Agilent 663xx power supply was not
found, continue with the next steps.

3.

If the folder that you saved the license file in is not part of the Agilent
14565B license search folders, you need to add the folder to the license
search folders.

a.

Click the License Manager button in the License Main window.

b.

In the License Manager, click the Add Folder button. Locate and add
the folder in which you saved the license file.

c.

You should now see the serial number of the licensed Agilent 663xx
power supply in the Licenses Found list.
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