Advanced Design System 1.5
Data Display

December 2000
Notice

The information contained in this document is subject to change without notice.

Agilent Technologies makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Agilent Technologies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Warranty

A copy of the specific warranty terms that apply to this software product is available upon request from your Agilent Technologies representative.

Restricted Rights Legend

Use, duplication or disclosure by the U. S. Government is subject to restrictions as set forth in subparagraph (c) (1) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 for DoD agencies, and subparagraphs (c) (1) and (c) (2) of the Commercial Computer Software Restricted Rights clause at FAR 52.227-19 for other agencies.

Agilent Technologies
395 Page Mill Road
Palo Alto, CA 94304 U.S.A.

Copyright © 2000, Agilent Technologies. All Rights Reserved.
Contents

1 Data Display Basics
   Opening a Data Display Window ............................................................................... 1-3
   Inserting Pages ........................................................................................................ 1-4
   Creating a Data Display .......................................................................................... 1-5
       Using a Dataset .................................................................................................. 1-5
       Choosing a Plot Type ....................................................................................... 1-7
       Selecting a Data Variable ................................................................................ 1-8
       Selecting a Trace Type .................................................................................... 1-9
       Adding Markers ............................................................................................... 1-10
   Writing and Displaying Equations ........................................................................ 1-12
   Saving a Data Display ......................................................................................... 1-14
   Using a Template in Your Display ....................................................................... 1-14
   Viewing the Display Area .................................................................................... 1-15
   Scrolling through Lists and Traces ....................................................................... 1-15
   Editing a Data Display .......................................................................................... 1-16
       Selecting Objects ............................................................................................. 1-17
       Moving Objects ............................................................................................... 1-18
       Scaling Objects ............................................................................................... 1-18
       Arranging Objects ........................................................................................... 1-19
       Cutting, Copying, Pasting, and Deleting .......................................................... 1-19
   Closing a Data Display Window ........................................................................... 1-20
   Setting Data Display Preferences ....................................................................... 1-20
   Printing Your Work ............................................................................................. 1-21
   Locating Data Display Examples .......................................................................... 1-21

2 Plots and Lists
   Inserting Plots ....................................................................................................... 2-1
   Editing Plots .......................................................................................................... 2-3
   Setting Plot Preferences ....................................................................................... 2-11
   Inserting Lists ....................................................................................................... 2-13
   Editing Lists .......................................................................................................... 2-15
   Setting List Preferences ....................................................................................... 2-19

3 Traces
   Inserting a Trace ................................................................................................... 3-2
       Selecting Independent and Dependent Variables .............................................. 3-4
       Viewing Complex Data on a Rectangular Plot .................................................. 3-4
   Editing Traces ....................................................................................................... 3-5
   Deleting Traces ...................................................................................................... 3-8
   Setting Trace Preferences .................................................................................... 3-9
4 Equations
   Inserting Equations......................................................................................... 4-1
   Shortening Variable Names.............................................................................. 4-3
   Viewing Data From Multiple Datasets............................................................ 4-3
   Viewing Equation Results.................................................................................. 4-4
   Working with Multidimensional Data............................................................... 4-5
     Data Structure ............................................................................................... 4-7
     Accessing Data .............................................................................................. 4-7
     Accessing Sequences of Data ....................................................................... 4-8
   Working with Swept S-parameters .................................................................. 4-12
     Setting up an Example .................................................................................. 4-12
     Data Structure ............................................................................................... 4-14
     Accessing Data .............................................................................................. 4-14
     Working with an S Matrix ............................................................................. 4-18
   Viewing Variable Information ......................................................................... 4-19
     Finding an Index ......................................................................................... 4-19
   Using Markers in Equations .......................................................................... 4-20
     Using Independent Marker Data .................................................................. 4-21

5 Annotating the Data Display
   Inserting Text .................................................................................................. 5-1
   Editing Text ...................................................................................................... 5-2
   Setting Text Preferences................................................................................... 5-3
   Inserting Objects ............................................................................................. 5-4
   Editing Objects ................................................................................................. 5-5
   Adding Date and Time to a Data Display .......................................................... 5-5
   Setting Object Preferences............................................................................... 5-7

6 Markers
   Marker Readout............................................................................................... 6-1
   Inserting Markers............................................................................................. 6-2
   Moving Markers .............................................................................................. 6-2
   Editing Markers............................................................................................... 6-2
   Delta Mode....................................................................................................... 6-3
   Setting Marker Preferences............................................................................. 6-4

7 Command Reference

Index
Chapter 1: Data Display Basics

Data generated by a simulation, as well as data that has been imported from other sources, such as a network analyzer or CITI file, is stored in a dataset. The Data Display window enables you to view and analyze a dataset.

In a Data Display window you can:

- Display data in a variety of plots and formats
- Create plots with more than two axes.
- Add markers to traces to read specific data points
- Write mathematical equations to perform complex operations on data, and display the results
Data Display Basics

- Add text and drawing objects to enhance your documentation
- Edit plot titles and axis labels, equations, text, drawing objects, and column headings in lists.

Data can be plotted on rectangular plots, polar plots, Smith charts, and stacked plots. Data can be displayed as linear traces, histograms, scatter plots, and spectral plots, as well as in digital and wide-word (bus) data formats. In addition to graphical displays of data, data can be viewed numerically in lists.

The basic process of creating a data display consists of the following steps.
The various plot and trace types enable you to display data in different formats. In addition, you can use equations to perform complex mathematical operations on data for further analysis.

**Spurious-Free Dynamic Range Calculation**

The spurious-free dynamic range is calculated here as the difference in power between a desired IF signal at the output and the noise floor, when the intermodulation distortion power is equal to the noise floor power. In this case the IM terms are below the noise floor, so the input power to the mixer must be increased until the IM terms reach the noise floor. Delta is the difference between the noise floor and the IM terms, and the IF signal power must increase by 1/3 of this difference for the IM and noise floor terms to be equal.

\[
\text{SpurFreeDynamicRange} = \frac{m1 + Delta}{3} - \left(\frac{\text{NoisePowerTotal}}{\text{dBm}}\right)
\]

\[
\begin{align*}
m1 &= 250.0000000MHz \\
\text{dBm}(\text{Mixer1..Vif}) &= -38.757290 \\
m2 &= 250.1500000MHz \\
\text{dBm}(\text{Mixer1..Vif}) &= -132.482930
\end{align*}
\]

Opening a Data Display Window

To open a Data Display window:

- Choose **Window > New Data Display** or click the **New Data Display Window** button on the toolbar from the Main or Schematic window.
Data Display Basics

To open additional windows from a Data Display window:

• Choose **File** > **New** or click the **New** button to open a window for a new dataset.
• Choose **View** > **New Window** to open a window for the same dataset.

To open an existing data display:

• Choose **Window** > **Open Data Display** from the Main or Schematic window, select the dataset, and click **OK**.

To close a data display:

• Choose **File** > **Close Window** in the window you want to close. This closes only the active window and does not affect the rest of the data display. If the contents of the display have been modified and it is the only window displaying data from that dataset, you are prompted to save any changes.

The following form the basic elements of a data display window.

• The **Menu bar** displays the menus that are available in a Data Display window
• The **Dataset List** displays the datasets that are available in a Data Display window
• The **Title bar** displays the window type, filename, and a number for identifying which data display window it is
• The **Toolbar** contains buttons for frequently used commands
• The **Display Area** is where you create your data presentations
• The **Instrument Server** enables you to read in data from outside sources, such as an S-parameters from a CITI file or a network analyzer. The instrument server also sends data from Advanced Design System to files and instruments.

**Inserting Pages**

The Data Display allows the user to add multiple pages to the display area. Multiple pages provide the user with additional display area that can be used to display and organize large amounts of data. To insert a new page

1. Choose **Insert** > **Page**.
2. The New Page dialog box appears. Type a new name for the page.
3. Click the **OK** button to close the dialog box and insert the page.
Creating a Data Display

The basic process of creating a data display consists of:

• Choosing a dataset (by name) to display
• Choosing a plot type for the display (Rectangular, Polar, etc.)
• Specifying the data variable to be displayed
• Choosing a trace type (Linear, Scatter, Histogram, etc.)

The various plot and trace types enable you to display data in different formats. Equations enable you to perform complex mathematical operations on data for further analysis.

Optionally, you can enhance your data display by adding:

• Markers identifying specific data points
• Text for clarification
• Graphical objects, such as lines and circles

Using a Dataset

The numerical data presented in a data display window comes from two sources, datasets and equations. Datasets collect and store data either from internal sources, such as a simulation, or from external sources, such as a network analyzer or Touchstone file.

For information on how to enter data from external sources into a dataset, refer to the Using Instruments with ADS manual.

For information on how to write equations, refer to “Equations” on page 4-1.

Choosing a Dataset

When you open a Data Display window, all datasets defined for the current project are available for display. One dataset is selected as the default; it will be used as the
Data Display Basics

source of data unless a different dataset is chosen. If no datasets have been defined for the current project, the label on the drop-down menu reads dataset.

You can also view datasets that are stored under other projects or are not part of a project, such as a dataset that contains measured instrument data. This can be useful for comparing simulated versus actual results or comparing results between projects.

The data display does not store any data, it only retrieves and displays the data within a dataset. Thus, if the data in the dataset changes (for example, if you alter a design and resimulate), the data display will be updated to reflect the most current information in the dataset.

To choose a dataset:

1. Click the arrow to view the drop-down list of currently defined datasets.
2. Choose the name of the desired dataset. The Datasets and Equations list box is updated to reflect the data variables contained in the selected dataset.

Adding a Dataset:

To view a dataset outside the current project:

1. Choose Insert > Plot.
2. Position the pointer, click, and select a plot type.
3. Under Datasets and Equations, select Other Dataset.
4. By default, datasets are saved with the extension .ds under the <project_name>/data directory. Navigate to the file of interest and select the file.
5. Click OK.
Choosing a Plot Type

A variety of plot types are available so that you can view data in different ways. The available plot types are shown in the following illustration.

- Rectangular Plot—displays scalar data in a linear or logarithmic format
- Polar Plot—displays real and imaginary components of complex data on a polar plot
- Smith Chart—displays real and imaginary components of complex data on a Smith chart
- Stacked Plot—displays multiple rectangular plots
- List—displays data in tabular format
- Equation—displays equation created to generate data for display

To specify a plot type:

1. Choose Insert > Plot or click one of the plot type buttons on the palette.
2. As you move the pointer into the display area, an outline of the shape and size of the current plot type appears.
   - If you are satisfied with the size, position the image as desired and click to place it.
   - If you want to change the size of the plot, position the image as desired (the upper-left corner is the reference point), press the left mouse button, and drag the pointer to the opposite corner. When the shape is the desired size, release the mouse button.
3. Use the Plot Traces & Attributes dialog box to add the desired traces to the plot.

4. Click **OK**.

**Selecting a Data Variable**

By default, selected data is plotted as the dependent variable, and the independent variable is a logical default, such as frequency or time. For a rectangular plot or a listing, you can also choose the independent variable.

To select the variable whose data you wish to plot for analysis:

1. Select a dataset from the Datasets and Equations list box. Variables in the dataset appear in the list below.

2. Select a variable and click **Add**. The selected data is added to the Traces list box.

3. Repeat as needed to display the desired data on the current plot.

4. Click **OK**.

To plot one variable against another:
1. Double-click on the plot or select the plot and choose **Edit > Item Options**.
2. The Plot Traces & Attributes dialog box appears.
3. Select a variable from the Datasets and Equations list box. This variable will be plotted along the Y-axis.
4. Click the **Add vs.** button. From the dialog box that appears, select a second variable. (It can be from a different dataset or equation.) This one will be plotted along the x-axis and is considered the independent variable.
5. Click **OK** to accept the variable.
6. Click **OK** to display the trace on the plot.

### Selecting a Trace Type

A trace type is assigned to the data during simulation to simplify viewing results. The trace type can be changed. A variety of trace types are available so that you can view data in different ways.

To select a trace type:

1. Double-click on the plot or select the plot and choose **Edit > Menu Items**.

   **Tip**  You can also double-click the trace directly to display its options.

2. Select at least one variable from the Traces list box.
3. Click **Trace Options** to display the Trace Options dialog box.
4. Click the **Trace Type** tab and select the desired trace type.

5. Click **OK**.

### Adding Markers

You can insert one or more markers onto a trace. Markers return the independent and dependent values of the data at that point on the trace. You can also display the difference between two or more markers using the delta mode. The readouts of the selected markers change relative to the marker that you assign as the reference marker.

To insert a marker:

1. Choose **Marker > New**.

2. Position the pointer on the trace where you want to insert the marker and click.

   You can also drag an existing marker and move it to any position along a trace. An active marker readout is displayed to help you position the marker.
3. The marker data appears next to the marker. To keep your plot uncluttered, enlarge the Data Display window, then select the marker text and drag it off to one side of the plot.

The marker readout includes:

- A label that matches the label on the marker
- The value of the independent variable
- The value of the dependent variable. Data from polar plots and Smith charts is displayed in real and imaginary components; data from rectangular and stacked plots is returned in scalar format.

To activate delta mode:

1. Position the pointer over a marker and **shift+click**. Repeat this for each marker you want to display in delta mode.

2. Choose **Marker > Delta Mode On**.

3. A dialog box appears listing the selected markers. Select one marker from this list to be the reference marker.

4. Click **OK**.
Data Display Basics

The markers can be on different traces within a plot, or even on different plots. Note that the marker symbol of the marker in delta mode is rotated.

![Diagram showing marker symbols and equations]

Writing and Displaying Equations

The Data Display supports the creation and display of complex mathematical equations. The expression can be made up of dataset variables, constants, and expressions.

To insert an equation in the display area:

1. Choose Insert > Equation.
2. Position the pointer in the display area and click. The Enter Equation dialog box appears.
3. Type your equation. The equation variable is the left side of the equation; constants, functions, and dataset variables make up the right side.

4. When the equation is complete, click OK.

To add a dataset variable to an equation:

1. Edit the equation by double-clicking it.

2. Position the cursor in the equation where you want to insert the variable.

3. Select the dataset name from the list box.

4. A list of variables in the dataset is displayed. Select the variable you want to insert.

5. Click Insert and click OK.

To view the results of your equation:

1. Choose Insert > Plot and select a plot type.

2. Select Equations from the Datasets and Equations drop-down list. It appears at the bottom of the list.

3. Double-click the equation variable. To verify or change the default trace type for the chosen data, click Trace Options and proceed to edit the trace.
4. Click **OK** to dismiss the dialog box and display the results of your equation.

![Graph](image)

**Saving a Data Display**

There are two commands for saving a data display: Save and Save As.

- Choose File > Save to save changes to an existing file. A file suffix of .dds is automatically appended to a data display file.
- Choose File > Save As to save the Data Display window as a new file or to save a copy of the open file using a new name.

**Using a Template in Your Display**

Templates are files that contain only the items that are placed in a display area. Templates enable you to store preconfigured plots and other graphical items, which you can use in any data display. For example, you may have a standard set of plots that you use in different projects. Rather than reinsert the plots and edit them for each data display, you design it once and save it as a template. You can then add these plots to any data display window by inserting the template.

Templates can include not only plots but traces, markers, annotation, or any other item that can be inserted in the display area.

To save a data display as a template:

1. Choose File > **Save As Template** in the Data Display window.
2. Supply a name and click OK. The extension .ddt is automatically appended to filenames of data display templates. The template is saved in the current project directory.

To insert a data display template in an existing data display:
1. From the Data Display window, choose Insert > Template.
2. Navigate to the name of the template file that you want to use.
3. Click OK.

To insert a data display template in a new data display:
1. From a Data Display window, choose File > New.
2. Choose Insert > Template.
3. Navigate to the name of the template file that you want to use.
4. Click OK.

**Viewing the Display Area**

To aid in viewing your work, the following commands are available from the View menu and as buttons on the toolbar.

<table>
<thead>
<tr>
<th>Command</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View &gt; View All</td>
<td>View All</td>
<td>View all graphical objects on the display area</td>
</tr>
<tr>
<td>View &gt; Zoom Area</td>
<td>Zoom Rectangle</td>
<td>Zoom in so the selected area fills the window</td>
</tr>
<tr>
<td>View &gt; Zoom In x2</td>
<td>Zoom x2</td>
<td>Zoom in to make objects appear twice as large</td>
</tr>
<tr>
<td>View &gt; Zoom Out x2</td>
<td>Zoom x1/2</td>
<td>Zoom out to make objects appear twice as small</td>
</tr>
<tr>
<td>View &gt; Actual Size</td>
<td>Actual Size</td>
<td>View objects at actual size</td>
</tr>
</tbody>
</table>

Like other Advanced Design System windows, the Data Display window has scroll bars along the window edges so you can pan across the display area.

**Scrolling through Lists and Traces**

The scroll buttons in the toolbar enable you to scroll through long lists of data in listing columns.
Data Display Basics

It also works with other types of plots. If you turn off automatic scaling to display smaller portions of data on a plot, you can use these buttons to move data horizontally across the plot.

To use the scroll buttons:

1. Choose View > Scroll Data.
2. Select the list or trace you want to scroll.
3. Select scroll buttons as shown in the figures below.

---

**Editing a Data Display**

You can make changes to the data display as you work. The typical sequence is to select the object you wish to edit, then perform the operation. In some cases, you can select the command first and then the object. If an edit command has this capability, it is noted.
Selecting Objects

You can select one, several, or all objects on a data display area to facilitate editing your work. A selected item is enclosed with a dashed outline and handles. A selected trace has a thicker, dashed appearance.

![A selected object](image)

The following select options are available.

Table 1-2. Select Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select one object</td>
<td>Click the object.</td>
</tr>
<tr>
<td>Select several objects</td>
<td>Shift+click the objects.</td>
</tr>
<tr>
<td>Select all objects</td>
<td>Choose Edit &gt; Select All.</td>
</tr>
</tbody>
</table>

Deselecting an Object

If you want to deselect an object, click anywhere on the display area that is not occupied by the object.
Data Display Basics

**Moving Objects**
You can move an object anywhere on the display area.

To move an object:
1. Select the object.
2. Drag the object to the new position.
3. The object remains selected and can be moved again.

To move several objects:
1. Select the objects.
2. Hold down the Shift key and drag the objects to the new position.

**Scaling Objects**
To scale an object:
1. Select the item.
2. Drag one of the object handles to reduce or enlarge the object to the desired size.

By dragging a handle, the object can be enlarged (as shown) or reduced.
Arranging Objects

Arranging objects is useful when you have overlapping objects. Select the object of interest and choose an arranging option. The following options are available.

Table 1-3. Options for Arranging Objects

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit &gt; Arrange &gt; Move to Front</td>
<td>Displays the selected object in front of all other objects</td>
</tr>
<tr>
<td>Edit &gt; Arrange &gt; Send to Back</td>
<td>Displays the selected object behind all other objects</td>
</tr>
<tr>
<td>Edit &gt; Arrange &gt; Move Forward</td>
<td>Exchanges the positions of the selected object and the object in front of it</td>
</tr>
<tr>
<td>Edit &gt; Arrange &gt; Move Backward</td>
<td>Exchanges the positions of the selected object and the object behind it</td>
</tr>
</tbody>
</table>

Cutting, Copying, Pasting, and Deleting

You can perform cut, copy, paste, and delete operations in the Data Display much like other windows in Advanced Design System. First select an item in the display area, then choose a command.

Table 1-4. Cut, Copy, Paste, and Delete Operations

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit &gt; Cut</td>
<td>Erase the selected object from the display area and place it on the clipboard</td>
<td>CTRL + X</td>
</tr>
<tr>
<td>Edit &gt; Copy</td>
<td>Place a copy of the selected object on the clipboard</td>
<td>CTRL + C</td>
</tr>
<tr>
<td>Edit &gt; Paste</td>
<td>Place the object on the clipboard in the display area</td>
<td>CTRL + V</td>
</tr>
<tr>
<td>Edit &gt; Delete</td>
<td>Erase the selected object without placing it on the clipboard</td>
<td>DEL</td>
</tr>
</tbody>
</table>

Tip You can also delete an object by first selecting the Delete command, then selecting the object.
Data Display Basics

Closing a Data Display Window

To close a Data Display window, choose File > Close Window in the window you want to close. If the contents of the display are have been modified and it is the only window displaying data from that file, you are prompted to save any changes. This closes only the active window and does not affect the rest of the data display.

Setting Data Display Preferences

The appearance of each type of graphical object can be customized in a number of ways, depending on the type of object. Objects are drawn initially using program defaults, but you can change these characteristics and use them as new defaults for all projects, or you can save your settings to a file for use in an individual project.

To set new defaults for all projects:

1. Choose Options > Preferences.
2. Modify any or all settings as desired and click OK. (These settings are saved in $HOME/hpeesof/config/ddsdefaults.ael.)

Note Preferences are saved when you exit the program. These settings will be the defaults used when you restart the data display.

To save preferences for an individual project:

1. Choose Options > Preferences.
2. Modify any or all settings as desired and click Save.
3. Type the desired filename and click OK.

To read a preferences file:

1. Choose Options > Preferences.
2. Click Read. Navigate to the preferences file, then select the file. Objects will be drawn using the new preferences.
3. Click OK.

You can save different sets of preferences to different files. You can update a Data Display window at any time with a new preferences file. Reading in new preferences overwrites the existing ones.
For information on the characteristics you can change for the different types of objects, refer to the appropriate chapter.

Table 1-5. Setting Data Display Preferences

<table>
<thead>
<tr>
<th>Preferences to be Edited</th>
<th>Refer to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plots and lists</td>
<td>Chapter 2, Plots and Lists</td>
</tr>
<tr>
<td>Traces</td>
<td>Chapter 3, Traces</td>
</tr>
<tr>
<td>Equations</td>
<td>Chapter 4, Equations</td>
</tr>
<tr>
<td>Lines, polylines, rectangles, circles, polygons, and text</td>
<td>Chapter 5, Annotating the Data Display</td>
</tr>
<tr>
<td>Markers</td>
<td>Chapter 6, Markers</td>
</tr>
</tbody>
</table>

Printing Your Work

The print functions in the data display are the same as for other parts of Advanced Design System. Print functions are available from the File menu. For more information on how to use print functions, refer to the User’s Guide.

Locating Data Display Examples

Many of the designs in the Examples directory include data displays. The data displays use a variety of plots, trace formats, markers, and many include equations. These examples can help you design your own data displays so that you can analyze simulation data effectively. A list of some of the examples is given below.

Table 1-6. Data Display Examples

<table>
<thead>
<tr>
<th>Examples Subdirectory</th>
<th>Project</th>
<th>Data Displays</th>
</tr>
</thead>
<tbody>
<tr>
<td>Com_Sys</td>
<td>BER_prj</td>
<td>Displays bit-error rate data in lists, as time-domain waveforms, and on scatter plots.</td>
</tr>
<tr>
<td></td>
<td>cdmafilter_prj</td>
<td>Displays the frequency response, unit step response, and unit pulse response of a filter.</td>
</tr>
<tr>
<td></td>
<td>DeltaSigma_prj</td>
<td>Displays the magnitude of the output of a delta-sigma modulator on a rectangular plot.</td>
</tr>
<tr>
<td></td>
<td>gsm_prj</td>
<td>Displays a variety of waveforms generated in a basic GSM 0.3 GSM system, including the output data, recovered clock, recovered carrier, modulated spectrum, and MSK trajectory.</td>
</tr>
</tbody>
</table>
### Data Display Basics

#### Table 1-6. Data Display Examples (continued)

<table>
<thead>
<tr>
<th>Examples Subdirectory</th>
<th>Project</th>
<th>Data Displays</th>
</tr>
</thead>
<tbody>
<tr>
<td>IS95_prj</td>
<td>Displays the spectrum of a simple IS95 forward channel carrier on a rectangular plot.</td>
<td></td>
</tr>
<tr>
<td>rfsystem_prj</td>
<td>Displays a wide range of simulation results, including TOI in spectral format, budget data in lists, and channel spectra.</td>
<td></td>
</tr>
<tr>
<td>widebandcdma_prj</td>
<td>Displays waveforms generated in a wide CDMA modulator.</td>
<td></td>
</tr>
<tr>
<td>DSP</td>
<td>CHBT_TH_prj</td>
<td>Displays a wide range of results simulating the output from a Sine wave.</td>
</tr>
<tr>
<td>Momentum</td>
<td>Balun_prj</td>
<td>Compares S-parameters of a balun in magnitude and phase on rectangular plots.</td>
</tr>
<tr>
<td></td>
<td>BoxExample_prj</td>
<td>Compares the S-parameters from the box example to a set of reference S-parameters.</td>
</tr>
<tr>
<td></td>
<td>Coupled_Stubs_prj</td>
<td>Displays S-parameters in magnitude and phase on rectangular plots.</td>
</tr>
<tr>
<td></td>
<td>CPW_line_prj</td>
<td>Displays S-parameters in magnitude and phase on rectangular plots.</td>
</tr>
<tr>
<td></td>
<td>Hairpin_filter_prj</td>
<td>Displays the response of the filter.</td>
</tr>
<tr>
<td></td>
<td>Low_pass_filter_prj</td>
<td>Compares measured S(2,1) data to Momentum and Advanced Design simulations.</td>
</tr>
<tr>
<td></td>
<td>Lp4_8Ghz_prj</td>
<td>Identifies the numerical noise floor of the filter.</td>
</tr>
<tr>
<td>MW_Ckts</td>
<td>LNA_prj</td>
<td>Displays a wide range of results from the simulations of a low-noise amplifier, including the S-parameters of an optimized amplifier displayed using lists, Smith charts, and rectangular plots; sweeps of collector-emitter voltage and collector current that display similar to a curve tracer; and the amplifier output from multiple input tones, displayed in spectral format.</td>
</tr>
<tr>
<td></td>
<td>mw_filter_prj</td>
<td>Displays the S-parameters of a 12 GHz bandpass filter, scaled for display on a rectangular plot.</td>
</tr>
</tbody>
</table>
Chapter 2: Plots and Lists

A variety of plot types can be inserted into a data display so that you can view data in different ways. The plot types are:

- **Rectangular**  Displays scalar data in a linear or logarithmic format.
- **Polar**  Displays real and imaginary components of complex data on a polar plot.
- **Smith Chart**  Displays real and imaginary components of complex data on a Smith chart.
- **Stacked**  Displays a vertical stack of rectangular plots, each with the same x axis and different y axes.
- **List**  Displays data in columnar format.

You can have more than one plot in a single window. Some plot examples:

---

**Inserting Plots**

To insert a plot, do the following:
Plots and Lists

1. Choose **Insert > Plot** or select a plot type from the palette.

   - Rectangular Plot
   - Polar Plot
   - Smith Chart
   - Stacked Plot

2. Position the pointer on the display area. A ghost image of a rectangle is attached to the pointer. It indicates the position and size of the plot.

   If you are satisfied with the size and position of the rectangle, click the mouse.

   If you want to customize the size of the plot, position the pointer where you want the upper-left corner of the plot, then drag the mouse. When the rectangle is the desired size, release the mouse.

3. The Plot Traces & Attributes dialog box appears. Plot types are shown across the top and the selected plot type is highlighted. To change to a different plot type, click the button that corresponds to the plot type that you want.
4. Click the **Plot Options** tab to set up the plot. Options include adding titles and scaling data. Changing options are discussed in the next section.

5. The lower part of the dialog box contains selections for adding traces to the plot. These are described in Chapter 3, Traces.

6. Click **OK** to dismiss the dialog box and insert the plot.

**Editing Plots**

The title, grid, scale and other attributes can be changed for an existing plot. Any changes that you make will only affect the currently selected plot. To change properties for all plots added subsequently, refer to “Setting Plot Preferences” on page 2-11.
2-4 Editing Plots

Plots and Lists

Note  Plot options for the chosen plot type are displayed automatically. If the plot options do not seem correct, click the Plot Type tab, click the Plot button corresponding to the type of plot you want, then reselect the Plot Options tab.

To edit a plot, use the following steps:

1. Double-click on the plot.
2. The Plot Traces and Attributes dialog box appears.
3. To change the plot type, click the button corresponding to the new plot type.
4. Click the Plot Options tab.
5. In most cases a plot will use two axes. You can add an additional axis by following these steps:
   • Select an axis from the Select Axis window.
   • Click the Add Axis button and make the following selections to the Create New Axis dialog box:
     Type the name of the axis in the Axis Name field.
     Select an orientation from the Axis Orientation list.
     Click OK to close the Create New Axis dialog box and add the new axis.
6. The Data Display allows you to add a title above a plot or edit an existing title.

---

2-4 Editing Plots
This is done as follows:

- Type the plot title in the Title field.
- If you want to format the title, click More and make the following selections in the Title dialog box:
  - Select a font from the Font Type list.
  - Select a font size from the Font Size list.
  - Click the Color bar, select a text color, then click OK.
  - Click OK to close the Title dialog box.

7. The Data Display allows you to change the text along both axes and to format of the numbers along an axis.

The names of the variables that are displayed on a plot appear along the axes of a plot. The names of the independent and dependent variables are displayed on the x and y axes, respectively.

Plots can display the data from multiple independent variables. Each time a trace is added to a plot, a different color is used to draw the trace. The color of the label matches the trace to help you identify the source of the data.

The figure below displays default axis labels. Note that by giving descriptive names to schematic items like named connections and variables, or to data display equations, you may find it unnecessary to change the default axis labels.
To format a plot’s axis labels and numbers, use these steps:

• Select the axis from the Select Axis window.
• Type directly into the Axis Label field.

**Note**  By default, the names of the independent and dependent variables are displayed as labels along the axes of a plot. If you enter text in the Axis Label field, the variable names along the selected axis will be replaced by this text.

• Click **More** (next to the Axis Label field) and make the following selections in the Axis Label dialog box:

  Select a format for the numbers along the axis from the Format list. The choices are:

  **Auto**  A default format is automatically chosen, based on the type of data to be displayed along the axis.

  **Full**  All digits before the decimal are displayed (i.e., 1530000).

  **Scientific**  Numbers are displayed in scientific format (for example, 1000 is displayed as 1.00e3).

  **Engineering**  Numbers are displayed using engineering notation. For example, frequency values end in Hz. Additionally, numbers are displayed in powers of 10^3 (for example, 1000 Hz is displayed as 1.0 kHz).

  **Hex**  Numbers are displayed in hexadecimal (base 16).

  **Octal**  Numbers are displayed in octal (base 8).

  **Binary**  Numbers are displayed in binary (base 2).
Specify the number of digits that you want to appear after the decimal. If Auto is selected, the number of digits after the decimal is chosen automatically (the # of Decimal Digits field is displayed but any value in this field will not affect the display). For the other formats, the field is displayed as Significant Digits.

Select a font from the Font Type list.

Select a font size from the Font Size list.

Click the **Color** bar, select a new text color, then click **OK**.

---

**Note**  If you set this to a color other than black, all labels will be displayed in this color.

* Click **OK** to dismiss the Axis Label dialog box.
8. The scale on rectangular and stacked plots and Smith charts can be changed to linear or logarithmic format. The scale can be different along each axis.

To change the scale format, do the following:

• Select an axis from the Select Axis window.
• Select Auto Scale.
• Under Scale, select either Linear or Log.
• Select the other axis in the list and change the scale in a similar manner.

9. The data display automatically scales plot axes to display the entire range of a variable on the plot and give an optimum view of the data. For rectangular and stacked plots, you can manually set the start and endpoints of a plot to show only a limited range of data.
On polar plots and Smith charts, you can specify the radius of the plot and the range of data for the independent variable. To manually scale a plot, do the following:

- Select the axis that you want to scale from the Select Axis window.
- Deselect Auto Scale.
- Enter the starting value of the axis in the Min field.
- Enter the ending value of the axis in the Max field. For Smith plots, this is the maximum radius of the plot.
- Enter the incremental value in the Step field (rectangular, stacked, and polar plots only). Grid lines will be placed on the plot along the axis as values increase by this increment.

The full range of data can sometimes be difficult to view.

Viewing a portion of the data can facilitate analysis.
Plots and Lists

• To limit the range of data displayed in Smith charts, deselect **Display All**.
• Enter the minimum value of the data that you want to display in the Start field (polar plots and Smith charts only).
• Enter the maximum value of the data that you want to display in the Stop field (polar plots and Smith charts only).

**Note**  You can scroll through traces that have more data than what is displayed on the plot. Select the trace, then use the scroll buttons on the toolbar to scroll through the trace. For more information on scrolling, refer to “Scrolling through Lists and Traces” on page 1-15.

10. The coordinates used on Smith charts can be changed by choosing **Impedance**, **Admittance**, or **Both** from the Coordinate list box.

11. The type, thickness, and color of lines in a grid can be changed. On rectangular plots and stacked plots, horizontal lines and vertical lines can have different properties. The same is true for impedance and admittance lines on Smith charts.

To edit a plot’s grid, do the following:
• For rectangular and stacked plots, select an axis from the Select Axis window. Select the x axis to format the vertical lines of the grid, select the y axis to format horizontal lines. For stacked plots, the y axis on each plot must be formatted individually.
Setting Plot Preferences 2-11

• Click Grid. The Grid dialog box is displayed. If the plot is a rectangular, polar, or stacked rectangular plot, you will be able to modify the grid attributes. For Smith charts, you will be able to edit either the impedance or admittance lines.

• Select a line pattern from the Type list.

• Select a line thickness either by using the scroll bar or by entering a value into the Points field. Thickness can range from 0 to 10 points. If 0 points is selected, a very thin line is drawn.

• Click the Color bar, select a new color, then click OK.

• Click OK to dismiss the Grid dialog box.

12. You can remove the grid from a plot. To remove the grid:

• Click Grid. The Grid dialog box is displayed.

  Deselect the Display Grid option.

  Click OK to dismiss the Grid dialog box.

13. Click OK to dismiss the Plot Traces & Attributes dialog box and save the changes.

Setting Plot Preferences

Plot preferences set the default plot properties and determine the appearance of a plot in the display area. Preferences affect all plot types and include setting the font type, size, and color for titles and axis labels; the numeric format of axis labels; and the line type, width, and color of grids.

Plot preference changes will apply to all plots created after the changes were made and saved. To change the properties for an existing plot, refer to “Editing Plots” on page 2-3.

Data display preference settings can be saved for reuse by creating a preferences file. For more information on how to create and use such a file, refer to “Setting Data Display Preferences” on page 1-20.

To set plot preferences, use the following steps:

1. Choose Options > Preferences.

2. The Preference dialog box appears. Click the Plot tab followed by the Main tab.
3. To set the plot title attributes, do the following:
   • Select a font from the Font Type list.
   • Select a font size from the Font Size list.
   • Click the Text Color bar, select a color, then click OK.

4. The axis numbers can be formatted for plots that use more than one axis. This is done as follows:
   • Select an axis label format from the Label Format list. The choices are:
     Auto  A default format is automatically chosen, based on the type of data to be displayed along the axis.
     Full   All digits before the decimal are displayed (i.e., 1530000).
     Scientific Numbers are displayed in scientific format (for example, 1000 is displayed as 1.00e3).
     Engineering Numbers are displayed using engineering notation. For example, frequency values end in Hz. Additionally, numbers are displayed in powers of $10^3$ (for example, 1000 Hz is displayed as 1.0 kHz).
     Hex    Numbers are displayed in hexadecimal (base 16).
     Octal  Numbers are displayed in octal (base 8).
     Binary Numbers are displayed in binary (base 2).
   • Specify the number of digits that you want to appear after the decimal. If Auto is selected, the number of digits after the decimal is chosen automatically (the # of Decimal Digits field is displayed but any value in this field will not affect the display). For the other formats, the field is displayed as Significant Digits.

5. To format axis label text, click on Label and make the following selections from the Axis Labels dialog box:
   • Select a font from the Font Type list.
   • Select a font size from the Font Size list.
   • Click the Text Color bar, select a new color, then click OK.
Note If you set this to a color other than black, all labels will be displayed in this color.

• Click OK to dismiss the Axis Label dialog box.

6. To set grid preferences, click Grid and make the following selections in the Grid dialog box:
   • Select a line pattern from the Type list.
   • Select a line thickness either by using the scroll bar or by entering a value into the Points field. Thickness can range from 0 to 10 points. If 0 points is selected, a very thin line is drawn.
   • Click the Color bar, select a new color, then click OK.
   • Select a Smith chart admittance line pattern from the Type list.
   • Select a Smith chart admittance line thickness by using the scroll bar or entering a value into the Points field. Thickness can range from 0 to 10 points. If 0 points is selected, a very thin line is drawn.
   • Select a Smith chart admittance line color by clicking the Color bar, selecting a new color, then clicking OK.
   • Click OK to dismiss the Grid dialog box.

7. To set the axis scale for linear and stacked plots, click the Linear, Stack tab and select Linear or Log.

8. To set the coordinates used on Smith charts, click the Smith tab and select Impedance, Admittance, or Both from the Coordinate list.

9. Click OK to dismiss the Preference dialog box and save the changes.

Inserting Lists

To insert a list, do the following:
Plots and Lists

1. Choose **Insert > Plot** or select **List** from the palette.

2. Position the pointer on the display area. A ghost image of a rectangle is attached to the pointer. It indicates the position and size of the list.
   
   If you are satisfied with the size and position of the rectangle, click the mouse.
   
   If you want to customize the size of the list, position the pointer where you want the upper-left corner of the list, then drag the mouse. When the rectangle is the desired size, release the mouse.
   
3. The **Plot Traces & Attributes** dialog box appears. Plot types and list icon are shown across the top. If the List icon is not highlighted, select it.
4. Click the **Plot Options** tab to set up the list. Options are provided for formatting the data. Changing list options are discussed in the next section.

5. Click **OK** to dismiss the dialog box and insert the list.

**Editing Lists**

Except for titles, lists have options that are not common to the other plot types. You can change these list settings:

- Numeric format of data displayed in lists
- Text format of data, such as font type and color
- Format of the lines that outline a list
- Display of column headings
- Display of data in table format
Plots and Lists

Any changes that you make will only affect the currently selected list. To change the properties for all subsequently created lists, refer to “Setting List Preferences” on page 2-19.

To edit a list, do the following:

1. Double-click on the list.
2. The Plot Traces & Attributes dialog box appears. Click the Plot Options tab.
3. To specify the numeric format of the data, do the following:
   • Select a format for the data from the Format drop-down list. The choices are:
     Auto A default format is automatically chosen based on the type of data displayed.
     Full All digits before the decimal are displayed (for example, 1530000).
     Scientific Numbers are displayed in scientific format. For example, 1000 is displayed as 1.00e3.
     Engineering Numbers are displayed using engineering notation. For example, frequency values end in Hz. Also, numbers are displayed in powers of 10^3 (1000 Hz is displayed as 1.0 kHz).
     Hex Numbers are displayed in hexadecimal (base 16).
     Octal Numbers are displayed in octal (base 8).
     Binary Numbers are displayed in binary (base 2).
   • Specify the number of digits to appear after the decimal. If Auto or Full is selected, enter the number of digits to be displayed in the # of Decimal Digits field. For the other formats, the field is displayed as Significant Digits.

Note If columns are too narrow to display data correctly, an ellipsis (...) appears in the data. To widen the columns, select the list and drag the lower-right or lower-left handle horizontally.

4. To change the type font, size, and color of list text, do the following:
   • Click Listing Text.
   • Make the following selections from the Column Listing dialog box:
Select a font from the Font Type list
Select a font size from the Font Size list.
Click Text Color, select a color, then click OK.

Click OK to dismiss the Column Listing dialog box

5. The type, color, and thickness of the line around the perimeter of a list can be changed by following these steps:
   • Click Outline.
   • Make these selections from the Outline dialog box:
     Select a line pattern from the Type list.
     Select a line thickness either by using the Thickness scroll bar or by entering a value into the Points field.
     Click Color, select a new outline color, then click OK.
   • Click OK to dismiss the Outline dialog box.

6. Column headings display the name of the variable that is the source of the data. They are displayed by default. To remove them, deselect Display Column Headings.

7. Table format is only used to display data with two independent and one dependent variable. It is chosen automatically. To disable table format, select Suppress Table Format.

8. If you use table format, you can also transpose the data, which reverses the position of the two independent variables. This is recommended if the independent variable data listed across the table has more values than the independent variable data listed down the table. Transposing would give you a longer, narrower table.
   
   To transpose tabular data, select Transpose Data.
   
   In the example below, the two independent variables are VCE and IBB. The measured data is IC.i. The first list is in table format, which is the default and generally the best way to display data. The second list uses table format and transposed data, note the change of position between VCE and IBB. The third
Plots and Lists

list is in suppressed table format, both independents are displayed in one column.

<table>
<thead>
<tr>
<th>VCI</th>
<th>Curve, Trace...[0;3,3;8]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>IBB=2.000E-5</td>
</tr>
<tr>
<td>0.000</td>
<td>-0.000</td>
</tr>
<tr>
<td>0.100</td>
<td>0.001</td>
</tr>
<tr>
<td>0.200</td>
<td>0.002</td>
</tr>
<tr>
<td>0.300</td>
<td>0.002</td>
</tr>
<tr>
<td>0.400</td>
<td>0.002</td>
</tr>
<tr>
<td>0.500</td>
<td>0.002</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>VBE</th>
<th>Curve, Trace...[0;1]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>IBB=2.000E-5</td>
</tr>
<tr>
<td>2.000E-5</td>
<td>-0.000</td>
</tr>
<tr>
<td>3.000E-5</td>
<td>-0.000</td>
</tr>
<tr>
<td>4.000E-5</td>
<td>-0.000</td>
</tr>
<tr>
<td>5.000E-5</td>
<td>-0.000</td>
</tr>
</tbody>
</table>

9. Click **OK** to dismiss the dialog box and save the changes.
Setting List Preferences

List preferences set the default list properties and determine the appearance of a list in the display area. List preference changes will affect all lists created after the changes were made and saved. To edit the properties of an existing plot, refer to “Editing Lists” on page 2-15.

To set list preferences, follow these steps:

1. Choose Options > Preferences.
2. The Preference dialog box appears. Select under the Plot tab followed the List tab.
3. To specify the numeric format of the data, do the following:
   - Select a format for the data from the Format drop-down list. The choices are:
     - Auto: A default format is automatically chosen based on the type of data displayed.
     - Full: All digits before the decimal are displayed (i.e., 1530000).
     - Scientific: Numbers are displayed in scientific format (for example, 1000 is displayed as 1.00e3).
     - Engineering: Numbers are displayed using engineering notation. For example, frequency values end in Hz. Also, numbers are displayed in powers of 10^3 (for example, 1000 Hz is displayed as 1.0 kHz).
     - Hex: Numbers are displayed in hexadecimal (base 16).
     - Octal: Numbers are displayed in octal (base 8).
     - Binary: Numbers are displayed in binary (base 2).
   - Specify the number of digits to appear after the decimal. If Auto or Full is selected, enter the number of digits to be displayed in the # of Decimal Digits field. For the other formats, the field is displayed as Significant Digits.

Note: If columns are too narrow to display data correctly, an ellipsis (...) appears in the data. To widen the columns, select the list and drag the lower-right or lower-left handle horizontally.

4. To change the type font, size, and color of list text, do the following:
Plots and Lists

- Click **Listing Text**.
- Make the following selections from the Column Listing dialog box:
  - Select a font from the Font Type list
  - Select a font size from the Font Size list.
  - Click **Text Color**, select a color, then click **OK**.
- Click **OK** to dismiss the Column Listing dialog box

5. The type, color, and thickness of the line around the perimeter of a list can be changed by following these steps:

- Click **Outline**.
- Make these selections from the Outline dialog box:
  - Select a line pattern from the Type list.
  - Select a line thickness either by using the Thickness scroll bar or by entering a value into the Points field.
  - Click **Color**, select a new outline color, then click **OK**.
- Click **OK** to dismiss the Outline dialog box.

6. Column headings display the name of the variable that is the source of the data. They are displayed by default. To remove them, deselect **Display Column Headings**.

7. Table format is only used to display data with two independent and one dependent variable. It is chosen automatically. To disable table format, select **Suppress Table Format**.

8. If you use table format, you can also transpose the data, which reverses the position of the two independent variables. To transpose tabular data, select **Transpose Data**.

9. Select a complex data format from the Complex Data List. The choices are:
   - **Real/Imaginary** Real and imaginary values.
   - **Mag/Degrees** Magnitude and angle in degrees.
   - **dB/Degrees** The dB value and angle in degrees.
   - **Mag/Radians** The magnitude and angle in radians.
dB/Radians  The dB value in radians.

10. Click OK to dismiss the Preference dialog box and save the settings.
Plots and Lists
Chapter 3: Traces

Traces are used to display the data that is stored in a dataset and the results of equations. There are several trace formats available for displaying data. Selecting various combinations of traces and plot types enable you to analyze simulation results in a variety of ways.

Trace types include:

- **Auto**   A default trace type that is assigned to the data during simulation is automatically selected.
- **Bus**    Displays bus or long-word data in octal, decimal, or hexadecimal format.
- **Linear** Displays data as a line. Points between measured data points are interpolated linearly to create a connected trace.
- **Scatter** Displays data as discrete points.
- **Spectral** Each data point is represented as an arrow that is perpendicular to the x-axis, the base of each arrow is on the x-axis, and each arrow points in the positive direction.
- **Histogram** Displays data as a histogram or bar chart, which is useful for statistical or yield analyses.
- **Digital** Displays data in a stair format, similar to a digital pulse. The trace steps up or down depending upon the relative position of two adjacent points.
- **Sampled** Similar to a spectral trace, except that vectors point in the positive and negative direction, and you can specify the type of symbol used on the ends of the vectors.

Because an automatic trace type is selected for data, you can view simulation results with little effort. If you want to analyze data in different ways, you can choose other formats or use equations to perform computations with data. For more information, refer to “Equations” on page 4-1.
Traces

Examples of traces are displayed below.

Inserting a Trace

You can add a trace as you create a new plot, or you can add a trace to an existing plot.

To insert a trace onto a plot:

1. Double-click on an existing plot or create a new plot by selecting a plot type from the palette, positioning the pointer over the display area, and clicking the mouse.

2. The Plot Traces & Attributes dialog box appears. Select the dataset containing the data from Datasets and Equations drop down list. There are two other choices at the end of the list:
• Select **Equations** to display the results of an equation on a plot. Equations are discussed in Chapter 4, Equations.
• Select **Other Dataset** to display data in datasets that are not in the current project.

3. The variables in the dataset are listed under the dataset name. To add a variable to the plot, double-click on the variable or select the variable and click the **Add** button. The selected variables appear under the Traces list.

4. A trace type for each selected variable is automatically chosen based on the type of data in the variable. You can select a different trace type or change trace attributes such as color.

5. Click **OK** to dismiss the dialog box and insert the trace.
Selecting Independent and Dependent Variables

When Add is used to add data to a plot, the data is plotted with respect to the independent variable of a simulation. For example, transient simulations are a function of time, so any data from a transient simulation that is added to a plot using Add would be plotted with respect to time.

If you want to use an independent variable other than the default, use Add vs. to add data to a plot. You can use Add vs. with rectangular plots and with lists. For rectangular plots, you select the variables to be plotted along the x-axis and y-axis. For lists, the independent and dependent variables appear in two separate columns.

To compare two variables, do the following:

1. To compare two variables on a new plot, choose Insert > Plot, position the pointer, and click or select a plot type from the palette. To compare two variables on an existing plot, double-click on the plot. The Plot Traces & Attributes dialog box appears.
2. If this is a new plot, select a plot type.
3. For new and existing plots, select the dependent variable from the list below Datasets and Equations and click Add vs.
4. If you are using a rectangular plot and the dependent variable you selected is a complex number, the Complex Data dialog box will appear. Select how the data is to be handled and click OK.
5. The Select Independent Variable dialog box appears. Select the independent variable from the list. It can be from a different dataset or equation. Click OK.
6. If the independent variable you selected is a complex number, the Complex Data dialog box will appear. Select how the data is to be handled and click OK.
7. Click OK to dismiss the Plot Traces & Attributes dialog box and display the trace on the plot.

Viewing Complex Data on a Rectangular Plot

The data from frequency-domain simulations, such as S-parameter or harmonic balance simulations, is stored in complex format. You can plot data from these simulations on rectangular plots, but you must scale the data to one of the following formats:

- dB
• dBm
• Magnitude
• Phase
• Real
• Imaginary

When you select the data and click Add or Add vs, if the data must be scaled the dialog box shown below will automatically appear. Select a format and click OK, and continue with the plot as usual.

Editing Traces

Trace options enable you to choose different trace formats and change trace attributes. If the trace is generated from an equation, you can also edit the equation.

The Trace Options dialog box is used to modify existing traces. Any changes made from this dialog box will only affect the currently selected trace. To change the options for all subsequent traces, refer to “Setting Trace Preferences” on page 3-9.

Note Trace options for the chosen trace type are displayed automatically. If the trace options do not seem correct, click the Trace Type tab, click the button corresponding to the type of trace you want, then reselect the Trace Options tab.
To edit trace options:

1. Double-click on the trace or select the trace and choose Edit > Item Options.
2. The Trace Options dialog box appears.
3. The Data Display allows you to change an existing trace's type. This is done by
   - Selecting the Trace Type tab.
   - Clicking the button above the desired trace type (see figure below).

The suggested plot-trace combinations are:

<table>
<thead>
<tr>
<th>Plot Type</th>
<th>Trace Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangular and Stacked</td>
<td>Any type</td>
</tr>
<tr>
<td>Polar</td>
<td>Linear and Scatter</td>
</tr>
<tr>
<td>Smith Charts</td>
<td>Linear and Scatter</td>
</tr>
<tr>
<td>List</td>
<td>None. Data is formatted from Plot Options</td>
</tr>
</tbody>
</table>

4. You can keep the Auto trace type and still edit the attributes of the trace. Generally, the correct trace options will be displayed automatically. If you are not sure about the trace type or options, perform the following steps:
   - Click the Trace Options tab followed by the Auto tab.
   - Note the trace type shown in the Auto tab.

5. The pattern, thickness, and color of a trace can be changed for all trace types except scatter. To modify a trace line, make the following selections:
   - Click the Trace Options tab followed by the tab that matches the trace type.
   - Select a line pattern from the Type list.
• Select a line thickness by using the scroll bar or entering a value into the Points field.
• Click the Color bar, select a new color, then click OK.

6. In addition to editing the trace of a histogram, and you can also fill the histogram with a pattern. The color of the fill will be the same as the trace color. To fill a histogram:
• Click the Trace Options tab followed by the Histogram tab.
• Enable Use Fill Pattern.
• Click the Pattern bar, select a fill pattern, then click OK.

7. The type of symbol used on a trace can be changed. Symbols are used with linear, scatter, and sampled traces to identify the data points that were measured during a simulation. To modify symbols, make the following selections:
• Click the Trace Options tab followed by the tab that matches the trace type.
• For linear traces, enable Place Symbol at Data (symbols are automatically added to scatter and sampled traces).
• Select a symbol from the Symbol Type list.
• For scatter traces, select a thickness for the line that outlines the symbol by using the scroll bar or by entering a value into the Points field.
• For scatter traces, click the Color bar, select a new color, then click OK.

8. The Data Display allows you to change the text properties and numeric format used in bus traces. This is done by clicking the Trace Options tab followed by the Bus tab and making the following selections:
• Select a format for the data from the Format list. The choices are:
  • Auto A default format is automatically chosen based on the data to be displayed.
  • Dec Numbers are displayed in decimal (base 10).
  • Hex Numbers are displayed in hexadecimal (base 16).
  • Octal Numbers are displayed in octal (base 8).
  • Binary Numbers are displayed in binary (base 2).
To remove a trace from a plot, do the following:

1. To delete a single trace, single-click on the trace. For multiple traces, hold the Shift key down and single-click on each trace of interest.

2. Press the Delete key or choose Edit > Delete.

Sometimes it is difficult to select a trace from a plot with multiple traces because the traces overlap. If you have trouble selecting a trace, use the steps listed below:

1. Double-click on the plot.

2. The Plot Traces & Attributes dialog box appears.
3. Under Traces, select the variables used to generate the trace.
4. Click Delete.
5. Click OK to dismiss the dialog box and delete the trace.

Setting Trace Preferences

Trace preferences set the default trace properties and determine how traces will appear when inserted onto a plot.

Any changes made to the preferences will only affect subsequently created traces. To change an option for an existing trace, make the change using the Trace Options dialog box.

To save and reuse preference settings, you can create a preferences file that can be read by the data display. For more information on how to create and use such a file, refer to “Setting Data Display Preferences” on page 1-20.

To set trace preferences, use the following steps:

1. Choose Options > Preferences.
2. The Preference dialog box appears.
3. Click the Main tab. Set the trace line and symbol preferences by making the following selections:
   • Select a line pattern from the Type list.
   • Select a line thickness by using the scroll bar or entering a value into the Points field.
4. Click the Bus tab. Set the bus trace text and numbering preferences by using these steps:
   • Select a format for the data from the Format list. The choices are:
     Auto A default format is automatically chosen based on the data to be displayed.
     Dec Numbers are displayed in decimal (base 10).
     Hex Numbers are displayed in hexadecimal (base 16).
     Octal Numbers are displayed in octal (base 8).
     Binary Numbers are displayed in binary (base 2).
3-10 Setting Trace Preferences

Traces

- Select a font from the Font Type list.
- Click the Text Color bar, select a color, then click OK.

5. Click the Labels & Symbols tab. Set the label and symbol preferences by doing the following:

- If you want to display labels, enable Display Label.
- Select Display Arrowheads On Spectral Traces if you want arrowheads to appear on the measured data points on spectral traces.
- If you want symbols to appear on the measured data points on linear traces, select Place Symbol at Data.
- Select a symbol type from the Symbol Type list. This is the default symbol for linear, scatter, and sampled traces.

6. Click the Histogram tab and set the histogram fill preferences by doing the following:

- Enable Use Fill Pattern.
- Click the Pattern bar, select a fill pattern, then click OK.

7. When you have finished setting preferences, click the OK button to close the Preference dialog box and save the changes.
Chapter 4: Equations

Equations perform complex mathematical operations on data. You can display equations results on data display plots, enabling you to analyze information in various ways.

This chapter describes how to write equations and how to display the results. It includes examples of how to use some of the mathematical expressions that are in Advanced Design System. A reference of the functions that are available can be found online, it can be accessed from the Equations dialog box.

Equations can be simple or very complex. An equation can include:

- Mathematical expressions and operations
- Functions
- Other data display equations
- Dataset variables
- Marker labels

The rules for writing expressions are minimal:

- Equations are case-sensitive
- Equation names cannot start with a digit
- All functions must be completed using the given syntax
- Parentheses are used to define order of operation

Inserting Equations

To insert an equation on the data display:

1. Click the Equation button from the palette or choose Insert > Equation.
2. Position the pointer on the display area and click the mouse. The Enter Equation dialog box appears.
4-2 Inserting Equations

Equations

3. Type in the equation with the equation name on the left side and the expression on the right. A sample equation is shown below.

\[ RL_1 = \text{db}(\text{amplifier..S}(1,1)) \]

The expression can include any of the items in the previous list. For a list of valid mathematical functions, click Functions Help.

**Note** Only the functions in the Expressions, Measurements, and Simulation Data Processing manual should be used to write Data Display equations.

4. To add a dataset variable to the equation, position the cursor in the equation where you want to insert the variable.

5. Select the dataset name from the list box.

6. A list of variables in the dataset is presented. Select a variable from this list and click Insert.
7. When the equation is complete, click OK.

**Note** If you entered an equation incorrectly, a warning message will appear and the equation identifier, Eqn, is displayed in the color red (if an equation is correct, this is displayed in the color black).

### Shortening Variable Names

When using variables in the default dataset, the dataset variable names can be shortened to make an equation easier to read, as long as each name remains unique. For example, if the variable is entered as:

```
Curve_Tracer.Sweep1.DC1.DC.IC.i
```

If this variable is in the default dataset, you can erase everything from the last period back and keep `IC.i`.

If you want to use a variable with the same name, but from another dataset in the project, you cannot delete part of the name of either variable. Variable names must be unique.

If you enter data from datasets that are outside the project, the full file path is entered. You may want to keep the full path or you can erase the part of the file path that is common with the current project.

### Viewing Data From Multiple Datasets

The default dataset list only allows you to refer to a single dataset. If you have several equations you can easily change the referenced datasets by defining string variables with a dataset name and referring to the string variable in the equations. For example:

```
MeasuredData="measured"
MeasS21=db($MeasuredData..S(2, 1))
DiffS21=MeasS21 – SimS21
SimulatedData="simulated"
SimS21=db($SimulatedData..S(2, 1))
```
Equations

Viewing Equation Results

Equation results can be plotted or displayed in a list. You treat results like any other data. You can apply markers, edit the format, or use the results of an equation within another equation.

To view the results of your equation:

1. Click the Equation button on the palette or choose Insert > Equation.
2. Position the pointer on the display area and click the mouse button.
3. The Enter Equation dialog box appears. Select Equations from the Datasets and Equations list.
4. Select the equation variable and click the Insert button.
   If the equation contains an error, a message describing the problem will appear in the Error window.
5. The default trace type for the chosen data will be used. If you want to verify or change the trace type, click Trace Options and proceed to edit the trace.
6. Click OK to dismiss the dialog box and display the equation results.

\[ S11svswr=svswr(DC_and_Sparams.SP2.SP.S(1,1)) \]
Working with Multidimensional Data

It is not uncommon to sweep more than one parameter in a simulation. Data from such simulations is stored as multidimensional data. If you want to perform calculations on, or display only portions of the data from such simulations, you need to use equations to select the subsets of data.

The curve tracer example is used to illustrate how to do this. The example is under the Examples directory in the MW_Circuits subdirectory. From this subdirectory, open the project LNA_prj and then open the Curve_Tracer schematic that is part of this project.

To open the data display, from the curve tracer schematic window, choose Window > Open Data Display and select Curve_Tracer.dds.

Refer to the schematic. In this example the base current, IBB, and the collector-emitter voltage, VCE are swept in this manner: IBB is set to 20 \( \mu \text{A} \), and VCE is swept from 0V to 6 V in 0.1 V increments. At each 0.1 V increment, IC is calculated and stored in the dataset. When this sweep is complete, IBB is increased to 30 \( \mu \text{A} \), VCE is swept from 0V to 6V, and at every 0.1 V increment IC is measured and stored in the dataset. This is repeated until IBB equals 100 \( \mu \text{A} \); a final sweep of VCE is performed and the simulation is complete.

Refer to the data display. The curve tracer is the entire collection of IC data points. This data is stored in the dataset, and the structure of how data is stored is described next.
IC results. VCE and IBB are swept variables.
Data Structure

Based on the simulation sweeps, there are six values for IBB and 31 values for VCE. The index for IBB is 0-4, the index for VCE is 0-30. For each of these combinations of VCE and IBB, IC was calculated and stored in the dataset.

It is possible to select a single point of data or a sequence of data. The next section describes how to access portions of data using indices.

Accessing Data

Data is accessed by index values. The equation below returns the value of IC when VCE=0V and IBB=20 μA.

\[ x = \text{IC}[0,0] \quad \text{use square brackets} \]

Type the equation and use a list to display your results. For information on how to enter equations, refer to "Inserting Equations" on page 4-1. For information on how to display equation results, refer to "Viewing Equation Results" on page 4-4.

For this equation, the order of the indices did not matter, but in general it does. The next section describes index order.
Index Order

Data is retrieved by the index values. The index order is critical to returning intended data, and it is based on how the simulation is set up. In the curve tracer simulation, the Parameter Sweep item references the DC Simulation item, and the DC simulation parameter (VCE) is swept based on the parameter-sweep parameter (IBB). The index order is outermost to innermost, so the index for IBB precedes the index of VCE.

Try retrieving other data points, such as:

\[ x_1 = IC.i[1,0] \]
\[ x_2 = IC.i[0,1] \]
\[ x_3 = IC.i[1,60] \]

View the results in lists and compare your results to the data structure illustration.

Accessing Sequences of Data

You can access subsets of data using indices. You can either specify the range, or use wildcards.
For example, to display only the trace for $\text{IBB} = 40\mu\text{A}$, type as an equation:

$$\text{IBB40} = \text{IC.i}[2,:,:]$$

Add IBB40 to the curve tracer plot to view the results.

The characters `::` in the equation are the wildcard. In this equation, the wildcard substitutes for a $\text{VCE}$ index value, so all values of $\text{VCE}$ are used and the entire trace of data is returned.

To display only a portion of the trace, use a sequence:

$$\text{IBB40} = \text{IC.i}[2,10::1::30]$$

The data in the 10th through 30th elements are displayed. The default increment is 1, so this sequence could also be written as $10::30$. If you want to skip data points within the sequence, set the increment to a value larger than one.
**Tip**  Try setting this trace to a Scatter trace type, then insert different increment settings in the equation to view the effects of the increment parameter.

To display a portion of several traces, use two sequences:

IBB40=I.C.i[2::5,10::30]

Note the results on the curve tracer plot.
Accessing a Sweep of Data

You can return a sweep of data using a wildcard in the first position of the equation:

\[
\text{VCE5} = \text{IC} . i[::,5]
\]

This example returns the values of IC where \( VCE = 0.5V \).

Do not plot this result on the existing curve tracer plot. Instead, insert a new plot and add the data to the new plot. The axes on this plot are different from the curve tracer. \( VCE \) is plotted along the y axis as a function of \( IBB \), which is plotted along the x axis.

You can change the trace type from Linear to Scatter and see the individual data points.

You can also write the same equation as:

\[
\text{VCE5} = \text{IC} . i[5]
\]

The wildcard in the first position is assumed.
Working with Swept S-parameters

If you want to access subsets of swept S-parameters, you need to use both index notation and S-parameter notation. This section describes the various combinations and the results that are returned.

Setting up an Example

If you want to have an example to work with, set up and perform the simulation described here. Otherwise, skip to the next section.

This example adds a parameter sweep to the amplifier.dsn schematic in the project SweptSparams_prj.

1. From the Main window, click the Examples directory.
2. Select Tutorial.
4. Choose File > Copy Project and make a copy of the project.
5. Open the copy of SweptSparams_prj.
6. Open the schematic amplifier.dsn.
7. Add a swept parameter by modifying the voltage source using a Var Eqn Data item and a parameter sweep item, as shown below.

8. Rerun the simulation. The simulation will run in this manner: Vbias is set to 3V and an S-parameter simulation is performed at each frequency specified in the S-parameter simulation item and the S matrixes are stored in the dataset; Vbias is set to 3.9 V and another set of S-parameter simulations are performed and stored in the dataset; this continues until Vbias equals 2.0 V, when a final set of S-parameter simulations are performed and the entire simulation is complete.

9. When the simulation is complete, open a new Data Display window.

10. Set the default dataset to **amplifier**.

11. Insert a rectangular plot and add S(2,1) to the plot. The entire collection of S(2,1) data points that were calculated for each frequency point and for each value of Vbias is displayed.

The next section describes how the data is stored in the dataset.
Data Structure

Based on the simulation sweeps, there are eleven values for \( V_{\text{bias}} \) and 200 values for \( \text{freq} \). The index for \( V_{\text{bias}} \) is 0-10, the index for \( \text{freq} \) is 0-199. For each of these combinations of \( V_{\text{bias}} \) and \( \text{freq} \), an \( S \) matrix was calculated and stored in the dataset.

Index order is the same as described in “Index Order” on page 4-8. That is, the outermost index is first, innermost is last. In the example above, the first position is the index of \( V_{\text{bias}} \), the second is for \( \text{freq} \).

Accessing Data

You can access \( S \)-parameters using indices. The equation below returns \( S_{21} \) calculated for \( V_{\text{bias}}=2.9 \) V and \( \text{freq}=5 \) MHz:

\[
\text{myS21}=S_{21}[1,0]
\]

Type the equation and use a list to display your results. For information on how to enter equations, refer to “Inserting Equations” on page 4-1. For information on how to display equation results, refer to “Viewing Equation Results” on page 4-4.
The equation below returns $S_{21}$ at all frequencies for a single value of $V_{bias}$ ($V_{bias}=2V$):

$$S_{21\text{at2V}}=S_{21}[10,:].$$

Add this result to a plot. The wildcard `:` is used to substitute for a `freq` index, so all values of `freq` are returned, enabling you to display an entire trace of $S_{21}$ results.

To display only a portion of the trace, use a sequence:

$$S_{21\text{at2V}}=S_{21}[10,80::1::199]$$

**Note:**
- **Start** and **Increment** are used to specify the range and step size.
- **Stop** is used to define the end of the range.
The data in the 50th through 199th elements are displayed. The default increment is 1, and the sequence could be written as \(50::199\). If you want to skip data points within the sequence, set the increment to a value larger than one.

Tip
Try setting this trace to a Scatter trace type, then insert different increment settings, for example replace 1 with 20, to view the effects of the increment parameter.

To display a portion of several traces, use two sequences:

\( S21\text{block} = S21[2::10, 90::140] \)

Add this to the plot and note the results.
Accessing a Sweep of Data

You can return a sweep of data using a wildcard in the first position of the equation:

\[
\text{column=S21[:,80]}
\]

This example returns S21 for every value of Vbias at the frequency with index 80.

Do not plot this result on the existing curve tracer plot. Instead, insert a new plot and add the data to the new plot. The axes on this plot are different from the curve tracer. S21 is plotted along the y axis as a function of Vbias, which is plotted along the x axis.

You can change the trace type from Linear to Scatter and see the individual data points.

You can also write the same equation as:

\[
\text{column=S[80]}
\]

The wildcard in the first position is assumed.
Working with an S Matrix

S-parameters are stored in an S matrix. In general, you will probably want to work with a specific S-parameter and not the entire matrix. You can, however, access an entire matrix. If you do not specify an S-parameter, an equation using S returns the entire S matrix:

\[ \text{myMatrix} = \text{S}[1,0] \]

Note If an ellipse appears in the list of data, enlarge the list by selecting the list and dragging a handle horizontally until all values are displayed correctly.
You can also use indices in this way without specifying an S-parameter and return the S matrix at each point:

```python
manyMatrices=S[2::5, 80::90]
```

Use a list to display your results. Use the scroll buttons to browse the entire list of data. As you can see, a large amount of data is returned.

**Viewing Variable Information**

Use the `what` function to view information about a variable, including:

- Independent variables
- Number of data points
- Matrix size
- Data type, such as real or complex

If the variable contains a single number or a one-dimensional sequence of numbers (like a row or column) it is termed Scalar. If the data is two dimensional, it is termed a Matrix and the size of the matrix is given. Examples of two variables from the swept S-parameter example, Vbias and the S matrix, S, are shown below. For details about these variables, refer to “Setting up an Example” on page 4-12.

**Finding an Index**

The amount of data in this simulation is two dimensional and relatively small, and it is not difficult to determine the swept parameter values that correspond to indices.
For more complex problems, you can use the find_index() function. The find_index() function returns the index that corresponds to a data value. For example, in the Curve_Tracer example, VCE is a scalar that contains 61 points of data. The equation below returns the index when VCE is 3 V:

\[ \text{VCEIndex} = \text{find\_index}(\text{VCE}[2, :, :], 3) \]

The find_index() function works only on scalar data. VCE is specified using indices in order to present it in scalar format.

Using Markers in Equations

You can add marker labels to equations and perform operations on marker data. The operation is performed on the dependent marker data.

To add a marker to an equation:

1. Click the Equation button on the palette or choose Insert > Equation.
2. Position the pointer on the display area and click the mouse.
3. The Enter Equation dialog box appears. Type the equation.
4. At the point where you want to add the marker, choose Equations from the Datasets and Equations list.
5. Select the marker label and click Insert.
6. Complete the equation, then click OK.

You can treat markers like any other variable in an equation.

Note: If you change the marker label (which is accomplished by selecting the marker and choosing Edit > Item Options), you must edit your equations by deleting the old marker label and entering the new marker label.
Using Independent Marker Data

You may want to retrieve the independent data in a marker. You can do this using the `indep` function. For example:

```plaintext
myequation = indep(m1)
```
where `m1` is the marker label. You can also nest this within another function.

Markers on polar plots and Smith charts return data in complex format. You may want to work with only the imaginary portion of the number, which you can retrieve using the `imag` function. The illustration below shows a Smith chart, the marker applied to a trace, the equation used to isolate the imaginary component, and a list to verify the equation is correct.

![Smith Chart Illustration]

```plaintext
m1 = 885.00000 MHz
DC_cne_Sparameters.S(1,1) = 0.633719 - 12.475679j  imaginary part of m1
Impedance = 20 * (0.632453 - j2.633494j)

<table>
<thead>
<tr>
<th>freq</th>
<th>m1.imag</th>
</tr>
</thead>
<tbody>
<tr>
<td>865</td>
<td>-0.478</td>
</tr>
</tbody>
</table>
```

Equation is correct
Equations
Chapter 5: Annotating the Data Display

Designs can be better documented by making annotations on the display. The Data Display includes drawing tools that allow you to annotate the display by inserting text and drawing objects.

Inserting Text

To add text:

1. Click the Insert Text button or choose Insert > Text.
Annotating the Data Display

2. Place the cursor on the display page, move to the desired location, and click the mouse. The text will be inserted at the red line.

3. Type the text.

4. When you are finished, click the **End Command** button or choose **Edit > End Command**.

**Editing Text**

The text, fill, and outline and outline of a text box can be easily changed by using the Enter Text dialog box. Any changes made from this dialog box will only affect the currently selected text box. To change the options for all subsequent text entries, refer to “Setting Text Preferences” on page 5-3.

To edit text:

1. Double-click on the text or select the text and choose **Edit > Item Options**.
2. The Enter Text dialog box appears.
3. Change the text as desired.
4. To change the text format, click the **Properties** button.
5. To change the font properties:
   - Select a font from the Font Type list.
   - Select a font size from the Font Size list.
   - Click the **Text Color** bar, select a new color, then click **OK**.
6. The text is enclosed in a text frame. To display the outline of this frame, enable **Draw Outline**. To edit the outline:
   - Select a line pattern from the Type list.
   - Select a line thickness either by using the scroll bar or entering a value into the Points field.
   - Click the **Color** bar, select a new color, then click **OK**.
7. To fill the background of the frame, enable **Use Fill Pattern**. To edit the fill:
   - Click the **Color** bar, select a new color, then click **OK**.
   - Click the **Pattern** bar, select a pattern, then click **OK**.
8. Click **OK** to close the Edit Text Properties dialog box.
9. Click **OK** to close the Enter Text dialog box and accept the changes.

**Setting Text Preferences**

Any changes made to the preferences will only affect subsequently created text. To modify existing text, make the change using the Enter Text dialog box.

To save and reuse preference settings, you can create a preferences file that can be read by the data display. For more information on how to create and use such a file, refer to “Setting Data Display Preferences” on page 1-20.

To set preferences:

1. Choose **Options > Preferences**.
2. The Preference dialog box appears. Click the **Text** tab.
3. Set the text preferences by doing the following:
   - Select a font from the Font Type list.
   - Select a font size from the Font Size list.
   - Click the **Text Color** bar, select a new text color, then click **OK**.
4. The appearance of text box outlines is set by using these selections:
   - Enable **Draw Outline**.
   - Select an outline pattern from the Type list.
   - Select the outline thickness either by using the Thickness scroll bar or entering a value into the Points field.
   - Click the **Color** bar, select a new color, then click **OK**.
5. Text box fill preferences are set as follows:
   - Enable **Use Fill Pattern**.
   - Click the **Color** bar, select a new fill color, then click **OK**.
   - Click the **Pattern** bar, select a fill Pattern, then click **OK**.
6. Click **OK** close the Preference dialog box and accept the changes.
Annotating the Data Display

**Inserting Objects**

The commands used to add graphical objects to your display are found on the Insert menu as well as on the toolbar.

1. Click the button on the toolbar that corresponds to the desired shape (Circle, Rectangle, etc.) or choose the shape from the Insert menu.
2. Position the pointer on the display page and click the mouse.
   - For lines, move the pointer until the line is the desired length, then click the mouse.
   - For rectangles and circles, move the pointer until the object is the desired size, then click the mouse.
   - For polylines and polygons, continue adding segments by positioning the pointer and clicking the mouse.
   To complete a polyline, double-click the mouse. For a polygon, draw the second to last segment and then double-click the mouse. The last segment is added to make a closed region.
3. The object drawing mode remains active, allowing you to place other objects of the same type by moving the pointer and clicking the mouse.
4. If you are finished, click the End Command button or choose Edit > End Command.

---

5-4 Inserting Objects
Editing Objects

You can edit object properties such as line width, line thickness, and color. For 2-D objects, you can fill the area with a pattern and color.

You can also edit objects by moving them, changing their size, or by using delete, cut, copy, and paste commands. For more information on these functions, refer to Chapter 1, Data Display Basics.

Any changes that you make will only affect the currently selected object. To change properties for all objects added subsequently, refer to “Setting Object Preferences” on page 5-7.

Objects are edited using the following steps:

1. Double-click on the object or select the object and choose Edit > Item Options.
2. The edit dialog box appears.
3. Lines and object outlines are edited using these selections:
   - Select a line pattern from the Type list.
   - Select the line or outline thickness either by using the Thickness scroll bar or by entering a value into the Points field.
   - Click the Color bar, select a new color, then click OK.
4. An object’s fill can be changed using these selections:
   - Enable Use Fill Pattern.
   - Click the Color bar, select a new fill color, then click OK.
   - Click the Pattern bar, select a fill Pattern, then click OK.
5. Click OK close the dialog box and accept the changes.

Adding Date and Time to a Data Display

You can add the current date and time to a data display using the AEL function date_time(). You can add this (or any other AEL expression) to a data display using an equation, then display the results on a plot. In the procedure below, date and time are displayed in a list.

1. Click the Equation button on the palette or choose Insert > Equation.
Annotating the Data Display

2. Position the pointer on the display area and click the mouse button.

3. The Enter Equation dialog box appears. Enter the equation as
   \texttt{current\_date\_time=date\_time()}. (Use any variable name on the left side of
   the equation and the AEL function on the right side of the equation.) Click \textbf{OK}.

4. From the tool bar on the left side of the Data Display window, click the \textbf{List}
   button, move the pointer into the display area of the window, and click.

5. In the dialog box that appears, select \textbf{Equations} from the Datasets and
   Equations drop-down list.

6. Select the variable (in this case, \texttt{current\_date\_time}) and click \textbf{Add}. Click \textbf{OK}.

   ![Enter Equation Dialog Box]

Note this is not a date/time stamp, it is updated to reflect the current date and time.

---

**Note** You can add variables to a schematic to display current date and time, plus
other design and system information. Refer to the User’s Guide.

---

5-6 Adding Date and Time to a Data Display
Setting Object Preferences

Object preferences determine how new graphical objects will appear when they are inserted onto a display area.

Object preferences affect all objects created after the changes were made and saved. To change the properties for an existing object, refer to “Editing Objects” on page 5-5.

To save and reuse preference settings, you can create a preferences file that can be read by the data display, which can facilitate setting preferences. For more information on how to create and use such a file, refer to “Setting Data Display Preferences” on page 1-20.

To set preferences:

1. Choose Options > Preferences.

2. The Preference dialog box appears. There are tabs for each type of object. Move through the tabs and define your preferences.

3. Lines and object outlines preferences are set using these selections:
   • Select a line pattern from the Type list.
   • Select the line or outline thickness either by using the scroll bar or entering a value into the Points field.
   • Click the Color bar, select a new color, then click OK.

4. An object’s fill preferences can be set by using these selections:
   • Enable Use Fill Pattern.
   • Click the Color bar, select a new fill color, then click OK.
   • Click the Pattern bar, select a fill Pattern, then click OK.

5. Click OK close the Preference dialog box and accept the changes.
Annotating the Data Display
Chapter 6: Markers

Markers allow you to read data values at specific points on a trace. They return the independent and dependent values of the data. Markers can also be used in equations. The figure below shows a marker inserted onto a trace and the data returned from that point on the trace.

When a marker is inserted, the following items appear on the display page:

- The marker symbol.
- The marker readout, which returns the data at that point on the trace
- Marker labels, one next to the marker symbol and one next to the readout. This is helpful when you have multiple markers displayed.

For information on how to use markers in equations, refer to “Equations” on page 4-1.

Marker Readout

A marker readout includes:

- A label that matches the label on the marker
- The value of the independent variable
- The value of the dependent variable. Values from polar plots and Smith charts are displayed in real and imaginary components; markers on Smith charts also
Markers

Markers display either impedance or admittance. Values from rectangular and stacked plots are returned in scalar format.

```
marker label
---m1
independent variable
freq=13.21666GHz
dependent variable
de(h01r11..s(1,1))=-0.28562z
```

**Inserting Markers**

You can insert one or more markers onto a trace.

To insert a marker:

1. Choose **Marker > New**.
2. Position the pointer on the trace where you want to insert the marker and click.

   **Tip**  The information dialog box that appears when you choose **Marker > New** will be dismissed automatically when you insert the marker.

3. The marker data appears next to the marker. To keep your plot uncluttered, enlarge the data display window, select the marker readout text, and drag it off to one side of the plot.

**Moving Markers**

You can move a marker to any position along a trace by dragging the marker. An active marker readout is displayed to help you position the marker.

**Editing Markers**

An existing marker's label, symbol, and readout can be changed with the Edit Marker Properties dialog box.

Any changes that you make will only affect the currently selected marker. To change the properties for all markers added subsequently, refer to “Setting Marker Preferences” on page 6-4.

To edit a marker, follow the steps below.
1. Double-click on the marker or the marker readout. The Edit Marker Properties dialog box appears.

2. To edit the marker label, click the **Main** tab.

3. Enter a marker label in the **Label Text** field.

   **Note** Markers can be used in equations by adding the marker label to an equation. Be aware that if you use a marker label in an equation and then change the marker label in the **Label Text** field, you must update your equation with the new marker label.

4. Select a font type from the **Font Type** list.

5. Select a text size from the **Font Size** list.

6. Click the **Text Color** bar, select a color, then click **OK**.

7. Click the **Marker Color** bar, select a color, then click **OK**.

8. Click the **Readout** tab.

9. Select a font type from the **Font Type** list.

10. Select a font size from the **Font Size** list.

11. Click the **Text Color** bar, select a color, then click **OK**.

12. Click **OK** to close the dialog box and accept the changes.

**Delta Mode**

The difference between two or more markers can be displayed using delta mode. The readouts of the selected markers change relative to the marker that you assign as the reference.

You can select any markers in a data display for comparison in delta mode. The markers can be on the same trace, on different traces in the same plot, or on different traces in different plots. The delta marker equation is:

\[
\text{delta} = \text{reference marker} - \text{delta marker}
\]
Markers

The following example shows two markers used in delta mode. Note that the marker symbol of the marker in delta mode is rotated. The reference marker symbol is unchanged.

m1 is the delta. It displays m2 - m1 results
\[ VCE_{m2} - VCE_{m1} = 3.3 - 3 = 0 \]
\[ I_{C.m2} - I_{C.m1} = 2.507 mA - 10.979 mA = -8.472 mA \]

m2 is the reference marker. It does not change.

To activate delta mode:

1. Position the pointer over a marker symbol and shift+click. Repeat this for each marker you want to display in delta mode. Be sure to include the reference marker.

   Tip As an alternative to selecting marker symbols, you can select the marker readout.

2. Choose Marker > Delta Mode On.

3. A dialog box appears listing the selected markers. Select one marker from this list to be the reference marker.

4. Click OK.

Setting Marker Preferences

Marker preferences set the default marker properties and determine the appearance of a marker when it is inserted onto a plot.

Marker preference changes will apply to all markers created after the changes were made and saved. To change properties for an existing marker, refer to “Editing Markers” on page 6-2.
To save and reuse preference settings, you can create a preferences file that can be read by the data display. For more information on how to create and use such a file, refer to “Setting Data Display Preferences” on page 1-20.

To set marker preferences, do the following:

1. Choose **Options > Preferences**.
2. The Preference dialog box appears. Click the **Marker** tab.
3. Select a font from the Font Type list.
4. Select a font size from the Font Size list.
5. Click the **Text Color** bar, select a color, then click **OK**.
6. Click the **Marker Color** bar, select a color, then click **OK**.
7. Click the **Readout** tab.
8. Select a font type from the Font Type list.
9. Select a font size from the Font Size list.
10. Click the **Text Color** bar, select a color, then click **OK**.
11. Click **OK** to close the dialog box and set the preferences.
Chapter 7: Command Reference

File Menu
New
    Creates a new file in the current data display window.
Open...
    Opens an existing design in the current data display window.
Close Window
    Closes the current data display window.
Save
    Saves the current data display window to an existing file.
Save As...
    Saves the data display window to a new file.
Save As Template...
    Save the display page as a template.
Import
    Import a dataset using the Instrument Server.
Export > Write Selected Item to Tab - Delimited ASCII
    Writes the selected plot or table to a tab-delimited ASCII text file.
Export > Export Dataset Using the Instrument Server
    Exports data to the Instrument Server.
Print...
    Prints the contents of the data display window as defined by the Page Setup.
Print Selected...
    Prints the contents of the data display window as defined by the Page Setup.
Print Setup...
    Specifies the print setup options.
Command Reference

Exit Advanced Design System...
Closes the application.

Edit Menu
End Command
Ends a command. You will want to do this, for example, when you are finished inserting a line or other object onto the display page.

Undo
Undoes the last editing command.

Redo
Executes the last editing command prior to Undo.

Cut
Deletes the selected object from the display page and places it on the clipboard.

Copy
Copies the selected object to the system clipboard.

Paste
Inserts the object on the clipboard into the selected data display window.

Delete
Deletes the selected object without placing it on the clipboard.

Select All
Selects all objects on the display page.

Group
Groups all selected objects on the display page.

Arrange > Move to Front
Moves an object in front of all other objects.

Arrange > Send to Back
Moves an object behind all other objects.
Arrange > Move Forward
   Moves an object in front of the preceding object.
Arrange > Move Backward
   Moves an object behind the following object.
Arrange > Align Left Edges
   Aligns the left edges of selected plots, lists, equations, drawing objects, and text.
Arrange > Align Right Edges
   Aligns the right edges of selected plots, lists, equations, drawing objects, and text.
Arrange > Align Tops
   Aligns the top edges of selected plots, lists, equations, drawing objects, and text.
Arrange > Align Bottoms
   Aligns the bottom edges of selected plots, lists, equations, drawing objects, and text.
Arrange > Center Vertically
   Vertically centers the selected plots, lists, equations, drawing objects, and text.
Arrange > Center Horizontally
   Horizontally centers the selected plots, lists, equations, drawing objects, and text.
Ungroup
   Ungroups the selected object into individual objects.
Text > Font
   Opens the font style which is used to select a style for the selected text.
Text > 1 Point Larger
   Makes the selected text one point larger.
Text > 1 Point Smaller
   Makes the selected text one point smaller.
Text > 6 Point
   Changes the size of the selected text to 6 points.
Command Reference

**Text > 8 Point**
Resizes the selected text to 8 points.

**Text > 10 Point**
Changes the selected text's size to 10 points.

**Text > 12 Point**
Changes the size of the selected text to 12 points.

**Text > 14 Point**
Resizes the selected text to 14 points.

**Text > 16 Point**
Changes the selected text's size to 16 points.

**Text > 20 Point**
Changes the size of the selected text to 20 points.

**Text > 24 Point**
Resizes the selected text to 24 points.

**Item Options...**
Sets the options for how the selected graphical object (drawing object, plot, trace) is displayed.

**View Menu**

**View All**
Brings all graphical elements on the drawing page into view.

**Zoom Area**
Zoom in on the selected area.

**Zoom In x2**
Enlarge graphical objects by a factor of 2.

**Zoom Out x2**
Reduce the size of graphical objects by a factor of 2.
Actual Size
Return graphical objects to the default viewing size.

New Window
Opens a new view of the project in the data display window.

Scroll Data > Beginning of Data
Displays the first line of data in a list.

Scroll Data > Left Page
Scrolls to the left page of a list.

Scroll Data > Left
Scrolls to the left side of a list.

Scroll Data > Right
Scrolls to the right side of a list.

Scroll Data > Right Page
Scrolls to the right page of a list.

Scroll Data > End of Data
Displays the last line of data in a list.

Zoom Data > Autoscale
Centers a trace and converts it to the optimum size for the plot.

Zoom Data > Zoom Rectangle
Zoom in on the selected area.

Zoom Data > Zoom In
Zooms in on a plot by a factor of 2.

Zoom Data > Zoom Out
Zooms out on a plot by a factor of 2.

Toolbar
Hides or displays the toolbar.
Command Reference

**Item Palette**

Hides or displays the item palette.

**Insert Menu**

**Plot...**

Inserts a plot onto the display page.

**Equation...**

Inserts an equation onto the display page.

**Line**

Inserts a line onto the display page.

**Circle**

Inserts a circle onto the display page.

**Rectangle**

Inserts a rectangle onto the displayed page.

**Polygon**

Inserts a polygon onto the display page.

**Polyline**

Inserts a polyline onto the display page.

**Text**

Adds text to a display page.

**Page**

Inserts a new page in the Data Display.

**Template**

Inserts preconfigured plots and objects onto the display page.

**Marker Menu**

**New...**

Inserts a new marker onto a trace:
Delta Mode On
   Enables the marker readout to display the difference between two or more markers.

Delta Mode Off
   Returns the marker readout to its original display.

Page Menu
New Page
   Inserts a new page in the Data Display.

Rename Page
   Used to rename the current Data Display page.

Delete Page
   Deletes the current Data Display page.

Next Page
   Displays the next Data Display page.

Previous Page
   Displays the previous Data Display page.

Options Menu
Hot Key/Toolbar Configuration...
   Allows the user to customize the Data Display toolbar and the keyboard hot keys.

Preferences...
   Sets default preferences for how plots, traces, drawing objects, and text are displayed.

Help Menu
What's This?
   Displays context-sensitive help for a menu, command, button, or control that is selected subsequently.
Command Reference

**Topics and Index**
Provides access to a brief list of topics for each product area, as well as access to an index of topics in all product areas.

**About the Data Display Server**
Displays version, copyright, and technical support information. Provides a direct link to the Agilent EEsof web site.

**Agilent EEsof Web Resources**
Launches the browser (Netscape by default) defined in Options > Preferences > Web Browser in the Advanced Design System Main window, provided the path for the browser has been established.

**Palette Buttons**

**End Command**
Ends a command. You will want to do this, for example, when you are finished inserting a line or other object onto the display page.

**Rectangular Plot**
Inserts a rectangular plot onto the display page.

**Polar Plot**
Inserts a polar plot onto the display page.

**Smith Chart**
Inserts a Smith Chart onto the display page.

**Stacked Rectangular Plot**
Inserts multiple rectangular plots onto the display page.

**List**
Inserts a list onto the display page.

**Equation**
Inserts an equation onto the display page.
**Toolbar Buttons**

**New Data Display Window**
- Opens a new Data Display window.

**Open Existing Data Display Window**
- Opens an existing design in the current data display window.

**Save Current Data Display**
- Saves the current data display window to an existing file.

**Print**
- Prints the contents of the data display window as defined by the Page Setup.

**End Command**
- Ends a command. You will want to do this, for example, when you are finished inserting a line or other object onto the display page.

**Delete**
- Deletes the selected object without placing it on the clipboard.

**Undo**
- Undoes the last editing command.

**View All**
- Brings all graphical elements on the drawing page into view.

**Zoom Area**
- Zoom in on the selected area.

**Zoom In x2**
- Enlarge graphical objects by a factor of 2.

**Zoom Out x2**
- Reduce the size of graphical objects by a factor of 2.

**View Actual Size**
- Return graphical objects to the default viewing size.
Command Reference

**Insert Line**
Inserts a line onto the display page.

**Insert Polygon**
Inserts a polygon onto the display page.

**Insert Polyline**
Inserts a polyline onto the display page.

**Insert Rectangle**
Inserts a rectangle onto the displayed page.

**Insert Circle**
Inserts a circle onto the display page.

**Insert Text**
Adds text to a display page.

**Default Dataset**
Displays the default dataset. It is used unless a different one is specified when you enter data on a plot.

**Beginning of Data**
Displays the first line of data in a list.

**Scroll Up One Page**
Scrolls a list of data up by one page.

**Scroll Toward Beginning**
Scrolls a list of data up by one line.

**Scroll Toward End**
Scrolls a list of data down by one line.

**Scroll Down One Page**
Scrolls a list of data down by one page.

**End of Data**
Displays the last line of data in a list.
**Autoscale Plot**

Centers a trace and converts it to optimum size for the plot.

**Zoom In On Data By Rectangle**

Zoom in on the selected area.

**Zoom In On Data**

Zooms in on a plot by a factor of 2.

**Zoom Out On Data**

Zooms out on a plot by a factor of 2.

**Instrument Server**

Starts the instrument server. The instrument servers reads data from an outside source, such as a network analyzer or CITI file, into a dataset. The data can then be displayed. The instrument server also sends out data from datasets to instruments and other files.
Index

A
Add command, 3-3
adding
   datasets, 1-6
arranging objects, 1-19
auto
   list format, 2-16
axes
   editing labels and numbers, 2-6
   editing numeric format, 2-6
data displays
   adding text, 5-1
   editing, 1-16
   features of, 1-1
   printing, 1-21
   starting, 1-3
   using equations, 4-1
data variables
   selecting, 1-8
datasets
   adding, 1-6, 3-3
   adding variables, 3-3
   choosing, 1-5
   in a data display, 1-5
   sources of, 1-5
   viewing data from multiple, 4-3
date/time, adding, 5-5
Delete command
to erase traces, 3-8
delta markers, 6-3
delta mode, 6-3
editing
   a marker, 6-2
End command, 5-4
engineering
   list format, 2-16
equations
   accessing multidimensional data, 4-7
   adding a dataset variable, 1-13
   adding as a trace, 3-3
   and help, 4-2
   and markers, 4-20
   and multidimensional data, 4-5
   and S matrices, 4-18
   and swept S-parameters, 4-12
   and variable names, 4-2, 4-3
   finding an index, 4-19
   independent marker data, using, 4-21
   inserting, 1-12, 4-1
   inserting markers, 4-20
   inserting on the data display, 4-1
   parts of, 4-1
   rules, 4-1

B
binary
   list format, 2-16
circles
   setting preferences, 5-7
columns
   correcting display, 2-16, 2-19
   headings
   editing, 2-17
   comparing trace data, 6-3
complex data
   viewing, 3-4
data
   accessing with equations, 4-7
   and indexes, 4-8
   and variable information, 4-19
   scrolling through, 1-15, 2-10
   structure, 4-7
   working with, 4-5
Data Display
   elements, 1-4
   opening, 1-3
data display
   capabilities, 1-1
   closing, 1-20
   creating, 1-5
   locating examples, 1-21
   opening, 1-3
   saving, 1-14
   setting preferences, 1-20

C
circles
   setting preferences, 5-7
columns
   correcting display, 2-16, 2-19
   headings
   editing, 2-17
   comparing trace data, 6-3
complex data
   viewing, 3-4
data
   accessing with equations, 4-7
   and indexes, 4-8
   and variable information, 4-19
   scrolling through, 1-15, 2-10
   structure, 4-7
   working with, 4-5
data displays
   adding text, 5-1
   editing, 1-16
   features of, 1-1
   printing, 1-21
   starting, 1-3
   using equations, 4-1
data variables
   selecting, 1-8
datasets
   adding, 1-6, 3-3
   adding variables, 3-3
   choosing, 1-5
   in a data display, 1-5
   sources of, 1-5
   viewing data from multiple, 4-3
date/time, adding, 5-5
Delete command
to erase traces, 3-8
delta markers, 6-3
delta mode, 6-3
editing
   a marker, 6-2
End command, 5-4
engineering
   list format, 2-16
equations
   accessing multidimensional data, 4-7
   adding a dataset variable, 1-13
   adding as a trace, 3-3
   and help, 4-2
   and markers, 4-20
   and multidimensional data, 4-5
   and S matrices, 4-18
   and swept S-parameters, 4-12
   and variable names, 4-2, 4-3
   finding an index, 4-19
   independent marker data, using, 4-21
   inserting, 1-12, 4-1
   inserting markers, 4-20
   inserting on the data display, 4-1
   parts of, 4-1
   rules, 4-1
sample, 4-2
using markers, 4-20
viewing, 4-4
viewing results, 1-13, 4-4
viewing variable information, 4-19

F
files
  saving data displays, 1-14
full
  list format, 2-16
functions
  using in equations, 4-2

G
graphical objects. See objects
grids
  editing, 2-10

H
hex
  list format, 2-16
hexadecimal, 2-16

I
index
  finding, 4-19
Insert command
  to insert a plot, 2-1, 2-13
  to insert traces, 3-2
inserting
  equations, 4-1

L
labels
  editing on markers
    editing, 6-2
  on markers, 6-1
  setting preferences
    markers, 6-4
lines
  setting preferences, 5-7
lists, 2-1
  column headings, 2-17
  editing, 2-15
  narrow columns, 2-16, 2-19
  outlines, editing, 2-17
  scrolling through, 1-15
setting preferences, 2-19
setting preferences, 2-19

M
markers, 6-1
  adding, 1-10
  delta mode, 6-3
  editing, 6-2
  in equations, 4-20
  independent data, using, 4-21
  inserting, 6-2
  moving, 6-2
  readout, 6-1
  setting preferences, 6-4
moving
  objects, 1-18
multidimensional data, 4-5
  accessing, 4-7
  accessing sequences of data, 4-8
  accessing sweeps, 4-11
  index order, 4-8
  structure, 4-7
multidimensional data, using, 4-5

O
objects
  arranging, 1-19
  copying, 1-19
  cutting, 1-19
  deleting, 1-19
  deselecting, 1-17
  editing, 5-5
  inserting, 5-4
  moving, 1-18
  pasting, 1-19
  scaling, 1-18
  selecting, 1-17
  setting preferences, 5-7
octal
  list format, 2-16
  outlines
    editing in lists, 2-17

P
pages
  inserting, 1-4
plots
  adding a title, 2-5
adding markers, 6-2
adding traces, 3-2
choosing, 1-7
ing, 2-3
ing axes, 2-6
ing numeric formats, 2-6
inserting, 2-1, 2-13
palette, 2-2, 2-14
olar, 2-1
preferences, 2-11
rectangular, 2-1
scaling, 2-8
scaling, manually, 2-9
setting list options, 2-15
setting preferences, 2-11
stacked, 2-1
types, 2-1
polygons
setting preferences, 5-7
polylines
setting preferences, 5-7
preferences
saving to a file, 1-20
setting, 1-20
setting at startup, 1-20
printing, 1-21

R
rectangles
setting preferences, 5-7
reference markers, 6-3

S
scalar
formats, 3-4
scaling
objects, 1-18
plots, 2-8
scientific
list format, 2-16
Scroll buttons, 1-15
scrolling
through data, 2-10
selecting
objects, 1-17
Significant Digits, 2-12, 2-16
Smith charts
coordinates, setting, 2-10
smith charts, 2-1
S-parameters
viewing with equations, 4-12
swept S-parameters, 4-12
accessing data, 4-14
accessing sweeps, 4-17
data structure, 4-14
S matrix, 4-18
setting up an example, 4-12
symbols
editing marker, 6-2
marker, 6-1
setting marker preferences, 6-4

T
templates
adding to a data display, 1-15
inserting in data display, 1-14
text
editing, 5-2
editing marker, 6-2
inserting, 5-1
setting preferences, 5-3, 5-7
titles
adding to plots, 2-5
traces
applying markers, 6-2
auto, 3-1
bus, 3-1
bus auto format, 3-7
bus binary format, 3-7
bus dec format, 3-7
bus hex format, 3-7
bus octal format, 3-7
choosing a dataset, 3-2
deleting, 3-8
dependent variables, 3-4
digital, 3-1
editing, 3-5
editing preferences, 3-9
equations, 3-3
histogram, 3-1
independent variables, 3-4
inserting, 3-2
linear, 3-1
other datasets, 3-3
sampled, 3-1
scatter, 3-1
scrolling through, 1-15
selecting a trace type, 1-9
setting preferences, 3-9
spectral, 3-1

V
variables
dependent, 3-4
finding information, 4-19
independent, 3-4
names, 4-2, 4-3
viewing information, 4-19
View commands, 1-15

W
window elements, Data Display, 1-4