Advanced Design System 1.5
Digital Filter Designer

December 2000
Notice

The information contained in this document is subject to change without notice.

Agilent Technologies makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Agilent Technologies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Warranty

A copy of the specific warranty terms that apply to this software product is available upon request from your Agilent Technologies representative.

Restricted Rights Legend

Use, duplication or disclosure by the U. S. Government is subject to restrictions as set forth in subparagraph (c) (1) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 for DoD agencies, and subparagraphs (c) (1) and (c) (2) of the Commercial Computer Software Restricted Rights clause at FAR 52.227-19 for other agencies.

Agilent Technologies
395 Page Mill Road
Palo Alto, CA 94304 U.S.A.

Copyright © 2000, Agilent Technologies. All Rights Reserved.
Contents

1 Digital Filter Designer
   Main Window ................................................................. 1-2
   Menus and Toolbar .......................................................... 1-3
      Menubar ................................................................. 1-3
      Toolbar ................................................................. 1-4
   Desired Response Tab ...................................................... 1-4
   Weighting Function Tab .................................................... 1-5
   Other Parameters Tab ...................................................... 1-6
   Data Display Window ...................................................... 1-6
   Status Window .............................................................. 1-7

2 Digital Filter Designer Basics
   Launching Digital Filter Designer ................................. 2-1
   Using Projects ............................................................ 2-2
      Creating a New Project ............................................... 2-3
      Opening an Existing Project ....................................... 2-4
   Managing Designs ....................................................... 2-5
      Creating a Design ..................................................... 2-5
      Opening a Design ..................................................... 2-6
      Importing Ideal Coefficients ...................................... 2-8
      Instrument Link ....................................................... 2-11
      Copying and Saving a Design ...................................... 2-13
   Generating Outputs .................................................... 2-14
      Printing Specifications ............................................... 2-14
      Plotting an Analysis .................................................. 2-14
      Generating a Schematic .............................................. 2-17
      Viewing Coefficients ................................................ 2-18

3 Creating a Multipass FIR Filter
   Response and Weighting Specifications .......................... 3-1
   Exercise 1: Entering Design Specifications ...................... 3-3
      Creating the Filter Design ........................................... 3-3
      Defining the Desired Response ................................. 3-7
      Saving and Printing the Specifications ......................... 3-9
   Exercise 2: Designing and Analyzing a Filter .................... 3-10
      Choosing the Analysis Options .................................... 3-11
      Designing and Analyzing the Filter ............................. 3-12
   Exercise 3: Implementing a Filter Design ......................... 3-13
      Choosing the Implementation Options ......................... 3-14
      Generating a Schematic ............................................. 3-16
4 Designing a Digital Filter

Choosing a Filter Response Type ................................................................. 4-1
- FIR ............................................................................................................. 4-2
- IIR .............................................................................................................. 4-2

Choosing a Frequency Response ................................................................ 4-3
- Lowpass ................................................................................................... 4-5
- Highpass ................................................................................................... 4-5
- Bandpass ................................................................................................. 4-6
- Bandstop ................................................................................................. 4-6
- Multipass ................................................................................................. 4-7
- Multistop ................................................................................................. 4-7
- Differentiator .......................................................................................... 4-7
- Hilbert Transformer ................................................................................... 4-8
- Raised Cosine .......................................................................................... 4-8
- Root Raised Cosine ................................................................................... 4-9
- Gaussian and Edge ................................................................................... 4-9

Choosing a Design Method .......................................................................... 4-9
- FIR ............................................................................................................. 4-9
- IIR .............................................................................................................. 4-15

Defining the Filter Order ........................................................................... 4-18

Choosing the Frequency Unit ..................................................................... 4-19

Specifying the Sampling Frequency ............................................................ 4-19

Defining the Response Specifications ........................................................ 4-20
- Entering the Number of Bands ................................................................. 4-21
- Entering Low and High Frequencies ......................................................... 4-21
- Entering the Amplitude ............................................................................ 4-22
- Specifying the Ripple ............................................................................... 4-22
- Entering the Exponential Amplitudes ....................................................... 4-22
- Specifying the Weighting ........................................................................ 4-22
- Selecting the Magnitude Format ............................................................... 4-24
- Selecting the Amplitude Format ............................................................... 4-24

Choosing the Filter Transform ................................................................... 4-26
- Bilinear Z Transform ............................................................................... 4-26
- Impulse Invariant ..................................................................................... 4-27

Choosing the Compensation ....................................................................... 4-27
- Sinc ............................................................................................................ 4-28
- Unity ......................................................................................................... 4-28

Defining the Symmetricity .......................................................................... 4-28
- Symmetric ............................................................................................... 4-28
- Antisymmetric .......................................................................................... 4-28
- Nonsymmetric .......................................................................................... 4-29

Entering a Windowing Parameter ................................................................. 4-29
Raised Cosine Parameters ................................................................. 4-30
Symbol Rate ...................................................................................... 4-31
Roll Off ............................................................................................. 4-31
Passband Ripple ............................................................................... 4-31
Stopband Ripple ............................................................................... 4-31

5 Implementing a Digital Filter
Choosing an Implementation Structure ............................................. 5-2
FIR Filter ....................................................................................... 5-2
IIR Filter ....................................................................................... 5-4
Selecting the Numeric Format ......................................................... 5-7
Specifying the Bit Width ................................................................. 5-8
Selecting the Norm ........................................................................ 5-9
L Infinity .......................................................................................... 5-9
Fractional ......................................................................................... 5-9
L 1 .................................................................................................. 5-10

6 Analysis and Output
Printing the Filter Specifications ................................................... 6-1
Defining the Analysis Options ....................................................... 6-3
Displaying the Analysis Plots ......................................................... 6-9
Editing an Analysis Plot ................................................................. 6-10
Displaying Coefficients ................................................................. 6-11
Generating a Schematic ................................................................. 6-13
Retrieving and Placing Coefficients ............................................... 6-15
Saving a Design File ....................................................................... 6-16
Using Coefficients in Agilent Ptolemy Components ....................... 6-17

7 Manipulating Arrays
Declaring and Initializing Arrays ................................................... 7-1
Displaying Arrays ......................................................................... 7-2
Accessing Array Elements ............................................................ 7-2
Array Operations ........................................................................... 7-3
Addition and Subtraction .............................................................. 7-3
Multiplication .................................................................................. 7-4
Scalars and Arrays ......................................................................... 7-4
Transposing Arrays ........................................................................ 7-4

8 Command Reference
File Menu ...................................................................................... A-1
Design Menu .................................................................................. A-2
Options Menu ................................................................................ A-3
View Menu ..................................................................................... A-4
Tools Menu ..................................................................................... A-4
Chapter 1: Digital Filter Designer

Digital Filter Designer is an integrated application within Advanced Design System's DSP Designer Pro and an option with DSP Designer. It is a specifications-based software tool for designing, simulating, analyzing, and generating coefficients for high-quality digital filters.

Digital Filter Designer enables you to design and analyze a range of digital FIR and IIR filters based upon your specifications. Digital Filter Designer can automatically calculate the least number of taps that meet the desired response specifications, and it can generate both a schematic and a table of coefficients for the designed filter.

The Digital Filter Designer environment has a Main window for entering the filter design specifications and a Status window to display feedback, error, and status messages.

The results of an analysis are automatically displayed in a separate Data Display window that can be configured to plot the frequency response, unit pulse response, unit step response, group delay, poles/zeros, and eye diagram. It can also be used to display the coefficients in a table format.

Coefficients generated by Digital Filter Designer can be used to implement filters and they can be imported into Agilent Ptolemy filter components. Schematics generated by Digital Filter Designer can be added to Advanced Design System schematics and they can be synthesized using DSP Synthesis.
Main Window

The Main window is displayed each time the application is launched. It displays a set of specifications that may be modified as desired.

In general it may be fruitful to think of the Main window in terms of its three regions, each with its own focus: filter specification area, response specification area, and filter implementation area. While the first two regions are used to design an ideal filter, the third region is used to specify the details for conversion from the ideal filter to a practical filter design.

**Note**  Disabling conversion reduces the filter design time. So, if your current focus is to generate only an ideal filter design, choose Options > Disable/Enable Conversion to deactivate the implementation functions.
Menus and Toolbar

The Digital Filter Designer environment provides six menus along with a toolbar that includes buttons for commonly performed tasks.

Menubar

The Digital Filter Designer menubar is made up of the following six menus:

• File
• Design
• Options
• View
• Tools
• Help

The File menu includes the standard Advanced Design System project and file manipulation commands. The Design menu includes commands used to design a filter based upon the displayed specifications and generate a schematic of the filter design. The Options menu provides customizing options along with commands to use alternative design methods. The View menu provides a command to display the filter coefficients and the toolbar. The Help menu provides commands to access online documentation and context-sensitive help.
Digital Filter Designer

**Toolbar**

The Digital Filter Designer toolbar includes frequently used buttons for folder and file manipulation, filter design, filter analysis, and output generation tasks.

![Digital Filter Designer Toolbar](image)

The function of each button on the toolbar (going from left to right) is as follows:

- New Project
- Open Project
- Create New Filter Design
- Open Existing Filter Design
- Save Current Filter Design
- Print Current Filter Design
- Import Ideal Coefficients File
- Start Filter Design
- Analyze
- Setup Analysis Parameters
- [Root] Raised Cosine Wizard
- Disable/Enable Conversion
- Generate Schematic
- View Coefficients
- What's This?

**Desired Response Tab**

The Desired Response tab is used to enter the filter specifications for the desired response. These specifications include the number of passbands and stopbands along
with their frequency, amplitude, ripple, and phase values. The numerical format, polynomial or linear, used to describe the amplitude can also be specified.

**Weighting Function Tab**

The Weighting Function tab is used to define any weighting you may want to specify for the desired response. Weighting specifications include the number of weightbands along with their frequency and magnitude values. The numerical format, polynomial or linear, used for the frequency values can also be specified. The settings in this tab are available when designing an FIR filter using either the Least Squares method or the Equiripple method with a manually specified filter order.
Other Parameters Tab

The Other Parameters tab is used to enter a collection of specifications for transformation, compensation, symmetricity, and windowing parameters when designing certain special (and nonstandard) filters.

Data Display Window

The Data Display window is used to plot and display the data and graphs generated when a filter is designed, a design is analyzed, specifications are plotted, or
coefficients are displayed. This window is launched automatically after a filter is designed.

Status Window

The Status window is displayed automatically when Digital Filter Designer is launched. This window is used to display feedback that is divided into two parts:
simulation or synthesis messages including errors and warnings, and status or summary messages.
Chapter 2: Digital Filter Designer Basics

The Digital Filter Designer offers you an integrated environment for creating and simulating a filter design based upon your specifications. Once a filter is designed, you can view an analysis of its simulation in a Data Display window that is launched automatically. The data displayed in this window can also be configured to use a variety of plot and tabular options.

Digital Filter Designer uses the Advanced Design System project paradigm. A project acts as a container for the data generated in designing, simulating, and analyzing one or more filter designs. It is also used to store the analysis displays, filter coefficients, and implementation schematics.

You will need to create or open a design project before you begin using Digital Filter Designer for your filter design tasks. Once you open or create a project, you can begin the process of either modifying an existing filter design or creating a new filter design using one of several available methods to define the filter specifications.

In addition to being able to print the filter specifications and the contents of any given display, coefficients or filter taps generated using Digital Filter Designer can be exported in an ASCII format. An implementation schematic of the digital filter can also be generated, if desired.

Launching Digital Filter Designer

The Digital Filter Designer can be launched independently or from within the Advanced Design System (ADS). Depending upon your computer platform and
configuration, you can launch the Digital Filter Designer using any one of the following methods:

**From an ADS Schematic window:**

Choose **Tools > Start Digital Filter** from the Schematic window menubar for a signal processing design.

When you launch Digital Filter Designer this way, it uses the current design project directory and you can continue on to creating or modifying a digital filter design.

**On a UNIX workstation:**

To launch Digital Filter Designer without launching the ADS, type `dfilter` in a terminal window.

When you launch Digital Filter Designer in this manner, you need to open or create a project before you can continue on to creating or modifying a digital filter design.

---

**Tip** Navigate to within a project directory before you type `dfilter` in a terminal window to facilitate access to designs within the project directory.

---

**On a PC:**

To launch Digital Filter Designer without launching the ADS, choose **Start > Programs > Advanced Design System > ADS Tools > ADS Digital Filter Designer.**

When you launch Digital Filter Designer this way, you need to open or create a project before you can continue on to creating or modifying a digital filter design.

Once Digital Filter Designer is launched and a project has been opened, the specification options in the Main window become active. Choose **Help > What’s This?** from the Digital Filter Designer menubar and click within the window to display context-sensitive, online help for using the item you clicked.

---

**Using Projects**

Digital Filter Designer uses the Advanced Design System paradigm of projects. A project acts as an organizer of one or more designs that may be created to accomplish
a larger, overall design goal. A project is also used to keep together all the information generated in the process of designing, simulating, analyzing, and implementing a digital filter design.

### Creating a New Project

You will need to create or open a design project before you can begin using Digital Filter Designer for your design tasks. To create a new design project, choose **File > New Project** from the Digital Filter Designer menubar and display the New Project dialog box.

Enter a name and path for the new project or click **Browse** and use the New Project File Browser dialog box to define the path.
Digital Filter Designer Basics

Once you have defined a name and path, click **OK** in the New Project dialog box to create the project. A feedback message is displayed to confirm that the current working directory has been changed to the project you specified.

The Digital Filter Designer window is then updated to display the default filter specifications which you can modify as desired to complete your digital filter design tasks.

**Opening an Existing Project**

To open and work within an existing project, choose **File > Open Project** from the Digital Filter Designer menubar and use the Open Project dialog box that is displayed to locate the existing project you wish to use.
Once you have selected the project you wish to use, click OK in the Open Project dialog box to open the project.

**Managing Designs**

Digital Filter Designer offers the standard file handling and management capabilities. Even though more than one file or component is used to make up a design file, the interface is designed to present a simple and familiar environment.

**Creating a Design**

Choose File > New Filter Design from the Digital Filter Designer menubar to create a new design file. An alert message is displayed to confirm whether you wish to save any changes made to the currently open file.

![Save Design Alert]

After you choose to save or discard any changes, a new, untitled design file is created and the Digital Filter Designer window is updated to display the default filter specifications which you can modify as desired to complete your digital filter design tasks.

**Using Command Lines**

Digital Filter Designer includes a command line interface that you can use to automate some of your filter design tasks. Choose Options > Command Line to display the Command Line dialog box.
By keeping this dialog box open while you complete your filter design tasks, you can generate a list of commands that you can reuse either directly or with any enhancements or parameters you wish to add.

**Opening a Design**

Choose **File > Open Filter Design** from the Digital Filter Designer menubar to open an existing filter design file. An alert message is displayed to confirm whether you wish to save any changes made to the currently open file.

After you choose to save or discard any changes, the File Open dialog box is displayed to enable you to identify the existing file you wish to open.
Once you have selected the design file you wish to use, click OK in the File Open dialog box to open the file and proceed with your digital filter design tasks.

**Retrieving Filter Designs**

Choose Tools > Digital Filter > Retrieve and Place Current Ideal (Scaled) Coefficient Filter from an Advanced Design System Schematic Window to retrieve a filter design and generate a schematic. When you open a filter design in this manner, a schematic is generated using the filter coefficients. You will need to have Digital Filter Designer running to perform this operation. A schematic of the designed filter will be created and saved using the filename you specify.

**Using the Design List**

If the design file you wish to open is located within the current project directory, choose File > Design List from the Digital Filter Designer menubar to display the Design List dialog box that lists all the existing design files in the current project.

Click a design file to select it and click OK to open it. An alert message is displayed to confirm whether you wish to save any changes made to the currently open file. After you choose to save or discard any changes, the design file you selected is opened.
Digital Filter Designer Basics

**Using File History**
If you wish to reopen one of the last five designs you created or modified using Digital Filter Designer, choose the design from the list at the bottom of the Digital Filter Designer File menu. An alert message is displayed to confirm whether you wish to save any changes made to the currently open file. After you choose to save or discard any changes, the design file you selected is opened.

**Importing Ideal Coefficients**
To design a digital filter using an existing set of ideal coefficients, choose File > Import Ideal Coefficients File from the Digital Filter Designer menubar and display the Import Ideal Coefficients File dialog box.
Enter a name and path for the file containing the ideal coefficients you wish to use or click **Browse** and use the File Import Ideal Coefficients dialog box to define the filename and path.

Once you have defined a name and path, click **OK** in the Import Ideal Coefficients File dialog box to import the file and proceed with your digital filter design tasks.

**Importing an Ideal Coefficients Function**

Digital Filter Designer also enables you to test, view, edit, and import an AEL function you've created to generate the ideal coefficients for a custom, Gaussian, or Edge standard digital filter. Using this import function you can create your own special FIR filter that can then be scaled, quantized, and implemented for simulation and synthesis.
To design a digital filter using an AEL function to generate its coefficients, choose File > Import Ideal Coefficients Function from the Digital Filter Designer menubar and display the Import Ideal Coefficients Function dialog box.

Enter a name and path for the file containing the AEL function you wish to use or click Browse and use the File Import Ideal Coefficients Function dialog box to define the filename and path.

You can use the Import Ideal Coefficients Function dialog box to display and edit the function, and to test it. For details on using AEL to create a function, refer to “Manipulating Arrays” on page 7-1.

Click OK in the Import Ideal Coefficients Function dialog box to import the function and proceed with your digital filter design tasks.

---

**Note**  An AEL template that can be customized is included with the current installation of Digital Filter Designer. You can modify this template to design symmetric FIR filters according to GSM specifications using the desired rolloff, symbol period, and tolerable order values.
Ideal Coefficients File Format

The ideal coefficients file you import needs to be created using the following template:

<table>
<thead>
<tr>
<th>FIR Filter</th>
<th>IIR Filter</th>
</tr>
</thead>
<tbody>
<tr>
<td>BEGIN FIR</td>
<td>BEGIN IIR</td>
</tr>
<tr>
<td># FIR (time_dim parm_format T t QuantizeCoeff)</td>
<td># IIR (time_dim parm_format T t QuantizeCoeff)</td>
</tr>
<tr>
<td>% X</td>
<td>% X</td>
</tr>
<tr>
<td>C(0,0)</td>
<td>b(0,1)...b(0,2) a(0,1)...a(0,2)</td>
</tr>
<tr>
<td>C(1,0)</td>
<td>b(1,1)...b(1,2) a(1,1)...a(1,2)</td>
</tr>
<tr>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>C(N-1,0)</td>
<td>END IIR</td>
</tr>
<tr>
<td>END FIR</td>
<td>END IIR</td>
</tr>
</tbody>
</table>

Where:

time_dim specifies the units used for the sampling time step t. The available formats are SEC, MSEC, USEC, NSEC, and PSEC.

parm_format specifies the format used for the filter coefficients. The available formats are:

- RI for real and imaginary
- MA for magnitude and angle (degree)
- DB for 20log (magnitude) and angle (degree)

T is placed to make the file more readable and to indicate the following number is the sampling time and t is the actual sampling time.

QuantizeCoeff is used to indicate to the application the coefficients may be quantized, if needed.

Instrument Link

If your computer has an HPIB or GPIB card and supporting software installed, you can use the Instrument Link feature. This allows FIR filter coefficients to be exported to instruments such as the Agilent ESG-D signal generator and eliminates the need to manually enter each coefficient with the FIR table editor.
Digital Filter Designer Basics

To export a digital filter design, choose File > Export Ideal Coefficients from the Digital Filter Designer menubar. The Export Ideal Coefficients to Instrument dialog appears.

Enter the address of the instrument that you want to connect to. The HP-IB address for the Agilent ESG-D can be found by pressing the Utility key on the instrument. Type the symbolic name of the interface card (required to transfer data via the HPIB or GPIB cards). Then enter the FIR file name. This file will be used to store the coefficients in the instrument.

When you have entered the information, click OK to export the design data to the instrument.
Copying and Saving a Design

Choose **File > Save As** from the Digital Filter Designer menubar to save a copy of the currently open filter design file. Use the File Save As dialog box that is displayed to provide a name and location for the file you wish to create.

If you have computed the ideal and the implementation coefficients for the filter design, separate files containing each set of coefficients are saved as ASCII files using the MDIF format. The naming convention used for these files is `<design_name>ideal.mdb` and `<design_name>scaled.mdb` respectively and the files are saved in the synthesis subdirectory within the project directory. Files without the header information are also saved in the same location using the same naming convention and the `.txt` extension. Ideal coefficients from these files can be used for components within Agilent Ptolemy or any other application.

Coefficients for an FIR filter are listed in a single column whereas those for an IIR filter are listed in six (6) columns where each row corresponds to a second-order section and the coefficients are listed as $b_0$, $b_1$, $b_2$, $a_0$, $a_1$, $a_2$ where $b_0$, $b_1$, $b_2$ and $a_0$, $a_1$, $a_2$ denote the numerator and denominator coefficients, respectively. For details on the coefficient formats, or for information on how the coefficient values can be displayed, refer to "Displaying Coefficients" on page 6-11 in Chapter 6, Analysis.
and Output. For details on using these coefficients, refer to "Using Coefficients in Agilent Ptolemy Components" on page 6-17 in Chapter 6, Analysis and Output.

Generating Outputs

Digital Filter Designer can be used to print filter specifications, display plots for analyzing filter designs, view filter coefficients, and generate schematic outputs.

Printing Specifications

Choose File > Print Filter Design from the Digital Filter Designer menubar to generate a printout of the filter specifications. Choose File > Print Setup from the Digital Filter Designer menubar to modify the printer and printing specifications, as desired.

The printed output lists the current filter, parameter, and implementation specifications.

Plotting an Analysis

Choose Design > Design Filter from the Digital Filter Designer menubar to design a filter based upon the entered specifications. After the filter design process is completed, various plots are displayed automatically for your analysis.

The data computed and plotted for your analysis depends upon the kind of filter being designed, FIR or IIR, and the analysis options you specify. To define the options and detail used in the display of plots for analysis, choose Design > Setup Analysis.
from the Digital Filter Designer menubar to display the Setup Analysis dialog box. Click **Help** within the dialog box to display online help instructions on the available options.

![Setup Analysis Dialog Box](image)

Use this dialog box to select the analysis options. Some of the options, such as the display of Poles/Zeros and Group Delay, are only available for IIR filters, and the Eye diagram plot option is only available for raised cosine and root raised cosine FIR filters. Options that you select are used to display plots for analyzing your filter design.
Choose Design > Analyze from the Digital Filter Designer menubar to display the plots for designed filter.
Generating a Schematic

Choose Design > Generate Schematic from the Digital Filter Designer menubar to generate a schematic based upon a filter design. Use the Generate Schematic dialog box that is displayed to specify a name and type for the schematic to be generated.

The schematic is generated and displayed in a new schematic window that is launched within Advanced Design System.
Digital Filter Designer Basics

Viewing Coefficients

Choose View > Coefficients from the Digital Filter Designer menubar to display the coefficients for the designed filter. A table listing the filter coefficients is displayed automatically in the Data Display window.

<table>
<thead>
<tr>
<th>Coefficients</th>
<th>Ideal Coefficients , data</th>
<th>ind</th>
<th>Scaled Coefficients , data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1.000</td>
<td>1</td>
<td>0.032</td>
</tr>
<tr>
<td>2</td>
<td>2.000</td>
<td>2</td>
<td>0.073</td>
</tr>
<tr>
<td>3</td>
<td>1.000</td>
<td>3</td>
<td>0.037</td>
</tr>
<tr>
<td>4</td>
<td>0.887</td>
<td>4</td>
<td>0.070</td>
</tr>
<tr>
<td>5</td>
<td>-0.880</td>
<td>5</td>
<td>-1.374</td>
</tr>
<tr>
<td>6</td>
<td>1.000</td>
<td>6</td>
<td>1.000</td>
</tr>
<tr>
<td>1</td>
<td>1.000</td>
<td>1</td>
<td>0.190</td>
</tr>
<tr>
<td>2</td>
<td>2.000</td>
<td>2</td>
<td>0.065</td>
</tr>
<tr>
<td>3</td>
<td>1.000</td>
<td>3</td>
<td>0.190</td>
</tr>
<tr>
<td>4</td>
<td>0.874</td>
<td>4</td>
<td>0.710</td>
</tr>
<tr>
<td>5</td>
<td>-0.876</td>
<td>5</td>
<td>-1.218</td>
</tr>
<tr>
<td>6</td>
<td>1.000</td>
<td>6</td>
<td>1.000</td>
</tr>
<tr>
<td>1</td>
<td>1.000</td>
<td>1</td>
<td>0.181</td>
</tr>
<tr>
<td>2</td>
<td>2.000</td>
<td>2</td>
<td>0.361</td>
</tr>
<tr>
<td>3</td>
<td>1.000</td>
<td>3</td>
<td>0.181</td>
</tr>
<tr>
<td>4</td>
<td>0.796</td>
<td>4</td>
<td>0.795</td>
</tr>
<tr>
<td>5</td>
<td>-0.799</td>
<td>5</td>
<td>-0.832</td>
</tr>
<tr>
<td>6</td>
<td>1.000</td>
<td>6</td>
<td>1.000</td>
</tr>
</tbody>
</table>
Chapter 3: Creating a Multipass FIR Filter

The exercises that follow demonstrate the ease with which you can design, analyze, and generate outputs for a digital filter using Digital Filter Designer. Complete the exercises before you use Digital Filter Designer for your filter design tasks. Doing the exercises first will help you understand the basic features and conventions of the Digital Filter Designer and save you time later.

Feel free to go through the exercises at your own pace. Stop or digress at any time you wish, and pick up later where you left off. The exercises, like Digital Filter Designer, put you in control with an environment that is flexible enough to work the way you do.

This tutorial teaches you to design, implement, and generate outputs for a multipass FIR filter design using the following exercises:

• **Exercise 1: Entering Design Specifications** introduces you to the basics of entering the filter design specifications and the desired response and weighting specifications. After going through this exercise you should be able to create a filter design based upon your specifications.

• **Exercise 2: Designing and Analyzing a Filter** introduces you to the basics of analyzing a design. After going through this exercise you should be able to specify analysis options, design a digital filter, and generate analysis plots.

• **Exercise 3: Implementing a Filter Design** introduces you to the basics of implementing a filter design. After going through this exercise you should be able to specify implementation options, display filter coefficients, and generate a schematic from the filter design.

Response and Weighting Specifications

This exercise takes you through the design process for a 64-tap, symmetric, multipass FIR filter that uses the Frequency Weighted Least Squares design method. The specifications call for two passbands and three stopbands with a sampling frequency of 8 kHz. The desired magnitude response for this linear phase filter uses the following specifications:
Creating a Multipass FIR Filter

Table 3-1. Desired Magnitude Response Specifications.

<table>
<thead>
<tr>
<th>Frequency Band</th>
<th>Magnitude</th>
</tr>
</thead>
<tbody>
<tr>
<td>400 to 1200 Hz</td>
<td>1.0</td>
</tr>
<tr>
<td>1600 to 2400 Hz</td>
<td>1.0</td>
</tr>
<tr>
<td>0 to 400 Hz</td>
<td>0</td>
</tr>
<tr>
<td>1200 to 1600 Hz</td>
<td>0</td>
</tr>
<tr>
<td>2400 to 4000 Hz</td>
<td>0</td>
</tr>
</tbody>
</table>

These specifications can be represented graphically as follows:

![Graph showing magnitude response specifications]

The desired weighting specifications for the magnitude response of this filter conform to the following specifications using the polynomial magnitude format:

Table 3-2. Desired Weighting Specifications.

<table>
<thead>
<tr>
<th>Frequency Band</th>
<th>Frequency</th>
<th>Weighting</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>0 to 300 Hz</td>
<td>2.5, 0.03125</td>
</tr>
<tr>
<td>1</td>
<td>400 to 1200 Hz</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>1300 to 1500 Hz</td>
<td>5</td>
</tr>
<tr>
<td>3</td>
<td>1600 to 2400 Hz</td>
<td>0.5, 0, 1.5625e-5</td>
</tr>
<tr>
<td>4</td>
<td>2500 to 4000 Hz</td>
<td>1</td>
</tr>
</tbody>
</table>
Exercise 1: Entering Design Specifications

The weighting specifications can be represented graphically as follows:

![Weighted Magnitude vs Frequency Graph](image)

Keep in mind that weighting indicates the priority of desired magnitude response at the designated passband, stopband, or transition band.

**Exercise 1: Entering Design Specifications**

This exercise is made up of three sections. Each section takes you through the steps involved in a specific aspect of creating a digital filter design for a multipass FIR filter. The first section takes you through the process of launching Digital Filter Designer and creating a design file. The next two sections take you through the process of entering, saving, and printing the response and weighting specifications for the filter design.

Complete the following sections to create the filter design. At the end of this exercise, you will be familiar with the major features and ease-of-use advantages of using Digital Filter Designer to enter and verify specifications for a digital filter design.

- Create a filter design file
- Define the desired response
- Save and print specifications

**Creating the Filter Design**

Assume that your goal is to create a multipass FIR filter design using the Frequency Weighted Least Squares method. This section takes you through the process of
Creating a Multipass FIR Filter

launching Digital Filter Designer and creating a new design project. It ends with saving the design and printing a copy of your filter specifications.

**Note** This exercise assumes that you have a working knowledge of Advanced Design System. For more information on the available features and functionality, refer to the Advanced Design System User's Guide.

1. Launch Advanced Design System.

   Launch Advanced Design System, create a new signal processing design project, and open a Schematic window for a digital signal processing network design.

   The Main window is used to create and manage projects and designs, while the Schematic window is used to actually create the design.
2. Launch Digital Filter Designer.

Choose **Tools > Digital Filter > Start Digital Filter** from the Schematic window menubar to launch Digital Filter Designer.

In addition to the Digital Filter Designer window, a Status window is displayed. Feedback messages on the progress of tasks you initiate are displayed in this window.
Creating a Multipass FIR Filter

3. Verify that **FIR** is the currently selected filter type.

4. Choose **Multipass** as the desired response type to create a multipass FIR filter design.

5. Choose **Least Squares** as the desired design method.
   
   When you choose Least Squares as the design method, you also need to specify the number of taps or filter order. Accept the default filter order of 64.

6. Specify the frequency unit of measure.
   
   Use the drop-down list to choose **Hz** as the unit of measure for the response specifications. The frequency unit you specify is used automatically for any desired response values you enter subsequently.

7. Enter **8 kHz** as the sampling frequency for the filter. You can override a default unit of measure by entering a different unit of measure for a particular value.
Exercise 1: Entering Design Specifications

8. Enter the desired number of passbands.

Enter 2 as the desired number of passbands and press Tab to validate your choice. Doing so displays the Select Stopband Number dialog box, which you can use to specify the corresponding number of stopbands. Accept the default of 3 stopbands.

![Select Stopband Number dialog box]

Defining the Desired Response

Now that you have defined a multipass FIR filter design using the Frequency Weighted Least Squares method, you can begin the process of entering the desired response specifications. This section takes you through the process of entering the desired response and weighting specifications using the Desired Response and Weighting Function tabs.

![Desired Response and Weighting Function interface]
1. Enter the desired response specifications.

Enter the following values for the low and high frequencies of the two passbands:

Table 3-3. Passband Frequency Entries.

<table>
<thead>
<tr>
<th>Low Frequency</th>
<th>High Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td>400 Hz</td>
<td>1200 Hz</td>
</tr>
<tr>
<td>1600 Hz</td>
<td>2400 Hz</td>
</tr>
</tbody>
</table>

The grayed-out low and high frequencies for the three stopbands should change to the following values:

Table 3-4. Stopband Frequency Entries.

<table>
<thead>
<tr>
<th>Low Frequency</th>
<th>High Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 Hz</td>
<td>400 Hz</td>
</tr>
<tr>
<td>1200 Hz</td>
<td>1600 Hz</td>
</tr>
<tr>
<td>2400 Hz</td>
<td>4000 Hz</td>
</tr>
</tbody>
</table>

2. Enter the weighting for the magnitude response specifications.

Click the **Weighting Function** tab. Enter 5 as the desired number of weightbands and press Tab to add the weightbands.
Note  To add weightbands when their specifications are similar to the desired response specifications, click **Copy Desired Bands** to copy the specifications from the desired response bands and create weightband specifications. You can then modify the specifications for each weightband, as desired.

Enter the following values for the low and high frequencies and magnitudes of the five weightbands:

<table>
<thead>
<tr>
<th>Low Frequency</th>
<th>High Frequency</th>
<th>Magnitude</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 Hz</td>
<td>300 Hz</td>
<td>2.5, 0.03125</td>
</tr>
<tr>
<td>400 Hz</td>
<td>1200 Hz</td>
<td>1</td>
</tr>
<tr>
<td>1300 Hz</td>
<td>1500 Hz</td>
<td>5</td>
</tr>
<tr>
<td>1600 Hz</td>
<td>2400 Hz</td>
<td>0.5, 0, 1.5625e-5</td>
</tr>
<tr>
<td>2500 Hz</td>
<td>4000 Hz</td>
<td>1</td>
</tr>
</tbody>
</table>

**Saving and Printing the Specifications**

Now that you have created a multipass FIR filter design using the Frequency Weighted Least Squares method and entered the desired response and weighting specifications, you can save your design specifications and verify their accuracy. This section takes you through the process of saving the design and printing a copy of your filter design specifications.

1. Save the filter design.
   Choose **File > Save Filter Design** and use the File Save As dialog box that is displayed to name and save the filter design specifications you have entered.

2. Print the specifications.
   Choose **File > Print Filter Design** and use the Print dialog box that is displayed to print the filter design specifications you have just entered. Use the printout to verify the accuracy of what you have entered against the following specifications.

*Filter type: FIR
Response type: Multipass
Method type: Least Squares
Order: 64*
Creating a Multipass FIR Filter

Frequency unit: MHz
Sampling frequency: 8 kHz

Desired response specification:
Magnitude format: Polynomial
Number of passbands: 2
Number of stopbands: 3
Specification values:
Stopband[0]: (0.0 MHz, 400 Hz, (0.0), n/a, (1, 0))
Passband[0]: (400 Hz, 1200 Hz, (1.0), n/a, (1, 0))
Stopband[1]: (1200 Hz, 1600 Hz, (0.0), n/a, (1, 0))
Passband[1]: (1600 Hz, 2400 Hz, (1.0), n/a, (1, 0))
Stopband[2]: (2400 Hz, 4 kHz, (0.0), n/a, (1, 0))

Weighting function specification:
Amplitude format: Polynomial
Number of weightbands: 5
Specification values:
weightband[0]: (0.0 MHz, 300 Hz, (2.5,0.03125))
weightband[1]: (400 Hz, 1200 Hz, (1.0))
weightband[2]: (1300 Hz, 1500 Hz, (5.0))
weightband[3]: (1600 Hz, 2400 Hz, 0.5,0,1.5625e-5)
weightband[4]: (2400 Hz, 4 kHz, (1.0))

Other parameters specifications:
Compensation: unity
Symmetricity: symmetric

Conversion/Implementation data:
Implementation structure: Direct
Number of bits: 32
Implementation format: Floating_point
Norm criterion: L-infinity

Exercise 2: Designing and Analyzing a Filter

This exercise is made up of two sections. Each section takes you through the steps involved in a specific aspect of designing and analyzing the multipass FIR digital filter. The first section provides an overview of the analysis options. The second section takes you through the process of designing the filter and displaying the analysis plots.
Complete the following sections to analyze the filter design. At the end of this exercise, you will be familiar with the major features and ease-of-use advantages of analyzing filter designs using Digital Filter Designer.

- Choose the analysis options
- Display the analysis plots

**Choosing the Analysis Options**

Assume that your goal is to set up the analysis options for the multipass FIR filter design that you created. This section takes you through the process of specifying the analysis options.

1. Specify the analysis options.

   Choose **Design > Setup Analysis** to display the Setup Analysis dialog box.

   ![Setup Analysis Dialog Box]

   The Setup Analysis dialog box is used to define the three basic analysis options: the detail used to display results graphically, the plots to be displayed, and whether comparative data needs to be retained.
Creating a Multipass FIR Filter

First enter 512 as the number of frequency points to be plotted. The higher the number of frequency points, the greater the response resolution.

Then select the option to plot the magnitude specifications within the frequency response plot. Choosing this option will enable you to see the specified shape and how closely the response adheres to it.

Click OK to specify the setup options and close the dialog box.

2. Disable the conversion options.

Choose Options > Disable/Enable Conversion to disable the implementation details for the filter design. When the implementation options are disabled, only the ideal filter analysis (using the full IEEE double precision or machine-defined standard) is performed.

Designing and Analyzing the Filter

Now that you have specified the analysis options, it is time to design the filter and see how closely it meets the desired response specifications. This section takes you through the process of designing the ideal filter and displaying the analysis plots.

1. Design the filter and display the plots.

Choose Design > Design Filter to begin the process of designing the digital filter using the specifications and analysis options you have defined. Once the design process is complete, the analysis plots are displayed automatically in a Data Display window. In the example below, the Y-axis displays dB.
Exercise 3: Implementing a Filter Design

This exercise is made up of two sections. Each section takes you through the steps involved in a specific aspect of implementing the digital filter design for a multipass FIR filter. The first section provides an overview of the implementation options. The second section takes you through the process of generating a schematic from the filter design.
Creating a Multipass FIR Filter

Complete the following sections to generate a practical filter design. At the end of this exercise, you will be familiar with the major features and ease-of-use advantages of implementing filter designs using Digital Filter Designer.

- Choose the implementation options
- Generate a Schematic

Choosing the Implementation Options

Assume that your goal is to set up the implementation options for the multipass FIR filter design that you created. This section takes you through the process of specifying the implementation options.

1. Activate the implementation options.

   Choose Options > Disable/Enable Conversion and select the implementation details for the filter design. Once the implementation options are activated, the ideal filter analysis (using the full IEEE double precision or machine-defined standard) can be compared to a scaled analysis using the specified numeric format and precision.

2. Choose the implementation structure.

   Choose Direct Transpose as the implementation structure. A direct transpose structure can be used to implement symmetric FIR filters with half as many multipliers as there are coefficients.

3. Define the desired numeric format and bitwidth.

   Select Fixed Point as the numeric format. A fixed-point format scales (quantizes) the filter coefficients based upon the bitwidth you enter.
Once you select a fixed-point format, enter 16 as the desired bitwidth.

4. Design the filter and display the plots.

Choose **Design > Design Filter** to begin the process of designing the digital filter using the implementation options you have specified. Once the design process is complete, the Data Display window is updated automatically to display both the ideal and the scaled plots.

As you can see, the performance of the scaled filter closely approximates the performance of the ideal filter.
Creating a Multipass FIR Filter

Generating a Schematic

Now that you have designed a filter using the implementation options, you can generate a schematic from the filter design. This section takes you through the process of generating a schematic from a digital filter design.

1. Save the filter design.
   
   Choose **File > Save Filter Design** to save the filter design you have created.

2. Display the filter coefficients.
   
   Choose **View > Coefficients** to display the coefficients for the filter you have designed. The coefficients are displayed in a new table within the Data Display window.

   Click the table to select it and choose **Edit > Item Options** from the Data Display menubar to display the Insert Plot dialog box. Click the Plot Options tab and enter 15 in the # of Decimal Digits field.

   ![Insert Plot Dialog Box]

   Click **OK** to dismiss the dialog box and display the table of coefficients. The first column displays the coefficient number, the second column displays coefficients.
for an ideal or floating-point implementation, while the third column displays coefficients for a scaled or fixed-point implementation.

<table>
<thead>
<tr>
<th>Index</th>
<th>Ideal Coefficients...data</th>
<th>Scaled Coefficients...data</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>-0.01235465789012345</td>
<td>-0.01235465789012345</td>
</tr>
<tr>
<td>1</td>
<td>-0.0234567890123456</td>
<td>-0.0234567890123456</td>
</tr>
<tr>
<td>2</td>
<td>-0.0345678901234567</td>
<td>-0.0345678901234567</td>
</tr>
<tr>
<td>3</td>
<td>-0.0456789012345678</td>
<td>-0.0456789012345678</td>
</tr>
<tr>
<td>4</td>
<td>-0.0567890123456789</td>
<td>-0.0567890123456789</td>
</tr>
<tr>
<td>5</td>
<td>-0.0678901234567890</td>
<td>-0.0678901234567890</td>
</tr>
<tr>
<td>6</td>
<td>-0.0789012345678901</td>
<td>-0.0789012345678901</td>
</tr>
<tr>
<td>7</td>
<td>-0.0890123456789012</td>
<td>-0.0890123456789012</td>
</tr>
<tr>
<td>8</td>
<td>-0.0901234567890123</td>
<td>-0.0901234567890123</td>
</tr>
<tr>
<td>9</td>
<td>-0.1012345678901234</td>
<td>-0.1012345678901234</td>
</tr>
<tr>
<td>10</td>
<td>-0.1123456789012345</td>
<td>-0.1123456789012345</td>
</tr>
<tr>
<td>11</td>
<td>-0.1234567890123456</td>
<td>-0.1234567890123456</td>
</tr>
<tr>
<td>12</td>
<td>-0.1345678901234567</td>
<td>-0.1345678901234567</td>
</tr>
<tr>
<td>13</td>
<td>-0.1456789012345678</td>
<td>-0.1456789012345678</td>
</tr>
<tr>
<td>14</td>
<td>-0.1567890123456789</td>
<td>-0.1567890123456789</td>
</tr>
<tr>
<td>15</td>
<td>-0.1678901234567890</td>
<td>-0.1678901234567890</td>
</tr>
<tr>
<td>16</td>
<td>-0.1789012345678901</td>
<td>-0.1789012345678901</td>
</tr>
<tr>
<td>17</td>
<td>-0.1890123456789012</td>
<td>-0.1890123456789012</td>
</tr>
<tr>
<td>18</td>
<td>-0.1901234567890123</td>
<td>-0.1901234567890123</td>
</tr>
<tr>
<td>19</td>
<td>-0.2012345678901234</td>
<td>-0.2012345678901234</td>
</tr>
<tr>
<td>20</td>
<td>-0.2123456789012345</td>
<td>-0.2123456789012345</td>
</tr>
</tbody>
</table>

Note: To display the rest of the coefficients, enlarge the window or use the scroll bars. For details on using the Data Display window, refer to the Data Display online help or User’s Guide.

3. Generate a schematic for the filter design.

Choose Design > Generate Schematic from the Digital Filter Designer menubar to display the Generate Schematic dialog box.
Creating a Multipass FIR Filter

Enter a name for the scaled coefficient schematic to be generated and click OK to generate and display the schematic in a new Schematic window within Advanced Design System.

4. Save the schematic.

Choose File > Save Design As from the Advanced Design System Schematic window menubar and use the dialog box that is displayed to save the schematic using the desired name and location.

5. Save the filter design and exit Digital Filter Designer.

Choose File > Save As from the Digital Filter Designer menubar and use the dialog box that is displayed to save the filter design file using the desired name and location.

Choose File > Exit from the Digital Filter Designer menubar to exit the application.

Choose File > Exit Advanced Design System from either the Schematic or the Main window menubar to exit Advanced Design System.
Congratulations. This marks the end of the tutorial exercises for Digital Filter Designer. The steps you have gone through in this tutorial make up a majority of the tasks you are likely to use in your day-to-day filter design tasks.

If you have completed all three exercises, you have created, analyzed, and implemented a multipass FIR filter that conforms to the given desired response specifications.

Please refer to the online documentation for details on the tasks you have completed in these exercises and the other features you can use to design a digital filter using Digital Filter Designer.

For more information on using either the Advanced Design System or Data Display, refer to their online documentation.
Creating a Multipass FIR Filter
Chapter 4: Designing a Digital Filter

This chapter describes the steps involved in designing a digital filter. It also includes reference and background information on the available options. The two basic steps for designing a digital filter using Digital Filter Designer are:

1. **Define the filter design specifications.**
   
   This step consists of defining the filter type, design method, and filter order.

   ![Diagram of filter design specifications]

2. **Define the filter response specifications.**

   This step consists of defining one or more of the following specifications: Frequency unit, sampling frequency, response type, response specifications, amplitude entry format, weighting function, transform, compensation, and symmetricity.

   ![Diagram of filter response specifications]

**Choosing a Filter Response Type**

Choose either an Infinite Impulse Response (IIR) filter or a Finite Impulse Response (FIR) filter based upon your performance, design, and implementation needs and limitations. For example, when linearity of phase is an issue, an FIR filter is a better choice because an IIR filter achieves its computational efficiency at the cost of nonlinear phase.
4-2 Choosing a Filter Response Type

Designing a Digital Filter

- To specify the filter type for a design within Digital Filter Designer, click the desired option to select it.

**FIR**

A Finite Impulse Response (FIR) type is an all-zero or moving average (MA) filter that uses past and present input samples to calculate the output value.

In general the FIR design problem is easier to control in a wide range of practical situations. An FIR filter is able to provide pure linear-phase characteristics. It also can accurately approximate arbitrary frequency-response characteristics.

Even though a non-recursive design typically needs a large number of coefficients, it is inherently stable because it does not involve feedback.

The following illustration depicts the difference equation and implementation structure for a transposed FIR filter.

\[ y[n] = b_0 x[n] + b_1 x[n-1] + b_2 x[n-2] + b_3 x[n-3] \]

**IIR**

An Infinite Impulse Response (IIR) type is a pole and zero or auto-regressive, moving average (ARMA) filter. Each output value in such a filter is calculated using previous outputs, as well as past and present input samples. The feedback in this system gives this filter an impulse response that is infinite in duration.
Simplicity of its design procedure is a major advantage of an IIR filter. A variety of classical frequency-selective filters can be designed using closed-form formulas. Another major advantage of an IIR filter is its computational economy with respect to the filter implementation. Filter responses with high frequency selectivity can be obtained using a few recursive coefficients.

An IIR filter is generally unable to provide a linear phase response and its implementation is relatively more complex. However, when phase considerations are not an issue, a given magnitude response specification can be implemented more efficiently with an IIR filter.

The following illustration depicts the difference equation and structure for an IIR filter.

\[
y[n] = 2x[n] + 5x[n-1] + 7x[n-2] + 4y[n-1] + 3y[n-2]
\]

Choosing a Frequency Response

The output spectrum of a linear, time-invariant filter is a result of the product of the input signal spectrum and the filter’s frequency response. Specifying the frequency response of a filter thus determines which frequency bands of the input signal will be passed and which will be rejected.
Choosing a Frequency Response

Note: An ideal filter would do a perfect job of either passing or attenuating a region of the spectrum. Actual filters, however, have passbands that are not perfectly flat, stopbands that don’t reject bands of frequencies completely, and transitions between passbands and stopbands that are not instantaneous.

- To choose the frequency response type within Digital Filter Designer, click the desired option to select it.

Choose a frequency response to specify the desired passband and stopband response. In addition to the basic filter responses, more advanced filter responses are also supported within Digital Filter Designer. Any one of the following responses can be specified using Digital Filter Designer. The following table lists the amplitude responses Digital Filter Designer currently supports for FIR and IIR filters.
Table 4-1. Supported Amplitude Responses by Filter Type.

<table>
<thead>
<tr>
<th>Amplitude Response</th>
<th>FIR Filter</th>
<th>IIR Filter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lowpass</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Highpass</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Bandpass</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Bandstop</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Multipass</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Multistop</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Differentiator</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Hilbert Transformer</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Raised Cosine</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Root Raised Cosine</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Gaussian</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Edge</td>
<td>•</td>
<td></td>
</tr>
</tbody>
</table>

**Lowpass**

A lowpass frequency response can be achieved with either an FIR or an IIR filter. A lowpass filter is made up of a passband and a stopband, where the lower frequencies of the input signal are passed through while the higher frequencies are attenuated. An idealized lowpass filter frequency response has the following shape.

![Lowpass Filter Frequency Response](image)

**Highpass**

A highpass frequency response can be achieved with either an FIR or an IIR filter. A highpass filter is made up of a stopband and a passband where the lower frequencies are attenuated and the higher frequencies are passed through.
of the input signal are attenuated while the higher frequencies are passed. An idealized highpass filter frequency response has the following shape.

![Highpass Filter Frequency Response](image)

**Bandpass**

A bandpass frequency response can be achieved with either an FIR or an IIR filter. A bandpass filter is made up of two stopbands and one passband so that the lower and higher frequencies of the input signal are attenuated while the intervening frequencies are passed. An idealized bandpass filter frequency response has the following shape.

![Bandpass Filter Frequency Response](image)

**Bandstop**

A bandstop frequency response can be achieved with either an FIR or an IIR filter. A bandstop filter is made up of two passbands and one stopband so that the lower and higher frequencies of the input signal are passed while the intervening frequencies are attenuated. An idealized bandstop filter frequency response has the following shape.

![Bandstop Filter Frequency Response](image)
**Multipass**

A multipass frequency response can be achieved with either an FIR or an IIR filter. A multipass filter begins with a stopband followed by more than one passband. By default, a multipass filter in Digital Filter Designer consists of three passbands and four stopbands. The frequencies of the input signal at the stopbands are attenuated while those at the passbands are passed. An idealized multipass filter frequency response has the following shape.

![Multipass Frequency Response Diagram](image1)

**Multistop**

A multistop frequency response can be achieved with either an FIR or an IIR filter. A multistop filter begins with a passband followed by more than one stopband. By default, a multistop filter in Digital Filter Designer consists of three passbands and two stopbands. The frequencies of the input signal at the passbands are passed while those at the stopbands are attenuated. An idealized multistop filter frequency response has the following shape.

![Multistop Frequency Response Diagram](image2)

**Differentiator**

A differentiator frequency response can be achieved only with an FIR filter. An ideal differentiator provides a purely imaginary, linear response across the entire

---

Choosing a Frequency Response 4-7
Designing a Digital Filter

spectrum with a slope of \( j2\pi f/T \). An idealized differentiator filter frequency response has the following shape.

\[ \begin{align*}
\text{Hilbert Transformer} \\
\text{A Hilbert transformer frequency response can be achieved only from an FIR filter. An ideal Hilbert transformer filter provides a purely imaginary constant linear response across the entire spectrum.}
\end{align*} \]

\[ \begin{align*}
\text{Raised Cosine} \\
\text{A raised cosine frequency response can be achieved only from an FIR filter. A raised cosine filter provides a flat passband with a roll-off that has a sinusoidal form. This type of a filter is typically used in the design of pulse-amplitude modulation (PAM) digital communication systems. When used within such a system, it achieves a minimum probability of error by reducing the combined effects of intersymbol interference and noise.}
\end{align*} \]
Root Raised Cosine

A root raised cosine frequency response can be achieved only from an FIR filter. Typically, two root raised cosine filters are used together within a pulse-amplitude modulation (PAM) digital communication system, one in the transmitter and other in the receiver. When combined in this manner, they achieve the raised cosine characteristics.

Gaussian and Edge

Gaussian and Edge frequency responses can also be achieved for an FIR filter using AEL functions to generate their ideal coefficients. For details on generating these frequency responses, refer to “Importing an Ideal Coefficients Function” on page 2-9. For details on using AEL to create functions that generate ideal coefficients for these frequency responses, refer to the “Manipulating Arrays” on page 7-1.

Note: An AEL template that can be customized is included with the current installation of Digital Filter Designer in $HPEESOF_DIR/dfilter/ function. You can modify this template to design symmetric FIR filters according to GSM specifications using the desired rolloff, symbol period, and tolerable order values. For details on using an AEL functions file to generate filter coefficients, refer to “Importing an Ideal Coefficients Function” on page 2-9.

Choosing a Design Method

Digital Filter Designer’s filter design methods include the classic algorithms for FIR and IIR filter design. Each method offers its own way of approximating the desired response, where, depending upon the purpose of the filter, one method may be better suited for a particular design.

FIR

The techniques for designing FIR filters are based on directly approximating the desired frequency response of the discrete-time system. For an FIR filter, Equiripple and Least Squares are among the most flexible methods. In addition, numerous windowing methods that truncate the ideal impulse response using a finite-length
window are also available. The simplicity of windowing makes it an attractive alternative to the other more complicated optimizations.

- To choose the design method for an FIR filter design within Digital Filter Designer, click the desired option to choose it.

![Choose Design Method]

**Equiripple**

The Equiripple method approaches filter design as an optimization problem in which the coefficient values are adjusted to create an optimal filter with ripples that are of equal height. This method uses the most efficient optimization procedure to minimize the transition width along with the stopband and passband ripple.

**Hint** Modify the filter order if an optimization ever fails to converge. Although rare, such a situation may occur occasionally in the design of a high-order filter.

The Equiripple method uses the Parks-McClellan algorithm to compute the filter such that its response \( H(e^{j2\pi f}) \) represents the best approximation to the ideal frequency response \( H_d(j2\pi f) \) in a manner that minimizes the maximum weighted approximation error (where \( Q() \) is the weighting function):

\[
\varepsilon(j2\pi f) = \max_{f \in [-0.5, 0.5]} [Q(j2\pi f)[H_d(j2\pi f) - H(e^{j2\pi f})]]
\]
Note Specify a weighting function for the Least Squares method (and for the
Equiripple method when the Auto Order feature is not used) to assign an appropriate
relative cost for the deviation from a desired response. Frequency regions where more
accurate approximations are required need larger weighting values than the less
critical regions. A zero weighting is typically specified in the transitional frequency
band between a passband and a stopband.

Least Squares

The Least Squares method computes the filter such that its response $H(e^{j2\pi f})$
represents the best approximation to the ideal frequency response $H_d(j2\pi f)$ in a
weighted least-squares sense (where $Q()$ is the weighting function):

$$\varepsilon^2 = \int_{-0.5}^{0.5} |H_d(j2\pi f) - H(e^{j2\pi f})|^2 Q(j2\pi f) df$$

Windowing

Windowing is the quickest method for designing an FIR filter. It begins with an ideal
desired frequency response that can be expressed in terms of the corresponding
impulse response. A windowing function simply truncates the ideal impulse response
to obtain a causal FIR approximation that is noncausal and infinitely long. Smoother
window functions provide higher out-of-band rejection in the filter response. However
this smoothness comes at the cost of wider stopband transitions.

Selecting the appropriate windowing method for a particular application involves
weighing trade-offs between ripple and transition width to achieve acceptable
results. For the most part, a good windowing method attempts to minimize the width
of the main lobe (peak) of the frequency response. In addition, it attempts to
minimize the side lobes (ripple) of the frequency response. Some of the windowing
methods can be used to make this trade-off by adjusting their windowing parameter.

Rectangular This is the most basic of windowing methods. It does not require any
operations because its values are either 1 or 0. It creates an abrupt discontinuity that
results in sharp roll-offs but large ripples.
Designing a Digital Filter

The Rectangular windowing method is defined by the following equation:

\[
  w[n] = \begin{cases} 
    1, & (0 \leq n \leq N) \\
    0, & \text{otherwise} 
  \end{cases}
\]

**Rectangular**

This is the simplest windowing method that exhibits a nonnegative transform. The computational simplicity of this window, a simple convolution of two rectangle windows, and the lower sidelobes make it a viable alternative to the rectangular window.

The Triangular windowing method is defined by the following equation:

\[
  w[n] = \begin{cases} 
    \frac{2n}{N}(0 \leq n \leq \frac{N}{2}) \\
    2 - \frac{2n}{N}, & (\frac{N}{2} < n \leq N) \\
    0, & \text{otherwise} 
  \end{cases}
\]

**Triangular**

This is the simplest windowing method that exhibits a nonnegative transform. The computational simplicity of this window, a simple convolution of two rectangle windows, and the lower sidelobes make it a viable alternative to the rectangular window.

**Kaiser**

This windowing method is designed to generate a sharp central peak. Although it is computationally involved, its coefficients are easy to generate largely
as a result of helpful design rules that eliminate iterations typically needed to achieve desired ripple and transition specifications.

The Kaiser windowing method is defined by the following equation using the windowing parameter, $\alpha$:

$$w[n] = \frac{\text{bessel}[\alpha, \frac{2n}{N-1}\left(2 - \frac{2n}{N-1}\right)]}{\text{bessel}[\alpha]}$$


**Hamming** This windowing method generates a moderately sharp central peak. Its ability to generate a maximally flat response makes it convenient for speech processing filtering.

The Hamming windowing method is defined by the following equation using the windowing parameter, $\alpha$:

$$w[n] = \alpha - (1 - \alpha) \cos\left[\frac{(2n+1)\pi}{N}\right]$$
Designing a Digital Filter

**Hanning**  This windowing method generates maximally flat filter designs as well. Its other advantages are an easy to generate set of coefficients and easily identified properties of the transform of the cosine function.

The Hanning windowing method is defined by the following equation using the windowing parameter, \( \alpha \):

\[
    w[n] = \alpha - (1 - \alpha) \cos \left( \frac{(2n + 1) \Pi}{N} \right)
\]

**Dolph Chebyshev**  This windowing method provides good sidelobe rejection but its sidelobe structure displays extreme sensitivity to coefficient errors. It is optimal for most instances that don't use a fixed-point implementation.

**Note**  For details on the equations used by the Dolph Chebyshev windowing function, refer to “Digital Signal Processing” by Roberts & Mullis. pp 225-228.

**Blackman**  This windowing method provides good sidelobe rejection although it results in a broad central peak.

The Blackman windowing method is defined by the following equation:

\[
    w[n] = 0.42 - 0.5 \cos \left( \frac{(2n + 1) \Pi}{N} \right) + 0.08 \cos 2\Pi \left( \frac{2n + 1}{N} \right)
\]
IIR

IIR filter design is based on transformations of continuous-time IIR systems into discrete-time IIR systems. For an IIR filter type, Butterworth and Chebyshev are among the better known design methods. In addition to the auto-selection option that picks the most suitable method automatically, the Elliptic method is also available.

- To choose the design method for an IIR filter design within the Digital Filter Designer, click the desired option to choose it.

Auto Selection

Choose this option to pick the most appropriate method automatically. This option evaluates the filter design using each of the available methods and picks the method that results in a filter with the smallest order. Typically this choice is used to obtain the most economical filter design that may be further refined using a different method, if desired.

Chebyshev I

The Chebyshev method of approximation provides an equiripple performance in the passband and it varies monotonically in the stopband. Although an increase in the filter order increases the number of passband ripples, it also leads to better stopband performance. In addition, the good magnitude characteristics of this method come at the cost of phase characteristics that depart considerably from the ideal linear-phase.
Designing a Digital Filter

An nth order Chebyshev I lowpass filter with cutoff frequency $f_c$ is specified using the following equation:

$$A_n(f^2) = \frac{1}{1 + \varepsilon^2 V_n^2(f/f_c)}$$

**Chebyshev II**

The Chebyshev II or Inverse Chebyshev method of approximation provides an equiripple performance in the stopband and it is monotonic in the passband. Although an increase in the filter order increases the number of stopband ripples, it also leads to better passband performance because it yields the smallest delay in the passband. In addition, the Chebyshev II method provides good phase and delay response by providing the widest region of the passband over which the group delay is constant.

An nth order Chebyshev II lowpass filter with cutoff frequency $f_c$ is specified using the following equation:

$$A_n(f^2) = \frac{\varepsilon^2 V_n^2(f/f_c)}{1 + \varepsilon^2 V_n^2(f/f_c)}$$

**Butterworth**

The Butterworth method of approximation provides a monotonic performance in the passband and the stopband. As the filter order is increased, the passband and stopband performance improves, with the transition from passband to stopband becoming sharper. The Butterworth method is best suited for design problems that focus on controlling passband and stopband ripple.

---

4-16  Choosing a Design Method
An nth order Butterworth lowpass filter with cutoff frequency \( f_c \) is specified using the following equation:

\[
A_n(f^2) = \frac{1}{1 + \left( \frac{f}{f_c} \right)^{2n}}
\]

**Elliptic**

The Elliptic method of approximation provides an equiripple response in both the passband and the stopband. This method uses the smallest filter order for a transition from passband to stopband, but it does so at the cost of some ripple in both bands. As a result, when phase linearity is not an issue, the elliptic method results in a filter with the lowest-order and therefore the least computation overhead.

An Elliptic filter is based on a mapping of the following function:

\[
T^2(\omega) = \frac{1}{1 + \epsilon^2 \text{sn}^2(w, k)}
\]
Defining the Filter Order

The most apparent measure of the complexity of a filter is its order. The order refers to the order of the filter’s system function. Within Digital Filter Designer, the design process can be driven either by the filter order or by the filter specifications. That is, given the ripple specifications, the minimum filter order can be calculated automatically in all cases except the Least Squares method. On the other hand, given a filter order constraint, the filter coefficients can also be generated without constraining the ripple.

- To manually define the order for a filter design within Digital Filter Designer, click **Auto Order** to deselect it and then enter the desired order in the Order Number field. Keep in mind that for an N-tap FIR filter the filter order will be N-1.

Note: The auto order feature automatically sets the filter order and weighting, in the case of an equiripple FIR filter. In the case of a windowing FIR filter, it sets the filter order and windowing parameter. As a result, when you define an equiripple filter order manually, be sure to also specify the weighting for each band. In the case of a windowing filter, be sure to specify the windowing parameter as well. For details on weighting, refer to “Specifying the Weighting” on page 4-22. For details on the windowing parameter, refer to “Entering a Windowing Parameter” on page 4-29.

Digital Filter Designer may be unable to achieve the desired response using certain window design methods, regardless of the filter order. In such cases, a feedback message is displayed in the Status window to let you know.

Be sure you verify the accuracy of the results obtained using the auto-order feature when designing a filter with a nonlinear passband amplitude, a raised cosine filter for example.
For best results in a filter design with passbands at the Nyquist frequency (frequency = sampling frequency/2) use an odd numbered filter order for an antisymmetric filter, and an even numbered filter order for a symmetric filter. For details on the symmetricity option used in a filter design, refer to “Defining the Symmetricity” on page 4-28.

Choosing the Frequency Unit

Choose a frequency unit for the specifications you enter. The default unit is MHz.

- To use a frequency unit other than the default within Digital Filter Designer, choose the desired option from the Frequency Unit drop-down list.

Note The frequency unit you specify is used for specifications you enter subsequently. To override the default, enter a different unit of measure for any individual specification.

Specifying the Sampling Frequency

Enter the desired sampling frequency. The default frequency is 1 MHz. The sampling frequency you enter is the rate at which the signal is sampled (F_s). The high frequency, F_H, in the last band is automatically changed to F_s/2 to avoid designing a filter that suffers from aliasing distortion.
Designing a Digital Filter

• To modify the sampling frequency, replace the existing value with the desired value in the Sampling Frequency field.

Defining the Response Specifications

Desired response specifications define the parameters for the passbands, stopbands, and weightbands of a digital filter. Response specifications include the number of bands in the case of a multiband filter, the low and high cutoff frequencies, the amplitude, ripple or attenuation, and phase.

• To define the response specifications within Digital Filter Designer, enter values, as applicable.

Note  When entering the values, keep in mind the default unit of measure. To use a unit of measure other than the default, either change the default unit before entering a value or type in the unit of measure along with the value.
Entering the Number of Bands

The number of bands you enter defines the shape of the filter. Within Digital Filter Designer you can specify the number of passbands, stopbands, and weightbands. These values need to be entered for multipass and multistop filters; they are otherwise automatically set to the appropriate values based upon the specified amplitude response.

Entering Low and High Frequencies

Define the acceptable cutoffs for the passbands, stopbands, and weightbands. Enter the passband cutoff as its High Frequency value, and the stopband cutoff as its Low Frequency value. The region in the middle of the two values defines the transition band.

Note  When you use the Equiripple or frequency-weighted Least Squares method, take care to not use very wide transition bands. Transition bands are treated as “don’t care” regions and are left unconstrained in the attempt to minimize the approximation effort while using the minimum filter order. Consequently, unexpected peaks can occur in wide transition bands.
Designing a Digital Filter

**Entering the Amplitude**
Define the amplitude for the passbands. For details on the format and conventions used for entering the amplitude value, refer to “Selecting the Amplitude Format” on page 4-24 and “Nonsymmetric” on page 4-29.

**Specifying the Ripple**
Define the acceptable deviation in the passbands and rejection (attenuation) in the stopbands. This value is specified in dB.

**Entering the Exponential Amplitudes**
Define the desired exponential amplitude in the passbands. The exponential amplitude response field provides another representation for the desired amplitude response.

The overall desired frequency response will be the product of the response specified in the amplitude and exponential amplitude fields.

\[ H_d(f) = G(f)S(f) \]

The response in the exponential amplitude field corresponds to

\[ S(f) = \alpha_0 e^{j2\pi\beta_0} + \alpha_1 e^{j2\pi\beta_1} + \ldots \]

These values are entered in the exponential amplitude field as

\[ \alpha_0, \beta_0, \alpha_1, \beta_1, \alpha_2, \beta_2 \]

For information on how to control the exponential amplitude specification of the filter design, refer to “Nonsymmetric” on page 4-29.

**Specifying the Weighting**
Weighting is an available option when the Equiripple or frequency-weighted Least Squares method is used to design an FIR filter. The approximation to the desired frequency response can be weighted using one or more weightbands, each with its own low and high frequency and magnitude specifications. The magnitude values you
specify are relative. That is, a magnitude value of 1 is ten times greater than a magnitude value of 0.1.

**Hint**  For numeric simplicity, scale the weightband magnitude to the range 0 to 1.0 when using the Equiripple method.

- To define the weighting specifications within Digital Filter Designer, enter the frequency and magnitude values. For details on the format and conventions used for entering the magnitude value, refer to “Selecting the Magnitude Format” on page 4-24.

The weighting function assigns an appropriate relative cost for the deviation from a desired response. Frequency regions where more accurate approximations are required need larger weighting values than the less critical regions. A zero weighting is typically specified in the transitional frequency band between a passband and a stopband.

Specification of these bands is not required. However, regions that are not weighted are automatically assumed to have zero weighting.

**Note**  The response in weighted regions can be improved by not weighting the response in regions where the response is not important. However, when an unweighted region becomes very wide, unexpected peaks may result.
Copying the Response Specifications

Click **Copy Desired Bands** to use the stopband and passband frequency specifications of the desired response for the weightbands as well. This feature provides a useful reminder of the passband edges specified in the Desired Response tab. As a result, you may wish to add more weightbands subsequently to weight the stopbands.

Selecting the Magnitude Format

For the case of weighting specifications, only magnitudes are considered. Therefore, all values in the magnitude column should be real values. Also, unlike the desired response, there is no exponential amplitude specification for the weighting response.

Selecting the Amplitude Format

The amplitude format used depends upon the desired shape of the passbands or weightbands. In both formats, the amplitude is essentially represented by a polynomial of some degree, zero or greater.

Digital Filter Designer automatically computes the actual inverse Fourier transform for the piecewise polynomial magnitude representation to provide superior optimization accuracy when compared to approximations that use FFTs.

- To define the amplitude format the desired response, select the desired format.

Polynomial

This is the recommended default for most designs. This format is able to express both linear and non-linear polynomial response shapes. The overall desired frequency
response will be the product of the response specified in the amplitude and phase fields.

\[ H_d(f) = G(f)S(f) \]

Given a band in the range \( f_{Li} \leq f \leq f_{Hi} \), the desired complex amplitude shape given values \( a, b, c, d \) is defined by the equation:

\[ G(f) = a + b(f - f_L) + c(f - f_L)^2 + d(f - f_L)^3 \]

In addition, the polynomial format is best able to express a linear shape with a constant or zero slope. That is, this format is also the most convenient for expressing the complex amplitude given by a single value, \( a \).

Within Digital Filter Designer, multiple polynomial values for a given complex amplitude are separated by commas, as follows: 2.5, 0.03125 or 0.5, 0, 1.5625e-5 where \( a=2.5, b=0.03125 \) or \( a=0.5, b=0.0, c=1.5625e-5 \), respectively.

**Linear**

This format is best able to express a first degree polynomial shape, that is a non-constant linear response using the two band-edge complex amplitude values. In such situations, it is a more convenient format for expressing complex amplitude values \( a, b \). Within Digital Filter Designer, linear values are separated by commas, as follows: 0.5, 0.8 or 2, 2.5.

Given a band in the range \( f_{Li} \leq f \leq f_{Hi} \), the linear format for a complex amplitude that is expressed by two values \( a \) and \( b \) so that \( H(f_L) = a \) and \( H(f_H) = b \) is best defined using the Linear complex amplitude format.

**Note** For example, the following passband shape is obtained by using amplitude values of 0.5 and 0.8 with the Linear format. To obtain the same passband shape using the Polynomial format would require that the amplitude values be specified as 0.5 and 1.5e-6.
Choosing the Filter Transform

A filter transform maps the filter's poles and zeros in the s plane to the z plane to convert the analog filter into an acceptable digital IIR filter.

- To select the transform used for an IIR filter design within Digital Filter Designer, click the desired option within the Other Parameters tab.

<table>
<thead>
<tr>
<th>Desired Response</th>
<th>Weighting Function</th>
<th>Other Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Filter Transform</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Bilinear Z Transform

This transform avoids the problem of aliasing by using an algebraic transformation between the variables s and z that map the \(j\omega\) axis in the s plane to one revolution of the unit circle in the z plane. However, neither the impulse response nor the phase response of the analog filter are preserved in the digital filter that is obtained.

The mapping of the continuous-time system to the discrete-time system is accomplished using the following equation:

\[ s = \frac{2}{T} \frac{z - 1}{z + 1} \]
**Impulse Invariant**

This transform is a method for obtaining a discrete-time system whose frequency response is determined by the frequency response of a continuous-time system. Because the impulse invariance relationship between continuous-time and discrete-time frequency is linear, the shape of the frequency response is preserved, except for aliasing effects. Filters with high frequency passband are not designed using this transform because of the threat of aliasing.

The system function for the discrete-time system is expressed by the following equation where:

\[
H_D(z) = \sum_{i=1}^{N} \frac{C_i z + e^{p_i T}}{z - e^{p_i T}}
\]

**Choosing the Compensation**

Use Compensation when filtering a discrete-time signal prior to a D/A conversion. Compensation takes into account any attenuation that occurs due to a zero-order hold operation. It is used only when designing an FIR filter.

- To select the compensation used for an FIR filter design within Digital Filter Designer, click the desired option within the Other Parameters tab.

<table>
<thead>
<tr>
<th>Desired Response</th>
<th>Weighting Function</th>
<th>Other Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **Transformation:**
  - Linear, Z
  - Impulse Invariant

- **Compensation:**
  - Sinc
  - Unity

- **Symmetry:**
  - Symmetric
  - Anti-symmetric
  - Non-symmetric
Defining the Symmetricity

Symmetry is used only when designing an FIR filter. One of the reasons that the FIR filter is popular is the ease in which linear phase frequency responses can be achieved. Specifically, a linear phase response is obtained if the resulting unit pulse response is either symmetric or antisymmetric.

- To select the symmetricity used for an FIR filter design within Digital Filter Designer, click the desired option within the Other Parameters tab.

### Symmetric

This is the default option for most designs. Selecting this option results in an FIR filter design with a symmetric unit pulse phase response of $h_n = h_{n-N}$

### Antisymmetric

An antisymmetric sequence is used to design FIR filters with a purely imaginary frequency response (such as Differentiators and Hilbert Transformers). Selecting this option will result in an antisymmetric unit pulse response of $h_n = -h_{N-n}$
An antisymmetric design is not generally used for a filter with passbands starting at DC (frequency = 0 Hz) because of the poor response characteristics that result from the basic Fourier transform properties.

**Note** For best results in a filter design with passbands at the Nyquist frequency (frequency = sampling frequency/2) use an odd number for an antisymmetric filter with a manually specified order, and an even number for a symmetric filter with a manually specified order. For details on the filter order used in a filter design, refer to “Defining the Filter Order” on page 4-18.

**Nonsymmetric**

The Digital Filter Designer allows the user to control the phase by specifying a complex amplitude response if a nonlinear phase response is desired. In this case, the Nonsymmetric option must be chosen to withdraw the design constraint on symmetry. This is useful in applications that require phase compensation or low system delay.

**Entering a Windowing Parameter**

Enter a value for the windowing parameter, $\alpha$. The value you enter as the windowing parameter is used in the equation for the windowing method you selected.

- To enter the windowing parameter for a windowed FIR filter design within Digital Filter Designer, enter the desired value within the Other Parameters tab.
Designing a Digital Filter

- The Kaiser window method uses a default value of $\alpha = 10.0$ if the windowing parameter value equals 0.
- The Hamming window method uses a default value of $\alpha = 0.54$ if the windowing parameter value equals 0.
- The Hanning window method uses a default value of $\alpha = 0.5$ if the windowing parameter value equals 0.
- The Dolph Chebyshev window method uses a default value of $\alpha = 0.5$ if the windowing parameter value equals 0.

For details on using a windowing method refer to “Windowing” on page 4-11.

**Raised Cosine Parameters**

Response parameters specific to Raised Cosine and Root Raised Cosine filters are specified in a separate dialog box within the Digital Filter Designer.

- Select **Raised Cosine** or **Root Raised Cosine** from the Response Type list to open the Root/Raised Cosine Parameters dialog box.

![Computing Desired [Root] Raised Cosine Parameters](image)

You can enter the desired [Root] Raised Cosine filter parameters in the dialog box and click **Next** to compute the desired specification values.

The **Finish Computing Desired [Root] Raised Cosine** dialog box appears. The application automatically selects the appropriate amplitude, frequency, ripple,
and exponential amplitude values based on the entries made by the user. The user can change the automatic selections by clicking Back, manually editing the field entries, and clicking Next.

If you are satisfied with the computed desired values, click the Finish button to dismiss the dialog box. Once the Finish Computing Desired [Root] Raised Cosine dialog box has been dismissed, it can be reopened by clicking the Root/Raised Cosine icon on the top toolbar.

Symbol Rate
Enter a value to specify the symbol rate in Hz.

Roll Off
Enter a value to specify the desired roll-off or width of the transition from a passband to a stopband. The acceptable range for the roll-off value, \( \alpha \), is \( 0 \leq \alpha \leq 1 \). \( \alpha = 0 \) leads to a zero-width transition band, while \( \alpha = 1 \) leads to a transition band width that is equal to the symbol rate.

Passband Ripple
Enter a value to specify the acceptable ripple in the passband.

Stopband Ripple
Enter a value to specify the acceptable ripple or attenuation in the stopband.

Designing a Digital Filter
Chapter 5: Implementing a Digital Filter

This chapter describes the steps involved in implementing a digital filter design using Digital Filter Designer. It also includes reference and background information on the available options in the three broad implementation areas: structure, scaling, and quantization.

The implementation structure determines the realized structure of a filter, the scaling determines the numeric precision used to represent the coefficients, and the quantization option determines the relative importance of overflow and quantization.

By default Digital Filter Designer generates both ideal and scaled coefficients for a filter that you design. It also offers you the option of disabling the implementation options to speed up the filter design process. You should consider disabling the implementation options when your goal is to generate ideal coefficients only, using the full IEEE double precision or machine-defined standard without any number rounding or saturation.

You can disable the implementation options by choosing Options > Disable/Enable Conversion from the Digital Filter Designer menubar.

The three broad implementation options for a digital filter design using Digital Filter Designer are as follows.
Implementing a Digital Filter

**Choosing an Implementation Structure**

Choose the desired structure to implement the digital filter you have designed. Depending upon the filter response type, one or more of the implementation structure options may not be available. The implementation structures are supported for FIR filters while a range of Cascaded second order structures are supported for IIR filters. The implementation structure you choose is used to generate a schematic within Advanced Design System. Implementation only affects the schematic that is generated, and has no effect on the coefficients or the analysis data.

**FIR Filter**

To specify the structure for the fixed-point implementation of an FIR filter, choose the desired option from the Implementation Structure list.

![Choose FIR Implementation Structure](image)

**Note** Different implementation structures are used to minimize quantization effects that occur as a result of coefficient scaling with the use of a fixed-point numeric format and finite-precision arithmetic. When you use the ideal floating-point numeric format, the schematic generated remains constant for all implementation structures. The following “ideal” structure is used to implement a floating-point design for an FIR filter.

---

5-2 Choosing an Implementation Structure
Direct

The Direct structure is typically used to implement the simplest form of a fixed-point FIR filter. This structure allows highly parallel architecture because all the additions and coefficient multiplications can be done simultaneously. The final addition can be performed either with a single, multiple-input adder or with parallel adders. In this structure, the past N input samples are directly accessible from their respective delay blocks.

Direct Transpose

In the Direct Transpose structure inputs are multiplied by each filter coefficient before being delayed. As a result multiplications can be avoided in filters that contain duplicate coefficients. For example, the Direct Transpose structure can implement a symmetric, fixed-point FIR filter with half as many multipliers as there are coefficients.
Implementing a Digital Filter

**Direct Transpose Symmetric**

The Direct Transpose Symmetric structure is only available for symmetric FIR filters and it takes advantage of the properties of the Direct Transpose structure.

**IIR Filter**

To specify the structure for the fixed-point implementation of an IIR filter, choose the desired option from the Implementation Structure list.
Note Different implementation structures are used to minimize quantization effects that occur as a result of coefficient scaling with the use of a fixed-point numeric format and finite-precision arithmetic. When you use the ideal floating-point numeric format, the schematic generated remains constant for all implementation structures. The following “ideal" structure is used to implement a floating-point design for an IIR filter.

Cascaded 2nd Order
The Cascaded Second Order structure implements a cascaded, fixed-point IIR filter. This structure relates directly to the IIR difference equation.
Implementing a Digital Filter

**Cascaded 2nd Order Transpose**

The Cascaded Second Order Transpose structure reverses the cascaded second order implementation of the poles and zeros in the fixed-point IIR filter.

![Cascaded Second Order Transpose Diagram](image)

**Direct II Cascaded Second Order**

The Direct II Cascaded Second Order structure implements a design with the minimum number of delays and multiplications in the fixed-point IIR filter.

![Direct II Cascaded Second Order Diagram](image)
Direct II Transpose Cascaded Second Order

The Direct II Transpose Cascade Second Order structure reverses the Direct II implementation of the poles and zeros. This is typically done when the IIR filter is implemented on a fixed-point processor or in the presence of noise.

Selecting the Numeric Format

Select the numeric format based upon the purpose, and resources available for the implementation, of a filter design. Any change in the numeric format causes the filter response to deviate from the ideal.

Keep in mind that any change in the numeric format or bit width affects the performance of the filter. Be sure to check that the filter performance is acceptable after any changes to these specifications. Within Digital Filter Designer, an ideal filter analysis is always presented to enable you to compare the deviation between what is theoretically possible and what is physically realized, based upon your implementation criteria. This ideal analysis is based upon the full IEEE double precision or machine-standard definition.

In a schematic generated for a scaled filter design, you can use the global parameters component (VarEqn) to change design parameters and propagate the change across the entire design rather than manually editing the parameters for each component.
Implementing a Digital Filter

**Hint** If your goal is to generate ideal coefficients only (using the full IEEE double precision or machine-defined standard without any number rounding or saturation), you can disable the implementation or conversion options by choosing **Options > Disable/Enable Conversion** from the Digital Filter Designer menubar.

When the floating-point format option is selected, it scales to the IEEE single precision definition to achieve a word length of 23 with a fractional length of 8.
The fixed-point format with a bitwidth of \( n \) uses 1 bit to represent the sign bit and \( n-1 \) bits to represent the fractional coefficients.
To select an numeric format, click the desired format option.

**Note** A scaled floating-point or single precision schematic can't be generated if the simulator does not provide the library support for the required components.

**Specifying the Bit Width**

Specify the coefficient precision or bit width when implementing a filter design using the fixed-point numeric format. Keep in mind that a fixed-point format with a bitwidth of \( n \) uses 1 bit to represent the sign bit and \( n-1 \) bits to represent the fractional coefficients.
To modify the bit width, replace the existing value with the desired value in the Bitwidth field.

```
Coefficient Precision

<table>
<thead>
<tr>
<th>Numeric Format</th>
<th>Bitwidth</th>
</tr>
</thead>
<tbody>
<tr>
<td>Floating_point</td>
<td>32</td>
</tr>
<tr>
<td>Fixed_point</td>
<td></td>
</tr>
</tbody>
</table>

Norm Criterion

- L_infinity
- Fractional
- L_1
```

**Selecting the Norm**

Select a norm based upon the quantization criterion you wish to emphasize in the implementation of the filter design.

To select the norm, click the desired option.

**L Infinity**

Use this option to prevent overflow at the expense of high quantization noise. This option scales the coefficients so that the maximum magnitude response (for each section in the IIR case) is unity.

**Fractional**

Use this option when no scaling is desired. With this option, only when a coefficient is greater than unity it is scaled just enough to make its largest value fractional.
Implementing a Digital Filter

**L 1**

Use this option to achieve a reasonable compromise while trying to minimize both overflow error and quantization noise. This option scales the coefficients so that the sum of their absolute values is one.

**Note** An IIR filter may exhibit larger attenuation from unity after scaling. This is especially true for IIR filters that have poles close to the unit circle. Digital Filter Designer attempts to alleviate this effect by implementing the filter sections containing the poles closest to the unit circle at the edge closer to the filter output.
Chapter 6: Analysis and Output

This chapter describes the steps involved in analyzing and generating the output of a digital filter design. It also includes background information on the available options. Digital Filter Designer provides you with a number of analysis and output options from printing specifications to analyzing filter characteristics and generating implementation schematics.

Once a filter is designed, its characteristics are displayed automatically. By default Digital Filter Designer generates both ideal and quantized coefficients for a filter that you design. These coefficients can be displayed in a table then imported into Agilent Ptolemy filter components. You can also generate schematics for further simulation using Advanced Design System or synthesis using DSP Synthesis.

The analysis and output options for a digital filter design using Digital Filter Designer are:

- Print specifications
- Define analysis options
- Display plots
- View coefficients
- Generate a schematic
- Save a filter design file

Printing the Filter Specifications

Digital Filter Designer enables you to print the filter design specifications for future reference and use. Printing the filter specifications can be accomplished using the standard functionality of the Print and Print Setup functions.
Analysis and Output

- To print the currently displayed filter design specifications, choose **File > Print Filter Design** from the Digital Filter Designer menubar.

The printed output lists the filter, parameter, and implementation specifications.
- Filter type: IIR
- Response type: Lowpass
- Method type: Chebyshev I
- Order: Auto order
- Frequency unit: MHz

- To modify the default printing options, choose **File > Print Setup** from the Digital Filter Designer menubar.
Defining the Analysis Options

Use the setup analysis options to define the analyses that are plotted, to define the detail used in the display, and to retain previous data for comparison.

To customize the analysis that is plotted:

1. Choose **Design > Setup Analysis** from the Digital Filter Designer menubar to display the Setup Analysis dialog box.

2. Define the level of detail to be used.

   The detail used in the display is determined by the number of frequency points and by the number of unit pulse response points.

   **Frequency Points**

   Increasing the number of points leads to a corresponding increase in the display detail. The number of frequency points is always rounded and expressed as a power of two.
Analysis and Output

**Number of Unit Pulse Response Points**

Increasing the number of points leads to a corresponding increase in the pulse duration for which the pulse response is computed. This setting is only useful for an IIR filter because the unit pulse response for an FIR filter is always a finite duration.

3. Specify the data to be displayed.

Select one or more of the Compute options as desired. Data for the options you select here is displayed in the graphs that are generated for analysis.

**Frequency Response**

Select this option to plot the frequency response for the filter design.
Unit Pulse Response

Select this option to plot the unit pulse response for the filter design.
Analysis and Output

**Unit Step Response**

Select this option to plot the unit step response for the filter design.
Group Delay

Select this option to plot the group delay response for the filter design. This option is only available for an IIR filter.
Analysis and Output

**Poles/Zeros**
Select this option to plot the poles and zeros for the filter design. This option is only available for an IIR filter.

**Eye Diagram**
Select this option to plot the eye diagram and eye closure for a FIR filter design. Keep in mind that a lower eye closure can be achieved with an even order filter.
4. Plot the specifications.

Select the option to include a plot of the magnitude in the frequency response plot. The magnitude plotted is based on the filter specifications and can be used to visually verify the shape of the filter based upon the specifications you have entered.

5. Keep data for comparison.

Select the option to keep previous data if you wish to retain it for a comparative analysis of different iterations of a design.

Displaying the Analysis Plots

The analysis plots for a filter are displayed automatically in a Data Display window after the filter design process is completed. In addition, analysis plots for a filter that has been designed previously can also be displayed.

- To design a filter and display its analysis plots automatically, choose Design > Design Filter from the Digital Filter Designer menubar. Plots for the specified analyses are displayed in the Data Display window.
To display the analysis plots for a filter that has been designed previously, choose Design > Analyze from the Digital Filter Designer menubar. Plots for the specified analyses are displayed in the Data Display window. By default, analysis plots are displayed for both ideal and scaled coefficients. The ideal coefficients are given in the full IEEE double precision or machine-standard definition while the quantized coefficients are based upon the numeric format you specified, floating-point or fixed-point, and the bit width. To display an analysis of just the ideal coefficients, disable the implementation or conversion options by choosing Options > Disable/Enable Conversion from the Digital Filter Designer menubar.

**Editing an Analysis Plot**

Click a plot to select it and choose Edit > Item Options to display the Plot Traces & Attributes dialog box. Use the Datasets and Equations drop-down list in the dialog...
box to choose the dataset. Click **data** from the list on the left and click **Add** to move it to the list on the right. Digital Filter Designer consistently uses the label “data” for any data that is generated while designing a filter.

Repeat this process to add all the desired data before you click **OK** to close the dialog box and display the plot.

Refer to the online help or printed documentation for details on using the features and functionality available within the Data Display environment.

**Displaying Coefficients**

Coefficients for a filter can be displayed after the design process is completed. In addition, coefficients for a filter that has been designed previously can also be displayed.
Digital Filter Designer generates two sets of coefficients, ideal and scaled, for a filter design.

- The ideal coefficients are based upon the full IEEE double precision or machine-standard definition.
- The scaled coefficients use either a floating-point numeric format or a fixed-point numeric format. The floating-point format quantizes to the IEEE single precision format to achieve a word length of 23 with a fractional length of 8. The fixed-point format with a bitwidth of \( n \) uses 1 bit to represent the sign bit and \( n-1 \) bits to represent the fractional coefficients.

**Hint**  If your goal is to generate ideal coefficients only (using the full IEEE double precision or machine-defined standard without any number rounding or saturation), you can disable the implementation or conversion options by choosing **Options > Disable/Enable Conversion** from the Digital Filter Designer menubar.

Choose **View > Coefficients** from the Digital Filter Designer menubar to display the coefficients generated for the designed filter. A table of the filter coefficients is displayed in the Data Display window.

<table>
<thead>
<tr>
<th>Ind</th>
<th>Ideal_Coeficients...</th>
<th>Scaled_Coeficients...</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0.00932164213620</td>
<td>0.0097365234375</td>
</tr>
<tr>
<td>1</td>
<td>-0.00139902142684</td>
<td>-0.00365623149375</td>
</tr>
<tr>
<td>2</td>
<td>-0.512475504128351</td>
<td>-0.512619616235500</td>
</tr>
<tr>
<td>3</td>
<td>-0.277036197579904</td>
<td>-0.280500631821920</td>
</tr>
<tr>
<td>4</td>
<td>-0.036124909338430</td>
<td>-0.0365960798125</td>
</tr>
<tr>
<td>5</td>
<td>-0.03162896861495</td>
<td>-0.037832037500000</td>
</tr>
<tr>
<td>6</td>
<td>-0.0164360771724</td>
<td>-0.016456603815626</td>
</tr>
<tr>
<td>7</td>
<td>0.027477031207770</td>
<td>0.028686621593750</td>
</tr>
<tr>
<td>8</td>
<td>0.027604560077923</td>
<td>0.034708690835600</td>
</tr>
<tr>
<td>9</td>
<td>0.03765422667275</td>
<td>0.0268787103750</td>
</tr>
<tr>
<td>10</td>
<td>0.012019887369499</td>
<td>0.010131835935750</td>
</tr>
<tr>
<td>11</td>
<td>-0.012768366365672</td>
<td>-0.017852783203125</td>
</tr>
<tr>
<td>12</td>
<td>-0.00085079794978</td>
<td>-0.004961669921875</td>
</tr>
<tr>
<td>13</td>
<td>-0.051650581135394</td>
<td>-0.053549563975000</td>
</tr>
</tbody>
</table>

In the case of an FIR filter, the coefficients are listed in a single column. To scroll through the table of coefficients, click the table to select it and choose the desired option from the **View > Scroll Data** submenu in the Data Display window menubar or click the appropriate button in the Data Display window toolbar.

Refer to the online help or printed documentation for details on using the features and functionality available within the Data Display environment.
The coefficients for an IIR filter in each row correspond to a second-order section and the coefficients are listed as \( b_0, b_1, b_2, a_0, a_1, a_2 \) corresponding to the transfer function of the section as follows:

\[
\frac{b_0 + b_1 z + b_2 z^2}{a_0 + a_1 z + a_2 z^2}
\]

For the scaled coefficients, the pairing logic used follows the rule that pairs the poles closest to the unit circle with the zeros nearest to them. In addition, the sections are ordered using the logic that it is best to keep the sections in a sequence from the least peaked to the most peaked (typically those with poles closest to the unit circle). For more information on the pairing and ordering logic used for IIR filter coefficients, refer to “Digital Filters and Signal Processing” by Leland B. Jackson, pp. 321-323.

### Coefficients

<table>
<thead>
<tr>
<th>nd</th>
<th>Ideal Coefficients, data</th>
<th>Ind</th>
<th>Scaled Coeffic</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1.000</td>
<td>iter=0, row=0</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>2.000</td>
<td>iter=0, row=1</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>1.000</td>
<td>iter=0, row=2</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>0.857</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>-0.600</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>1.000</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Generating a Schematic

When generating a schematic, keep in mind that the topology of the schematic you generate is affected by the implementation options you have selected. For information on the available implementation options, refer to “Choosing an Implementation Structure” on page 5-2 in Chapter 5, Implementing a Digital Filter.

To generate a schematic from your digital filter design:
1. Choose Design > Generate Schematic from the Digital Filter Designer menubar to display the Generate Schematic dialog box.

If you disabled conversions by choosing Options > Disable/Enable Conversion, or if you selected Floating Point as the numeric format while designing the filter, you will be able to generate a schematic for only an Ideal (infinite precision) filter.

Specify the filename to be used for saving the schematic. A scaled floating-point or single precision schematic can't be generated if the simulator does not provide the library support for the required components.

2. Enter the desired specifications in the dialog box and click OK or Apply to generate the schematic.

**Note** Keep in mind that various implementation structures are used to minimize quantization effects that occur as a result of coefficient scaling with the use of a fixed-point numeric format and finite-precision arithmetic. As a result, when you use the ideal floating-point numeric format, the schematic generated remains constant for all implementation structures.

3. The generated schematic is displayed in a new Schematic window within Advanced Design System.
If Advanced Design System is not running, it is launched and then the schematic is displayed in a new Schematic window.

The generated schematic can now be edited or printed on its own. It can also be placed within another schematic, if desired.

**Note**  In a schematic generated for a scaled filter design, a component is added to provide global parameters for the entire filter structure. Use this component to change design parameters such as bit width to propagate the change across the entire design rather than manually editing the parameters for each component.

**Retrieving and Placing Coefficients**

Given an existing filter design, you can generate a schematic from its coefficients directly from within an Advanced Design System Schematic window. To do so, choose **Tools > Digital Filter > Retrieve And Place Current Ideal Coefficient Filter** or **Tools > Digital Filter > Retrieve And Place Current Scaled Coefficient Filter** and use the dialog box that is displayed to specify a filename for the schematic. Using the coefficients you choose
Analysis and Output

to retrieve (ideal or scaled), a new schematic is generated and saved using the filename you specify.

**Saving a Design File**

Choose **File > Save Filter Design** to save changes to an existing filter design file. If you wish to create a new filter design file or save changes to a new file, choose **File > Save As** and use the File Save As dialog box to save the file using the desired filename and location.

If you have computed the ideal and the implementation coefficients for the filter design, separate files containing each set of coefficients are typically saved in the
Saving a Design File 6-17

synthesis subdirectory as ASCII files using the MDIF format. These files are used by Digital Filter Designer to store information on the filter you design. The naming convention used for the .mdb files is <design_name>ideal.mdb and <design_name>scaled.mdb.

In the MDIF file, the coefficients for an FIR filter are listed in a single column whereas those for an IIR filter are listed in six (6) columns where each row corresponds to a second-order section and the coefficients are listed as $a_0, b_1, b_2, a_0, a_1, a_2$ corresponding to the transfer function of the section as follows:

$$\frac{b_0 + b_1 z + b_2 z^2}{a_0 + a_1 z + a_2 z^2}$$

Coefficient data without the header and footer information is also typically saved in the synthesis subdirectory as ASCII files using the .txt extension. Use these text files to add the filter coefficients to a component within Advanced Design System or your application of choice. The naming convention used for the .txt files is <design_name>ideal.txt and <design_name>scaled.txt.

In the text files, the coefficients for an FIR filter are listed in a single column just as in the MDIF file. Coefficients for an IIR filter are listed in six (6) columns where each row corresponds to a second-order section and the coefficients are listed as $a_0, b_1, b_2, a_0, a_1, a_2$ corresponding to the transfer function of the section as follows:

$$\frac{b_0 z^{-2} + b_1 z^{-1} + b_2}{a_0 z^{-2} + a_1 z^{-1} + a_2}$$

This format facilitates the use of this data within Advanced Design System.

**Using Coefficients in Agilent Ptolemy Components**

Ideal filter coefficients that you generate using Digital Filter Designer can be read into Agilent Ptolemy components you place within a schematic.

To use the filter coefficients for a component:

1. Place the component.

   From the Numeric Signal Processing palette, choose the **FIR** or the **BqdCscd** (IIR) component and place it on the schematic.
Analysis and Output

2. Edit the component parameters.

Select the component and then choose Edit > Component > Edit Component Parameters to display the parameters for the component.

Click the Taps parameter and enter the relative or absolute path and filename for the text file containing the coefficients you wish to use. Be sure to enter a left angle bracket (<) before the path and filename.

Click Apply or OK to close the dialog box and use the filter coefficients from the specified file.
Chapter 7: Manipulating Arrays

Use AEL to manipulate arrays when you create AEL functions to generate ideal coefficients for designing custom filters. For details on using AEL, refer to the AEL documentation. For details on importing an AEL function you have created, refer to "Importing an Ideal Coefficients Function" on page 2-9.

Declaring and Initializing Arrays

AEL supports multidimensional arrays using the following conventions.

- Array values are enclosed in curly braces "{ }"
- Array elements are separated by commas "",
- Array elements may be integers, doubles, or complex numbers
- Sequences can be used to initialize an integer or double array
- Matrices (enclosed within brackets "[ ]") can be assigned by separating rows by semicolons ";" and elements within rows by commas ""

Example:

// one dimension (row vectors) decl x = {1+3i, 4-5i, 9+3i, 10i};
x = [1+3i, 4-5i, 9+3i, 10i];
x = {1::10} // x = {1,2,3,4,5,6,7,8,9,10} x = {1::2::.5}
// x = {1,1.5,2}

// column vectors
decl z;
z = {{1},{2},{3}};
z = [1;2;3];

// two dimension (matrix)
decl y;
y = { {1,2}, {3,4}, {5,6}, {7,8} };
y = [ 1,2; 3,4; 5,6; 7,8 ];

// three dimension
decl s;
s = {{0,1;2,3},[4,5;6,7]};
s = {{{0,1},{2,3}},
   {{4,5},(6,7)};
Displaying Arrays

Use the following function to display and print arrays during the debugging process.

\[
\text{identify\_value();}
\]

This function converts the value assigned to a variable (or array) to a string. This value can then be printed using an output function such as `fprintf`.

Example:

```c
decl x = {1+3i, 4-5i, 9+3i, 10i};
fprintf(stdout, "%s\n", identify_value(x));
// this would output "(1+3i, 4-5i, 9+3i, 10i)"

decl y = {{{1,2},{3,4},{5,6},{7,8}}};
fprintf(stdout, "%s\n", identify_value(y));
// this would output "{{1,2},{3,4},{5,6},{7,8}}"
```

Accessing Array Elements

To access elements within an array, specify the array name followed by the indexes enclosed in square brackets `[ ]`.

To access elements of multidimensional arrays:

- The indices may be separated by commas and the whole sequence enclosed in square brackets as follows: `[1,3]`
- Each index may be enclosed in square brackets as follows: `[1][3]`
- An index may be an AEL sequence as follows: `[1::3]`

Example:

```c
// x's 2nd element is modified to a new value x[1] = 10-10i;
// an element in y is printed, the value printed is "4" fprintf(stderr, "%s", identify_value(y[1,1]));

// an element in y is changed from "7" to "50" y[3][0] = 50;
// this loop produces the sum of all elements of x sum = 0;
for ( i=0; i<4; i++)
sum += x[i];
```
Array Operations

Assignments, additions, subtraction, multiplication (which is essentially matrix multiplication), division, and negation are some of the operations that may be performed on a whole array.

Example:

```c
decl x = {1,2,3,4};
// z = {1,2,3,4}
decl z = x;
// x = {1,2,3,4} and z = {5,5}
z = {5,5};
```

Note  Unlike C arrays, when assignments are made in AEL arrays, the receiver of the assignment points to the original array. And when modifications are made to an array, a new array is created so that other variables pointing to that array are not modified.

Addition and Subtraction

When addition or subtraction is executed between whole arrays, the math is executed one element at a time. Therefore, the array bounds must be exactly the same. Element by element multiplication, division, and power are also supported by using the operators \(*\), //, and \(^*\).

Example:

```c
decl x = {1,2,3,4};
decl y = {9,8,7,6};
// z = {10,10,10,10};
decl z = x + y;
x = ( {1,2}, {3,4} );
y = ( {10,9}, {8,7} );
// z = ( {-9,-7}, {-5,-3} );
z = x - y;
// z = (9,16,21,24)
```
Manipulating Arrays

\[ z = x .* y; \]

**Multiplication**

When multiplication is executed between whole arrays, matrix multiplication is executed. Therefore, the arrays must be two dimensional and the array bounds must be compatible for matrix multiplication, which is \( \text{row1} \times \text{col1} \times \text{row2} \times \text{col2} \) where \( \text{col1} \) must equal \( \text{row2} \) and the new array will have the dimensions \( \text{row1} \times \text{col2} \).

**Example:**

\[
x = (\{1,2\}, \{3,4\});
y = (\{10,9\}, \{8,7\});
\]

// z = (\{26,23\}, \{62,55\});

\[ z = x * y; \]

**Note**  The following shorthand notations are supported: +=, -=, *=

**Scalars and Arrays**

Any math operation between an array and scalar values is legal. The result of such expressions is an array.

**Example:**

```plaintext
decl x = (1,2,3,4);
// x = "\{6,7,8,9\}"
x += 5;
// x = "\{32,28,24,22\}"
x = 100 / x * 2;
```

**Transposing Arrays**

Transposition of arrays is supported using the following syntax.

**Example:**

```plaintext
decl x = (1,2,3,4);
// x = (\{(1),(2),(3),(4)\})
```
$y = x'$;

**Note**  Several built-in math functions are also available for operation on arrays. These include functions such as sin, cos, tan, asin, acos, atan, etc. For details on the math functions available within AEL, refer to the “Math Functions” section in the AEL documentation.
Manipulating Arrays
Chapter 8: Command Reference

File Menu

New Filter Design
Create a new file for a filter design.

Open Filter Design...
Open an existing file containing a filter design.

Save Filter Design
Save the active filter design file. In addition to the design file, any coefficients generated for the ideal and scaled filter are also saved at the same location.

Save As...
Save a copy of the active filter design using a different name or location. In addition to the design file, any coefficients generated for the ideal and scaled filter are also saved.

Print Filter Design...
Print the specifications entered for the filter design.

Print Setup...
Specify the printer options for printing the contents of the filter design window.

Import Ideal Coefficients File...
Specify the file containing the coefficients to be imported.

Import Ideal AEL Coefficients Function...
Specify the file containing the AEL function you wish to use to generate the ideal coefficients for import.
Export Ideal Coefficients...
Sends the current filter design from the Digital Filter Designer to an external instrument.

New Project...
Create a new project for your filter design tasks.
Before you create a filter design, you will need to specify the project directory for storing information related to the design.

Open Project...
Open an existing project to work on your filter design tasks.
Before you create a filter design, you will need to specify the project directory for storing information related to the design. Likewise, before you open an existing filter design, you will need to open (or specify) the project to be used for storing information related to the design.

Delete Project...
Specify the project you wish to delete.

Design List...
Display the list of designs.

Exit
Exit Digital Filter Designer.
File history at the bottom of the menu enables you to open any of the last four designs that were opened. This number can be configured with the variable FILE_OPEN_HISTORY_DISP in the dfilter.cfg file.

Design Menu

Design Filter
Design a digital filter, generate filter coefficients, and display an analysis of the design using the specifications you have entered.
Choosing this menu item also launches the Data Display window where the results of the analysis are displayed using the options you specified in the Setup Analysis dialog box. Once the analysis is performed, you can also choose to view the filter coefficients generated from the design specifications.

**Analyze**
Display an analysis of the active filter design.
Use this option to analyze a filter you have designed or to analyze a filter design based upon coefficients that you have imported. This option displays analysis plots using the existing filter design or coefficient information.

**Setup Analysis...**
Specify the analysis options for a filter design.

**Generate Schematic...**
Generate a schematic using the displayed filter design.
When you choose this option, Advanced Design System is launched and a schematic of the filter design is generated in a new Schematic window.

**Options Menu**

**Hot Key/Toolbar Configuration...**
Modify the hot key assignments for the keyboard and the toolbar buttons. “Hot keys” are keyboard sequences you use to initiate commonly performed tasks.

**Command Line...**
Enter or display text commands used to execute tasks in the design of a digital filter.

**Disable/Enable Conversion**
Disable or enable the implementation structure and coefficient precision conversion options.
When conversion is enabled, the ideal filter (using the full IEEE or machine-defined standard) and the scaled filter (floating or fixed point) are designed and analyzed. When conversion is disabled, only the ideal filter design is created.

**View Menu**

**Coefficients**
Display the coefficients generated for the filter design.
Use this option to display the coefficients generated for a filter that you have designed. This option displays the coefficients generated for the existing design.

**Toolbar**
Display or hide the toolbar and its buttons.

**Tools Menu**

**Start Advanced Design System**
Launch Advanced Design System.

**Help Menu**

**What's This?**
Displays context-sensitive help for a menu, command, button, or control that is selected subsequently.

**Topics and Index**
Provides access to a brief list of topics for each product area, as well as access to an index of topics in all product areas.

**Agilent EEsof Web Resources**
Launches the browser (Netscape by default) which enables you to access documentation and other information.
About Digital Filter Designer
Displays version, copyright, and technical support information.
Index

A
amplitude, specifying for passbands, 4-22
amplitude, specifying for weightbands, 4-22
analysis options
defining for design, 6-3
eye Diagram, using, 6-8
frequency points, using, 6-3
frequency response, using, 6-4
group delay response, using, 6-7
plotting specifications, 6-9
poles/zeros, using, 6-8
unit pulse response, using, 6-4, 6-5
unit step response, using, 6-6
analysis plots, displaying, 6-10
analyzing design plots, 2-14
attenuation, specifying for stopbands, 4-22
auto selection method, using, 4-15

B
bandpass filter
defined, 4-6
bands, specifying number of, 4-21
bandstop filter
defined, 4-6
bilinear Z transform, defined, 4-26
bitwidth, specifying for design, 5-9
Blackman windows, 4-14
Butterworth method, using, 4-16

C
cascaded second order implementation structure, 5-5
cascaded second order transpose implementation structure, 5-6
Chebyshev I method, using, 4-15
Chebyshev II method, using, 4-16
coefficients
displaying FIR for analysis, 6-12
displaying IIR for analysis, 6-13
file format, 2-11
format for IIR filter, 6-13
generating from designs, 2-18
importing for design, 2-8
importing functions, 2-10
retrieving from schematic, 6-16
using in Ptolemy, 6-17
command lines, using for design automation, 2-6
compensation
choosing for FIR filters, 4-27
sinc, using, 4-28
unity, using, 4-28

data displays
window contents, 1-7
design files
copying and saving, 6-16
name conventions, 6-17
design methods
auto selection, using, 4-15
Blackman windows, using, 4-14
Butterworth, using, 4-16
Chebyshev I, using, 4-15
Chebyshev II, using, 4-16
choosing for FIR, 4-10
choosing for IIR, 4-15
Dolph Chebyshev windows, using, 4-14
elliptic, using, 4-17
equiripple, using, 4-10
Hamming windows, using, 4-13
Hanning windows, using, 4-14
Kaiser windows, using, 4-13
least squares, using, 4-11
rectangular windows, using, 4-12
triangular windows, using, 4-12
windowing, defined, 4-11
design projects
creating new, 2-3
opening, 2-4
using, 2-3
design specifications, printing for filter, 6-2
designs
analyzing plots, 2-14
copying and saving files, 2-13, 6-16
creating new, 2-5
file naming conventions, 2-13, 6-17
generating coefficients, 2-18
generating schematics, 2-17
importing coefficient functions, 2-10
importing coefficients, 2-8
managing files, 2-5
opening existing, 2-7
desired response, filter settings, 1-5
differentiator filter, defined, 4-8
Digital Filter Designer
copying designs, 2-13, 6-16
creating designs, 2-5
data display window, 1-7
desired response settings, 1-5
file naming conventions, 2-13, 6-17
generating coefficients, 2-18
generating outputs, 2-14
generating schematics, 2-17
importing coefficient functions, 2-10
importing coefficients, 2-8
launching application, 2-2
main window, 1-2
managing designs, 2-5
menus, 1-3
opening designs, 2-7
other parameters settings, 1-6
plotting an analysis, 2-14
printing specifications, 2-14
saving files, 2-13, 6-16
status window, 1-8
toolbar, 1-4
using command lines, 2-6
using online documentation, 1-2, 2-2
using projects, 2-3
weighting function settings, 1-5
direct II cascaded second order implementation structure, 5-6
direct II transpose cascaded second order implementation structure, 5-3
direct transpose implementation structure, 5-3
direct transpose symmetric implementation structure, 5-4
Dolph Chebyshev windows, 4-14

E
Edge filter, generating response, 4-9
equilibrium method, using, 4-10
exponential amplitudes, specifying for passbands, 4-22

F
files
copying and saving designs, 2-13, 6-16
format for ideal coefficients, 2-11
naming conventions, 2-13, 6-17
filter coefficients
file format for ideal, 2-11
generating from designs, 2-18
importing for design, 2-8
importing functions, 2-10
filter order, effects of defining, 4-18
filter response type, choosing, 4-2
filter settings
desired response, 1-5
other parameters, 1-6
weighting function, 1-5
copying designs, 2-13, 6-16
format for ideal coefficients, 2-11
naming conventions, 2-13, 6-17
filter coefficients
file format for ideal, 2-11
generating from designs, 2-18
importing for design, 2-8
importing functions, 2-10
filter order, effects of defining, 4-18
filter response type, choosing, 4-2
filter settings
desired response, 1-5
other parameters, 1-6
weighting function, 1-5
filters
bandpass, defined, 4-6
bandstop, defined, 4-6
designing to GSM specifications, 2-10, 4-9
differentiator, filter defined, 4-8
Edge, generating filter response, 4-9
Gaussian, generating filter response, 4-9
highpass, defined, 4-6
Hilbert Transformer, defined, 4-8
lowpass, defined, 4-5
multipass, defined, 4-7
multistop, defined, 4-7
printing design specifications, 6-2
raised cosine, defined, 4-8
root raised cosine, defined, 4-9
FIR filter
antisymmetric, using, 4-28
Blackman window design method, 4-14
choosing design method, 4-10
choosing the compensation, 4-27
choosing the symmetricity, 4-28
defined, 4-2
direct implementation, 5-3
direct transpose implementation, 5-3
direct transpose symmetric implementation, 5-4
Dolph Chebyshev window design method, 4-14
entering raised cosine parameters, 4-30
entering the windowing parameter, 4-29
<table>
<thead>
<tr>
<th>Term</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>equiripple design method</td>
<td>4-10</td>
</tr>
<tr>
<td>Hamming window design method</td>
<td>4-13</td>
</tr>
<tr>
<td>Hanning window design method</td>
<td>4-14</td>
</tr>
<tr>
<td>ideal implementation</td>
<td>5-2</td>
</tr>
<tr>
<td>Kaiser window design method</td>
<td>4-13</td>
</tr>
<tr>
<td>least squares design method</td>
<td>4-11</td>
</tr>
<tr>
<td>magnitude response options</td>
<td>4-5</td>
</tr>
<tr>
<td>nonsymmetric, using</td>
<td>4-29</td>
</tr>
<tr>
<td>rectangular window design method</td>
<td>4-12</td>
</tr>
<tr>
<td>sinc compensation</td>
<td>4-28</td>
</tr>
<tr>
<td>specifying weighting</td>
<td>4-23</td>
</tr>
<tr>
<td>symmetric, using</td>
<td>4-28</td>
</tr>
<tr>
<td>triangular window design method</td>
<td>4-12</td>
</tr>
<tr>
<td>unity compensation</td>
<td>4-28</td>
</tr>
<tr>
<td>windowing design methods</td>
<td>4-11</td>
</tr>
<tr>
<td>fixed-point format, details of</td>
<td>5-8</td>
</tr>
<tr>
<td>floating-point format, details of</td>
<td>5-8</td>
</tr>
<tr>
<td>fractional, using as norm</td>
<td>5-9</td>
</tr>
<tr>
<td>frequencies, entering values</td>
<td>4-21</td>
</tr>
<tr>
<td>frequency points, using for analysis</td>
<td>6-3</td>
</tr>
<tr>
<td>frequency response, using for analysis</td>
<td>6-4</td>
</tr>
<tr>
<td>frequency unit, effect of choosing</td>
<td>4-19</td>
</tr>
<tr>
<td>G</td>
<td></td>
</tr>
<tr>
<td>Gaussian filter, generating</td>
<td>4-9</td>
</tr>
<tr>
<td>group delay response, using for analysis</td>
<td>6-7</td>
</tr>
<tr>
<td>GSM specifications, creating filters</td>
<td>2-10</td>
</tr>
<tr>
<td></td>
<td>4-9</td>
</tr>
<tr>
<td>H</td>
<td></td>
</tr>
<tr>
<td>Hamming windows</td>
<td>4-13</td>
</tr>
<tr>
<td>Hanning windows</td>
<td>4-14</td>
</tr>
<tr>
<td>highpass filter, defined</td>
<td>4-6</td>
</tr>
<tr>
<td>Hilbert Transformer filter, defined</td>
<td>4-8</td>
</tr>
<tr>
<td>I</td>
<td></td>
</tr>
<tr>
<td>ideal coefficients</td>
<td></td>
</tr>
<tr>
<td>defined</td>
<td>6-12</td>
</tr>
<tr>
<td>file format</td>
<td>2-11</td>
</tr>
<tr>
<td>IIR filter</td>
<td></td>
</tr>
<tr>
<td>auto selection design method</td>
<td>4-15</td>
</tr>
<tr>
<td>bilinear Z transform</td>
<td>4-26</td>
</tr>
<tr>
<td>Butterworth design method</td>
<td>4-16</td>
</tr>
<tr>
<td>cascaded second order implementation</td>
<td>5-5</td>
</tr>
<tr>
<td>cascaded second order transpose</td>
<td>5-6</td>
</tr>
<tr>
<td>Chebyshev I design method</td>
<td>4-15</td>
</tr>
<tr>
<td>Chebyshev II design method</td>
<td>4-16</td>
</tr>
<tr>
<td>choosing a transform</td>
<td>4-26</td>
</tr>
<tr>
<td>choosing design method</td>
<td>4-15</td>
</tr>
<tr>
<td>defined</td>
<td>4-3</td>
</tr>
<tr>
<td>direct II cascaded second order</td>
<td>5-6</td>
</tr>
<tr>
<td>implementation</td>
<td></td>
</tr>
<tr>
<td>direct II transpose cascaded second order</td>
<td></td>
</tr>
<tr>
<td>implementation</td>
<td>5-7</td>
</tr>
<tr>
<td>elliptic design method</td>
<td>4-17</td>
</tr>
<tr>
<td>ideal implementation</td>
<td>5-5</td>
</tr>
<tr>
<td>impulse invariant transform</td>
<td>4-27</td>
</tr>
<tr>
<td>magnitude response options</td>
<td>4-5</td>
</tr>
<tr>
<td>implementation structure</td>
<td></td>
</tr>
<tr>
<td>cascaded second order transpose</td>
<td></td>
</tr>
<tr>
<td>IIR filter</td>
<td>5-6</td>
</tr>
<tr>
<td>direct II transpose cascaded second order</td>
<td></td>
</tr>
<tr>
<td>IIR filter</td>
<td>5-7</td>
</tr>
<tr>
<td>direct transpose symmetric, FIR filter</td>
<td>5-4</td>
</tr>
<tr>
<td>direct transpose, FIR filter</td>
<td>5-3</td>
</tr>
<tr>
<td>direct, FIR filter</td>
<td>5-2</td>
</tr>
<tr>
<td>ideal for FIR filter</td>
<td>5-5</td>
</tr>
<tr>
<td>impulse invariant transform, defined</td>
<td>4-27</td>
</tr>
<tr>
<td>K</td>
<td></td>
</tr>
<tr>
<td>Kaiser windows</td>
<td>4-13</td>
</tr>
<tr>
<td>L</td>
<td></td>
</tr>
<tr>
<td>L 1, using as norm</td>
<td>5-10</td>
</tr>
<tr>
<td>L infinity, using as norm</td>
<td>5-9</td>
</tr>
<tr>
<td>launching Digital Filter Designer</td>
<td>2-2</td>
</tr>
<tr>
<td>least squares method, using</td>
<td>4-11</td>
</tr>
<tr>
<td>linear magnitude format</td>
<td></td>
</tr>
<tr>
<td>defined</td>
<td>4-25</td>
</tr>
<tr>
<td>example of using</td>
<td>4-25</td>
</tr>
<tr>
<td>lowpass filter, defined</td>
<td>4-5</td>
</tr>
<tr>
<td>M</td>
<td></td>
</tr>
<tr>
<td>magnitude format</td>
<td></td>
</tr>
<tr>
<td>linear defined</td>
<td>4-25</td>
</tr>
<tr>
<td>polynomial defined</td>
<td>4-25</td>
</tr>
<tr>
<td>specifying for passbands</td>
<td>4-24</td>
</tr>
</tbody>
</table>
magnitude response
  choosing, 4-4
  options available, 4-5
main window, 1-2
menus
  functionality in Digital Filter Designer, 1-3
  multipass filter, defined, 4-7
  multistop filter, defined, 4-7
N
norm
  fractional, 5-9
  L_1, 5-10
  L_infinity, 5-9
  selecting for design, 5-9
numeric format, selecting for design, 5-8
O
online documentation
  using, 2-2
  using in Digital Filter Designer, 1-2
other parameters, filter settings, 1-6
outputs
  generating coefficients, 2-18
  generating from designs, 2-14
  generating schematics, 2-17
  plotting an analysis, 2-14
  printing specifications, 2-14
P
passband ripple, entering for raised cosine filters, 4-31
passbands
  copying specifications for weightbands, 4-24
  entering cutoff frequencies, 4-21
  specifying amplitude, 4-22
  specifying exponential amplitudes, 4-22
  specifying magnitude format, 4-24
  specifying number of, 4-21
  specifying ripple, 4-22
  specifying ripple for raised cosine filters, 4-31
plots
  displaying for analysis, 6-10
  plotting design analyses, 2-14
poles, using for analysis, 6-8
polynomial magnitude format
  defined, 4-25
  example of using, 4-25
printing
  design specifications, 2-14
projects
  creating new, 2-3
  opening existing, 2-4
  using for design tasks, 2-3
Ptolemy, using filter coefficients, 6-17
R
raised cosine filter, defined, 4-8
raised cosine parameters
  entering for FIR filters, 4-30
  entering passband ripple, 4-31
  entering roll off, 4-31
  entering stopband ripple, 4-31
  entering symbol rate, 4-31
rectangular windows, 4-12
response specifications
  copying for weightbands, 4-24
  defining for filters, 4-20
response type, choosing, 4-2
ripple, specifying for passbands, 4-22
roll off, entering for raised cosine filters, 4-31
root raised cosine filter, defined, 4-9
S
sampling frequency, specifying, 4-20
scaled coefficients, defined, 6-12
schematics
  generating coefficients, 6-16
  generating from design, 6-14
  generating from designs, 2-17
sinc compensation, using, 4-28
specifications, printing for filter design, 6-2
status window
  functionality, 1-8
stopbands
  copying specifications for weightbands, 4-24
  entering cutoff frequencies, 4-21
  specifying attenuation, 4-22
  specifying magnitude format, 4-24
  specifying number of, 4-21
  specifying ripple for raised cosine filters, 4-31
symbol rate, entering for raised cosine filters. 4-31
symmetricity
  antisymmetric filter, using, 4-28
  choosing for FIR filters, 4-28
  nonsymmetric filter, using, 4-29
  symmetric filters, using, 4-28

T
toolbars
  functionality in Digital Filter Designer, 1-4
transform
  bilinear Z transform, 4-26
  choosing for IIR filters, 4-26
  impulse invariant transform, 4-27
triangular windows, 4-12

U
unit pulse response, using for analysis, 6-4, 6-5
unit step response, using for analysis, 6-6
unity compensation, using, 4-28

W
weightbands
  copying response specifications, 4-24
  entering cutoff frequencies, 4-21
  specifying amplitude, 4-22
  specifying magnitude format, 4-24
  specifying number of, 4-21
weighting functions
  filter settings, 1-5
  weighting, specifying for FIR filter, 4-23
windowing
  Blackman window, 4-14
  defined, 4-11
  Dolph Chebyshev window, 4-14
  Hamming window, 4-13
  Hanning window, 4-14
  Kaiser window, 4-13
  rectangular window, 4-12
  triangular window, 4-12
windowing parameter
  entering for FIR filters, 4-29

Z
zeros, using for analysis, 6-8