Advanced Design System 1.5
User’s Guide

February 2001
Notice

The information contained in this document is subject to change without notice.

Agilent Technologies makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Agilent Technologies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Warranty

A copy of the specific warranty terms that apply to this software product is available upon request from your Agilent Technologies representative.

Restricted Rights Legend

Use, duplication or disclosure by the U. S. Government is subject to restrictions as set forth in subparagraph (c) (1) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 for DoD agencies, and subparagraphs (c) (1) and (c) (2) of the Commercial Computer Software Restricted Rights clause at FAR 52.227-19 for other agencies.

Agilent Technologies
395 Page Mill Road
Palo Alto, CA 94304 U.S.A.

Copyright © 2001, Agilent Technologies. All Rights Reserved.

Acknowledgements

Netscape is a U.S. trademark of Netscape Communications Corporation
Contents

1 Program Basics
   Documentation Conventions................................................................. 1-1
   Basic Terminology ............................................................................... 1-2
   Starting the Program ........................................................................... 1-3
      Selecting a Design Type .................................................................. 1-4
   The Design Environment ...................................................................... 1-5
      Working in the Main Window ......................................................... 1-7
      Working in Design Windows ......................................................... 1-8
      Status Message Window .................................................................. 1-16
      Using the Data Display Window ..................................................... 1-19
      Using the File/Instrument Window ............................................... 1-20
   Naming Conventions ........................................................................... 1-20
   Limitations ......................................................................................... 1-23
   Global Node Naming Conventions ...................................................... 1-24
   Using Keyboard Shortcuts and Accelerator Keys ................................. 1-24
   Setting Preferences for Miscellaneous Options .................................. 1-24
   Exiting the Program ........................................................................... 1-26

2 Managing Projects and Designs
   Working in Projects ........................................................................... 2-1
      Creating a Project ........................................................................... 2-1
      Opening a Project ........................................................................... 2-3
      Copying a Project ........................................................................... 2-6
      Deleting a Project ........................................................................... 2-7
      Using an Example Project ............................................................. 2-8
      Creating a Hierarchical Project ...................................................... 2-9
      Archiving a Project ......................................................................... 2-11
      Unarchiving a Project ..................................................................... 2-11
   Importing and Exporting .................................................................... 2-12
      Importing a Design ......................................................................... 2-13
      Exporting a Design ......................................................................... 2-14
   Managing Design Files ....................................................................... 2-15
      Creating a Design File ................................................................. 2-15
      Using a Template ........................................................................... 2-16
      Saving a Design File ....................................................................... 2-17
      Saving All Designs in Memory ...................................................... 2-18
      Opening an Existing Design ......................................................... 2-18
      Copying a Design ........................................................................... 2-20
      Deleting a Design ........................................................................... 2-21
      Clearing a Design from Memory ................................................... 2-21
### 6 Editing Designs

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the Undo Command</td>
<td>6-1</td>
</tr>
<tr>
<td>Deleting Items</td>
<td>6-1</td>
</tr>
<tr>
<td>Editing Component Parameters</td>
<td>6-2</td>
</tr>
<tr>
<td>- Editing Component Parameters On-screen</td>
<td>6-2</td>
</tr>
<tr>
<td>- Editing Component Parameters Through the Dialog Box</td>
<td>6-3</td>
</tr>
<tr>
<td>Breaking Wire Connections Between Components</td>
<td>6-7</td>
</tr>
<tr>
<td>Swapping Components</td>
<td>6-7</td>
</tr>
<tr>
<td>Searching and Replacing References</td>
<td>6-8</td>
</tr>
<tr>
<td>Moving Component Text</td>
<td>6-9</td>
</tr>
<tr>
<td>Changing Component Text Attributes</td>
<td>6-10</td>
</tr>
<tr>
<td>Editing Symbol Pins</td>
<td>6-11</td>
</tr>
<tr>
<td>Selecting and Deselecting Items</td>
<td>6-11</td>
</tr>
<tr>
<td>- Selecting/Deselecting All Items in the Drawing Area</td>
<td>6-11</td>
</tr>
<tr>
<td>- Selecting/Deselecting Items by Name</td>
<td>6-12</td>
</tr>
<tr>
<td>- Selecting/Deselecting With a Selection Window</td>
<td>6-13</td>
</tr>
<tr>
<td>- Using the Vertices Filter</td>
<td>6-14</td>
</tr>
<tr>
<td>Copying and Pasting Items</td>
<td>6-15</td>
</tr>
<tr>
<td>Moving Items</td>
<td>6-19</td>
</tr>
<tr>
<td>Rotating Items</td>
<td>6-22</td>
</tr>
<tr>
<td>- Rotating Items Using the Mouse</td>
<td>6-23</td>
</tr>
<tr>
<td>- Rotating Items Around a Specified Point</td>
<td>6-23</td>
</tr>
<tr>
<td>- Rotating Items in Degrees, Relative to 0,0</td>
<td>6-24</td>
</tr>
<tr>
<td>- Rotating Objects Across a Specified X- or Y-axis</td>
<td>6-25</td>
</tr>
<tr>
<td>- Rotating Objects Using an Absolute Angle</td>
<td>6-26</td>
</tr>
<tr>
<td>Editing Shapes</td>
<td>6-27</td>
</tr>
<tr>
<td>- Converting Circles/Arcs to Simple Polygons</td>
<td>6-27</td>
</tr>
<tr>
<td>- Editing Polygons and Polylines</td>
<td>6-29</td>
</tr>
<tr>
<td>- Adding a New Vertex</td>
<td>6-30</td>
</tr>
<tr>
<td>- Moving a Vertex</td>
<td>6-30</td>
</tr>
<tr>
<td>- Deleting a Vertex</td>
<td>6-30</td>
</tr>
<tr>
<td>- Converting a Vertex to an Arc</td>
<td>6-31</td>
</tr>
<tr>
<td>- Converting a Vertex to a Mitered Edge</td>
<td>6-31</td>
</tr>
<tr>
<td>- Stretching a Wire or an Edge of a Shape</td>
<td>6-32</td>
</tr>
<tr>
<td>- Scaling an Object Using a Scaling Factor</td>
<td>6-34</td>
</tr>
<tr>
<td>- Scaling an Object Relative to the Design Window Units</td>
<td>6-35</td>
</tr>
</tbody>
</table>
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing Existing Text and Text Attributes</td>
<td>6-36</td>
</tr>
<tr>
<td>Forcing Objects Back onto the Grid</td>
<td>6-38</td>
</tr>
<tr>
<td>7 Annotating Designs</td>
<td></td>
</tr>
<tr>
<td>Adding a Drawing Sheet</td>
<td>7-1</td>
</tr>
<tr>
<td>Adding Text</td>
<td>7-2</td>
</tr>
<tr>
<td>Using Variables to Display Design and System Information</td>
<td>7-3</td>
</tr>
<tr>
<td>Drawing Shapes</td>
<td>7-4</td>
</tr>
<tr>
<td>Drawing Shapes Using Specific Coordinates</td>
<td>7-8</td>
</tr>
<tr>
<td>8 Simulating and Viewing Results</td>
<td></td>
</tr>
<tr>
<td>Setting up a Simulation</td>
<td>8-1</td>
</tr>
<tr>
<td>Placing Simulation Control Items in Your Design</td>
<td>8-1</td>
</tr>
<tr>
<td>Specifying a Name for the Simulation Data</td>
<td>8-2</td>
</tr>
<tr>
<td>Simulating</td>
<td>8-6</td>
</tr>
<tr>
<td>Excluding Individual Items from the Simulation</td>
<td>8-6</td>
</tr>
<tr>
<td>Clearing Highlights from Items Causing Simulation Errors</td>
<td>8-7</td>
</tr>
<tr>
<td>Tuning</td>
<td>8-7</td>
</tr>
<tr>
<td>9 Setting Design Environment Preferences</td>
<td></td>
</tr>
<tr>
<td>Specifying Design Entry and Display Preferences</td>
<td>9-2</td>
</tr>
<tr>
<td>Setting Select Options</td>
<td>9-3</td>
</tr>
<tr>
<td>Setting Grid/Snap Options</td>
<td>9-6</td>
</tr>
<tr>
<td>Setting Placement Options</td>
<td>9-9</td>
</tr>
<tr>
<td>Setting Pin/Tee Options</td>
<td>9-11</td>
</tr>
<tr>
<td>Setting Entry/Edit Options</td>
<td>9-12</td>
</tr>
<tr>
<td>Setting Component Text Options (in Advance)</td>
<td>9-15</td>
</tr>
<tr>
<td>Setting Text Options (in Advance)</td>
<td>9-17</td>
</tr>
<tr>
<td>Setting Display Options</td>
<td>9-18</td>
</tr>
<tr>
<td>Setting Units/Scale Options</td>
<td>9-18</td>
</tr>
<tr>
<td>Setting Tuning Options</td>
<td>9-19</td>
</tr>
<tr>
<td>Saving and Reading Preference Files</td>
<td>9-20</td>
</tr>
<tr>
<td>Specifying Layer Definitions</td>
<td>9-21</td>
</tr>
<tr>
<td>Setting Colors and Fill Patterns</td>
<td>9-24</td>
</tr>
<tr>
<td>Setting Shape Display Characteristics Layer-by-Layer</td>
<td>9-25</td>
</tr>
<tr>
<td>Setting Line Style Characteristics Layer-by-Layer</td>
<td>9-25</td>
</tr>
<tr>
<td>Setting the Visibility of Items Layer-by-Layer</td>
<td>9-26</td>
</tr>
<tr>
<td>Setting the Selection Status of Items Layer-by-Layer</td>
<td>9-26</td>
</tr>
<tr>
<td>Setting Layer Characteristics Globally</td>
<td>9-27</td>
</tr>
<tr>
<td>Miscellaneous Layer Editor Features</td>
<td>9-27</td>
</tr>
<tr>
<td>Saving and Reading Layer Files</td>
<td>9-28</td>
</tr>
<tr>
<td>Changing the Current Entry Layer</td>
<td>9-29</td>
</tr>
<tr>
<td>Customizing Keyboard Shortcuts</td>
<td>9-29</td>
</tr>
</tbody>
</table>
10 Working with Symbols
Switching Between Schematic and Symbol Views ................................................... 10-2
Generating a Symbol ................................................................................................ 10-3
Drawing a Custom Symbol ....................................................................................... 10-4
  Drawing Setup .................................................................................................... 10-4
  Drawing the Symbol Body ................................................................................. 10-7
  Adding Pins to Your Symbol ............................................................................. 10-7
Assigning a Symbol to a Schematic ...................................................................... 10-9
Making Symbols Available Globally ....................................................................... 10-10
Modifying Search Paths .......................................................................................... 10-12

11 Printing and Plotting
Printing from UNIX ................................................................................................... 11-2
  Adding a Printer .............................................................................................. 11-3
  Selecting a Printer ........................................................................................... 11-8
  Sending Output to the Printer .......................................................................... 11-9
Creating a Printer-specific Print File ..................................................................... 11-9
Printing to File in a Generic Format ..................................................................... 11-11
Printing from the PC .............................................................................................. 11-12
  Establishing a Print Setup .............................................................................. 11-13
  Basic Printing .................................................................................................. 11-14
  Printing a Scaled Layout .................................................................................. 11-15

12 Using the Text Editor
Starting the Text Editor Program ........................................................................... 12-1
  Command Line Options .................................................................................... 12-2
Text File Management ............................................................................................ 12-3
  Creating a Text File ......................................................................................... 12-3
  Opening an Existing File ................................................................................ 12-3
  Inserting One Text File into Another ........................................................... 12-4
  Saving Text Files ............................................................................................. 12-4
Printing Text Files ................................................................................................. 12-5
Exiting the Text Editor ............................................................................................ 12-5
  Editing Text Files ............................................................................................ 12-5
  Performing Search and Replace Operations .................................................... 12-6
Keyboard Mappings ................................................................................................. 12-8
Chapter 1: Program Basics

The Advanced Design System design environment includes all the tools you need to manage your projects, create and edit schematics, and simulate your designs easily and efficiently. The program basics described here include:

- “Documentation Conventions” on page 1-1
- “Basic Terminology” on page 1-2
- “Starting the Program” on page 1-3
- “The Design Environment” on page 1-5
- “Naming Conventions” on page 1-20
- “Using Keyboard Shortcuts and Accelerator Keys” on page 1-24
- “Setting Preferences for Miscellaneous Options” on page 1-24
- “Exiting the Program” on page 1-26

Note For installation instructions, refer to the Advanced Design System Installation manual for your platform.

Documentation Conventions

To help you locate and interpret information easily, Advanced Design System manuals employ consistent visual cues, a few standard text formats, and some special terminology. Table 1-1 describes the typographic conventions used throughout the manual set.

<table>
<thead>
<tr>
<th>Type style</th>
<th>Used for</th>
</tr>
</thead>
<tbody>
<tr>
<td>italic</td>
<td>Signals a new term; identifies directory names, filenames, and program names; highlights commands used within text.</td>
</tr>
</tbody>
</table>

Table 1-1. Typographic conventions
Basic Terminology

Your familiarity with the terms described in Table 1-2 will make the concepts and procedures presented here easier to understand.

Table 1-2. Basic terminology

<table>
<thead>
<tr>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>To quickly press and release the left mouse button</td>
</tr>
<tr>
<td>Choose</td>
<td>To click a menu or command name</td>
</tr>
<tr>
<td>Directory</td>
<td>A collection of files</td>
</tr>
<tr>
<td>Double-click</td>
<td>To click the mouse button twice in rapid succession</td>
</tr>
<tr>
<td>Drag</td>
<td>To hold down the mouse button while you slide the mouse</td>
</tr>
<tr>
<td>Icon</td>
<td>(1) A picture (on a button) that represents the action that will be carried out or the component that will be chosen when you press that button; (2) the small box on your screen that represents an entire window; (3) a graphic symbol used on the PC to start a program.</td>
</tr>
<tr>
<td>Menu</td>
<td>A collection of related commands.</td>
</tr>
<tr>
<td>Press</td>
<td>To hold a mouse button down, usually combined with dragging, before releasing to complete some action</td>
</tr>
<tr>
<td>Project name</td>
<td>A designation for the location of files or directories on your disk.</td>
</tr>
<tr>
<td>Select</td>
<td>To mark an item by clicking on or near it with a mouse. For example, you might select an item and then choose the Delete command to remove the item from the drawing area.</td>
</tr>
</tbody>
</table>
Starting the Program

To start the program:

- UNIX, from the terminal window type:
  ```
  hpads
  ```

- Windows NT 4.0 and Windows 95, 98, and 2000, from the Start menu choose:
  ```
  Programs > Advanced Design System 1.5 > Advanced Design System
  ```

to bring up the Advanced Design System Main window, which provides access to all features of the Advanced Design System. Alternatively, choose one of the other commands to access these specific features of the Advanced Design System:

<table>
<thead>
<tr>
<th>ADS Tools</th>
<th>Displays a list of ADS tools such as Digital Filter Designer, DSP Synthesis, Library Translator, or LineCalc. Choose the tool you want to launch.</th>
</tr>
</thead>
</table>
| ADS Documentation | Launches the online documentation viewer and displays the primary window for accessing documentation from:  
Disk, if you chose to install it during Setup or  
CD-ROM, with the documentation CD-ROM in place |

| RF Designer | Launches the ADS Main window for use with the RF Designer product (the base ADS product for RF design) |

**Hint** The first time you start the program, a window appears displaying information on new features in this release.
Selecting a Design Type

The first time you launch the application, you are prompted to select which type of components you want loaded on start-up: Analog/RF Only, Digital Signal Processing Only, or Both. Choosing either of the first two categories limits your choice of components, for the current session, to the selected category. Choosing Both allows both types of design work in the same session.

If you select Both (Both, With Default:), you must also specify a default design type. This default design type serves the following purposes: defines the components available by default in a design window and defines the default design type that appears in the New Design dialog box. (This choice only serves as a default and can be changed any time you start a new design (File > New).

Note You can change these options at any time through Options > Advanced Design System Setup in the Main window. When you change these options, you are changing them for the subsequent session and you are prompted to exit the application and restart it to effect the change. The selections remain valid until you explicitly change them again.

When you dismiss the setup dialog box, the Advanced Design System Main window appears.
The Design Environment

The design environment is made up of windows. All operations take place within the framework of windows.

Main window. Contains a title bar with the name of the window (Advanced Design System), a menu bar, and a toolbar for quick access to common operations. In addition it provides a tree-like view of directories, and where applicable, the designs comprising a hierarchical design.

From the Main window you can:

• Create and manage projects and designs
• Set program preferences
• Change toolbar configuration and keyboard shortcuts for the Main window
• Change the type of components loaded on start-up
• Playback macros created through Applications Extension Language (AEL)
• Issue AEL commands
• Launch a text editor
• Open a data display window
• Display all types of files and open as desired through context-sensitive menu
Program Basics

**Design windows.** The Schematic and Layout windows have the same basic appearance: title bar, menu bar, toolbar, palette, prompt panel, and drawing area.

From the Schematic window you can:
- Create and edit schematics
- Create variables and equations
- Simulate and optimize
- Open a data display window
- Generate a layout from the schematic

From the Layout window you can:
- Create and edit layouts
- Generate a schematic from the layout
- Create and edit parameterized artwork macros
- Define design rules and verify the design meets the established rules
- Launch Momentum
- Open a data display window

**Data Display window.** Contains a title bar, a menu bar, a toolbar, a palette, and a graphics area. This window enables you to view and compare simulation data.

**Message/Status window.** Appears whenever a simulator is launched and displays messages about the status of the current process as well as warning messages.

---

**Hint** As you work with multiple windows, you may find it helpful to minimize the Status window to clear additional space on your screen. To quickly restore it to the screen, choose Window > Simulation Status from any program window.
Working in the Main Window

The Main window enables you to create and manage projects. Projects are central to the operation of all the simulators and allow you to organize your related designs.

From the Main window you can:

- Create and manage projects and designs
- Quickly open example projects (File > Example Project)
- Set program preferences
- Change toolbar configuration and keyboard shortcuts
- Change the type of components loaded on start-up
- Playback macros created through Application Extension Language (AEL)
- Issue AEL commands
- Launch the text editor
- Open a data display window
- Display all types of files and open as desired through context-sensitive menu (View > Show All Files). Click right to open different types of files in the appropriate type of window (including a text editor for .ael, .cfg, etc.).

For a detailed discussion of projects, refer to Chapter 2, Managing Projects and Designs.
Working in Design Windows

A design window is where you create and edit all of your designs. You can resize and move these windows in the workspace. You can enlarge one window to fill the entire workspace and you can shrink each window to an icon. The following illustration shows the parts of a design window.

- The **Title bar** displays the window type, design type, filename, and a number identifying which window of that type it is.
- The **Menu bar** displays the menus available in that window.
- The **Toolbar** contains buttons for frequently used commands and for choosing the appropriate orientation for components. The collection of buttons on the toolbar is configurable (Options > Menu/Toolbar Configuration) and can be toggled on and off (View > Toolbar).

When you move your pointer slowly over the buttons on the toolbar, a balloon appears with a label identifying the function of that button. By default, the option that controls the display of this label is turned on. To turn this option off, choose Options > Preferences in the Main window and turn off Balloon Help.
Hint To change the timing for the display of the balloon, set the variable BALLOON_HELP_TIMEOUT in the file de_sim.cfg.

- The Palette List enables you to choose a category of components to place on the Component Palette
- The Component History drop-down list is continuously updated to reflect the components you have placed in your design. It provides a quick method of placing another instance of a component in your design and can be used as a starting point for creating a custom palette.
- The Drawing area is where you create your designs
- The Component Palette contains buttons for placing components
- The Prompt panel provides messages to assist you during the execution of most commands, as well as various pieces of information to assist you in creating a design.
- The Pop-up menu lets you access many common commands with a minimum of mouse movement. You access the pop-up menu by pressing the right mouse button in the drawing area of any design window. The context-sensitive commands appear on the pop-up menu when the pointer is positioned over certain shapes or text and you click right.

Table 1-3 describes the actions of the pop-up menu commands. Not all windows support all of these commands. Most of the commands can be given at any time without interrupting other commands in progress.

Table 1-3. Pop-up menu shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>End Command</td>
<td>Cancels the active command</td>
</tr>
<tr>
<td>Deselect All</td>
<td>Deselects anything in the window that is selected</td>
</tr>
<tr>
<td>Redraw View</td>
<td>Refreshes the screen without affecting window magnification</td>
</tr>
<tr>
<td>View All</td>
<td>Scales the view of your drawing so that all of it fits inside</td>
</tr>
<tr>
<td>Pan View</td>
<td>Moves a point you specify to the center of the window</td>
</tr>
<tr>
<td>Zoom Area</td>
<td>Enables you to define a window of the drawing to fill the</td>
</tr>
<tr>
<td>Zoom In x2</td>
<td>Zoom in by a factor of 2 around a point you specify</td>
</tr>
</tbody>
</table>
Program Basics

Table 1-3. Pop-up menu shortcuts (continued)

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom Out x2</td>
<td>Zoom out by a factor of 2 from a point you specify</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected object(s)</td>
</tr>
<tr>
<td>Arc (clockwise)</td>
<td>Enables you to draw a clockwise arc</td>
</tr>
<tr>
<td>Arc (counterclockwise)</td>
<td>Enables you to draw a counterclockwise arc</td>
</tr>
<tr>
<td>Undo Vertex</td>
<td>Removes the last arc or vertex entered</td>
</tr>
</tbody>
</table>

**Context-sensitive commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Polygon Layer</td>
<td>Enables you to select a different layer for the polygon</td>
</tr>
<tr>
<td>Polyline Layer</td>
<td>Enables you to select a different layer for the polyline</td>
</tr>
<tr>
<td>Rectangle Layer</td>
<td>Enables you to select a different layer for the rectangle</td>
</tr>
<tr>
<td>Edit Component Artwork</td>
<td>Enables access to selecting different artwork for the selected component</td>
</tr>
<tr>
<td>Wire Layer</td>
<td>Enables you to select a different layer for the wire</td>
</tr>
<tr>
<td>Edit Circle</td>
<td>Enables you to select a different layer for the circle, change its radius and its resolution</td>
</tr>
<tr>
<td>Edit Arc</td>
<td>Enables you to select a different layer for the arc and change its resolution</td>
</tr>
<tr>
<td>Edit Text</td>
<td>Enables you to select a different layer for the text, edit the text itself, change the font, size, justification, and angle</td>
</tr>
<tr>
<td>Set As Text Default Values</td>
<td>Uses the new settings as defaults (same as Options &gt; Preferences &gt; Text)</td>
</tr>
<tr>
<td>Edit Path/Trace</td>
<td>Enables you to modify Path/Trace characteristics such as Width, Layer, and Corner Type</td>
</tr>
<tr>
<td>Set as Path/Trace Default Values</td>
<td>Uses the new settings as defaults</td>
</tr>
<tr>
<td>Symbol Pin Edit (Symbol view only)</td>
<td>Enables you to edit a pin's name, number, angle, and type</td>
</tr>
</tbody>
</table>

**Hint**  The display of the following options can be toggled on and off through these View menu commands by these names:

- Toolbar, Component Palette, Status Bar, Coordinate Readout
Opening Design Windows

There are several ways to open design windows and the method you use is based on what you want to do in that window.

- **New design**—To open a Schematic or Layout window for creating a new design or editing an existing design not currently in memory, click the **New Schematic** or **New Layout** button or choose the command (by the same name) from the Window menu in the Main window.

- **Additional window**—To open an additional Schematic or Layout window for a design that is already open, choose the Schematic or Layout command from the Window menu in that window.

**Hint** You can also open a new Data Display window from the Main window.

Note that Schematic and Layout windows are numbered sequentially as they are opened throughout a session. If Schematic window number three is open (the title bar reflects `(Schematic):3`) and you open a dialog box from that window, the title bar of the dialog box will also reflect :3. This is to assist you in identifying which design window you are about to make changes to.

Opening Multiple Design Windows for the Same Design

The design environment enables you to use multiple Schematic and Layout windows at the same time. For example, you can open two Schematic windows with different designs making it easy to copy and paste parts from one design to another. Or the windows can contain the same design making it easier to accomplish certain design tasks.

**Hint** When you want to open a window for creating a new design or editing an existing design, use the Window menu in the Main window; when you want to open an additional window for the current design, use the Window menu in that window (Schematic or Layout).

*Figure 1-1* illustrates how you can connect components in a large schematic when the components are far apart and the pins difficult to see. You can open an additional window containing the same design. In the first window, zoom in on one of the components. In the second window, zoom in on the other component. Choose the
desired Wire command and draw the wire by clicking the appropriate pin in one window, moving the pointer to the second window and clicking the appropriate pin there.

Figure 1-1. Connecting components using multiple windows
Using the Component Palette
The Component Palette contains buttons that provide a quick method of placing items to create your design.

![Component Palette Diagram]

**Hint**  All palette items can also be placed through the Library. Some items are only available through the Library.

Detaching the Component Palette
The component palette can be detached from the window and moved anywhere on the screen. You may find this helpful in temporarily providing additional space in the drawing area.

To detach the component palette:

Choose View > Component > Detach Component Palette. Window borders and a title bar appear. Where applicable, scroll bars also appear. This window can now be moved around and manipulated like any other window.
To attach the palette to the window again:

Choose **View > Component > Attach Component Palette**. The palette is once again integrated with the design window.

**Hint** On the PC only, you can detach and re-attach using the mouse. Position the pointer over a blank area between buttons on the palette and press the left mouse button. A border appears. Drag the palette to the desired location and release. To re-attach, position the pointer in the title bar of the detached palette and press the left mouse button. Drag the palette toward its original location, positioning the title bar just under the bottom of the palette drop-down list and release.

**Moving Toolbars (PC Only)**

The toolbars can be repositioned anywhere on the screen. You can move them away from the window and use them like floating palettes or you can dock them along the window’s edges.

**Hint** When the title bar of a toolbar is visible, positioning your pointer within the title bar for the drag operation simplifies the docking process. If a title bar is not visible, move the toolbar away from the window’s edge and release; when it is not docked, a title bar appears.

To float a toolbar away from the window:

1. Position the pointer over a blank area between icons on the toolbar and press the left mouse button.
2. Drag the toolbar to the desired location and release. When you release the toolbar, a title bar appears at the top of it.

To dock a toolbar on a window border:

1. Position the pointer over a blank area between icons and press the left mouse button.
2. Drag the toolbar toward the desired window border and notice that the ghost image of the toolbar changes as needed to fit in a vertical or horizontal space.
3. When the ghost image reflects the proper orientation, release the mouse button and refine the toolbar’s position by dragging as necessary.

To reattach a toolbar near the top of the window:

1. Position the pointer in the title bar of the toolbar and press the left mouse button.

2. Drag the toolbar toward the top of the window and when your pointer is overlapping the menu bar, or another toolbar, release.

For details on customizing and creating toolbars, refer to the section, “Configuring Toolbars” on page 9-30.

Schematic Window

The Schematic window is where you create your schematic designs. You create your design by placing components, ports, data items, units, variables, equations, etc.

The program is shipped with a set of standard defaults and parts libraries. These differ depending on program options. However, all defaults can be modified on a system-wide, or project basis. Before beginning any serious design effort, you can customize these defaults to better match the typical designs done at your site.
Program Basics

The most important thing you can do before starting your design is to configure your setup correctly. There are many ways to configure the program defaults. The best configuration for you depends on the type of designs you create, the options you have, and the type of final output you require.

Layout Window

Although the Layout window has many things in common with the Schematic window, it also has many important differences. For details on the Layout option, refer to the Layout manual.

Closing Design Windows

To close an individual design window, but keep the design in memory:

From the Window menu in that window, choose Close.

Status Message Window

The Simulation/Synthesis Message window appears whenever a simulator is launched and displays messages about the status of the current process, as well as warning messages. Each simulation generates its own set of messages which are stored in memory during the current session. These sets of messages can be distinguished from one another by the number displayed in the title bar of the window.

The window contains two information panels:

• Simulation/Synthesis Messages

• Status/Summary

The Simulation/Synthesis Messages portion of the window displays detailed messages about problems encountered during a simulation or synthesis, and where possible, what you can do to solve the problem.

1-16  The Design Environment
Hint  Watch for a message that prompts you to click to view the source of the problem. Clicking this message highlights the component(s)—in the Schematic window—causing the problem.

The Status/Summary portion of the window displays a Simulation finished message, statistics such as how long the simulation or synthesis took, and the system resources used.

Viewing Simulation Status and Error Messages

When the simulation/synthesis is finished, you can save the displayed information to file or you can send it directly to the printer.

To save the currently displayed information to file with a default filename:

Choose File > Save Design and click OK. The default filename consists of the simulation process number (from the title bar of the window), with a prefix of the string sesslogpeesoofsim and a file extension of .txt. The file is saved to the current project directory.

To save the currently displayed information to file with a filename of your choosing:

Choose File > Save As. Supply a filename and click OK. The file is saved to the current project directory.

Note  If you have changed projects during the current session, the file may be written to the initial project opened in this session.
Program Basics

To send the information directly to the printer:

1. If needed, choose File > Print Setup to establish the desired setup and click OK.
2. Choose File > Print. The displayed information is sent to the printer.

For details on print setup, refer to Chapter 11, Printing and Plotting.

Because each simulation generates a set of messages identified by unique names, you can view any messages generated during the current session. You can view these one at a time in the same window, or you can open multiple windows and display different ones all at the same time.

To view messages generated by another simulation:

1. Optionally, choose Window > New Window.
2. From the Window menu, select the simulation information you want to view, as identified by the unique number displayed in the title bar associated with each simulation. The display changes to reflect your selection.

To close any individual status window:

Choose Window > Close Window.
Using the Data Display Window

You can open a Data Display window to see the results of your simulation analysis. To view a graph, choose Window > New Data Display from the Main or Schematic window. After you open a window, you can select an independent swept variable, select dependent measurements, scale the data, and add captions to your graph. Then you can print or plot the graph.

You can open one or more Data Display windows at a time inside the same work space. For example, you can view the same data on a graph and in a tabular format at the same time. Each graph appears in a separate window.

For detailed information on working with data displays, refer to the Data Display manual.
Using the File/Instrument Window

The Instrument window enables you to read data from sources such as a network analyzer or a Touchstone file into Advanced Design System as a dataset. The Instrument Server can also write data from a dataset out to an instrument or file. To display the Instrument Server window, choose Window > File/Instrument Server. For details on using the Instrument Server, refer to the Using Instruments with ADS manual.

Naming Conventions

Prior to Advanced Design System 1.5, user-supplied names throughout the software were restricted in numerous ways. Not only were names restricted with respect to the allowable set of characters, but you could not have any duplication of names among certain types of items, such as node names and instance names. Using the same name for the following items is now allowed:

- Variable names (created in VarEqn and MeasEqn components)
- Node names
- Instance Names
- Component names (includes supplied components and models, and your designs used as subnetworks)

The following illustration shows how these terms are used.
User-supplied names that were previously restricted to alphanumeric and underscore (_) characters (hereafter referred to as the standard character set), can now take advantage of an extended character set that incorporates additional special characters. The extended character set (a superset) consists of the following characters:

```
 alphanumeric _ +- ^= ` @ # & $ %
```

In addition, you can now use a numeral as the first character in many names.
Program Basics

The following table denotes where the extended set and numeric prefixes can be used, as well as several exceptions:

<table>
<thead>
<tr>
<th>Name</th>
<th>Character Set</th>
<th>Exceptions</th>
<th>Numeric Prefix</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variable (VarEqn, MeasEqn)</td>
<td>Standard</td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>Node</td>
<td>Extended</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Instance</td>
<td>Extended</td>
<td>An underscore cannot be used as the first character. The following components are restricted to the standard character set for their Instance Name: SweepPlan, ParamSweep, DC, AC, S_Param, HB, LSSP, P2D XDB, Envelope, Transient, Options, YieldSpec, Goal, Yield, Optim, YieldOptim, MeasEqn, VarEqn, DataAccessComponent</td>
<td>Yes</td>
</tr>
<tr>
<td>Component</td>
<td>Extended</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Design</td>
<td>Extended</td>
<td>Design names may not contain $ or %. These characters are reserved for ADS environment variable substitution. Note: If a design name includes special characters or starts with a numeral (such as &quot;00a&quot; or &quot;@&quot;), optimization results are not updated Note: If a design name consists solely of numerals, The transistor device operating points dialog box cannot be displayed.</td>
<td>Yes</td>
</tr>
<tr>
<td>Project</td>
<td>Standard</td>
<td></td>
<td>Yes</td>
</tr>
</tbody>
</table>
Limitations

- When the extended character set is used to define a name, and that name becomes part of a variable name in a dataset, the data cannot be accessed directly with respect to either data displays or measurement equations. A special access function called \texttt{var()}, must be used. For example, if you name a node \texttt{V++} then to display its magnitude you must use the expression:
  \[ \text{mag(var("V++"))} \]
  where \texttt{var()} is passed the name of the variable as a string. The \texttt{var()} function interprets the passed string as the name of a variable, which prevents any expression processing of the string. Note that using this function limits you to accessing datasets in the data directory of the current project. Data Display automatically adds \texttt{var()} when required to access names defined using the extended character set.

- Substrate Instance Names—If a leading number is used as a substrate ID, then that substrate cannot be referenced by its corresponding set of distributed models.

- Model Instance Names—Currently, the characters $ and \% are not allowed in instance names for model items, such as BJT\_Model, R\_Model, etc.

- Dataset Names—Special characters from the extended set are not allowed in dataset names (standard set, with non-numeric first character, is required). Thus, if you have two or more designs whose names are distinguishable from one another only with respect to the use of special characters, you should supply unique dataset names prior to simulating. If you do not, and you perform successive simulations of these designs, the dataset resulting from the first simulation will be overwritten by the next (because the special characters will be dropped from the automatically derived dataset names).

  Note: If your design name begins with a number, the default dataset name will be the design name with an underscore character (_) added to the front.

- Optimization Goals—Special characters currently cannot be referenced by an Optimization Goal or Yield spec. If a design name includes special characters or starts with a numeral (such as "00a" or "$"), optimization results are not updated.

- Operating Point Annotation—The transistor device operating points dialog box does not come up when a design has a numeric name such as "0000" or "1234".
Program Basics

- Spaces are not allowed in project and design names

**Note** An invalid character is changed to "_" (underscore).

Global Node Naming Conventions
If you use an exclamation point (!) as the last character in a node name, it denotes that the node is a global node.

Using Keyboard Shortcuts and Accelerator Keys
Keyboard shortcuts are available for every command and are identified by the underlined character in every command on every menu. Accelerator keys are available for many menu commands and are identified by a key combination listed to the right of the command, where applicable.
- For a table listing the default assignments, refer to Appendix B, Shortcut Keys.
- For details on changing the default assignments, refer to the section “Customizing Keyboard Shortcuts” on page 9-29.

Setting Preferences for Miscellaneous Options
The Preferences dialog box, accessed through the Options menu in the Main window, enables you to establish preferences for a variety of features that affect you throughout the design environment.
- **Warning Bell**—The system beeps anytime you receive a pop-up window with a warning message.
- **Error Bell**—The system beeps anytime you receive a pop-up window with an error message.
- **Balloon Help**—As you move your pointer over the toolbar and palette buttons, a small balloon appears with text describing that button’s purpose (or a component’s name).
- **Design Synchronization Checking**—You are warned if you attempt to simulate a design that is not fully synchronized.
• **Large Toolbar Bitmap**—A set of large bitmaps is placed on the toolbar. Turn this option off to place a set of small bitmaps on the toolbar (better for monitors with lower screen resolution). This change will be evident in any subsequently opened windows. To see the change take effect in a currently open window, open the Menu/Toolbar Configuration dialog box, click the Toolbar tab, and click OK.

• **Display Project Listing**—Filters the contents of the selected directory to display only project directories under the Project Listing heading.

• **Save Project State on Exit**—The setup of the project you are exiting is saved, including all design windows. The group of windows, and their positions on the screen, are restored the next time you open the project.

• **Create Initial Schematic Window**—A Schematic window opens automatically each time you create a project.

• **Create Initial Layout Window**—A Layout window opens automatically each time you create a project.

• **New/Open Design in New Window**—Sets a default in the New Design dialog box (File > New Design) that determines whether to open a new window for the new design or use the currently open window.

```
Create New Design in:

- Current Window  [ ] New Schematic Window  [ ] New Layout Window
```

Changing this setting does not affect the default setting in currently open Schematic/Layout windows, but will take affect in any subsequently opened Schematic/Layout windows.

• **Add Project Extension**—The extension you want appended to project names to clearly identify them as projects (default is _prj).

• **External Text Editor**—Specifies the text editor to be launched when you choose Options > Text Editor in the Main window.

• **Wire Thickness**—The thickness (Thin, Medium, Thick) of all wires drawn in a Schematic window.
Program Basics

To change any of these settings:

1. Choose Options > Preferences, in the Main window, and a dialog box appears.
2. Change any or all options as desired, and click OK. All changes take effect immediately, except as noted in the descriptions.

Exiting the Program

You can exit the program from the design windows or the Main window.

To close your project and exit the program:

Choose File > Exit Advanced Design System in any window.

- Click Yes to exit Advanced Design System
- Click No if you do not want to exit Advanced Design System

To save all designs in all windows, choose File > Save All in the Main window.

If any files with unsaved changes exist, a dialog box appears listing one of the files and offering the following choices:

- Yes—Click this to save changes to the named file and to be prompted individually for any additional files with unsaved changes
- No—Click this to disregard changes to the named file and to be prompted individually for any additional files with unsaved changes
- Yes To All—Click this to save changes to all files without being prompted individually
- No To All—Click this to disregard changes to all files without being prompted individually
- Cancel—Click this to cancel the command
Chapter 2: Managing Projects and Designs

This chapter describes the project directory concept, managing projects and design files, and the basics of importing and exporting designs. For information on these topics, review the following sections:

- “Working in Projects” on page 2-1
- “Importing and Exporting” on page 2-12
- “Managing Design Files” on page 2-15

Working in Projects

All design work must be done in a project directory. Working in project directories enables you to organize related files within a predetermined file structure. This predetermined file structure consists of a set of subdirectories. These subdirectories are used in the following manner:

- networks contains schematic and layout information, as well as information needed for simulating
- data is the default directory location for input and output data files used or generated by the simulator
- mom_dsn contains designs created with the Agilent EEsof planar electromagnetic simulator, Momentum
- synthesis contains designs created with DSP filter and synthesis tools
- verification contains files generated by the Design Rule Checker (DRC), used with Layout

Creating a Project

You can create any number of project directories.

To create a project directory:

1. Choose File > New Project and a dialog box appears. By default, the path is set to your start-up directory.
Note: Spaces are not allowed in project paths or project names.

2. Type a new path directly in the Name field or use the Browser to specify the location for the new project.

3. Enter a project name in the Name field.

Note: By default, the suffix _prj is automatically added to the project name you supply. This behavior is defined by the option Add Project Extension. You can change this option through Options>Preferences in the Main window.

4. Click **Length Units** and select the appropriate setting.

![Length Unit dialog box]

This unit setting serves as a default for all designs in this project and is both:
- The unit of measure for parameters with physical length (in both Schematic and Layout windows)
- The design unit (grid display and cursor snapping) in the Layout window

**Hint:** The design unit (grid display and cursor snapping) in the Schematic window is inches.
5. Click **OK** to establish Length Units.

6. Click **OK** to create the specified project. When the directory structure is complete, the path and the project name appear at the bottom of the Main window.

**Hint** By default, a Schematic window opens on creation of a project. This behavior is defined by the option Create Initial Schematic Window. You can turn this option off through Options > Preferences in the Main window.

---

**Opening a Project**

The directory that appears as the current directory when you start the program varies by platform:

- **UNIX**—the directory from which you started the program. Once you have created project directories, you can start the program from a project directory, if desired.

- **PC**—the path you specified as the Work Directory during installation (by default, c:\ AdvDesSys). You can set a different work directory through file Properties. (Right-click a program's shortcut icon and adjust the path in the Start field.) If you want to open a specific project directory while starting the program, use that project directory's name in the Start in field.
Managing Projects and Designs

Once the Main window appears, there are two ways to open a project directory:

- Use the File > Open Project command
- Double-click the project name in the Project Listing pane of the Main window

To open a project using the Open Project command:

1. Choose File > Open Project and a dialog box appears. All projects in the current directory are listed in the Files list box.
2. Change directories as needed to find the directory containing the project.
3. Select the project name and click OK. Once the project is open, the right-hand group of toolbar buttons is activated and the path and project appear in the status panel at the bottom of the window.
To open a project using the File Browser:

1. Change directories as needed in the File Browser pane to locate the directory containing the project.

2. Choose View > Project Listing. All projects in the current directory are listed under the Project Listing pane. (For information on the Project Listing preference, refer to the section, “Setting Preferences for Miscellaneous Options” on page 1-24.)

3. Double-click to open the desired project. Once the project is open, the right-hand group of toolbar buttons is activated and the path and project appear in the status panel at the bottom of the window.

The windows that open when you open a project vary based on the following options:

- If the Save Project State on Exit option was enabled for this project, any design windows that were open when you last exited the project are restored.

- If the Save Project State on Exit option was not enabled for this project, but the option Create Initial Schematic window was enabled (the default), a blank Schematic window appears.

- If neither of the aforementioned options was enabled, you must manually open a Schematic window. (Click the New Schematic Window toolbar button or choose Window > New Schematic.)
Managing Projects and Designs

Hint  For descriptions of these options, refer to “Setting Preferences for Miscellaneous Options” on page 1-24.

Copying a Project

The Copy Project command copies a project directory and its contents, to a new project directory with a name you specify.

Note  Copying projects should only be done through the program, as described here. Copying projects outside the program may result in invalid projects.

To copy a project:

1. Choose File > Copy Project.
2. Locate the project you want to copy.

   Hint  To copy an example project, click the Example Directory button to quickly set the path to the examples directory.

   Click Browse next to the From Project field.

3. In the dialog box that appears, change directories as needed to locate the project.
4. Select the project you want to copy and click OK.
5. Specify the destination directory for the copied project.

   Hint  To copy the project to your start-up directory, click the Startup Directory button to quickly set the path to your start-up directory.

   Click Browse next to the To Project field.

6. In the dialog box that appears, select the destination path, and click OK.
7. Supply a project name, if desired, in the To Project field (following the path).
Hint If you want the copy to use the same name as the original project, you do not need to specify a name in the To Project field.

8. If the project you are copying is hierarchical, and you want to preserve the hierarchy, leave the Copy Project Hierarchy option enabled.

Note When copying a hierarchical project, you are prompted for each included project to confirm whether or not you want to copy that project. If you do not copy an included project (Skip), a reference to its source location is created in the copied project hierarchy. You are also prompted to supply a path and name for each copied project in the hierarchy. Click Browse to adjust the path without typing.

9. Click OK.

Deleting a Project

The Delete command enables you to delete a project directory and all its contents.

Note Deleting projects should only be done through the program, as described here. Deleting projects outside the program may result in program errors.

To delete a project:

1. Choose File > Delete Project and a dialog box appears.
2. Change the path as needed to locate the project directory you want to delete.

Note You cannot delete the current project directory.

3. Select the project and click OK. You are prompted to confirm that you want to delete that project directory.
4. Click Yes to delete it; click No to keep it.
Managing Projects and Designs

Using an Example Project

An extensive set of example projects is provided to demonstrate designing for various technologies.

To view the list of example projects:

1. In the Main window, click the Examples button on the toolbar. The File Browser pane changes to display the categories of examples available.
2. Click the category of interest to view the projects in that category.

To open an example project:

1. Use any of these methods:
   • Double-click the project name listed in the File Browser pane on the left.
   • Double-click the project name listed in the Project Listing pane on the right. (Refer to the Project Listing option described in “Setting Preferences for Miscellaneous Options” on page 1-24.)
   • Choose File > Example Project. Select the appropriate category and then the desired example.
2. Example projects are saved in a particular state and one or more designs will open automatically.
   • UNIX-Notice that when the Schematic window appears, the title bar reflects that the example is READ-ONLY. To simulate or modify designs in this project, make a copy of the project.
• PC-To preserve the example designs, make a copy of the project before modifying any of the designs in it.

Creating a Hierarchical Project

You can create hierarchical projects using the Include/Remove Projects command. This command creates a reference, or link, to another project. Hierarchical projects offer several benefits, including:

- The ability to create hierarchical designs by referencing designs from other projects
- The ability to maintain a single source of a design referenced by other users. Other users can include the project containing the design of interest, and benefit from updates to the original design, since they are only linking to it, not copying it.
- Reduced disk space required for shared designs.

An example of a hierarchical project is shown next.

To include a project:

1. Open the project directory under which you want to include other projects.
2. Choose File > Include/Remove Projects.
3. Use the File Browser to locate and select the project you want to include.
4. Click the Include button. The project is added to the Project Hierarchy listing.
5. Repeat as needed, then click OK.
Managing Projects and Designs

To remove an included project:

1. Open the project that includes the project to be removed.
2. Choose File > Include/Remove Projects.
3. Under Project Hierarchy, select the project you want to remove from the hierarchy and click the Remove button. The Project Hierarchy display is updated.

If your hierarchical project includes other hierarchical projects, projects at lower levels cannot be removed unless the project in which they were originally included is the current project. For example, in the illustration shown next, you cannot remove the project amp1_prj from the hierarchy when rec_front_end_prj is the current project; you must make amplifiers_prj the current project first.

4. Repeat as needed, then click OK.

Working with Hierarchical Projects

Observing the following tips may simplify working with hierarchical projects:

- The title bar of the Schematic window displays the source of a project/design. This tip may help orient you when working with hierarchical designs within hierarchical projects. If you Push Into Hierarchy to view a design being referenced, the title bar displays the source of the design.

- If the project name in the title bar of the Schematic window does not match the current project name shown in the prompt panel of the Main window, simulation of that design is not allowed. This situation would occur, for example, if you place an instance of a design (as a subnetwork) from a project that is included in another project, and push into that subnetwork and attempt to simulate.
Archiving a Project

You can create a single file for a project, making it easy to transfer the project to another file system or another location on the same file system.

To archive a project:

1. In the Main window, choose File > Archive Project.
2. Use the Archive Project Browser and select the project you want to archive.
3. Use the To File Browser and select a path for the archived file. (Hint: You cannot archive directly to a floppy disk; you need more space for the process.)
4. Supply a name for the archived file. The extension .zap is automatically appended to the filename you supply.
5. If the project is hierarchical and you want to preserve the hierarchy, select the Archive Project Hierarchy option.
6. Click OK.

Hint If transferring projects back and forth between UNIX and PC, keep in mind that UNIX is case-sensitive and the PC is not. The PC does not always preserve case, so filenames going back and forth should be unique.

Unarchiving a Project

To unarchive a project:

1. In the Main window, choose File > Unarchive Project. (Hint: When you unarchive it, the project will be restored in the directory containing the archived file.) The file listing displays all files in the current directory with the extension .zap.
2. Change directories as needed to locate the archived project file.
3. Select the file and click OK. If the project is hierarchical, all projects are restored with their original name(s).

Hint The directory you use to unarchive the project cannot contain any subdirectory or filename of the same name as the archived project(s).
Importing and Exporting

The Import and Export commands enable you to import and export HP IFF files, as well as files in a variety of formats produced by other software. You can import files through the Main, Schematic, and Layout windows; exporting is done from Schematic and Layout. The listing below shows the available formats.

- For details on these formats and descriptions of the options associated with each, refer to the Importing and Exporting Designs manual
- For details on importing and exporting SPICE files, refer to the Spice Netlist Translator manual
- For details on importing Series IV designs, refer to the Series IV Migration manual

Table 2-1. Program Windows and Available Import/Export Formats

<table>
<thead>
<tr>
<th></th>
<th>Main</th>
<th>Schematic</th>
<th>Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Import</strong></td>
<td>HP IFF</td>
<td>EGS Generate</td>
<td>DXF (hierarchical)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>EGS Archive</td>
<td></td>
</tr>
<tr>
<td><strong>Spice</strong></td>
<td>HPGL/2</td>
<td>EGS Generate</td>
<td></td>
</tr>
<tr>
<td></td>
<td>HP IFF</td>
<td>GDSII Stream Format</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mask File (.msk)</td>
<td>HPGL/2</td>
<td></td>
</tr>
<tr>
<td><strong>Spice File</strong></td>
<td>HP IFF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>IGES</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Mask File (.msk)</td>
<td></td>
</tr>
<tr>
<td><strong>Export</strong></td>
<td>HP IFF</td>
<td></td>
<td>DXF (hierarchical), (flattened)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>EGS Archive</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>EGS Generate</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>GDSII Stream Format</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Gerber</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Gerber Viewer</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>HPGL/2</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>HP IFF</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>IGES</td>
<td></td>
</tr>
</tbody>
</table>
### Importing a Design

To import a design:

**Note** You must open a project before importing a design.

1. Choose **File > Import**.

2. In the dialog box that appears, select the appropriate file format from the **File Type** drop-down list.

3. To define options for the imported file, click **More Options** and dialog box appears.

**Note** The program translators are controlled by translator options files. A system-wide options file exists for each translator. These files can be found in the `$HPEESOF_DIR/config` directory. The default system file is automatically read when you click **More Options** in the Import dialog box (unless a local options file already exists in the current project directory). When you make changes in the options dialog box and click **OK**, a local copy of the options file is written to the current project directory.

4. To specify the path and filename of the file you want to import, click **Browse**.

5. Double-click as needed to locate the directory containing the design. By default, all files are listed that have the file suffix appropriate for the chosen file format.

6. Select the design you want to import and click **OK**. You are returned to the Import dialog box and the selected filename appears in the field labeled **Import File Name (Source)**.

7. Where applicable, type a new name for your imported design in the **New Design Name (Destination)** field. Note: For certain file types, the translator uses the existing filename to determine the new design name.

<table>
<thead>
<tr>
<th>Main</th>
<th>Schematic</th>
<th>Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Mask File (.msk)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MGC/PCB</td>
</tr>
</tbody>
</table>

Table 2-1. Program Windows and Available Import/Export Formats (continued)
8. Click **OK** to import the design and dismiss the Import dialog box.

**Exporting a Design**

To export a file:

1. Choose **File > Export**.
2. In the dialog box that appears, select a file format from the File Type drop-down list.
3. To set export options, click **More Options** and a dialog box appears.

---

**Note** The program translators are controlled by translator options files. A system-wide options file exists for each translator. These files can be found in the `$HPEESOFT_DIR/config` directory. The default system file is automatically read when you click More Options in the Export dialog box (unless a local options file already exists in the current project directory). When you make changes in the options dialog box and click **OK**, a local copy of the options file is written to the current project directory.

---

4. Change options as needed and click **OK**.
5. To specify a path for the exported file, click **Browse**.
6. Double-click as needed to locate the directory for the exported design. By default, all files are listed that have the file suffix appropriate for the chosen file format.
7. Click **OK**.
8. Type a new filename in the Export dialog box, following the path, and click **OK**. The file is written to the specified directory.
Managing Design Files

Before you begin your design work, you should understand the basics of file management within the design environment.

Creating a Design File

You can begin your design work in an untitled design window or supply a filename before you begin. When selecting a filename, keep in mind the guidelines described in the section, “Naming Conventions” on page 1-20.

To create a design file:

1. In a Schematic (or Layout) window, choose File > New Design and a dialog box appears.
2. Enter a design name in the Name field. The program automatically adds the extension .dsn to your filename.

Note If a project created on UNIX contains two or more designs whose names are only distinguishable from one another by differences in case, do not archive and transfer this project to a PC without renaming the designs such that they all have unique names. This requirement is due to the fact that the PC is case insensitive.

3. Where applicable (you selected Both in the initial or setup dialog box), select the design type.
   Analog/ RF Network or Digital Signal Processing Network
   This affects the type of components available for design work.

Hint The choices presented here reflect the setting in the Advanced Design System Setup dialog box (Main window, Options menu).

4. Select the New Window option to create the new design in its own window. (This step is only required if you chose File > New in a window containing a design and you want to keep that design open in addition to creating a new design.)
Managing Projects and Designs

5. Optionally, select a Design Template as a starting point for your design. (For details, refer to the section, “Using a Template” on page 2-16.)

6. Click OK. The design name is reflected in the title bar of the window.

Using a Template

Several simulation templates are provided as a convenience to help you create designs more quickly. You can turn any of your own designs into a template using the Save Design As Template command.

To start a new design with an existing template:

Choose File > New Design, select a template from the list, and click OK.

To add an existing template to an existing design:

Choose Insert > Template, select a template from the list, and click OK.

To create a new design for use as a template:

1. Create the design just as you would any other design.

2. Choose File > Save Design As Template. (The program automatically adds the extension .tpl to your filename.) The design is saved to your local templates directory and will now appear in the list of available templates (File > New Design and Insert > Template) when you choose to use one.

To modify a supplied template or one you have created:

1. Choose Insert > Template, select that template from the list, and click OK.

2. Make the desired changes and choose File > Save Design As Template.

Note To associate an AEL macro file with a template, give it the same name as the template file, add underscore tpl (_tpl), and an .ael extension. Example: For a template filename of my_amp.tpl, name the AEL macro file my_amp_tpl.ael. Place this file in home/ hpeesof/ circuit/ templates (or home/ hpeesof/ hptolem/ templates), along with the template file, and it will be loaded when you insert the template in another design.
Saving a Design File

There are three commands related to saving files: Save Design, Save Design As, and Save Design As Template.

• The Save Design command enables you to save changes to an existing file. (If you choose Save in an untitled window, the Save Design As dialog box appears.)

• The Save Design As command enables you to save an existing file with a new name. For example, to make a copy of an existing design so that you can edit it while preserving the original, use the Save Design As command to create a copy of the file with another name.

• Use the Save Design As Template command to save a design, at any stage, for use as a template. (Select a template for use through File > New Design or Insert > Template.) The program automatically adds the extension .tpl to your filename.

If you have made changes to a design and want to discard those changes, but continue working with the previously saved version of the design, choose File > Revert to Saved Design.

To save changes to an existing file:

Choose File > Save Design. If the file was previously saved (it resides on the disk), a dialog box appears.

• If you want to overwrite the old version with the new version, click Yes.

• If you do not want to overwrite the old version, click No and use the Save Design As command to save the design to another name.

To save an existing file with a new name, or to save a new file you have not yet named:

1. Choose File > Save Design As and a dialog box appears prompting you for a New File Name.

2. Enter a name for the design and click OK. The file is saved and automatically assigned an extension, which varies depending on the window (Schematic/Layout uses .dsn; Data Display uses .dds).
Managing Projects and Designs

Note  The Save Design As command names or renames all files associated with the design (.dsn, .ael, etc.) and is therefore the preferred method for saving a design to a new name. Therefore we recommend you use the design environment for all file management operations.

Saving All Designs in Memory

To save any designs currently in memory, including data displays, that have not been saved since changes were made:

In the Main window, choose File > Save All.

Opening an Existing Design

There are several ways to open existing designs:

• Double-click it in the Main window (from the Design Information pane)
• Double-click it from the Design Hierarchy dialog box (View > Design Hierarchies)
• Use the File > Open Design command in the appropriate design window
• If it is one of the last four designs opened, it appears on the file list at the bottom of the File menu and you can click there to open it
• If the design is currently open (in memory), it appears on the list at the bottom of the Window menu and you can click there to open it. You can also open it using the Designs Open command (on the Window menu).

To open an existing design from the browser in the Main window:

1. In the File Browser pane, click once to expand the networks directory and a list of all designs in that directory appears.

2. Double-click to select a design name. If the design is hierarchical, the hierarchy is listed under Design Information on the right side of the window; if the design is not hierarchical, its complete path and name appear under Design Information.

3. Double-click the design name from the right pane to open it.
To open an existing design from the File menu in a design window:

1. Choose File > Open Design and a dialog box appears.
   By default, the files displayed in this dialog box are located in the current project directory and have a .dsn extension.
2. Select the design you want to open from the Files list box, and click OK. The design appears in the window.

   **Important** To make a complete set of files for a design in another project directory, use the File > Copy Design command in the Main window.

To view a design currently open (in memory) from the Window menu:

Choose Window (in the Schematic or Layout window) and select the design of interest from:

- The list of files at the bottom of the Window menu
- The dialog box that appears when you choose Designs Open

Note that when the number of designs in memory exceeds the number of designs displayed at the bottom of the Window menu, an additional menu choice, More, appears. Choose More to see a complete list of designs in memory.

**Hint** The number of designs displayed on the Window menu (by default, nine) can be customized by setting the variable DESIGN_LIST_COUNT equal to the desired value. For details, refer to Chapter 1, Customizing the ADS Environment, in the Customization manual.
Managing Projects and Designs

**Copying a Design**

The Copy Design command copies all files associated with the design and is therefore the preferred method for copying designs.

---

**Note** Copying designs should only be done through the program, as described here. Copying designs outside the program may result in invalid designs.

---

To copy a design:

1. Choose **File > Copy Design** and click **Browse** (From Design).
2. Change directories as needed to locate the directory containing the design you want to copy.
3. Select the design and click **OK**.
4. Click **Browse** (To Path) and change directories as needed to specify the path for the copied design. Click **OK**.
5. Supply a name, following the path, for the copied design.
6. If the design is hierarchical, and you want to preserve the design in its entirety, select the Copy Design Hierarchy option.
7. When the From and To fields in the Copy Design dialog box reflect the appropriate paths and filenames, click **OK**.
Deleting a Design

To delete a design:

1. Choose **File > Delete Design** and a dialog box appears.

   **Note** Deleting designs should only be done through the program, as described here.

2. Change directories as needed (by default, the directory shown in the File Browser pane) to locate the project containing the design you want to delete.

3. Select the design you want to delete and click **OK**. You are prompted to confirm you want to delete that design.
   - To delete it, click Yes
   - To cancel, click No

   **Important** If you delete a design that serves as a subnetwork in other designs, remember to delete all occurrences of that subnetwork in those designs.

Clearing a Design from Memory

Every design you open is stored in memory until you explicitly clear it from memory or exit the program. There are two ways to clear designs from memory: **Close Design, Delete All**. This distinction enables you to clear an entire design (both schematic and layout information, which are stored in the same file) from memory, or clear only schematic information or only layout information from memory.

- **Close Design**—File menu—clears the entire design file from memory
  - If any unsaved changes are detected, you are prompted, Design not saved, clear anyway?
    - If you want to clear the design without saving, click **Yes**.
    - If you do not want to clear the design without saving, click **No**, and then select **Save Design** from the File menu.
Managing Projects and Designs

- **Delete All**—Edit menu—deletes the current schematic information, if issued from the Schematic window, or the layout information, if issued from the Layout window

**Hint** As with other commands found on the Edit menu, the Undo command works on Delete All.

**Clearing All Designs from Memory**

To clear all designs, including data displays, currently in memory:

In the Main window, choose **File > Close All**.

If any files with unsaved changes exist, a dialog box appears listing one of the files and offering the following choices:

- **Yes**—Saves changes to the named file and prompts you individually for any additional files with unsaved changes
- **No**—Discards changes to the named file and prompts you individually for any additional files with unsaved changes
- **Yes To All**—Saves changes to all files without prompting you for each one
- **No To All**—Discards changes to all files without prompting you for each one
- **Cancel**—Stops the Close All command
Chapter 3: Creating Designs

This chapter describes creating designs in the Advanced Design System environment. The starting point of this chapter assumes you have started the program, as described in Chapter 1, Program Basics, and that you are familiar with the project directory concept and design file management, as described in Chapter 2, Managing Projects and Designs.

Although you can perform a wide variety of editing operations on your design as you create it or once the design is complete, you can set numerous options before you begin your design work to minimize the need for editing. These options can be set through the Preferences dialog box (Options > Preferences) in a design window. Listed below are some of the options that can be set in advance to assist you in creating your designs:

- “Setting Placement Options” on page 9-9
- “Setting Entry/Edit Options” on page 9-12
- “Setting Grid/Snap Options” on page 9-6

These options, as well as others, are described in Chapter 9, Setting Design Environment Preferences.

Because all shapes and text are entered on layers, you may also want to modify layer definitions before beginning your design work. For details refer to the section, “Specifying Layer Definitions” on page 9-21.

For details on adding a drawing sheet to the design window, refer to the section, “Adding a Drawing Sheet” on page 7-1.

Defining Units for a Design

The design environment uses Units in a number of ways, differentiated as follows:

- Layout Units—the unit used for grid and snap features in the drawing area of the Layout window (Options > Preferences > Layout Units)

**Note**  The unit used for grid and snap features in the drawing area of the Schematic window is inches, and cannot be changed. When you see choices in various dialog boxes for screen pixels or schem units, the schem units are inches.
Creating Designs

- **Length Unit**—the unit of measure for parameters with physical length in both the Schematic and Layout windows, and the Layout Units of the Layout window. When you create a project directory, you choose the Length Unit to be used as a default for all designs in that project. When working with the Layout option, we recommend keeping the Length Unit and the Layout Units the same, thus the Length Unit serves both purposes, by default.

  **Note** You can choose a different Length Unit for an individual design (Options > Preferences > Units/ Scale) but a change made in this manner exists only in memory unless you save the preferences to a file. For details, refer to the section “Saving and Reading Preference Files” on page 9-20.

- **Units/ Scale**—The scale factors shown in the Units/ Scale tab of the Preferences dialog box serve as defaults in the following situations:
  - When a parameter of a supplied component does not have a default unit and you do not assign one (in the component parameter dialog)
  - When you supply a default parameter value without units while creating a parametric subnetwork (File > Design Parameters)

  **Hint** Notice there are both Length and Distance scale factors, where Length typically applies to parameters such as transmission line length, and Distance is a much larger scale factor that applies to things like antenna path length.

Adjust these settings as desired before you begin your design work to reflect the defaults that will best meet your design needs. Note that changes to these settings exist only in memory unless you save the preferences to a file. For details, refer to the section “Saving and Reading Preference Files” on page 9-20.

---

3-2 Defining Units for a Design
Placing Components

You create designs by placing items (such as, components, data items, measurements, sources, simulation controls, etc.) in a design window. There are several ways to access these items:

• Browsing—in the Component Library window
• Searching—in the Component Library window
• Component Palette—on the left side of the design window
• Component History—on the toolbar or as a dialog box

Although there are several methods of access, the basic steps for placing a component are the same.

To place a component in the design window:

1. Locate and click to select the component.
2. Move the pointer into the drawing area and click the orientation button to rotate the symbol as necessary.
3. Click to place the symbol in the desired location.

For additional information on working with components, refer to the following sources:

• For details on changing the orientation of a component, refer to the section, “Rotating Components” on page 3-16.
• For details on connecting components, refer to the section, “Connecting Components” on page 3-18.
• For details on changing component parameters, refer to the section, “Editing Component Parameters” on page 6-2.
• For details on changing attributes of component text:
  • Prior to placing components, refer to the section, “Setting Component Text Options (in Advance)” on page 9-15.
  • After placing components, refer to the section, “Changing Component Text Attributes” on page 6-10.
Browsing for Components

You can view the components that make up any individual library by selecting the library name in the Component Library window. The libraries listed vary with the current design type—Analog/RF versus Digital Signal Processing.

In the following figure, the left side shows the top-level libraries (for the Analog/RF design type) collapsed; the right side shows a partial listing of the Analog/RF sub-libraries as it appears expanded.

![Component Library Tree](image)

To browse for a component:

1. From any design window, click the Library button on the toolbar (or choose Insert > Component > Component Library).

2. Click the plus sign in front of a library name to expand it and view its sub-libraries.

In addition to these libraries, a library named Frequently Used Components is filled, as you work, with the components you place, enabling you to quickly place additional instances of those components. Note that the Frequently Used Components library is project-specific; the library that is created in any given project directory will remain until you explicitly clear it.

The Subnetworks library provides access to all the designs in the current project for use as subnetworks in other designs in that project. (To enable access to designs in other projects, create a hierarchical project as described in the section “Creating a Hierarchical Project” on page 2-9.)
3. Select a sub-library and its components are displayed in the Components section of the window. By default, a brief description for each component is also displayed.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>R</td>
<td>Resistor</td>
</tr>
<tr>
<td>R_Model</td>
<td>Resistor Model</td>
</tr>
<tr>
<td>L</td>
<td>Inductor</td>
</tr>
<tr>
<td>C</td>
<td>Capacitor</td>
</tr>
<tr>
<td>C_Model</td>
<td>Capacitor Model</td>
</tr>
<tr>
<td>DC_Feed</td>
<td>DC Feed</td>
</tr>
<tr>
<td>DC_Block</td>
<td>DC Block</td>
</tr>
<tr>
<td>Short</td>
<td>Short</td>
</tr>
</tbody>
</table>

Additional component information is available once you select a library. For details, refer to the section, “Customizing the Component Library Display” on page 3-8.

To place components from any library:

1. Select the library to display the list of components.
2. Select the component you want to place, move the pointer into the drawing area, and click to place it.

**Hint** To clear the current list of frequently used components, select the Frequently Used Components library and choose Edit > Clear Frequently Used Components.
Creating Designs

**Searching for Components**

You can search for a component (or group of components with something in common) based upon text that is part of the component name or description.

To search for a component:

1. From any design window, click the **Library** button on the toolbar (or choose **Insert > Component > Component Library**).
2. In the Component Library window, choose **Tools > Find**.
3. Type the word or phrase you want to search for.

![Find Component Dialogue Box](image)

**Note**  Only the library currently highlighted in the Libraries pane will be searched. By default, All libraries are searched. To narrow the search, select a specific library or sub-library. Your choice is reflected in the **Look in** field.

When the search is complete, the components and/or descriptions matching the search criteria are displayed.

The following figure shows the results of a search for the word pulse in all libraries.
To limit your initial search using case sensitivity:

1. Select the **Case Sensitive** option.

2. Type the search text matching the case of the component name(s) as it appears in the program.

   Example: The component you are looking for contains the word BEND, as part of its name, in uppercase and you want to search for all components that include BEND as part of their name, but exclude components whose descriptions contain the word Bend (mixed case).

To perform a secondary search on your initial search results to view some subset of those results:

1. Select the **Refine Search** option.

2. Change the search text in the Find field as needed and click **Apply**. The initial results are searched for anything meeting the revised search criteria.

   Example: Initiate a search through all libraries on the word amplifier. As you scan the resulting list, you notice several amplifiers with drain current of 17 mA scattered throughout. To view only those amplifiers, type id=17ma in the Find field, select the Refine Search option, and click Apply. The resulting subset of amplifiers is displayed.
Creating Designs

Customizing the Component Library Display

Several features are provided to enable you to customize the Component Library display. You can:

- Collapse/expand the display of libraries and sub-libraries to minimize scrolling
- Add new libraries
- Rearrange the libraries and sub-libraries using Cut, Copy, and Paste
- Show or hide the display of several types of component information
- Set defaults for the widths of the various component information displays
- Alphabetically sort the display of libraries and components

Once you customize the display to meet your needs, you can save the settings to file and use those settings in any subsequent session. For details refer to, “Saving Customized Library Displays” on page 3-12.

**Note**  Several aspects of the browser display can be set for all projects (user) or on a site-wide basis. For details, refer to the hpeesofbrowser.cfg file described in Chapter 1, Customizing the ADS Environment, of the Customization manual.

To expand a library so that its sub-libraries are displayed:

Click the plus sign in front of the library name. To collapse the library, click the minus sign.

The expanding and collapsing of libraries can also be accomplished via toolbar buttons or the View menu (View > Libraries).
Placing Components 3-9

• Expand Libraries—Expands the view of all top-level libraries
• Collapse Libraries—Collapses the view of all top-level libraries
• Expand Selected Library—Expands the view of the currently selected library
• Collapse Selected Library—Collapses the view of the currently selected library

To add a new library:

2. Supply a library name and click Apply (or OK if only creating one library at this time). The new library is added to the bottom of the current list of libraries.

Rearranging Libraries

You can rearrange and delete libraries to make the library display better meet your design needs:

• Use Cut and Paste to rearrange the order of libraries—relative to other libraries, or the order of sub-libraries—relative to other sub-libraries. (Use Copy and Paste to copy a sub-library to another location).
  
  You can also turn a sub-library into a library by pasting it at the library level—highlight All and paste.

• Use Cut to delete libraries (or sub-libraries) you do not use for a specific project or are not licensed for, to help minimize scrolling.

Note that when you paste, the affected library or sub-library is pasted at the bottom of the list. Once you make your changes, you need to save your customized views (“Saving Customized Library Displays” on page 3-12).

To rearrange or delete libraries using Cut/Copy/Paste:

1. Highlight the library you want to move (or delete) and choose Edit > Cut.
2. To paste it at the bottom of the list of All libraries, highlight All and choose Edit > Paste.
Creating Designs

To rearrange sub-libraries using Cut/Copy/Paste:

1. Highlight the sub-library you want to move, copy, or delete.

**Note** Sub-libraries cannot be pasted within another sub-library.

2. Choose **Edit > Cut** (or **Copy**), and:
   - To paste the sub-library at the bottom of an existing library, highlight that library.
   - To paste the sub-library as a library (at the bottom of the list of all libraries), highlight **All**.

3. Choose **Edit > Paste**.

**Setting Display Preferences**

To view additional columns of component information:

1. Choose **Options > Preferences**. In the Show Columns section of the dialog box that appears, several categories are listed:
   - **Description**—Provides a brief description of each component.
   - **Vendor**—Displays the manufacturer's name
   - **Availability (Available/Obsolete)**—Reserved for future use.
   - **License Information**—Indicates whether or not you have a license for the part(s) of interest. In the ADS 1.5 release, this field only applies to vendor parts.
   - **Web-site Address**—Reserved for future use.

**Hint** Two additional pieces of information (Lib-name and Placement Status) are available—on PC only at this time—if you manually resize the columns. Position the pointer within the bar containing the column headings (to the right of **Description**) and move it until the pointer changes into a double-ended arrow. Press and drag to expose the additional column(s).
• Lib-name—Lists the name of the library for each component listed. This can be helpful if you find a component by searching, and want to know which library it is from.

• Placement Status—Identifies for each component listed whether or not it is used in layout

2. Select column options as desired and click **Apply** (or OK, if done with this dialog box).

To set default widths (in characters) for the columns of component information:

1. Choose **Options > Preferences**.

2. In the Field Width section of the dialog box that appears, set each field as desired, and click **Apply**. Note that these settings serve as defaults, but the columns can be resized manually by dragging the cell border one direction or the other.

To change the Show/Hide status of obsolete or unlicensed components:

1. Choose **Options > Preferences**.

2. In the Show Components section of the dialog box that appears, set these options as desired, and click **Apply**.

To alphabetically sort a list of sub-libraries:

1. Highlight the library whose sub-libraries you want to sort.

2. Choose **Options > Preferences** and in the Sort Library section of the dialog box that appears, select the desired sorting method—ascending or descending—and click **Apply**. (Not Sorted is the default state.)

To alphabetically sort the list of components for a specific sub-library:

1. Highlight the sub-library whose components you want to sort.

2. Choose **Options > Preferences** and in the Sort Component section of the dialog box that appears, select the desired sorting method—ascending or descending—and click **Apply**. (Not Sorted is the default state.)

---

**Hint** You can also set the width of the Library pane through **Options > Preferences**.
Creating Designs

**Saving Customized Library Displays**

When you first open the Component Library—in any given session of ADS—the view of libraries is the Default view. This is the complete set of libraries as shipped. Changes you make to this view will persist during the current session, however, the next time you restart ADS, the Default view is restored. You can save any number of customized views and restore them later. By default, customized view files are saved to the current project directory, but you can save them in and restore them from any other project directory.

To save a customized view in the component library:

Choose View > Save View As. Supply a filename and click Save.

To open a previously saved customized view:

Choose View > Open View. Select the filename of the view you want to restore and click Open.

To close any currently open customized view:

Choose View > Close View. If no other customized views are open, the Default view is restored.

**Resetting and Updating the Library Display**

If during any given session, you cut libraries from the Default view and you want to restore them (without exiting and restarting ADS), you can do so with the Reset/Update command. This command will also update the library display with any libraries that were created through AEL.

To restore libraries cut from the Default view and/or update the display with new libraries:

Choose View > Reset/Update.

---

**Note** Some additional information is available for libraries and components through the Edit menu (Library Properties and Component Properties). These features will be enhanced in a future release.
Using the Component Palette

The palette, on the left side of each design window, is a quick method of placing components if you know the name of the library containing the component. To change the library of components on the palette, select a new one from the drop-down Palette List.

Hint: You can also bring the palette selection list up as a dialog box by selecting View > Component > Select Component Palette. Leave it on the screen if you want to change the palette frequently.

To use the Palette to place items:

1. Display the desired library on the palette by selecting it from the drop-down list (in this example, TLines-Printed Circuit Board).
Creating Designs

2. If necessary, scroll the new palette to locate the button representing the component you want to place.

Using Component History

As you place components in your design, a history of these components is created. This dynamically created history enables you to quickly place additional instances of components placed in the current session.

**Hint** This history serves as the starting point for creating a custom component palette. For details refer to, “Creating a Custom Component Palette” on page 9-33.

To place items from Component History:

1. Click to access the drop-down Component History list or bring up the dialog box (View > Component > Component History).

2. If necessary, scroll the list to locate the component you want to place.

**Hint** Once vendor components are placed, they are part of Component History which can be used to create a custom palette containing these vendor parts.
Placing Components at Specific Coordinates

The Coordinate Entry command enables you to place a component at specific coordinates. Pin 1 of the symbol is placed at the coordinates you specify.

To use the coordinate entry method for placing components:

1. Choose Insert > Coordinate Entry and a dialog box appears. Move the dialog box so that the desired design window is visible.
2. Select the component you want to place.
3. Select the desired orientation for this component.
4. Enter the desired X and Y coordinates in the dialog box.
   Enter coordinates by typing them directly in the fields labeled X and Y, or use the up and down arrows of the X Increment and Y Increment fields to increase or decrease the values of the X and Y fields. By default, the X and Y Increment fields are set to the current snap spacing, but you can use any increment that meets your design needs.
5. Click Apply and the component appears in the drawing area at the specified location.
Creating Designs

Rotating Components

You can specify the orientation, or rotation, of a component in the following ways:

- Prior to placing it in the drawing area, using the Insert menu (Insert > Component) or toolbar orientation button (each click rotates the item 90 degrees clockwise)
- After placing it in the drawing area, using the Edit menu (Edit > Rotate -90) or toolbar rotate button

To rotate a component prior to placing it, use any of the following methods:

- Click the Rotate By -90 button on the toolbar (each click rotates the item 90 degrees clockwise)
- Press <Ctrl>r (rotates the item 90 degrees clockwise)
- Choose Rotate -90 from the Edit menu
- Choose one of the Insert > Component > Set Component Orientation commands: UP, DOWN, LEFT, RIGHT. These directions refer to the direction the symbol is drawn relative to pin 1.

To rotate a component after placing it:

1. Select the component.
2. Click the Rotate button or choose Edit > Rotate 90. Pin 1 is used as the reference point. You are prompted to enter the offset location.
3. As you move the pointer, a ghost image of the component moves with it. Click to position it in the desired orientation.
Defining Parameters

As you place components in the drawing area, you will notice that some parameters have default values and that other parameters are followed by an equal sign (=) and nothing else. The lone equal sign indicates that a default value is defined elsewhere for this parameter. Some of these parameter values are defined by the simulator, while others are defined in various Simulation Control items. For details on where the default value is defined and to review the guidelines for choosing other values for that parameter, refer to the Circuit Components manual or the Signal Processing Components manual.

Note  The at symbol (@) must be used to suppress quotes when specifying a variable, for example, @freq1, where freq1 is a variable declared in a VAR item.

You can change parameter values using the on-screen editor or through the Component Parameters dialog box. To display the Component Parameters dialog box for editing parameters after placing components:

- Position the pointer over the component you want to edit and double-click
- Select the component and choose Edit > Component > Edit Component Parameters

Alternatively, you can specify parameters for each component as you create your design. By default, the option controlling the automatic display of the Component Parameters dialog box is turned off. To display the dialog box automatically when you select a component, select the option Component Parameter Dialog through Options > Preferences > Placement.

Hint  To keep the dialog box on your screen for editing parameters of many components, use the Apply button to effect changes for each component.

For details on the Component Parameters dialog box and using the on-screen editor, refer to “Editing Component Parameters” on page 6-2.
Creating Designs

### Measuring Distance and Angle

The Measure command produces a dialog box that displays the cumulative distance between points you specify in the design window. In addition, it displays the angle from the first point to the current point.

To use the Measure command:

1. Choose **Measure** from the Insert menu or the pop-up menu and a dialog box appears.
2. Click on the desired points in the design window and observe the information displayed in the dialog box.

   • To clear the information but keep the command active, click **Clear** or double click in the design window.
   • To stop the command and dismiss the dialog box, click **Cancel**.

### Connecting Components

When you place a component in the design area, you will notice that each of the pins is highlighted by a diamond-shaped outline. This shape identifies unconnected pins, and disappears when a connection is made.

There are three ways to connect components:

- Directly, pin-to-pin
- With wires
- With names
Connecting Components Directly

To connect components directly:

1. Select the desired rotation for the component you are about to connect.
2. Position the pointer directly over the pin of the component you are connecting to, and click.

Connecting Components with Wires

When you connect components with wires, you can use the Wire command or the Wire Route command:

- The Wire command works best when you are connecting two components close together, or when you are adding a wire that will be temporarily unconnected at one or both ends.
- The Wire Route command works best when other items lie between the connecting points and you must route the wire around these items.

To use the Wire command:

1. Click the Add Wire button or choose Wire from the Component menu. You are prompted to enter the starting point.
2. Position the pointer at the desired location and click. You are prompted to enter the next point.
3. Position the pointer at the desired location and click. A wire is drawn between the specified points.

Tips:

- To specify an endpoint of a wire on a pin, click once.
- To specify an endpoint of an unconnected wire, double-click or press the space bar.
- To move an unconnected endpoint of a wire, use Move Wire Endpoint.
- Wires are drawn on the current entry layer.
- Context-sensitive editing is available for wires with respect to changing the layer on which the wire is drawn. Position the pointer over the wire, right click, and select Wire Layer from the pop-up menu.
To use the Wire Route command:

1. Choose **Wire Route** from the Component menu. You are prompted to enter the starting point. Position the cursor on the pin (or wire) at one end and click. You are prompted to enter a node location to end.

2. Position the cursor on the pin (or wire) at the other end and click. A wire is drawn connecting the specified points, routed around items, as necessary.

- By default, wires are routed through component text. If you want wires routed around it, select the Route around component text option (Options > Preferences > Entry/ Edit).

- If the Route around component text option is selected, wires are routed 0.125 inches, by default (Schematic), away from items in the wire's path. To change the Wire Route distance (in schem/layout units or screen pixels) use Options > Preferences > Entry/ Edit.

**Hint**  Context-sensitive editing is available for wires with respect to changing the layer on which the wire is drawn. Position the pointer over the wire, right click, and select Wire Layer from the pop-up menu.
Connecting Components with Node Names

Assigning node names provides you with the following capabilities:

- Provide connectivity without wires. Two or more pins in the same network, with the same node name, are connected as if they were wired.
- Identify node voltages, in an Analog/RF network, that should be output to the dataset after simulation.

Note the following guidelines when assigning node names:

- If you assign a node name to a pin that is connected to a wire, all pins connected to that wire will display that name.
- To indicate connectivity, assign the same node name to two or more pins.
- To produce output from a single pin, assign a unique node name to that pin.
- For information on naming conventions, refer to “Naming Conventions” on page 1-20 in the User’s Guide.

**Hint**

Using the same node name in nodes across subnetworks does not result in connectivity unless a Global Node data item is placed in the design declaring that node name global. A Global Node data item with the specified node name will connect all nodes with that name across all subnetworks. This is useful for distribution of signals such as supply voltages and clocks.

To name a node:

1. Choose **Insert > Node Name** and a dialog box appears.
2. Enter a Name for the node and click all pins you want to connect or identify with this name. As you click each pin, the name you have supplied appears near the pin.
3. To name another node, supply a different name, and click each pin, as described above. To dismiss the dialog box, click **Done**.

To clear a node name:

1. Choose **Edit > Component > Remove Node Name**.
2. Click each pin of that should no longer be connected with that node name.
Creating Designs

Note To prevent potentially undesirable connectivity, node names are not retained—by default—during copy/paste operations. This behavior is controlled by the option Keep node names when copying, found in the Preferences dialog box.

Setting Connection Preferences
When a connection is made, the pin color changes to the color designated as the Connected Pin color (Options > Preferences > Pins/Tees). The color of the pin and the diamond-shaped outline prior to connection is the color designated as the Highlight color (Options > Preferences > Display).

Adding Ports to a Design
1. Click the port symbol on the toolbar (or choose Insert > Port).
2. Select the appropriate rotation by clicking the toolbar button (Rotate By -90) as needed.
3. Move the pointer into the drawing area, position the symbol as needed, and click to place it there.

Using Special Components
There are a number of commonly used components in ADS whose special features must be understood to be used successfully. Please review the following topics, and where applicable, the additional referenced topics:

• “Using Substrates” on page 3-23
• “Using Nonlinear Models” on page 3-24
• “Components that Allow File-Based Parameters” on page 3-25
Using Substrates

Substrates (such as microstrip, stripline, etc.) are specified by placing the required substrate component in your design and then setting the substrate parameter (Subst) of the associated circuit component(s) equal to the instance name of the substrate component.

In the following example, the substrate parameters of the MSub1 instance are associated with the Bend1 instance by assigning the instance name “MSub1” (of the MSUB substrate component) to the Subst parameter of the MBEND2 component.

Note that the default value of the substrate parameter Subst, as well as the default substrate instance name (in this example, MSub1), can be edited.
Using Nonlinear Models

A nonlinear model can be associated with a nonlinear device instance by placing the required nonlinear model item in your design and then setting the parameter Model of the nonlinear device equal to the instance name of the nonlinear model item. This is especially useful in a hierarchical design that contains multiple subnetworks, each of which should reference the same model. In this case, place the _Model item in the top-level design, and place an instance of the device in each of the subnetworks, setting their Model parameter equal to the Instance Name of the _Model item.

In the following example, the model parameters of the BJ TM1 instance are associated with the BJ T1 instance by assigning the instance name “BJ TM1” (of the BJ T_Model item) to the parameter Model of the BJ T4_PNP device.

![Diagram of nonlinear device instances](image)

Note: The default value of the Model parameter—for any given device—is the same as the default Instance Name of the related model (in this example, BJ TM1). The Instance Name of the model can be changed, like any other Instance Name. If you do, be sure to change the Model parameter (of instances referencing that model) accordingly.
Components that Allow File-Based Parameters

Several components, such as DataAccessComponent (DAC), Deembed, and the SnP components, enable you to set a parameter to reference a file-based set of values. For details on the file formats of the data file types, refer to Chapter 20, Data File Formats, in the Circuit Simulation manual.

To specify file-based parameters for these components:

1. Select the File parameter.
2. Select the appropriate Parameter Entry Mode: Data filename (DAC) or Network parameter filename (SnP, Deembed1, Deembed2).
3. Type the data filename, or Browse to select it. By default, only the files listed in the current / data directory are displayed.
4. Optionally, click Edit to display the file (in your default text editor) for modification.
5. Optionally, click Copy Template to copy a data file of a specific format for use as a template. This template can be a supplied template or one you have created. By default, the program looks in the following location:
   $HPEESOF_DIR/circuit/templates (for Analog/RF designs)
   or
   $HPEESOF_DIR/hptolemy/templates (for Digital Signal Processing designs)
Creating Designs

**Using the DataAccessComponent**

Many component parameters, as well as variables, can be assigned a value from a data file by using the DataAccessComponent (DAC). The basics of accessing file-based parameters are as follows:

- Add a DAC component to your design
- Set the File parameter of the DAC equal to the data file of interest
- Set the parameter of the component of interest to reference the DAC (by its Instance Name)

For details on setting the DAC’s parameters and some basic examples, refer to DataAccessComponent in Chapter 1, Introduction, in the Circuit Components manual.

**Using Macros to Automate Tasks**

You can record a macro (a series of AEL commands) by performing a sequence of commands using the mouse, and then play it back later to repeat the sequence.

---

**Note**  Not all commands/actions are supported in macro recording; therefore, we do not recommend relying on this for recording complicated command sequences, but rather as a tool for learning how to use AEL.

---

To record a macro:

1. In the Main window choose Options > Start Recording Macro and a dialog box appears.

2. Enter a name for your macro—the file extension .dem will be added automatically—and click OK.

3. Perform the desired sequence of commands.

4. When you are finished with the desired sequence, choose Options > Stop Recording Macro. The file is saved to your current project directory.
To play back a macro:

1. Choose Options > Playback Macro and a dialog box appears displaying the macro files in the current project directory (that match the filter).

2. Select the desired macro and click OK. (To run a macro stored in another project directory, adjust the path as necessary, select the macro from the list, and click OK.) The selected macro is executed.

**Viewing and Entering AEL Commands**

The AEL commands that are issued in response to your activity in the Main window and the design windows are displayed in the Command Line dialog box. This command summary is updated continuously as you work. You can view this summary any time and you can issue previously executed commands from this list.

To view the command summary:

Choose Options > Command Line in the Main window and the dialog box appears. As you execute commands, the corresponding AEL functions are displayed.

To execute AEL commands from this command summary:

- Type the command(s) in the Command >> field and press Return or click Apply after each to execute. (Note: All commands entered in the Command >> field must be in AEL format.)

  or

- Select a previously typed command from the list and press Return or click Apply to execute.

  or

- Double click any command in the list and the command is executed.

Click Cancel to dismiss the dialog box.

**Note** For configuration details on using AEL, refer to the AEL manual. For layout artwork and usage, refer to the Layout manual.
Creating Designs

Creating a Netlist

By default, every time you simulate a design, you generate a netlist file, netlist.log, in the current project directory, but it is possible to generate the netlist file without simulating the design.

To generate a netlist without simulating:

1. Open the desired Schematic.
2. Choose Options > Command Line in the Main window and the Command Line dialog box appears.

   **Hint** Replace the number 1, shown in parentheses in the next step, with the number of the window from which you want to generate a netlist. The number of the window is displayed in the titlebar.

3. Click in the Command >> field and type `set_window(1);` and press Return. Notice that what you type is echoed in the list above.
4. Click in the Command >> field and type `netlist();` and press Return or click Apply. After a short time, the netlist.log file is written to the project directory.

To use a different filename for any given project, you can insert the following line in the de_sim.cfg file in that project directory and specify a filename other than netlist.log.

   ```plaintext
   NETLIST_FILE_NAME=netlist.log
   ```

   **Important** If you edit your schematic after generating a netlist, you will need to generate the netlist again, since nodes may be renumbered as you edit.
Generating Reports

The Reports command enables you to generate a Bill of Materials (BOM) and a Parts List. Examples of a BOM and a Parts List are shown below.

---

Note  By default, you are supplied with one format for the BOM and two for the Parts List, but these formats can be customized, and additional formats added, through AEL. For details, refer to the AEL manual.

---

To generate a Bill of Materials:

2. By default, the design name and a .rpt.bom extension appear as the filename for the generated file. Accept this name or supply another and click OK. The file is displayed in a window on the screen.

![Figure 3-1. Bill of Materials Example](image)

3. To save it to file with the default filename, click OK; to save it to file with a filename of your choosing, click Print. Supply a filename and click OK.

To generate a Parts List:

1. Choose File > Reports > Parts List.
2. Choose the desired Report Type.
   - HP EEsOf (HP EEsOf PL format)—component name, ID, coordinates, angle, and side
   - HP EEsOf (netlist format)—component names and parameters
3. By default, a .rpt.pl (parts list) or .rpt.net (netlist) extension is automatically added to the filename. Accept this name or supply another and click OK. The file is displayed in a window on the screen. Figure 3-2 shows an example of the parts list format.

```
Parts list for: /networks/tee_atten Tue Mar 31 11:28:45 1998

<table>
<thead>
<tr>
<th>Component</th>
<th>Ref ID</th>
<th>X, Y,</th>
<th>ANG</th>
<th>SIDE</th>
</tr>
</thead>
<tbody>
<tr>
<td>R</td>
<td>R1</td>
<td>1, 0.5</td>
<td>0</td>
<td>top</td>
</tr>
<tr>
<td>R</td>
<td>R2</td>
<td>3.5, 0.5</td>
<td>0</td>
<td>top</td>
</tr>
<tr>
<td>R</td>
<td>R3</td>
<td>2.75,-0.125</td>
<td>-90</td>
<td>top</td>
</tr>
</tbody>
</table>
```

Figure 3-2. Parts List Format Example

Figure 3-3 shows an example of the netlist format.

```
Net list Tue Mar 31 11:49:33 1998

TOP LEVEL DESIGN: tee_atten
Design: tee_atten
Port P1 1
  Num=1
Port P2 4
  Num=2
GROUND G1 0
R R1 1 2
  R=10 Ohm
R R2 2 4
  R=10 Ohm
R R3 2 0
```

Figure 3-3. Netlist Format Example

4. Click OK to save it to file with the default filename. Click Print to print to file or to the printer, based on your current Print Setup. If the current Print Setup is
set to print to file, a dialog box appears prompting you for a filename. Supply a filename and click **OK**.
Creating Designs
Chapter 4: Creating Hierarchical Designs

You can use any network as a subnetwork within another network to create a hierarchical design. There are two ways to create a subnetwork:

- Use the Create Hierarchy command and specify a portion of an existing design to be copied to its own design file for use as a subnetwork
- Create a new design consisting of a network you want to use as a subnetwork

Hint To view design hierarchy in the current project, choose View > Design Hierarchies from the Main window.

To access a design in one project for use as a subnetwork in a design in another project, create a hierarchical project (File > Include/Remove, in the Main window). For details, refer to “Creating a Hierarchical Project” on page 2-9.

Note The Update Component Definitions command (Edit > Component) enables you to explicitly update component definitions (that you have changed) throughout the current design. If you select the Update Component Definitions in Subnetwork option, the design hierarchy will be traversed (downward) and components will be updated throughout the hierarchy.

Creating a Subnetwork from an Existing Design

The Create Hierarchy command copies the selected portion of your design to another file, saves that new file, deletes the selected items in the original file and replaces them with a default symbol representing the deleted items.

Hint You can create a custom symbol to use in place of the default symbol. For more information on assigning a custom symbol, refer to the section, “Assigning a Symbol to a Subnetwork” on page 4-13.

The example used to illustrate this command is based on a simple, 3-resistor attenuator that is part of a larger design. In this example, the main design is named
Creating Hierarchical Designs

main_design and the file created using the Create Hierarchy command (containing the 3-resistor attenuator) is named my_atten.

To create a subnetwork from an existing design:

1. Select the items you want to include in the subnetwork (represented here inside the box drawn with a dashed line).

2. Choose Edit > Component > Create Hierarchy and a dialog box appears.

3. Provide a name for the new file, in this example, my_atten, and click OK. (The name you supply is the filename for the subnetwork as well as part of the annotation for the symbol when you place it in a design—however, no annotation is displayed in this example.)

The selected items disappear from your original design and are replaced by a default symbol (in this example, a 2-port symbol). Wires are redrawn to reconnect the remainder of the design to the symbol.

4. Save the file. The design used in this example appears as shown next.
If you want to use this network as a parametric subnetwork in a hierarchical design, you must open this newly created file (my_atten.dsn) and define the parameters that you want to be passed from the subnetwork to the network.

To define parameters for an existing subnetwork:

1. Open the file containing the subnetwork design.
2. Choose File > Design Parameters and a dialog box appears.
3. Supply a parameter name (not to exceed 8 characters), and select the appropriate characteristics for that parameter.
4. When you are through assigning characteristics to that parameter, click Add and the newly defined parameter is added to the Parameters list box.
5. Continue in this manner until you have assigned all the desired parameters for this network and click OK.

For a more detailed discussion on defining parameters, refer to the section titled, “Defining Parameters” on page 4-8.

Creating a Parametric Subnetwork

Any network can serve as a parametric subnetwork. A parametric subnetwork is any network for which you define the control parameters that pass through to the network into which you place the subnetwork. Once you have defined the parameters, your subnetwork can serve as a template enabling you to assign parameter values each time you place it in a design. You can construct whole libraries of re-usable subnetworks in this manner.

While it is possible to turn any existing network into a parametric subnetwork (as discussed in the previous section), we recommend that you use the process described here to define the parameters prior to creating the network you intend to use as a subnetwork because if you define the control parameters first, they will appear for selection in a dialog box when you create your parametric subnetwork. But, if you create the subnetwork first, you must remember and type the names of all control parameters; you will not be able to select them from a list.

The details of this process are presented using a simple design consisting of a capacitor and a resistor in series and two ports. This subnetwork is called series_r_c and is represented by the default 2-port symbol.
Creating Hierarchical Designs

Creating a Parametric Subnetwork

File > Design Parameters

Create a design definition

Define the parameters

Create the subnetwork

Use default symbol or assign custom symbol

Place subnetwork within desired design

series_r_c

Port 1 C R Port 2
P1 C1 R1 Num=1
P2 C2 R Num=2

default 2-port symbol

main_network

Amp 1 Amp 2
series_r_c
poro_sub1 C=2 F

When you place the subnetwork within another design, you have the opportunity to assign values to any parameters you defined.
Creating a Design Definition

The first step in creating a parametric subnetwork is to define the characteristics of the subnetwork.

To create a file and define design characteristics:

1. Choose File > New Design in the Schematic window and assign a name, in this example, series_r_c. This name becomes part of the annotation for the symbol representing the subnetwork when you place it within another design.

2. Select Analog/RF Network as the Type of Network and click OK.

3. Choose File > Design Parameters and a dialog box appears. The current design name is reflected in the Name field at the top of the dialog box.

In the tab labeled General, you can change any or all of the default design characteristics. If the default design characteristics meet your needs, proceed to the next section, “Defining parameters.”

To alter the default characteristics:

1. The Description field displays the current design name by default. You can change this to a more helpful label defining the purpose of the network design. The label you provide here will be displayed, together with the design name, as a component to place from the designated library (Library Name field).

   Optionally, add a description, in this example, cap and res.

   ![Description](caption)

2. The Component Instance Name default is X. The text in this field is used as a prefix in building a unique name (ID) for every item. This prefix becomes part of the annotation displayed with the symbol representing the parametric subnetwork when you place it in a design.

   Optionally, assign a unique name, in this example, para_sub.

   ![Component instance Name](caption)

3. In the Library Name field, specify the name of the library in which you want the subnetwork stored. This library name is the name that appears in the Library
Creating Hierarchical Designs

Browser enabling you to select the subnetwork and place it in a design. There are several ways to specify a library name:

- Accept the default Library Name—an asterisk (*). This means the design will be available in the Component Library through the current project
- Type any name to create a new library
- Enter the name of any of the supplied libraries

Select a library name, in this example, a new library, `my_subnetworks`.

4. Turn on or off the following options, as required by your design.

- **Allow Only One Instance**—Specifies whether or not the subnetwork can be placed more than once in a design. The default is off, meaning the subnetwork can appear more than once in a design. Change to on if you want to restrict placement of the subnetwork to once per design (seldom done).
- **Include in BOM**—Specifies whether or not the details of this design are included when a BOM is generated. Without this option, only the top level design information is included in the BOM.
- **Layout Object**—Analog/RF designs only. Defines the design as an object. Layout objects have no parameters and are used to assign artwork to new elements or designs with no default artwork. For details, refer to the Layout manual.
- **Simulate from Layout (SimLay)**—Analog/RF designs only. The netlist required for simulation is generated from either the Schematic or the Layout. Select this option to generate the netlist from the Layout.

The SimLay portion of this label will appear in the Status panel of the Schematic and Layout windows if you select this option; the default is to simulate from the Schematic, and the Status panel reflects SimSchem.
5. Layout only—select the appropriate Simulation method:

- Select Subnetwork, to use a schematic symbol you have created
- Select Built-in Component, to use a supplied simulator item.
  
  Simulate As—Select a component name from the drop-down list, or type the name of any component

  Copy Component’s Parameters—Select this option to copy the parameters of the selected component to use as a starting point

- Select Not Simulated, to create layout- or schematic-only non-simulated items

6. Analog/RF layout designs only—select the appropriate artwork Type:

- Select Synchronized if the artwork for the network can be found in the design file itself. This is most useful when the artwork of a network is dependent on schematic components. When you choose Synchronized as the artwork type, the program will regenerate the artwork accordingly.

- Select Fixed if the artwork for the network is in a separate file. Select or type the Name of the artwork file to be associated with this subnetwork.
Creating Hierarchical Designs

- Select AEL Macro if the layout is represented as an AEL function and select or type the Name of the AEL macro to be associated with this subnetwork.
- Select None if no artwork is going to be generated or no artwork is going to be used in synchronizing the schematic with layout objects.

7. Click **Save AEL file** to save the information defined so far. (This is done automatically when you save the design file.)

**Defining Parameters**

When you define parameters for a network, the network serves as a template, enabling you to assign new parameter values each time you use the network. This is useful when a portion of the network is used several times in a design with certain element value differences, or in constructing libraries of reusable networks.

Parameters of the network are generally referenced as variables by the elements of the network. You can define the parameters before or after creating these variable references. When placing or editing elements in the network, a list of defined parameters and other variables can be displayed. So, if you have not defined and placed the elements and their variable references first, you will have to type the intended name of the parameter, rather than pick it from a list when assigning values to element parameters.

Each parameter has characteristics that determine how it is handled when the network is reused. These include the name and label displayed in the Item Parameters dialog box, the unit of the parameter, the type of value assigned to the parameter, the default value, and certain control attributes.

To define the parameters that should be passed to the upper-level network:

1. Click the **Parameters** tab.
2. Optionally (Analog/RF designs only), you can click **Copy Parameters From** as a shortcut for defining parameters, if one of the supplied components has a number of parameters in common. You can then cut any unwanted parameters, as well as modify the characteristics of the remaining parameters.
3. The Parameter Name field contains the parameter name that will be referenced in the subnetwork schematic. Parameter names become part of the annotation of the symbol representing the parametric subnetwork when you place it in a design.

Supply a Parameter Name (not to exceed 8 characters), in this example, C.
4. Select a Value Type from the drop-down list, in this example, **Real**.

5. Specify a Default Value, in this example, 5. This value can be changed at the time you place the subnetwork.

**Hint** If you do not specify a scale factor along with the default value, the current setting in the Preferences dialog box is used (Options > Preferences > Unit/Scale), based on the Parameter Type.

6. Optionally, select a Parameter Type for this parameter, in this example, **Capacitance**. This can be a dimensional unit or a string for the parameter, if one is needed. (String is used for assigning SMT artwork in layout.)

7. Optionally, supply a Parameter Description.

8. Select any of all of the following options, as they apply. Note that some options are desensitized depending on the current Value Type.
Creating Hierarchical Designs

- Display parameter on schematic—Select this option to display, on the schematic, the parameter being defined.
- Optimizable—Select this option to allow this parameter to be optimized.
- Allow Statistical Distribution—Select this option to allow post-production tuning for this parameter during yield analysis.
- Not edited—Select this option to prevent this parameter from appearing in the Component Parameters dialog box for editing and always use the default value assigned here instead.
- Not netlisted—Select this option to prevent a parameter from being considered in simulation, but still be recognized for artwork generation.

9. Click Add to add the newly defined parameter to the Select Parameter list box. The parameter C is added to the Parameters list box.

- Use Add to add a new parameter to the list
- Use Cut to delete parameters
- Use Cut and Paste buttons to rearrange the order of the parameters.

10. Continue defining parameters for the subnetwork in this manner. When you are through defining parameters, click Save AEL file and click OK.

11. Optionally (Analog/RF designs only), you can click Add Multiplicity Factor (_M) to enable simulation of this subnetwork as though it were x number of these subnetworks—connected in parallel—where x is the value you assign to the parameter _M.

Creating the Subnetwork

Once you have defined subnetwork control parameters, you can place schematic items in the Schematic window to create the subnetwork. By defining control parameters first, you have a greater selection of value options for the components you will be placing in your subnetwork.

To create the subnetwork:

1. Click the Library button and select a category, in this example, Lumped Components.
2. Select a component, in this example, C (Capacitor).

3. Place the capacitor in the Schematic window. Note the component parameter C is set equal to the default value of 1.0 pF. Click the Cancel Command button.

4. Click the capacitance value to invoke the on-screen editor and use the Back Space key to erase the 1.0 pF.

5. Type C and press Return. The parameter now reads C=C. (This is the C parameter defined in the Design Definitions dialog box and serves as a variable here.) The parameter C (capacitance) of this element will now pass through to the network in which it is placed.

6. Place the next element, in this example, R (Resistor), accepting the default values. Connect it to pin 2 of the capacitor symbol.

7. Add ports. The subnetwork should resemble the illustration shown next.

8. Click the Cancel Command button.


10. Notice (in the General tab) that the Symbol Name field reads SYM_0Port. Select SYM_2Port to assign the default 2-port symbol to the subnetwork.

   **Hint** Clicking the Save AEL file button will select SYM_2Port for you. When you explicitly save the AEL file, the program determines how many ports the current design contains and updates this field accordingly.

11. Click OK to close the dialog box and then save the network by choosing File > Save Design.
Placing the Subnetwork in a Design

Now you can place the subnetwork you just created into another network. The parameter you assigned (capacitance in this example) will pass through to the network.

To place a subnetwork:

1. Open the file containing the network in which you want to place the subnetwork (in this example, main_network—not shown).
2. Click the Library button (or choose Insert > Component > Component Library).
3. In the Component Library window, locate the Subnetworks folder and note the following libraries listed under it:
   - The current project
   - If the current project is hierarchical, the included projects (refer to “Creating a Hierarchical Project” on page 2-9)
   - User-defined libraries (created through the Design Parameters dialog box)
4. Select the name of the library containing the design, in this example, my_subnetworks.
5. Select the subnetwork, in this example, series_r_c (cap and res), and place it in the drawing area. Click Cancel Command.
   Notice that C = 5 F. This 5 is the value from the Default Value field (for the parameter C) in the Design Definition dialog box. Because we did not specify a scale factor, the default F (Farads), from the Preferences dialog box is used (Options > Preference > Unit/Scale).
6. Using the on-screen editor, change the default capacitance value to the desired value for the current design, in this example, 2. Press Return.
You can create a custom symbol and assign it to a design. For information on assigning a symbol to a subnetwork, refer to the section, “Assigning a Symbol to a Subnetwork” on page 4-13.

Modifying a Design that Serves as a Subnetwork

If you make changes to a design—that affect the component definition(s)—that serves as a subnetwork in a higher-level design, you need to explicitly update the higher-level design to recognize those changes.

To update a higher-level design that contains a modified subnetwork:

1. From the higher-level design, choose Edit > Component > Update Component Definitions.
2. To traverse the hierarchy (downward) in search of any subnetwork designs whose component definitions have been changed, select the option Update Component Definitions in Subnetwork and click OK. Changes to any subnetwork designs are now reflected in the instance(s) in the main design.

Assigning a Symbol to a Subnetwork

If you want to use a custom symbol to represent a subnetwork, you can do one of following:

• Create a symbol in the design file that contains the subnetwork itself. This symbol will only be available to represent this subnetwork.

• Create a symbol in a file that contains nothing but the symbol. This symbol can then be used to represent any design.

The illustration that follows represents the difference between these methods.
Creating Hierarchical Designs

Important  The symbol you draw must contain the correct number of ports with respect to the design in which you intend to place the subnetwork.

To assign a custom symbol to a subnetwork:

1. Open the file containing the subnetwork.

2. Choose File > Design Parameters and a dialog box appears.

3. In the Symbol Name field, select a symbol from the drop-down list or type the name of the symbol you would like to represent the subnetwork.

   • If the symbol is in the same file as the subnetwork, use the filename (minus the .dsn extension).

   • If the symbol is in a different file, use that filename (minus the .dsn extension).
Note  By default, several commonly used symbols are available (on the drop-down list) for you to choose from. You can use AEL to add to this list any other default symbols supplied, as well as any symbols you have created. For details on adding symbol names to this list, refer to the section, Modifying the List of Available Symbol Names in the Customization manual.

4. Click OK to dismiss the dialog box and choose File > Save Design.

Now that you have inserted a reference to a custom symbol to represent the subnetwork, you must delete the subnetwork in the main design and place it again for the new symbol to appear.

To replace the default symbol with the custom symbol:
1. Open the design that contains the subnetwork.
2. Select the default symbol and delete it.
3. Click Library and select the appropriate Library Name, for example, my_subnetworks, and then select the name of the subnetwork.
4. Place the symbol in the design and redraw wires or move design elements, as necessary.

Viewing the Network Represented by a Symbol

Whenever your design contains a symbol that represents a network, you can view the actual network being represented by the symbol by using the Push Into Hierarchy command.

To push into and then pop out of an item:
1. Select the item.
2. Choose View > Push Into Hierarchy. The network represented by the symbol is displayed.
   The Pop Out of Hierarchy command is the reverse of pushing, and only works if a design has been pushed into.
3. When you are through viewing the network, choose Pop Out of Hierarchy and you are brought back to the item (or design containing the item).
Placing a Design as a Subnetwork

You can also use the Component Library window to access user-defined libraries and select a design for use as a subnetwork. This facilitates hierarchical design creation, enabling you to select a design from this list and place it as a subnetwork in the current design.

To place a design as a subnetwork:

1. Choose Component > Component Library.
2. Select the project or custom library name.
3. Select the design and move the pointer into the drawing area to place it.
Chapter 5: Viewing Designs

The View menu commands enable you to change the current view of the drawing area to aid you in working with the image in the window. Additionally, there are a number of commands on the Options menu that display various aspects of design information.

- “Zooming In and Out” on page 5-1
- “Repositioning a Design to Fit the Window” on page 5-2
- “Moving the Center Point of a Window” on page 5-2
- “Redrawing the View in a Window” on page 5-3
- “Saving and Restoring Views” on page 5-3
- “Viewing Design Information” on page 5-4

Zooming In and Out

The Zoom commands enable you to enlarge or shrink the area being viewed. Zoom Window enables you to specify your own view window for zooming, if the other zoom commands do not meet your needs.

To zoom in on a specified point in the window:

Choose Zoom In Point.

Click to specify a point and the current view is magnified by a factor of two, moving the point you specify to the center of the window.

To zoom out from a specified point in the window:

Choose Zoom Out Point.

Click to specify a point and the current view is decreased by a factor of two, moving the point you specify to the center of the window.

To specify a particular factor by which to zoom:

Choose Zoom By Factor and choose the appropriate command.

- Zoom In x2 (zooms in by a factor of 2)
- Zoom Out x2 (zooms out by a factor of 2)
- Zoom in x5 (zooms in by a factor of 5)
Viewing Designs

- Zoom Out x5 (zooms out by a factor of 5)
- Zoom In by . . . (and specify the desired factor)
- Zoom Out by . . . (and specify the desired factor)

To specify a particular portion of the view for zooming:

1. Choose Zoom Area. You are prompted to enter the first corner.
2. Move the cursor to the point representing the upper-left corner of the desired view window and click left. You are prompted to enter the second corner. As you move the mouse, a flexible box, representing the view window, moves with it.
3. Move the cursor to the point representing the lower-right corner of the desired view window and click left. The portion of your drawing enclosed by the view window is magnified. (The magnification amount is determined by the size of the view window you specified.)

Repositioning a Design to Fit the Window

To rescale and reposition your design so that it all fits in the window:

Choose View All. Your design is scaled as needed and repositioned to fit it all, plus a five-percent border, in the viewing area.

Moving the Center Point of a Window

The Pan command moves a point you specify, to the center of your window. Alternatively, you can use the scroll bars to move a different part of the window to the center.

To change the center point:

1. Choose Pan View from the View menu or the pop-up menu. You are prompted to enter the new window center.
2. Click once and the selected point becomes the new center point of the window. Your design is redrawn accordingly.
Redrawing the View in a Window

The Redraw View command refreshes the image in your window without changing anything. Choose Redraw View from the View menu anytime you make changes and see that an image is not completely drawn.

Saving and Restoring Views

It is possible to save multiple views of your design at various zoom settings.

- **Save View** enables you to save the current zoomed or panned view with a name
- **Restore View** enables you to retrieve a saved view
- **Delete View** enables you to delete a saved view
- **Restore Last View** enables you to restore the view that was in the window the last time you issued a Pan or Zoom command

To save the current view:

1. Choose **View > Save View**. A dialog box appears.
2. Supply a name for the view and click **OK**.

To restore a view that has been saved:

1. Choose **View > Restore View**. A dialog box appears.
2. Supply the name of the view you want and click **OK**.

To delete a view that has been saved:

1. Choose **View > Delete View**. A dialog box appears.
2. Supply the name of the view you want and click **OK**.

To restore the view that was in the window the last time you issued a Pan or Zoom command:

Choose **View > Restore Last View**.
Viewing Design Information

You can display a variety of design information using commands found on the Options menu:

- **Hierarchy** displays a listing of the hierarchical information of the current design in the Schematic and Layout windows.
- **Info** displays a detailed listing of design information including current units, preference and layer file associated with design, instances by name and ID, mask layer information, and a summary.
- **Identify** lists detailed data for selected instances, shapes, or text.
- **Check Representation** provides information on unconnected pins, port vs. pin mismatch, and nodal mismatch.

Viewing Detailed Design Information

The details on closed shapes include area, perimeter, and layer; for text, it includes the string and font attributes; for polylines it includes length. For components, the Name, ID, X, Y location, fixed/free status and equivalent element are displayed. A short summary is included that shows the number of items and shapes, the layers used, and the total selected area, length and perimeter.

To display detailed information for selected items:

1. Choose **Options > Info** and the Information dialog box appears.
2. To view details on items not selected initially, select and click **Refresh**. The information is updated to display details of the newly selected item(s).
3. Optionally, click **Print** to send the information to your default printer.
4. Click **OK** to dismiss the Information dialog box.

Viewing Detailed Instance Information

To display detailed information for selected instances:

1. Choose **Options > Identify** and a dialog box appears.
2. To print the information, click **Print** and it is sent to the default printer.
3. Click **OK** to dismiss the dialog box.
Viewing Hierarchical Design Information

There are two different ways to view hierarchical design information:

- At the design level, for the current project (View > Design Hierarchies, in the Main window)
- At the component level, for the current design (Options > Hierarchy, in the Schematic and Layout windows)

To view design hierarchies for the current project:

1. In the Main window, choose View > Design Hierarchies.
Viewing Designs

If the project contains more top-level designs than can be displayed at one time, the arrows on either side of the tabs enable you to cycle through the remaining top-level designs to select the one you want.

2. Double-click any design to open it.

To view the component hierarchy information for the current design:

1. Choose Options > Hierarchy and the Hierarchy dialog box appears.

Hierarchical levels are indicated by the level of indentation in the list. Top level items are not indented; each nested level is indented with two spaces.

2. Click Print to send the information to your default printer.

3. Click OK to dismiss the Hierarchy dialog box.

Viewing Connectivity Information

The Check Representation command provides access to information about any of the following characteristics of your design:

Schematic and Layout:

- If you select Unconnected pins, it displays the total number of unconnected pins, and for each item with an unconnected pin, lists the component name and ID, the pin number and coordinates of the unconnected pin. The affected items are highlighted in the design window.

- If you select Nodal mismatches (layout vs schematic), it reports items that are connected differently in one representation than they are in the other. The report lists the name of the item, the pin that is connected differently and what the pin is connected to. The affected items are highlighted in the design window.

- If you select Overlaid components, it reports the IDs of any overlapping items where the items contain the same number of pins and pin 1 of each item is placed in the same location.

- If you select Overlap wires (Overlap wire/ traces in layout), it highlights any wires (or traces) that overlap, that are not part of the same node.
Schematic only:

- If you select Component pin vs Symbol port mismatches (instance level) it reports a discrepancy between the number of pins on the symbol representing an instance of a subnetwork and the number of ports on the schematic it represents.

- If you select Rep port vs Symbol port mismatch (schematic level) it reports a discrepancy between the number of ports on the schematic representation and the number of pins on the symbol representing it.

Layout only:

- Wires in layout reports all items connected to pins that are interconnected with a wire, or a zero-width trace

To view this information:

1. Choose Options > Check Representation and a dialog box appears.
2. Select the desired information category (or categories) and click OK. A dialog box appears displaying the requested information.
3. Click Print to print the report, if desired.
4. Click OK to dismiss the report dialog box.
Chapter 6: Editing Designs

While editing, keep in mind that most edit commands allow you to select the item(s) before you select the edit command, or vice versa. Take note also that many editing commands are repeating commands, that is, once the command is chosen, it remains active until another command is chosen or until it is explicitly canceled (Edit > End Command).

You will find it easier to edit your designs if you understand some of the features provided to assist you in selecting the item(s) you want to edit. While there are several features available to assist you in selecting objects for editing, there are three distinct features you should know about:

- Using Selection Filters
- Changing the Pick Box Size
- Setting the Selection Status of Items Layer-by-Layer

These and other design entry and display preferences are described in Chapter 9, Setting Design Environment Preferences.

Using the Undo Command

Selecting Undo undoes the last editing command. A stack of edit commands is created enabling you to choose Undo repeatedly to return to an earlier state of your design. A stack is maintained for each window, thus the Undo command works independently from window to window. You can specify the number of commands you want the stack to hold through Options > Preferences > Entry/ Edit, Undo edit count.

Hint  You can also press <Ctrl > u to issue the Undo command.

Deleting Items

To delete selected items, click the Delete button on the toolbar, or press the Delete key on the keyboard, or choose Delete from the Edit menu. Deleted items can be restored using the Undo command.
Editoring Component Parameters

There are several methods for changing component parameters. The simplest methods involve editing parameters for individual components:

- Using the on-screen editor
- Using the component parameter dialog box

Additional methods that accommodate editing parameters in specific situations are:

- Searching for a particular parameter—a parameter whose value is stated as a reference to another component (Search/Replace Reference)—and then replacing that parameter throughout the design
- Changing the value of a particular parameter common to components throughout the design (Group Edit Parameter Value)

Note: The at symbol (@) must be used to suppress quotes when specifying a variable, for example, @freq1, where freq1 is a variable declared in a VAR item.

Editing Component Parameters On-screen

You can use on-screen parameter editing to change parameter values. In addition, you can change the Value Type from nominal to variable, and vice-versa. If you need to change a parameter's Value Type to anything other than nominal or variable, refer to the next section, "Editing Component Parameters Through the Dialog Box" on page 6-3.

Hint: When you click the component name, you initiate the Swap Components command.

To edit one or more parameters for a component using the on-screen method:

1. Position the pointer over the parameter you want to change and click. The editable portion of the parameter takes on the current Highlight color (Options > Preferences > Display). You will also see that a vertical bar (|), representing a text insertion cursor, appears in the parameter line.
2. Use the mouse, arrow keys, and backspace key as necessary, to change the parameters.

3. To end the parameter editing command, move the pointer away from the component and click once. (If the parameter is the last one in a list of parameters or is the only parameter for this component, pressing Return also ends the command.)

**Hint**  When editing several parameters for one component, you can click each individual parameter you want to edit, or you can press Return as many times as needed to get to the next parameter you want to edit. Pressing Return for the last parameter in the list ends the parameter editing command.

---

**Editing Component Parameters Through the Dialog Box**

Despite variations for some components, certain basic guidelines apply to completing the component parameters dialog box for most components. Note the following features of this dialog box:

- The input fields change based on the individual parameter selected.

- A default ID for a given instance of a given component appears in the **Instance Name** field. This ID is unique for every component in the design. You can use the default name or supply any name of your choosing.

- Some parameters offer the ability to use data from a referenced data file. For details refer to the section, “Components that Allow File-Based Parameters” on page 3-25.

- You can turn the display of individual parameters on or off. You can also use Component Options to set or clear the display of all parameters for the component at once. For details, refer to the section, “Changing the Visibility of Component Parameters on a Schematic” on page 6-5.

- For details on Optimization/Statistics Setup, refer to the section Specifying Component Parameters for Optimization in Chapter 2, Performing Nominal Optimization, in the Tuning, Optimization and Statistical Design manual.
Editing Designs

To edit one or more parameters for a component through the dialog box:

1. Choose one of the following methods for displaying the dialog box:
   - Choose Edit > Component > Edit Component Parameters and click the component symbol.
   - Click the Edit Component Parameters button on the toolbar and click the component symbol.
   - Double-click the component symbol.

2. Select the parameter you want to change from the Select Parameter list box.

**Hint** Use the following shortcut to edit parameters for most or all components: select everything in the drawing area (Select > Select All) and choose Edit > Component > Edit Component Parameters. Click Apply to accept parameter changes for one component, and another component is displayed for editing.

2. Select the parameter you want to change from the Select Parameter list box.
3. Type the new value in the parameter value editing field.

4. Press **Return**. The Parameters list box is updated to reflect the new value and the value of the next parameter is displayed for editing.

5. When you are through editing parameters, click **OK** to dismiss the dialog box.

**Changing the Visibility of Component Parameters on a Schematic**

You can change the visibility status of all parameters of a given component through the Component Options dialog box (accessed through the component parameters dialog box).

- **Set All**—Displays all parameters for this component on the schematic. Use this option to display all, or almost all, parameters for this component. To display most—but not all—parameters, select **Set All** and then go back and turn off the display of individual parameters as desired.

- **Clear All**—Clears the display of all parameters for this component from the schematic. Use this option to turn off the display of all, or almost all, parameters for this component. To display a small subset of parameters, select **Clear All** and then go back and turn on the display of individual parameters as desired.

**Referencing VAR Data Items and Model Items in Hierarchical Designs**

The **Scope** option applies to the VAR (Variables and Equations) data item and most model items (such as R_Model, BJ T_Model, BSIM3_Model). Exception: it does not apply to multilayer models. Scope indicates the levels, from a hierarchical standpoint, that recognize the expressions defined in the VAR data item or model item.

- **Nested**—VAR or model item expressions are recognized within the design containing the VAR or model item, as well as within any subnetworks (designs at lower levels) referenced by the design containing the VAR or model item.

- **Global**—VAR or model item expressions are recognized throughout the entire design, no matter what level in the design hierarchy the VAR or model item is placed.
Editing Designs

Editing Common Parameters for a Group of Items

The Group Edit Parameter Value command enables you to select a group of components with one or more common parameters, select a parameter that applies to them all, and change that parameter’s value for all selected components.

To edit every occurrence of a parameter for selected components:

1. Select all components containing the parameter you want to edit.
2. Choose Edit > Component > Group Edit Parameter Value and a dialog box appears.
3. Click Name Options and a dialog box appears listing all parameters in your design by name.
4. Select the desired parameter from this list and click OK. The selected parameter appears in the Parameter Name field.
5. If the value type of the selected parameter is numeric, type the new value in the Parameter Value field; otherwise, click Value Options and a dialog box appears. The contents of the dialog box vary depending on the value type of the chosen parameter.

Note You can only change the nominal value of the parameter, not the Value Type.

6. Select the desired parameter value and click OK.
7. Click Apply in the Group Edit Parameter Value dialog box (or click OK if you are through with this dialog box) and the design is updated accordingly.
Breaking Wire Connections Between Components

To break connections:

1. Select the component(s) whose connections you want to break.
2. Choose Edit > Component > Break Connections. The interconnections of selected components are deleted.

Swapping Components

The Swap Components command enables you to select any number of components, with any number of ports, and replace them all with another component.

To swap components:

1. Select all components you want to replace.

    **Hint** Use the Select > Select By Name command to quickly select every component of a particular type.

2. Choose Edit > Component > Swap Components and a dialog box appears.
3. Click Select and the Component Library window appears.
4. Select the appropriate library and desired component. The component name appears in the New Component Name field of the dialog box.
5. Click Edit Parameters and the component parameters dialog box appears.
6. Change any parameters as desired and click OK.
7. To keep the IDs of the original components, select the option Keep the original component ID(s); to let the program replace the IDs with new ones, deselect this option. Click OK. All selected components in the design window are replaced by the new component with the specified parameters.

Searching and Replacing References

The Search/Replace Reference command enables you to replace every occurrence of a parameter value where that parameter value is a reference, such as a reference to a data item. For example, if your design contains two MSUB data items, MSUB1 and MSUB2, you can replace every reference to MSUB1 with a reference to MSUB2 instead. You can replace references to data items or variables.

To search and replace references to data items or variables in your design:

1. Choose Edit > Component > Search/Replace Reference and a dialog box appears.
2. Select the desired Reference Type, Component or Variable.
3. Under the heading Search For, click Select and a dialog box appears. The listing varies according to the selected reference type.

   **Hint** To highlight these references prior to replacing any, use the Search Only option and click Apply.

4. Select the Instance Name or Variable name representing the item you want to search for and click OK. The selected reference appears in the Search For field.
5. Under the heading Replace With, click Select.
6. Select the Instance Name or Variable name representing the desired replacement and click OK. The Replace With field is updated.
7. Click Apply (or OK if you are through with the Search/Replace dialog box). All occurrences of the selected reference are updated in your design.
Moving Component Text

You can reposition the component text, collectively, of any component with the Move Component Text command. In addition, you can change the layer assignment of individual pieces (Name, ID, Parameters) with the Change Component Text Layer command.

To move component text:

1. Choose Edit > Move > Move Component Text. You are prompted to enter a reference location.
2. Click the component whose component text you want to move. You are prompted to enter an offset location.
3. As you move the pointer, a ghost image representing the component text moves with it. Click again to reposition the component text in the new location.

**Hint** The function key F5 initiates the Move Component Text command. Press F5, click the component symbol, move the pointer and a ghost image of the component text moves with it. Position the image in the desired location and click again to place it there.

To change the component text layer:

1. Choose Insert > Entry Layer and select the desired destination layer from the list.
2. Choose Edit > Component > Change Component Text Layer.
3. Click any individual piece (Name, ID, Parameters) of component text. Its layer is changed to the current entry layer and the component text immediately takes on the characteristics of the current entry layer.

**Note** To change the layer on which component text is placed in advance of placing components, use Options > Preferences > Component Text to specify the desired layer for each type of component text. For details, refer to the section, “Setting Component Text Options (in Advance)” on page 9-15.
Changing Component Text Attributes

You can change the attributes of existing component text through the Edit menu. This command only affects existing component text. To establish attributes for all subsequent component text, specify the desired settings through Options > Preferences > Component Text. For details on changing text you have added to your design, refer to “Editing Existing Text and Text Attributes” on page 6-36.

To change component text attributes:

1. Select the components whose component text you want to edit.
2. Choose Edit > Component > Component Text Attributes.
3. Make any desired changes to the text attributes.
   - Font Type—All True Type fonts (Schematic only) installed on your system are available. Select the desired font from the drop-down list.
   - Point—Represents the size of text in traditional units used in printing.
   - Parameter Rows—The maximum number of rows of parameters before another column is created.

   Note. On UNIX, if you want to add additional True Type fonts that were not supplied with ADS, copy them to $HPEESOF_DIR/lib/fonts.

4. Click OK and the component text is immediately updated to reflect the changes.
Editing Symbol Pins

The Symbol Pin command enables you to change the name, number, and orientation angle of existing pins.

To edit characteristics of existing pins:

1. Select a pin for editing and click Edit > Symbol Pin. A dialog box appears.
2. Change any of the characteristics as desired and click Apply (or click OK to accept the changes and dismiss the dialog box).

For details on pin characteristics, refer to, “Adding Pins to Your Symbol” on page 10-7.

Selecting and Deselecting Items

While you can always use the mouse to select and deselect items, several commands found on the Select menu can assist you in selecting and deselecting items more quickly.

Note
Only objects on selectable layers can be selected for editing. If the select status (Sel) of a given layer is disabled (through the Layer Editor dialog box), the select commands have no effect on items on that layer.

Selecting/Deselecting All Items in the Drawing Area

To select all items in the drawing area:

Choose Select > Select All. Boxes are drawn around all items (that match the filter selection) showing that they are currently selected.

To deselect all selected items that match the filter selection:

Choose Select > Deselect All
or click anywhere inside the window, away from the selected objects.
Selecting/Deselecting Items by Name

The commands Select By Name and Deselect By Name ignore the selection filters.

To select items by name:

1. Choose Select > Select By Name. A dialog box appears. By default, a list of each type of item in the design is displayed by Component Name. You can also view a list of individual items by selecting by Instance Name. The following illustration shows the listings of a simple network.

2. Select the desired list type and click the item(s) from the list that you want to select. Click Apply. The specified items are selected in the design window.

If you have a very long list of components, you can use the wildcard field to filter the list for items of the same type. For example, to list all transmission line elements in the design, type TLIN (for a listing by Component Name) or TL* (for a listing by Instance Name), and click Apply.
To deselect items by name:

1. Choose Select > Deselect By Name and a dialog box appears. By default, a list of each type of item selected in the design is displayed by Component Name. You can also view a list of individual selected items by selecting by Instance Name.

2. Select the desired list type and click the item(s) from the list that you want to deselect. Click Apply. The specified items are deselected in the design window.

**Hint** Alternatively, you can use the wildcard field to filter the list for selected items of the same type. For example, to list all selected transmission lines in the design, type TLIN (for a listing by Component Name) or TL* (for a listing by Component ID), and click Apply.

---

**Selecting/Deselecting With a Selection Window**

You can include several objects at once for selection/deselection by enclosing them in a selection window.

To select items using a selection window:

1. Position the pointer at one corner of a window that will enclose the desired items, and press the left mouse button.

2. As you move the mouse, keeping the button depressed, a ghost image of the selection window is drawn. Release the button to specify the opposite corner of the window. All items totally enclosed within the selection window, that match the filter selection, are now selected and are identified by taking on the Select color chosen under Option > Preferences.

To deselect items using a selection window:

1. Choose Select > Deselect Area.

2. Draw a selection window enclosing the items you want to deselect. All items in the selection window (that match the filter selection) are deselected.
Editing Designs

Using the Vertices Filter

By default, the Vertices filter is turned on. This means that when you use a selection window to encompass a portion of a given shape, the shape itself is not selected, but rather only the vertices that fall within the selection window. To modify this behavior so that individual vertices are not selected when you click an individual vertex or use a selection window, turn off the Vertices filter through Options > Preferences > Select.

The illustration that follows shows what happens when the Vertices filter is on, you draw a selection window enclosing parts of shapes on two different layers, and then choose Edit > Move > Move Using Reference.

![Diagram showing before, during, and after states of vertices selection](image)

**Hint** When the Vertices filter is turned on, all selected vertices are identified by a marker. You can change the size of this marker with the Selected Vertex option through Options > Preferences > Select.
Copying and Pasting Items

There are several Copy commands that enable you to copy and paste items in different ways:

- **Cut**—Enables you to delete one or more items from one window, and paste in another window.

- **Copy**—Enables you to copy items in a given design window and then paste those items within the same design window or another design window. On the PC only, it also copies the items to the Windows clipboard enabling you to paste the item(s) as a graphic in a Windows application.

**Hint** To enable pasting the item using coordinates as the reference point, choose Options > Preferences > Entry/ Edit and select the option Show Set Paste Origin Dialog for Copy command.

- **Paste**—Enables you to paste items that you previously cut or copied

**Advanced Copy/Paste**

- **Copy Using Reference**—Enables you to copy selected items, prompting for a reference point and a destination point. The copied items can then be placed anywhere within the same design window.

- **Copy Relative**—Enables you to copy items a specified distance from the original items

- **Copy To Layer**—Enables you to copy items from one layer to another, within the same design window

- **Step And Repeat**—Enables you to create a copy in the form of an array, with the number of rows and columns you specify

To copy an item and paste it on the same layer:

1. Select the item(s).

2. Choose **Edit > Copy** (or click the **Copy** button on the toolbar).

   If you enabled the aforementioned option, Show Set Paste Origin Dialog for Copy command, a dialog box appears enabling you to specify a reference point for pasting. (The default reference point for pasting a component, or group of components, is the first unconnected pin; when pasting shapes, the default...
Editing Designs

reference point is the lower left corner.) Specify the X and Y coordinates. (These are the positional coordinates identifying the position of the pointer in relation to the total window.) Click OK.

3. Choose Edit > Paste from the desired design window. As you move the pointer, a ghost image of the copied item moves with it.

4. Click again to specify the destination point.

To copy items using a reference point:

1. Select the item(s).
2. Choose Edit > Advanced Copy/Paste > Copy Using Reference.
3. You are prompted to enter a reference point. Click the point on the item (or group of items) you want to use as a reference point for positioning the copy.
4. You are prompted to enter the offset location. Click to place the item(s) in the desired location.

To create a copy in a specific position, relative to the selected item:

1. Select the item you want to copy.
2. Choose Edit > Advanced Copy/Paste > Copy Relative. A dialog box appears enabling you to specify the distance from the original that the copy should be placed.

The values you specify here are with respect to the units of the window, schematic or layout. For example, using the default inches of the Schematic window, if you supply 1.0 for both X and Y, the reference point of the copied item will be placed 1 inch in the direction of X and 1 inch in the direction of Y from the reference point of the original item.

Reference Point of Copy

1 Inch in Y

Reference Point of Original

1 Inch in X
3. Specify the desired units in X and Y and click **Apply**. A copy appears at the specified location.

To copy from one layer and paste to another:

1. Select the item(s).
2. Choose **Edit > Advanced Copy/Paste > Copy To Layer**.
3. Select the desired destination layer from the dialog box that appears and click **Apply**.

**Important** Clicking **Apply** enables you to continue copying items from the current layer to any other layer. If this is the only layer you want to copy the selected shape to, then click **Cancel**; if you click **OK**, you will paste an additional copy on the last layer selected.

The **Step and Repeat** command enables you to select an item or items you would like multiple copies of and then specify how many copies and how many rows and/or columns. This command also enables you to specify the distance between the items in X and Y coordinates.

To copy items using the **Step and Repeat** command:

1. Select the item or items you want to copy.
2. Choose **Edit > Advanced Copy/Paste > Step and Repeat**. A dialog box appears.
3. By default, the current snap spacing is displayed as the X and Y spacing in this dialog box. You can either accept the default spacing or change these numbers by typing or clicking the up and down arrows.
4. Specify the number of rows and columns by typing or by clicking the up and down arrows.
5. To automatically connect the pins of these items with one another, select the option **Connect overlapping pins** and change the X or Y spacing field to 0, based upon the component and the desired configuration.
6. Click **Apply**. As you move the pointer into the drawing area, a ghost image of the items moves with it. The lower left corner of the group serves as the reference point for placement.

**Hint** The Step and Repeat command is a repeating command; you can place this same configuration as many times as you like. Or you can change the configuration each time and choose Apply before placing.

An illustration using a $2 \times 4$ array of BJTs is shown next.
Moving Items

The quickest way to move objects is with the mouse:

1. Position the pointer over the object(s) you want to move.

   **Hint**  To move several items at once, select them using a selection window. To add additional items to (or delete items from) a selected group, use Shift+Click.

2. Press the left mouse button, drag to the new location, and release. When moving items using the drag method, the move must be more than the distance specified as the Threshold for it to be recognized as a move.

This option (Options > Preferences > Entry/ Edit) protects you from moving an item unintentionally if you click to select it and accidentally move the pointer.

There are several additional Move commands that enable you to move components and shapes in specific ways:

- **Move Using Reference**—Enables you to move selected items, prompting for a reference point and a destination point
- **Move Edge**—Enables you to stretch the edge (between two vertices) of an existing shape

   **Hint**  This movement can be restricted by setting the option Maintain adjacent angles for Move Edge command. Refer to “Setting Entry/Edit Options” on page 9-12.

- **Move Relative**—Enables you to move items by specifying coordinates, relative to 0,0
- **Move & Disconnect**—Breaks connections as you move selected components
- **Move To Layer**—Enables you to move items from one layer to another
Move Wire Endpoint—Enables you to manipulate an unconnected end of a wire.

To move items specifying the reference and destination locations:

1. Select the item(s) you want to move.
2. Choose Edit > Move > Move Using Reference. You are prompted to enter a reference location.
3. Specify a reference point by clicking the point on the item (or group of items) you want to use when specifying the destination. If you are moving component symbols, clicking a pin as a reference point will help you align and connect the items.
4. As you move the mouse, a ghost image of the selected objects follows. You are prompted to enter an offset location.
5. Click again to place the items in the new location. Where applicable, wires are redrawn maintaining connections.

**Hint** The manner in which wires are redrawn is controlled by the option Re-route wire/trace after move. For more information, refer to the section “Setting Entry/Edit Options” on page 9-12.

To move an item a specific amount, relative to the coordinates 0,0:

1. Select the item you want to move.
2. Choose Edit > Move > Move Relative.
3. Specify the amount in X and the amount in Y (in inches) you want to move the selected object and click Apply. The item is moved, using the default reference point, by the specified amount.

**Hint** The default reference point of an item varies depending on the nature of the item—for a component, it is pin 1; for a shape, it is the lower left corner.
To move and disconnect:

1. Select the items you want to move.

2. Choose Edit > Move > Move & Disconnect. You are prompted to enter a reference location.

3. Specify a reference point by clicking on or near the selected items. If you are moving component symbols, clicking on a pin as the reference point will help you align and connect the items.

   As you move the mouse, a ghost image of the selected items follows. You are prompted to enter an offset location.

4. Click again to place the items in the new location. The connections of the items moved and the items left behind, are deleted. The interconnections among the items moved, remain intact.

To move shapes or text to another layer:

1. Select the object you want to move.

2. Choose Edit > Move > Move To Layer. A dialog box appears with a list of currently defined layers. Select the desired layer and click OK. The selected object immediately takes on the color and other display characteristics of the selected layer.

Note The following items can be moved to another layer using the context-sensitive menu that appears when you right-click with the pointer positioned over any of these items: Polygon, Polyline, Rectangle, Circle, Arc, Text, Arrow, Wire, Construction Line, Path, Trace.
Rotating Items

There are several commands to assist you in rotating components and shapes:

- **Rotate -90** enables you to rotate components and shapes 90 degrees clockwise

  *Advanced Rotate/Mirror*

  - **Rotate** enables you to rotate components and shapes using the mouse. The reference point is chosen by the program.
  - **Rotate Around Reference** enables you to rotate components and shapes using the mouse, specifying the reference point and the destination point.
  - **Rotate Relative** enables you to rotate components and shapes by a specific number of degrees, relative to 0,0.
  - **Set Rotation Angle**, in conjunction with the Rotate command, enables you to rotate components and shapes by a specific number of degrees.
  - **Mirror About X, Mirror About Y** enable you to rotate objects across an axis you specify

---

**Hint**  The Rotate and Rotate Around Reference commands can both be used on either components or shapes, but the Rotate command is typically better for working with components (the reference point is specified by the program) whereas the Rotate Around Reference command is typically better for working with shapes (you are prompted to specify the reference point around which to rotate).

---

6-22  Rotating Items
Rotating Items Using the Mouse

When you use the Rotate command for components or shapes, the reference point used in the rotation is chosen by the program. This reference point is the center of gravity for shapes, and pin 1 for components. Note that by default, the pointer snaps to rotation increments of 45 degrees. You can specify a different rotation increment by specifying a different number of degrees for the Rotation Increment (angle) through Options > Preferences > Entry/ Edit.

To rotate an object using the mouse:

1. Select the object.
2. Choose Edit > Advanced Rotate/Mirror > Rotate. As you move the pointer, a ghost image of the item moves with it. The pointer snaps in increments of the number of degrees specified in the Rotation Increment (angle) field in the Preferences dialog box (Options > Preferences > Entry/ Edit).
3. Click to specify the desired rotation.

Rotating Items Around a Specified Point

To rotate a selected object around a specified point:

1. Select the object.
2. Choose Edit > Advanced Rotate/Mirror > Rotate Around Reference. You are prompted to enter a reference location.
3. Click once on the object at the point around which you want to rotate it. You are prompted to enter the offset location. As you move the mouse, a ghost image of the object moves with it. The pointer snaps in increments of the number of degrees specified in the Rotation Increment (angle) field in the Preferences dialog box (Options > Preferences > Entry/ Edit).
4. Move the pointer until you are satisfied with the angle of rotation and click to place it.
Rotating Items in Degrees, Relative to 0,0

To rotate a selected object by a specific number of degrees, relative to 0,0:

1. Select the object.
2. Choose Edit > Advanced Rotate/Mirror > Rotate Relative.
3. In the dialog box that appears, enter the number of degrees by which you want the object rotated.

Hints:
• Positive values rotate the object in a counterclockwise direction; negative values rotate the object clockwise.
• The reference point for rotating shapes is the lower left corner.
• The reference point for rotating components is the left-most pin 1.
• Values entered here are rounded up or down to the nearest incremental value in accordance with the number of degrees specified in the Rotation Increment (angle) field in the Preferences dialog box (Options > Preferences > Entry/ Edit).
Rotating Objects Across a Specified X- or Y-axis

To rotate selected objects across a specified X-axis (mirror):

1. Select the object.
2. Choose Edit > Advanced Rotate/Mirror > Mirror About X. You are prompted to enter a point on the X-axis.
3. Click to specify the X-axis over which you want the object rotated. The selected object is rotated.

To rotate selected objects across a specified Y-axis:

1. Select the object.
2. Choose Edit > Advanced Rotate/Mirror > Mirror About Y. You are prompted to enter a point on the Y-axis.
3. Click to specify the Y-axis over which you want the object rotated. The selected object is rotated.
Rotating Objects Using an Absolute Angle

You can specify an absolute angle of rotation using the Set Rotation Angle command. This command is used in conjunction with the Rotate command.

**Note** The angle you specify in the Rotation Increment (angle) field (Options > Preferences > Entry/ Edit) must be less than or equal to the setting you specify in the Set Rotation Angle dialog box.

To rotate an object using an absolute rotation angle:

1. Select the object you want to rotate.
2. Choose **Edit** > **Advanced Rotate/Mirror** > **Set Rotation Angle**. The Set Rotation Angle dialog box appears.
3. Click the **Rotate** button or choose **Edit** > **Advanced Rotate/Mirror** > **Rotate**. As you move the mouse, a ghost image of the object moves with it.

**Hint** The pointer snaps in increments of the number of degrees specified in the Angle Increment (degrees) field. The value displayed here by default is the value set in the Rotation Increment (angle) field in the Preferences dialog box (Options > Preferences > Entry/ Edit). You can change the snap increment here as needed, or set a new default in the Preferences dialog box.

Notice that the reference point for shapes is the center of gravity, for components it is pin 1.

4. Specify the desired rotation angle in degrees. You can increment or decrement the value in the Rotation Angle field in increments of the value that appears in the Angle Increment field by using the arrows.
5. Click **Apply** and the object is rotated by that amount.
Editing Shapes

There are several ways you can edit or manipulate various shapes after you have added them to your design:

• “Converting Circles/Arcs to Simple Polygons” on page 6-27
• “Editing Polygons and Polylines” on page 6-29
• “Adding a New Vertex” on page 6-30
• “Moving a Vertex” on page 6-30
• “Deleting a Vertex” on page 6-31
• “Converting a Vertex to an Arc” on page 6-31
• “Converting a Vertex to a Mitered Edge” on page 6-32
• “Stretching a Wire or an Edge of a Shape” on page 6-33
• “Scaling an Object Using a Scaling Factor” on page 6-34
• “Scaling an Object Relative to the Design Window Units” on page 6-35

Converting Circles/Arcs to Simple Polygons

Circles and arcs can be converted to simple polygons allowing vertex editing. The smoothness of the converted circle or arc is determined globally by the setting Arc/ Circle Resolution (degrees) in Options > Preferences > Entry/ Edit. You can use different settings for individual shapes using Edit > Modify > Arc or Edit > Modify > Circle.
Editing Designs

To convert a selected circle to a polygon:
Choose Edit > Modify > Convert To Polygon.

To edit the characteristics of a selected circle:
1. Choose Edit > Modify > Circle.
2. Select the desired mode for changing the radius:
   • Absolute Radius—Select this option to scale a circle by an absolute amount. For example, if your circle has a radius of .75 inches and you specify a Radius of 1, the circle is scaled such that the radius is 1 inch.
   • Delta Radius—Select this option to scale a circle by a relative amount. For example, if your circle has a radius of .75 inches and you specify a Radius of 1, the circle is scaled such that the radius is 1.75 inches.
3. Specify the Radius, the amount by which you want the circle scaled.
4. Specify a new number for resolution, if desired. (See the illustration at the beginning of this section.) Note: This changes the resolution for the selected circle only, independent of the global setting made through the Preferences dialog box, Options > Preferences > Entry/Edit.
5. Specify a different layer for the circle, if desired.
6. Click Apply (or OK if you are done editing circles).

To edit the characteristics of a selected arc:
1. Specify a new number for resolution, if desired. (See the illustration at the beginning of this section.) Note: This changes the resolution for the selected arc only, independent of the global setting made through the Preferences dialog box, Options > Preferences > Entry/Edit.
2. Specify a different layer for the arc, if desired.
3. Click Apply (or OK if you are done editing arcs).
Editing Polygons and Polylines

Several commands found on the Edit > Modify menu can assist you in editing polygons and polylines.

- The Join command allows selected polylines with coincident endpoints to be joined into a single polyline. If a closed shape results, the joined polylines are converted to a polygon.
- The Break command converts a selected polygon into a single polyline.
- The Explode command converts selected polygons or polylines into two-point polylines.

To join multiple polylines into a single polyline:
1. Select the individual polylines you want to join.
2. Choose Edit > Modify > Join. All coincident endpoints are joined. You can verify what has been joined by clicking on the shape to select it and observing whether or not the entire shape is selected.

To convert a polygon into a single polyline:
1. Select the polygon.
2. Choose Edit > Modify > Break. The starting and ending points of the polygon are broken, identified by a marker, and you can now manipulate the shape as a polyline.
Editing Designs

To convert a polygon or polyline to individual, two-point line segments:

1. Select the polygon or polyline.
2. Choose Edit > Modify > Explode. All vertices are disconnected leaving you with individual line segments that you can edit as needed.

Adding a New Vertex

To add a new vertex to a polygon or polyline:

2. Click a point between two existing vertices, and move the pointer. A flexible line is drawn between the vertices and the pointer.
3. Click again to specify the new vertex and the shape is redrawn.

Moving a Vertex

To move a vertex on a polygon or polyline to change its shape:

1. Click to select the vertex and drag the pointer in the desired direction. A flexible line is drawn from the affected vertex to the pointer.
2. Click again to specify the new location of the vertex and the shape is redrawn.
Deleting a Vertex

To delete a vertex on a shape you have drawn, be sure the Vertices filter is turned on (Options > Preferences > Select) and draw a selection window enclosing all vertices you want to delete. Click the Delete button on the toolbar and the shape is redrawn without those vertices.

Clicking anywhere on an arc deletes the arc and connects the former endpoints of the arc with a straight line.

Converting a Vertex to an Arc

You can convert any vertex to an arc and specify the desired radius of the arc, with respect to the units of the window.

To convert a vertex to an arc:

1. Choose Edit > Vertex > To Arc. You are prompted for location of the vertex and a dialog box appears.

2. Change the radius as desired and click Apply.

3. Click any vertex you want to convert to an arc. The vertex is redrawn accordingly.

You can continue converting vertices in this manner using a different radius each time if desired, but you must click Apply each time you change the radius. When you are through making these changes, click OK to dismiss the dialog box.
Converting a Vertex to a Mitered Edge

You can convert any vertex to a mitered edge and specify the desired length of the mitered edge, with respect to the units of the window.

To convert a vertex to a mitered edge:

1. Choose Edit > Vertex > Miter. You are prompted enter location of the vertex and a dialog box appears.
2. Change the miter length as desired and click Apply.
3. Click any vertex you want to convert to a mitered edge. The vertex is redrawn accordingly.

You can continue converting vertices in this manner using a different miter length each time if desired, but you must click Apply each time you change the length. When you are through making these changes, click OK to dismiss the dialog box.
Stretching a Wire or an Edge of a Shape

The Move > Move Edge command enables you to change the shape of an existing wire, or to redefine a shape by stretching an edge (a segment between two vertices).

To stretch an edge:

1. Choose Edit > Move > Move Edge. You are prompted to enter the location of the line.
2. Click the edge you want to stretch. As you move the pointer, a ghost image moves with it and showing how the shape will be redrawn.
3. Click again to define the new shape.
Scaling an Object Using a Scaling Factor

To scale an object using a scaling factor:

1. Choose Edit > Scale/Oversize > Scale and the Scale dialog box appears.
2. Enter scaling factors for both X and Y.
   - Scaling factors must be positive. Scaling factors greater than 1.0 increase the size of objects, while factors less than 1.0 decrease the size of objects. To scale the objects uniformly, enter the same scaling factor for both X and Y.
3. Click OK and you are prompted to enter a reference point on the object around which to scale.
4. Click to specify the reference point and the object is scaled.
Scaling an Object Relative to the Design Window Units

There are two commands, Oversize and Copy & Oversize, that enable you to scale an object with respect to the design units, for example, inches or mils. The Oversize command replaces the original image with a scaled image. The Copy & Oversize command places a copy of the selected object, using the size you specify, on the current entry layer, preserving the original object.

To scale the object itself, in Schem or Layout units:

1. Select the object.
2. Choose Edit > Scale/Oversize > Oversize and a dialog box appears.

   This field enables you to specify an amount by which the selected object should be scaled (in all directions). A positive number increases the size of the object by that amount; a negative number decreases the size of the object by that amount.

   This field enables you to specify a cutoff angle for mitering corners. Any angle of a polygon smaller than the specified cutoff angle is mitered. The default cutoff angle is 45 degrees.

3. Make any necessary changes in the dialog box, and click OK.

   In this example, a 1 inch square was oversized by 0.1 resulting in a 1.2 inch square.
Editing Designs

To make a scaled copy of an object, in Schem or Layout units:

1. Select the object.
2. Choose **Edit > Scale/Oversize > Copy & Oversize** and a dialog box appears.
3. Specify the desired angle and click **OK**.

**Editing Existing Text and Text Attributes**

There are two methods of editing text you have added to your design: you can use the on-screen editor or edit through a dialog box. Note: To edit text attributes, you must use the dialog box method.

To edit text using the on-screen method:

1. Position the pointer over the text you want to edit and click. Notice the following changes:
   - The text takes on the color currently defined for Highlight in the Preferences dialog box (Options > Preferences > Display).
   - The status panel prompt changes to read, On-screen Text Editor: in progress
   - A vertical bar (|) representing a text insertion cursor appears in the line of text.
2. Use the arrow keys or the mouse to reposition the cursor, as needed, near the text you want to change. Use the backspace key, as necessary, to make your changes.
3. When you are through, move the pointer away from the text and click once to end the text editing command.

To edit text using the dialog box method:

1. Choose **Edit > Edit Text**. The dialog box appears and you are prompted to enter the location of the text.
2. Click to select the text you want to edit. The selected text appears in the dialog box for editing. (If you type multiple lines as a block of text, that block appears.)
3. Make any desired changes to the text.
4. Make any desired changes to the text attributes.
   • Font Type—Schematic only—All True Type fonts installed on your system are available. Select the desired font from the drop-down list.
   
   **Note** On UNIX, if you want to add additional True Type fonts that were not supplied with ADS, copy them to $HPEESOF_DIR/lib/fonts.

   • Point—Represents the size of text in traditional units used in printing.
   • Layer—Enables you to select a different layer for the text.
   • Placement Angle—Enables you to rotate existing text by specifying an angle in degrees. Positive values rotate the text counterclockwise; negative values rotate it clockwise.
   • Non-rotating (when in hierarchy)—Select this option to prevent text on a symbol or design from being rotated when the symbol is rotated.
   • Justification, Horizontal—This setting represents two types of justification: one is how individual lines of text in a block of text are aligned with one another; the second is how an individual line of text or block of text is positioned horizontally, relative to the reference point you specified to begin typing the text.
   • Justification, Vertical—This setting aligns a string or block of text vertically, relative to the reference point you specified to begin typing the text.

5. Click **Apply**. Changes to the selected text are reflected immediately in the drawing area.

   You can continue to select text and make changes, but you must click Apply for each set of changes for those changes to take effect.

6. When you are through making changes to text, click **OK** to dismiss the dialog box.
Forcing Objects Back onto the Grid

If an object is offset from the current grid spacing, you can force it back to the nearest grid point with the Modify > Force to Grid command. If the selected object is an item with pins, pin 1 is forced to the nearest grid point.

To force an object back onto the grid:

1. Select the object.
2. Choose Edit > Modify > Force to Grid. The selected object snaps to the grid.
Chapter 7: Annotating Designs

You can annotate your schematic by adding a drawing sheet, inserting a variety of shapes, and adding text (including system variables such as date, time, etc.). For details, refer to the following topics:

- “Adding a Drawing Sheet” on page 7-1
- “Adding Text” on page 7-2
- “Drawing Shapes” on page 7-4

Adding a Drawing Sheet

If you want to use a drawing sheet that contains any constant information or graphics, such as a company logo, you will probably want to save it as a template enabling you to insert it in any design where it is needed.

To create a drawing sheet:

2. Supply a name for the file.
3. Choose Insert > Component > Component Library.
4. Select the Drawing Formats category.
5. Select the appropriate drawing sheet size, for example, FORMATA.
6. Click OK and move the pointer into the drawing area.
7. Note that the lower left corner serves as the reference point. Position the image of the drawing sheet as required and click to place it there.

To move the drawing sheet after placing it, you must be able to select it, and by default, the Drawing Format filter is turned off. To turn it on, choose Options > Preferences > Select and enable the Drawing Format option. If you do enable this filter, you will probably want to disable it again after moving the drawing sheet, before beginning your design work.
Annotating Designs

**Hint** If you want to reposition the lower left corner of the drawing sheet at the coordinates 0,0 (to assist in placing items using exact measurements), you can use the Set Origin command. Choose Edit > Modify > Set Origin and click the lower left corner of the drawing sheet. Use View All if necessary to bring the entire sheet into view.

8. Add all desired information.

9. Choose Save Design As Template to make it available for insertion in any design.

**Adding Text**

Once you have established the desired text attributes, you can add text to your design using the Text command on the Insert menu or the Text button on the toolbar. Prior to adding text, you should change the current entry layer to text1 (or a text layer you have created) and place all text on that layer. For details on which type of objects are placed on which layers, refer to the section, “Specifying Layer Definitions” on page 9-21.

To change the current entry layer:

Choose Insert > Entry Layer > text1.

Any text you add, or object you draw, will now be placed on the text1 layer until you change to another entry layer. Text will take on the characteristics defined in the Preferences dialog box (except for color, which is defined through the Layer Editor). For details on changing attributes of text:

- Prior to adding it to the drawing area, refer to the section, “Setting Text Options (in Advance)” on page 9-17.
- After adding it to the drawing area, refer to the section, “Editing Existing Text and Text Attributes” on page 6-36.

To add text to your design:

1. Choose Insert > Text. The status panel prompt changes to read, New Text: Enter location for new text.

2. Position your cursor in the desired location, click once, and begin typing.
Using Variables to Display Design and System Information

You can add any of the following variables to your design to display the type of information indicated:

@dname = Design name
@pname = Full path to design
@ddate = Date design was last saved
@dtime = Time design was last saved
@cdate = Current date
@cime = Current time
@SIM_HOST = Name of machine hosting the simulation
@SIM_DDS = Name of the simulation data set

To add variables to your text:

1. Choose Insert > Text.
2. Click to begin typing text and include any of the variables shown above as desired. For example:

This version of @dname was last saved on @ddate at @dtime.
Annotating Designs

3. Press Esc to stop the Text command and the variables are replaced by their equivalents.

Drawing Shapes

The Insert menu contains commands that enable you to draw a variety of shapes and lines to help annotate your schematic. Select End Command from the pop-up menu (or click the End Command toolbar button, or press Esc) during execution of any draw command, to terminate the command and remove the partial shape.

Hints:

- Several shapes that require you to specify multiple points (such as polygons, polylines, arcs) allow you to specify the last point by pressing the space bar.
- Context-sensitive editing is available for several shapes (rectangle, polygons, polylines) with respect to changing the layer on which the shape is drawn. Position the pointer over the shape, right click, and select the layer command from the pop-up menu.
- You can change the thickness of the lines of the following shapes drawn in the Schematic window (schematic view): polygons, polylines, rectangles, circles, arrows, and all arcs. (Edit > Modify > Line Thickness)
- You can set (in advance) the thickness of the lines of the following shapes drawn in the Schematic window (symbol view): polygon, polyline, rectangle, circle. To edit line thickness subsequently, choose Edit > Modify > Line Thickness.

To draw a rectangle (or square):

1. Choose Insert > Shape > Rectangle (or click the Rectangle button). You are prompted to enter the first corner.
2. Click to specify the first corner. You are prompted to enter the second corner.
3. As you move the mouse, a flexible box stretches from the anchor point to the position of the mouse, expanding and contracting as you move. When you are satisfied with the size, click to finish.
To draw a polygon:

1. Choose **Insert > Shape > Polygon** (or click on the Polygon button). You are prompted to enter a vertex.

2. Click to anchor the starting point of the polygon.

3. Move the cursor to the position where you want the first line segment to end, and click. A line appears between the two points.
   - At any time during entry of a polygon, you can choose one of the Arc commands to include an arc in your polygon.
   - You can use the **Undo Vertex** command to backtrack to the previous point anytime you want to erase the segment or arc you have just drawn.

   **Hint** If you want all line segments to be drawn perfectly horizontal or vertical, choose **Options > Preferences > Entry/ Edit Mode** and check **Orthogonal**.

4. Continue in this manner until you are ready to draw the final line segment(s) completing your polygon.
   - To draw all but the last line segment, double-click or press the space bar while the pointer is still positioned over the last vertex.
   - To draw all but the last two line segments, move the pointer so that it is positioned over the next vertex, and double-click or press the space bar.

   The polygon is automatically closed. The illustration demonstrates the latter method.

To draw a polyline (a series of connected line segments):

1. Choose **Insert > Shape > Polyline** (or click on the Polyline button). You are prompted to enter a vertex.

2. Click to anchor the starting point of the polyline.
Annotating Designs

3. Move the cursor to the position where you want the first line segment to end, and click. A line appears between the two points.
   - At any time during entry of a polyline, you can choose one of the Arc commands to include an arc in your polyline.
   - You can use the Undo Vertex command to backtrack to the previous point anytime you want to erase the segment or arc you have just drawn.

4. When you have drawn the final line segment, double-click or press the space bar to end the Polyline command.

To draw an Arc:

1. Choose Insert > Shape > Arc (clockwise or counterclockwise). You are prompted Enter the start point of the arc.
2. Move the cursor into the drawing area and click left to specify the start point of the arc. You are prompted Enter the arc center.
3. Click to specify the center point of the arc. A flexible arc appears as you move your cursor. You are prompted Enter the ending point of the arc.
4. Click to specify the end point. If you are through drawing arcs, click End Command.

Hint  Context-sensitive editing is available for arcs. Position the pointer over the arc, right click, and select Edit Arc from the pop-up menu.

You can also draw an arc by specifying the start point, end point, and circumference. To draw an arc in this manner:

1. Choose Insert > Shape > Arc (start, end, circumference). You are prompted Start pt of arc.

7-6  Drawing Shapes
2. Move the pointer into the drawing area and click left to specify the start point of the arc. You are prompted End pt of arc.

3. Click to specify the end point of the arc. You are prompted Circ point of arc. A flexible arc appears as you move the pointer.

4. Click to specify the final size of the arc.

To draw a circle:
1. Choose Circle from the toolbar or from the Insert menu. You are prompted to enter the circle center.
2. Click to specify the center point.
3. Drag the mouse until the circle is the desired size and click.

**Hint**  Context-sensitive editing is available for circles. Position the pointer over the circle, right click, and select Edit Circle from the pop-up menu.

To draw an arrow:
1. Choose Insert > Arrow. You are prompted to enter the first point. In the dialog box that appears, set the following options as needed:

   - Number of Arrowheads
     
     One  Two

   - Polygon arrowhead—select to draw arrowhead as a polygon
     
     Polyline arrowhead  Polygon arrowhead

   - Arrowhead width in schematic units:
     
     Arrowhead width increased (from default of 0.08) to 0.125

   - Arrowhead length in schematic units:
     
     Arrowhead length decreased (from default of 0.25) to 0.125
Annotating Designs

---

**Hint**  To restore the default values/options, click Default.

2. Click **Apply**.

3. Click to specify the first point of the arrow. You are prompted to enter the second point.

4. Move the pointer as needed to identify the endpoint of the line segment and click.

To change the line thickness of an existing shape:

1. Select the shape.
2. Choose **Edit > Modify > Line Thickness**.
3. Select the desired thickness and click **OK**.

**Drawing Shapes Using Specific Coordinates**

The **Coordinate Entry** command enables you to draw a variety of shapes by specifying coordinates for each vertex.

To use the coordinate entry method for drawing:

1. Choose **Insert > Coordinate Entry** and a dialog box appears. Move the dialog box so that the desired design window is visible.
2. Choose the required drawing or editing command.
3. Enter the X and Y coordinates for the first point.

You can enter coordinates by typing them directly in the fields labeled X and Y, or you can use the up and down arrows of the X Increment and Y Increment fields to increase or decrease the values of the X and Y fields. By default, the X and Y Increment fields are set to the current snap spacing, but you can use any increment that meets your design needs.
4. Click **Apply**.

5. Continue specifying all desired points, clicking **Apply** for each.

**Hint**  When drawing polygons with coordinate entry, click **Apply** for the final segment of the shape to be drawn automatically.
Annotating Designs
Chapter 8: Simulating and Viewing Results

The information presented here explains only the basics of simulating and viewing results in the Advanced Design System. Simulation is described in more detail in the Circuit Simulation and Agilent Ptolemy Simulation manuals. Viewing results is described in detail in the Data Display manual.

Setting up a Simulation

All simulations are performed from the Schematic window. There are two basic steps required to set up a simulation:

- Place the appropriate simulation control item(s) in your design
- Specify a name for the data that will be generated by your simulation

Placing Simulation Control Items in Your Design

Simulating with the Advanced Design System is accomplished by placing simulation control items in the Schematic window along with your design (no connection required). The control items available vary with the current design type. Some of the categories of control items for each design type are listed next.

Analog/RF Designs

- Frequency-Domain Sources
- Time-Domain Sources
- Noise Controlled Sources
- DC Simulation
- AC Simulation
- S-Parameter Simulation
- Harmonic Balance Simulation
- Large-Signal S-parameter (LSSP) Simulation
- Gain Compression (XDB) Simulation
- Envelope Simulation
- Transient Simulation
Simulating and Viewing Results

Digital Signal Processing Designs

- Data Flow Controller
- Sweep Plan
- Parameter Sweep
- Performance Optimization Controller

For Digital Signal Processing designs, you must also connect a Sink component or an Interactive Controls and Displays component to the output of your schematic. A Sink collects data or performs a measurement. The data can then be displayed via the Data Display window.

Specifying a Name for the Simulation Data

All data produced by a given simulation is stored collectively as a dataset. Every dataset has a name associated with it. You can assign a name prior to simulating or you can accept the default dataset name. The default name is the name of the current design, with the extension `.ds` automatically appended. Note the following guidelines regarding the naming of datasets:

Note If you accept the default dataset name and perform multiple simulations, the dataset will be overwritten each time. To collect separate datasets for each simulation, specify a unique name (for the data set you are about to create) prior to each simulation.

For additional information regarding the naming of datasets, refer to “Limitations” on page 1-23 (under Naming Conventions).

To specify a dataset name prior to simulating:

1. Choose Simulate > Simulation Setup.
2. Supply a name in the Dataset field. (Click Browse to view existing dataset names in the current project.)

Hint Datasets are stored in the / data subdirectory of a project. This means that you should provide unique names for the datasets that will be generated from the different designs in the same project directory.
3. Supply a name in the Data Display field, or accept the default name.

Data Display—The name you specify here will be the title of the Data Display window that is opened, and the default filename should you choose Save As (from the Data Display window). The default name shown is based on the current design name.

Open Data Display when simulation completes—If this option is selected, a Data Display window will open automatically when the simulation is complete. For details refer to the section, “Automatically Displaying Simulation Data” on page 8-4.

4. Optionally, select a different Remote Simulation Host for the simulation, if you are running the simulation on a remote machine.

For details on setting up your remote and local machines for remote processing, refer to the appropriate appendices:

• Appendix E, Using Remote Simulation in the Installation on PC Systems manual

5. Click Simulate.
Simulating and Viewing Results

Automatically Displaying Simulation Data

When setting up your simulation (Simulate > Simulation Setup, in the Schematic window), you can enable an automatic display of your results.

Select the Open Data Display when simulation completes option to force a Data Display window to open automatically when the simulation is complete. The data display that appears in that window depends on the simulation setup and the status of display templates:

- If you specify the name of an existing display to open, that display is opened.
- If you specify a new name, then a blank Data Display window opens.
- If one or more data display templates are associated with the current design, then the Data Display window opens and inserts each template on its own page. A data display template can be associated with a design in one of two ways:
  - By default, if your design includes a supplied schematic template, and a data display template is associated with that schematic template.
  - Explicitly, if you create your own data display template (File > Save As Template in the Data Display window) and associate that template with your design via the DisplayTemplate component. (Refer to the next section, “Using a DisplayTemplate Component” on page 8-4.)
- If none of the above criteria are met, but you select the option, then a blank Data Display window opens.

Using a DisplayTemplate Component

The DisplayTemplate component (available from most simulation libraries) enables you to associate one or more data display templates with a given design. (If you include one of the supplied schematic templates in your design, it most likely has a data display template associated with it.)

The starting point of this procedure assumes you have already created a data display file for use as a template, by setting up the Data Display window as desired and choosing File > Save As Template.
To associate a data display template with the current design:

1. Place a DisplayTemplate component in the Schematic window.

2. Select **String and Reference** as the Parameter Entry Mode.

3. Enter the name of the template (the filename you supplied in the Data Display window) and click **Add**.

   **Hint** You can specify multiple templates for the same data display and subsequently access them from the Page menu.

4. When you are through specifying display templates for the current design, click **OK**.

**Manually Displaying Simulation Data**

If you do no want the Data Display window to open automatically, disable the option **Open Data Display when simulation completes** in the Simulation Setup dialog box.

To open a new window for displaying and manipulating data:

   Choose **Window > New Data Display** from the Main, Schematic, or Layout windows.

To save a graph for later viewing/manipulating:

   Choose **File > Save**.

To save a graph for use as a template:

   Choose **File > Save As Template**.

---

Setting up a Simulation 8-5
Simulating and Viewing Results

To open a previously saved data display:

1. Choose Window > Open Data Display from the Main, Schematic, or Layout windows. In the dialog box that appears, the path is automatically set to the current project directory and the filter displays all saved graphs (*.dds).
2. Double-click the graph you want to open or select it and click OK.

For details on working with simulation data, refer to the Data Display manual.

Simulating

To simulate using current data set name:

Choose Simulate > Simulate. The Status window appears and displays messages about the simulation as it progresses. When the simulation is complete, it will display the message, Simulation finished.

To highlight a specific node on your schematic:

Choose Simulate > Highlight Node. The list box that appears displays a list of all nodes on the schematic. Select any node name from the list and that node is highlighted on the schematic. (The highlight color can be changed through Options > Preferences > Display > Highlight).

To clear one or more highlights, choose Simulate > Clear Highlighting.

Excluding Individual Items from the Simulation

You can deactivate items in the Schematic window, excluding them from a simulation without deleting them from your design.

To deactivate an item:

1. Click the Deactivate button on the toolbar or choose Edit > Component > Deactivate.
2. Click the item or items you want to deactivate. A box with an X drawn through it appears over each item.

Hint: The color of this identifying box is the Highlight color defined through Options > Preferences > Display.
To activate a deactivated item:

1. Click the **Activate** button on the toolbar or choose **Edit > Item > Activate**.
2. Click the item or items you want to activate. The box disappears and theses items are considered in a subsequent simulation.

**Clearing Highlights from Items Causing Simulation Errors**

When an error occurs during simulation, a box is drawn around each item causing an error. To clear all highlights, choose the **Clear Highlighting** command from the **View** menu in the appropriate window.

**Hint** The color of this identifying box is the Highlight color defined through **Options > Preferences > Display**.

**Tuning**

Advanced Design System's tuning capability enables you to change one or more design parameter values and quickly see the effect on the output without resimulating the entire design. Multiple plots generated from various tuning trials can be overlaid in the Data Display window. This can help you find the best results and the most sensitive components or parameters more easily.

Basic tuning consists of the following steps:

1. Build the design you want to tune.
2. Simulate your design.
3. Set up the Data Display window to display the results you want from your design.
4. Choose **Simulate > Tuning** or click the **Tuning** icon (tuning fork) on the toolbar. When the initial analysis is complete, the Tune Control dialog box appears.
5. Select the parameter you want to tune by clicking it on the schematic.
Simulating and Viewing Results

6. Select one of the following tune analysis modes from the Perform Analysis drop-down list:
   • After each change
   • After pressing Tune
   • While slider is moving

7. Change the tunable parameter by moving the slider, clicking the left/right arrows, or typing the value in the box. Depending on the selected tuning mode, your results will be updated as soon as the new simulation is completed.
Chapter 9: Setting Design Environment Preferences

You can easily customize many aspects of design entry and display through the Preferences and Layer Editor dialog boxes accessed through the Options menu. Some of the options set here serve as defaults and can be changed during execution of individual commands.

Some of the things you can customize are:

- The default settings for color of the grid, pins/tees, highlighted and selected objects, and the background and foreground of the design windows
- The sizes of pins/tees, the selection pick box, and the size of the marker drawn when you have the Vertices filter turned on and select objects in the drawing area
- The display of the Component Parameters dialog box, coordinate readouts, pin names and numbers, and pins/tees

When you change the settings in these dialog boxes and click Apply, the design window is updated with the changes, but unless you save these changes in a file, these settings only apply to the current session in the current project directory. For details on saving to a file, refer to the sections, “Saving and Reading Preference Files” on page 9-20 and “Saving and Reading Layer Files” on page 9-28.
Specifying Design Entry and Display Preferences

To change design entry and display preferences:

Choose **Options > Preferences** in any design window.

Many options relating to the size of an item displayed on the screen offer a choice of specifying the size in terms of screen pixels or schem units (or layout units, in the Layout window).

- **screen pixels**—Use this setting to specify sizes in terms of pixels on the screen. For example, if you set 10 screen pixels for the Pick Box size, the pick region will be 10 pixels by 10 pixels.

- **schem units**—Use this setting to specify sizes in terms of inches, in the Schematic window. In the Layout window, select layout units to specify a size with respect to the design units of the Layout window.
Setting Select Options

The Select options can assist you in editing your designs by modifying how items are selected.

**Note** Changes made to the settings in this dialog box exist only in memory unless you save them to a file. For details on saving to a file, refer to the section, “Saving and Reading Preference Files” on page 9-20.

Using Selection Filters

Selection filters enable you to specify types of items you want included in or excluded from your selections. For example, if you turn on only Components and Wires, none of the other types of items in the drawing area will be available for selection. By default, all types of items are turned on except Drawing Format.

![Select Filters](image)

To change the default settings:

Select the types of items you want available for selection, and deselect the types of items you want excluded from selection.

**Hints:**

- Any item type that is turned off will not be selected when you click it individually, attempt to enclose it in a selection window, or choose the Select All command.
- Only the Select By Name and Deselect By Name commands ignore the selection filters.
Setting Design Environment Preferences

- To enable most filters, choose Set All to quickly select all filters, then deselect those you want excluded.
- To disable most filters, choose Clear All to quickly deselect all filters, then select those you want included.

Changing the Select Mode for Polygons

- Choose By Edge to be able to select polygons by clicking on the outer edge.
- Choose Inside if you want to be able to select polygons by clicking anywhere inside the shape.

Changing the Pick Box Size

The pick box is a region you define that determines how close your cross cursor must be to an object before clicking will select that object. You can choose a size in schem/layout units, relative to the units of the design window, or you can choose a size in screen pixels.

Figure 9-1 shows an example of the region defined by a pick box specified in inches.

![Pick region based on schem Units](image)

In Figure 9-1, the pick box size was set to 0.25 inch (the same as the default grid display).
When you define the region using n screen pixels, the pick region is a square of n pixels × n pixels, centered around the spot where you click. For example, if you specify 20, the pick region extends 10 pixels beyond the spot where you click, horizontally and vertically.

![Table](Image)

<table>
<thead>
<tr>
<th>Size</th>
<th>Pick Box</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td></td>
<td>screen pixels</td>
</tr>
</tbody>
</table>

**Hint** It may be necessary to use a very small number in designs where items are tightly spaced.

---

### Changing the Selected Vertex Size

When the Vertices filter is enabled, and you select a vertex (or vertices), a marker appears identifying each selected vertex. You can change the size of the marker from the Select tab of the Preferences dialog box.

To change the size of the marker that identifies selected vertices:

1. Choose the desired units from the drop-down Units list box.
2. Change the value as desired.

---

### Changing the Select Color

When objects in the drawing area are selected, a box is drawn around them identifying them as being selected. By default, this highlight color is black, but you can change it from the Select tab of the Preferences dialog box. This color is also the color of the marker that identifies selected vertices.
Setting Design Environment Preferences

Setting Grid/Snap Options

The display grid and cursor snap features are provided to assist you in creating and editing your designs more quickly and accurately.

**Note**  Changes made to the settings in this dialog box exist only in memory unless you save them to a file. For details on saving to a file, refer to the section, “Saving and Reading Preference Files” on page 9-20.

By default, snap mode is turned on and the cursor snaps to pins and to the grid defined by the snap spacing. The default snap spacing is 0.125 inch (in the Schematic window) with a display factor of 2. This means that although the cursor snaps every 0.125 inch, the dots only appear every 0.25 inch. If you set the display to anything smaller than 0.25 inch, the grid will be too dense to display without zooming in on it.

**Hint**  The default component symbols have been created uniformly, in 0.125-inch increments. Thus, if you keep the default settings while creating your design, you should be able to connect all symbols with minimal effort.

### Display

- **Dots**  Select Dots or Lines to display a visible grid made up of dots or lines
- **Lines**  Select None if you want no visible grid
- **Color**  Click to access a palette for choosing a grid color

### Spacing

**Snap Grid Distance (in schem units)**  represents the snap spacing, where the number you specify determines the distance (in design units, or inches) between the points to which the cursor snaps.

<table>
<thead>
<tr>
<th>Snap Grid Distance (in schem units)</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
</tr>
<tr>
<td>Y</td>
</tr>
</tbody>
</table>

9-6  Specifying Design Entry and Display Preferences
**Snap Grid per Display Grid** represents the spacing between the dots (or lines) on the display grid in terms of a factor of the snap spacing. The smaller the number, the finer the grid.

![Snap Grid per Display Grid](image)

**Hint** If the display factor you specify makes the grid too dense to display, it is invisible unless you zoom in. To see the grid without zooming, choose a larger display factor.

**Snap Distance - all other modes** represents how close to an object the cursor must be before it will snap to that object.

![Snap Distance - all other modes](image)

**Active Snap Modes**

This section enables you to restrict the manner in which the cursor snaps. You can activate any combination of choices. If you select more than one, the cursor snaps to the nearest one. By default, Grid and Pin are turned on to assist you in quickly creating schematics.

- **Enable Snap**—Toggles snap mode on and off. You can also toggle snap mode on and off from the Options menu itself (Snap Enabled).

To select all or most snap modes:

Click **Set All** and then deselect those you want excluded.

To deselect all or most snap modes:

Click **Clear All** and then select those you want included.

**Hint** All snap modes (except Grid) rely on the cursor being within the distance specified as Snap Distance (Diameter).
Setting Design Environment Preferences

- **Pin**—When the pin of an object you are positioning gets within the snap distance of a pin on an existing object, the pins are automatically connected. Pin snapping takes priority over all other snap modes.

  **Note**  Angle Snapping automatically occurs when only Pin snapping is enabled and you place a part so that the pin at the cursor connects to an existing part. The placed part rotates so that it properly aligns with the connected part.

- **Vertex**—When the object you are positioning gets within the snap distance of a vertex on an existing object, the object you are positioning is automatically placed at that vertex. This snap mode is especially helpful if something was originally drawn or placed on the grid and then moved off, or the grid spacing has been changed.

- **Midpoint**—When the object you are positioning gets within the snap distance of the midpoint of an existing object, the new object is automatically placed at the midpoint of the existing object.

- **Intersection**—When the object you are positioning gets within the snap distance of the intersection of the edges of two existing objects, the object you are positioning is automatically placed at the intersection of the existing objects.

- **Arc/Circle Center**—When the object you are positioning gets within the snap distance of the center of an existing arc or circle, the object is placed at the midpoint of the existing arc or circle.

- **Edge**—When the object you are positioning gets within the snap distance of the edge of an existing object, the object is automatically placed at the edge of the existing object.

  **Hint**  Once a selected point snaps to an edge, it will slide along the edge unless you move the cursor out of the snap distance.

- **Grid**—The cursor snaps to points on the grid defined by snap spacing. All other snap modes have priority over grid snap mode.

  **Hint**  The Reset button returns settings to their defaults (if you have not yet clicked Apply).
Setting Placement Options

Set the following options—related to placing components in the drawing area—in a manner that suits the way you work:

---

**Note**  
Changes made to the settings in this dialog box exist only in memory unless you save them to a file. For details on saving to a file, refer to the section, “Saving and Reading Preference Files” on page 9-20.

---

**Defining the Placement Mode for Schematic and Layout Representations**

When you are working with both schematic and layout representations, you can select the simultaneous placement mode that works best for you. For schematic only design work, use the default option, Single Representation.

- **Single Representation**
  - When you place an item in one representation, nothing is placed automatically in the other representation.

- **Dual Representation**
  - When you place an item in one representation and move the pointer into the window for the other representation, the equivalent component is already selected. Position the pointer as desired and click to place it. (If a window for the other representation—containing the same design—is not open, one will be opened automatically.)

- **Always Design Synchronize**
  - Causes the program to fully synchronize both representations after each part is placed, ensuring all parts are fully interconnected. This takes more time than the Dual Representation mode and may move or rearrange the layout of the schematic to preserve connectivity.
Displaying the Component Parameter Dialog Box by Default

When you place a component in the drawing area, you can change parameters using the on-screen editor. Alternatively, you can make changes through the Component Parameter dialog box. By default, in the Schematic window, the option that controls the automatic display of the component parameter dialog box is turned off. You can turn this option on if you want the dialog box to be displayed every time you select a component (Options > Preferences > Placement).

• Show Component Parameter Dialog Box
  Controls whether or not the Component Parameters dialog box appears every time you select an item to place in the drawing area.

• Show Component Parameter Dialog Box for components without parameters
  Select this option if you want the Component Parameters dialog box to be displayed even for components that do not have parameters (for example, a design used as a subnetwork for which no parameters have been defined through File > Design Parameters). By default it is off and the dialog box does not appear.

Setting a Default for Component Swapping

• Keep the original instance name(s) when swapping components
  Retains the component ID of the original component when using the Swap Components command. (Tip: this setting serves as a default; it can be changed for any given operation through the Swap Components dialog box.)
Setting Pin/Tee Options

You can change several options relating to pins/tees through Options > Preferences > Pin/ Tee.

**Note** Changes made to the settings in this dialog box exist only in memory unless you save them to a file. For details on saving to a file, refer to the section, “Saving and Reading Preference Files” on page 9-20.

- **Pin Size**
  Enables you to change the size of the pins drawn on all components.

- **Tee Size**
  Enables you to change the size of the Tee connections between interconnected wires.

- **Color**
  Enables you to specify colors for the items shown here. Click each to display a color palette with the available selections.

- **Visibility**
  Enables you to change the visibility status of pin numbers and names, and whether or not pin connections are identified by markers.

  **Connected Pins**—Select this option to display a marker identifying a pin connection. The marker is drawn using the size specified in the Pin/Tee tab of the Preferences dialog box.

  **Pin Numbers**—Select this option to display pin numbers.

  **Pin Names**—Select this option to display pin names.
Setting Design Environment Preferences

Setting Entry/Edit Options

This group of options allows you to control several aspects of shape entry and editing including the angle at which lines and wires are drawn, the resolution of arcs and circles, and how wires are routed relative to component text.

**Note**  Changes made to the settings in this dialog box exist only in memory unless you save them to a file. For details on saving to a file, refer to the section, “Saving and Reading Preference Files” on page 9-20.

- **Non-orthogonal**
  Enables you to draw polylines, polygons, and wires using all angles.

- **Orthogonal**
  Restricts shape entry to horizontal or vertical.

- **Show Coordinate Entry Dialog for Insert and Edit commands**
  Select this option to force the Coordinate Entry dialog box to be displayed when invoking the following commands:
  - Insert (Shape)—Polygon, Polyline, Rectangle, Circle, Arc (clockwise and counter-clockwise), Text, Construction Line, Symbol Pin, Path, Trace.
  - Edit—Move Wire Endpoint, Mirror X, Mirror Y, Move & Disconnect, Step And Repeat, Set Origin, Move Component Text.

- **Show Set Paste Origin Dialog for Copy Command**
  Select this option to force the Set Paste Origin dialog box to be displayed when you choose the Copy command. This dialog box enables you to specify X and Y coordinates to be used as a reference point when pasting.

- **Polygon self-intersection checking**
  Prevents you from placing additional points on a polygon if overlapping lines will result.

- **Maintain adjacent angles for Move Edge command**
  Restricts the Move Edge command to stretch an edge while maintaining the adjacent angles of the edge being stretched to other edges adjacent to that edge.
• **Keep node names when copying**
  Select this option if you want to preserve node names when performing copy/paste operations. (Note: We recommend you do so with caution, as potentially undesirable connectivity may result.)

• **Re-route wire/trace after move**
  When this option is selected, and you move a component connected to other components, the wire connections are re-routed so that there is only one orthogonal bend per connection. When this option is deselected and you move a component, the original wire connection is preserved and a new wire is drawn from the endpoint of the original wire to the new location of the component, with an orthogonal bend, as required by the move.

• **Route around component text**
  By default, wires are routed through component text. If you want wires routed around component text, select this option.

• **Arc/Circle Resolution (degrees)**
  This setting determines how smoothly curves are drawn. The length of each line segment making up the arc is determined by the size of the angle drawn using the specified number of degrees.

![Diagram showing arc drawn with 5 degrees and arc drawn with 45 degrees](image)

In general, the smaller the number of degrees, the smoother the shape, but the longer it will take to redraw the screen.

**Note** This setting only affects circles in that the number specified here is used if you convert a circle to a polygon.

• **Auto-backup edit count**
  Your file is automatically saved every time the number of edits you have performed reaches the number in this field.
Setting Design Environment Preferences

- **Undo edit count**
  This option represents the maximum number of commands held in the stack. Selecting Undo from the Edit menu or clicking the Undo button on the toolbar undoes the last editing command. A stack of edit commands is maintained for each window, thus the Undo command works independently from window to window. You can choose Undo repeatedly to return to an earlier state of your design. You can specify the number of commands you want the stack to hold using the Undo edit count option.

- **Rotation Increment (angle)**
  This option forces objects you rotate to snap—during rotation—in n-degree increments, where n is the number you specify here. For details on how this default is used, refer to the section “Rotating Items” on page 6-22.

- **Wire Route/Units**
  If the Route around component text option is selected, by default, wires are routed 0.125 inches away from items in the wire's path (Schematic). To change the Wire Route distance (in schem units or screen pixels) use this option.

- **Drag and Move**
  This option is designed to prevent you from moving an item when you click to select it (for any purpose) and unintentionally move the pointer in the process. By default, a move less than 10 screen pixels is not recognized as a move. An intentional move must be more than the distance specified here for it to be recognized as a move.
Setting Component Text Options (in Advance)

Component text is the text associated with components selected from a Library or Palette. This text appears automatically when you place the component in the drawing area and consists of a name, a unique ID, and parameters (where applicable).

---

**Note** Changes made to the settings in this dialog box exist only in memory unless you save them to a file. For details on saving to a file, refer to the section, “Saving and Reading Preference Files” on page 9-20.

---

There are two ways to change component text attributes:

- In advance of placing components, through the Options menu (Options > Preferences > Component Text). This setting serves as a default, but attributes of component text for an individual component, or all components, can be changed later through the Edit menu.

- After placing components, through the Edit menu (Edit > Component > Component Text Attributes). Refer to “Changing Component Text Attributes” on page 6-10.

You can specify the following display characteristics of component text: font, point size, maximum numbers of rows displayed in a single column, precision, and the layer on which each type of text is placed.

- **Font Type**
  All TrueType fonts installed on your system are available. Select the desired font from the drop-down list. When printing to an HP-GL/2 file, text information will not be saved if the font is a TrueType font. To preserve the text in your output file, convert it to HersheyRomanNarrow before saving to HP-GL/2.

  **Note** On UNIX, if you want to add additional TrueType fonts that were not supplied with ADS, copy them to $HPEESOF_DIR/lib/fonts.

- **Point**
  Represents the size of text in traditional units used in printing.
Setting Design Environment Preferences

- **Apply To Layer**
  Each of the three types of component text resides on its own layer. This enables you to quickly change the appearance of the component text by changing the attributes of a layer, or making a layer invisible. For more information on changing layer attributes, refer to the section, “Specifying Layer Definitions” on page 9-21.

<table>
<thead>
<tr>
<th>Component Name</th>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>labels</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Instance Name</td>
<td></td>
<td></td>
</tr>
<tr>
<td>identifiers</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Component Parameter</td>
<td></td>
<td></td>
</tr>
<tr>
<td>parameters</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Sample of component text for a capacitor

To change the layer for any given type of component text, click the arrow and select a new layer from the drop-down list.

- **Annotation precision**
  Represents the number of significant digits displayed to the right of the decimal point for schematic component text.

- **Parameter Rows**
  Represents the maximum number of rows of component text displayed in one column. Using a relatively small number here is helpful for large parameter sets so you can view the parameters in several short columns.
Setting Text Options (in Advance)

You can establish text attributes—prior to adding text to your design—that affect all subsequently added text. Establishing attributes in advance is done through the Options menu; editing attributes of existing text is done through the Edit menu (refer to “Editing Existing Text and Text Attributes” on page 6-36).

**Note** Changes made to the settings in this dialog box exist only in memory unless you save them to a file. For details on saving to a file, refer to the section, “Saving and Reading Preference Files” on page 9-20.

To establish text attributes:

1. Choose **Options > Preferences > Text** and set the text attributes as desired.

   - **Font Type**—All TrueType fonts installed on your system are available. Select the desired font from the drop-down list. When printing to an HP-GL/2 file, text information will not be saved if the font is a TrueType font. To preserve the text in your output file, convert it to HersheyRomanNarrow before saving to HP-GL/2.

   **Note** On UNIX, if you want to add additional TrueType fonts that were not supplied with ADS, copy them to $HPEESOF_DIR/lib/fonts (where $HPEESOF_DIR represents your complete installation path).

   - **Point**—Represents the size of text in traditional units used in printing.
   - **Justification, Horizontal**—This setting represents two types of justification: one is how individual lines of text in a block of text are aligned with one another; the second is how an individual line of text or block of text is positioned horizontally, relative to the reference point you specified to begin typing the text.
   - **Justification, Vertical**—This setting aligns a string or block of text vertically, relative to the reference point you specified to begin typing the text.
   - **Placement Angle**—The angle at which all text subsequently added to your design will be drawn.
Setting Design Environment Preferences

- **Non-rotating (when in hierarchy)**—Select this option to prevent text on a symbol or design from being rotated when the symbol is rotated.

2. Change any or all options as desired and click **Apply** (or **OK** if you are not changing any other preferences).

**Setting Display Options**

The Display tab enables you to change the Foreground, Background, and Highlight colors.

**Note** Changes made to the settings in this dialog box exist only in memory unless you save them to a file. For details on saving to a file, refer to the section, “Saving and Reading Preference Files” on page 9-20.

- **Foreground**
  The color of the lines making up polygons, polylines, and arcs while they are being drawn.

- **Background**
  The color of the drawing area background in the design window.

- **Highlight**
  The color used to identify problem items (with respect to simulation), orphaned items in schematic and layout representations, and unconnected pins.

**Setting Units/Scale Options**

The settings in the Units/Scale tab of the Preferences dialog box serve as defaults in the following situations:

- When a parameter of a supplied component does not have a default unit and you do not assign one (in the component parameter dialog)

- When you supply a default parameter value without units while creating a parametric subnetwork (File > Design Parameters)
Note Changes made to the settings in this dialog box exist only in memory unless you save them to a file. For details on saving to a file, refer to the section, “Saving and Reading Preference Files” on page 9-20.

Setting Tuning Options

The Tuning settings in the Preferences dialog box serve as defaults and can be changed during tuning in the Tune Control and Tune Control Details dialog boxes.

Note Changes made to the settings in this dialog box exist only in memory unless you save them to a file. For details on saving to a file, refer to the section, “Saving and Reading Preference Files” on page 9-20.

Select the Tune Analysis mode that you want to serve as the default:

• **Analysis Mode**
  - Single—Perform analysis after each change
  - Multiple—Perform analysis only after the Tune button is clicked. This is designed for tuning after multiple changes, but can be used for single changes.
  - Continuous—Perform analysis while the slider is moving

• **Trace History**
  - Number of traces to display—Set the default number of traces to be displayed on your plots

Set the following Slider options to the desired defaults:

• **Range Min and Max**—Set the minimum and maximum range to the initial parameter value plus or minus the percent you enter here

• **Step Size**—Enter a percentage of the initial parameter value

• **Slider Scaling**—Choose Linear or Logarithmic
Setting Design Environment Preferences

**Saving and Reading Preference Files**

When you create a project, the files `schematic.prf` (for the Schematic window) and `layout.prf` (for the Layout window) are copied to the new project from the installation directory. You can work with these default preferences or you can customize them and save them.

- To use the same set of customized preferences for every design in the project, customize the files with the default filenames (`schematic.prf` and `layout.prf`). By default, these preference files are associated with every design in the project.
- To use different sets of preferences for different designs in the project, customize the preferences as needed and save them to a preference file with a unique name. To associate a customized preference file with a specific design, open the design, read the customized preference file, and save the design.

Whenever you open a design, the last preference file associated with it is automatically read. You can save any number of files containing customized preferences. All the preferences set through the Preferences dialog box can be saved to a preference file in this manner.

**Note** When you save a preference file, all the current settings found in the Preferences dialog box are also saved, with the following exception: Options that may be set differently within an individual design, such as text height, are not saved in the preference file.

To save customized preference files:

1. Change any desired settings in the Preferences dialog box and click **Apply**.
2. Click **Save** in the Preferences dialog box. The Save Preference File dialog box appears, displaying the default filename, `schematic.prf`.
   - To use the default filename for the current settings, click **OK**.
   - To use another filename, enter a name of your choosing (the .prf extension is added automatically) and click **OK**.
To read in a previously saved preference file:

1. Click **Read** in the Preferences dialog box. The Read Preference File dialog box appears.

2. Select the desired file from the list of files, and click **OK**. (You can read in preference files from other project directories.)

**Hint** The variable that defines the search path for these files is PREFERENCES_PATH. For details refer to Appendix D, Customizing the ADS Environment

---

**Specifying Layer Definitions**

All shapes and text are entered on layers. By placing various groups of items on different layers, each of which may be assigned different characteristics, you can customize and easily alter the overall visual effect of the design in the viewing area.

The Layer Editor dialog box enables you to:

- Change display characteristics on a layer-by-layer basis
- Define new layers
- Change the plotting priority of layers (Layout window)
- Turn the display of items on and off on any specified layer. For example, you can turn on and off the display of any or all the parts making up component text—Name (labels), ID (identifiers), Parameters (parameters).
- Protect items on any given layer from being selected, that is, when clicking in the drawing area to select items, those items on a protected layer cannot be selected as you edit your design. This is helpful when you have a lot of editing to do on certain kinds of items, but not others, in a crowded design.
- Save the layer definitions to the default schematic.lay file or to a unique filename.lay file

At any time during the modification of layer definitions, if you have not yet clicked **Apply**, you can click **Reset** to return to the previous settings.
Note  The layer number—not the name—is the common identifier used in both the
design file and the layer file, and should not be changed.

The order in which layers are plotted is determined differently in the Schematic
window than it is in the Layout window.

• In the Schematic window, layers are plotted in numerical sequence—based on
the layer number—beginning with zero and ending with the highest number.
You can rearrange layers in the list for your convenience, but it will have no
effect on the plotting order.

• In the Layout window, the position of the layers in the list, relative to each
other, indicates their priority when plotted. Higher priority layers are plotted
on top of lower priority layers—the lower in the list, the higher the priority.

The following figure shows the list of default defined layers. These are the default
layers in the Schematic window; for details on layers in the Layout window, refer to
the Layout manual.
Important  Be sure to use compatible layer definitions for related designs, especially designs that are related hierarchically.

To move a layer within the layer list:

1. Click once to highlight the layer ID or Name.
2. Click Cut. The name and number disappear from the list.
3. Highlight the layer you want to paste the cut layer above, click Paste and click Apply.

To delete a layer:

Note  Do not delete the supplied, default layer definitions; the ability to delete is provided to enable you to redefine layer definitions you have created. Deleting supplied layer definitions will degrade the appearance of your schematic, as parts whose layer has been deleted will now be drawn on the default layer.

1. Click once to highlight the layer ID or Name.
2. Click Cut. The name and number are deleted from the list, and that number is now available for a new layer. (Hint: If you change your mind, use Paste to add the layer back.)

To change a layer’s name:

1. Click in the Name field and change the name as desired.
2. Click Apply.

To add a layer:

1. Click New from the group of buttons labeled Layer.
Setting Design Environment Preferences

The layer list scrolls to the bottom and a new layer is added. The layer number is the next available, sequential number, and a default name appears that includes the layer number.

2. Rename the layer as desired and click Apply.

Setting Colors and Fill Patterns

The Color/Pattern columns of the Layer Editor dialog box enable you to choose colors and fill patterns of items, on a layer-by-layer basis.

To change color and/or pattern settings for any given layer:

1. Click to access the available colors or patterns (PC—click the arrow for the drop-down list; UNIX—click the color bar itself) from the color or pattern box of the layer you want to modify.
2. Click the desired color or pattern (UNIX—click OK).
3. The new color is displayed in the Layer Editor dialog box. To see the change in the drawing area, click Apply.

Note  When choosing Fill Patterns, keep in mind that the patterns produced by a Postscript printer are Postscript fill patterns and will vary somewhat from those on your screen.
Setting Shape Display Characteristics Layer-by-Layer

All shapes are drawn with one of the following display types:

- Both (both an outline and a fill pattern)
- Outline (an outline with no fill pattern)
- Filled (a fill pattern with no outline)

The following illustration shows the shape display Both, where you see both the fill pattern and the outline.

![Shape Display Illustration](image)

The Shape Display drop-down list for each layer enables you to choose the shape display of items, on a layer-by-layer basis.

```
Shape Display
Outline
```

**Hint** For details on changing the shape display globally for all layers, refer to the section, “Setting Layer Characteristics Globally” on page 9-27.

Setting Line Style Characteristics Layer-by-Layer

When you include the Outline of shapes as part of Shape Display on any given layer, you can also choose a line style for that outline. Click to select a different line style from the drop-down list.

```
Line Style
Solid
```
Hint For details on changing the line style globally for all layers, refer to the section, “Setting Layer Characteristics Globally” on page 9-27.

Setting the Visibility of Items Layer-by-Layer

The Vis (visible) column enables you to turn on and off the display of items on any given layer. For example, if you want to print or plot your schematic without component annotation, you could make the labels, identifiers, and parameters layers invisible. By default, all layers are visible.

Hint For details on changing the visibility globally for all layers, refer to the section, “Setting Layer Characteristics Globally” on page 9-27.

Setting the Selection Status of Items Layer-by-Layer

If you need to edit certain types of items (that reside on a given layer) and not others (that reside on other layers), and the selection filters do not meet your needs, you can prevent items from being selected by disabling the Sel (select) option for any layers as needed.

When you disable the select status for any given layer, items on that layer will not be selected as you edit your design.
Hint For details on changing the shape display globally for all layers, refer to the section, “Setting Layer Characteristics Globally” on page 9-27.

Setting Layer Characteristics Globally

This section of the Layer Editor dialog box enables you to change the Selection, Visibility, Shape Display, and Line Style status of all layers at once. For example, if you want to prevent selection on all layers except one or two of them, use Select None, then select the individual layers you want access to, and turn on the Select status for those layers.

<table>
<thead>
<tr>
<th>Select</th>
<th>Visible</th>
<th>Shape Display</th>
<th>Line Style</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>All</td>
<td></td>
<td></td>
</tr>
<tr>
<td>None</td>
<td>None</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Miscellaneous Layer Editor Features

• The Ins (insert) column enables you to change the current entry layer while working in the Layer Editor dialog box so that you can quickly see the effect of your changes.

• The Reverse button toggles the display of the layer list top-to-bottom, or vice versa.

• The Visibility tab enables you to reduce the size of the Layer Editor dialog box while keeping the most commonly used features of it available for editing.
Saving and Reading Layer Files

The default layer definitions are contained in the files schematic.lay (for the Schematic window) and layout.lay (for the Layout window). These files are read automatically—from the installation directory—every time you open a design, unless you have explicitly associated another layer file with that design. To associate a customized layer file with a specific design, open the design, read the customized layer file, and save the design. Whenever you open a design, the last layer file associated with it is automatically read.

You can create any number of files containing customized layer definitions, and subsequently read in any of these files for any design.

To save customized layer files:

1. Make all the desired changes in the Layer Editor dialog box and click **Save**. The Save Layer File dialog box appears, displaying the default filename, schematic.lay.
2. To use the default filename for the current settings, click **OK**.
   For another layer file, enter a name of your choosing (the .lay extension is added automatically) and click **OK**.

To read in a previously saved layer file:

1. Click **Read** from the Layer Editor dialog box. The Read Layer File dialog box appears.
2. Select the desired file from the list of files, and click **OK**. (You can read in layer files from other project directories.)

**Hint**  The variable that defines the search path for these files is LAYERS_PATH. For details refer to Chapter 1, Customizing the ADS Environment, in the Customization manual.
Changing the Current Entry Layer

To change layers:

1. Choose **Insert > Entry Layer** and a dialog box appears listing all the currently defined layers.
2. Select a layer that is appropriate for the task at hand.
3. Click **OK**. Anything you draw now is drawn on this layer. The name of the layer is displayed in the status panel of the Schematic window.

Customizing Keyboard Shortcuts

Advanced Design System allows you to redefine default keyboard shortcuts as well as create new ones.

To change or add a keyboard shortcut:

1. Choose **Options > Hot Key/Toolbar Configuration** and click the **Hot Key** tab in the dialog box that appears.
2. Select the menu name or menu/command sequence from the Category list box.
3. Select the command from the Item list box. If a shortcut currently exists for the item, the current assignment is displayed.
4. Select the modifier key(s)—Ctrl, Alt, Shift—and type the letter(s) you want to use in the Key field (UNIX is case-sensitive; the PC is not). If the combination you choose is currently assigned to another command sequence, you are warned and given the opportunity to go ahead with the change or select another key sequence.
5. To replace the assignment with your own choice, continue, otherwise choose a new key combination and click Apply. When you are through making all keyboard changes, click OK to dismiss the dialog box.
Setting Design Environment Preferences

For a list of default keyboard shortcuts, refer to Appendix B, Shortcut Keys.

Configuring Toolbars

By default, the toolbar in each design window contains:

- A pull-down scrollable list for selecting the group of components you want to place on the palette (Palette List)
- A dynamically updated list of components you have placed in that window (Component History)
- In the Layout window, a pull-down scrollable list for selecting a different entry layer (Entry Layer List)
- A button for choosing the orientation of the component you are about to place
- Buttons representing frequently used commands

You can reconfigure these default toolbars and create your own to better meet your design needs (Options > Hot Key/Toolbar Configuration).

Customizing an Existing Toolbar

To reconfigure an existing toolbar:

1. Choose Options > Hot Key/Toolbar Configuration and click the Toolbar tab in the dialog box that appears.
2. In the Toolbar Group list box, select the name of the toolbar you want to change.
3. To add or delete icons, use one of the following methods:
• To delete an icon from the toolbar, select the associated command in the Tool Item list box, and click the Cut button.

![Toolbar Item Example](image)

Select the command

Click the Cut button

• To add an icon to the toolbar, select the appropriate menu/command sequence from the Menu Category list box, select the command from the Menu Item list box, and click the Add button. The command is added to the Tool Item list box.

![Menu Category and Menu Item Example](image)

When you select a command, its default bitmap is displayed

**Hint** When you add a button to the toolbar, its position relative to the other buttons is determined by its position in the Tool Item list box. Before you click the Add button, be sure to highlight the command that the new command should follow. In this example, Zoom In Point was highlighted before the Add button was clicked so that Redraw View would take the place of Pan View (deleted in the previous example).
4. If you want to edit another toolbar, click Apply to effect these changes and begin the process again. When you are through making changes to the toolbars, click OK.

**Creating a New Toolbar**

To create a custom toolbar:

1. Choose Options > Hot Key/Toolbar Configuration and click the Toolbar tab in the dialog box that appears.

**Hint** The position of the new toolbar, relative to the position of any existing toolbars, is determined by its position in the Toolbar Group list box; the new name is added below the name that is highlighted when you click the Add button. For example, if you keep both default toolbars and want to add a third one below them, highlight the bottom one before you click the Add button.

2. Supply a name in the Toolbar Name field and click **Add**.

```
Toolbar Name
my_toolbar

Add  Cut
```

The name you supply is added to the Toolbar Group list box.
Creating a Custom Component Palette

Creating a custom component palette can speed up the design creation process by grouping frequently used items in one or more palettes.

To create a custom palette:

1. Choose View > Component > Create Component Palette and a dialog box appears.

   **Hint** By default, the components currently listed in Component History are listed for inclusion in the new palette. If this list does not represent a significant number of components you want to include on the new palette, use the Clear Component History command to avoid individually selecting and cutting components from the custom list.

2. Cut any components from the New Palette Group Components list box, as necessary.

3. Select a palette, from the List of Palette Groups, that contains components you want in the custom palette.

4. Select the desired component, from the Palette Group Components list box, and click Add.
5. Repeat as needed to include additional components from any palette.

6. Provide a name for the new palette in the New Palette Group Description field. This is the name that will appear in the drop-down Palette List enabling you to place the custom group on the palette.

Turning On/Off the Coordinate Readout Display

There are two types of coordinate readouts, positional and differential.

- Positional—the X,Y coordinates of the cursor position in relation to the total window. By default, the lower left corner is 0,0. This display also reflects the current precision setting (in this example, 1,000).

- Differential—the distance in X,Y the cursor has traveled since the last click. Set the starting point to 0,0 by clicking the left mouse button anywhere in the drawing area.

The X,Y coordinate readouts are displayed in the status bar of each window. By default, Positional readouts are turned on in every window.

<table>
<thead>
<tr>
<th>Positional</th>
<th>Differential</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.375, 4.000</td>
<td>1.125, 0.500</td>
</tr>
</tbody>
</table>

You can turn the coordinate readout on or off from the View menu.
Chapter 10: Working with Symbols

Symbols are used to represent individual components in a schematic and subnetworks in hierarchical designs. Default symbols exist for schematics with 0 to 99 ports, but you might want to draw your own symbol for any of the following reasons:

- You want a symbol you feel better represents the schematic
- You want to replace the default symbol of a simulator component with one of your own
- You create a new simulator component (using the model builder) and need to create a schematic symbol for it

Schematic symbols consist of a symbol body and, optionally, symbol pins (interconnect points). If you are drawing a symbol to represent an electrical component or a subnetwork for a hierarchical design, you must add pins to the symbol body.

The default symbols have been created in a uniform manner. Custom symbols should be created in a similar manner, that is, their overall length, from pin to pin, should be a multiple of 0.125 inch. This ensures the custom symbol will connect easily to the set of supplied symbols. In addition, pin 1 should be located at the coordinates 0,0 which serve as the reference point when you place the symbol in a design.

A symbol can be defined in one of two ways:

- As part of a design file containing a schematic—when you need the symbol to represent only that schematic
- In a design file containing nothing but the symbol—when you want the symbol to be available to represent any schematic

An illustration representing these differences is shown next.
Switching Between Schematic and Symbol Views

When you are creating a schematic, the View menu displays the command Create/Edit Schematic Symbol. When you choose this command, you display the symbol view of the current design. If you look at the View menu again, you will see that the command name has changed to read Create/Edit Schematic. This enables you to switch back and forth between these views.
 Generating a Symbol

When you are finished creating your schematic, you can generate a symbol for it as follows:

1. Choose Create/Edit Schematic Symbol.
2. Specify the desired symbol characteristics (or accept the defaults). The symbol characteristics are defined as follows:
   - **Symbol Type**
     - Dual—Restricts pins to two sides of symbol body
     - Quad—Allows pins on all four sides of symbol body
   - **Order Pins by**
     - Location—Numbers symbol pins in the same relative order as the ports on the schematic
     - Number—Numbers symbol pins sequentially in a left-right, top-down order
   - **Replace existing symbol**—Replaces the current symbol, if one exists, with the one you are about to generate
   - **Lead Length**—The length of any line drawn between the symbol body and a pin
   - **Distance Between Pins**—Distance between pins drawn on the same side of the symbol body
3. Click OK. A symbol is drawn consisting of a symbol body, connecting lines, and pins.

**Hint** To regenerate the symbol specifying different symbol characteristics, choose Insert > Generate Symbol.

You can edit the generated symbol as desired at any time, including assigning the desired characteristics to each pin through the Edit > Symbol Pin command (refer to “Adding Pins to Your Symbol” on page 10-7).

To restore the view of your schematic:

Choose View > Create/Edit Schematic and your schematic reappears.
Working with Symbols

Once you have generated a symbol for your schematic and saved the file, the program automatically assigns the design filename as the symbol name (File > Design Parameters). This means that any time this schematic is placed as a subnetwork, the symbol used to represent the schematic will be the symbol contained in the design file itself. For additional information on assigning a symbol to a schematic, refer to the section “Assigning a Symbol to a Schematic” on page 10-9.

Drawing a Custom Symbol

When you draw a custom symbol, you can draw it in a file containing a schematic, where it will be dedicated to that schematic, or you can draw it in an empty file and use it to represent any schematic.

Drawing Setup

Before you begin, you may find it helpful to review a number of the program’s defaults, and you will most likely need to make a few changes.

Setting Snap and Grid Spacing

By displaying a grid and drawing with snap enabled, you can quickly draw objects with great accuracy. To view or change these settings, use Options > Preferences > Grid/Snap. Snap mode offers options for snapping to many different types of objects. These options are all described in the section, “Setting Grid/Snap Options” on page 9-6. When drawing a custom symbol, the most important option will probably be Grid, however if you are drawing complex shapes, several other options may be helpful.

The display grid can be made visible or invisible. When you turn on the grid display, you should specify a sufficiently large factor of the snap spacing so that a grid is displayed even when the snap spacing is very fine. For example, the default snap spacing (in the Schematic window) is 0.125 which means the cursor snaps every 1/8 inch. The default display factor is 2 which means that the dots appear every 1/4 inch (0.125 x 2).

Before you begin drawing, check to see if the current grid spacing is set to something other than the default of 0.125 inch, and if it is, change it back to the default and make sure Enable Snap is turned on. This step ensures that your custom symbol will easily connect to the set of supplied symbols.
Hint  Once you have drawn the symbol body and pins, you can change these settings if desired. For example, you might want to turn snap off before adding text to your design to give you more flexibility in the positioning of the text.

**Specifying the Drawing Layer**

All shapes and text are entered on layers. The color and visibility of any shape is controlled by the layer on which it is drawn. Before you begin drawing any part of the symbol, change the current entry layer in accordance with the part you are about to draw. For example, if you are creating a custom symbol, you should draw the symbol body, pins, and lead lines on the symbody layer so that it will be on the same layer as the supplied symbols, and subject to changes you make to that layer.

To change layers:

1. Choose **Insert > Entry Layer** and a dialog box appears listing all the currently defined layers.

2. Select a layer that is appropriate for the task at hand.

3. Click **OK**. Anything you draw now is drawn on this layer. The name of the layer is displayed in the status panel of the Schematic window.

*Table 10-1* lists the default layers and the types of items placed on those layers (by default).

<table>
<thead>
<tr>
<th>Layer name</th>
<th>Layer number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>default</td>
<td>0</td>
<td>Objects drawn on an undefined layer are plotted on this layer. Also, if you delete a layer, any objects residing on that layer are moved to this layer.</td>
</tr>
<tr>
<td>user_symbody</td>
<td>1</td>
<td>User-created schematic symbol</td>
</tr>
<tr>
<td>user_symtxt</td>
<td>2</td>
<td>User-created schematic symbol text</td>
</tr>
<tr>
<td>user_symbol</td>
<td>3</td>
<td>User-created schematic symbol</td>
</tr>
<tr>
<td>wire</td>
<td>4</td>
<td>Wires</td>
</tr>
<tr>
<td>text1</td>
<td>5</td>
<td>Available layer name for text</td>
</tr>
<tr>
<td>labels</td>
<td>6</td>
<td>Component or item names</td>
</tr>
<tr>
<td>identifiers</td>
<td>7</td>
<td>Unique ID of components or items</td>
</tr>
</tbody>
</table>
Table 10-1. Layer Names, Numbers, and Descriptions (continued)

<table>
<thead>
<tr>
<th>Layer name</th>
<th>Layer number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>parameters</td>
<td>8</td>
<td>Parameters of components or items</td>
</tr>
<tr>
<td>pin_num</td>
<td>9</td>
<td>Pin numbers and names for symbols†</td>
</tr>
<tr>
<td>notes</td>
<td>10</td>
<td>Any additional descriptive information you want to add</td>
</tr>
<tr>
<td>symbody</td>
<td>11</td>
<td>Schematic symbol body outline</td>
</tr>
<tr>
<td>symdesign</td>
<td>12</td>
<td>Portion of schematic symbol contained within symbol body</td>
</tr>
<tr>
<td>SPint</td>
<td>13</td>
<td>Signal Processing integer data††</td>
</tr>
<tr>
<td>SPfix</td>
<td>14</td>
<td>Signal Processing fixed point data††</td>
</tr>
<tr>
<td>SPfloat</td>
<td>15</td>
<td>Signal Processing floating point data††</td>
</tr>
<tr>
<td>SPcomplex</td>
<td>16</td>
<td>Signal Processing complex data†††</td>
</tr>
<tr>
<td>SPtimed</td>
<td>17</td>
<td>Signal Processing timed data†††</td>
</tr>
<tr>
<td>SPany</td>
<td>18</td>
<td>Signal Processing any data type††</td>
</tr>
<tr>
<td>SPother</td>
<td>19</td>
<td>Signal Processing user-defined data††</td>
</tr>
<tr>
<td>symtext</td>
<td>20</td>
<td>Text contained within schematic symbol body</td>
</tr>
<tr>
<td>symbodyFilled</td>
<td>21</td>
<td>Schematic symbol body with fill pattern</td>
</tr>
<tr>
<td>symbodySlash</td>
<td>22</td>
<td>The slash that identifies pin 1</td>
</tr>
</tbody>
</table>

† The pin_num layer is visible by default, but you must turn on Pin Numbers and/or Pin Names in the Visibility (on/off) section of the Pin/Tee tab of the Preferences dialog box to make pin numbers and names appear.
†† For details, refer to Chapter 16, Data Types for Model Builders, in the Agilent Ptolemy Simulation manual.
Drawing the Symbol Body

The commands you need to draw your symbol can be found on the Insert menu. In addition, many of them are available on the default toolbar. For details on using these commands, refer to the section, “Drawing Shapes” on page 7-4.

---

**Note**  The Layer Editor dialog box enables you to determine the color and fill pattern, shape display, and line style for objects drawn on each layer. For details, refer to the section, “Specifying Layer Definitions” on page 9-21.

---

Adding Pins to Your Symbol

Remember that symbol pins should be located at 0.125-inch intervals so that your custom symbol will connect easily to the set of supplied symbols. In addition, pin 1 should be placed at the coordinates 0,0. Choose any of the methods shown below to accomplish this.

To specify 0,0 in the process of drawing pin 1:

1. Choose **Insert > Coordinate Entry** and a dialog box appears.
2. Choose **Insert > Symbol Pin** and a dialog box appears. Define the pin characteristics as described in the section, “Establishing Pin Characteristics” on page 10-8, and click **Apply**.
3. Enter the coordinates 0,0 in the Coordinate Entry dialog box and click **Apply**. Pin 1 is placed at 0,0. You can now use the View All command to reposition the image in your design window.

To move 0,0 to the center of the window before you begin:

1. Choose **Pan** from the View menu or the pop-up menu.
2. Click the small cross identifying the 0,0 coordinates (lower left corner of the drawing area). The 0,0 coordinates move to the center of your design window.
3. Choose **Insert > Symbol Pin** and a dialog box appears. Define the pin characteristics as described in the section, “Establishing Pin Characteristics” on page 10-8.
To move pin 1 to 0,0 after you have placed it:

1. Choose **Insert > Symbol Pin** and a dialog box appears. Define the pin characteristics as described in the section, “Establishing Pin Characteristics” on page 10-8, and click **Apply**.

2. Choose **Edit > Modify > Set Origin**.

3. Click the pin. The pin moves to 0,0. You can now use the View All command to reposition the image in your design window.

**Establishing Pin Characteristics**

The pin characteristics are defined as follows:

- **Name**—Optional. The pin name is not displayed on your schematic unless you select the Pin Names option in Options > Preferences > Pin/Tee.

- **Number**—Optional. A default pin number is displayed. This number is automatically incremented as each pin is added. To display pin numbers on the schematic, select Pin Numbers in Options > Preferences > Pin/Tee.

- **Orientation Angle**—Optional. This feature is only used by the program when generating a schematic from a layout. It enables you to specify an orientation angle for each pin that determines the orientation of an item connected directly to that pin. Any angle from -90 to 180 degrees is allowed, but we recommend 90-degree increments. The recommended angles for schematic symbol pins are shown in the following illustration.

```
  90

  180

  0

  -90
```

- **Type**
  - **Input**—Identifies the pin as an input port
  - **Output**—Identifies the pin as an output port
  - **Input/Output**—Identifies the pin as an input or output port
Note When you create a symbol for use with any design, it is only available in the project directory in which you create it, unless you modify certain configuration files (and for model builder usage, modify AEL files according to stated guidelines). If you want the symbol to be available for all design work, refer to the section, “Making Symbols Available Globally” on page 10-10.

Assigning a Symbol to a Schematic

Each symbol provided is stored in its own design (.dsn) file. If you generate a symbol for a particular schematic, or create one manually in a design file containing a schematic, then that symbol is stored in the same design file as the schematic. Unless you explicitly specify the name of another symbol, the schematic will be represented by the symbol found in the design file itself. You can verify the symbol being used by choosing File > Design Parameters, clicking the General tab and noting the name in the Symbol Name field. If it reflects the current design name (minus the .dsn extension), the symbol in this file will be used.

If you create a symbol in its own design file—which makes it available to represent any schematic—you must assign that symbol to the desired schematic.

To assign a symbol to the schematic:

1. Open the schematic design.
2. Choose File > Design Parameters and the Design Definition dialog box appears.
3. In the Symbol Name field, type the name of the file (minus the .dsn extension) that contains the desired symbol.
4. Click OK.
Working with Symbols

**Hint** If you generate a symbol and then decide to use a custom one instead, after you type the symbol filename in the Symbol Name field, click the Save AEL button in the dialog box to save the change.

5. Choose *File > Save Design.*

The next time you place this design within another design, the new symbol will appear.

**Making Symbols Available Globally**

Custom symbols are only available in the project directory where you create them unless you modify the search path of a particular variable in a configuration file. In addition, if you want the names of these symbols to appear for selection within the related dialog box, you must modify a certain AEL file.

While it is possible to leave all files containing custom symbols in the project directories in which they were created, the aforementioned configuration changes will be greatly simplified if you move all custom symbols to central locations, one location for individual use and one for site use. (If necessary, see your system administrator to create the directory for site use.) We recommend maintaining the same directory structure used by Advanced Design System. Thus, the symbols should be placed in the following locations, in accordance with their use (circuit vs. hptolemy):

**Use these directories on UNIX:**

<table>
<thead>
<tr>
<th>UNIX</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Individual Use</strong></td>
<td>$HOME/hpeesof/circuit/symbols</td>
</tr>
<tr>
<td></td>
<td>$HOME/hpeesof/hptolemy/symbols</td>
</tr>
<tr>
<td><strong>Site Use</strong></td>
<td>$HPEESOF_DIR/custom/circuit/symbols</td>
</tr>
<tr>
<td></td>
<td>$HPEESOF_DIR/custom/hptolemy/symbols</td>
</tr>
</tbody>
</table>
Use these directories on the PC:

<table>
<thead>
<tr>
<th>PC*</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Individual Use</td>
<td>%HOME%/ hpeesof/ circuit/ symbols</td>
<td>%HOME%/ hpeesof/ hptolemy/ symbols</td>
</tr>
<tr>
<td>Site Use</td>
<td>%HPEESOF_DIR%/ custom/ circuit/ symbols</td>
<td>%HPEESOF_DIR%/ custom/ hptolemy/ symbols</td>
</tr>
</tbody>
</table>

* %HOME% represents the path you specified as the Home Folder during installation (C:\ users\ default by default); %HPEESOF_DIR% represents the path you specified as your Program Folder during installation (C:\ AdvDesSys by default).

**Note** If you use a directory other than one of those shown in the tables, then you must declare the variable USR_DSN_PATH and provide the search path.

To access custom symbols—if stored in a directory other than one of the defaults:

1. Using any text editor, open the file $HOME/ hpeesof/ config/ de_sim.cfg.
2. Add the variable USR_DSN_PATH and set it equal to the path you have chosen for your symbols directory.
3. Save the file.

Once you have created the symbols directory (regardless of where), move the files containing the custom symbols from their current project directory locations into the appropriate, newly created directory.
Modifying Search Paths

Search paths that control the order of directories searched are defined by certain program variables. These variables should be modified in a local copy of the de_sim.cfg file. This file is written to the / config directory during installation and should not be modified there. But you can open this file and copy the default variable definition (where applicable), then paste it in your own local copy and modify it. (This simplifies typing a lengthy search path.)

The program creates a de_sim.cfg file automatically in $HOME/ hpeesof/ config. Settings modified here apply to all projects.

To modify the search path of the variable:

1. Using any text editor, open the de_sim.cfg file in $HPEESOF_DIR/ config.
2. Locate the variable definition, copy it, and close the file.
3. Open the de_sim.cfg file in your $HOME/ hpeesof/ config directory and paste the variable definition.
4. Edit the variable definition as needed.
5. Save the file.
Chapter 11: Printing and Plotting

This chapter describes printing and plotting from Advanced Design System. You can send output to printers and plotters as well as to file in a variety of formats. When printing to file, the format of the file is determined by the current output device and the file is saved in the current project directory.

You can connect any output device that is supported by your operating system. To connect additional printers and plotters, and select a default printer, choose the appropriate method for your platform:

- Windows NT—Print Manager
- Windows 95, 98, and 2000—Start menu > Settings > Printers
- UNIX—Choose File > Print Setup > Install > Add Printer

The basic Print commands are summarized next:

- Use the Print command to print the contents of the drawing area of the current window
- Use the Print Area command to print a region of the drawing area
- Use the Print Setup command to establish a default printing configuration, although you can modify it at the time of printing

Note For detailed information on printing and print setup options on the PC, refer to your Windows documentation.

Because the print methods vary significantly between UNIX and the PC, this chapter describes printing from these platforms separately. Refer to the appropriate section for your platform:

- “Printing from UNIX” on page 11-2
- “Printing from the PC” on page 11-12
Printing and Plotting

**Printing from UNIX**

Printing and plotting from Advanced Design System on UNIX is accomplished by establishing the desired print setup and then choosing File > Print. The Print Setup and related dialog boxes enable you to:

- Choose to send output to a printer/plotter or print to file
- Install additional printers
- Select a printer (if sending to printer) other than the default
- Select a file format (if printing to file)
- Select Portrait or Landscape orientation
- Scale the output
- Specify the number of copies

When you select a printer, you can change the following default printer-specific options:

- Resolution
- Page Size
- Paper Tray

When you choose File > Print, you can select from the following additional options:

- **Convert to HP-GL/2 file**
  Select this option to print to file using the HP-GL/2 format.
- **Color output**
  Select this option to print in color (on a color printer) or in grayscale, rather than black and white (on a monochrome printer)
- **Scale to fit page**
  Select this option to fill the printed page. If selected, this option overrides any scaling factor you have set.

**Hint**

Click Options in the Print dialog box as a shortcut back to the Print Setup dialog box if you decide to make changes to the current setup.
Your print setup is saved in $HOME/.Xprinterdefaults. If you do not have a local copy of this file, or the file .Xpdefaults (from a previous release), the default file is read from the $HPEESOF_DIR/xprinter directory. When you change your print setup, the changes are saved (as new defaults) to $HOME/.Xprinterdefaults. Note: If you do have a file .Xpdefaults (from a previous release), the settings of this file are copied to the new filename to serve as the starting point for your print setup. Both files are valid, depending on which release of ADS you are using. The old file is maintained for running an earlier version of ADS, but the new file is used when you run ADS 1.5.

Adding a Printer

The basic steps required for adding a printer through the Print Setup dialog box are: defining a port and associating a printer with that port.

To define a port and add a printer:

1. Choose File > Print Setup and a dialog box appears.
2. Click **Install** and a dialog box appears listing all currently installed printers.
3. Click Add Printer and a dialog box appears listing all available printer devices and all currently defined ports.

![Add Printer Dialog Box]

- Add Highlighted Printer and Port to List of Installed Printers
- Provides Access to Dialog Box for Defining a New Port
- Close Dialog Box Accepting Changes

**Note** For a list of supported printers, see filename_map.txt in $HPEESOF_DIR/xprinter. Visit the Bristol web site if you need printer drivers (www.bristol.com/xprinter/download/ppds).
4. Click **Define New Port** and a dialog box appears listing all currently defined ports.

5. Add all ports you want to access for printing:
   - On HP 700 and Sun Solaris workstations, click **Spooler** and the list of ports is automatically generated (based on your printcap file).
   - On all other workstations, type the port definition in the Edit Port field using the following syntax: `printer name=print command` (no spaces around equal sign), where print command is the print alias, just as you would type it in the terminal window. Click **Add-Replace**. Repeat for each desired port.

   **Note** Port names can be any names you choose with the exception of FILE: which is a reserved port name.
6. Click **Dismiss** to accept the new port definitions and return to the Add Printer dialog box. The Current Port Definitions list box is updated.

   ![Current Port Definitions](image)

7. Select the desired printer from the list of Printer Devices.
8. Select the port you want to associate with this printer.

   ![Printer Devices](image)

9. Click **Add Selected**. The Printer Installation dialog box is updated.

   ![Currently Installed Printers](image)

   If you defined multiple ports, you can associate a printer with each, as just described.

10. **Dismiss** the Add Printer and Printer Installation dialog boxes. You will now be able to select any of the installed printers, as needed.
Selecting a Printer

To select a printer other than the current default:

1. Choose File > Print Setup.
2. Select Printer as the Output Format in the Print Setup dialog box.

3. Click Options and a dialog box appears.

4. Select the desired printer from the Printer Name drop-down list. The printer-specific options are updated to reflect the default options for the selected printer.

5. Change any or all of these options as needed and click OK.

6. Set the following options, in the Print Setup dialog box, as desired for the current printer:
   - Orientation
   - Scale (the value 2.0 would double the size; 0.5 would reduce it by half)
   - Copies

**Hint** Like all other information in the setup-related dialog boxes, settings made here become the new defaults for this printer.

7. Click OK and the current printer configuration information is saved.
Sending Output to the Printer

To send the entire contents of the window to the printer:

1. Choose File > Print and a dialog box appears.
2. Select any print options as needed, and click OK.

**Hint** The Scale to fit page option will fill the printed page, regardless of the current value in the Scale field of the Print Setup dialog box

Creating a Printer-specific Print File

You can create a print file in the format used by a particular printer by associating that printer with the FILE: port. This port appears by default in the Add Printer dialog box. Once you make the association, you can select this printer as the current printer and create a print file for it.

To associate the desired printer with the FILE: port:

1. Choose File > Print Setup.
2. Click Install > Add Printer.
3. Select the desired printer and the FILE:= port definition.
4. Click Add Selected. The Printer Installation dialog box is updated.
5. **Dismiss** the Add Printer and Printer Installation dialog boxes.
Printing and Plotting

To make this printer the current printer:

1. Click **Options** and select the printer associated with FILE: from the Printer Name drop-down list.

![Options dialog box]

2. Change any options as needed and click **OK**.
3. Click **OK** in the Print Setup dialog box.

To create the print file:

1. Choose **File > Print**.
2. Select any print options as needed, and click **OK**. A dialog box appears prompting you for a filename.
3. Change directories if desired—the file is written to the current project by default—and supply a name in the Output To File field. Click **OK**. The file is written to the specified directory.
Printing to File in a Generic Format

You can send your output to file, in a limited number of generic formats, which can then be imported in a variety of applications. The available formats are:

- Encapsulated Postscript®
- PCL4
- PCL5

Note You have the option of converting to an HPGL/2 file when you choose File > Print.

To establish a print setup for printing to file:

1. Choose File > Print Setup.
2. Select File (Generic Only) as the Output Format.
3. Select a different file type from the drop-down list as needed. The default File Name is updated to reflect the selected file type.
4. Set the following options as desired:
   - Orientation
   - Scale
   - Copies
5. Click OK in the Print Setup dialog box.

To print to file:

1. Choose File > Print and a dialog box appears offering additional options.
2. Select any or all of these options, as needed, and click OK.
3. The file is written to the current project directory, using the filename from the Print Setup dialog box.
Printing and Plotting

Printing from the PC

This section describes some of the actual printing features available on the PC. For information on basics (such as adding a printer), refer to your Windows documentation.

Printing from Advanced Design System on the PC is accomplished by establishing the desired print setup and then choosing File > Print (or Print Area). Listed below are some of the more common options you can set through the Print Setup and related dialog boxes:

Note The options available vary based on the printer/printer driver you select.

- Printer (select any installed printer)
- Paper size and source
- Orientation (Landscape is generally recommended for schematics and layouts)
- Number of copies
- Single- or two-sided printing
- Scaling

When you choose File > Print, you can select from the following additional options:

- **Print to file**: Select this option to send output to file for printing at a later time. Select Enhanced Metafile, Windows Metafile, or HP-GL/2 as the file format when the Print to File dialog box appears.

- **Color output**: Select this option to print in color (on a color printer) or in grayscale, rather than black and white (on a monochrome printer).

- **Copy to clipboard**: Select this option to place the image on the Windows clipboard (Bitmap) for pasting in any Windows application.

- **Fit to page**: Select this option to fill the printed page. If selected, this option overrides any scaling percentage you have set.
Establishing a Print Setup

To establish a print setup:

1. Choose **File > Print Setup**.
2. Select the desired printer from the drop-down list.
3. Change any of the options here as desired, or click **Properties** to set additional options, such as Scaling. Note that the appearance of the Properties dialog box varies depending on the selected printer.
4. Change any other options as desired and click **OK** to dismiss the Properties dialog box.
5. Click **OK** in the Print Setup dialog box and you are ready to print.
Basic Printing

To send the entire contents of the window to the printer:

1. Choose File > Print and a dialog box appears.

   Note  The Fit to page option overrides any scaling percentage set. Disable this option if you have intentionally set a scaling percentage.

2. Change any print options as needed, and click OK.

To print a specific region of your schematic or layout:

1. Choose File > Print Area. As you move your pointer into the drawing area, it changes to a cross-hair cursor, and the Status panel prompt changes to read, PrintArea: Enter the starting point.

2. Position the pointer at one corner of a window that will enclose the area you want to print, and click. The Status panel prompt changes to read, PrintArea: Enter the next point.

3. As you move the mouse, a ghost image of the window is drawn. Click again to specify the opposite corner of the window and the Print dialog box appears.

4. Change any options as needed and click OK to print the specified region.
Printing a Scaled Layout

To scale a layout for printing:

**Note** This process involves flattening and, potentially, scaling your layout in ADS. You can do this to your actual design—and then close it without saving changes—or make a copy of it before printing and make the changes to the copy.

1. Choose **File > Save Design As** to make a copy of the layout.
2. Choose **Edit > Component > Flatten** to convert it to shapes-only information. (Components are not scalable.)
3. Choose **Insert > Measure** and establish the size of the design.
4. Determine the appropriate scaling factor based on the actual size of the design and the paper size you want to use.

**Note** The ability to scale a design for printing is a function of the printer driver associated with the selected printer. In general, PostScript printer drivers enable scaling while PCL printer drivers do not. Many printer drivers can be downloaded from the Internet. If your printer driver does not allow a sufficiently large scaling factor, you can also scale the design in ADS to reach a combined scale factor appropriate for your layout.
The example shown here is based on a design from the examples directory: `/examples/mw_ckts/drc_via_prj/pwramp`.

This design measures 1525 microns (or 0.1525 cm) across, and is close enough to being square to use that measurement as the basis for determining a scaling factor. In this example we want to basically fill ANSI E paper (34" x 44") and so we convert the metric units to English units $0.1525 \text{ cm} \times 0.39370 = 0.06$ inches. To simplify this example, we settle on a 30 inch image, yielding a required scaling factor of 500 (30 / 0.06 = 500).

5. To verify the maximum scaling factor your printer driver allows, choose File > Print Setup and click Properties.
6. Locate the Scaling option. It may appear on the tab displayed by default, or in an Advanced tab, as shown in this example.

7. Select the Scaling option and supply the desired scaling percentage in the field provided.

   In this example, we opted for 500% (factor of 5) scaling through the printer driver, and a scale factor of 100 (for a total of 500) through ADS.

8. Select the Paper Size option and select the appropriate size.

9. Change any other options as desired and click OK to dismiss the Properties dialog box.

10. Click OK in the Print Setup dialog box.
11. If necessary, scale the design in ADS. Choose Select > Select All., then choose Edit > Scale/Oversize > Scale. Supply the desired scaling factor, in this example, 100, and click OK.

12. Choose View > View All.

13. Choose File > Print Area and draw a border around the layout. (This is to ensure best results, since printing otherwise begins at the coordinates 0,0 and may include empty space.)

14. When the Print dialog box appears, select any other options as desired, such as Color Output if your printer is a color printer.

Note: The Fit to page option overrides any scaling percentage set. Disable this option if you have intentionally set a scaling percentage.
Chapter 12: Using the Text Editor

Hpeesofedit is a general-purpose ASCII text editor capable of editing one file at a time. It enables you to cut and paste, search for text, replace text, and go to a specific line of text. You can access Hpeesofedit from the Options menu in the Main window or you can start it from any command shell. The topics described here are:

- “Starting the Text Editor Program” on page 12-1
- “Text File Management” on page 12-3
- “Editing Text Files” on page 12-5
- “Performing Search and Replace Operations” on page 12-6
- “Keyboard Mappings” on page 12-8

Starting the Text Editor Program

To start the text editor program:

- Choose **Options > Text Editor** in the Main window.
  
  or

- Type `hpeesofedit` in any command shell, and press **Return**.

The Hpeesofedit window appears.

The status bar displays warnings, the status of the search/replace operation, and the current line number and character position. The copyright message is displayed in the status bar until you begin typing. The text entry portion of the edit window displays all text you type or paste into the window.
Using the Text Editor

Command Line Options

The Hpeesofedit program accepts most standard X/Xt command line options. These options are listed in Table 12-1. (For further details on these options, refer to your UNIX documentation.)

Table 12-1. Command line options

<table>
<thead>
<tr>
<th>Option</th>
<th>Argument</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>-background, -bg</td>
<td>color_name</td>
<td>-bg white</td>
</tr>
<tr>
<td>-foreground, -fg</td>
<td>color_name</td>
<td>-fg blue</td>
</tr>
<tr>
<td>-display</td>
<td>display_name</td>
<td>-display unix:0</td>
</tr>
<tr>
<td>-geometry</td>
<td>geometry string</td>
<td>-geometry 300x400+10+30</td>
</tr>
<tr>
<td>-iconic</td>
<td></td>
<td></td>
</tr>
<tr>
<td>-xrm</td>
<td>X-resource</td>
<td>-xrm <strong>background:blue</strong></td>
</tr>
</tbody>
</table>

To start the Hpeesofedit program with a command line option:

In any command shell, type `hpeesofedit <desired option>` and press Return.

Alternatively, any of these resources can be specified in your resource file using Hpeesofedit as the class name. Hpeesofedit is also the resource filename for the program.

Note: Any option not preceded by a dash (-) is treated as a filename and the program will attempt to open a file by this name. If a file by this name does not exist, a new file is created.
Text File Management

Basic file operations include creating new files, opening existing files, inserting existing files into other files, and printing and saving files.

Creating a Text File

To create a new text file:

1. Select File > New. If there is currently any text in the window, you are prompted Text exists, clear?
   • To avoid clearing the text in the window, click No and then take the desired action.
   • To clear it and start a new file, click Yes.

2. When the window is empty and labeled untitled, type the desired text. (You assign a name to the file when you save it.)

Opening an Existing File

To open an existing file:

1. Select File > Open. If there is currently any text in the window, you are prompted Text exists, clear?
   • To avoid clearing the text in the window, click No and then take the desired action.
   • To clear it and open a file, click Yes, and a dialog box appears.

   The default file filter is an asterisk (*) so all files in the current directory are listed.

2. Select the desired file and click Open. The file appears in the Hpeesof edit window for editing.
Inserting One Text File into Another

The Insert command enables you to insert a text file, in its entirety, into another text file.

To insert a text file into the currently open file:

1. Select File > Insert. A dialog box appears.
2. Select the desired file and click Insert. The selected file is inserted at the current cursor position in the currently open file.

Saving Text Files

The File menu contains two commands related to saving files: Save and Save As.

- The Save command enables you to save changes to an existing file.
- The Save As command enables you to save a new file, and name it in the process, or save an existing file with a new name. For example, if you would like a copy of an existing file so that you can make changes to it while preserving the original, you can use the Save As command to create a copy of the file with another name.

To save an existing file:

Select File > Save. The file is saved and the number of bytes and path/filename are displayed in the status bar.

To save a new file or to save an existing file with a new name:

1. Select File > Save As... and a dialog box appears.
2. Adjust the path, if desired.
3. Enter a name for the file in the Selection field.
4. Choose Save As. The file is saved.
Printing Text Files

To print a text file:

Select File > Print. The file is sent to the printer and a status window appears briefly displaying the status of the print request and noting which printer was used.

Note  The setting of the environment variable PRINTER determines which printer is used. If this variable is not set, the default printer is used.

Exiting the Text Editor

To exit the program:

Select File > Quit. If the file has been modified since the last save, you are prompted, File Modified, exit anyway?

• To exit without saving the file, click Yes.
• To cancel so that you can save the file, click No.

Editing Text Files

The Edit menu enables you to copy, cut, paste, and delete text.

To copy text from one location to another:

1. Select the text you wish to copy.
2. Select Edit > Copy. The selected text is copied to the buffer.
3. Position the cursor in the desired location (in any window) and select Paste.

To move text from one location to another:

1. Select the text you wish to move.
2. Select Edit > Cut. The selected text is removed from that location and placed in the buffer.
3. Position the cursor in the desired location (in any window) and select Paste.

To paste text currently being held in the buffer:
Using the Text Editor

Position the cursor in the desired location (in any window) and select **Edit > Paste**. The contents of the buffer appear at the current cursor location.

To delete text:

Select the text you want to delete and select **Edit > Delete**. The selected text disappears.

**Performing Search and Replace Operations**

The Search menu contains commands to enable you to jump to a specified line number in the text file and to search for and replace specified text strings.

To jump to a specific line number in the file:

1. Select **Search > Go To...** and a dialog box appears.
2. Type the desired line number and click **OK**. The cursor jumps to that line number in the file.

To perform the search and replace operation:

1. Select **Search > Search/Replace...** and a dialog box appears. In the Search String field, type the string of characters you want to search for, including wildcard characters, if desired. (If you use wildcard characters, you must check the box labeled Regular Expression.)

```
Search String:

<p>|</p>
<table>
<thead>
<tr>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
</tr>
</tbody>
</table>
```
2. In the Replace String field, type the string of characters you want to use to replace the Search String characters.

Replace String:

3. Optionally, check this box if you want to search backward from the current cursor position.

4. Optionally, check this box if you want to include wildcard characters in your search.

5. Click Search. If the requested text is found, it is highlighted; if it is not found, a pop-up appears and displays the message String not found.

6. If you want to replace the highlighted occurrence with the contents of the Replace String field, click Replace. The highlighted text is replaced.

Note For details on including Regular Expressions in your search, refer to your UNIX documentation.

7. If you want to replace every occurrence of the specified search string at once, click Replace All. Every occurrence is replaced.

8. When you are through using the Search and Replace function, click Cancel to clear any remaining highlights from text and dismiss the dialog box.

Hint To clear the highlight from text at any time, simply click somewhere inside the text editor window.
Using the Text Editor

**Keyboard Mappings**

The text entry area in the editor supports the complete Motif set of keyboard mappings. These mappings are primarily controlled by the XKeysymDB file (or its equivalent), which is typically found in `/usr/lib/X11`. Table 12-2 describes the mapping of the Sun keyboard. (The mappings for the HP and IBM platforms follow the Sun’s mappings with few exceptions.) Note that the Meta keys are labeled differently on different keyboards, but are always the keys on either side of the space bar.

Table 12-2. Keyboard mappings

<table>
<thead>
<tr>
<th>Keyboard or Mouse Operation</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Copies selected text to the clipboard</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes text from the clipboard to current insertion point</td>
</tr>
<tr>
<td>Cut</td>
<td>Cuts selected text to the clipboard</td>
</tr>
<tr>
<td>Arrow Keys</td>
<td>Moves the insertion point cursor/scrolls window</td>
</tr>
<tr>
<td>Shift Arrow Keys</td>
<td>Moves insertion point, selects text</td>
</tr>
<tr>
<td>Page Up/Down</td>
<td>Moves the window up/down by the number of visible lines</td>
</tr>
<tr>
<td>Home/End</td>
<td>Moves cursor to beginning/ending of current line</td>
</tr>
<tr>
<td>Ctrl Home/End</td>
<td>Moves cursor to first/last visible line in window</td>
</tr>
<tr>
<td>Back Space</td>
<td>Deletes text to left of the insertion cursor</td>
</tr>
<tr>
<td>Meta Ctrl left arrow</td>
<td>Moves cursor backward one word</td>
</tr>
<tr>
<td>Meta Ctrl right arrow</td>
<td>Moves cursor forward one word</td>
</tr>
<tr>
<td>Meta Ctrl down arrow</td>
<td>Moves cursor down one paragraph</td>
</tr>
<tr>
<td>Meta Ctrl up arrow</td>
<td>Moves cursor up one paragraph</td>
</tr>
<tr>
<td>Left mouse button down/move</td>
<td>Selects text range</td>
</tr>
<tr>
<td>Shift left mouse button down/move</td>
<td>Extends selected text range</td>
</tr>
</tbody>
</table>
Appendix A: Using Online Documentation

The Advanced Design System includes online help and a complete set of online manuals. They are available from the hard disk (if installed) or from the CD-ROM.

The online documentation is in the form of HTML and can be viewed using Netscape or Internet Explorer. (Other browsers may work but are not supported at this time.) Each online manual is also available as a single PDF file and can be viewed and printed using Adobe Acrobat Reader.

Individual browsers provide information on using various browser features. To access this information in Netscape, choose Help > Help followed by Index. In Internet Explorer, choose Help > Contents and Index.

In the Adobe Acrobat Reader, you can access information on how to use the Reader by choosing Help > Reader Guide

Accessing Documentation

To access the online documentation, choose Help > Topics and Index from any ADS window. The browser opens and displays the online documentation front page. You can select a topic by clicking the appropriate link at the top of the page.

Searching

The online documentation provides the capability to search for a word or phrase in the currently open document, a category of manuals, or the entire documentation library.

To search for a word or phrase in the currently open document:

• From Netscape, select Edit > Find In Page. When the Find dialog box opens, enter the word or phrase in the Find field and click Find.

• From Internet Explorer, select Edit > Find (on this page). In the Find dialog box, enter the word or phrase in the Find What field and click Find Next.

To search for a word or phrase in the entire documentation library:

1. From any documentation page, click Search from the set of links at the top of the content pane (on the right).

2. Enter the word(s) in the Query field, and click Find.
Hint  You can restrict the global search to a specific category of documentation by selecting a category from the drop-down Search in list. Tips on searching are provided in the search window itself.

Printing

You can print individual help topics or entire books.

To print a help topic, click once in the content frame (to make it the active frame) and:

- In Netscape, choose File > Print Frame. When the Print dialog box appears, make the desired selections, and click Print.
- In Internet Explorer, choose File > Print. When the Print dialog box appears, make the desired selections, and click OK.

To print an entire book, or contiguous sections (formatted for printing):

Click the Print version of this book (PDF file) link at the top of any page of a currently displayed manual. When the document is displayed, choose File > Print. In the Print dialog box, specify the desired print range.

Hint  The page numbering of the PDF file is displayed in the status bar at the bottom of the window.
Appendix B: Shortcut Keys

Table B-1 lists the default keyboard shortcuts found in the Schematic, Layout and Data Display windows. For details on customizing these shortcuts, refer to the section, "Customizing Keyboard Shortcuts" on page 9-29.

<table>
<thead>
<tr>
<th>Table B-1. Shortcut Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Edit &gt; Copy/Paste Commands</strong></td>
</tr>
<tr>
<td>Cut</td>
</tr>
<tr>
<td>Copy</td>
</tr>
<tr>
<td>Paste</td>
</tr>
<tr>
<td>Copy Using Reference</td>
</tr>
</tbody>
</table>

| **View Commands** | |
| View All          | Ctrl + f |
| Restore Last View | Ctrl + l |
| Zoom In x2        | + (addition key) |
| Zoom Out x2       | - (subtraction key) |

| **Grid/Snap Commands** | |
| Grid Display         | Ctrl + g |
| Minor Grid Display   | Ctrl + g |
| Major Grid Display   | Shift + g |
| Snap Enabled         | Ctrl + e |

| **Move Commands** | |
| Move Using Reference | Ctrl + m |
| Move Wire/Trace Endpoint | Ctrl + Shift + m |
| Move Component Text (Edit > Move) | F5 |

<p>| <strong>Rotate Commands</strong> | |
| Rotate              | Shift + r |
| Mirror About X      | Shift + x |
| Mirror About Y      | Shift + y |
| Rotate -90          | Ctrl + r |</p>
<table>
<thead>
<tr>
<th><strong>File Management Commands</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>New Design</td>
<td>Ctrl + n</td>
</tr>
<tr>
<td>Open Design</td>
<td>Ctrl + o</td>
</tr>
<tr>
<td>Save Design</td>
<td>Ctrl + s</td>
</tr>
<tr>
<td><strong>Window Commands</strong></td>
<td></td>
</tr>
<tr>
<td>Close Window (Schematic and Layout windows)</td>
<td>Ctrl + F4</td>
</tr>
<tr>
<td>Schematic (Schematic and Layout windows)</td>
<td>Ctrl + Shift + s</td>
</tr>
<tr>
<td>Layout (Schematic and Layout windows)</td>
<td>Ctrl + Shift + l</td>
</tr>
<tr>
<td>New Schematic (Main window)</td>
<td>Ctrl + Shift + n</td>
</tr>
<tr>
<td>New Layout (Main window)</td>
<td>Ctrl + Shift + a</td>
</tr>
<tr>
<td>Designs Open</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td><strong>Shape Commands</strong></td>
<td></td>
</tr>
<tr>
<td>Polygon (Insert)</td>
<td>Ctrl + Shift + p</td>
</tr>
<tr>
<td>Rectangle (Insert)</td>
<td>Ctrl + Shift + r</td>
</tr>
<tr>
<td><strong>Undo Commands</strong></td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl + z</td>
</tr>
<tr>
<td>Undo Vertex</td>
<td>Shift + z</td>
</tr>
<tr>
<td><strong>Help Commands</strong></td>
<td></td>
</tr>
<tr>
<td>What’s This?</td>
<td>Shift F1</td>
</tr>
<tr>
<td>Topics and Index</td>
<td>F1</td>
</tr>
<tr>
<td><strong>Simulate Commands</strong></td>
<td></td>
</tr>
<tr>
<td>Simulate</td>
<td>F7</td>
</tr>
<tr>
<td><strong>Select Commands</strong></td>
<td></td>
</tr>
<tr>
<td>Select All (Select)</td>
<td>Ctrl + a</td>
</tr>
<tr>
<td><strong>Miscellaneous Commands</strong></td>
<td></td>
</tr>
<tr>
<td>Print (File)</td>
<td>Ctrl + p</td>
</tr>
<tr>
<td>Change Entry Layer To (Insert)</td>
<td>Ctrl + Shift + c</td>
</tr>
<tr>
<td>Delete (Edit)</td>
<td>Del</td>
</tr>
<tr>
<td>End Command (Edit)</td>
<td>Esc</td>
</tr>
<tr>
<td>Text (Insert)</td>
<td>Ctrl + Shift + t</td>
</tr>
<tr>
<td>Feature</td>
<td>Shortcut</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>----------</td>
</tr>
<tr>
<td>Clear Highlighting (View)</td>
<td>F8</td>
</tr>
<tr>
<td>Wire (Insert)</td>
<td>Ctrl + w</td>
</tr>
<tr>
<td>Trace (Insert)</td>
<td>Ctrl + t</td>
</tr>
<tr>
<td>Exit Advanced Design System (File)</td>
<td>Alt + F4</td>
</tr>
</tbody>
</table>
Appendix C: Using Advanced Design System Across Platforms

A device library or design project stored on a shared volume can be accessed and modified from either a PC (running Windows NT, Windows 95, 98) or a UNIX workstation. In addition, files created on one platform can be transferred and used on another.

When creating and modifying a file on a shared volume, keep in mind the following:

• You need read and write access to modify a file on a shared volume.

• Only one user can access a file at a time.

Files can be transferred electronically via FTP or they can be moved physically using a medium such as floppy disks. When transferring libraries and projects from one platform to another, keep in mind the following:

• Use a Binary (image) file transfer method.

• Maintain the original file and directory structure at all times.

• Copy all hidden files.

• Use the Archive Project command before copying a project to a diskette or transferring it via FTP. For details, refer to “Archiving a Project” on page 2-11.

Note If a project created on UNIX contains two or more designs whose names are only distinguishable from one another by differences in case, do not archive and transfer this project to a PC without renaming the designs such that they all have unique names. This requirement is due to the fact that the PC is case insensitive.
Opening Projects

To open a project, you need a licensed copy of Advanced Design System for your current platform and access to the current location of the project files.

To open a project:

1. In the Main window, choose File > Open Project or click the Open Project button.
2. In the dialog box that appears, select the project and click OK.

Guidelines for Cross-platform Use

Use the following guidelines when creating libraries or projects for cross-platform use:

- Use filename characters and conventions that are legal on both platforms. For example, Windows does not recognize case-sensitive differences in filenames.
- Use only the standard ASCII character set for text.
- Use fonts that are standard on both platforms.
- Use colors that are standard on both platforms.
Appendix D: Glossary

accelerator keys
See shortcut keys.

active design
The design currently displayed in any window.

active window
The window to which the next keystroke or command will apply. If a window is active, its title bar changes color to differentiate it from other open windows.

AEL
Application Extension Language. A C-like general purpose interpreted language used in Advanced Design System products to configure and define extensions to the design environment. It is available to any application as a linkable library.

annotation
Old Series IV term used to denote explanatory text that is automatically placed with a component. Now referred to as component text.

back annotation
Synchronizing values between optimization and the Schematic window, or between a schematic and its associated layout.

background
The drawing area of a screen upon which a design or data display is placed.

bias-dependent analysis
Whenever a single-point DC bias analysis is required to carry out a linear analysis, it is referred to as a bias-dependent analysis.

boot
To start or restart your computer by loading the operating system.

budget analysis
A single-tone bandpass analysis that determines the system internodal signal and noise performance for components in the top level of a system network.
check box
A small box or circle inside a dialog box. A check box represents an option and it can be turned on and off. When the option is selected, it appears darkened.

click
To press and release a mouse button quickly (most often, the left mouse button).

command
A word or phrase found on a menu or represented by a button on a toolbar, that you choose to carry out an action.

component text
Explanatory text that is automatically placed with a component.

convolution
A SPICE-type analysis involving the solution of a set of integro-differential equations that express the frequency dependence of the currents and voltages of the circuit under analysis. Convolution represents all the distributed elements in the frequency domain to enable analysis of their frequency-dependent behavior. It is based upon the premise that characterization of many RF and microwave distributed elements is best accomplished in the frequency domain.

cursor
A graphical representation of the location of the mouse. A cursor appears when the location requires text input.

data display window
Window in which to view simulation results. A data display window can be opened from the Main window, a Schematic window, or a Layout window.

data set
A file that contains data from a given simulation.

design environment
The entire group of windows used for creating and simulating designs and viewing results for the Agilent EEsof simulator suite. It includes the Main window, all Design windows, the Message/Status window, and the Data Display window.
design files
Project files, which include schematic and layout information. These files have a .dsn extension.

design units
See layout units, schem units.

design windows
Schematic and Layout windows.

dialog box
A rectangular box that requests and/or provides information.

directory
A collection of files and subdirectories that are stored at the same location on a disk. See also subdirectory.

double-click
To press and release a mouse button twice in rapid succession without moving the mouse. Double-clicking carries out an action, such as displaying the dialog box for editing component parameters.

drag
To move an item on the screen by pressing and holding down the mouse button and then moving the mouse. For example, you can move a window to another location on the screen by dragging its title bar.

drawing formats
Templates for use as a design sheet that include a title block and space for design information. Standard sizes include: A, B, C, D, E, and metric.

Electrical component models
Models based on circuit theory signal S-parameters and noise wave parameters. Each port of any n-port electrical element has a bidirectional signal flow; that is, each port has an input and output signal and noise characteristic. At any port of an n-port electrical element, incident signal and noise produce reflected signal and noise at the incident port; the incident signal and noise produce signal and noise output at all other n-1 element ports.
**component**

An item placed in the Schematic or Layout window, typically an electrical component or specification.

**Functional, optical, and DSP component models**

Models based on transformation of input signals and noise into output signals and noise. Each component port is unidirectional, and is either an input port or an output port.

**graph**

A diagram showing the values of a function.

**grid**

A set of evenly spaced horizontal and vertical dots or lines to aid in locating specific points.

**harmonic balance**

An iterative method of analysis based on the assumption that for a given sinusoidal excitation, there exists a steady-state solution that can be approximated to satisfactory accuracy using a finite Fourier series.

**hierarchical design**

A network design containing one or more subnetworks.

**histograms**

There are two types of histograms available with yield analysis: sensitivity and measurement histograms.

- The sensitivity histogram plots percent pass versus parameter value bin. Each sample has parameter values randomly assigned to those parameters with yield value types.

- The measurement histogram plots percent of samples versus measurement value bin. The random parameter values causes the measurements listed in a MEAS_HIST item to be statistically distributed.

**keyboard shortcuts**

See shortcut keys.
large-signal S-parameter analysis

The calculation of large-signal, power-dependent S-parameters of a 2-port network, which can be stored in a P2D disk file for use in the system simulator.

layout units

The unit used for grid display and cursor snapping, usually the same as length unit. (See also length unit and schem units.)

length unit

In the Schematic and Layout windows, the unit of measure for parameters with physical length. Also the unit used for grid display and cursor snapping in the Layout window. (See also layout units and schem units.)

library

A collection of components sharing similar characteristics.

list box

A region within a dialog box that lists all available choices.

macro

A series of actions represented by AEL functions that can be played back using the Playback Macro command on the Options menu of the Main window. May also refer to AEL artwork macros that you can assign to networks or new components.

menu bar

The horizontal bar containing the names of all the menus. It appears below the title bar.

message window

A window that is displayed during simulation and optimization. Messages displayed within this window report on the status of the current operation.

meta key

The key on either side of the space bar. The label on this key varies depending on the keyboard manufacturer.
mnemonics
A series of keys pressed to initiate a command. The key combination typically includes a significant letter in the command name, such as Alt + F to access the File menu. See also shortcut keys.

netlist
A textual listing of all the parts in a design showing how they are interconnected.

network
A design consisting of interconnected components with input/output ports, and with associated data, units, and optional variables and equation items. In general, a network can have a schematic and a layout representation.

node
The connection of pins of two or more elements or items.

nonlinear steady-state circuit analysis
An analysis performed by the Harmonic Balance, Oscillator, or Large-signal S-parameter test benches. The types of analyses are:
  • Harmonic balance analysis (single- and multi-tone)
  • Mixer analysis
  • Dynamic load-line analysis
  • Oscillator analysis
  • Large-signal S-parameter analysis

nonlinear transient time-domain circuit analysis
An analysis involving the solution of a set of integro-differential equations that express the time dependence of the currents and voltages of the circuit under analysis. The result is a nonlinear analysis with respect to time and, possibly, a swept variable.
optimization

There are two kinds of optimization: performance optimization and yield optimization.

• Performance optimization is the process of modifying parameter values in order to satisfy predetermined performance criteria. Optimizers compare the computed and desired responses and modify design parameter values to bring the computed response closer to the desired response.

• Yield optimization involves a series of yield analyses where the yield variable nominal values are adjusted to maximize the yield estimate. In yield optimization, each yield improvement is referred to as a design iteration.

oscillator analysis

A special kind of harmonic balance analysis in which the frequency of operation varies as the algorithm progresses, allowing the simulator to zoom in on the actual frequency of oscillation for a given oscillator circuit.

date

A set of buttons with icons representing various commands that allow quick execution of those commands (found on the left side of all design windows).

parameters

The characteristics defining a component.

parametric subnetwork

A network design with associated parameters that are passed to the main network when it is placed as a subnetwork within the main network.

PDE

See project design environment.

pin

A terminal on a schematic or layout component.

pointer

A graphical representation of the current location of the mouse.

port

Refers to either a terminal on a network or symbol to indicate input or output.
post production tuning
A process that combines with yield analysis to allow certain parameter values to receive additional tuning. Typically, post production tuning is used to ensure that yield specifications are met.

project
A set of designs stored in a predetermined directory structure referred to as a project directory. It contains subdirectories for different types of files.

Project Design Environment
The entire group of windows used for creating and simulating designs and viewing results for a project using the Agilent EEsof simulator suite.

schem units
In the Schematic window, the unit used for grid display and cursor snapping, inches. (See also length unit and layout units.)

scroll bars
The bars at the bottom and right edge of a window or list box that appear when the contents are not entirely visible. Each scroll bar contains a small box, called a scroll box, and two scroll arrows to allow different directions in scrolling.

shortcut keys
A combination of one or more modifier keys (Ctrl, Shift, Alt, etc.) and a letter that equates to a command. Pressing these keys initiates the command, for example, Ctrl + r initiates the rotate command.

small-signal analysis
An alternate mode of analysis that often increases simulation speed. When used for mixers, small-signal analysis assumes that amplitude of the RF signal is small enough to generate negligible harmonics, and that the power level of the RF signal is smaller than that of the LO signal.

spurious signals
Spurious signals are generated within RF systems by mixers, nonlinear amplifiers, and spectrally impure oscillators.
**statistical design**
The process of varying a set of parameter values over specified probability distributions to determine how many possible combinations satisfy predetermined performance criteria. The statistical design methods used are yield analysis, yield optimization.

**subnetwork**
A network that is used as a component inside of another network.

**symbol**
A graphical representation of a component or subnetwork.

**toolbar**
A group of buttons with icons representing various commands that allow quick execution of those commands (found at the top of all design windows).

**units**
See individual entries for design units, length units, layout units, and schem units.

**user units**
Old Series IV term for schem units or layout units.

**vertex**
A beginning or ending point, turn, or junction in a segment.

**wildcard character**
A character that represents another character. In filenames, you can use the asterisk (*) as a wildcard character to indicate any character or group of characters that might match that position in other filenames. For example, *.dsn represents all files with the .dsn filename extension.

**yield analysis**
A process involving a yield estimation over a given number of trials in which the yield variables have values that vary statistically about their nominal values according to specified probability distribution functions.

**yield optimization**
See optimization.
Symbols

.lay files, 9-28
.prf files, 9-20

A
accelerator keys, B-1, D-8
  customizing, 9-29
Activate command, 8-7
Add command (Edit > Vertex), 6-30
Advanced Design System Setup command, 1-4
annotation
  adding system variables to your designs, 7-3
Arc (clockwise) command, 7-6
Arc (counter-clockwise) command, 7-6
Arc (start,end,circumference) command, 7-6
Archive Project command, 2-11
Arrow command, 7-7
Attach Component Palette command, 1-14

B
backup of design file, automatic, 9-13
balloon help
  changing timing of display, 1-8
    described, 1-8
    turning on/off, 1-24
Bill of Materials command, 3-29
bitmap size, changing, 1-25
Break command (Edit > Modify), 6-29
Break Connections command, 6-7

C
cancel
  see End Command, 1-9
Change Component Text Layer command, 6-9
Circle command, 7-7
circles
  converting to simple polygons, 6-27
Clear Component History command, 9-33
Clear Highlighting command, 8-7
Close All Designs command, 2-22
Close Design command (File menu), 2-21
Close View command (component library), 3-12
Close Window command (design windows), 1-16
colors
  saving preference file, 9-20
Command Line command, 3-27
Component History command, 3-14
Component Library command, 3-4
Component Palette command, 3-13
Component Properties command (component library), 3-12
component text
  making visible/invisible, 9-26
Component Text Attributes command (Edit > Component), 6-10
components
  connecting, 3-18
    editing parameters, 6-3
    locating by browsing, 3-4
    locating by searching, 3-6
    orientation of, 3-16
    parameters, displaying on schematic, 6-5
    placing
      at specific coordinates, 3-15
      in drawing area, 3-3
    rotating
      after placing, 3-16
      prior to placing, 3-16
text
  changing layer/visibility, 9-16
    editing attributes of existing, 6-10
    establishing attributes in advance, 9-15
    moving, 6-9
connecting
  components, 3-18
context-sensitive commands, the pop-up menu, 1-9
Convert To Polygon command, 6-28
Coordinate Entry command, 3-15, 7-8
Coordinate Readout command, 1-10
coordinate readouts
  differential, 9-34
  display of, 9-34
  positional, 9-34
Copy And Oversize command (scaling), 6-36
Copy command, 6-15
Copy command (component library), 3-9
Copy Design command, 2-20
Copy Project command, 2-6
Copy Relative command, 6-16
Copy To Layer command, 6-17
Copy Using Reference command, 6-16
Create Component Palette command, 9-33
Create Hierarchy command, 4-1, 4-2
Create/Edit Schematic command, 10-3
Create/Edit Schematic Symbol command, 10-3
Cut command, 6-15
Cut command (component library), 3-9

D

data displays
   opening automatically, 8-4
date
   system
      annotating your designs with, 7-3
Deactivate command, 8-6
Delete All command (Edit menu), 2-21
Delete command, 6-1
Delete Design command, 2-21
Delete Project command, 2-7
Delete View command, 5-3
Deselect All command, 6-11
Deselect By Name command, 6-13
Deselect Window command, 6-13
deselecting a group, 6-13
deselecting by name, 6-12
Design Hierarchies command, 5-5
Design Parameters command, 4-5
design windows
   defined, 1-8
      opening multiple, 1-11
designs
   copying, 2-20
      creating, 2-15
deleting, 2-21
   importing/exporting, 2-12
   saving, 2-17
      saving/clearing all at once, 2-18
Detach Component Palette command, 1-13
differential coordinate readout, 9-34
display, Schematic/Layout windows,
customizing, 9-1
documentation, online
   printing, A-2
   searching, A-1
   using, A-1
Drag and Move option, 6-19, 9-14

E

Edit Component Artwork command, 30
Edit Component Parameters command, 6-4
End Command, 1-9, 7-4
Entry Layer command, 7-2, 9-29
Example Project command, 2-8
eexample projects
   copying, 2-6
Exit Advanced Design System command, 1-26
exiting
   ADS, 1-26
Explode command (Edit > Modify), 6-30
Export command, 2-14
exporting
   procedure described, 2-14
extensions
   data display filenames, 8-6
data set filenames, 8-2
design filenames, 2-15
template filenames, 2-17

F

file-based parameters, 3-25
filename
   extensions
      data display files, 8-6
data set files, 8-2
design files, 2-15
template files, 2-17
filenames
   restrictions, 1-20
files
   See designs, 2-15
filters (selection)
   changing through Preferences, 9-3
Find command (component library), 3-6
fonts. See text
Force To Grid command, 6-38
Index-3

G
Generate Symbol command, 10-3
Global Node command, 3-21
Grid/Snap command, 9-6, 10-4
  grids
display
  defined, 9-6
  setting spacing, 9-7, 10-4
snap
defined, 9-6
  setting spacing, 9-6, 10-4
Group Edit Parameter Value command, 6-6

H
help
  balloon, described, 1-8
hierarchical designs
  creating, 4-1
  creating parametric subnetworks, 4-1, 4-3
  parametric subnetwork, defined, 4-3
  viewing detailed information of, 5-5
Hierarchy command, 5-6
Hot Key/Toolbar Configuration command, 9-30
hot keys, B-1
customizing, 9-29

I
Identify command, 5-4
Import command, 2-13
importing
  data files of various formats, 2-12
Include/Remove Projects command, 2-9
Increment Component Orientation By -90 command, 3-16
Info command, 5-4
Insert Template command, 2-16

J
Join command (Edit > Modify), 6-29

K
keyboard
  shortcuts
customizing, 9-29
defaults, B-1
keyboard shortcuts, B-1, D-8

L
layer files
customizing, 9-28
layers
  defining/changing, 9-21
  for drawing, 10-5
  making visible/invisible, 9-26
  protecting from selection, 9-26
  saving custom definitions, 9-28
Layers command, 9-21
Layout command (Window menu), 1-11
layout.prf file, 9-20
Length Units
defined, 3-2
Library command, 3-9
Library Properties command (component library), 3-12
Line Thickness command, 7-8

M
macros
  playing back, 3-27
  recording, 3-26
Main window
  overview, 1-7
Measure command, 3-18
Message window, 1-16
Mirror About X command, 6-25
Mirror About Y command, 6-25
Miter command (Edit > Vertex), 6-32
mnemonics, B-1, D-6
customizing, 9-29
Modify commands (Edit menu)
  Break, 6-29
  Convert To Polygon, 6-28
  Explode, 6-30
  Force To Grid, 6-38
  Join, 6-29
  Set Origin, 10-8
Move & Disconnect command (Edit > Move), 6-21
Move commands (Edit menu)
  Move & Disconnect, 6-21
  Move Edge, 6-33
  Move Relative, 6-20
  Move To Layer, 6-21
  Move Using Reference, 6-20
  Move Wire Endpoint, 3-19

Index-3
Move Component Text command, 6-9
Move Edge command (Edit > Move), 6-33
Move Relative command (Edit > Move), 6-20
Move To Layer command (Edit > Move), 6-21
Move Using Reference command, 6-20
Move Wire Endpoint command, 3-19
moving
  a vertex, 6-30
  component text, 6-9
  components and shapes, 6-19
  shortcut using mouse, 6-19

N
Name Node command, 3-21
netlist
  creating a, 3-28
New command
  Schematic/Layout window, 2-15
New Data Display command, 8-5
New Layout command (Window menu), 1-11
New Project command
  Main window, 2-1
New Schematic command (Window menu), 1-11
nodes
  identifying by name, 3-21
non-orthogonal
  mode for entering shapes, 9-12

O
online documentation
  printing, A-2
  searching, A-1
on-screen text editor, 6-36
Open command
  Schematic/Layout windows, 2-19
Open Data Display command, 8-6
Open Project command
  Main window, 2-4
Open View command (component library), 3-12
orientation of components, 3-16
orthogonal
  mode for entering shapes, 9-12
Oversize command (scaling), 6-35

P
palettes
  creating custom, 9-33
  defined, 3-13
  detaching from window, 1-13
  re-attaching to the window, 1-14
  selecting items from, 3-13
  using and changing component, 1-13
Pan View command, 5-2
parameter editing, 6-2
  group with common parameters, 6-6
  on the screen, 6-2
  through dialog box, 6-3
parameters
  displaying on schematic, 6-5
  editing component, 6-3
  file-based, 3-25
Parameters command (File menu), 4-8
parametric
  subnetwork, see hierarchical designs
Parts List command, 3-29
Paste command, 6-15
Paste command (component library), 3-9
PDE (Project Design Environment), 1-5
pick box
  changing the size of, 9-4
  defined, 9-4
Pin Snap, defined, 9-8
pins
  adding to a symbol, 10-7
  changing the color of, 9-11
  display of names, 9-11
  display of numbers, 9-11
  displaying connections, 9-11
  establishing characteristics of, 10-8
Playback Macro command, 3-27
Polygon command, 7-5
polygons
  editing, 6-29
Polyline command, 7-5
polylines
  editing, 6-29
Pop Out of Hierarchy command, 4-15
pop-up menu, using as a shortcut, 1-9
positional coordinate readout, 9-34
Preferences command
  design windows, 9-2
  Main window, 1-24
Print Area command, 11-1
Print command, 11-1
Print Setup command, 11-1
printing
  online documentation, A-2
printing/plotting
  a scaled layout, 11-15
  adding a printer (UNIX), 11-3
  PC (overview), 11-2
  UNIX (overview), 11-2
Project Design Environment (PDE), 1-5
project directories
  copying, 2-6
  creating, 2-1
  deleting, 2-7
  described, 2-1
  opening, 2-3
Project Listing command, 2-5
Properties command, see Momentum documentation
Push Into Hierarchy command, 4-15

R
Read command
  layers file, 9-28
  preference file, 9-21
Rectangle command, 7-4
Redraw View command, 5-3
Remove Node Name command, 3-21
Reports command, 3-29
Reset/Update command (component library), 3-12
Restore Last View command, 5-3
Restore Status command, 1-6
Restore View command, 5-3
Revert to Saved Design command, 2-17
Rotate/Mirror commands (Edit menu)
  Mirror About X, 6-25
  Mirror About Y, 6-25
  Rotate, 6-23
  Rotate Around Reference, 6-23
  Rotate Relative, 6-24
  Set Rotation Angle command, 6-26
rotating
  components
    after placing, 3-16
    prior to placing, 3-16
  setting default snapping angle, 9-14

S
Save All Designs command, 2-18
Save As command
  design windows, 2-17
Save As Template command, 2-17
Save command
  design windows, 2-17
  layer file, 9-28
  preference file, 9-20
Save View As command (component library), 3-12
Save View command, 5-3
Scale command, 6-34
scaling
  objects
    using a scaling factor, 6-34
    using design units, 6-35
Schematic command (Window menu), 1-11
  window, overview of, 1-15
schematic
  symbols, see symbols
  schematic.prf file, 9-20
  screen, refresh, 5-3
search paths
  modifying, 10-12
Search/Replace Reference command, 6-8
searching
  for components, 3-6
  online documentation, A-1
Select All command, 6-11
Select By Name command, 6-12
selecting
  a group using a selection window, 6-13
  by name, 6-12
  controlling the process of, 9-3
  using filters, 9-3
Set Component Orientation command (UP, DOWN, LEFT, RIGHT), 3-16
Set Origin command, 10-8
shapes
  drawing using specific coordinates, 7-8
  editing, 6-27
  layer display, changing, 9-25
shortcut keys, B-1, D-8
Show All Files command, 1-7
Simulate command, 8-6
Simulation Setup command (Simulate menu), 8-2
simulations
naming the resulting data set, 8-2
results
displaying automatically, 8-4
snap
spacing
setting, 9-6, 10-4
Snap Enabled, defined, 9-7
speed keys, B-1
customizing, 9-29
Start Recording Macro command, 3-26
Status Bar command, 1-10
Status window, 1-16
Step And Repeat command, 6-17
Stop Recording Macro command, 3-26
subnetworks
See hierarchical designs
Swap Components command, 6-7
Symbol Pin command
adding, 10-7
editing, 10-8
symbols
generating, 10-3
preparing to draw custom, 10-4
usage, 10-1

T
tees
changing the color of, 9-11
templates
creating, 2-16
saving, 2-17
text
adding to a design, 7-2
attributes
editing existing, 6-36
establishing in advance, 9-17
cutting and pasting, 7-2
on-screen editing, 6-36
See also component text, 9-15
Text command (Edit > Text), 6-36
Text command (Insert > Text), 7-2
text editors, launching from HP ADS, 12-1
time
system, annotating your designs with, 7-3
To Arc command (Edit > Vertex), 6-31
Toolbar command, 1-10
toolbars
configuring, 9-30
moving, 1-14
U
Unarchive Project command, 2-11
Undo command
how many times you can use, 9-14
Undo Vertex command, 7-6
units
Length, defined, 3-2
Units/Scale (Preferences dialog), 9-18
V
variables
annotating your designs with, 7-3
system
annotating your designs with, 7-3
vertex
adding, 6-30
converting to a mitered edge, 6-32
converting to an arc, 6-31
deleting, 6-31
editing, 6-30
moving, 6-30
Vertex commands (Edit menu)
Add, 6-30
Miter, 6-32
To Arc, 6-31
vertices
specifying for editing, 6-14
Vertices filter
using for editing shapes, 6-14
View All command, 5-2
W
windows
design
defined, 1-8
opening multiple, 1-11
moving the center point of, 5-2
opening and closing, 1-11
program, overview of, 1-7
repositioning design to view all, 5-2
screen refresh, 5-3
Wire command, 3-19
Wire Route command, 3-20
wire routing
  around annotation, 3-20
wire thickness, setting, 1-25
wires
  breaking connections, 6-7

Z
Zoom Area command, 5-2
Zoom By Factor command, 5-1
Zoom In Point command, 5-1
Zoom Out Point command, 5-1