Notice

The information contained in this document is subject to change without notice.

Agilent Technologies makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Agilent Technologies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Warranty

A copy of the specific warranty terms that apply to this software product is available upon request from your Agilent Technologies representative.

Restricted Rights Legend

Use, duplication or disclosure by the U. S. Government is subject to restrictions as set forth in subparagraph (c) (1) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 for DoD agencies, and subparagraphs (c) (1) and (c) (2) of the Commercial Computer Software Restricted Rights clause at FAR 52.227-19 for other agencies.

Agilent Technologies
395 Page Mill Road
Palo Alto, CA 94304 U.S.A.

## Contents

### 1 Layout Basics

- The Layout Window ................................................................. 1-2
- Opening and Closing a Layout Window ........................................ 1-2
- Setting Layout Defaults ........................................................... 1-3
- Insertion Layers ........................................................................ 1-3
- Inserting Components and Shapes .............................................. 1-4
- Editing Objects in a Layout Window ........................................... 1-6
- Creating Artwork ................................................................. 1-7
- Releasing a Layout License ...................................................... 1-7
- Using the Design Rule Checker .................................................. 1-7

### 2 Setting Layout Options

- Defining Layers ......................................................................... 2-1
- Setting Layer Characteristics Globally ...................................... 2-3
- Miscellaneous Layer Editor Features ........................................ 2-3
- The Default Layer ..................................................................... 2-4
- Determining the Layer for an Item ............................................. 2-5
- Changing Layer Priority ........................................................... 2-5
- Changing the Entry Layer .......................................................... 2-6
- Defining Port Connections (Layer Binding) ................................. 2-7
- Changing the Visibility and Protected Status of Items ............... 2-7
- Using IGES and GDSII Numbers ................................................ 2-8
- Assigning Layers for Transmission Line Components ................ 2-8
- Layer Files and Library Components ........................................ 2-8
- Layer Files and Design Files .................................................... 2-9
- Layer File Format ................................................................. 2-10
- Preferences for Layout ............................................................ 2-12
- Changing Select Options ......................................................... 2-13
- Changing Grid and Snap Settings .............................................. 2-15
- Selecting Placement Options .................................................... 2-20
- Changing Options for Pins/Tees ................................................ 2-22
- Changing Entry/Edit Attributes ............................................... 2-24
- Changing Component Text Attributes ...................................... 2-27
- Changing Typed-in Text Attributes .......................................... 2-28
- Changing Display Colors ........................................................ 2-29
- Setting DRC Memory Use and Performance ................................ 2-30
- Changing Miscellaneous Display Options ................................. 2-32
- Setting Units/Scale Factors ..................................................... 2-33
- Changing Layout Units & Resolution ......................................... 2-34
- Toggling the Coordinate Readout Display ................................. 2-35
Saving a Layout Setup .............................................................................................. 2-36
Saving Layout Preferences ...................................................................................... 2-36
Saving Layer Information ....................................................................................... 2-37
Using an Existing Layout Setup ............................................................................. 2-37
Reading in an Existing Preferences File ............................................................... 2-37
Reading in an Existing Layer File .......................................................................... 2-38
Reading a File from a Different Project Directory .................................................. 2-38
Pick and Place Report ............................................................................................. 2-38
Viewing Pick and Place Report Configuration Options ....................................... 2-38
Configuring the Pick and Place Report ................................................................. 2-39
DE_PARTS_SET_PICK_AND_PLACE_OPTIONS ............................................... 2-40
Configuring the Parts List Report ......................................................................... 2-41
Reformatting the Reports ...................................................................................... 2-41

3 Creating a Layout
The Layout Environment ......................................................................................... 3-1
Creating a Layout Manually .................................................................................... 3-2
Inserting Components ............................................................................................ 3-2
Drawing Shapes ...................................................................................................... 3-4
Working with Traces ............................................................................................... 3-6
Working with Paths ................................................................................................. 3-14
Working with Wires ............................................................................................... 3-16
Inserting Text .......................................................................................................... 3-17
Creating a Layout from a Schematic ....................................................................... 3-22
Creating a Layout as You Create a Schematic ....................................................... 3-22
Hierarchical Layouts .............................................................................................. 3-23
Advantages of a Hierarchical Design ..................................................................... 3-23
Schematic Considerations ....................................................................................... 3-24
Parametric Subnetworks ......................................................................................... 3-24
Creating a Hierarchical Layout .............................................................................. 3-25
Viewing Hierarchical Design Information ............................................................. 3-27
Flattening Hierarchy ............................................................................................... 3-27
Creating a Hierarchical Design for Repeated Use ................................................. 3-28
Pushing Into or Popping Out of Hierarchy ............................................................. 3-28
Libraries and Search Paths .................................................................................... 3-29

4 Design Synchronization
The synchronization process ................................................................................... 4-1
Working with Hierarchical Designs ........................................................................ 4-3
Identifying Components Without Artwork ............................................................ 4-7
Using TEE Junctions in a Schematic ...................................................................... 4-8
Using Steps and Tapers in a Schematic ................................................................. 4-9
Checking Schematic Component Orientation ....................................................... 4-10
1 Identifying Connections Among Three or More Items ........................................ 4-11
2 Identifying Components that Form Loops ...................................................... 4-12
3 Establishing Preferences .................................................................................. 4-13
4 Generating a Layout .......................................................................................... 4-14
5 Placing Unplaced Components ........................................................................ 4-18
6 Fixing and Freeing Component Positions ....................................................... 4-20
7 Dual Representation Mode .............................................................................. 4-21
8 Viewing connectivity information .................................................................... 4-22
9 Generating a Schematic (Layout-driven Design) .............................................. 4-23
10 RF PCB design considerations ........................................................................ 4-25
11 Creating the Board, System Setup ................................................................... 4-25
12 Interactive Layout, Manual Layout ................................................................. 4-26
13 Automatic design synchronization .................................................................. 4-26
14 Interactive placement ...................................................................................... 4-27
15 Fixing part placement and back annotation ................................................... 4-27
16 Trace Routing .................................................................................................. 4-28
17 Layout versus Schematic Nodal Mismatches .................................................. 4-28
18 Trace Simulation .............................................................................................. 4-28
19 Generating a report .......................................................................................... 4-29
20 Exporting the PCB layout ................................................................................ 4-29
21 Part and library creation .................................................................................. 4-29

5 Creating Elements

22 Creating New Items .......................................................................................... 5-1
23 Simulation Items .............................................................................................. 5-1
24 Defining a New Item ......................................................................................... 5-2
25 Defining Design Characteristics ...................................................................... 5-3
26 Creating a New Item Using a Built-in Simulator Model ................................... 5-5
27 Defining Parameters ......................................................................................... 5-7

6 Editing a Layout

28 Using Selection Filters .................................................................................... 6-1
29 Editing Shapes .................................................................................................. 6-2
30 Selecting Shapes .............................................................................................. 6-2
31 Manipulating Polygons and Polylines ............................................................. 6-2
32 Manipulating Vertices ...................................................................................... 6-9
33 Moving Shapes or Text to a Different Layer ...................................................... 6-12
34 Manipulating Dimension Lines ........................................................................ 6-12
35 Moving Endlines .............................................................................................. 6-12
36 Modifying Dimension Lines ............................................................................ 6-13
37 Moving an Object to the Coordinates 0,0 ........................................................... 6-14
38 Forcing an Object onto the Grid ....................................................................... 6-15
39 Editing Layout Hierarchy (Flatten) ................................................................... 6-15
Creating Hierarchy.................................................................................................... 6-16
Connecting Layout Components ............................................................................. 6-16
Viewing Connectivity Information ....................................................................... 6-16
Working with Transmission Lines ......................................................................... 6-17
Splitting a Transmission Line.............................................................................. 6-17
Replacing a Transmission Line Element............................................................. 6-18
Stretching a Transmission Line........................................................................... 6-18
Squeezing a Transmission Line While Maintaining its Length............................ 6-19
Editing Paths, Traces and Wires............................................................................... 6-21
Editing Component Text ........................................................................................... 6-23
Using Boolean Logical Operations ........................................................................... 6-24
Edit > Boolean Logical > DIFF........................................................................... 6-25
Edit > Boolean Logical > AND............................................................................ 6-26
Edit > Boolean Logical > OR.............................................................................. 6-26
Edit > Boolean Logical > XOR............................................................................ 6-27
Creating Clearance................................................................................................... 6-27

7 Artwork
Fixed Artwork............................................................................................................ 7-1
AEL Artwork Macros................................................................................................. 7-1
Special Types of Artwork.......................................................................................... 7-2
Space Artwork........................................................................................................... 7-2
Connection Artwork.................................................................................................. 7-3
SMT Package Artwork........................................................................................... 7-3
Supplied Artwork ...................................................................................................... 7-4
Custom Artwork........................................................................................................ 7-4
Creating a Layout Object....................................................................................... 7-5
Adding pins/ports to artwork............................................................................... 7-5
Creating Fixed Artwork..................................................................................... 7-7
Creating Artwork Using an AEL Macro............................................................... 7-7
Associating Artwork with an Item............................................................................. 7-12
Selecting the Appropriate Artwork Type............................................................. 7-12
Overriding the Default Artwork Assignment ....................................................... 7-15

8 Importing and Exporting Layouts
Importing a Layout.................................................................................................... 8-2
Opening and Viewing a Translated Layout .......................................................... 8-2
Saving a Translated Layout.................................................................................. 8-2
Listing the Hierarchy of a Translated Layout....................................................... 8-2
Exporting a Layout.................................................................................................... 8-3
Preparing a Layout for Translation...................................................................... 8-3
Flattening Instances to Eliminate Hierarchy and Connectivity............................ 8-3
Adding a Process Offset....................................................................................... 8-4
9 Standard AEL Macros

<table>
<thead>
<tr>
<th>Macro</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>conn</td>
<td>9-2</td>
</tr>
<tr>
<td>cpad2</td>
<td>9-2</td>
</tr>
<tr>
<td>cpad3</td>
<td>9-3</td>
</tr>
<tr>
<td>cpad4</td>
<td>9-4</td>
</tr>
<tr>
<td>pad1</td>
<td>9-5</td>
</tr>
<tr>
<td>pad3</td>
<td>9-6</td>
</tr>
<tr>
<td>pad4</td>
<td>9-7</td>
</tr>
<tr>
<td>padn</td>
<td>9-8</td>
</tr>
<tr>
<td>rpad2</td>
<td>9-9</td>
</tr>
<tr>
<td>rpad3</td>
<td>9-10</td>
</tr>
<tr>
<td>rpad4</td>
<td>9-11</td>
</tr>
<tr>
<td>spac</td>
<td>9-12</td>
</tr>
<tr>
<td>spad2</td>
<td>9-12</td>
</tr>
<tr>
<td>spad3</td>
<td>9-13</td>
</tr>
<tr>
<td>spad4</td>
<td>9-14</td>
</tr>
<tr>
<td>tar1</td>
<td>9-15</td>
</tr>
</tbody>
</table>

10 Fixed Artwork

<table>
<thead>
<tr>
<th>Artwork</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>145MILXP</td>
<td>10-1</td>
</tr>
<tr>
<td>145ML4PK</td>
<td>10-1</td>
</tr>
<tr>
<td>1D2J1A</td>
<td>10-2</td>
</tr>
<tr>
<td>2D3H1A</td>
<td>10-2</td>
</tr>
<tr>
<td>2D3J1C</td>
<td>10-3</td>
</tr>
<tr>
<td>2D7C1A</td>
<td>10-3</td>
</tr>
<tr>
<td>AFLANGE</td>
<td>10-4</td>
</tr>
<tr>
<td>AK</td>
<td>10-4</td>
</tr>
<tr>
<td>ALMK</td>
<td>10-5</td>
</tr>
<tr>
<td>ALMK2</td>
<td>10-5</td>
</tr>
<tr>
<td>AP</td>
<td>10-6</td>
</tr>
<tr>
<td>AQ</td>
<td>10-6</td>
</tr>
<tr>
<td>ATF36</td>
<td>10-7</td>
</tr>
<tr>
<td>ATF70</td>
<td>10-7</td>
</tr>
<tr>
<td>ATF76</td>
<td>10-8</td>
</tr>
<tr>
<td>ATF84</td>
<td>10-8</td>
</tr>
<tr>
<td>ATF86</td>
<td>10-8</td>
</tr>
<tr>
<td>ATCCAP</td>
<td>10-9</td>
</tr>
<tr>
<td>AVNK35</td>
<td>10-10</td>
</tr>
<tr>
<td>AVNK70</td>
<td>10-10</td>
</tr>
<tr>
<td>AVNK85</td>
<td>10-11</td>
</tr>
<tr>
<td>Item</td>
<td>Page</td>
</tr>
<tr>
<td>---------------------------</td>
<td>------</td>
</tr>
<tr>
<td>AVNK86</td>
<td>10-11</td>
</tr>
<tr>
<td>AXIAL_L</td>
<td>10-12</td>
</tr>
<tr>
<td>AXIAL_M</td>
<td>10-12</td>
</tr>
<tr>
<td>AXRES</td>
<td>10-13</td>
</tr>
<tr>
<td>AXRES2</td>
<td>10-13</td>
</tr>
<tr>
<td>AXRES3</td>
<td>10-14</td>
</tr>
<tr>
<td>BFLANGE</td>
<td>10-14</td>
</tr>
<tr>
<td>C-LL</td>
<td>10-15</td>
</tr>
<tr>
<td>C-LR</td>
<td>10-15</td>
</tr>
<tr>
<td>C-UL</td>
<td>10-16</td>
</tr>
<tr>
<td>C-UR</td>
<td>10-16</td>
</tr>
<tr>
<td>C145D01</td>
<td>10-17</td>
</tr>
<tr>
<td>C18202</td>
<td>10-17</td>
</tr>
<tr>
<td>C2003</td>
<td>10-18</td>
</tr>
<tr>
<td>C211D07</td>
<td>10-18</td>
</tr>
<tr>
<td>C211D07V2</td>
<td>10-19</td>
</tr>
<tr>
<td>C221CD02</td>
<td>10-19</td>
</tr>
<tr>
<td>C244D04</td>
<td>10-20</td>
</tr>
<tr>
<td>C249D05</td>
<td>10-20</td>
</tr>
<tr>
<td>C2904</td>
<td>10-21</td>
</tr>
<tr>
<td>C30301</td>
<td>10-21</td>
</tr>
<tr>
<td>C305D01</td>
<td>10-22</td>
</tr>
<tr>
<td>C317D02</td>
<td>10-22</td>
</tr>
<tr>
<td>C319BD01</td>
<td>10-23</td>
</tr>
<tr>
<td>C319D06</td>
<td>10-23</td>
</tr>
<tr>
<td>C369D03</td>
<td>10-24</td>
</tr>
<tr>
<td>C5102</td>
<td>10-24</td>
</tr>
<tr>
<td>C744AD01</td>
<td>10-25</td>
</tr>
<tr>
<td>C751D03</td>
<td>10-25</td>
</tr>
<tr>
<td>C7904</td>
<td>10-26</td>
</tr>
<tr>
<td>CD</td>
<td>10-26</td>
</tr>
<tr>
<td>CERECX</td>
<td>10-27</td>
</tr>
<tr>
<td>CERECXF</td>
<td>10-27</td>
</tr>
<tr>
<td>CHPCAP</td>
<td>10-28</td>
</tr>
<tr>
<td>CHPRES</td>
<td>10-28</td>
</tr>
<tr>
<td>COIL1</td>
<td>10-28</td>
</tr>
<tr>
<td>DISK_L</td>
<td>10-29</td>
</tr>
<tr>
<td>DISK_M</td>
<td>10-29</td>
</tr>
<tr>
<td>DISK_S</td>
<td>10-30</td>
</tr>
<tr>
<td>GD11</td>
<td>10-30</td>
</tr>
<tr>
<td>GD16</td>
<td>10-31</td>
</tr>
<tr>
<td>GD4</td>
<td>10-31</td>
</tr>
<tr>
<td>Model</td>
<td>Page</td>
</tr>
<tr>
<td>---------------</td>
<td>------</td>
</tr>
<tr>
<td>GD7</td>
<td>10-32</td>
</tr>
<tr>
<td>GD9</td>
<td>10-32</td>
</tr>
<tr>
<td>GF1</td>
<td>10-33</td>
</tr>
<tr>
<td>GF11</td>
<td>10-33</td>
</tr>
<tr>
<td>GF21</td>
<td>10-34</td>
</tr>
<tr>
<td>GF4</td>
<td>10-34</td>
</tr>
<tr>
<td>GF7</td>
<td>10-35</td>
</tr>
<tr>
<td>HP70GT</td>
<td>10-35</td>
</tr>
<tr>
<td>HP85PLAS</td>
<td>10-36</td>
</tr>
<tr>
<td>HPAC100</td>
<td>10-36</td>
</tr>
<tr>
<td>HPAC100X</td>
<td>10-37</td>
</tr>
<tr>
<td>HPAC200</td>
<td>10-37</td>
</tr>
<tr>
<td>HPAC200V2</td>
<td>10-38</td>
</tr>
<tr>
<td>LG</td>
<td>10-38</td>
</tr>
<tr>
<td>LLD</td>
<td>10-39</td>
</tr>
<tr>
<td>M205</td>
<td>10-39</td>
</tr>
<tr>
<td>M253</td>
<td>10-40</td>
</tr>
<tr>
<td>MACROT</td>
<td>10-40</td>
</tr>
<tr>
<td>MACROX</td>
<td>10-41</td>
</tr>
<tr>
<td>ME</td>
<td>10-41</td>
</tr>
<tr>
<td>MICROX</td>
<td>10-42</td>
</tr>
<tr>
<td>MOP</td>
<td>10-42</td>
</tr>
<tr>
<td>MW4</td>
<td>10-43</td>
</tr>
<tr>
<td>MWT70</td>
<td>10-43</td>
</tr>
<tr>
<td>MWT71</td>
<td>10-44</td>
</tr>
<tr>
<td>MWT73</td>
<td>10-44</td>
</tr>
<tr>
<td>NEC01</td>
<td>10-45</td>
</tr>
<tr>
<td>NEC03</td>
<td>10-45</td>
</tr>
<tr>
<td>NEC07</td>
<td>10-46</td>
</tr>
<tr>
<td>NEC08</td>
<td>10-46</td>
</tr>
<tr>
<td>NEC12</td>
<td>10-47</td>
</tr>
<tr>
<td>NEC13</td>
<td>10-47</td>
</tr>
<tr>
<td>NEC14</td>
<td>10-48</td>
</tr>
<tr>
<td>NEC15</td>
<td>10-48</td>
</tr>
<tr>
<td>NEC18</td>
<td>10-49</td>
</tr>
<tr>
<td>NEC19</td>
<td>10-49</td>
</tr>
<tr>
<td>NEC20</td>
<td>10-50</td>
</tr>
<tr>
<td>NEC30</td>
<td>10-50</td>
</tr>
<tr>
<td>NEC32</td>
<td>10-51</td>
</tr>
<tr>
<td>NEC33</td>
<td>10-51</td>
</tr>
<tr>
<td>NEC34</td>
<td>10-52</td>
</tr>
<tr>
<td>NEC35</td>
<td>10-52</td>
</tr>
</tbody>
</table>
NEC37................................................................................................................ 10-53
NEC38................................................................................................................ 10-53
NEC39................................................................................................................ 10-54
NEC53E ............................................................................................................. 10-54
NEC75................................................................................................................ 10-55
NEC83................................................................................................................ 10-55
NEC84................................................................................................................ 10-56
NEC84A ............................................................................................................. 10-56
NEC87................................................................................................................ 10-57
NEC89................................................................................................................ 10-57
NEC89A .......................................................... 10-58
OKI_1 .......................................................... 10-58
PFLANGE .......................................................... 10-59
RADIAL_L .......................................................... 10-59
RADIAL_M .......................................................... 10-60
RADIAL_S .......................................................... 10-60
RESA.......................................................... 10-61
SFLANGE .......................................................... 10-61
SMA_FEM .......................................................... 10-62
SMSMICROX .......................................................... 10-62
SOD123.......................................................... 10-63
SOD223.......................................................... 10-63
SOD80.......................................................... 10-64
SOT103 .......................................................... 10-64
SOT143 .......................................................... 10-65
SOT143R .......................................................... 10-65
SOT143RV2 .......................................................... 10-66
SOT143V2 .......................................................... 10-66
SOT143V3 .......................................................... 10-67
SOT143V4 .......................................................... 10-67
SOT143V5 .......................................................... 10-68
SOT143V6 .......................................................... 10-69
SOT143V7 .......................................................... 10-70
SOT223 .......................................................... 10-71
SOT223V2 .......................................................... 10-71
SOT23 .......................................................... 10-72
SOT23V2 .......................................................... 10-72
SOT23V3 .......................................................... 10-73
SOT23V4 .......................................................... 10-73
SOT23V5 .......................................................... 10-74
SOT23V6 .......................................................... 10-74
SOT23V7 .......................................................... 10-75
SOT23V8............................................................................................................ 10-75
SOT323.............................................................................................................. 10-76
SOT37................................................................................................................ 10-76
SOT89................................................................................................................ 10-77
SOT89V2............................................................................................................ 10-77
SRP.................................................................................................................... 10-78
TO117................................................................................................................. 10-78
TO206AA............................................................................................................ 10-79
TO206AF ............................................................................................................ 10-79
TO226AA............................................................................................................ 10-80
TO99................................................................................................................... 10-80
TO72................................................................................................................... 10-81
TO72V2 .............................................................................................................. 10-81
TO92................................................................................................................... 10-82
TPLAST.............................................................................................................. 10-82
TUNCAP............................................................................................................. 10-83
UMD ................................................................................................................... 10-83
UPRIGHT .......................................................................................................... 10-84
URP.................................................................................................................... 10-84
WIRE0 ................................................................................................................ 10-85
WIRE1 ................................................................................................................ 10-85

11 SMT Package Layout Artwork Library
   Using SMT PAL for Custom Components ................................................................. 11-2
   Using SMT Package Artwork as Artwork Replacement ........................................... 11-3
   Ceramic Flat Pack (CFP) Packages ....................................................................... 11-4
   Chip and MELF Components ............................................................................... 11-5
   SOT, DPAK, D2PAK Packages ............................................................................ 11-7
   Plastic Flat Pack (PFP) Packages ....................................................................... 11-9
   Quad Flat Pack (QFP) Packages ....................................................................... 11-9
   Plastic Leaded Chip Carrier (PLCC) .................................................................. 11-12
   Small Outline IC (SOIC) .................................................................................. 11-14

12 Font Definitions
   din17......................................................................................................................... 12-1
   iso3098.................................................................................................................... 12-1
   roman ...................................................................................................................... 12-2
   smooth ................................................................................................................... 12-2
   italic ....................................................................................................................... 12-3
   standard .............................................................................................................. 12-3
   gothic ...................................................................................................................... 12-4
   math ....................................................................................................................... 12-4
   sans ....................................................................................................................... 12-5
Index

sansbold ................................................................. 12-5
filled ................................................................. 12-6
filledbold .............................................................. 12-6
straight ................................................................. 12-7
straightfilled .......................................................... 12-7

xii
Chapter 1: Layout Basics

You can create a layout in one of two basic ways:

- By placing parts directly in a Layout window
- By generating it from a schematic in a Schematic window

Creating a Layout Directly, in a Layout Window

For many high-frequency designs, layout constraints control the design process. Slight discontinuities in transmission lines can have a significant impact on design performance. For this type of design, it is often more practical to work directly from a layout, and use the schematic only to add parasitics or non-layout related information for simulation. For example, it is easier to visualize the space requirements of a meandering line with a physical layout than with a schematic, as described in “Creating a Layout Manually” on page 3-2.

You can construct a layout without regard to a schematic, and then create a schematic automatically, from the layout. The layout parameters are automatically updated in the schematic and included in a simulation.

Creating a Layout from a Schematic, in a Schematic Window

You can create a layout from a schematic and maintain the correspondence between the two (this is also known as design synchronization). You can create a layout from a complete schematic, or a partially complete schematic. After you have a Layout and a Schematic, you can update in either direction. For details, see “Creating a Layout from a Schematic” on page 3-22.

Any other approach is a combination of these two. For example, you can simultaneously create a Layout and a Schematic. In this case, you can work in either window, and the other is automatically updated to reflect the changes. For details, see “Creating a Layout as You Create a Schematic” on page 3-22.

The best approach to creating a layout depends on the design and the designer. Regardless of the method or methods you use to create a layout design, you can export it in a variety of formats suitable for manufacturing.

---

Note For detailed information on the design environment, managing design files, and creating designs, see the User’s Guide.
Layout Basics

The Layout Window

The illustration shows the Layout window.

Opening and Closing a Layout Window

There are two ways to open a Layout window, depending on whether it is for a new design or an additional window for the current design.

- To open a Layout window for a new design, from the Main window, click the Layout toolbar icon or choose Window > New Layout (Ctrl+Shift+A).

- To open an additional Layout window for the current design, from the Schematic or Layout window, choose Window > Layout (Ctrl+Shift+L).

To close a Layout window:

- Choose Window > Close or use the keyboard shortcut Ctrl+F4.
Setting Layout Defaults

Layout is shipped with a set of standard defaults that differ depending on program options. These defaults can be modified on a project- or system-wide basis. Before you begin a layout, be sure that Layout defaults are appropriate for the design, program options, and final output required. For details, see “Setting Layout Options” on page 2-1.

Insertion Layers

In a Layout window, objects are placed on a layer. The name of the current insertion layer is displayed in the toolbar and in the status bar (see “The Layout Window” on page 1-2). You can change the insertion layer and copy shapes from one layer to another.

To change the insertion layer, choose one:

- On the Layout window toolbar, choose the name of the layer from the drop-down list next to the layer name.
- Select Insert > Entry Layer and choose a layer from the list.
- Select Options > Layers and select a layer from the list of defined layers in the Layer Editor dialog box.
- Select Insert > Change Entry Layer To and click an object whose layer you wish to make the current insertion layer.
- Use the keyboard shortcut Ctrl+Shift+C and click an object whose layer you want to make the current insertion layer.

To copy a shape from one layer to another:

- From the Layout menu, choose Edit > Advanced Copy/Paste > Copy To Layer. The copied shape is placed at exactly the same coordinates as the original.

When you experiment with placing shapes on different layers, remember to click OK to accept a change in a dialog box.
Layout Basics

Inserting Components and Shapes

To create a layout, you insert components and shapes on the Drawing Area.

To insert components:
- Choose a category of components to display on the Component Palette.
- Click the component in the palette, then click in the Layout window to place it.

To insert a connector, ground, or trace:
- Click the item on the toolbar, then click in the Layout window to place it.

Inserting Shapes

To insert shapes, choose one:
- Click the shape on the toolbar, then click in the Layout window to place it.
- Choose Insert > Coordinate Entry. In the dialog, enter the X and Y Increments to place the shape.
The two types of coordinates are: positional and differential.

*Positional* displays the X,Y coordinates of the cursor position in relation to the total window. By default, the large + in the center of the drawing area is 0,0.

*Differential* displays the distance in X,Y the cursor has traveled since the last click. Set the starting point to 0,0 by clicking anywhere in the drawing area.

<table>
<thead>
<tr>
<th>Positional</th>
<th>Differential</th>
</tr>
</thead>
<tbody>
<tr>
<td>-7.3478, 6.4878</td>
<td>-5.3847, 6.5813</td>
</tr>
</tbody>
</table>

- Choose Insert, then choose a listed shape. The program provides instructions (in the Prompt panel at the bottom of the window) as you insert the shape.

For example, when you select *Insert > Rectangle*, the program displays this prompt:

*Rectangle: Enter the first corner*

Click in the Layout window to define one corner of the rectangle. The prompt changes to:

*Rectangle: Enter the second corner*

As you drag the pointer, you can see the rectangle. When the rectangle is the size you want, click to insert it. See the example.

**Example**

1. Select the rectangle icon on the toolbar.
2. Click in the Drawing window to define the first point on the rectangle. Note that the Differential X,Y coordinate display reads 0.00, 0.00.
3. Move the cursor until the coordinate display reads 200.0, 100.0.
4. Click a second time. A rectangle 200 x 100 mil is inserted in the window.
Layout Basics

**Rotating a Component**

You can save time and mouse-clicks by rotating components as you insert them so that they are properly oriented when you place them.

If you find that a component is not oriented properly as you drag it into position, before you click in the window to place it, either press Shift+R or click the Rotate icon (see the toolbar, above). The component rotates −90° each time. When the component is oriented properly, click to insert it.

**Editing Objects in a Layout Window**

The two ways to edit objects in a Layout window are:

- Using a menu command (*Edit > <command>*)
- Using a command on the toolbar.

Experiment with these commands until you are comfortable using them.
Creating Artwork

In addition to the components supplied with the program that have layout footprints, you can create custom layout components by using one of these methods:

- Using the Graphical Cell Compiler. For details, see the *Graphical Cell Compiler* manual.
- Writing scripts in the Application Extension Language (AEL). For details, see the *AEL* manual.
- Drawing your own shapes and adding the necessary pins/ports.

Releasing a Layout License

When you finish doing layout work, release the Layout license so that the license is available to another user. In the Layout window, select File > Release Layout License.

Using the Design Rule Checker

The Design Rule Checker (DRC) is used to verify that a physical design complies with predefined rules or operations. DRC requires a separate license and is accessed through the Verify menu. For details, see the *Design Rule Checker* manual.
Layout Basics
Chapter 2: Setting Layout Options

This chapter provides details for setting layout options so that you can create a layout in an environment that is compatible with your design. Layout is shipped with preset options that can be modified on a project- or system-wide basis. Before you begin a layout, be sure that the environment is appropriate for the design, the program options, and the final output required.

Note  For output formats, see Chapter 8, Importing and Exporting Layouts.

Defining Layers

All shapes and text are entered on layers. Layout allows you to define any number of mask layers in a file, and to create any number of mask layer files. Each layer must have a unique name and number. Mask layers usually correspond to the masks used in manufacturing a layout. However, mask layers can be used for a number of other purposes.

Often a single process mask layer is represented by a number of layers in a CAD program. For example, power and ground lines are often placed on the same mask for manufacturing, but on a different mask for CAD layout to distinguish them. Further, simple text notes and annotation can be placed on layers that are not output for manufacturing at all.

The program provides a default set of layer definitions, but you can define and save your own layer sets. (See “Saving a Layout Setup” on page 2-36.) Using a standard set of layer definitions saves time because you do not have to define the layers each time you create a design. Note that it is important that hierarchically related designs use the same layer definitions. (See “Using an Existing Layout Setup” on page 2-37.)

Layer definitions are modified through the Layer Editor. To display the Layer Editor, choose Options > Layers.
The details of the Basic and Advanced tabs are covered in Chapter 9, Specifying Layer Definitions, in the User’s Guide. The Visibility tab provides a method of reducing the size of the dialog box while keeping the most frequently used options visible.
Setting Layer Characteristics Globally

You can set attributes layer-by-layer or you can use Global Attributes Control to set the following attributes on all layers at once:

- Protection (against selection) of items on layers
- Visibility of items on layers
- How shapes are displayed
- The style of lines used

The buttons in this area of the Layer Editor dialog enable you to change at once the layer protection and visibility status, how shapes are displayed, and the line style used for all layers. This can be easier than making the same change layer-by-layer. It can also be faster to set an attribute the same for all layers, and then individually change that attribute on the few layers that are an exception. If you want to prevent selection on all layers except one or two of them, use Select None, then select the individual layers you want access to, and turn on the Select status for those layers.

Miscellaneous Layer Editor Features

- The *Ins* (insert) column enables you to change the current entry layer while working in the Layer Editor dialog box so that you can quickly see the effect of your changes.
- The *Reverse* button toggles the display of the layer list top-to-bottom, or vice versa.
- The *Visibility* tab enables you to reduce the size of the Layer Editor dialog box while keeping the most commonly used features of it available for editing.
The Default Layer

Every layer set contains a *default* layer. If you end up with a shape whose layer number does not exist in the current layer set, the attributes of the default layer are assigned to the shape. For example, if you create a shape on a layer and then you delete that layer definition from the Layers list, the shape appears with the characteristics of the default layer. You cannot delete or change the name or number of the default layer, but you can modify all other attributes.

To view the currently-defined layers, choose one:

Choose **Options > Layers.**
Determining the Layer for an Item

To determine the layer for a specific item:

- Select the item and choose Options > Info.

Changing Layer Priority

Layer priority is determined by a layer’s position in the layer list. In the Layout window, layers are drawn from lowest priority (at the top of the list) to highest priority (at the bottom of the list); higher priority layers are drawn on top of lower priority layers.

To change a layer’s priority, change the position of that layer in the list:

1. In the Layers list, choose a layer name or ID.
2. Click Cut. The name and number are deleted from the Layers list.
3. Highlight the layer name that will follow the moved layer.
4. Click Paste to add the layer above the highlighted layer.
Setting Layout Options

To add a layer:

1. Click New.

2. The layer list scrolls to the bottom and a new layer is added. The layer number is the next available, sequential number, and a default name appears that includes the layer number.

3. Rename the layer, if you want, and click Apply.

To delete a layer:

1. In the Layers list area, select a layer name or ID.

2. Click Cut. The name and number are deleted from the Layers list.

Note Do not delete the default layer definitions. The ability to delete is provided to enable you to redefine layer definitions you have created.

Changing the Entry Layer

The name of the current entry layer is displayed in the status panel at the bottom of the window, in the toolbar at the top of the window, and in the Entry Layer dialog. Anything you draw is drawn on the layer you set.

To set the current entry layer, choose one:

- Choose Insert > Entry Layer. Select a layer from the entry layer list.
- Choose Options > Layers. Select the layer from the layer editor list.
- Choose Insert > Change Entry Layer To. Click the object whose layer you wish to make current.
- Click the entry layer drop-down in the toolbar. Choose the layer from the list.
Defining Port Connections (Layer Binding)

Use layer binding (in the Advanced tab of the Layer Editor) to define the connections that a given port can make. In this field, enter the layers that ports must be on to connect to a port on the selected layer. For example, if the selected layer is cond and the only entry in the Layer Binding list is cond2, ports on the cond layer will connect only to ports on the cond2 layer. Enter an asterisk (*) to connect to ports on any layer.

<table>
<thead>
<tr>
<th>Layer Binding</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
</tr>
<tr>
<td>x</td>
</tr>
<tr>
<td>x</td>
</tr>
<tr>
<td>x</td>
</tr>
<tr>
<td>x</td>
</tr>
<tr>
<td>cond</td>
</tr>
<tr>
<td>cond2</td>
</tr>
<tr>
<td>x</td>
</tr>
<tr>
<td>x</td>
</tr>
</tbody>
</table>

Changing the Visibility and Protected Status of Items

Visible toggles the display of items on the selected layer. To display items on a given layer, enable the Vis option for that layer. By default, visibility is turned on for all layers, making all items visible.

Selected toggles the protection status of items on the selected layer. To protect a layer so that you can prevent items from being selected, disable the Sel option for that layer. This can be useful if you need to edit certain types of items, but not others, in a crowded design. By default, protection is turned off for all layers, making all items available for selection.
Setting Layout Options

Using IGES and GDSII Numbers

These numbers do not have to be unique. The IGES number is used to set the IGES level number. The GDSII layer number is used for both reading and writing GDSII stream files; it must be a number between 0-255.

Assigning Layers for Transmission Line Components

By default, transmission line components are placed on the cond layer, but you can specify different layers for multi-layer designs.

To assign the layer for transmission line components:

1. Double-click the appropriate substrate item (to open the Component Parameters dialog box):
   - For microstrip elements, this is the referenced MSUB.
   - For Stripline elements, use SSUB (Stripline Substrate).
   - For Suspended Substrate elements, use SSSUB (Suspended Substrate).

2. Select any of the following layer parameters to be re-mapped:

<table>
<thead>
<tr>
<th>Cond1</th>
<th>Cond2</th>
<th>Die1</th>
<th>Die2</th>
<th>Hole</th>
<th>Res</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;cond&quot;</td>
<td>&quot;cond2&quot;</td>
<td>&quot;die1&quot;</td>
<td>&quot;die2&quot;</td>
<td>&quot;hole&quot;</td>
<td>&quot;yes&quot;</td>
</tr>
</tbody>
</table>

3. Select a different layer from the list of layers at the right and click **Apply**.

4. Regenerate the layout. All the microstrip components will be placed on the new layer.

Layer Files and Library Components

Library components rely on certain layers being defined. For example, by default, all top-level metallization for components in microstrip and stripline libraries is placed on layer 1 (cond). In general, layers 1-12 should be defined so that the layout libraries function properly. If a layer is missing, the artwork for an element can not be created.

If you remove layer 1 cond, you must change the element’s corresponding substrate element to specify a different layer number. For example, if you remove layer 1,
artwork for microstrip elements will not be generated unless you change the *cond* parameter of the MSUB_DEFAULT item referenced by these elements. Also, the packaged parts library uses a number of layers to display part-packaged outlines, leads and other information. If you plan to use this library, be sure to include layer definitions compatible with the defaults.

**Layer Files and Design Files**

Every design has an associated layer file. When you create a design, the program automatically looks for a layer file called *layout.lay*. By default, the program looks in the current project directory first. If it does not exist there, it looks for it in the directory `HPEESOF_DIR\lib\<program_name>\defaults`.

---

**Note**  
The variable that defines this search order is `LAYERS_PATH`. For additional details, refer to the *Installation and Customization* manual.

---

All text and shapes are entered on layers, and each layer has a number assigned to it. The layer number for each part of a design is stored in the design file, but the attributes comprising the actual layer definition are stored in the layer file. For example, if your design contains a polygon, the program notes the layer number for the polygon in the design file and searches the current layer file for a matching layer number. It can then display the polygon with the appropriate color, fill pattern, etc.

**Ensuring Compatible Layer Definitions**

Always use the same (or compatible) layer definitions for related designs. This is especially important for designs that are related hierarchically. For example, if you use layer 1 for first layer metallization in one design, you should do the same for all related designs. If designs have incompatible layer numbering, you can change the layer number associated with a shape by moving that shape to the appropriate layer using the *Edit > Move > Move to Layer* command.

If you have made any changes to the layer definitions but have *not yet clicked Apply*, you can click Reset (in the Layer Editor dialog box) to return the layer definitions to the state they were in before you started making changes.

Different designs can have different layer sets associated with them by reading in different layer files.
Layer File Format

Each line in a layer file defines a layer. There is no limit to the number of layers that can be defined. The layer names and numbers must be unique. Any layer numbered 0, must have the name default. It can have its other characteristics set to any valid value. By default, when a new design is created, it becomes associated with the schematic.lay and layout.lay layer file found on the path. If none are found, the program uses internal defaults.

The format for a layer file is:

```
layer_name layer_num gds_num iges_num color fill line_type plot_mode protect_flag
visible_flag layer_binding layer_type
```

The fields are separated by one or more spaces or tabs. Each field is described below.

*layer_name*  Name of the layer. It must be unique within this file. The name default has special significance and must have layer number 0. For details, see the User’s Guide.

The string can be any length, but should only contain letters, numbers or the underscore.

*layer_num*  This is the layer number. The number associates a layer’s attributes (color, name, fill, etc.) with objects stored in the design. For example, stored with a rectangle is the information that it is on mask layer 4. The program searches the layer file by number to determine how to plot the layer.

All layer numbers are integers between 0 and the largest integer (approximately 2 billion). Layer number 0 is reserved for the default layer (see above). Each layer number in the file must be unique.

*gds_num*  This is the number to use as the GDSII stream layer number when translating a layout to GDSII stream format with the GDSII export option.

This is an integer in the range of 0-255.

*iges_num*  This is used as the IGES level number when exporting a layout to IGES format.

*color*  An index into the eesof.col file that determines the color that an object is drawn. It can be any integer in the range of 0, to the number of colors defined in eesof.col.
**fill**  An index into the *eesof.fil* file that determines the fill pattern used when the layer plot mode is *filled* or *both*. It can be any integer in the range of 0, to the number of fill patterns defined in *eesof.fil*.

**Note**  The *hpeesof.fil* file contains the names of X bitmap files that determine screen fill, and the HPGL fill pattern numbers when plotting to a HPGL hardcopy device.

**line_type**  An integer representing the line style type. The available line styles are:

0 = solid
1 = dot
2 = double dot
3 = short dash
4 = short dot dash
5 = long dash
6 = long dot dash

**plot_mode**  An integer representing how a closed object (circle or polygon) is plotted.

0 = outline
1 = filled
2 = both filled and outline

**protect_flag**  Integer 0 or 1 representing whether a layer is protected or not (nothing can be selected on a protected layer).

0 = not protected
1 = protected

**visible_flag**  The integer 0 or 1 representing whether a layer is visible or not.

0 = not visible (not plotted)
1 = visible

**layer_binding**  Names of the layers a port must be on to connect to a port on this layer. An asterisk (*) = connection to any layer.

**layer_type**  An integer representing the layer type.
Setting Layout Options

1 = Physical
2 = Notes
4 = DRC
5 = LVS

Preferences for Layout

To access Preferences for Layout, select Options > Preferences.

Use these to scroll among the various tabs.
Changing Select Options

To change select options, select Options > Preferences > Select.

Setting How Polygons are Selected

You can choose one of two select modes for closed shapes (polygons): clicking inside the shape or clicking near the edge of the shape.

1. Choose the menu command Options > Preferences.
2. In the Preferences for Layout Dialog Box, choose the Select tab.
3. In the Select Mode for Polygons, choose the method:
   - By edge enables you to select a polygon by clicking on its outer edge.
   - Inside enables you to select a polygon by clicking anywhere inside the shape.
Setting Layout Options

Setting Color for Selected Items

1. Choose the menu command **Options > Preferences**.
2. In the Preferences for Layout Dialog Box, choose the Select tab.
3. Click the colored box next to the word Color and select the color from the displayed palette. This sets the color for:
   - the color of the marker that identifies a selected vertex,
   - the box drawn around items identifying them as being selected.

Setting the Size of the Pick Region

The pick region defines how close the pointer must be to an item to select it.

1. Choose the command **Options > Preferences**
2. In the Preferences for Layout Dialog Box, choose the Select tab.
3. In the Size area, locate the Pick Box field.
4. Enter the size for the marker, and select the units.
   - **Screen pixels** specifies sizes in terms of pixels on the screen. For example, if you choose 5 screen pixels, an item must be within 5 pixels of the pointer to be selected.
   - **Layout Units** specifies sizes in terms of the current units of the window. For example, if you are using inches and choose 0.1 layout units, an item must be within 0.1 inch of the pointer to be selected.
Setting the Size of Vertex Markers

A Vertex marker identifies a selected vertex.

1. Choose the menu command **Options > Preferences**.
2. In the Preferences for Layout Dialog Box, choose the Select tab.
3. In the Size area, locate the Selected Vertex field.
4. Enter the size for the marker, and select the units.

   *Screen pixels* specifies sizes in terms of pixels on the screen. For example, if you choose 5 screen pixels, the size of the marker is 5 pixels.

   *Layout Units* specifies sizes in terms of the current units of the window. For example, if you are using inches and choose 0.1 layout units, the size of the marker is 0.1 inch.

Changing Grid and Snap Settings

To change grid and snap settings, select **Options > Preferences > Grid/Snap**

You can establish settings for a snap grid and a display grid to assist you in creating a layout. The display grid appears on the screen as a series of vertical and horizontal lines or dots, but does not print. You use it to ensure exact alignment of pins and vertices as well as provide visual clues to spacing.
Setting Layout Options

2-16 Preferences for Layout

Setting Grid Visibility and Color

1. Choose the menu command Options > Preferences.
2. In the Preferences for Layout Dialog Box, choose the Grid/Snap tab.
3. In the Display area, choose Major, Minor, or both.
4. Choose the Type of display (Dots or Lines). You can have to zoom in to see the grid display.
5. Click the colored rectangle next to the word Color, and choose the color for the grid. Click OK to dismiss the color palette.
6. Click Apply.

Setting Snap and Grid Spacing

The ability to display a major grid as an increment of the minor grid enables you to better gauge distances and align objects in layout.

1. Choose the menu command Options > Preferences.
2. In the Preferences for Layout Dialog Box, choose the Grid/Snap tab.
3. In the Spacing area, enter Minor Grid display factors for both X and Y.
   The larger the number, the wider the grid spacing.
4. Click Apply.
If the display factor you specify makes the grid too dense to display, it is invisible unless you zoom in. To see the grid without zooming, choose a larger display factor.

5. If the Major Grid requires changing, enter X and Y factors in those fields and click Apply.

**Setting Pin/Vertex Snap Distance**

Represents how close the cursor must be to a pin of a component or a vertex of a shape before the cursor will snap to it.

A large value makes it easier to place an object on a snap point when you are unsure of the snap point’s exact location. A small value makes it easier to select a given snap point that has several other snap points very near it.

1. Choose the menu command **Options > Preferences**.

2. In the Preferences for Layout Dialog Box, choose the Grid/Snap tab. In the Pin/Vertex Snap area, enter a number for the Diameter of the snap region.

3. Specify the Units.

   *Screen pixels* specifies sizes in terms of pixels on the screen. For example, if you choose 15 screen pixels, the diameter of the snap region is 15 pixels.

   *Layout Units* specifies sizes in terms of the current units of the window. For example, if you are using inches and choose 0.1 layout units, the diameter of the snap region is 0.1 inch.

4. Click Apply.

**Setting Snap Modes**

Snap modes control where the program places objects on the page when you insert, move, or stretch them; you can change snap modes when inserting, moving, or stretching an object, or drawing a shape. When snap is enabled, items are pulled to the snap grid. You can restrict or enhance the manner in which the cursor snaps by choosing any combination of snap modes. *Table 2-1* lists the snap modes that you can set, and their priorities.
Setting Layout Options

Table 2-1. Setting Snap Modes

<table>
<thead>
<tr>
<th>Snap Mode</th>
<th>Priority</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pin</td>
<td>1</td>
</tr>
<tr>
<td>Vertex</td>
<td>2</td>
</tr>
<tr>
<td>Midpoint</td>
<td></td>
</tr>
<tr>
<td>Intersect</td>
<td></td>
</tr>
<tr>
<td>Arc/Circle Center</td>
<td></td>
</tr>
<tr>
<td>Edge</td>
<td>3</td>
</tr>
<tr>
<td>Grid</td>
<td>4</td>
</tr>
</tbody>
</table>

_Angle Snapping_ automatically occurs when only Pin snapping is enabled and you place a part so that the pin at the cursor connects to an existing part. The placed part rotates so that it properly aligns with the connected part.

For example, if you have a microstrip curve at $30^\circ$ and place a microstrip line so that it connects to it, the microstrip line will snap to $30^\circ$ so that it properly abuts the curve.

_Enable Snap_ toggles snap mode on and off. You can toggle snap mode on and off from the Options menu itself, and by default, there are snap mode buttons on the toolbar.

Except for pin snap, the pointer defines the point on the inserted object (the selected location).

When you set all snap modes OFF, you can insert objects exactly where you release them on the page. This is sometimes called raw snap mode. Like other snap modes, the raw snap mode also applies when you move or stretch objects.

_Pin_ When a _pin_ on an object you insert, move, or stretch is within the snap distance of a pin on an existing object, the program inserts the object with its pin connected to
the pin of the existing object. Pin snapping takes priority over all other snapping modes.

**Vertex** When the selected location on an object you insert, move, or stretch is within the snap distance of a vertex on an existing object, the program inserts that object with its selected location on the vertex of the existing object. (Vertex refers to a control point or boundary corner on a primitive, or an intersection of construction lines.)

**Midpoint** When the selected location on an object you insert, move, or stretch is within the snap distance of the midpoint of an existing object, the program inserts that object with its selected location on the midpoint of the existing object.

**Intersection** When the selected location on an object you insert, move, or stretch is within the snap distance of the intersection of the edges of two existing objects, the program inserts that object with its selected location on the intersection of the existing objects.

---

**Hint** Because of the length of time it takes to redraw the screen when Intersection snap is on, we recommend you turn it on only when you are ready to make the connection, and then turn it off again.

---

**Arc/Circle Center** When the selected location on an object you insert, move, or stretch is within the snap distance of the center of an existing arc or circle, the program inserts that object with its selected location on the midpoint of the existing arc or circle.

**Edge** When the selected location on an object you insert, move, or stretch is within the snap distance of the edge of an existing object, the program inserts that object with its selected location on the edge of the existing object. After a point snaps to an edge, it is captured by that edge, and will slide along the edge unless you move the pointer out of the snap distance.

Because edge snapping has a priority 3, if the cursor comes to within snap distance of anything with a priority 1 or 2 while sliding along an edge, it will snap the selected location to that.

**Grid** When the selected location on an object you insert, move, or stretch is within the snap distance of a grid point, the program inserts that object with its selected location on the grid point.

All other snap modes have priority over grid snap mode.
Setting Layout Options

Hints

- Whenever possible, keep grid snapping on. After data is off grid, it is difficult to get it back on.

- Use 45- or 90-degree angles to ensure even alignment of data with less probability of small layout gaps due to round-off errors.

- Keep grid spacing set at increments of a base grid setting. When grid snapping is on, coordinates entered with the mouse are rounded off or snapped to the grid setting.

Selecting Placement Options

To change placement options, select Options > Preferences > Placement.

Single Representation  When you place an item in one representation, nothing is automatically placed in the other representation.

Dual Representation  When you place an item in one representation and move the pointer into the window for the other representation, the equivalent component is already selected. Position the pointer and click to place it. (If a window for the other representation—containing the same design—is not open, one is opened automatically.)
Preferences for Layout 2-21

Always Design Synchronize  Causes the program to fully synchronize both representations after each part is placed, ensuring all parts are fully interconnected. This takes more time than the Dual Representation mode and can move or rearrange the layout or the schematic to preserve connectivity.

**Toggling Display of the Component Parameter Dialog Box**

The Component Parameter Dialog box displays the parameters for a selected component. Double-click a component to view this dialog box.

1. Choose the menu command **Options > Preferences**
2. In the Preferences for Layout dialog box, choose the Placement tab.
3. Toggle the options for the Component Parameter dialog box.

*Component Parameter Dialog* toggles the display of the Component Parameter dialog box. By default, when you click a component, a dialog box appears that displays the component’s parameters. If you disable this feature, the dialog box appears only when you choose the command Edit > Item > Edit Component Parameters, or when you click the Edit Component Parameters button on the toolbar.

*Show Component Parameter Dialog for components without parameters* displays the Item Parameters dialog box even for components that do not have parameters (GROUND, for example). By default it is off and the dialog box does not appear. Double-clicking the component symbol brings up the dialog box so that you can change the item ID.

4. Click Apply.

**Toggling Repeatable Component Placement**

By default, a component remains selected for placement until you deactivate it. This enables you to place more than one copy of a component without selecting it each time.

1. Choose the menu command **Options > Preferences**.
2. In the Preferences for Layout dialog box, choose the Placement tab.
3. Enable/disable the Auto-repeatable component placement option.
4. Click Apply.
Setting Layout Options

**Setting the Size of Ports and Grounds**

Use the field in this panel to set the size (in layout units or screen pixels) of ports and grounds.

**Changing Options for Pins/Tees**

To change pins/tees options, select *Options > Preferences > Pin/Tee*.

![Pin/Tee settings dialog box]

**Setting the Size of Connection Markers**

1. Choose the menu command *Options > Preferences*.
2. In the Preferences for Layout Dialog Box, choose the Pin/Tee tab. There are two types of connection markers:
   - *Pin* sets the size of the marker that identifies component pins.
   - *Tee* sets the size of the marker that identifies tee connections between interconnected wires.
3. Enter the size and select the units.
   - *Screen pixels* specifies sizes in terms of pixels on the screen. For example, if you choose 5 screen pixels, the size of the marker is 5 pixels.
Layout Units specifies sizes in terms of the current units of the window. For example, if you are using inches and choose 0.1 layout units, the size of the marker is 0.1 inch.

Setting the Color of Pin & Tee Connections

1. Choose the menu command Options > Preferences.
2. In the Preferences for Layout Dialog Box, choose the Pin/Tee tab.
3. Use the selections in the Color area to specify the color of the markers that identify connected pins, tee connections between interconnected wires, pin numbers, pin names, node voltages, pin currents, and node names.

Note Unconnected pins appear in the color set for highlighted items (see “Changing Display Colors” on page 2-29).

Setting Visibility of Connected Pins, Pin Numbers & Names

1. Choose the menu command Options > Preferences.
2. In the Preferences for Layout Dialog Box, choose the Pin/Tee tab.
3. Use the selections in the Visibility area to toggle the visibility status of connected pin markers, pin numbers, and pin names.

Note The Connected Pin selection in the Color area of this panel sets the color for the markers that identify connected pins, pin numbers, and pin names.
Changing Entry/Edit Attributes

To change entry/edit options, choose Options > Preferences > Entry/Edit.

- **Polygon Entry Mode: Any angle**
  Enables you to draw polylines, polygons, and wires using all angles.

- **Polygon Entry Mode: 45 degree angle only**
  Restricts shape entry to 45 degree rotation increments.

- **Polygon Entry Mode: 90 degree angle only**
  Restricts shape entry to horizontal or vertical.

- **Show Coordinate Entry Dialog for Insert and Edit commands**
  Select this option to force the Coordinate Entry dialog box to be displayed when invoking the following commands:

    - **Insert (Shape)**—Polygon, Polyline, Rectangle, Circle, Arc (clockwise and counter-clockwise), Text, Construction Line, Symbol Pin, Path, Trace.
    - **Edit**—Move Wire Endpoint, Mirror X, Mirror Y, Move & Disconnect, Step And Repeat, Set Origin, Move Component Text.

- **Show Set Paste Origin Dialog for Copy Command**
  Select this option to force the Set Paste Origin dialog box to be displayed when you choose the Copy command. This dialog box enables you to specify X and Y coordinates to be used as a reference point when pasting.

- **Polygon self-intersection checking**
  Prevents you from placing additional points on a polygon if overlapping lines will result.

---

2-24  Preferences for Layout
• **Maintain adjacent angles for Move Edge command**
  
  Restricts the Move Edge command to stretch an edge while maintaining the adjacent angles of the edge being stretched to other edges adjacent to that edge.

• **Reroute entire wire attached to moved component**
  
  When this option is selected, the wire connection is allowed to be completely redrawn and rerouted as needed. When this option is deselected, only the segment (up to the first bend) of the wire attached to the component you are moving is rerouted; the remainder of the wire is unaffected.

• **Reroute entire trace attached to moved component**
  
  When this option is selected, the trace connection is allowed to be completely redrawn and rerouted as needed. When this option is deselected, only the segment (up to the first bend) of the trace attached to the component you are moving is rerouted; the remainder of the trace is unaffected.

![Diagram of rerouting options](image)

• **Arc/Circle Radius (degrees)**
  
  Determines how smoothly curves are drawn. The number entered here defines when the program starts a new line segment. For example, an entry of 5 means that the program begins a new line every 5 degrees. In general, the fewer degrees, the smoother the shape, but the longer it takes to redraw the screen.

![Diagram of arc/circle radius examples](image)
Note: This setting affects only circles in that the number specified here is used if you convert a circle to a polygon.

- **Auto-backup edit count**
  Automatically saves a file each time the number of edits to that file reaches the number in this field.

- **Undo edit count**
  This option represents the maximum number of commands held in the stack. Selecting *Undo* from the Edit menu or clicking the Undo button on the toolbar undoes the last editing command. A *stack* of edit commands is maintained for each window, thus the *Undo* command works independently from window to window. You can choose *Undo* repeatedly to return to an earlier state of your design. You can specify the number of commands you want the stack to hold using the *Undo edit count* option.

- **Rotation Increment (angle)**
  This option forces objects you rotate to snap—during rotation—in $n$-degree increments, where $n$ is the number you specify here.

- **Drag and Move**
  This option is designed to prevent you from moving an item when you click to select it (for any purpose) and unintentionally move the pointer in the process. By default, a move less than 10 screen pixels is not recognized as a move. An intentional move must be more than the distance specified here for it to be recognized as a move.

- **Merge/Boolean Logical/Create Clearance**
  *Final Minimum Vertex Distance (in Layout Units)*—Vertices that fall within the distance entered here are collapsed into one vertex. This eliminates the spikes or slivers created during merge operations that happen when vertices are too close together.
Changing Component Text Attributes

To change text attribute options, select Options > Preferences > Component Text.

Component text is the text associated with components selected from a library or palette. If the designated layer is visible, this text appears automatically when a component is placed in the Layout window.

Setting Component Text Font & Height

*Font*  Use the drop-down list to choose a font. The default is HersheyRomanNarrow.

*Height* represents the text height with respect to the current units in a window (displayed in the status panel at the bottom of the window).

Setting the Layers for Component Text

When a component is placed in layout, its name and reference designator (ID) are automatically placed with it on the silk screen layers. By default, the name is placed on the layer *silk_screen2*; the ID is placed on the layer *silk_screen*.

*Name*  Use the drop-down list to define the layer for component names.

*ID*  Use the drop-down list to define the layer for component IDs.


**Changing Typed-in Text Attributes**

To change text options, select *Options > Preferences > Text.*

- **Font Type**—All TrueType fonts installed on your system are available. Select the desired font from the drop-down list. When printing to an HP-GL/2 file, text information will not be saved if the font is a TrueType font. To preserve the text in your output file, convert it to HersheyRomanNarrow before saving to HP-GL/2.

  
  
  **Note** On UNIX, if you want to add additional TrueType fonts that were not supplied with ADS, copy them to `$HPEESOF_DIR/lib/fonts` (where `$HPEESOF_DIR` represents your complete installation path).

- **Size**—Represents the size of text in traditional units used in printing.

- **Justification, Horizontal**—This setting represents two types of justification: one is how individual lines of text in a block of text are aligned with one another; the second is how an individual line of text or block of text is positioned horizontally, relative to the reference point you specified to begin typing the text.

- **Justification, Vertical**—This setting aligns a string or block of text vertically, relative to the reference point you specified to begin typing the text.

- **Placement Angle**—The angle at which all text subsequently added to your design will be drawn.
• **Non-rotating (when in hierarchy)**—Select this option to prevent text on a symbol or design from being rotated when the symbol is rotated.

### Changing Display Colors

To change display color options, select *Options > Preferences > Display.*

![Display Preferences](image)

#### Setting the Color of the Drawing Area

1. Choose the menu command *Options > Preferences.*
2. In the Preferences for Layout Dialog Box, choose the *Display* tab.
3. In the Color area, click the color box to display a palette from which to choose a color.
   - *Foreground* defines the color of the lines making up polygons, polylines, and arcs.
   - *Background* defines the color of the Layout window background.
4. Click *Apply.*

#### Setting the Color of Unconnected Pins

1. Choose the menu command *Options > Preferences.*
2. In the Preferences for Layout Dialog Box, choose the Display tab.
3. In the Color area, click the colored box next to the word *Highlight* and select the color from the displayed palette.
Setting Layout Options

4. Click **OK** to dismiss the palette.

5. Click Apply. This sets the color for:
   - the marker that identifies an unconnected component pin, and
   - the box that the *program* uses to highlight an item. This type of highlighting is used when you use choose one of the *Layout (Schematic) > Show* commands.

Setting DRC Memory Use and Performance

To change DRC options, select **Options > Preferences > Verify.**

![DRC Memory Use and Performance](image)

Use these selections to set parameters that tune DRC’s memory usage and performance.
Memory Management

- Real Memory—This is the real memory that DRC is allowed to use (in Mbyte).
- Storage per Area—This is the amount of memory needed per unit area (in layout units). To enable a large design to be checked on a small machine, a design can be broken down into a list of smaller check regions. Using these two memory factors, DRC decides whether the design fits in a single check region, or whether it requires a large number of smaller check regions.

\[
\text{Maximum_check_area} = \frac{\text{real_memory_in_bytes}}{\text{storage_per_area}}
\]

The storage_per_area can be calibrated. At the end of a DRC run, the actual storage_per_area used is reported, and can be used as a better estimate for subsequent runs on the same design.

Epsilon

The offset to the clearance rule in DRC operation to compensate for arithmetic rounding errors. Note this is in database units, not layout units. For example, for a 5 micron minimum spacing rule, this ensures that the edges, which are exactly 5 microns apart, will not be pulled in as an error.

Fringe

If a design is broken down into smaller check regions due to memory constraints, each region is enlarged by this amount to catch any errors that occur close to the border of the region. This is normally the size of the biggest clearance rule, and is specified in layout units.

Bin Width

Bin width is used to tune the performance of DRC operation. Each check region is divided into bins by the sorting grid of this width. The performance of the check depends on the number of vertices and edges loaded in each bin. Too many empty bins, or too many vertices and edges in each bin will degrade the performance. This is specified in layout units.
Changing Miscellaneous Display Options

To change hierarchy display options, select Options > Preferences > Display.

- **Foreground** — The color of the lines making up polygons, polylines, and arcs while they are being drawn.
- **Background** — The color of the drawing area background in the design window.
- **Highlight** — The color used to identify problem items (with respect to simulation), orphaned items in schematic and layout representations, and unconnected pins.
- **Hierarchical Plotting Depth** — The level of detail displayed in hierarchical designs. Any item nested below the plotting depth specified here is drawn as a bounding box, which can significantly increase the redraw speed of complex hierarchical designs. Plotting depth affects both screen and hardcopy output.
- **Minimum Object Size To Display (in pixels)** — The minimum size (in pixels) an object must be before it is actually drawn in the Schematic window. Objects smaller than this are not visible.
- **Display Box For Objects Smaller Than Minimum Object Size (<current minimum size>)** — Draws a box to represent any object that is smaller than the minimum object size (based on the setting in the field above).
  - **Maximum Hierarchical Depth At Which to Draw Box** — The number of levels in the hierarchical design for which you want a box drawn.
- **Display instance names of components in subnetworks** —
- **Display text origin marker** — Displays a cross mark at the point you clicked to begin typing text (the lower left corner of the text string).
Setting Units/Scale Factors

To change units and scale options, select Options > Preferences > Units/Scale.

Scale factors are used in simulation and in generating artwork for parameterized artwork components.

Scale factors used in the layout should match those you want in the final output.

There are usually no problems associated with translating units that are in the same measurement system (mils to inches, or centimeters to millimeters), but round-off errors can occur when translating between metric and English units.
Setting Layout Options

Changing Layout Units & Resolution

To change layout units and resolution options, select Options > Preferences > Layout Units.

1. Choose the menu command Options > Preferences.
2. In the dialog box that appears, select the Layout Units tab.
3. Enter the resolution.
4. Click Apply. The resolution changes for the current design.

Layout units are used for any drawn item (such as a polygon, circle, or square).

Notes  Set the correct layout units at the beginning of a design. Changing units after a design is complete can result in the loss of information (due to round-off errors). Because of this, if you must change the units of an existing design, you should make a copy of the file before you change the units. Then you can compare the designs after the change to determine if any information was lost.

When you change layout units, only the current design is rescaled to the new units.

Setting Layout Resolution

Set the correct resolution (the smallest number allowed in layout) at the beginning of a design.

1. Choose the menu command Options > Preferences.
2. In the dialog box that appears, select the Layout Units tab.
3. Enter the resolution.
4. Click Apply. The resolution changes for the current design.
The smaller the number the more precise the data base, but because Layout uses a 32-bit integer data base, setting a very small resolution limits the largest user number that can be represented. This is usually not a problem for most designs until the resolution is greater than 0.0001.

The greater the resolution, the more difficult it is to ensure exact alignment of vertices in layout. Conversely, the greater the resolution, the smaller the gaps from round-off errors produced by non-orthogonal angles.

It is important to consider using a consistent resolution when creating related designs, or when using the packaged parts library. Information can be lost when going from a higher to a lower resolution; and, a design with a resolution setting of 1000 placed inside a design with resolution setting of 100 will appear 10 times too large. The packaged parts library was created using the default resolution setting (100).

Angles are stored in the data base as integers, but they have a hard-coded resolution of 1000 data base units per degree. All angles are stored in degrees between −180 and 180 degrees. Angles specified with more than three decimal places are rounded off (24.7895 is stored as 24.790).

**Toggling the Coordinate Readout Display**

To change coordinate readout display options, select View > Coordinate Readout.

The X,Y coordinate display, which appears in the status bar at the bottom of the Layout window, displays two types of coordinates: positional and differential.

The coordinate readout is on by default.

*Positional* displays the X,Y coordinates of the cursor position in relation to the total window. By default, the large + in the center of the drawing area is 0,0.

*Differential* displays the distance in X,Y the cursor has traveled since the last click. Set the starting point to 0,0 by clicking anywhere in the drawing area.
Setting Layout Options

To toggle the display:

1. Choose the menu command View.
2. Click Coordinate Readout.

Saving a Layout Setup

After you have the layout environment set optimally for your design, you can save these settings to be used for other designs. A complete layout setup comprises two files:

- A preferences file that contains all settings under the Options menu except for layer information and options that can be set differently within a design (such as text height).
- A layer file that contains all of the layer information.

Note: When you save a design file, the preference and layer files that are current at that time are read the next time you open that design file.

Saving Layout Preferences

You can save the settings in the Preferences for Layout dialog box to either the default preferences file (layout.prf), or a new preferences file.

1. In the Preferences for Layout dialog box, click Save.
2. In the Save Preferences File dialog box, add the file name to the end of the path displayed in the Selection field.

If you use the default preferences filename (layout.prf), those preferences are read in each time you create a design in the current project directory.
Saving Layer Information

You can save the settings in the Layer Editor dialog box to either the default layer file (layout.lay), or a new layer file.

1. In the Layer Editor dialog box (Options > Layers), click **Save**.
2. In the Save Layer File dialog box, add the layer file name to the end of the path displayed in the Selection field.

If you use the **default** layer filename (layout.lay), the default layer set is read in each time you *create* a design in that project directory.

Using an Existing Layout Setup

You can re-use existing layout information for a design, rather than setting up the layout environment each time you begin a design. A complete layout setup comprises two files:

- A **preferences** file that contains all settings under the Options menu except for layer information and options that can be set differently within a design (such as text height).
- A **layer** file that contains all of the layer information.

**Note** When you save a design file, the preference and layer files that are current at that time are read the next time you open that design file.

Reading in an Existing Preferences File

1. In the Preferences for Layout dialog box, click **Read**.
2. In the Read Preferences File dialog box, double click the *.pref file you want to read.
Setting Layout Options

Reading in an Existing Layer File
1. In the Layer Editor dialog box (Options > Layers), click Read.
2. In the Read Layer File dialog box, double click the *.lay file you want to read.

Reading a File from a Different Project Directory
1. In the Directories field, double click *_prj/...
2. Choose the project directory you want to read.
3. Double click the layer file.

Pick and Place Report
To generate a Pick and Place Report:
1. Select File > Reports > Pick and Place to open the dialog.

![Pick and Place Report dialog box]

This dialog box allows you to edit the report name.

Viewing Pick and Place Report Configuration Options
To view the current pick and place report configuration options, do the following:
1. Select File > Reports > Pick and Place.
2. In the Pick And Place dialog box click the Show Options button.

![Pick and Place Report dialog box with Show Options button highlighted]
3. The Report Options dialog box appears. This dialog box allows you to view and print the current report configuration options.

![Report Options dialog box]

### Configuring the Pick and Place Report

The Pick and Place Report is configured using the file `de_parts.ael`. This file is read during startup.

**Note** Prior to ADS 1.3, the `de_parts.ael` file contained an AEL script that generated a Parts List Report. The report was generated when Parts List was executed. The `de_parts.ael` file is now used only to configure the Pick and Place and Parts List reports.

If you have customized the Parts List report, you can retain this functionality by concatenating your custom `de_parts.ael` file to the system `de_parts.ael` file. You will be redefining the `de_parts` function.

You can customize the column data and the formatting of the report. You can add extra data columns in the report. The columns can be instance parameters, instance properties, or instance attributes.

The procedure `de_parts_set_pick_and_place_options` is called every time a Pick and Place Report is generated.

To modify the format of the Pick and Place Parts list, make a local copy of the system `de_parts.ael` file:
Setting Layout Options

```
cp $HPEESOF_DIR/de/ael/de_parts.ael $HOME/hpeesof/de/ael

To make your changes current without having to reboot ADS, reload the de_parts.ael file by typing the following line in the Command Line dialog box:

load ('de_parts.ael');

DE_PARTS_SET_PICK_AND_PLACE_OPTIONS

Routine: Configure the pick and place report
Method: This procedure is called every time a Pick and Place Report is generated.

defun de_parts_set_pick_and_place_options ()
{
    de_parts_option_initialize ();
    /* Reset to system defaults */
    /* Null out the exclusion and
       inclusion lists */

    de_parts_option_set_hierarchical (TRUE); /* Hierarchical report */
    de_parts_option_set_center_placement (TRUE); /* X,Y location at center */
    de_parts_option_check_bom (FALSE); /* Do not check BOM flag */

    /* Do not include simulation models */
    de_parts_option_add_exclusion_items (DePartsLumpedWithArtworkElements);
    de_parts_option_add_exclusion_items (DePartsMicrostripElements);
    de_parts_option_add_exclusion_items (DePartsPCBoardElements);
    de_parts_option_add_exclusion_items (DePartsStriplineElements);
    de_parts_option_add_exclusion_items (DePartsSuspSubElements);
    de_parts_option_add_exclusion_items (DePartsCoplanarElements);
    de_parts_option_add_exclusion_items (DePartsMultilayerElements);
    de_parts_option_add_exclusion_items (DePartsBlockTextFontsElements);

    /* Add an additional column to display the PART_NUM instance attribute */
    de_parts_option_set_attribute_columns (list ("PART_NUM"));
    de_parts_option_set_delimeter (NULL); /* Align columns */
    de_parts_option_include_header (TRUE); /* Include header */
    de_parts_option_sort_by_component (TRUE); /* Sort by component name */
}
```
Configuring the Parts List Report

The procedure `de_parts_set_parts_list_options` is called every time a Parts List Report is generated.

```c
// DE_PARTS_SET_PARTS_LIST_OPTIONS
// Routine: Configure the parts list report
// Methods: This procedure is called every time a Parts List Report
// is generated.

defun de_parts_set_parts_list_options ()
{
    de_parts_option_initialize (); /* Reset to system defaults */
    /* Null out the exclusion and inclusion lists */
    de_parts_option_set_hierarchical (TRUE); /* Hierarchical report */
    de_parts_option_set_center_placement (TRUE); /* X,Y location at center */
    de_parts_option_check_bom (FALSE); /* Do not check BOM flag */
    /* Do not include simulation models */
    de_parts_option_add_exclusion_items (DePartsLumpedWithArtworkElements);
    de_parts_option_add_exclusion_items (DePartsMicrostripElements);
    de_parts_option_add_exclusion_items (DePartsPCBoardElements);
    de_parts_option_add_exclusion_items (DePartsStriplineElements);
    de_parts_option_add_exclusion_items (DePartsSuspSubElements);
    de_parts_option_add_exclusion_items (DePartsCoplanarElements);
    de_parts_option_add_exclusion_items (DePartsMultilayerElements);
    de_parts_option_add_exclusion_items (DePartsBlockTextFontsElements);
    de_parts_option_set_delimeter (NULL); /* Align columns */
    de_parts_option_include_header (TRUE); /* Include header */
    de_parts_option_sort_by_component (TRUE); /* Sort by component name */
}
```

Reformatting the Reports

You can omit and reorder the columns in a Parts List or Pick and Place Report using AEL. Contact technical support if you wish to get a copy of the report formatting AEL script.
Setting Layout Options

**Check BOM Flag**

Command: `de_parts_option_check_bom` (TRUE|FALSE);

- **TRUE**   Only include instances with attribute INST_SPECIAL set as ITEM_BOM_ITEM
- **FALSE**  Do not test for ITEM_BOM_ITEM (default)

**Exclusion List**

Command: `de_parts_option_add_exclusion_items` (list("MLIN"));

Items in the list will not appear in the parts list.

This list is useful if parts have not been consistently flagged as BOM items. For this case, you wish to include everything except items in the exclusion list.

In order to include everything, do not check the BOM flag.

For example:

```
de_parts_option_check_bom (FALSE);
de_parts_option_add_exclusion_items (DePartsLumpedWithArtworkElements);
```

**Inclusion List**

Command: `de_parts_option_add_inclusion_items` (list("res_smt"));

Items in the list will appear in the parts list.

This list is useful if parts have not been consistently flagged as BOM items. For this case, specify to include only items flagged as BOM items, and add additional items in the inclusion list.

Inclusion items are treated as leaf-level parts and do not get flattened. For example, if an inclusion item is a hierarchical part, its sub-elements will not be included in the parts list.

For example:

```
de_parts_option_check_bom (TRUE);
de_parts_option_add_inclusion_items (list("res_smt"));
```
Hierarchical Reporting

Command: `de_parts_option_set_hierarchical (TRUE | FALSE);`

**TRUE**   Produce a parts list containing instances from all levels of the hierarchy. (default)

**FALSE**  Produces a parts list containing instances from only the top level of hierarchy.

**Enhancements:**
- Placement coordinates are in world space
- Arbitrary angles are supported
- Reference IDs are unique
- IDs contain the hierarchical path to the instance

Component Placement X,Y Coordinates

Command: `de_parts_option_set_center_placement (TRUE | FALSE);`

**TRUE**   Coordinates represent the center point of the instance bounding box. The bounding box does not include the annotation text. (default)

**FALSE**  Coordinates represent the location of pin one.

**Enhancement:**
- x,y placement coordinates can be either the center of the instance bounding box or the location of pin one

Component Placement X,Y Offset coordinates

Command: `de_parts_option_set_package_offset (packageAttributeName, packageName, xOffset, yOffset);`

For example:

`de_parts_option_set_package_offset ("Package", "P1", 15, 0);`

For each instance which has a user attribute named "Package", with attribute value "P1", the placement coordinate will be the origin offset by xOffset, yOffset.

**Enhancement:**
Setting Layout Options

- The x,y placement coordinate for an asymmetrical instance is not the center of the instance bounding box, but rather a fixed offset from the origin. The offset can be incorporated in the report.

User Attribute Columns

Command: `de_parts_option_set_attribute_columns (list ("INST_SPECIAL", "PART_NUM", "Price"));`

Attributes in the list will appear as columns in the parts list. The attributes can be user properties, user parameters, or instance attributes. The following instance attributes can appear in the report:

- INST_TYPE
- INST_SPECIAL
- INST_NAME
- INST_DESIGN_NAME
- INST_SYMBOL_NAME
- INST_BBOX
- INST_PROPERTY

Delimiter Character

Command: `de_parts_option_set_delimeter (delimiter);` where delimiter is used to separate column data (i.e. " ", ",") Default is NULL.

If a NULL delimiter is specified, column widths will be determined by the longest data field and all data will be left justified.

For example:

/* Separate columns with commas */
de_parts_option_set_delimeter (",");

For example:

/* Auto-format */
de_parts_option_set_delimeter (NULL);
Include Header

Command: `de_parts_option_include_header` (TRUE | FALSE); TRUE = Output header information (default)
FALSE = Output part data only

**Enhancement:**
- User can specify whether to include the header information in the report. A report containing only part data will be easier to parse.

Sort by Component Name

Command: `de_parts_option_sort_by_component` (TRUE | FALSE);
TRUE = Sort the parts list by the component name (default)
FALSE = Parts are listed as they appear in the database

**Enhancement:**
- Default behavior is to sort the report by component name
- Parts previously appeared in the order they where found in the database. Simple edits could cause the parts to be listed in a different order.
Setting Layout Options
Chapter 3: Creating a Layout

Whether you create a layout directly as a layout, generate it from an existing schematic, or create it simultaneously as you create a schematic, there are only three basic steps to the process:

- Set up the layout environment. Customize the environment for the design you wish to create. How to edit layout defaults is described in Chapter 2, Setting Layout Options.
- Create the layout, as described in this chapter.
- Edit and complete the layout, as described in Chapter 6, Editing a Layout.

The Layout Environment

The following settings are especially important when you will be drawing shapes in the Layout window, but you should familiarize yourself with these setup features even if you will be generating your layout from a schematic.

- Set snap and grid spacing (see “Changing Grid and Snap Settings” on page 2-15). By making the grid visible, then drawing in snap mode, you can draw shapes with exact size and spacing.
- Set up your layer definitions (see “Defining Layers” on page 2-1)
- Specify the drawing layer (see “Changing the Entry Layer” on page 2-6). All shapes are entered on layers. The color and visibility of any shape is controlled by the layer on which it is drawn. Before you begin drawing, specify the current entry layer according to the intended purpose.
Creating a Layout Manually

When you create a layout directly, you place components or shapes in the Layout window. You can select components from either the palette or the library list. You can draw shapes with the cursor or by designating coordinates.

To Insert a Shape or Polyline:
  1. Select an icon (or Insert command).
  2. Follow the instructions in the lower, left corner of the window.

To Insert a Component from the Palette or Library List:
  1. Select the desired component.
  2. Drag to the desired location in the Layout window.
  3. Click to place the component in the desired location.

Inserting Components

You can insert components using any of the following methods:

- A component palette
- The component library
- Typing a component name in the Component History field (then press Enter)
- Creating a hot key for it

For details on these methods of placing components, refer to the User’s Guide.

Using Construction Lines

Construction lines can help you align parts, shapes, and text. The lines are infinitely long, so you can place components in one area, scroll the view of the window, and know that you are lining up objects correctly.

To add a construction line:
  2. Click any two points along the line you want drawn.
Placing Components by Defining Coordinates

Use the following steps to place a component at specific coordinates:

1. Select a component.
2. Choose the menu command Insert > Coordinate Entry.
3. In the Coordinate Entry dialog box, enter a value for X and a value for Y.
4. Click Apply. The component is placed in the Layout window, with pin 1 at the specified coordinates.

Hint  By default, the X and Y Increment fields are set to the current snap spacing, but you can use any increment that meets your design needs.

Identifying Unconnected and Connected Pins

When you place a component in the Layout window, note that each pin is outlined, and that when you connect two pins, the outline disappears. As described in Chapter 2, Setting Layout Options, you can modify the highlight color of pins (see “Setting the Color of Unconnected Pins” on page 2-29) as well as the color of connections (see “Setting the Color of Pin & Tee Connections” on page 2-23).
Creating a Layout

**Drawing Shapes**

In the Layout window, you can use the following geometric forms when creating layout shapes:

- Polygons
- Polylines
- Rectangles
- Circles
- Text
- Paths
- Dimension Lines
- Arrows

Shapes can be stretched and merged, and you can move or delete their vertex points. The Insert menu contains commands that enable you to draw a variety of shapes and lines. Many of the Insert menu commands are also found as icons on the toolbar.

---

**Note**  
Selecting the cursor on the toolbar during execution of any Insert command terminates the command and removes the incomplete shape.

---

To draw a shape:

1. Either click the shape icon on the toolbar, or choose **Insert** > `<desired_shape>`.
2. Follow the tips shown in the status panel.
3. Click to place the shape.

**Drawing a Polygon:** Enter line segments, and double-click to automatically create the closing segment.

- *Including an Arc in a Polygon*  
  Any time during the creation of the polygon, choose **Insert** > *Arc* `<desired direction>`.

- *Erasing a Newly Drawn Segment or Arc*  
  To backtrack to the previous point choose **Insert** > *Undo Vertex*.

**Drawing a Polyline:** Enter line segments, and double-click to end the final segment.
• Including an Arc in a Polyline  Any time during the creation of a polyline, choose either Insert > Arc (<desired direction>).

• Erasing a Newly Drawn Segment or Arc  To backtrack to the previous point, choose Insert > Undo Vertex.

**Drawing a Rectangle:** Enter two corners.

**Drawing a Circle:** Enter the center point, then a point on the perimeter.

**Drawing a Dimension Line:** Enter the end points.

**Drawing an Arc:** Enter the point where the arc begins, the center of the arc, and the point where the arc ends. You can draw an arc clockwise or counter-clockwise.

![Diagram of an arc with start point, center point, and end point labeled]

**Note**  Only closed shapes (polygons, circles, rectangles) can be displayed filled; shapes created with polylines (such as arcs) cannot.

---

**Undoing a Vertex**

To remove the last arc or vertex entered while creating a polygon, polyline, wire, trace, or path, choose the menu command Insert > Undo Vertex.

**Drawing Shapes by Entering Coordinates**

Just as you can place a component by specifying coordinates (see “Placing Components by Defining Coordinates” on page 3-3), you can draw a shape by specifying the coordinates required for that shape.

1. Select the desired drawing command.

2. Choose the menu command Insert > Coordinate Entry.

3. In the Coordinate Entry dialog box, specify the desired X and Y coordinates for the anchor point and press Enter (or click Apply).

4. Continue specifying all points required for the selected shape.
Creating a Layout

By default, the X and Y Increment fields are set to the current snap spacing, but you can use any increment that meets your design needs. A simple example showing the coordinates used to draw a square, starting at 0,0, is shown at right.

```
(0,0) (2,0)
(0,2) (2,2)
```

Working with Traces

Traces are wires with width and a bend type, and are used to represent physical transmission lines. Like wires, they can be used to connect components. For simulation purposes, there is no difference between a trace connection and a wire connection. Traces are normally simulated as simple connections (shorts). However they can be converted to or simulated as transmission lines, to allow for more accurate simulation. You can:

- Explicitly convert them to transmission lines (Edit > Path/Trace/Wire > Convert Traces). In this case, the selected traces are actually removed and replaced by an equivalent transmission line component in the layout itself. For details, refer to “Explicitly Converting Traces to Transmission Lines” on page 3-9.

- Simulate them as transmission lines without actually converting them. In this case, the traces are not replaced, but an underlying subnetwork is created for each one, and that subnetwork contains the equivalent transmission line. The subnetwork creation occurs during the Design Synchronization process (Generate/Update). For details, refer to “Simulating Traces as Transmission Lines” on page 3-11.
Trace Routing

Once components are placed, they can be interconnected. Parts can be connected either by abutting their pins or by drawing a wire or trace between them. If pins are abutted, moving the parts does not disconnect the pins. Instead, a wire is drawn between them. Wires and traces are stored in the same way in the program. Wires are traces with a zero width. Thus, wires can be converted to traces and back again by changing their width (Edit > Path/Trace/Wire > Edit Path/Trace/Wire).

Traces can be entered on any layer, though by default, traces that you want to simulate should be placed on specific layers. For traces that will be simulated as microstrip or stripline, the trace should be entered on layer 1 (cond); for traces that will be simulated as PCB transmission line components, you should use layers 16-25 (pcbl1-9). To change the current entry layer before inserting a trace, use Insert > Entry Layer and select the appropriate layer.

You can extend a path using the Edit > Point > Add (Vertex) command, or create another path abutting exactly to the end of the existing path and use the Edit > Modify > Join command to create a single path. The path can then be converted back to a trace if both ends of the path are exactly abutting to connecting pins. You can use the Snap to Pin mode in the Grid dialog box to make sure the end points are exactly coincident with the pins.

When moving parts connected with traces, the traces will be re-routed. By default, in layout, traces and wires will be re-routed from their end-points to maintain connectivity. You can have the whole connection re-routed using the Re-route entire trace attached to moved component preference set through Options > Entry/Edit. Traces and wires are re-routed to remain orthogonal with the fewest corner jogs introduced. To check for overlapping components, use the option by that name under Options > Check Representation.
Creating a Layout

Inserting Traces

Traces have the same restriction as wires do in schematic: they cannot form a short (connect back on themselves). Also, each trace has a uniform width and corner type (curved, mitered, square). To introduce a step, taper, or gap you must add a step, taper, or gap component, and connect the trace to it. Some limitations of using traces can be overcome by converting traces to paths. Refer to “Working with Paths” on page 3-14.

Note If a trace contains a bend, the shortest segment that is part of that vertex cannot be shorter than $3 \times \frac{w}{4}$ where $w$ is the width of the trace.

To insert a trace:

1. Choose Insert > Trace.
2. In the dialog box that appears, set the trace characteristics as desired.
   - Corner Type—Select from Mitered, Square, Curve
   - Width—The desired width for the trace
   - Mitered Corner Cutoff Ratio (%)—The desired cutoff ratio for the corner type Mitered
   - Curve Radius—The desired curve radius for the corner type Curve

Hint If you make changes to the current attribute settings, and want to return to the settings as they were when you brought up the dialog box, you can click Reset, if you have not yet clicked Apply.
3. Click **Apply** to insert a trace using the current settings.

4. Move the pointer into the Layout window and click to specify the first endpoint of the trace.

5. Move the pointer to the desired endpoint (or vertex) for this segment. Notice that the Trace dialog box Line Length region is dynamically updated as you move the pointer so that you can easily make the trace the exact length you want it.

   ![Line Length](image)

   Click to specify the endpoint (or vertex) for this segment.

6. Continue in this manner until the trace is complete, and signify the final endpoint by double-clicking or pressing the Spacebar.

**Explicitly Converting Traces to Transmission Lines**

You can explicitly convert traces to transmission lines for more accurate simulation results.

**Important** When you explicitly convert a trace to a transmission line, it is a one-way conversion; you cannot change a transmission line back into a trace.

To explicitly convert traces to transmission lines:

1. Select the traces you want to convert.

   **Hint** To select all transmission lines on a given layer, make that layer the current entry layer and choose Select > Select All On Layer.

2. Select Edit > Path/Trace/Wire > Convert Traces.
3. In the *Trace Control* dialog box, select the type to convert trace to:
   - Transmission line elements
   - Single transmission line element—With this choice, you must also provide the name for that element. A default is provided, based on the selected Element Set.
   - Nodal connection (short)

4. Select the desired Element Set.

5. Provide the appropriate Substrate Reference. The asterisk (*) indicates the default Instance Name of the first instance of this type placed in your design.

6. Click OK.

The following illustration shows traces converted to microstrip with square corners. The parameters for each element are derived from the physical dimensions of the trace segments.
Simulating Traces as Transmission Lines

This method allows you to include transmission line effects in simulation, without cluttering your schematic or layout with numerous transmission line components.

During the design synchronization process, a subnetwork is created for each trace. This subnetwork is a transmission line equivalent based on the selected Element Set in the Trace Control dialog box (accessed through the Generate/Update dialog box, available from the Schematic and Layout menus). When simulating, the transmission line subnetworks are passed to the simulator for analysis.

Once you run through the design synchronization process, you will find you can use the View > Push Into Hierarchy command to view (in either the Schematic or Layout window) the actual transmission line equivalent generated by the design synchronization process. If you are working from the layout and you modify the traces, you must run the design synchronization process again for the subnetworks to be updated. Tee components are automatically created and accounted for.

The following illustration shows the MLIN subnetwork that is created during the design synchronization process, from a single trace and two ports (ports are required).
Creating a Layout

For details on the design synchronization process, refer to Chapter 4, Design Synchronization.

Inserting Meander Traces

Meander traces enable you to quickly insert traces with specific characteristics including length, spacing, and orientation.

- Corner Type—Select from Mitered, Square, Curve (see “Working with Traces” on page 3-6 for illustration of corner types)
- Starting Direction—The direction (clockwise or counterclockwise) in which the first two segments connected to the starting lead are drawn
• Ending Direction—The direction (clockwise or counterclockwise) in which the last two segments connected to the ending lead are drawn.

• Width—The desired width for the trace

• Minimum Spacing—The minimum spacing between the parallel trace segments

• Line Length—The total length of the trace, including the lead length segments

• Mitered Corner Cutoff Ratio (%)—The desired cutoff ratio for the corner type Mitered

• Curve Radius—The desired curve radius for the corner type Curve

• Lead Length—The length of the starting and ending segments

• Meander Line Orientation—Select Vertical if you want the trace to meander vertically between the specified starting and ending leads; select Horizontal if you want the trace to meander horizontally between the specified starting and ending leads.

To insert a meander trace:

1. Choose Insert > Meander Trace. In the dialog box that appears, set the options as desired and click Apply.

2. Move the pointer into the drawing area and click to specify the endpoint of the starting lead.

3. Move the pointer as needed in both the direction of X and Y until you see the ghost image of the meander trace.

4. Adjust as needed and click to specify the endpoint of the ending lead.
Creating a Layout

**Working with Paths**

Paths are polylines with width. Paths have no connectivity information associated with them, but can start and end at any point and can be converted to traces.

![Diagram of a path with corners and distances](image)

**Note**  If a trace or path contains a bend, the shortest segment that is part of that vertex cannot be shorter than $3 \times \frac{w}{4}$ where $w$ is the width of the trace.

Note that paths are different from traces in that they have no connectivity information associated with them; however, when you are through adding to and editing a layout, you can convert the paths to traces. The traces will then provide the necessary connectivity information to perform design generation and update.

To draw a path between two points:

1. Choose **Insert > Path**. The Path dialog box appears.
2. Specify a corner type and width.
   - Corner Type lists the available options for corner types.
   - Width sets the width of the path, with respect to the current design unit.
3. Set the path attributes and click Apply.
4. Position the pointer at the start point and click.
5. Position the pointer at the end point and click. A path is drawn between the specified points.

To make certain the corner of a curved path is exactly where you want it, try one of the following methods:
• Draw a square path and then use the command
  `Edit Path/Trace/Wire > Edit Path/Trace/Wire` to change it to a curved path.

• Specify the vertices observing the coordinate readouts in the status panel and
draw as though you were drawing a square path.
Creating a Layout

**Working with Wires**

You can use a temporary wire to create an electrical connection between layout components. Wires make it easy to move components within a layout without breaking connectivity. Wires also make it easy to simulate the performance of a circuit before you insert the lines that will actually be used. The simulator treats wires as short circuits (as though the connected components are physically touching). Later you can connect components directly, or replace the wires with traces and repeat the simulation to verify circuit performance.

At times, unintentional gaps can be generated in a layout. When this happens, a wire appears to indicate an electrical connection between elements that are not abutting. Note that moving artwork can introduce new wires (disconnect components). You can often adjust the layout parameters to close gaps, or introduce new elements, rather than manually moving objects.

### Inserting Wires

When you draw wires, they must start and end at either a pin or another wire.

1. Choose **Insert > Wire**.
2. Click on the pin (or wire) at one end.
3. Click on the pin (or wire) at the other end. A wire is drawn between the specified points.
Inserting Text

You can add text to a design using either the Text command from the Insert menu or the Text icon on the toolbar.

1. Choose **Insert > Text**. The status panel prompt displays the following message: *New Text: Enter location for new text*

2. Click the pointer at the desired location and begin typing.
   - You can use the arrow keys, the backspace and delete keys to make changes; you can also drag across text to highlight it, then re-type or delete it.
   - To continue the text on the next line, press Enter and continue typing.

3. When you are through with this text, move the pointer away from the text and click.
   - To type text in another location, click in that location and begin typing.

4. When you are through adding text, choose **Insert > End Command** or click the cursor on the toolbar.

---

### Notes

To establish default attributes for new text, choose **Options > Preferences > Text**.

To edit existing text and text attributes, choose **Edit > Edit Text**.

---

### Layout Block Text Fonts

When creating physical designs for output to a production process, you can provide text that displays on the produced parts. Often this means that the text must be composed of primitives shapes that have thickness to them, not a simple stroke font.

![Text](image)

The Advanced Design System has a palette of polygon-based text fonts, called Block Text Fonts, to satisfy this need.
Creating a Layout

The program supports a total of 14 fonts. The first eight are the same as the fonts that were supplied in the Microwave Development System (MDS). The supported fonts are:

- **din17** - An industrial standard font.
- **iso3098** - Another industrial standard font.
- **roman** - A font similar to the Times Roman font.
- **smooth** - A font with the characters more round and smooth.
- **italic** - An italic font.
- **standard** - The original font supplied in MDS.
- **gothic** - A font that's more for fun than practical use.
- **math** - A font of special math characters.
- **sans** - A basic sans serif style font.
- **sansbold** - A bolder version of sans.
- **filled** - A font with no holes in the characters.
- **filledbold** - A bolder version of filled.
- **straight** - A font with no curves.
- **straightfilled** - A filled (no holes) version of straight.

These are not simple stroke fonts that are put through a translation process, but are actually implemented as polygon definitions for each letter in the font. The fonts are implemented as components (built using the Graphical Cell Compiler) and, therefore, have a wide range of attributes available in the component edit dialog.
The attributes are:

**Text String**—The actual text string to be displayed. The text string should not be enclosed in quotes ("”) but may contain quotes that display in the placed component. The text can have multiple lines with the characters backslash-n (\n) representing a new line. The parameter can be a reference using the "@" prefix, so you can specify a variable name. The contents of the variable is the text string displayed (see “Example” on page 3-21).

**Character Height**—The height of the characters. This is actually the height of the standard character size for the specific font. Lower-case characters are not as large and characters with descenders (for example: g, j, p, q, and y) extend below the standard size.

**Character Spacing**—A multiplier for the horizontal space used for the standard character size. When set to 1.0, large characters like W or M can touch. If set to a value smaller than 1.0, characters can overlap.

**Line Spacing**—A multiplier for the space vertical space used for the standard character size. The default value of 1.2 leaves enough room between lines so that characters with descenders do not overlap the characters of the next line.
Creating a Layout

**Insertion Layer**—The numeric layer ID where the polygons for the text string are placed.

The polygon definitions for each font are not loaded unless a font component is being inserted or edited, so that startup speed or memory usage is not impacted. When a font is used for the first time in a session, a small dialog informs you that the font is being loaded. When the loading is complete, the dialog closes.

![Wait for font2](image)

After a font is loaded, you do not need to load it again for the duration of the current session of ADS. In addition, you do not need to load the font to view a previously-inserted text component since the component is simply a set of polygons. You only need to load the font if you edit the component (causing it to be re-created) or if you insert a new text component in that font.

After you insert a text component, you can modify all component attributes using *Edit / Component / Edit Component Parameters*. You can edit the text string, change any of the physical-size attributes, or change the layer the component is inserted on—you can adjust the text easily so it can fit within any physical constraints in the design.

If you need to change the font on a text component, you can use *Edit / Component / Swap Components*. Since the component name is the font name, changing the component name to a different font causes the component to be re-created in that new font.

**Note**  For detailed font definitions, see Chapter 12, Font Definitions.
Example

This example shows how a block font text component can reference a schematic variable and display its contents.

First, open a Schematic window and place a Var component. Then edit the component and add a name/value pair to be used in Layout.

Next, open a Layout window. Confirm that the Layout window is for the same design as the Schematic window. Select a font to insert. In the text field use the "@" syntax to specify the variable name defined in the Schematic in the Var component.

Insert the component and notice that the contents of the variable, not the variable name, is displayed.
Creating a Layout from a Schematic

You can ensure that a schematic and layout are equivalent by using the design synchronization process (Generate/Update) whether you are creating a schematic from a layout, or a layout from a schematic. When you do either, the program examines each element in the source representation and modifies or creates an equivalent element in the target representation.

- For details on automatically generating a layout or schematic, refer to Chapter 4, Design Synchronization.
- For details on creating the two representations simultaneously, refer to the section, “Creating a Layout as You Create a Schematic” on page 3-22.

Creating a Layout as You Create a Schematic

Creating a layout as you create a schematic is similar to creating a layout from a finished schematic, except that you place components simultaneously in both the source and target representations.

1. From either window, choose **Options > Preferences > Placement**.
2. Enable either **Dual Representation** or **Always Design Synchronize**.
   - **Dual Representation** enables you to place equivalent components in the other representation quickly, because the component is already selected in the second window.
   - **Always Design Synchronize** causes the program to fully synchronize both representations after each part is placed.

Common Potential Problems

There are several design aspects that can be problematic if you are not aware of how to handle them:

- Junctions (refer to “Using TEE Junctions in a Schematic” on page 4-8)
- Steps and tapers (“Using Steps and Tapers in a Schematic” on page 4-9)
- Flipping versus rotation
Flipping versus Rotating Components

Flipping and rotating components in the schematic window may appear to have the same effect, but they are actually handled differently during layout generation. If a component was flipped in the schematic window, it will be flipped in the layout. However, if a component is rotated in the schematic window, the rotation is not carried through to the layout.

Hierarchical Layouts

Hierarchy is the relationship between different parts of a layout. A layout with hierarchy contains one or more artwork elements that exist in separate design files. You can create a hierarchical design by placing an existing design within the current design. This creates an instance or reference to the design.

In the program, the term *component* is often used interchangeably with *instance*. In this case, instance refers something that is referenced by another layout. Creating an instance is different than copying the contents of one layout into another layout. Creating an instance does *not* copy any data; instead, a *reference* to the desired layout is created.

There is no limit to the level of hierarchy that can be created. Designs can reference designs that, in turn, reference other designs. Parameters can be passed to all levels of hierarchy. The only limitation is that a design cannot reference itself at *any* level of the hierarchy (for example, design A referencing design B that, in turn, references design A).

Advantages of a Hierarchical Design

The primary advantage to creating a hierarchical design is that it saves you time. You can use one layout in many places. Making a change in the referenced layout is automatically reflected in all layouts that use that instance. In Layout you can build up libraries of reusable designs that can be referenced by any project.
Creating a Layout

Schematic Considerations

If you want to simulate a design containing a layout, there must be a schematic. In general, the hierarchies of the schematic and layout should match. That is, if there is a subnetwork in the schematic, there should be a corresponding subnetwork in the layout.

Although the system can create the hierarchy of one representation automatically from the other, it is flexible in how it generates and updates schematic and layout. You can, when creating a subnetwork, specify any design or AEL macro as its layout equivalent (File > Design Parameters). For details on selecting the appropriate artwork, refer to Chapter 7, Artwork.

It does not matter whether you select the File > Design Parameters command from the Schematic or Layout window, they both write descriptions to the same file when you save the design.

Parametric Subnetworks

Unlike most CAD systems, instances can be modified on a per-instance basis; each instance of a referenced design does not have to be identical. You can add parameters to a schematic component that modify one or more of its attributes, so that when you use that schematic in another design, you can define the parameters as required. This type of design is called a parameterized design. For example, you can create a schematic with a parameter that modifies the length of a microstrip line; when the design is placed in another design, you can define that parameter as any length.

When you generate the layout, the artwork elements reflect the parameters you defined. See online help for details on creating parametric subnetworks.
Creating a Hierarchical Layout

Creating Hierarchy Using Design Generation

1. Create a first-level design in the Schematic (or Layout) window.

2. Use the **Generate/Update** command from the Layout (or Schematic) menu so that you have both representations available.

The following schematic and layout examples are called *lpf*. The *mlength* parameter was created using the File > Design/Parameters command, which creates a parameterized design.
Creating a Layout

3. Save the design.
4. Create the top-level design by choosing **File > New Design**.
5. Click the **Library** button. From the Subnetworks library, select the newly created design file, *lpf*.
6. As you move the pointer into the Schematic window, a ghost image of the design moves with it to aid you in positioning. Click to position the design.
7. Complete your top-level design.
8. Save your design.

The following examples show *lpf*, placed twice. The top-level design is called *lpf2*.

---

Creating Hierarchy Manually

1. Create a design, in the Layout window, that you want to reference in your top-level design.
2. Add ports if the layout is to be used with a schematic design for simulation.
3. Create the top-level design by choosing **File > New Design**.
4. Click the **Library** button. From the Subnetworks library, select the newly created design.
5. As you move the pointer into the Schematic window, a ghost image of the design moves with it to aid you in positioning. Click to position the design.
6. Complete your top-level design.
7. Save your design.

**Viewing Hierarchical Design Information**

You can view or print a list of the hierarchy levels of your design. Hierarchy levels are indicated by the indentation of the list. Top level instances are not indented, each nested level is indented with one space.

1. Choose **Options > Hierarchy** and the Hierarchy dialog box appears.
2. To save the information to file, choose **Print**. The information is sent to the default printer.
3. Click OK to dismiss the Hierarchy dialog box.

![Hierarchy dialog box](image)

**Flattening Hierarchy**

When you are ready to generate final artwork, you might want to use the Flatten command to remove all levels of hierarchy. This process copies all data from the referenced design to the current representation. Repeat the Flatten command for each level of hierarchy you want to delete. When you finish this process, your design will be intact, but contain no references that could affect your final design.

1. Open your top level hierarchical design.
2. Select an instance, the instance becomes highlighted.
3. Choose **Edit > Component > Flatten**.
   
   This copies all data from the component to the current representation. Now you have two sets of component data.
4. Repeat this procedure for each instance you want to flatten.
Creating a Layout

5. Check that all hierarchy levels have been removed by choosing Options > Hierarchy. There should be no indented levels.

6. Save your design.

Breaking the Connection Between Layout and Schematic

The Flatten command works on components like MLIN. You can use it to break the connection between the layout and the schematic so that you can change a layer or edit the shape in the layout.

1. Select the microstrip(s).

2. Choose Edit > Component > Flatten.

3. Repeat this procedure for each instance you want to flatten.

Creating a Hierarchical Design for Repeated Use

The Create Hierarchy command copies selected artwork elements to another file, saves that new file, deletes the selected components in the original file and replaces them with a reference to the new design. In addition, you can parameterize the design in the newly created file, and use it as a subnetwork in any design.

Assigning a Symbol to a Subnetwork

To use a custom symbol to represent the design, you can do one of following:

- Create a symbol to represent only this particular design. This method requires drawing the symbol in the design file containing the design.

- Create a symbol that can be used to represent any design. This method requires drawing a symbol in a file that contains only the symbol.

Pushing Into or Popping Out of Hierarchy

In the Layout window, you can push into an component to view the actual artwork represented by the component.

1. Select the component.

2. Choose View > Push Into Hierarchy to display the network represented by the symbol.
3. When you are through viewing the network, choose **Pop Out of Hierarchy** to return to the component (or design containing the component).

Note that the **Pop Out of Hierarchy** command is the reverse of pushing and only works if a design has been pushed into.

**Libraries and Search Paths**

Many designs use a hierarchical approach. A top-level design is built from reusable, lower-level, subnetworks. Layout stores all networks in separate design files. The top level network is maintained in a separate file that *refers* to the lower-level, subnetwork files.

When a hierarchical design file is read in, each reference to a subnetwork is automatically read in as well. In most cases, all subnetworks are in the same directory as the top level design, but this is not required. Design files can be located anywhere in the file system. A library search path is used to locate referenced design files when any design is read into the program.

A library search path is a list of directories that the program uses when searching for a referenced design file. The directories in the list are examined in sequential order until the file is found. The networks, tests, and default directories of the current project are usually the first directories in the search path; system example and symbol directories usually follow. After the file is found, the search is terminated and the file is read in.

The library search path mechanism allows the construction of any number of reusable layout libraries that can be shared among different designs. Creating design libraries of tested and commonly used layout components can save a great deal of time, while ensuring reliable designs.

The environment variable **SIMULATOR_AEL** lists the AEL files the program should search for. When modifying this variable, add the names of your AEL files after the default filename. A related variable, **AEL_PATH**, defines the search path for these AEL files.

The directories listed in the path in the **AEL_PATH** variable are searched in order from left to right. The search is terminated as soon as a design is found.

If you create a library of reusable elements, you must add the directory containing the library to the search path.
Creating a Layout

**Modifying Search Paths & Environment Variables**

Search paths that control the order of directories searched and the files loaded by the program are defined by certain environment variables. For information on these variables, refer to the *Customization and Configuration* manual.
Chapter 4: Design Synchronization

Because schematic and layout information is contained in the same design file, we refer to the schematic representation and the layout representation of a design, and ADS can maintain equivalent representations of any design. You can make changes to one representation and then synchronize the other representation with it, ensuring they are equivalent. The representation you issue the synchronization command (Generate/Update) from is referred to as the source representation, and the representation that will be automatically modified to match the source representation is the target representation.

The Layout menu (in the Schematic window) contains a variety of commands that enable you to generate a layout from the schematic and to troubleshoot and modify your approach with respect to components that didn’t generate in the expected manner. An equivalent set of commands can be found on the Schematic menu (in the Layout window) for generating a schematic from a layout, because the synchronization process is bidirectional.

The synchronization process

When you synchronize two representations, the program examines each component in the source representation and modifies or creates an equivalent component in the target representation. The synchronization process can be fully automatic or incremental. If artwork exists for all schematic components, a layout of all connected components can be generated in one step. However, if any components do not have artwork associated with them (these will be represented by a generic artwork placeholder), or the layout has components that do not connect by abutment (typical in RF designs), the layout can be created incrementally. This is done by interactively placing components one at a time or a group at a time, then connecting them using traces. In addition, there is a dual placement mode that allows interconnected components to be automatically placed in the other representation during insertion mode.

Although this process is bidirectional, the first part of this chapter describes the process from the perspective of generating a layout from a schematic. Details related to using this process in the other direction are covered in the section, “Generating a Schematic (Layout-driven Design)” on page 4-23.
Design Synchronization

In general, your layout generation will be far more successful if you perform a prescribed series of checks prior to generating the layout:

- Identify schematic components without artwork and create/assign it
- Verify that schematic tee junction components are used where necessary
- Verify that schematic step or taper components are used where necessary
- Ensure schematic components are oriented correctly
- Identify three-way (or more) connections, which require special handling
- Identify components that may contribute to forming loops, which require special handling
- Establish preferences for: port/ground size, layer for generic artwork, wire extensions and component text, and the size and font for component text

Hint You can select an item in the Layout or Schematic window at any time and highlight its equivalent item in the other representation. Choose Layout (or Schematic) > Show Equivalent Component. Click an item. The corresponding item in the other representation is highlighted.
Working with Hierarchical Designs

When working with hierarchical designs, the best approach is to start with the subnetwork that represents the lowest level in the hierarchical design and go through the checklist just mentioned, then generate the layout for that particular subnetwork. Once you are satisfied with the results, move up to the next level in the hierarchy and repeat the process. When you are finished with all the subnetworks, repeat the process for the top-level design.

If any given subnetwork has one or more parameters that reference variables defined in another design, you must identify the top design in the hierarchy and the path from the top design back down through the hierarchy (via Instance Names) to the level where the variable value is declared.

To specify the location of the actual variable values, choose **Options > Variables**.

- **Top Design in Hierarchy**—Type the name (or use the browser) of the top-level design in the hierarchy the subnetwork is part of.

- **Representation**—Select *Layout* only when working with layout-only designs.

- **Component Path (Instance Names) to Variable Values**—Use the following guidelines to determine the appropriate path:

  - **Note** Each instance from one level of the hierarchy is concatenated to the one in the next level with the use of a period (.)

- If the variable is declared in a VAR item in the top design, leave this field blank.
- If the variable is declared in a VAR item further down the hierarchy, specify the Instance Name (appearing in the top design) that must be *pushed into* to find the design containing the VAR item or the next instance that must be *pushed into* to find the design containing the VAR item. Continue specifying instances as required for your design. (See Figure 4-1.) Alternatively, you can specify the actual design containing the VAR item in the *Top Design in Hierarchy* field and leave this field blank.
- To identify the actual values for a parametric subnetwork's (PSN) parameters, specify the instance path, starting with the top design, as described in the second bulleted statement. (See Figure 4-2.)
- To identify the actual values for a PSN's parameters when the design also references a value declared in a VAR item, identify the path to the VAR (as
Design Synchronization

described in the second bulleted statement) and then go to the design containing the instance of interest (desired parameter value) and generate from there. (See Figure 4-3.)

In Figure 4-1 the variable $Z$—in design $B$—must be resolved before artwork can be generated for it. Since the variable is defined in a VAR item in design $A$, and the instance of $A$ in the top design is $X3$, specify $X3$ in the component path field to force the program to look for the VAR in the design represented by $X3$.

Figure 4-1. Generating a layout for design $B$ with a VAR item in a design other than the top design
In Figure 4-2 the variable $C$—in design $B$—must be resolved before artwork can be generated for it. This variable is defined differently in four different instances of $B$, two in design $A$, and two in Top_level. To use the value defined in $X1$ or $X2$ of the top design, specify one of these instances in the component path. To use one of the values defined in $X1$ or $X2$ of design $A$, specify $X3$ (the instance representing design $A$) and then $X1$ or $X2$, as desired.

Figure 4-2. Generating a layout for design $B$ when the desired PSN instance is at any level of the hierarchy
In Figure 4-3 the variables $Z$ and $C$—in design $B$—must be resolved before artwork can be generated for it. The variable $Z$ can be resolved by specifying $X3$ in the Variables dialog box. But you must go to the higher level design containing the instance of interest and generate your layout from there. In this example, that could be either Top_level or $A$, depending on which instance of $B$ you want to use.

Figure 4-3. Generating a layout for design $B$ and resolving both VAR item variables and PSN variable parameters
Identifying Components Without Artwork

Before you generate the layout, you should check for any components without pre-defined artwork and either create it or associate an existing artwork with the component.

To identify components without artwork:

1. From the Schematic window, choose **Layout > Show Components With No Artwork**. All components that have no artwork associated with them are highlighted and a confirmation dialog box appears asking if you want to choose artwork for the highlighted items.

2. Click **Yes** and a dialog box appears displaying the Instance Name of one of the components without artwork and offering a choice of artwork types.
Design Synchronization

**Hint** To go back later and change the artwork association for a given component, select the component and choose *Edit > Component > Edit Component Artwork.*

3. Select the desired Artwork Type and Name and click **Apply**. The artwork association is made, the highlight on that instance disappears, and the Instance Name of another component needing artwork is presented.

4. Repeat this process until all artwork associations are made.

**Using TEE Junctions in a Schematic**

When multiple transmission lines form a tee junction, one of the *TEE* components is required.

If three layout components are joined without the use of a tee component, as in the incorrect diagram, they will be connected with wires in the generated schematic, and the length of these wires are based on the setting in the Preferences dialog accessed through the Generate/Update dialog box. The use of tee components is not only important for layout, but is also important for proper simulation of interconnected transmission lines.
Using Steps and Tapers in a Schematic

You must use step or taper components to introduce changes in transmission line widths. A common error in microstrip and stripline layout is to put two different width transmission lines together without a transition component, as shown in the illustration that follows.

To account for the discontinuity, you must insert either a taper or step component between the two components.

- Step components do not introduce additional length, but do ensure that the discontinuity is accounted for in simulation.
- Taper components do have length. They should be used to describe any gradual change in transmission line widths.

There are a number of other discontinuities that can be included in simulation such as gaps and end effects. For a list of components relevant to your design, refer to the Circuit Components manual.
Checking Schematic Component Orientation

The correct orientation of all schematic components is required to successfully generate a layout. Notice the difference in the resulting layout when the orientation of Taper2 (lower illustration) is incorrect.

Pin 1 is always identified by a small tick mark, but you can see all pin numbers by turning on Pin Numbers through Options > Preferences > Pin / Tee.
Identifying Connections Among Three or More Items

The generation of a layout works best if the initial generation proceeds along a route where only one-to-one connections exist. This means you need to decide on a main route and deactivate the components that are not on the main route. Once you generate a layout for the activated components, you can go back and interactively place the deactivated components.

**Hint**  It is a good practice to choose a route that leads to a port.

To select a main route for the initial layout generation:

1. Visually inspect the schematic looking for nodes that connect three or more components.
2. Click the Deactivate icon on the toolbar and click each component you want to deactivate.

After generating the layout for the activated components, you can activate all components and interactively place them one by one components by choosing **Layout > Place Components From Schem To Layout** (from the Schematic window). This procedure is described later in this chapter.
Identifying Components that Form Loops

The generation of a layout works best if the initial generation proceeds along a route where there are no loops. This means you need to decide on a main route and deactivate the components that contribute to forming loops off the main route. Once you generate a layout for the activated components, you can go back and interactively place the previously deactivated components manually.

To select a main route for the initial layout generation:

1. Visually inspect the schematic looking for components that form any kind of loop.
2. Click the **Deactivate** icon on the toolbar and click each component you want to deactivate.

After generating the layout for the activated components, you can activate all components and interactively place them one by one by choosing **Layout > Place Components From Schem To Layout** (from the Schematic window). This procedure is described later in this chapter.
Establishing Preferences

There are a number of miscellaneous settings you can control for the generation of a layout:

- The size for ports/grounds
- The layer on which generic artwork, wire extensions and component text should be drawn
- Component text font and size

To adjust these options for the design you are about to generate or update:

1. From the Schematic window, choose **Layout > Generate/Update Layout > Preferences**. (The remaining fields in this dialog box are described in the section, “Generating a Layout” on page 4-14.)

2. Change any or all options as desired and click **OK**.
Design Synchronization

Generating a Layout

After performing the preliminary checks, and taking the recommended action based on the results, you are ready to generate a layout. The transmission line shown next is used to illustrate the process.

To automatically generate a layout from a schematic:

1. Open a Layout window, and from the Schematic window choose **Layout > Generate/Update Layout**.
In this example, the Starting Component field shows P1 (port 1). This can be changed by clicking a different item in the Schematic window. The Equivalent Component field is empty, indicating that the equivalent has not yet been created (in the layout). In addition, all of the components in the schematic are highlighted, indicating that they all need to be generated.

**Hint** If choosing Generate/Update Layout causes an item to be highlighted, the highlighting indicates that the item needs to be generated, regenerated, or repositioned.

2. Click **OK** and the layout is generated, as shown in the initial illustration.

The details of the Generate/Update dialog box are as follows:

- **Starting Component**—The program starts with this item, moving through port/pin1 to the next connected component, until all interconnected components with artwork are generated or updated. Click an item in your design to designate it as the starting point for the design synchronization process.

- **Equivalent Component**—Informational only. The counterpart of the item in the other representation appears in this field (when one exists).

- **Status**—Informational only.
  - not created—The equivalent of the starting component has not yet been created in the target representation.
Design Synchronization

• positioned—The starting component has been positioned in the layout.

• X-Coordinate, Y-Coordinate, Angle—If you select a component in the Schematic, and the equivalent has been generated, these fields show the coordinates for the equivalent item, including angle. If the equivalent has not been generated, accept the default location (0,0) to allow the program to place it or type the desired coordinates. The angle of rotation in the source representation is displayed by default. Accept this or change it as needed.

The program generates a layout by creating artwork for each component in the schematic. If you start the process from a schematic, an artwork component is placed at the given X,Y location with the given angle. Each subsequent component is placed at an angle that is determined by the angle of the connecting component, plus the angle specified for that pin.

• In Example A above, the angle of M1 is 0, and the angle of its pin 2 (on the right) is 0, so M2 is placed to the right of M1 at 0 degrees.

• In Example B, for M3, pin 2 (on top) is at 90 degrees, so M4 is connected at 90 degrees.

• In Example C, M3 is placed at a 20 degree angle, so M4 is placed at 110 degrees (90 + 20).
For all artwork supplied in ADS, the angle of each pin is preset to generate a reasonable topology. However, it may be necessary to flip and rotate components to get a better layout; this will have no effect on your schematic.

- **Options**
  - *Delete equivalent components in Layout that have been deleted/deactivated in Schematic*—Turn this on to force the design synchronization process to automatically delete items in the target representation that do not appear in both representations. This forces one representation to match the current representation.
  - *Show status report*—Turn this on to have a status report appear after design synchronization. This report includes the number of items modified, how many items processed, and the name of any trace subnetworks created, if automatic trace conversion was specified.
  - *Fix starting component’s position in Layout*—When this option is turned on, the starting component’s position is set to fixed so that it will not be changed automatically during subsequent synchronizations (however, you can still manually move it).
  - *Preferences*—Allows access to a variety of settings to assist you in generating the desired schematic or layout.

**From Layout to Schematic**

- **Length in X-Direction**—The length of horizontal wires drawn between schematic components when their layout equivalents connect by abutment.
- **Length in Y-Direction**—The length of vertical wires drawn between schematic components when their layout equivalents connect by abutment.

**From Schematic to Layout**

- **Length in X-Direction**—The length in the direction of X that you want wire extensions drawn for three-way connections
- **Length in Y-Direction**—The length in the direction of Y that you want wire extensions drawn for three-way connections.
- **Generic Artwork Size**—The length of the box (with an X drawn through it) drawn in layout when there is no artwork associated with the schematic component
Design Synchronization

- **Port/Ground Size**—The size of the port/ground symbol (an arrow) drawn in the layout representation.
- **Entry Layer**—The entry layer on which generic artwork and wire extensions should be drawn.
- **Variables**—Used for identifying a design/instance that contains the actual values of variables being referenced by the subnetwork (for which you want to generate a layout), when the design containing those variables is either not related hierarchically, or is related hierarchically, but is found at a lower level (than the subnetwork) in the hierarchy. For more information, refer to the section, “Working with Hierarchical Designs” on page 4-3.
- **Trace Control**—Allows access to a dialog box for specifying details for interpreting traces in layout. For details on working with traces, refer to “Working with Traces” on page 3-6.
  - **Simulate As**—Select one of the following: Transmission line elements, Single transmission line element (then specify that element in the field provided, MLIN by default), Nodal connection (short).
  - **Element Set**—Select one of the following: Microstrip, Stripline, Printed circuit board.
  - **Substrate References**—The Instance Name of the substrate item to be referenced when simulating traces as transmission lines.

<table>
<thead>
<tr>
<th>Element Set</th>
<th>Substrate Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microstrip</td>
<td>MSUB</td>
</tr>
<tr>
<td>Stripline</td>
<td>SSUB</td>
</tr>
<tr>
<td>Printed circuit board</td>
<td>PCSUB</td>
</tr>
</tbody>
</table>

**Placing Unplaced Components**

Unplaced components are items that do not have counterparts in the other representation. When a component without artwork, such as a series capacitor, is encountered during the synchronization process, the synchronizer places a generic artwork box in its place. Once you create/assign artwork to these components, you can initiate the synchronization process again or you can individually place these remaining components one at a time, interactively, in the other representation.
• By selecting Layout > Generate/Update Layout again and using either the first unplaced item as the starting item, or selecting any other component that already exists in the layout. This mode automatically positions artwork by pin abutment.

• By using the Layout > Place Components From Schem To Layout command (this is the preferred method for RF designs). This mode allows any distance between artworks.

The Place Components From Schem To Layout command enables you to interactively place items from one representation to the other. It is important to note that placing items in this fashion is different from placing items from a library or palette; if an item is placed from a library or palette, no association is made with its equivalent item until design synchronization is run again.

To locate unplaced items:

Select Layout > Show Unplaced Components. The unplaced components are highlighted.

To place an unplaced component:

1. Select Layout > Place Components From Schem To Layout and click any of the highlighted components you want to place.

2. Move the pointer to the Layout window. A ghost image of the item, as well as wire guides identifying the connectivity point(s), tracks with the pointer. Position the item and click.

In the illustration that follows, one of dotted lines represents the wire guides that track with the artwork and the pointer.
Fixing and Freeing Component Positions

All items in the Schematic and Layout windows have either a fixed or free status associated with their position. If an item’s position is fixed (in the target representation), then it cannot be repositioned automatically by the program during the design synchronization process. If an item’s position is free, then the program may reposition that item. Understanding the basic behaviors involved will help you in manually creating designs, as well as generating one representation from another:

- Items manually placed in the Schematic window are fixed. If you make changes to the layout and update a schematic containing fixed items, the fixed items retain their positions but may be rewired to maintain connectivity.

- Items generated in the Schematic window during the design synchronization process are free. However, if you manually move an item in the schematic, the program automatically sees that item’s position as fixed and will not reposition it on subsequent synchronizations.

- Items placed in the Layout window, either manually or during the design synchronization process, are free and should remain that way. However, occasionally you may have critical sections or completed sections of your layout that you do not want repositioned by the program. In this case, you can explicitly set these items as fixed. Unlike moving items in the Schematic window, moving items in the Layout window does not change their free status.

- Items placed with the Place Components From ... command are fixed components and maintain the orientation angle of the source representation when you place them in the target representation.

- Items placed in either representation during the design synchronization process, maintain the orientation angle of the source representation if the item is fixed in the source representation.

The following commands (found on the Layout and Schematic menus) can help you identify and change the fixed versus free status of a component, relative to the window from which you issue the command:

- Show Fixed Components—Highlights all components whose status is fixed
- Fix Component Position—Prevents a component from being repositioned automatically by the design synchronization process
- Free Component Position—Allows a component to be repositioned automatically by the design synchronization process
Dual Representation Mode

When working from either schematic or layout, it is sometimes desirable to have items placed in both representations simultaneously. This is accomplished using the dual placement or synchronization modes found in Options > Preferences > Placement.

- **Single Representation (schematic OR layout)**
  When you place an item in one representation, nothing is placed automatically in the other representation.

- **Dual Representation (schematic AND layout)**
  When you place an item in one representation and move the pointer into the window for the other representation, the equivalent component is already selected. Position the pointer as desired and click to place it. (If a window for the other representation—containing the same design—is not open, one will be opened automatically.)

- **Always Design Synchronize (schematic AND layout)**
  Causes the program to fully synchronize both representations after each part is placed, ensuring all parts are fully interconnected. This takes more time than the Dual Representation mode and may move or rearrange the layout of the schematic to preserve connectivity.

---

**Note**  The second (*Dual*) and third (*Always*) modes are designed to work in insert mode (while placing components). If you need to edit as you insert components, these two modes are not recommended.
Design Synchronization

Viewing connectivity information

The Options > Check Representation command enables you to request the program to display information about any of the following characteristics of your design:

- **Open Connections**—Displays the total number of unconnected pins and wires. For each item with an unconnected pin, it lists the component name and ID, the pin number and the coordinates of the unconnected pin. For each wire with an open end, it displays the coordinates of the wire segment. The affected items are highlighted in the design window.

- **Nodal mismatches (layout vs schematic)**—Reports items that are connected differently in one representation than they are in the other. The report lists the name of the item, the pin that is connected differently and what the pin is connected to. The affected items are highlighted in the design window. Note, this option works on designs where the layout is composed of layout items that have schematic equivalents. It does not work on arbitrary geometry, nor does it do any device extraction.

- **Wires in layout**—Reports all items connected to pins that are interconnected with a wire, or a zero-width trace.

- **Overlaid components**—Reports the IDs of any overlapping items where the items contain the same number of pins and pin 1 of each item is placed in the same location.

- **Overlap wires/traces**—Highlights any wires or traces that overlap, that are not part of the same node.
Generating a Schematic (Layout-driven Design)

Generating a schematic from a layout involves steps similar to those used in generating a layout from a schematic. When you modify the layout, its modified parameter values can be back-annotated to the schematic in a similar fashion.

Layout items can be picked from a palette or library list and placed and interconnected in the Layout window. If a library of layout components has been created and associated with schematic and simulator items, they can be added to existing palettes or new custom palettes. For detailed information, refer to Chapter 5, Creating Elements.

To generate a schematic from layout:

1. Open a Layout window.

2. Create your layout design in the Layout window (by placing items from the library and palette) and interconnecting them by abutting their pins, as shown in the following example.
Design Synchronization

**Note** Before you can place an item (such as SLIN) in the Layout window that references a substrate item, you must place that substrate item in the Schematic window.

3. From the Layout window choose **Schematic > Generate/Update Schematic**. The dialog box appears, and all items in your layout are highlighted, indicating that they need to be generated, updated, or moved in the other representation.

4. Accept the default Starting Component (C1 in this example) or click a different item in your layout (the item you want the program to use as the starting point for generating your schematic).

5. Specify the location and angle of the equivalent item in the Schematic window, and click **OK**. The equivalent schematic appears in the Schematic window.

6. Click **Preferences** and specify the horizontal and vertical spacing that you want between the items in your schematic, then click **OK**.
RF PCB design considerations

Many RF PCB applications require an interactive approach to layout. Typically, a schematic is created and simulated before layout begins. The Design Environment supports creating layout at any time, before during or after a schematic is created. A large 90,000 part library is supplied; many parts are available with their packaged-part outlines and mounting footprints.

The layout tool contains a number of features specially designed to support PCB layout. These include:

- Large, comprehensive parts library
- Complete integration with system and circuit level simulation
- Interactive placement mode
- Automatic component parameter forward and back annotation
- Rat’s nest connectivity display
- Layout vs. schematic checking
- Trace routing and layered transmission line simulation
- Simplified library parts creation
- Configurable BOM, Parts Lists, pick and place output
- Optional Gerber, DXF, IGES output
- Optional integration with Mentor’s Board and Hybrid Station

Creating the Board, System Setup

A generic board outline can be created by placing the PCB board item. This will create a rectangular board outline, given the dimensions on the outline layer. The outline is marked as drawing format to prevent its unintentional selection when editing your layout. By default, the selection format for drawing formats is off. To enable editing of it, you must turn on the Drawing Format filter under Options > Select. The outline can then be selected and flattened to produce primitive geometry that can then be edited to create an exact board outline.

Once the board outline is created, the 0,0 origin of the board can be moved using the Edit > Modify > Set Origin command.
A number of layers have been pre-defined for PCB board layout. The silk-screen layers are defined to place text and other silk-screen information. The pcb1-9 layers are designators for trace routing using traces or the PCB transmission line components. Other layers can be used or defined as needed. There are no limits to the number of layers that can be defined, though the multi-layer PCB transmission line components have a limit of nine conductor layers.

Interactive Layout, Manual Layout

Components can be placed in layout at any point in the design. As in the schematic, parts can be placed in the layout by selecting them from a palette or library and positioning them on the board. Most of the standard SMT parts and other packaged parts are selected from library lists.

Parts can be moved to the bottom side of the board, or placed on the bottom by mirroring them. When creating a schematic for a PCB design, make sure every part has a layout equivalent. For ideal components, such as a CAP, RES, etc., use the Lumped-With Artwork version of these components to account for them in layout.

Parts can also be placed directly from the schematic. The advantage is that the schematic and layout can then be kept synchronized. It is important to note that if you place items in the schematic with the library or palette lists, and then place equivalents in the layout in the same manner, the two will not be synchronized. To keep the layout and schematic synchronized, you must either use the Generate/Update feature to automatically create one representation from the other, or use interactive placement to incrementally create one representation from the other.

Automatic design synchronization

A layout can be automatically created from an interconnected schematic using the design synchronization feature (Generate/Update). This command will take each component in the schematic and place it in the layout so that the interconnected pins abut. While this works very well for microwave designs that have every transmission line discontinuity accounted for in the schematic, it does not usually produce acceptable results for PCB layouts that have extensive interconnections using traces. It will, however, give you an initial placement of components that can then be moved into a correct position.
Interactive placement

Placing parts interactively from the schematic to the layout, or vice-versa is usually the most practical method of creating a PCB layout. The Place Components From Schem To Layout (or Layout to Schem) command is used to select a part in one representation and place it in the other.

The command prompts you to pick a component in the source representation and place it in the target. If initiated from the Schematic window, you are prompted to click a schematic component and then move the cursor into the Layout window. A ghosted image of the part can then be seen moving with the cursor. You can use the arrow buttons on the palette to rotate the part before placing it. Clicking the left mouse button places the part, with the same parameter values used in the schematic.

Wire guides are displayed that indicate where each component should be connected. These lines can be re-displayed with the Schematic > Show Connected Components command, which will draw a connection (rat's nest) depicting the interconnection of each unconnected pin using the source representation as the reference. Use Clear Highlighted Components to remove these lines.

The Schematic > Place Components From Schem To Layout (or Layout to Schem) command highlights all the components in the reference representation not yet placed in the target. Use the Clear Highlighted Components command to remove highlighting.

Fixing part placement and back annotation

When parts are placed in the layout, they are placed as free components. That is, if design synchronization is run, the part will be repositioned to abut at least one of its pins with an interconnected component. While this is the preferable method of synchronizing microwave designs, it is usually not the desirable method for PCB components.

If the parts were placed with the Place Components From Schem To Layout (or Layout to Schem) command they will be placed as fixed components. That is, they will not be repositioned when design synchronization is run. However, if they were placed in some other manner, they will be placed as free components and will need to be set to fixed. To check the status of the placed components in layout, select Schematic > Show Fixed Components. This will highlight each fixed component. For non-highlighted components, select these and use the Schematic > Fix Component Position to fix these components’ positions.
Design Synchronization

Once the components are placed, you can use the design synchronization feature of the program to maintain parameter changes in one representation with the other. Thus, if you change the value of a capacitor in layout, you can back-annotate this change by running design synchronization from the Layout window. Each component that is not yet placed or that has a changed value will be highlighted. Clicking OK or Apply in the dialog box will update the highlighted parts in the target representation.

Trace Routing

You can use traces (or wires) to parts when you do not want to connect them merely by abutment. For details on using traces, refer to “Working with Traces” on page 3-6.

Layout versus Schematic Nodal Mismatches

You can compare the layout and schematic any time during the design process using Options > Check Representation and selecting the Nodal mismatches (layout vs. schematic) option. This will generate a report that compares the connectivity of the target representation against the source. Missing components, or pins connected differently in one representation from the other are reported.

Note, this option works on designs where the layout is composed of layout items that have schematic equivalents. It does not work on arbitrary geometry, nor does it do any device extraction. For complex layouts that are disconnected in more than one area, running the command from both representations can help better pin-point the source of the mismatch. Using this command in conjunction with Layout > Show Unplaced Components, Show Equivalent Component, Show Connected Components commands can usually solve most discrepancy problems.

Trace Simulation

For many high-frequency PCB designs, transmission line effects become significant and need to be accounted for in simulation. In Layout, you can explicitly convert traces to transmission line components for simulation, or globally simulate traces as transmission lines without explicitly converting them. For details, refer to “Working with Traces” on page 3-6.
Generating a report

To generate a Bill of Materials (BOM) or Parts List with pick and place information, select **File > Reports**. These reports are created using the `de_bom` and `de_parts` AEL functions and can be customized. For details refer to “Pick and Place Report” on page 2-38.

Exporting the PCB layout

Most PCB layouts are manufactured via Gerber output. Gerber is supported via the optional MTOOLS Gerber translator. The design environment interfaces with the Gerber translator via mask files. A mask file can contain one or more layers. All design exporting is done through **File > Export** in the Layout window. For basic information, refer to Chapter 8, Importing and Exporting Layouts. For details, refer to the Importing and Exporting Designs manual.

Part and library creation

Though a large library of PCB discrete components is available, you may not find the components and their layout footprints you are looking for. But you can define new items in a number of ways. For details refer to Chapter 5, Creating Elements. Note, that a large number of layout objects are also available. For non-electrical items, these can be placed directly in the layout without concern for the schematic. For electrical items, you can create a new item that uses a pre-defined layout object for layout, or you can use an ideal component such as a CAP or S2P with a gap artwork equivalent. The gap can be specified to allow the layout object to then be inserted.
Design Synchronization
Chapter 5: Creating Elements

This chapter presents details for creating new items.

Creating New Items

There are two basic categories of items that can be placed in a design: items that can
be simulated and items that cannot be simulated. Simulated items, include all the
program-supplied items in the libraries and palettes and all user-defined networks.
Non-simulated items, are termed objects. Typical objects are alignment markers,
schematic sheet borders, mechanical fasteners, etc. Objects can be selected from
palettes and libraries like any other item, but are not included in simulation, nor are
they normally included in design synchronization between layout and schematic.

Simulation Items

Simulation items, as the name implies, are included in simulation. Each simulation
item has one of two types of simulation models associated with it: models represented
as schematics and built-in simulation models. Either type can be used when creating
a new item. Built-in models can be user-defined items, or any item for which the
simulator has an intrinsic representation. (For more information on creating
user-defined elements, refer to the Analog/RF User-Defined Models manual or
Chapter 13 of the Agilent Ptolemy Simulation manual.)

Creating a new item using a built-in simulation model can be used to assign artwork
to items with no default artwork assignment, such as lumped components or device
models. An example application would be to create a new item for a FET that is
modeled with an S-parameter file using the S2P item.

Creating a new item modeled with a schematic network allows a greater degree of
freedom. An example would be creating a network that models the parasitic effects of
the solder pads for a Surface Mount Technology (SMT) lumped component. The
ability to pass parameters into custom networks increases the flexibility of this
approach by allowing any network to be parameterized in the same manner as
built-in simulation models.
Defining a New Item

You can define any type of new item by selecting File > Design Parameters from the Schematic or Layout window. Filling in the fields of this dialog box creates a custom item definition.

The custom item definition is stored in an AEL file. This file is named <design>.ael, where design is the name of the open design file. This file contains a number of AEL function statements. These functions register the new item with the Design Environment. This registration includes which palettes and libraries the item should show up in, how the item will be simulated (if at all), what the item’s parameters are, the item’s artwork and other details. It is possible to view and edit this AEL file using a text editor (the syntax for these functions is defined in the AEL manual). However, the syntax is complex and using the dialog box eliminates many possible errors in defining a new item.

Once the item definition is complete, the item can then be placed and used in your designs in the same manner as those supplied by the program. By default, your custom items are assigned to the Subnetworks directory of the current project, but you can store it in a library of your own choosing by supply a new library name.

If you are creating an item with a schematic network model or an item using custom artwork, you should create the network or artwork before creating the new item definition. For items using a schematic network, the item definition is usually done with the completed schematic network open in the Schematic window. For any other type of item definition, the Schematic and Layout windows are usually empty. The artwork and models are in other design or AEL files and are referenced by name.
Defining Design Characteristics

While the default design characteristics may be acceptable in many cases, the Design Parameters dialog box allows you to alter the default characteristics of the network. You may wish to modify any or all of the following default characteristics found on the General tab.

**Name.** This field is informational only and displays the current design name.

**Description.** Provide any descriptive phrase for clarification. This description appears in the Component Parameters dialog box when placing the item or network.

**Component Instance Name.** The default is X, but the text in this field is used as a prefix in building a unique name (ID) for every item. This prefix becomes part of the annotation displayed with the symbol when you place it in a design.

**Symbol Name.** The filename you supply in this field specifies the symbol used when you place the item in a design. You can supply a symbol name in one of several ways:

- You can type the desired name here. If you type a filename, it must be the exact filename (minus the .dsn extension) of any file containing only a symbol.
- You can select a symbol from the list of symbols on the drop-down list. This list contains several common symbols available by default. You can add to this list the names of any symbols you have created by adding the filenames to the list through AEL. (For details on how to do this, refer to the section “Modifying the List of Available Symbol Names” in the Customization and Configuration manual.)
- Click More Symbols to bring up a dialog box that displays icons for all supplied symbols.

When you specify a symbol, make sure that it has the correct number of ports.

**Library Name.** By default this field contains an asterisk (*) and if you accept this default, your item will be stored in the Subnetworks directory of the current project. This name can be changed to any custom-defined library name.

**Allow only one instance.** This enables you to specify whether or not the item or network can be placed in a design more than once. The default is off, meaning the item or network is not unique and can appear more than once in a design. Change to on if you want to restrict placement to once per design.
Creating Elements

**Include in BOM.** Turn this on if you want the details of the subnetwork design to be included in a generated BOM. When this is turned off, only the top level design information is included.

**Layout Object.** Turn this on if the design you are defining is an object used with the Layout option. (Layout objects are not simulated or synchronized but typically contain items such as alignment markers.) This attribute controls whether or not they will show up in layout palettes and libraries or schematic palettes and libraries.

**Simulate From Layout (SimLay).** Analog/RF designs only. The netlist required for simulation is generated from either the Schematic or the Layout. Select this option to generate the netlist from the Layout.

**Simulation**

- **Model.** Enables you to assign a netlist choice:
  - Built-in Component—A built-in simulator item (such as CAP or RES)
  - Subnetwork—A schematic network you have defined
  - Not Simulated—Create layout or schematic only non-simulated items

- **Simulate As.** This field should contain the name of a built-in simulator item or the name of a schematic (usually the name of the current design). If the Simulation Model is set to Subnetwork, enter the design name; if it is set to Built-in Component, enter the name of a built-in simulator item or select one from the drop-down list. If you chose Not Simulated for the item, this field is unused.

**Artwork**

- **Type.** Allows you to assign an artwork type: Synchronized, Fixed, AEL Macro or None.

- **Name.** Allows you to assign a macro item or design item with the appropriate artwork name.

**Save AEL File.** Allows you to incrementally save definitions (which are contained in the .ael file). By turning this on and choosing OK, rather than waiting until you save the design file itself, the AEL definition for the new item is saved.

If the default design characteristics meet your needs, you may proceed directly to the section, “Defining Parameters” on page 5-7.
Creating a New Item Using a Built-in Simulator Model

To define the simulation model, first create a new empty design using File > New Design in the Schematic window. Define your design characteristics and add any parameters that need to be passed to your item (File > Design Parameters). Once the parameters are defined, save the item definition.

For the following topics discussed in this section, you will be using a simple capacitor CAP as the simulation model, with predefined artwork representing a chip capacitor footprint CHPCAP.

To define an item using a built-in model:

1. Create a new project or open an existing project.
2. Open a Schematic window and select File > New Design.
3. Give the file a name (in this example, mycap).
   
   **Note** You do not need to place anything in the Schematic or Layout windows for this example—the entire item definition is done through the Design Parameters dialog box.

5. Optionally, enter a new Item ID Prefix for your item, in this example, C.
6. Specify a Symbol Name using one of the methods described earlier. In this example, we are using the supplied capacitor symbol, SYM_C.
7. Enable the Layout Object option.
8. Specify an Artwork Type, for example Fixed.
   
   When you design a network, you need to determine what type of artwork should represent your network when it is placed in another network. For creating most elements, either Fixed or AEL Macro should be used. For details on using artwork, refer to Chapter 7, Artwork.
9. Specify a name in the Artwork Name field (for fixed artwork, enter the same name that appears in the Label field; for a macro, enter the name of the AEL function). For this example, select CHPCAP as the artwork for a chip capacitor.
10. Select the appropriate simulation model, as described earlier. In this example, use Built-in Component.
11. Specify how you want the item (or network) simulated. Select **C** for this example. Your dialog box should now look like the following example.

![Diagram of dialog box with selected option]

12. Click **Save AEL** to save this portion of the item definition, and continue to the next section, “Defining Parameters” on page 5-7.
Defining Parameters

Most new items you define need parameters. In this example, the parameters for the new item are the same as those for the Simulation Model, CAP, i.e., $C$ (capacitance). For items with AEL artwork, you may need to add additional parameters (at the beginning of the parameter list) for layout.

In this example, the first artwork, CHPCAP, has no additional parameters for layout, so you only need to define the parameter $C$ for this item. After selecting *Built-in Component* as the model type, you can click on the *Parameters* tab to define parameters.

**Hint** You can click *Copy Component's Parameters* and the set of parameters for the item named in the *Simulate As* field (in this example, CAP) is assigned automatically to your new item. In this example, this is the only step needed to define parameters, since there are no extra layout parameters.

For more complex definitions, each parameter has characteristics that determine how it is handled when the item is used. These include the name and label displayed in the Component Parameters dialog box, the unit type for the parameter, the type of value assigned to the parameter, the default value, and certain control attributes.

To define a parameter:

1. For this example, click *Copy Component's Parameters* then click the *Parameters* tab. The parameters for the supplied capacitor component are listed.

![Parameter Table](image)
Important For AEL generated artwork, entering your parameters in the correct order is critical. The order you specify in this dialog box must match the order given in the function. For example, in the AEL function for an MLIN, width comes before length. If you enter the length parameter first, it is still read by the function as width (ignoring the Name identifier).

Also, artwork parameters must precede those used for simulation, and must be marked Not Netlisted. For items with artwork, add any artwork parameters first, then use copy parameters or add the simulation parameters.

2. In this example, since we copied parameters of a supplied component, the Edit Parameter fields are filled in with defaults.
   - The Value Type is set to Real.
   - The Default Value is set to 1.0 pF. Note that this value serves only as a default. You can change the value each time you place the item subsequently.
   - The Parameter Type is set to Capacitance.
   - The Parameter Description (optional) reads Capacitance. (This is used only to document the meaning of the parameter.)

3. Enable or disable the following options, based on your design needs:
   - Display parameter on schematic—Select this option to display, on the schematic, the parameter being defined.
   - Optimizable—Select this option to allow this parameter to be optimized.
   - Allow Statistical Distribution—Select this option to allow post-production tuning for this parameter during yield analysis.
   - Not edited—Select this option to prevent this parameter from appearing in the Component Parameters dialog box for editing and always use the default value assigned here instead.
   - Not netlisted—Select this option to prevent a parameter from being considered in simulation, but still be recognized for artwork generation. (In general, layout-only parameters (not used for simulation) are assigned the Not Netlisted attribute.)
4. If defining new parameters (as opposed to copying the simple parameters for this example, you must click ADD to add each new parameter to the parameter list.

**Hint** You can assign attributes for each parameter as you define it, or you can define all parameters and then go back and assign attributes.

5. Save your design.

When the design file is saved, an AEL definition is created in the `/networks` directory of the current project. This file (along with the design file containing the schematic/layout) can then be moved to other directories for use as library parts, either for personal use or site-wide use. For details, refer to “Creating Custom Libraries” of the *Customization and Configuration* manual.

For details on adding items to a palette, see the `de_define_palette_group` function in the AEL manual.
Creating Elements
Chapter 6: Editing a Layout

As in other areas of the program, most edit commands enable you to select one or more components either before or after you select the edit command. The most commonly used editing commands, Copy, Delete, Move, Rotate, and Undo are performed in a layout just as they are in any other part of the program. As in other areas of the program, you can edit text, and you can change either the attributes of existing text, or define the attributes of all subsequent text.

An electrically complete layout circuit has all components connected. Refer to this chapter for details on editing and connecting layout circuit components.

Using Selection Filters

*Options > Preferences > Select*

Selection Filters enable you to specify the types of components you want to include or exclude in sections. Any component that is turned off is not selected when you click on it individually, attempt to enclose it in a selection window, or choose the Select All command. Only the Select By Name and Deselect By Name commands ignore the selection filters.

By default, all types of components are turned on except Drawing Format.
Editing Shapes

There are a variety of editing operations you can perform on common layout shapes. For details on these editing operations, refer to the section of interest:

- “Manipulating Polygons and Polylines” on page 6-2
- “Manipulating Vertices” on page 6-9
- “Stretching the Edge of a Shape” on page 6-7
- “Scaling Shapes” on page 6-8

Selecting Shapes

In addition to the selection features provided by the selection filters, you can quickly select all items on a layer you specify.

To select all items on a given layer:

1. Choose Select > Select All On Layer.
2. In the dialog box that appears, select the layer containing the items you want to select for editing. To select all items on multiple layers, click Apply after selecting each layer, then click OK. The items on the chosen layers are selected for editing.

Manipulating Polygons and Polylines

There are several ways to modify polygons and polylines after drawing them:

- Edit > Merge > And Enables you to create a single shape from two existing shapes on the same layer that overlap. This operation applies to the following shapes: polygons, rectangles, circles, and paths.
- Edit > Merge > Or Used to create a single shape from the union of two existing shapes on the same layer that overlap. This operation applies to the following shapes: polygons, rectangles, circles, and paths.
- Edit > Merge > Difference Allows you to create a single shape from two existing shapes on the same layer that overlap, with the resulting shape missing the area where the shapes overlapped. This operation applies to the following shapes: polygons, rectangles, circles, and paths.
• *Edit > Modify > Convert To Polygon*  Used to convert circles, as well as polygons containing arcs, to simple polygons where all curves are converted to line segments that approximate their original shape.

• *Edit > Modify > Join*  Allows you to join selected polylines with coincident endpoints into a single polyline. If a closed shape results, the joined polylines are converted to a polygon.

• *Edit > Modify > Explode*  Enables you to convert a polygon into individual line segments that are disconnected at each vertex.

• *Edit > Modify > Break*  Used to convert a polygon into a single polyline.

• *Edit > Modify > Chop*  Allows you to chop a selected region off of a polygon, rectangle, circle, or wire/trace.

• *Edit > Modify > Extend*  Enables you to extend the selected endpoint of a polyline to a designated reference line segment.

• *Edit > Modify > Crop*  Used to specify an area of a polygon, rectangle, circle, or wires/trace; save the selected area; and delete the remainder.

• *Edit > Modify > Split*  Allows you to split a polygon, rectangle, circle, or path/trace into multiple objects.

### Creating a Polygon from Intersections or Polylines

To create a polygon from the intersection of two closed shapes:

1. Select the two shapes.
2. Choose *Edit > Merge > And.*

![Before and After](image)

To create a polygon from the union of two intersecting closed shapes:

1. Select the two shapes.
2. Choose *Edit > Merge > Or.*
Editing a Layout

To create a polygon from two intersecting closed shapes, with the intersection removed:

1. Select the two shapes.
2. Choose **Edit > Merge > Difference**.

Converting a Shape to a Polygon

To convert a shape to a polygon:

1. Select the shape, where the shape can be a circle or polygon containing an arc.
2. Choose **Edit > Modify > Convert To Polygon**. All curves are converted to line segments that approximate their original shape. The number of line segments used in this conversion is determined by the setting *Arc/Circle Resolution (degrees)* in *Options > Preferences > Entry/Edit*. 

Hint: the change may not be evident until you move the shapes apart.
Joining Multiple Polylines

To join selected polylines (with coincident endpoints) into a single polyline:

1. Select the individual polylines you want to join.
2. Select **Edit > Modify > Join**. All coincident endpoints are joined. You can verify what has been joined by clicking on the shape to select it and observing whether or not the entire shape is selected.

![Diagram of joining multiple polylines](image)

To verify what has been joined, click the shape to select it and observe whether or not the entire shape is selected.

Converting a Polygon into Individual Two-point Line Segments

To convert a polygon into individual, two-point line segments:

1. Select the polygon.
2. Choose the command **Edit > Modify > Explode**. All vertices are disconnected leaving individual line segments that you can edit as needed.

![Diagram of converting a polygon](image)
Converting a Polygon into a Single Polyline

To convert a polygon into a single polyline:

1. Select the polygon.
2. Choose Edit > Modify > Break. The starting and ending points of the polygon are broken, identified by a marker, and you can now manipulate the shape as a polyline.

Chopping a Selected Region Off of a Shape

To chop a selected region off of a polygon, rectangle, circle, or wire/trace, do the following:

1. Select the shape.
2. Choose Edit > Modify > Chop.
3. Use the mouse to draw the rectangular region to be chopped over the object.

Extending the Endpoint of a Polyline

To extend the endpoint of a polyline to a designated reference line segment:

1. Choose Edit > Modify > Extend.
2. Click on the line that you want to extend.
3. Click on the reference line.
Cropping a Shape
To save the specified area of a polygon, rectangle, circle, or wires/trace and delete the remainder, do the following:

1. Select the shape.
2. Choose **Edit > Modify > Crop**.
3. Use the mouse to draw the rectangular region to be saved over the object.

Splitting a Shape
To split a polygon, rectangle, circle, or path/trace into multiple objects:

1. Select the shape.
2. Choose **Edit > Modify > Split**.
3. Use the mouse to draw the rectangular region to be split away from the rest of the object.

Stretching the Edge of a Shape
You can redefine a shape by stretching an edge (a segment between two vertices).

1. Choose **Edit > Move > Move Edge**. You are prompted to enter the location of the line.
2. Click once on the edge you wish to stretch. A ghost image moves and changes as you move the cursor, showing how the shape will be redrawn.
3. Click again to define the new shape.

![Diagram showing before, during, and after stretching an edge]
**Scaling Shapes**

To scale an object or text by a percentage:

1. Choose **Edit > Scale/Oversize > Scale** and the Scale dialog box appears.

2. Enter scaling factors for both X and Y.

   Scaling factors must be positive. Scaling factors greater than 1.0 increase the size of objects, while factors less than 1.0 decrease the size of objects. To scale the objects uniformly, enter the same scaling factor for both X and Y. For text, only the X scale is used.

3. Click **OK** and you are prompted to enter a reference point on the object around which to scale.

4. Click to specify the reference point, and the object is scaled.

To scale an object relative to the design units:

1. Select the object.

2. To replace the original object with a scaled image, choose the command **Edit > Scale/Oversize > Oversize**.

   To place a copy of the selected object (using the size you specify) on the current entry layer, preserving the original object, choose the command **Edit > Scale/Oversize > Copy & Oversize**.

   When you select either of these commands, a dialog box appears.

3. Enter the sizing amount. A positive number increases the size of the object; a negative number decreases the size.

<table>
<thead>
<tr>
<th>Oversize(+) / Undersize(-) Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.3000</td>
</tr>
</tbody>
</table>

4. Enter a cutoff angle for mitering corners. Any angle of a polygon smaller than the specified cutoff angle is mitered. Default = 45°.

<table>
<thead>
<tr>
<th>Acute Angle Cutoff</th>
</tr>
</thead>
<tbody>
<tr>
<td>45.0000</td>
</tr>
</tbody>
</table>

5. Make any changes in the dialog box, and click **OK**.
If you chose Oversize in step 2, the object is scaled to the specified size.

If you chose Copy & Oversize in step 2, a copy of the selected object is drawn on the current entry layer, at the specified size.

**Manipulating Vertices**

---

**Note** To select, move, or delete a vertex, the Vertices select filter must be on (see “Using Selection Filters” on page 6-1).

To add a vertex to a polygon or polyline:

1. Choose **Edit > Vertex > Add**.
2. Click on a point between two existing vertices, and move the mouse. A flexible line is drawn between the vertices and the cursor.
3. Click again to specify the new point and the shape is redrawn.
Editing a Layout

To move a vertex:
1. Select **Edit > Move > Move**, click on the vertex, and move the mouse. A flexible line is drawn from the affected vertices to the cursor.
2. Click again to specify the new location, and the shape is redrawn.

To delete a vertex:
1. Draw a selection window enclosing all vertices you wish to delete.
2. On the toolbar, click the delete button. The shape is redrawn without those vertices.

![Before During After](image)

To delete an arc from a polyline
1. On the toolbar, click the delete button.
2. Click anywhere on an arc. The arc is deleted and the former endpoints of the arc are connected with a straight line.

![Before After](image)

**Converting a Vertex to an Arc**

You can convert any vertex to an arc and specify the desired radius of the arc, with respect to the units of the window.

1. Choose **Edit > Point > To Arc**. You are prompted *enter location of the vertex*, and a dialog box appears.
2. Set the radius as desired and click **Apply**.
3. Click on any vertex you wish to convert to an arc. The vertex is redrawn accordingly.
You can continue converting vertices in this manner using a different radius each time if desired, but you must click Apply each time you change the radius. When you are through making these changes, click OK to dismiss the dialog box.

**Converting a Vertex to a Mitered Edge**

You can convert any vertex to a mitered edge and specify the desired length of the mitered edge, with respect to the units of the window.

1. Choose **Edit > Vertex > Miter**. You are prompted *enter location of the vertex*, and a dialog box appears.

2. Set the miter length as desired and click Apply.

3. Click on any vertex you wish to convert to a mitered edge. The vertex is redrawn accordingly.

You can continue converting vertices in this manner using a different miter length each time if desired, but you must click Apply each time you change the length.

4. To dismiss the dialog box, click OK.
**Editing a Layout**

**Moving Shapes or Text to a Different Layer**

To move shapes or text to another layer:

1. Select the object you want to move.

   [**Note**] Do not use the *Move To Layer* command to move ports to a different layer; set the *Layer* parameter of the port to the desired layer.

2. Choose *Edit > Move > Move To Layer*. A dialog box appears with a list of currently defined layers. Select the desired layer and click *OK*. The selected object immediately takes on the color and other display characteristics of the selected layer.

   [**Note**] The following items can be moved to another layer using the context-sensitive menu that appears when you right-click with the pointer positioned over any of these items: Polygon, Polyline, Rectangle, Circle, Arc, Text, Arrow, Wire, Construction Line, Path, Trace.

**Manipulating Dimension Lines**

Dimension lines can be moved and modified.

**Moving Endlines**

A dimension line can be stretched using the *Edit > Move > Dimension Line Endline* command. This is done as follows:

1. Select *Edit > Move > Move Dimension Line Endline*.

2. Move the cross-hairs over the dimension line end that you want to stretch and click.

   [**Note**] If you have trouble selecting the end of the dimension line, see if the dimension line arrowhead is visible. If it is not, zoom in and try selecting the end of the dimension line again.
3. Move the cross-hairs to the desired position and click.

**Modifying Dimension Lines**

To modify the attributes of a dimension line, do the following:

1. Double-click on the dimension line.
2. The Dimension Line dialog box appears.

Choose the parameter that you want to change from the Select Parameter list. The choices are:

- **LineLength**: The length of the dimension line
- **LineOffset**: The dimension line vertical offset from the x-axis
- **Endline**: The height of the end line from the dimension line
- **ArrowLength**: The length of the arrow
Editing a Layout

ArrowWidth: The width of the arrow
ArrowDir: The arrow direction. The possible values are inward and outward.
TailLength: If ArrowDir is inward, this represents the length of the arrows’ tails
Layer: The dimension line layer.
TextOffset: The text offset from the dimension line.
TextHeight: The text height
Precision: The displayed length precision
TextPosition: The text position in relation to the dimension line. Available choices are above, below, left, or right.
TextUnits: The unit to use to display distance

3. Edit the parameter settings
4. Click OK to save the change and close the dialog box.

Moving an Object to the Coordinates 0,0

By default, the coordinates 0,0 are located in the center of the Layout window. You can reposition an object that you have placed or drawn elsewhere, at the origin.

1. Choose Edit > Modify > Set Origin. You are prompted, enter origin location.
2. Click the point of the object (for example, pin 1) that you want to position at 0,0 and the object is moved; the specified point is now located at 0,0.

Note  You can use the View All command to bring the object back into view.
Forcing an Object onto the Grid

If an object is offset from the current grid spacing, you can force it to the nearest grid point. If the selected object is an component with pins, pin 1 is forced to the nearest grid point.

1. Select the object.
2. Choose Edit > Modify > Force to Grid. The selected object snaps to the grid.

Editing Layout Hierarchy (Flatten)

When you are ready to generate final artwork, you can remove all levels of hierarchy. This process copies all data from the referenced design to the current representation. You must then delete that instance of the subnetwork, which deletes the reference to the other design. Repeat this process for each level of hierarchy you want to delete. When you finish, the design will be intact, but contain no references that could affect the final design.

1. Open the top-level hierarchical design.
2. Select an instance.
3. Choose Edit > Component > Flatten.
   
   This copies all data from the component to the current representation. Now you have two sets of component data.

4. While the component is still highlighted, choose Edit > Delete. This deletes the duplicate instance and its reference.
5. Repeat this procedure for each instance you want to flatten.
6. To check that all hierarchy levels have been removed choose the command Options > Hierarchy. There should be no indented levels.
7. Save the design.
Creating Hierarchy

1. Select the components you want to include.
2. Choose Edit > Component > Create Hierarchy, and a dialog box appears.

The program copies the selected artwork elements to another file, saves that new file, deletes the selected components in the original file and replaces them with a reference to the new design.
3. Provide a name for the new file and click OK. (The name you supply becomes part of the annotation displayed when you place the symbol in a design.)

Connecting Layout Components

Hint Regardless of how you connect components, you should turn pin snapping on before you begin (Options > Preferences > Grid/Snap > Pin).

Viewing Connectivity Information

1. Choose Options > Check Representation.
2. In the Check Representation dialog box, select the desired information category (or categories).
   - Unconnected pins displays the total number of unconnected pins, and for each component with an unconnected pin, lists the component name and ID, the pin number and coordinates of the unconnected pin. The affected components are highlighted in the design window.
   - Nodal mismatch (layout vs schematic) reports components that are connected differently in one representation than they are in the other. The report lists the name of the component, the pin that is connected differently and what the pin is connected to. The affected components are highlighted in the design window.
   - Wires in layout displays all components connected to pins that are interconnected with a wire (or a zero-width trace).
Overlaid Components reports the IDs of any overlapping components where the components contain the same number of pins and pin 1 of each component is placed in the same location.

3. Click OK. The Check Representation Report appears displaying the requested information.

4. If desired, click Print to print the report.

5. To dismiss the report, click OK.

Working with Transmission Lines

For some types of design work, designing from the layout can save considerable time. This is especially true in designs with complex transmission lines. In layout, transmission lines can be created either by placing transmission line elements manually or by inserting traces and converting them to transmission lines later. Regardless of how you create them, there are a number of ways you can edit them.

Splitting a Transmission Line

You can replace one transmission line element with two identical elements.


2. On the transmission line, and click on a reference point.
## Editing a Layout

### Replacing a Transmission Line Element

You can replace one transmission line element with two identical elements and a tee.

![Diagram: MLIN and MTEE elements](image)

1. Select **Edit > Transmission Line > Tap Transmission Line**. A **Tap Length** dialog box appears where you specify the length of the tee element.

2. Type a number for the tap length, and click OK.

   Either an MTEE or STEE is inserted, depending on whether an MLIN or SLIN was tapped.

3. On the transmission line, click on a reference point where you want the tee element inserted.

   **Hint**  
   The third pin of the tee will be placed on the transmission line edge closest to the cursor.

### Stretching a Transmission Line

1. Select **Edit > Transmission Line > Stretch Transmission Line**.

2. Click on a node of the transmission line, and move the pointer away from the element. A flexible dashed line appears and moves with the pointer.

3. Click on a second reference point (where you want the element to stretch to). The element is now changed to the new length.
Squeezing a Transmission Line While Maintaining its Length

You can modify an existing transmission line to squeeze it into a smaller space, specifying several characteristics in the process, such as corner type, lead length and minimum spacing.

You can adjust any or all of the following characteristics as needed:

- **Corner Type**—Select from Mitered, Square, Curve
Editing a Layout

- **Ending Direction**—The direction (clockwise or counterclockwise) in which the last two segments connected to the ending lead are drawn.

- **Minimum Spacing**—The minimum spacing between the parallel trace segments.

- **Mitered Corner Cutoff Ratio (%)**—The desired cutoff ratio for the corner type *Mitered*.

- **Curve Radius**—The desired curve radius for the corner type *Curve*.

- **Lead Length**—The length of the starting and ending segments.

To squeeze a transmission line into a smaller space while maintaining its length:

1. Choose **Edit > Transmission Line > Squeeze Transmission Line Keeping Length**. In the dialog box that appears, set the options as desired and click **Apply**.

2. You are prompted to enter the reference location. Click the pin at one end of the transmission line and you are prompted to enter the offset location.

3. Move the pointer toward the other end of the transmission line. When the ghost image of the transmission line represents what you want, click to draw the modified transmission line.
Editing Paths, Traces and Wires

Converting Traces to Paths

Unlike converting traces to transmission line elements, where the conversion is one-way, you can change paths back into traces. Use the following steps to change a trace into a path:

1. Select the desired trace.
2. Choose Edit > Path/Trace/Wire > Convert Trace to Path.

Converting Paths to a Traces

Unlike converting traces to transmission line elements, where the conversion is one-way, you can change traces back into paths, as follows:

1. Select the desired path.
2. Select Edit > Path/Trace > Convert Path to Trace.

Changing the Attributes of an Existing Path/Trace/Wire

1. Select the desired traces/paths/wires.
2. Choose Edit > Path/Trace/Wire > Path/Trace/Wire. The Path dialog box appears.

Corner Type  Select Mitered, Square, or Curve.

Width  Specify the width (in layout units).

Mitered Corner Cutoff Ratio (%)  Set a percentage of cutoff; the larger the number the more of the corner is cut off.

Curve Radius  Specify a curve radius.

3. Fill in the appropriate fields, and click OK.
Editing a Layout

**Stretching a Wire**

You can change the shape of an existing wire by stretching an edge (a segment between two vertices).

1. Choose **Edit > Move > Move Edge**.
2. Click once on the edge you wish to stretch. A ghost image moves and changes as you move the cursor, showing how the shape will be redrawn.
3. Click again to define the new shape.

**Converting a Wire to a Trace**

If the separation between components is intentional, you can convert a wire to a trace.

1. Select the wire and choose **Edit > Path/Trace/Wire > Edit Path/Trace/Wire**.
2. In the dialog box that appears, change the characteristics as desired, as described in “Inserting Traces” on page 3-8, and click **OK**.

**Hint**  Because traces have width, if the wire you are converting to a trace has a bend, the shortest segment that is part of that vertex cannot be shorter than $3 \times w/4$ where $w$ is the width for the trace, as specified by Path Width.
Editing Component Text

By default, when you place a component in layout, its Instance Name (a unique ID) is automatically placed with it on the silk_screen layer. (The Component Name is placed on the silk_screen2 layer, which is not visible by default.) Instance Names are automatically assigned but you can change them as long as you maintain unique IDs for each instance.

To change the Instance Name for a given component, use either of the following methods:

- Change it using the onscreen editor
- Change it in the Component Parameters dialog box (double-click the component or choose Edit > Component > Edit Component Parameters)

To change component text attributes (font and size):

1. Select the component and choose Edit > Component > Component Text Attributes.
2. Change the attributes as desired and click OK.

For details on adding block text to your layout, see “Layout Block Text Fonts” on page 3-17.
Editing a Layout

Using Boolean Logical Operations

In the Layout window, you can insert onto any destination layer polygons that are the result of comparing the contents of two layers. In effect, the material you select on the source layers is copied to a destination layer according to logical rules.

Use the following steps for any of the logical operations described in this section:

1. Ensure that the source layers and the destination layer are not protected (Options > Layers).
2. Choose the command Edit > Boolean Logical.
3. In the dialog box that appears, use the drop-down lists to indicate the two source layers, the operation you want performed, and the destination layer. Except for DIFF, it makes no difference which source layer you identify first. See “Edit > Boolean Logical > DIFF” on page 6-25.
4. Select whether you want the logical operation to apply to shapes that you select, or to all shapes on the two source layers.
   - If you choose Selected Shapes, you must select at least one object on each of the two source layers.
5. Select whether you want the original shapes deleted.
6. Click OK. The program performs the selected operation on the shapes.
Edit > Boolean Logical > DIFF

Use DIFF to create (on the destination layer) one or more polygons that are a copy of everything that you select on the first source layer minus the material you select on the second source layer that is in the same x, y location. In effect, the system copies the material that you select on the first source layer, and then subtracts from it the material that you select on the second layer.

In the following examples, the result on the destination layer appears to the right, beside the source layers. This does not happen in the program, where objects on the destination layer appear in the same x,y location as in the source layers.

Example 1

In this example, the cond layer is specified as the first source layer. The program first copies the rectangle on that layer. Then (in effect) the circles on the cond2 layer (the second source layer) are subtracted from it. The result is a polygon, as shown.

Example 2

In this example, the cond2 layer is specified first. The system first copies the circles on that layer. Then (in effect) the rectangle on the cond layer is subtracted from them. Only parts of the two circles at the top of the cond2 layer appear on the destination layer. Everything else on that layer lies within the boundaries defined by the rectangle on the cond layer.
A practical application of the DIFF option would be to create holes on a layer. This would be done as follows:

1. Place all shapes on the Cond layer.
2. Place all holes on the Hole layer.
3. Choose **Edit > Boolean Logical > DIFF**.
4. In the Boolean dialog box, go from left to right and make the following menu selections: Cond, DIFF, Hole, and Cond.
5. In the Apply To section, select **All Shapes**.
6. Select the **Delete Original** button.
7. Click the **OK** button.

**Edit > Boolean Logical > AND**

Use **AND** to create (on the destination layer) one or more polygons that are a copy of only those things selected that are in the same x,y location on both source layers. The system deletes material that appears on only one source layer. In the following example, the destination layer contains only the parts of the circles on the cond2 layer that are inside the boundaries defined by the rectangle on the cond layer. The upper parts of the top circles are in a region where there is nothing on the cond layer, so they do not appear on the destination layer.

**Edit > Boolean Logical > OR**

Use **OR** to create (on the destination layer) one or more polygons that are a merged copy of everything selected on either source layer. In the following example, the destination layer includes (in a single, merged polygon) the rectangle on the cond layer and all of the circles on the cond2 layer. This includes the two circles at the top of the cond2 layer, even though parts of them are outside the boundaries defined by the rectangle on the cond layer.
**Edit > Boolean Logical > XOR**

Use XOR to create (on the destination layer) one or more polygons that are a merged copy of everything selected that appears in any x,y location on *only one* source layer. Anything that appears on *both* source layers is, in effect, deleted.

In the following example, the destination layer is similar to the first DIFF example, except that the polygon includes the parts of the two circles at the top of the *cond2* layer that are outside the boundary defined by the rectangle on the *cond* layer. These are included *because* they appear only on the *cond2* layer.

---

**Creating Clearance**

You can define the clearance between a ground plane and a shape on the same layer, as follows:

1. Choose **Edit > Create Clearance**.
2. As prompted, select the ground plane and click OK.
3. Select the shapes.
4. Enter the desired offset.
5. Click OK.
Editing a Layout
Chapter 7: Artwork

Any item can have an artwork representation. There are several ways to define artwork for any given item you want to represent in layout, but in general, the artwork is categorized in one of two ways:

- Fixed artwork
- AEL artwork macros

For both types of artwork, a large number of artworks are supplied, but you can also create custom artwork of either type.

Fixed Artwork

The simplest artwork is fixed artwork and over 100 fixed artwork shapes are provided. Fixed artwork can be thought of as a layout object. These objects are saved in design files and may or may not have connection pins. This type of artwork is often used for layout items that do not change size or shape based on parameter settings. For example, an SOT23 package outline is the same for any device with that package, regardless of the device operating parameters.

- The supplied fixed artwork objects are documented in Chapter 10, Fixed Artwork. For details on associating one of these fixed artworks with an item, refer to “Associating Artwork with an Item” on page 7-12.
- For details on creating your own fixed artwork, refer to “Creating Fixed Artwork” on page 7-7.

AEL Artwork Macros

A more flexible approach is to use the AEL artwork creation functions to define the artwork for an item. The artwork for the built-in transmission line elements (microstrip, stripline, etc.) is defined in this fashion, and over 200 AEL artwork macros are provided. These macros include functions for creating solder pads, space artwork and no artwork.

The AEL macro is versatile because it can accept parameters that are used to determine the shape, size, layer, and connection points of the layout artwork. Every reference to an item defined with an AEL macro can be different, depending on the parameters passed to it.
The supplied AEL macros for layout-only components are documented in Chapter 9, Standard AEL Macros.

- AEL macros are supplied for additional components that are documented (as components) in the Circuit Components manual.
- AEL macros are supplied for over 100 standard SMT packages and are documented in Chapter 11, SMT Package Layout Artwork Library.
- For details on creating your own AEL artwork macros, refer to “Creating Artwork Using an AEL Macro” on page 7-8.
- For details on creating AEL artwork macros using the Graphical Cell Compiler, refer to the Graphical Cell Compiler manual.

Special Types of Artwork

The following special types of artwork are also available: space artwork, connection artwork, and SMT package artwork.

Space Artwork

Space artwork refers to leaving a space or gap in layout. No actual artwork is created with the space macro. Instead, it instructs the program to view items connected through an item with space artwork as connected. In the layout, a gap is created separating items connected to the item with space artwork.

Using this artwork type is common for layouts where the artwork representing a simulation item may frequently change. For example, you may have an S-parameter device model (S2P) in your design and wish to swap out the referenced S-parameter file to test different devices.

If each device has a different artwork representation, there is no one package outline to assign to this element. However, by assigning space as the artwork (SPAC), you can leave a gap, whose size is a parameter of the item, and insert a layout package outline later.

Built-in item definitions have been supplied for the most common cases of simulation items that could benefit from using SPAC as artwork. These include many lumped elements as well as the S2P element, and can be found in the Lumped Components (with artwork) and the Linear Data File Items (with artwork) palette and library groups. Any item from the library of packaged parts supplied with the program, or layout object you define, can then be used to insert into the space for layout.
Connection Artwork

Connection artwork is a special case of space artwork. However, rather than leaving a gap in layout, it simply connects items that are connected through it together (a space of 0). In other words, items with connection artwork are simulated and included in your schematic, but are ignored in layout. For example, you may have included parasitic capacitors or resistors in your network that have no artwork. By assigning connection artwork to these items, you can include them in simulation and have the layout ignore them.

It is important to use items with connection artwork, rather than items without any artwork assigned at all, to ensure that the layout can be automatically synchronized with the schematic.

Like items with space artwork, the most commonly used items with connection artwork have been pre-defined and included in the program. These are also listed in the Lumped -With Artwork and the Linear Data File Items (with artwork) palette and library groups.

SMT Package Artwork

SMT package artwork is available for over one hundred parts. These artwork macros are versatile because the dimensions of the land pattern can be varied by changing the width and length of the package. The position of the land pattern, with respect to the component package, can be varied by changing the OFFSET parameter. For details on available SMT package artwork and an example, refer to Chapter 11, SMT Package Layout Artwork Library.
Supplied Artwork

Default artwork exists for all microstrip and stripline components, as well as many other components. Artwork also exists for a large number of component libraries. This artwork is in the form of AEL artwork macros.

Default artwork also exists for a number of optional libraries. This artwork is usually in the form of fixed part outlines. For packaged part libraries, it is the component footprint or outline; for other parts it is the actual part geometry.

For other parts, there is no default artwork. To include these components in layout, you need to create special component equivalents with artwork specific to your requirements. For details refer to “Custom Artwork” on page 7-4.

Custom Artwork

Custom artwork for a design can be created before or after the simulation model. Depending on what the artwork represents, you may want to create the artwork using an AEL function, or simply create it by drawing a fixed set of shapes. Two examples are given to demonstrate how to create artwork using either method.

Depending on the type of layout you are creating, you can create the artwork as a library of fixed artwork components, as parameterized artwork macros, or a combination of both. For some layouts, capacitors come in a set of fixed, discrete capacitance values, so it may be better to create a fixed layout for each unique capacitance value. In other layouts, the capacitors can take a range of values. If implemented as an artwork macro, the macro can accept a parameter value and adjust shape dimensions to produce the corresponding artwork. Microstrip transmission lines (MLIN) are another example of a component that is best implemented as an AEL macro, because the width and length of the line are passed into the macro (using the length unit set for the design), which controls the size of the rectangle used to represent it.

To simplify creating new items with artwork, AEL functions and a library of fixed artwork are provided. The AEL functions include: functions that generate a space or gap in layout (this allows an artwork to be inserted later), macros for pad placement (for 2-, 3-, and 4-pin components), routines to create different types of PCB pads, a predefined set of commonly used components with space, connection, or pad artwork, and a way to provide a simple electrical connection between items. The fixed library contains artwork for most popular packaged parts outlines, including a large SMT
library. (For lists of the supplied fixed and AEL macro artwork items, choose File > Design Parameters and view the drop-down list associated with each artwork type.)

**Creating a Layout Object**

To create a layout object:

1. For a layout object, open the Layout window and draw the shapes representing the object.
   
   Optionally, you can add connection points or pins ("Adding pins/ports to artwork" on page 7-5). You do not need to add pins if the object is going to be used as artwork to be inserted into a layout gap (refer to "Space Artwork" on page 7-2).

2. When the artwork is drawn, choose File > Design Parameters in the Layout window for layout objects, or from the Schematic window for schematic objects.

3. Select Fixed as the Artwork Type if it is to be included in a schematic, otherwise select Not Synchronized.

4. Type the name of the currently open design file in the Name field (without the .dsn extension).

5. Type (or select if it already exists) the name of the library in which you want the item stored.

6. From the Model list in the Simulation field, select Not Simulated.

7. Check the Layout Object box and click OK.

8. Save the design.

**Adding pins/ports to artwork**

For any artwork item you create that will be connected electrically, you will need to add pins. Pins represent an electrical connection point to which a trace, wire or the pin of another item can be connected.

When creating your own artwork components, the angle of the ports affects how components are connected. The port symbol in layout (an arrow) shows the angle to be used. When creating artwork macros, you can specify the angle of the ports.

To add a pin in layout, place a port element for each electrical connection point. The term pin and port are used interchangeably. In some cases you may have more than
Artwork

one location on the artwork that you would like to connect to, in this case you can use multiple ports or nports. Nports allow you to place multiple physical connection points that represent a single electrical port. Connecting to any same numbered nports creates the connection.

Any item may use nports, and have as many as required. Each nport representing a single connection shares the same port number. The only special requirement when using nports is that one of the ports in the set be a preferred port. A preferred port is a connection point that the design synchronization facility uses to connect to. Nports are created using the nport item; preferred ports are created using the standard port item. In a set of multiple ports sharing the same port number, there can be only one preferred port.

When creating artwork using AEL, the same concept applies. The only difference is that ports are created using the de_define_nport and de_define_port or de_draw_nport and de_draw_port AEL functions.
Creating Fixed Artwork

The artwork for this example is a fixed pattern representing the mounting pads for the chip capacitor. The only parameter for the subnetwork is $C$, the nominal capacitance. A resistor is added to the schematic to account for loss. An equation is used to calculate the resistance from the nominal capacitance.

The following schematic describes the simulation model.

To create the fixed artwork for the chip capacitor:

1. Open the Layout window.
2. Select an entry layer for your artwork (select Insert > Entry Layer).
3. Optionally, make the grid visible (select View > Zoom In).
4. Draw the shapes representing the capacitor pads. Be sure your dimensions and layers are appropriate for your design.
5. Add ports to your artwork. The orientation of the ports determines how components will be connected to your artwork when design synchronization is run. Place port 1 on the left side of the left rectangle with the coordinates at node 1 set to 0,0. Port 1 looks like an arrow pointing into the artwork.

6. Place Port 2, rotating it to point in to the right rectangle.

When your capacitor is placed during synchronization, it will have connecting items placed to the right and left of it, at the same angle the capacitor is placed.

7. Save your design.

Creating Artwork Using an AEL Macro

The artwork for this example is programmable artwork generated using an AEL function for creating a thin film (MMIC) capacitor. The capacitor area is calculated from the parameters passed into the network. You can create the network first, and then the AEL function, or vice versa. Once the artwork function is complete, you need to associate it with the network ("Associating Artwork with an Item" on page 7-12).

The following schematic describes the simulation model.
To create an artwork function:

1. Using any text editor, create the macro functions in an AEL file (the file must use an .ael extension). For details on the structure of an AEL function, refer to the AEL manual.

The following annotated example is for a thin film capacitor (TFC), tfc.ael:

/* layout artwork generation function for MIMCAP element */

This example assumes a MMIC process, with two metal layers, and a via layer. The processing steps required are:
1) deposit first metal and etch to layer 1
2) deposit dielectric and etch vias to layer 4
3) deposit second metal and etch to layer 2

Global technology parameters are provided to show how standard constants could be applied to all artwork functions

*/

//load("stdart");       // make sure we have standard definitions
// define technology parameters, all in MKS
decl lpad, lab, lpost, wpost, vu, lol, cpua;
lab = 6e-6;               // length of air bridge
lpost = 6e-6;             // length of post/via
wpost = 10e-6;            // width of post/via
vu = 0.5e-6;              // via undersize
lpad = 4e-6;              // bottom plate pad length
lol = 2e-6;               // bottom plate overlap
cpua = 300e-6;            // capacitance per unit area
// actual artwork generation function
defun mimart(c, ar) 
{
decl c_mks, netu, wcap, lcap;
dcl lbot, wvia, w, l;

netu = mks_factor(5);    //get length conversion factor from mks
 c_mks = c*mks_factor(4); // get capacitance in farads
 lcap = sqrt(c_mks/cpua*ar)/netu; // get length in meters
 wcap = lcap/ar;         // get width in network units

// compute some useful values
lbot=(2.0*lol+lpad)/netu+lcap; // compute length of bottom plate
wvia = (wpost-2.0*vu)/netu;   // compute width of via
w = (2.0*lol)/netu + wcap;   // compute overall width
l = (lab+lpost)/netu + lbot;  // compute overall length

// draw lower plate and output contact
Artwork

```
de_set_layer(1);    // set the first metal layer
de_draw_rect(0.0, -w/2.0, lbot, w/2.0);
de_draw_rect(l-lpost/netu, -wpost/netu/2.0, l, wpost/netu/2.0);
// cut via hole
de_set_layer(4);     // set via (dielectric) layer
de_draw_rect(l-(lpost-vu)/netu, -wvia/2.0, l-vu/netu, wvia/2.0);
// draw air bridge metal
de_set_layer(2);    // set the second metal layer
de_draw_rect((lpad+lol)/netu, -wcap/2.0, lbot-lol/netu,wcap/2.0);
de_draw_rect(lbot-lol/netu, -wpost/netu/2.0, l, wpost/netu/2.0);
// add ports
de_draw_port(0.0, 0.0, -90.0);
del_draw_port(1, 0.0, 0.0);
}
```

2. Save the file in your project networks directory.

To associate this artwork with your subnetwork:

1. Open the network design and choose File > Design Parameters.

2. From the General tab, select SYM_C as the Symbol Name. (This is the symbol that will represent the schematic.)

3. Set the Simulation Model to Subnetwork.

4. Select AEL Macro as the Artwork Type.

5. In the Artwork Name field, type the name of the function you just created. In this example, mimart. This is defined in the example by the line:

```
defun mimart(c, ar)
```

6. From the Parameters tab, create the parameters C and AR, as defined in the artwork function. Both should be set to Netlisted. You can optionally set them as optimizeable.

The following illustration shows the MMIC capacitor in layout with C=20 and AR=1.
Note that rather than writing the functions from scratch, you may find it helpful to copy AEL macro code from one or more of the following files and modify it in your own AEL file:

- `destdart.ael` Artwork macros available from the Design Parameters dialog box, located in `$HPEESOF_DIR/de/ael`
- `ckt_linear_art.ael` Existing artwork for circuit simulators, located in `$HPEESOF_DIR/circuit/ael`

If you want to move the `.ael` file to a directory other than the project’s networks directory, refer to “Creating Custom Libraries” in the Customization and Configuration manual for details.
Artwork

**Associating Artwork with an Item**

When associating artwork with an item, choose one of the following artwork types:

- Synchronized
- Fixed
- AEL Macro
- None

**Selecting the Appropriate Artwork Type**

The following sections describe how the different artwork types are intended to be used.

**Synchronized Artwork**

When you create and save a network, a design definition is automatically created with certain defaults (which can be modified through File > Design Parameters) including Artwork Type. By default, the artwork type will be Synchronized.

Synchronized artwork is the appropriate artwork type when the layout contains parameterized components or if the layout is a subnetwork that needs to be regenerated when a parameter is changed. When synchronized artwork is selected as the artwork type, the artwork that is generated is based on the default artwork defined for each component in the schematic. Additionally, when the design synchronization process is run, it checks the subnetwork references for any changes to its parameters and automatically regenerates the layout based on the changes.

**Fixed Artwork**

If your layout is comprised of fixed shapes, then Fixed artwork is the appropriate Artwork Type. The layout artwork can reside in the same design file as the schematic or in a different file.

To associate fixed artwork with an item:

1. From the design of interest, choose File > Design Parameters.
2. From the Artwork Type drop-down list, select Fixed.
3. In the Artwork Name field, select or type the name of the design file containing the artwork. This can be supplied artwork or custom artwork. You do not need
to include the full path, just the design file name, minus the .dsn extension. The file should reside either in your project’s /networks directory or in a directory whose files are automatically loaded by the program (based on the search path). For details refer to “Creating Custom Libraries” in the Customization and Configuration manual.

4. Change any other design definition characteristics as desired and click **OK**.

### AEL Macro Artwork

If you want to generate artwork based on parameters that may change, then **AEL Macro** artwork is the appropriate Artwork Type.

To associate an AEL Macro artwork with an item:

1. From the design of interest, choose **File > Design Parameters**.
2. From the General tab, select **AEL Macro** as the Artwork Type.
3. In the Artwork Name field, select or type the name of the function. Note, this is not the name of the AEL file, rather it is the name of the AEL artwork creation function (specified with the `defun AEL` function).

   The function must be in an AEL file that is loaded by the program. All AEL files in your project’s `networks` directory are automatically loaded. For details on loading files from other directories (based on the search path), refer to “Creating Custom Libraries” in the Customization and Configuration manual.

4. From the Parameters tab, enter the list of parameters used by the macro and assign the appropriate characteristics including Value Type. Note the following guidelines when defining parameters:

   - **Artwork parameters must be defined in the same order in which they are used by the macro and they must be listed before any other parameters. Their type should be Not Netlisted.**

   - **All parameters that define physical dimensions should be assigned Length as the Parameter Type. If you do not define a unit along with the Default Value, the specified value will be read as meters. When you place an instance of this**
subnetwork in a schematic, the specified default value is converted from meters to the current *Length* unit set for the Schematic window.

- The *Layer* parameter is the Layer Number on which the artwork should be drawn, and must be an integer.

**Hint**  To quickly populate the list of parameters, click *Copy Parameters From* and select a component with parameters similar to those you need, then modify the list of parameters and their characteristics as desired.

5. Optionally, select an appropriate Parameter Type. This selection determines the choices available for editing the parameters when you place your subnetwork.

The following example shows *Value Type* and *Parameter Type* settings based on the *cpad2* macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value Type</th>
<th>Parameter Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>R</td>
<td>Real</td>
<td>Length</td>
</tr>
<tr>
<td>S</td>
<td>Real</td>
<td>Length</td>
</tr>
<tr>
<td>LAYER</td>
<td>Integer</td>
<td>Unitless</td>
</tr>
</tbody>
</table>

If the AEL Macro artwork is SMT package artwork:

1. In the Design Parameters dialog box, set the Artwork Type to *AEL Macro* and select the appropriate Artwork Name (*smtart_<part_name>*).

2. In the Parameters section, define the two parameters, SMTPAD and OFFSET.

- For the SMTPAD parameter, set the Parameter Type to *String* and set the default value to the appropriate SMTPAD Instance Name (for example, PAD1). Select the *Not netlisted* option.

- For the OFFSET parameter, set the type to *Real*, with a default value 0.

**None**

Select *None* as the Artwork Type if no artwork is to be generated or no artwork is to be used to synchronize the schematic with layout objects.
Overriding the Default Artwork Assignment

You can override the default artwork assignment for any given component.

To change the artwork for a given component:

1. Select the component and choose Edit > Component > Edit Component Artwork.

2. Choose from one of the following Artwork Types:

   - **Default**: Uses the artwork specified in the component’s create_item definition. The artwork type and artwork function name are displayed.
   - **Fixed**: Any supplied or custom fixed artwork. Select or type the design filename containing the artwork from the Artwork Name drop-down list, or use the browser to select one.
   - **Null Artwork**: Draws a generic box (with an X through it)

3. Click **Apply** for this component and select another and repeat as needed. Click **OK** when you are finished.
Artwork
Chapter 8: Importing and Exporting Layouts

The import/export translators in the Advanced Design System are highly configurable. Each translator has an associated options file that controls how the translator works. Default options files are included with the program and are automatically used unless you specify otherwise.

This chapter provides an overview of importing and exporting layouts.

Table 8-1. Import/Export Formats

<table>
<thead>
<tr>
<th>Import</th>
<th>File Format</th>
<th>Export</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>DXF</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>EGS Archive Format</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>EGS Generate Format</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td>GDSII Stream Format</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td>Gerber</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td>Gerber Viewer</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>HPGL/2</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>IFF</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>IGES</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>Mask File</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td>MGC/PCB</td>
<td>3</td>
</tr>
</tbody>
</table>

**Note**  For details, refer to the *Importing and Exporting* manual.
Importing and Exporting Layouts

Importing a Layout

Use the following procedure to import a layout.

1. In the Layout window, choose the command File > Import. The Import dialog box appears.
2. From the Import dialog box, select the desired format.
3. Click Select File, choose a file name, and click OK.
4. Define any options or layer attributes.
5. Click OK. The file is translated into the program. One or more design files can be created.

For all translators, one or more designs can be created. The top level design for IGES or GDSII is displayed in the Layout window (no schematics are created using any of the translators).

**Note** Errors or warnings generated during translation are written to a write<translator>.log file, such as writegds.log (GDSII), writeigs.log (IGES), or writeeegs.log (EGS).

Opening and Viewing a Translated Layout

Use either the design tree in the Main window, or the File menu in the Layout window to open an imported layout.

Saving a Translated Layout

You must explicitly save a translated design. It is not automatically saved. Use the following step to save one or more translated designs (individual designs created during the translation of a hierarchical design):

In the Main window, choose the command File > Save All Designs.

Listing the Hierarchy of a Translated Layout

In the Layout window, choose the command Options > Hierarchy.
Exporting a Layout

Preparing a Layout for Translation

Preparing a layout for translation consists of some or all of the following steps:

- Remove (flatten) any hierarchy that exists in the layout. This is necessary if you want to make changes that would affect all levels of the hierarchy, such as merging shapes.

- Edit the shapes that make up the graphical representations of the circuit components in the layout. The most common editing steps are to:
  - Merge graphics shapes that are on the same layer and touching (to eliminates boundaries between components so that the layout consist of graphics only).
  - Apply process offsets.
  - Create reverse images.
  - Change colors.

Layouts are sometimes edited to reverse the arrangement of colors: to replace white with black, for example.

- Change the visibility or arrangement of layers.

The steps you must use depend on the type of translation, and on what must appear in the finished file.

Flattening Instances to Eliminate Hierarchy and Connectivity

When you flatten components, you turn each component in the layout into a set of unrelated shapes. Component grouping is lost, and the shapes no longer behave as an electrical entity for simulation. Use the following steps:

1. In the Layout window, choose File > Generate Artwork.

2. When the program prompts you for a new design name, enter the desired name and click OK.

Hierarchy is removed so that all primitives are contained in the copied top-level layout icon.
Adding a Process Offset

It is sometimes necessary to have two layers that are almost the same except that one has a process offset. A process offset is a fixed amount of space (width) that is added to or subtracted from all dimensions of an object to compensate for production tolerances. Process offsets are used to create objects that overlap or underlie other objects, and to fix the actual amount of the overlap. If the object is a polyline or an arc, the object must have width to use a process offset. In addition, when process offsets are used with these primitives, only width is affected; process offsets do not change the endpoints of polylines or arcs. To create a process offset in your layout, copy the shapes from one layer to an empty layer, merge the shapes on the new layer, and then oversize (or undersize) the merged shapes.

Copying Shapes to a New Layer

To copy shapes from one layer to another:

1. If the layer to which you want to copy the shapes does not exist, choose Options > Layers to display the Layer Editor, then add the desired layer.
2. In the Layout window, select the shapes that you want to copy.
3. Choose Edit > Copy/Paste > Copy to Layer.
4. In the Copy to Layer dialog box, select the destination layer and click OK.

Note   The program places a copy of the selected shapes on the destination layer, in exactly the same place as they appear on the source layer. Because of this, you cannot see the copied shapes. When you click OK, a copy is placed on the destination layer; click Apply only if you want to select an an additional layer to copy shapes to.
Merging Shapes

Merging replaces all shapes on the same layer and touching with combined shapes. This step is especially necessary before doing process offsets with negative values, but should follow the elimination of hierarchy, as described in “Flattening Instances to Eliminate Hierarchy and Connectivity” on page 8-3.

To merge shapes:

1. Select the shapes that you want to merge.
2. Choose Edit > Merge.

Resizing Shapes

You can increases or decreases the outline size of a shape, which is sometimes needed to compensate for a manufacturing process.

To resize shapes:

1. Select the shapes that you want to resize.
2. Choose Edit > Scale/Oversize > Oversize.
3. In the Oversize dialog box, enter (in layout units) how much you want added to or removed from the selected shapes. A positive number increases the size of a shape, a negative number decreases it.
4. Click OK.

Creating a Reverse Image of a Layer

You can create a ground plane or a solder mask that includes the area between shapes, as follows:

1. Copy the desired shapes to a an empty layer.
2. Place a rectangle (that represents the ground plane) over the shapes.
3. Choose Edit > Create Clearance.
4. When prompted, select the rectangle that represents the ground plane, then click OK.
5. In the Create Clearance dialog box that appears, enter any clearance you want for a ground plane (or offset you want added to the final shapes when creating a solder mask).
Importing and Exporting Layouts

6. Select the shapes and click OK.
7. Select and delete the shapes to leave the ground plane/solder mask.

![Image Before Reversal](image1.png) ![Reversed Image](image2.png)

**Translating a Layout**

To export a layout:

1. In the Layout window, choose the command **File > Export**. The Export dialog box appears.

2. From the Export dialog box, select the desired format.

   Only one format can be specified at a time. The format you choose determines which options are available for translation. The options control the program translator.

3. If desired, specify a file name. If no file name is given, the name of the translated design is used. You do not need to specify the file extension.

4. Define any preferences or layer attributes (both in the **Options** menu).

   To specify the GDSII layer number or IGES level number to be used in exporting a design, choose **Options > Layers** to access the Layer Editor. Valid GDSII layer numbers are 0 through 255.

5. To start the translation process, click OK. If no path is specified, the file is written to the current project directory.
Chapter 9: Standard AEL Macros

The AEL macros described here are for layout-only components.

- “conn” on page 9-2
- “cpad2” on page 9-2
- “cpad3” on page 9-3
- “cpad4” on page 9-4
- “pad1” on page 9-5
- “pad3” on page 9-6
- “pad4” on page 9-7
- “padn” on page 9-8
- “rpad2” on page 9-9
- “rpad3” on page 9-10
- “rpad4” on page 9-11
- “spac” on page 9-12
- “spad2” on page 9-12
- “spad3” on page 9-13
- “spad4” on page 9-14
- “tar1” on page 9-15

Additional components for which AEL macros are supplied are documented in the Circuit Components manual.
Standard AEL Macros

**conn**
Port Connection

*Illustration:*

![Diagram of conn](image)

*Parameters:*
None

**cpad2**
Circular Two Pads with Non-Preferred Ports

*Illustration:*

![Diagram of cpad2](image)

*Parameters:*

- \( R \): Radius of the pads
- \( S \): Center-to-center spacing
- LAYER: Layer number
cpad3
Circular Three Pads with Non-Preferred Ports

Illustration:

Parameters:
R1 = Radius of pads 1 and 2
S1 = Center-to-center spacing between pad 1 and 2
R2 = Radius of pad 3
S2 = Vertical distance between pad 2 and 3
LAYER = Layer number
Standard AEL Macros

**cpad4**

Circular Four Pads with Non-Preferred Ports

**Illustration:**

![Diagram of cpad4](image)

**Parameters:**
- \( R_1 \) = Radius of pads 1 and 2
- \( S_1 \) = Center-to-center spacing between pad 1 and 2
- \( R_2 \) = Radius of pads 3 and 4
- \( S_2 \) = Center-to-center spacing between pads 3 and 4
- LAYER = Layer number
**pad1**

Rectangular Two Pads with preferred ports

**Illustration:**

```
   W

S       S

L

1       2
```

**Parameters:**

W = Width  
S = Spacing  
L = Pin 1 to Pin 2  
LAYER = Layer number
pad3

Rectangular Three Pads with preferred ports

Illustration:

Parameters:

W1 = Width of pad at pins 1 and 2
W2 = Width of pad at pin 3
S = Spacing
L1 = Total horizontal length
L2 = Vertical length from pin 1 to pin 3
LAYER = Layer number
**pad4**

Rectangular Four Pads with preferred ports

**Illustration:**

![Diagram of pad4](attachment:pad4_diagram.png)

**Parameters:**

- $W_1$ = Width of pad at pins 1 and 2
- $W_2$ = Width of pad at pins 3 and 4
- $S$ = Spacing (length of pads)
- $L_1$ = Total horizontal length + space
- $L_2$ = Total vertical length from top of pin 4 to bottom of pin 3 + space
- LAYER = Layer number
Standard AEL Macros

padn

N Pads for a dip

Illustration:

Parameters:
PW = Pad width
XS = X-axis spacing between recurrent pads
YS = Y-axis spacing between recurrent pads
NUM = Total number of pads
LAYER = Layer number
rpad2

Rectangular Two Pads with Non-Preferred Ports

Illustration:

Parameters:

\[ W = \text{Width} \]
\[ S = \text{Spacing} \]
\[ L = \text{Total length of the pads + space} \]
\[ \text{LAYER} = \text{Layer number} \]
Standard AEL Macros

**rpad3**

Rectangular Three Pads with Non-Preferred Ports

**Illustration:**

![Diagram of rpad3](image)

**Parameters:**

- \( W_1 \) = Width of pad at pins 1 and 2
- \( W_2 \) = Width of pad at pin 3
- \( S \) = Spacing between pad 1 and pad 2
- \( L_1 \) = Total horizontal length + space
- \( L_2 \) = Vertical length from pin 1 to pin 3 + space
- \( \text{LAYER} \) = Layer number
rp4d

Rectangular Four Pads with Non-Preferred Ports

Illustration:

Parameters:

- W1 = Width of pad at pins 1 and 2
- W2 = Width of pad at pins 3 and 4
- S = Space between pad 1 and pad 2
- L1 = Pin 1 to pin 2
- L2 = Length from pin 4 to pin 3
- LAYER = Layer number
Standard AEL Macros

**spac**

Space

**Illustration:**

```

1 o o 2
\      \   L
\    \   |
\   \   |
\  \  \
\ \ \ |
\ \ \I
```

**Parameter:**

\( L = \) Length

**spad2**

Square Two Pads with Non-Preferred Ports

**Illustration:**

```

W
\|\ P1
|\ P2
|\ L
```

**Parameters:**

\( W = \) Width
\( L = \) Pin 1 to Pin 2
\( \text{LAYER} = \) Layer number
**spad3**

Square Three Pads with Non-Preferred Ports

**Illustration:**

![Diagram of spad3](image)

**Parameters:**

- **W** = Width
- **L** = Pin 1 to Pin 2
- **LAYER** = Layer number
Standard AEL Macros

**spad4**

Square Four Pads with Non-Preferred Ports

**Illustration:**

![Illustration of spad4](image)

**Parameters:**

- $W =$ Width
- $L =$ Pin 1 to Pin 2
- $\text{LAYER} =$ Layer number
Square Pad

**Illustration:**

**Parameter:**

\[ W = \text{Width} \]
Standard AEL Macros
Chapter 10: Fixed Artwork

145MILXP
145 MIL X-PACK
4 ports
package and hole 145 mil diameter
3 leads $30 \times 155.5$ mil, 1 lead $30 \times 391.5$ mil
pads 60 mil square
BJT

145ML4PK
145 MIL FOUR-PACK
4 ports
package and hole 145 mil diameter
4 leads $30 \times 168.7$ mil
pads 60 mil square
BJT
Fixed Artwork

1D2J1A
1-2J1A
2 ports
package 59 × 110.2 mil
2 leads 23.6 × 255.9 mil
2 pads 43.6 mil square
Diode

2D3H1A
2-3H1A
3 ports
flange 98.4 × 338.6 mil
package 98.4 mil square and circle 90 mil diameter
holes 63 mil diameter 240.2 mil center-to-center
2 leads 23.6 × 78.8 mil
2 pads 23.6 mil square
FET
**2D3J1C**

- 2-3J1C
- 4 ports
- SMT
- package $114.4 \times 59$ mil
- 2 short leads $15.8 \times 21.8$ mil, 1 long lead $15.8 \times 33.6$ mil
- collector lead $23.6 \times 53.6$ mil
- pads are lead size plus 10 mil
- BJT

![2D3J1C Diagram](image)

**2D7C1A**

- 2-7C1A
- 3 ports
- flange $236.2 \times 728.4$ mil
- package $236.2 \times 267.8$ mil and $220.4 \times 267.8$ mil
- holes $98.4$ mil diameter spaced $551.2$ mil center-to-center
- 2 leads $27.6 \times 157.5$ mil
- 2 pads $27.6$ mil square
- FET

![2D7C1A Diagram](image)
AFLANGE
(no name given by vendor)
3 ports
flange 820 × 250 mil
holes 120 mil diameter spaced 570 mil center-to-center
leads 50 × 150 mil
pads 50 mil square
FET

AK
AK
5 ports
open flange 976 × 256 mil
holes 130 mil diameter spaced 726 mil center-to-center
leads 60 × 205 mil
pads 60 mil square
FET
**ALMK**
Alignment marker
conductor diameter 30 mil
no ports

**ALMK2**
Alignment marker
conductor diameter 20 mil
no ports
Fixed Artwork

**AP**

AP  
3 ports  
flange $750 \times 250$ mil  
holes $125$ mil diameter $560$ mil center-to-center  
leads $60 \times 200$ mil  
pads $60$ mil square  
FET

**AQ**

AQ  
5 ports  
flange $750 \times 250$ mil  
holes $130$ mil diameter $560$ mil center-to-center  
leads $60 \times 197.5$ mil  
pads $60$ mil square  
FET
**ATF36**

Avantek 36  
4 ports  
SMT  
package 100 mil octagon and 83 mil diameter circle  
leads 20 × 40 mil  
pads 20 mil square  
FET

![ATF36 Diagram]

**ATF70**

Avantek 70  
4 port  
SMT  
package 70 mil square and circle  
2 leads 40 × 212.5 mil, 2 leads 20 × 212.5 mil  
2 pads 40 mil square, 2 pads 20 mil square  
FET

![ATF70 Diagram]
Fixed Artwork

**ATF76**
Avantek 76
4 ports
SMT
package 70 mil octagon and circle
2 leads $40 \times 69$ mil, 2 leads $20 \times 69$ mil
2 pads 40 mil square, 2 pads 20 mil square
FET

![ATF76 Diagram](image)

**ATF84**
Avantek 84
4 ports
package 85 mil diameter
hole 85 mil diameter
leads $20 \times 65$ mil
pads $20 \times 20$ mil
FET

![ATF84 Diagram](image)
**ATF86**

Avantek 86  
4 ports  
SMT  
package 85 mil diameter  
leads 20 × 57.5 mil  
pads 40 × 66.3 mil  
FET

![ATF86 Diagram](image)

**ATCCAP**

Chip capacitor outline  
2 ports  
75 mil port-to-port  
leads 110 × 25 mil  
packages 110 × 75

![ATCCAP Diagram](image)
Fixed Artwork

**AVNK35**
Avantek 35  
4 ports  
SMT  
package 100 mil square  
leads 20 × 175 mil  
pads 40 mil square  
BJT

---

**AVNK70**
Avantek 70  
4 ports  
SMT  
package 70 mil square and circle  
leads 40 × 212.5 mil and leads 20 × 212.5 mil  
pads 40 mil square and pads 20 mil square  
BJT
AVNK85
Avantek 85
4 ports
package and hole 85 mil diameter
leads 20 × 207.5 mil
 pads 40 mil square
BJT

AVNK86
Avantek 86
4 ports
SMT
package 85 mil diameter
leads 20 × 57.5 mil
 pads 40 × 66.3 mil
BJT
**AXIAL_L**
Axial leaded components (large)
2 ports
leads 30 × 325
packages 300 × 770

**AXIAL_M**
Axial leaded components (medium)
2 ports
leads 30 × 270
packages 140 × 390
**AXRES**

Axial leaded components (small)
2 ports
leads 29 × 100 mil
resistor 95 × 249

**AXRES2**

Axial leaded components
2 ports
leads 17.5 × 60 mil
resistor 57 × 150
**AXRES3**
Axial leaded components
2 ports, 500 mil port-to-port
leads 29.2 × 205 mil
resistor

**BFLANGE**
no name given by vendor
3 ports
flange 820 × 250 mil
holes 120 mil diameter 570 mil center-to-center
leads 50 × 170 mil
pads 50 mil square
FET
**C-LL**

Alignment corner marks  
no ports  
conductor 5 mil wide

![C-LL Diagram]

**C-LR**

Alignment corner marks  
no ports  
conductor 5 mil wide

![C-LR Diagram]
Fixed Artwork

**C-UL**

Alignment corner marks  
no ports  
conductor 5 mil wide

---

**C-UR**

Alignment corner marks  
no ports  
conductor 5 mil wide

---
**C145D01**

Motorola Case 145-01
4 ports
stud mount
package 375 mil diameter
hole 325 mil diameter
4 leads 225 × 317.5 mil
3 pads 225 mil square. 1 pad 225 × 205 mil
BJT

![Diagram of C145D01](image)

**C18202**

Motorola Case 182-02
2 ports
package 170 mil diameter cut × 130 mil chord
holes 22 mil diameter and 22 × 20 mil
pads 40 mil square
Diode

![Diagram of C18202](image)
C2003
Motorola Case 20-03
3 ports
case 219.5 mil diameter
holes 21 mil diameter 50 mil from case center
pads 40 mil square
BJT

C211D07
Motorola Case 211-07
4 ports
flange 975 × 250 mil
package 380 mil diameter
holes 120 mil diameter 725 mil center-to-center
leads 220 × 210 mil at 45°
pads 220 × 210 mil
FET
**C211D07V2**

Motorola Case 211-07  
4 ports  
flange $975 \times 250$ mil  
package 380 mil diameter  
holes 120 mil diameter 725 mil center-to-center  
leads $220 \times 210$ mil at $45^\circ$  
pads $220 \times 210$ mil  
BJT

![Diagram of C211D07V2](image.png)

**C221CD02**

Motorola Case 221C-02  
3 ports  
drawn as if flange  
package $398 \times 698$ mil  
hole 145 mil diameter  
3 leads $132 \times 33$ mil and 58 mil  
3 pads $58 \times 132$ mil  
BJT

![Diagram of C221CD02](image.png)
Fixed Artwork

**C244D04**
Motorola Case 244-04
4 ports
stud mount
package 282 mil diameter
hole 250 mil diameter
leads 220 × 294 mil
pads 220 × 220 mil
FET

![Diagram of C244D04](image)

**C249D05**
Motorola Case 249-05
4 ports
package and hole 282 mil diameter
4 leads 220 × 294 mil
4 pads 220 mil square
BJT

![Diagram of C249D05](image)
**C2904**
Motorola Case 29-04
3 ports
package 170 mil diameter cut × 135 mil chord
holes 22 mil diameter and 22 × 20 mil
pads 40 mil square
Diode

![Diagram of C2904](image)

**C30301**
Motorola Case 303-01
4 ports
SMT
100 mil square package
2 leads 40 × 197.5 mil, 2 leads 20 × 197.5 mil
pads 40 mil square
BJT

![Diagram of C30301](image)
Fixed Artwork

**C305D01**
Motorola Case 305-01
4 ports
stud mount
package and hole 210 mil diameter
2 leads $60 \times 330$ mil, 2 leads $30 \times 330$ mil
2 pads 60 mil square, 2 pads 30 mil square
BJT

![Diagram of C305D01](image)

**C317D02**
Motorola Case 317-02
4 ports
190 mil diameter package and hole
1 lead $100 \times 270.5$ mil, 3 leads $36 \times 207.5$ mil
1 pad 100 mil square, 3 pads 72 mil square
BJT

![Diagram of C317D02](image)
C319BD01
Motorola Case 319B-01
5 ports
flange 975 × 233 mil
holes 130 mil diameter 725 mil center-to-center
leads 60 × 130 mil
pads 60 mil square
FET

![Diagram of C319BD01](image)

C319D06
Motorola Case 319-06
3 ports
flange 975 × 233 mil
holes 130 mil diameter 725 mil center-to-center
4 leads 60 × 100 mil, 2 leads 120 × 100 mil (one notch)
4 pads 80 × 100 mil, 1 pad 40 × 120 mil
BJT

![Diagram of C319D06](image)
**C369D03**

Motorola Case 369-03
3 ports
drawn as for flange mount
package 240 × 258 mil
3 leads 30 × 365 mil
2 pads 63 × 118 mil, 1 pad 265 mil square
BJT

![C369D03 diagram]

**C5102**

Motorola Case 51-02
2 ports
package 96 × 265 mil
2 leads 20 × 40 mil (bent)
2 holes 22 mil square
2 pads 44 mil square
Diode

![C5102 diagram]
**C744AD01**

Motorola Case 744A-01
8 ports
flange 385 × 900 mil
package 424 × 400 mil
holes 126 mil diameter 650 mil center-to-center
4 leads 182 × 70 mil, 4 leads 182 × 120 mil
4 pads 70 mil square, 4 pads 120 mil square
BJT

![C744AD01 Diagram]

**C751D03**

Motorola Case 751-03
8 ports
SMT
single device inside
package 192 × 154 mil
8 leads 16.5 × 41.5 mil
8 pads 36.5 mil square
BJT

![C751D03 Diagram]
Fixed Artwork

**C7904**
Motorola Case 79-04
3 ports
package 352.5 mil diameter
holes 21 mil diameter
100 mil from package center
pads 40 mil square
BJT

![Diagram of C7904]

**CD**
CD
4 ports
package 250 mil square
2 leads 100 × 200 mil, 1 lead 90 × 200 mil, 1 lead 50 × 200 mil
2 pads 100 mil square, 1 pad 90 mil square, 1 pad 50 mil square
FET

![Diagram of CD]

---

10-26
CERECX

CEREC-X
4 ports
SMT
package 100.4 mil octagon and 86.6 mil diameter circle
leads 19.7 × 32.5 mil
pads 39.5 mil square
BJT

CERECXF

CEREC-XF
4 ports
SMT
package 70 mil octagon
leads 20 × 47.5 mil
pads 20 mil square
FET
CHPCAP

Surface mount components
conductor 40 × 30 mil
packages 60 × 120 mil
2 ports

CHPRES

2 ports
packages 60 × 120 mil
leads 40 × 30 mil

COIL1

General inductor outline
hand wound coil inductor
2 ports
dia.35 mil
**DISK_L**

Ceramic disk capacitors (large)
2 ports 200 mil port-to-port
packages 140 × 432 mil
leads 24 mil diameter

**DISK_M**

Ceramic disk capacitors (medium)
2 ports 200 mil port-to-port
packages 140 × 300 mil
leads 24 mil diameter
**DISK_S**

Ceramic disk capacitors (small)
2 ports 90 mil port-to-port
packages 140 × 200 mil
leads 24 mil diameter

**GD11**

GD11
4 ports
SMT
package 98.4 mil square and circle
2 leads 39.4 × 196.9 mil, 2 leads 19.7 × 196.9 mil
2 pads 39.4 mil square, 2 pads 19.7 mil square
FET
**GD16**

GD16  
4 ports  
SMT  
package 75 mil octagon  
2 leads 40 × 40 mil, 2 leads 20 × 40 mil  
2 pads 40 mil square, 2 pads 20 mil square  
FET

![Diagram of GD16](image)

**GD4**

GD4  
4 ports  
SMT  
package 75 mil octagon  
2 leads 40 × 157.5 mil, 2 leads 20 × 157.5 mil  
2 pads 40 mil square, 2 pads 20 mil square  
FET

![Diagram of GD4](image)
Fixed Artwork

**GD7**

GD7  
4 ports  
SMT  
package 70 mil square (package is octagonal underneath)  
2 leads 40 × 30 mil, 2 leads 20 × 30 mil  
2 pads 40 mil square, 2 pads 20 mil square  
FET

![GD7 Diagram]

**GD9**

GD9  
4 ports  
SMT  
package 70 mil square  
2 leads 40 × 157.5 mil, 2 leads 20 × 157.5 mil  
2 pads 40 mil square, 2 pads 20 mil square  
FET

![GD9 Diagram]
GF1

GF1
3 ports
flange 327 × 98 mil 10 mil rad corners
package 98 mil square
2 holes 63 mil diameter 213 mil center-to-center
2 leads 24 × 79 mil
2 pads 24 mil square
FET

GF11

GF11
3 ports
open flange 433 × 256 mil
holes 70 mil diameter 362 mil center-to-center
2 leads 20 × 79 mil
2 pads 20 mil square
FET
Fixed Artwork

GF21
GF21
3 ports
open flange 689 × 250 mil 30 mil corners
holes 98.4 mil diameter 563 mil center-to-center
2 leads 39.4 × 157.5 mil
2 pads 39.4 × 39.4 mil
FET

GF4
GF4
3 ports
flange 417 × 138 mil 12 mil corners
package 150 × 98 mil minus indentations
holes 63 mil diameter 264 mil center-to-center
2 leads 24 × 79 mil
2 pads 24 mil square
FET
GF7

GF7
3 ports
flange 551 × 173 mil
package 197 × 173 mil minus indentations
holes 87 mil diameter 354 mil center-to-center
2 leads 24 × 79 mil
2 pads 24 mil square
FET

HP70GT

HPAC-70GT
4 ports
SMT
package 70 mil diameter
2 leads 30 × 165 mil, 2 leads 20 × 165 mil
pads 40 mil square
BJT
Fixed Artwork

**HP85PLAS**

HP85 Plastic
4 ports
package and hole 85 mil diameter
leads 20 × 100.5 mil
pads 40 mil square
BJT

![Diagram of HP85PLAS](image)

**HPAC100**

HPAC100
4 ports
SMT
package 100 mil square and diameter
2 leads 40 × 130 mil, 2 leads 20 × 130 mil
pads 40 mil square
BJT

![Diagram of HPAC100](image)
HPAC100X

HPAC100X
4 ports
SMT
package 100 mil octagon and 83 mil diameter circle
4 leads $20 \times 150$ mil
pads 40 mil square
BJT

HPAC200

HPAC200
4 ports
package and hole 200 mil diameter
leads enter package at 128 mil diameter
2 leads $60 \times 200$ mil, 2 leads $30 \times 200$ mil
pads 60 mil square
BJT
Fixed Artwork

**HPAC200V2**
HPAC200
4 ports
package and hole 200 mil diameter
leads enter package at 128 mil diameter
2 leads 60 × 200 mil, 2 leads 30 × 200 mil
pads 60 mil square
BJT

**LG**
LG
4 ports
SMT
package 70 mil octagon
2 leads 40 × 59 mil, 2 leads 20 × 59 mil
2 pads 40 mil square, 2 pads 20 mil square
FET
LLD

LLD
2 ports
SMT
package 114.2 × 53.2 mil
2 leads 11.8 × 53.2 mil
2 pads 31.8 × 73.2 mil
Diode

M205

M205
2 ports
SMT
package 60 × 106.3 mil
2 leads 21.7 × 21.5 mil
2 pads 41.7 × 41.5 mil
Diode
Fixed Artwork

**M253**

- M253
- 4 ports
- SMT
- package 70 mil octagon
- 2 leads $40 \times 59$ mil, 2 leads $20 \times 59$ mil
- 2 pads 40 mil square, 2 pads 20 mil square
- FET

**MACROT**

- MACRO-T
- 3 ports
- package and hole 190 mil diameter
- 2 pins $36 \times 207.5$ mil, 1 pin $36 \times 337.5$ mil
- pads 72 mil square
- BJT
MACROX

MACRO-X
4 ports
package and hole 190 mil diameter
3 pins 36 × 207.5 mil, 1 pin 36 × 337.5 mil
pads 72 mil square
BJT

ME

ME
3 ports
flange 630 × 197 mil
package 197 mil square
holes 87 mil diameter 472 mil center-to-center
2 leads 39 × 79 mil
2 pads 39 mil square
FET
**MICROX**

MICRO-X  
4 ports  
SMT  
package 100 mil octagon and 83 mil diameter circle  
leads 20 × 177.5 mil  
pads 40 mil square  
BJT

![diagram](index_cut)

**MOP**

Mini Octal Package  
8 ports  
SMT  
package 185.4 × 59 mil  
8 leads 25 × 15.8 mil  
8 pads 45 × 35.8 mil  
Diode

![diagram](c3 a5 c2 e5)

10-42
**MW4**

MW4  
4 ports  
SMT  
package 51.2 \times 114.2 \text{ mil}  
2 leads 31.5 \times 25.6 \text{ mil}, 2 leads 15.8 \times 25.6 \text{ mil}  
2 pads 51.5 \times 45.6 \text{ mil}, 2 pads 35.8 \times 45.6 \text{ mil}  
FET

![ MW4 Diagram ]

**MWT70**

MWT70  
4 ports  
SMT  
package 70 \text{ mil square and circle}  
2 leads 40 \times 200 \text{ mil}, 2 leads 20 \times 200 \text{ mil}  
2 pads 40 \text{ mil square}, 2 pads 20 \text{ mil square}  
FET

![ MWT70 Diagram ]
Fixed Artwork

**MWT71**

MWT71
3 ports
flange $335 \times 98$ mil
package 98 mil square
holes 63 mil diameter 240 mil center-to-center
2 leads $24 \times 201$ mil
2 pads 24 mil square
FET

**MWT73**

MWT73
4 ports
SMT
package 70 mil octagon and circle
2 leads $40 \times 157$ mil, 2 leads $20 \times 157$ mil
2 pads 40 mil square, 2 pads 20 mil square
FET
**NEC01**

NEC01
3 ports
package 275.6 mil diameter circle cut to 244 mil width
1 lead 59 × 78.8 mil, 1 lead 59 mil square
1 pad 59 mil square, 1 pad 59 × 78.8 mil
emitter on bottom
BJT

![NEC01 Diagram]

**NEC03**

NEC03
4 ports
SMT
package 137.8 mil diameter
2 leads 78.7 × 196.9 mil, 2 leads 39.4 × 196.9 mil
pads 78.7 mil square
BJT

![NEC03 Diagram]
Fixed Artwork

NEC07
NEC07
4 ports
SMT
package 98.4 mil square and circle
2 leads 39.4 × 196.9 mil, 2 leads 19.7 × 196.9 mil
pads 39.4 mil square
BJT

NEC08
NEC08
4 ports
SMT
package 78.7 mil square
leads 23.6 × 196.9 mil
pads 47.2 mil square
BJT
**NEC12**

NEC12  
3 ports  
package 229.9 mil diameter  
holes 17.8 mil diameter  
50 mil from package center  
pads 40 mil square  
BJT

![NEC12 Diagram]

**NEC13**

NEC13  
3 ports  
package 370.1 mil diameter  
holes 17.8 mil diameter  
100 mil from package center  
pads 40 mil square  
BJT

![NEC13 Diagram]
Fixed Artwork

**NEC14**

NEC14
3 ports
package 370.1 mil diameter
holes 17.8 mil diameter
100 mil from package center
pads 40 mil square
BJT

**NEC15**

NEC15
3 ports
package 370.1 mil diameter
holes 17.8 mil diameter
100 mil from package center
pads 40 mil square
BJT
**NEC18**

NEC18  
4 ports  
SMT  
package $49.2 \times 78.7$ mil  
3 leads $11.8 \times 15.8$ mil, 1 lead 15.8 mil square  
3 pads 31.8 mil square

![NEC18 Diagram](image)

**NEC19**

NEC19  
3 ports  
SMT  
package $31.5 \times 63$ mil  
2 leads $7.9 \times 15.8$ mil, 1 lead $11.8 \times 15.8$ mil  
BJT

![NEC19 Diagram](image)
**NEC20**

NEC20  
4 ports  
stud mount  
package and hole 295.3 mil diameter  
4 leads $78.8 \times 196.9$ mil  
4 pads 78.8 mil square  
BJT

**NEC30**

NEC30  
3 ports  
SMT  
package $49.3 \times 78.8$ mil  
leads $11.8 \times 16.7$ mil  
pads $31.9 \times 36.8$ mil  
BJT
NEC32
NEC32
3 ports
package 204.7 mil diameter circle cut × 149.9 mil chord
total y-axis height 165.4 mil
holes 19.7 mil diameter 69.7 mil down from chord spaced 50 mil center-to-center
pads 40 mil square
BJT

NEC33
NEC33
3 ports
SMT
package 115 × 51 mil
leads 16.5 × 21.5 mil
pads 41.5 × 39.4 mil
BJT
Fixed Artwork

**NEC34**

NEC34  
3 ports  
SMT  
package 177.2 x 97.7 mil  
2 leads 16.5 x 33.1 mil and 27.6 x 64.4 mil  
2 pads 39.4 x 59.1 mil  
BJT

![NEC34 Diagram](image)

**NEC35**

NEC35  
4 ports  
SMT  
package 100.4 mil octagon and 82.7 mil diameter circle  
leads 19.7 x 149.6 mil  
pads 39.4 mil square  
BJT

![NEC35 Diagram](image)
**NEC37**

NEC37
4 ports
package and hole 149.6 mil diameter
3 leads $23.6 \times 157.5$ mil, 1 lead $23.6 \times 393.7$ mil
pads 47.2 mil square
BJT

**NEC38**

NEC38
4 ports
SMT
package 70 mil octagon
leads $20 \times 43.5$ mil
pads 20 mil square
FET
**NEC39**

NEC39  
4 ports  
SMT  
package 59.1 x 114.2 mil  
3 leads 15.7 x 25.6 mil, 1 lead 23.6 x 25.6 mil  
pads are leads ±10 mil xy  
BJT

![Diagram of NEC39](image)

**NEC53E**

NEC53E  
3 ports  
flange 800 x 250 mil  
holes 130 mil diameter 563 mil center-to-center  
1 lead 30 x 210 mil, 1 lead 115 x 210 mil  
1 pad 30 mil square, 1 pad 115 mil square  
BJT

![Diagram of NEC53E](image)
**NEC75**

NEC75  
3 ports  
flange 385.8 × 90.6 mil  
holes 70.8 mil diameter 275.6 mil center-to-center  
2 leads 19.6 × 118.1 mil  
2 pads 19.6 mil square  
FET

**NEC83**

NEC83  
4 ports  
SMT  
package 70 mil square  
2 leads 40 × 157.5 mil, 2 leads 20 × 157.5 mil  
2 pads 40 mil square, 2 pads 20 mil square  
FET
**NEC84**

NEC84  
4 ports  
SMT  
package 70 mil octagon  
leads 20 × 157.5 mil  
pads 20 mil square  
FET

---

**NEC84A**

NEC84A  
4 ports  
SMT  
package 70 mil octagon  
leads 20 × 157.5 mil  
pads 20 mil square  
FET
**NEC87**

NEC87  
3 ports  
package $114.2 \times 137.8$ mil octagon  
2 leads $23.6 \times 196.9$ mil  
2 pads $23.6$ mil square  
collector on bottom  
BJT

![NEC87 Diagram](image)

**NEC89**

NEC89  
4 ports  
SMT  
package 80 mil octagon  
2 leads $80 \times 157.5$ mil, 2 leads $20 \times 157.5$ mil  
2 pads 20 mil square, 2 pads 80 mil square  
FET

![NEC89 Diagram](image)
**NEC89A**

NEC89A  
4 ports  
SMT  
package 80 mil octagon  
2 leads 80 × 157.5 mil, 2 leads 20 × 157.5 mil  
2 pads 20 mil square, 2 pads 80 mil square  
FET

![Diagram of NEC89A](image)

**OKI_1**

(no name given by vendor)  
3 ports  
package and hole 130 × 185 mil  
2 leads 19.7 × 78.8 mil  
2 pads 19.7 mil square  
2 support bars 5 × 20 mil  
FET

![Diagram of OKI_1](image)
**PFLANGE**

(no name given by vendor)
5 ports
flange 820 × 250 mil
holes 120 mil diameter 570 mil center-to-center
leads 60 × 200 mil
pads 60 mil square
FET

**RADIAL_L**

Radial leaded components
2 ports 400 mil port-to-port
packages 140 × 480 mil
leads 28 mil diameter
Fixed Artwork

**RADIAL_M**
Radial leaded components
2 ports 200 mil port-to-port
packages 90 × 290 mil
leads 28 mil diameter

**RADIAL_S**
Radial leaded components
2 ports 200 mil port-to-port
packages 90 × 190 mil
leads 28 mil diameter
RESA

Chip resistor
2 ports 30 mil port-to-port
packages 20 × 30 mil
resi 20 × 50 mil

SFLANGE

(no name given by vendor)
4 ports
flange 975 × 250 mil
package 380 mil diameter
holes 120 mil diameter 725 mil center-to-center
leads 220 × 210 mil at 45°
pads 220 × 210 mil
FET
Fixed Artwork

**SMA_FEM**

SMA connector outline female
no ports
conductor
cond2
leads

---

**SMSMICROX**

Siemens MICRO-X
4 ports
SMT
package 70 mil octagon
2 leads 20 × 47.5 mil, 2 leads 40 × 47.5 mil
2 pads 20 mil square, 2 pads 40 mil square
FET
WARNING: NOT identical to MICROX

---

10-62
**SOD123**

SOD123  
2 ports  
SMT  
package $61 \times 106.3$ mil  
2 leads $19.7 \times 23.6$ mil  
2 pads $39.7 \times 43.6$ mil  
Diode

---

**SOD323**

SOD323  
2 ports  
SMT  
package $49.2 \times 98.6$ mil  
2 leads $11.8 \times 15.8$ mil  
2 pads $31.8 \times 35.8$ mil  
Diode
Fixed Artwork

**SOD80**

SOD80  
2 ports  
SMT  
package $63 \times 137.8$ mil  
2 leads $11.8 \times 63$ mil  
2 pads $31.8 \times 83$ mil  
Diode

![Diode SOD80 Diagram]

**SOT103**

SOT103  
4 ports  
package and hole $189$ mil diameter  
3 leads $45.3 \times 200.8$ mil  
1 lead $45.3 \times 318.9$ mil  
pads $90.6$ mil square  
BJT

![BJT SOT103 Diagram]
SOT143

SOT143
4 ports
SMT
package 51 × 115 mil
3 leads 16 × 20 mil, 1 lead 32 × 20 mil
3 pads 40 × 39.4 mil, 1 pad 55.2 × 40 mil
BJT

SOT143R

SOT143R
4 ports
SMT
package 51 × 115 mil
3 leads 16 × 20 mil, 1 lead 32 × 20 mil
3 pads 40 × 39.4 mil, 1 pad 55.2 × 40 mil
BJT
**SOT143RV2**

SOT143  
4 ports  
SMT  
package 51 × 115 mil  
3 leads 16 × 20 mil, 1 lead 32 × 20 mil  
3 pads 40 × 39.4 mil, 1 pad 55.2 × 40 mil  
BJT

![SOT143RV2 Diagram](port-4)

**SOT143V2**

SOT143  
4 ports  
SMT  
package 51 × 115 mil  
3 leads 16 × 20 mil, 1 lead 32 × 20 mil  
3 pads 40 × 39.4 mil, 1 pad 55.2 × 40 mil  
BJT

![SOT143V2 Diagram](port-4)
SOT143V3
SOT143
4 ports
SMT
package 51 × 115 mil
3 leads 16 × 20 mil, 1 lead 32 × 20 mil
3 pads 40 × 39.4 mil, 1 pad 55.2 × 40 mil
Diode

SOT143V4
SOT143
4 ports
SMT
package 51 × 115 mil
3 leads 16 × 20 mil, 1 lead 32 × 20 mil
3 pads 40 × 39.4 mil, 1 pad 55.2 × 40 mil
Diode
**SOT143V5**

SOT143
4 ports
SMT
package $51 \times 115$ mil
3 leads $16 \times 20$ mil, 1 lead $32 \times 20$ mil
3 pads $40 \times 39.4$ mil, 1 pad $55.2 \times 40$ mil
Diode
SOT143V6

SOT143
4 ports
SMT
package 51 × 115 mil
3 leads 16 × 20 mil, 1 lead 32 × 20 mil
3 pads 40 × 39.4 mil, 1 pad 55.2 × 40 mil
Diode
SOT143V7
SOT143
4 ports
SMT
package 51 × 115 mil
3 leads 16 × 20 mil, 1 lead 32 × 20 mil
3 pads 40 × 39.4 mil, 1 pad 55.2 × 40 mil
Diode
**SOT223**

SOT223  
4 ports  
SMT  
package $255.9 \times 137.8$ mil  
3 leads $27.6 \times 68.9$ mil, 1 lead $118.1 \times 68.9$ mil  
3 pads $98.5 \times 59.2$ mil, 1 pad $78.9 \times 149.6$ mil  
BJT

**SOT223V2**

SOT223  
3 ports  
SMT  
package $255.9 \times 137.8$ mil  
3 leads $27.6 \times 68.9$ mil, 1 lead $118.1 \times 68.9$ mil  
3 pads $98.5 \times 59.2$ mil, 1 pad $78.9 \times 149.6$ mil  
Diode
**SOT23**

SOT23
3 ports
SMT
package 115 × 51 mil
leads 16.5 × 21.5 mil
pads 41.5 × 39.4 mil
BJT

![SOT23 Diagram]

**SOT23V2**

SOT23
2 ports
SMT
package 115 × 51 mil
leads 16.5 × 21.5 mil
pads 41.5 × 39.4 mil
Diode

![SOT23V2 Diagram]
**SOT23V3**

SOT23
2 ports
SMT
package $115 \times 51$ mil
leads $16.5 \times 21.5$ mil
pads $41.5 \times 39.4$ mil
Diode

---

**SOT23V4**

SOT23
2 ports
SMT
package $115 \times 51$ mil
leads $16.5 \times 21.5$ mil
pads $41.5 \times 39.4$ mil
Diode
Fixed Artwork

**SOT23V5**

SOT23
3 ports
SMT
package 115 × 51 mil
leads 16.5 × 21.5 mil
pads 41.5 × 39.4 mil
Diode

**SOT23V6**

SOT23
3 ports
SMT
package 115 × 51 mil
leads 16.5 × 21.5 mil
pads 41.5 × 39.4 mil
Diode
**SOT23V7**

SOT23  
3 ports  
SMT  
package 115 × 51 mil  
leads 16.5 × 21.5 mil  
pads 41.5 × 39.4 mil  
Diode

**SOT23V8**

SOT23  
3 ports  
SMT  
package 115 × 51 mil  
leads 16.5 × 21.5 mil  
pads 41.5 × 39.4 mil  
Diode
**SOT323**

SOT323  
3 ports  
SMT  
package 78.6 × 49.4 mil  
leads 11.8 × 16.8 mil  
pads 31.8 × 36.8 mil  
BJT

**SOT37**

SOT37  
3 ports  
package and hole 189 mil diameter  
2 leads 41.3 × 200.8 mil  
1 lead 41.3 × 318.9 mil  
pads 82.6 mil square  
BJT
SOT89

SOT89
3 ports
SMT
package 177.2 × 97.7 mil
2 leads 16.5 × 33.1 mil
collector lead 18.6 × 33.1 mil and 27.6 × 64.64 mil
2 pads 59.1 × 39.4 mil
BJT

SOT89V2

SOT89
3 ports
SMT
package 177.2 × 97.7 mil
2 leads 16.5 × 33.1 mil
collector lead 18.6 × 33.1 mil and 27.6 × 64.64 mil
2 pads 59.1 × 39.4 mil
BJT
Fixed Artwork

**SRP**

SRP
2 ports
SMT
package $63 \times 104.3$ mil
2 leads $22.6 \times 23.6$ mil
2 pads $42.6 \times 43.6$ mil
Diode

**TO117**

TO117
4 ports
stud mount package and hole $295.3$ diameter
2 leads $157.5 \times 393.7$ mil, 2 leads $59.1 \times 393.7$ mil
2 pads $59.1$ mil square, 2 pads $157.5$ mil square
BJT
**TO206AA**

TO206AA  
3 ports  
package 219.5 mil diameter  
holes 21 mil diameter 50 mil from package center  
pads 40 mil square  
BJT

**TO206AF**

TO206AF  
3 ports  
package 219.5 mil diameter  
holes 21 mil diameter 50 mil from package center  
pads 40 mil square  
BJT
Fixed Artwork

**TO226AA**

TO226AA
3 ports
package 170 mil diameter cut \( \times \) 135 mil chord
holes 22 mil diameter and 22 \( \times \) 20 mil
pads 40 mil square
BJT

**TO39**

TO39
3 ports
package 352.5 mil diameter
holes 21 mil diameter 100 mil from package center
pads 40 mil square
BJT
TO72

TO72
3 ports
package 225.4 mil diameter
holes 21 mil diameter 50 mil from center
pads 40 mil square
BJT

TO72V2

TO72V2
3 ports
package 225.4 mil diameter
holes 21 mil diameter 50 mil from center
pads 40 mil square
BJT
Fixed Artwork

**TO92**

3 ports
package 170 mil diameter cut × 135 mil chord
holes 22 mil diameter and 22 × 20 mil
pads 40 mil square
BJT

**TPLAST**

3 ports
package and hole 181.1 mil diameter
2 leads 35.4 × 196.85 mil, 1 lead 35.4 × 315 mil
pads 70.8 mil square
BJT
TUNCAP
Tunable chip capacitor
2 ports 75 mil port-to-port
leads 110 × 25 mil
packages 12 × 62
dielectric 110 × 115

UMD
UMD
2 ports
package 63 × 102.4 mil
2 leads 15.8 × 31.6 mil (bent)
2 pads 40 mil square
2 holes 20 mil square
Diode
**UPRIGHT**

Upright mounted variable resistor
no ports
packages 170 × 250 mil
Text

![Diag1](image1.png)

**URP**

URP
2 ports
SMT
package 52 × 70 mil
2 leads 10 × 15 mil
2 pads 30 × 35 mil
Diode

![Diag2](image2.png)
**WIRE0**

Wire loop outline
2 ports 133.5 mil port-to-port
conductor 15 mil wide × 47 mil
dielectric

![Diagram of WIRE0](image1)

**WIRE1**

one turn coil outline
2 ports 330 mil port-to-port
dielectric 35 mil wide

![Diagram of WIRE1](image2)
Fixed Artwork
Chapter 11: SMT Package Layout Artwork Library

The SMT Package Layout Artwork Library (SMT PAL) defines the SMT package artwork for some of the most commonly-used packages. The SMT PAL consists of 131 artwork packages of 7 different types:

- Ceramic Flat Pack (CFP)
- Chip and MELF components
- SOT, DPAK and D2PAK
- Plastic Flat Pack (PFP)
- Quad Flat Pack (QFP)
- Plastic Leaded Chip Carrier (PLCC)
- Small Outline IC (SOIC)

This chapter describes the library, including the package type and name, the AEL interface function name (AEL macro name), and the dimensions of the package. A diagram is shown for each package type.

This chapter also describes how you can use the SMT PAL to define the SMT package artwork in a custom `create_item` and how you can use the AEL macro name defining the package artwork as an artwork replacement for sub-circuits or sub-systems.
Using SMT PAL for Custom Components

This section describes how to use SMT package artwork for a custom component. An example of this process uses the AEL function defining the SMT package artwork in the SMT PAL. This artwork is used in the SMT component libraries: capacitors, resistors, inductors, amplifiers, filters, and mixers. In the SMT amplifier library, the layout artwork (SOT143 package) for HP’s Model No. MSA-2111 uses the SMT PAL primitive AEL function in the following sequence:

- The AEL `create_item` function calls the AEL macro function `sa_hp_SOT143`. The AEL macro function `sa_hp_SOT143` is located in the library artwork file `SMT_AmplifierLibrary_artwork.ael`.

- In turn, `sa_hp_SOT143` calls the primitive AEL function `smtart_draw_SMT`. The primitive AEL function `smtart_draw_SMT` is located in the SMT PAL file `smtart.ael`.

- Then the AEL function `smtart_draw_SMT` passes the parameters that are necessary for customizing the artwork, as shown in Figure 11-1.

```lisp
defun sa_hp_SOT143 (de_set_global_db_factor(), smtpad, smtpad2, offset)
{
  decl initialD1, initialD2, portS2x, port3Y;
  //initialD1 = 0.5 * (0.00293 - 0.0017125 - 0.5*0.00085 - 0.5*0.000455);
  //initialD2 = 0.5 * (0.00293 - 0.00191 - 0.5*0.000455 - 0.5*0.000455);
  initialD1 = 0.0002825;
  initialD2 = 0.0002825;
  portS2x = 0.0013 + 2 * (0.0005375 - 0.5*0.000455);

  smtart_draw_SMT (list(smtpad,smtpad2),offset,0.0013,0.00293,0,0,
                  list(0.0017125,0,0.00191,0), list(initialD1,0,initialD2,0),
                  list(2,0,2,0), list(0.000455, 0.0005375, 0.00085, 0.0005375, NULL,
                   0.000455, 0.0005375, 0.000455, 0.0005375, NULL, "side1"),
                  list(0,-90, 0,0.00191,-90.0, portS2x,-0.0017125,90,
                   portS2x,0.0,90,0,"mts", "portOpt6",0,
                   list(1,3)));
}
```

Figure 11-1. Example of Customizing Artwork Using the AEL Function `smtart_draw_smt`
Using SMT Package Artwork as Artwork Replacement

The procedure for using the SMT package artwork as an artwork replacement is similar to using the standard artwork replacements. In the Design Parameters dialog box, change the artwork type to AEL macro and define the two parameters, SMTPAD and OFFSET. Set the SMTPAD parameter type to string.

**Note** Some packages require two SMTPAD parameters in the Parameters dialog box.

Figure 11-2 shows an example for using the SMT package layout artwork library AEL function as an artwork replacement, through the Parametric Subnetwork (PSN). Underlying the network psn_smt is the element S3P, that can be viewed by pushing into the component. In the Design Parameters dialog for the parametric subnetwork, psn_smt, the Artwork Type is set to AEL macro and Name is set to smtart_SOT23. Two parameters, SMTPAD and OFFSET, are defined in the Design Parameters dialog. For the parameter SMTPAD, set the type to string, with the default value *. For the parameter OFFSET, set the type to real, with a default value 0.

Figure 11-2. SMT Artwork Replacement Examples

For more information, refer to “Associating Artwork with an Item” on page 7-12.
Ceramic Flat Pack (CFP) Packages

Table 11-1 lists 17 CFP packages and the associated layout artwork AEL macro name and dimensions for each package. Figure 11-3 shows the layout artwork for a typical CFP with the marked dimensions given in the table.

Table 11-1. Ceramic Flat Pack (CFP) Packages

<table>
<thead>
<tr>
<th>Part Name</th>
<th>AEL Macro Name</th>
<th>Package Width (mm)</th>
<th>Package Length (mm)</th>
<th>Lead Width (mm)</th>
<th>Lead Length (mm)</th>
<th>Lead-lead Spacing (mm)</th>
</tr>
</thead>
<tbody>
<tr>
<td>CFP24</td>
<td>smtart_CFP24</td>
<td>15.36</td>
<td>9.65</td>
<td>0.43</td>
<td>7.87</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP28</td>
<td>smtart_CFP28</td>
<td>18.78</td>
<td>9.14</td>
<td>0.43</td>
<td>7.87</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP42</td>
<td>smtart_CFP42</td>
<td>27.16</td>
<td>16.24</td>
<td>0.43</td>
<td>7.61</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP10-03</td>
<td>smtart_CFP10_03</td>
<td>7.36</td>
<td>3.81</td>
<td>0.305</td>
<td>2.74</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP10-04</td>
<td>smtart_CFP10_04</td>
<td>7.36</td>
<td>3.81</td>
<td>0.431</td>
<td>2.74</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP14-04</td>
<td>smtart_CFP14_04</td>
<td>9.9</td>
<td>3.81</td>
<td>0.305</td>
<td>2.74</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP16-04</td>
<td>smtart_CFP16_04</td>
<td>11.17</td>
<td>6.35</td>
<td>0.431</td>
<td>2.47</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP16-21</td>
<td>smtart_CFP16_21</td>
<td>11.17</td>
<td>13.96</td>
<td>0.431</td>
<td>3.16</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP20-22</td>
<td>smtart_CFP20_22</td>
<td>13.71</td>
<td>6.5</td>
<td>0.431</td>
<td>2.89</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP24-19</td>
<td>smtart_CFP24_19</td>
<td>16.25</td>
<td>8.88</td>
<td>0.431</td>
<td>3.20</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP24-21</td>
<td>smtart_CFP24_21</td>
<td>16.25</td>
<td>13.96</td>
<td>0.431</td>
<td>3.16</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP28-19</td>
<td>smtart_CFP28_19</td>
<td>18.79</td>
<td>8.88</td>
<td>0.508</td>
<td>3.20</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP36-20</td>
<td>smtart_CFP36_20</td>
<td>23.87</td>
<td>11.42</td>
<td>0.431</td>
<td>2.93</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP36-21</td>
<td>smtart_CFP36_21</td>
<td>23.87</td>
<td>13.96</td>
<td>0.431</td>
<td>3.16</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP36-23</td>
<td>smtart_CFP36_23</td>
<td>23.87</td>
<td>21.57</td>
<td>0.431</td>
<td>2.86</td>
<td>1.27</td>
</tr>
<tr>
<td>CFP40-20</td>
<td>smtart_CFP40_20</td>
<td>26.41</td>
<td>11.42</td>
<td>0.431</td>
<td>2.93</td>
<td>1.27</td>
</tr>
</tbody>
</table>
Table 11-2 lists 15 chip component packages and 4 MELF components, and the associated layout artwork AEL macro name and dimensions for each package. Figure 11-4 shows the layout artwork for a typical chip component, 0402, with the marked dimensions given in the table.

Table 11-2. Chip and MELF Component Packages

<table>
<thead>
<tr>
<th>Part Name</th>
<th>AEL Macro Name</th>
<th>Package Width (mm)</th>
<th>Package Length (mm)</th>
<th>End-cap Termination Width (mm)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0402</td>
<td>smtart_0402</td>
<td>0.508</td>
<td>1.00</td>
<td>0.127</td>
<td>Resistor</td>
</tr>
<tr>
<td>0603-Res</td>
<td>smtart_0603R</td>
<td>0.787</td>
<td>1.55</td>
<td>0.305</td>
<td>Resistor</td>
</tr>
<tr>
<td>0603-Cap</td>
<td>smtart_0603C</td>
<td>0.787</td>
<td>1.55</td>
<td>0.203</td>
<td>Capacitor</td>
</tr>
<tr>
<td>0805</td>
<td>smtart_0805</td>
<td>1.22</td>
<td>2.01</td>
<td>0.457</td>
<td>Resistor or capacitor</td>
</tr>
<tr>
<td>1005</td>
<td>smtart_1005</td>
<td>1.27</td>
<td>2.54</td>
<td>0.254</td>
<td>Capacitor</td>
</tr>
</tbody>
</table>
Table 11-2. Chip and MELF Component Packages (continued)

<table>
<thead>
<tr>
<th>Part Name</th>
<th>AEL Macro Name</th>
<th>Package Width (mm)</th>
<th>Package Length (mm)</th>
<th>End-cap Termination Length (mm)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1206</td>
<td>smtart_1206</td>
<td>1.57</td>
<td>3.20</td>
<td>0.558</td>
<td>Resistor or capacitor</td>
</tr>
<tr>
<td>1210</td>
<td>smtart_1210</td>
<td>2.49</td>
<td>3.20</td>
<td>0.558</td>
<td>Resistor or capacitor</td>
</tr>
<tr>
<td>1805</td>
<td>smtart_1805</td>
<td>1.27</td>
<td>4.57</td>
<td>0.305</td>
<td>Capacitor</td>
</tr>
<tr>
<td>1808</td>
<td>smtart_1808</td>
<td>2.03</td>
<td>4.57</td>
<td>0.305</td>
<td>Capacitor</td>
</tr>
<tr>
<td>1812</td>
<td>smtart_1812</td>
<td>3.17</td>
<td>4.57</td>
<td>0.305</td>
<td>Capacitor</td>
</tr>
<tr>
<td>1825</td>
<td>smtart_1825</td>
<td>6.35</td>
<td>4.57</td>
<td>0.305</td>
<td>Capacitor</td>
</tr>
<tr>
<td>2010</td>
<td>smtart_2010</td>
<td>2.54</td>
<td>5.1</td>
<td>0.40</td>
<td>Capacitor</td>
</tr>
<tr>
<td>2220</td>
<td>smtart_2220</td>
<td>5.08</td>
<td>5.58</td>
<td>1.27</td>
<td>Capacitor</td>
</tr>
<tr>
<td>2225</td>
<td>smtart_2225</td>
<td>6.35</td>
<td>5.58</td>
<td>1.27</td>
<td>Capacitor</td>
</tr>
<tr>
<td>2512</td>
<td>smtart_2512</td>
<td>3.2</td>
<td>6.3</td>
<td>0.40</td>
<td>Capacitor</td>
</tr>
<tr>
<td>2309</td>
<td>smtart_2309</td>
<td>2.3</td>
<td>5.9</td>
<td>1.0</td>
<td>MELF</td>
</tr>
<tr>
<td>1406</td>
<td>smtart_1406</td>
<td>1.55</td>
<td>3.5</td>
<td>0.80</td>
<td>MELF</td>
</tr>
<tr>
<td>SOD-80</td>
<td>smtart_SOD80</td>
<td>1.60</td>
<td>3.5</td>
<td>0.431</td>
<td>MELF</td>
</tr>
<tr>
<td>SOD-87</td>
<td>smtart_SOD87</td>
<td>1.6</td>
<td>3.5</td>
<td>0.30</td>
<td>MELF</td>
</tr>
</tbody>
</table>

Note: The pads have been omitted in the figure.

Figure 11-4. Chip Component Layout Artwork
SOT, DPAK, D2PAK Packages

Table 11-3 lists 20 SOT, DPAK, and D2PAK packages and the associated layout artwork AEL macro name and dimensions for each package.

Some packages require 2 SMTPAD parameters in the Parameters dialog box. An asterisk (*) denotes that the artwork requires 2 SMTPAD components. If lead 1 (e.g., SOT143) is of a different dimension than the other leads, the first SMTPAD identifies lead 1. If a lead other than lead 1 (e.g., DPAK1) is of a different dimension, then the second SMTPAD identifies the lead of a different dimension.

Figure 11-5 shows the layout artwork for a typical SOT-23 package with the marked dimensions given in the table.

Table 11-3. SOT, DPAK, D2PAK Packages

<table>
<thead>
<tr>
<th>Part Name</th>
<th>AEL Macro Name</th>
<th>Package Width (mm)</th>
<th>Lead 1 Width (mm)</th>
<th>Other Leads Width (mm)</th>
<th>Lead-lead Spacing Side 1 (mm)</th>
<th>Side 2 (mm)</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOT-23</td>
<td>smtart_SOT23</td>
<td>2.92</td>
<td>1.30</td>
<td>0.45</td>
<td>0.51</td>
<td>1.90</td>
</tr>
<tr>
<td>SOT-23,</td>
<td>smtart_SOT23M1</td>
<td>2.92</td>
<td>1.50</td>
<td>0.45</td>
<td>0.50</td>
<td>1.90</td>
</tr>
<tr>
<td>Metric</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SOT-23,</td>
<td>smtart_SOT23M2</td>
<td>2.92</td>
<td>1.50</td>
<td>0.45</td>
<td>0.65</td>
<td>1.90</td>
</tr>
<tr>
<td>Metric</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SOT-23,</td>
<td>smtart_SOT23M3</td>
<td>1.60</td>
<td>0.80</td>
<td>0.30</td>
<td>0.40</td>
<td>1.00</td>
</tr>
<tr>
<td>Metric</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SOT-23,</td>
<td>smtart_SOT23M4</td>
<td>2.00</td>
<td>1.25</td>
<td>0.30</td>
<td>0.43</td>
<td>1.30</td>
</tr>
<tr>
<td>Metric</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SOT-23,</td>
<td>smtart_SOT23M5</td>
<td>2.90</td>
<td>1.30</td>
<td>0.40</td>
<td>0.55</td>
<td>1.90</td>
</tr>
<tr>
<td>Metric</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SOT-25</td>
<td>smtart_SOT25A</td>
<td>2.92</td>
<td>1.50</td>
<td>0.30</td>
<td>0.65</td>
<td>1.90</td>
</tr>
<tr>
<td>SOT-25</td>
<td>smtart_SOT25B</td>
<td>2.00</td>
<td>0.90</td>
<td>0.20</td>
<td>0.60</td>
<td>1.30</td>
</tr>
<tr>
<td>SOT-25</td>
<td>smtart_SOT25C</td>
<td>2.00</td>
<td>1.25</td>
<td>0.20</td>
<td>0.43</td>
<td>0.65</td>
</tr>
<tr>
<td>SOT-25</td>
<td>smtart_SOT25D</td>
<td>2.90</td>
<td>1.60</td>
<td>0.30</td>
<td>0.60</td>
<td>0.95</td>
</tr>
<tr>
<td>SOT-36</td>
<td>smtart_SOT36</td>
<td>2.90</td>
<td>1.60</td>
<td>0.30</td>
<td>0.60</td>
<td>0.95</td>
</tr>
<tr>
<td>SOT-143*</td>
<td>smtart_SOT143A</td>
<td>2.90</td>
<td>1.30</td>
<td>0.88</td>
<td>0.75</td>
<td>1.70</td>
</tr>
<tr>
<td>SOT-143*</td>
<td>smtart_SOT143B</td>
<td>2.90</td>
<td>1.30</td>
<td>0.88</td>
<td>0.60</td>
<td>1.70</td>
</tr>
</tbody>
</table>

Note: An asterisk (*) denotes that the artwork requires 2 SMTPAD components.
Table 11-3. SOT, DPAK, D2PAK Packages (continued)

<table>
<thead>
<tr>
<th>Part Name</th>
<th>AEL Macro Name</th>
<th>Package</th>
<th>Lead 1</th>
<th>Other Leads</th>
<th>Lead-lead Spacing</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Width (mm)</td>
<td>Length (mm)</td>
<td>Width (mm)</td>
<td>Length (mm)</td>
</tr>
<tr>
<td>SOT-223*</td>
<td>smtart_SOT223</td>
<td>6.50</td>
<td>3.50</td>
<td>3.00</td>
<td>1.75</td>
</tr>
<tr>
<td>DPAK*</td>
<td>smtart_DPAK1</td>
<td>5.00</td>
<td>5.50</td>
<td>5.20</td>
<td>2.79</td>
</tr>
<tr>
<td>DPAK*</td>
<td>smtart_DPAK2</td>
<td>5.50</td>
<td>5.50</td>
<td>5.20</td>
<td>12.0</td>
</tr>
<tr>
<td>DPAK*</td>
<td>smtart_DPAK3</td>
<td>6.09</td>
<td>6.09</td>
<td>5.20</td>
<td>2.74</td>
</tr>
<tr>
<td>DPAK*</td>
<td>smtart_DPAK4</td>
<td>5.87</td>
<td>6.10</td>
<td>4.83</td>
<td>2.74</td>
</tr>
<tr>
<td>DPAK*</td>
<td>smtart_DPAK5</td>
<td>8.15</td>
<td>5.82</td>
<td>5.38</td>
<td>4.45</td>
</tr>
<tr>
<td>D2PAK*</td>
<td>smtart_D2PAK</td>
<td>10.41</td>
<td>9.96</td>
<td>0.71</td>
<td>4.83</td>
</tr>
</tbody>
</table>

Note: An asterisk (*) denotes that the artwork requires 2 SMTPAD components.

Figure 11-5. SOT-23 Layout Artwork
Plastic Flat Pack (PFP) Packages

Table 11-4 lists 3 Plastic Flat Pack (PFP) packages and the associated layout artwork AEL macro name and dimensions for each package. Figure 11-6 shows the layout artwork for a PFP with the marked dimensions given in the table.

Table 11-4. Plastic Flat Pack (PFP) Packages

<table>
<thead>
<tr>
<th>Part Name</th>
<th>AEL Macro Name</th>
<th>Package Width (mm)</th>
<th>Package Length (mm)</th>
<th>Lead Width (mm)</th>
<th>Lead Length (mm)</th>
<th>Lead-lead Spacing (mm)</th>
</tr>
</thead>
<tbody>
<tr>
<td>PFP-16</td>
<td>smtart_PFP16</td>
<td>10.18</td>
<td>6.85</td>
<td>0.43</td>
<td>8.88</td>
<td>1.27</td>
</tr>
<tr>
<td>PFP-18</td>
<td>smtart_PFP18</td>
<td>11.04</td>
<td>7.79</td>
<td>0.43</td>
<td>7.87</td>
<td>1.27</td>
</tr>
<tr>
<td>PFP-20</td>
<td>smtart_PFP20</td>
<td>15.49</td>
<td>9.27</td>
<td>0.43</td>
<td>7.72</td>
<td>1.27</td>
</tr>
</tbody>
</table>

Note: The pads have been omitted in the figure.

Figure 11-6. Plastic Flat Pack (PFP) Layout Artwork

Quad Flat Pack (QFP) Packages

Table 11-5 lists 48 Quad Flat Pack (QFP) and the associated layout artwork AEL macro name and dimensions for each package. Figure 11-7 shows the layout artwork for a typical QFP package with the marked dimensions given in the table.
### Table 11-5. Quad Flat Pack (QFP) Packages

<table>
<thead>
<tr>
<th>Part Name</th>
<th>AEL Macro Name</th>
<th>Package Width (mm)</th>
<th>Lead Width (mm)</th>
<th>Lead Length (mm)</th>
<th>Lead-lead Spacing (mm)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>QFP32A</td>
<td>smtart_QFP32A</td>
<td>7.0</td>
<td>0.3</td>
<td>1.0</td>
<td>0.8</td>
<td>8 leads/side</td>
</tr>
<tr>
<td>QFP32B</td>
<td>smtart_QFP32B</td>
<td>5.0</td>
<td>0.2</td>
<td>1.0</td>
<td>0.5</td>
<td>8 leads/side</td>
</tr>
<tr>
<td>QFP40A</td>
<td>smtart_QFP40A</td>
<td>6.0</td>
<td>0.2</td>
<td>1.0</td>
<td>0.5</td>
<td>10 leads/side</td>
</tr>
<tr>
<td>QFP40B</td>
<td>smtart_QFP40B</td>
<td>5.0</td>
<td>0.15</td>
<td>1.0</td>
<td>0.4</td>
<td>10 leads/side</td>
</tr>
<tr>
<td>QFP40C</td>
<td>smtart_QFP40C</td>
<td>7.0</td>
<td>0.2</td>
<td>1.0</td>
<td>0.5</td>
<td>12 × 8 leads</td>
</tr>
<tr>
<td>QFP44A</td>
<td>smtart_QFP44A</td>
<td>10.5</td>
<td>0.3</td>
<td>1.5</td>
<td>0.8</td>
<td>11 leads/side</td>
</tr>
<tr>
<td>QFP44B</td>
<td>smtart_QFP44B</td>
<td>10.1</td>
<td>0.3</td>
<td>1.1</td>
<td>0.8</td>
<td>11 leads/side</td>
</tr>
<tr>
<td>QFP44C</td>
<td>smtart_QFP44C</td>
<td>10.6</td>
<td>0.3</td>
<td>1.9</td>
<td>0.8</td>
<td>11 leads/side</td>
</tr>
<tr>
<td>QFP44D</td>
<td>smtart_QFP44D</td>
<td>10.0</td>
<td>0.3</td>
<td>1.61</td>
<td>0.8</td>
<td>11 leads/side</td>
</tr>
<tr>
<td>QFP44E</td>
<td>smtart_QFP44E</td>
<td>10.0</td>
<td>0.41</td>
<td>1.99</td>
<td>0.8</td>
<td>11 leads/side</td>
</tr>
<tr>
<td>QFP44F</td>
<td>smtart_QFP44F</td>
<td>14.0</td>
<td>0.35</td>
<td>1.61</td>
<td>1.0</td>
<td>11 leads/side</td>
</tr>
<tr>
<td>QFP48A</td>
<td>smtart_QFP48A</td>
<td>12.7</td>
<td>0.3</td>
<td>2.3</td>
<td>0.8</td>
<td>12 leads/side</td>
</tr>
<tr>
<td>QFP48B</td>
<td>smtart_QFP48B</td>
<td>12.0</td>
<td>0.3</td>
<td>1.65</td>
<td>0.8</td>
<td>12 leads/side</td>
</tr>
<tr>
<td>QFP48C</td>
<td>smtart_QFP48C</td>
<td>7.0</td>
<td>0.2</td>
<td>1.0</td>
<td>0.5</td>
<td>12 leads/side</td>
</tr>
<tr>
<td>QFP48D</td>
<td>smtart_QFP48D</td>
<td>6.0</td>
<td>0.15</td>
<td>1.0</td>
<td>0.4</td>
<td>12 leads/side</td>
</tr>
<tr>
<td>QFP52A</td>
<td>smtart_QFP52A</td>
<td>16.7</td>
<td>0.3</td>
<td>2.3</td>
<td>1.0</td>
<td>13 leads/side</td>
</tr>
<tr>
<td>QFP52B</td>
<td>smtart_QFP52B</td>
<td>10.0</td>
<td>0.3</td>
<td>1.61</td>
<td>0.65</td>
<td>13 leads/side</td>
</tr>
<tr>
<td>QFP52C</td>
<td>smtart_QFP52C</td>
<td>10.0</td>
<td>0.3</td>
<td>2.05</td>
<td>0.65</td>
<td>13 leads/side</td>
</tr>
<tr>
<td>QFP52D</td>
<td>smtart_QFP52D</td>
<td>7.0</td>
<td>0.15</td>
<td>1.0</td>
<td>0.40</td>
<td>16 × 10 leads</td>
</tr>
<tr>
<td>QFP54</td>
<td>smtart_QFP5</td>
<td>11.2</td>
<td>0.3</td>
<td>1.6</td>
<td>0.65</td>
<td>14 × 13 leads</td>
</tr>
<tr>
<td>QFP56</td>
<td>smtart_QFP56</td>
<td>11.5</td>
<td>0.3</td>
<td>1.5</td>
<td>0.65</td>
<td>14 leads/side</td>
</tr>
<tr>
<td>QFP60A</td>
<td>smtart_QFP60A</td>
<td>14.0</td>
<td>0.4</td>
<td>2.1</td>
<td>0.8</td>
<td>15 leads/side</td>
</tr>
<tr>
<td>QFP60B</td>
<td>smtart_QFP60B</td>
<td>10.0</td>
<td>0.2</td>
<td>1.0</td>
<td>0.5</td>
<td>12 × 18 leads</td>
</tr>
<tr>
<td>QFP64A</td>
<td>smtart_QFP64A</td>
<td>15</td>
<td>0.35</td>
<td>1.3</td>
<td>0.8</td>
<td>16 leads/side</td>
</tr>
<tr>
<td>QFP64B</td>
<td>smtart_QFP64B</td>
<td>19.4</td>
<td>0.4</td>
<td>1.3</td>
<td>1.0</td>
<td>13 × 19 leads</td>
</tr>
<tr>
<td>QFP64C</td>
<td>smtart_QFP64C</td>
<td>15.3</td>
<td>0.35</td>
<td>1.5</td>
<td>0.8</td>
<td>16 leads/side</td>
</tr>
<tr>
<td>QFP64D</td>
<td>smtart_QFP64D</td>
<td>21.3</td>
<td>0.41</td>
<td>1.7</td>
<td>1.0</td>
<td>13 × 19 leads</td>
</tr>
</tbody>
</table>
Table 11-5. Quad Flat Pack (QFP) Packages (continued)

<table>
<thead>
<tr>
<th>Part Name</th>
<th>AEL Macro Name</th>
<th>Package Width (mm)</th>
<th>Package Length (mm)</th>
<th>Lead Width (mm)</th>
<th>Lead Length (mm)</th>
<th>Lead-lead Spacing (mm)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>QFP64E</td>
<td>smtart_QFP64E</td>
<td>22.8</td>
<td>22.8</td>
<td>0.457</td>
<td>10.15</td>
<td>1.27</td>
<td>16 leads/side</td>
</tr>
<tr>
<td>QFP64F</td>
<td>smtart_QFP64F</td>
<td>14.0</td>
<td>14.0</td>
<td>0.381</td>
<td>1.61</td>
<td>0.8</td>
<td>13 × 19 leads</td>
</tr>
<tr>
<td>QFP64G</td>
<td>smtart_QFP64G</td>
<td>14.0</td>
<td>14.0</td>
<td>0.356</td>
<td>1.18</td>
<td>0.8</td>
<td>16 leads/side</td>
</tr>
<tr>
<td>QFP64H</td>
<td>smtart_QFP64H</td>
<td>20.0</td>
<td>14.0</td>
<td>0.432</td>
<td>1.61</td>
<td>1.0</td>
<td>13 × 19 leads</td>
</tr>
<tr>
<td>QFP64I</td>
<td>smtart_QFP64I</td>
<td>7.0</td>
<td>7.0</td>
<td>0.15</td>
<td>1.0</td>
<td>0.4</td>
<td>16 leads/side</td>
</tr>
<tr>
<td>QFP70</td>
<td>smtart_QFP70</td>
<td>23.6</td>
<td>10.4</td>
<td>0.3</td>
<td>2.5</td>
<td>0.8</td>
<td>11 × 24 leads</td>
</tr>
<tr>
<td>QFP72</td>
<td>smtart_QFP72</td>
<td>10.0</td>
<td>10.0</td>
<td>0.2</td>
<td>1.0</td>
<td>0.5</td>
<td>18 leads/side</td>
</tr>
<tr>
<td>QFP74</td>
<td>smtart_QFP74</td>
<td>20.6</td>
<td>20.6</td>
<td>0.4</td>
<td>1.3</td>
<td>1.0</td>
<td>18 × 19 leads</td>
</tr>
<tr>
<td>QFP76</td>
<td>smtart_QFP76</td>
<td>10.0</td>
<td>7.0</td>
<td>0.15</td>
<td>1.0</td>
<td>0.4</td>
<td>15 × 23 leads</td>
</tr>
<tr>
<td>QFP80A</td>
<td>smtart_QFP80A</td>
<td>14.0</td>
<td>14.0</td>
<td>0.3</td>
<td>1.6</td>
<td>0.65</td>
<td>20 leads/side</td>
</tr>
<tr>
<td>QFP80B</td>
<td>smtart_QFP80B</td>
<td>20.0</td>
<td>14.0</td>
<td>0.35</td>
<td>1.8</td>
<td>0.8</td>
<td>16 × 24 leads</td>
</tr>
<tr>
<td>QFP80C</td>
<td>smtart_QFP80C</td>
<td>20.0</td>
<td>14.0</td>
<td>0.35</td>
<td>2.35</td>
<td>0.8</td>
<td>16 × 24 leads</td>
</tr>
<tr>
<td>QFP80D</td>
<td>smtart_QFP80D</td>
<td>14.0</td>
<td>14.0</td>
<td>0.3</td>
<td>1.18</td>
<td>0.65</td>
<td>20 × 20 leads/side</td>
</tr>
<tr>
<td>QFP80E</td>
<td>smtart_QFP80E</td>
<td>20.0</td>
<td>14.0</td>
<td>0.36</td>
<td>2.1</td>
<td>0.8</td>
<td>16 × 24 leads</td>
</tr>
<tr>
<td>QFP80F</td>
<td>smtart_QFP80F</td>
<td>20.0</td>
<td>14.0</td>
<td>0.36</td>
<td>1.6</td>
<td>0.8</td>
<td>16 × 24 leads</td>
</tr>
<tr>
<td>QFP80G</td>
<td>smtart_QFP80G</td>
<td>12.0</td>
<td>12.0</td>
<td>0.203</td>
<td>1.0</td>
<td>0.5</td>
<td>20 × 20 leads/side</td>
</tr>
<tr>
<td>QFP88A</td>
<td>smtart_QFP88A</td>
<td>20.0</td>
<td>14.0</td>
<td>0.3</td>
<td>2.5</td>
<td>0.65</td>
<td>18 × 26 leads</td>
</tr>
<tr>
<td>QFP88B</td>
<td>smtart_QFP88B</td>
<td>12.0</td>
<td>12.0</td>
<td>0.2</td>
<td>1.0</td>
<td>0.5</td>
<td>22 leads/side</td>
</tr>
<tr>
<td>QFP88C</td>
<td>smtart_QFP88C</td>
<td>10.0</td>
<td>10.0</td>
<td>0.15</td>
<td>1.0</td>
<td>0.4</td>
<td>22 leads/side</td>
</tr>
<tr>
<td>QFP88D</td>
<td>smtart_QFP88D</td>
<td>14.0</td>
<td>10.0</td>
<td>0.2</td>
<td>1.0</td>
<td>0.5</td>
<td>18 × 26 leads</td>
</tr>
<tr>
<td>QFP94</td>
<td>smtart_QFP94</td>
<td>20.6</td>
<td>20.6</td>
<td>0.35</td>
<td>1.3</td>
<td>0.8</td>
<td>23 × 24 × 23 × 24 leads</td>
</tr>
</tbody>
</table>
Plastic Leaded Chip Carrier (PLCC)

Table 11-6 lists 11 Plastic Leaded Chip Carrier (PLCC) packages and the associated layout artwork AEL macro name and dimensions for each package. Figure 11-8 shows the layout artwork for a typical PLCC package with the marked dimensions given in the table.

Table 11-6. Plastic Leaded Chip Carrier (PLCC) Packages

<table>
<thead>
<tr>
<th>Part Name</th>
<th>AEL Macro Name</th>
<th>Package Width (mm)</th>
<th>Package Length (mm)</th>
<th>Lead Width (mm)</th>
<th>Lead-lead Spacing (mm)</th>
</tr>
</thead>
<tbody>
<tr>
<td>PLCC18AA</td>
<td>smtart_PLCC18A A</td>
<td>10.85</td>
<td>7.32</td>
<td>0.431</td>
<td>1.27</td>
</tr>
<tr>
<td>PLCC18AB</td>
<td>smtart_PLCC18 AB</td>
<td>12.52</td>
<td>7.42</td>
<td>0.431</td>
<td>1.27</td>
</tr>
<tr>
<td>PLCC20SQ</td>
<td>smtart_PLCC20 SQ</td>
<td>8.13</td>
<td>8.13</td>
<td>0.431</td>
<td>1.27</td>
</tr>
<tr>
<td>PLCC22RT</td>
<td>smtart_PLCC22 RT</td>
<td>11.62</td>
<td>6.54</td>
<td>0.431</td>
<td>1.27</td>
</tr>
<tr>
<td>PLCC28RT</td>
<td>smtart_PLCC28 RT</td>
<td>12.94</td>
<td>7.87</td>
<td>0.431</td>
<td>1.27</td>
</tr>
<tr>
<td>PLCC28SQ</td>
<td>smtart_PLCC28 SQ</td>
<td>10.67</td>
<td>10.67</td>
<td>0.431</td>
<td>1.27</td>
</tr>
<tr>
<td>PLCC32RT</td>
<td>smtart_PLCC32 RT</td>
<td>12.95</td>
<td>10.67</td>
<td>0.431</td>
<td>1.27</td>
</tr>
</tbody>
</table>
Table 11-6. Plastic Leaded Chip Carrier (PLCC) Packages (continued)

<table>
<thead>
<tr>
<th>Part Name</th>
<th>AEL Macro Name</th>
<th>Package Width (mm)</th>
<th>Package Length (mm)</th>
<th>Lead Width (mm)</th>
<th>Lead-lead Spacing (mm)</th>
</tr>
</thead>
<tbody>
<tr>
<td>PLCC44SQ</td>
<td>smtart_PLCC44 SQ</td>
<td>15.48</td>
<td>15.48</td>
<td>0.431</td>
<td>1.27</td>
</tr>
<tr>
<td>PLCC52SQ</td>
<td>smtart_PLCC52 SQ</td>
<td>18.02</td>
<td>18.02</td>
<td>0.431</td>
<td>1.27</td>
</tr>
<tr>
<td>PLCC68SQ</td>
<td>smtart_PLCC68 SQ</td>
<td>23.10</td>
<td>23.10</td>
<td>0.431</td>
<td>1.27</td>
</tr>
<tr>
<td>PLCC84SQ</td>
<td>smtart_PLCC84 SQ</td>
<td>28.17</td>
<td>28.17</td>
<td>0.431</td>
<td>1.27</td>
</tr>
</tbody>
</table>

Note: The pads have been omitted in the figure.

Figure 11-8. Plastic Leaded Chip Carrier (PLCC) Layout Artwork
Small Outline IC (SOIC)

Table 11-7 lists 13 Small Outline IC (SOIC) packages and the associated layout artwork AEL macro name and dimensions for each package. Figure 11-9 shows the layout artwork for a typical SOIC package with the marked dimensions given in the table.

<table>
<thead>
<tr>
<th>Part Name</th>
<th>AEL Macro Name</th>
<th>Package Width (mm)</th>
<th>Package Length (mm)</th>
<th>Lead Width (mm)</th>
<th>Lead Length (mm)</th>
<th>Lead-lead Spacing (mm)</th>
</tr>
</thead>
<tbody>
<tr>
<td>SO8N</td>
<td>smtart_SO8N</td>
<td>3.90</td>
<td>4.87</td>
<td>0.432</td>
<td>1.05</td>
<td>1.27</td>
</tr>
<tr>
<td>SO14N</td>
<td>smtart_SO14N</td>
<td>3.90</td>
<td>8.63</td>
<td>0.432</td>
<td>1.05</td>
<td>1.27</td>
</tr>
<tr>
<td>SO16N</td>
<td>smtart_SO16N</td>
<td>3.90</td>
<td>9.90</td>
<td>0.432</td>
<td>1.05</td>
<td>1.27</td>
</tr>
<tr>
<td>SO14M</td>
<td>smtart_SO14M</td>
<td>5.59</td>
<td>9.910</td>
<td>0.432</td>
<td>1.01</td>
<td>1.27</td>
</tr>
<tr>
<td>SO16M</td>
<td>smtart_SO16M</td>
<td>5.59</td>
<td>11.20</td>
<td>0.457</td>
<td>1.01</td>
<td>1.27</td>
</tr>
<tr>
<td>SO8L</td>
<td>smtart_SO8L</td>
<td>7.50</td>
<td>5.20</td>
<td>0.432</td>
<td>1.40</td>
<td>1.27</td>
</tr>
<tr>
<td>SO14L</td>
<td>smtart_SO14L</td>
<td>7.50</td>
<td>9.010</td>
<td>0.432</td>
<td>1.40</td>
<td>1.27</td>
</tr>
<tr>
<td>SO16L</td>
<td>smtart_SO16L</td>
<td>7.50</td>
<td>10.30</td>
<td>0.432</td>
<td>1.40</td>
<td>1.27</td>
</tr>
<tr>
<td>SO18L</td>
<td>smtart_SO18L</td>
<td>7.50</td>
<td>11.55</td>
<td>0.432</td>
<td>1.40</td>
<td>1.27</td>
</tr>
<tr>
<td>SO20L</td>
<td>smtart_SO20L</td>
<td>7.50</td>
<td>12.80</td>
<td>0.432</td>
<td>1.40</td>
<td>1.27</td>
</tr>
<tr>
<td>SO24L</td>
<td>smtart_SO24L</td>
<td>7.50</td>
<td>15.37</td>
<td>0.432</td>
<td>1.40</td>
<td>1.27</td>
</tr>
<tr>
<td>SO28L</td>
<td>smtart_SO28L</td>
<td>7.50</td>
<td>17.92</td>
<td>0.432</td>
<td>1.40</td>
<td>1.27</td>
</tr>
<tr>
<td>SO32L</td>
<td>smtart_SO32L</td>
<td>7.50</td>
<td>20.50</td>
<td>0.432</td>
<td>1.70</td>
<td>1.27</td>
</tr>
</tbody>
</table>
Figure 11-9. Small Outline IC (SOIC) Package Layout Artwork
SMT Package Layout Artwork Library
Chapter 12: Font Definitions

din17

```
abcdefghijkl
mnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ

' 1234567890-=|
~!@#$%^&*( )_-+
[ ]()<>;:'",./?
```

iso3098

```
abcdefghijkl
mnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ

' 1234567890-=|
~!@#$%^&*( )_-+
[ ]()<>;:'",./?
```
Font Definitions

roman

abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789
!"#$%&'()*+,-.;:===?[]^_`{|}~

smooth

abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789
!"#$%&'()*+,-.;:===?[]^_`{|}~

12-2 roman
Font Definitions

gothic

math
Font Definitions

**filled**

`abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ`  
`1234567890-=`
`~!@#$%^&*()_+`  
`[]{}<>;:'",./?`

**filledbold**

`abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ`  
`1234567890-=`
`~!@#$%^&*()_+`  
`[]{}<>;:'",./?`
straight

abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
\1234567890-=|
~!@#$%^&*()_+\
[\]{}<>;ः".,/?

straightfilled

abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
\1234567890-=|
~!@#$%^&*()_+\
[\]{}<>;ः".,/?
Font Definitions

12-8  straightfilled
Index

A
Add command, 6-9
AEL
macro artwork examples, 9-1
AEL macro artwork, 7-13
AEL_PATH, 3-29
Always Design Synchronize command, 3-22
And command (Edit > Merge), 6-3
angles
snapping, 2-18
arc/circle
center, and snap mode, 2-19
arcs
converting from vertices, 6-10
deleting from a polyline, 6-10
arithmetic rounding errors
DRC, 2-31
artwork
adding pins/ports, 7-5
AEL macro, 7-13
associating with an item, 7-12
connection, 7-3
creating, 1-7
creating elements with, 5-1
creating hierarchical designs for repeated use, 3-28
custom, 7-4
fixed, 7-12, 10-1
flattening hierarchical designs before generating, 6-15
layout or schematic only object, 7-5
space, 7-2
supplied, 7-4
supplied AEL macros, 7-1
supplied fixed, 7-1
synchronized, 7-12
viewing, 3-29
attributes
entry/edit, changing, 2-24
layer, modifying, 2-4

B
Bill of Materials
 generating for RF PCB designs, 4-29
Boolean logical commands
AND, 6-26
DIFF, 6-25
OR, 6-26
XOR, 6-27
Break command, 6-6

C
Change Entry Layer To command, 2-6
Change Layer To command, 1-3
Check Representation command, 4-23, 4-28, 6-16
clearance
creating, 6-27
closed shapes
selecting, 2-13
colors
and layers, 2-10
changing display, 2-29
drawing area, setting for, 2-29
pin/tee connections, setting, 2-23
setting, 2-14
unconnected pins, setting for, 2-29
Component Parameter dialog
toggling display of, 2-21
Component Text Attributes command, 6-23
custom
changing layers, 2-8
connecting in layout, 6-16
connecting with wires in layout, 3-16
copying, 2-21
custom
creating, 1-7
editing, 1-6
IDs, setting layers for, 2-27
inserting, 3-2
Instance Names, changing, 6-23
layout
creating custom, 1-7
names, setting layers for, 2-27
overlaid/overlapping, 6-17
placement, toggling, 2-21
placing, 2-21
at specific coordinates, 3-3
simultaneously in layouts and schematics, 3-22
Index-2
translation, 8-2
Explode command, 6-5

**F**
filling
   and layers, 2-11
patterns, HPGL, 2-11
filters
   selection, changing, 6-1
Fix Component Position command, 4-20
fixed artwork, 7-12
Flatten command, 6-15
Flatten Hierarchy command, 3-27
flattening
   components, 8-3
   instances, 8-3
flipping components
   effect on generated layout, 3-23
Force To Grid command, 6-15
Free Component Position command, 4-20
fringe setting
   DRC, 2-31

**G**
gaps
   in layouts, unintentional, 3-16
GDSII
   numbers, using, 2-8
   stream files
      and layer numbers, 2-10
      exporting, 2-10
      reading and writing, 2-8
generating
   artwork
      and Flatten command, 3-27
grids
   color, setting, 2-16
forcing objects onto, 6-15
   setting preferences for layout, 2-15
snap modes, 2-19
   spacing of, 2-20
spacing, setting, 2-16
visibility, setting, 2-16
grounds
   setting size of, 2-22

**H**
hierarchical designs
   advantages of, 3-23
   and layer definitions, 2-9
   and parameters, 3-23
   and schematic considerations, 3-24
   creating, 3-23, 3-26
      for repeated use, 3-28
      parametric subnetworks, 3-24
   editing, 6-15
   flattening, 3-27, 6-15
   flattening before generating final artwork
      for, 6-15
   matching, 3-24
   via design generation, 3-25
   viewing hierarchy of, 3-27
hierarchies
   changing display of, 2-32
   flattening, 8-3
   of translated layouts, 8-2
   removing, 8-3
   smashing, 8-3
Hierarchy command, 3-27
Hierarchy dialog, 3-27
holes
   from polygons, 6-26
HP Graphical Cell Compiler, 1-7

**I**
IGES
   numbers, using, 2-8
Import command, 8-2
   instances
      flattening, 8-3
      smashing, 8-3
items
   creating layout-only objects, 5-1
   creating simulation, 5-1
defining, 5-2

**J**
Join command, 6-5
junctions
   schematic/layout concerns, 4-8

**L**
layer files, 2-36, 2-37
   and design files, 2-9
   format of, 2-10
   layout.lay, 2-10
schematic.lay, 2-10
layers
  adding, 2-6
  and visibility, 2-11
  binding, 2-11
  changing defaults, 2-8
  component text, 2-27
  creating
    reverse images of, 8-5
  default, 2-1
  defaults, 2-4
  defining, 2-1, 2-10
    and ensuring compatibility, 2-9
  definitions, 2-1
  deleting, 2-6
  existing file, using, 2-38
  item selectability, changing, 2-7
  item visibility, changing, 2-7
  limits, 2-1
  names, 2-10
  numbers, 2-9, 2-10
    and GDSII stream format, 2-10
    changing, 2-9
  port connections, defining, 2-7
  priority of, changing, 2-5
  protecting, 2-7, 2-11
  rearranging, 2-5
  removing, 2-8
  type, 2-11
  visibility, 2-1
layout.lay, 2-9, 2-10
layout-driven simulation
  overview, 1-1
layouts
  constraints, 1-1
  creating, 3-1
    along with schematics, 3-22
    directly, 3-2
    from schematics, 3-22
  environment, 3-1
  existing setups, using, 2-37
  exporting, 8-1, 8-3
  files
    layout.lay, 2-9
  global attributes, setting, 2-1
  hierarchical, 3-23
  importing, 8-1, 8-2
libraries, and defining layers, 2-8
  preferences, saving, 2-36
  preparing for translation, 8-3
  removing hierarchy, 8-3
  repeated use of, 3-23
  resolution units
    setting, 2-34
  setups, saving, 2-36
  translated
    and hierarchies, 8-2
    saving, 8-2
  translated, opening and viewing, 8-2
  translating, 8-6
  units, specifying size of, 2-14, 2-22
  updating, 1-1
libraries
  component
    defining layers for, 2-8
  components, defining layers for, 2-8
  layout
    reusable, 3-29
    sharing between designs, 3-29
  of commonly used items, 3-29
  reusable designs, defining search path for, 3-30
  search path, 3-29
licenses
  for Design Rule Checker, 1-7
  releasing, 1-7
lines
  styles, 2-1
listing
  all design files, 3-23
logical commands
  AND, 6-26
  DIFF, 6-25
  OR, 6-26
  XOR command, 6-27
M
  macros
    creating artwork using, 7-8
  manufacturing processes
    compensating for, 8-5
  markers
    connection, setting, 2-22
  masks
and layout layers, 2-1
Meander Trace command, 3-12
memory management
DRC, 2-31
midpoint snap, 2-19
Miter command, 6-11
mitered edges from vertices, 6-11
models
   editing, 1-6
Move command, vertex, 6-10
Move Edge command, 6-22

N
networks
   creating parametric. See hierarchical designs
   storage of, 3-29
   nodal mismatches, 6-16

O
objects
   moving, 6-14
   scaling, 6-8
Or command (Edit > Merge), 6-3
Oversize command (scaling), 6-8

P
parameterized designs, 3-24
parts list
   generating for RF PCB designs, 4-29
paths
   changing attributes of existing, 6-21
   converting from traces, 6-21
   converting to traces, 6-21
   described, 3-14
   inserting, 3-14
physical designs, compiling, 1-7
Pick and Place Report, 2-38
pick regions
   setting, 2-14
PickPlaceReportOptions, 2-38
pins, 3-3
   changing options of, 2-22
   connected
      identifying, 3-3
   connections
      setting color of, 2-23
   identifying connected and unconnected, 3-3
   multiple, representing single port, 7-5
   snapping, 2-18
   unconnected
      identifying, 3-3
      visibility, setting, 2-23
   pins/tees, setting size of, 2-22
   Place Components From Layout To Schem command, 4-18
   Place Components From Schem To Layout command, 4-18
   Place Unplaced Item command, 4-27
   placement options
      always design synchronize, 2-21
      dual representation, 2-20
      selecting, 2-20
      single representation, 2-20
   plotting
      a closed object, 2-11
   polygon
      selection of, 2-13
   polygons
      converting into holes, 6-26
      creating using the DIFF command, 6-25
      entry mode, 2-24
      manipulating, 6-2
      self intersection checking, 2-24
   polylines
      drawing, 3-4
      manipulating, 6-2
   Pop Out of Item command, 3-29
   ports
      connections, defining, 2-7
      setting size of, 2-22
   positional coordinate readout, 1-5, 2-35
   precision
      changing, 6-14
   preferences
      existing file, using, 2-37
      file, 2-36, 2-37
      file, reading, 2-37
   Print command, 3-27
   process offsets
      adding, 8-4
   Push Into Item command, 3-28

R
real memory
DRC, 2-31
Release Layout License command, 1-7
resolution
setting, 2-34
resolution of curved shapes, 2-25
reverse images
creating, 8-5
RF PCB designs
automatic design synchronization, 4-26
considerations, 4-25
creating the board, system setup, 4-25
exporting the PCB layout, 4-29
fixing part placement and back annotation, 4-27
generating a report, 4-29
interactive layout, manual layout, 4-26
interactive placement, 4-27
layout vs. schematic nodal mismatch, 4-28
part and library creation, 4-29
trace simulation, 4-28
rotating components
effect on generated layout, 3-23
rotation
increment, setting, 2-26

S
saving
automatically, 2-26
Scale command, 6-8
scaling, 6-8
factors, setting, 2-33
schematic.lay, 2-10
schematics
creating
from a layout, 1-1
updating, 1-1
screen pixels
specifying size of, 2-14, 2-15, 2-22
search paths
defining for libraries of reusable designs, 3-30
library, 3-29
modifying, 3-30
Select command, 2-13
self intersections
checking for polygons, setting, 2-24
Set Origin command, 4-25, 6-14
shapes
copying to new layers, 8-4
defining display of, 2-1
displaying, 2-1
drawing, 3-1, 3-4
by entering coordinates, 3-5
ingoing, 1-6, 6-1, 6-2
inserting
in a layout, 1-4
merging, 3-4, 8-5
moving to a different layer, 6-12
resizing, 8-5
selecting, 6-1
stretching, 3-4
stretching edges of, 6-7
terminating draw command, 3-4
Show Connected command, 4-28
Show Equivalent Component command, 4-2
Show Equivalent Item command, 4-28
Show Fixed Components command, 4-20
Show Unplaced Items command, 4-28
simulation
models
defining design characteristics, 5-3
defining parameters, 5-7
described, 5-5
SIMULATOR_AEL, 3-29
single representation, 2-20
slivers
eliminating, 2-26
smash instances, 8-3
SMT Package Layout Artwork Library, 11-1
snap modes
layout, setting for, 2-17
priority of, setting, 2-18, 2-19
spacing, setting, 2-16
snapping to pins, 6-16
spikes
eliminating, 2-26
Squeeze Transmission Line Keeping
Length command, 6-19
steps
schematic/layout concerns, 4-9
storage per area
DRC memory management, 2-31
Stretch command, 6-7
subnetworks
assigning symbols to, 3-28

Index-6
Symbols
- To represent designs, 3-28
- Representations, 2-21
- Synchronizing designs, 4-1
- Synchronize representations, 2-21
- Synchronized artwork, 7-12
- Synchronizing designs, 4-1

Tap Transmission Line command, 6-18
- Tapers
- Schematic/layout concerns, 4-9
- Tees
- And transmission lines, 6-18
- Changing options, 2-22
- Connections, setting color of, 2-23
- Schematic/layout concerns, 4-8

Text
- Adding to designs, 3-17
- Changing attributes of, 3-17
- Component
- Setting attributes of, 2-27
- Component, changing attributes of, 6-23
- Components
- Setting layers for, 2-27
- Editing, 3-17, 6-14
- Fonts and height, setting, 2-27
- Moving to a different layer, 6-12
- Typed-in, changing attributes, 2-28

To Arc command, 6-10
- Traces
- Changing attributes of existing, 6-21
- Converting
- Explicitly, 3-9
- To paths, 6-21
- Converting from paths, 6-21
- Converting from wires, 6-22
- Described, 3-6
- Meandering, 3-12
- Rerouting when moving, 2-25
- Simulating as transmission lines, 3-11
- To represent electrical connectivity, 3-4

Translating
- Layouts, 8-6
- Translation errors, 8-2

Transmission lines
- Converting traces to explicitly, 3-9
- Editing, 6-17
- Elements
- Assigning layers for, 2-8
- Splitting, 6-17
- Stretching, 6-18
- Tapping and replacing with a tee, 6-18

U
Unconnected pins
- Finding, 4-22

Undo command, 2-26
- Undo edits
- Setting count for, 2-26

Undo Vertex command, 3-5
- Units
- And changing the design, 6-14
- Changing
- Cautions, 2-34
- Units/scale factors
- Setting, 2-33

V
Variables command, 4-3
- Vertex points
- Deleting, 3-4
- Moving, 3-4

Vertices
- Adding
- To polygons, 6-9
- To polylines, 6-9
- Converting
- To a mitered edge, 6-11
- To arcs, 6-10
- Deleting, 3-5, 6-9, 6-10
- Distance of, 2-26
- Editing, 6-9
- Manipulating, 6-9
- Markers
- Setting size of, 2-15
- Moving, 6-9, 6-10

Points
- Deleting, 3-4
- Moving, 3-4
- Selecting, 6-9
- Snapping, 2-19

W
Wires
changing attributes of existing (layout), 6-21
connecting components with in layout, 3-16
converting to traces, 6-22
in layout, 6-16
inserting in layout, 3-16
rerouting when moving, 2-25
stretching, 6-22