Notice

The information contained in this document is subject to change without notice.

Agilent Technologies makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Agilent Technologies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Warranty

A copy of the specific warranty terms that apply to this software product is available upon request from your Agilent Technologies representative.

Restricted Rights Legend

Use, duplication or disclosure by the U. S. Government is subject to restrictions as set forth in subparagraph (c) (1) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 for DoD agencies, and subparagraphs (c) (1) and (c) (2) of the Commercial Computer Software Restricted Rights clause at FAR 52.227-19 for other agencies.

Agilent Technologies
395 Page Mill Road
Palo Alto, CA 94304 U.S.A.


Acknowledgments

Mentor Graphics is a trademark of Mentor Graphics Corporation in the U.S. and other countries.

Microsoft®, Windows®, MS Windows®, Windows NT®, and MS-DOS® are U.S. registered trademarks of Microsoft Corporation.

Pentium® is a U.S. registered trademark of Intel Corporation.

PostScript® and Acrobat® are trademarks of Adobe Systems Incorporated.

UNIX® is a registered trademark of the Open Group.
Contents

1 Passive Circuit QuickStart Guide
Using DesignGuides ................................................................. 1-1
  Guide to Passive Circuit Documentation .............................. 1-3
Using the DesignGuide .............................................................. 1-4
Accessing the DesignGuide ....................................................... 1-5
Navigating Through the DesignGuide ......................................... 1-7
  Accessing the Documentation .............................................. 1-7
  Control Window Access ...................................................... 1-8
  SmartComponent Palette Access .......................................... 1-9
Step-by-Step Example ............................................................... 1-10
  Create a New Schematic ...................................................... 1-10
  Open the DesignGuide Control Window ......................... 1-10
  Design a Microstrip Line ................................................... 1-10
  Design and Analyze a Branch-Line Coupler ..................... 1-12
  Optimize the Branch-Line Coupler ..................................... 1-13
  Display Branch-Line Coupler Analysis Results ................ 1-14
General Concepts ........................................................................ 1-15
  Design Flow ................................................................. 1-15
  Use of SmartComponents ................................................. 1-16
  Automated-Assistants ....................................................... 1-18

2 How Do I?
How Do I Topics ........................................................................ 2-1
  How Do I Use SmartComponents? ....................................... 2-2
    Place ................................................................. 2-2
    Copy/Edit ........................................................... 2-2
    Delete .................................................................... 2-2
    Stand Alone Usage ................................................... 2-2
    Specific SmartComponent Properties ............................ 2-2
  SmartComponent Manipulation Answers ............................. 2-3
  How Do I Design (Synthesize) SmartComponents? .............. 2-6
    Design .............................................................. 2-6
    Specific SmartComponent Design ................................ 2-6
  SmartComponent Design Answers ..................................... 2-7
  How Do I Simulate (Analyze) SmartComponents? ............... 2-8
    Simulation (Analysis) ............................................. 2-8
    Specific SmartComponent Simulation ............................ 2-8
  SmartComponent Simulation Answers ............................... 2-8
  How Do I Optimize SmartComponents? .............................. 2-10
    Optimization ......................................................... 2-10
Specific SmartComponent Optimization ............................................................. 2-10
SmartComponent Optimization Answers ........................................................... 2-10
How Do I Display Simulation (Analysis) Results? .............................................. 2-12
  Display Results ................................................................................................ 2-12
  Specific SmartComponent Display Template ................................................. 2-13
Simulation Display Answers .............................................................................. 2-13
How Do I Layout SmartComponent Artwork? .................................................... 2-14
  Create Layout ................................................................................................ 2-14
  Update Layout ................................................................................................ 2-14
  Layout of Specific SmartComponents ....................................................... 2-14
SmartComponent Artwork Layout Answers ...................................................... 2-14

3 SmartComponents
  SmartComponent Basics .............................................................................. 3-1
  Placing SmartComponents .......................................................................... 3-1
  Copying SmartComponents .......................................................................... 3-2
  Editing SmartComponents ............................................................................ 3-3
  Deleting SmartComponents .......................................................................... 3-4
  Design, Analysis, Optimization and Layout .................................................... 3-4
  Stand Alone SmartComponent Usage ............................................................. 3-5

4 Design Assistant
  Design Assistant Operation ............................................................................. 4-1
  Control Window: Single Component Design ..................................................... 4-1
  Control Window: Multiple Component Design ................................................. 4-1

5 Simulation Assistant
  Simulation Assistant Operation ......................................................................... 5-1
  Simulation Frequency Sweep .......................................................................... 5-1
  Automatically Display Results ......................................................................... 5-1
  Control Window ............................................................................................... 5-2
  Simulation Templates ......................................................................................... 5-2

6 Optimization Assistant
  Optimization Assistant Operation ..................................................................... 6-1
  Control Window ............................................................................................... 6-1
  Optimization Templates ................................................................................. 6-1

7 Display Assistant
  Display Template Features ............................................................................ 7-1
  Basic Layout .................................................................................................... 7-1
  Typical Area One Graph .................................................................................. 7-2
  Typical Area Two Graphs ................................................................................ 7-2
  Typical Area Three Templates .......................................................................... 7-3
Display Assistant Operation................................................................. 7-4
Control Window ................................................................................. 7-4
Display Templates............................................................................. 7-4

8 Layout Generation
Layout Artwork Creation ................................................................. 8-1
Layout Artwork Update ................................................................... 8-1

9 SmartComponent Reference
SmartComponent List........................................................................ 9-1
BLCoupler (Branch-Line Coupler) .................................................... 9-4
CLCoupler (Coupled-Line Coupler) .................................................... 9-7
CLFilter (Coupled-Line Filter) .......................................................... 9-10
CMFilter (Comb-Line Filter) .............................................................. 9-13
DSMatch (Double-Stub Match) ......................................................... 9-16
HPFilter (Hairpin Filter) ................................................................. 9-19
IDFilter (Interdigital Filter) .............................................................. 9-22
LCoupler (Lange Coupler) ............................................................... 9-25
LEMatch (Lumped Component Match) ............................................. 9-28
MBend (Microstrip Bend Component) .............................................. 9-31
MBStub (Microstrip Butterfly Radial Stub) ........................................ 9-33
MCFil (Microstrip Coupled Filter Component) ................................. 9-36
MCLine (Microstrip Coupled Line Component) ............................... 9-38
MCorn (Microstrip Corner Component) .......................................... 9-40
MCross (Microstrip Cross Component) ............................................ 9-41
MCurve (Microstrip Curve Component) .......................................... 9-43
MGap (Microstrip Gap Component) ................................................ 9-45
MiCapP (Microstrip 4-port Interdigital Capacitor) ............................ 9-46
MiCapPG (Microstrip Grounded 2-port Interdigital Capacitor) .......... 9-49
MiCapS (Microstrip 2-port Interdigital Capacitor) ............................. 9-52
MiCapSG (Microstrip 1-port Interdigital Capacitor) ........................ 9-55
MLine (Microstrip Line) ................................................................. 9-58
MMndr (Microstrip Meander Line) .................................................. 9-60
MREInd (Microstrip Elevated Rectangular Inductor) ......................... 9-63
MRInd (Microstrip Rectangular Inductor) ......................................... 9-66
MRStub (Microstrip Radial Stub) ...................................................... 9-69
MSInd (Microstrip Spiral Inductor) .................................................. 9-72
MStep (Microstrip Step Component) ................................................. 9-75
MStub (Microstrip Stub) ................................................................. 9-76
MTaper (Microstrip Taper Component) ........................................... 9-78
MTEE (Microstrip Tee Component) .................................................. 9-80
MTFC (Microstrip Thin Film Capacitor) .......................................... 9-82
QWMatch (Quarter-Wave Match) .................................................... 9-85
Chapter 1: Passive Circuit QuickStart Guide

The Passive Circuit QuickStart Guide is designed to have you effectively using the Passive Circuit DesignGuide very quickly. The DesignGuide allows you to design, simulate and optimize passive circuit components. This guide assumes you have installed the DesignGuide with appropriate licensing codewords.

For further details on the Design Guide features, refer to chapters 2 through 9 of this manual, which provides complete information on the DesignGuide.

Note This manual is written describing and showing access through the cascading menu preference. If you are running the program through the selection dialog box method, the appearance and interface will be slightly different.

Using DesignGuides

All DesignGuides can be accessed in the Schematic window through either cascading menus or dialog boxes. You can configure your preferred method in the Advanced Design System Main window. Select the DesignGuide menu.

The commands in this menu are as follows:

DesignGuide Studio Documentation > Developer Studio Documentation is only available on this menu if you have installed the DesignGuide Developer Studio. It brings up the DesignGuide Developer Studio documentation. Another way to access the Developer Studio documentation is by selecting Help > Topics and Index > DesignGuides > DesignGuide Developer Studio (from any ADS program window).

DesignGuide Developer Studio > Start DesignGuide Studio is only available on this menu if you have installed the DesignGuide Developer Studio. It launches the initial Developer Studio dialog box.

Add DesignGuide brings up a directory browser in which you can add a DesignGuide to your installation. This is primarily intended for use with DesignGuides that are custom-built through the Developer Studio.

List/Remove DesignGuide brings up a list of your installed DesignGuides. Select any that you would like to uninstall and choose the Remove button.
Preferences brings up a dialog box that allows you to:

- Disable the DesignGuide menu commands (all except Preferences) in the Main window by unchecking this box. In the Schematic and Layout windows, the complete DesignGuide menu and all of its commands will be removed if this box is unchecked.
- Select your preferred interface method (cascading menus vs. dialog boxes).

![DesignGuide Preferences dialog box]

Close and restart the program for your preference changes to take effect.

Note On PC systems, Windows resource issues might limit the use of cascading menus. When multiple windows are open, your system could become destabilized. Thus the dialog box menu style might be best for these situations.
Guide to Passive Circuit Documentation

The chapters of this manual include the following:

1. **Chapter 1, Passive Circuit QuickStart Guide** is the recommended starting point for users. Review this chapter for a quick overview of using this DesignGuide.

2. **Chapter 2, How Do I?** includes specific questions on DesignGuide usage. It answers many of the commonly asked questions about the DesignGuide.

3. **Chapter 3, SmartComponents** explains how to use SmartComponents.

4. **Chapter 4, Design Assistant** explains how to generate SmartComponent designs.

5. **Chapter 5, Simulation Assistant** explains how to analyze SmartComponent designs.

6. **Chapter 6, Optimization Assistant** explains how to optimize SmartComponent designs.

7. **Chapter 7, Display Assistant** explains how to display SmartComponent simulation results.

8. **Chapter 8, Layout Generation** explains the steps required to generate a layout.

9. **Chapter 9, SmartComponent Reference** describes each SmartComponent in detail.
Using the DesignGuide

The Passive Circuit DesignGuide provides SmartComponents and automated-assistants for the design, simulation, optimization and performance analysis of common passive microstrip structures. SmartComponents are included for microstrip structures such as lines, couplers, power dividers, filters, and matching networks. Automated-assistants include a Design Assistant, Simulation Assistant, Optimization Assistant and Display Assistant, which allow you to quickly create and verify a design. All SmartComponents can be modified when selected. You simply select a SmartComponent and with little effort redesign or verify its performance.

The complexity of Advanced Design System (ADS) is made easily accessible to the designer through the automated assistants. This allows a first-time or casual ADS user to begin benefiting from the capability of ADS quickly. Experienced ADS users will be able to perform tasks faster than ever before. As an example, a microstrip coupled-line filter can be designed, verified and a layout generated in a few minutes saving the designer substantial time.
Accessing the DesignGuide

The Passive Circuit DesignGuide is accessed from a Schematic window within ADS. First you must create or open a project. From the ADS main window, select File > New Project or File > Open Project, as shown here. For this example, create a new project called QuickStart.

To open a Schematic window, select Window > New Schematic or click the New Schematic Window toolbar button.

Note: Depending on how your ADS preferences are set, a Schematic window may automatically appear when you create or open a project.
Navigating Through the DesignGuide


Accessing the Documentation

To access the documentation for the DesignGuide, select either of the following:

- **Help > Topics and Index > DesignGuides > Passive Circuits** (from any ADS program window)
Control Window Access

All features are available from the Control Window that includes menus, a toolbar, and SmartComponent manipulation controls. To access the Control Window, select Passive Circuit Control Window from the Passive Circuit menu.

Passive Circuit DesignGuide Control Window

1. Place a SmartComponent from one of the “Passive Circuit” palettes (accessible from DesignGuide toolbar or menu).
2. Design SmartComponent from the “Design Assistant” tab.
3. Set SmartComponent simulation frequencies from the “Simulation Assistant” tab. The “Automatically Display Results” option controls automatic launching of display following simulation.
4. Simulate SmartComponent from the “Simulation Assistant” tab.
5. If you did not choose to “Automatically Display Results,” open display from the “Display Assistant” tab.
6. If the performance is not satisfactory, optimize SmartComponent from the “Optimization Assistant” tab.
7. Re-simulate SmartComponent from the “Simulation Assistant” tab.
The menus and toolbar buttons perform the basic functions for each automated Assistant (Design, Simulate, Optimize, Display) as well as display the SmartComponent palettes. Full features are available from each of the tab pages on the window. Explore each Automated Assistant tab page by clicking on the tab at the top of each page. Explore the window menus as well to familiarize yourself with the basic DesignGuide capabilities.

The window includes the following features and functions:

- You can place the window anywhere on the screen:

- With the fields at the top of the Control Window, you can navigate multiple Schematic windows and SmartComponents.
  - The Current Schematic drop-down list box allows you to select any of the currently opened Schematic windows. This field is also updated when Passive Circuit Control Window is selected from the Passive Circuit menu.
  - The current design name is also displayed below the Current Schematic. The SmartComponent drop-down list box allows you to select any of the SmartComponents on the currently selected schematic window.
  - The SmartComponent Capability field informs you of what functions (design, simulate, optimize, and display) the DesignGuide can perform for that particular component.

- To close the Control Window, select File > Exit DesignGuide from the Control Window menu bar. The window may also be closed using the window close feature of the operating system (a button marked with an ‘x’ at the top of the window).

**SmartComponent Palette Access**

The SmartComponent palettes are displayed by using the Control Window menus and toolbar. (They can also be chosen from the palette list box in the Schematic window toolbar.) Six palettes are available for accessing the SmartComponents. The Passive Circuit palette contains all of the passive SmartComponents. The other five palettes group the components by their functionality. A blue accent in the upper-left corner of a palette button indicates the component is a SmartComponent.
Step-by-Step Example

This example will take you step-by-step through the design of a microstrip line, and the design, analysis and optimization of a branch-line coupler. After completing these examples, you should have a basic understanding of the DesignGuide and be ready to begin using it.

Create a New Schematic

A new schematic design is needed to contain the microstrip line and branch-line coupler for the following exercises. Follow these simple steps to create a new design named Example.

1. Open a new Schematic window.
2. Create a new Schematic (design). Select File > New from the Schematic window to create a design named Example.

Open the DesignGuide Control Window


Design a Microstrip Line

A microstrip line can easily be designed given a substrate definition, its characteristic impedance, and length. Follow these simple steps to design a microstrip line.
1. Display the Passive Circuit - Lines palette. (Refer to the section, “SmartComponent Palette Access” on page 1-9)

2. Place a microstrip substrate definition (MSUB) component. Click the MSUB palette button, then click within the schematic window at the desired placement location.

3. Edit the MSUB component parameters. Open the component parameter dialog box by double-clicking the MSUB component. Change the substrate thickness (H) to 20 mil and the dielectric constant (Er) to 5.

4. Place a microstrip line (MLine) SmartComponent. Click the MLine palette button, then click within the schematic window at the desired placement location. The MLine SmartComponent is located in the Passive Circuit - Lines palette.

5. Edit the MLine component parameters. Open the component parameter dialog box by double-clicking the MLine component. Change the center frequency (F) to 5 GHz, the characteristic impedance (Zo) to 75 Ohm, and the electrical length (Lelec) to 0.25 wavelengths.

6. Design the MLine component. Select the MLine component either by clicking on it in the Schematic window or selecting it in the SmartComponent drop-down list box on the Control Window. On the Control Window, select the Design Assistant tab page, then click the Design button. This will start the Design Assistant and generate the design for the SmartComponent.
7. **Examine the MLine design.** Select the component **MLine** and click the **Push Into Hierarchy** toolbar button. After examining the design, pop out of the SmartComponent by clicking the **Pop Out of Hierarchy** toolbar button.

8. **Delete the MLine SmartComponent.** Select **Tools > Delete SmartComponent** from the DesignGuide Control Window menu.

   **Note** This is different from the **Delete** button on the ADS Schematic window toolbar.

---

**Design and Analyze a Branch-Line Coupler**

A branch-line coupler can be designed as easily as a microstrip line. Follow these simple steps to design and analyze a branch-line coupler.

1. **Place a branch-line coupler (BLCoupler) SmartComponent.** Click the **BLCplr** palette button and then click within the schematic window at the desired placement location. The BLCoupler SmartComponent is in the **Passive Circuit - Couplers** palette.

2. **Edit the branch-line coupler parameters.** Change the center frequency (F) to **5 GHz**.

3. **Design the branch-line coupler.** Select the BLCoupler component in the SmartComponent drop-down list box on the Control Window and then click the **Design** button on the **Design Assistant** tab page. This will start the Design Assistant and generate the design for the SmartComponent.

4. **Analyze (simulate) the branch-line coupler.** Select the Simulation Assistant tab page on the Control Window and click the **Simulate** button (accept default...
frequency/display specifications). This will invoke the Simulation Assistant and analyze the SmartComponent. The analysis results are shown here.

5. **Close the branch-line coupler analysis results window.** Close the display window by choosing **File > Close Window** from the menu.

**Optimize the Branch-Line Coupler**

The branch-line coupler as designed in the preceding section has a center frequency of 5.5 GHz, which is different from the desired 5 GHz. The difference is due to limitations of the synthesis method used to generate the design. However, the Optimization Assistant can be used to easily optimize the design so that the center frequency is as specified.

6. **Optimize the branch-line coupler.** Select the Optimization Assistant tab page on the Control Window and click the **Optimize** button. This will start the Optimization Assistant and optimize the SmartComponent.

7. **Re-analyze the branch-line coupler.** Select the Simulation Assistant tab page on the Control Window and click the **Simulate** button (accept default frequency/display specifications). This will invoke the Simulation Assistant and re-analyze the branch-line coupler. The new analysis results are shown here.
8. Close the branch-line coupler analysis results window. Close the display window. Select File > Close Window from the menu.

**Display Branch-Line Coupler Analysis Results**

If a SmartComponent has been analyzed with the Simulation Assistant, the analysis results can be displayed using the Display Assistant. The results from the branch-line coupler designed and analyzed above can be quickly displayed by following these simple steps.

1. **Display the analysis (simulation) results for the branch-line coupler.** Select the Display Assistant tab page on the Control Window and click the Display button. This will start the Display Assistant and display the existing simulation results.

2. **Close the branch-line coupler analysis results window.** Close the display window. Select File > Close Window from the menu.
General Concepts

There are two important general concepts: SmartComponents and Automated Assistants. The DesignGuide provides a large number of passive SmartComponents such as couplers, filters, and matching networks. SmartComponents contain specification parameters and a schematic representation of the design. Smart-Components are manipulated using several Automated Assistants. These assistants allow you to easily design, simulate, and optimize the SmartComponents.

Design Flow

The use of the DesignGuide follows a normal design procedure:

1. Select a component needed for your design.
2. Provide specifications.
3. Design and analyze the component.
4. If the component performance needs adjustment, optimize the component.

SmartComponent Setup

1. Choose and place a SmartComponent.
2. Edit the SmartComponent parameters (specifications).

SmartComponent Design and Analysis

3. Design the SmartComponent using the DesignAssistant.
4. Analyze the SmartComponent’s performance using the SimulationAssistant.
5. Display the performance of the SmartComponent using the DisplayAssistant.

Optional SmartComponent Optimization

6. If necessary, optimize the SmartComponent’s performance using the Optimization Assistant.
7. Re-analyze the SmartComponent’s performance using the SimulationAssistant.
Use of SmartComponents

SmartComponents are smart sub-network designs that can be placed into a schematic. The Branch-Line Coupler Smart Component is shown here.

The components are placed in the schematic by selecting the desired SmartComponent from the palette and clicking at the point where you want them placed in the schematic. The desired specifications of the SmartComponent are entered by clicking on its parameters and changing them. Or a dialog box (as shown here) containing all parameters is available by double-clicking on the SmartComponent.
The SmartComponent design (schematic) can be viewed by pushing into the SmartComponent's subnetwork. A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. For details on the SmartComponents, refer to Chapter 9, SmartComponent Reference.

**Hint**  Place a branch-line coupler SmartComponent into a schematic by clicking the BLCplr palette button and clicking within the Schematic window at the desired placement location. Open the parameter dialog box by double-clicking the branch-line coupler component and edit its parameters.
Automated-Assistants

Four Automated Assistants are available in this DesignGuide. They provide quick design, simulation, optimization and analysis display of SmartComponents. Each Automated Assistant has a tab that is accessed from DesignGuide Control Window. Explore each tab on the Control Window. Following are descriptions of each Automated Assistant.

**Design Assistant** is used to generate/update a SmartComponent’s schematic design. After a SmartComponent is placed and the parameters are specified, you start the Design Assistant to design the component. Subsequently, if the parameters of the SmartComponent are modified, you start the Design Assistant again to update the design. For more information, refer to Chapter 4, Design Assistant.

**Simulation Assistant** is used to automatically perform a simulation of a SmartComponent. After a SmartComponent has been designed using the Design Assistant, you start the Simulation Assistant to automatically analyze the component. You can easily examine the simulation results using the Display Assistant. For more information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant** is used to automatically optimize a SmartComponent design so that the desired specifications are achieved. After a SmartComponent has been analyzed using the Simulation Assistant, you can start the Optimization Assistant to automatically optimize the component. After the Optimization Assistant has finished, you can rerun the Simulation Assistant to examine the optimized performance of the SmartComponent. For more information, refer to Chapter 6, Optimization Assistant.

**Display Assistant** is used to automatically display the analysis results generated using the Simulation Assistant. By starting the Display Assistant, you can quickly display the results generated from the most recent simulation of a SmartComponent. For more detailed see Chapter 7, Display Assistant.
Chapter 2: How Do I?

This chapter provides answers to many common questions about the Passive Circuit DesignGuide. Select a topic from the list below to see a more detailed list of questions. The questions are provided to help you quickly find the answer you need.

How Do I Topics

How Do I Use SmartComponents?
How Do I Design (Synthesize) SmartComponents?
How Do I Simulate (Analyze) SmartComponents?
How Do I Optimize SmartComponents?
How Do I Display Simulation (Analysis) Results?
How Do I Layout SmartComponent Artwork?
How Do I Use SmartComponents?

Place
How do I place a new SmartComponent into a design?
How do I place an existing SmartComponent from the current project into a design?
How do I place an existing SmartComponent from a different project into a design?

Copy/Edit
How do I copy a SmartComponent within a design?
How do I copy a SmartComponent from one design to another?
How do I copy a SmartComponent from one Schematic Window to another?
How do I copy a SmartComponent and make it a new SmartComponent, not just a new instance?
How do I edit a SmartComponent?

Delete
How do I delete a SmartComponent from a design?
How do I completely delete a SmartComponent’s files from a project?

Stand Alone Usage
How do I use a SmartComponent without the DesignGuide?
How do I use a SmartComponent within the same project?
How do I use a SmartComponent from another project?

Specific SmartComponent Properties
How do I get information on the properties of a specific SmartComponent?
SmartComponent Manipulation Answers

How do I place a new SmartComponent into a design?
SmartComponents are placed into a design using the DesignGuide palettes. Refer to the section Placing SmartComponents in the chapter SmartComponents for complete instructions.

How do I place an existing SmartComponent from the current project into a design?
Any existing SmartComponent in the current project can be placed into a design using the Component Library. Refer to the section Using an Existing SmartComponent Within the Same Project in the chapter SmartComponents for complete instructions.

How do I place an existing SmartComponent from a different project into a design?
Any existing SmartComponent from another project can be placed into a design by including the project and using the Component Library to place it. Refer to the section Using an Existing SmartComponent in Any Project in the chapter SmartComponents for complete instructions.

How do I copy a SmartComponent within a design?
To copy a SmartComponent within a design, refer to the section Copying Within A Design in the chapter SmartComponents for complete instructions.

How do I copy a SmartComponent from one design to another?
To copy a SmartComponent from one design to another, refer to the section Copying Between Designs or Schematic Windows in the chapter SmartComponents for complete instructions.

How do I copy a SmartComponent from one Schematic Window to another?
To copy a SmartComponent from one Schematic Window to another, refer to the section Copying Between Designs or Schematic Windows in the chapter SmartComponents for complete instructions.
How do I copy a SmartComponent and make it a new SmartComponent, not just a new instance?

All copied SmartComponents will initially refer to the same SmartComponent design. When the Design Assistant is used to perform a design or update operation, it will transform each copied SmartComponent into a unique SmartComponent design. A design operation is accomplished by launching the Design Assistant.

How do I edit a SmartComponent?

A SmartComponent’s position, orientation, and parameters can be edited like any other component in ADS. Refer to the section Editing SmartComponents in the chapter SmartComponents for complete instructions.

How do I delete a SmartComponent from a design?

A SmartComponent can be deleted from the current design just like any other component in ADS. Refer to the section Delete From Current Design in the chapter SmartComponents for complete instructions.

How do I completely delete a SmartComponent’s files from a project?

A SmartComponent and its associated files can be completely removed from a project by using the DesignGuide Delete SmartComponent command/or by using the computer’s file system. Refer to the section Delete From Current Project in the chapter SmartComponents for complete instructions.

How do I use a SmartComponent without the DesignGuide?

Once SmartComponents are designed and tested, they can be used as stand-alone components. The Passive Circuit DesignGuide is not needed to use them in new designs unless you wish to modify or analyze them. Refer to the section Stand Alone SmartComponent Usage in the chapter SmartComponents for complete instructions.

How do I use a SmartComponent within the same project?

An existing SmartComponent present in the current project can be used in any design. Refer to the section Using an Existing SmartComponent Within the Same Project in the chapter SmartComponents for complete instructions.
How do I use a SmartComponent from another project?

An existing SmartComponent from another project can be used in any design by including the project and using the Component Library to place it. Refer to the section Using an Existing SmartComponent in Any Project in the chapter SmartComponents for complete instructions.

How do I get information on the properties of a specific SmartComponent?

Refer to Chapter 9, SmartComponent Reference for a description of each component. The properties and other information specific to a SmartComponent are given.
How Do I Design (Synthesize) SmartComponents?

Design
How do I get information on the synthesis of a specific SmartComponent?
How do I find out about the Design Assistant?
How do I examine a synthesized design?
How do I force the redesign of a SmartComponent?
How do I force the redesign of all SmartComponents in a design?

Specific SmartComponent Design
How do I get information on the synthesis of a specific SmartComponent?
How do I find which SmartComponents can be synthesized with the Design Assistant?
SmartComponent Design Answers

How do I find out about the Design Assistant?
Refer to Chapter 4, Design Assistant for complete information on using the Design Assistant.

How do I design (synthesize) a SmartComponent?
The Design Assistant is used to automatically synthesize a SmartComponent design. To accomplish this, you simply select the SmartComponent on the Control Window and launch the Design Assistant. This will automatically design the SmartComponent. Refer to Chapter 4, Design Assistant for complete information.

How do I examine a synthesized design?
The design for a SmartComponent is contained within a sub-network design file. The design is easily examined by selecting the Push Into Hierarchy toolbar button or choosing View > Push Into Hierarchy from the Schematic window. When you are finished examining the design, choose the Pop Out Of Hierarchy toolbar button or select View > Pop Out Of Hierarchy from the Schematic Window.

How do I force the redesign of a SmartComponent?
The SmartComponent will be re-designed by selecting the SmartComponent on the Control Window and launching the Design Assistant. Refer to the section Design Assistant Operation of the chapter Design Assistant for complete information.

How do I force the redesign of all SmartComponents in a design?
Choosing the Design All button from the DesignGuide Control Window will force the redesign of all SmartComponents in the current design. Refer to the section Control Window: Single Component Design in the chapter Design Assistant for complete information.

How do I get information on the synthesis of a specific SmartComponent?
Refer to Chapter 9, SmartComponent Reference for specific synthesis information on each SmartComponent.
How Do I find which SmartComponents can be synthesized with the Design Assistant?

All SmartComponents included with the Passive Circuit DesignGuide can be automatically synthesized using the Design Assistant.

How Do I Simulate (Analyze) SmartComponents?

Simulation (Analysis)

How do I find out about the Simulation Assistant?
How do I change the frequency sweep of a simulation?
How do I display the results of a simulation?
How do I examine the simulation circuit?
How do I perform a simulation manually?

Specific SmartComponent Simulation

How do I get information on the simulation of a specific SmartComponent?
How do I find which SmartComponents can be analyzed with the Simulation Assistant?

SmartComponent Simulation Answers

How do I find out about the Simulation Assistant?

Refer to Chapter 5, Simulation Assistant for complete information on using the Simulation Assistant.

How do I simulate (analyze) a SmartComponent?

The Simulation Assistant is used to automatically simulate a SmartComponent design. To accomplish this, you simply select the SmartComponent on the Control Window and launch the Simulation Assistant. This will automatically simulate the SmartComponent. Refer to Chapter 5, Simulation Assistant for complete information.
How do I change the frequency sweep of a simulation?

The frequency sweep for a simulation is set by specifying the start, stop, and step size found on the Simulation Assistant tab page on the Control Window. Refer to the section Simulation Frequency Sweep in the chapter Simulation Assistant for complete instructions.

How do I display the results of a simulation?

To have the results of a simulation automatically displayed when a simulation ends, enable the automatic display option. Refer to the section Automatically Display Results in Chapter 5, Simulation Assistant for complete instructions on enabling the automatic display option. The Display Assistant can also be used to display the results of a simulation. Refer to Chapter 7, Display Assistant for complete instructions on displaying simulation results.

How do I examine the simulation circuit?

With the SmartComponent selected in the DesignGuide Control Window, press Create Template from the Simulation Assistant tab page. This will open the simulation circuit used to analyze the SmartComponent. When you are finished examining the circuit, press the Update from Template button on the Simulation Assistant tab page. Refer to the section Simulation Templates in the chapter Simulation Assistant for more information.

How do I perform a simulation manually?

With the SmartComponent selected in the DesignGuide Control Window, press Create Template from the Simulation Assistant tab page. This will open the simulation circuit used to analyze the SmartComponent. When you are finished examining the circuit, press the Update from Template button on the Simulation Assistant tab page. Refer to the section Simulation Templates in the chapter Simulation Assistant for more information.

How do I get information on the simulation of a specific SmartComponent?

Refer to Chapter 9, SmartComponent Reference for specific simulation information on each SmartComponent.
How Do I?

How do I find which SmartComponents can be analyzed with the Simulation Assistant?

Most SmartComponents can be analyzed with the Simulation Assistant. All distributed RLC components, couplers, power dividers, filters, and matching circuit components can be simulated with the Simulation Assistant. The SmartComponents on the Lines menu and palette can not be simulated with the Simulation Assistant because of their simplicity. The SmartComponent Capability field on the DesignGuide Control Window indicates if the currently selected component can be analyzed.

How Do I Optimize SmartComponents?

Optimization

How do I find out about the Optimization Assistant?

How do I update a design with parameters from an optimization?

How do I examine the optimization circuit?

How do I perform an optimization manually?

How do I change the goals of an optimization?

How do I proceed when an optimization is not successful?

Specific SmartComponent Optimization

How do I get information on optimization related to a specific SmartComponent?

How do I find which SmartComponents can be optimized with the Optimization Assistant?

SmartComponent Optimization Answers

How do I find out about the Optimization Assistant?

Refer to Chapter 6, Optimization Assistant for complete information on using the Optimization Assistant.
How do I optimize a SmartComponent?
The Optimization Assistant is used to automatically optimize a SmartComponent design. To accomplish this, you simply select the SmartComponent on the Control Window and launch the Optimization Assistant. This will automatically optimize the SmartComponent. Refer to Chapter 6, Optimization Assistant for complete information.

How do I update a design with parameters from an optimization?
The Optimization Assistant will update the SmartComponent automatically. If the optimization has been performed manually using the optimization template, use the Update from Template button from the Optimization Assistant tab page on the Control Window to update the SmartComponent. Refer to the section Optimization Templates in the chapter Optimization Assistant for more information.

How do I examine the optimization circuit?
With the SmartComponent selected in the DesignGuide Control Window, press Create Template from the Optimization Assistant tab page. This will open the circuit used to optimize the SmartComponent. When you are finished examining the circuit, press the Update from Template button on the Simulation Assistant tab page. Refer to the section Optimization Templates in the chapter Optimization Assistant for more information.

How do I perform an optimization manually?
With the SmartComponent selected in the DesignGuide Control Window, press Create Template from the Optimization Assistant tab page. This will open the circuit used to optimize the SmartComponent. When you are finished examining the circuit, press the Update from Template button on the Simulation Assistant tab page. Refer to the section Optimization Templates in the chapter Optimization Assistant for more information.

How do I change the goals of an optimization?
With the SmartComponent selected in the DesignGuide Control Window, press Create Template from the Optimization Assistant tab page. This will open the optimization circuit. Edit the optimization goals. Refer to Chapter 9, SmartComponent Reference for specific optimization information on each SmartComponent. Optimize the circuit by selecting Simulate > Simulate from the
How Do I?

Schematic Window. When you are finished examining the circuit, press the Update from Template button on the Simulation Assistant tab page. Refer to the section Optimization Templates in the chapter Optimization Assistant for more information.

How do I proceed when an optimization is not successful?

If the optimization fails, the optimization goals can usually be adjusted to fix the problem. Refer to Chapter 9, SmartComponent Reference for specific optimization information on each SmartComponent.

How do I get information on optimization related to a specific SmartComponent?

Refer to Chapter 9, SmartComponent Reference for specific optimization information on each SmartComponent.

How do I find which SmartComponents can be optimized with the Optimization Assistant?

Most SmartComponents can be optimized with the Optimization Assistant. All couplers, power dividers, and filters and most of the matching circuits and distributed RLC components can be optimized with the Optimization Assistant. The SmartComponents on the Lines menu and palette and the rectangular spiral inductors cannot be optimized with the Optimization Assistant. The SmartComponent Capability field on the DesignGuide Control Window indicates if the currently selected component can be optimized.

How Do I Display Simulation (Analysis) Results?

Display Results

How do I get information on a specific SmartComponent's display template?

How do I display the results from a SmartComponent simulation?

How do I open a specific display template manually?

How do I learn about the different components and features of the SmartComponent display templates?
Specific SmartComponent Display Template

How do I get information on a specific SmartComponent's display template?

Simulation Display Answers

How do I find out about the Display Assistant?
Refer to Chapter 7, Display Assistant for complete information on using the Display Assistant.

How do I display the results from a SmartComponent simulation?
The Display Assistant is used to automatically display the results of a SmartComponent simulation. To accomplish this, you simply select the SmartComponent on the Control Window and launch the Display Assistant. This will automatically display the simulation results for the SmartComponent. Refer to Chapter 7, Display Assistant for complete information.

How do I open a specific display template manually?
From the Display Assistant tab page on the Control Window, select the desired display from the Available Templates field and press the Open Display Template button. This will open the selected display. Refer to the section Display Templates in the chapter Display Assistant for complete information.

How do I learn about the different components and features of the SmartComponent display templates?
Refer to the section Display Template Features in the chapter Display Assistant for information on the different components and features of the display templates.

How do I get information on a specific SmartComponent’s display template?
Refer to Chapter 9, SmartComponent Reference for display template information on each SmartComponent.
How Do I Layout SmartComponent Artwork?

Create Layout

How do I automatically create artwork for SmartComponents?

Update Layout

How do I update artwork when I make changes or redesign a SmartComponent?

Layout of Specific SmartComponents

How do I get information on the layout of specific SmartComponents?

SmartComponent Artwork Layout Answers

How do I automatically create artwork for SmartComponents?

Artwork for all of the passive circuit SmartComponents in this DesignGuide can be automatically generated. The Generate Layout capability of ADS is used to generate the artwork for the SmartComponents. Refer to the section Layout Artwork Creation in the chapter Layout Generation for complete information.

How do I update artwork when I make changes or redesign a SmartComponent?

Refer to the section Layout Artwork Update in the chapter Layout Generation for complete information.

How do I get information on the layout of specific SmartComponents?

Refer to Chapter 9, SmartComponent Reference for layout information on each SmartComponent.
Chapter 3: SmartComponents

This DesignGuide provides a large number of passive SmartComponents such as couplers, filters, lines and matching networks. SmartComponents are smart sub-network designs that can be placed into a schematic and provide the container for specification parameters and a schematic representation of the design. Several automated-assistants allow you to easily design, simulate (analyze) and optimize the SmartComponents.

SmartComponent Basics

SmartComponents can be placed, copied, edited and deleted like other components in the Advanced Design System. The basics of placement, copying, editing and deleting are described here.

Placing SmartComponents

The DesignGuide contains six SmartComponent palettes that provide quick and easy access to the SmartComponents. To place a SmartComponent:

1. Click on the desired component button in a SmartComponent palette.
2. Click within the Schematic window at the location you want the SmartComponent placed.
3. You may change the orientation of the SmartComponent before placement by selecting from the Insert > Component > Component Orientation commands or by repeatedly selecting Rotate by -90 from the schematic toolbar.
4. The place component mode will remain active until you choose End Command from the Schematic toolbar.

The six available component palettes are:

- All contains all of the SmartComponents.
- Lines contains the simple line element SmartComponents.
- RLC contains the distributed resistor, inductor, and capacitor SmartComponents.
- Couplers contains the coupler and power divider SmartComponents.
- Filters contains the distributed filter SmartComponents.
SmartComponents

- Match contains the distributed and lumped matching SmartComponents.

There are two methods to display the desired SmartComponent palette.

- Open the Passive Circuit DesignGuide Control Window by selecting DesignGuide > Passive Circuit DesignGuide > Passive DesignGuide Control Window. Display the desired SmartComponent palette by selecting one of the Component Palette buttons from the control window toolbar or by selecting View > Component Palette - <Palette Name> from the control window menu.

- Select the desired SmartComponent palette from the Component Palette drop-down list box in the Schematic window toolbar (directly above the palette).

Note When a SmartComponent is initially placed, a temporary component is used to initially place and specify the parameters for the SmartComponent. This component does not contain a subnetwork design. After the Design Assistant has been used to design the SmartComponent, the temporary component is replaced with a permanent component. The SmartComponent is renamed to DA_ComponentName_DesignName and an autogenerated design is placed inside the SmartComponent’s subnetwork design file. Subsequently, if the SmartComponent parameters are edited, the Design Assistant will need to be used again to update the subnetwork design file.

Copying SmartComponents

SmartComponents can be copied within a design, to another design, or to another Schematic window.

Copying Within A Design

1. Click the SmartComponent to be copied.
2. Select Edit > Copy, then Edit > Paste from the schematic window.
3. Click the spot where you want the copy placed.

Copying Between Designs or Schematic Windows

1. Click the SmartComponent to be copied.
2. Select Edit > Copy from the Schematic window.
3. Display the design or Schematic window you want to copy the SmartComponent to.

4. Select Edit > Paste to copy the SmartComponent to the design.

5. Click where you want the component placed.

---

**Note**  All copied SmartComponents will initially refer to the same SmartComponent design. When the Design Assistant is used to perform a design operation, it will transform each copied SmartComponent into a unique SmartComponent design. A design operation is accomplished by launching the Design Assistant from the DesignGuide Control Window.

---

**Editing SmartComponents**

A SmartComponent's position, orientation, and parameters can be edited like any other component in ADS.

**Position and Orientation**

A SmartComponent is moved by dragging it to any location in the Schematic window. Its orientation is changed by following these steps.

1. Select Edit > Advanced Rotate/Mirror > Rotate from the Schematic window or select Rotate Items from the toolbar.
2. Click on the desired SmartComponent.
3. Rotate the component.
4. The rotate mode will remain active until you select the End Command from the toolbar.

**Parameters**

Parameters are changed by clicking on a SmartComponent parameter in the Schematic window and editing it or by double-clicking a component and editing the parameters in the component dialog box.
Deleting SmartComponents

SmartComponents can be deleted from a design like other components, but completely removing a SmartComponent’s files requires the actions described here.

Delete From Current Design

A SmartComponent can be deleted from a design by selecting the component and pressing the Delete key, selecting Delete from the toolbar, or by selecting Edit -> Delete from the Schematic window. However, this does not remove the SmartComponent files from the project directory.

Delete From Current Project

To delete a SmartComponent and all associated files from your project, follow these steps.

1. From the DesignGuide Control Window, select the Delete SmartComponent button.

2. Click on the SmartComponent you want deleted. This will delete the SmartComponent from the current design and remove all of its files from your project.

3. The SmartComponent delete mode will remain active until you select the End Command from the Schematic toolbar.

Delete Manually Using File System

You may use your computer’s file system to delete a SmartComponent by deleting the appropriate files in the network subdirectory of a project. Delete files that start with DA_, SA_’ and OA_, contain the SmartComponent title, and end with .ael or .dsn.

Design, Analysis, Optimization and Layout

The DesignGuide contains several automated assistants that provide automatic design, analysis, and optimization for the SmartComponents. The following assistants are available.

- **Design Assistant.** The Design Assistant is used to generate and update the design contained within a SmartComponent. It invokes a synthesis engine that generates a design from the given specification. It will design and update a
single SmartComponent or all SmartComponents in a design. Refer to Chapter 4, Design Assistant for more information.

• Simulation (Analysis) Assistant. The Simulation Assistant is used to analyze the design contained within a SmartComponent. It creates a simulation circuit containing the SmartComponent, then performs a simulation. It can also automatically display the results of the simulation. Refer to Chapter 5, Simulation Assistant for more information.

• Optimization Assistant. The Optimization Assistant is used to optimize the design contained within a SmartComponent. It creates an optimization circuit containing the SmartComponent, performs an optimization, and updates the SmartComponent. Refer to Chapter 6, Optimization Assistant for more information.

• Display Assistant. The Display Assistant is used to quickly display the performance of a SmartComponent. Display templates have been created for most of the SmartComponents. The display templates are preconfigured templates which provide a comprehensive look at the component’s performance. Refer to Chapter 7, Display Assistant for more information.

• Automatic Layout Generation. Artwork for all of the passive circuit SmartComponents in this DesignGuide can be automatically generated. The synthesis engine used by the Design Assistant creates a schematic for the SmartComponents that is auto-layout-generation ready. The Generate Layout capability of ADS is used to generate the artwork for the SmartComponents. Refer to Chapter 8, Layout Generation for more information.

Stand Alone SmartComponent Usage

Once SmartComponents are designed and tested, they can be used as stand-alone components. The Passive Circuit DesignGuide is not needed to use them in new designs unless you wish to modify or analyze them.

Using an Existing SmartComponent Within the Same Project

1. Open the Component Library window by selecting Insert > Component > Component Library from the Schematic window or Display Component Library List from the toolbar.
2. Select the project name under **All > Sub-networks** in the Libraries list at the left of the Component Library window. Available components will be listed in the Components list at the right of the Component Library window.

3. Select the desired SmartComponent in the Components list.

4. Place the desired SmartComponent into your design by clicking in the Schematic window at the location you wish it placed.

5. The insert mode will remain active until you select **End Command** from the toolbar.

### Using an Existing SmartComponent in Any Project

A library of predesigned reusable SmartComponents can be easily created. This is done by placing the reusable SmartComponents in a project. This project can be included in any project and its SmartComponents will be accessed using the Component Library. Follow these steps.

1. Select **File > Include/Remove Projects** from the main ADS window.

2. Select the project that contains the desired SmartComponent from the File Browser at the left of the Include & Remove window.

3. Choose the **Include** button to include the project in the hierarchy.

4. Choose the **OK** button.

5. Open the Component Library window by selecting **Insert > Component > Component Library** from the Schematic window or **Display Component Library List** from the toolbar.

6. Select the included project name under **All > Sub-networks** in the Libraries list at the left of the Component Library window.

7. Available components will be listed in the Components list at the right of the Component Library window.

8. Select the desired SmartComponent in the Components list.

9. Place the desired SmartComponent into your design by clicking in the Schematic window at the location you wish it placed.

10. The insert mode will remain active until you select **End Command** from the toolbar.
Chapter 4: Design Assistant

The Design Assistant is used to generate and update the design contained within a SmartComponent from the given specifications. It will design and update a single SmartComponent or all SmartComponents in a design.

The Design Assistant is accessed using the Passive Circuit DesignGuide Control Window. From the control window, full design control is enabled from the Design Assistant tab. Single component design operations can also be accomplished using the Control Window menu and toolbar.

Design Assistant Operation

Following are details on the use of the Design Assistant.

Control Window: Single Component Design

To design a single SmartComponent using the control window, select the desired SmartComponent either from the SmartComponent drop-down list box in the upper right corner of the control window or by clicking on the component in the Schematic window. The design is accomplished using one of the following methods.

• Push the Design button on the Design Assistant tab. The design progress is indicated on the tab page.
• Push the Design button on the Control Window toolbar.
• Select Tools > Auto-Design from the Control Window menu.

Control Window: Multiple Component Design

Selecting the Design All button on the Design Assistant tab designs all SmartComponents on the current Schematic. To avoid screen flicker associated with the design, the Schematic window will disappear during the process. Design progress is indicated on the tab page.
Design Assistant
Chapter 5: Simulation Assistant

The Simulation Assistant is used to analyze the design contained within a SmartComponent. It creates a simulation circuit around the SmartComponent, then performs a simulation. If desired it will automatically display the simulation results.

The Simulation Assistant is accessed using the Passive Circuit DesignGuide Control Window. From the control window, full simulation control is enabled from the Simulation Assistant tab. Basic simulation can also be accomplished using the Control Window menu and toolbar.

Simulation Assistant Operation

For all simulation operations, the selected SmartComponent is designed if necessary, a simulation schematic is created, the simulation is performed, and the results are displayed. The simulation frequency sweep must be specified on the Simulation Assistant tab in the Control window.

Simulation Frequency Sweep

The simulation frequency sweep is specified on the Passive Circuit DesignGuide control window. If you are performing the simulation from the Control Window, select the Simulation Assistant tab and specify the sweep by entering the start frequency, stop frequency, and either frequency step size or number of points. The values entered are stored in the selected SmartComponent (as displayed in the SmartComponent drop-down list box) and will be recalled each time this SmartComponent is selected.

Note  If a SmartComponent has been selected from the SmartComponent drop-down list box on the control window, default frequencies will be set for the component.

Automatically Display Results

If the Automatically Display Results box on the Control Window’s Simulation Assistant tab is selected, the simulation results will be automatically displayed upon completion of the analysis.
**Simulation Assistant**

**Control Window**
To simulate a SmartComponent using the control window, select the desired SmartComponent either from the SmartComponent drop-down list box in the upper right corner of the control window or by clicking on the component on the schematic window. The simulation frequency sweep display option must be specified on the Simulation Assistant tab as previously described. The simulation is then accomplished using one of the following methods:

- Push the Simulate button on the Simulation Assistant tab.
- Push the Simulate button on the Control Window toolbar.
- Select Tools > Auto-Simulate from the Control Window menu.

**Simulation Templates**
In some cases it might be useful to manually simulate the SmartComponent. To generate a simulation schematic around the selected SmartComponent, press the Create Template button on the control window Simulation Assistant tab. You can examine or modify the simulation schematic, then manually start the simulation by selecting Simulate > Simulate from the Schematic window. When you are finished, pressing the Update from Template button on the Simulation Assistant tab will transfer any changes you have made to the SmartComponent on the Simulation schematic to the original SmartComponent and redesign if necessary. You can also manually close the simulation schematic using File > Close Design from the Schematic window menu, although this will result in loss of any changes you have made to the SmartComponent.
Chapter 6: Optimization Assistant

The Optimization Assistant is used to optimize the design contained within a SmartComponent. It creates an optimization circuit containing the SmartComponent, then performs an optimization.

The Optimization Assistant is accessed using the Passive Circuit DesignGuide Control Window. From the Control Window, full optimization control is enabled from the Optimization Assistant tab. Basic optimization can also be accomplished using the control window menu and toolbar.

Optimization Assistant Operation

For all optimization operations, the selected SmartComponent is designed if necessary, an optimization schematic is created, and the optimization is performed. The optimization results are transferred to the original SmartComponent, and this altered component is redesigned. For each component, the optimization alters one or more of the physical design dimensions in order to make the component response more closely meet the specified performance.

Control Window

To optimize a SmartComponent using the Control Window, select the desired SmartComponent either from the SmartComponent drop-down list box in the upper right corner of the control window or by clicking on the component on the schematic window. The optimization is then accomplished using one of the following methods.

- Push the Optimize button on the Optimization Assistant tab.
- Push the Optimize button on the control window toolbar.
- Select Tools > Auto-Optimize from the control window menu.

The Optimization Assistant tab contains fields that indicate the objective of the optimization operation as well as the physical parameters to be altered during the process.

Optimization Templates

In some cases it may be useful to manually optimize the SmartComponent. To generate an optimization schematic around the selected SmartComponent, press the
Create Template button on the control window Optimization Assistant tab. You can examine or modify the optimization schematic, then manually start the optimization by selecting Simulate > Simulate from the Schematic window. When you are finished, selecting Simulate > Update Optimization Values will cause the optimized values to appear in the VAR element in the schematic lower left corner for your inspection. Pressing the Update from Template button on the Optimization Assistant tab will transfer the optimization results to the original SmartComponent and redesign. You may also manually close the optimization schematic using File > Close Design from the Schematic window menu, although this will cause optimization results to be lost.
Chapter 7: Display Assistant

The Display Assistant is used to easily and quickly display the performance of a SmartComponent. Display templates have been created for most of the SmartComponents. This includes all of the RLC, coupler, filter and matching components. The line components do not have auto-simulation, auto-optimization or auto-display capability because of their simplicity. The display templates are preconfigured templates that provide a comprehensive look at the performance of the component. You can create your own displays or modify the included display templates using the built in features of Advanced Design System, but in most situations, the included display templates will provide all the information you need.

The Display Assistant is accessed using either the Passive Circuit DesignGuide Control Window. From the control window, full display control is enabled from the Display Assistant tab. Basic display selection can also be accomplished using the Control Window menu and toolbar.

Display Template Features

The display templates opened by the Display Assistant have common features that are discussed here. For features unique to the display templates of some SmartComponents, refer to Chapter 9, SmartComponent Reference.

Basic Layout

Following is the basic layout of the display templates. Area one of the display template contains a graph of the most important parameters of the SmartComponent. Area two contains several graphs that give a comprehensive look at the component's performance. Area three contains a table listing the basic specifications and performance of the component.
Typical Area One Graph

A typical graph from area one of a display template follows. The frequency range of the graph is determined by the Simulation Assistant. As you change the frequency range in the Simulation Assistant, this graph will update appropriately. The markers A and B are used to define the frequency range of the graphs in area two. This feature is used to zero in on the region of interest and obtain a comprehensive look at the component’s performance. The marker M1 can be moved by dragging it with the mouse. The performance at the frequency given by M1 will be shown in the table in area three.

Typical Area Two Graphs

Typical graphs from area 2 of a display template are shown here. These graphs provide a quick, comprehensive look at the component’s performance. Their frequency range is determined by the location of the “A” and “B” markers found in the main graph. Any markers such as M2 shown here can be moved by dragging them with the mouse. Performance criteria at the marker frequency will be displayed in the table in area three.
Typical Area Three Templates

A typical table from area three of a display template is shown here. The white rows show the desired specifications and important performance criteria for the component. The gray rows give the performance criteria at the user defined marker frequencies. The box below the table provides explanatory information for the table.

<table>
<thead>
<tr>
<th>Desired Center Frequency</th>
<th>F</th>
<th>S11</th>
<th>S21</th>
<th>S31</th>
<th>S41</th>
<th>PhaseD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual Center Frequency</td>
<td>5.00</td>
<td>-10.72</td>
<td>-4.64</td>
<td>-2.91</td>
<td>-12.15</td>
<td>84.94</td>
</tr>
<tr>
<td>Change/Worst A-&gt;B</td>
<td>5.00</td>
<td>-4.20</td>
<td>-8.16</td>
<td>-5.41</td>
<td>-7.22</td>
<td>70.77</td>
</tr>
<tr>
<td>Marker M1</td>
<td>5.00</td>
<td>-10.72</td>
<td>-4.64</td>
<td>-2.91</td>
<td>-12.15</td>
<td>84.94</td>
</tr>
<tr>
<td>Marker M2</td>
<td>6.00</td>
<td>-22.47</td>
<td>-2.54</td>
<td>-3.66</td>
<td>-22.25</td>
<td>89.83</td>
</tr>
</tbody>
</table>

F: Frequency (GHz)
1: Input Port
2: In-phase (I) Port
3: Quadrature (Q) Port
4: Isolated Port
C: Desired Coupling
PhaseD: I-Q Phase Difference

Note: Change/Worst A->B provides performance over the range from marker A to B. The change of F and PhaseD are given, and the worst case S-parameter values are given.
Display Assistant Operation

Before using the Display Assistant, a valid dataset from a simulation of the selected SmartComponent must exist in the current project data directory. This simulation can be conveniently accomplished using the Simulation Assistant. Refer to the Simulation Assistant chapter for details on this step.

Control Window

To display results from a SmartComponent simulation using the Control Window, select the desired SmartComponent either from the SmartComponent drop-down list box in the upper right corner of the control window or by clicking on the component on the schematic window. The display is then launched using one of the following methods.

- Push the Display button on the Display Assistant tab.
- Push the Display button on the control window toolbar.
- Select Tools > Auto-Display from the Control Window menu.

If no valid dataset exists for the selected SmartComponent, the Display button on the Display Assistant tab will be insensitive. If the toolbar or menu are used to try to display the results, a message will appear indicating that no dataset exists.

Display Templates

In some cases it may be useful to use one of the display templates provided with the DesignGuide for other applications. To gain access to one of these templates, select the desired template from the Available Templates field and press the Open DisplayTemplate button on the control window Display Assistant tab. You can then insert a dataset of your choice using the dataset pull-down list box in the upper left corner of the display. You may find that some parameters in the display template are not defined in the selected dataset and may want to make appropriate modifications to the display. These changes can be saved using the commands in the display File menu.
Chapter 8: Layout Generation

Artwork for all of the passive circuit SmartComponents in this DesignGuide can be automatically generated. You need an Advanced Design System Layout license to use this feature. The Design Assistant creates a schematic for the SmartComponents that is ready for auto-layout generation. The ADS Generate Layout capability is used to generate the artwork for the SmartComponents.

Layout Artwork Creation

To create artwork for SmartComponents, follow these steps:

1. Choose and place the desired SmartComponents in the schematic window.
2. Specify the desired parameters for each SmartComponent.
3. Design the SmartComponents using the Design Assistant.
4. Select Layout > Generate/Update Layout from the Schematic window.
5. Choose OK in the Generate/Update Layout box.

The artwork for each SmartComponent and any other components that have associated artwork will be displayed in the Layout window. If the status report checkbox is selected in the Generate/Update Layout box, a layout generation status report will also be opened.

Layout Artwork Update

To edit the properties of a SmartComponent and update the associated artwork, follow these steps:

1. Choose the desired SmartComponent in the schematic window.
2. Edit the desired parameters of the SmartComponent.
3. Design the SmartComponent using the Design Assistant.
4. Select Layout > Generate/Update Layout from the Schematic window.
5. Select OK in the Generate/Update Layout box.

The artwork for the SmartComponent will be updated and displayed in the layout window.
Layout Generation

8-2 Layout Artwork Update
Chapter 9: SmartComponent Reference

SmartComponent List

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Lines
- MLine (Microstrip Line)
- MStub (Microstrip Stub)
- MMndr (Microstrip Meander Line)
- MRStub (Microstrip Radial Stub)
- MBStub (Microstrip Butterfly Radial Stub)
- MCLine (Microstrip Coupled Line Component)
- MBStub (Microstrip Butterfly Radial Stub)
- MTaper (Microstrip Taper Component)
- MStep (Microstrip Step Component)
- MGap (Microstrip Gap Component)
- MTe (Microstrip Tee Component)
- MCross (Microstrip Cross Component)
- MBend (Microstrip Bend Component)
- MCorn (Microstrip Corner Component)
- MCurve (Microstrip Curve Component)

Distributed Capacitors
- MICapSG (Microstrip 1-port Interdigital Capacitor)
- MICapS (Microstrip 2-port Interdigital Capacitor)
SmartComponent Reference

MICapPG (Microstrip Grounded 2-port Interdigital Capacitor)
MICapP (Microstrip 4-port Interdigital Capacitor)
MTFC (Microstrip Thin Film Capacitor)
TFC (Thin Film Capacitor)

**Distributed Resistors**
TFR (Thin Film Resistor)

**Distributed Inductors**
MRStub (Microstrip Radial Stub)
MRInd (Microstrip Rectangular Inductor)
MREInd (Microstrip Elevated Rectangular Inductor)

**Couplers**
BLCoupler (Branch-Line Coupler)
CLCoupler (Coupled-Line Coupler)
HPFilter (Hairpin Filter)
RRCoupler (Rat-Race Coupler)

**Dividers**
WDCoupler (Wilkinson Divider)
TCoupler (Tee Power Divider)

**Filters**
SIFilter (Stepped Impedance Lowpass Filter)
SLFilter (Stub Lowpass Filter)
CLFilter (Coupled-Line Filter)
ZZFilter (Zig-Zag Coupled-Line Filter)
SRFilter (Stepped Impedance Resonator Filter)
HPFilter (Hairpin Filter)
IDFilter (Interdigital Filter)
CMFilter (Comb-Line Filter)
SBFilter (Stub Bandpass Filter)

**Matching Networks**
LEMatch (Lumped Component Match)
SSMatch (Single-Stub Match)
CMFilter (Comb-Line Filter)
QWMatch (Quarter-Wave Match)
TLMatch (Tapered-Line Match)
BLCoupler (Branch-Line Coupler)

Symbol

Summary

A branch-line coupler outputs from the coupled port (pin 3) a fraction of the power presented at the input (pin 1). The remainder of the power is passed through to the output port (pin 2). At the center frequency the phase difference between the outputs is 90 degrees, with the coupled port representing the quadrature (Q) output and the output port representing the in-phase (I) output. The coupling coefficient specifies the ratio of the input power to the coupled power ($P_1/P_3$). Pin 4 represents the isolated port, and it is typically well isolated from the input port near the center frequency.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters

Subst = microstrip substrate name
F = center frequency, in hertz
C = coupling coefficient, in dB
Zo = characteristic impedance, in ohms
Delta = length added to branches for tuning performance

Palette

Passive Circuit - Couplers

Available Automated-Assistants

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage

For general information, refer to Chapter 4, Design Assistant.
1. The coupling coefficient must be positive and greater than 3 dB. Best results are obtained for tight couplings of 6 dB or better (C < 6 dB). Choosing the coupling parameter larger than 6 dB often causes width constraint violations to occur on the MTEE components, resulting in warning messages during design and simulation. A coupling coefficient of 3 dB provides an equal power split between the two outputs.


**Simulation Assistant Usage**

For general information, refer to Chapter 5, *Simulation Assistant*.

**Optimization Assistant Usage**

For general information, refer to Chapter 6, *Optimization Assistant*.

The optimization minimizes the input reflection coefficient (S11) at the design center frequency by changing the length of the lines forming the four branches. All branches are changed by the same physical length during the optimization. This optimization generally provides very good results but may not guarantee that the specified coupling is attained at the design frequency. More advanced tuning can be performed by changing line width of the branch lines.

**Display Assistant Usage**

For general information, refer to Chapter 7, *Display Assistant*.

**Example**

A branch-line coupler was designed for a center frequency of 5 GHz with an equal power split between the I and Q ports. Tuning using the Optimization Assistant yielded a value of Delta = 49.532 mil.
SmartComponent Reference

![Graph showing frequency response with labeled points and curves]

9-6  SmartComponent List
**CLCoupler (Coupled-Line Coupler)**

**Symbol**

![CLCoupler Symbol](image)

**Summary**

A coupled-line coupler outputs from the coupled port (pin 4) a fraction of the power presented at the input (pin 1). The remainder of the power is passed through to the output port (pin 2). The coupling coefficient specifies the ratio of the input power to the coupled power (P1/P4). The remaining port is isolated, although the isolation is often similar in value to the coupling coefficient for microstrip realizations.

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

**Parameters**

- Subst = microstrip substrate name
- F = center frequency, in hertz
- C = coupling coefficient, in dB
- Zo = characteristic impedance, in ohms
- Delta = length added to branches for tuning performance

**Palette**

Passive Circuit - Couplers

**Available Automated-Assistants**

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

**Design Assistant Usage**

For general information, refer to Chapter 4, Design Assistant.

1. The coupling coefficient must be positive and greater than 3 dB. Best results are obtained for weak couplings of roughly 10 dB or more (C >10dB). Choosing the coupling coefficient too small may require a spacing between the coupled lines too small to realize.

**Simulation Assistant Usage**
For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**
For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the absolute difference between $S_{41}$ in dB and the specified coupling coefficient at the design center frequency by changing the length of the coupled-line section.

**Display Assistant Usage**
For general information, refer to Chapter 7, Display Assistant.

**Example**
A coupled-line coupler was designed for a center frequency of 5 GHz with 20 dB of coupling. Tuning using the Optimization Assistant yielded a value of $\Delta = -1.087$ mil.

---

```
MSub
MSub1
H=30 mil
E=3.2

MSUB
DA_CLCoupler1_test
DA_CLCoupler1
Subst="MSub1"
F=5 GHz
C=20 dB
Zo=50 Ohm
Delta=-1.087 mil
```
CLFilter (Coupled-Line Filter)

Symbol

Summary
A coupled-line filter provides a bandpass frequency response between the input and output ports. N coupled-line sections produces an N-1 order filter response. Additional numbers of sections can be used to steepen the transition band roll off or widen the pass bandwidth.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
Fs1 = lower stopband edge frequency, in hertz
Fp1 = lower passband edge frequency, in hertz
Fp2 = upper passband edge frequency, in hertz
Fs2 = lower stopband edge frequency, in hertz
Ap = passband edge attenuation (or ripple for Chebyshev), in dB
As = stopband edge attenuation, in dB
N = number of filter sections (or 0 to compute N)
ResponseType = type of frequency response (maximally flat or Chebyshev)
Zo = desired input/output impedance, in ohms
Delta = length added to coupled sections for tuning performance

Palette
Passive Circuit - Filters

Available Automated-Assistants
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant
Design Assistant Usage

For general information, refer to Chapter 4, Design Assistant.

1. Because of the heavy computational burden in determining the line parameters, a brief delay will occur for the design.

2. For a Chebyshev (equal ripple) frequency response, ripple levels greater than about 1 dB are not recommended. Exceeding this value will typically deform the shape of the passband characteristics.

3. If N is zero, the number of filter sections will be computed from the frequency/attenuation information. If N is non-zero, the design will use the frequency/attenuation parameters only for determining the design center frequency.


Simulation Assistant Usage

For general information, refer to Chapter 5, Simulation Assistant.

Optimization Assistant Usage

For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the absolute difference between S21 in dB and the specified passband edge attenuation (which equals the ripple for Chebyshev response) at the passband edge frequencies. Because only the line lengths are changed, this tuning will typically center the response within the specified passband. More advanced shaping of the passband response can be accomplished by manually tuning the widths and spacings of the coupled filter sections.

Display Assistant Usage

For general information, refer to Chapter 7, Display Assistant.

Example

A coupled-line filter was designed for a maximally flat response with the 3 dB passband edge frequencies at 2 GHz and 2.4 GHz respectively. The design required 4 coupled-line sections. Tuning using the Optimization Assistant yielded a value of Delta = -5.244 mil.
SmartComponent Reference

MSub
MSCUB
MSub1
H=30 mil
Em=0.2
F1=1.0 GHz
Fp1=2.2 GHz
Fp2=2.4 GHz
Ap=3 dB
As=20 dB
N=0
Zo=50 Ohm
Delta=6.244 mil

![Diagram of S11 and S21 with Spec]

Frequency (GHz)

-50  -40  -30  -20  -10  0

S (dB)
**CMFilter (Comb-Line Filter)**

**Symbol**

---

**Summary**

A comb-line filter provides a bandpass frequency response between the input and output ports. \( N \) coupled-line sections produce an \( N-1 \) order filter response. Additional numbers of sections can be used to steepen the transition band roll off or widen the pass bandwidth.

---

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

---

**Parameters**

- **Subst** = microstrip substrate name
- **Fs1** = lower stopband edge frequency, in hertz
- **Fp1** = lower passband edge frequency, in hertz
- **Fp2** = upper passband edge frequency, in hertz
- **Fs2** = lower stopband edge frequency, in hertz
- **Ap** = passband edge attenuation (or ripple for Chebyshev), in dB
- **As** = stopband edge attenuation, in dB
- **N** = number of filter sections (or 0 to compute \( N \))
- **ResponseType** = type of frequency response (maximally flat or Chebyshev)
- **Zo** = desired input/output impedance, in ohms
- **Lelec** = electrical length of filter resonators (the units of \( \text{Lelec} \) are in fractions of a wavelength i.e., \( 0.25 = 1/4 \) wavelength)
- **ya** = normalized interior resonator admittance (\( 0 < \text{ya} < 1 \))
- **CouplingType** = type of input/output coupling (coupled line or tapped line transformer)
- **Delta** = length added to coupled sections for tuning performance
Palette
Passive Circuit - Filters

Available Automated-Assistants
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. Because of the heavy computational burden in determining the line parameters, a brief delay will occur for the design.

2. A two-layer substrate must be used for this topology.

3. For a Chebyshev (equal ripple) frequency response, ripple levels greater than about 1 dB are not recommended. Exceeding this value will typically deform the shape of the passband characteristics.

4. If N is zero, the number of filter sections will be computed from the frequency/attenuation information. If N is non-zero, the design will use the frequency/attenuation parameters only for determining the design center frequency.

5. Using a CouplingType of “Coupled Line Transformer Input” will use an extra coupled line section on the inputs and outputs to feed the device. Choosing “Tapped Line Transformer Input” will bring the feedline directly into the first resonator.


Simulation Assistant Usage
For general information, refer to Chapter 5, Simulation Assistant.

Optimization Assistant Usage
For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the absolute difference between S21 in dB and the specified passband edge attenuation (which equals the ripple for Chebyshev response) at the passband edge frequencies. Because only the line lengths are changed, this tuning will typically center the response within the specified passband. More advanced shaping of the passband response can be accomplished by manually tuning the widths and spacings of the coupled filter sections.

Display Assistant Usage
For general information, refer to Chapter 7, Display Assistant.

Example

A comb-line filter was designed for a maximally flat response with the 3 dB passband edge frequencies at 2 GHz and 2.2 GHz respectively. The design required 5 coupled lines. Tuning using the Optimization Assistant yielded a value of Delta = 168.41 mil.
DSMatch (Double-Stub Match)

Summary
A double-stub matching network matches a complex load impedance ($Z_{load}$) to a desired complex input impedance ($Z_{in}$) using two shunt stubs and a connecting line.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = center frequency, in hertz
$Z_{in}$ = desired complex input impedance, in ohms
$Z_{load}$ = complex load impedance to match, in ohms
$Z_{stub1}$ = characteristic impedance of stub line 1 (nearest input), in ohms
$Z_{stub2}$ = characteristic impedance of stub line 2 (nearest output), in ohms
$Z_{line}$ = characteristic impedance of line between stubs, in ohms
$Z_{feed1}$ = characteristic impedance of line connected to port 1, in ohms
$Z_{feed2}$ = characteristic impedance of line connected to port 2, in ohms
Stub1Type = stub 1 type (open or short circuit)
Stub2Type = stub 2 type (open or short circuit)
Delta = length added to stubs for tuning performance

Palette
Passive Circuit - Matching

Available Automated-Assistants
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

**Design Assistant Usage**

For general information, refer to Chapter 4, Design Assistant.

1. An impedance match can be realized using any combination of stub types, although some combinations may be more realizable.

2. \( Z_{\text{feed1}} \) and \( Z_{\text{feed2}} \) are used simply to ensure that the input and output legs of the microstrip tee components are of the proper width.

3. The length of the line between the stubs is nominally chosen to be an eighth of a line wavelength. However, if this will not realize the match, the length of line is computed such that the rotated circle on the Smith chart encloses the load admittance.

4. MTEE component width constraint violations will be avoided generally by choosing similar characteristic impedances for the line, stub, and feed.

5. Since two solutions are possible, the solution that results in the smallest length of stub 1 is chosen. For example, if stub 1 is open circuited, the solution for which stub 1 must realize a capacitive reactance is chosen.


**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

The input port termination is set to the conjugate of \( Z_{\text{in}} \) so that the ideal input reflection coefficient will be zero. The output port termination is set to \( Z_{\text{load}} \).

**Optimization Assistant Usage**

For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the value of \( S_{11} \) (referenced to the conjugate of \( Z_{\text{in}} \)) at the design center frequency by changing the length of the stubs. Both stubs are tuned by the same length.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A double-stub matching network was designed to match a load impedance of 100 - j30 ohms to a 50 ohm line at a center frequency of 5 GHz with open circuited stubs. Tuning using the Optimization Assistant yielded a value of \( \Delta = -31.633 \text{ mil} \).  

---

SmartComponent List 9-17
SmartComponent Reference

MSub
MSUB
MSub1
H=30 mil
E=3.2

DA_DSMatch1_test
DA_DSMatch1
Subst="MSub1"
F=5 GHz
Zin=50 Ohm
Zcage=(100-j30) Ohm
Zstub1=50 Ohm
Zstub2=50 Ohm
Zline=50 Ohm
Delt=-31.633 mil

![Graph with frequency and S parameter dB vs. frequency](image)

9-18 SmartComponent List
HPFilter (Hairpin Filter)

Symbol

Summary

A hairpin filter provides a bandpass frequency response between the input and output ports. N coupled-line sections produce an N-1 order filter response. Additional numbers of sections can be used to steepen the transition band roll off or widen the pass bandwidth.

Note

A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters

Subst = microstrip substrate name
Fs1 = lower stopband edge frequency, in hertz
Fp1 = lower passband edge frequency, in hertz
Fp2 = upper passband edge frequency, in hertz
Fs2 = lower stopband edge frequency, in hertz
Ap = passband edge attenuation (or ripple for Chebyshev), in dB
As = stopband edge attenuation, in dB
N = number of filter sections (or 0 to compute N)
ResponseType = type of frequency response (maximally flat or Chebyshev)
Zo = desired input/output impedance, in ohms
Sphys = physical spacing between legs within hairpin resonator (set to zero if Selec specified)
Selec = spacing between legs within hairpin resonator in wavelengths (set to zero if Sphys specified)
Delta = length added to coupled sections for tuning performance

Palette
Passive Circuit - Filters

**Available Automated-Assistants**

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

**Design Assistant Usage**

For general information, refer to Chapter 4, Design Assistant.

1. Because of the heavy computational burden in determining the line parameters, a brief delay will occur for the design.

2. For a Chebyshev (equal ripple) frequency response, ripple levels greater than about 1 dB are not recommended. Exceeding this value will typically deform the shape of the passband characteristics.

3. If N is zero, the number of filter sections will be computed from the frequency/attenuation information. If N is non-zero, the design will use the frequency/attenuation parameters only for determining the design center frequency.


**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**

For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the absolute difference between $S_{21}$ in dB and the specified passband edge attenuation (which equals the ripple for Chebyshev response) at the passband edge frequencies. Because only the line lengths are changed, this tuning will typically center the response within the specified passband. More advanced shaping of the passband response can be accomplished by manually tuning the widths and spacings of the coupled filter sections.

**Display Assistant Usage**

For general information, refer to the Chapter 7, Display Assistant chapter.

**Example**

A hairpin filter was designed for a maximally flat response with the 3 dB passband edge frequencies at 2 GHz and 2.2 GHz respectively. The design required 4-coupled sections. Tuning using the Optimization Assistant yielded a value of $\Delta = -41.682$ mil.
**IDFilter (Interdigital Filter)**

**Symbol**

![Symbol](image)

**Summary**

An interdigital filter provides a bandpass frequency response between the input and output ports. N coupled-line sections produce an N-1 order filter response. Additional numbers of sections can be used to steepen the transition band roll off or widen the pass bandwidth.

---

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

---

**Parameters**

- **Subst** = microstrip substrate name
- **Fs1** = lower stopband edge frequency, in hertz
- **Fp1** = lower passband edge frequency, in hertz
- **Fp2** = upper passband edge frequency, in hertz
- **Fs2** = lower stopband edge frequency, in hertz
- **Ap** = passband edge attenuation (or ripple for Chebyshev), in dB
- **As** = stopband edge attenuation, in dB
- **N** = number of filter sections (or 0 to compute N)
- **ResponseType** = type of frequency response (maximally flat or Chebyshev)
- **Zo** = desired input/output impedance, in ohms
- **ya** = normalized interior resonator admittance (0 < ya < 1)
- **CouplingType** = type of input/output coupling (coupled line or tapped line transformer)
- **Delta** = length added to coupled sections for tuning performance

**Palette**

Passive Circuit - Filters
Available Automated-Assistants

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage

For general information, refer to Chapter 4, Design Assistant.

1. Because of the heavy computational burden in determining the line parameters, a brief delay will occur for the design.

2. A two-layer substrate must be used for this topology.

3. For a Chebyshev (equal ripple) frequency response, ripple levels greater than about 1 dB are not recommended. Exceeding this value will typically deform the shape of the passband characteristics.

4. If N is zero, the number of filter sections will be computed from the frequency/attenuation information. If N is non-zero, the design will use the frequency/attenuation parameters only for determining the design center frequency.

5. Using a CouplingType of “Coupled Line Transformer Input” will use an extra coupled line section on the inputs and outputs to feed the device. Choosing “Tapped Line Transformer Input” will bring the feedline directly into the first resonator.


Simulation Assistant Usage

For general information, refer to Chapter 5, Simulation Assistant.

Optimization Assistant Usage

For general information, refer to Chapter 6, Optimization Assistant

The optimization minimizes the absolute difference between S21 in dB and the specified passband edge attenuation (which equals the ripple for Chebyshev response) at the passband edge frequencies. Because only the line lengths are changed, this tuning will typically center the response within the specified passband. More advanced shaping of the passband response can be accomplished by manually tuning the widths and spacings of the coupled filter sections.

Display Assistant Usage

For general information, refer to Chapter 7, Display Assistant.

Example
An interdigital filter was designed for a maximally flat response with the 3 dB passband edge frequencies at 2 GHz and 2.2 GHz respectively. The design required 5 coupled lines. Tuning using the Optimization Assistant yielded a value of Delta = 14.979 mil.
LCoupler (Lange Coupler)

Summary
A Lange coupler outputs from pin 2 a small fraction of the power presented at the input (pin 1). The remainder of the power is passed through pin 3. The coupling coefficient specifies the power ratio $P_1/P_2$. Pin 4 is isolated, and often the isolation is 10 dB better than the coupling coefficient in microstrip realizations.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = center frequency, in hertz
C = coupling coefficient, in dB
N = number of fingers (4, 6, or 8)
Zo = characteristic impedance, in ohms
Delta = length added to fingers for tuning performance

Palette
Passive Circuit - Couplers

Available Automated-Assistants
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.
1. The Lange coupler is best for weak couplings of roughly 10 dB or more (C >10dB). Choosing the coupling coefficient too small may produce an unrealizable design. If the design creates a finger spacing S that is not realizable, increase the value of N.

2. The Design Assistant computes the required even and odd mode impedances to achieve the desired coupling and translates them to finger width and spacing. The length of the fingers is a quarter wavelength at the design frequency.


**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**

For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the absolute difference between S21 and the specified coupling coefficient at the design center frequency by changing the length of the fingers section.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A Lange coupler was designed for a center frequency of 3 GHz with 20 dB of coupling and 6 fingers. Tuning using the Optimization Assistant yielded a value of Delta = -4.57 mil.

```
MSUB
MSub1
h=30 mil
Er=3.2

DA_LCoupler1
Subst="MSub1"
F=3 GHz
C=20 dB
N=6
Zo=50 Ohm
Delta=-4.57 mil
```
LEMatch (Lumped Component Match)

Symbol

Summary

A lumped component matching network uses reactive components to match a complex load impedance (Zload) to a desired complex input impedance (Zin).

Note: A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters

F = center frequency, in hertz
Zin = desired complex input impedance, in ohms
Zload = complex load impedance to match, in ohms
NetworkType = type of network (source to load)

Palette

Passive Circuit - Matching

Available Automated-Assistants

Design Assistant, Simulation Assistant, Display Assistant

Design Assistant Usage

For general information, refer to Chapter 4, Design Assistant.

1. The network type specifies the type of reactive components used (L represents inductance, C represents capacitance) as well as their orientation (series or shunt). The first component specified is that nearest the source, while the second is that nearest the load. If the chosen network type cannot realize the impedance match specified, or if the network type is chosen as “Allow Selection”, a dialog box will appear allowing selection from the possible network types that can perform the match.
2. Either two or four distinct networks are possible depending on the load and input impedance specified.


**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

The input port termination is set to the conjugate of Zin so that the ideal input reflection coefficient will be zero. The output port termination is set to Zload.

**Optimization Assistant Usage**

No optimization assistant is provided since the design procedure is exact for ideal lumped component models.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A lumped component matching network was designed to match a load impedance of 100 - j30 ohms to an input impedance of 50 ohms at a center frequency of 1 GHz. A Series L Shunt C configuration was used to realize this match.

![Diagram](image)

- **MSUB**
- **MSub1**
- **H=30 mil**
- **Er=3.2**

- **DA_LEMatch1_test**
- **DA_LEMatch1**
- **F=1 GHz**
- **Zin=50 Ohm**
- **Zload=(100-j*30) Ohm**
SmartComponent Reference

![Graph of SmartComponent Reference with frequency and magnitude (dB) axes.]}
MBend (Microstrip Bend Component)

Symbol

Summary

MBend designs a microstrip bend given the substrate, desired characteristic impedance, and bend properties. The design will realize the native MBEND, MBEND2, or MBEND3 components.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters

Subst = microstrip substrate name
F = design frequency, in hertz
Zo = desired characteristic impedance, in ohms
BendType = type of bend
Angle = angle of bend (for arbitrary angle/miter bend)
M = miter fraction (for arbitrary angle/miter bend)

Palette

Passive Circuit - Lines

Available Automated-Assistants

Design Assistant

Design Assistant Usage

For general information, refer to Chapter 4, Design Assistant.

1. Since the design uses the models inherent to ADS to compute the line width, there is no need for a dedicated Simulation Assistant, Optimization Assistant, or Display Assistant.
2. **BendType** can be **Arbitrary Angle/Miter (MBEND)**, **90 Degree/Miter (MBEND2)**, or **90 Degree/Optimal Miter (MBEND3)**. The parameters **Angle** and **M** are only used for MBEND realizations. Refer to the discussion of these components in the ADS Microstrip Components documentation for a more detailed description.
MBStub (Microstrip Butterfly Radial Stub)

Symbol

Summary
MBStub designs a microstrip butterfly radial stub given the substrate, desired input reactance, and stub dimensions.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = design frequency, in hertz
Xin = desired input reactance, in ohms (only one of Xin, Cin, and Lin can be non-zero)
Cin = desired input capacitance, in farads (only one of Xin, Cin, and Lin can be non-zero)
Lin = desired input inductance, in henries (only one of Xin, Cin, and Lin can be non-zero)
W = width of feed line (set to zero if Z specified)
Z = characteristic impedance of feed line (set to zero if W specified)
Angle = subtended angle of circular sector
d = insertion depth of circular sector in feed line
Delta = length added to stub for tuning performance

Palette
Passive Circuit - Lines

Available Automated-Assistants
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. The stub is designed by dividing the radial lines into several short segments.

2. For proper operation, only one of Xin, Cin, and Lin can be non-zero. If all are zero, the stub is designed to provide an open circuit.

3. Refer to the discussion of the MBSTUB component in the Microstrip Components documentation for a more detailed description of the model used for this component.

Simulation Assistant Usage
For general information, refer to Chapter 5, Simulation Assistant.

Optimization Assistant Usage
For general information, refer to Chapter 6, Optimization Assistant

The optimization changes the length of the stubs to achieve the desired input reactance.

Display Assistant Usage
For general information, refer to Chapter 7, Display Assistant.

Example
A MBStub component was used to design an open circuit stub at a center frequency of 1 GHz. Optimization yielded a value of Delta = 88.786 mil.

```
MSUB
MStub
H=30 mil
Er=3.2

DA_MBSStub1
Stub="MStub1"
F=1 GHz
Xin=0 Ohm
Cin=0 pF
Lin=0 nH
W=0 mil
Z=60 Ohm
Angle=60
D=3 mil
Delta=86.786 mil
```
MCFil (Microstrip Coupled Filter Component)

**Symbol**

![Symbol Image]

**Summary**
MCFil designs a microstrip coupled filter component given the substrate, desired even- and odd-mode characteristic impedances, and physical or electrical length.

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

**Parameters**
- Subst = microstrip substrate name
- F = design frequency, in hertz
- Zoe = desired even-mode characteristic impedance, in ohms
- Zoo = desired odd-mode characteristic impedance, in ohms
- Zo1 = characteristic impedance of input line at port 1, in ohms
- Zo2 = characteristic impedance of input line at port 2, in ohms
- Lphys = physical line length (set to zero if Lelec specified)
- Lelec = line length in wavelengths (set to zero if Lphys specified)

**Palette**
Passive Circuit - Lines

**Available Automated-Assistants**
Design Assistant

**Design Assistant Usage**
For general information, refer to Chapter 4, Design Assistant.
1. Since the design uses the models inherent to ADS to compute the line width, there is no need for a dedicated Simulation Assistant, Optimization Assistant, or Display Assistant.

2. For proper operation, either Lphys or Lelec must be zero.

3. Zo1 and Zo2 specify the impedance of the lines attached to this component and are provided to ensure proper pin location in the layout. Refer to the discussion of the MCFIL component in the Microstrip Components documentation for a more detailed description of the model used for this component.
**MCLine (Microstrip Coupled Line Component)**

**Symbol**

![Symbol](image)

**Summary**

MCLine designs a microstrip coupled line component given the substrate, desired even- and odd-mode characteristic impedances, and physical or electrical length.

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

**Parameters**

- **Subst** = microstrip substrate name
- **F** = design frequency, in hertz
- **Zoe** = desired even-mode characteristic impedance, in ohms
- **Zoo** = desired odd-mode characteristic impedance, in ohms
- **Zo1** = characteristic impedance of input line at port 1, in ohms
- **Zo2** = characteristic impedance of input line at port 2, in ohms
- **Zo3** = characteristic impedance of input line at port 3, in ohms
- **Zo4** = characteristic impedance of input line at port 4, in ohms
- **Lphys** = physical line length (set to zero if Lelec specified)
- **Lelec** = line length in wavelengths (set to zero if Lphys specified)

**Palette**

Passive Circuit - Lines

**Available Automated-Assistants**

Design Assistant

**Design Assistant Usage**
For general information, refer to Chapter 4, Design Assistant

1. Since the design uses the models inherent to ADS to compute the line width, there is no need for a dedicated Simulation Assistant, Optimization Assistant, or Display Assistant.

2. For proper operation, either Lphys or Lelec must be zero.

3. Zo1 through Zo4 specify the impedance of the lines attached to this component and are provided to ensure proper pin location in the layout. Refer to the discussion of the MCFIL component in the Microstrip Components documentation for a more detailed description of the model used for this component.
MCorn (Microstrip Corner Component)

Symbol

Summary
MCorn designs a microstrip corner component given the substrate and characteristic impedance of the input and output lines.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = design frequency, in hertz
Zo = desired characteristic impedance, in ohms

Palette
Passive Circuit - Lines

Available Automated-Assistants
Design Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. Since the design uses the models inherent to ADS to compute the line width, there is no need for a dedicated Simulation Assistant, Optimization Assistant, or Display Assistant.
2. Refer to the discussion of the MCORN component in the Microstrip Components documentation for a more detailed description of the model used for this component.
**MCross (Microstrip Cross Component)**

**Symbol**

![Symmetrical Cross Component symbol](image)

**Summary**

MCross designs a microstrip cross given the substrate, desired characteristic impedance on each port, and bend properties. The design will realize the native MCURVE and MCURVE2 components.

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

**Parameters**

Subst = microstrip substrate name

F = design frequency, in hertz

Z1 = characteristic impedance of port 1, in ohms

Z2 = characteristic impedance of port 2, in ohms

Z3 = characteristic impedance of port 3, in ohms

Z4 = characteristic impedance of port 4, in ohms

**Palette**

Passive Circuit - Lines

**Available Automated-Assistants**

Design Assistant

**Design Assistant Usage**

For general information, refer to Chapter 4, Design Assistant.

1. Since the design uses the models inherent to ADS to compute the line width, there is no need for a dedicated Simulation Assistant, Optimization Assistant, or Display Assistant.
2. Refer to the discussion of the MCROSS component in the Microstrip Components documentation for a detailed description of this component.
MCurve (Microstrip Curve Component)

Symbol

Summary
MBind designs a microstrip bend given the substrate, desired characteristic impedance, and bend properties. The design will realize the native MCURVE and MCURVE2 components.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = design frequency, in hertz
Zo = desired characteristic impedance, in ohms
Angle = angle of curve
Radius = radius of curvature (set to zero if Lelec specified)
Lelec = curve length in wavelengths (set to zero if Radius specified)
CurveType = type of curve
Nmode = number of modes (for Waveguide Model)

Palette
Passive Circuit - Lines

Available Automated-Assistants
Design Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.
1. Since the design uses the models inherent to ADS to compute the line width, there is no need for a dedicated Simulation Assistant, Optimization Assistant, or Display Assistant.

2. Either Lelec or Radius must be zero for proper operation.

3. BendType can be Transmission Line Model (MCURVE) or Magnetic Wall Waveguide Model (MCURVE2). The parameter Nmode is used only for MCURVE2. Refer to the discussion of these components in the Microstrip Components documentation for a more detailed description.
**MGap (Microstrip Gap Component)**

**Symbol**

[Diagram of MGap symbol]

**Summary**

MGap designs a microstrip gap given the substrate, desired characteristic impedance, and gap width.

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

**Parameters**

- **Subst** = microstrip substrate name
- **F** = design frequency, in hertz
- **Zo** = desired characteristic impedance, in ohms
- **S** = length of gap (spacing)

**Palette**

Passive Circuit - Lines

**Available Automated-Assistants**

Design Assistant

**Design Assistant Usage**

For general information, refer to Chapter 4, Design Assistant.

1. Since the design uses the models inherent to ADS to compute the line width, there is no need for a dedicated Simulation Assistant, Optimization Assistant, or Display Assistant.

2. Refer to the discussion of the MGAP component in the Microstrip Components documentation for a detailed description of this component.
SmartComponent Reference

**MICapP (Microstrip 4-port Interdigital Capacitor)**

**Symbol**

![Symbol](image)

**Summary**

MICapP designs a capacitance between two adjacent microstrip lines using interdigital fingers. The underlying design uses the MICAP2 component contained in the Tlines-Microstrip palette.

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

**Parameters**

- Subst = microstrip substrate name
- F = center frequency, in hertz
- C = capacitance, in farads
- W = width of fingers
- G = gap between fingers
- Ge = gap at end of fingers
- Np = number of finger pairs
- Wt = width of interconnect (0 if Zt specified)
- Zt = characteristic impedance of interconnect lines, in ohms (0 if Wt specified)
- Delta = length added to fingers for tuning performance

**Palette**

Passive Circuit - RLC

**Available Automated-Assistants**

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

**Design Assistant Usage**
The design is accomplished using a simple model that specifies the length required to achieve the capacitance $C$ at the design center frequency given the remaining physical parameters. If the computed length is unreasonable, decreasing or increasing the gap $G$ will increase or decrease the capacitance, respectively and therefore allow altering of the length.

2. Both $W_t$ and $Z_t$ specify the properties of the interconnect line. For proper operation, make sure that only one of these parameters is non-zero.

3. For more detailed discussion of the parameters $W$, $G$, $G_e$, $N_p$, and $W_t$, please refer to the discussion of MICAP2 in the Microstrip Components documentation.

**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**

For general information, refer to Chapter 6, Optimization Assistant.

The Optimization Assistant tunes the length of the fingers to achieve the desired capacitance. Because of the simple design approach used, it is often wise to first roughly tune the design within the Simulation Assistant and subsequently use the optimizer to perform the fine tuning.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A MICapP component was used to design a 1 pF capacitance between two 50 ohm lines at a center frequency of 5 GHz. Optimization yielded a value of $\Delta = -22.19$ mil.
SmartComponent Reference

SmartComponent List

MSUB
MSUB1
H=30 mil
Er=3.2

DA_MICap_pTest
DA_MICapP1
Substr=MSUB1
F=6 GHz
C=1 pF
W=5 mil
G=5 mil
Np=3
W=0 mil
Zt=60 Ohm
Delta=-22.19 mil

![Graph showing C vs Frequency](image)

- Actual C
- Desired C

Frequency (GHz)

C (pF)

A
B
MICapPG (Microstrip Grounded 2-port Interdigital Capacitor)

Symbol

Summary

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

MICapPG designs a capacitance between a microstrip line and ground using interdigital fingers. The underlying design uses the MICAP4 component contained in the Tlines-Microstrip pallette.

**Parameters**

Subst = microstrip substrate name
F = center frequency, in hertz
C = capacitance, in farads
W = width of fingers
G = gap between fingers
Ge = gap at end of fingers
Wt = width of interconnect (0 if Zt specified)
Zt = characteristic impedance of interconnect lines, in ohms (0 if Wt specified)
Delta = length added to fingers for tuning performance

**Palette**

Passive Circuit - RLC

**Available Automated-Assistants**

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

**Design Assistant Usage**

For general information, refer to Chapter 4, Design Assistant.
1. The design is accomplished using a simple model that specifies the length required to achieve the capacitance \( C \) at the design center frequency given the remaining physical parameters. If the computed length is unreasonable, decreasing or increasing the gap \( G \) will increase or decrease the capacitance, respectively and therefore allow altering of the length.

2. Both \( W_t \) and \( Z_t \) specify the properties of the interconnect line. For proper operation, make sure that only one of these parameters is non-zero.

3. For more detailed discussion of the parameters \( W, G, G_e, N_p, \) and \( W_t \), please refer to the discussion of MICAP4 in the Microstrip Components documentation.

**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**

For general information, refer to Chapter 6, Optimization Assistant.

The Optimization Assistant tunes the length of the fingers to achieve the desired capacitance. Because of the simple design approach used, it is often wise to first roughly tune the design within the Simulation Assistant and subsequently use the optimizer to perform the fine tuning.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A MICapPG component was used to design a 1 pF capacitance from a 50 ohm microstrip line and ground at a center frequency of 5 GHz. Optimization yielded a value of \( \Delta = -21.355 \) mil.
MICapS (Microstrip 2-port Interdigital Capacitor)

Symbol

Summary

MICapS designs a series capacitance within a microstrip line using interdigital fingers. The underlying design uses the MICAP1 component contained in the Tlines-Microstrip palette.

Note

A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters

Subst = microstrip substrate name
F = center frequency, in hertz
C = capacitance, in farads
W = width of fingers
G = gap between fingers
Ge = gap at end of fingers
Np = number of finger pairs
Wf = width of feed line (0 if Zf specified)
Zf = characteristic impedance of feed line, in ohms (0 if Wf specified)
Delta = length added to fingers for tuning performance

Palette

Passive Circuit - RLC

Available Automated-Assistants

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage
1. The design is accomplished using a simple model that specifies the length required to achieve the capacitance $C$ at the design center frequency given the remaining physical parameters. If the computed length is unreasonable, decreasing or increasing the gap $G$ will increase or decrease the capacitance, respectively and therefore allow altering of the length.

2. Both $W_f$ and $Z_f$ specify the properties of the feed line. For proper operation, make sure that only one of these parameters is non-zero.

3. For more detailed discussion of the parameters $W$, $G$, $Ge$, $Np$, $Wt$, and $Wf$, please refer to the discussion of MICAP1 in the Microstrip Components documentation.

**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**

For general information, refer to Chapter 6, Optimization Assistant.

The Optimization Assistant tunes the length of the fingers to achieve the desired capacitance. Because of the simple design approach used, it is often wise to first roughly tune the design within the Simulation Assistant and subsequently use the optimizer to perform the fine tuning.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A MICapS component was used to design a 1 pF series capacitance for a 50 ohm line at a center frequency of 5 GHz. Optimization yielded a value of Delta = 2.443 mil.
SmartComponent Reference

MSub

MSUB
MSub1
H=30 mil
Er=3.2

DA_MiCapS1_post
DA_MiCapS1
Subst="MSub1"
F=5 GHz
C=1 pF
W=6 mil
G=5 mil
Ge=6 mil
n=3
Wt=26 mil
Wf=0 mil
Zf=50 Ohm
Delta=2.443 mil

![Graph showing C (µF) vs Frequency (GHz)]

- Actual C
- Desired C

9-54 SmartComponent List
**MICapSG (Microstrip 1-port Interdigital Capacitor)**

**Symbol**

![Symbol Image]

**Summary**

MICapSG designs a series capacitance between a microstrip line and ground using interdigital fingers. The underlying design uses the MICAP3 component contained in the Tlines-Microstrip pallette.

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

**Parameters**

Subst = microstrip substrate name
F = center frequency, in hertz
C = capacitance, in farads
W = width of fingers
G = gap between fingers
Ge = gap at end of fingers
Np = number of finger pairs
Wt = width of interconnect
Wf = width of feed line (0 if Zf specified)
Zf = characteristic impedance of feed line, in ohms (0 if Wf specified)
Delta = length added to fingers for tuning performance

**Palette**

Passive Circuit - RLC

**Available Automated-Assistants**

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant
**SmartComponent Reference**

**Design Assistant Usage**
For general information, refer to Chapter 4, Design Assistant.

1. The design is accomplished using a simple model that specifies the length required to achieve the capacitance C at the design center frequency given the remaining physical parameters. If the computed length is unreasonable, decreasing or increasing the gap G will increase or decrease the capacitance, respectively and therefore allow altering of the length.

2. Both Wf and Zf specify the properties of the feed line. For proper operation, make sure that only one of these parameters is non-zero.

3. For more detailed discussion of the parameters W, G, Ge, Np, Wt, and Wf, please refer to the discussion of MICAP3 in the Microstrip Components documentation.

**Simulation Assistant Usage**
For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**
For general information, refer to Chapter 6, Optimization Assistant.

The Optimization Assistant tunes the length of the fingers to achieve the desired capacitance. Because of the simple design approach used, it is often wise to first roughly tune the design within the Simulation Assistant and subsequently use the optimizer to perform the fine tuning.

**Display Assistant Usage**
For general information, refer to Chapter 7, Display Assistant.

**Example**
A MICapSG component was used to design a 1 pF capacitance for a 50 ohm line at a center frequency of 5 GHz. Optimization yielded a value of Delta = -1.841 mil.
MLine (Microstrip Line)

Symbol

Summary
MLine designs a microstrip line given the substrate, desired characteristic impedance, and physical or electrical length.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
- Subst = microstrip substrate name
- F = design frequency, in hertz
- Zo = desired characteristic impedance, in ohms
- Lphys = physical line length (set to zero if Lelec specified)
- Lelec = line length in wavelengths (set to zero if Lphys specified)

Palette
Passive Circuit - Lines

Available Automated-Assistants
Design Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. Since the design uses the models inherent to ADS to compute the line width and length, there is no need for a dedicated Simulation Assistant, Optimization Assistant, or Display Assistant.
2. For proper operation, either Lphys or Lelec must be zero.
3. Refer to the discussion of the MLIN component in the Microstrip Components documentation for a more detailed description of the model used for this component.
MMndr (Microstrip Meander Line)

Symbol

Summary

MMndr designs a meandering microstrip line given the substrate, desired characteristic impedance, physical or electrical length, and maximum rectangular dimensions of the line.

Note

A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters

Subst = microstrip substrate name
F = design frequency, in hertz
Zo = desired characteristic impedance, in ohms
Lphys = physical line length (set to zero if Lelec specified)
Lelec = line length in wavelengths (set to zero if Lphys specified)
WR = bounding rectangle width, in meters
HR = bounding rectangle height, in meters
Delta = length added to vertical lines for tuning performance

Palette

Passive Circuit - Lines

Available Automated-Assistants

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage

For general information, refer Chapter 4, Design Assistant.

1. The line input and output ports will be at the center of the rectangle on the side characterized by HR.
2. The final width and height of the bounding box may be smaller than that specified depending on the desired length.

3. For proper operation, either \( L_{\text{phys}} \) or \( L_{\text{elec}} \) must be zero.

4. Refer to the discussion of the MLIN component in the Microstrip Components documentation for a more detailed description of the model used for this component.

**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**

For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the absolute difference between the transmission phase and that resulting from the specified length. Only the vertical dimension is optimized, and since the corners tend to add excess phase delay the resulting height will be slightly smaller than specified.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A MMndr component was used to design a 1-wavelength line in a 1-inch by -inch square area at a center frequency of 1 GHz. Optimization yielded a value of \( \Delta = -10.469 \) mil.

---

A MMndr component was used to design a 1-wavelength line in a 1-inch by -inch square area at a center frequency of 1 GHz. Optimization yielded a value of \( \Delta = -10.469 \) mil.
MREInd (Microstrip Elevated Rectangular Inductor)

Symbol

Summary
MREInd designs an elevated microstrip rectangular inductor. The underlying design uses the MRINDELA component contained in the Tlines-Microstrip palette.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = center frequency, in hertz
L = inductance, in henries
Ln = length of innermost segment (0 means full length)
Ln1 = length of second innermost segment
Ln2 = length of second innermost segment
W = conductor width
Ri = resistivity (relative to gold) of conductors
Sx = spacing limit between support posts (0 to ignore posts)
Cc = coefficient for capacitance of corner support posts
Cs = coefficient for capacitance of support posts along segment
Wu = width of underpass strip conductor
Au = angle of departure from innermost segment
UE = extension of underpass beyond inductor
Delta = incremental number of segments for tuning inductance (need not be integer)
Palette
Passive Circuit - RLC

Available Automated-Assistants
Design Assistant, Simulation Assistant, Display Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. The design is accomplished using a simple model that specifies the number of segments in the rectangular inductor required to achieve the inductance L at the design center frequency given the remaining physical parameters.

2. The parameters from Hi through Cs are not actually used in the design process, and therefore final tuning is required to achieve the proper value of the inductance.

3. The tuning parameter Delta represents the number of additional segments to add to the outside of the structure. If it is not an integer value, the outermost segment (L1) will not be full length, with the fractional remainder of Delta specifying the fractional length of this outermost segment.

4. The values Ln, Ln1, and Ln2 represent the lengths Ln, Ln-1, and Ln-2 associated with the MRINDELA component. For more detailed discussion of these lengths as well as the parameters from W through UE, please refer to the discussion of MRINDELA in the Microstrip Components documentation.

Simulation Assistant Usage
For general information, refer to Chapter 5, Simulation Assistant.

Optimization Assistant Usage
Because of the difficulties associated with tuning the inductor using additional discrete segments, no Optimization Assistant is provided. However, tuning can be accomplished quite effectively by manually updating the value of Delta from within the Simulation Assistant. refer to Chapter 5, Simulation Assistant, as well as the following example for more details.

Display Assistant Usage
For general information, refer to Chapter 7, Display Assistant.

Example
A MREInd component was used to design a 1 nH inductor at a center frequency of 3 GHz. The design used a full-length innermost segment. By tuning the number of segments within the
Simulation Assistant, it was determined that a value of Delta = 1.63 would achieve the desired inductance.
**MRInd (Microstrip Rectangular Inductor)**

**Symbol**

```
  1
  |
  |
  |
  2
```

**Summary**

MRInd designs a microstrip rectangular inductor. The underlying design uses the MRINDNBR and MRINDWBR components contained in the Tlines-Microstrip palette.

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

**Parameters**

- **Subst** = microstrip substrate name
- **F** = center frequency, in hertz
- **L** = inductance, in henries
- **IndType** = inductance type (no bridge or wire bridge)
- **Ln** = length of innermost segment (0 means full length)
- **Ln1** = length of second innermost segment
- **Ln2** = length of second innermost segment
- **W** = conductor width
- **S** = conductor spacing
- **Rb** = resistivity (relative to gold) of bridge wire (for wire bridge)
- **Hw** = height of wire above inductor (for wire bridge)
- **Aw** = angle of departure from innermost segment (for wire bridge)
- **WE** = extension of bridge beyond inductor (for wire bridge)
- **Delta** = incremental number of segments for tuning inductance (need not be integer)

**Palette**
Passive Circuit - RLC

**Available Automated-Assistants**

Design Assistant, Simulation Assistant, Display Assistant

**Design Assistant Usage**

For general information, refer to Chapter 4, Design Assistant.

1. The design is accomplished using a simple model that specifies the number of segments in the rectangular inductor required to achieve the inductance L at the design center frequency given the remaining physical parameters.

2. The parameters Rb and Hw are not actually used in the design process, and therefore final tuning is required to achieve the proper value of the inductance.

3. The value of IndType specifies the type of inductor that will be designed. If this parameter is set to “No Bridge”, then the MRINDNBR component is designed and the parameters from Dw to WE are ignored. If the parameter is set to “Wire Bridge”, then the MRINDWBR component is designed and the parameters from Dw to WE are used.

4. The tuning parameter Delta represents the number of additional segments to add to the outside of the structure. If it is not an integer value, the outermost segment (L1) will not be full length, with the fractional remainder of Delta specifying the fractional length of this outermost segment.

5. The values Ln, Ln1, and Ln2 represent the lengths Ln, Ln-1, and Ln-2 associated with the MRINDNBR and MRINDWBR components. For more detailed discussion of these lengths as well as the parameters W through WE, please refer to the discussion of these components in the Microstrip Components documentation.

**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**

Because of the difficulties associated with tuning the inductor using additional discrete segments, no Optimization Assistant is provided. However, tuning can be accomplished quite effectively by manually updating the value of Delta from within the Simulation Assistant, refer to Chapter 5, Simulation Assistant, as well as the following example for more details.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**
A MRInd component with no bridge was used to design a 1 nH inductor at a center frequency of 3 GHz. The design used a full-length innermost segment. By tuning the number of segments within the Simulation Assistant, it was determined that a value of Delta = 0.52 would achieve the desired inductance.
MRStub (Microstrip Radial Stub)

Symbol

Summary
MRStub designs a microstrip radial stub given the substrate, desired input reactance, and stub dimensions.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = design frequency, in hertz
Xin = desired input reactance, in ohms (only one of Xin, Cin, and Lin can be non-zero)
Cin = desired input capacitance, in farads (only one of Xin, Cin, and Lin can be non-zero)
Lin = desired input inductance, in henries (only one of Xin, Cin, and Lin can be non-zero)
W = width of feed line (set to zero if Z specified)
Z = characteristic impedance of feed line (set to zero if W specified)
Angle = subtended angle of circular sector
Delta = length added to stub for tuning performance

Palette
Passive Circuit - Lines

Available Automated-Assistants
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.
1. The stub is designed by dividing the radial line into several short segments.
2. For proper operation, only one of Xin, Cin, and Lin can be non-zero. If all are zero, the stub is designed to provide an open circuit.
3. Refer to the discussion of the MRSTUB component in the Microstrip Components documentation for a more detailed description of the model used for this component.

**Simulation Assistant Usage**
For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**
For general information, refer to Chapter 6, Optimization Assistant.

The optimization changes the length of the stubs to achieve the desired input reactance.

**Display Assistant Usage**
For general information, refer to Chapter 7, Display Assistant.

**Example**
A MRStub component was used to design an open circuit stub at a center frequency of 1 GHz. Optimization yielded a value of Delta = -40.092 mil.
**MSInd (Microstrip Spiral Inductor)**

**Symbol**

![Symbol Image]

**Summary**

MSInd designs a microstrip spiral inductor. The underlying design uses the MSIND component contained in the Tlines-Microstrip palette.

**Note**

A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

**Parameters**

- **Subst** = microstrip substrate name
- **F** = center frequency, in hertz
- **Ri** = inner radius measured to center of conductor
- **W** = conductor width
- **S** = conductor spacing
- **W1** = width of strip connected to pin 1
- **W2** = width of strip connected to pin 2
- **Delta** = incremental number of turns for tuning inductance (need not be integer)

**Palette**

Passive Circuit - RLC

**Available Automated-Assistants**

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

**Design Assistant Usage**

For general information, refer to Chapter 4, Design Assistant.
1. The design is accomplished using a simple model that specifies the number of turns in the spiral inductor required to achieve the inductance $L$ at the design center frequency given the remaining physical parameters.

2. The value of $R_i$ specifies the distance from the center of the inductor to the center of the conductor at its innermost point in the spiral. Refer to the discussion of the MSIND component in the Microstrip Components documentation for a more detailed discussion of this parameter.

3. The tuning parameter $\Delta$ represents the number of additional turns to add to the outside of the structure. Fractional numbers of turns are accommodated (i.e., $\Delta$ need not be an integer value).

**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**

For general information, refer to Chapter 6, Optimization Assistant.

The Optimization Assistant tunes the number of turns to achieve the desired inductance.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A MSInd component was used to design a 1 nH inductor at a center frequency of 3 GHz. Optimization yielded a value of $\Delta = -0.53$. 

![Component Diagram]
MStep (Microstrip Step Component)

Symbol

Summary
MStep designs a microstrip step given the substrate and desired characteristic impedances.

Note
A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = design frequency, in hertz
Z1 = characteristic impedance of port 1, in ohms
Z2 = characteristic impedance of port 2, in ohms

Palette
Passive Circuit - Lines

Available Automated-Assistants
Design Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. Since the design uses the models inherent to ADS to compute the line width, there is no need for a dedicated Simulation Assistant, Optimization Assistant, or Display Assistant.

2. Refer to the discussion of the MSTEP component in the Microstrip Components documentation for a detailed description of this component.
MStub (Microstrip Stub)

Symbol

Summary
MStub designs a microstrip open or short circuited stub given the substrate, desired characteristic impedance, and physical or electrical length. The design will realize the native MLOC, MLSC, and MLEF components.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = design frequency, in hertz
Zo = desired characteristic impedance, in ohms
Lphys = physical line length
Lelec = line length in wavelengths
Xin = desired input reactance, in ohms
Cin = desired input capacitance, in farads
Lin = desired input inductance, in henries
StubType = type of stub

Only one of Lphys, Lelec, Xin, Cin, and Lin can be non-zero.

Palette
Passive Circuit - Lines

Available Automated-Assistants
Design Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. Since the design uses the models inherent to ADS to compute the line width and length, there is no need for a dedicated Simulation Assistant, Optimization Assistant, or Display Assistant.

2. For proper operation, only one of Lphys, Lelec, Xin, Cin, and Lin can be non-zero.

3. StubType can be either Open Circuit (MLOC), End Effect (MLEF), or Short Circuit (MLSC). Refer to the discussion of these components in the Microstrip Components documentation for a more detailed description of these different options.
MTaper (Microstrip Taper Component)

Symbol

Summary
MTaper designs a microstrip tapered line given the substrate, desired characteristic impedance, and physical or electrical length.

Note: A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = design frequency, in hertz
Z1 = characteristic impedance at port 1, in ohms
Z2 = characteristic impedance at port 2, in ohms
Lphys = physical line length (set to zero if Lelec specified)
Lelec = line length in wavelengths (set to zero if Lphys specified)

Palette
Passive Circuit - Lines

Available Automated-Assistants
Design Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. Since the design uses the models inherent to ADS to compute the line width and length, there is no need for a dedicated Simulation Assistant, Optimization Assistant, or Display Assistant.

2. For proper operation, either Lphys or Lelec must be zero.
3. Z1 and Z2 are used to determine the widths at each end of the taper component. Refer to the discussion of the MTAPER component in the Microstrip Components documentation for a more detailed description of this component.
MTee (Microstrip Tee Component)

Symbol

Summary
MTee designs a microstrip tee given the substrate and desired characteristic impedance at each port.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = design frequency, in hertz
Z1 = characteristic impedance of port 1, in ohms
Z2 = characteristic impedance of port 2, in ohms
Z3 = characteristic impedance of port 3, in ohms

Palette
Passive Circuit - Lines

Available Automated-Assistants
Design Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. Since the design uses the models inherent to ADS to compute the line width and length, there is no need for a dedicated Simulation Assistant, Optimization Assistant, or Display Assistant.
2. Z1, Z2, and Z3 are used to determine the widths of each port. Refer to the discussion of the MTEE component in the Microstrip Components documentation for a more detailed description of this component.
MTFC (Microstrip Thin Film Capacitor)

Symbol

Summary
MTFC designs a microstrip thin film capacitor. The underlying design uses the MTFC component contained in the Tlines-Microstrip pallette.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = center frequency, in hertz
C = capacitance, in farads
W = conductor width (set to 0 if Zo specified)
Zo = characteristic impedance of line for computing W (set to 0 if W specified)
CPUA = capacitance per unit area, in pf/mm^2
T = thickness of capacitor dielectric
RsT = sheet resistance of top metal plate, in ohms
RsB = sheet resistance of bottom metal plate, in ohms
TT = thickness of top metal plate
TB = thickness of bottom metal plate
COB = bottom conductor overlap
COT = top conductor overlap
DO = dielectric overlap
Delta = length added to conductor for tuning capacitance
Palette
Passive Circuit - RLC

Available Automated-Assistants
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. The design is accomplished by determining the length required to achieve the desired capacitance using the capacitance per unit area (CPUA) in conjunction with the specified width (W).

2. Since this capacitor is often fed with a microstrip line, either the physical width or the characteristic impedance of a microstrip line on the substrate can be specified. However, only one of the parameters should be non-zero.

3. The parameters from RsT through DO inclusive are not used in the design process but are passed on to the underlying MTFC component and therefore included in any simulations or optimizations.

4. The tuning parameter Delta represents incremental length required to achieve the desired capacitance. It is typically relatively small, as the initial design tends to be accurate.

Simulation Assistant Usage
For general information, refer to Chapter 5, Simulation Assistant.

Optimization Assistant Usage
For general information, refer to Chapter 6, Optimization Assistant.

The Optimization Assistant tunes the conductor length to achieve the desired capacitance.

Display Assistant Usage
For general information, refer to Chapter 7, Display Assistant.

Example
A MTFC component was used to design a 100 pF capacitor at a center frequency of 2 GHz. The conductor width corresponds to that of a 50 ohm microstrip line fabricated on MSub1. Optimization yielded a value of Delta = -2.411.
QWMatch (Quarter-Wave Match)

Symbol

Summary
A quarter-wave matching network matches a real load impedance ($R_{load}$) to a desired real input impedance ($Z_0$) using multiple quarter wavelength sections. A specified frequency response can be realized by proper design of the individual sections.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = center frequency, in hertz
DeltaF = total frequency bandwidth, in hertz
$Z_0$ = desired input impedance, in ohms
$R_{load}$ = load impedance to match, in ohms
ResponseType = type of frequency response
N = number of quarter-wave sections (set N=0 to compute N)
Rmax = maximum voltage reflection coefficient
Delta = length added to transformer sections for tuning performance

Palette
Passive Circuit - Matching

Available Automated-Assistants
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.
1. DeltaF is defined as the total bandwidth centered at the design center frequency.

2. If the number of sections N is set to zero, the Design Assistant chooses N such that the reflection coefficient is less that Rmax over the bandwidth DeltaF. The resulting bandwidth may be broader than that specified. Otherwise, Rmax and DeltaF are ignored.

3. The ResponseType specifies the distribution of the partial reflection coefficients seen at each section interface - Uniform, Binomial, and Chebyshev distributions are available. These in turn specify the shape of the reflection coefficient versus frequency.

4. A single-section quarter-wave matching transformer can be designed by setting N = 1.


**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**

For general information, refer to the Chapter 6, Optimization Assistant.

Since the reflection coefficient may not be at its minimum value at the design center frequency, the optimization centers the variation of S11 (referenced to the value of Zo) versus frequency at the center frequency by changing the length of each quarter-wave section. All sections are tuned by the same length during the optimization.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A quarter-wave matching network was designed to match a load impedance of 100 ohms to a 50 ohm line at a center frequency of 4 GHz. Specifying a Chebyshev frequency response for which the reflection coefficient remains below 0.1 over a 3 GHz bandwidth dictates 3 quarter-wave sections. Tuning using the Optimization Assistant yielded a value of Delta =-2.284 mil.
MSUB

MSub1

H=30 mil

Er=3.2

DA_Gm/Match1\_test
LAA_Gm/Match1
Sub/st="MSub1";

F=4 GHz

DeltaF=3 GHz

Zo=50 Ohm

Rload=100 Ohm

N=0

Rmax=0.1

Delta=2.204 mil

---

SmartComponent List 9-87
RRCoupler (Rat-Race Coupler)

Symbol

![Diagram of RRCoupler](image)

Summary
A rat-race coupler equally divides the power input at port 1 (or at port 4) between ports 2 and 3. When the device is fed from port 4, the output signals are 180 degrees out of phase, and therefore this device is sometimes referred to as a 180-degree hybrid. When the device is fed from port 1, the output signals are in phase. Ports 1 and 4 are isolated from each other.

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters

- **Subst** = microstrip substrate name
- **F** = center frequency, in hertz
- **Zo** = characteristic impedance, in ohms
- **Delta** = length added to ring branches for tuning

Palette

Passive Circuit - Couplers

**Available Automated-Assistants**

- Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

**Design Assistant Usage**

For general information, refer to Chapter 4, Design Assistant.

1. The design specifies the width and length of the microstrip lines to ensure that the ports are matched to Zo and equal power split is achieved at the design center frequency.

Simulation Assistant Usage
For general information, refer to Chapter 5, Simulation Assistant.

Optimization Assistant Usage
For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the value of S11 (referenced to the value of Zo) at the design center frequency by changing the length of the ring.

Display Assistant Usage
For general information, refer to Chapter 7, Display Assistant.

Example
A rat-race coupler was designed for a 50 ohm system impedance at a center frequency of 2 GHz. Tuning using the Optimization Assistant yielded a value of Delta = -2.099 mil.

---

SmartComponent List  9-89
SBFilter (Stub Bandpass Filter)

Symbol

Summary
A stub bandpass filter provides a bandpass frequency response between the input and output ports. The design uses shunt stubs connected by lengths of transmission line. If the specified passband response is too narrow, large differences in impedance values may result in a non-realizable configuration.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
Fs1 = lower stopband edge frequency, in hertz
Fp1 = lower passband edge frequency, in hertz
Fp2 = upper passband edge frequency, in hertz
Fs2 = lower stopband edge frequency, in hertz
Ap = passband edge attenuation (or ripple for Chebyshev), in dB
As = stopband edge attenuation, in dB
N = number of filter sections (or 0 to compute N)
ResponseType = type of frequency response (maximally flat or Chebyshev)
StubConfig = configuration of interior shunt stubs
Zo = desired input/output impedance, in ohms
D = impedance control parameter (0 < D < 1)
Delta = length added to stubs for tuning performance

Palette
Passive Circuit - Filters

**Available Automated-Assistants**

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

**Design Assistant Usage**

For general information, refer to *Chapter 4, Design Assistant.*

1. This design is typically practical for fractional bandwidths of 0.4 to 0.7 or higher. If the bandwidth is too narrow, the design will generally require large differences in impedances between the stubs and the connecting lines, producing an unrealizable configuration.

2. For a Chebyshev (equal ripple) frequency response, ripple levels greater than about 1 dB are not recommended. Exceeding this value will typically deform the shape of the passband characteristics.

3. The parameter StubConfig specifies whether the interior stubs (all but those closest to the source and load) are implemented as a single stub or as two stubs in parallel. Choosing a single stub often produces narrower stub linewidths, and therefore this parameter can impact the ability to manufacture.

4. The parameter D offers some control over the ratio between the stub impedances at the ends of the filter to those in the interior. In some cases where a MCROSS or MTEE width constraint violation is encountered, decreasing (or increasing) this value in the range $0 < D < 1$ may remedy the problem.

5. If N is zero, the number of filter sections will be computed from the frequency/attenuation information. If N is non-zero, the design will use the frequency/attenuation parameters only for determining the design center frequency.


**Simulation Assistant Usage**

For general information, refer to *Chapter 5, Simulation Assistant.*

**Optimization Assistant Usage**

For general information, refer to *Chapter 6, Optimization Assistant.*

The optimization minimizes the absolute difference between S21 and the specified passband edge attenuation (which equals the ripple for Chebyshev response) at the passband edge frequencies. All stub lengths are tuned by the same amount. Because only the stub lengths are changed, this
tuning will typically center the response within the specified passband. More advanced shaping of the passband response can be accomplished by manually tuning the widths and lengths of all lines.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A stub bandpass filter was designed for a Chebyshev response with a 0.1 dB ripple. The passband edge frequencies are at 1.3GHz and 2.7 GHz respectively. The design uses two parallel stubs in the interior regions with \( D = 1 \). The design required 4 stubs. Tuning using the Optimization Assistant yielded a value of \( \Delta = -19.316 \text{ mil} \).
SIFilter (Stepped Impedance Lowpass Filter)

Symbol

![Symbol Image]

Summary

A stepped impedance filter provides a lowpass frequency response between the input and output ports. The design is realized using alternating wide and narrow microstrip lines.

Note

A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters

Subst = microstrip substrate name
Fp = frequency at passband edge, in hertz
Ap = passband edge attenuation (or ripple for Chebyshev), in dB
Fs = frequency at stopband edge, in hertz
As = stopband edge attenuation, in dB
N = number of filter sections (or 0 to compute N)
ResponseType = type of frequency response (maximally flat or Chebyshev)
FElement = first filter component (automatic, capacitive, or inductive)
Zo = desired input/output impedance, in ohms
ZL = characteristic impedance of low impedance sections, in ohms
ZH = characteristic impedance of high impedance sections, in ohms
Delta = length added to filter sections for tuning performance

Palette

Passive Circuit - Filters

Available Automated-Assistants
Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. The stepped impedance filter uses wide microstrip lines to approximate shunt capacitors and narrow lines to approximate series inductors in order to provide a lowpass frequency response.

2. For a Chebyshev (equal ripple) frequency response, ripple levels greater than about 1 dB are not recommended. Exceeding this value will typically deform the shape of the passband characteristics. In order to obtain an impedance match, Chebyshev designs must use an odd number of components (N).

3. The parameter FElement specifies whether the first stub is inductive or capacitive. If Automatic is chosen, the first component is inductive if $Zo/ZL > ZH/Zo$ and capacitive otherwise.

4. If $N$ is zero, the number of filter sections will be computed from the frequency/attenuation information. If $N$ is non-zero, the design will use the frequency/attenuation parameters only for determining the design center frequency.

5. Because this filter design strategy is approximate, the resulting stopband attenuation may not satisfy the specification. Choosing more sections than that computed by the design can improve the stopband performance.


Simulation Assistant Usage
For general information, refer to Chapter 5, Simulation Assistant.

Optimization Assistant Usage
For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the absolute difference between $S21$ and the specified passband edge attenuation (which equals the ripple for Chebyshev response) at the passband edge frequency. All filter sections are tuned by the same amount.

Display Assistant Usage
For general information, refer to Chapter 7, Display Assistant.

Example
A stepped impedance lowpass filter was designed for a maximally flat response with a 3 dB attenuation at the passband edge frequency of 4 GHz. Choosing FElement as Automatic results in a capacitive first component. Tuning using the Optimization Assistant yielded a value of Delta = 27.446 mil.
SLFilter (Stub Lowpass Filter)

Symbol

Summary
A stub lowpass filter provides a lowpass frequency response between the input and output ports. The design is realized using narrow lines to approximate series inductances and shunt open circuited stubs to realize shunt capacitances.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
Fp = frequency at passband edge, in hertz
Ap = passband edge attenuation (or ripple for Chebyshev), in dB
Fs = frequency at stopband edge, in hertz
As = stopband edge attenuation, in dB
N = number of filter sections (or 0 to compute N)
ResponseType = type of frequency response (maximally flat or Chebyshev)
StubType = type of stubs (commensurate or variable length)
FElement = first filter component (automatic, capacitive, or inductive)
Zo = desired input/output impedance, in ohms
ZS = characteristic impedance of stubs, in ohms
ZH = characteristic impedance of connecting sections, in ohms
Delta = length added to stubs for tuning performance

Palette
Passive Circuit - Filters
Available Automated-Assistants

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. The stub lowpass filter uses narrow microstrip lines that approximate series inductors connecting open-circuited stubs that approximate shunt capacitors in order to provide a lowpass frequency response.

2. For a Chebyshev (equal ripple) frequency response, ripple levels greater than about 1 dB are not recommended. Exceeding this value will typically deform the shape of the passband characteristics. In order to obtain an impedance match, Chebyshev designs must use an odd number of components (N).

3. If the parameter StubType is set as Commensurate, all stubs will have equal lengths, and the stub line width is computed. The value of ZS is then ignored, and the resulting design may be difficult to realize. If StubType is set as Variable Length Stub, the stub line widths are determined from ZS and the stub lengths are computed from the specifications.

4. The parameter FElement specifies whether the first stub is inductive or capacitive. If Automatic is chosen, the first component is set to be capacitive since this tends to offer improvements in manufacturing.

5. If N is zero, the number of filter sections will be computed from the frequency/attenuation information. If N is non-zero, the design will use the frequency/attenuation parameters only for determining the design center frequency. Because this filter design strategy is approximate, the resulting stopband attenuation may not satisfy the specification. Choosing more sections than that computed by the Design Assistant can improve the stopband performance.

6. For a more detailed discussion of this device, refer to: Matthaei, Young and Jones, Microwave Filters, Impedance-Matching Networks, and Coupling Structures, Artech House, 1980, pp. 375.

Simulation Assistant Usage
For general information, refer to Chapter 5, Simulation Assistant.

Optimization Assistant Usage
For general information, refer to Chapter 6, Optimization Assistant.
The optimization minimizes the absolute difference between $S_{21}$ and the specified passband edge attenuation (which equals the ripple for Chebyshev response) at the passband edge frequency by changing the stub lengths. All stubs are tuned by the same amount.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A stub lowpass filter was designed for a maximally flat response with a 3 dB attenuation at the passband edge frequency of 1 GHz. A variable length StubType and automatic FElement resulted in 13 components for the design. Tuning using the Optimization Assistant yielded a value of Delta = 164.04 mil.
SRFilter (Stepped Impedance Resonator Filter)

Symbol

Summary
A stepped impedance resonator filter provides a bandpass frequency response between the input and output ports. \( N \) coupled-line sections produce an \( N-1 \) order filter response. Additional numbers of sections can be used to steepen the transition band roll off or widen the pass bandwidth. The use on non-uniform impedance for each resonator moves the second pass band center frequency away from the second harmonic of the fundamental frequency.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
Fs1 = lower stopband edge frequency, in hertz
Fp1 = lower passband edge frequency, in hertz
Fp2 = upper passband edge frequency, in hertz
Fs2 = lower stopband edge frequency, in hertz
Ap = passband edge attenuation (or ripple for Chebyshev), in dB
As = stopband edge attenuation, in dB
N = number of filter sections (or 0 to compute \( N \))
ResponseType = type of frequency response (maximally flat or Chebyshev)
Zo = desired input/output impedance, in ohms
Fsp = center frequency of first spurious passband
Delta = length added to filter sections for tuning performance

Palette
Passive Circuit - Filters

**Available Automated-Assistants**
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

**Design Assistant Usage**
For general information, refer to Chapter 4, Design Assistant.

1. Because of the heavy computational burden in determining the line parameters, a brief delay will occur for the design.

2. For a Chebyshev (equal ripple) frequency response, ripple levels greater than about 1 dB are not recommended. Exceeding this value will typically deform the shape of the passband characteristics.

3. If N is zero, the number of filter sections will be computed from the frequency/attenuation information. If N is non-zero, the design will use the frequency/attenuation parameters only for determining the design center frequency.

4. The center frequency of the first spurious passband should be on the order of twice the fundamental passband center frequency.


**Simulation Assistant Usage**
For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**
For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the absolute difference between S21 in dB and the specified passband edge attenuation (which equals the ripple for Chebyshev response) at the passband edge frequencies. Because only the line lengths are changed, this tuning will typically center the response within the specified passband. More advanced shaping of the passband response can be accomplished by manually tuning the widths and spacings of the coupled filter sections.

**Display Assistant Usage**
For general information, refer to Chapter 7, Display Assistant.

**Example**
A stepped impedance resonator filter was designed for a maximally flat response with the 3 dB passband edge frequencies at 2 GHz and 2.2 GHz respectively. The second passband was set to 4.1 GHz. The design required 4 coupled lines. Tuning using the Optimization Assistant yielded a value of Delta = 0.785 mil.
SSMatch (Single-Stub Match)

Symbol

Summary

A single-stub matching network matches a complex load impedance (Zload) to a desired complex input impedance (Zin) using a single shunt stub and length of line.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters

Subst = microstrip substrate name
F = center frequency, in hertz
Zin = desired complex input impedance, in ohms
Zload = complex load impedance to match, in ohms
Zstub = characteristic impedance of stub line, in ohms
Zline = characteristic impedance of line, in ohms
Zfeed = characteristic impedance of line connected to port 1 or 2, in ohms
StubType = stub type (open or short circuit)
NetType = network type (source to load)
Delta = length added to stub for tuning performance

Palette

Passive Circuit - Matching

Available Automated-Assistants
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. The parameter NetType can be Automatic, stub-line, or line-stub, with the latter two choices representing configurations that have a stub followed by a line or vice-versa as the network is observed from source to load. Many impedance combinations can be realized using both possible types, although some can only be realized using one of the two choices. Choosing Automatic will ensure a realizable choice is given.

2. An impedance match can be realized using either stub type.

3. Zline represents the impedance of the line either next to the source or load (depending on the value of NetType). Zfeed represents the desired impedance on the other side of the stub from the line and is used to ensure that the corresponding leg of the microstrip tee component is of the proper width.

4. MTEE component width constraint violations will be avoided generally by choosing similar characteristic impedances for the line, stub, and feed.


**Simulation Assistant Usage**
For general information, refer to Chapter 5, Simulation Assistant.

The input port termination is set to the conjugate of Zin so that the ideal input reflection coefficient will be zero. The output port termination is set to Zload.

**Optimization Assistant Usage**
For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the value of S11 (referenced to the conjugate of Zin) at the design center frequency by changing the length of the stub.

**Display Assistant Usage**
For general information, refer to Chapter 7, Display Assistant.

**Example**
A single-stub matching network was designed to match a load impedance of 100 - j25 ohms to a 50 ohm line at a center frequency of 2GHz. Choosing an open-circuit stub with automatic selection of the NetType resulted in a stub-line configuration. Tuning using the Optimization Assistant yielded a value of Delta = -5.078 mil.
MSub

MSub1
H=30 mil
Er=3.2

DA_SSMatch1_test
DA_SSMatch1
Subs="MSub1"

F=2 GHz
Zin=50 Ohm
Zload=(100-j125) Ohm
Zstub=50 Ohm
Zline=50 Ohm
Delta=-5.079 mil

---

SmartComponent List 9-107
**TCoupler (Tee Power Divider)**

**Symbol**

![Symbol](image)

**Summary**
A tee power divider splits the power at the input (pin 1) between the two outputs (pins 2 and 3). Unequal or equal power splits can be realized. The input port will be matched to its feeding line, although in general the output ports will not be matched.

**Note** A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

**Parameters**
Subst = microstrip substrate name
F = center frequency, in hertz
Zo1 = characteristic impedance of input port 1, in ohms
Zo2 = characteristic impedance of output port 2, in ohms
K = ratio of power out port 2 to power out port 3
Delta = length added to quarter-wave sections for tuning performance

**Palette**
Passive Circuit - Couplers

**Available Automated-Assistants**
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

**Design Assistant Usage**
For general information, refer to Chapter 4, Design Assistant.

1. The value of K can be set to realize the desired power split out of ports 2 and 3. However, choosing K larger than 3 to 4 (or smaller than 1/3 to 1/4) may cause the ratio of the widths of
the tee branches to violate the range of the MTEE simulation model. While the simulation will still proceed, the results may have some inaccuracies.

2. Quarter-wave matching sections are provided on the output ports to ensure a proper power split is achieved.


**Simulation Assistant Usage**

For general information, refer to Chapter 5, *Simulation Assistant*.

**Optimization Assistant Usage**

For general information, refer to Chapter 6, *Optimization Assistant*.

The optimization minimizes the input reflection coefficient (S11) at the design center frequency by changing the length of the quarter wave transformers on the output legs.

**Display Assistant Usage**

For general information, refer to Chapter 7, *Display Assistant*.

**Example**

A tee power divider was designed for a center frequency of 1GHz with an unequal power split (K = 3.5). Tuning using the Optimization Assistant yielded a value of Delta = -34.633 mil.
TFC (Thin Film Capacitor)

Symbol

Summary
TFC designs a thin film capacitor. The underlying design uses the TFC component contained in the Tlines-Microstrip pallette.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
F = center frequency, in hertz
C = capacitance, in farads
W = conductor width
T = thickness of capacitor dielectric
Er = relative dielectric constant
Rho = resistivity of conductor (relative to gold)
TanD = dielectric loss tangent
CO = conductor overlap
DO = dielectric overlap
Delta = length added to conductor for tuning capacitance

Palette
Passive Circuit - RLC

Available Automated-Assistants
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage
SmartComponent Reference

For general information, refer to Chapter 4, Design Assistant.

1. The design is accomplished by determining the length required to achieve the desired capacitance using the simple parallel plate capacitor model \( C = \varepsilon_r W \frac{L}{T} \). The parameters from Rho through DO inclusive are not used in the design process but are passed on to the underlying TFC component and are therefore included in any simulations or optimizations.

2. The tuning parameter \( \Delta \) represents incremental length required to achieve the desired capacitance. It is typically relatively small, as the initial design tends to be accurate.

**Simulation Assistant Usage**
For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**
For general information, refer to Chapter 6, Optimization Assistant.
The Optimization Assistant tunes the conductor length to achieve the desired capacitance.

**Display Assistant Usage**
For general information, refer to Chapter 7, Display Assistant.

**Example**
A TFC component was used to design a 1 pF capacitor at a center frequency of 5 GHz using a dielectric with a 0.2 mil thickness and dielectric constant of 9.6. Optimization yielded a value of \( \Delta = -0.000178 \) mil.

![SmartComponent Diagram]

MSUB
MSUB1
H=30 mil
\( \varepsilon_r = 3.2 \)

DA_TFC1_Inst
DA_TFC1
F=5 GHz
C=1 pF
W=25 mil
T=0.2 mil
\( \varepsilon_r = 9.6 \)
Delta=-0.000178 mil
TFR (Thin Film Resistor)

Symbol

Summary
TFR designs a thin film resistor. The underlying design uses the TFR component contained in the Tlines-Microstrip palette.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
F = center frequency, in hertz
R = resistance, in ohms
W = conductor width (set to 0 if Zo specified)
Zo = characteristic impedance of line assuming Rs = 0 (set to 0 if W specified)
Rs = sheet resistivity, in ohms/square
CO = conductor overlap
Delta = length added to conductor for tuning resistance

Palette
Passive Circuit - RLC

Available Automated-Assistants
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage
For general information, refer to Chapter 4, Design Assistant.

1. The design is accomplished by determining the length required to achieve the desired resistance using the sheet resistivity Rs in conjunction with the strip width W. The
parameters Freq and CO are not used in the design process but are passed on to the underlying TFR component and are therefore included in any simulations or optimizations.

2. Since this resistor is often fed with a microstrip line, either the physical width or the characteristic impedance of a microstrip line on the substrate can be specified.

3. The tuning parameter Delta represents incremental length required to achieve the desired resistance.

**Simulation Assistant Usage**
For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**
For general information, refer to Chapter 6, Optimization Assistant.

The Optimization Assistant tunes the conductor length to achieve the desired resistance.

**Display Assistant Usage**
For general information, refer to Chapter 7, Display Assistant.

**Example**
A TFR component was used to design a 50 ohm resistor at a center frequency of 5 GHz using a conductor with a sheet resistance of 50 ohm/square. The conductor width was chosen to correspond to that of a 50 ohm microstrip line on the substrate. Optimization yielded a value of Delta = -3.549 mil.
TLMatch (Tapered-Line Match)

Symbol

```
1 2
```

Summary

A tapered-line matching network matches a real load impedance (Rload) to a desired real input impedance (Zo) using a continuously varying line characteristic impedance to realize a specified frequency response. The reflection coefficient remains below the specified maximum value for all frequencies above the design frequency.

Note

A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters

Subst = microstrip substrate name

F = design frequency, in hertz

Zo = desired input impedance, in ohms

Rload = load impedance to match, in ohms

ResponseType = type of frequency response (exponential, triangular, Klopfenstein)

L = length of tapered line in wavelengths at frequency F(set L=0 to compute L)

Rmax = maximum voltage reflection coefficient

NSection = number of linear taper sections per wavelength

Palette

Passive Circuit - Matching

Available Automated-Assistants

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage

For general information, refer to Chapter 4, Design Assistant.
1. The continuous impedance taper of this circuit is approximated using a sequence of linear tapers. Increasing the number of sections per wavelength (NSection) will improve the approximation to the defined taper.

2. If the length of the line L is set to zero, the Design Assistant chooses L such that the reflection coefficient is less than Rmax for all frequencies above the design frequency. Otherwise, Rmax is ignored.

3. The ResponseType specifies the distribution of the impedance along the length of the line and therefore determines the frequency response of the match.


**Simulation Assistant Usage**

For general information, refer to Chapter 5, *Simulation Assistant*.

**Optimization Assistant Usage**

For general information, refer to Chapter 6, *Optimization Assistant*.

No Optimization Assistant is provided since the design process is exact to within the approximation of the continuous impedance taper using multiple linear taper segments. Increasing the value of NSection will improve the computed response.

**Display Assistant Usage**

For general information, refer to Chapter 7, *Display Assistant*.

**Example**

A tapered-line matching network was designed to match a load impedance of 100 ohms to a 50 ohm line at a center frequency of 4 GHz. Specifying a Klopfenstein frequency response for which the reflection coefficient remains below 0.1 along with 30 sections per wavelength dictates 18 tapered-line sections to realize the match. The plot has been shown in linear magnitude rather than dB to emphasize the equal-ripple frequency response.
SmartComponent List 9-119

MSUB
MSub1
H=30 mil
Er=3.2

DA_TLMatch1_test
DA_TLMatch1
Subst="MSub1"
F=4 GHz
Zo=50 Ohm
Rload=100 Ohm
L=0.0
Rmax=0.1
NSection=30

Graph showing |S| vs Frequency (GHz) with markers M1 and A, B.
WDCoupler (Wilkinson Divider)

Symbol

![Wilkinson Divider Symbol]

Summary

A Wilkinson power divider splits the power at the input (pin 1) between the two outputs (pins 2 and 3). Unequal or equal power splits can be realized. The signals at the outputs are in phase. All three ports will be matched, and ports 2 and 3 will in general be well isolated from each other.

Note

A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters

Subst = microstrip substrate name
F = center frequency, in hertz
Zo = characteristic impedance, in ohms
K = ratio of power out port 2 to power out port 3
Wgap = width of gap for resistor
Delta = length added to quarter-wave branches for tuning performance

Palette

Passive Circuit - Couplers

Available Automated-Assistants

Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage

For general information, refer to Chapter 4, Design Assistant.

1. The value of K can be set to realize the desired power split out of ports 2 and 3. However, choosing K larger than 3 to 4 (or smaller than 1/3 to 1/4) may cause difficulties in the design.

**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**

For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the input reflection coefficient (S11) at the design center frequency by changing the length of the quarter wave branches forming the divider.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A Wilkinson power divider was designed for a center frequency of 5 GHz with an equal power split (K = 1) and a gap width for the resistor of 50 mil. Tuning using the Optimization Assistant yielded a value of \( \Delta = 58.03 \) mil.
 ZZFilter (Zig-Zag Coupled-Line Filter)

Symbol

Summary
A zig-zag coupled-line filter provides a bandpass frequency response between the input and output ports. The design uses a coupled-line filter topology but includes 90 degree bend between each coupled section so that the layout is more compact.

Note A SmartComponent subnetwork is empty until the Design Assistant is used to generate the design. Refer to Chapter 4, Design Assistant.

Parameters
Subst = microstrip substrate name
Fs1 = lower stopband edge frequency, in hertz
Fp1 = lower passband edge frequency, in hertz
Fp2 = upper passband edge frequency, in hertz
Ap = passband edge attenuation (or ripple for Chebyshev), in dB
As = stopband edge attenuation, in dB
N = number of filter sections (or 0 to compute N)
ResponseType = type of frequency response (maximally flat or Chebyshev)
Zo = desired input/output impedance, in ohms
Delta = length added to coupled sections for tuning performance

Palette
Passive Circuit - Filters

Available Automated-Assistants
Design Assistant, Simulation Assistant, Optimization Assistant, Display Assistant

Design Assistant Usage
1. Because of the heavy computational burden in determining the line parameters, a brief delay will occur for the design.

2. For a Chebyshev (equal ripple) frequency response, ripple levels greater than about 1 dB are not recommended. Exceeding this value will typically deform the shape of the passband characteristics.

3. If N is zero, the number of filter sections will be computed from the frequency/attenuation information. If N is non-zero, the design will use the frequency/attenuation parameters only for determining the design center frequency.


**Simulation Assistant Usage**

For general information, refer to Chapter 5, Simulation Assistant.

**Optimization Assistant Usage**

For general information, refer to Chapter 6, Optimization Assistant.

The optimization minimizes the absolute difference between S21 and the specified passband edge attenuation (which equals the ripple for Chebyshev response) at the passband edge frequencies. Because only the line lengths are changed, this tuning will typically center the response within the specified passband. More advanced shaping of the passband response can be accomplished by manually tuning the widths and spacings of the coupled filter sections.

**Display Assistant Usage**

For general information, refer to Chapter 7, Display Assistant.

**Example**

A zig-zag coupled-line filter was designed for a maximally flat response with the 3 dB passband edge frequencies at 2 GHz and 2.4 GHz respectively. The design required 4 coupled-line sections. Tuning using the Optimization Assistant yielded a value of Delta = -6.233 mil.
MSUB
MSub1
H=30 mil
Er=3.2

DA_ZZFilter1
Subst="MSub1"
Fs1=1.8 GHz
Fp1=2 GHz
Fp2=2.2 GHz
Fs2=2.4 GHz
Ap=3 dB
As=20 dB
N=0
Zo=50 Ohm
Delta=6.233 mil

S11
S21
Spec
Index

D
DesignGuide QuickStarts
Passive Circuit, 1-1

P
Passive Circuit DesignGuide
  Control Window (using), 1-8
coupler components, 9-2
creating artwork, 8-1
Design Assistant (using), 4-1
design flow, 1-15
Display Assistant (using), 7-1
distributed capacitor components, 9-1
distributed inductor components, 9-2
distributed resistor components, 9-2
divider components, 9-2
filter components, 9-2
How Do I?, 2-1
layout generation, 8-1
line components, 9-1
matching network components, 9-3
navigation, 1-5
Optimization Assistant (using), 6-1
QuickStart, 1-1
simple examples, 1-10
Simulation Assistant (using), 5-1
Smart component Reference, 9-1
updating layouts, 8-1