Installation on PC Systems

September 2004
Notice

The information contained in this document is subject to change without notice.

Agilent Technologies makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Agilent Technologies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Warranty

A copy of the specific warranty terms that apply to this software product is available upon request from your Agilent Technologies representative.

Restricted Rights Legend

Use, duplication or disclosure by the U. S. Government is subject to restrictions as set forth in subparagraph (c) (1) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 for DoD agencies, and subparagraphs (c) (1) and (c) (2) of the Commercial Computer Software Restricted Rights clause at FAR 52.227-19 for other agencies.

Agilent Technologies
395 Page Mill Road
Palo Alto, CA 94304 U.S.A.

Copyright © 1998-2004, Agilent Technologies. All Rights Reserved.

Acknowledgments

Mentor Graphics is a trademark of Mentor Graphics Corporation in the U.S. and other countries.

Microsoft®, Windows®, MS Windows®, Windows NT®, and MS-DOS® are U.S. registered trademarks of Microsoft Corporation.

Pentium® is a U.S. registered trademark of Intel Corporation.

PostScript® and Acrobat® are trademarks of Adobe Systems Incorporated.

UNIX® is a registered trademark of the Open Group.

Java™ is a U.S. trademark of Sun Microsystems, Inc.
Contents

1 Before You Begin
   Note the Changes in ADS 2004A ................................................................. 1-1
   Check the System Requirements ................................................................. 1-2
   Check the Supported Instrument Interfaces ............................................... 1-3
   Get Codewords for ADS 2004A ................................................................. 1-4
   Backup Your Data ....................................................................................... 1-4
   Check Available Memory ............................................................................ 1-5
   Check Available Disk Space ........................................................................ 1-6

2 Installing Advanced Design System
   Installation Overview .................................................................................. 2-1
   Quick Installation ......................................................................................... 2-2
   Detailed Installation .................................................................................... 2-3
      Typical Installation List ........................................................................... 2-8
      Complete Installation List ........................................................................ 2-8
      Custom Installation List ........................................................................... 2-9
   Client-Server Installations .......................................................................... 2-10
      Installing on the Server ........................................................................... 2-10
      Installing on Clients ................................................................................ 2-11
   Installing from a File Server ....................................................................... 2-14
   Using Multiple ADS Versions ...................................................................... 2-16
      Setting the HOME Directory ................................................................... 2-16
      Setting the HOME Environment Variable .............................................. 2-17
   Silent Installations ..................................................................................... 2-18
      Silent Installation Overview ..................................................................... 2-18
      Response File Contents .......................................................................... 2-18
      Running a Silent Installation ................................................................... 2-20
      Running a Silent Uninstallation .............................................................. 2-21
      Troubleshooting ...................................................................................... 2-21
      Creating Your Own Response File .......................................................... 2-22
   Installing Connection Manager ................................................................... 2-23

3 Setting Up Licenses
   Using LMTOOLs for FLEXlm ...................................................................... 3-1
   License Installation Overview ..................................................................... 3-2
   Installing Your Licenses ............................................................................. 3-3
      Installing a Hardware Key ........................................................................ 3-3
      Installing the FLEXid Driver .................................................................... 3-4
      Using the Ethernet ID .............................................................................. 3-5
      Determining License Type ....................................................................... 3-6
Installing Node-Locked Licenses ................................................................. 3-7
Changing the License File Location ......................................................... 3-7
Installing Floating Licenses on a PC Server .............................................. 3-9
Installing the License File ........................................................................ 3-9
Entering the Hostname ............................................................................. 3-10
Setting the Vendor Daemon Path ............................................................ 3-11
Starting FLEXlm ..................................................................................... 3-12
Ensuring Access to the License File ....................................................... 3-15
Accessing Licenses From a UNIX or Linux License Server ....................... 3-16
Setting Up the UNIX or Linux License Server ......................................... 3-16
Setting Up the Client(s) .......................................................................... 3-17
Selecting a License Bundle ...................................................................... 3-17
Special Licensing Needs .......................................................................... 3-18
Using FLEXlm Options .......................................................................... 3-18
Updating the License File ........................................................................ 3-21
Merging Multiple Vendor Licenses ............................................................ 3-21
Redundant License Servers ..................................................................... 3-25
Controlling License Path Settings ............................................................ 3-25
Manually Setting the License Bundle Preference ..................................... 3-29
Accessing Licenses through a Firewall .................................................... 3-30
Managing Multiple ADS Versions ............................................................. 3-32
Backward Compatibility of Codewords ...................................................... 3-32
Combining ADS 2004A Codewords with Other Agilent EEs of EDA Codewords 3-33
Example of a Merged License File ............................................................. 3-35
Using the Agilent License Information Tool .............................................. 3-39

4 Using Advanced Design System
Running Advanced Design System ......................................................... 4-1
Using the Agilent License Preference Tool .............................................. 4-2
Running ADS in Verbose Mode ............................................................... 4-7
Using the ADS RF Designer Suite ........................................................... 4-7
Common Problems .................................................................................. 4-8
ADS Does Not Start ................................................................................. 4-8
ADS Does Not Run After Starting the License Server .............................. 4-9
Licenses Stop Working ............................................................................ 4-9
Losing Licenses When Opening Help ...................................................... 4-10
How Do I .................................................................................................. 4-10
Install Over Multiple Hard Disks ............................................................. 4-10
Check the Nodelock ID of My Hardware Key ........................................... 4-10
Add and Remove ADS Files ................................................................. 4-11
Change the Home Directory .................................................................... 4-13
Agilent EEs of Technical Support ............................................................ 4-14
5 Using Remote Simulation
- Setting up Your Simulation Server .......................................................... 5-2
- Setting up a PC Server ............................................................................. 5-2
- Setting up a UNIX or Linux Server ........................................................ 5-4
- Setting up Your Client PC ......................................................................... 5-6
- Using Multiple Servers ........................................................................... 5-6
- Ending Remote Operation ......................................................................... 5-7
- Simulator Server Error ............................................................................. 5-7
- Remote Simulation Error .......................................................................... 5-8
- Remote Simulation Restrictions ............................................................... 5-8
- Defining the EMX Daemon Remote Address ......................................... 5-9
- Using LSF Remote Simulation ................................................................. 5-10
- LSF Requirements ................................................................................ 5-10
- Setting Up LSF and ADS ......................................................................... 5-12

A Installing Connection Manager Server
- Before You Begin .................................................................................. A-1
  - System Requirements ........................................................................ A-1
  - Licensing Requirements .................................................................... A-1
  - EDA Software Version Requirements ............................................. A-2
  - Installation Package Overview ......................................................... A-2
  - Installation Types ........................................................................... A-2
- Installing the Server ................................................................................ A-3
- Configuring the Server IO on the PC ...................................................... A-3
  - To Configure Common LAN or GPIB Interfaces .............................. A-3
  - To Manually Configure Other Interfaces ........................................ A-6

Index
Chapter 1: Before You Begin

Before you begin, please take the time to go over the guidelines for installing Advanced Design System (ADS) on a PC running Windows (2000/XP). For last-minute installation information, see the file readme.htm, included on the installation disk. For last-minute program and documentation information, refer to the Release Notes document on our website at:

http://www.agilent.com/find/eesof-docs

Choose Advanced Design System 2004A > Manuals > Release Notes

Note the Changes in ADS 2004A

Important If you have systems running older versions of ADS, see Table 1-1 for a brief description of changes in recent ADS versions and their impact on systems with older versions installed.

<table>
<thead>
<tr>
<th>Description and Reference to Details</th>
<th>Version Introduced and Impact</th>
</tr>
</thead>
<tbody>
<tr>
<td>License Packages are replaced by Bundles. The Bundle licenses work only if users select them by running the Agilent License Preference tool prior to starting ADS. See “Using the Agilent License Preference Tool” on page 4-2.</td>
<td>ADS 2003A Impacts all licenses that use bundles and the license check-out process.</td>
</tr>
<tr>
<td>The FLEXlm version for the license server (lmgrd) has changed to 9.2a from 8.2a. See “Installing Your Licenses” on page 3-3, and “Installing Floating Licenses on a PC Server” on page 3-9.</td>
<td>ADS 2004A Impacts all systems, hardware keys, license servers, and license administration scripts.</td>
</tr>
<tr>
<td>The codeword version changed to 2.34 from 2.3. The codewords are version-dependent. New codewords will enable ADS 2004A back through ADS 2002. See “Installing Your Licenses” on page 3-3.</td>
<td>ADS 2004A You must obtain new FLEXlm license codewords from Agilent EEsof EDA.</td>
</tr>
<tr>
<td>Supported platforms changed. See “Check the System Requirements” on page 1-2.</td>
<td>ADS 2004A Windows NT® 4.0 is no longer supported.</td>
</tr>
</tbody>
</table>
Before You Begin

Check the System Requirements

Be sure your hardware and software configuration meets the following minimum hardware and system requirements to install and/or run Advanced Design System, including RAM, disk space, operating systems, service packs and updates, etc. Keep in mind that minimum requirements are just that, and they may not provide adequate performance and responsiveness. For the latest system requirement information, refer to the Installation on PC Systems document on our website at:

http://www.agilent.com/find/eesof-docs

Choose Advanced Design System 2004A > Manuals > Installation

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating System and Service Pack</td>
<td>Microsoft Windows 2000 Professional SP4; Windows XP Professional SP1.</td>
</tr>
<tr>
<td>Display</td>
<td>High-resolution color only (Super VGA, 800x600, 15-inch monitor minimum).</td>
</tr>
<tr>
<td>RAM</td>
<td>512 MB RAM recommended minimum. Additional RAM will improve performance.</td>
</tr>
<tr>
<td>Virtual Memory</td>
<td>300 MB recommended minimum. Increased virtual memory may be required for larger designs.</td>
</tr>
<tr>
<td>Web Browser</td>
<td>ADS documentation is HTML-based and displayed via a web browser. Microsoft Internet Explorer version 5.5 or higher. Java Virtual Machine and JavaScript must be enabled on your browser for the documentation to appear correctly. You may need to download and install a Java plug-in.</td>
</tr>
<tr>
<td>Hard Disk</td>
<td>613 MB for a minimum installation, 2.15 GB for a typical installation, and 2.52 GB for a complete installation. It is recommended that you install Advanced Design System software on your local drive. Recommended file systems are FAT32 and NTFS. Novell file servers are not supported. VFAT/FAT systems are not recommended for complete installations.</td>
</tr>
<tr>
<td>Security Device</td>
<td>Advanced Design System software codewords are locked to an external device (FLEXid hardware security key) attached to the PC’s parallel port or locked to a PC’s LAN ethernet card.</td>
</tr>
<tr>
<td>Supported Printers</td>
<td>Printers supported by the operating system used. (Note for HP LaserJet 3100 Only: There may be a conflict with the hardware key; if so, contact HP Printer Support by phone or on the web.)</td>
</tr>
<tr>
<td>Supported Plotters</td>
<td>Plotters supported by the operating system used.</td>
</tr>
</tbody>
</table>
Checking the Operating System Version

To determine the version of your operating system, double-click the My Computer icon. Choose Help > About Windows.

Check the Supported Instrument Interfaces

For details on configuring and using the various instrument interfaces supported by Advanced Design System, please refer to the latest list of supported instruments at:

http://www.agilent.com/find/eesof-docs

Choose Advanced Design System 2004A > Manuals > Design and Display > Using Instruments

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Supported Media Type</td>
<td>CD-ROM required for program installation.</td>
</tr>
<tr>
<td>Processor</td>
<td>Intel Pentium® III 700 MHz or higher.</td>
</tr>
</tbody>
</table>
| HDL simulator (required only for HDL cosimulation) | These HDL simulators are the latest versions supported on ADS:  
  - Mentor Graphics ModelSim SE 5.8d  
  - Cadence VerilogXL LDV 3.3 [3.30.p001]  
  - Cadence NCSim  
  - LDV 5.1 [05.10-s013] (HdlSimulatorGUI=ON does not work) |
Before You Begin

Get Codewords for ADS 2004A

You must have new FLEXlm license codewords to run Advanced Design System 2004A. The codewords will be tied to the FLEXid of your hardware key or the Ethernet MAC address of your PC’s Ethernet LAN card. While you can install any component, you will be able to run only those for which you have codewords. For details about license codewords required for simulators, design library components, and other ADS products, see the ADS License Dependency Table at:

http://www.agilent.com/find/eesof-license-dependencies

A Codeword Request form is included with your installation media. Please fill it out completely and fax it to the number on the form. You can also ask for licenses or codewords on the Web at:

http://www.agilent.com/find/eesof-support

Choose Codeword Request

The codewords are emailed to you in a license file called license.lic.

If you choose to tie your codewords to a hardware key or dongle, the hardware key is generally shipped with the software disks. If you do not have one, contact Agilent EEsof Business Support at 1-800-507-6274.

For details on both methods of securing codewords refer to “Installing Your Licenses” on page 3-3 in Chapter 3, Setting Up Licenses.

Backup Your Data

You can retain earlier installations of Advanced Design System and ADS 2004A in separate directories on the same machine, but you cannot install version 2004A over a previous Advanced Design System installation. This also applies to an Early Access (Beta) 2004A version.

Before you delete a previous installation:

• Copy your projects, customized configuration files, and other data.
• Copy your license file from the <install_directory>\licenses folder.

For details on running multiple ADS versions, refer to “Using Multiple ADS Versions” on page 2-16 in Chapter 2, Installing Advanced Design System.
Check Available Memory
You need a minimum of 512 MB of memory installed on your system. More memory results in better overall system performance for some design work. To check the amount of memory on your system without rebooting, double-click the My Computer icon. Choose Help > About Windows.

Checking Virtual Memory
The recommended minimum virtual memory is 300 MB. Very large designs and designs with many hierarchical levels could require more. To check the current amount of virtual memory:
Select Start > Settings > Control Panel > System
On the Advanced tab, choose Performance Options. Under Virtual memory, choose Change. You can choose to use the current setting or change it.
Before You Begin

Check Available Disk Space

The amount of disk space required depends on the Advanced Design System products that you want to install. As you run the Setup installation program, the amount of space for various installation components is indicated, so you are aware of these requirements before you select the components to install.

To check the amount of disk space on your system without rebooting, double-click the My Computer icon. Select View > Details. Look in the Free Space column for each of your drives. (You might have to use the bottom scroll bar to see this column.)

Defining an Install Folder

Be sure you have permissions to write to the disk drive on which you want to install Advanced Design System. The installation also adds entries to your PC's Windows Registry. Make sure you have permissions to do so.

---

**Important**  The installation path for Advanced Design System software cannot contain any folder names that use a space (don't try to install to c:\ Program Files\ ). If you include a space in a folder name, you will get an error when you try to run a simulation. You will have to uninstall ADS and then install it again.

---

You can re-run the installation program to install components you chose not to install the first time through.

For details on install steps and options, refer to “Detailed Installation” on page 2-3 in Chapter 2, Installing Advanced Design System.
Chapter 2: Installing Advanced Design System

Use the following information for installing Advanced Design System on a PC running Windows. For last-minute installation information, see the file readme.htm, included on the installation disk. For last-minute program and documentation information, refer to the Release Notes document on our website at:

http://www.agilent.com/find/eesof-docs

Choose Advanced Design System 2004A > Manuals > Release Notes

Installation Overview

```
Obtain codewords

Install FLEXid hardware key or use LAN card ID

Insert installation CD

Run setup program

Install program files

Add codewords to license file and start FLEXlm

Will you use license bundles?

Yes

Select license bundle using Agilent License Preference Tool

No

Launch Advanced Design System
```
Quick Installation

Use this condensed installation procedure if you are experienced installing Agilent EEsof products. For notes, tips, and details, see “Detailed Installation” on page 2-3. If you installed an Early Access version of ADS 2004A, you should uninstall it before installing this version.

1. Insert the ADS PC installation CD-ROM #1 into your CD-ROM drive. If the Setup program does not start automatically, choose Start > Run and enter D:\setup, where D: is the drive letter of your CD-ROM drive, then click OK.

2. When the installation wizard appears, you can begin to set up the installation and install ADS. Details about each screen are available in “Detailed Installation” on page 2-3. When you are done, click Finish to exit the installation wizard.

3. The FLEXlm installation program may start running to load the latest FLEXid driver needed to license ADS. Macrovision recommends that you install the FLEXid System Driver with their installer, which is included on the ADS PC Setup disk. See “Installing Your Licenses” on page 3-3 in Chapter 3, Setting Up Licenses.

   • If you are installing a network server, you are now ready to start setting up clients. For instructions, refer to “Installing on the Server” on page 2-10.

   • Install your codewords. For instructions, refer to “Installing Your Licenses” on page 3-3 in Chapter 3, Setting Up Licenses.

   • Install the Macrovision FLEXid software-security hardware key to your PC’s parallel port or use your PC LAN card’s ethernet ID. For instructions, refer to “Installing Your Licenses” on page 3-3 in Chapter 3, Setting Up Licenses.

4. Start ADS. See “Running Advanced Design System” on page 4-1. If you will be using license bundles, select a bundle using the Agilent License Preference Tool prior to running ADS. This tool is described in “Using the Agilent License Preference Tool” on page 4-2.
Detailed Installation

Use the following steps for installing Advanced Design System on a PC running Windows. If you have not done so, please review Chapter 1, Before You Begin. Also, if you installed an Early Access version of Advanced Design System 2004A, you should uninstall it before installing this version.

To install Advanced Design System on a Windows PC:

1. Exit all Windows programs and insert Advanced Design System installation CD labeled PC Setup (CD #1) into your CD-ROM drive. The Setup program will start automatically. If it doesn’t, choose Start > Run and enter D:\setup, where D: is the drive letter of your CD-ROM drive, then click OK.

2. At the Welcome screen, choose:
   - Next to read the License Agreement. This is a usage agreement and is not related to the license codewords required to run the software. You must accept the agreement to continue with the installation. This appears only when you run Setup the first time or after uninstalling ADS.

3. At the License Agreement screen, after reviewing the agreement, choose:
   - Yes to accept the License Agreement and continue with the setup.
   - No to reject the License Agreement and end the setup program.

4. At the Customer Information screen, enter your information. There are no special requirements for this information, or connection to license codewords. Then choose:
   - Next to specify the installation location.

5. At the Specify Your Installation Directory screen, choose:
   - Next to install to the default folder. The installation program will create this folder if it does not already exist.
   - Browse to specify a different destination folder. You should not choose a folder that contains an older ADS version. If you specify a folder that does not already exist, the installation program will create it for you.
6. At the Specify Your Home Directory screen, choose:
   - **Next** to accept the default.
   - **Browse** to select a different folder.
   
   The folder you specify will be the default startup folder for Advanced Design System. It will also be used to store the configuration data in a subfolder called hpeesof. If you are using more than one ADS version, please choose a new Home folder for each version. For the best performance, choose a folder on your local, not network, drive.

7. At the Select Features screen, choose an installation option:
   - **Typical** requires about 2.02 GB of disk space installing the ADS design environment, simulators, documentation, and examples. For a list of typical installation components, see "Typical Installation List" on page 2-8.

   **Note** A Typical installation does not install the Wireless Design Libraries such as W-CDMA, DesignGuides, nor a few specialized tools such as HDL Cosimulation.

   - **Complete** requires about 2.52 GB of disk space installing the ADS design environment, simulators, documentation, examples, DesignGuides, and LAN client files. For a list of complete installation components, see "Complete Installation List" on page 2-8.

   If you choose a Typical or Complete installation, skip to step 9.

   - **Custom** lets you choose the ADS components you want to install. For a list of custom installation components, see "Custom Installation List" on page 2-9.

     If you choose a Custom installation, and the machine you are installing to will be a network server, you must install the LAN Client Files component. For details, refer to "Installing on the Server" on page 2-10.

   If you choose a Custom installation, continue with step 8.

   **Note** While you choose here which ADS features you want to install, the ability to run them is determined by the licenses you have purchased.
8. For a Custom installation, the next screen lets you choose the components you want to install. Click a component name to see a description. Select the components you wish to install and click Next to continue.

**Important** Please be aware of the impact of the following choices:

You must choose to install the component ADS Programs and tools which includes Layout, Simulators and Schematic Capture. You can install other components, but without ADS Programs and tools, ADS will not run properly.

The component, Manuals & Help, is selected by default. This selection installs the entire ADS documentation set. If you uncheck this item, documentation and help files will not be available regardless of which other items you choose.

9. At the Personal or Common program folder screen, choose:
   - Next to select the default option: Create start menu icons for current user only.
   - The option: Create start menu icons for all users, then click Next to continue.

10. Use the Select Program Folder screen to choose:
    - Next to install the ADS program icons to the default destination, which is Advanced Design System 2004A.
    - Enter a new folder name, or choose a different destination folder for the icons from the Existing Folders list, then click Next to continue.
11. At the Check Setup Information screen, review your choices and click:
   • **Back** to access previous screens to verify entries and make changes. This screen appears again if you go back to make other choices.
   • **Next** to immediately begin the installation.
   • **Cancel** to exit the Setup without completing the installation.

Immediately after you click **Next**, the Setup Status screen appears and the program configures the installation process. When the program determines that your system is ready for installation, it begins to install files. The status screen displays the files being installed and the progress.

**Note** If you are doing a Typical or Complete installation, or a Custom installation with examples and/or documentation, you are prompted to insert CD #2 when installation from CD #1 is complete. Insert CD #2, then click **OK**.

12. When the installation is done, read the information displayed about license requirements and how to obtain codewords, then click **OK**.

13. A question box appears asking if the current PC will use a hardware key (also known as a dongle) to run the FLEXlm licensing system for ADS; choose:
   • **Yes** if you will use a dongle to run the FLEXlm licensing system. The Macrovision installation program loads the latest FLEXid drivers needed for the hardware key. If you need to install the drivers later, Macrovision recommends that you install the FLEXid drivers with their installer, which is included on the ADS PC Setup disk.
   • **No** if you will be using a PC LAN card's Ethernet ID to run the FLEXlm licensing system.
14. When the InstallShield Wizard Complete screen appears, remove the CD and click Finish; then:

• If you are installing a network server, you are now ready to start setting up clients. For instructions, refer to “Installing on the Server” on page 2-10.

• Install your codewords. For instructions, refer to “Installing Your Licenses” on page 3-3 in Chapter 3, Setting Up Licenses.

• Install the Macrovision FLEXid software-security hardware key to your PC’s parallel port, or use your PC LAN card’s Ethernet ID. For instructions, refer to “Installing Your Licenses” on page 3-3 in Chapter 3, Setting Up Licenses.


If you will be using license bundles, select a bundle using the Agilent License Preference Tool prior to running ADS. (See “Using the Agilent License Preference Tool” on page 4-2.)
Typical Installation List

A typical installation installs these components, and requires about 2.02 GB of disk space:

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADS Run-Time Files</td>
<td>This is the basic ADS software, including the Design Environment; Data Display; and simulators for analog/RF systems, signal processing, and electromagnetic designs.</td>
</tr>
<tr>
<td>Vendor Component Libraries</td>
<td>Parts libraries, such as the RF Transistor Library or the Analog Parts Library.</td>
</tr>
<tr>
<td>Examples (requires 860 MB)</td>
<td>Complete set of ADS application examples with search engine.</td>
</tr>
<tr>
<td>Online Documentation (requires 508 MB)</td>
<td>Online manuals, help, and search engine. ADS 2004A uses HTML-based documentation displayed using your Web browser. See “Check the System Requirements” on page 1-2 for browser requirements.</td>
</tr>
</tbody>
</table>

Complete Installation List

A complete installation installs these components, and requires about 2.52 GB of disk space:

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADS Run-Time Files</td>
<td>This is the basic ADS software, including the Design Environment; Data Display; and simulators for analog/RF systems, signal processing, and electromagnetic designs.</td>
</tr>
<tr>
<td>Vendor Component Libraries</td>
<td>Parts libraries, such as the RF Transistor Library or the Analog Parts Library.</td>
</tr>
<tr>
<td>DesignGuides</td>
<td>Special interactive tool kits and handbooks for various types of designs.</td>
</tr>
<tr>
<td>LAN Client Files</td>
<td>Installs a setup folder enabling the PC to be a server for other LAN clients.</td>
</tr>
<tr>
<td>Examples (requires 860 MB)</td>
<td>Complete set of ADS application examples with search engine.</td>
</tr>
<tr>
<td>Online Documentation (requires 508 MB)</td>
<td>Online manuals, help, and search engine. ADS 2004A uses HTML-based documentation displayed using your Web browser. See “Check the System Requirements” on page 1-2 for browser requirements.</td>
</tr>
</tbody>
</table>
## Custom Installation List

The following options are available for a custom installation:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADS Programs and Tools (requires 613 MB)</td>
<td>This is the basic ADS software, and is the minimum required for ADS to run properly. This option includes all of the ADS tools (Design Environment; Data Display; and simulators for analog/RF systems, signal processing, and electromagnetic designs). Does not include online documentation, examples, and DesignGuides.</td>
</tr>
<tr>
<td>DesignGuides and Application Guides</td>
<td>Special interactive tool kits and handbooks for various design types.</td>
</tr>
<tr>
<td>LAN Client Files</td>
<td>Installs a setup folder enabling the PC to be a server for other LAN clients. Be sure to select this option if you intend to establish the current installation as a network server. For details, see “Installing on the Server” on page 2-10.</td>
</tr>
<tr>
<td>Layout, Simulators, and Schematic Capture</td>
<td>Includes the Schematic Capture/Layout tool, and primary simulators.</td>
</tr>
<tr>
<td>FLEXlm Files</td>
<td>Installs the FLEXlm license management software for a license server installation on a separate machine. For details, see “Installing Floating Licenses on a PC Server” on page 3-9.</td>
</tr>
<tr>
<td>Vendor Component Libraries</td>
<td>Parts libraries, such as the RF Transistor Library or the Analog Parts Library.</td>
</tr>
<tr>
<td>Manuals and Help (requires 508 MB)</td>
<td>Online manuals, help, and search engine. Documentation and help files will not be available if this option is not selected. ADS 2004A uses HTML-based documentation displayed using your Web browser. See “Check the System Requirements” on page 1-2 for browser requirements.</td>
</tr>
<tr>
<td>Examples (requires 860 MB)</td>
<td>Complete ADS application examples with search engine, including: Communications Systems Examples, Digital Signal Processing Examples, Microwave Circuit Examples, Momentum Examples, RFIC Examples, RF Board and RF System-in-Package Examples, Tutorial Examples, Training Examples, Behavioral Models Examples</td>
</tr>
</tbody>
</table>
Client-Server Installations

Advanced Design System can also be set up to run using a client-server configuration. Use the following steps to set up your client-server configuration, starting with the server installation and setup.

**Caution** When performing a client-server installation over a network, Agilent recommends that the parent folder of the ADS installation folder be shared. If the ADS installation folder itself is shared, problems will result in the simulation Data Display window.

Installing on the Server

Install Advanced Design System on the server, making sure that the LAN client files are part of the installation. This installs a folder named setup under the installation folder (for example: C:\ ADS2004A\ setup), which contains the files needed to set up client machines.

Once the installation is completed, share the installation directory so that client machines can access the software across the network. Please consult your system administrator or refer to your Windows documentation or help for instructions on sharing directories.
Installing on Clients

Once you have installed Advanced Design System on a server and shared the installation folder, use the following steps to install clients on each client machine.

**Note** Certain LAN/Client PC installation problems can occur unless you avoid the following setup: You access server files through a UNC path, or a path such as `\hostname\share`. This path can come about by using the Network Neighborhood to attach to server files, where you assign a drive letter to it; or through the use of the Windows Explorer, where you use `\hostname\share` notation to access a shared drive.

1. Map a drive on the client machine that connects to the shared Advanced Design System installation directory from the server machine. For example, you might create a mapped drive G: that accesses the C:\ADS2004A directory on the server. Please consult your system administrator or refer to your Windows documentation or help for instructions on mapping paths.

2. Double-click `setup.exe` in the setup folder within the installation folder.

3. The Advanced Design System 2004A LAN Client Installation title window appears displaying the Welcome screen. Choose:
   - **Next** to view the License Agreement.

4. At the License Agreement screen, choose:
   - **Yes** to accept the License Agreement and continue with the setup.

5. In the Select Features screen, choose a client installation option:
   - **Recommended network installation.** Installs main program files on the client machine and runs online manuals and component libraries from the network (requires approximately 350 MB of disk space on the client machine).
   - **Maximum network installation.** Runs all program files from the network. Only registry information, and PC icons are installed on the client machine, typically in C:\ADS2004A.

6. Once you have specified an installation option, to confirm your choice of run-time directory (specifying the path to files on the server), choose **Yes** or **No**. (If you choose **No**, the LAN Setup program will end.)
Installing Advanced Design System

For Maximum network installation, go to step 9 (Select Program Folder screen).
For Recommended network installation, continue here:

7. At the Choose Destination Location screen, define the install destination for the client's program files. Choose:
   • Next to install to the default folder. The installation program will create this folder if it does not already exist.
   • Browse to specify a different destination folder. If you specify a folder that does not already exist, the installation program will create it for you.

The installation program also creates a Home folder which will be the default startup folder for Advanced Design System. Typically, this is C:\users\default. It is also used to store the configuration data in a subfolder called hpeesof. If you are using more than one ADS version, please choose a new Home folder for each version. For the best performance, choose a folder on your local, not network, drive. To change the Home folder, click Back to see the Specify Your Home Directory screen.

8. At the Select System Components to Install screen, select the additional components you want installed on the Client (or local) machine. The Space Required field displays the total disk space the installation will require, based upon your choices. Click Next to continue.

9. At the Select Program Folder screen, specify the location to place the program icons. Choose:
   • Next to install the program icons to the default destination.
   • Enter a new folder name, or choose a different destination folder for the icons from the Existing Folders list, then click Next to continue.

10. At the Personal or Common program folder screen, choose:
   • Next to select the default option: Create start menu icons for current user only.
   • The option: Create start menu icons for all users, then click Next.
11. At the Check Setup Information screen, review your choices and click:
   • **Back** to access previous screens to verify entries and make changes. This screen appears again if you go back to make other choices.
   • **Next** to begin the installation.
   • **Cancel** to exit the LAN Setup without completing the client installation.

Immediately after you click **Next**, the Setup Status window appears and the program starts copying files. The status window displays the files being installed and shows the progress installing the indicated option or file. When installing the recommended network installation, the program will prompt you to switch CDs when necessary.

12. When the installation is complete, choose **Finish**.
Installing from a File Server

The contents of the ADS CD-ROMs can be copied to a file server PC enabling you to install ADS from this file server. This arrangement is useful for doing silent installations (see “Silent Installations” on page 2-18). The following steps explain how to set up the file server and run the installation on client PCs. Agilent EEsof recommends that you use the Windows Explorer to create folders and copy files in this procedure.

1. On the file server PC, create a folder and subfolder on a sharable hard disk using the structure shown in the following figure. This example assumes the folders are created on the D: drive.

   ![Folder Structure](image)

   **Important** The contents of the two ADS PC installation CD-ROMs must be copied into the cdrom folder shown in this example.

2. Insert the ADS PC installation CD #1 into the file server’s CD-ROM drive. If the Setup program starts automatically, cancel it at your first opportunity.

3. Copy the contents of CD #1 into the folder `D:\ADS2004A\cdrom`.
   To ensure copying all files, select the CD-ROM drive in Windows Explorer, and choose **Edit > Select All**, then **Edit > Copy**. Next, select the `cdrom` folder and choose **Edit > Paste**.
   Remove CD #1 from the CD-ROM drive after all files are copied.

4. Insert CD #2 into the file server’s CD-ROM drive. If the Setup program starts automatically, cancel it at your first opportunity.

5. Copy the contents of CD #2 into the folder `D:\ADS2004A\cdrom`.
   To ensure copying all files, select the CD-ROM drive in Windows Explorer, and choose **Edit > Select All**, then **Edit > Copy**. Next, select the `cdrom` folder and choose **Edit > Paste**.
   Remove CD #2 from the CD-ROM drive after all files are copied.
   
   In Windows Explorer, select the folder, then choose **File > Properties**. Select the **Sharing** tab, and complete the information. Click **OK**.

7. For each client PC on which you want to install ADS, map the client to the folder `D:\ADS2004A` on the file server PC. In Windows Explorer, choose **Tools > Map Network Drive** and complete the information.

8. On the client PCs, run `setup.exe` from the mapped network drive. You may run the normal installation described in “Detailed Installation” on page 2-3, or the silent installation described in “Silent Installations” on page 2-18.
Using Multiple ADS Versions

Use the following instructions to maintain and run more than one version of ADS (such as version 2003C and 2004A). Keep a separate $HOME directory for each version of Advanced Design System to help in structuring all the files and prevent problems that may arise if the configuration files are shared between multiple installations.

Setting the HOME Directory

Use the following steps to specify the $HOME variable value in the registry for each version of Advanced Design System.

**Caution** Use extreme care when editing the system registry. The computer may not function properly if the registry contains an error. You should backup the registry as a precaution. For more information, see the Registry Editor’s online Help.

1. Click on Start > Run.
2. Type in regedit.exe and click OK.
3. In the registry editor, select HKEY_LOCAL_MACHINE > SOFTWARE > Agilent > ADS > (ADS version) > eeenv
4. Select HOME and choose Edit > Modify to enter the desired location.
5. Close the registry editor.

Repeat these steps for each version of Advanced Design System.
Setting the HOME Environment Variable

Alternatively, you can set the $HOME variable as an environment variable. In this case, you will need to set it up in a MS-DOS batch script and run that batch script to start ADS.

Script for ADS 2003C

REM *************************************************
REM * ADS 2003C Startscript
REM *************************************************
REM * ADS 2004A Startscript
REM *************************************************
REM * ADS 2004A Startscript
Installing Advanced Design System

Choose the ADS version by running the appropriate script. As a last step, you need to make sure that the Start in variable is set correctly on the desktop shortcut:

1. Right-click the desktop shortcut that you use to start ADS.
2. Click Properties.
3. Click the Shortcut tab.
4. Verify that the Start in value is the same as the $HOME variable setting.

Silent Installations

The InstallShield program provided with ADS supports a silent installation using Microsoft's Windows Installer (MSI) technology. A normal (non-silent) installation receives the necessary input from the person installing the software in the form of responses to prompts in dialog boxes. However, a silent installation does not display prompts for inputs. Instead, a silent installation gets inputs from the InstallShield silent response (.iss) file.

Silent Installation Overview

Here is an overview about how to set up and run a silent installation on a Windows PC for ADS 2004A.

1. On a server PC’s sharable hard disk, copy the contents of the ADS PC installation CD-ROMs to a folder. Details about setting up a file server are described in “Installing from a File Server” on page 2-14.
2. Share this folder and map the folder to a client machine.
3. On client PCs, run the setup.exe utility using arguments for a silent installation, including the file name for a response file.
4. If needed, run a silent uninstallation to remove ADS from client PCs.

Response File Contents

When a normal installation runs, the inputs to prompts are entered manually into dialog boxes. During silent installations, the inputs are provided automatically by a response file. The command to execute a silent installation includes the file name for a specific response file. ADS provides two sample response files. They are copied into the folder where the ADS PC installation CD-ROMs are copied onto the file server.
PC. For example, if the CD-ROM contents are installed in D:\ ADS2004A\ cdrom, the sample files are located in D:\ ADS2004A\ cdrom\ silent. The sample response files are:

- **typical.iss** performs a Typical installation
- **complete.iss** perform a Complete installation.

**Note**  Silent installations using the complete.iss response file do not install the LAN Client files. In a normal Complete installation, LAN Client files are installed into the folder $HPEESOF_DIR\ setup.

The sample response files contain the default settings used for the normal Typical and Complete installations defined in "Detailed Installation" on page 2-3. They supply the following inputs requested by the installation program:

- Install ADS 2004A into the folder C:\ ADS2004A.
- Set the home folder to C:\ users\ default.
- Place shortcut icons for the Start menu in a default location.

If you want to change these settings, edit the response file directly. Be careful to locate and change only the settings in question to avoid corrupting the file:

- To change the installation folder, change C:\ ADS2004A to a new setting.
- To change the home folder setting, change C:\ users\ default to a new setting.
Installing Advanced Design System

Running a Silent Installation

To run a silent installation on a client PC, run the setup.exe utility using the silent installation switch and identify which response file to use:

1. On the client PC, verify that ADS 2004A has not already been installed. There should not be a C:\ ADS2004A folder since the silent installation process is not expecting it to be there. If ADS has been installed, you should uninstall it.

2. On the client PC, open a Command Prompt or DOS prompt window. In a command prompt, change to the folder D:\ ADS2004A\ cdrom that is shared by the server PC.

3. Execute the setup.exe command. Use the silent installation option /s and identify the full path for the response file and log file using /f1 and /f2.

   Note   When entering the paths for the response and log files, do not enter a space after the /f1 or /f2 switches, and be sure to place quotation marks around the path.

   The following example commands spawn a process running a Complete installation silently. The process appears in the Task Bar. The log file is written to the temp folder on the C: drive.

   cd D:\ADS2004A\cdrom
   setup /s /f1"D:\ADS2004A\cdrom\disk1\silent\complete.iss"
   /f2"C:\temp\complete.log"

4. To monitor the silent installation process, wait three to five minutes. Then, in a command prompt, change to the folder $HPEESOF_DIR\ tools\ lib\ dpkg, and run the tail command as shown in this example:

   cd C:\ADS2004A\tools\lib\dpkg
   ..\..\bin\tail -f adsinstalllog.txt

   You will see the following message at the end of the log file when the process is done:

   End of silent installation
Running a Silent Uninstallation

When you need to run a silent uninstallation on a client PC, use the sample batch file, uninst.bat. Using our example location for the CD-ROM contents, it is located in the folder D:\ADS2004A\cdrom\silent.

To run a silent uninstallation:

1. In a command prompt, change to the folder containing the batch file.
   ```cmd
   cd D:\ADS2004A\cdrom\silent
   ```
2. Copy the uninstall response file to the folder C:\temp and run the batch file:
   ```cmd
   copy uninst.iss C:\temp
   .\uninst
   ```
   This process opens a progress dialog box. When the dialog box closes, the process is done.

Troubleshooting

The most effective way to troubleshoot errors with the silent install/uninstall process is to run the same type of installation in normal or visual mode.
Creating Your Own Response File

A response file contains information that a person running a normal installation would usually enter as responses to dialog boxes. During a silent installation, when setup.exe is run with the /s option, setup.exe reads the necessary input from the response file at run time.

A response file is a plain text file consisting of sections containing data entries. A response file's format resembles that of a .ini file, except a response file uses the .iss extension.

To create a response file, run setup.exe using the /r option in a command prompt. This runs the installation normally, and records your inputs into a response file which can be used during a silent installation. By default, the response file is called setup.iss, and is created in the Windows or WinNT folder. To specify a different name and location for the response file, use the /f1 switch with setup.exe. For example, the following commands change to the folder containing setup.exe, run setup.exe, and create a response file. This command runs an installation session in a normal visual mode:

```
cd D:\ADS2004A\cdrom
setup /r /f1"c:\temp\mysetup.iss"
```

On another PC, or on the same PC after you uninstall ADS, you can play back or run this response file by running the command:

```
setup /s /f1"c:\temp\mysetup.iss"
```
Installing Connection Manager

If you will be using the Connection Manager product, you should be aware that it contains two parts: the Connection Manager client, and the Connection Manager server.

The Connection Manager client is installed during the ADS installation. To run it, you must obtain the license link_connect_mgr. Then, to use Connection Manager to communicate with instruments, you must install the Connection Manager server. The Connection Manager client and server installations are not related to a client-server installation of ADS.

The Connection Manager server must be installed on a Windows PC. This can be the same PC on which you installed ADS and the Connection Manager client, or it can be a separate, stand-alone PC server. The server software is located on the CD-ROM labelled Connection Manager Server 2004A Installation Disc. The Connection Manager server does not require a license regardless of where it is installed. For instructions about installing the Connection Manager server, see Appendix A, Installing Connection Manager Server. For general information about Connection Manager, see the documentation Connection Manager.

Note Prior to ADS 2004A, when the Connection Manager Server was installed on a stand-alone Windows PC, ADS had to be installed on the same PC. Starting with ADS 2004A, when you install Connection Manager server on a stand-alone PC, it is no longer necessary to also install ADS on the same PC.

The Connection Manager client and server software must be from the same release. If you used an older release of Connection Manager, then you install ADS 2004A on a client system, you must also install the same version of the Connection Manager server onto the Windows PC you will use as the server.
Chapter 3: Setting Up Licenses

Use the following information to set up licenses for Advanced Design System on a PC running Windows. After you install Advanced Design System using the steps described in Chapter 2, Installing Advanced Design System, you will need to set up the FLEXlm license manager and your ADS license file (license.lic) before you can run Advanced Design System.

Advanced Design System uses Macrovision Corporation’s Flexible License Manager (FLEXlm) software for all software security configurations. When you run the Advanced Design System Setup program, the FLEXlm software is installed at <installation folder>\licenses\bin where <installation folder> is the destination folder you specified when you ran Setup.

Using LMTOOLS for FLEXIm

ADS 2004A uses the utility lmtools with the FLEXlm software. This utility does not replace the steps in this chapter for license installation, but can help in the installation and use of FLEXlm licenses.

The utility can be found in the \ADS2004A\licenses\bin folder and is named lmtools.exe. Using lmtools, you can:

• Determine your system’s settings, which you will need when you request codewords from Agilent EEsof EDA. This information can be found under the System Settings tab.

• Configure your FLEXIm licenses to start from a license file or as a Service using the Service/License File tab. If you choose to start FLEXIm as a service, you can configure the FLEXIm service from the Configure Services tab.

• Start, stop, and reread license.lic files and services using the Start/Stop/Reread tab.

For details on using FLEXIm and lmtools, refer to the Macrovision website at:

http://www.macrovision.com/

Choose Products > Legacy Products > FLEXIm
Setting Up Licenses

License Installation Overview

---

Note  The Agilent License Information Tool is available to check your environment variable settings, display your license file, and show your license and server status. Refer to “Using the Agilent License Information Tool” on page 3-39.
Installing Your Licenses

You must request and install new license codewords for ADS 2004A. To learn how to request codewords, see “Get Codewords for ADS 2004A” on page 1-4. Use the steps in the following sections to install your Advanced Design System licenses. If you have not done so, please review Chapter 1, Before You Begin. Ideally, you should have installed Advanced Design System before you complete these steps. For details on installing Advanced Design System on a PC running Windows, please refer to Chapter 2, Installing Advanced Design System.

Use one of the following methods to run the FLEXlm licensing system on your PC:

- Install a FLEXid hardware key.
- Read your LAN card’s ethernet ID.

**Important** ADS 2004A installs version 9.2a of FLEXlm. Make sure you use the latest version of the FLEXlm software, drivers, and hardware key as needed on all ADS systems and license servers.

Installing a Hardware Key

One way to run the FLEXlm licensing system on your PC is to install the FLEXid hardware key (also called a dongle) on a parallel port of your computer. In a node-locked environment, it is installed on the local machine. In a floating license environment, it is only required on the server machine.

**Note** Before you install the key, make a note of the hardware key ID number on the key. If you have not already received your security codewords from Agilent EEsof, you will need to provide this number for your Codeword Request Form, as explained in the section, “Determining License Type” on page 3-6.
Setting Up Licenses

Installing the FLEXid Driver

Complete the following steps to install the latest FLEXid driver needed to license ADS. You need to do this only if you wish to lock your licenses to a hardware key. Be aware that this procedure requires system administrator privileges. Macrovision recommends that you install the FLEXid System Driver with their installer, which is included on the ADS PC Setup disk.

The installation program will attempt to load the FLEXid driver automatically; however, it may not be able to do so if your system has a FLEXid driver. In that case you will need to load it using the following steps.

To install the Macrovision FLEXid Driver:

1. Place the Advanced Design System PC Setup disk in your CD drive.
2. Select Start > Run (or use your Windows Explorer and skip the next step).
3. In the Run box, click Browse.
4. Change to the CD-ROM drive.
5. Locate and double-click the file flexid.exe. The Driver Setup Program is displayed.

   **Note** If your install disks include the file flexidsilent.exe, use it instead of the file flexid.exe. This will enable you to install the FLEXid driver without needing to reboot your system.

6. Click the Next button.
7. When the process is complete, a dialog box with a message to restart your system is displayed.
8. Click OK.
9. Restart your computer. The driver will not become active until your PC is rebooted.
Using the Ethernet ID

Another way to run the FLEXlm licensing system on your PC is to read your LAN card’s ethernet ID and have Agilent EEsof Business Support tie this ID to your ADS codewords. To use this method, do the following:

1. Make sure that you have TCP/IP and IPX/SPX network protocols loaded on your PC. The IPX/SPX protocol is required by FLEXlm. To get help on network protocols, refer to your Windows Help for Network Protocols:
   • Choose Start > Help.
   • Select the Index tab.
   • Enter network protocols.
   • Click the Display button.
   • Select To install a network protocol.
   • Click the Display button.
   • Follow the help instructions, which will ask you to click in the help dialog box to continue.
   • If you already have TCP/IP and IPX/SPX network protocols loaded, these items will be displayed. If you don’t have both, choose the Add button and select the needed protocols from the list that appears. For example, select NWLink IPX/SPX Compatible Transport to add the IPX/SPX network protocol.

2. Verify that you can read your LAN card’s ethernet address. For all versions of Windows, run the following FLEXlm command from the MS DOS Command Prompt:

   cd \ADS2004A\licenses\bin
   lmutil lmhostid

   To obtain your LAN card’s ethernet address before you have ADS installed:

   Type ipconfig /all
   If lmutil lmhostid does not return the expected ethernet address of your LAN card, make sure you have the IPX/SPX (NWLink IPX/SPX Compatible Transport) protocol loaded.
Setting Up Licenses

**Note** Before you can use your LAN card's ethernet ID, you will have to let Agilent EEsof Business Support tie this ID to your ADS codewords. If you have not already received your security codewords from Agilent EEsof, you will need to provide this number on your Codeword Request Form, as explained in the section, “Determining License Type” on page 3-6.

### Determining License Type

Look at the INCREMENT lines in your license file to determine the type of licenses you have. If the INCREMENT lines contain the strings HOSTID= and uncounted, then your licenses are node-locked. Otherwise, your licenses are floating. For example:

**Node-locked License**

```plaintext
INCREMENT ads_schematic agileesofd 2.34 01-jun-2004 uncounted \
       VENDOR_STRING="5E700059B957 : JRDNMSO IWSPGBB ICHLEDL \ 
       ICUNETS MCTENRX YGRTAKP SOG" HOSTID=FLEXID=8-5E700059B957 \ 
       SIGN="03C2 589C 3175 F509 1528 464B 2087 5082 5840 FFD4 \ 
       B701 7845 1421 8EB7 841E 6722 A307 35A9 4030 68A6 4811"
```


**Floating License**

```plaintext
INCREMENT ads_schematic agileesofd 2.34 01-jun-2004 2 \
       VENDOR_STRING="5E700059B957 : JRDNMSO IWSPGBB ICHLEDL \ 
       ICUNETS MCTENRX YGRTAKP SOG" SIGN="0129 3D82 9EED A56B \ 
       87AC 22D3 F27F CDC4 AF52 C4BD 2403 901E 17B2 75FC 00A2 \ 
       6033 79D0 5D3F F333 863F 4BD1"
```

For Floating licenses, refer to, “Installing Floating Licenses on a PC Server” on page 3-9.
Installing Node-Locked Licenses

The license file with the node-locked codewords must be installed on each local machine. The default install path is: <installation folder>\licenses; for example, C:\ ADS2004A\ licenses). Copy the license file that you received via e-mail to the <installation folder>\ licenses folder.

Note Do not execute FLEXlm's lmgrd command for node-locked licenses. If you have started this program, stop it using the Task Manager or re-boot your PC.

Changing the License File Location

If you use the default license file location, your environment variables are set automatically. To use the license file from a different location, you need to set the AGILEESOFD_LICENSE_FILE environment variable to point to the location.

To define the environment variable:

- On Windows 2000/XP, choose Start > Settings > Control Panel > System > Advanced > Environment Variables then add a new variable named AGILEESOFD_LICENSE_FILE that points to the full path to the license file.

Your environment variable can be entered either as a user variable or as a system variable. The user variable affects only the currently logged-in user; the system variable affects all users. For a node-locked license, be sure you add the AGILEESOFD_LICENSE_FILE variable to the System variables, not the User variables.
Setting Up Licenses

If you are running multiple versions of ADS, do not include the HPEESOF_DIR variable in the System variables or User variables list boxes (and remove them if you have them).

**Important** The AGILEESOFD_LICENSE_FILE environment variable overrides any LM_LICENSE_FILE settings you might have set up. The LM_LICENSE_FILE variable is used only when the AGILEESOFD_LICENSE_FILE is not set. As a result, using the AGILEESOFD_LICENSE_FILE variable will isolate your ADS license configurations from other applications that use the LM_LICENSE_FILE variable.
Installing Floating Licenses on a PC Server

Use the following sections to install your Advanced Design System floating licenses. You should have installed Advanced Design System before you complete these steps. For details on installing Advanced Design System on a PC running Windows, please refer to Chapter 2, Installing Advanced Design System.

Important Be sure to use the following information to update all existing license servers with the latest version of the FLEXlm software (e.g., lmgrd and lmutil). The software is installed with ADS 2004A. Using older versions may cause license-encryption errors, invalid hostid results, and unsupported feature errors.

Verify that all multiple and redundant servers are updated including any license administration scripts in use. Run lmutil directly from the ADS 2004A installation location ($HPEESOF_DIR\licenses\bin) for information to help modify the scripts.

You will need to stop, then restart, the license server to make these updates.

Installing the License File

The license file that implements FLEXlm security must be installed to run ADS. The default install path is: <installation folder>\licenses; for example, C:\ADS2004A\licenses). Copy the license file that you received via e-mail to the <installation folder>\licenses folder.

If your licenses will be served by a central server, have your system administrator install the license file on the license server machine.
Setting Up Licenses

**Entering the Hostname**

Change the default hostname setting in your license file to the actual hostname of your license server. The license server is the machine that will serve the licenses on the network, and whose Ethernet address or FLEXID hardware key number, appears on the SERVER line.

For example, assuming that a machine with FLEXID hardware key number 8-5E 700059B957 has a hostname of joshua. The SERVER line should read:

```text
SERVER joshua FLEXID=8-5E700059B957
```

Starting with ADS 2002, all license files are generated with SERVER lines with the following format:

```text
SERVER <hostname> <hostid>
```

where:

- `<hostname>` is set to unknown by default
- `<hostid>` is the FLEXID hardware key number or Ethernet address of the license server.

You can also specify a specific TCP port number for license requests as follows:

```text
SERVER <hostname> <hostid> <tcp_port>
```

To run ADS and check out a license from this license server, you will need to set the `LM_LICENSE_FILE` or `AGILEESOFD_LICENSE_FILE` as follows.

```text
LM_LICENSE_FILE=2100@joshua
AGILEESOFD_LICENSE_FILE=2100@joshua
```

The `AGILEESOFD_LICENSE_FILE` environment variable overrides any `LM_LICENSE_FILE` settings you might have set up. The `LM_LICENSE_FILE` variable is used only when the `AGILEESOFD_LICENSE_FILE` is not set. As a result, using the `AGILEESOFD_LICENSE_FILE` variable will isolate your ADS license configurations from other applications that use the `LM_LICENSE_FILE` variable.
If you do not specify a TCP port number on the SERVER line, the license server will use the first available TCP port number in the range 27000 to 27009. In this case you will need to set the LM_LICENSE_FILE or AGILEESOFD_LICENSE_FILE as follows.

```
LM_LICENSE_FILE=@joshua
AGILEESOFD_LICENSE_FILE=@joshua
```

**Note** Enter a specific port address on the SERVER line for improved license check-out performance. You may enter a port address outside the range of 27000 to 27009, as long as the address is not used elsewhere. Then set the environment variable AGILEESOFD_LICENSE_FILE or LM_LICENSE_FILE.

## Setting the Vendor Daemon Path

By default, no path is specified for the agileesofd vendor daemon executable. This is acceptable as long as lmgrd and agileesofd are in the same folder when you start FLEXlm.

In the typical license configuration, lmgrd and agileesofd are both located in the \ads2004A\licenses\bin folder. When lmgrd is started from the \ads2004A\licenses\bin folder, it looks for agileesofd in the same folder. If agileesofd is not in the same folder as lmgrd, you must specify a path to it using the following syntax

```
VENDOR agileesofd c:\ads2004A\licenses\vendors\agileesofd
```

## Connecting to a License Server through a Firewall

If client systems connect to a license server through an Internet firewall set up on a Windows PC, you must also specify the port number the vendor daemon uses. You can specify the port number on the license file's VENDOR line. If the port is not specified, the default is chosen by the operating system at run time. If this port number is specified, there may be a delay restarting the vendor daemon until all clients have closed their connections to the daemon. Here is an example of a properly configured VENDOR line including the daemon path and port number:

```
VENDOR agileesofd c:\ads2004A\licenses\vendors\agileesofd 27000
```

Some clients may timeout before they can connect to a license server through a firewall. The default timeout period is 0.1 second. If you need a longer timeout period,
you can set the environment variable FLEXLM_TIMEOUT to a new value. Enter the value using microseconds. Agilent EEsof recommends trying one second. For example:

FLEXLM_TIMEOUT=1000000

Depending on your network, you may need to adjust the period so it is long enough to allow connections without slowing down simulations excessively.

Starting FLEXlm

FLEXlm can be started either manually or automatically. You must start the FLEXlm license manager daemon (lmgrd) on the license server(s) first. Once the license server(s) is running lmgrd and has started the vendor daemon(s), you can configure the other machines (clients) and user login accounts that need to access ADS.

To start FLEXlm you need the following.

• FLEXlm software installed in the <installation_location>/licenses folder. This is done when you install Advanced Design System.

• The license server machine connected to the network using the TCP/IP network protocol.

• A local copy of the licenselic file that contains the FLEXlm codewords. Every machine that will run Advanced Design System must be able to access the licenselic file used by the license server(s) to check out a license. Access to the licenselic file can be via a local copy of the licenselic file or through a network drive.

• Properly configured SERVER and VENDOR lines in your licenselic file.

If you have a three-server redundant configuration, you must start FLEXlm on all three servers before the licenses will be available on the network. Once you have FLEXlm running, you can configure the other machines (clients) and user login accounts that need to access ADS by setting the LM_LICENSE_FILE or AGILEESOFD_LICENSE_FILE.
Starting FLEXlm Manually

While starting FLEXlm manually is a good way to verify that FLEXlm starts correctly, it is generally not recommend for a server machine, because it requires a dedicated MS-DOS Command Prompt to be open at all times and it requires re-starting after rebooting the license server. Use the following steps to start the FLEXlm executable file, lmgrd.exe:

1. From a MS-DOS Command Prompt, change to  
   <installation_directory>\licenses\bin, where <installation_directory> is the folder where you installed ADS.

2. Type the following command specifying the full path and location of the license file.

    lmgrd -app -c <installation_directory>\licenses\license.lic  -l  <inst_dir>\licenses\flex.log

To shut down the license manager, enter the following at a command prompt, from the <installation_directory>\licenses\bin folder:

    lmutil lmdown -c <installation_directory>\licenses\license.lic
Setting Up Licenses

Starting FLEXlm Automatically

Ideally you should configure FLEXlm to start up automatically each time your system is booted by installing the license manager as a Control Panel service.

To start the license manager automatically:

1. From a MS-DOS Command Prompt, change to 
   `<installation_directory>\licenses\bin`, where `<installation_directory>` is the folder where you installed ADS.

2. Enter the full path and filename of both the license executable file and the license file. The default location for the executable file is `installation_directory\licenses\bin\lmgrd.exe` (The flex.log file is useful for troubleshooting.)

   `installs -e <path to lmgrd> -c <path to license file> -l <path to flex.log>`

   For example:

   `installs -e d:\ADS2004A\licenses\bin\lmgrd.exe -c d:\ADS2004A\licenses\license.lic -l d:\ADS2004A\licenses\flex.log`

   If you don’t specify a flex.log file using the “-l” option when you run installs.exe, FLEXlm creates a default log file in the system32 folder. While this default log file does not contain as much information, it can still be useful. This file is typically located in c:\ winnt\ system32\ and is named lmgrd.log or lmgrd.xxxx where “xxxx” is the process ID number of lmgrd.

3. Activate the license server by starting the FLEXlm service using the Control Panel or by rebooting the system:

   On Windows 2000:
   Start > Settings > Control Panel > Administrative Tools > Services

   On Windows XP:
   Start > Control Panel (in classic view) > Administrative Tools > Services

   To remove the license manager from the service list and cancel the automatic FLEXlm startup:

   From a system prompt, change to the license folder and enter: `installs -r`

   To change the path to your license file, first remove the existing FLEXlm service using the installs -r command, reinstall FLEXlm using the new location, and then reboot your system.

---

3-14 Installing Floating Licenses on a PC Server
Ensuring Access to the License File

You need to configure each client machine to access the license server and to check out a license. You can do this by using one of two methods:

- Place a copy of the license.lic file in the `<installation_directory>\licenses` folder of each local machine.
- Configure the `LM_LICENSE_FILE` or `AGILEESOFD_LICENSE_FILE` to point to the license file.

Typically it is best to use the `port@host` syntax to set the `AGILEESOFD_LICENSE_FILE` to point to the license server.

```plaintext
set AGILEESOFD_LICENSE_FILE=27000@joshua
```

Where 27000 is the TCP port on the SERVER line in the license.lic file and joshua is the host name of the license server.

If your license server is set up to search for an available port, use the `@host` syntax to set the `AGILEESOFD_LICENSE_FILE` to point to the license server.

```plaintext
set AGILEESOFD_LICENSE_FILE=@joshua
```

You can also set the `AGILEESOFD_LICENSE_FILE` to point to the full path and filename of the license.lic file used by the license server.

---

**Note**  The `AGILEESOFD_LICENSE_FILE` environment variable will override any `LM_LICENSE_FILE` settings you might have set up. If `AGILEESOFD_LICENSE_FILE` is not set, `LM_LICENSE_FILE` will be used.
3-16 Accessing Licenses From a UNIX or Linux License Server

Setting Up Licenses

Accessing Licenses From a UNIX or Linux License Server

You can access licenses from a UNIX or Linux license server by doing the following:

1. Set up the UNIX/Linux license server(s) to use FLEXlm version 9.2a or higher lmgrd and agileesofd daemons.
2. Set up the PC to access the UNIX/Linux license server’s licenselic file.

Setting Up the UNIX or Linux License Server

You must use version 9.2a or higher of the FLEXlm daemons lmgrd and agileesofd. Use the following commands to check the version of lmgrd and agileesofd on your UNIX/Linux license server:

```
cd $HPEESOF_DIR/licenses/bin
   ./ lmgrd -version

cd $HPEESOF_DIR/licenses/vendors
   ./ agileesofd -v
```

Use the following steps to update current FLEXlm daemons on your license server(s):

1. Stop the current FLEXlm daemons on the license server:

```
cd $HPEESOF_DIR/licenses/bin
   ./lmutil lmdown -c ../license.lic
```

2. Replace the following files with the supported FLEXlm version files:

```
$HPEESOF_DIR/licenses/bin/lmgrd
$HPEESOF_DIR/licenses/bin/lmutil
$HPEESOF_DIR/licenses/bin/agileesofd
```

   If you have more than one license server, make sure you do this on all of them.

3. Restart the license daemons on the UNIX/Linux license server(s):

```
cd $HPEESOF_DIR/licenses/bin
   ./ lmgrd -c ../license.lic -l ../flex.log
```
Setting Up the Client(s)

Your PC can access the UNIX/Linux license server’s license.lic file in either of two ways:

- By copying the license.lic file from the UNIX/Linux license server to the PC’s installation_directory\licenses folder
- By setting the AGILEESOFD_LICENSE_FILE variable on the PC to point to the UNIX/Linux license server as follows:

  ```
  set AGILEESOFD_LICENSE_FILE=<port>@<host>
  ```

  For example:

  ```
  set AGILEESOFD_LICENSE_FILE=27000@joshua
  ```

  where 27000 is the port number on the SERVER line in the license.lic file on the UNIX/Linux license server and joshua is the hostname of the UNIX/Linux license server.

To set an AGILEESOFD_LICENSE_FILE system environment variable that points to the license.lic file, use the steps outlined in “Changing the License File Location” on page 3-7.

Selecting a License Bundle

This step is necessary only if you are using license bundles.

If you have been using license packages in previous versions, you should be aware that packages were replaced by license bundles in ADS 2003A. Bundles are an improvement over packages by giving you more control over which license bundles are used during an ADS session.

You must select a bundle when starting ADS to ensure a license bundle is being used. The Agilent License Preference Tool is available to help you make a selection. To learn how to select bundles using the preference tool, see “Using the Agilent License Preference Tool” on page 4-2.
Setting Up Licenses

**Special Licensing Needs**

Be sure to use the lmtools utility to install an ADS license on a server that is already running FLEXlm. For details on using FLEXlm, refer to the Macrovision website at:

http://www.macrovision.com/

Choose FLEXlm

**Using FLEXlm Options**

An options file enables the license administrator to control the security parameters of FLEXlm. Specifically the license administrator can:

- Allow the use of features based on user, hostname or display name.
- Deny the use of features based on user, hostname or display name.
- Reserve licenses based on user, hostname or display name.
- Control the amount of information logged about license usage.

**Creating an Options File**

Use the desired options listed to create the options file using any text editor. Ideally, you should keep the options file in the same directory as your license.lic file. Also, add the pathname to the options file in the license.lic file as the fourth field on the VENDOR line for agileesofd as shown in the following example. (Remember to use the backslash (\) character if the file contains wrapped lines.)

```
VENDOR agileesofd c:\ads2004A\licenses\vendors\agileesofd \c:\ads2004A\licenses\agileesofd.opt
```

You can include comments in your options file by starting each comment with a pound sign ‘#’. Everything in the options file is case-sensitive. Be sure that user names and feature names, for example, are entered correctly. The available options are:

- **EXCLUDE**
  Deny a user access to a feature.

- **EXCLUDEALL**
  Deny a user access to all feature served by this vendor daemon.

- **GROUP**
  Define a group of users for use with any options.
• INCLUDE
  Allow a user to use a feature.

• INCLUDEALL
  Allow a user to use all features served by this vendor daemon.

• NOLOG
  Turn off logging certain items.

• REPORTLOG
  Specify that a logfile be written suitable for use by the FLEXadmin End-User Administration Tool.

• RESERVE
  Reserve licenses for an individual user or groups of users.

• TIMEOUT
  Works only for specified simulator and library licenses.

• TIMEOUTALL
  Works for all simulator and library licenses.

Use the following steps to create and use an options file. Details about each step located in previous sections:

1. Create an options file with your required options.

2. Modify your license.lic file so that the VENDOR or DAEMON line points to this option file as shown in this example:

   VENDOR agileesofd c:\ads2004A\licenses\vendors\agileesofd \c:\ads2004A\licenses\agileesofd.opt

3. Start up your license server (lmgrd) that is pointing to your license file. You must stop it first if it is running. It’s important that a message is displayed or recorded in the FLEXlm log verifying the license manager is using the options file. The following example shows that the license manager is using the agileesofd.opt file containing the TIMEOUTALL option set to 900 seconds:

   17:35:14 (agileesofd) Using options file:
   "c:\ads2004A\licenses\agileesofd.opt"

   17:35:15 (agileesofd) ALL FEATURES: INACTIVITY TIMEOUT set to 900 seconds

4. Set AGILEESOFD_LICENSE_FILE to point to your license server.

5. Run ADS.
Specifying the TIMEOUT Option

You can set a custom time-out period for simulator and library licenses using the TIMEOUT or TIMEOUTALL options. If you do not specify a time-out value in your options file or do not have an options file, a default two-hour limit is used. These time-out options apply to those application features that have explicitly implemented time-out via the heartbeat function. This includes licenses for the Analog/RF and Signal Processor simulators and for libraries, and do not affect licenses for the design environment and data display. The time-out option sets the amount of time a feature may remain idle before its license is released and reclaimed by the vendor daemon. The TIMEOUT option enables you to identify specific licenses, and the TIMEOUTALL affects all licenses (simulators and libraries).

To use TIMEOUT, add an entry for each feature to the options file using the following format:

```
TIMEOUT feature_name seconds
```

where:

- feature_name is name of the feature.
- seconds is the number of seconds before inactive license is reclaimed. The minimum value is 900 seconds (15 minutes). If you specify a time-out value smaller than the minimum, the minimum is used.

The option TIMEOUTALL works just like TIMEOUT, but applies to all features.

```
TIMEOUTALL seconds
```

Here are example entries you can include in your options file:

To set a time-out for the harmonic balance simulator to one hour (3600 seconds):

```
TIMEOUT sim_harmonic 3600
```

To set time-outs for multiple simulators to different periods:

```
TIMEOUT sim_linear 900
TIMEOUT sim_harmonic 3600
TIMEOUT sim_convolution 3600
```

To set a time-out for all simulators and libraries to one hour (3600 seconds):

```
TIMEOUTALL 3600
```
**Updating the License File**

If you have been running FLEXlm and receive updated codewords from Agilent EEsof, you can add the new licenses to the FLEXlm environment as follows:

1. Replace the existing license.lic files on the license servers and clients with the new license.lic file.
2. On the primary server, run `lmutil lmreread`. This causes the lmgrd on the primary server to re-read the license.lic file and update all of the other lmgrd processes on the network.
3. After you have done this, you can run `lmutil lmstat -a` to verify that the license servers have received the new license information.

If this does not work, you may need to stop all of the lmgrd processes on your network and then restart them as described in “Starting FLEXlm” on page 3-12.

**Merging Multiple Vendor Licenses**

When you are running FLEXlm-licensed products from multiple vendors, you have three ways to prevent licensing conflicts during installation:

- Multiple license server nodes; each running one lmgrd and one license file
- One license server node running one lmgrd and one license file
- One license server node running multiple lmgrds and multiple license files

Each lmgrd can only read a single license file. With the first option you will have more license servers to monitor. With the third option you have only one server but multiple lmgrds to administer.

Your product’s license file(s) define the license server(s) by hostname and hostid in the SERVER line(s) in the license file.

- If the license files for two or more products contain identical hostids on the SERVER line(s), then these files can be combined.
- If the license files for two products contain different hostids on a SERVER line, then the license servers for those products will be running on different nodes and the license files cannot be combined.
Setting Up Licenses

If you have two or more products whose license servers run on the same node (as specified by the SERVER lines in the license files), you may be able to combine the license files into a single license file.

- If the SERVER lines in those files have identical hostids, then you can combine the files into a single file.
- If the SERVER lines have different hostids, then you must keep the license files separate.

Essentially, you can combine two license files under the following conditions:

1. The number of SERVER lines in each file is the same.
2. The hostid field of each SERVER line in one file exactly matches the hostid field of each SERVER line in the other file.

Some possible reasons license files may not be compatible are:

- License files are set up to run on different server nodes, so hostids are different.
- One file is set up for single server (has only one SERVER line), the other is set up for redundant servers (has multiple SERVER lines).
- One vendor uses a custom hostid algorithm, so the hostids on the SERVER lines are different even though the files are for the same machine.

If your license files are compatible as described above, then you can combine license files and run a single lmgrd, as described in “Combining License Files from Multiple Vendors” on page 3-23. If the license files are not compatible, then you must keep the license files separate and run separate copies of lmgrd for each license file, as described in the section, “Using Separate License Files on the Same Server Node” on page 3-24. For specific information about combining licenses for multiple versions of ADS, see “Managing Multiple ADS Versions” on page 3-32.

**Important** There is virtually no performance or system-load penalty for running separate lmgrd processes.

---

3-22 Special Licensing Needs
Combining License Files from Multiple Vendors

If your license files are compatible, you can combine them using any text editor. To combine license files, read all of the compatible license files into one file, then edit out the extra SERVER lines so that only one set of SERVER lines remains. Write out this data, and you have your combined license file.

If you combine license files from multiple vendors, it is a good idea to keep a copy of the combined license file in each vendor’s default license file location. This way, your users can avoid having to set AGILEESOFD_LICENSE_FILE, because each package finds its license information in the default place. On UNIX or Linux, you can do this with a symbolic link from each default location to the location of the combined license file.

FLEXlm Version Component Compatibility

When you combine license files for two different FLEXlm-licensed products, the products may not use the same version of FLEXlm. FLEXlm is designed to handle this situation. There are two basic compatibility rules for FLEXlm:

1. A newer lmgrd can be used with an older vendor daemon, but a newer vendor daemon might not work properly with an older lmgrd.
2. A newer vendor daemon (or lmgrd) can be used with an older client program, but a newer client program might not work properly with an older vendor daemon.

From these two compatibility rules come the simple rules for selecting which version of administration tools to use:

1. Always use the newest version of lmgrd and the newest version of each vendor daemon.
2. Use the newest FLEXlm utilities.

For specific application programs, you can use either the new or the old version (with the assumption that the vendor daemon for that application is at least as new as the application).
Setting Up Licenses

Using Separate License Files on the Same Server Node

You must run a separate copy of lmgrd for each license file. When you run multiple copies of lmgrd, there are two details to remember:

1. The port number on the SERVER line of each license file must be unique. You can use a standard text editor to change the port number in each license file so that they are all different.

2. You must make sure that you are using a compatible version of lmgrd when you start it up for a particular license file. This can be done by using an explicit path to lmgrd.

When running client programs (such as a licensed application), you can set the AGILEESOFD_LICENSE_FILE environment variable to point to multiple license files. For example, you may have a license file from vendor ABC and a license file from vendor XYZ with incompatible servers. You can place the license file from vendor ABC into:

```
c:\user\flexlm\abc.lic
```

and the license file from vendor XYZ into:

```
c:\user\flexlm\xyz.lic
```

then set the AGILEESOFD_LICENSE_FILE environment variable to point to both of them. The syntax is as follows:

```
AGILEESOFD_LICENSE_FILE=27000@server1;27000@server2;27000@server3
```

Note that each path is separated with a semi-colon.

AGILEESOFD_LICENSE_FILE can point to only one license file for FLEXlm v1.x applications.
Redundant License Servers

FLEXlm enables you to set up a redundant license server configuration. This involves configuring three license servers with one of the three servers functioning as the master server. If the master server goes down, one of the other two servers becomes the new master server, and the licenses remain available on the network.

Setting up redundant servers requires extra system administration and is not recommended unless you absolutely need it.

To set up redundant license servers, use the same FLEXlm procedures on all three servers. All three servers need to be up and running before your licenses will be made available.

Controlling License Path Settings

The lmutil utility provides the lmpath function which allows direct control over FLEXlm license path settings. You can use lmpath to add to, override, or get the current license path set in the registry. This enables you to change or view path settings without locating individual settings in the Windows registry on the PC or in the FLEXlm registry (.flexlmrc) on UNIX or Linux.

The lmutil utility is located in $HPEESOF_DIR\licenses\bin. This location must be in your PATH, or use the following command before running the utility:

```bash
cd $HPEESOF_DIR\licenses\bin
```
Setting Up Licenses

The usage for this function is:

```
lmutil lmpath {status | -add | -override} {vendor_name| all} license_path_list
```

where

- `status` displays the current license path settings.
- `add` appends `license_path_list` to the front of the current license-path settings or creates the list of license-path settings, if it doesn't exist, initializing it to `license_path_list`. Duplicates are discarded.
- `override` overrides the existing list of license-path settings with the contents of `license_path_list`. If `license_path_list` is the null string, """, the specified list is deleted. For example:
  
  ```
lmutil lmpath -override agileesofd ""
  Deletes the value of AGILEESOFD_LICENSE_FILE from the registry.
  
lmutil lmpath -override vendor2 ""
  Deletes the value of VENDOR2_LICENSE_FILE from the registry.
  
lmutil lmpath -override all ""
  Deletes the value of LM_LICENSE_FILE from the registry.
  
  vendor` is a string naming a particular vendor daemon name. Affects the value of `vendor_LICENSE_FILE`. For example, use `agileesofd` to affect `AGILEESOFD_LICENSE_FILE`.
  
  `all` refers to all vendor daemons. Affects the value of only `LM_LICENSE_FILE`.
  
  `license_path_list` is the new path setting(s). On UNIX/Linux, this is a colon-separated list, and on Windows it is a semi-colon-separated list. If `license_path_list` is the null string, """, then the list is deleted for the specified vendor. Though you can enter specific license file names, you gain flexibility by entering only a path without a file name. This will include all *.lic files in the same location.

Note: Environment variable settings (set in your shell) always override these registry settings.
Checking the Status

Before you change license path settings, Agilent recommends that you display the current settings. To display the settings, enter the following commands:

`lmutil lmpath -status`

The following example status listing is from UNIX and is similar to PC and Linux listings:

```
lmpath - Copyright (C) 1989-2002 Globetrotter Software, Inc.
Known Vendors:

agileesofd: /ads2003a/licenses/license.lic:/ads2004A/licenses/license.lic

Other Vendors:

/usr/local/flexlm/licenses/license.lic
```

**Note** Where a path is set to a directory, each of the *.lic files are listed separately.
Setting Up Licenses

**Changing License Path Settings**

When adding or overriding path settings, lmpath sets the FLEXlm entry in the Windows registry on the PC, or changes the file $HOME/.flexlmrc on UNIX/Linux. Here are examples of how license settings may appear in each registry:

**UNIX/Linux**

AGILEESOFD_LICENSE_FILE = /ads2003a/licenses:/ads2004A/licenses

**Windows**

Registry location:

My Computer\HKEY_LOCAL_MACHINE\Software\Agilent\ADS2004A

Registry license path setting:

AGILEESOFD_LICENSE_FILE REG_SZ C:\ADS2004A\licenses

To change license path settings, enter the appropriate command in a Command Prompt on Windows, or a terminal window on UNIX/Linux. You can adapt the following examples which change path settings for AGILEESOFD_LICENSE_FILE:

- To add path settings on UNIX/Linux:
  
  lmutil lmpath -add agileesofd <new_lic_path1>:<new_lic_path2>

- To add path settings on Windows:
  
  lmutil lmpath -add agileesofd C:\<new_lic_path1>;C:\<new_lic_path2>

- To replace the current path settings on UNIX/Linux:
  
  lmutil lmpath -override agileesofd <new_lic_path>

- To replace the current path settings on Windows:
  
  lmutil lmpath -override agileesofd C:\<new_lic_path>
**Manually Setting the License Bundle Preference**

If you are using license bundles, you are aware that you must select a bundle prior to running ADS. Typically, bundles are selected by using the Agilent License Preference Tool. This tool is discussed in “Using the Agilent License Preference Tool” on page 4-2. However, system administrators and advanced users can manually configure environment variables when they need more bundle selection flexibility. Proper configuration using these environment variables control which licenses are used, and the systems using them.

The two environment variables that control bundle selection are:

- **AGILEESOFD_LICPREF_<hostname>** controls bundle selection specifically for the system identified by `<hostname>`.
- **AGILEESOFD_LICPREF** controls bundle selection for all systems on a network with access to the license server.

ADS looks for these variables in the following locations in the order given here:

- Shell environment
- `<project_directory>\hpeesof.cfg`
- `$HOME/hpeesof\config\hpeesof.cfg`
- `$HPEESOF_DIR\custom\config\hpeesof.cfg`
- `$HPEESOF_DIR\config\hpeesof.cfg`

ADS first looks for **AGILEESOFD_LICPREF_<hostname>** in each of these locations. If ADS cannot find a value for **AGILEESOFD_LICPREF_<hostname>**, then ADS looks for **AGILEESOFD_LICPREF**. If **AGILEESOFD_LICPREF** is not found, no bundle is selected.
Setting Up Licenses

Examples

- Joe Smith wants to use the pl_desenv bundle when he runs ADS on the system with the hostname alpha. To set this up, Joe should add

  AGILEESOFD_LICPREF_ALPHA=pl_desenv
  
  to the configuration file

  $HOME\hpessof\config\hpessof.cfg

  where $HOME is Joe's home directory

- A system administrator wants to configure a system to use the pl_ui bundle when anyone runs ADS on the system named beta, and to use the ltp_mmic bundle when ADS is run on other systems. To set this up, the administrator should add

  AGILEESOFD_LICPREF_BETA=pl_ui
  AGILEESOFD_LICPREF=ltp_mmic

  to the configuration file

  $HPESOF_DIR\custom\config\hpessof.cfg

Accessing Licenses through a Firewall

There may be situations where it is necessary to check out FLEXlm licenses through a firewall (or router). This may occur when a license server is behind a company firewall and other sites or companies need to check out licenses.

Assuming your license agreement allows you to serve licenses in this manner, you can enable license checkout through a firewall by configuring your firewall to allow TCP communication through the TCP ports used by the license manager daemon (lmgrd) and any vendor daemons you will run.

For example, assume you have a license server serving EEsof EDA licenses and your license file contains the following lines:

  SERVER myserver 00809AC7123F8
  VENDOR agileesofd c:\apps\flexlm\vendors\agileesofd
  VENDOR agileesof c:\apps\flexlm\vendors\agileesof
  DAEMON hpessofd c:\apps\flexlm\vendors\hpessofd

To set up your firewall to allow TCP access to the license server, you must specify a TCP port number for lmgrd on the SERVER line and for each vendor daemon on the VENDOR or DAEMON lines. For example:

SERVER myserver 00809AC7123F8
  TCP 2001
  TCP 2002
  TCP 2003
  
VENDOR agileesofd c:\apps\flexlm\vendors\agileesofd
  TCP 2001
  TCP 2002
  TCP 2003
  
VENDOR agileesof c:\apps\flexlm\vendors\agileesof
  TCP 2001
  TCP 2002
  TCP 2003
  
DAEMON hpessofd c:\apps\flexlm\vendors\hpessofd
  TCP 2001
  TCP 2002
  TCP 2003
  
For additional information, refer to the documentation for your firewall software.
Note After specifying TCP ports in your license file, you must stop and restart your license server.

Next, configure your firewall or router to allow TCP communication through the TCP ports you specified in your license file. In the example above this would be ports 27005, 1705, 1706, and 1707.

Finally, clients must set the AGILEESOFD_LICENSE_FILE environment variable to the port number assigned to the license server. Using the example above, the setting would be:

AGILEESOFD_LICENSE_FILE=27005@myserver

Once this has been done, clients outside of the firewall will be able to access licenses from your server.

Note Some clients may timeout before they can connect to a license server through a firewall set up on a Windows PC. The default timeout period is 0.1 second. If you need a longer timeout period, you can set the environment variable FLEXLM_TIMEOUT to a new value. Enter the value using microseconds. Agilent EEsof recommends trying one second. For example:

FLEXLM_TIMEOUT=1000000

Depending on your network, you may need to adjust the period so it is long enough to allow connections without slowing down simulations excessively.
Managing Multiple ADS Versions

This section discusses how to manage the licenses for multiple versions of ADS.

Backward Compatibility of Codewords

The following table lists previous ADS versions with details of their license management. The compatibility of codewords with the various ADS versions is discussed below.

<table>
<thead>
<tr>
<th>Release Name</th>
<th>License File Version</th>
<th>Daemon Name</th>
<th>FLEXlm Version</th>
<th>License Environment Variable</th>
<th>Default License File Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADS 1.5</td>
<td>1.5</td>
<td>hpeesofd</td>
<td>7.0g</td>
<td>LM_LICENSE_FILE</td>
<td>$HPEESOF_DIR/licenses/license.dat</td>
</tr>
<tr>
<td>ADS 2001</td>
<td>1.7</td>
<td>hpeesofd</td>
<td>7.0g</td>
<td>HPEESOFD_LICENSE_FILE</td>
<td>$HPEESOF_DIR/licenses/license.dat</td>
</tr>
<tr>
<td>ADS 2002</td>
<td>1.9</td>
<td>agileesof</td>
<td>7.2h CRO</td>
<td>AGILEESOF_LICENSE_FILE</td>
<td>$HPEESOF_DIR/licenses/</td>
</tr>
<tr>
<td>ADS 2002C</td>
<td>2.1</td>
<td>agileesof</td>
<td>7.2h CRO</td>
<td>AGILEESOF_LICENSE_FILE</td>
<td>$HPEESOF_DIR/licenses/</td>
</tr>
<tr>
<td>ADS 2003A</td>
<td>2.3</td>
<td>agileesofd</td>
<td>8.2a CRO</td>
<td>AGILEESOFD_LICENSE_FILE</td>
<td>$HPEESOF_DIR/licenses/</td>
</tr>
<tr>
<td>ADS 2003C</td>
<td>2.3</td>
<td>agileesofd</td>
<td>8.2a CRO</td>
<td>AGILEESOFD_LICENSE_FILE</td>
<td>$HPEESOF_DIR/licenses/</td>
</tr>
<tr>
<td>ADS 2004A</td>
<td>2.34</td>
<td>agileesofd</td>
<td>9.2a CRO</td>
<td>AGILEESOFD_LICENSE_FILE</td>
<td>$HPEESOF_DIR/licenses/</td>
</tr>
</tbody>
</table>


- ADS 2004A codewords will also work with ADS 2003C as long as the codeword is not a new codeword that has been introduced in ADS 2004A.
- ADS 2003C codewords will also work with ADS 2003A as long as the codeword is not a new codeword that has been introduced in ADS 2003C.
- ADS 2003A codewords will also work with ADS 2003C as long as support for the codeword has not been removed in ADS 2003C.
- ADS 2003C and 2003A codewords will not work with any previous versions of ADS and codewords from previous versions of ADS will not work with ADS 2003C or 2003A.
ADS 2002C and 2002 Codewords

- ADS 2002C codewords will also work with ADS 2002 as long as the codeword is not a new codeword that has been introduced in ADS 2002C.
- ADS 2002 codewords will also work with ADS 2002C as long as support for the codeword has not been removed in ADS 2002C.
- ADS 2002C and 2002 codewords will not work with any other versions of ADS and codewords from other versions of ADS will not work with ADS 2002C or 2002.

Combining ADS 2004A Codewords with Other Agilent EEsof EDA Codewords

For ADS 2004A, the vendor daemon agileesofd is used. This is the same vendor daemon that was used for ADS 2003A and 2003C. If you want to serve ADS 2004A licenses and earlier from the same server, you need to have the latest version of lmgrd, v9.2a, and two or three DAEMON lines in your license file, depending on how many versions you want to support. The ADS daemon names available are:

- agileesofd - for ADS 2003A, 2003C, and 2004A
- agileesof - for ADS 2002 and 2002C
- hpeesofd - up to and including ADS 2001

For example, the license file would include:

```
SERVER xyzmems 77a588a7 1700
VENDOR agileesofd c:\ads2004A\licenses\vendors\agileesofd
VENDOR agileesof c:\ads2002C\licenses\vendors\agileesof
DAEMON hpeesofd c:\ads2001\licenses\vendors\hpeesofd
```

You would then add the INCREMENT lines for the different products to the file.

Here is how you might build a license file that contains ADS 2004A, ADS 2003C, ADS 2003A, ADS 2002C, ADS 2001, and IC-CAP 2001 codewords. The name and extension of the license file are arbitrary (i.e., license.dat, license.lic or adslicenses.txt). By default, all ADS versions up to and including ADS 2001 look for a file named license.dat and all ADS versions from ADS 2002 to ADS 2004A look for a file named license.lic. You can use one of these names, or some other name you prefer. Whatever name you choose to use, make sure you set the environment variables to point to your license file.
Setting Up Licenses

Supported environment variables are:

- `AGILEESOFD_LICENSE_FILE` for ADS 2003A, 2003C, and 2004A
- `AGILEESOF_LICENSE_FILE` for ADS 2002 and 2002C
- `HPEESOFD_LICENSE_FILE` for ADS 2001
- `LM_LICENSE_FILE` for ADS 1.5 and earlier

For example, if the combined codeword file is named `adslicenses.txt`, then:

- ADS 2003A, 2003C, and 2004A will use:
  `AGILEESOFD_LICENSE_FILE=c:\licenses\adslicenses.txt`
- ADS 2002 and 2002C will use:
  `AGILEESOF_LICENSE_FILE=c:\licenses\adslicenses.txt`
- ADS 2001 will use:
  `HPEESOFD_LICENSE_FILE=c:\licenses\adslicenses.txt`
- ADS 1.5 and earlier will use:
  `LM_LICENSE_FILE=c:\licenses\adslicenses.txt`

Each version of ADS uses a certain search order to look for the environment variable:


- ADS 2002 and 2002C will first look for the environment variable named `AGILEESOF_LICENSE_FILE`. If `AGILEESOF_LICENSE_FILE` and `LM_LICENSE_FILE` are both defined, ADS 2002 and 2002C will use `AGILEESOF_LICENSE_FILE` and ignore `LM_LICENSE_FILE`. If `AGILEESOF_LICENSE_FILE` is not defined, then ADS 2002 and 2002C will default to `LM_LICENSE_FILE`. 
• ADS 2001 will first look for the environment variable named HPEESOFD_LICENSE_FILE. If HPEESOFD_LICENSE_FILE and LM_LICENSE_FILE are both defined, ADS 2001 will use HPEESOFD_LICENSE_FILE and ignore LM_LICENSE_FILE. If HPEESOFD_LICENSE_FILE is not defined, then ADS 2001 will default to LM_LICENSE_FILE.

• All previous ADS versions, up to and including ADS 1.5 will use LM_LICENSE_FILE.

Even though all versions of ADS will default to LM_LICENSE_FILE if that is the only environment variable that exists, it is recommended that you use the supported environment variables listed above.

Example of a Merged License File

SERVER solarone 80FB214D 1700
DAEMON hpeesofd c:\hfs\d1\local\licenses\hpeesofd
VENDOR agileesof c:\hfs\d1\local\licenses\agileesof
VENDOR agileesofd c:\hfs\d1\local\licenses\agileesofd
#
# ADS 2001 codewords
#
INCREMENT Adapt_comp hpeesofd 1.5 03-nov-2002 5 EC7A98E3FB4AC8771142 \ VENDOR_STRING=s=80FB214D
INCREMENT Ad_da_appkit hpeesofd 1.5 03-nov-2002 5 \ 1CCA189368AF358196C4 VENDOR_STRING=s=80FB214D
INCREMENT Ampsa_appkit hpeesofd 1.5 03-nov-2002 5 \ 0CBAB813D8101E34EB55 VENDOR_STRING=s=80FB214D
INCREMENT Analog_lib hpeesofd 1.5 03-nov-2002 5 9CEA88930822C5CF81AC \ VENDOR_STRING=s=80FB214D
INCREMENT Tx_appkit hpeesofd 1.5 03-nov-2002 5 6COA587386F9624DFF5 \ VENDOR_STRING=s=80FB214D
INCREMENT User_defined_model hpeesofd 1.5 03-nov-2002 5 \ 2CAAE8E326E3D9D888B VENDOR_STRING=s=80FB214D
INCREMENT Verilog_code_gen hpeesofd 1.5 03-nov-2002 5 \ FCAA489350CD03768D44 VENDOR_STRING=s=80FB214D
INCREMENT Vhdl_code_gen hpeesofd 1.5 03-nov-2002 5 \ FC4A58B306108640C5C VENDOR_STRING=s=80FB214D
INCREMENT Wcdma3g_des_lib hpeesofd 1.5 03-nov-2002 5 \ DC7AA8938909E4B61BF VENDOR STRING=s=80FB214D
INCREMENT Wcdma_des_lib hpeesofd 1.5 03-nov-2002 5 \ 7C0A38F308FA2C30CE3D VENDOR_STRING=s=80FB214D
INCREMENT Wlan_des_lib hpeesofd 1.5 03-nov-2002 5 \ 4C8A6893E259E6C86399 VENDOR STRING=s=80FB214D
#

Setting Up Licenses

# IC-CAP 2001 codewords
#
INCREMENT a_si_tft agileesof 6.0 29-oct-2001 1 D0A4535DE290 \  VENDOR_STRING=80FB214D
INCREMENT ac_driver agileesof 6.0 29-oct-2001 1 1A9EE36873A0 \  VENDOR_STRING=80FB214D
INCREMENT analysis agileesof 6.0 29-oct-2001 1 025C2B939B05 \  VENDOR_STRING=80FB214D
INCREMENT curtice_statz_fet agileesof 6.0 29-oct-2001 1 7D88F11FEE4B \  VENDOR_STRING=80FB214D
INCREMENT dc_driver agileesof 6.0 29-oct-2001 1 65C14D4C7948 \  VENDOR_STRING=80FB214D
INCREMENT gummel_poon_bjt agileesof 6.0 29-oct-2001 1 8FB9632C0555 \  VENDOR_STRING=80FB214D
INCREMENT ucb_bsim3 agileesof 6.0 29-oct-2001 1 BEDFA8C2810F \  VENDOR_STRING=80FB214D
INCREMENT ucb_bsim4 agileesof 6.0 29-oct-2001 1 D454A8AB830D \  VENDOR_STRING=80FB214D
INCREMENT vbic_bjt agileesof 6.0 29-oct-2001 1 3DE6FB45CD8C \  VENDOR_STRING=80FB214D
#
# ADS 2002C Codewords
#
INCREMENT ads_datadisplay agileesof 2.0 30-jun-2002 1 \  VENDOR_STRING=80FB214D HOSTID=80fb214d SIGN="008E 5A70 FEEF \  8BEF 9B3A 8A67 7375 0A51 0940 A264 6B00 C335 666B 03E2 D8E7 \  99A8 A0F9 9007 2AC4 E7F7 E101"
INCREMENT ads_datadisplay agileesof 2.0 30-jun-2002 1 \  VENDOR_STRING=80FB214D SIGN="01CB 4272 B241 5A67 A4C8 CADB \  A080 FFB2 7796 EC02 C3A9 FDBA BE47 C0C0 F027 5552 947F \  64CC 06BA 2201"
INCREMENT ads_drc agileesof 2.0 30-jun-2002 1 VENDOR_STRING=80FB214D \  HOSTID=80fb214d SIGN="073B 7694 1703 2703 8FFB 2614 067B 2A7E \  203F 4F0C C900 79FE F186 9B1E 2B10 3B3D D650 2204 18CF 00C9 \  3E3A"
INCREMENT trans_veriloggen agileesof 2.0 30-jun-2002 1 \  VENDOR_STRING=80FB214D HOSTID=80fb214d SIGN="014D A119 4C16 \  9B31 16B3 B5C6 EFB7 ED11 D0AE F389 EA00 5908 0EOA E0CD 5E4D \  9CE6 E6AD B27E 2CC4 8C1A 1D9D"
INCREMENT trans_veriloggen agileesof 2.0 30-jun-2002 1 \  VENDOR_STRING=80FB214D SIGN="0332 DEBA 839B B80F D2A0 0237 \  B2F7 0CE7 1CF3 CB15 2902 A5CB 47FA ECCB 9C6B BED2 E3D9 FBEB \  EF84 FAEE 7AC8"
INCREMENT trans_vhdlgen agileesof 2.0 30-jun-2002 1 \  VENDOR_STRING=80FB214D HOSTID=80fb214d SIGN="03D0 0C40 7E3C"
INC trans_vhdlgen agileesof 2.0 30-jun-2002 \\
VENDOR_STRING="028D FD25 D0E4 AD1A A0B7 5D61 \\
E2A8 7C2C 8135 D605 8200 F200 39D8 E5AF 4B9E D240 3682 4BAA \\
D9BD 6FB3 E580"
# ADS2003C codewords
#
INCREMENT ads_datadisplay agileesofd 2.3 07-jul-2003 \\
VENDOR_STRING="0047518D858 : O2GAZUD WSGSONJ 12WCKCE \\
LRXGY60 MYWFGP AKBFPNXY LSNO" HOSTID=0047518D858 SIGN="0246 \\
771A BBA2 A0D4 B29E 7371 6FF7 F3D9 161A 1204 EE00 2692 8AC0 \\
1AF7 FA9F 5B2C B017 23F7 91E8 BF97 B9AD"
INCREMENT ads_drc agileesofd 2.3 07-jul-2003 \\
VENDOR_STRING="0047518D858 : QEGHABE KEYWTHV 1HEINWD JFAVQ2A \\
UJXJ2EW KYARWERQ GY" HOSTID=0047518D858 SIGN="02EC 9EA3 EE62 \\
BDBC 9793 019D 0551 FD3E 20DD D0C1 D0A5 9F79 16A8 5E11 \\
1B81 E7CC 90F8 68A0 E116 8F0B"
INCREMENT ads_layout agileesofd 2.3 07-jul-2003 \\
VENDOR_STRING="0047518D858 : BUYPSCY ESZGY2G PWZPON XODFINY \\
IUUACJ EFQGAUY XLYSX" HOSTID=0047518D858 SIGN="032E E2FE \\
1D41 5386 F290 C7A6 207B 20C6 91B7 D255 0D00 7DB9 8FF8 531A \\
9947 9ABD 5D72 A8E6 9807 3037 F7EA"
# ADS2004A codewords
#
INCREMENT ads_datadisplay agileesofd 2.34 1-jun-2004 \\
VENDOR_STRING="0047518D858 : RQGFLS2 UIWQULP CBWADWE HJUJSCIE QWLYGOZ DWSFKGU \\
AUB2J20 VZBSGQP B" HOSTID=0047518D858 SIGN="00EC 53F6 475B FFAB 3868 \\
F3C2 09A7 DAF3 07E8 B254 A502 DF9F 82F5 F7A1 173A 80BC 0961 \\
8274 20EF EADO B65F"
INCREMENT ads_drc agileesofd 2.34 1-jun-2004 \\
VENDOR_STRING="0047518D858 : MWYMYOM HRFV121 HHFRGNY KUOC13E PBKWLSD CYS2UAJ \\
COMRFUI BHO" HOSTID=0047518D858 SIGN="02F3 067C 79A8 A37F 7117 DAD6 \\
5B31 2691 8189 69B9 4B00 ED66 F0E7 1567 73A8 634D 3288 673F \\
E8C1 DCOE 52F1"
INCREMENT ads_layout agileesofd 2.34 1-jun-2004 \\
VENDOR_STRING="0047518D858 : EJALGQG WNATA281 CWE1WYG XJENKUL KW02HUL XJLIMUEJ \\
DAQHFGO WSGS02Z" HOSTID=0047518D858 SIGN="0210 D212 518C 6163 5030 \\
53E 70C5 C26E FDE7 A0B2 7603 EEB4 2DA5 A886 EED4 9927 518B \\
277D 6F76 0E97 D49E"
Setting Up Licenses

VENDOR_STRING="TNHYM2D KSAQCOM DNIJWBS TAESDFP PGUA1UC KB2HXEY\
2B2HEKI" HOSTID=80fb214d SIGN="0188 0107 5389 19F7 7407 16BB 64DF\
55EC 550D ACB1 4A00 A2C8 799A B6AE 4040 8742 EAE0 F1BF 0D03\
FDF5 907B"
Using the Agilent License Information Tool

The Agilent License Information Tool is available to check your environment variable settings, display your license.lic file, and show your license and server status.

You can access this tool in three ways:

- From your Start menu, choose Programs > Advanced Design System 2004A > ADS Tools > License Information Tool.
- From the ADS Main window, choose Tools > License Information.
- If you are unable to run ADS, you may be having a problem with licenses. In this case, run the tool from the MS-DOS command prompt, as follows:
  
  Type `<installation folder>\bin\aglmtool` in the MS-DOS window and press Enter to display the following window.

For a current list of codewords available from Agilent EEsof with product descriptions and part numbers, see http://www.agilent.com/find/eesof-cwtables.
Setting Up Licenses
Chapter 4: Using Advanced Design System

To get you started using Advanced Design System on a PC running Windows, this section includes some basics along with useful tips for resolving problems that might occur after you have installed ADS.

Running Advanced Design System

Your FLEXlm license file must be properly configured and installed before you can run Advanced Design System. To set up your license file, follow the instructions in Chapter 3, Setting Up Licenses.

To run Advanced Design System, from the Start menu
Select Programs > Advanced Design System 2004A > Advanced Design System

The choices available are:

• **ADS Tools.** Displays a list of Advanced Design System tools, such as Digital Filter Designer, or LineCalc if they have been installed. Choose the tool you want to launch (provided you have licensed these features). Other tools include the License Information Tool, License Preference Tool, and the Ptolemy Modelbuilder Shell.

• **ADS Documentation.** Brings up your Web browser and the starting point for accessing Advanced Design System documentation. The documentation files are accessed from the location in which they are installed (if you chose to install documentation).

• **Advanced Design System.** Launches the Advanced Design System Main window, which enables the use of the various ADS Suites, features, and modules you have licensed. (If you have purchased the special RF Designer product, choose RF Designer, below, instead.)

  If you are not familiar with ADS, choose Help > Topics and Index > Quick Tour for help on getting started with Advanced Design System.

• **RF Designer.** Launches the ADS Main window for use with the RF Designer product, which is the lowest-cost ADS suite for RF design.

  Choose Help > Topics and Index > Quick Tour for help on getting started with Advanced Design System.
Using Advanced Design System

- **Uninstall ADS.** Launches the Uninstall Program. For information on using this utility, refer to the section, "Add and Remove ADS Files" on page 4-11.

**Using the Agilent License Preference Tool**

This section applies only to customers who have purchased license bundles.

If you have been using license packages in previous versions, you should be aware that license bundles replaced license packages beginning in ADS 2003A. License bundles are either Pay-Per-Use License (PL) bundles, or Limited Term Package (LTP) bundles. Typically, only PL or LTP bundles are available on a system - not both. A bundle looks like any other INCREMENT line in the license.lic file, but ADS recognizes the feature name as a collection, or bundle, of individual features. When ADS checks out the license bundle, it enables all the functionality associated with the individual features.

You must select a license bundle when starting ADS, and the License Preference Tool is available to help you make a selection. This sets the environment variable AGILEESOFD_LICPREF_<hostname>. Since you cannot check out more than one bundle, you have more control over which license bundles are used during an ADS session. You only need to run the License Preference Tool when you want to change the latest bundle selection. If you need more bundle selection flexibility to control which licenses are used on selected systems, see "Manually Setting the License Bundle Preference" on page 3-29.
Running the License Preference Tool

To run the License Preference Tool:

**UNIX/Linux**  There are two ways to start the License Preference Tool. In a terminal window:

- When starting ADS, enter `ads -p`. This runs the License Preference Tool, then runs ADS after you finish choosing bundles.
- To run the tool as a standalone utility, enter `$HPEESOF_DIR/bin/aglmpref`. This runs only the License Preference Tool.

**Windows**  There are two ways to start the License Preference Tool:

- From your Start menu, choose **Programs > Advanced Design System 2004A > ADS Tools > License Preference Tool**.

- Modify the Advanced Design System shortcut located on the Start menu. Right-click the **Advanced Design System** icon, and choose **Properties**. Edit the shortcut command on the Target line to include the `-p` option as shown here:

  ```
  C:\ADS2004A\bin\ads.exe -p
  ```

  This runs the License Preference Tool every time you start ADS.

The License Preference window appears similar to the figures below (Figure 4-1 and Figure 4-2). It enables you to view the available bundles and their features, and select bundles.

- To see the features available in a bundle, click the expansion icon next to the bundle name under **Available License Bundles**.

- To select a bundle, choose one of the bundles listed under **Available License Bundles**, then click **Add**. The selected bundle appears under **Selected License Bundles**.

- To accept your choice, click **OK**. This sets the environment variable `AGILEESOFD_LICPREF_=<hostname>` in `$HOME/hpeesof/config/hpeesof.cfg`.

---

**Note**  You must have write permissions to update this file.
Using Advanced Design System

Figure 4-1. License Preference Tool with ltp_analog Selected
How the License Preference Tool Works

- When you run the License Preference tool, it attempts to locate a license file using the following license definitions:
  - Environment variable AGILEESOFD_LICENSE_FILE
  - $HPEESOF_DIR/licenses/license.lic
  - aglmtool -c <port_address>@<hostname> (example port address is 27000)

- The License Preference Tool will show all possible bundles if a license file is not located.

- You can select a bundle according to specific rules controlled by the License Preference Tool. See “Bundle-Selection Rules” on page 4-6.

- ADS will start when a license bundle is selected, and ADS will not use a bundle unless it is selected using the License Preference Tool.
Using Advanced Design System

• If, while using ADS, the feature you attempt to use is not in the currently selected bundle, ADS will attempt to check out a valid floating or nodelocked license for the feature. This is known as license roll-over. If license roll-over fails to check out a license, a license error will appear even if another bundle with the requested feature is available.

You can then select another bundle that contains the feature. Save your work, and exit ADS. Then run the License Preference Tool to remove and add bundles, and restart ADS.

Bundle-Selection Rules

The License Preference Tool controls bundle selection using the following rules. A warning message appears for any incorrect selection.

If you are using Limited Term Package Bundles

• LTP bundles (except ltp_design_guides) contain a design environment codeword (ads_schematic) enabling ADS to run. You must select an LTP bundle containing a design environment codeword for a license preference to occur.

• Only one LTP bundle containing a design environment codeword can be selected at a time.

• The ltp_design_guides bundle (if available) can be selected with any other LTP bundle except ltp_iccap.

• Any PL bundles available on your system cannot be selected with an LTP bundle.

• If ADS and RF Design Environment are installed on the same UNIX/Linux system, RFDE bundles cannot be selected with LTP bundles.

If you are using Pay-Per-Use License Bundles

• The pl_desenv and pl_ui bundles contain a design environment codeword (ads_schematic) enabling ADS to run. You must select either pl_desenv or pl_ui for a license preference to take place. Other PL bundles appearing under pl_desenv are not selectable.

• Any LTP bundles available on your system cannot be selected with PL bundles.

• After selecting a PL bundle, you cannot select any additional bundles except for the following conditions:
• The pl_design_guides bundle (if available) can be selected with the PL bundle.

• If ADS and RF Design Environment are installed on the same UNIX/Linux system, only the pl_rfde bundle (if available) can be selected for RFDE.

Running ADS in Verbose Mode

ADS can be started in verbose (debug) mode to display more information about what is happening as ADS runs. This extra information can be very useful to debug a problem with ADS both at startup and in general operation. In verbose mode, ADS writes a log file to the root folder of your PC’s system disk. Typically, this is:

C:\ ads_daemon.log

The ads_daemon.log file can be sent by e-mail to Agilent EEsof EDA Technical Support for assistance.

To start ADS in verbose mode, do the following:

1. Open your Windows Explorer.
2. Navigate to the bin folder in the ADS installation folder. For example, C:\ ADS2004A\ bin
3. Double click on the ads_verbose.bat file.

This will start ADS. You will notice some extra message windows as ADS starts. Just click OK on each of the windows. Run ADS until the problem you are trying to debug occurs, then take a look at the ads_daemon.log file for errors.

If you can’t locate the trouble based on the contents of ads_daemon.log, please contact Agilent EEsof EDA Technical Support and e-mail the ads_daemon.log file to the support engineer working with you.

Using the ADS RF Designer Suite

You need to purchase a specific product license to access Advanced Design System’s RF Designer product, which is the lowest-cost ADS suite for RF design.

If you select RF Designer from the Startup menu and you don’t have this license installed, an error message will appear. If you want to purchase this product suite, contact your Agilent EEsof Sales Representative. If you have purchased this suite and are encountering the same problem, check your license file to make sure it is
Using Advanced Design System

properly set up. Follow instructions in Chapter 3, Setting Up Licenses, for details on licensing procedures.

Common Problems

Following are descriptions and possible solutions to common problems encountered when running Advanced Design System.

Some problems that occur regard the FLEXlm licensing setup for ADS. For details on using FLEXlm and lmtools, refer to the Macrovision website at:

http://www.macrovision.com/

Choose FLEXlm

ADS Does Not Start

It is possible to install programs or options for which you have not purchased licenses. Although the icons and features will appear in the software, you cannot access the applications without a license. Contact your Agilent EEsof EDA sales representative to obtain additional licenses.

If your Advanced Design System applications will not start:

- Make sure all of your licensing requirements are correctly set up, as explained in Chapter 3, Setting Up Licenses.

- Using a text editor open and review the install.log file in your installation folder to see if there are any apparent problems with the installation structure. (You can re-run Setup if necessary to re-install.)

- Try using the Agilent License Information Tool, which is available to check your environment variable settings, display your license.lic file, and show your license and server status. Refer to “Using the Agilent License Information Tool” on page 3-39 in Chapter 3, Setting Up Licenses.

If you cannot find the problem, run ADS in verbose (debug) mode and contact Technical Support to help pinpoint the problem.
ADS Does Not Run After Starting the License Server

If the following error message appears when you run ADS, license bundle selection may be required:

No such feature exists
Feature: ads_schematic
License path:
$HPEESOF_DIR/licenses/license.lic;$HPEESOF_DIR/licenses/licenses.dat
FLEXlm error: -5,357

This error can appear if your license.lic file contains license bundles and you have not run the Agilent License Preference Tool to select a license bundle. You must select a license bundle using the License Preference Tool, so ADS will know to use it. See “Using the Agilent License Preference Tool” on page 4-2.

Licenses Stop Working

The FLEXlm software must be able to read the ethernet address of your LAN card for your licenses to work properly. If you only have the TCP/IP protocol loaded on your PC, then FLEXlm will be unable to read the ethernet address and ADS will not work.

You must have the NWLink IPX/SPX protocol loaded in addition to the TCP/IP protocol.

To load the NWLink IPX/SPX protocol in Windows, do the following:

1. Choose Start > Settings > Control Panel.
2. In the Control Panel, double-click Network.
3. In the Network dialog box, select the Protocols tab.
4. Click the Add button.
5. Select NWLink IPX/SPX Compatible Transport from the list that appears and click OK.
6. The protocol will be loaded. Once it is complete, select OK until out of the Network dialog box.
7. To complete this procedure, reboot your PC.
Losing Licenses When Opening Help

On network configurations, such as a VPN (virtual private network), where ADS and its licenses are accessed through a web browser, opening an ADS help topic may break the connection to the network. To avoid this situation, set the following Internet Explorer option so ADS help opens in a new browser window:

1. In Internet Explorer, select **Tools > Internet Options**.
2. On the **Advanced** tab, in the **Browsing** section, disable (uncheck) **Reuse windows for launching shortcuts**.

How Do I...

Following are some frequently asked questions about installation of Advanced Design System programs on the PC.

Install Over Multiple Hard Disks

To install Advanced Design System applications over multiple hard disks, you need to re-run the Setup program as many times as necessary, installing selected installation components to a different destination each time.

Check the Nodelock ID of My Hardware Key

You need the nodelock ID of your hardware security key to get codewords from Agilent EEsof. It might also be useful to access this information when you place a call to Technical Support. There are two ways to check this:

- Before you install the hardware key on your PC, you can read the ID directly from the key.
- If you have installed the hardware key on your PC, and have also already installed your codewords and the FLEXlm software, enter the following command to check the nodelock ID:

  `lmutil lmhostid -flexid`
Add and Remove ADS Files

The InstallShield Wizard used to install Advanced Design System, can be used to modify or remove the ADS installation with these options:

- Modify your current ADS installation. This option enables you to add ADS files to your current installation.
- Remove all ADS files. This runs the Uninstaller, which deletes all installed ADS files, including registry entries. Use this option to remove the ADS program from the computer, or to prepare for re-installing ADS.

Notes  The Repair option that appears in the InstallShield Wizard's Welcome screen cannot be used with ADS. To repair your ADS installation, uninstall ADS using the instructions below. Then, re-install ADS using the instructions in Chapter 2, Installing Advanced Design System.

Agilent EEsof does not recommend using the Add/Remove Programs feature available on the Control Panel.

To add ADS components to an existing ADS installation (requires the ADS installation CD):

1. Close all Advanced Design System applications, and all Windows programs. Insert Advanced Design System installation CD labeled PC Setup (CD #1) into your CD-ROM drive. The Setup program will start automatically. If it doesn’t, choose Start > Run and enter D:\setup, where D: is the drive letter of your CD-ROM drive.

2. At the Welcome screen, select Modify (default), then choose Next.

3. At the Select System Components to Install screen, check the items to install, then choose Next.

4. At the Check Setup Information screen, confirm the Current Settings, then choose Next to begin installing the items. The Setup Status screen appears showing the installation progress.

5. When the Maintenance Complete screen appears, click Finish. If you chose to install Examples, this screen prompts you to insert CD #2. It is important to insert CD #2 after clicking Finish to install Examples.
Using Advanced Design System

6. Follow the prompts to select and install Examples. Click Finish when the installation is complete.

To uninstall ADS (does not require the ADS installation CD):

Notes  Be sure you have exited all applications before running the Uninstaller program. If you have not, it is possible you will get errors upon re-installing Advanced Design System. If these errors occur, reboot your computer and start the new installation again, or search for and end any lingering processes using the Task Manager and start the new installation again.

The uninstaller will not remove all files in the ADS folder. Files that have been added or modified since the previous ADS installation are not removed.

Be sure to retain the license.lic file to use if you re-install ADS.

1. Close all Advanced Design System applications, and all Windows programs.
2. Select Start > Programs > Advanced Design System 2004A > Uninstall ADS.
3. At the Welcome screen, choose Remove, then choose Next.
4. At the Confirm Uninstall dialog, click OK to proceed with the uninstallation. This immediately begins the uninstall process.
5. When the uninstall process is complete, choose Finish.
Change the Home Directory

To change your Advanced Design System home directory:

1. Select **Start > Run**.
   
   Type `regedit.exe`
   
   Click **OK**.

   **Caution** Use extreme care when editing the system registry. The computer may not function properly if the registry contains an error. You should backup the registry as a precaution. For more information, see the Registry Editor’s online Help.

2. Inside the registry editor, find the folder or window titled `HKEY_LOCAL_MACHINE on Local Machine`. Select **Software > Agilent > ADS > 2.5 > eenv**. You will see a registry entry called `HOME: C:\users\default`.
   
   (This is only true if you accepted the default startup folder during installation.)

3. Double-click this entry to open the string editor. Change it to reflect the path of your new home directory.

4. Change the Start directory of the Advanced Design System Main window’s file browser. Select the following:

   **Start > Settings > Taskbar > Start Menu Programs > Advanced**.

   This opens the Explorer window.

5. On the right side of the Explorer window, double-click the **Programs** icon.

6. Open the **Agilent Advanced Design System** icon. This displays the shortcuts to ADS executable.

7. Right-click the **Advanced Design System** icon and choose **Properties**.

8. Choose the **Shortcut** tab.

9. Change the field **Start in:** to reflect the path of your new home directory.
Agilent EEs of Technical Support

Agilent EEs of worldwide technical support is available Monday through Friday. The toll-free North America hotline is open 6:00 am to 5:00 pm PT. Throughout Europe, the localized Online Technical Support Centers are open during business hours, typically 8:30 am to 5:30 pm, local time; throughout Asia, the localized Customer Response Centers are open during business hours, typically 9:00 am to 6:00 pm, local time.

The e-mail addresses for the various regions are listed below. However, for both the regional e-mail addresses and local telephone numbers for more than 25 countries, please refer to the Agilent EEs of EDA Support Web site at

http://www.agilent.com/find/eesof-supportcontact

North America

Phone: 1 800 47 EEs of (473-3763) · Fax: 707-577-3511

e-mail: eesof_support@agilent.com

Europe: e-mail: eesof-europe_support@agilent.com

Japan: e-mail: eesof-japan_support@agilent.com

Korea: e-mail: eesof_korea@agilent.com

Asia: e-mail: eesof-asia_support@agilent.com
Chapter 5: Using Remote Simulation

Use the following information to enable and run remote Advanced Design System simulations using a PC client. Before starting the client process, you need to first set up a server (host) computer on which to run remote simulations.

In this chapter, the term server has the same meaning as host or remote computer, and the term client has the same meaning as local computer.

Note These procedures are not exactly the same for the Momentum Electromagnetic simulator. For Momentum remote simulation, refer to the Momentum manual in Simulation > Performing Remote Simulations.

Supported operating systems for use as a server (host):
- Windows 2000/XP
- UNIX systems
- Linux systems

Supported operating systems for use as a client (local computer):
- Windows 2000/XP

Note The LSF type of remote simulation is described in “Using LSF Remote Simulation” on page 5-10. Momentum does not support LSF remote simulation.
Setting up Your Simulation Server

Setting up a PC Server

To prepare your PC server (remote computer) perform the following steps:

1. Set the TCP communication port (socket address) in the PC server using one of the following methods. This provides the socket address to the hpremote script. If you are unfamiliar with setting socket addresses, see details about these methods in “Defining the EMX Daemon Remote Address” on page 5-9.
   - Edit the file $HPEESOF_DIR\config\hpeesof.cfg to set the socket address. Add the following line:
     
     EEDAEMON_SOCKET = xxxx

     where xxxx is the socket address, such as 1537.
   - Create a new hpeesof.cfg file in the folder C:\users\default\hpeesof\config. Add the line shown in the example above to it.
   - Do not assign a socket address to EEDAEMON_SOCKET. This allows the EMX daemon started by the hpremote script to use the default socket address of 1537. This method may be unreliable.

Note: Momentum requires an additional line in the hpeesof.cfg file, which is:

MOMENTUM_SIM_PATH=<remote_computer_name>

Refer to the Momentum documentation in Simulation > Performing Remote Simulations.
2. Start the Remote Simulation daemon with the command:

```
<HPEESOF_DIR>\bin\hpremote -d remote_sim.log
```

from an MS-DOS command prompt or from the Windows > Start > Run menu.

The -d option is for debugging purposes. It allows you to see the screen messages and save them in the remote_sim.log file for later verification. This file will be stored in $HPEESOF_DIR\bin.

---

**Note**  Do not terminate the MS-DOS window that pops up. Doing so will immediately terminate the daemon as well.

---

The server (remote) PC is now ready to run ADS simulations started on a client.
Using Remote Simulation

Setting up a UNIX or Linux Server

To prepare a UNIX or Linux server (remote computer), perform the following steps:

1. Log in to the remote computer.

2. Set the HPEESOF_DIR, PATH, and DISPLAY environment variables as you normally would when running Advanced Design System. See chapter 3, Setting Up Licenses, in the Installation on UNIX and Linux Systems manual for more information.

Note: DISPLAY has to be set if you are running ADS Ptolemy simulations with TkPlots in them. This allows the server to display the TkPlots on the client machine.

3. Set the TCP communication port (socket address) in the UNIX/Linux server using one of the following methods. This provides the socket address to the hpremote script. If you are unfamiliar with setting socket addresses, see details about these methods in “Defining the EMX Daemon Remote Address” on page 5-9.

   • Edit the file $HPEESOF_DIR/config/hpeesof.cfg to set the socket address. Add the following line:

     EEDAEMON_SOCKET = xxxx

     where xxxx is the socket address, such as 1537.

   • Edit the file /etc/services to set the socket address. Add the following line:

     eedaemon xxxx/tcp eedaemon

     where xxxx is the socket address, such as 1537.

   • Do not define a socket address, which allows the EMX daemon started by the hpremote script to use the default socket address of 1537. This method may be unreliable.
Note  Momentum requires an additional line in the hpeesof.cfg file, which is:
MOMENTUM_SIM_PATH=<remote_computer_name>
Refer to the Momentum manual in Simulation > Performing Remote Simulations.

4. Run the following script on the server:

```bash
hpremote -d /tmp/remote_sim.log
```

The -d option is for debugging purposes. It allows you to see the screen messages and save them in the remote_sim.log file for later verification. This file will be stored in the /tmp directory.

If you get an error message, see “Simulator Server Error” on page 5-7 or “Remote Simulation Error” on page 5-8.

To view the last part of the file, use the following command:

```bash
tail -f /tmp/remote_sim.log
```

5. You can verify that the hpremote daemon is running by checking the process:

```bash
ps -ef | grep hpeesofemx
```

**Note**  If another user has already launched the hpremote, then it must not be launched a second time. Subsequent remote users (you in this situation) can connect to this daemon as well. Make sure that the HPEESOF_DIR is set correctly for your simulation.
Setting up Your Client PC

A client machine should now be ready to run remote simulation. Do the following:

1. Start ADS.
2. Open or create a project.
3. Open or create a design.
4. From the Schematic window, choose Simulate > Simulation Setup.
5. In the dialog box that appears, type in the Host name (or Host’s IP address) in the Remote Simulation Host field.
6. Click on Simulate.

If Remote Simulation succeeds, the Status window will open and show the progression of the simulation.

Whether you need any other setup on the client PC depends on user preferences and if an OPEN_SIMULATOR error message occurs, see “Simulator Server Error” on page 5-7.

Using Multiple Servers

Multiple servers may be available on your system. Multiple servers are particularly useful when you intend to compare circuit simulation results as quickly as possible. Once multiple servers are set up, they can be accessed by typing in each name at a client computer, or by generating a listing on a client.

This listing appears when you click the down arrow next to the Remote Simulation Host field. Normally this is a list of one, defaulting to local and no others. However, you may write a list of hosts into the de_sim.cfg file on a client computer. Edit the de_sim.cfg file, located in your <ADS_home>\config directory, or c:\users\default\hpeesof\config (on PC) or <home>/hpeesof/config (on UNIX/Linux) directory, to include the following line:

SIMULATION_HOST_LIST=[hostname1] [hostname2]...

where each [hostname] must be separated by a single space. After making this edit, start ADS. From the Schematic window, choose Simulate > Simulation Setup. In the dialog box that appears, click the down arrow just to the right of the Remote Simulation Host field, highlight the host you want, and click the Simulate button.
Ending Remote Operation

Be sure to end the remote simulation process or task on the server once a remote simulation is finished. To end a remote simulation process:

1. On the local machine, exit Advanced Design System.
2. Terminate the hpeesofmx daemon that is running on the remote server. In Windows, go to the Task Manager and End the Process.
   In UNIX/Linux, to find the process, do the following:
   
   ```
   ps -ef | grep hpeesofemx
   and then kill the process as follows:
   kill -9 <process ID>
   ```
   The next time Advanced Design System is launched, it will default to simulate locally again.

Simulator Server Error

For either a PC or UNIX/Linux server, if you get the following error message when running Remote Simulation on the client:

```
(send_server_command) OPEN_SIMULATOR
server error
```

The EMX daemon may not be running on the Server. Check the Server:

- **PC**  Try using `hpremote -d <filename>` to start the daemon. If a failure re-occurs, you can check the log file `<filename>` saved in the `<ADS_home>/bin` directory to search for causes. On the client side, try typing in the Server’s IP address instead of its machine name in the Remote Simulation Host field of the box that pops up from Simulate > Simulation Setup.

- **UNIX/Linux**  Please be sure you edited and ran hpremote as described above. Remember that adding `EEDAEMON_SOCKET = 1537` to `hpeesof.cfg` is recommended before running hpremote.

- **PC and UNIX/Linux**  If you are sure hpeesofemx is running on the Server, it may be listening to a different socket address than the client seeks. Please verify that both client and Server computers are using the same TCP socket. It is recommended to use socket 1537, the default setting in ADS sought by clients.
Remote Simulation Error

For remote simulations using a UNIX/Linux server, if you receive an error message such as the following when running the hpremote script:

[1] + Stopped (tty output) -hpeesofemx-d remote.log &

this might be an indication that you are running from a shell that does not write messages to tty for a background process (tty gets the terminal name).

In this situation, use the following command in the hpremote script:

    hpeesofemx 2>&1 &

Note that this message also appears if you are using remote simulation with Momentum.

Remote Simulation Restrictions

Please note that the following restriction applies to remote simulation:

In the Momentum simulator, if a substrate computation is required, you must set the
<ADS_home>/momentum/lib/substrates directory and the files under it accessible for reading and writing. However, if you do not do this, the program will warn you.
Defining the EMX Daemon Remote Address

Remote simulation requires fixed socket addresses for the client(s) and server(s) computers. By default, the EMX daemon started by the hpremote script uses a socket address of 1537. However, relying on this default setting may or may not result in a successful remote simulation. Agilent Technologies recommends explicitly setting the socket address using one of the two options below:

**Important** Before setting a socket address, ensure that the number is not used in the `/etc/services` file nor the Windows Services. NIS (Network Information Services) is not supported for setting the EMX daemon socket address, and the address you use must not be used in NIS. To check NIS, use the following command where xxxx is the address:

```
ypcat services | grep xxxx
```

- Edit the `$HPEESOF_DIR/config/hpeesof.cfg` file for each client and server computer (PC or UNIX/Linux). Set the variable `EEDAEMON_SOCKET` by adding the following line:

  ```
  EEDAEMON_SOCKET = xxxx
  ```

  where `xxxx` is the socket address. The address can be 1537 or any other port number that is not used elsewhere (e.g., 5332). This socket address should be known and fixed across all associated client and host platforms. This might require root or super-user privileges to make the change. Ask your IT department to help you. If access to the IT department is slow, then create a new `hpeesof.cfg` file in your `$HOME/hpeesof/config` directory and add the line above to it. On a PC, create the new `hpeesof.cfg` file in `C:\users\default\hpeesof\config`.

- Edit the `/etc/services` file to set a socket address for EEDAEMON, such as

  ```
  eedaemon xxxx/tcp eedaemon
  ```

  where `xxxx` is a number such as 1537 or 5332. This method is useful in a multi-node environment. However, the `/etc/services` entry must be identical on every node. This approach has greater power, but requires root or super-user privileges to make the change. If access to a system administrator is slow, it may be easier to use the first option.
Using Remote Simulation

Using LSF Remote Simulation

This section describes how to use LSF to perform remote simulations on one or more remote simulation servers.

LSF (Load Sharing Facility) from Platform Computing is a facility that enables remote simulations with dynamic host selection. ADS 2004A integrates this facility to enable automatic remote host selection. Simple swept simulations can also be configured to utilize many available machines on the network. We call this feature parallel simulation. A simple sweep can be setup to run on a set of machines. LSF is used to select the best machine set. Individual sweep points are run on each machine and results combined into a single dataset on the local machine.

For a machine to participate as a “fastest host” or in a parallel simulation it must have both LSF and ADS 2004A installed. ADS also needs configuration changes to tell it what hosts are available. The feature is configured using the status server configuration file, hpeesofsess.cfg.

**Note**: Momentum Electromagnetic simulator does not support LSF remote simulation.

**LSF Requirements**

Supported Operating Systems for Use as a Server (Host):

- UNIX and Linux systems

Supported Operating Systems for Use as a Client (Local Computer):

- UNIX and Linux systems
- Windows 2000/XP

Supported LSF Software:

- LSF Standard Edition 4.1

Where to get LSF software:

- http://www.platform.com
Where to get LSF documentation:

http://www.platform.com/services/support/docs_home.asp
(requires password)

**Note**  LSF is used largely to determine suitable hosts for remote simulations. Many of the LSF features, like queuing and priorities, are unused in this release.

**Security**

Security is minimal. It is assumed that ADS and LSF are being used in a trusted environment. It is possible to accidentally use a different user’s /Linux account when simulating.

**Recommendations For Use**

- For UNIX/Linux, all users (who will be using ADS and LSF) must have a common, shared, $HOME directory, on all systems. Note that, not only must the same $HOME directory name be used on all systems, but the same directory must be used (typically, the same directory is mounted via NFS in the same location on all systems). In other words, if a file in a user’s $HOME directory is changed on one system, that change must be immediately reflected on every other system.

- Keep at least 100 MB of free disk space be available on each system for use by temporary simulation data (the more, the better).

- It's also strongly recommended that the disk space be on a local disk, as opposed to a network (NFS) disk. While network disks can be used, a significant simulation performance degradation can be seen if network disks are used. For best performance, the free disk space should be on a disk local to each system. This last statement is not in conflict with the requirement about $HOME directories. $HOME directories must be shared (and, therefore, be on a network drive), but temporary disk space should be on a local disk.
**Setting Up LSF and ADS**

Use the steps in the following sections to set up LSF and ADS.

1. Follow the LSF instructions to set up LSF at your site. Note that LSF servers must be running on every system that you want to use as a possible simulation host. LSF clients must also be running on every system on which ADS will be running. If LSF is not running, ADS will not be able to perform LSF-managed simulations.

2. Install ADS on every UNIX/Linux system that you want to use as a possible LSF remote simulation host, and install ADS into the same location on each host (or use a symlink at the same location to point to where you actually installed ADS). Alternatively, you can install ADS on one or more centralized servers, and have each UNIX/Linux system access ADS via NFS and symlinks. All systems must be able to access ADS using the same directory path. Use symlinks, if necessary, to meet this requirement.
Setting Up Scripts on Each LSF Remote Host

Scripts on each LSF remote simulation host must be configured (if ADS is installed on centralized servers, the following need only be done on each centralized server). Do the following for each remote simulation host:

1. First, determine a location for a temporary work directory. The default is /tmp. You can use /tmp or /var/tmp, or some other convenient directory. However, you must have enough disk space at this location to hold the data for each LSF-managed intermediate simulation. Be sure this is a local disk with at least 100 MB of free disk space. If you plan on performing large simulations, you'll need more disk space (the more, the better).

   While you do not have to use the same directory location on each LSF remote simulation host, using the same directory location (using symlinks if necessary) will greatly simplify configuration in the following steps.

2. Copy the file, $HPEESOF_DIR/sess/remote-sim-server, to
   $HPEESOF_DIR/custom/config/remote-sim-server (this destination file should not already exist). Example:

   ```
   cd $HPEESOF_DIR/sess
   cp remote-sim-server ..../custom/config/remote-sim-server
   ```
Using Remote Simulation

3. The newly copied file, $HPEESOF_DIR/custom/config/remote-sim-server, is a plain shell script. Edit this file and appropriately change the settings of the HPEESOF_DIR environment variable to match the correct HPEESOF_DIR value for the current host.

You must explicitly set the value for HPEESOF_DIR. You cannot rely upon the HPEESOF_DIR environment variable being properly set when this script is run due to the way in which ADS executes this script.

(If the HPEESOF_DIR variable is set, it will have the value of HPEESOF_DIR for the system on which the ADS graphical user interface is running. This may not be the correct value for HPEESOF_DIR on the remote simulation host, which is the host on which this script will be run.)

In this script, the default value for HPEESOF_DIR is /dev/null, which is clearly incorrect; this value was chosen to emphasize the fact that this script must be edited.

Note that this script allows different platforms (HP-UX, Solaris) to have different values for HPEESOF_DIR; make sure that you edit the correct occurrence of HPEESOF_DIR for the current platform.

You must also change the first line of the newly copied file from `#! /bin/sh` to `#! /usr/bin/sh`.

4. Make sure that the newly copied file has execute permission, for example:

   chmod 555 $HPEESOF_DIR/custom/config/remote-sim-server

**Editing ADS Configuration Files**

Next, on each LSF remote simulation host, one or more ADS configuration files must be edited (if ADS is installed on centralized servers, the following need only be done on each centralized server).

The configuration can be controlled on a system-wide or per-user basis. System-wide configurations affect all users on a system, but are simple to configure; only one file needs to be edited. Per-user configurations affect only a single user, and take precedence over any system-wide configurations; however, you’ll have to configure a file for each user. You’ll have to decide which is best for you. However, most users will be satisfied with a system-wide configuration.
1. To set a system-wide configuration, edit (create) the following file, and use steps 2 through 4 to set values in it:

$HPEESOF_DIR/custom/config/hpeesofsess.cfg

To set the configuration for a single user, edit (create) the following file, instead, and use steps 2 through 4 to set values in it:

$HOME/hpeesof/config/hpeesofsess.cfg

2. By default, LSF-controlled simulations will use all available LSF hosts for remote simulations, and every available host will be used for each simulation. For some sites, there may be issues with this:

• This assumes that ADS is installed/available on all LSF hosts. Some sites may have ADS installed/available on only a subset of LSF hosts.

To restrict simulations to a subset of LSF hosts, you must create a list of hosts to which LSF simulations may be submitted. See step 4 in this section, below, for instructions on how to set the LSF_HOSTFILE variable.

• Some sites may want to limit the number of hosts that a single simulation can use.

To limit the number of LSF hosts that a single LSF simulation will use, you must set the variable LSF_MAX_HOSTS. Example:

LSF_MAX_HOSTS = 17

This will impose a limit of 17 hosts when performing a single LSF simulation. Note that this limit applies to each user’s simulation. For example, if two users have a limit of 17, and both perform LSF-controlled simulations, the maximum number of systems used is 34, and not 17.

If you need to limit both the hosts and the number of hosts, both methods can be used simultaneously.
Using Remote Simulation

3. You must tell ADS the location of the remote-sim-server script (from the section on scripts, above) on the remote systems. You do this by setting the variable REMOTE_SIM_SERVER.

Example: If you installed ADS on the remote systems such that HPEESOF_DIR=/ADS2004A, you would add this line to the configuration file (without leading spaces):

   REMOTE_SIM_SERVER = /ADS2004A/custom/config/remote-sim-server

Do not use any environment variables when setting this variable; you must use the actual, absolute path name. In other words, do not use a line such as:

   REMOTE_SIM_SERVER = $HPEESOF_DIR/custom/config/remote-sim-server

This will not work, and will only cause problems.

4. If you did not choose /tmp as the temporary work directory (for all systems) in step 1 in the section on scripts, above, you will have to tell ADS about this. If all systems will be using /tmp, you can skip this step.

You can specify a different temporary work directory for each remote simulation host, or you can specify that the same directory path is to be used on each host. If you want to specify the same temporary work directory path for all remote simulation hosts, you do so by placing a line like the following into the hpeesofsess.cfg file:

   LSF_TMPDIR = /my/tmp/dir

Replace /my/tmp/dir with the desired name of the temporary work directory. By setting LSF_TMPDIR, you are specifying that this directory path is to be used as the default temporary work directory on all remote simulation hosts.

If all systems will be using the same path specified by LSF_TMPDIR, you can skip the rest of this step.

If you need to restrict LSF simulations to a subset of LSF hosts, or if you want to specify different temporary work directory names for some or all of the remote simulation hosts, you must create a file that lists each remote simulation host and the corresponding temporary work directory (if different from the default). However, if you create this file, note that only the systems listed in this file will be used by LSF-controlled simulations.

This file is specified using the variable LSF_HOSTFILE. Example:

   LSF_HOSTFILE = /my/path/to/some/hostfile
This file can have any name, and it consists of text lines of the form:

```
<system_name> [ <temporary_directory_name> ]
```

Where:

- `<system_name>` is the name of a remote simulation host, including domain name. In other words, the name must be a fully qualified domain name (FQDN).

Note that all systems must be within your local domain (the same domain as the system from which ADS is run). You cannot specify systems that are not within your local domain. If you do, ADS may not work properly.

- `<temporary_directory_name>` is the optional name of the temporary directory to use on the remote simulation host. If this directory is not specified, the value of LSF_TMPDIR will be used, or, if LSF_TMPDIR is not set, `/tmp` will be used.

Example (assuming that your domain name is “qptzx.com”):

```
system1.qptzx.com /tmp
system2.qptzx.com /disk2/tmp
system3.qptzx.com
system4.qptzx.com /some/disk/foo
```

Note that `system3` does not have an explicit temporary directory; since one is not specified, the value of LSF_TMPDIR will be used or, if LSF_TMPDIR is not set, `/tmp` will be used. As only four systems are specified here, the maximum number of LSF-controlled simulations is four (even though there may be more LSF-managed hosts available).

Only the systems listed in this file will be used for LSF-controlled simulations, and so you must ensure that all systems that you want to use are listed here. Also, make sure that all temporary working directories are writable.
Using Remote Simulation

The following is an example of an lsf_hosts.cfg file:

#this is my LSF control file
#Date: 8/12/2002

# sirpoh will use /tmp
server.yourcompany.com /tmp

# no directory specification => jane will use * => /tmp/parallel.
jane.server.yourcompany.com

# joe will use /users/poh/tmp
joe.server.yourcompany.com /users/poh/tmp

# generic temporary directory # specification on a host line
* /tmp/parallel
Configuring Each ADS User

Each user running ADS needs to be configured. Basically, each user needs to use a different port number for LSF-controlled simulations, and this port number must be manually chosen, and manually checked to insure that the port number is not being used by any other user.

Note that the port number must be unique. If two or more users share the same port number, it’s quite likely that one user will end up performing LSF simulations as another user.

Once the port number is chosen, the rest of the procedure is simple. For each user, from a shell prompt, do the following:

```
mkdir -p $HOME/hpeesof/config echo "EEDAEMON_SOCKET=12345" >> $HOME/hpeesof/config/hpeesof.cfg
```

Replace “12345” with the chosen port number.

Checking the User $PATH

Before running ADS, the path to the LSF programs must be in each user’s $PATH. To verify that LSF is in $PATH, you can run the lshosts command as a test, for example:

```
lshosts
```

Here, lshosts should print a list of available LSF-managed hosts.
Appendix A: Installing Connection Manager Server

Connection Manager server can be installed and used with RF Design Environment (RFDE) and Advanced Design System (ADS) EDA software. Follow these instructions to install the Connection Manager server and configure the server IO.

Before You Begin

To communicate with instruments, you must install the Connection Manager server. Before installing the server, ensure that your PC workstation and your EDA software licensing meet the following requirements.

System Requirements

The server must be installed on a Windows PC connected to the same network as the EDA software network server or local installation.

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>Pentium III 450 MHz or higher</td>
</tr>
<tr>
<td>RAM</td>
<td>256 MB</td>
</tr>
<tr>
<td>Hard Disk Space</td>
<td>500 MB on system drive</td>
</tr>
<tr>
<td>Operating System</td>
<td>Windows 2000 Professional (Service Pack 2)</td>
</tr>
<tr>
<td></td>
<td>Windows XP Professional (Service Pack 1)</td>
</tr>
<tr>
<td>Network Configuration</td>
<td>TCP/IP</td>
</tr>
<tr>
<td>Supported Media Type</td>
<td>CD-ROM required for program installation.</td>
</tr>
</tbody>
</table>

Licensing Requirements

Although the Connection Manager client requires a license, Connection Manager server does not require a license regardless of where it is installed.
Installing Connection Manager Server

**Note** The Connection Manager client is installed during the main software installation. The link_connect_mgr license is required to run the client from a schematic page. Connection Manager client and server installations are not related to the client-server installation of the EDA software.

**EDA Software Version Requirements**

The Connection Manager client and server software must be from the same release.

If you used an older release of Connection Manager, install latest version of Connection Manager server when you install latest version of the EDA software.

**Installation Package Overview**

The Connection Manager server installation installs all the software necessary to enable the EDA software-supplied measurements. This includes:

- Run-time versions of the Agilent Test and Measurement Programmer’s Toolkit. This includes the most recent version of VISACom available when the Toolkit was released. The latest version is available from the Agilent Developer Network at:
  
  http://adn.tm.agilent.com/

- The Agilent IO Libraries
- ADS Measurement Libraries
- Plug&Play and IVI-COM drivers
- Run-time versions of Microsoft .NET, suitable for running .NET application
- The Connection Manager server

**Installation Types**

**Complete**

The Complete installation installs all program features in the default installation directory C:\ Program Files\ Agilent\ Connection Manager Server.
Custom

The Custom installation lets you define the installation directory and choose the optional program features, such as the ADS Measurement Library, Connection Manager documentation, Ptolemy VEE Link Server, and VEE Service Control Panel Application.

Installing the Server

1. Ensure that your PC workstation meets the system requirements.
2. Insert the Connection Manager Server 2004A Installation Disc into the workstation CD-ROM drive.
3. When the installation wizard prompts you, choose the type of installation.
4. Follow the command prompts to complete the installation.

This completes the installation process. To connect instruments to the server workstation, complete the steps in “Configuring the Server IO on the PC” on page A-3.

Configuring the Server IO on the PC

Prior to using Connection Manager for the first time, you must configure the IO on the server workstation.

This section provides instructions for automatically configuring common LAN and GPIB interfaces, and for manually configuring other interfaces such as LAN/GPIB gateways.

“To Configure Common LAN or GPIB Interfaces” on page A-3 provides simplified instructions to configure a common LAN or GPIB interface.

To manually configure an available interface (for example, the Agilent E5810A LAN/GPIB gateway), see “To Manually Configure Other Interfaces” on page A-6.

To Configure Common LAN or GPIB Interfaces

Follow the instructions in this section to auto-configure the IO and connect instruments to the server using a LAN or GPIB interface.

1. In the server’s Windows system tray, select IO > Run IO Config.
Installing Connection Manager Server

This opens the IO Config dialog. The Available Interface Types group box lists the IO types supported by the Agilent IO Libraries. List entries with an asterisk (*) can be automatically configured in step 2.

2. To automatically configure common LAN and GPIB interfaces in the IO Config dialog, select Auto Config.

Auto-configured interfaces appear in the Configured Interfaces group box, as shown.

If you encounter a problem

For GPIB interfaces, ensure that the GPIB interface is installed/connected to the server.

For LAN interfaces, the IO auto-configuration routine creates a TCPIP network tunnel and displays TCPIP 1an in the Configured Interfaces group box. The routine creates only one TCPIP interface regardless of the number of LAN cards installed on the server workstation.
Follow the steps in “To Connect Instruments to the Server through the LAN” on page A-5 to complete the LAN interface configuration.

To Connect Instruments to the Server through the LAN

Unlike GPIB interfaces where instruments communicate directly with the server via an exclusive bus, the Agilent IO libraries do not dynamically discover instruments connected to the server via LAN. You must manually add LAN devices to the server IO.

To add LAN devices, complete the following steps.

1. In the IO Config dialog, highlight TCPIP0 in the Configured Interface group box and click Edit.
2. In the LAN Client dialog, click Edit VISA Config.
3. In the TCPIP devices dialog, click Add device.
4. In the Add a TCPIP device dialog Machine Name/IP field, enter the IP address of the instrument you would like to connect to the server and click OK.
5. In the TCPIP devices dialog, click OK.
6. In the LAN Client dialog, click OK.
7. In the IO Config dialog, click OK.

If you encounter a problem

Ensure the following conditions are met:

- The server is connected to the LAN.
- The instrument is connected to the LAN.
- The instrument line power is switched on.
- The LAN is operational.

To Manually Configure Other Interfaces

This section explains how to manually configure an IO that cannot be auto-configured by the Agilent IO Library. This section explains how to configure a LAN/GPIB gateway, such as the Agilent E5810A. Follow the screen prompts to manually configure your installed interface.

Follow the instructions in this section to manually configure a LAN/GPIB gateway.
1. In the Windows system tray, select **IO > Run IO Config**.

2. In the **Available Interface Types** group box, highlight **VISA LAN Client Interface (E5810A)** and click **Configure**.

3. In the **VISA LAN Client Interface (LAN to GPIB)** dialog Local Settings group box, use the scroll box to choose a VISA Interface Name.

4. In the **Remote Settings** group box, enter the hostname or IP address of the LAN/GPIB gateway.

5. In the **Remote Settings** group box, enter the SICL interface name assigned to the LAN/GPIB gateway (or other network interface device) and click **OK**.

During the process of configuring the LAN/GPIB gateway, you must assign a SICL interface name to the device. You must enter the same SICL interface name in the Remote SICL Interface Name data entry field.

6. In the **VISA LAN Client Interface (LAN to GPIB)** dialog, click **OK**.

To exit the IO configuration without connecting instruments to the server, in the IO Config dialog click **OK**. To connect instruments to the server, follow the steps in “To Connect Instruments to the Server through the LAN” on page A-5.
If you encounter a problem
Ensure the following conditions are met:
  • The server is connected to the LAN.
  • The LAN is operational.
Index

A
Advanced Design System, on Start menu, 4-1
agileesofd, 3-11
AGILEESOFD_LICENSE_FILE, 3-7
AGILEESOFD_LICPREF, 3-29
AGILEESOFD_LICPREF_hostname, 3-29, 4-2

B
browser, 1-2
bundles, license
  selecting, 3-29, 4-2
  selection rules, 4-6

C
client installation, 2-11
codewords
  backward compatibility, 3-32
  installing, 3-3
  requesting, 1-4, 3-3
compiler (for model development), 1-3
Connection Manager
description, 2-23
server
  installation, A-1
  installation procedure, A-3
  IO configuration procedure, A-3
  LAN configuration, A-5
  overview, install package, A-2
  requirements, licensing, A-1
requirements, system, A-1
requirements, version, A-2
network configuration

D
debug mode, 4-7
disk drive, 1-2
displays, 1-2
documentation, on Start menu, 4-1

E
EMX daemon, 5-9
environment variables
  AGILEESOFD_LICENSE_FILE, 3-7
  AGILEESOFD_LICPREF, 3-29

F
file server PC
  installing from, 2-15
  setting up, 2-14
firewall
  accessing license daemon, 3-30
  accessing vendor daemon, 3-11
FLEXid driver, installing, 3-4
FLEXid hardware key installation, 3-3
FLEXid hardware key license method, 3-3
FLEXlm
  accessing UNIX server, 3-16
  options file, 3-18
  setting up, 3-1
  setting vendor daemon path, 3-11
  starting, 3-12
  starting automatically, 3-14
  starting manually, 3-13
  TIMEOUT and TIMEOUTALL options, 3-20
FLEXLM_TIMEOUT, 3-12, 3-31
floating license
  example, 3-6
  installing, 3-9

G
GPIB configuration, A-3
GPIB interface
  See also LAN interface
  configuring, A-6

H
hard disk, 1-2
hard disk space
  checking, 1-6
hardware key installation, 3-3
HDL simulator (for HDL cosimulation), 1-3
Home directory
changing, 4-13
setting, 2-16
HOME environment variable, 2-17

I
installation
  complete, components, 2-8
  completing requirements, 4-1
  Connection Manager server, A-1
  custom, components, 2-9
detailed, 2-3
FLEXid driver, 3-4
licenses (See licenses)
modifying ADS installation, 4-11
on multiple hard disks, 4-10
overview, 2-1
procedure, 2-3
quick, 2-2
requirements, 1-2
server and clients, 2-10
silent, 2-18
typical, components, 2-8
uninstalling ADS, 4-12
installation procedure, Connection
Manager server, A-3
InstallShield
  adding ADS components, 4-11
  modify and remove files, 4-11
  removing ADS, 4-12
  silent installation, 2-18
  uninstalling ADS, 4-12
instrument interfaces, 1-3
instruments, connecting through LAN, A-5
IO
  interfaces, auto-configuring, A-4
  interfaces, polling available, A-7
IO configuration, A-3
IO configuration procedure, Connection
Manager server, A-3

L
LAN configuration, A-3
LAN Ethernet ID license method, 3-3, 3-5
LAN interface
  See also GPIB interface
  configuring, A-3, A-7
  connecting instruments, A-5
troubleshooting, A-4, A-6, A-7
License Information Tool, 3-39
license manager setup, 3-1
License Preference Tool, 4-2
license server, 3-16
PC client setup, 3-17
redundant servers, 3-25
UNIX server setup, 3-16
license.lic file, 3-9
  updating, 3-21
licenses
  accessing UNIX server, 3-16
  bundle selection, 3-29, 4-2
  bundles, 4-2
  changing path settings, 3-25
  installation overview, 3-2
  license.lic file, 3-9
  multiple ADS licenses, 3-33
  multiple vendor licenses, 3-21
  packages, 4-2
  setting location, 3-7
type, 3-6
  verifying environment variable path, 3-15
licensing methods, 3-3
LM_LICENSE_FILE (See
  AGILEESOFD_LICENSE_FILE)
lmtools, using to setup FLEXlm, 3-1
Load Sharing Facility (See LSF)
LSF
  configuration files, 5-14
description
documentation, 5-11
preliminary setup, 5-12
recommendations, 5-11
requirements, 5-10
security, 5-11
setting path to LSF programs, 5-19
using scripts, 5-13

M
memory, 1-2
  checking, 1-5
multiple ADS versions, running, 2-16

N
network client
  installing, 2-11
network installation, 2-10
network server
installing, 2-10
node lock ID, checking, 4-10
node-locked license
example, 3-6
installing, 3-7

O
operating system
  checking version, 1-3
  requirements, 1-2
  requirements, Connection Manager server, A-1
overview, install package, Connection Manager server, A-2

P
printers and plotters, 1-2

R
RAM, 1-2
RAM requirements, Connection Manager server, A-1
readme file, 2-1
redundant license servers, 3-25
release notes, 2-1
remote simulation, 5-1
  EMX daemon, 5-9
  Load Sharing Facility (See LSF)
  multiple servers, 5-6
  restrictions, 5-8
  server error, 5-7
  setting up PC client, 5-6
  setting up PC server, 5-2
  setting up UNIX server, 5-4
  simulation error, 5-8
  starting, 5-6
  stopping, 5-7
requirements, 1-2
requirements, licensing, Connection Manager server, A-1
requirements, system, Connection Manager server, A-1
requirements, version, Connection Manager server, A-1
response files (See silent installation)
revisions to ADS, 1-1
RF Designer
  on Start menu, 4-1
  using, 4-7

S
security codeword file, 3-9
security devices, 1-2
server installation, 2-10
silent installation, 2-18
  creating response file, 2-22
  response file samples, 2-18
  running, 2-20
  troubleshooting, 2-21
  using for uninstalling, 2-21
simulation, remote (See remote simulation)
Start menu, 4-1
support, 4-14
system requirements, 1-2

T
technical support, 4-14
tools, on Start menu, 4-1
troubleshooting, 4-8
  ADS does not start, 4-8
  LAN, A-4, A-6, A-7
  license issues, 4-9
uninstaller, on Start menu, 4-2
uninstalling ADS, 4-12

V
vendor daemon
  accessing through firewall, 3-11, 3-30
  agileesofd, 3-11
  multiple vendor licenses, 3-21
  setting path, 3-11
  verbose (debug) mode, 4-7
  versions
    running multiple, 2-16
    virtual memory, 1-2
    checking, 1-5

W
web browser, 1-2