Schematic Capture and Layout

September 2004
Notice

The information contained in this document is subject to change without notice.

Agilent Technologies makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Agilent Technologies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Warranty

A copy of the specific warranty terms that apply to this software product is available upon request from your Agilent Technologies representative.

Restricted Rights Legend

Use, duplication or disclosure by the U. S. Government is subject to restrictions as set forth in subparagraph (c) (1) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 for DoD agencies, and subparagraphs (c) (1) and (c) (2) of the Commercial Computer Software Restricted Rights clause at FAR 52.227-19 for other agencies.

Agilent Technologies
395 Page Mill Road
Palo Alto, CA 94304 U.S.A.

Copyright © 1998-2004, Agilent Technologies. All Rights Reserved.

Acknowledgments

Mentor Graphics is a trademark of Mentor Graphics Corporation in the U.S. and other countries.

Microsoft®, Windows®, MS Windows®, Windows NT®, and MS-DOS® are U.S. registered trademarks of Microsoft Corporation.

Pentium® is a U.S. registered trademark of Intel Corporation.

PostScript® and Acrobat® are trademarks of Adobe Systems Incorporated.

UNIX® is a registered trademark of the Open Group.

Java™ is a U.S. trademark of Sun Microsystems, Inc.
Contents

1 Program Basics
   Starting the Program .......................................................... 1-1
   Selecting a Design Type ...................................................... 1-2
   Using the Greeting Dialog .................................................. 1-3
   The Design Environment .................................................... 1-3
      Main Window ................................................................. 1-3
      Design Windows .......................................................... 1-5
      Layout Basics ............................................................. 1-12
      Status Message Window ................................................. 1-16
   Using the Data Display Window ......................................... 1-19
   Reading and Writing Data Files ........................................... 1-20
   Naming Conventions .......................................................... 1-20
   Limitations .......................................................................... 1-23
   Global Node Naming Conventions ...................................... 1-24
   Creating an Electronic Notebook ........................................ 1-24
      Deleting Pages from the Notebook ................................. 1-26
      Adding Descriptions to the Notebook ............................. 1-26
      Adding Pages to an Existing Notebook ......................... 1-27
      Reorganizing Pages in the Notebook ............................. 1-28
      Adding External Images to the Notebook ....................... 1-28
      Changing Image Capture Settings in the Notebook ........... 1-29
      Saving Changes to the Notebook .................................... 1-30
      Viewing an Existing Notebook ...................................... 1-30
      Updating an Existing Notebook .................................... 1-31
      Zipping the Files of a Notebook ..................................... 1-31
   Verifying License Status .................................................... 1-32
   Setting Preferences for Miscellaneous Options ................... 1-33
   Exiting the Program .......................................................... 1-34

2 Managing Projects and Designs
   Working in Projects .......................................................... 2-1
      Creating a Project .......................................................... 2-1
      Opening a Project .......................................................... 2-4
      Copying a Project .......................................................... 2-6
      Deleting a Project .......................................................... 2-7
      Using an Example Project .............................................. 2-8
   Creating a Hierarchical Project .......................................... 2-11
   Archiving a Project .......................................................... 2-13
   Unarchiving a Project ....................................................... 2-14
   Importing and Exporting .................................................... 2-14
Importing a Design ................................................................. 2-15
Exporting a Design ............................................................... 2-16
Managing Design Files .......................................................... 2-18
Creating a Design File ........................................................... 2-18
Using a Template ................................................................. 2-20
Saving a Design File ............................................................. 2-20
Saving All Designs in Memory ............................................... 2-21
Opening an Existing Design ................................................ 2-22
Copying a Design ................................................................. 2-24
Deleting a Design ................................................................. 2-25
Clearing a Design from Memory ............................................. 2-25
Clearing All Designs from Memory ........................................ 2-26

3 Creating Designs
Defining Units for a Design ................................................... 3-2
Placing Components ............................................................. 3-3
  Browsing for Components .................................................. 3-3
  Searching for Components .................................................. 3-6
Customizing the Component Library Display ......................... 3-8
  Using the Component Palette .............................................. 3-14
  Using Component History ................................................. 3-15
  Using Hot Keys to Place Components ................................ 3-16
  Placing Components at Specific Coordinates ..................... 3-18
Rotating Components .......................................................... 3-19
Defining Parameters ............................................................ 3-20
  Units/Scale Factors ........................................................... 3-21
Measuring Distance and Angle .............................................. 3-26
Connecting Components ...................................................... 3-26
  Connecting Components Directly ....................................... 3-27
  Connecting Components with Wires ................................. 3-27
  Connecting Components Without Wires ............................ 3-28
Creating Buses ....................................................................... 3-29
  Creating Bundles .............................................................. 3-36
  Bus Pins and Iterated Ports ................................................. 3-37
  Buses in ADS Ptolemy ........................................................ 3-38
  Checking Connectivity ........................................................ 3-39
Adding Ports to a Design ....................................................... 3-49
Using Special Components .................................................. 3-50
  Using Substrates .............................................................. 3-50
  Using Nonlinear Models .................................................... 3-51
  Components that Allow File-Based Parameters .................. 3-52
Using Macros to Automate Tasks .......................................... 3-53
Viewing and Entering AEL Commands ................................................................. 3-54
Creating a Netlist .................................................................................................. 3-55
Generating Reports ............................................................................................ 3-56

4 Creating Hierarchical Designs

Creating a Subnetwork from an Existing Design .............................................. 4-1
Creating a Parametric Subnetwork ................................................................. 4-3
  Creating the Subnetwork .............................................................................. 4-5
  Defining Design Characteristics ................................................................. 4-6
  Defining Parameters ..................................................................................... 4-9
  Viewing the Network Represented by a Symbol ............................................. 4-12
Editing a Hierarchical Design .......................................................................... 4-13
  Edit in Place Hints/Tips .............................................................................. 4-14

5 Viewing Designs

Zooming In and Out ........................................................................................... 5-1
Repositioning a Design to Fit the Window ........................................................ 5-2
Moving the Center Point of a Window .............................................................. 5-2
Redrawing the View in a Window ...................................................................... 5-3
Saving and Restoring Views .......................................................................... 5-3
Viewing Design Information ........................................................................... 5-4
  Viewing Detailed Design Information ......................................................... 5-4
  Viewing Detailed Instance Information ....................................................... 5-4
  Viewing Hierarchical Design Information .................................................... 5-5
Checking Connectivity Information in Schematic ........................................ 5-6
  Cross-Probing ............................................................................................. 5-7

6 Editing Designs

Using the Undo Command .................................................................................. 6-1
Deleting Items ..................................................................................................... 6-1
Activating, Deactivating, and Shorting Components ......................................... 6-1
  Activating and Deactivating Components ...................................................... 6-1
  Deactivating and Shorting Components ........................................................... 6-2
Editing Component Parameters ....................................................................... 6-3
  Editing Component Parameters On-screen .................................................. 6-4
  Editing Component Parameters Through the Dialog Box ................................ 6-5
Using the Equation Editor .............................................................................. 6-8
Breaking Wire Connections Between Components .......................................... 6-10
Swapping Components ..................................................................................... 6-10
Searching and Replacing References ............................................................ 6-11
Moving Component Text .................................................................................. 6-12
Changing Component Text Attributes ............................................................ 6-13
Editing Symbol Pins ........................................................................................... 6-14
Selecting and Deselecting Items ................................................................. 6-14
  Selecting/Deselecting All Items in the Drawing Area ............................. 6-14
  Selecting/Deselecting Items by Name ................................................... 6-15
  Selecting/Deselecting With a Selection Window ................................. 6-16
  Using the Vertices Filter ..................................................................... 6-17
Copying and Pasting Items........................................................................ 6-18
Moving Items .......................................................................................... 6-22
Rotating Items .......................................................................................... 6-25
  Rotating Items Around a Specified Point ............................................ 6-26
  Rotating Items in Degrees, Relative to 0,0 .......................................... 6-26
  Rotating Objects Across a Specified X- or Y-axis ............................. 6-27
  Rotating Objects Using an Absolute Angle ....................................... 6-28
Editing Shapes ......................................................................................... 6-29
  Converting Circles/Arcs to Simple Polygons ................................. 6-29
  Editing Polygons and Polylines.......................................................... 6-31
  Adding a New Vertex ......................................................................... 6-32
  Moving a Vertex ................................................................................ 6-32
  Deleting a Vertex ................................................................................ 6-33
  Converting a Vertex to an Arc ............................................................ 6-33
  Converting a Vertex to a Mitered Edge ............................................. 6-34
  Stretching a Wire or an Edge of a Shape ......................................... 6-35
  Scaling an Object Using a Scaling Factor ........................................... 6-36
  Scaling an Object Relative to the Design Window Units ................... 6-36
Editing Existing Text and Text Attributes .................................................. 6-37
Editing Wire/Pin Label Attributes ............................................................ 6-39
Forcing Objects Back onto the Grid .......................................................... 6-39

7  Annotating Designs
  Adding a Drawing Sheet ....................................................................... 7-1
  Adding Text ......................................................................................... 7-2
    Using Variables to Display Design and System Information .......... 7-3
  Drawing Shapes .................................................................................. 7-4
    Drawing Shapes Using Specific Coordinates ............................... 7-8

8  Working with Symbols
  Switching Between Schematic and Symbol Views .............................. 8-3
  Creating a Symbol for use with any Design ..................................... 8-3
  Generating a Symbol .......................................................................... 8-4
  Using One of the Supplied Symbols .................................................... 8-5
  Drawing a Custom Symbol ................................................................. 8-6
    Drawing Setup ................................................................................. 8-6
    Drawing the Symbol Body .............................................................. 8-9
    Adding Pins to Your Symbol .......................................................... 8-9
9 Creating a Layout
The Layout Environment ............................................................ 9-1
Using the Layout Ruler ................................................................. 9-1
Creating a Layout Manually .......................................................... 9-3
Inserting Components ................................................................. 9-3
Drawing Shapes ........................................................................... 9-4
Adding Ports and Grounds ............................................................. 9-7
Designating Edge and Area Ports ................................................... 9-8
Working with Traces ...................................................................... 9-8
Working with Paths ........................................................................ 9-15
Differences Between Paths and Traces ............................................ 9-16
Creating Interconnects with Shapes .............................................. 9-17
Working with Wires ....................................................................... 9-17
Inserting Text ............................................................................... 9-18
Creating a Layout from a Schematic .............................................. 9-24
Creating a Layout as You Create a Schematic ................................ 9-24
Hierarchical Layouts ...................................................................... 9-25
Advantages of a Hierarchical Design ............................................. 9-25
Schematic Considerations ............................................................. 9-26
Parametric Subnetworks ............................................................... 9-26
Creating a Hierarchical Layout ..................................................... 9-27
Viewing Hierarchical Design Information .................................... 9-29
Flattening Hierarchy .................................................................... 9-29
Creating a Hierarchical Design for Repeated Use ......................... 9-30
Pushing Into or Popping Out of Hierarchy ..................................... 9-30
Libraries and Search Paths .......................................................... 9-30

10 Creating Elements
Creating New Items ......................................................................... 10-1
Simulation Items ........................................................................... 10-1
Defining a New Item ........................................................................ 10-2
Defining Design Characteristics .................................................... 10-3
Creating a New Item Using a Built-in Simulator Model ................... 10-5
Defining Parameters ...................................................................... 10-7

11 Editing a Layout
Using Selection Filters .................................................................... 11-1
Editing Shapes .............................................................................. 11-2
Selecting Shapes ............................................................................................... 11-2
Manipulating Polygons and Polylines ................................................................. 11-2
Manipulating Vertices ......................................................................................... 11-9
Moving Shapes or Text to a Different Layer........................................................ 11-12
Manipulating Dimension Lines.............................................................................. 11-12
Moving Endlines ................................................................................................. 11-12
Modifying Dimension Lines ................................................................................ 11-13
Moving an Object to the Coordinates 0,0 .................................................................. 11-14
Forcing an Object onto the Grid ............................................................................. 11-15
Editing Layout Hierarchy (Flatten) ....................................................................... 11-15
Physical Connectivity Engine ................................................................................... 11-16
Polygon-Based Layout Connectivity ...................................................................... 11-16
Simplified Vertical Interconnects ........................................................................... 11-17
Edge/Area Pins ..................................................................................................... 11-17
Nodal and Physical Interconnect Verification .................................................... 11-17
Usage Notes........................................................................................................... 11-18
Connecting Layout Components .......................................................................... 11-19
Checking Connectivity Information in Layout.................................................... 11-19
Highlighting Interconnects .................................................................................... 11-20
Cross-Probing ....................................................................................................... 11-23
Disabling Layout Connectivity Features ............................................................ 11-23
Working with Transmission Lines ......................................................................... 11-24
Splitting a Transmission Line ................................................................................ 11-24
Replacing a Transmission Line Element ............................................................ 11-26
Stretching a Transmission Line............................................................................. 11-26
Squeezing a Transmission Line While Maintaining its Length............................ 11-27
Editing Paths, Traces and Wires .......................................................................... 11-29
Editing Component Text......................................................................................... 11-31
Using Boolean Logical Operations ........................................................................ 11-31
Edit > Boolean Logical > DIFF .......................................................................... 11-32
Edit > Boolean Logical > AND ........................................................................... 11-34
Edit > Boolean Logical > OR ............................................................................. 11-34
Edit > Boolean Logical > XOR ........................................................................... 11-35
Creating Clearance.............................................................................................. 11-35

12 Design Synchronization
The Synchronization Process............................................................................... 12-1
Synchronization Modes ....................................................................................... 12-2
Working with Hierarchical Designs ..................................................................... 12-3
Identifying Components Without Artwork ......................................................... 12-6
Using TEE Junctions in a Schematic................................................................. 12-7
Using Steps and Tapers in a Schematic.............................................................. 12-8
Exporting a Layout................................................................. 14-3
Preparing a Layout for Translation...................................... 14-3
Flattening Instances to Eliminate Hierarchy and Connectivity 14-3
Adding a Process Offset......................................................... 14-4
Creating a Reverse Image of a Layer...................................... 14-5
Translating a Layout............................................................... 14-6

15 Standard AEL Macros
conn.......................................................... 15-2
cpad2..................................................... 15-2
cpad3..................................................... 15-3
cpad4..................................................... 15-4
pad1....................................................... 15-5
pad3....................................................... 15-6
pad4....................................................... 15-7
padn....................................................... 15-8
rpad2 .................................................... 15-9
rpad3..................................................... 15-10
rpad4..................................................... 15-11
spac..................................................... 15-12
spad2..................................................... 15-12
spad3..................................................... 15-13
spad4..................................................... 15-14
tar1...................................................... 15-15

16 Printing and Plotting
Printing from UNIX............................................. 16-2
Adding a Printer..................................................... 16-3
Selecting a Printer................................................... 16-8
Sending Output to the Printer...................................... 16-9
Creating a Printer-specific Print File.......................... 16-9
Printing to File in a Generic Format.......................... 16-11
Printing from the PC............................................. 16-12
Establishing a Print Setup........................................ 16-13
Basic Printing...................................................... 16-14
Printing a Scaled Layout........................................ 16-15

17 Using the Text Editor
Starting the Text Editor Program................................. 17-1
Command Line Options............................................ 17-2
Text File Management............................................. 17-3
Creating a Text File.............................................. 17-3
Opening an Existing File ............................................ 17-3
Inserting One Text File into Another .......................................................... 17-4
Saving Text Files ............................................................................................. 17-4
Printing Text Files ............................................................................................ 17-5
Exiting the Text Editor ..................................................................................... 17-5
Editing Text Files .............................................................................................. 17-5
Performing Search and Replace Operations ................................................... 17-6
Keyboard Mappings .......................................................................................... 17-8

A Using Advanced Design System Across Platforms

Opening Projects .............................................................................................. A-2
Guidelines for Cross-platform Use ................................................................. A-2

Index
Chapter 1: Program Basics

The Advanced Design System design environment includes all the tools you need to manage your projects, create and edit schematics, and simulate your designs easily and efficiently.

Starting the Program

To start the program:

- UNIX, from the terminal window type:
  
  ads

  **Note** Starting ADS in this manner assumes you have established a path to the ADS installation directory. If you have not, type `<installation_dir>/bin/ads`, where `<installation_dir>` represents your complete installation path. For details on establishing a path statement, refer to Chapter 2 of the Installation on UNIX/LINUX Systems manual.

- Windows, from the Start menu choose:

  Programs > Advanced Design System 2003A > Advanced Design System

  to bring up the Advanced Design System Main window, which provides access to all features of the Advanced Design System. Alternatively, choose one of the other commands to access these specific features of the Advanced Design System.
Selecting a Design Type

The first time you launch the application, you are prompted to select which type of components you want loaded on start-up: Analog/RF Only, Digital Signal Processing Only, or Both. Choosing either of the first two categories limits your choice of components, for the current session, to the selected category. Choosing Both allows both types of design work in the same session.

If you select Both (Both, With Default:), you must also specify a default design type. This default design type serves the following purposes: defines the components available by default in a design window and defines the default design type that appears in the New Design dialog box. (This choice only serves as a default and can be changed any time you start a new design (File -> New).

**Note**  You can change these options at any time through **Tools -> Advanced Design System Setup** in the Main window. When you change these options, you are changing them for the subsequent session and you are prompted to exit the application and restart it to effect the change. The selections remain valid until you explicitly change them again.
Using the Greeting Dialog

The Greeting Dialog is available to help you get started as soon as an ADS session is launched. It will appear every time an ADS session is started, unless you select the Don't display this dialog box again option. To re-access the Greeting Dialog the next time an ADS session is started, select Tools > Preferences... > Display the Greeting Dialog at start-up. Once an icon is selected, the Greeting Dialog will be dismissed.

The Design Environment

The design environment is made up of windows. All operations take place within the framework of windows. As you work with multiple windows, you may find it helpful to minimize the Status window to clear additional space on your screen. To quickly restore it to the screen, choose Window > Simulation Status from any program window.

Main Window

The Main window enables you to create and manage projects. Projects are central to the operation of all the simulators and allow you to organize your related designs.
From the Main window you can:

- Create and manage projects and designs
- Quickly open example projects (File > Example Project)
- Set program preferences
- Change toolbar configuration and keyboard shortcuts
- Change the type of components loaded on start-up
- Playback macros created through Application Extension Language (AEL)
- Issue AEL commands
- Launch the text editor
- Open a data display window
- Pop obscured windows to the top (from the Window menu)
- Display all types of files and open as desired through context-sensitive menu (View > Show All Files). Click right to open different types of files in the appropriate type of window (including a text editor for .ael, .cfg, etc.).
**Design Windows**

A design window is where you create and edit all of your designs. You can resize and move these windows in the workspace. You can enlarge one window to fill the entire workspace and you can shrink each window to an icon. The following illustration shows the parts of a design window.

- **Title bar** displays the window type, design type, filename, and a number identifying which window of that type it is.
- **Menu bar** displays the menus available in that window.
- **Toolbar** contains buttons for frequently used commands and for choosing the appropriate orientation for components. The collection of buttons on the toolbar is configurable (Tools > Hot Key/Toolbar Configuration) and can be toggled on and off (View > Toolbar).

When you move your pointer slowly over the buttons on the toolbar, a balloon appears with a label identifying the function of that button. By default, the option that controls the display of this label is turned on. To turn this option off, choose Tools > Preferences in the Main window and turn off Balloon Help.
Program Basics

---

**Hint**  To change the timing for the display of the balloon, set the variable `BALLOON_HELP_TIMEOUT` in the file `de_sim.cfg`.

---

- The Palette List enables you to choose a category of components to place on the Component Palette.
- The Component History drop-down list is continuously updated to reflect the components you have placed in your design. It provides a quick method of placing another instance of a component in your design and can be used as a starting point for creating a custom palette.
- The Drawing area is where you create your designs.
- The Component Palette contains buttons for placing components.
- The Prompt panel provides messages to assist you during the execution of most commands, as well as various pieces of information to assist you in creating a design.
- The Pop-up menu lets you access many common commands with a minimum of mouse movement. You access the pop-up menu by pressing the right mouse button in the drawing area of any design window. The context-sensitive commands appear on the pop-up menu when the pointer is positioned over certain shapes or text and you click right.

**Opening Design Windows**

There are several ways to open design windows and the method you use is based on what you want to do in that window.

- **New design**—To open a Schematic or Layout window for creating a new design or editing an existing design not currently in memory, click the New Schematic or New Layout button or choose the command (by the same name) from the Window menu in the Main window. Selecting New Schematic will launch the Schematic Wizard, which guides you through a sequence of steps gathering information about the type of schematic you want to create. Based on your inputs, the wizard automatically creates the specified schematic components. The wizard then provides you with instructions for completing the schematic manually, and for invoking the simulator when applicable. The simulations are set up to automatically display
the results after successful simulations. For more information on the Schematic Wizard see the Using Circuit Simulators manual.

- Additional window—To open an additional Schematic or Layout window for a design that is already open, choose the Schematic or Layout command from the Window menu in that window.

**Hint** You can also open a new Data Display window from the Main window.

Note that Schematic and Layout windows are numbered sequentially as they are opened throughout a session. If Schematic window number three is open (the title bar reflects (Schematic):3) and you open a dialog box from that window, the title bar of the dialog box will also reflect :3. This is to assist you in identifying which design window you are about to make changes to.

**Opening Multiple Design Windows for the Same Design**

The design environment enables you to use multiple Schematic and Layout windows at the same time. For example, you can open two Schematic windows with different designs making it easy to copy and paste parts from one design to another. Or the windows can contain the same design making it easier to accomplish certain design tasks.

**Hint** When you want to open a window for creating a new design or editing an existing design, use the Window menu in the Main window; when you want to open an additional window for the current design, use the Window menu in that window (Schematic or Layout).

**Figure 1-1** illustrates how you can connect components in a large schematic when the components are far apart and the pins difficult to see. You can open an additional window containing the same design. In the first window, zoom in on one of the components. In the second window, zoom in on the other component. Choose the desired Wire command and draw the wire by clicking the appropriate pin in one window, moving the pointer to the second window and clicking the appropriate pin there.
Using the Component Palette

The Component Palette contains buttons that provide a quick method of placing items to create your design.
Hint  All palette items can also be placed through the Library. Some items are only available through the Library.

Detaching the Component Palette

The component palette can be detached from the window and moved anywhere on the screen. You may find this helpful in temporarily providing additional space in the drawing area.

To detach the component palette:

Choose View > Component > Detach Component Palette. Window borders and a title bar appear. Where applicable, scroll bars also appear. This window can now be moved around and manipulated like any other window.

To attach the palette to the window again:

Choose View > Component > Attach Component Palette. The palette is once again integrated with the design window.
Hint  On the PC only, you can detach and re-attach using the mouse. Position the pointer over a blank area between buttons on the palette and press the left mouse button. A border appears. Drag the palette to the desired location and release. To re-attach, position the pointer in the title bar of the detached palette and press the left mouse button. Drag the palette toward its original location, positioning the title bar just under the bottom of the palette drop-down list and release.

Moving Toolbars (PC Only)

The toolbars can be repositioned anywhere on the screen. You can move them away from the window and use them like floating palettes or you can dock them along the window’s edges.

Hint  When the title bar of a toolbar is visible, positioning your pointer within the title bar for the drag operation simplifies the docking process. If a title bar is not visible, move the toolbar away from the window’s edge and release; when it is not docked, a title bar appears.

To float a toolbar away from the window:

1. Position the pointer over a blank area between icons on the toolbar and press the left mouse button.

2. Drag the toolbar to the desired location and release. When you release the toolbar, a title bar appears at the top of it.

To dock a toolbar on a window border:

1. Position the pointer over a blank area between icons and press the left mouse button.

2. Drag the toolbar toward the desired window border and notice that the ghost image of the toolbar changes as needed to fit in a vertical or horizontal space.

3. When the ghost image reflects the proper orientation, release the mouse button and refine the toolbar’s position by dragging as necessary.

To reattach a toolbar near the top of the window:
1. Position the pointer in the title bar of the toolbar and press the left mouse button.

2. Drag the toolbar toward the top of the window and when your pointer is overlapping the menu bar, or another toolbar, release.

**Schematic Window**

The Schematic window is where you create your schematic designs. You create your design by placing components, ports, data items, units, variables, equations, etc.

The program is shipped with a set of standard defaults and parts libraries. These differ depending on program options. However, all defaults can be modified on a system-wide, or project basis. Before beginning any serious design effort, you can customize these defaults to better match the typical designs done at your site.

The most important thing you can do before starting your design is to configure your setup correctly. There are many ways to configure the program defaults. The best configuration for you depends on the type of designs you create, the options you have, and the type of final output you require.
Closing Design Windows
To close an individual design window, but keep the design in memory:
From the Window menu in that window, choose Close.

Layout Basics
The Layout Window
The illustration shows the Layout window.

Opening and Closing a Layout Window
There are two ways to open a Layout window, depending on whether it is for a new design or an additional window for the current design.

• To open a Layout window for a new design, from the Main window, click the Layout toolbar icon or choose Window > New Layout (Ctrl+Shift+A).
• To open an additional Layout window for the current design, from the Schematic or Layout window, choose Window > Layout (Ctrl+Shift+L).

To close a Layout window:
• Choose **Window > Close** or use the keyboard shortcut **Ctrl+F4**.

**Setting Layout Defaults**

Layout is shipped with a set of standard defaults that differ depending on program options. These defaults can be modified on a project- or system-wide basis. Before you begin a layout, be sure that Layout defaults are appropriate for the design, program options, and final output required.

**Insertion Layers**

In a Layout window, objects are placed on a layer. The name of the current insertion layer is displayed in the toolbar and in the status bar (see “The Layout Window” on page 1-12). You can change the insertion layer and copy shapes from one layer to another.

To change the insertion layer, choose one:

- On the Layout window toolbar, choose the name of the layer from the drop-down list next to the layer name.
- Select **Insert > Entry Layer** and choose a layer from the list.
- Select **Options > Layers** and select a layer from the list of defined layers in the Layer Editor dialog box.
- Select **Insert > Change Entry Layer To** and click an object whose layer you wish to make the current insertion layer.
- Use the keyboard shortcut **Ctrl+Shift+C** and click an object whose layer you want to make the current insertion layer.

To copy a shape from one layer to another:

- From the Layout menu, choose **Edit > Advanced Copy/Paste > Copy To Layer**. The copied shape is placed at exactly the same coordinates as the original.

When you experiment with placing shapes on different layers, remember to click OK to accept a change in a dialog box.

**Inserting Components and Shapes**

To create a layout, you insert components and shapes on the Drawing Area.
To insert components:

- Choose a category of components to display on the Component Palette.
- Click the component in the palette, then click in the Layout window to place it.

To insert a connector, ground, or trace:

- Click the item on the toolbar, then click in the Layout window to place it.

### Inserting Shapes

To insert shapes, choose one:

- Click the shape on the toolbar, then click in the Layout window to place it.
- Choose **Insert > Coordinate Entry**. In the dialog, enter the X and Y Increments to place the shape.

The two types of coordinates are: positional and differential.

Positional displays the X,Y coordinates of the cursor position in relation to the total window. By default, the large + in the center of the drawing area is 0,0.
Differential displays the distance in X,Y the cursor has traveled since the last click. Set the starting point to 0,0 by clicking anywhere in the drawing area.

<table>
<thead>
<tr>
<th>Positional</th>
<th>Differential</th>
</tr>
</thead>
<tbody>
<tr>
<td>cond</td>
<td>-7.9478, 6.4878</td>
</tr>
</tbody>
</table>

• Choose Insert, then choose a listed shape. The program provides instructions (in the Prompt panel at the bottom of the window) as you insert the shape.

For example, when you select Insert > Rectangle, the program displays this prompt:

Rectangle: Enter the first corner

Click in the Layout window to define one corner of the rectangle. The prompt changes to:

Rectangle: Enter the second corner

As you drag the pointer, you can see the rectangle. When the rectangle is the size you want, click to insert it. See the example.

Example

1. Select the rectangle icon on the toolbar.
2. Click in the Drawing window to define the first point on the rectangle. Note that the Differential X,Y coordinate display reads 0.00, 0.00.
3. Move the cursor until the coordinate display reads 200.0, 100.0.
4. Click a second time. A rectangle 200 x 100 mil is inserted in the window.

Rotating a Component

You can save time and mouse-clicks by rotating components as you insert them so that they are properly oriented when you place them.
Program Basics

If you find that a component is not oriented properly as you drag it into position, before you click in the window to place it, either press Control + R or click the Rotate icon (see the toolbar, above). The component rotates -90° each time. When the component is oriented properly, click to insert it.

Editing Objects in a Layout Window

The two ways to edit objects in a Layout window are:

- Using a menu command (Edit > <command>)
- Using a command on the toolbar.

Creating Artwork

In addition to the components supplied with the program that have layout footprints, you can create custom layout components by using one of these methods:

- Using the Graphical Cell Compiler. For details, see the Graphical Cell Compiler manual.
- Writing scripts in the Application Extension Language (AEL). For details, see the AEL manual.
- Drawing your own shapes and adding the necessary pins/ports.

Releasing a Layout License

When you finish doing layout work, release the Layout license so that the license is available to another user. In the Layout window, select File > Release Layout License.

Using the Design Rule Checker

The Design Rule Checker (DRC) is used to verify that a physical design complies with predefined rules or operations. DRC requires a separate license and is accessed through the Verify menu. For details, see the Design Rule Checker manual.

Status Message Window

The Simulation/Synthesis Message window appears whenever a simulator is launched and displays messages about the status of the current process, as well as warning messages. Each simulation generates its own set of messages which are stored in memory during the current session. These sets of messages can be
distinguished from one another by the number displayed in the title bar of the window.

The window contains two information panels:

- Simulation/Synthesis Messages
- Status/Summary

The Simulation/ Synthesis Messages portion of the window displays detailed messages about problems encountered during a simulation or synthesis, and where possible, what you can do to solve the problem.

**Hint** Watch for a message that prompts you to click to view the source of the problem. Clicking this message highlights the component(s)—in the Schematic window—causing the problem.

The Status/ Summary portion of the window displays a Simulation finished message, statistics such as how long the simulation or synthesis took, and the system resources used.
Viewing Simulation Status and Error Messages

When the simulation/synthesis is finished, you can save the displayed information to file or you can send it directly to the printer.

To save the currently displayed information to file with a default filename:

Choose **File > Save Design** and click **OK**. The default filename consists of the simulation process number (from the title bar of the window), with a prefix of the string `sessloghpeesofsim` and a file extension of `.txt`. The file is saved to the current project directory.

To save the currently displayed information to file with a filename of your choosing:

Choose **File > Save As**. Supply a filename and click **OK**. The file is saved to the current project directory.

---

**Note** If you have changed projects during the current session, the file may be written to the initial project opened in this session.

---

To send the information directly to the printer:

1. If needed, choose **File > Print Setup** to establish the desired setup and click **OK**.
2. Choose **File > Print**. The displayed information is sent to the printer.

For details on print setup, refer to Chapter 16, Printing and Plotting.

Because each simulation generates a set of messages identified by unique names, you can view any messages generated during the current session. You can view these one at a time in the same window, or you can open multiple windows and display different ones all at the same time.

To view messages generated by another simulation:

1. Optionally, choose **Window > New Window**.
2. From the Window menu, select the simulation information you want to view, as identified by the unique number displayed in the title bar associated with each simulation. The display changes to reflect your selection.

To close any individual status window:

Choose **Window > Close Window**.
Using the Data Display Window

You can open a Data Display window to see the results of your simulation analysis. To view a graph, choose Window > New Data Display from the Main or Schematic window. After you open a window, you can select an independent swept variable, select dependent measurements, scale the data, and add captions to your graph. Then you can print or plot the graph.

You can open one or more Data Display windows at a time inside the same workspace. For example, you can view the same data on a graph and in a tabular format at the same time. Each graph appears in a separate window.

For detailed information on working with data displays, refer to the Data Display manual.
Reading and Writing Data Files

You can transfer data from a file into a dataset, or vice versa. One application is to transfer data from a dataset to an MDIF file, for use with a specific type of component. For example, a file in P2D format (P2D is one of several MDIF formats) containing S-parameters can then be used by the P2D amplifier. Using the Data File Tool, you can write S-parameters from a dataset to a file in P2D format. Another application is reading Agilent IC-CAP data into a dataset to be used in conjunction with a component, such as a source, that can read data from a dataset.

You can start the Data File Tool from a Schematic window or a Data Display Window by selecting Tools > Data File Tool. For more information on the Data File Tool, refer to the Using Circuit Simulators manual, Chp. 4, Reading and Writing Data Files.

Naming Conventions

Prior to Advanced Design System 1.5, user-supplied names throughout the software were restricted in numerous ways. Not only were names restricted with respect to the allowable set of characters, but you could not have any duplication of names among certain types of items, such as node names and instance names. Using the same name for the following items is now allowed:

- Variable names (created in VarEqn and MeasEqn components)
- Node names/Wire labels
- Instance Names
- Component names (includes supplied components and models, and your designs used as subnetworks)

Note: The names of supplied components cannot be used as design names. If you receive an error message stating the supplied design name is reserved for Advanced Design System, you have most likely used a name that is reserved for a component. To review these names, see the component libraries or the component manuals.

The following illustration shows how these terms are used.
User-supplied names that were previously restricted to alphanumeric and underscore (_) characters (hereafter referred to as the standard character set), can now take advantage of an extended character set that incorporates additional special characters. The extended character set (a superset) consists of the following characters:

```
alphanumeric _ + = ` @ # & $ %
```

In addition, you can now use a numeral as the first character in many names.

The following table denotes where the extended set and numeric prefixes can be used, as well as several exceptions:
## Program Basics

<table>
<thead>
<tr>
<th>Name</th>
<th>Character Set</th>
<th>Exceptions</th>
<th>Numeric Prefix</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variable (VarEqn, MeasEqn)</td>
<td>Standard</td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>Node/wire label</td>
<td>Extended</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Instance</td>
<td>Extended</td>
<td>An underscore cannot be used as the first character.</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The following components are restricted to the standard character set for their Instance Name:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>SweepPlan, ParamSweep, DC, AC, S_Param, HB, LSSP, P2D, XDB, Envelope, Transient, Options, YieldSpec, Goal, Yield, Optim, YieldOptim, MeasEqn, VarEqn, DataAccessComponent</td>
<td></td>
</tr>
<tr>
<td>Component</td>
<td>Extended</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Design</td>
<td>Extended</td>
<td>Design names may not contain $ or %. These characters are reserved for ADS environment variable substitution.</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note: If a design name includes special characters or starts with a numeral (such as &quot;00a&quot; or &quot;@&quot;), optimization results are not updated</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note: If a design name consists solely of numerals, the transistor device operating points dialog box cannot be displayed.</td>
<td></td>
</tr>
<tr>
<td>Project</td>
<td>Standard</td>
<td></td>
<td>Yes</td>
</tr>
</tbody>
</table>
Limitations

- When the extended character set is used to define a name, and that name becomes part of a variable name in a dataset, the data cannot be accessed directly with respect to either data displays or measurement equations. A special access function called var(), must be used. For example, if you name a node V++ then to display its magnitude you must use the expression:

  \[ \text{mag(var("V++"))} \]

  where var() is passed the name of the variable as a string. The var() function interprets the passed string as the name of a variable, which prevents any expression processing of the string. Note that using this function limits you to accessing datasets in the data directory of the current project. Data Display automatically adds var() when required to access names defined using the extended character set.

- Substrate Instance Names—If a leading number is used as a substrate ID, then that substrate cannot be referenced by its corresponding set of distributed models.

- Model Instance Names—Currently, the characters $ and % are not allowed in Instance Names for model items, such as BJT_Model, R_Model, etc.

- Dataset Names—Special characters from the extended set are not allowed in dataset names (standard set, with non-numeric first character, is required). Thus, if you have two or more designs whose names are distinguishable from one another only with respect to the use of special characters, you should supply unique dataset names prior to simulating. If you do not, and you perform successive simulations of these designs, the dataset resulting from the first simulation will be overwritten by the next (because the special characters will be dropped from the automatically derived dataset names).

  Note: If your design name begins with a number, the default dataset name will be the design name with an underscore character (_) added to the front.

- Optimization Goals—Special characters currently cannot be referenced by an Optimization Goal or Yield spec. If a design name includes special characters or starts with a numeral (such as "00a" or "@"), optimization results are not updated.
Program Basics

- Operating Point Annotation—The transistor device operating points dialog box does not come up when a design has a numeric name such as "0000" or "1234".
- Spaces are not allowed in project and design names

**Note**  An invalid character is changed to "_" (underscore).

**Global Node Naming Conventions**

If you use an exclamation point (!) as the last character in a node name, it denotes that the node is a global node.

**Creating an Electronic Notebook**

The Electronic Notebook enables you to generate a portable notebook containing screen captures of schematic and layout designs, as well as data displays, for a given project. You can add descriptions for every page in the notebook, and you can include text and graphics from other sources. The annotated body of design work can then be viewed in a browser, enabling you to share your designs with others, without running ADS. You can also zip the set of files generated by the notebook to facilitate transferring them.

To create an electronic notebook:

1. From a Schematic window in the project of interest, choose **Tools > Electronic Notebook**. A dialog box appears providing a brief description of the notebook basics.

2. Click **OK** and the main Electronic Notebook Editor dialog box appears. The notebook displays the default notebook structure, which includes every design and data display in the current project, as well as a single Description page for the notebook.

At this point, you can click Generate and generate the actual HTML, based on the default structure and default options, but the notebook editor contains several features that enable you to customize it. For details, refer to the following topics of interest:

- “Deleting Pages from the Notebook” on page 1-26
3. To generate a new notebook using the defaults, click **Generate**. An information message appears with important guidelines regarding the status of ADS windows during the HTML generation process. After reading these messages, click **OK** and the HTML generation process begins. When the generation is complete, the first page of the notebook is displayed in your browser. The following illustration identifies the basic layout of the notebook using an individual Schematic page as an example.

Refer to the following topics for descriptions of additional features:
- “Adding Descriptions to the Notebook” on page 1-26
- “Adding Pages to an Existing Notebook” on page 1-27
- “Reorganizing Pages in the Notebook” on page 1-28
- “Adding External Images to the Notebook” on page 1-28
- “Changing Image Capture Settings in the Notebook” on page 1-29

![Diagram of notebook layout]

---

Creating an Electronic Notebook 1-25
Program Basics

- “Zipping the Files of a Notebook” on page 1-31

Deleting Pages from the Notebook

By default, when you create a new notebook, it includes pages for every design and data display in the project, but you can easily delete designs from the notebook.

To delete individual designs from the notebook:

Select the design you want to delete and click Delete Page. If you change your mind, click Add Page, select the appropriate Page Type, select the design from the drop-down list, and click OK to add it back.

Adding Descriptions to the Notebook

To add descriptive text to a specific page of the notebook:

1. Select the page from the list of pages on the left and enter the desired text in the Description area(s) on the right. For individual design pages, you are provided with two text boxes: Description and Bottom Description, which are added above and below, respectively, the captured image.

   Hint To include existing text from another source: on UNIX, highlight that text and use the middle mouse button to paste it, or on the PC, copy the desired text and use the pop-up menu available from within the Description text boxes to paste it. On the PC only, you can copy and paste text among the various description text boxes using this pop-up menu.

2. Optionally, you can use HTML in any of the description text boxes, enabling you to format it as you please. Some basic HTML shortcuts are provided, but you can enter most standard HTML tags directly in the text boxes.
To use the shortcut HTML tags, highlight the desired text and click the desired shortcut icon. The associated HTML tags appear.

**Note**  Due to differences in individual browsers and the fonts installed on your operating system, these formats may not always produce the expected results.

3. When you are through making changes, click **Generate** and these descriptions will be incorporated in the notebook.

### Adding Pages to an Existing Notebook

You can add a number of page types to the notebook. You can add new (since the notebook was generated) or previously deleted Schematic, Layout, and Data Display pages. You can also add a page that combines a Schematic and a Data Display on the same page. And you can add an Image page for displaying a graphic from a source other than ADS.

To add a page to the notebook:

1. Click the **Add Page** button.
2. Select the desired Page Type. The dialog box changes, based on the selected Page Type.
   - If adding a Description page, no additional action is needed yet.
   - If adding a Schematic, Layout, or Data Display page, select the name of the design (to appear on that page) from the drop-down list.
   - If adding a combined Schematic/Data Display page, select both the schematic design name and the data display name from the respective drop-down lists.
   - If adding an Image page, enter the filename or use the browser to select it (refer to “Adding External Images to the Notebook” on page 1-28).
3. Click **OK** and the page appears among the list of other notebook pages.

**Hint**  If an individual design is highlighted when you add the page, the new page appears under that design. If a group is highlighted, the new page appears at the bottom of that group. You can then move it up and down, as well as left and right, to position where you want it.
Program Basics

Reorganizing Pages in the Notebook

To reorganize the designs in the notebook to reflect the design hierarchy:

1. Select the top-level design and click the Left arrow to make it a folder.
2. Use the Up and Down arrows to move the subnetwork designs under it, in the desired order.

Moving a design/display from one group to another (such as, moving a data display into the schematic group) requires making it a folder temporarily. To group related schematic/layout designs and data displays together:

1. Select the design and click the Left arrow button (to make it a folder).
2. Use the Up and Down arrow buttons to move it above or below the design you want to group it with, and click the Right arrow button to move it in again.

Adding External Images to the Notebook

You can include an image from an external source by adding an Image page, and you can add descriptive text above and below it, just as you can with other types of pages. You can also replace the Agilent logo with an image of your own.

To add an Image page to your notebook:

1. Click Add Page and select Image as the Page Type. A field for a filename appears.
2. Type the path and filename or use the browser to select the file.
3. Optionally, click View to verify you have the image you want.
4. Click OK.

**Hint** The image will be copied to the notebook directory, so if you change this image in its original location, and want those changes to be part of the notebook, be sure to import it to a new image page, copy and paste descriptions, etc., and then delete the image page containing the older image.

5. Optionally, reposition the image page within the notebook using the Up and Down arrows, and add any desired descriptive text.
6. When you are through making changes, click **Generate** and the new image page will be incorporated in the notebook.

To replace the Agilent logo with your own image:

In the Banner Image field, type the path and filename, or use the browser to select one. Click Generate when you have made all other desired changes.

### Changing Image Capture Settings in the Notebook

During the HTML generation, screen captures are taken of all schematics, layouts, and data displays that are part of the notebook. By default, these screen captures will be 700 pixels wide x 500 pixels high, with a normal zoom (see illustration that follows). You can establish default settings for all new screen captures, and override these defaults for individual designs.

To set a default capture size and zoom for all designs in the project:

1. From the Notebook Properties pane, click **Preferences**.

   ![Capture Size](image)

   Default dimensions of a new Schematic window. Adjust as needed for larger or smaller designs.

   ![Capture Quality](image)

   - **Single Image** — No zoom capability. Best suited to small, simple designs.
   - **Normal Zoom** — Capture taken in four parts (without overlaps). Zoom in on each quadrant.
   - **Detailed Zoom** — Capture taken in nine parts (with overlaps). Zoom in for a better view of a portion of a complex design.
2. Change the capture dimensions and zoom setting as desired and click **OK**.

3. To override the default capture size and/or zoom for an individual design:

4. Select the design of interest and click **Capture Options**.

5. Change the settings as desired.

**Hint** If after experimenting you decide you want to go back to the original settings, click **Restore Defaults**.

- For a new notebook, click **OK** in the Capture Options dialog box. When you generate the notebook as a whole, these settings will be used for this design.
- If you are updating an existing notebook, click **Recapture Image**. A message appears explaining that if you proceed, the currently saved image will be replaced by a new capture, using the new capture settings. If this is what you want to do, click **Yes** to continue and click **OK** in the Capture Options dialog box. The next time you generate the notebook, this design will be recaptured using the new settings.

**Note** The **Recapture Image** capability only works if the option **Update images automatically** is enabled (the default state).

### Saving Changes to the Notebook

Whenever you Generate the notebook, the information is saved automatically. But any time you have made changes to the notebook (such as modifying descriptions or reorganizing pages) that you want to keep, and you have not regenerated, click **Save** to explicitly save the changes.

### Viewing an Existing Notebook

Whenever you want to view an existing notebook in the browser, launch the notebook (**Tools > Electronic Notebook**) and click **View**. Note that if you have made changes to any of the designs, or to the notebook itself, you must Generate to see those changes.
Updating an Existing Notebook

To modify or update an existing notebook:

1. From a Schematic window in the project of interest, choose **Tools > Electronic Notebook**.

2. When the notebook appears, make the desired changes.
   - By default, any design that has changed will be updated when you **Generate**. This behavior is controlled by the option **Update images automatically**, which is set individually for every page in the notebook.
   - If you do not want a given image to be updated, disable this option.
   - If you have made changes to the individual image capture settings of several designs, you can click **Recapture All Images** (from the Notebook Properties pane) to enable the notebook to recapture these images when the notebook is regenerated.
   - Modify any descriptions or rearrange pages as desired.

   **Note**   The **Recapture All Images** capability only works for designs where the option **Update images automatically** is enabled (the default state).

3. Click **Generate**. The notebook is regenerated to incorporate the changes, and is displayed in your browser.

Zipping the Files of a Notebook

To zip the files comprising the notebook so that they can be easily shared:

1. Click **Zip HTML**. You are prompted for a filename and location.

2. Changes paths as desired, supply a filename, and click **Save**.
   - The recipient of the file can view the notebook by unzipping it and opening index.html.
Verifying License Status

The license information tool enables you to view the current status of your ADS licenses. There are two ways to launch the viewer:

- From the ADS Main window, through Help > License Information
- UNIX—From a terminal window, type $HPEESOF_DIR/bin/aglmtool, where $HPEESOF_DIR represents your complete installation path.
- PC—From Windows Explorer, locate <install_dir>/bin and double-click aglmtool.exe where <install_dir> represents your complete installation path.

Environment  Lists environment/license variables and machine information that affect your ADS license configuration. This information can be very helpful when debugging license trouble. Use the Compact View option to wrap the lines making it easier to see where multiple path statements start and stop.

Licenses   Lists all licenses found in the license.dat file installed on your computer, or in the case of a network installation, the license server. Use the Compact View option to wrap the lines making it easier to view complete license statements. Click Refresh if the license.dat file has been modified while viewing license information.

Servers  Lists all license servers serving Agilent EEsof licenses on your network. You can expand any given server to see the licenses served by that server.

Usage  This pane enables you to view the current status of all installed licenses. You can sort by Licenses (multiple licenses for a single feature) or by Users (select the User Info option first). Select All to view a complete list of installed licenses. Select Available to view only those licenses that are currently available. Select In Use to view only those licenses that are currently in use.
Setting Preferences for Miscellaneous Options

The Preferences dialog box, accessed through the Options menu in the Main window, enables you to establish preferences for a variety of features that affect you throughout the design environment.

- **Warning Bell**—The system beeps anytime you receive a pop-up window with a warning message.
- **Error Bell**—The system beeps anytime you receive a pop-up window with an error message.
- **Balloon Help**—As you move your pointer over the toolbar and palette buttons, a small balloon appears with text describing that button’s purpose (or a component’s name).
- **Design Synchronization Checking**—You are warned if you attempt to simulate a design that is not fully synchronized.
- **Large Toolbar Bitmap**—A set of large bitmaps is placed on the toolbar. Turn this option off to place a set of small bitmaps on the toolbar (better for monitors with lower screen resolution). This change will be evident in any subsequently opened windows. To see the change take effect in a currently open window, open the Menu/Toolbar Configuration dialog box, click the Toolbar tab, and click OK.
- **Display Project Listing**—Filters the contents of the selected directory to display only project directories under the Project Listing heading.
- **Save Project State on Exit**—The setup of the project you are exiting is saved, including all design windows. The group of windows, and their positions on the screen, are restored the next time you open the project.
- **Create Initial Schematic Window**—A Schematic window opens automatically each time you create a project.
- **Create Initial Layout Window**—A Layout window opens automatically each time you create a project.
- **New/Open Design in New Window**—Sets a default in the New Design dialog box (File > New Design) that determines whether to open a new window for the new design or use the currently open window.
Changing this setting does not affect the default setting in currently open Schematic/Layout windows, but will take affect in any subsequently opened Schematic/Layout windows.

- **Add Project Extension**—The extension you want appended to project names to clearly identify them as projects (default is _prj).

- **External Text Editor**—Specifies the text editor to be launched when you choose Tools > Text Editor in the Main window.

- **Wire Thickness**—The thickness (Thin, Medium, Thick) of all wires drawn in a Schematic window.

To change any of these settings:

1. Choose Tools > Preferences, in the Main window, and a dialog box appears.
2. Change any or all options as desired, and click OK. All changes take effect immediately, except as noted in the descriptions.

### Exiting the Program

You can exit the program from the design windows or the Main window.

To close your project and exit the program:

Choose File > Exit Advanced Design System in any window.

- Click Yes to exit Advanced Design System
- Click No if you do not want to exit Advanced Design System

To save all designs in all windows, choose File > Save All in the Main window.

If any files with unsaved changes exist, a dialog box appears listing one of the files and offering the following choices:

- Yes—Click this to save changes to the named file and to be prompted individually for any additional files with unsaved changes
• No—Click this to disregard changes to the named file and to be prompted individually for any additional files with unsaved changes

• Yes To All—Click this to save changes to all files without being prompted individually

• No To All—Click this to disregard changes to all files without being prompted individually

• Cancel—Click this to cancel the command
Program Basics
Chapter 2: Managing Projects and Designs

This chapter describes the project directory concept, managing projects and design files, and the basics of importing and exporting designs. For information on these topics, review the following sections:

- “Working in Projects” on page 2-1
- “Importing and Exporting” on page 2-14
- “Managing Design Files” on page 2-18

Working in Projects

All design work must be done in a project directory. Working in project directories enables you to organize related files within a predetermined file structure. This predetermined file structure consists of a set of subdirectories. These subdirectories are used in the following manner:

- **networks** contains schematic and layout information, as well as information needed for simulating
- **data** is the default directory location for input and output data files used or generated by the simulator
- **mom_dsn** contains designs created with the Agilent EEsof planar electromagnetic simulator, Momentum
- **synthesis** contains designs created with DSP filter and synthesis tools
- **verification** contains files generated by the Design Rule Checker (DRC), used with Layout

Creating a Project

You can create any number of project directories.

To create a project directory:

1. Choose File > New Project and a dialog box appears. By default, the path is set to your start-up directory.
2. Working in Projects

Managing Projects and Designs

**Note** Spaces are not allowed in project paths or project names.

2. Type a new path directly in the Name field or use the Browser to specify the location for the new project.

3. Enter a project name in the Name field.

**Note** By default, the suffix _prj is automatically added to the project name you supply. This behavior is defined by the option Add Project Extension. You can change this option through Tools > Preferences in the Main window.

4. Use the Project Technology Files drop down list to select the appropriate layout and schematic unit preferences.

There are three sets of ADS standard technology files:

- Length unit - mil
- Length unit - millimeter
- Length unit - micron

Each of these technology file settings copies a schematic preference file and a layout preference file into the project. This serves as a default for all designs in this project and is both:

- The unit of measure for parameters with physical length (in both Schematic and Layout windows)
• The design unit (grid display and cursor snapping) in the Layout window. The design unit (grid display and cursor snapping) in the Schematic window is inches.

It is also possible to have the new project use your own preferences and layers files by using the Add Custom Technology selection. To use this, you should have a directory anywhere on your computer and place preferences and layers files into this directory. The files should have the names schematic.prf, schematic.lay, layout.prf, and layout.lay. The name of the directory will be used to name your technology files. You will see this name when creating new designs with the File > New Design menu. It will be on the dialog box under Design Technology Files. You can create these files by saving preferences or layers from either schematic or layout. You do not need each of these files:

• schematic.prf - You should have this to establish your choice of length units.
• schematic.lay - Normally not needed. It can be used to change color usage on a schematic.
• layout.prf - Important to have if you are using layout. Various length and grid setting are contained in this file.
• layout.lay - Needed if you are using different layer settings than the standard ADS defaults.

If you have Design Kits enabled you will also see Technology File selections that are based on the name of the design kit. Choosing one of these will cause technology files to be copied from the design kit's de/defaults directory. The description of technology files in this directory is the same as for Add Custom Technology.

Note As preferences and layers files are copied from various locations as described above, they are renamed and put into the project. Renaming is done by prefixing the standard name (schematic.prf, schematic.lay, layout.prf, layout.lay) with a technology name plus an underscore ("_"). The technology name is the length unit (mil, mm, or um), the directory name of a custom technology, or the design kit name. Renaming the technology files allow easy use of multiple technologies in a project. The exact names that will be copied and used in your project can be seen by selecting View Details.

5. Click OK to create the specified project. When the directory structure is complete, the path and the project name appear at the bottom of the Main
The Schematic Wizard guides you through a sequence of steps gathering information from you about the type of schematic you want to create. Based on your inputs, the wizard automatically creates the specified schematic components. The wizard then provides you with instructions for completing the schematic manually, and for invoking the simulator when applicable. The simulations are set up to automatically display the results after successful simulations. For more information on the Schematic Wizard see the Using Circuit Simulators manual.

**Hint** By default, a Schematic window opens on creation of a project. This behavior is defined by the option Create Initial Schematic Window. You can turn this option off through Tools > Preferences in the Main window.

### Opening a Project

The directory that appears as the current directory when you start the program varies by platform:

- **UNIX**—the directory from which you started the program. Once you have created project directories, you can start the program from a project directory, if desired.

- **PC**—the path you specified as the Work Directory during installation (by default, `c:\AdvDesSys`). You can set a different work directory through file Properties. (Right-click a program's shortcut icon and adjust the path in the Start field.) If you want to open a specific project directory while starting the program, use that project directory's name in the Start in field.
Once the Main window appears, there are two ways to open a project directory:

- Use the File > Open Project command
- Double-click the project name in the Project Listing pane of the Main window.

To open a project using the Open Project command:

1. Choose File > Open Project and a dialog box appears. All projects in the current directory are listed in the Files list box.
2. Change directories as needed to find the directory containing the project.
3. Select the project name and click OK. Once the project is open, the right-hand group of toolbar buttons is activated and the path and project appear in the status panel at the bottom of the window.

To open a project using the File Browser:

1. Change directories as needed in the File Browser pane to locate the directory containing the project.

2. Choose View > Project Listing. All projects in the current directory are listed under the Project Listing pane. (For information on the Project Listing preference, refer to the section, “Setting Preferences for Miscellaneous Options” on page 1-33.)
Managing Projects and Designs

3. Double-click to open the desired project. Once the project is open, the right-hand group of toolbar buttons is activated and the path and project appear in the status panel at the bottom of the window.

The windows that open when you open a project vary based on the following options:

- If the **Save Project State on Exit** option was enabled for this project, any design windows that were open when you last exited the project are restored.
- If the **Save Project State on Exit** option was not enabled for this project, but the option **Create Initial Schematic window** was enabled (the default), a blank Schematic window appears.
- If neither of the aforementioned options was enabled, you must manually open a Schematic window. (Click the **New Schematic Window** toolbar button or choose **Window > New Schematic**.)

**Hint** For descriptions of these options, refer to “Setting Preferences for Miscellaneous Options” on page 1-33.

**Copying a Project**

The **Copy Project** command copies a project directory and its contents, to a new project directory with a name you specify.

**Note** Copying projects should only be done through the program, as described here. Copying projects outside the program may result in invalid projects.

To copy a project:

1. Choose **File > Copy Project**.
2. Locate the project you want to copy.

**Hint** To copy an example project, click the **Example Directory** button to quickly set the path to the examples directory.

Click **Browse** next to the **From Project** field.
3. In the dialog box that appears, change directories as needed to locate the project.

4. Select the project you want to copy and click **OK**.

5. Specify the destination directory for the copied project.

   **Hint**  To copy the project to your start-up directory, click the Startup Directory button to quickly set the path to your start-up directory.

   Click **Browse** next to the To Project field.

6. In the dialog box that appears, select the destination path, and click **OK**.

7. Supply a project name, if desired, in the To Project field (following the path).

   **Hint**  If you want the copy to use the same name as the original project, you do not need to specify a name in the To Project field.

8. If the project you are copying is hierarchical, and you want to preserve the hierarchy, leave the Copy Project Hierarchy option enabled.

   **Note**  When copying a hierarchical project, you are prompted for each included project to confirm whether or not you want to copy that project. If you do not copy an included project (Skip), a reference to its source location is created in the copied project hierarchy. You are also prompted to supply a path and name for each copied project in the hierarchy. Click **Browse** to adjust the path without typing.

9. Click **OK**.

**Deleting a Project**

The Delete command enables you to delete a project directory and all its contents.
Managing Projects and Designs

**Note**  Deleting projects should only be done through the program, as described here. Deleting projects outside the program may result in program errors.

To delete a project:

1. Choose File > **Delete Project** and a dialog box appears.
2. Change the path as needed to locate the project directory you want to delete.

**Note**  You cannot delete the current project directory.

3. Select the project and click **OK**. You are prompted to confirm that you want to delete that project directory.
4. Click **Yes** to delete it; click **No** to keep it.

**Using an Example Project**

An extensive set of example projects is provided to demonstrate designing for various technologies.

To view the list of example projects:

1. In the Main window, click the **Examples** button on the toolbar. The File Browser pane changes to display the categories of examples available.
2. Click the category of interest to view the projects in that category.
To open an example project:

1. Use any of these methods:
   • Double-click the project name listed in the File Browser pane on the left.
   • Double-click the project name listed in the Project Listing pane on the right. (Refer to the Project Listing option described in “Setting Preferences for Miscellaneous Options” on page 1-33.)
   • Choose File > Example Project. Select the appropriate category and then the desired example.

2. Example projects are saved in a particular state and one or more designs will open automatically.
   • UNIX Notice that when the Schematic window appears, the title bar reflects that the example is READ-ONLY. To simulate or modify designs in this project, make a copy of the project.
   • PC To preserve the example designs, make a copy of the project before modifying any of the designs in it.

Finding an Example Project or Design

Use the examples search to look for keywords, expressions, or component names in example projects and designs. This search feature looks through the design, layout, and data display files within all example projects and displays a list of projects that contain the terms you specified.
Use the following steps to access the Examples Search from the ADS Main window:

1. Choose **Tools > Examples Search**.

2. Use the Search section of the dialog box to define any combination of the following choices to define your search criteria.
   - **Components** — Search for a specific component.
   - **Keywords** — Search for a specific keyword.
   - **Expressions** — Search for a specific expression.

3. Use the Query field to enter the search word or a combination of the search word separated by Boolean operators. The search words are case sensitive. For example, searching the word `amplifier` will produce different results than searching for `Amplifier`. This is because `amplifier` is treated as a keyword, while `Amplifier` is treated as a component name. You can use Boolean “OR” operation if you want to search for both `amplifier` and `Amplifier`.

   Use an asterisk (*) at either end of the word as a wildcard when entering your search criteria. For example, use “*ing” to look for all words with the suffix “ing.” When using wildcards, the search is limited to a maximum of one hundred words.

   If you enter two or more words separated by a space, the AND operator is implied. You can also specify AND using uppercase letters. For example, `Amplifier BPF_Butterworth Attenuator` returns the same results as `Amplifier AND BPF_Butterworth AND Attenuator`.

   An OR operator requires an explicit entry using uppercase letters. For example, `Amplifier OR BPF_Butterworth OR Attenuator`. Note that all multiple word search is limited to a maximum of four words.

4. Select **Show Valid Search Words** to display a list of valid words corresponding to the letters you type. The words appear in the list below the text entry field. You can double-click any word in the scroll-down list to add it to the Query field.

5. Click **Search Now** to begin the search. Click **Clear** to clear the search criteria. Click **Help** to display online documentation for the Examples Search tool.

6. Display Results

   Example projects that meet the search criteria are listed in the Results section. Use the + in the Results field to expand an example project hierarchy and view the designs or data display files. A red X across an example in the Results field
indicates the example is not available for viewing. You may need to install the example from your CD.

The Path field displays the full path to the currently selected example. Double-click a project, a design, or data display in the Results field to open the selected item.

The Mode radio buttons allow you to select how you would like to open the project/files that you select. Open Selected Project will open the selected project in a new window. Copy to Current Project will create a copy of the selected file within the current project that is already open. .dsn files will be copied to the network directory, .dds files will be copied to the project directory, and .ds files will be copied to the data directory) View Only will bring up a read only copy of the file that you selected. Read only files can not be simulated.

Click View Selected File Help to display documentation for the selected example. If documentation is not available for the selected project, this button is dimmed.

Creating a Hierarchical Project

You can create hierarchical projects using the Include/Remove Projects command. This command creates a reference, or link, to another project. Hierarchical projects offer several benefits, including:

• The ability to create hierarchical designs by referencing designs from other projects

• The ability to maintain a single source of a design referenced by other users. Other users can Include the project containing the design of interest, and benefit from updates to the original design, since they are only linking to it, not copying it.

• Reduced disk space required for shared designs.

An example of a hierarchical project is shown next.
Managing Projects and Designs

To include a project:

1. Open the project directory under which you want to include other projects.
2. Choose File > Include/Remove Projects.
3. Use the File Browser to locate and select the project you want to include.
4. Click the Include button. The project is added to the Project Hierarchy listing.
5. Repeat as needed, then click OK.

To remove an included project:

1. Open the project that includes the project to be removed.
2. Choose File > Include/Remove Projects.
3. Under Project Hierarchy, select the project you want to remove from the hierarchy and click the Remove button. The Project Hierarchy display is updated.

If your hierarchical project includes other hierarchical projects, projects at lower levels cannot be removed unless the project in which they were originally included is the current project. For example, in the illustration shown next, you cannot remove the project amp1_prj from the hierarchy when rec_front_end_prj is the current project; you must make amplifiers_prj the current project first.

4. Repeat as needed, then click OK.
Working with Hierarchical Projects

Observing the following tips may simplify working with hierarchical projects:

- The title bar of the Schematic window displays the source of a project/design. This tip may help orient you when working with hierarchical designs within hierarchical projects. If you Push Into Hierarchy to view a design being referenced, the title bar displays the source of the design.

- If the project name in the title bar of the Schematic window does not match the current project name shown in the prompt panel of the Main window, simulation of that design is not allowed. This situation would occur, for example, if you place an instance of a design (as a subnetwork) from a project that is included in another project, and push into that subnetwork and attempt to simulate.

Archiving a Project

You can create a single file for a project, making it easy to transfer the project to another file system or another location on the same file system.

To archive a project:

1. In the Main window, choose File > Archive Project.
2. Use the Archive Project Browser and select the project you want to archive.
3. Use the To File Browser and select a path for the archived file. (Hint: You cannot archive directly to a floppy disk; you need more space for the process.)
4. Supply a name for the archived file. The extension .zap is automatically appended to the filename you supply.
5. If the project is hierarchical and you want to preserve the hierarchy, select the Archive Project Hierarchy option.
6. Click OK.

**Hint** If transferring projects back and forth between UNIX and PC, keep in mind that UNIX is case-sensitive and the PC is not. The PC does not always preserve case, so filenames going back and forth should be unique.
Unarchiving a Project

To unarchive a project:

1. In the Main window, choose File > Unarchive Project. (Hint: When you unarchive it, the project will be restored in the directory containing the archived file.) The file listing displays all files in the current directory with the extension .zap.

2. Change directories as needed to locate the archived project file.

3. Select the file and click OK. If the project is hierarchical, all projects are restored with their original name(s).

Hint The directory you use to unarchive the project cannot contain any subdirectory or filename of the same name as the archived project(s).

Importing and Exporting

The Import and Export commands enable you to import and export IFF files, as well as files in a variety of formats produced by other software. You can import files through the Main, Schematic, and Layout windows; exporting is done from Schematic and Layout. The listing below shows the available formats.

- For details on these formats and descriptions of the options associated with each, refer to the Importing and Exporting Designs manual
- For details on importing and exporting SPICE files, refer to the Spice Netlist Translator manual
- For details on importing Series IV designs, refer to the Series IV Migration manual

Table 2-1. Program Windows and Available Import/Export Formats

<table>
<thead>
<tr>
<th>Import</th>
<th>Main</th>
<th>Schematic</th>
<th>Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>IFF</td>
<td>EGS Generate</td>
<td>DXF (hierarchical)</td>
<td></td>
</tr>
<tr>
<td>Netlist</td>
<td>HPGL/2</td>
<td>EGS Archive</td>
<td></td>
</tr>
<tr>
<td>IFF</td>
<td></td>
<td>EGS Generate</td>
<td></td>
</tr>
<tr>
<td>Mask File (.msk)</td>
<td></td>
<td>GDSII Stream Format</td>
<td></td>
</tr>
</tbody>
</table>
Importing and Exporting

Importing a Design

Use the following steps to import a design. Keep in mind you need to open a project before you can import a design:

1. Choose File > Import.
2. In the dialog box that appears, select the appropriate file format from the File Type drop-down list.
3. To define options for the imported file, click More Options and dialog box appears.

Table 2-1. Program Windows and Available Import/Export Formats (continued)

<table>
<thead>
<tr>
<th>Main</th>
<th>Schematic</th>
<th>Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Netlist File</td>
<td>HPGL/2</td>
<td>IFF</td>
</tr>
<tr>
<td></td>
<td></td>
<td>IGES</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Mask File (.msk)</td>
</tr>
<tr>
<td>Export</td>
<td>IFF</td>
<td>DXF (hierarchical),</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(flattened)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>EGS Archive</td>
</tr>
<tr>
<td></td>
<td></td>
<td>EGS Generate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>GDSII Stream Format</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Gerber</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Gerber Viewer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>HPGL/2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>IFF</td>
</tr>
<tr>
<td></td>
<td></td>
<td>IGES</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Mask File (.msk)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MGC/PCB</td>
</tr>
</tbody>
</table>
Managing Projects and Designs

**Note** The program translators are controlled by translator options files. A system-wide options file exists for each translator. These files can be found in the $HPEESOF_DIR/config directory. The default system file is automatically read when you click More Options in the Import dialog box (unless a local options file already exists in the current project directory). When you make changes in the options dialog box and click OK, a local copy of the options file is written to the current project directory.

4. To specify the path and filename of the file you want to import, click **Browse**.
5. Double-click as needed to locate the directory containing the design. By default, all files are listed that have the file suffix appropriate for the chosen file format.
6. Select the design you want to import and click **OK**. You are returned to the Import dialog box and the selected filename appears in the field labeled Import File Name (Source).
7. Where applicable, type a new name for your imported design in the New Design Name (Destination) field. Note: For certain file types, the translator uses the existing filename to determine the new design name.
8. Click **OK** to import the design and dismiss the Import dialog box.

**Exporting a Design**

To export a file:

1. Choose **File > Export**.
2. In the dialog box that appears, select a file format from the File Type drop-down list.
3. To set export options, click **More Options** and a dialog box appears.
The program translators are controlled by translator options files. A system-wide options file exists for each translator. These files can be found in the $HPEESOF_DIR/config directory. The default system file is automatically read when you click More Options in the Export dialog box (unless a local options file already exists in the current project directory). When you make changes in the options dialog box and click OK, a local copy of the options file is written to the current project directory.

4. Change options as needed and click **OK**.

5. To specify a path for the exported file, click **Browse**.

6. Double-click as needed to locate the directory for the exported design. By default, all files are listed that have the file suffix appropriate for the chosen file format.

7. Click **OK**.

8. Type a new filename in the Export dialog box, following the path, and click **OK**. The file is written to the specified directory.
Managing Projects and Designs

Managing Design Files

Before you begin your design work, you should understand the basics of file management within the design environment.

Creating a Design File

You can begin your design work in an untitled design window or supply a filename before you begin. When selecting a filename, keep in mind the guidelines described in the section, “Naming Conventions” on page 1-20.

To create a design file:

1. In a Schematic (or Layout) window, choose File > New Design and a dialog box appears.

   ![New Design dialog box]

2. Enter a design name in the Name field. The program automatically adds the extension .dsn to your filename.
3. Where applicable (you selected Both in the initial or setup dialog box), select the Type of Network.

Analog/RF Network or Digital Signal Processing Network

This affects the type of components available for design work.

**Hint** The choices presented here reflect the setting in the Advanced Design System Setup dialog box (Main window, Tools menu).

4. Under the Create New Design in option, select create the new design in the Current Window, a New Schematic Window, or a New Layout Window.

5. Checking the Schematic Wizard box will launch the Schematic Wizard when you click OK. (For details, refer to the Using Circuit Simulators manual.) Optionally, select a Design Template as a starting point for your design. (For details, refer to the section, “Using a Template” on page 2-20.)

6. Select Design Technology Files to determine which preference and layer files will be used by this design. The default choice of Design Technology File is shown in the pull down before you change it. The default choice is established when the project is created. It can be changed by choosing the Set as project default box on this dialog or on the dialog box created by the main window DesignKit > Setup Project menu. (For details, refer to the section, “Creating a Project” on page 2-1)

7. Click OK. The design name is reflected in the title bar of the window.
Managing Projects and Designs

Using a Template

Several simulation templates are provided as a convenience to help you create designs more quickly. You can turn any of your own designs into a template using the Save Design As Template command.

To start a new design with an existing template:

Choose File > New Design, select a template from the list, and click OK.

To add an existing template to an existing design:

Choose Insert > Template, select a template from the list, and click OK.

To create a new design for use as a template:

1. Create the design just as you would any other design.
2. Choose File > Save Design As Template. (The program automatically adds the extension .tpl to your filename.) The design is saved to your local templates directory and will now appear in the list of available templates (File > New Design and Insert > Template) when you choose to use one.

To modify a supplied template or one you have created:

1. Choose Insert > Template, select that template from the list, and click OK.
2. Make the desired changes and choose File > Save Design As Template.

Note To associate an AEL macro file with a template, give it the same name as the template file, add underscore tpl (_tpl), and an .ael extension. Example: For a template filename of my_amp.tpl, name the AEL macro file my_amp_tpl.ael. Place this file in home/ hpeesof/ circuit/ templates (or home/ hpeesof/ adsptolemy/ templates), along with the template file, and it will be loaded when you insert the template in another design.

Saving a Design File

There are three commands related to saving files: Save Design, Save Design As, and Save Design As Template.

- The Save Design command enables you to save changes to an existing file. (If you choose Save in an untitled window, the Save Design As dialog box appears.)
• The Save Design As command enables you to save an existing file with a new name. For example, to make a copy of an existing design so that you can edit it while preserving the original, use the Save Design As command to create a copy of the file with another name.

• Use the Save Design As Template command to save a design, at any stage, for use as a template. (Select a template for use through File > New Design or Insert > Template.) The program automatically adds the extension .tpl to your filename.

If you have made changes to a design and want to discard those changes, but continue working with the previously saved version of the design, choose File > Revert to Saved Design.

To save changes to an existing file:
Choose File > Save Design. If the file was previously saved (it resides on the disk), a dialog box appears.

• If you want to overwrite the old version with the new version, click Yes.

• If you do not want to overwrite the old version, click No and use the Save Design As command to save the design to another name.

To save an existing file with a new name, or to save a new file you have not yet named:
1. Choose File > Save Design As and a dialog box appears prompting you for a New File Name.
2. Enter a name for the design and click OK. The file is saved and automatically assigned an extension, which varies depending on the window (Schematic/Layout uses .dsn; Data Display uses .dds).

Note The Save Design As command names or renames all files associated with the design (.dsn, .ael, etc.) and is therefore the preferred method for saving a design to a new name. Therefore we recommend you use the design environment for all file management operations.

Saving All Designs in Memory
To save any designs currently in memory, including data displays, that have not been saved since changes were made:
Managing Projects and Designs

In the Main window, choose **File > Save All.**

**Opening an Existing Design**

**Note** Starting with ADS2003C, you can open Analog/RF designs from subsequent versions of ADS. However, you cannot open Signal Processing designs from subsequent versions.

When opening an Analog/RF design from a subsequent version of ADS:

1. If a design from the subsequent version of ADS contains any instances of components that were modified, the system displays a warning dialog box with a list of modified instances, including a list of which parameters were updated.

2. If the design from the subsequent version of ADS contains instances of components that do not exist in the current version of ADS, the system fails to find the component definitions for those components. You must delete those instances or replace them with alternative components.

There are several ways to open existing designs:

- Double-click it in the Main window (from the Design Information pane)
- Double-click it from the Design Hierarchy dialog box (**View > Design Hierarchies**)
- Use the **File > Open Design** command in the appropriate design window
- If it is one of the last four designs opened, it appears on the file list at the bottom of the File menu and you can click there to open it
- If the design is currently open (in memory), it appears on the list at the bottom of the Window menu and you can click there to open it. You can also open it using the Designs Open command (on the Window menu).

To open an existing design from the browser in the Main window:

1. In the File Browser pane, click once to expand the networks directory and a list of all designs in that directory appears.

2. Double-click to select a design name. If the design is hierarchical, the hierarchy is listed under Design Information on the right side of the window; if the design
is not hierarchical, its complete path and name appear under Design Information.

3. Double-click the design name from the right pane to open it.

To open an existing design from the File menu in a design window:

1. Choose **File > Open Design** and a dialog box appears.

   By default, the files displayed in this dialog box are located in the current project directory and have a `.dsn` extension.

2. Select the design you want to open from the Files list box, and click **OK**. The design appears in the window.

---

**Important** To make a complete set of files for a design in another project directory, use the **File > Copy Design** command in the Main window.

---

To view a design currently open (in memory) from the Window menu:
Choose **Window** (in the Schematic or Layout window) and select the design of interest from:

- The list of files at the bottom of the Window menu
  - or
- The dialog box that appears when you choose **Designs Open**

Note that when the number of designs in memory exceeds the number of designs displayed at the bottom of the Window menu, an additional menu choice, **More**, appears. Choose **More** to see a complete list of designs in memory.

---

**Hint** The number of designs displayed on the Window menu (by default, nine) can be customized by setting the variable `DESIGN_LIST_COUNT` equal to the desired value. For details, refer to Chapter 1, Customizing the ADS Environment, in the **Customization** manual.
Copying a Design

The Copy Design command copies all files associated with the design and is therefore the preferred method for copying designs.

**Note**  Copying designs should only be done through the program, as described here. Copying designs outside the program may result in invalid designs.

To copy a design:

1. Choose File > **Copy Design** and click **Browse** (From Design).
2. Change directories as needed to locate the directory containing the design you want to copy.
3. Select the design and click **OK**.
4. Click **Browse** (To Path) and change directories as needed to specify the path for the copied design. Click **OK**.
5. Supply a name, following the path, for the copied design.
6. If the design is hierarchical, and you want to preserve the design in its entirety, select the Copy Design Hierarchy option.
7. When the From and To fields in the Copy Design dialog box reflect the appropriate paths and filenames, click **OK**.
Deleting a Design

To delete a design:

1. Choose File > Delete Design and a dialog box appears. By default, all .dsn files in the current project are listed.

   Note  Deleting designs should only be done through the program, as described here.

2. Change directories as needed to locate the project containing the designs/files you want to delete.

3. Change the File Type as needed to locate the designs/files you want to delete. You can select a different file type from the drop-down list, or type a file extension and press Enter or click Filter.

4. Select the design/file you want to delete and click Apply (or OK if this is the only file you want to delete). You are prompted to confirm you want to delete that file. Click Yes to delete it; click No to keep it.

   Important  If you delete a design that serves as a subnetwork in other designs, remember to delete all occurrences of that subnetwork in those designs.

Clearing a Design from Memory

Every design you open is stored in memory until you explicitly clear it from memory or exit the program. There are two ways to clear designs from memory: Close Design, Delete All. This distinction enables you to clear an entire design (both schematic and layout information, which are stored in the same file) from memory, or clear only schematic information or only layout information from memory.

- Close Design—File menu—clears the entire design file from memory

   If any unsaved changes are detected, you are prompted, Design not saved, clear anyway?
   - If you want to clear the design without saving, click Yes.
Managing Projects and Designs

- If you do not want to clear the design without saving, click No, and then select Save Design from the File menu.
- Delete All—Edit menu—clears the current schematic information, if issued from the Schematic window, or the layout information, if issued from the Layout window.

**Hint**  As with other commands found on the Edit menu, the Undo command works on Delete All.

**Clearing All Designs from Memory**

To clear all designs, including data displays, currently in memory:

In the Main window, choose **File > Close All**.

If any files with unsaved changes exist, a dialog box appears listing one of the files and offering the following choices:

- Yes—Saves changes to the named file and prompts you individually for any additional files with unsaved changes
- No—Discards changes to the named file and prompts you individually for any additional files with unsaved changes
- Yes To All—Saves changes to all files without prompting you for each one
- No To All—Discards changes to all files without prompting you for each one
- Cancel—Stops the Close All command
Chapter 3: Creating Designs

This chapter describes creating designs in the Advanced Design System environment. The starting point of this chapter assumes you have started the program, as described in Chapter 1, Program Basics, and that you are familiar with the project directory concept and design file management, as described in Chapter 2, Managing Projects and Designs.

Although you can perform a wide variety of editing operations on your design as you create it or once the design is complete, you can set numerous options before you begin your design work to minimize the need for editing. These options can be set through the Preferences dialog box (Options > Preferences) from a design window. For more information refer to Setting Design Environment Preferences in the Customization manual.

For details on adding a drawing sheet to the design window, refer to the section, "Adding a Drawing Sheet" on page 7-1.
Defining Units for a Design

The design environment uses Units in a number of ways, differentiated as follows:

- **Layout Units**—the unit used for grid and snap features in the drawing area of the Layout window (Options > Preferences > Layout Units)

  *Note* The unit used for grid and snap features in the drawing area of the Schematic window is inches, and cannot be changed. When you see choices in various dialog boxes for screen pixels or schem units, the schem units are inches.

- **Length Unit**—the unit of measure for parameters with physical length in both the Schematic and Layout windows, and by default, the Layout Units of the Layout window

  When you create a project directory, you choose the Length Unit to be used as a default for all designs in that project. When working with the Layout option, we recommend keeping the Length Unit and the Layout Units the same, thus the Length Unit serves both purposes, by default.

  *Note* You can choose a different Length Unit for an individual design (Options > Preferences > Units/Scale) but a change made in this manner exists only in memory unless you save the preferences to a file. For details, refer to Saving and Reading Preference Files in the Customization manual.

- **Units/Scale**—The scale factors shown in the Units/Scale tab of the Preferences dialog box serves as defaults in a limited number of situations. For details refer to the section, “Units/Scale Factors” on page 3-21.
Placing Components

You create designs by placing items (such as, components, data items, measurements, sources, simulation controls, etc.) in a design window. There are several ways to access these items:

- Browsing—in the Component Library window
- Searching—in the Component Library window
- Component Palette—on the left side of the design window
- Component History—on the toolbar or as a dialog box
- Hot Keys—once you have added components to the Component submenu

Although there are several methods of access, the basic steps for placing a component are the same.

To place a component in the design window:

1. Locate and click to select the component.
2. Move the pointer into the drawing area and click the orientation button to rotate the symbol as necessary.
3. Click to place the symbol in the desired location.

Note: If you click more than once, in a single spot in a design, ADS will cycle through selecting items that are selectable from the original clicked spot. Once you click away from that spot, cycle select will stop.

Browsing for Components

You can view the components that make up any individual library by selecting the library name in the Component Library window. The libraries listed vary with the current design type—Analog/RF versus. Digital Signal Processing.

In the following figure, the left side shows the top-level libraries (for the Analog/RF design type) collapsed; the right side shows a partial listing of the Analog/RF sub-libraries as it appears expanded.
Creating Designs

To browse for a component:

1. From any design window, click the Library button on the toolbar (or choose Insert > Component > Component Library).

2. Click the plus sign in front of a library name to expand it and view its sub-libraries.

In addition to these libraries, a library named Frequently Used Components is filled, as you work, with the components you place, enabling you to quickly place additional instances of those components. Note that the Frequently Used Components library is project-specific; the library that is created in any given project directory will remain until you explicitly clear it.

The Subnetworks library provides access to all the designs in the current project for use as subnetworks in other designs in that project. (To enable access to designs in other projects, create a hierarchical project as described in the section “Creating a Hierarchical Project” on page 2-11.)

3. Select a sub-library and its components are displayed in the Components section of the window. By default, a brief description for each component is also displayed.
Additional component information is available once you select a library. For details, refer to the section, “Customizing the Component Library Display” on page 3-8.

To place components from any library:

1. Select the library to display the list of components.
2. Select the component you want to place, move the pointer into the drawing area, and click to place it.

**Hint** To clear the current list of frequently used components, select the Frequently Used Components library and choose Edit > **Clear Frequently Used Components**.
Creating Designs

Searching for Components

You can search for a component (or group of components with something in common) based upon text that is part of the component name or description.

To search for a component:

1. From any design window, click the Library button on the toolbar (or choose Insert > Component > Component Library).
2. In the Component Library window, choose Tools > Find.
3. Type the word or phrase you want to search for.

Note Only the library currently highlighted in the Libraries pane will be searched. By default, All libraries are searched. To narrow the search, select a specific library or sub-library. Your choice is reflected in the Look in field.

When the search is complete, the components and/or descriptions matching the search criteria are displayed.

The following figure shows the results of a search for the word pulse in all libraries.
To limit your initial search using case sensitivity:

1. Select the **Case Sensitive** option.

2. Type the search text matching the case of the component name(s) as it appears in the program.

Example: The component you are looking for contains the word BEND, as part of its name, in uppercase and you want to search for all components that include BEND as part of their name, but exclude components whose descriptions contain the word Bend (mixed case).

To perform a secondary search on your initial search results to view some subset of those results:

1. Select the **Refine Search** option.

2. Change the search text in the Find field as needed and click **Apply**. The initial results are searched for anything meeting the revised search criteria.

Example: Initiate a search through all libraries on the word amplifier. As you scan the resulting list, you notice several amplifiers with drain current of 17 mA scattered throughout. To view only those amplifiers, type id=17ma in the Find field, select the Refine Search option, and click Apply. The resulting subset of amplifiers is displayed.
Creating Designs

Customizing the Component Library Display

Several features are provided to enable you to customize the Component Library display. You can:

- Collapse/expand the display of libraries and sub-libraries to minimize scrolling
- Add new libraries
- Rearrange the libraries and sub-libraries using Cut, Copy, and Paste
- Show or hide the display of several types of component information
- Set defaults for the widths of the various component information displays
- Alphabetically sort the display of libraries and components

Once you customize the display to meet your needs, you can save the settings to file and use those settings in any subsequent session. For details refer to, “Saving Customized Library Displays” on page 3-12.

**Note**  Several aspects of the browser display can be set for all projects (user) or on a site-wide basis. For details, refer to the hpeosofbrowser.cfg file described in Chapter 1, Customizing the ADS Environment, of the Customization and Configuration manual.

To expand a library so that its sub-libraries are displayed:

Click the plus sign in front of the library name. To collapse the library, click the minus sign.

The expanding and collapsing of libraries can also be accomplished via toolbar buttons or the View menu (View > Libraries).
• Expand Libraries—Expands the view of all top-level libraries
• Collapse Libraries—Collapses the view of all top-level libraries
• Expand Selected Library—Expands the view of the currently selected library
• Collapse Selected Library—Collapses the view of the currently selected library

To add a new library:
2. Supply a library name and click Apply (or OK if only creating one library at this time). The new library is added to the bottom of the current list of libraries.

To add a new sub-library:
2. Select from the drop-down list the library you want the new sub-library to be part of.
3. Supply a sub-library name and click Apply (or OK if only creating one sub-library at this time). The new sub-library is added to the bottom of the current list of sub-libraries.
Creating Designs

Rearranging Libraries

You can rearrange and delete libraries to make the library display better meet your design needs:

- Use Cut and Paste to rearrange the order of libraries—relative to other libraries, or the order of sub-libraries—relative to other sub-libraries. (Use Copy and Paste to copy a sub-library to another location).
  
  You can also turn a sub-library into a library by pasting it at the library level—highlight All and paste.

- Use Cut to delete libraries (or sub-libraries) you do not use for a specific project or are not licensed for, to help minimize scrolling.

Note that when you paste, the affected library or sub-library is pasted at the bottom of the list. Once you make your changes, you need to save your customized views. (“Saving Customized Library Displays” on page 3-12.)

To rearrange or delete libraries using Cut/Copy/Paste:

1. Highlight the library you want to move (or delete) and choose Edit > Cut.

2. To paste it at the bottom of the list of All libraries, highlight All and choose Edit > Paste.

To rearrange sub-libraries using Cut/Copy/Paste:

1. Highlight the sub-library you want to move, copy, or delete.

   Note  Sub-libraries cannot be pasted within another sub-library.

2. Choose Edit > Cut (or Copy), and:

   • To paste the sub-library at the bottom of an existing library, highlight that library.
   
   • To paste the sub-library as a library (at the bottom of the list of all libraries), highlight All.

3. Choose Edit > Paste.
Setting Display Preferences

Several aspects of the Component Library display can be customized through Options > Preferences.

Component Tree Width

To modify the width of the tree in the Library pane:

Enter the desired value (in characters). Note that the change will not take effect until your next session of ADS.

Field Width

To set default widths (in characters) for the columns of component information:

In the Field Width section, set each field as desired. Note that these settings serve as defaults, but the columns can be resized manually by dragging the cell border one direction or the other. Setting the Field Width has no effect if the column status is hidden (deselected). To make it visible, select it in the Show Columns section of the dialog box.

Show Columns

The Component column is always visible. The Description column is the only optional column that is visible by default.

To show or hide optional columns of component information:

1. In the Show Columns section select or deselect any of the following:
   - Vendor—Displays the name of the manufacturer for the vendor parts in the selected sub-library.
   - Description—Provides a brief description of each component.
   - Library Name—Lists the name of the library for each component listed. This can be helpful if you find a component by searching, and want to know which library it is from.
   - Placement Status—Identifies for each component listed whether or not it is used in layout
   - Availability (Available/Obsolete)—Reserved for future use.
   - Web-site Address—Reserved for future use.
   - License Information—Reserved for future use.
Creating Designs

2. Click **Apply**.

**Show Components**

To change the Show/Hide status of obsolete or unlicensed components:

1. In the Show Components section of the dialog box, set these options as desired:
   - Hide Obsolete Components
   - Hide Unlicensed Components
2. Click **Apply**.

**Sorting Libraries and Components**

To alphabetically sort the list of libraries:

1. Highlight any library under **All**.
2. In the Library Sort section of the Preferences dialog box, select the desired sorting method—Ascending or Descending (Unsorted is the default state) and click **Apply**.

To alphabetically sort the list of components for a specific sub-library:

1. Highlight the sub-library whose components you want to sort.
2. In the Component Sort section of the Preferences dialog box, select the desired sorting method—Ascending or Descending (Unsorted is the default state) and click **Apply**.

**Saving Customized Library Displays**

When you first open the Component Library—in any given session of ADS—the view of libraries is the Default view. This is the complete set of libraries as shipped. Changes you make to this view will persist during the current session, however, the next time you restart ADS, the Default view is restored. You can save any number of customized views and restore them later. By default, customized view files are saved to the current project directory, but you can save them in and restore them from any other project directory.
To save a customized view in the component library:

Choose View > Save View As. Supply a filename and click Save.

To open a previously saved customized view:

Choose View > Open View. Select the filename of the view you want to restore and click Open.

To close any currently open customized view:

Choose View > Close View. If no other customized views are open, the Default view is restored.

**Resetting and Updating the Library Display**

If during any given session, you cut libraries from the Default view and you want to restore them (without exiting and restarting ADS), you can do so with the Reset/Update command. This command will also update the library display with any libraries that were created through AEL.

To restore libraries cut from the Default view and/or update the display with new libraries:

Choose View > Reset/Update.

**Note** Some additional information is available for libraries and components through the Edit menu (Library Properties and Component Properties). These features will be enhanced in a future release.
Creating Designs

Using the Component Palette

The palette, on the left side of each design window, is a quick method of placing components if you know the name of the library containing the component. To change the library of components on the palette, select a new one from the drop-down Palette List.

Hint  You can also bring the palette selection list up as a dialog box by selecting View > Component > Select Component Palette. Leave it on the screen if you want to change the palette frequently.

To use the Palette to place items:

1. Display the desired library on the palette by selecting it from the drop-down list (in this example, TLines-Printed Circuit Board).

2. If necessary, scroll the new palette to locate the button representing the component you want to place.
Using Component History

As you place components in your design, a history of these components is created. This dynamically created history enables you to quickly place additional instances of components placed in the current session.

**Hint**  This history serves as the starting point for creating a custom component palette. For details refer to, Creating a Custom Component Palette in the Customization manual.

To place items from Component History:

1. Click to access the drop-down Component History list or bring up the dialog box (View > Component > Component History).

2. If necessary, scroll the list to locate the component you want to place.

**Hint**  Once vendor components are placed, they are part of Component History which can be used to create a custom palette containing these vendor parts.
Creating Designs

Using Hot Keys to Place Components

You can place frequently used components via hot keys, by adding them to the Component submenu (Insert > Component) and then assigning hot keys to them. Components added to the menu in this manner apply to all projects. Customization of this Component menu is done separately for the Schematic and Layout windows.

To add components to the Component submenu:

1. Choose Tools > Hot Key/Toolbar Configuration and in the dialog box that appears, select the Component Menu/Hot Key tab.
2. Select the components you want to add to the Component submenu from any of the following lists:
   - Available Components displays all the components contained in the current design.
   - Select any of the standard component libraries from the drop-down list.
   - Select History (for a list of components placed in the current session) or Selected Design Components (for a list of all currently selected components in the active design).

   **Hint** You can use the PC method of Shift+click to select a contiguous group of components, or Ctrl+click to select components that are not contiguous.

3. Click Add to add the selected component(s) to the Component Menu/Hot Key list box.

Alternatively, you can select one or more components currently placed in the drawing area of the desired (Schematic or Layout) window and choose Insert > Component > Add Selected to Component Menu. All selected components are added to the Component submenu.

To create hot keys for the menu-based components:

1. Choose Tools > Hot Key/Toolbar Configuration and in the dialog box that appears, select the Component Menu/Hot Key tab.
2. Select a component from the Component Menu/Hot Key list box.
3. Select the modifier key(s)—Ctrl, Alt, Shift—and type the letter(s) you want to use in the Key field (UNIX is case-sensitive; the PC is not). If the combination
you choose is currently assigned to another command sequence or component, you are warned and given the choice to proceed or to select another key sequence.

**Note** If you use Alt as the modifier key, and a letter that is already assigned as an accelerator for a menu (see the underscored letters on the menu bar), the menu accelerator is replaced by your custom shortcut (with no warning).

4. Click **Apply**. The shortcut appears next to the component.

5. Repeat as needed for each component.

To remove components from the Component submenu:

1. Choose **Tools > Hot Key/Toolbar Configuration**.

2. In the dialog box that appears, select the **Component Menu/Hot Key** tab.

3. Select any component you want to delete from the Component submenu and click **Delete**. (To delete all but the standard components—Port, GROUND, VAR—click **Delete All**.)

**Hint** To remove a shortcut for a given component, select that component and deselect the modifier key(s) and erase the letter(s), then click **Apply**.
Creating Designs

**Placing Components at Specific Coordinates**

The Coordinate Entry command enables you to place a component at specific coordinates using Cartesian or Polar coordinates specified in absolute or relative numbers.

To use the coordinate entry method for placing components:

1. Choose **Insert > Coordinate Entry** and a dialog box appears. Move the dialog box so that the desired design window is visible.
2. Select the component you want to place.
3. Select the desired orientation for this component.
4. Select the coordinate type: Cartesian or Polar and Absolute or Relative.
5. Enter the desired X and Y coordinates by typing them in the fields labeled **X** and **Y**. The coordinate values you enter are plotted in the Coordinate Plotted field.
6. Click **Apply** and the component appears in the drawing area at the specified location.

**Note** Coordinate entry will modify the coordinates entered according to the current snapping rules. You may want to turn snapping off when using coordinate entry. To access snapping, use the tool bar button labeled **Toggle Snap Enabled Mode**.
Rotating Components

You can specify the orientation, or rotation, of components in a number of ways. To change the orientation during or after placing it in the drawing area, use any of the following methods.

- Click the **Rotate By Increment** button on the toolbar.
- Press **Ctrl+r**.
- Choose **Edit > Rotate**.

Each of these actions rotates the component $n$ degrees clockwise, where $n$ is the increment specified in **Options > Preferences > Entry/Edit > Rotation Increment (angle)**. The default is 90 degrees.

In addition to the above methods of rotation, you can rotate a component during the insertion process using any of the following commands:

- Choose **Insert > Component > Set Component Orientation UP**
- Choose **Insert > Component > Set Component Orientation DOWN**
- Choose **Insert > Component > Set Component Orientation LEFT**
- Choose **Insert > Component > Set Component Orientation RIGHT**

These directions refer to the direction the symbol is drawn relative to pin 1.

**Hint** Place these individual commands on the toolbar to have individual toolbar buttons for each orientation. For details refer to Configuring Toolbars in the **Customization** book.
Defining Parameters

As you place components in the drawing area, you will notice that some parameters have default values and that other parameters are followed by an equal sign (=) and nothing else. The lone equal sign indicates that a default value is defined elsewhere for this parameter. Some of these parameter values are defined by the simulator, while others are defined in various Simulation Control items. For details on where the default value is defined and to review the guidelines for choosing other values for that parameter, refer to the Circuit Components manual or the Signal Processing Components manual.

Note The at symbol (@) must be used to suppress quotes when specifying a variable as a parameter value, for example, use @freq1, where freq1 is a variable declared in a VAR item.

You can change parameter values using the on-screen editor or through the Component Parameters dialog box. To display the Component Parameters dialog box for editing parameters after placing components:

- Position the pointer over the component you want to edit and double-click
- or
- Select the component and choose Edit > Component > Edit Component Parameters

Alternatively, you can specify parameters for each component as you create your design. By default, the option controlling the automatic display of the Component Parameters dialog box is turned off (in the Schematic window). To display the dialog box automatically when you select a component, select the option Show Component Parameter Dialog Box through Options > Preferences > Placement.

Hint To keep the dialog box on your screen for editing parameters of many components, use the Apply button to effect changes for each component.

For details on the Component Parameters dialog box and using the on-screen editor, refer to “Editing Component Parameters” on page 6-3.
Units/Scale Factors

The fundamental units for ADS are shown in Table 3-1. An ADS parameter with a given dimension is evaluated based on the corresponding units. For example, for a resistance \( R = 10 \), 10 is assumed to be 10 Ohms.

Table 3-1. Fundamental units in ADS

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Fundamental unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frequency</td>
<td>Hertz</td>
</tr>
<tr>
<td>Resistance</td>
<td>Ohms</td>
</tr>
<tr>
<td>Conductance</td>
<td>Siemens</td>
</tr>
<tr>
<td>Capacitance</td>
<td>Farads</td>
</tr>
<tr>
<td>Inductance</td>
<td>Henries</td>
</tr>
<tr>
<td>Length</td>
<td>meters</td>
</tr>
<tr>
<td>Time</td>
<td>seconds</td>
</tr>
<tr>
<td>Voltage</td>
<td>Volts</td>
</tr>
<tr>
<td>Current</td>
<td>Amperes</td>
</tr>
<tr>
<td>Power</td>
<td>Watts</td>
</tr>
<tr>
<td>Distance</td>
<td>meters</td>
</tr>
<tr>
<td>Temperature</td>
<td>Celsius</td>
</tr>
</tbody>
</table>

Variations on these fundamental units are referred to as scale factors. A scale factor is a single word/abbreviation that begins with a letter or an underscore character (_). The remaining characters, if any, consist of letters, digits, and underscores. The value of a given scale factor is resolved using the following rules, in the order shown:

1. If the scale factor exactly matches one of the predefined scale-factor words (see Table 3-2), then use its numerical equivalent
   
   else

2. If a scale factor exactly matches one of the scale-factor units (see Table 3-3) with the exception of \( m \), then use its numerical equivalent
   
   else

3. If the first character of the scale factor is one of the scale-factor prefixes (see Table 3-4), then use its numerical equivalent
else

4. The scale factor is not recognized. When ADS does not recognize a scale factor it issues a warning and uses a scale-factor value of 1.0.

Table 3-2 lists the ADS scale-factor words and their numerical equivalents.

<table>
<thead>
<tr>
<th>Scale Factor Words</th>
<th>Numerical Equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>mil</td>
<td>2.54e-5</td>
</tr>
<tr>
<td>mils</td>
<td>2.54e-5</td>
</tr>
<tr>
<td>cm</td>
<td>1.0e-2</td>
</tr>
<tr>
<td>in</td>
<td>2.54e-2</td>
</tr>
<tr>
<td>ft</td>
<td>12*2.54e-2</td>
</tr>
<tr>
<td>mi</td>
<td>5280<em>12</em>2.54e-2</td>
</tr>
<tr>
<td>nmi</td>
<td>1852</td>
</tr>
<tr>
<td>PHz</td>
<td>1.0e15</td>
</tr>
<tr>
<td>dB</td>
<td>1.0</td>
</tr>
</tbody>
</table>

Table 3-3 lists the ADS scale-factor units and their numerical equivalents.

<table>
<thead>
<tr>
<th>Scale Factor Unit</th>
<th>Meaning</th>
<th>Numerical Equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Amperes</td>
<td>1.0</td>
</tr>
<tr>
<td>F</td>
<td>Farads</td>
<td>1.0</td>
</tr>
<tr>
<td>H</td>
<td>Henries</td>
<td>1.0</td>
</tr>
<tr>
<td>Hz</td>
<td>Hertz</td>
<td>1.0</td>
</tr>
<tr>
<td>meter</td>
<td>meters</td>
<td>1.0</td>
</tr>
<tr>
<td>metres</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ohm</td>
<td>Ohms</td>
<td>1.0</td>
</tr>
<tr>
<td>Ohms</td>
<td></td>
<td></td>
</tr>
<tr>
<td>S</td>
<td>Siemens</td>
<td>1.0</td>
</tr>
</tbody>
</table>
Table 3-4 lists the ADS scale-factor prefixes and their numerical equivalents.

Table 3-4. ADS scale-factor prefixes

<table>
<thead>
<tr>
<th>Scale Factor Prefixes</th>
<th>Meaning</th>
<th>Numerical Equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>a</td>
<td>atto</td>
<td>1e-18</td>
</tr>
<tr>
<td>f</td>
<td>femto</td>
<td>1e-15</td>
</tr>
<tr>
<td>p</td>
<td>pico</td>
<td>1e-12</td>
</tr>
<tr>
<td>n</td>
<td>nano</td>
<td>1e-9</td>
</tr>
<tr>
<td>u</td>
<td>micro</td>
<td>1e-6</td>
</tr>
<tr>
<td>m</td>
<td>milli</td>
<td>1e-3</td>
</tr>
<tr>
<td>_ (underscore)</td>
<td>no scale</td>
<td>1</td>
</tr>
<tr>
<td>k, K</td>
<td>kilo</td>
<td>1e3</td>
</tr>
<tr>
<td>M</td>
<td>Mega</td>
<td>1e6</td>
</tr>
<tr>
<td>G</td>
<td>Giga</td>
<td>1e9</td>
</tr>
<tr>
<td>T</td>
<td>Tera</td>
<td>1e12</td>
</tr>
</tbody>
</table>

Notes:

- Scale factors are case sensitive. Note the different meanings for f and F, and a and A in the preceding tables.
- The imperial units (mils, in, ft, mi, nmi) do not accept prefixes.
- Scale factors can be used anywhere in an expression (e.g., 1 GHz + 1 MHz).

When you select a parameter—with which a fundamental unit is associated—in the Component Parameter dialog box, a drop-down list appears containing all available scale factors for that particular parameter.
Table 3-5 lists the available scale factors for parameters with which a fundamental unit is associated.

<table>
<thead>
<tr>
<th>Table 3-5. Available scale factors</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Frequency</strong></td>
</tr>
<tr>
<td><strong>Resistance</strong></td>
</tr>
<tr>
<td><strong>Conductance</strong></td>
</tr>
<tr>
<td><strong>Capacitance</strong></td>
</tr>
<tr>
<td><strong>Inductance</strong></td>
</tr>
<tr>
<td><strong>Voltage</strong></td>
</tr>
<tr>
<td><strong>Current</strong></td>
</tr>
<tr>
<td><strong>Time</strong></td>
</tr>
<tr>
<td><strong>Length</strong></td>
</tr>
<tr>
<td><strong>Distance</strong></td>
</tr>
<tr>
<td><strong>Power</strong></td>
</tr>
</tbody>
</table>
Notes:

- The option none means no scale factor is applied to the value.
- Although dBm and dBW appear on the drop-down lists, they are not valid scale factors; built-in functions convert these values to Watts and Celsius.
- There is no scale-factor option for temperature.

This same set of scale factors (with the exception of none) appears in the Preferences dialog box (Options > Preferences > Units/Scale). Note that these default settings are only used in the following situations:

- When a parameter of a supplied component does not have a default unit and you do not assign one (in the component parameter dialog box)
- When you supply a default parameter value without units while creating a parametric subnetwork (File > Design Parameters)

**Hint** You will see both Length and Distance scale factors in the Preferences dialog box. Length typically applies to parameters such as transmission line length, and Distance is a much larger scale factor that applies to things like antenna path length.
Measuring Distance and Angle

The Measure command produces a dialog box that displays the cumulative distance between points you specify in the design window. In addition, it displays the angle from the first point to the current point.

To use the Measure command:

1. Choose Measure from the Insert menu or the pop-up menu and a dialog box appears.
2. Click on the desired points in the design window and observe the information displayed in the dialog box.
   • To clear the information but keep the command active, click Clear or double click in the design window.
   • To stop the command and dismiss the dialog box, click Cancel.

Note  The Clear command can also be activated by pressing the space bar.

Connecting Components

When you place a component in the design area, you will notice that each of the pins is highlighted by a diamond-shaped outline. This shape identifies unconnected pins, and disappears when a connection is made.

There are three ways to connect components:
   • Directly, pin-to-pin
   • With wires
• Without wires (with names)

Hint When a connection is made, the pin color changes to the color designated as the Connected Pin color (Options > Preferences > Pins/Tees). The color of the pin and the diamond-shaped outline prior to connection is the color designated as the Highlight color (Options > Preferences > Display).

Connecting Components Directly
To connect components directly:

1. Select the desired rotation for the component you are about to connect.
2. Position the pointer directly over the pin of the component you are connecting to, and click.

Connecting Components with Wires
To connect components with wires:

1. Click the Insert Wire button or choose Wire from the Insert menu. You are prompted to enter the starting point.
2. Position the pointer at the desired location and click. You are prompted to enter the next point.
3. Position the pointer at the desired location and click. A wire is drawn between the specified points.

Tips:

• To specify an endpoint of an unconnected wire, double-click or press the space bar.

• To move an unconnected endpoint of a wire, use Edit > Move > Move Wire Endpoint.

• Wires are always routed on the grid unless items connected to them were placed or moved off the grid. In this case, the shortest wire segment needed to make the connection is drawn off the grid as required. This means the maximum number of wires that connect to a single point is four.
This is especially important to understand when using multiple input components (such as Add and Mpy) in Signal Processing designs, because to connect more than four wires to the input, you will need to connect additional wires to one of the existing wires rather than to the input pin itself.

- Context-sensitive editing is available for wires with respect to changing the layer on which the wire is drawn. Position the pointer over the wire, right click, and select Wire Layer from the pop-up menu.
- If moving a component causes wires to be rerouted incorrectly, undo the move, deselect the reroute entire wire option (Options > Reroute entire wire attached to moved component), and try the move again.

If the wire is still rerouted incorrectly, undo the move, disconnect the wire (Edit > Move > Move and Disconnect), move the component, and reroute the wire manually.

**Connecting Components Without Wires**

Connecting components without wires is accomplished by adding wire labels. Adding wire labels to your schematic enables you to:

- Indicate connectivity without wires. Two or more pins in the same network, with the same wire label, are connected as if they were wired.
- Identify node voltages—in an Analog/RF network—that you want output to the dataset after simulation. Note that if you assign a wire label to a pin that is connected to a wire, all pins connected to that wire will display that name.
- Create buses and bundles. For details, refer to the section that follows, “Creating Buses” on page 3-29.

For information on naming conventions, refer to “Naming Conventions” on page 1-20.

**Hint** Using the same node name in nodes across subnetworks does not result in connectivity unless a Global Node data item is placed in the design declaring that node name global. A Global Node data item with the specified node name will connect all nodes with that name across all subnetworks. This is useful for distribution of signals such as supply voltages and clocks.

To connect without wires or identify a node voltage for output:
1. Choose Insert > Wire/Pin Label and a dialog box appears.

2. Enter a Name and click all pins you want to connect with this name. As you click each pin, the name you have supplied appears near the pin.
   To produce output from a single pin, assign a unique node name to that pin.

3. To name another node, supply a different name, and click each pin, as described above. To dismiss the dialog box, click Close.

4. To clear a node name:
   Choose Edit > Wire/Pin Label > Remove Wire/Pin Label.

5. Click each pin or wire whose name you want to remove.
   Alternatively, you can use the on-screen editor and the Backspace key.

   **NOTE** To clear a node name you may also select Insert > Wire/Pin Label, leaving the label field blank in the dialog box. Select a named node, and the node name will vanish.

### Creating Buses

Using buses and iterated instances can greatly simplify the schematic representation of your design. The following terms are used in describing how to create buses in ADS:

- **Net**—In the broadest sense, any connection between the pins of different electrical components
- **Bus**—A set of wires or a single wire carrying a set of signals. A bus is a kind of net or collection of nets where all members share the same base name (Data<1:4> ⇒ Data<1>, Data<2>, Data<3>, Data<4>).
- **Wire Label**—An identifying label used to name a net that enables referencing that net by name. A simple wire label (A) merely labels a wire for identification or connection purposes; a vectorized wire label (A<1:4>) identifies that wire as a bus and enables connection by tapping, using the base name and an index (A<2>). The vectors identify the bus width.
- **Bundle**—A collection of wires (or buses) that do not share the same base name (Data<1>, A, B).
Creating Designs

- Iterated Instance—A single instance on the schematic that represents multiple instances. To iterate an instance you modify the Instance Name to include a vectorized label (InstanceName<1:4>).

**Note**  See the example project, Examples/ Tutorials/ wire_bus_prj.

To represent a bus on an ADS schematic, add a vectorized wire label by supplying a base name and vectors that identify the bus width.

![Diagram](image1)

Add a vectorized wire label and it becomes a bus.

To tap the individual bus wires, use the bus base name and an index.

![Diagram](image2)

To iterate an instance (connected to the bus), modify the Instance Name by adding the vectorized portion of the bus wire label.

![Diagram](image3)

Add a vectorized label to the Instance Name.
In the following illustration, the bus and iterated instance on the right are equivalent to the four grounded sources connected to individual wires on the left.

The labels you use to identify the bus and everything connected to it must be added using the appropriate syntax. The terminology shown in the following illustration identifies the terms used to define this syntax.
Creating Designs

**Syntax:**

**Bus**

base name<start:stop>

Example: `InBus<1:4>`

or

base name<start:stop:increment> for an increment other than 1. Use this to create patterns such as `{2,4,6,8}` and `{1,3,5,7}`.

Example: `InBus<2:8:2>`

**Tapped Wires**

base name<index>

Example: `InBus<1>`

**Iterated Instance**

instance_name<start:stop>

where instance_name is the actual instance name you are using for this component, and the vector information tracks with the bus vectors, including an increment, where applicable.

Example: `SRC1<1:4>`

Note that pins and ports can be iterated in the same manner. For details refer to, "Bus Pins and Iterated Ports” on page 3-37.

---

**Important** Be sure to use the correct syntax for all related parts of a bus; syntax errors produce connectivity errors.
The following illustration is a simple example using input and output buses consisting of four wires each.

The basic steps to include this type of bus in your schematic are as follows:

• Designate the desired wire as a bus by adding a vectorized wire label, for example, InBus<1:4>.

• Label the tapped wires of the bus by using the same base name you used for the bus (in this example, InBus), and supplying an index to indicate which bus wire it is.

• Add vectors (in this example, <1:4>) to the instance name of the component connected to the bus (in this example, V_DC) to signify that it represents multiple instances or an iterated instance.
Notes:

- Occasionally the visual rendering of a bus wire might not appear as expected. But as long as it is named correctly, connectivity will be correct.

- Setting the value of a parameter of an iterated instance sets that parameter to that value for all instances created by the iteration.

- Iterated instances cannot be tuned, swept, or optimized directly. To perform any of these operations on an iterated instance, you must create an intermediate variable representing the parameter of interest. You can then set the instance parameter to this variable, and sweep/tune/optimizing the variable, indirectly sweeping/tuning/optimizing the instance parameter.

- It is not necessary to create a bus on the schematic that includes all of the array indices. The simulator will collect all bus references with the same base name into a single array (vector) with the required range of indices. For example a schematic with \texttt{A<0>, A<1>, A<2>, A<3> and A<4:15>} will create a vector \texttt{A<0:15>}.

- Negative indices are not allowed, although a negative increment is. You can effect a countdown using indices such as \texttt{A<4:1>} which contains the nets \texttt{A<4>, A<3>, A<2>, A<1>}, or use a negative increment if the increment is other than 1, such as \texttt{<8:2:-2>} which contains the nets \texttt{A<8>, A<6>, A<4>, A<2>}

- When choosing a bus base name, keep in mind that the name must adhere to the same rules as node names. For details, refer to “Naming Conventions” on page 1-20.
To create a bus or bundle:

1. Draw the wire and choose **Insert > Wire/Pin Label** and a dialog box appears.
   - Bus—Enter the bus base name using the appropriate syntax and click the wire that you want to designate as a bus.
   - Bundle—Enter the names of the wires (or buses) that should be part of the bundle and click the wire that you want to designate as a bundle.

2. The label appears and the rendering of the wire changes to a thicker line indicating that the wire now represents a bus/bundle. Click **Close**.

To tap wires off the bus:

1. Draw the bus tap wire, choose **Insert > Wire/Pin Label** and a dialog box appears.

2. Enter the bus base name and the index for the bus wire you want to tap, and click that wire. Increment the index in the dialog box as needed and click the next wire. Continue in the same manner until you have tapped all desired wires of the bus, then click **Close**.

To iterate an instance of a component/port or a symbol pin:

1. Double-click the instance or pin to display the dialog box for editing that item.

2. Add the appropriate iteration syntax to the instance name and click **OK**.

   For components and ports, you can add labels using the on-screen editor; for pins you must use the **Edit > Symbol Pin** dialog box (**View > Create/Edit Schematic Symbol**).

Wire labels can be edited in the following ways:

- To move a wire label—Position the pointer over the bus/bundle label you want to move. Press the left mouse button, drag the label (you will see a ghosted image) to the desired location, and release. Note that moving a label a very small amount is affected by whether the Snap Enabled option is on or off (Options menu toggle), and the size of the Drag and Move threshold option (**Options > Preferences > Entry/Edit**). You can also use **Edit > Move > Move Wire/Pin Label**.

- To set the color, size, and font of wire labels in advance—Use **Options > Preferences > Component Text/Wire Label**.
Creating Designs

- To change the color, size, and font of existing wire labels—Choose one of the following methods:
  - Use Edit > Wire/Pin Label > Wire/Pin Label Attributes
  - Double-click the wire label to display the dialog box
  - Right-click and select Wire/Pin Label Attributes from the pop-up menu
- To delete a wire label, use one of the following methods:
  - Invoke the on-screen editor and use the Backspace key (followed by Esc)
  - Choose Edit > Wire/Pin Label > Remove Wire Label and click the wire whose label you want to delete.
- To modify the label itself:
  - Double-click the wire to display the Wire/Pin Label dialog box

Creating Bundles

A bundle is a collection of wires or buses that do not share the same base name. To indicate a bundle on your schematic, add a wire label consisting of a list of the wire labels and/or buses to be included in the bundle, separated by commas.

Syntax:

<wire_label/bus>, <wire_label/bus>, ...

Any wire/bus in the bundle can be accessed by name. In the following example, if you want to access A<4:5>, you can name a net A<4:5>.

![Diagram of A<4:5> bundle]
Bus Pins and Iterated Ports

A bus pin enables you to connect a bus or bundle to it. If you generate a symbol for a design containing iterated ports, the symbol generator will create bus pins for you. If you create a custom symbol for a design containing iterated ports, you must explicitly assign an iteration to the symbol pins on your custom symbol. If you opt to use a supplied symbol for a design containing iterated ports, you must explicitly assign an iteration to the symbol pins on the supplied symbol. Note that you will be warned when you select a supplied symbol if the number of pins on the symbol does not match the number of (iterated) ports. Default symbols (which appear when you place an instance of a design with no symbol assigned to it) are not allowed because they do not contain iterated pins.

Creating a Bus Pin via Iterated Ports and a Generated Symbol

When you iterate one or more ports on your schematic (by modifying the Instance Name), then generate a symbol for it, the generated symbol is created with bus pins.

Creating a Bus Pin on a Custom Symbol

To explicitly create bus pins for a custom symbol representing a design containing iterated ports, modify the pin name (Edit > Symbol Pin), using the same syntax as for a bus or bundle (e.g., P1<1:4> or A,B) in symbol view (View > Create/Edit Schematic Symbol). The number of iterated ports in the schematic must always equal the number of symbol pins. This equivalence can be checked using Tools > Check Representation > Rep port vs Symbol port mismatch.
Creating Designs

**Buses in ADS Ptolemy**

ADS Ptolemy provides a different use model for buses, and there are two types: MultiPortHoles and the fixed-point data type (which uses components—not wires—for bus manipulations).

A MultiPortHole is an ordered set of PortHoles that can be expanded dynamically. A PortHole is equivalent to a pin in ADS. Pins that have double arrows are MultiPortHoles that initially have zero PortHoles. As each connection is made on the bus, a new PortHole is added to the MultiPortHole. Thus in this configuration, the MultiPortHole pin represents a bus input.

A MultiPortHole can also be expanded (using netlist syntax) to a predefined size. These MultiPortHoles are represented in the design environment as n separate pins where n is the number of PortHoles in the MultiPortHole. All of the current PortHoles and MultiPortHoles are directional, in contrast to the non-directional pins of analog components. The following illustration shows the ADS Ptolemy multiplier components.

A MultiPortHole that is represented as a double arrow is equivalent to a bus pin with unspecified size. To fix the size, add wire labels (in the schematic) just as you would for an Analog/RF design, generate a symbol for it, and place it as a subnetwork, as shown next.
Checking Connectivity

Although a number of operations automatically perform a connection check, you can explicitly test the bus-to-instance connections in a schematic through Tools > Check Representation > Bus Connectivity. The connection check attempts to resolve all bus-instance connections, and highlights (on the schematic) any connections it is unable to resolve. Connections that are part of a bus or bundle are verified using a set of rules. The following terms are used in describing these rules:

- **Connection Width**—The total number of pins at a given port of an iterated instance. Computed by multiplying the pin width at the port by the instance width.
- **Instance Width**—The number of instances in an iterated instance (I<0:3> represents 4 instances)
- **Net Width**—The number of individual wires in a bus/bundle (N<0:7> represents 8 wires)
- **Pin Width**—The number of pins at the given port of a component
Resolving Connections Related to Names

When a net includes both named and unnamed wire segments, the unnamed segments are considered to include every name that appears on all named segments. In other words, the name implicitly assigned to an unnamed segment is the intersection of all names on named segments.

In the following illustration, the segments 3, 5, and 7 are unnamed. A, B, C, D is the union of all names on this net, and this is the name that is used for all three unnamed segments.
In an unnamed net (one with no named wires at all):

- If all instances to which this wire network is connected have a connection width of N, then each wire in the network is given width N.

- If any instance to which this wire network is connected has a connection width of 1, then the entire wire network is given width 1. Instances with connection widths greater than 1 will be shorted together.

- If the instances to which this wire network are connected have mismatched connection widths, and none of them have a connection width of 1, then there is a connectivity error.
Creating Designs

Resolving Connections Related to Widths

To verify a connection, the net width of the bus is checked against the pin width of the component, the instance width, and the connection width (where the connection width represents the total number of pins: connection width = pin width * instance width).

ADS Ptolemy incorporates the concept of pins that can accept buses as inputs. These pins are of arbitrary size and are annotated by double arrows on the pin stem. For the ADS Ptolemy MultiPortHole examples:

- Wires without names—connected to MultiPortHole pins—have unspecified width.
- MultiPortHoles without a pin width have an unspecified pin width.
- Instances without an explicit width have an instance width of 1 (in other words, the instance width can never be unspecified because it defaults to 1).

In the following descriptions of how various connection types are resolved, some connection types apply only to Digital Signal Processing (DSP) designs while others apply to both Analog/RF (A/RF) and DSP designs:

- “Unspecified net width, multiple input or multiple output connections (DSP only)” on page 3-43
- “Unspecified input or output pin width, specified net width (DSP only)” on page 3-45
- “Unspecified pin width, unspecified net width, specified instance width” on page 3-45
- “Unspecified net width, pin width specified, instance width specified” on page 3-45
- “Net width = connection width” on page 3-46
- “Net width = pin width” on page 3-47
- “Net width = 1” on page 3-47

If none of the conditions above apply, then the connection is not valid, and will be flagged as an error. When an invalid connection is found during connection checking, that invalid connection will be highlighted on the schematic.
Unspecified net width, multiple input or multiple output connections (DSP only)

ADS Ptolemy currently supports this connection type for instance widths equal to one. Only the following two cases are supported: multiple outputs feeding a multiport input and a single output feeding multiple inputs.

- Multiple outputs feeding a multiport input
  - Net width = number of outputs
  - Pin width of input = net width
  - Pin width of any unspecified output pin = 1

This connection only works for commutative operators because it does not guarantee the ordering of the bus.

To specify the exact ordering of the net, you must add wire labels or use the BusSplit or BusMerge operators.
Creating Designs

- Output feeding multiple inputs:
  - Net width = 1
  - Pin width of output = 1
  - Pin width of any unspecified input pin = 1

The problem with named nodes seen in the previous example does not occur in the next example because the net width is resolved to 1. ADS Ptolemy interprets this as a single wire and replicates the output. The output here can be either a uniport or multiport pin.
Unspecified input or output pin width, specified net width (DSP only)

If the pin width is unspecified and the net width is an integer multiple of the
instance width then:

• Pin width = net width/instance width

For the Add example above, the ADS Ptolemy post-processor will need to recognize
that the input/output pin is connected to N<0>, N<1>, N<2> for I<0>,
N<3>, N<4>, N<5> for I<1> and N<6>, N<7>, N<8> for I<2>. An example netlist
follows:

Options ResourceUsage=yes
UseNutmegFormat=no
TopDesignName="C:\test_prj\networks\buses"
_vAgilentEEsof_dSDF_nAdd_lsdffstars:I<0> N<0>, N<1>, N<2> __net1
_vAgilentEEsof_dSDF_nAdd_lsdffstars:I<1> N<3>, N<4>, N<5> __net2
_vAgilentEEsof_dSDF_nAdd_lsdffstars:I<2> N<6>, N<7>, N<8> __net3

Unspecified pin width, unspecified net width, specified instance width

Pin width is set to 1 and net width is set to the instance width.

Unspecified net width, pin width specified, instance width specified

Net width inherits connection width (pin width * instance width).
Creating Designs

For the next three cases, everything (pin, instance and net width) is specified. The first case that applies (based on the order shown next) is the correct case.

- Net width = connection width
- Net width = pin width
- Net width = 1

Net width = connection width

The net width of the bus/bundle is the same as the connection width. This connection is resolved and verified because the total number of pins (connection width) matches the individual wires available.

Instance width = 3
Pin width = 3
Net width = 9
Connection width = 3*3 = 9

N<0> connects to P<0> of I<0>
N<1> connects to P<1> of I<0>
N<2> connects to P<2> of I<0>
N<3> connects to P<0> of I<1>
N<4> connects to P<1> of I<1>
N<5> connects to P<2> of I<1>
N<6> connects to P<0> of I<2>
N<7> connects to P<1> of I<2>
N<8> connects to P<2> of I<2>
Net width = pin width

If the net width and the pin width are the same, but the connection width is different, then the connection is valid, but the wires making up the bus/bundle must be repeated $M$ times, where $M$ is the instance width.

Net width = 1

If the net width is 1, and does not satisfy the previous two conditions, then the bus (really a single wire) is repeated $M$ times, where $M$ is the connection width. Thus this is the case when the pin width is greater than 1 and the net width is 1. This case will issue a warning because although this is valid, we assume that a pin with width connected to a single wire (shorted) may not be what the user intended.
Creating Designs

The following figure illustrates how the connections of a six-bit bus are mapped to which pin of which instance, where there are—in essence—two instances, each with three pins.

Net Width = Connection Width

Connect this instance to a 6-bit bus A,B,C,D,E,F to map the connections as shown on the left.

The next figure illustrates how the connections are made if you connect the aforementioned instance to a three-bit bus instead, which is allowed because the iterated instance has a three-bit pin.
Adding Ports to a Design

1. Click the port symbol on the toolbar (or choose Insert > Port).
2. Select the appropriate rotation by clicking the toolbar button (Rotate By -90) as needed.
3. Move the pointer into the drawing area, position the symbol as needed, and click to place it there.

**Hint**  Do not use the MoveTo Layer command to move ports to a different layer; set the Layer parameter of the port to the desired layer.
Using Special Components

There are a number of commonly used components in ADS whose special features must be understood to be used successfully. Please review the following topics, and where applicable, the additional referenced topics:

- “Using Substrates” on page 3-50
- “Using Nonlinear Models” on page 3-51
- “Components that Allow File-Based Parameters” on page 3-52

Using Substrates

Substrates (such as microstrip, stripline, etc.) are specified by placing the required substrate component in your design and then setting the substrate parameter (Subst) of the associated circuit component(s) equal to the instance name of the substrate component.

In the following example, the substrate parameters of the MSub1 instance are associated with the Bend1 instance by assigning the instance name “MSub1” (of the MSUB substrate component) to the Subst parameter of the MBEND2 component.

Note that the default value of the substrate parameter Subst, as well as the default substrate instance name (in this example, MSub1), can be edited.
Using Nonlinear Models

A nonlinear model can be associated with a nonlinear device instance by placing the required nonlinear model item in your design and then setting the parameter `Model` of the nonlinear device equal to the instance name of the nonlinear model item. This is especially useful in a hierarchical design that contains multiple subnetworks, each of which should reference the same model. In this case, place the `Model` item in the top-level design, and place an instance of the device in each of the subnetworks, setting their `Model` parameter equal to the Instance Name of the `Model` item.

In the following example, the model parameters of the BJT1 instance are associated with the BJT1 instance by assigning the instance name “BJ TM1” (of the BJT_Model item) to the parameter `Model` of the BJT4_PNP device.

![Diagram showing model parameters]

Note: The default value of the `Model` parameter—for any given device—is the same as the default Instance Name of the related model (in this example, BJT1). The Instance Name of the model can be changed, like any other Instance Name. If you do, be sure to change the `Model` parameter (of instances referencing that model) accordingly.
Components that Allow File-Based Parameters

Several components, such as DataAccessComponent (DAC), Deembed, and the SnP components, enable you to set a parameter to reference a file-based set of values. For details on the file formats of the data file types, refer to Chapter 4, Working with Data Files, in the Using Circuit Simulators manual.

To specify file-based parameters for these components:

1. Select the **File** parameter.
2. Select the appropriate Parameter Entry Mode: **Data filename** (DAC) or **Network parameter filename** (SnP, Deembed1, Deembed2).
3. Type the data filename, or **Browse** to select it. By default, only the files listed in the current / data directory are displayed.
   
   Alternatively, click **Data files list** to select a data file. The files listed are the files found in the set of search paths assigned to the DATAFILES variable (in de_sim.cfg). The data directory of the current project is usually the first path. For more information on setting variables refer to the section, Variables in de.cfg, de_sim.cfg in the Customization manual.
4. Optionally, click **Edit** to display the file (in your default text editor) for modification.
5. Optionally, click **Copy Template** to copy a data file of a specific format for use as a template. This template can be a supplied template or one you have created. By default, the program looks in the following location:
   
   $HPEESOF_DIR/circuit/templates (for Analog/RF designs)
   
   or
   
   $HPEESOF_DIR/adsptolemy/templates (for Digital Signal Processing designs)
Using the DataAccessComponent

Many component parameters, as well as variables, can be assigned a value from a data file by using the DataAccessComponent (DAC). The basics of accessing file-based parameters are as follows:

- Add a DAC component to your design
- Set the File parameter of the DAC equal to the data file of interest
- Set the parameter of the component of interest to reference the DAC (by its Instance Name)

For details on setting the DAC’s parameters and some basic examples, refer to DataAccessComponent in Chapter 5, of the Circuit Components manual.

Using Macros to Automate Tasks

You can record a macro (a series of AEL commands) by performing a sequence of commands using the mouse, and then play it back later to repeat the sequence.

Note Not all commands/actions are supported in macro recording; therefore, we do not recommend relying on this for recording complicated command sequences, but rather as a tool for learning how to use AEL.

To record a macro:

1. In the Main window choose Tools > Start Recording Macro and a dialog box appears.
2. Enter a name for your macro—the file extension .dem will be added automatically—and click OK.
3. Perform the desired sequence of commands.
4. When you are finished with the desired sequence, choose Tools > Stop Recording Macro. The file is saved to your current project directory.
Creating Designs

To play back a macro:

1. Choose Tools > Playback Macro and a dialog box appears displaying the macro files in the current project directory (that match the filter).
2. Select the desired macro and click OK. (To run a macro stored in another project directory, adjust the path as necessary, select the macro from the list, and click OK.) The selected macro is executed.

Viewing and Entering AEL Commands

The AEL commands that are issued in response to your activity in the Main window and the design windows are displayed in the Command Line dialog box. This command summary is updated continuously as you work. You can view this summary any time and you can issue previously executed commands from this list.

To view the command summary:

Choose Tools > Command Line in the Main window and the dialog box appears. As you execute commands, the corresponding AEL functions are displayed.

To execute AEL commands from this command summary:

- Type the command(s) in the Command >> field and press Return or click Apply after each to execute. (Note: All commands entered in the Command >> field must be in AEL format.)
  or
- Select a previously typed command from the list and press Return or click Apply to execute.
  or
- Double click any command in the list and the command is executed.

Click Cancel to dismiss the dialog box.

Note  For configuration details on using AEL, refer to the AEL manual. For layout artwork and usage, refer to the Layout manual.
Creating a Netlist

By default, every time you simulate a design, you generate a netlist file, netlist.log, in the current project directory, but it is possible to generate the netlist file without simulating the design.

To generate a netlist without simulating:

1. Open the desired Schematic.
2. Choose **Tools > Command Line** in the Main window and the Command Line dialog box appears.

   **Hint** Replace the number 1, shown in parentheses in the next step, with the number of the window from which you want to generate a netlist. The number of the window is displayed in the title bar.

3. Click in the Command >> field and type `de_set_window(1);` and press **Return**. Notice that what you type is echoed in the list above.
4. Click in the Command >> field and type `de_netlist();` and press **Return** or click **Apply**. After a short time, the netlist.log file is written to the project directory.

To use a different filename for any given project, you can insert the following line in the de_sim.cfg file in that project directory and specify a filename other than netlist.log.

```
NETLIST_FILE_NAME=netlist.log
```

**Important** If you edit your schematic after generating a netlist, you will need to generate the netlist again, since nodes may be renumbered as you edit.
Generating Reports

The Reports command enables you to generate a Bill of Materials (BOM) and a Parts List. Examples of a BOM and a Parts List are shown below.

**Note** By default, you are supplied with one format for the BOM and two for the Parts List, but these formats can be customized, and additional formats added, through AEL. For details, refer to the AEL manual.

To generate a Bill of Materials:

1. Choose **File > Reports > Bill of Materials**.

2. By default, the design name and a .bom extension appear as the filename for the generated file. Accept this name or supply another and click **OK**. The file is displayed in a window on the screen.

   ![](Figure 3-1. Bill of Materials Example)


<table>
<thead>
<tr>
<th>Item</th>
<th>Qty</th>
<th>Description</th>
<th>Designators</th>
</tr>
</thead>
<tbody>
<tr>
<td>RES</td>
<td>3</td>
<td>Resistor</td>
<td>R2 R3 R1</td>
</tr>
</tbody>
</table>

3. To save it to file with the default filename, click **OK**; to save it to file with a filename of your choosing, click **Print**. Supply a filename and click **OK**.

---

3-56 Generating Reports
Components included in the Bill of Materials are physical parts only (concrete items that can be touched). Examples of physical parts are vendor parts, SMT components, and packaged components. Components that are not physical parts, like distributed components, are not included in the Bill of Materials.

The ITEM_BOM_ITEM attribute in create_item() is what triggers a component to be listed in the Bill of Materials. If you have created a library part, representing a physical part, then you can set the ITEM_BOM_ITEM attribute by selecting File > Design Parameters > Parameters tab > Include in BOM checkbox.

To generate a Parts List:

1. Choose File > Reports > Parts List.
2. Choose the desired Report Type.
   - EEsof (EEsof PL format)—component name, ID, coordinates, angle, and side
   - EEsof (netlist format)—component names and parameters
3. By default, a .pl (parts list) or .net (netlist) extension is automatically added to the filename. Accept this name or supply another and click OK. The file is displayed in a window on the screen. Figure 3-2 shows an example of the parts list format.

```
  Component    Ref ID     X, Y,     ANG     SIDE
  ---------------------------------------------
     R   R1  1, 0.5    0       top
     R   R2  3.5, 0.5  0       top
     R   R3  2.75, -0.125  -90   top
```

Figure 3-2. Parts List Format Example

Figure 3-3 shows an example of the netlist format.
4. Click OK to save it to file with the default filename. Click Print to print to file or to the printer, based on your current Print Setup. If the current Print Setup is set to print to file, a dialog box appears prompting you for a filename. Supply a filename and click OK.
Chapter 4: Creating Hierarchical Designs

You can use any network as a subnetwork within another network to create a hierarchical design. There are two ways to create a subnetwork:

- Use the Create Hierarchy command and specify a portion of an existing design to be copied to its own design file for use as a subnetwork
- Create a new design consisting of a network you want to use as a subnetwork

Hint: To view design hierarchy in the current project, choose View > Design Hierarchies from the Main window.

To access a design in one project for use as a subnetwork in a design in another project, create a hierarchical project (File > Include/Remove, in the Main window). For details, refer to “Creating a Hierarchical Project” on page 2-11.

Note: The Update Component Definitions command (Edit > Component) enables you to explicitly update component definitions (that you have changed) throughout the current design. If you select the Update Component Definitions in Subnetwork option, the design hierarchy will be traversed (downward) and components will be updated throughout the hierarchy.

Creating a Subnetwork from an Existing Design

The Create Hierarchy command copies the selected portion of your design to another file, saves that new file, deletes the selected items in the original file and replaces them with a default symbol representing the deleted items.

Hint: You can create a custom symbol to use in place of the default symbol. For details on symbols, refer to Chapter 8, Working with Symbols.

The example used to illustrate this command is based on a simple, 3-resistor attenuator that is part of a larger design. In this example, the main design is named
Creating Hierarchical Designs

main_design and the file created using the Create Hierarchy command (containing the 3-resistor attenuator) is named my_atten.

To create a subnetwork from an existing design:

1. Select the items you want to include in the subnetwork (represented here inside the box drawn with a dashed line).

2. Choose Edit > Component > Create Hierarchy and a dialog box appears.

3. Provide a name for the new file, in this example, my_atten, and click OK. (The name you supply is the filename for the subnetwork as well as part of the annotation for the symbol when you place it in a design—however, no annotation is displayed in this example.)

The selected items disappear from your original design and are replaced by a default symbol (in this example, a 2-port symbol). Wires are redrawn to reconnect the remainder of the design to the symbol.

4. Save the file. The design used in this example appears as shown next.
If you want to use this network as a parametric subnetwork in a hierarchical design, you must open this newly created file (my_atten.dsn) and define the parameters that you want to be passed from the subnetwork to the network.

To define parameters for an existing subnetwork:

1. Open the file containing the subnetwork design.
2. Choose File > Design Parameters and a dialog box appears.
3. Supply a parameter name (not to exceed 8 characters), and select the appropriate characteristics for that parameter.
4. When you are through assigning characteristics to that parameter, click Add and the newly defined parameter is added to the Parameters list box.
5. Continue in this manner until you have assigned all the desired parameters for this network and click OK.

For a more detailed discussion on defining parameters, refer to the section titled, “Defining Parameters” on page 4-9.

Creating a Parametric Subnetwork

Any network can serve as a parametric subnetwork. A parametric subnetwork is any network for which you define the control parameters that pass through to the network into which you place the subnetwork. Once you have defined the parameters, your subnetwork can serve as a template enabling you to assign parameter values each time you place it in a design. You can construct whole libraries of re-usable subnetworks in this manner.

The details of this process are presented using a simple design consisting of a capacitor and a resistor in series and two ports. This subnetwork is called series_r_c and is represented by the default 2-port symbol.
Creating Hierarchical Designs

When you place the subnetwork within another design, you have the opportunity to assign values to any parameters you defined.
Creating the Subnetwork

You can create the subnetwork first, or define parameters and then create the subnetwork. In this example, we create the subnetwork first.

To create the subnetwork:

1. Choose File > New Design in the Schematic window and assign a name, in this example, series_r_c. This name becomes part of the annotation for the symbol representing the subnetwork when you place it within another design.
2. Select Analog/RF Network as the Type of Network and click OK.
3. Click the Library button and select a category, in this example, Lumped Components.
4. Select a component, in this example, C (Capacitor).
5. Place the capacitor in the Schematic window. Note the component parameter C is set equal to the default value of 1.0 pF. Click the End Command button.
6. Click the capacitance value to invoke the on-screen editor and use the Back Space key to erase the 1.0 pF.
7. Type C and press Return. The parameter now reads C=C. (This C parameter will be defined in the Design Parameters dialog box in a later step and serves as a variable here.) The parameter C (capacitance) of this component will now pass through to the network in which it is placed.
8. Place the next element, in this example, R (Resistor), accepting the default values. Connect it to pin 2 of the capacitor symbol.
9. Add ports and click the End Command button. The subnetwork should resemble the following illustration.
Defining Design Characteristics

Design characteristics include things such as the name of the symbol used to represent the subnetwork and a library from which the subnetwork can be accessed. In some cases you may find the default design characteristics acceptable (default symbol and default current project as the library, for example). If this is the case, proceed to the next section, “Defining Parameters” on page 4-9.

To alter the default characteristics:

1. Choose File > Design Parameters and a dialog box appears. In the General tab, the current design name is reflected in the Name field at the top of the dialog box.

2. The Description field also displays the current design name by default. You can change this to a more helpful label defining the purpose of the network design. The label you provide here will be displayed, together with the design name, as a component to place from the designated library (Library Name field).

   Optionally, add a description, in this example, cap and res.

3. The Component Instance Name default is X. The text in this field is used as a prefix in building a unique name (ID) for every item. This prefix becomes part of the annotation displayed with the symbol representing the parametric subnetwork when you place it in a design.

   Optionally, assign a unique name, in this example, para_sub.

4. Notice that the Symbol Name field reads SYM_2Port. This is the default symbol for a 2-port design. In this example, we are using the default symbol, but you can select one of the other symbols from the drop-down list, or click More Symbols to select one by clicking an icon from the appropriate category. For details refer to Chapter 8, Working with Symbols.

5. In the Library Name field, specify the name of the library in which you want the subnetwork stored. This library name is the name that appears in the
Component Library enabling you to select the subnetwork and place it in a design. There are several ways to specify a library name:

- Accept the default Library Name—an asterisk (*). This means the design will be available in the Component Library through the current project
- Type any name to create a new library
- Enter the name of any of the supplied libraries
- Select the name of any library you created previously

Create a new library name, in this example, **my_subnetworks**.

6. Turn on or off the following options, as required by your design.

- **Allow Only One Instance**—Specifies whether or not the subnetwork can be placed more than once in a design. The default is off, meaning the subnetwork can appear more than once in a design. Change to on if you want to restrict placement of the subnetwork to once per design (seldom done).
- **Include in BOM**—Specifies whether or not the details of this design are included when a BOM is generated. Without this option, only the top level design information is included in the BOM.
- **Layout Object**—Analog/RF designs only. Defines the design as an object. Layout objects have no parameters and are used to assign artwork to new elements or designs with no default artwork. For details, refer to the Layout manual.
- **Simulate from Layout (SimLay)**—Analog/RF designs only. The netlist required for simulation is generated from either the Schematic or the Layout. Select this option to generate the netlist from the Layout.
Creating Hierarchical Designs

The SimLay portion of this label will appear in the Status panel of the Schematic and Layout windows if you select this option; the default is to simulate from the Schematic, and the Status panel reflects SimSchem.

7. Layout only—select the appropriate Simulation method:

- Select Subnetwork, to use a schematic symbol you have created
- Select Built-in Component, to use a supplied simulator item.
  
  Simulate As—Select a component name from the drop-down list, or type the name of any component
  
  Copy Component’s Parameters—Select this option to copy the parameters of the selected component to use as a starting point
- Select Not Simulated, to create layout- or schematic-only non-simulated items

8. Analog/RF layout designs only—select the appropriate artwork Type

9. Click Save AEL file to save the information defined so far. (This is done automatically when you save the design file.)
Defining Parameters

When you define parameters for a network, the network serves as a template, enabling you to assign new parameter values each time you use the network. This is useful when a portion of the network is used several times in a design with certain element value differences, or in constructing libraries of reusable networks.

Parameters of the network are generally referenced as variables by the elements of the network. You can define the parameters before or after creating these variable references.

Each parameter has characteristics that determine how it is handled when the network is reused. These include the name and label displayed in the Item Parameters dialog box, the unit of the parameter, the type of value assigned to the parameter, the default value, and certain control attributes.

To define the parameters that should be passed to the upper-level network:

1. Click the Parameters tab.

2. Optionally (Analog/RF designs only), you can click Copy Parameters From as a shortcut for defining parameters, if one of the supplied components has a number of parameters in common. You can then cut any unwanted parameters, as well as modify the characteristics of the remaining parameters.

3. The Parameter Name field contains the parameter name that will be referenced in the subnetwork schematic. Parameter names become part of the annotation of the symbol representing the parametric subnetwork when you place it in a design.

   Supply a Parameter Name (not to exceed 8 characters), in this example, C.

4. Select a Value Type from the drop-down list, in this example, Real.

5. Specify a Default Value, in this example, 5. This value can be changed at the time you place the subnetwork.
Creating Hierarchical Designs

**Hint**  If you do not specify a scale factor along with the default value, the current setting in the Preferences dialog box is used (**Options > Preferences > Unit/Scale**), based on the Parameter Type.

6. Optionally, select a Parameter Type for this parameter, in this example, **Capacitance**. This can be a dimensional unit or a string for the parameter, if one is needed. (String is used for assigning SMT artwork in layout.)

7. Optionally, supply a Parameter Description.

8. Select any of all of the following options, as they apply. Note that some options are desensitized depending on the current Value Type.

- Display parameter on schematic—Select this option to display, on the schematic, the parameter being defined.
- Optimizable—Select this option to allow this parameter to be optimized.
- Allow Statistical Distribution—Select this option to allow post-production tuning for this parameter during yield analysis.
- Not edited—Select this option to prevent this parameter from appearing in the Component Parameters dialog box for editing and always use the default value assigned here instead.
- Not netlisted—Select this option to prevent a parameter from being considered in simulation, but still be recognized for artwork generation.
9. Click **Add** to add the newly defined parameter to the Select Parameter list box. The parameter C is added to the Parameters list box.

- Use **Add** to add a new parameter to the list
- Use **Cut** to delete parameters
- Use **Cut** and **Paste** buttons to rearrange the order of the parameters.

**Hint** You can position these user-defined parameters to display somewhere other than the default location of supplied parameters. For details refer to “Positioning Parameters for Your Symbol” on page 8-14.

10. Optionally (Analog/RF designs only), you can click **Add Multiplicity Factor (_M)** to enable simulation of this subnetwork as though it were x number of these subnetworks—connected in parallel—where x is the value you assign to the parameter _M.

11. Click **OK** to dismiss the dialog box and choose **File > Save Design**.

**Placing the Subnetwork in a Design**

Now you can place the subnetwork you just created into another network. The parameter you assigned (capacitance in this example) will pass through to the network.

To place a subnetwork:

1. Open the file containing the network in which you want to place the subnetwork (in this example, main_network—not shown).
2. Click the **Library** button (or choose **Insert > Component > Component Library**).
3. In the Component Library window, locate and select the library containing the design, in this example, **my_subnetworks**.
4. Select the subnetwork, in this example, **series_r_c**, and place it in the drawing area. Click **End Command**.

Notice that C = 5 F. This 5 is the value from the Default Value field (for the parameter C) in the Design Definition dialog box. Because we did not specify a
Creating Hierarchical Designs

scale factor, the default F (Farads), from the Preferences dialog box is used (Options > Preference > Unit/Scale).

5. Using the on-screen editor, change the default capacitance value to the desired value for the current design, in this example, 2. Press Return.

Modifying a Subnetwork Design

If you make changes to a subnetwork that affect the component definition (any changes in the Design Parameters dialog box—information that is saved in the .ael file), that serves as a subnetwork in a higher-level design, you need to explicitly update the higher-level design to recognize those changes.

To update a higher-level design that contains a modified subnetwork:

1. From the higher-level design, choose Edit > Component > Update Component Definitions.

2. To traverse the hierarchy (downward) in search of any subnetwork designs whose component definitions have been changed, select the option Update Component Definitions in Subnetwork and click OK. Changes to any subnetwork designs are now reflected in the instance(s) in the main design.

Viewing the Network Represented by a Symbol

Whenever your design contains a symbol that represents a network, you can view the actual network being represented by the symbol by using the Push Into Hierarchy command.

To push into and then pop out of an item:

1. Select the item.
2. Choose View > Push Into Hierarchy. The network represented by the symbol is displayed.

   The Pop Out of Hierarchy command is the reverse of pushing, and only works if a design has been pushed into.

3. When you are through viewing the network, choose Pop Out of Hierarchy and you are brought back to the item (or design containing the item).

**Editing a Hierarchical Design**

In the Layout window, you can edit the actual artwork represented by a component without pushing down into the hierarchy. This feature is particularly helpful in some cases such as when you need to position items in the subnetwork to align with items in the main design. For details on pushing into a hierarchical design to edit it, refer to "Pushing Into or Popping Out of Hierarchy" on page 9-30.

Use the following steps to edit a hierarchical design without pushing into the hierarchy.

1. Select the component representing the design.

2. Choose Edit > Edit In Place > Push Into to enter the edit mode for the network represented by the symbol.

3. Use the editing commands and tools to make the desired modifications. The few commands that are disabled when you edit a hierarchical design are as follows. The Schematic window excludes the same commands as the Layout window. Schematic window commands that don’t have an equivalent command in the Layout window are not disabled.

   - **Main Window > File Menu**
     - ALL COMMANDS DISABLED.
     - EXCEPT: New Design, Open Design, and Copy Design

   - **Main Window > Tools Menu**
     - Playback Macro

   - **Layout Window > File Menu**
     - Close Design
     - Revert to Saved Design
     - Save Design As
     - Delete Design
     - Import
     - Export
     - Exit Advanced Design System
Creating Hierarchical Designs

Layout Window > Edit Menu   Component > Create Hierarchy
Layout Window > Tools Menu  DRC: Width Spacing
                         DRC: Custom Rules
Layout Window > Schematic Menu  All commands in menu

Edit in Place Hints/Tips

• You cannot use Push Into after you use Edit in Place, but you can use Edit in Place after you use Push Into.

• Edit in Place will not edit AEL artwork macros.

• Edit in Place will not work if Layout Units/Precision is different from the top level.

• Parametric subnetworks use default values defined in Design Parameters.

• You can snap to pin of ports but not to edges/vertices using Edit in Place.

• Edit > Edit In Place > Push Into will not work if the design is open in multiple windows or if it is being Edited in Place in another window.
Chapter 5: Viewing Designs

The View menu commands enable you to change the current view of the drawing area to aid you in working with the image in the window. Additionally, there are a number of commands on the Options menu that display various aspects of design information.

- “Zooming In and Out” on page 5-1
- “Repositioning a Design to Fit the Window” on page 5-2
- “Moving the Center Point of a Window” on page 5-2
- “Redrawing the View in a Window” on page 5-3
- “Saving and Restoring Views” on page 5-3
- “Viewing Design Information” on page 5-4
- “Checking Connectivity Information in Schematic” on page 5-6

Zooming In and Out

The Zoom commands enable you to enlarge or shrink the area being viewed. Zoom Window enables you to specify your own view window for zooming, if the other zoom commands do not meet your needs.

To zoom in on a specified point in the window:

Choose **Zoom In Point**.

Click to specify a point and the current view is magnified by a factor of two, moving the point you specify to the center of the window.

To zoom out from a specified point in the window:

Choose **Zoom Out Point**.

Click to specify a point and the current view is decreased by a factor of two, moving the point you specify to the center of the window.

To specify a particular factor by which to zoom:

Choose **Zoom By Factor** and choose the appropriate command.

- Zoom In x2 (zooms in by a factor of 2)
- Zoom Out x2 (zooms out by a factor of 2)
Viewing Designs

- Zoom in x5 (zooms in by a factor of 5)
- Zoom Out x5 (zooms out by a factor of 5)
- Zoom In by ... (and specify the desired factor)
- Zoom Out by ... (and specify the desired factor)

To specify a particular portion of the view for zooming:

1. Choose **Zoom Area**. You are prompted to enter the first corner.
2. Move the cursor to the point representing the upper-left corner of the desired view window and click left. You are prompted to enter the second corner. As you move the mouse, a flexible box, representing the view window, moves with it.
3. Move the cursor to the point representing the lower-right corner of the desired view window and click left. The portion of your drawing enclosed by the view window is magnified. (The magnification amount is determined by the size of the view window you specified.)

To zoom to a selected object(s):

Select the object(s) and choose **View > Zoom > Zoom To Selected**.

Repositioning a Design to Fit the Window

To rescale and reposition your design so that it all fits in the window:

Choose **View All**. Your design is scaled as needed and repositioned to fit it all, plus a five-percent border, in the viewing area.

Moving the Center Point of a Window

The **Pan** command moves a point you specify, to the center of your window. Alternatively, you can use the scroll bars to move a different part of the window to the center.

To change the center point:

1. Choose **Pan View** from the View menu or the pop-up menu. You are prompted to enter the new window center.
2. Click once and the selected point becomes the new center point of the window. Your design is redrawn accordingly.

---

5-2 Repositioning a Design to Fit the Window
Redrawing the View in a Window

The Redraw View command refreshes the image in your window without changing anything. Choose Redraw View from the View menu anytime you make changes and see that an image is not completely drawn.

Saving and Restoring Views

It is possible to save multiple views of your design at various zoom settings.

- Save View enables you to save the current zoomed or panned view with a name
- Restore View enables you to retrieve a saved view
- Delete View enables you to delete a saved view
- Restore Last View enables you to restore the view that was in the window the last time you issued a Pan or Zoom command

To save the current view:

1. Choose View > Save View. A dialog box appears.
2. Supply a name for the view and click OK.

To restore a view that has been saved:

1. Choose View > Restore View. A dialog box appears.
2. Supply the name of the view you want and click OK.

To delete a view that has been saved:

2. Supply the name of the view you want and click OK.

To restore the view that was in the window the last time you issued a Pan or Zoom command:

Choose View > Restore Last View.
Viewing Design Information

You can display a variety of design information using commands found on the Tools menu:

- **Hierarchy** displays a listing of the hierarchical information of the current design in the Schematic and Layout windows.
- **Info** displays a detailed listing of design information including current units, preference and layer file associated with design, instances by name and ID, mask layer information, and a summary.
- **Identify** lists detailed data for selected instances, shapes, or text.
- **Check Representation** provides information on unconnected pins, port vs. pin mismatch, and nodal mismatch.

Viewing Detailed Design Information

The details on closed shapes include area, perimeter, and layer; for text, it includes the string and font attributes; for polylines it includes length. For components, the Name, ID, X, Y location, fixed/free status and equivalent element are displayed. A short summary is included that shows the number of items and shapes, the layers used, and the total selected area, length and perimeter.

To display detailed information for selected items:

1. Choose **Tools > Info** and the Information dialog box appears.
2. To view details on items not selected initially, select and click **Refresh**. The information is updated to display details of the newly selected item(s).
3. Optionally, click **Print** to send the information to your default printer.
4. Click **OK** to dismiss the Information dialog box.

Viewing Detailed Instance Information

To display detailed information for selected instances:

1. Choose **Tools > Identify** and a dialog box appears.
2. To print the information, click **Print** and it is sent to the default printer.
3. Click **OK** to dismiss the dialog box.
Viewing Hierarchical Design Information

There are two different ways to view hierarchical design information:

- At the design level, for the current project (View > Design Hierarchies, in the Main window)
- At the component level, for the current design (Tools > Hierarchy, in the Schematic and Layout windows)

To view design hierarchies for the current project:

1. In the Main window, choose View > Design Hierarchies.

   ![Design Hierarchies][1]

   If the project contains more top-level designs than can be displayed at one time, the arrows on either side of the tabs enable you to cycle through the remaining top-level designs to select the one you want.

2. Double-click any design to open it.

---

[1]: viewing-design-information-5-5.png
Viewing Designs

To view the component hierarchy information for the current design:

1. Choose **Tools > Hierarchy** and the Hierarchy dialog box appears.
   
   Hierarchical levels are indicated by the level of indentation in the list. Top level items are not indented; each nested level is indented with two spaces.

2. Click **Print** to send the information to your default printer.

3. Click **OK** to dismiss the Hierarchy dialog box.

Checking Connectivity Information in Schematic

In the Schematic view, the Check Representation command provides access to information about any of the following characteristics of your design:

- **Open Connections**—Displays the total number of unconnected pins and wires. For each item with an unconnected pin, it lists the component name and ID, the pin number and the coordinates of the unconnected pin. For each wire with an open end, it displays the coordinates of the wire segment. The affected items are highlighted in the design window.

- **Bus connectivity**—Reports failed connections listing the bus or bundle, its width, and the Instance Name of the component to which you have attempted to connect the bus or bundle.

- **Nodal mismatches (schematic vs layout)**—Reports items that are connected differently in one representation than they are in the other. The report lists the name of the item, the pin that is connected differently and what the pin is connected to. The affected items are highlighted in the design window.

- **Port/Pin mismatch** — 1. Checks every instance in the design (against the source design it represents) and reports any discrepancy between the number of pins on the symbol in the current design and the number of ports on the schematic in the source design. 2. Compares the number of pins on a given symbol to the number of ports on the schematic the symbol represents and reports any discrepancy.

- **Parameter values mismatches (schematic vs layout)**—Reports items that have different parameter values in one representation than they have in the other. The report lists the name of the item and the parameters that have different values. The affected items are highlighted in the design window.
• Overlaid components—Reports the IDs of any overlapping items where the items contain the same number of pins and pin 1 of each item is placed in the same location.

To view this information:

1. Choose Tools > Check Representation and a dialog box appears.
2. Select the desired information category (or categories) and click OK. A dialog box appears displaying the requested information.
3. Click Print to print the report, if desired.
4. Click OK to dismiss the report dialog box.

For information on how to check connectivity from a layout see “Checking Connectivity Information in Layout” on page 11-19.

Cross-Probing

To see the layout representation of a specific node in your schematic, select Layout > Show Equivalent Node and click the pin or wire that you would like to see in the layout. When you view the layout, the objects that belong to the node of the wire or pin that you selected in the schematic will be highlighted.
Viewing Designs
Chapter 6: Editing Designs

While editing, keep in mind that most edit commands allow you to select the item(s) before you select the edit command, or vice versa. Take note also that many editing commands are repeating commands, that is, once the command is chosen, it remains active until another command is chosen or until it is explicitly canceled (Edit > End Command).

You will find it easier to edit your designs if you understand some of the features provided to assist you in selecting the item(s) you want to edit. Design entry and display preferences are described in the Customization Manual, Setting Design Environment Preferences.

Using the Undo Command

Selecting Undo (Ctrl+z) undoes the last editing command. A stack of edit commands is created enabling you to choose Undo repeatedly to return to an earlier state of your design. A stack is maintained for each window, thus the Undo command works independently from window to window. You can specify the number of commands you want the stack to hold through Options > Preferences > Entry/Edit, Undo edit count.

Deleting Items

To delete selected items, click the Delete button on the toolbar, or press the Delete key on the keyboard, or choose Delete from the Edit menu. Deleted items can be restored using the Undo command.

Activating, Deactivating, and Shorting Components

Use the following information to modify a design to include or exclude components without deleting them. Advanced Design System provides two ways to exclude items from a simulation: deactivating, and deactivating and shorting.

Activating and Deactivating Components

A deactivated component is excluded from the design during simulation. When a component is deactivated a box with an X drawn through it is displayed over the component.
Editing Designs

To deactivate or activate components:

1. Choose **Edit > Component > Deactivate/Activate**.
2. Select a component to switch its current state.
   - Clicking an active component deactivates it and a box with an X drawn through it is displayed over the item. A deactivated item is excluded from a subsequent simulation.
   - Clicking a deactivated component (shorted or not) reactivates it. The item is included in a subsequent simulation.

**Hint** The color of the deactivation box is the Highlight color defined through **Options > Preferences > Display**.

If you select more than one component and then invoke the Deactivate/Activate command, one of the following occurs:

- If all components were active, they get deactivated, and vice versa.
- If some of the selected components were activated while others were deactivated, all components get deactivated.

**Note** When using the Generate/Update Layout command, instances that have been deactivated will not appear in layout. This includes instances that have been deactivated and shorted. To work around this problem it may be necessary to run Generate/Update Layout more than once, and select a starting instance on either side of the deactivated and shorted instance. The short will have to be manually added in layout if it is desired to simulate from layout.

**Deactivating and Shorting Components**

A deactivated and shorted component is interpreted as a short during simulation. When a component is deactivated and shorted a box with an X and a solid bar drawn through it is displayed over the component.

To deactivate and short components, or to activate components:

1. Choose **Edit > Component > Deactivate and Short/Activate**.
2. Click one or more components to switch their current states.

Clicking an active component deactivates and shorts it. A box with an X and a solid bar drawn through it is displayed over the item. The item is interpreted as a short in a subsequent simulation.

Clicking a deactivated component (shorted or not) reactivates it. The item is included in a subsequent simulation.

**Note** If the component you have selected can’t be shorted, a message is displayed to let you know and the component is only deactivated.

If you select more than one component and then invoke the Deactivate and Short/Activate command, one of the following occurs:

- If all components were active, they get deactivated and shorted, and vice versa.
- If some of the selected components were activated while others were deactivated, all components get deactivated and shorted.

**Note** In Analog/RF designs, generally only components with two pins can be deactivated and shorted; other components are just deactivated. (Exceptions to this two-pin rule are: S2P, S2P_Conn, S2P_Pad3, S2P_Spac, and Deembed2. When these components are deactivated and shorted, the short is created between pins 1 and 2.) The Deactivate and Short or Activate Components command is disabled for DSP designs. To be able to deactivate and short a custom component with more than two pins, refer to the instructions for the `create_item` function in the AEL documentation.

---

**Editing Component Parameters**

There are several methods for changing component parameters. The simplest methods involve editing parameters for individual components:

- Using the on-screen editor
- Using the component parameter dialog box

Additional methods that accommodate editing parameters in specific situations are:
Editing Designs

- Searching for a particular parameter—a parameter whose value is stated as a reference to another component (Search/Replace Reference)—and then replacing that parameter throughout the design
- Changing the value of a particular parameter common to components throughout the design (Group Edit Parameter Value)

**Note**
The at symbol (@) must be used to suppress quotes when specifying a variable, for example, @freq1, where freq1 is a variable declared in a VAR item.

**Editing Component Parameters On-screen**

You can use on-screen parameter editing to change parameter values. In addition, you can change the Value Type from nominal to variable, and vice-versa. If you need to change a parameter’s Value Type to anything other than nominal or variable, refer to the next section, “Editing Component Parameters Through the Dialog Box” on page 6-5.

**Hint**
When you click the component name, you initiate the Swap Components command.

To edit one or more parameters for a component using the on-screen method:

1. Position the pointer over the parameter you want to change and click. The editable portion of the parameter takes on the current Highlight color (Options > Preferences > Display). You will also see that a vertical bar (|), representing a text insertion cursor, appears in the parameter line.
2. Use the mouse, arrow keys, and backspace key as necessary, to change the parameters.
3. To end the parameter editing command, move the pointer away from the component and click once. (If the parameter is the last one in a list of parameters or is the only parameter for this component, pressing Return also ends the command.)
Hint  When editing several parameters for one component, you can click each individual parameter you want to edit, or you can press Return as many times as needed to get to the next parameter you want to edit. Pressing Return for the last parameter in the list ends the parameter editing command.

Editing Component Parameters Through the Dialog Box

Despite variations for some components, certain basic guidelines apply to completing the component parameters dialog box for most components. Note the following features of this dialog box:

• The input fields change based on the individual parameter selected.

• All variable entries are available by selecting the Equation Editor from the Edit Component dialog. For more information refer to “Using the Equation Editor” on page 6-8.

• A default ID for a given instance of a given component appears in the Instance Name field. This ID is unique for every component in the design. You can use the default name or supply any name of your choosing.

• Some parameters offer the ability to use data from a referenced data file. For details refer to the section, “Components that Allow File-Based Parameters” on page 3-52.

• You can turn the display of individual parameters on or off. You can also use Component Options to set or clear the display of all parameters for the component at once. For details, refer to the section, “Changing the Visibility of Component Parameters on a Schematic” on page 6-7.

• For details on Optimization/Statistics Setup, refer to the section Specifying Component Parameters for Optimization in Chapter 2, Performing Nominal Optimization, in the Tuning, Optimization and Statistical Design manual.
Editing Designs

To edit one or more parameters for a component through the dialog box:

1. Choose one of the following methods for displaying the dialog box:
   - Choose **Edit > Component > Edit Component Parameters** and click the component symbol
   - Click the **Edit Component Parameters** button on the toolbar and click the component symbol
   - Double-click the component symbol

   
   ![Diagram of Edit Component Parameters dialog box]

   **Parameter Entry Mode**
   - **Value of Selected Parameter Displayed for Editing**
   - **Appropriate Choices for Current Parameter**

   **Default Unique ID for this Component (Automatically Incremented)**
   - **Parameters for this Component**

   **Select Parameter**
   - **C**
   - **Temp**
   - **Thisa**
   - **Thmos**
   - **TC1**
   - **TC2**
   - **WIV**
   - **InitCond**
   - **Model**
   - **Width**
   - **Length**
   - **M**

   ![Parameter Selection Buttons]

   **Add**  **OK**  **Cancel**  **Reset**  **Help**

   **OK**  **Apply**  **Cancel**  **Reset**  **Help**

   **C : Capacitance**

   **Display parameter on schematic**

   **Component Options**

   ![Parameter entry mode options]

   **Parameter Entry Mode**
   - **Standard**
   - **Equation Editor**
   - **Time/Opt/Stat/DOE Setup**

   **Select Parameter**
   - **C**
   - Value: 1.0 pF

   **Hint** Use the following shortcut to edit parameters for most or all components: select everything in the drawing area (Select > Select All) and choose **Edit > Component > Edit Component Parameters**. Click Apply to accept parameter changes for one component, and another component is displayed for editing.

2. Select the parameter you want to change from the Select Parameter list box.

6-6 Editing Component Parameters
3. Type the new value in the parameter value editing field.

4. Press Return. The Parameters list box is updated to reflect the new value and the value of the next parameter is displayed for editing.

5. When you are through editing parameters, click OK to dismiss the dialog box.

Changing the Visibility of Component Parameters on a Schematic
You can change the visibility status of all parameters of a given component through the Component Options dialog box (accessed through the component parameters dialog box).

- Set All—Displays all parameters for this component on the schematic. Use this option to display all, or almost all, parameters for this component. To display most—but not all—parameters, select Set All and then go back and turn off the display of individual parameters as desired.

- Clear All—Clears the display of all parameters for this component from the schematic. Use this option to turn off the display of all, or almost all, parameters for this component. To display a small subset of parameters, select Clear All and then go back and turn on the display of individual parameters as desired.

Referencing VAR Data Items and Model Items in Hierarchical Designs
The Scope option applies to the VAR (Variables and Equations) data item and most model items (such as R_Model, BJ_T_Model, BSIM3_Model). Exception: it does not apply to multilayer models. Scope indicates the levels, from a hierarchical standpoint, that recognize the expressions defined in the VAR data item or model item.

- Nested—VAR or model item expressions are recognized within the design containing the VAR or model item, as well as within any subnetworks (designs at lower levels) referenced by the design containing the VAR or model item.

- Global—VAR or model item expressions are recognized throughout the entire design, no matter what level in the design hierarchy the VAR or model item is placed.
Editing Designs

**Editing Common Parameters for a Group of Items**

The Group Edit Parameter Value command enables you to select a group of components with one or more common parameters, select a parameter that applies to them all, and change that parameter’s value for all selected components.

To edit every occurrence of a parameter for selected components:

1. Select all components containing the parameter you want to edit.
2. Choose **Edit > Component > Group Edit Parameter Value** and a dialog box appears.
3. Click **Name Options** and a dialog box appears listing all parameters in your design by name.
4. Select the desired parameter from this list and click **OK**. The selected parameter appears in the Parameter Name field.
5. If the value type of the selected parameter is numeric, type the new value in the Parameter Value field; otherwise, click **Value Options** and a dialog box appears. The contents of the dialog box vary depending on the value type of the chosen parameter.

**Note** You can only change the nominal value of the parameter, not the Value Type.

6. Select the desired parameter value and click **OK**.
7. Click **Apply** in the Group Edit Parameter Value dialog box (or click **OK** if you are through with this dialog box) and the design is updated accordingly.

**Using the Equation Editor**

The Equation Editor is a general purpose dialog box that enables you to access all of the variables defined in a particular design. You can access the Equation Editor from any standard component dialog box when the Standard Parameter Entry Mode is selected.

**Note** For a list of available simulator functions, refer to the Simulator Expressions documentation.
To edit a variable equation:

1. Click a parameter to edit in the Select Parameter list box.

2. If available, set the Parameter Entry Mode to **Standard** in the component dialog box.

   **Note** The Standard Parameter Entry Mode is not available for all component parameters. If the Standard Parameter Entry Mode is not available, the Equation Editor is not available for that particular parameter.

3. Click the **Equation Editor** button. The Equation Editor dialog box appears with the component parameter displayed on the left.

4. Select a variable from the Variables list box and then click the **Insert** button to add the variable to the component parameter entry field on the left. The variable selected appears in the parameter entry field. This field can be edited directly to use the selected variable in an equation.

5. Click **OK** to add the new equation to the component parameter.

6. Click **OK** or **Apply** in the component dialog box to initiate the change in the component.
Breaking Wire Connections Between Components

To break connections:

1. Select the component(s) whose connections you want to break.
2. Choose **Edit > Component > Break Connections**. The interconnections of selected components are deleted.

![Diagram showing before and after of breaking wire connections]

Swapping Components

The **Swap Components** command enables you to select any number of components, with any number of ports, and replace them all with another component.

To swap components:

1. Select all components you want to replace.

   **Hint** Use the **Select > Select By Name** command to quickly select every component of a particular type.

2. Choose **Edit > Component > Swap Components** and a dialog box appears.
3. Click **Select** and the Component Library window appears.
4. Select the appropriate library and desired component. The component name appears in the New Component Name field of the dialog box.
5. Click **Edit Parameters** and the component parameters dialog box appears.
6. Change any parameters as desired and click **OK**.
Searching and Replacing References

The Search/Replace Reference command enables you to replace every occurrence of a parameter value where that parameter value is a reference, such as a reference to a data item. For example, if your design contains two MSUB data items, MSUB1 and MSUB2, you can replace every reference to MSUB1 with a reference to MSUB2 instead. You can replace references to data items or variables.

To search and replace references to data items or variables in your design:

1. Choose Edit > Component > Search/Replace Reference and a dialog box appears.
2. Select the desired Reference Type, Component or Variable.
3. Under the heading Search For, click Select and a dialog box appears. The listing varies according to the selected reference type.

**Hint** To highlight these references prior to replacing any, use the Search Only option and click Apply.

4. Select the Instance Name or Variable name representing the item you want to search for and click OK. The selected reference appears in the Search For field.
5. Under the heading Replace With, click Select.
6. Select the Instance Name or Variable name representing the desired replacement and click OK. The Replace With field is updated.
7. Click Apply (or OK if you are through with the Search/Replace dialog box). All occurrences of the selected reference are updated in your design.

7. To keep the IDs of the original components, select the option Keep the original component ID(s); to let the program replace the IDs with new ones, deselect this option. Click OK. All selected components in the design window are replaced by the new component with the specified parameters.
Moving Component Text

You can reposition the component text, collectively, of any component with the Move Component Text command. In addition, you can change the layer assignment of individual pieces (Name, ID, Parameters) with the Change Component Text Layer command.

To move component text:

1. Choose Edit > Move > Move Component Text. You are prompted to enter a reference location.
2. Click the component whose component text you want to move. You are prompted to enter an offset location.
3. As you move the pointer, a ghost image representing the component text moves with it. Click again to reposition the component text in the new location.

---

**Hint**  The function key F5 initiates the Move Component Text command. Press F5, click the component symbol, move the pointer and a ghost image of the component text moves with it. Position the image in the desired location and click again to place it there.

---

To change the component text layer:

1. Choose Insert > Entry Layer and select the desired destination layer from the list.
2. Choose Edit > Component > Change Component Text Layer.
3. Click any individual piece (Name, ID, Parameters) of component text. Its layer is changed to the current entry layer and the component text immediately takes on the characteristics of the current entry layer.

---

**Note**  To change the layer on which component text is placed in advance of placing components, use Options > Preferences > Component Text/Wire Label to specify the desired layer for each type of component text.
Changing Component Text Attributes

You can change the attributes of existing component text through the Edit menu. This command only affects existing component text. To establish attributes for all subsequent component text, specify the desired settings through Options > Preferences > Component Text/Wire Label. For details on changing text you have added to your design, refer to “Editing Existing Text and Text Attributes” on page 6-37.

To change component text attributes:

1. Select the components whose component text you want to edit.
2. Choose Edit > Component > Component Text Attributes.
3. Make any desired changes to the text attributes.
   - Font Type—All True Type fonts (Schematic only) installed on your system are available. Select the desired font from the drop-down list.
   - Point—Represents the size of text in traditional units used in printing.
   - Parameter Rows—The maximum number of rows of parameters before another column is created.

Note On UNIX, if you want to add additional True Type fonts that were not supplied with ADS, copy them to $HPEESOF_DIR/lib/fonts.

- Parameter Rows—The maximum number of rows of parameters before another column is created.

4. Click OK and the component text is immediately updated to reflect the changes.
Editing Designs

**Editing Symbol Pins**

The Symbol Pin command enables you to change the name, number, and orientation angle of existing pins.

To edit characteristics of existing pins:

1. Select a pin for editing and click **Edit > Symbol Pin**. A dialog box appears.
2. Change any of the characteristics as desired and click **Apply** (or click OK to accept the changes and dismiss the dialog box).

For details on pin characteristics, refer to, “Adding Pins to Your Symbol” on page 8-9.

**Selecting and Deselecting Items**

While you can always use the mouse to select and deselect items, several commands found on the Select menu can assist you in selecting and deselecting items more quickly.

---

**Note** Only objects on selectable layers can be selected for editing. If the select status (Sel) of a given layer is disabled (through the Layer Editor dialog box), the select commands have no effect on items on that layer.

---

**Selecting/Deselecting All Items in the Drawing Area**

To select all items in the drawing area:

Choose **Select > Select All**. Boxes are drawn around all items (that match the filter selection) showing that they are currently selected.

To deselect all selected items that match the filter selection:

Choose **Select > Deselect All**

or click anywhere inside the window, away from the selected objects.
Selecting/Deselecting Items by Name

The commands Select By Name and Deselect By Name ignore the selection filters.

To select items by name:

1. Choose Select > Select By Name. A dialog box appears. By default, a list of each type of item in the design is displayed by Component Name. You can also view a list of individual items by selecting by Instance Name. The following illustration shows the listings of a simple network.

2. Select the desired list type and click the item(s) from the list that you want to select. Click Apply. The specified items are selected in the design window.
Selecting and Deselecting Items

To deselect items by name:

1. Choose Select > Deselect By Name and a dialog box appears. By default, a list of each type of item selected in the design is displayed by Component Name. You can also view a list of individual selected items by selecting by Instance Name.

2. Select the desired list type and click the item(s) from the list that you want to deselect. Click Apply. The specified items are deselected in the design window.

Hint: Alternatively, you can use the wildcard field to filter the list for selected items of the same type. For example, to list all selected transmission lines in the design, type TLIN (for a listing by Component Name) or TL* (for a listing by Component ID), and click Apply.

Selecting/Deselecting With a Selection Window

You can include several objects at once for selection/deselection by enclosing them in a selection window.

To select items using a selection window:

1. Position the pointer at one corner of a window that will enclose the desired items, and press the left mouse button.

2. As you move the mouse, keeping the button depressed, a ghost image of the selection window is drawn. Release the button to specify the opposite corner of the window. All items totally enclosed within the selection window, that match the filter selection, are now selected and are identified by taking on the Select color chosen under Option > Preferences.

To deselect items using a selection window:

1. Choose Select > Deselect Area.

2. Draw a selection window enclosing the items you want to deselect. All items in the selection window (that match the filter selection) are deselected.
Using the Vertices Filter

By default, the Vertices filter is turned on. This means that when you use a selection window to encompass a portion of a given shape, the shape itself is not selected, but rather only the vertices that fall within the selection window. To modify this behavior so that individual vertices are not selected when you click an individual vertex or use a selection window, turn off the Vertices filter through Options > Preferences > Select.

The illustration that follows shows what happens when the Vertices filter is on, you draw a selection window enclosing parts of shapes on two different layers, and then choose Edit > Move > Move Using Reference.

Hint When the Vertices filter is turned on, all selected vertices are identified by a marker. You can change the size of this marker with the Selected Vertex option through Options > Preferences > Select.
Copying and Pasting Items

There are several Copy commands that enable you to copy and paste items in different ways:

- **Cut**—Enables you to delete one or more items from one window, and paste in another window.

- **Copy**—Enables you to copy items in a given design window and then paste those items within the same design window or another design window. On the PC only, it also copies the items to the Windows clipboard enabling you to paste the item(s) as a graphic in a Windows application.

**Hint** To enable pasting the item using coordinates as the reference point, choose **Options > Preferences > Entry/Edit** and select the option **Show Set Paste Origin Dialog for Copy command**.

- **Paste**—Enables you to paste items that you previously cut or copied

**Advanced Copy/Paste**

- **Copy Using Reference**—Enables you to copy selected items, prompting for a reference point and a destination point. The copied items can then be placed anywhere within the same design window.

- **Copy Relative**—Enables you to copy items a specified distance from the original items

- **Copy To Layer**—Enables you to copy items from one layer to another, within the same design window

- **Step And Repeat**—Enables you to create a copy in the form of an array, with the number of rows and columns you specify

To copy an item and paste it on the same layer:

1. Select the item(s).

2. Choose **Edit > Copy** (or click the **Copy** button on the toolbar).

   If you enabled the aforementioned option, Show Set Paste Origin Dialog for Copy command, a dialog box appears enabling you to specify a reference point for pasting. (The default reference point for pasting a component, or group of components, is the first unconnected pin; when pasting shapes, the default
reference point is the lower left corner.) Specify the X and Y coordinates. (These are the positional coordinates identifying the position of the pointer in relation to the total window.) Click OK.

3. Choose Edit > Paste from the desired design window. As you move the pointer, a ghost image of the copied item moves with it.

4. Click again to specify the destination point.

To copy items using a reference point:

1. Select the item(s).
2. Choose Edit > Advanced Copy/Paste > Copy Using Reference.
3. You are prompted to enter a reference point. Click the point on the item (or group of items) you want to use as a reference point for positioning the copy.
4. You are prompted to enter the offset location. Click to place the item(s) in the desired location.

To create a copy in a specific position, relative to the selected item:

1. Select the item you want to copy.
2. Choose Edit > Advanced Copy/Paste > Copy Relative. A dialog box appears enabling you to specify the distance from the original that the copy should be placed.

The values you specify here are with respect to the units of the window, schematic or layout. For example, using the default inches of the Schematic window, if you supply 1.0 for both X and Y, the reference point of the copied item will be placed 1 inch in the direction of X and 1 inch in the direction of Y from the reference point of the original item.

![Diagram showing copying and pasting items using reference point](image-url)
Editing Designs

**Hint** The reference point on symbols is the first unconnected pin; the reference point on shapes is the lower left corner.

3. Specify the desired units in X and Y and click **Apply**. A copy appears at the specified location.

To copy from one layer and paste to another:

1. Select the item(s).
2. Choose **Edit > Advanced Copy/Paste > Copy To Layer**.
3. Select the desired destination layer from the dialog box that appears and click **Apply**.

**Important** Clicking **Apply** enables you to continue copying items from the current layer to any other layer. If this is the only layer you want to copy the selected shape to, then click **Cancel**; if you click **OK**, you will paste an additional copy on the last layer selected.

The Step and Repeat command enables you to select an item or items you would like multiple copies of and then specify how many copies and how many rows and/or columns. This command also enables you to specify the distance between the items in X and Y coordinates.

To copy items using the Step and Repeat command:

1. Select the item or items you want to copy.
2. Choose **Edit > Advanced Copy/Paste > Step and Repeat**. A dialog box appears.
3. By default, the current snap spacing is displayed as the X and Y spacing in this dialog box. You can either accept the default spacing or change these numbers by typing or clicking the up and down arrows.
4. Specify the number of rows and columns by typing or by clicking the up and down arrows.
5. To automatically connect the pins of these items with one another, select the option **Connect overlapping pins** and change the X or Y spacing field to 0, based upon the component and the desired configuration.
6. Click **Apply**. As you move the pointer into the drawing area, a ghost image of the items moves with it. The lower left corner of the group serves as the reference point for placement.

**Hint**  The Step and Repeat command is a repeating command; you can place this same configuration as many times as you like. Or you can change the configuration each time and choose Apply before placing.

An illustration using a $2 \times 4$ array of BJTs is shown next.
Moving Items

The quickest way to move objects is with the mouse:

1. Position the pointer over the object(s) you want to move.

   **Hint**  To move several items at once, select them using a selection window. To add additional items to (or delete items from) a selected group, use Shift+Click.

2. Press the left mouse button, drag to the new location, and release. When moving items using the drag method, the move must be more than the distance specified as the Threshold for it to be recognized as a move.

   ![Drag and Move](image)

   This option (Options > Preferences > Entry/Edit) protects you from moving an item unintentionally if you click to select it and accidentally move the pointer.

There are several additional Move commands that enable you to move components and shapes in specific ways:

- Move Using Reference—Enables you to move selected items, prompting for a reference point and a destination point
- Move Edge—Enables you to stretch the edge (between two vertices) of an existing shape

   **Hint**  This movement can be restricted by setting the option Maintain adjacent angles for Move Edge command.

- Move Relative—Enables you to move items by specifying coordinates, relative to 0,0
- Move & Disconnect—Breaks connections as you move selected components
- Move To Layer—Enables you to move items from one layer to another
- Move Wire Endpoint—Enables you to manipulate an unconnected end of a wire

To move items specifying the reference and destination locations:

1. Select the item(s) you want to move.
2. Choose Edit > Move > Move Using Reference. You are prompted to enter a reference location.
3. Specify a reference point by clicking the point on the item (or group of items) you want to use when specifying the destination. If you are moving component symbols, clicking a pin as a reference point will help you align and connect the items.
   As you move the mouse, a ghost image of the selected objects follows. You are prompted to enter an offset location.
4. Click again to place the items in the new location. Where applicable, wires are redrawn maintaining connections.

---

**Hint** The manner in which wires are redrawn is controlled by the option Reroute entire wire attached to moved component.

---

To move an item a specific amount, relative to the coordinates 0,0:

1. Select the item you want to move.
2. Choose Edit > Move > Move Relative.
3. Specify the amount in X and the amount in Y (in inches) you want to move the selected object and click Apply. The item is moved, using the default reference point, by the specified amount.

---

**Hint** The default reference point of an item varies depending on the nature of the item—for a component, it is pin 1; for a shape, it is the lower left corner.
To move and disconnect:

1. Select the items you want to move.

2. Choose Edit > Move > Move & Disconnect. You are prompted to enter a reference location.

3. Specify a reference point by clicking on or near the selected items. If you are moving component symbols, clicking on a pin as the reference point will help you align and connect the items.

   As you move the mouse, a ghost image of the selected items follows. You are prompted to enter an offset location.

4. Click again to place the items in the new location. The connections of the items moved and the items left behind, are deleted. The interconnections among the items moved, remain intact.

To move shapes or text to another layer:

1. Select the object you want to move.

   **Note** Do not use the Move To Layer command to move ports to a different layer; set the Layer parameter of the port to the desired layer.

2. Choose Edit > Move > Move To Layer. A dialog box appears with a list of currently defined layers. Select the desired layer and click OK. The selected object immediately takes on the color and other display characteristics of the selected layer.

   **Note** The following items can be moved to another layer using the context-sensitive menu that appears when you right-click with the pointer positioned over any of these items: Polygon, Polyline, Rectangle, Circle, Arc, Text, Arrow, Wire, Construction Line, Path, Trace.
Rotating Items

There are several commands to assist you in rotating components and shapes. The Advanced Rotate commands are more often used for shapes than components, but they do operate on components. For details on basic component rotation, refer to “Rotating Components” on page 3-19.

Use any of the following methods to rotate components and shapes by a specified increment:

- Click the **Rotate By Increment** button on the toolbar.
- Press **Ctrl+r**.
- Choose **Edit > Rotate**.

Each of these actions rotates the component $n$ degrees clockwise, where $n$ is the increment specified in **Options > Preferences > Entry/Edit > Rotation Increment (angle)**. The default is 90 degrees.

The **Mirror About X** and **Mirror About Y** commands enable you to rotate objects across an axis you specify.

**Advanced Rotate**

- **Rotate Around Reference** enables you to rotate components and shapes using the mouse, specifying the reference point and the destination point.
- **Rotate Relative** enables you to rotate components and shapes by a specific number of degrees, relative to the 0,0 coordinates of the drawing area.
- **Set Rotation Angle** rotates the selected item by the number of degrees specified, in conjunction with the Rotate command. Note that setting this angle resets the Rotation Increment (angle) in **Options > Preferences > Entry/Edit**.

---

**Hint** The Rotate and **Rotate Around Reference** commands can both be used on either components or shapes, but the Rotate command is typically better for working with components (the reference point is specified by the program) whereas the **Rotate Around Reference** command is typically better for working with shapes (you are prompted to specify the reference point around which to rotate).
Rotating Items Around a Specified Point

To rotate a selected object around a specified point:

1. Select the object.
2. Choose Edit > Advanced Rotate > Rotate Around Reference. You are prompted to enter a reference location.
3. Click once on the object at the point around which you want to rotate it. You are prompted to enter the offset location. As you move the mouse, a ghost image of the object moves with it. The pointer snaps in increments of the number of degrees specified in the Rotation Increment (angle) field in the Preferences dialog box (Options > Preferences > Entry/Edit).
4. Move the pointer until you are satisfied with the angle of rotation and click to place it.

Rotating Items in Degrees, Relative to 0,0

To rotate a selected object by a specific number of degrees, relative to 0,0:

1. Select the object.
2. Choose Edit > Advanced Rotate > Rotate Relative.
3. In the dialog box that appears, enter the number of degrees by which you want the object rotated.

Hints:
- Positive values rotate the object in a counterclockwise direction; negative values rotate the object clockwise.
- The reference point for rotating shapes is the lower left corner.
- The reference point for rotating components is the left-most pin 1.
- Values entered here are rounded up or down to the nearest incremental value in accordance with the number of degrees specified in the Rotation Increment (angle) field in the Preferences dialog box (Options > Preferences > Entry/Edit).
Rotating Objects Across a Specified X- or Y-axis

To rotate selected objects across a specified X-axis (mirror):

1. Select the object.
2. Choose Edit > Mirror About X. You are prompted to enter a point on the X-axis.
3. Click to specify the X-axis over which you want the object rotated. The selected object is rotated.

![Diagram showing before and after of object rotation across X-axis.]

To rotate selected objects across a specified Y-axis:

1. Select the object.
2. Choose Edit > Mirror About Y. You are prompted to enter a point on the Y-axis.
3. Click to specify the Y-axis over which you want the object rotated. The selected object is rotated.

![Diagram showing before and after of object rotation across Y-axis.]

Rotating Objects Using an Absolute Angle

You can specify an absolute angle of rotation using the Set Rotation Angle command. This command is used in conjunction with the Rotate command.

**Note** The angle you specify here becomes the new Rotation Increment (angle) in Options > Preferences > Entry/Edit.

To rotate an object using an absolute rotation angle:

1. Select the object you want to rotate.
2. Choose Edit > Advanced Rotate > Set Rotation Angle. The Set Rotation Angle dialog box appears.
3. Specify the desired rotation angle in degrees.
4. Click Apply and click the Rotate button. The object is rotated by that amount.
Editing Shapes

There are several ways you can edit or manipulate various shapes after you have added them to your design:

- “Converting Circles/Arcs to Simple Polygons” on page 6-29
- “Editing Polygons and Polylines” on page 6-31
- “Adding a New Vertex” on page 6-32
- “Moving a Vertex” on page 6-32
- “Deleting a Vertex” on page 6-33
- “Converting a Vertex to an Arc” on page 6-33
- “Converting a Vertex to a Mitered Edge” on page 6-34
- “Stretching a Wire or an Edge of a Shape” on page 6-35
- “Scaling an Object Using a Scaling Factor” on page 6-36
- “Scaling an Object Relative to the Design Window Units” on page 6-36

Converting Circles/Arcs to Simple Polygons

Circles and arcs can be converted to simple polygons allowing vertex editing. The smoothness of the converted circle or arc is determined globally by the setting Arc/ Circle Resolution (degrees) in Options > Preferences > Entry/Edit. You can use different settings for individual shapes using Edit > Modify > Arc or Edit > Modify > Circle.

![Diagram showing the comparison between a circle and a polygon with different resolution settings.](image)
Editing Designs

To convert a selected circle to a polygon:

Choose Edit > Modify > Convert To Polygon.

To edit the characteristics of a selected circle:

1. Choose Edit > Modify > Circle.
2. Select the desired mode for changing the radius:
   - Absolute Radius—Select this option to scale a circle by an absolute amount. For example, if your circle has a radius of 0.75 inches and you specify a Radius of 1, the circle is scaled such that the radius is 1 inch.
   - Delta Radius—Select this option to scale a circle by a relative amount. For example, if your circle has a radius of 0.75 inches and you specify a Radius of 1, the circle is scaled such that the radius is 1.75 inches.
3. Specify the Radius, the amount by which you want the circle scaled.
4. Specify a new number for resolution, if desired. (See the illustration at the beginning of this section.) Note: This changes the resolution for the selected circle only, independent of the global setting made through the Preferences dialog box, Options > Preferences > Entry/Edit.
5. Specify a different layer for the circle, if desired.
6. Click Apply (or OK if you are done editing circles).

To edit the characteristics of a selected arc:

1. Specify a new number for resolution, if desired. (See the illustration at the beginning of this section.) Note: This changes the resolution for the selected arc only, independent of the global setting made through the Preferences dialog box, Options > Preferences > Entry/Edit.
2. Specify a different layer for the arc, if desired.
3. Click Apply (or OK if you are done editing arcs).
Editing Polygons and Polylines

Several commands found on the Edit > Modify menu can assist you in editing polygons and polylines.

- The Join command allows selected polylines with coincident endpoints to be joined into a single polyline. If a closed shape results, the joined polylines are converted to a polygon.
- The Break command converts a selected polygon into a single polyline.
- The Explode command converts selected polygons or polylines into two-point polylines.

To join multiple polylines into a single polyline:

1. Select the individual polylines you want to join.
2. Choose Edit > Modify > Join. All coincident endpoints are joined. You can verify what has been joined by clicking on the shape to select it and observing whether or not the entire shape is selected.

To convert a polygon into a single polyline:

1. Select the polygon.
2. Choose Edit > Modify > Break. The starting and ending points of the polygon are broken, identified by a marker, and you can now manipulate the shape as a polyline.
Editing Designs

To convert a polygon or polyline to individual, two-point line segments:

1. Select the polygon or polyline.
2. Choose Edit > Modify > Explode. All vertices are disconnected leaving you with individual line segments that you can edit as needed.

![Vertices](image)

Adding a New Vertex

To add a new vertex to a polygon or polyline:

2. Click a point between two existing vertices, and move the pointer. A flexible line is drawn between the vertices and the pointer.
3. Click again to specify the new vertex and the shape is redrawn.

![Before, During, After](image)

Moving a Vertex

To move a vertex on a polygon or polyline to change its shape:

1. Click to select the vertex and drag the pointer in the desired direction. A flexible line is drawn from the affected vertex to the pointer.
2. Click again to specify the new location of the vertex and the shape is redrawn.
Deleting a Vertex

To delete a vertex on a shape you have drawn, be sure the Vertices filter is turned on (Options > Preferences > Select) and draw a selection window enclosing all vertices you want to delete. Click the Delete button on the toolbar and the shape is redrawn without those vertices.

Clicking anywhere on an arc deletes the arc and connects the former endpoints of the arc with a straight line.

Converting a Vertex to an Arc

You can convert any vertex to an arc and specify the desired radius of the arc, with respect to the units of the window.

To convert a vertex to an arc:

1. Choose Edit > Vertex > To Arc. You are prompted enter location of the vertex and a dialog box appears.
2. Change the radius as desired and click Apply.
3. Click any vertex you want to convert to an arc. The vertex is redrawn accordingly.

You can continue converting vertices in this manner using a different radius each time if desired, but you must click Apply each time you change the radius. When you are through making these changes, click OK to dismiss the dialog box.
Converting a Vertex to a Mitered Edge

You can convert any vertex to a mitered edge and specify the desired length of the mitered edge, with respect to the units of the window.

To convert a vertex to a mitered edge:

1. Choose Edit > Vertex > Miter. You are prompted to enter the location of the vertex and a dialog box appears.
2. Change the miter length as desired and click Apply.
3. Click any vertex you want to convert to a mitered edge. The vertex is redrawn accordingly.

You can continue converting vertices in this manner using a different miter length each time if desired, but you must click Apply each time you change the length. When you are through making these changes, click OK to dismiss the dialog box.
Stretching a Wire or an Edge of a Shape

The **Move > Move Edge** command enables you to change the shape of an existing wire, or to redefine a shape by stretching an edge (a segment between two vertices).

To stretch an edge:

1. Choose **Edit > Move > Move Edge**. You are prompted to enter the location of the line.
2. Click the edge you want to stretch. As you move the pointer, a ghost image moves with it and showing how the shape will be redrawn.
3. Click again to define the new shape.
Scaling an Object Using a Scaling Factor

To scale an object using a scaling factor:

1. Choose **Edit > Scale/Oversize > Scale** and the Scale dialog box appears.

2. Enter scaling factors for both X and Y.

   Scaling factors must be positive. Scaling factors greater than 1.0 increase the size of objects, while factors less than 1.0 decrease the size of objects. To scale the objects uniformly, enter the same scaling factor for both X and Y.

3. Click **OK** and you are prompted to enter a reference point on the object around which to scale.

4. Click to specify the reference point and the object is scaled.

Scaling an Object Relative to the Design Window Units

There are two commands, Oversize and Copy & Oversize, that enable you to scale an object with respect to the design units, for example, inches or mils. The Oversize command replaces the original image with a scaled image. The Copy & Oversize command places a copy of the selected object, using the size you specify, on the current entry layer, preserving the original object.

To scale the object itself, in Schem or Layout units:

1. Select the object.

2. Choose **Edit > Scale/Oversize > Oversize** and a dialog box appears.

   ![Over/Undersize](image)

   This field enables you to specify an amount by which the selected object should be scaled (in all directions). A positive number increases the size of the object by that amount; a negative number decreases the size of the object by that amount.
This field enables you to specify a cutoff angle for mitering corners. Any angle of a polygon smaller than the specified cutoff angle is mitered. The default cutoff angle is 45 degrees.

3. Make any necessary changes in the dialog box, and click OK.

To make a scaled copy of an object, in Schem or Layout units:

1. Select the object.
2. Choose Edit > Scale/Oversize > Copy & Oversize and a dialog box appears.
3. Specify the desired angle and click OK.

**Editing Existing Text and Text Attributes**

There are two methods of editing text you have added to your design: you can use the on-screen editor or edit through a dialog box. Note: To edit text attributes, you must use the dialog box method.

To edit text using the on-screen method:

1. Position the pointer over the text you want to edit and click. Notice the following changes:
   - The text takes on the color currently defined for Highlight in the Preferences dialog box (Options > Preferences > Display).
   - The status panel prompt changes to read, On-screen Text Editor: in progress
   - A vertical bar (|) representing a text insertion cursor appears in the line of text.

In this example, a 1 inch square was oversized by 0.1 resulting in a 1.2 inch square.

To make a scaled copy of an object, in Schem or Layout units:

1. Select the object.
2. Choose Edit > Scale/Oversize > Copy & Oversize and a dialog box appears.
3. Specify the desired angle and click OK.

**Editing Existing Text and Text Attributes**
2. Use the arrow keys or the mouse to reposition the cursor, as needed, near the text you want to change. Use the backspace key, as necessary, to make your changes.

3. When you are through, move the pointer away from the text and click once to end the text editing command.

To edit text using the dialog box method:

1. Choose **Edit > Edit Text**. The dialog box appears and you are prompted to enter the location of the text.

2. Click to select the text you want to edit. The selected text appears in the dialog box for editing. (If you type multiple lines as a block of text, that block appears.)

3. Make any desired changes to the text.

4. Make any desired changes to the text attributes.
   - **Font Type**—Schematic only—All True Type fonts installed on your system are available. Select the desired font from the drop-down list.

   **Note** On UNIX, if you want to add additional True Type fonts that were not supplied with ADS, copy them to `$HPEESOF_DIR/lib/fonts`.

   - **Point**—Represents the size of text in traditional units used in printing.
   - **Layer**—Enables you to select a different layer for the text.
   - **Placement Angle**—Enables you to rotate existing text by specifying an angle in degrees. Positive values rotate the text counterclockwise; negative values rotate it clockwise.
   - **Non-rotating (when in hierarchy)**—Select this option to prevent text on a symbol or design from being rotated when the symbol is rotated.
   - **Justification, Horizontal**—This setting represents two types of justification: one is how individual lines of text in a block of text are aligned with one another; the second is how an individual line of text or block of text is positioned horizontally, relative to the reference point you specified to begin typing the text.
   - **Justification, Vertical**—This setting aligns a string or block of text vertically, relative to the reference point you specified to begin typing the text.
5. Click **Apply**. Changes to the selected text are reflected immediately in the drawing area.

You can continue to select text and make changes, but you must click **Apply** for each set of changes for those changes to take effect.

6. When you are through making changes to text, click **OK** to dismiss the dialog box.

**Editing Wire/Pin Label Attributes**

To change the color, size, and font of existing wire labels, choose one of the following methods:

- Use **Edit > Wire/Pin Label > Wire/Pin Label Attributes**
- Double-click the wire label to display the dialog box
- Right-click and select **Wire/ Pin Label Attributes** from the pop-up menu

**Forcing Objects Back onto the Grid**

If an object is offset from the current grid spacing, you can force it back to the nearest grid point with the **Modify > Force to Grid** command. If the selected object is an item with pins, pin 1 is forced to the nearest grid point.

To force an object back onto the grid:

1. Select the object.

2. Choose **Edit > Modify > Force to Grid**. The selected object snaps to the grid.
Editing Designs
Chapter 7: Annotating Designs

You can annotate your schematic by adding a drawing sheet, inserting a variety of shapes, and adding text (including system variables such as date, time, etc.). For details, refer to the following topics:

• “Adding a Drawing Sheet” on page 7-1
• “Adding Text” on page 7-2
• “Drawing Shapes” on page 7-4

Adding a Drawing Sheet

If you want to use a drawing sheet that contains any constant information or graphics, such as a company logo, you will probably want to save it as a template enabling you to insert it in any design where it is needed.

To create a drawing sheet:

2. Supply a name for the file.
3. Choose Insert > Component > Component Library.
4. Select the Drawing Formats category.
5. Select the appropriate drawing sheet size, for example, FORMATA.
6. Click OK and move the pointer into the drawing area.
7. Note that the lower left corner serves as the reference point. Position the image of the drawing sheet as required and click to place it there.

To move the drawing sheet after placing it, you must be able to select it, and by default, the Drawing Format filter is turned off. To turn it on, choose Options > Preferences > Select and enable the Drawing Format option. If you do enable this filter, you will probably want to disable it again after moving the drawing sheet, before beginning your design work.
Annotating Designs

Hint If you want to reposition the lower left corner of the drawing sheet at the coordinates 0,0 (to assist in placing items using exact measurements), you can use the Set Origin command. Choose Edit > Modify > Set Origin and click the lower left corner of the drawing sheet. Use View All if necessary to bring the entire sheet into view.

8. Add all desired information.
9. Choose Save Design As Template to make it available for insertion in any design.

Adding Text

Once you have established the desired text attributes, you can add text to your design using the Text command on the Insert menu or the Text button on the toolbar. Prior to adding text, you should change the current entry layer to text1 (or a text layer you have created) and place all text on that layer.

To change the current entry layer:

Choose Insert > Entry Layer > text1.

Any text you add, or object you draw, will now be placed on the text1 layer until you change to another entry layer. Text will take on the characteristics defined in the Preferences dialog box (except for color, which is defined through the Layer Editor). For details on changing attributes of text:

- Prior to adding it to the drawing area, refer to the section, Setting Text Options in the Customization book.
- After adding it to the drawing area, refer to the section, “Editing Existing Text and Text Attributes” on page 6-37.

To add text to your design:

1. Choose Insert > Text. The status panel prompt changes to read, New_Text: Enter location for new text.
2. Position your cursor in the desired location, click once, and begin typing.
   If necessary, use the arrow keys, the backspace and spacebar to make changes. (You can drag the mouse across text to highlight it and type over it or use the
spacebar or backspace to delete it.) To continue the text on the next line, press Enter and continue typing.

• To type text in another location, click in that location and begin typing.

• To stop the text command, press Esc or move the pointer away from the new text and click once—to signify the end of that text block—then click the End Command button.

Hint  Context-sensitive editing is available for text. Position the pointer over the text, right click, and select Edit Text from the pop-up menu.

Using Variables to Display Design and System Information

You can add any of the following variables to your design to display the type of information indicated:

@dbname = Design name
@pname = Full path to design
@ddate = Date design was last saved
@dtime = Time design was last saved
@cdate = Current date
@cime = Current time
@SIM_HOST = Name of machine hosting the simulation
@SIM_DDS = Name of the data display
@SIM_DSS = Name of the simulation data set

To add variables to your text:

1. Choose Insert > Text.
2. Click to begin typing text and include any of the variables shown above as desired. For example:

   This version of @dbname was last saved on @ddate at @dtime.
Annotating Designs

3. Press Esc to stop the Text command and the variables are replaced by their equivalents.

Drawing Shapes

The Insert menu contains commands that enable you to draw a variety of shapes and lines to help annotate your schematic. Select End Command from the pop-up menu (or click the End Command toolbar button, or press Esc) during execution of any draw command, to terminate the command and remove the partial shape.

Hints:

- Several shapes that require you to specify multiple points (such as polygons, polylines, arcs) allow you to specify the last point by pressing the space bar.
- Context-sensitive editing is available for several shapes (rectangle, polygons, polylines) with respect to changing the layer on which the shape is drawn. Position the pointer over the shape, right click, and select the layer command from the pop-up menu.
- You can change the thickness of the lines of the following shapes drawn in the Schematic window (schematic view): polygons, polylines, rectangles, circles, arrows, and all arcs. (Edit > Modify > Line Thickness)
- You can set (in advance) the thickness of the lines of the following shapes drawn in the Schematic window (symbol view): polygon, polyline, rectangle, circle. To edit line thickness subsequently, choose Edit > Modify > Line Thickness.

To draw a rectangle (or square):

1. Choose Insert > Shape > Rectangle (or click the Rectangle button). You are prompted to enter the first corner.
2. Click to specify the first corner. You are prompted to enter the second corner.
3. As you move the mouse, a flexible box stretches from the anchor point to the position of the mouse, expanding and contracting as you move. When you are satisfied with the size, click to finish.
To draw a polygon:

1. Choose Insert > Shape > Polygon (or click on the Polygon button). You are prompted to enter a vertex.

2. Click to anchor the starting point of the polygon.

3. Move the cursor to the position where you want the first line segment to end, and click. A line appears between the two points.
   • At any time during entry of a polygon, you can choose one of the Arc commands to include an arc in your polygon.
   • You can use the Undo Vertex command to backtrack to the previous point anytime you want to erase the segment or arc you have just drawn.

   **Hint** If you want all line segments to be drawn perfectly horizontal or vertical, choose Options > Preferences > Entry/Edit Mode and check 90 degree angle only.

4. Continue in this manner until you are ready to draw the final line segment(s) completing your polygon.
   • To draw all but the last line segment, double-click or press the space bar while the pointer is still positioned over the last vertex.
   • To draw all but the last two line segments, move the pointer so that it is positioned over the next vertex, and double-click or press the space bar.

   The polygon is automatically closed. The illustration demonstrates the latter method.

To draw a polyline (a series of connected line segments):

1. Choose Insert > Shape > Polyline (or click on the Polyline button). You are prompted to enter a vertex.

2. Click to anchor the starting point of the polyline.
Annotating Designs

3. Move the cursor to the position where you want the first line segment to end, and click. A line appears between the two points.
   • At any time during entry of a polyline, you can choose one of the Arc commands to include an arc in your polyline.
   • You can use the Undo Vertex command to backtrack to the previous point anytime you want to erase the segment or arc you have just drawn.

4. When you have drawn the final line segment, double-click or press the space bar to end the Polyline command.

To draw an Arc:

1. Choose Insert > Shape > Arc (clockwise or counterclockwise). You are prompted Enter the start point of the arc.
2. Move the cursor into the drawing area and click left to specify the start point of the arc. You are prompted Enter the arc center.
3. Click to specify the center point of the arc. A flexible arc appears as you move your cursor. You are prompted Enter the ending point of the arc.
4. Click to specify the end point. If you are through drawing arcs, click End Command.

Hint  Context-sensitive editing is available for arcs. Position the pointer over the arc, right click, and select Edit Arc from the pop-up menu.

You can also draw an arc by specifying the start point, end point, and circumference. To draw an arc in this manner:

1. Choose Insert > Shape > Arc (start, end, circumference). You are prompted Start pt of arc.
2. Move the pointer into the drawing area and click left to specify the start point of the arc. You are prompted End pt of arc.

3. Click to specify the end point of the arc. You are prompted Circ point of arc. A flexible arc appears as you move the pointer.

4. Click to specify the final size of the arc.

To draw a circle:
1. Choose Circle from the toolbar or from the Insert menu. You are prompted to enter the circle center.
2. Click to specify the center point.
3. Drag the mouse until the circle is the desired size and click.

**Hint**  Context-sensitive editing is available for circles. Position the pointer over the circle, right click, and select Edit Circle from the pop-up menu.

To draw an arrow:
1. Choose Insert > Arrow. You are prompted to enter the first point. In the dialog box that appears, set the following options as needed:

   - **Number of Arrowheads**
     
     | One  | Two |
     |------|-----|

   - **Polygon arrowhead**—select to draw arrowhead as a polygon

     | Polyl ine arrowhead | Polyg on arrowhead |

   - **Arrowhead width in schematic units**:

     Arrowhead width increased (from default of 0.08) to 0.125

   - **Arrowhead length in schematic units**:

     Arrowhead length decreased (from default of 0.25) to 0.125
Annotating Designs

**Hint** To restore the default values/options, click Default.

2. Click **Apply**.
3. Click to specify the first point of the arrow. You are prompted to enter the second point.
4. Move the pointer as needed to identify the endpoint of the line segment and click.

To change the line thickness of an existing shape:
1. Select the shape.
2. Choose **Edit > Modify > Line Thickness**.
3. Select the desired thickness and click **OK**.

**Drawing Shapes Using Specific Coordinates**

The Coordinate Entry command enables you to draw a variety of shapes by specifying coordinates for each vertex.

To use the coordinate entry method for drawing:
1. Choose **Insert > Coordinate Entry** and a dialog box appears. Move the dialog box so that the desired design window is visible.
2. Choose the required drawing or editing command.
3. Enter the X and Y coordinates for the first point.

You can enter coordinates by typing them directly in the fields labeled X and Y, or you can use the up and down arrows of the X Increment and Y Increment fields to increase or decrease the values of the X and Y fields. By default, the X and Y Increment fields are set to the current snap spacing, but you can use any increment that meets your design needs.

**Note** Coordinate entry will modify the coordinates entered according to the current snapping rules. You may want to turn snapping off when using coordinate entry. To access snapping, use the tool bar button labeled **Toggle Snap Enabled Mode**.
If using the Rectangle command, specify coordinates for two corners opposite each other.

4. Click Apply.
5. Continue specifying all desired points, clicking Apply for each.

When drawing polygons with coordinate entry, click Apply for the final segment of the shape to be drawn automatically.
Chapter 8: Working with Symbols

Symbols are used to represent individual components in a schematic and subnetworks in hierarchical designs. Default symbols exist for schematics with 0 to 99 ports, but you might want to draw your own symbol for any of the following reasons:

- You want a symbol you feel better represents the schematic
- You want to replace the default symbol of a simulator component with one of your own
- You create a new simulator component (using the model builder) and need to create a schematic symbol for it

Schematic symbols consist of a symbol body and, optionally, symbol pins (interconnect points). If you are drawing a symbol to represent an electrical component or a subnetwork for a hierarchical design, you must add pins to the symbol body.

The default symbols have been created in a uniform manner. Custom symbols should be created in a similar manner, that is, their overall length, from pin to pin, should be a multiple of 0.125 inch. This ensures the custom symbol will connect easily to the set of supplied symbols. In addition, pin 1 should be located at the coordinates 0,0 which serve as the reference point when you place the symbol in a design.

A symbol can be defined in one of two ways:

- As part of a design file containing a schematic—when you need the symbol to represent only that schematic
- In a design file containing nothing but the symbol—when you want the symbol to be available to represent any schematic

An illustration representing these differences is shown next.
For information on assigning a symbol to a schematic, refer to the section “Assigning a Symbol to a Schematic” on page 8-15.
Switching Between Schematic and Symbol Views

When you are creating a schematic, the View menu displays the command Create/Edit Schematic Symbol. When you choose this command, you display the symbol view of the current design. If you look at the View menu again, you will see that the command name has changed to read Create/Edit Schematic. This enables you to switch back and forth between these views.

If you place an instance of your schematic design as a subnetwork—without creating a special symbol—a default symbol is used, based on the number of ports in your design. If you want to create a custom symbol for your design, you can switch to symbol view and:

- Accept the default generated symbol and then modify it
- Select one of the supplied symbols, which you can use as is or modify
- Click Cancel in the dialog box that appears and create your symbol from scratch

Refer to the following sections for details:

- “Generating a Symbol” on page 8-4
- “Using One of the Supplied Symbols” on page 8-5
- “Drawing a Custom Symbol” on page 8-6

Creating a Symbol for use with any Design

To create a symbol for use with any design:

1. Create a new (empty) design file.
2. Choose View > Create/Edit Schematic Symbol.
   - For details on how to copy and then modify one of the supplied symbols, refer to “Using One of the Supplied Symbols” on page 8-5
   - For details on creating a symbol from scratch, refer to “Drawing a Custom Symbol” on page 8-6
3. When the symbol is complete, you can associate any schematic with this symbol. For details refer to “Assigning a Symbol to a Schematic” on page 8-15.
Generating a Symbol

You can generate a symbol for your completed schematic providing minimal specifications.

To generate a symbol:

1. From the completed schematic, choose View > Create/Edit Schematic Symbol.
2. In the dialog box that appears, select the Auto-Generate tab and specify the desired symbol characteristics (or accept the defaults). The symbol characteristics are defined as follows:

   **Symbol Type**
   - Dual—Restricts pins to two sides of symbol body
   - Quad—Allows pins on all four sides of symbol body

   **Order Pins by**
   - Location—Numbers symbol pins in the same relative order as the ports on the schematic
   - Number—Numbers symbol pins sequentially in a left-right, top-down order

   **Replace existing symbol**—Replaces the current symbol, if one exists, with the one you are about to generate

   **Lead Length**—The length of any line drawn between the symbol body and a pin

   **Distance Between Pins**—Distance between pins drawn on the same side of the symbol body

3. Click OK. A symbol is drawn consisting of a symbol body, connecting lines, and pins.

**Hint** To regenerate the symbol specifying different symbol characteristics, choose Insert > Generate Symbol.

You can edit the generated symbol as desired at any time.

For details on drawing and editing shapes, refer to:

- "Drawing Shapes" on page 7-4
- "Editing Shapes" on page 6-29
For details on symbol-specific editing, refer to:

- “Establishing Pin Characteristics” on page 8-12
- “Positioning Parameters for Your Symbol” on page 8-14

**Using One of the Supplied Symbols**

You can use any of the symbols we supply and modify them or use them as is.

To associate a supplied symbol with your network:

1. From the completed schematic, choose View > Create/Edit Schematic Symbol.
2. In the dialog box that appears, select the Copy/Modify tab.
3. Select the desired symbol category from the Symbol Category drop-down list and the icons for that category are displayed. These categories represent the basic component libraries, but note that not all individual components will be displayed; if multiple components share the same symbol, only one of those components is displayed.
4. Click the desired symbol icon and its name is displayed in the Symbol name field.
   Alternatively, you can type a name directly in the Symbol name field:
   - Type an actual component name whose symbol you want to use
   - Type the name of a design file containing a symbol (or select it using the browser)
5. Click Apply to view the symbol in the design window and click OK when you are satisfied with your symbol selection. The program compares the number of pins on the symbol with the number of ports in the schematic view and reports any discrepancies.

You can edit the supplied symbol as desired at any time.

For details on drawing and editing shapes, refer to:

- “Drawing Shapes” on page 7-4
- “Editing Shapes” on page 6-29
Working with Symbols

Drawing a Custom Symbol

When you draw a custom symbol, you can draw it in a file containing a schematic, where it will be dedicated to that schematic, or you can draw it in an empty file and use it to represent any schematic.

Drawing Setup

Before you begin, you may find it helpful to review a number of the program’s defaults, and you will most likely need to make a few changes.

Setting Snap and Grid Spacing

By displaying a grid and drawing with snap enabled, you can quickly draw objects with great accuracy. To view or change these settings, use Options > Preferences > Grid/Snap. Snap mode offers options for snapping to many different types of objects. When drawing a custom symbol, the most important option will probably be Grid, however if you are drawing complex shapes, several other options may be helpful.

The display grid can be made visible or invisible. When you turn on the grid display, you should specify a sufficiently large factor of the snap spacing so that a grid is displayed even when the snap spacing is very fine. For example, the default snap spacing (in the Schematic window) is 0.125 which means the cursor snaps every 1/8 inch. The default display factor is 2 which means that the dots appear every 1/4 inch (0.125 x 2).

Before you begin drawing, check to see if the current grid spacing is set to something other than the default of 0.125 inch, and if it is, change it back to the default and make sure Enable Snap is turned on. This step ensures that your custom symbol will easily connect to the set of supplied symbols.

Hint Once you have drawn the symbol body and pins, you can change these settings if desired. For example, you might want to turn snap off before adding text to your design to give you more flexibility in the positioning of the text.

Specifying the Drawing Layer

All shapes and text are entered on layers. The color and visibility of any shape is controlled by the layer on which it is drawn. Before you begin drawing any part of the
symbol, change the current entry layer in accordance with the part you are about to
draw. For example, if you are creating a custom symbol, you should draw the symbol
body, pins, and lead lines on the symbody layer so that it will be on the same layer as
the supplied symbols, and subject to changes you make to that layer.

To change layers:

1. Choose **Insert > Entry Layer** and a dialog box appears listing all the currently
defined layers.
2. Select a layer that is appropriate for the task at hand.
3. Click **OK**. Anything you draw now is drawn on this layer. The name of the layer
   is displayed in the status panel of the Schematic window.

**Table 8-1** lists the default layers and the types of items placed on those layers (by
default).

<table>
<thead>
<tr>
<th>Layer Name</th>
<th>Layer Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>default</td>
<td>0</td>
<td>Objects drawn on an undefined layer are plotted on this layer. Also, if you delete a layer, any objects residing on that layer are moved to this layer.</td>
</tr>
<tr>
<td>user_symbody</td>
<td>1</td>
<td>User-created schematic symbol</td>
</tr>
<tr>
<td>user_symtxt</td>
<td>2</td>
<td>User-created schematic symbol text</td>
</tr>
<tr>
<td>user_symbol</td>
<td>3</td>
<td>User-created schematic symbol</td>
</tr>
<tr>
<td>wire</td>
<td>4</td>
<td>Wires</td>
</tr>
<tr>
<td>text1</td>
<td>5</td>
<td>Available layer name for text</td>
</tr>
<tr>
<td>labels</td>
<td>6</td>
<td>Component or item names</td>
</tr>
<tr>
<td>identifiers</td>
<td>7</td>
<td>Unique ID of components or items</td>
</tr>
<tr>
<td>parameters</td>
<td>8</td>
<td>Parameters of components or items</td>
</tr>
<tr>
<td>pin_num</td>
<td>9</td>
<td>Pin numbers and names for symbols†</td>
</tr>
<tr>
<td>notes</td>
<td>10</td>
<td>Any additional descriptive information you want to add</td>
</tr>
<tr>
<td>symbody</td>
<td>11</td>
<td>Schematic symbol body outline</td>
</tr>
<tr>
<td>symdesign</td>
<td>12</td>
<td>Portion of schematic symbol contained within symbol body</td>
</tr>
<tr>
<td>SPint</td>
<td>13</td>
<td>Signal Processing integer data††</td>
</tr>
<tr>
<td>SPFix</td>
<td>14</td>
<td>Signal Processing fixed point data††</td>
</tr>
</tbody>
</table>
### Table 8-1. Layer Names, Numbers, and Descriptions (continued)

<table>
<thead>
<tr>
<th>Layer name</th>
<th>Layer number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPfloat</td>
<td>15</td>
<td>Signal Processing floating point data††</td>
</tr>
<tr>
<td>SPcomplex</td>
<td>16</td>
<td>Signal Processing complex data††</td>
</tr>
<tr>
<td>SPtimed</td>
<td>17</td>
<td>Signal Processing timed data††</td>
</tr>
<tr>
<td>SPany</td>
<td>18</td>
<td>Signal Processing any data type††</td>
</tr>
<tr>
<td>SPother</td>
<td>19</td>
<td>Signal Processing user-defined data††</td>
</tr>
<tr>
<td>symtext</td>
<td>20</td>
<td>Text contained within schematic symbol body</td>
</tr>
<tr>
<td>symbodyFilled</td>
<td>21</td>
<td>Schematic symbol body with fill pattern</td>
</tr>
<tr>
<td>symbodySlash</td>
<td>22</td>
<td>The slash that identifies pin 1</td>
</tr>
</tbody>
</table>

† The pin_num layer is visible by default, but you must turn on Pin Numbers and/or Pin Names in the Visibility (on/off) section of the Pin/Tee tab of the Preferences dialog box to make pin numbers and names appear.

†† For details, refer to Chapter 3, Data Types, in the ADS Ptolemy Simulation manual.
Drawing the Symbol Body

The commands you need to draw your symbol can be found on the Insert menu. In addition, many of them are available on the default toolbar. For details on using these commands, refer to the section, “Drawing Shapes” on page 7-4.

Note  The Layer Editor dialog box enables you to determine the color and fill pattern, shape display, and line style for objects drawn on each layer.

Adding Pins to Your Symbol

There are two kinds of pins:

- Symbol Pin—A pin that represents a port of a network, that is needed to connect that network as a subnetwork in another design.
- Power Pin—A pin that also represents a port of a network, but does not appear in the schematic. The connection created via a power pin is an implied connection.

Symbol Pins

Remember that symbol pins should be located at 0.125-inch intervals so that your custom symbol will connect easily to the set of supplied symbols. In addition, pin 1 should be placed at the coordinates 0,0. Choose any of the methods shown below to accomplish this.

To specify 0,0 in the process of drawing pin 1:

1. Choose Insert > Coordinate Entry and a dialog box appears.
2. Choose Insert > Symbol Pin and a dialog box appears. Define the pin characteristics as described in the section, “Establishing Pin Characteristics” on page 8-12, and click Apply.
3. Enter the coordinates 0,0 in the Coordinate Entry dialog box and click Apply. Pin 1 is placed at 0,0. You can now use the View All command to reposition the image in your design window.
Working with Symbols

To move 0,0 to the center of the window before you begin:

1. Choose Pan from the View menu or the pop-up menu.
2. Click the small cross identifying the 0,0 coordinates (lower left corner of the drawing area). The 0,0 coordinates move to the center of your design window.
3. Choose Insert > Symbol Pin and a dialog box appears. Define the pin characteristics as described in the section, “Establishing Pin Characteristics” on page 8-12.

To move pin 1 to 0,0 after you have placed it:

1. Choose Insert > Symbol Pin and a dialog box appears. Define the pin characteristics as described in the section, “Establishing Pin Characteristics” on page 8-12, and click Apply.
2. Choose Edit > Modify > Set Origin.
3. Click the pin. The pin moves to 0,0. You can now use the View All command to reposition the image in your design window.

Power Pins

Power pins, also called inherited pins, are added in symbol view, but do not appear in the schematic. They create an implied connection. This connection is inherited from subnetworks throughout the hierarchy.

Note There is no support for power pins in the IFF translator in the current release.

To add a power pin to your symbol:

1. From the subnetwork design of interest, choose View > Create/Edit Schematic Symbol.
2. If a symbol does not yet exist for the current design, the Symbol Generator appears. Set the options as desired (refer to “Generating a Symbol” on page 8-4) and click OK. A symbol is generated that includes one pin for each port of the network.
   
   If a symbol already exists for the current design, that symbol appears.
3. Delete the symbol pin you want to replace with a power pin.
The numbering sequence for all pins of a given design must follow this rule: the symbol pin numbering sequence comes first, and the power pin numbering sequence follows.

5. In the dialog box that appears, set the pin characteristics as needed (refer to “Establishing Pin Characteristics” on page 8-12), including renumbering, where applicable, and click Apply.

6. Position the pointer in the drawing area and click to position the power pin.

7. Define additional power pins for this design as needed, and click Cancel to close the dialog box.

To override the default value of a power pin for a given instance:

1. Select the instance and choose Edit > Properties.

2. If the instance has more than one property, select the desired property. All power properties are inherited from instances throughout the hierarchy. All properties of this type will be identified as inherited.

3. Supply the desired Value (the name of the node or pin to which the invisible power pin should be connected).
Establishing Pin Characteristics

The pin characteristics are defined as follows:

- **Name**—Optional. The pin name is not displayed on your schematic unless you select the Pin Names option in **Options > Preferences > Pin/Tee**.

- **Number**—Optional. A default pin number is displayed. This number is automatically incremented as each pin is added. To display pin numbers on the schematic, select Pin Numbers in **Options > Preferences > Pin/Tee**.

- **Orientation Angle**—Optional. This feature is only used by the program when generating a schematic from a layout. It enables you to specify an orientation angle for each pin that determines the orientation of an item connected directly to that pin. Any angle from −90 to 180 degrees is allowed, but we recommend 90-degree increments. The recommended angles for schematic symbol pins are shown in the following illustration.
• **Type**
  - **Input**—Identifies the pin as an input port
  - **Output**—Identifies the pin as an output port
  - **Input/Output**—Identifies the pin as an input or output port
• **Power (<property>:<value>)**—Power pins only. Supply a property or name (a unique identifier) and a default value, such as the name of a global node contained in the hierarchy, separated by a colon.

To edit existing pin characteristics:

1. From symbol view (View > Create/Edit Schematic Symbol), choose **Edit > Symbol Pin** or for power pins, **Edit > Power Pin**.
2. Click the pin of interest.
3. Change the settings as desired and click **OK**.

**Note**  When you create a symbol for use with any design, it is only available in the project directory in which you create it, unless you modify certain configuration files (and for model builder usage, modify AEL files according to stated guidelines). If you want the symbol to be available for all design work, refer to the section, “Making Symbols Available Globally” on page 8-16.
Positioning Parameters for Your Symbol

By default, when you define parameters for your subnetwork (File > Design Parameters), those parameters are positioned in the same manner as the parameters of supplied components. You can position these parameters by adding references to them using the onscreen editor in symbol view.

To position user-defined parameters for a subnetwork symbol:

1. Open the design for which you want to customize parameter positions.
2. In symbol view (Edit > Create/Edit Schematic Symbol), choose Insert > Text (or click the Text icon on the toolbar).
3. Position the cursor where you want a given parameter to appear (relative to the symbol) and click once.
4. Type the parameter name—as defined in the Design Parameters dialog box—beginning with the at symbol (@). For example, if your subnetwork has a parameter width, type @width. (Parameters names are case sensitive on UNIX.)
5. To end the text string, do one of the following:
   • Move the cursor away from the text and click once. (That string is done, but the Text command is still in effect and you can click in a new location to add another string.)
   • Choose End Command. (That string is done and the Text command ends.)

Hint   When using the onscreen editor to position individual parameters, do not press Enter to move from one parameter to another; you must treat each parameter as an individual text string.

When you place the subnetwork hierarchically, the parameters you positioned in symbol view appear in the same position, relative to the network symbol.
User-defined parameters positioned in this manner:

- Take on the color of the layer on which the @<parameter_name> string was placed.
- Take on the font and size defined for other parameters (in advance, through Options > Preferences > Component Text/Wire Label or with editing, through Edit > Component > Component Text Attributes).

Assigning a Symbol to a Schematic

Symbols are stored in design (.dsn) files. If you generate a symbol for a particular schematic, or create one in a design file containing a schematic, then that symbol is stored in the same design file as the schematic and that symbol is automatically associated with that schematic, unless you explicitly specify the name of another symbol (design file). You can verify the symbol being used for any given schematic by opening that schematic and choosing File > Design Parameters, clicking the General tab and noting the name in the Symbol Name field. If it reflects the current design name (minus the .dsn extension), then the program will look in this file for the symbol.

If you create a symbol in its own design file—which makes it available to represent any schematic—you must assign that symbol to the desired schematic.

To assign a symbol to the schematic:

1. Open the schematic design.
2. Choose File > Design Parameters and the Design Definition dialog box appears.
3. In the Symbol Name field, type the name of the file (minus the .dsn extension) that contains the desired symbol.

**Hint** The drop-down list of symbols can be modified to include any supplied symbols as well as custom symbols. For details refer to the section, Modifying the List of Available Symbol Names in the Customization manual.

4. Click **OK**.

**Hint** If you generate a symbol and then decide to use a custom one instead, after you type the symbol filename in the Symbol Name field, click the Save AEL button in the dialog box to save the change.

5. Choose **File > Save Design**.

The next time you place this design within another design, the new symbol will appear.

**Hint** To place your design within another design, select the **Library Browser > Subnetworks** category. Your design name should appear in the Subnetworks list.

**Making Symbols Available Globally**

Custom symbols are only available in the project directory where you create them unless you modify the search path of a particular variable in a configuration file. In addition, if you want the names of these symbols to appear for selection within the related dialog box, you must modify a certain AEL file.

While it is possible to leave all files containing custom symbols in the project directories in which they were created, the aforementioned configuration changes will be greatly simplified if you move all custom symbols to central locations, one location for individual use and one for site use. (If necessary, see your system administrator to create the directory for site use.) We recommend maintaining the same directory structure used by Advanced Design System. Thus, the symbols should be placed in the following locations, in accordance with their use (circuit vs. adsptolemy):
Use these directories on UNIX:

<table>
<thead>
<tr>
<th>UNIX</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Individual Use</td>
<td>$HOME/hpeesof/circuit/symbols</td>
<td>$HOME/hpeesof/adsptolemy/symbols</td>
</tr>
<tr>
<td>Site Use</td>
<td>$HPEESOF_DIR/custom/circuit/symbols</td>
<td>$HPEESOF_DIR/custom/adsptolemy/symbols</td>
</tr>
</tbody>
</table>

Use these directories on the PC:

<table>
<thead>
<tr>
<th>PC*</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Individual Use</td>
<td>%HOME%\ hpeesof/ circuit/ symbols</td>
<td>%HOME%\ hpeesof/ adsptolemy/ symbols</td>
</tr>
<tr>
<td>Site Use</td>
<td>%HPEESOF_DIR%/ custom/ circuit/ symbols</td>
<td>%HPEESOF_DIR%/ custom/ adsptolemy/ symbols</td>
</tr>
</tbody>
</table>

* %HOME% represents the path you specified as the Home Folder during installation (C:\ users\ default by default);
* %HPEESOF_DIR% represents the path you specified as your Program Folder during installation (C:\ ADS200x by default).

**Note**  If you use a directory other than one of those shown in the tables, then you must declare the variable USR_DSN_PATH and provide the search path.

To access custom symbols—if stored in a directory other than one of the defaults:

1. Using any text editor, open the file $HOME/ hpessof/ config/ de_sim.cfg.

2. Add the variable USR_DSN_PATH and set it equal to the path you have chosen for your symbols directory.

3. Save the file.

Once you have created the symbols directory (regardless of where), move the files containing the custom symbols from their current project directory locations into the appropriate, newly created directory.
Modifying Search Paths

Search paths that control the order of directories searched are defined by certain program variables. These variables should be modified in a local copy of the de_sim.cfg file. This file is written to the / config directory during installation and should not be modified there. But you can open this file and copy the default variable definition (where applicable), then paste it in your own local copy and modify it. (This simplifies typing a lengthy search path.)

The program creates a de_sim.cfg file automatically in $HOME/hpeesof/config. Settings modified here apply to all projects.

To modify the search path of the variable:

1. Using any text editor, open the de_sim.cfg file in $HPEESOF_DIR/config.
2. Locate the variable definition, copy it, and close the file.
3. Open the de_sim.cfg file in your $HOME/hpeesof/config directory and paste the variable definition.
4. Edit the variable definition as needed.
5. Save the file.
Chapter 9: Creating a Layout

Whether you create a layout directly as a layout, generate it from an existing schematic, or create it simultaneously as you create a schematic, there are only three basic steps to the process:

- Set up the layout environment. Customize the environment for the design you wish to create.
- Create the layout, as described in this chapter.
- Edit and complete the layout, as described in “Layout Basics” on page 1-12.

The Layout Environment

The following settings are especially important when you will be drawing shapes in the Layout window, but you should familiarize yourself with these setup features even if you will be generating your layout from a schematic.

- Set snap and grid spacing (see the Customization Manual). By making the grid visible, then drawing in snap mode, you can draw shapes with exact size and spacing. Keep in mind that while it doesn't always cause performance problems, the intersection snap mode is the slowest of all snap modes so you should use this mode only when necessary.
- Set up your layer definitions (see the Customization Manual)
- Specify the drawing layer (see the Customization Manual). All shapes are entered on layers. The color and visibility of any shape is controlled by the layer on which it is drawn. Before you begin drawing, specify the current entry layer according to the intended purpose.

Using the Layout Ruler

You can place a ruler on a layout and use it to size objects you draw. Use the following steps to place and configure a ruler on a layout.

1. Choose Insert > Ruler in a Layout window.
2. Click within the layout to mark the start and end points for placing the ruler. Press Esc to exit from the ruler placement mode.
Creating a Layout

3. Double-click the placed ruler or choose **Edit > Component > Edit Component Parameters** to display the Ruler dialog box where you can edit the parameters to customize the ruler you have placed.

4. Edit the parameter settings
   
   Select the parameter that you want to change from the Select Parameter list. You can either enter a value for it directly or you can click the Equation Editor button to display the Equation Editor dialog box where you can choose from a list of variables to define an expression to calculate the value. The parameters are:
   
   - **LineLength**: Length of the ruler
   - **MajorTick**: Length of the major tick on the ruler
   - **MinorTick**: Length of the minor tick on the ruler
   - **MajorUnits**: Units used for the major ticks on the ruler
   - **MinorUnits**: Units used for the minor ticks on the ruler
   - **Layer**: Layer on which the ruler is placed
   - **TextHeight**: The text height used to display units on the ruler
   - **Units**: Default unit of measure used by the ruler. You can override this default by specifying a different unit for an individual parameter
   - **TextPrecision**: Precision used to display length text on the ruler
   - **TextPOrientation**: Orientation used to display length text. The choices are horizontal, vertical-left, and vertical-right.
   - **TextOrder**: Order (ascending or descending) used to display length text

5. Click **OK** to save the change and close the dialog box.
Creating a Layout Manually

When you create a layout directly, you place components or shapes in the Layout window. You can select components from either the palette or the library list. You can draw shapes with the cursor or by designating coordinates.

To Insert a Shape or Polyline:
1. Select an icon (or Insert command).
2. Follow the instructions in the lower, left corner of the window.

To Insert a Component from the Palette or Library List:
1. Select the desired component.
2. Drag to the desired location in the Layout window.
3. Click to place the component in the desired location.

Inserting Components
You can insert components using any of the following methods:
- A component palette
- The component library
- Typing a component name in the Component History field (then press Enter)
- Creating a hot key for it

Using Construction Lines
Construction lines can help you align parts, shapes, and text. The lines are infinitely long, so you can place components in one area, scroll the view of the window, and know that you are lining up objects correctly.

To add a construction line:
2. Click any two points along the line you want drawn.

Placing Components by Defining Coordinates
Use the following steps to place a component at specific coordinates:
Creating a Layout

1. Select a component.
2. Choose the menu command **Insert > Coordinate Entry**.
3. In the Coordinate Entry dialog box, enter a value for X and a value for Y.
4. Click **Apply**. The component is placed in the Layout window, with pin 1 at the specified coordinates.

**Hint** By default, the X and Y Increment fields are set to the current snap spacing, but you can use any increment that meets your design needs.

**Identifying Unconnected and Connected Pins**

When you place a component in the Layout window, note that each pin is outlined, and that when you connect two pins, the outline disappears. As described in the Customization Manual, you can modify the highlight color of pins as well as the color of connections.

**Drawing Shapes**

In the Layout window, you can use the following geometric forms when creating layout shapes:

- Polygons
Shapes can be stretched and merged, and you can move or delete their vertex points. The Insert menu contains commands that enable you to draw a variety of shapes and lines. Many of the Insert menu commands are also found as icons on the toolbar.

**Note** Selecting the cursor on the toolbar during execution of any Insert command terminates the command and removes the incomplete shape.

To draw a shape:

1. Either click the shape icon on the toolbar, or choose **Insert** > `<desired_shape>`.
2. Follow the tips shown in the status panel.
3. Click to place the shape.

**Drawing a Polygon**: Enter line segments, and double-click to automatically create the closing segment.

- Including an Arc in a Polygon: Any time during the creation of the polygon, choose **Insert** > **Arc** (`<desired_direction>`).
- Erasing a Newly Drawn Segment or Arc: To backtrack to the previous point, choose **Insert** > **Undo Vertex**.

**Drawing a Polyline**: Enter line segments, and double-click to end the final segment.

- Including an Arc in a Polyline: Any time during the creation of a polyline, choose either **Insert** > **Arc** (`<desired_direction>`).
- Erasing a Newly Drawn Segment or Arc: To backtrack to the previous point, choose **Insert** > **Undo Vertex**.

**Drawing a Rectangle**: Enter two corners.
Creating a Layout

Drawing a Circle: Enter the center point, then a point on the perimeter.
Drawing a Dimension Line: Enter the end points.
Drawing an Arc: Enter the point where the arc begins, the center of the arc, and the point where the arc ends. You can draw an arc clockwise or counter-clockwise.

![Start point - Center point - End point diagram]

**Note**  Only closed shapes (polygons, circles, rectangles) can be displayed filled; shapes created with polylines (such as arcs) cannot.

**Undoing a Vertex**

To remove the last arc or vertex entered while creating a polygon, polyline, wire, trace, or path, choose the menu command **Insert > Undo Vertex**.

**Drawing Shapes by Entering Coordinates**

Just as you can place a component by specifying coordinates (see “Placing Components by Defining Coordinates” on page 9-3), you can draw a shape by specifying the coordinates required for that shape.

1. Select the desired drawing command.
2. Choose the menu command **Insert > Coordinate Entry**.
3. In the Coordinate Entry dialog box, specify the desired X and Y coordinates for the anchor point and press Enter (or click Apply).
4. Continue specifying all points required for the selected shape.

By default, the X and Y Increment fields are set to the current snap spacing, but you can use any increment that meets your design needs.
Adding Ports and Grounds

Use the following steps to add a port or ground to a layout.

1. Click the port or ground symbol on the toolbar (or choose Insert > Port or Insert > Ground).
2. Select the appropriate rotation by clicking the toolbar button (Rotate By -90) as needed.
3. Move the pointer into the drawing area, position the symbol as needed, and click to place it there.

Use one of the following methods to edit the size of the ports and grounds in your layout.

- The default size in the Placement tab in the Preferences dialog box (Options > Preferences). Use this method to set a size if you have a predetermined standard.
- The size of all placed items using the Port/ Ground Size dialog box (Edit > Components Port/Ground Size). Any changes you make to the size here are applied to all ports and grounds. Changing the size in this manner also updates the preference in the Preference dialog box. Use this method to experiment with and arrive at an optimal size for the items in your layout.

The item size you specify is based on one of the following units:

- Layout Units specified for the layout window. The preference is displayed in the lower right corner of the window. This is the simpler method for ensuring a consistent size.
- Screen Pixels at the instant the item is placed. Keep in mind that you can rely on this method to achieve a uniform item size only if you use the same zoom factor each time you place an item.
Creating a Layout

**Designating Edge and Area Ports**

An edge port is created by placing a polyline or arc into your layout and then designating that this shape is associated with a specific point port. An area port is created by placing a polygon, circle, rectangle, or path into your layout and then designating that this shape is associated with a specific point port. You may have multiple edge and area ports associated with one port and they may be on multiple layers. See “Using Edge and Area Ports” on page 13-8.

**Working with Traces**

Traces are wires with width and a bend type, and are used to represent physical transmission lines. Like wires, they can be used to connect components. For simulation purposes, there is no difference between a trace connection and a wire connection. Traces are normally simulated as simple connections (shorts). However they can be converted to or simulated as transmission lines, to allow for more accurate simulation. You can:

- Explicitly convert them to transmission lines (Edit > Path/Trace/Wire > Convert Traces). In this case, the selected traces are actually removed and replaced by an equivalent transmission line component in the layout itself. For details, refer to “Explicitly Converting Traces to Transmission Lines” on page 9-11
- Simulate them as transmission lines without actually converting them. In this case, the traces are not replaced, but an underlying subnetwork is created for each one, and that subnetwork contains the equivalent transmission line. The subnetwork creation occurs during the Design Synchronization process (Generate/Update). For details, refer to “Simulating Traces as Transmission Lines” on page 9-12.

**Trace Routing**

Once components are placed, they can be interconnected. Parts can be connected either by abutting their pins or by drawing a wire or trace between them. If pins are abutted, moving the parts does not disconnect the pins. Instead, a wire is drawn between them. Wires and traces are stored in the same way in the program. Wires are traces with a zero width. Thus, wires can be converted to traces and back again by changing their width (Edit > Path/Trace/Wire > Edit Path/Trace/Wire).

Traces can be entered on any layer, though by default, traces that you want to simulate should be placed on specific layers. For traces that will be simulated as
Creating a Layout Manually

microstrip or stripline, the trace should be entered on layer 1 (cond); for traces that will be simulated as PCB transmission line components, you should use layers 16-25 (pcb1-9). To change the current entry layer before inserting a trace, use Insert > Entry Layer and select the appropriate layer.

You can extend a path using the Edit > Point > Add (Vertex) command, or create another path abutting exactly to the end of the existing path and use the Edit > Modify > Join command to create a single path. The path can then be converted back to a trace if both ends of the path are exactly abutting to connecting pins. You can use the Snap to Pin mode in the Grid dialog box to make sure the end points are exactly coincident with the pins.

When moving parts connected with traces, the traces will be re-routed. By default, in layout, traces and wires will be re-routed from their end-points to maintain connectivity. You can have the whole connection re-routed using the Re-route entire trace attached to moved component preference in the Entry/ Edit tab of the Preferences dialog box (Options > Preferences). Traces and wires are re-routed to remain orthogonal with the fewest corner jogs introduced. To check for overlapping components, use the option by that name under Tools > Check Design.

Inserting Traces

Traces have the same restriction as wires do in schematic: they cannot form a short (connect back on themselves). Also, each trace has a uniform width and corner type (curved, mitered, square). To introduce a step, taper, or gap you must add a step, taper, or gap component, and connect the trace to it. Some limitations of using traces can be overcome by converting traces to paths. Refer to “Working with Paths” on page 9-15.

---

Note If a trace contains a bend, the shortest segment that is part of that vertex cannot be shorter than $3 \times \frac{w}{4}$ where $w$ is the width of the trace.

To insert a trace:

1. Choose Insert > Trace.

2. In the dialog box that appears, set the trace characteristics as desired.
   - Corner Type—Select from Mitered, Square, Curve
Creating a Layout

- Width—The desired width for the trace
- Mitered Corner Cutoff Ratio (%)—The desired cutoff ratio for the corner type Mitered
- Curve Radius—The desired curve radius for the corner type Curve

**Hint**  If you make changes to the current attribute settings, and want to return to the settings as they were when you brought up the dialog box, you can click Reset, if you have not yet clicked Apply.

3. Click **Apply** to insert a trace using the current settings.

4. Move the pointer into the Layout window and click to specify the first endpoint of the trace.

5. Move the pointer to the desired endpoint (or vertex) for this segment. Notice that the Trace dialog box Line Length region is dynamically updated as you move the pointer so that you can easily make the trace the exact length you want it.

   ![Line Length](image)

   Click to specify the endpoint (or vertex) for this segment.

6. Continue in this manner until the trace is complete, and signify the final endpoint by double-clicking or pressing the Spacebar.
Explicitly Converting Traces to Transmission Lines

You can explicitly convert traces to transmission lines for more accurate simulation results.

**Important** When you explicitly convert a trace to a transmission line, it is a one-way conversion; you cannot change a transmission line back into a trace.

To explicitly convert traces to transmission lines:

1. Select the traces you want to convert.

**Hint** To select all transmission lines on a given layer, make that layer the current entry layer and choose **Select > Select All On Layer**.

2. Select **Edit > Path/Trace/Wire > Convert Traces**.

3. In the Trace Control dialog box, select the type to convert trace to:
   - Transmission line elements
   - Single transmission line element—With this choice, you must also provide the name for that element. A default is provided, based on the selected Element Set.
   - Nodal connection (short)

4. Select the desired Element Set.
Creating a Layout

5. Provide the appropriate Substrate Reference. The asterisk (*) indicates the default Instance Name of the first instance of this type placed in your design.

6. Click OK.

The following illustration shows traces converted to microstrip with square corners. The parameters for each element are derived from the physical dimensions of the trace segments.

Simulating Traces as Transmission Lines

This method allows you to include transmission line effects in simulation, without cluttering your schematic or layout with numerous transmission line components.

During the design synchronization process, a subnetwork is created for each trace. This subnetwork is a transmission line equivalent based on the selected Element Set in the Trace Control dialog box (accessed through the Generate/Update dialog box, available from the Schematic and Layout menus). When simulating, the transmission line subnetworks are passed to the simulator for analysis.

Once you run through the design synchronization process, you will find you can use the View > Push Into Hierarchy command to view (in either the Schematic or Layout window) the actual transmission line equivalent generated by the design synchronization process. If you are working from the layout and you modify the traces, you must run the design synchronization process again for the subnetworks to be updated. Tee components are automatically created and accounted for.
The following illustration shows the MLIN subnetwork that is created during the design synchronization process, from a single trace and two ports (ports are required).

For details on the design synchronization process, refer to “Design Synchronization” on page 12-1.

**Inserting Meander Traces**

Meander traces enable you to quickly insert traces with specific characteristics including length, spacing, and orientation.

Creating a Layout Manually 9-13
Creating a Layout

- Corner Type—Select from Mitered, Square, Curve (see “Working with Traces” on page 9-8 for illustration of corner types)
- Starting Direction—The direction (clockwise or counterclockwise) in which the first two segments connected to the starting lead are drawn
- Ending Direction—The direction (clockwise or counterclockwise) in which the last two segments connected to the ending lead are drawn
- Width—The desired width for the trace
- Minimum Spacing—The minimum spacing between the parallel trace segments
- Line Length—The total length of the trace, including the lead length segments
- Mitered Corner Cutoff Ratio (%)—The desired cutoff ratio for the corner type Mitered
- Curve Radius—The desired curve radius for the corner type Curve
- Lead Length—The length of the starting and ending segments
- Meander Line Orientation—Select Vertical if you want the trace to meander vertically between the specified starting and ending leads; select Horizontal if you want the trace to meander horizontally between the specified starting and ending leads.

To insert a meander trace:

1. Choose Insert > Meander Trace. In the dialog box that appears, set the options as desired and click Apply.
2. Move the pointer into the drawing area and click to specify the endpoint of the starting lead.

3. Move the pointer as needed in both the direction of X and Y until you see the ghost image of the meander trace.

4. Adjust as needed and click to specify the endpoint of the ending lead.

**Working with Paths**

Paths are polylines with width. Paths have no connectivity information associated with them, but can start and end at any point and can be converted to traces.

![Diagram of a path with points p1, p2, and p3 showing the width and distance constraints.]

**Note**  If a trace or path contains a bend, the shortest segment that is part of that vertex cannot be shorter than \(3 \times \frac{w}{4}\) where \(w\) is the width of the trace.

To draw a path between two points:

1. Choose **Insert > Path**. The Path dialog box appears.

2. Specify a corner type and width.
   - Corner Type lists the available options for corner types.
   - Width sets the width of the path, with respect to the current design unit.

3. Set the path attributes and click **Apply**.

4. Position the pointer at the start point and click.

5. Position the pointer at the end point and click. A path is drawn between the specified points.
Creating a Layout

To make certain the corner of a curved path is exactly where you want it, try one of the following methods:

- Draw a square path and then use the command `Edit Path/Trace/Wire` to change it to a curved path.
- Specify the vertices observing the coordinate readouts in the status panel and draw as though you were drawing a square path.

Differences Between Paths and Traces

Paths and traces are very similar in the way that they are created and edited. They both are represented in layout as lines with a width and can contain chamfered or curved corners. Paths and traces can both make connections in a layout design, though there are some subtle differences in how they can be used.

<table>
<thead>
<tr>
<th>Traces</th>
<th>Paths</th>
</tr>
</thead>
<tbody>
<tr>
<td>can only make connections at pins (point pins from other items can also make a connection to a trace along the centerline of the trace if the point pin is placed on the center of the trace)</td>
<td>connections can be made anywhere along the path</td>
</tr>
<tr>
<td>using design synchronization, can be synchronized in a schematic as a wire (short) or as transmission line components</td>
<td>using design synchronization, can be synchronized in a schematic as a wire (short)</td>
</tr>
<tr>
<td>joining two traces at their endpoints will merge the traces into a single trace</td>
<td>can be joined using <code>Edit &gt; Merge</code></td>
</tr>
</tbody>
</table>

9-16 Creating a Layout Manually
Creating a Layout Manually

Note Traces can be converted to paths by selecting Edit > Path/Trace/Wire > Convert Trace to Path. Paths can be converted to traces by selecting Edit > Path/Trace/Wire > Convert Path to Trace.

Creating Interconnects with Shapes

Starting with ADS 2004A, connections can be created by contact with/between polygons, circles, arcs, rectangles, and paths. In order to correctly calculate, the layer connections must be specified correctly in the Layer Binding dialog. See Defining Port Connections (Layer Binding) in chapter 3 of the Customization manual for more information on contact between different layers.

See “Adding pins/ports to artwork” on page 13-5 for information on associating polygons with ports.

Note Polylines do not create connections.

Working with Wires

You can use a temporary wire to create an electrical connection between layout components. Wires make it easy to move components within a layout without breaking connectivity. Wires also make it easy to simulate the performance of a circuit before you insert the lines that will actually be used. The simulator treats wires as short circuits (as though the connected components are physically touching). Later you can connect components directly, or replace the wires with traces and repeat the simulation to verify circuit performance.

At times, unintentional gaps can be generated in a layout. When this happens, a wire appears to indicate an electrical connection between elements that are not abutting. Note that moving artwork can introduce new wires (disconnect components). You can often adjust the layout parameters to close gaps, or introduce new elements, rather than manually moving objects.
Creating a Layout

Inserting Wires
When you draw wires, they must start and end at either a pin or another wire.

1. Choose Insert > Wire.
2. Click on the pin (or wire) at one end.
3. Click on the pin (or wire) at the other end. A wire is drawn between the specified points.

Inserting Text
You can add text to a design using either the Text command from the Insert menu or the Text icon on the toolbar.

1. Choose Insert > Text. The status panel prompt displays the following message: New Text: Enter location for new text
2. Click the pointer at the desired location and begin typing.
   You can use the arrow keys, the backspace and delete keys to make changes; you can also drag across text to highlight it, then re-type or delete it.
   To continue the text on the next line, press Enter and continue typing.
3. When you are through with this text, move the pointer away from the text and click.
   To type text in another location, click in that location and begin typing.
4. When you are through adding text, choose **Insert > End Command** or click the cursor on the toolbar.

**Notes**  To establish default attributes for new text, choose **Options > Preferences > Text**. To edit existing text and text attributes, choose **Edit > Edit Text**.

**Layout Block Text Fonts**

When creating physical designs for output to a production process, you can provide text that displays on the produced parts. Often this means that the text must be composed of primitives shapes that have thickness to them, not a simple stroke font.

The Advanced Design System has a palette of polygon-based text fonts, called Block Text Fonts, to satisfy this need.

The program supports a total of 14 fonts. The first eight are the same as the fonts that were supplied in the Microwave Development System (MDS). The supported fonts are:

- **din17** - An industrial standard font.
- **iso3098** - Another industrial standard font.
- **roman** - A font similar to the Times Roman font.
Creating a Layout

smooth - A font with the characters more round and smooth.
italic - An italic font.
standard - The original font supplied in MDS.
gothic - A font that's more for fun than practical use.
math - A font of special math characters.
sans - A basic sans serif style font.
sansbold - A bolder version of sans.
filled - A font with no holes in the characters.
filledbold - A bolder version of filled.
straight - A font with no curves.
straightfilled - A filled (no holes) version of straight.

These are not simple stroke fonts that are put through a translation process, but are actually implemented as polygon definitions for each letter in the font. The fonts are implemented as components (built using the Graphical Cell Compiler) and, therefore, have a wide range of attributes available in the component edit dialog.
The attributes are:

**Text String**—The actual text string to be displayed. The text string should not be encased in quotes (""") but may contain quotes that display in the placed component. The text can have multiple lines with the characters backslash-n (\n) representing a new line. The parameter can be a reference using the "@" prefix, so you can specify a variable name. The contents of the variable is the text string displayed (see "Example" on page 9-22).

**Character Height**—The height of the characters. This is actually the height of the standard character size for the specific font. Lower-case characters are not as large and characters with descenders (for example: g, j, p, q, and y) extend below the standard size.

**Character Spacing**—A multiplier for the horizontal space used for the standard character size. When set to 1.0, large characters like W or M can touch. If set to a value smaller than 1.0, characters can overlap.
Creating a Layout

**Line Spacing**—A multiplier for the space vertical space used for the standard character size. The default value of 1.2 leaves enough room between lines so that characters with descenders do not overlap the characters of the next line.

**Insertion Layer**—The numeric layer ID where the polygons for the text string are placed.

The polygon definitions for each font are not loaded unless a font component is being inserted or edited, so that startup speed or memory usage is not impacted. When a font is used for the first time in a session, a small dialog informs you that the font is being loaded. When the loading is complete, the dialog closes.

![Wait for font.png](Wait_for_font.png)

After a font is loaded, you do not need to load it again for the duration of the current session of ADS. In addition, you do not need to load the font to view a previously-inserted text component since the component is simply a set of polygons. You only need to load the font if you edit the component (causing it to be re-created) or if you insert a new text component in that font.

After you insert a text component, you can modify all component attributes using Edit/Component/Edit Component Parameters. You can edit the text string, change any of the physical-size attributes, or change the layer the component is inserted on—you can adjust the text easily so it can fit within any physical constraints in the design.

If you need to change the font on a text component, you can use Edit/Component/Swap Components. Since the component name is the font name, changing the component name to a different font causes the component to be re-created in that new font.

**Example**

This example shows how a block font text component can reference a schematic variable and display its contents.

First, open a Schematic window and place a Var component. Then edit the component and add a name/value pair to be used in Layout.
Next, open a Layout window. Confirm that the Layout window is for the same design as the Schematic window. Select a font to insert. In the text field use the "@" syntax to specify the variable name defined in the Schematic in the Var component.

![Variable Name Example](image)

Insert the component and notice that the contents of the variable, not the variable name, is displayed.

![Variable Insertion Example](image)
Creating a Layout from a Schematic

You can ensure that a schematic and layout are equivalent by using the design synchronization process (Generate/Update) whether you are creating a schematic from a layout, or a layout from a schematic. When you do either, the program examines each element in the source representation and modifies or creates an equivalent element in the target representation.

- For details on automatically generating a layout or schematic, refer to “Design Synchronization” on page 12-1.
- For details on creating the two representations simultaneously, refer to the section, “Creating a Layout as You Create a Schematic” on page 9-24.

Creating a Layout as You Create a Schematic

Creating a layout as you create a schematic is similar to creating a layout from a finished schematic, except that you place components simultaneously in both the source and target representations.

1. From either window, choose Options > Preferences > Placement.

2. Enable either Dual Representation or Always Design Synchronize.

   - Dual Representation enables you to place equivalent components in the other representation quickly, because the component is already selected in the second window.
   - Always Design Synchronize causes the program to fully synchronize both representations after each part is placed.

Common Potential Problems

There are several design aspects that can be problematic if you are not aware of how to handle them:

- Junctions (refer to “Using TEE Junctions in a Schematic” on page 12-7)
- Steps and tapers (“Using Steps and Tapers in a Schematic” on page 12-8)
- Flipping versus rotation

Flipping versus Rotating Components
Flipping and rotating components in the schematic window may appear to have the same effect, but they are actually handled differently during layout generation. If a component was flipped in the schematic window, it will be flipped in the layout. However, if a component is rotated in the schematic window, the rotation is not carried through to the layout.

**Hierarchical Layouts**

Hierarchy is the relationship between different parts of a layout. A layout with hierarchy contains one or more artwork elements that exist in separate design files. You can create a hierarchical design by placing an existing design within the current design. This creates an instance or reference to the design.

In the program, the term component is often used interchangeably with instance. In this case, instance refers something that is referenced by another layout. Creating an instance is different than copying the contents of one layout into another layout. Creating an instance does not copy any data; instead, a reference to the desired layout is created.

There is no limit to the level of hierarchy that can be created. Designs can reference designs that, in turn, reference other designs. Parameters can be passed to all levels of hierarchy. The only limitation is that a design cannot reference itself at any level of the hierarchy (for example, design A referencing design B that, in turn, references design A).

**Advantages of a Hierarchical Design**

The primary advantage to creating a hierarchical design is that it saves you time. You can use one layout in many places. Making a change in the referenced layout is automatically reflected in all layouts that use that instance. In Layout you can build up libraries of reusable designs that can be referenced by any project.
Creating a Layout

Schematic Considerations

If you want to simulate a design containing a layout, there must be a schematic. In general, the hierarchies of the schematic and layout should match. That is, if there is a subnetwork in the schematic, there should be a corresponding subnetwork in the layout.

Although the system can create the hierarchy of one representation automatically from the other, it is flexible in how it generates and updates schematic and layout. You can, when creating a subnetwork, specify any design or AEL macro as its layout equivalent (File > Design Parameters).

It does not matter whether you select the File > Design Parameters command from the Schematic or Layout window, they both write descriptions to the same file when you save the design.

Parametric Subnetworks

Unlike most CAD systems, instances can be modified on a per-instance basis; each instance of a referenced design does not have to be identical. You can add parameters to a schematic component that modify one or more of its attributes, so that when you use that schematic in another design, you can define the parameters as required. This type of design is called a parameterized design. For example, you can create a schematic with a parameter that modifies the length of a microstrip line; when the design is placed in another design, you can define that parameter as any length.

When you generate the layout, the artwork elements reflect the parameters you defined.
Creating a Hierarchical Layout

Creating Hierarchy Using Design Generation

1. Create a first-level design in the Schematic (or Layout) window.

2. Use the **Generate/Update** command from the Layout (or Schematic) menu so that you have both representations available.

   The following schematic and layout examples are called lpf. The mlength parameter was created using the **File > Design/Parameters** command, which creates a parameterized design.

3. Save the design.
Creating a Layout

4. Create the top-level design by choosing File > New Design.
5. Click the Library button. From the Subnetworks library, select the newly created design file, lpf.
6. As you move the pointer into the Schematic window, a ghost image of the design moves with it to aid you in positioning. Click to position the design.
7. Complete your top-level design.
8. Save your design.

The following examples show lpf, placed twice. The top-level design is called lpf2.

Creating Hierarchy Manually

1. Create a design, in the Layout window, that you want to reference in your top-level design.
2. Add ports if the layout is to be used with a schematic design for simulation.
3. Create the top-level design by choosing File > New Design.
4. Click the Library button. From the Subnetworks library, select the newly created design.
5. As you move the pointer into the Schematic window, a ghost image of the design moves with it to aid you in positioning. Click to position the design.
6. Complete your top-level design.
7. Save your design.

Viewing Hierarchical Design Information

You can view or print a list of the hierarchy levels of your design. Hierarchy levels are indicated by the indentation of the list. Top level instances are not indented, each nested level is indented with one space.

1. Choose Tools > Hierarchy and the Hierarchy dialog box appears.
2. To save the information to file, choose Print. The information is sent to the default printer.
3. Click OK to dismiss the Hierarchy dialog box.

Flattening Hierarchy

When you are ready to generate final artwork, you might want to use the Flatten command to remove all levels of hierarchy. This process copies all data from the referenced design to the current representation. See “Editing Layout Hierarchy (Flatten)” on page 11-15.

Breaking the Connection Between Layout and Schematic

The Flatten command works on components like MLIN. You can use it to break the connection between the layout and the schematic so that you can change a layer or edit the shape in the layout.

1. Select the microstrip(s).
2. Choose Edit > Component > Flatten.
3. Repeat this procedure for each instance you want to flatten.
Creating a Layout

Creating a Hierarchical Design for Repeated Use

The Create Hierarchy command copies selected artwork elements to another file, saves that new file, deletes the selected components in the original file and replaces them with a reference to the new design. In addition, you can parameterize the design in the newly created file, and use it as a subnetwork in any design.

Assigning a Symbol to a Subnetwork

To use a custom symbol to represent the design, you can do one of following:

- Create a symbol to represent only this particular design. This method requires drawing the symbol in the design file containing the design.
- Create a symbol that can be used to represent any design. This method requires drawing a symbol in a file that contains only the symbol.

Pushing Into or Popping Out of Hierarchy

In the Layout window, you can push into a component to view and edit the actual artwork represented by the component. This feature is particularly helpful is some cases such as when you need to work on a specific subnetwork without needing to see the overhead and details of the rest of the design. For details on editing a hierarchical design without pushing into it, refer to “Editing a Hierarchical Design” on page 4-13.

Use the following steps to push into or pop out of a hierarchical design either to view it or to edit.

1. Select the component.
2. Choose View > Push Into Hierarchy to display the network represented by the symbol.
3. When you are through viewing the network, choose Pop Out of Hierarchy to return to the component (or design containing the component).

Note that the Pop Out of Hierarchy command is the reverse of pushing and only works if a design has been pushed into.

Libraries and Search Paths

Many designs use a hierarchical approach. A top-level design is built from reusable, lower-level, subnetworks. Layout stores all networks in separate design files. The top
level network is maintained in a separate file that refers to the lower-level, subnetwork files.

When a hierarchical design file is read in, each reference to a subnetwork is automatically read in as well. In most cases, all subnetworks are in the same directory as the top level design, but this is not required. Design files can be located anywhere in the file system. A library search path is used to locate referenced design files when any design is read into the program.

A library search path is a list of directories that the program uses when searching for a referenced design file. The directories in the list are examined in sequential order until the file is found. The networks, tests, and default directories of the current project are usually the first directories in the search path; system example and symbol directories usually follow. After the file is found, the search is terminated and the file is read in.

The library search path mechanism allows the construction of any number of reusable layout libraries that can be shared among different designs. Creating design libraries of tested and commonly used layout components can save a great deal of time, while ensuring reliable designs.

The environment variable SIMULATOR_AEL lists the AEL files the program should search for. When modifying this variable, add the names of your AEL files after the default filename. A related variable, AEL_PATH, defines the search path for these AEL files.

The directories listed in the path in the AEL_PATH variable are searched in order from left to right. The search is terminated as soon as a design is found.

If you create a library of reusable elements, you must add the directory containing the library to the search path.

**Modifying Search Paths & Environment Variables**

Search paths that control the order of directories searched and the files loaded by the program are defined by certain environment variables. For information on these variables, refer to the *Customization and Configuration* manual.
Chapter 10: Creating Elements

This chapter presents details for creating new items.

Creating New Items

There are two basic categories of items that can be placed in a design: items that can be simulated and items that cannot be simulated. Simulated items, include all the program-supplied items in the libraries and palettes and all user-defined networks. Non-simulated items, are termed objects. Typical objects are alignment markers, schematic sheet borders, mechanical fasteners, etc. Objects can be selected from palettes and libraries like any other item, but are not included in simulation, nor are they normally included in design synchronization between layout and schematic.

Simulation Items

Simulation items, as the name implies, are included in simulation. Each simulation item has one of two types of simulation models associated with it: models represented as schematics and built-in simulation models. Either type can be used when creating a new item. Built-in models can be user-defined items, or any item for which the simulator has an intrinsic representation. (For more information on creating user-defined elements, refer to the User-Defined Models manual or the ADS Ptolemy Simulation manual.)

Creating a new item using a built-in simulation model can be used to assign artwork to items with no default artwork assignment, such as lumped components or device models. An example application would be to create a new item for a FET that is modeled with an S-parameter file using the S2P item.

Creating a new item modeled with a schematic network allows a greater degree of freedom. An example would be creating a network that models the parasitic effects of the solder pads for a Surface Mount Technology (SMT) lumped component. The ability to pass parameters into custom networks increases the flexibility of this approach by allowing any network to be parameterized in the same manner as built-in simulation models.
Creating Elements

**Defining a New Item**

You can define any type of new item by selecting File > Design Parameters from the Schematic or Layout window. Filling in the fields of this dialog box creates a custom item definition.

The custom item definition is stored in an AEL file. This file is named <design>.ael, where design is the name of the open design file. This file contains a number of AEL function statements. These functions register the new item with the Design Environment. This registration includes which palettes and libraries the item should show up in, how the item will be simulated (if at all), what the item's parameters are, the item's artwork and other details. It is possible to view and edit this AEL file using a text editor (the syntax for these functions is defined in the AEL manual). However, the syntax is complex and using the dialog box eliminates many possible errors in defining a new item.

Once the item definition is complete, the item can then be placed and used in your designs in the same manner as those supplied by the program. By default, your custom items are assigned to the Subnetworks directory of the current project, but you can store it in a library of your own choosing by supply a new library name.

If you are creating an item with a schematic network model or an item using custom artwork, you should create the network or artwork before creating the new item definition. For items using a schematic network, the item definition is usually done with the completed schematic network open in the Schematic window. For any other type of item definition, the Schematic and Layout windows are usually empty. The artwork and models are in other design or AEL files and are referenced by name.
Defining Design Characteristics

While the default design characteristics may be acceptable in many cases, the Design Parameters dialog box allows you to alter the default characteristics of the network. You may wish to modify any or all of the following default characteristics found on the General tab.

**Name.** This field is informational only and displays the current design name.

**Description.** Provide any descriptive phrase for clarification. This description appears in the Component Parameters dialog box when placing the item or network.

**Component Instance Name.** The default is X, but the text in this field is used as a prefix in building a unique name (ID) for every item. This prefix becomes part of the annotation displayed with the symbol when you place it in a design.

**Symbol Name.** The filename you supply in this field specifies the symbol used when you place the item in a design. You can supply a symbol name in one of several ways:

- You can type the desired name here. If you type a filename, it must be the exact filename (minus the .dsn extension) of any file containing only a symbol.

- You can select a symbol from the list of symbols on the drop-down list. This list contains several common symbols available by default. You can add to this list the names of any symbols you have created by adding the filenames to the list through AEL. (For details on how to do this, refer to the section “Modifying the List of Available Symbol Names” in the Customization and Configuration manual.)

- Click More Symbols to bring up a dialog box that displays icons for all supplied symbols.

When you specify a symbol, make sure that it has the correct number of ports.

**Library Name.** By default this field contains an asterisk (*) and if you accept this default, your item will be stored in the Subnetworks directory of the current project. This name can be changed to any custom-defined library name.

**Allow only one instance.** This enables you to specify whether or not the item or network can be placed in a design more than once. The default is off, meaning the item or network is not unique and can appear more than once in a design. Change to on if you want to restrict placement to once per design.
Creating Elements

**Include in BOM.** Turn this on if you want the details of the subnetwork design to be included in a generated BOM. When this is turned off, only the top level design information is included.

**Layout Object.** Turn this on if the design you are defining is an object used with the Layout option. (Layout objects are not simulated or synchronized but typically contain items such as alignment markers.) This attribute controls whether or not they will show up in layout palettes and libraries or schematic palettes and libraries.

**Simulate From Layout (SimLay).** Analog/RF designs only. The netlist required for simulation is generated from either the Schematic or the Layout. Select this option to generate the netlist from the Layout.

**Simulation**

- **Model.** Enables you to assign a netlist choice:
  - Built-in Component—a built-in simulator item (such as CAP or RES)
  - Subnetwork—a schematic network you have defined
  - Not Simulated—Create layout or schematic only non-simulated items

- **Simulate As.** This field should contain the name of a built-in simulator item or the name of a schematic (usually the name of the current design). If the Simulation Model is set to Subnetwork, enter the design name; if it is set to Built-in Component, enter the name of a built-in simulator item or select one from the drop-down list. If you chose Not Simulated for the item, this field is unused.

**Artwork**

- **Type.** Allows you to assign an artwork type: Synchronized, Fixed, AEL Macro or None.
- **Name.** Allows you to assign a macro item or design item with the appropriate artwork name.

**Save AEL File.** Allows you to incrementally save definitions (which are contained in the .ael file). By turning this on and choosing OK, rather than waiting until you save the design file itself, the AEL definition for the new item is saved.

If the default design characteristics meet your needs, you may proceed directly to the section, “Defining Parameters” on page 10-7.
Creating a New Item Using a Built-in Simulator Model

To define the simulation model, first create a new empty design using File > New Design in the Schematic window. Define your design characteristics and add any parameters that need to be passed to your item (File > Design Parameters). Once the parameters are defined, save the item definition.

For the following topics discussed in this section, you will be using a simple capacitor CAP as the simulation model, with predefined artwork representing a chip capacitor footprint CHPCAP.

To define an item using a built-in model:

1. Create a new project or open an existing project.
2. Open a Schematic window and select File > New Design.
3. Give the file a name (in this example, mycap).
5. Optionally, enter a new Item ID Prefix for your item, in this example, C.
6. Specify a Symbol Name using one of the methods described earlier. In this example, we are using the supplied capacitor symbol, SYM_C.
7. Enable the Layout Object option.
8. Specify an Artwork Type, for example Fixed.
   When you design a network, you need to determine what type of artwork should represent your network when it is placed in another network. For creating most elements, either Fixed or AEL Macro should be used.
9. Specify a name in the Artwork Name field (for fixed artwork, enter the same name that appears in the Label field; for a macro, enter the name of the AEL function). For this example, select CHPCAP as the artwork for a chip capacitor.
10. Select the appropriate simulation model, as described earlier. In this example, use Built-in Component.
Creating Elements

11. Specify how you want the item (or network) simulated. Select C for this example. Your dialog box should now look like the following example.

12. Click **Save AEL** to save this portion of the item definition, and continue to the next section, "Defining Parameters" on page 10-7.
Defining Parameters

Most new items you define need parameters. In this example, the parameters for the new item are the same as those for the Simulation Model, CAP, i.e., C (capacitance). For items with AEL artwork, you may need to add additional parameters (at the beginning of the parameter list) for layout.

In this example, the first artwork, CHPCAP, has no additional parameters for layout, so you only need to define the parameter C for this item. After selecting Built-in Component as the model type, you can click on the Parameters tab to define parameters.

**Hint** You can click Copy Component's Parameters and the set of parameters for the item named in the Simulate As field (in this example, CAP) is assigned automatically to your new item. In this example, this is the only step needed to define parameters, since there are no extra layout parameters.

For more complex definitions, each parameter has characteristics that determine how it is handled when the item is used. These include the name and label displayed in the Component Parameters dialog box, the unit type for the parameter, the type of value assigned to the parameter, the default value, and certain control attributes.

To define a parameter:

1. For this example, click **Copy Component's Parameters** then click the **Parameters** tab. The parameters for the supplied capacitor component are listed.
Creating Elements

**Important** For AEL generated artwork, entering your parameters in the correct order is critical. The order you specify in this dialog box must match the order given in the function. For example, in the AEL function for an MLIN, width comes before length. If you enter the length parameter first, it is still read by the function as width (ignoring the Name identifier).

Also, artwork parameters must precede those used for simulation, and must be marked Not Netlisted. For items with artwork, add any artwork parameters first, then use copy parameters or add the simulation parameters.

2. In this example, since we copied parameters of a supplied component, the Edit Parameter fields are filled in with defaults.
   - The Value Type is set to Real.
   - The Default Value is set to 1.0 pF. Note that this value serves only as a default. You can change the value each time you place the item subsequently.
   - The Parameter Type is set to Capacitance.
   - The Parameter Description (optional) reads Capacitance. (This is used only to document the meaning of the parameter.)

3. Enable or disable the following options, based on your design needs:
   - Display parameter on schematic—Select this option to display, on the schematic, the parameter being defined.
   - Optimizable—Select this option to allow this parameter to be optimized.
   - Allow Statistical Distribution—Select this option to allow post-production tuning for this parameter during yield analysis.
   - Not edited—Select this option to prevent this parameter from appearing in the Component Parameters dialog box for editing and always use the default value assigned here instead.
   - Not Netlisted—Select this option to prevent a parameter from being considered in simulation, but still be recognized for artwork generation. (In general, layout-only parameters (not used for simulation) are assigned the Not Netlisted attribute.)
4. If defining new parameters (as opposed to copying the simple parameters for this example, you must click ADD to add each new parameter to the parameter list.

**Hint**  You can assign attributes for each parameter as you define it, or you can define all parameters and then go back and assign attributes.

5. Save your design.

When the design file is saved, an AEL definition is created in the /networks directory of the current project. This file (along with the design file containing the schematic/layout) can then be moved to other directories for use as library parts, either for personal use or site-wide use. For details, refer to “Creating Custom Libraries” of the Customization and Configuration manual.

For details on adding items to a palette, see the de_define_palette_group function in the AEL manual.
Creating Elements
Chapter 11: Editing a Layout

As in other areas of the program, most edit commands enable you to select one or more components either before or after you select the edit command. The most commonly used editing commands, Copy, Delete, Move, Rotate, and Undo are performed in a layout just as they are in any other part of the program. As in other areas of the program, you can edit text, and you can change either the attributes of existing text, or define the attributes of all subsequent text.

An electrically complete layout circuit has all components connected. This chapter provides information on editing and connecting layout circuit components.

Using Selection Filters

Options > Preferences > Select

Selection Filters enable you to specify the types of components you want to include or exclude in sections. Any component that is turned off is not selected when you click on it individually, attempt to enclose it in a selection window, or choose the Select All command. Only the Select By Name and Deselect By Name commands ignore the selection filters.

By default, all types of components are turned on except Drawing Format.
Editing Shapes

There are a variety of editing operations you can perform on common layout shapes. For details on these editing operations, refer to the section of interest:

- “Manipulating Polygons and Polylines” on page 11-2
- “Manipulating Vertices” on page 11-9
- “Stretching the Edge of a Shape” on page 11-7
- “Scaling Shapes” on page 11-8
- “Adding Ports and Grounds” on page 9-7

Selecting Shapes

In addition to the selection features provided by the selection filters, you can quickly select all items on a layer you specify.

To select all items on a given layer:

1. Choose Select > Select All On Layer.
2. In the dialog box that appears, select the layer containing the items you want to select for editing. To select all items on multiple layers, click Apply after selecting each layer, then click OK. The items on the chosen layers are selected for editing.

Manipulating Polygons and Polylines

There are several ways to modify polygons and polylines after drawing them:

- **Edit > Merge > And** Enables you to create a single shape from two existing shapes on the same layer that overlap. This operation applies to the following shapes: polygons, rectangles, circles, and paths.
- **Edit > Merge > Or** Used to create a single shape from the union of two existing shapes on the same layer that overlap. This operation applies to the following shapes: polygons, rectangles, circles, and paths.
- **Edit > Merge > Difference** Allows you to create a single shape from two existing shapes on the same layer that overlap, with the resulting shape missing the area where the shapes overlapped. This operation applies to the following shapes: polygons, rectangles, circles, and paths.
• **Edit > Modify > Convert To Polygon**  Used to convert circles, as well as polygons containing arcs, to simple polygons where all curves are converted to line segments that approximate their original shape.

• **Edit > Modify > Join**  Allows you to join selected polylines with coincident endpoints into a single polyline. If a closed shape results, the joined polylines are converted to a polygon.

• **Edit > Modify > Explode**  Enables you to convert a polygon into individual line segments that are disconnected at each vertex.

• **Edit > Modify > Break**  Used to convert a polygon into a single polyline.

• **Edit > Modify > Chop**  Allows you to chop a selected region off of a polygon, rectangle, circle, or wire/trace.

• **Edit > Modify > Extend**  Enables you to extend the selected endpoint of a polyline to a designated reference line segment.

• **Edit > Modify > Crop**  Used to specify an area of a polygon, rectangle, circle, or wires/trace; save the selected area; and delete the remainder.

• **Edit > Modify > Split**  Allows you to split a polygon, rectangle, circle, or path/trace into multiple objects.

### Creating a Polygon from Intersections or Polylines

To create a polygon from the intersection of two closed shapes:

1. Select the two shapes.
2. Choose **Edit > Merge > And**.

![Before and After Image]

To create a polygon from the union of two intersecting closed shapes:

1. Select the two shapes.
2. Choose **Edit > Merge > Or**.
To create a polygon from two intersecting closed shapes, with the intersection removed:

1. Select the two shapes.
2. Choose Edit > Merge > Difference.

Converting a Shape to a Polygon

To convert a shape to a polygon:

1. Select the shape, where the shape can be a circle or polygon containing an arc.
2. Choose Edit > Modify > Convert To Polygon. All curves are converted to line segments that approximate their original shape. The number of line segments used in this conversion is determined by the setting Arc/ Circle Resolution (degrees) in Options > Preferences > Entry/Edit.
Joining Multiple Polylines

To join selected polylines (with coincident endpoints) into a single polyline:

1. Select the individual polylines you want to join.
2. Select **Edit > Modify > Join**. All coincident endpoints are joined. You can verify what has been joined by clicking on the shape to select it and observing whether or not the entire shape is selected.

![Diagram of Joining Polylines](image)

To verify what has been joined, click the shape to select it and observe whether or not the entire shape is selected.

Converting a Polygon into Individual Two-point Line Segments

To convert a polygon into individual, two-point line segments:

1. Select the polygon.
2. Choose the command **Edit > Modify > Explode**. All vertices are disconnected leaving individual line segments that you can edit as needed.

![Diagram of Exploding Polygons](image)
Converting a Polygon into a Single Polyline

To convert a polygon into a single polyline:

1. Select the polygon.
2. Choose **Edit > Modify > Break**. The starting and ending points of the polygon are broken, identified by a marker, and you can now manipulate the shape as a polyline.

   ![Starting and ending points](image)

- **Edit > Modify > Extend** Enables you to extend the selected endpoint of a polyline to a designated reference line segment.
- **Edit > Modify > Crop** Used to specify an area of a polygon, rectangle, circle, or wires/trace; save the selected area; and delete the remainder.
- **Edit > Modify > Split** Allows you to split a polygon, rectangle, circle, or path/trace into multiple objects.

Chopping a Selected Region Off of a Shape

To chop a selected region off of a polygon, rectangle, circle, or wire/trace, do the following:

1. Select the shape.
2. Choose **Edit > Modify > Chop**.
3. Use the mouse to draw the rectangular region to be chopped over the object.

Extending the Endpoint of a Polyline

To extend the endpoint of a polyline to a designated reference line segment:

1. Choose **Edit > Modify > Extend**.
2. Click on the line that you want to extend.
3. Click on the reference line.
Cropping a Shape
To save the specified area of a polygon, rectangle, circle, or wires/trace and delete the remainder, do the following:

1. Select the shape.
2. Choose Edit > Modify > Crop.
3. Use the mouse to draw the rectangular region to be saved over the object.

Splitting a Shape
To split a polygon, rectangle, circle, or path/trace into multiple objects:

1. Select the shape.
2. Choose Edit > Modify > Split.
3. Use the mouse to draw the rectangular region to be split away from the rest of the object.

Stretching the Edge of a Shape
You can redefine a shape by stretching an edge (a segment between two vertices).

1. Choose Edit > Move > Move Edge. You are prompted to enter the location of the line.
2. Click once on the edge you wish to stretch. A ghost image moves and changes as you move the cursor, showing how the shape will be redrawn.
3. Click again to define the new shape.
Scaling Shapes

To scale an object or text by a percentage:

1. Choose **Edit > Scale/Oversize > Scale** and the Scale dialog box appears.
2. Enter scaling factors for both X and Y.
   - Scaling factors must be positive. Scaling factors greater than 1.0 increase the size of objects, while factors less than 1.0 decrease the size of objects. To scale the objects uniformly, enter the same scaling factor for both X and Y. For text, only the X scale is used.
3. Click **OK** and you are prompted to enter a reference point on the object around which to scale.
4. Click to specify the reference point, and the object is scaled.

To scale an object relative to the design units:

1. Select the object.
2. To replace the original object with a scaled image, choose the command **Edit > Scale/Oversize > Oversize**.
   - To place a copy of the selected object (using the size you specify) on the current entry layer, preserving the original object, choose the command **Edit > Scale/Oversize > Copy & Oversize**.
   - When you select either of these commands, a dialog box appears.
3. Enter the sizing amount. A positive number increases the size of the object; a negative number decreases the size.
4. Enter a cutoff angle for mitering corners. Any angle of a polygon smaller than the specified cutoff angle is mitered. Default = 45°.
5. Make any changes in the dialog box, and click **OK**.
If you chose Oversize in step 2, the object is scaled to the specified size.
If you chose Copy & Oversize in step 2, a copy of the selected object is drawn on the current entry layer, at the specified size.

Manipulating Vertices

**Note**  
To select, move, or delete a vertex, the Vertices select filter must be on (see “Using Selection Filters” on page 11-1).

To add a vertex to a polygon or polyline:

1. Choose **Edit > Vertex > Add**.
2. Click on a point between two existing vertices, and move the mouse. A flexible line is drawn between the vertices and the cursor.
3. Click again to specify the new point and the shape is redrawn.
Editing a Layout

To move a vertex:
1. Select **Edit > Move > Move**, click on the vertex, and move the mouse. A flexible line is drawn from the affected vertices to the cursor.
2. Click again to specify the new location, and the shape is redrawn.

To delete a vertex:
1. Draw a selection window enclosing all vertices you wish to delete.
2. On the toolbar, click the delete button. The shape is redrawn without those vertices.

To delete an arc from a polyline
1. On the toolbar, click the delete button.
2. Click anywhere on an arc. The arc is deleted and the former endpoints of the arc are connected with a straight line.

Converting a Vertex to an Arc
You can convert any vertex to an arc and specify the desired radius of the arc, with respect to the units of the window.
1. Choose **Edit > Point > To Arc**. You are prompted to enter the location of the vertex, and a dialog box appears.
2. Set the radius as desired and click **Apply**.
3. Click on any vertex you wish to convert to an arc. The vertex is redrawn accordingly.
You can continue converting vertices in this manner using a different radius each time if desired, but you must click Apply each time you change the radius. When you are through making these changes, click OK to dismiss the dialog box.

**Converting a Vertex to a Mitered Edge**

You can convert any vertex to a mitered edge and specify the desired length of the mitered edge, with respect to the units of the window.

1. Choose *Edit > Vertex > Miter*. You are prompted enter location of the vertex, and a dialog box appears.

2. Set the miter length as desired and click Apply.

3. Click on any vertex you wish to convert to a mitered edge. The vertex is redrawn accordingly.

You can continue converting vertices in this manner using a different miter length each time if desired, but you must click Apply each time you change the length.

4. To dismiss the dialog box, click OK.
Editing a Layout

**Moving Shapes or Text to a Different Layer**

To move shapes or text to another layer:

1. Select the object you want to move.

   **Note** Do not use the Move To Layer command to move ports to a different layer; set the Layer parameter of the port to the desired layer.

2. Choose **Edit > Move > Move To Layer**. A dialog box appears with a list of currently defined layers. Select the desired layer and click **OK**. The selected object immediately takes on the color and other display characteristics of the selected layer.

   **Note** The following items can be moved to another layer using the context-sensitive menu that appears when you right-click with the pointer positioned over any of these items: Polygon, Polyline, Rectangle, Circle, Arc, Text, Arrow, Wire, Construction Line, Path, Trace.

**Manipulating Dimension Lines**

Dimension lines can be moved and modified.

**Moving Endlines**

A dimension line can be stretched using the **Edit > Move > Dimension Line Endline** command. This is done as follows:

1. Select **Edit > Move > Move Dimension Line Endline**.

2. Move the cross-hairs over the dimension line end that you want to stretch and click.

   **Note** If you have trouble selecting the end of the dimension line, see if the dimension line arrowhead is visible. If it is not, zoom in and try selecting the end of the dimension line again.
3. Move the cross-hairs to the desired position and click.

**Modifying Dimension Lines**

To modify the attributes of a dimension line, do the following:

1. Double-click on the dimension line.
2. The Dimension Line dialog box appears.

![Dimension Line dialog box](image)

Choose the parameter that you want to change from the Select Parameter list. The choices are:

- **LineLength**: The length of the dimension line
- **LineOffset**: The dimension line vertical offset from the x-axis
- **Endline**: The height of the end line from the dimension line
- **ArrowLength**: The length of the arrow
Editing a Layout

ArrowWidth: The width of the arrow
ArrowDir: The arrow direction. The possible values are inward and outward.
TailLength: If ArrowDir is inward, this represents the length of the arrows’ tails
Layer: The dimension line layer.
TextOffset: The text offset from the dimension line.
TextHeight: The text height
Precision: The displayed length precision
TextPosition: The text position in relation to the dimension line. Available choices are above, below, left, or right.
TextUnits: The unit to use to display distance

3. Edit the parameter settings
4. Click OK to save the change and close the dialog box.

Moving an Object to the Coordinates 0,0

By default, the coordinates 0,0 are located in the center of the Layout window. You can reposition an object that you have placed or drawn elsewhere, at the origin.

1. Choose Edit > Modify > Set Origin. You are prompted, enter origin location.
2. Click the point of the object (for example, pin 1) that you want to position at 0,0 and the object is moved; the specified point is now located at 0,0.

**Note** You can use the View All command to bring the object back into view.
Forcing an Object onto the Grid

If an object is offset from the current grid spacing, you can force it to the nearest grid point. If the selected object is an component with pins, pin 1 is forced to the nearest grid point.

1. Select the object.
2. Choose Edit > Modify > Force to Grid. The selected object snaps to the grid.

Editing Layout Hierarchy (Flatten)

When you are ready to generate final artwork, you can remove levels of hierarchy. This process copies all data from the referenced design to the current representation, resulting in the removal of one level of hierarchy. Repeat this process for each level of hierarchy you want to delete. When you finish, the design will be intact, but contain no references that could affect the final design.

1. Open the top-level hierarchical design.
2. Select an instance.
3. Choose Edit > Component > Flatten.
   This copies all data from the component to the current representation and deletes the reference to the subdesign. Note that one level of hierarchy is removed.
4. Repeat this procedure for each instance you want to flatten.
5. To check that all hierarchy levels have been removed select Tools > Hierarchy. This should produce an empty report.
6. Save the design.

Note  If you wish to remove all levels of hierarchy with one command, select File > Generate artwork
Physical Connectivity Engine

The ADS Physical Connectivity Engine enables you to establish electrical interconnects based on polygon shaped layout artwork and performs interconnect information extraction on the fly.

Key features include:

- “Polygon-Based Layout Connectivity” on page 11-16
- “Simplified Vertical Interconnects” on page 11-17
- “Edge/Area Pins” on page 11-17
- “Nodal and Physical Interconnect Verification” on page 11-17

Polygon-Based Layout Connectivity

Polygon-based layout connectivity removes the interconnect constraints of wires and traces and provides the ability to establish electrical connections with polygon based layout artwork. It also enables the use of custom tailored native interconnect configurations exhibiting electrical connectivity.

This new functionality gives you the flexibility to start a design either in schematic or layout, implement custom tailored layout interconnects (beyond simple traces), perform on the fly layout interconnect information extraction, and back annotate custom tailored interconnects to the schematic.

Other benefits include more robust design crosschecks between layout and schematic; open connections, nodal and components’ values mismatches, zero width wires in layout, overlaid components, layout shapes touching but belonging to different nodes, polygon/component overlapping, and non pin to pin connections. Significant improvements to design connectivity validation include polygonal shapes touching or overlapping but belonging to different nodes or not making a pin to pin connection.

The physical connectivity engine now takes care of potential connectivity problems that went unchecked previously, mainly due to the lack of arbitrary layout artwork connectivity information. See “Creating Interconnects with Shapes” on page 9-17 for more information.
Simplified Vertical Interconnects

As polygon shapes now exhibit electrical connectivity characteristics resembling real world conditions, vertical electrical connections are possible without requiring pre-built via components. Designers are no longer limited to the availability of pre-built via components in design kits (for MMIC designs) or component libraries (for PC board and module design) to establish vertical electrical connections. You can also define pin-less vias either in via macros or by overlapping layout artwork on a multi layered stack. The advantages of the new pin-less vias are simplified vertical connections, and the absence of the need to have via components placed in schematic as well as layout. See “Creating Interconnects with Shapes” on page 9-17 for more information.

Edge/Area Pins

Another enhancement to ADS Layout connectivity is the expansion of pins beyond the point pin concept to include edge and area pins. This new capability is most useful for design kit and component library developers, because it allows them to define unique edge and area pins to their layout components, however simple or complex they may be. See “Designating Edge and Area Ports” on page 9-8 for more information.

Nodal and Physical Interconnect Verification

The physical connectivity engine also enhances the ability to perform robust interconnect verification. Because all polygonal shapes in layout carry electrical connectivity information, you can perform a significant number of verification checks, including nodal and physical connectivity checks, at any point in the design process. See “Checking Connectivity Information in Layout” on page 11-19 for more information.

Nodal interconnect check lets you check the design’s nodes in schematic and layout (the definition of node is understood as a pin/port and all touching interconnects, excluding design components, whether they are active or passive.) This feature is very useful for performing schematic/layout nodal cross-probing to verify the accuracy of their designs as simple wires in schematic transform into elaborate physical interconnects. See “Highlighting Interconnects” on page 11-20 and “Cross-Probing” on page 11-23 for more information.
Editing a Layout

Physical interconnect check provides the ability to highlight all shorted (touching) metal in multi layer hierarchical designs. This enables an easy to perform interconnect integrity check for a design's physical layout, which identifies what a given metal trace, path, polygon, or transmission line touches. See “Highlighting Interconnects” on page 11-20.

These new capabilities can help microwave designers check the validity of their designs’ physical as well as nodal connectivity without overlooking important high frequency attributes. The new physical connectivity engine accomplishes this by extracting physical and nodal connectivity information upon opening a design (i.e. during design loading into layout environment) as well as while editing a design layout (i.e. on the fly extraction). Because connectivity extraction is performed in real time, large design files may take significantly longer to load into the layout environment. The amount of time required depends on hardware configuration, and upon available memory (where connectivity information is stored).

Usage Notes

1. When working with large design layout files and limited hardware resources, you may need to disable real time connectivity extraction. See “Disabling Layout Connectivity Features” on page 11-23 for step-by-step instructions.

2. In ADS2004A, shapes that overlap on the same layer appear to be merged when viewed from the parent design of the design they are on. This is a visual side effect of the new physical connectivity engine and does not affect the polygons/components' states in a given hierarchical design. In other words, even though the layout view may show a merged layout, no polygon/component merging is performed. If you push into the design, they no longer appear to be merged. In all cases, the shapes as represented in the ADS database are not actually merged. This is only a viewing in hierarchy issue.

   Work around: If you have shapes that are only used for documentation, such as the outline of a keep out region and you don’t want this shape to appear to be merged with another shape on the same layer, draw the shape with a polyline rather than a than a rectangle or polygon. Polylines never appear to be merged.

Connecting Layout Components

Regardless of how you connect components, you should turn pin snapping on before you begin (Options > Preferences > Grid/Snap > Pin). Keep in mind that while it
doesn't always cause performance problems, the intersection snap mode is the slowest of all snap modes so you should use this mode only when necessary. See Changing Grid and Snap Settings in the Customization and Configuration manual for more information.

Checking Connectivity Information in Layout

In the Layout view, the Check Design command provides access to information about the characteristics of your design. To access it, select Tools > Check Design. The Check Designs dialog will appear and list any warnings found in the Description field. These warnings are based on the selected items in the Check Design Options... menu. The Location field shows the x and y coordinates that refer to a specific warning message location. Selecting either the location number or description will highlight the instance on the layout. Checking the Auto Zoom box will zoom the layout in on the location of the warning.

To see the details of any of the warnings listed, select the warning and click the Details... button. An information window will list exact coordinates, instances, etc.

To access the Check Design Options menu click the Options... button. The options to check for are:

- Open connections Displays the total number of unconnected pins and wires. For each item with an unconnected pin, it lists the component name and ID, and the pin number. For each wire with an open end, it displays the coordinates of the wire segment. The affected items are highlighted in the design window. (default is turned on)
Editing a Layout

- Nodal mismatches (layout vs schematic) reports components that are connected differently in one representation than they are in the other. The report lists the name of the component, the pin that is connected differently and what the pin is connected to. The affected components are highlighted in the design window. (default is turned on)

- Wires in layout displays all components connected to pins that are interconnected with a wire (or a zero-width trace). (default is turned on)

- Parameter value mismatches (layout vs schematic) reports items that have different parameter values in one representation than they have in the other. The report lists the name of the item and the parameters that have different values. The affected items are highlighted in the design window. (default is turned on)

- Overlaid Components reports the IDs of any overlapping components where the components contain the same number of pins and pin 1 of each component is placed in the same location. (default is turned on)

- Shapes touch but belong to different nodes reports cases where two or more shapes overlap or touch, but are not connected to the same node. (default is turned on)

- Polygon overlaps component without overlapping a pin reports cases where a polygon or trace overlaps a component, and the area of overlap does not contain a pin. (default is turned on)

- Connection is not pin-to-pin reports cases where component pins are connected, but the pins are not in the same location. (default is turned off)

Highlighting Interconnects

There are two choices for viewing the connectivity between objects on your layout: Show Nodal Interconnect and Show Physical Interconnect.

Selecting Tools > Check Connectivity > Show Nodal Interconnect and clicking on a pin, wire, trace or polygon in your layout will highlight all objects at the current level that are connected to the same logical node. Nodal highlighting is used to highlight the interconnect metal between components.
Figure 11-1. Note that Show Nodal Interconnect, does not highlight components.
Selecting **Tools > Check Connectivity > Show Physical Interconnect** and clicking on a pin, trace or polygon in your layout will highlight all objects that are physically connected to the object you selected, throughout the hierarchy. Physical highlighting is used to highlight all metals including those that are part of components. Physical highlighting will follow connections thru vias onto another metal layer. Objects are physically connected when shapes on the same layer touch or overlap and when connections to another layer are made by a via.

![Diagram](image.png)

Figure 11-2. Note that the red metal in the inductor is highlighted because it is connected to the green metal layer by a via at its center. Also, the highlighting extends to the dual gates of the FET at bottom right.
Cross-Probing

To see the schematic representation of a specific node in your layout, select Schematic > Show Equivalent Node and click the pin, wire, trace or polygon that you would like to see in the schematic. When you view the schematic, the wire or pin representing the node of the object that you selected in the layout will be highlighted.

Disabling Layout Connectivity Features

Disabling layout connectivity features is only meant to be used when there are specific performance and memory consumption problems with large designs such as reticles or imported designs for use with Momentum. To disable layout connectivity features you can manually edit $HOME/hpeesof/config/de_sim.cfg by adding the following line: LAYOUT_PIN_CONNECTIVITY_ONLY=TRUE. See Customizing Environment Variables in Chapter 1 of the Customization manual for more information on specifying environment variables.

Note: ADS must be restarted to apply the change.

The following functionality will be disabled in schematic:

• Layout > Show Equivalent Node

The following functionality will be disabled in layout:

• Tools > Check Connectivity > Show Nodal Interconnect
• Tools > Check Connectivity > Show Physical Interconnect
• Schematic > Show Equivalent Node
• Edge and Area pins are disabled (only connections with pins will be recognized)
• Connections using polygons and paths are not recognized (only connections with traces will be recognized)
• Tools > Check Design will be replaced with Tools > Check Representation which will function as follows:
  Choose Tools > Check Representation. In the Check Representation dialog box, select the desired information category (or categories).
Editing a Layout

- **Unconnected pins** displays the total number of unconnected pins, and for each component with an unconnected pin, lists the component name and ID, the pin number and coordinates of the unconnected pin. The affected components are highlighted in the design window.

- **Nodal mismatch (layout vs schematic)** reports components that are connected differently in one representation than they are in the other. The report lists the name of the component, the pin that is connected differently and what the pin is connected to. The affected components are highlighted in the design window.

- **Wires in layout** displays all components connected to pins that are interconnected with a wire (or a zero-width trace).

- **Overlaid Components** reports the IDs of any overlapping components where the components contain the same number of pins and pin 1 of each component is placed in the same location.

Click OK. The Check Representation Report appears displaying the requested information. If desired, click Print to print the report. To dismiss the report, click OK.

**Working with Transmission Lines**

For some types of design work, designing from the layout can save considerable time. This is especially true in designs with complex transmission lines. In layout, transmission lines can be created either by placing transmission line elements manually or by inserting traces and converting them to transmission lines later. Regardless of how you create them, there are a number of ways you can edit them.

**Splitting a Transmission Line**

You can replace one transmission line element with two identical elements.
2. On the transmission line, and click on a reference point.
Editing a Layout

Replacing a Transmission Line Element
You can replace one transmission line element with two identical elements and a tee.

2. Type a number for the tap length, and click OK.
   Either an MTEE or STEE is inserted, depending on whether an MLIN or SLIN was tapped.
3. On the transmission line, click on a reference point where you want the tee element inserted.

Hint The third pin of the tee will be placed on the transmission line edge closest to the cursor.

Stretching a Transmission Line

2. Click on a node of the transmission line, and move the pointer away from the element. A flexible dashed line appears and moves with the pointer.
3. Click on a second reference point (where you want the element to stretch to). The element is now changed to the new length.
Squeezing a Transmission Line While Maintaining its Length

You can modify an existing transmission line to squeeze it into a smaller space, specifying several characteristics in the process, such as corner type, lead length and minimum spacing.

You can adjust any or all of the following characteristics as needed:

- Corner Type—Select from Mitered, Square, Curve

![Diagram showing before and after modifications of a transmission line.](image-url)
• Ending Direction—The direction (clockwise or counterclockwise) in which the last two segments connected to the ending lead are drawn

• Minimum Spacing—The minimum spacing between the parallel trace segments

• Mitered Corner Cutoff Ratio (%)—The desired cutoff ratio for the corner type Mitered

• Curve Radius—The desired curve radius for the corner type Curve

• Lead Length—The length of the starting and ending segments

To squeeze a transmission line into a smaller space while maintaining its length:

1. Choose Edit > Transmission Line > Squeeze Transmission Line Keeping Length. In the dialog box that appears, set the options as desired and click Apply.

2. You are prompted to enter the reference location. Click the pin at one end of the transmission line and you are prompted to enter the offset location.

3. Move the pointer toward the other end of the transmission line. When the ghost image of the transmission line represents what you want, click to draw the modified transmission line.
Editing Paths, Traces and Wires

Converting Traces to Paths

Unlike converting traces to transmission line elements, where the conversion is one-way, you can change paths back into traces. Use the following steps to change a trace into a path:

1. Select the desired trace.
2. Choose Edit > Path/Trace/Wire > Convert Trace to Path.

Converting Paths to a Traces

Unlike converting traces to transmission line elements, where the conversion is one-way, you can change traces back into paths, as follows:

1. Select the desired path.
2. Select Edit > Path/Trace > Convert Path to Trace.

Changing the Attributes of an Existing Path/Trace/Wire

1. Select the desired traces/paths/wires.
2. Choose Edit > Path/Trace/Wire > Path/Trace/Wire. The Path dialog box appears.

- Mitered corner
- Square corner
- Curve corner

Corner Type  Select Mitered, Square, or Curve.
Width  Specify the width (in layout units).
Mitered Corner Cutoff Ratio (%)  Set a percentage of cutoff; the larger the number the more of the corner is cut off.
Curve Radius  Specify a curve radius.
3. Fill in the appropriate fields, and click OK.
Editing a Layout

Stretching a Wire
You can change the shape of an existing wire by stretching an edge (a segment between two vertices).

2. Click once on the edge you wish to stretch. A ghost image moves and changes as you move the cursor, showing how the shape will be redrawn.
3. Click again to define the new shape.

Converting a Wire to a Trace
If the separation between components is intentional, you can convert a wire to a trace.

1. Select the wire and choose Edit > Path/Trace/Wire > Edit Path/Trace/Wire.
2. In the dialog box that appears, change the characteristics as desired, and click OK.

Hint  Because traces have width, if the wire you are converting to a trace has a bend, the shortest segment that is part of that vertex cannot be shorter than \(3 \times \frac{w}{4}\) where \(w\) is the width for the trace, as specified by Path Width.
Editing Component Text

By default, when you place a component in layout, its Instance Name (a unique ID) is automatically placed with it on the silk_screen layer. (The Component Name is placed on the silk_screen2 layer, which is not visible by default.) Instance Names are automatically assigned but you can change them as long as you maintain unique IDs for each instance.

To change the Instance Name for a given component, use either of the following methods:

• Change it using the onscreen editor
• Change it in the Component Parameters dialog box (double-click the component or choose Edit > Component > Edit Component Parameters)

To change component text attributes (font and size):

1. Select the component and choose Edit > Component > Component Text Attributes.
2. Change the attributes as desired and click OK.

Using Boolean Logical Operations

In the Layout window, you can insert onto any destination layer polygons that are the result of comparing the contents of two layers. In effect, the material you select on the source layers is copied to a destination layer according to logical rules.

Use the following steps for any of the logical operations described in this section:

1. Ensure that the source layers and the destination layer are not protected (Options > Layers).
2. Choose the command Edit > Boolean Logical.
3. In the dialog box that appears, use the drop-down lists to indicate the two source layers, the operation you want performed, and the destination layer. Except for DIFF, it makes no difference which source layer you identify first. See “Edit > Boolean Logical > DIFF” on page 11-32.
4. Select whether you want the logical operation to apply to shapes that you select, or to all shapes on the two source layers.

   If you choose **Selected Shapes**, you must select at least one object on each of the two source layers.

   For Boolean operations across the hierarchy, when an instance is selected, all objects in it will also be selected.

5. Select whether you want the original shapes deleted.

   In a hierarchical design, only the shapes at the top level of the design will be deleted.

   Traces are not deleted from the design but are used to generate boolean results.

6. Click **OK** to perform the selected operation on the shapes.

**Hint** To exclude a shape from a Boolean operation, select the shape, open its Properties dialog box (**Edit > Properties**), and add the following property.

   Name=DB_NO_BOOL, Value= 1, Value Type= Integer.

---

**Edit > Boolean Logical > DIFF**

Use **DIFF** to create (on the destination layer) one or more polygons that are a copy of everything that you select on the first source layer minus the material you select on the second source layer that is in the same x, y location. In effect, the system copies the material that you select on the first source layer, and then subtracts from it the material that you select on the second layer.
In the following examples, the result on the destination layer appears to the right, beside the source layers. This does not happen in the program, where objects on the destination layer appear in the same x,y location as in the source layers.

**Example 1**

In this example, the cond layer is specified as the first source layer. The program first copies the rectangle on that layer. Then (in effect) the circles on the cond2 layer (the second source layer) are subtracted from it. The result is a polygon, as shown.

![Example 1 Diagram]

**Example 2**

In this example, the cond2 layer is specified first. The system first copies the circles on that layer. Then (in effect) the rectangle on the cond layer is subtracted from them. Only parts of the two circles at the top of the cond2 layer appear on the destination layer. Everything else on that layer lies within the boundaries defined by the rectangle on the cond layer.

![Example 2 Diagram]

A practical application of the DIFF option would be to create holes on a layer. This would be done as follows:

1. Place all shapes on the Cond layer.
2. Place all holes on the Hole layer.
3. Choose **Edit > Boolean Logical > DIFF**.
4. In the Boolean dialog box, go from left to right and make the following menu selections: **Cond, DIFF, Hole, and Cond**.
5. In the Apply To section, select All Shapes.
6. Select the Delete Original button.
7. Click the OK button.

**Edit > Boolean Logical > AND**

Use AND to create (on the destination layer) one or more polygons that are a copy of only those things selected that are in the same x,y location on both source layers. The system deletes material that appears on only one source layer. In the following example, the destination layer contains only the parts of the circles on the cond2 layer that are inside the boundaries defined by the rectangle on the cond layer. The upper parts of the top circles are in a region where there is nothing on the cond layer, so they do not appear on the destination layer.

**Edit > Boolean Logical > OR**

Use OR to create (on the destination layer) one or more polygons that are a merged copy of everything selected on either source layer. In the following example, the destination layer includes (in a single, merged polygon) the rectangle on the cond layer and all of the circles on the cond2 layer. This includes the two circles at the top of the cond2 layer, even though parts of them are outside the boundaries defined by the rectangle on the cond layer.
**Edit > Boolean Logical > XOR**

Use XOR to create (on the destination layer) one or more polygons that are a merged copy of everything selected that appears in any x,y location on only one source layer. Anything that appears on both source layers is, in effect, deleted.

In the following example, the destination layer is similar to the first DIFF example, except that the polygon includes the parts of the two circles at the top of the cond2 layer that are outside the boundary defined by the rectangle on the cond layer. These are included because they appear only on the cond2 layer.

![Diagram showing XOR operation](image)

**Creating Clearance**

Choose **Edit > Create Clearance** and use the Create Clearance dialog to define clearance between ground planes and shapes on multiple mask layers.

![Diagram showing clearance](image)

1. In a layout window, with shapes on different layers, select **Edit > Create Clearance**

**Note** To display shapes as outlines, select **Edit** from the Layers menu, then select **Outline** from the Shape Display drop down menu.
2. The Select Planes dialog will prompt you to select the ground plane shapes. Hold down Ctrl to select more than one object. Click OK to continue, the Create Clearance menu will appear. If no objects were highlighted, an error dialog will be displayed.

3. In the Create Clearance menu select the Clearance Layers using the arrow buttons, select which shapes to Apply to using the radio buttons, and enter the Clearance Value in layout units. Click OK.

4. The resulting layout will reflect the clearance value selected.
Editing a Layout
Chapter 12: Design Synchronization

Because schematic and layout information is contained in the same design file, we refer to the schematic representation and the layout representation of a design, and ADS can maintain equivalent representations of any design. You can make changes to one representation and then synchronize the other representation with it, ensuring they are equivalent. The representation you issue the synchronization command (Generate/Update) from is referred to as the source representation, and the representation that will be automatically modified to match the source representation is the target representation.

The Layout menu (in the Schematic window) contains a variety of commands that enable you to generate a layout from the schematic and to troubleshoot and modify your approach with respect to components that didn't generate in the expected manner. An equivalent set of commands can be found on the Schematic menu (in the Layout window) for generating a schematic from a layout, because the synchronization process is bidirectional.

The Synchronization Process

When you synchronize two representations, the program examines each component in the source representation and modifies or creates an equivalent component in the target representation. The synchronization process can be fully automatic or incremental. If artwork exists for all schematic components, a layout of all connected components can be generated in one step. However, if any components do not have artwork associated with them (these will be represented by a generic artwork placeholder), or the layout has components that do not connect by abutment (typical in RF designs), the layout can be created incrementally. This is done by interactively placing components one at a time or a group at a time, then connecting them using traces. In addition, there is a dual placement mode that allows interconnected components to be automatically placed in the other representation during insertion mode.

Although this process is bidirectional, the first part of this chapter describes the process from the perspective of generating a layout from a schematic. Details related to using this process in the other direction are covered in the section, “Generating a Schematic (Layout-driven Design)” on page 12-19.
Design Synchronization

In general, your layout generation will be far more successful if you perform a prescribed series of checks prior to generating the layout:

- Identify schematic components without artwork and create/assign it
- Verify that schematic tee junction components are used where necessary
- Verify that schematic step or taper components are used where necessary
- Ensure schematic components are oriented correctly
- Establish preferences for: port/ground size, layer for generic artwork, wire extensions and component text, and the size and font for component text

**Hint** You can select an item in the Layout or Schematic window at any time and highlight its equivalent item in the other representation. Choose Layout (or Schematic) > Show Equivalent Component. Click an item. The corresponding item in the other representation is highlighted.

### Synchronization Modes

The synchronization can be complete or incremental and can be done to and from a schematic and a layout.

<table>
<thead>
<tr>
<th>Generate</th>
<th>Update</th>
<th>Place Component</th>
</tr>
</thead>
<tbody>
<tr>
<td>Place all activated components, including those with no artwork, connected to the starting component.</td>
<td>Update a previously generated design by placing components that have been modified.</td>
<td>Place items that have no counterparts in the other representation.</td>
</tr>
<tr>
<td>Components with fixed location status are not moved.</td>
<td>Components with fixed location status are not moved.</td>
<td>Use the &quot;Current Rep only&quot; component placement mode</td>
</tr>
<tr>
<td>Components that are not placed in the other representation are highlighted</td>
<td>&quot;Wire guides&quot; show connectivity in the other representation</td>
<td></td>
</tr>
<tr>
<td>Any component can serve as the starting point for which the location, orientation can be specified</td>
<td>Use the &quot;Options&gt;Variables&quot;: command to override the default resolution path for variable- and substrate-references</td>
<td></td>
</tr>
</tbody>
</table>
Working with Hierarchical Designs

When working with hierarchical designs, the best approach is to start with the subnetwork that represents the lowest level in the hierarchical design and go through the checklist just mentioned, then generate the layout for that particular subnetwork. Once you are satisfied with the results, move up to the next level in the hierarchy and repeat the process. When you are finished with all the subnetworks, repeat the process for the top-level design.

When generating artwork for a subnetwork that has one or more parameters that refer to variables or instances defined in a higher level design, you must identify the top design in the hierarchy and possibly the path from the top design back down through the hierarchy (via Instance Name) to that subnetwork. The path from the top design needs to be deep enough to resolve any ambiguity between VARs, substrates, or parameters on parametric subnetworks.

To specify the location of the actual variable values, choose Options > Variables.

- **Top Design in Hierarchy**—Type the name (or use the browser) of the top-level design in the hierarchy the subnetwork is part of.
- **Representation**—Select Layout only when working with layout-only designs.
- **Component Path (Instance Names) to Variable Values**—Use the following guidelines to determine the appropriate path:
  - If the variable is declared in a VAR item in the top design, leave this field blank.
  - If the variable is declared in a VAR item further down the hierarchy from the top design, specify a path starting with the Instance Name (appearing in the top design) that must be pushed into to find the current design, followed by the name of the next instance that must be pushed into to find the current design, etc. Note that the Instance Names should be separated by periods (e.g. X1.X2).
  - To generate artwork for a parameter subnetwork that uses a parameter value in an expression, you must specify the complete path to avoid ambiguity.
Design Synchronization

In this case the VAR and substrate are defined in the same design so there is no need to set the Top design in hierarchy.

In this case the VAR and substrate are defined in the top design, so there is no need to set the Top design in hierarchy for this design.

To generate artwork for this design, either start from example2_top or set Top design in hierarchy = example2_top

12-4 The Synchronization Process
In this case the VAR and substrate are defined in the top design so there is no need to set the Top design in hierarchy for this design.

In this case the VAR is defined but there is no substrate, so there is no need to set the Top design in hierarchy for this design.

To generate artwork for this design, either start from example3_top or set Top design in hierarchy = example3_top. If the Component Path is X1 or X1.X1 you will get X = 2. If the Component Path is X2 you will get X = 1. If the Component Path is not set, the system will find an instance of example_3 bottom, so either X = 1 or X = 2.
Identifying Components Without Artwork

Before you generate the layout, you should check for any components without pre-defined artwork and either create it or associate an existing artwork with the component.

To identify components without artwork:

1. From the Schematic window, choose **Layout > Show Components With No Artwork**. All components that have no artwork associated with them are highlighted and a confirmation dialog box appears asking if you want to choose artwork for the highlighted items.

2. Click **Yes** and a dialog box appears displaying the Instance Name of one of the components without artwork and offering a choice of artwork types.

**Hint** To go back later and change the artwork association for a given component, select the component and choose **Edit > Component > Edit Component Artwork**.

3. Select the desired Artwork Type and Name and click **Apply** to make the artwork association.
Choose **Default** to display in the dialog box, the default artwork specified in the create_item() definition for the component.

Choose **Fixed** to specify and use another design file to represent the artwork for the component.

Choose **Null Artwork** to create a component with just pins and no artwork.

---

**Hint** If you don’t want a lumped component to occupy layout space, use the Null Artwork type. If you want a lumped component to have pads, choose a component from the Lumped With Artwork component palette.

---

4. Repeat this process until all artwork associations are made.

**Using TEE Junctions in a Schematic**

When multiple transmission lines form a tee junction, one of the TEE components is required.

If three layout components are joined without the use of a tee component, as in the incorrect diagram, they will be connected with wires in the generated schematic, and the length of these wires are based on the setting in the Preferences dialog accessed through the Generate/Update dialog box. The use of tee components is not only important for layout, but is also important for proper simulation of interconnected transmission lines.
Using Steps and Tapers in a Schematic

You must use step or taper components to introduce changes in transmission line widths. A common error in microstrip and stripline layout is to put two different width transmission lines together without a transition component, as shown in the illustration that follows.

To account for the discontinuity, you must insert either a taper or step component between the two components.

- Step components do not introduce additional length, but do ensure that the discontinuity is accounted for in simulation.
- Taper components do have length. They should be used to describe any gradual change in transmission line widths.

There are a number of other discontinuities that can be included in simulation such as gaps and end effects. For a list of components relevant to your design, refer to the Circuit Components manual.
Checking Schematic Component Orientation

The correct orientation of all schematic components is required to successfully generate a layout. Notice the difference in the resulting layout when the orientation of Taper2 (lower illustration) is incorrect.

Pin 1 is always identified by a small tick mark, but you can see all pin numbers by turning on Pin Numbers through Options > Preferences > Pin/Tee.

Establishing Preferences

There are a number of miscellaneous settings you can control for the generation of a layout:

- The size for ports/grounds
Design Synchronization

- The layer on which generic artwork, wire extensions and component text should be drawn
- Component text font and size

To adjust these options for the design you are about to generate or update:

1. From the Schematic window, choose Layout > Generate/Update Layout > Preferences. (The remaining fields in this dialog box are described in the section, “Generating a Layout” on page 12-11.)

2. Change any or all options as desired and click OK.
Generating a Layout

After performing the preliminary checks, and taking the recommended action based on the results, you are ready to generate a layout. The transmission line shown next is used to illustrate the process.

To automatically generate a layout from a schematic:

1. Open a Layout window, and from the Schematic window choose **Layout > Generate/Update Layout**.

In this example, the Starting Component field shows P1 (port 1). This can be changed by clicking a different item in the Schematic window. The Equivalent Component field is empty, indicating that the equivalent has not yet been created (in the layout). In addition, all of the components in the schematic are highlighted, indicating that they all need to be generated.
Design Synchronization

Hint
If choosing Generate/Update Layout causes an item to be highlighted, the highlighting indicates that the item needs to be generated, regenerated, or repositioned.

2. Click OK and the layout is generated, as shown in the initial illustration.

The details of the Generate/Update dialog box are as follows:

- **Starting Component**—The program starts with this item, moving through port/pin1 to the next connected component, until all interconnected components with artwork are generated or updated. Click an item in your design to designate it as the starting point for the design synchronization process.

- **Equivalent Component**—Informational only. The counterpart of the item in the other representation appears in this field (when one exists).

- **Status**—Informational only.
  - not created—The equivalent of the starting component has not yet been created in the target representation.
  - positioned—The starting component has been positioned in the layout.
• X-Coordinate, Y-Coordinate, Angle—If you select a component in the Schematic, and the equivalent has been generated, these fields show the coordinates for the equivalent item, including angle. If the equivalent has not been generated, accept the default location (0,0) to allow the program to place it or type the desired coordinates. The angle of rotation in the source representation is displayed by default. Accept this or change it as needed.

![Diagram showing rotation angles](image)

• In the example above, the pin angles are for the schematic representation, not the layout representation.

The program generates a layout by creating artwork for each component in the schematic. If you start the process from a schematic, an artwork component is placed at the given X,Y location with the given angle. Each subsequent component is placed at an angle that is determined by the angle of the connecting component, plus the angle specified for that pin.

![Diagram showing M1, M2, M3, M4 connections](image)

• In Example A above, the angle of M1 is 0, and the angle of its pin 2 (on the right) is 0, so M2 is placed to the right of M1 at 0 degrees.

• In Example B, for M3, pin 2 (on top) is at 90 degrees, so M4 is connected at 90 degrees.
In Example C, M3 is placed at a 20 degree angle, so M4 is placed at 110 degrees (90 + 20).

For all artwork supplied in ADS, the angle of each pin is preset to generate a reasonable topology. However, it may be necessary to flip and rotate components to get a better layout; this will have no effect on your schematic.

**Options**

- **Delete equivalent components in Layout that have been deleted/deactivated in Schematic**—Select this option to force the design synchronization process to automatically delete items in the target representation that do not appear in both representations. This forces one representation to match the current representation.

- **Show status report**—Select this option to display a status report after design synchronization. This report includes the number of items modified, how many items processed, and the name of any trace subnetworks created, if automatic trace conversion was specified.

- **Fix starting component’s position in Layout**—When you select this option, the starting component’s position is set to fixed so that it will not be changed automatically during subsequent synchronizations (however, you can still manually move it).

- **Fix all components in Layout during Generate/Update**—Select this option to keep any existing components in the Layout (Schematic) in their current locations. If you don’t select this option, the synchronization process will move existing components to ensure they are adjacent to any newly placed components. This option is most useful when you have adjusted the position of components to meet your layout or schematic goals and would now like to synchronize other changes without disturbing the existing layout or schematic.

**Hint**

Use the Display tab in the Preferences dialog box (**Options > Preferences**) to define the display color for a fixed component to help you identify quickly any components with fixed positions.

**Preferences**—Allows access to a variety of settings to assist you in generating the desired schematic or layout.

**From Layout to Schematic**

12-14 Generating a Layout
• Length in X-Direction—The length of horizontal wires drawn between schematic components when their layout equivalents connect by abutment.

• Length in Y-Direction—The length of vertical wires drawn between schematic components when their layout equivalents connect by abutment.

• Component Text Font/Size—Font and size used for the component text.

• Variables—Used for identifying a design-instance that contains the actual values of variables being referenced by the subnetwork (for which you want to generate a layout), when the design containing those variables is either not related hierarchically, or is related hierarchically, but is found at a lower level (than the subnetwork) in the hierarchy.

• Trace Control—Allows access to a dialog box for specifying details for interpreting traces in layout.

  • Simulate As—Select one of the following: Transmission line elements, Single transmission line element (then specify that element in the field provided, MLIN by default), Nodal connection (short).
  
  • Element Set—Select one of the following: Microstrip, Stripline, Printed circuit board.
  
  • Substrate References—The Instance Name of the substrate item to be referenced when simulating traces as transmission lines.

<table>
<thead>
<tr>
<th>Element Set</th>
<th>Substrate Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microstrip</td>
<td>MSUB</td>
</tr>
<tr>
<td>Stripline</td>
<td>SSUB</td>
</tr>
<tr>
<td>Printed circuit board</td>
<td>PCSUB</td>
</tr>
</tbody>
</table>

From Schematic to Layout

• Length in X-Direction—The x-direction length for connecting wires used in three-way connections.

• Length in Y-Direction—The y-direction length for connecting wires used in three-way connections.

• Component Text Font/ Size—Font and size used for the component text.
Design Synchronization

• **Generic Artwork Size**—The length of the box (with an X drawn through it) drawn in layout when there is no artwork associated with the schematic component

• **Port/ Ground Size**—The size of the port/ground symbol (an arrow) drawn in the layout representation

• **Entry Layer**—The entry layer on which generic artwork and wire extensions should be drawn.

### Placing Unplaced Components

Unplaced components are items that do not have counterparts in the other representation. When a component without artwork, such as a series capacitor, is encountered during the synchronization process, the synchronizer places a generic artwork box in its place. Once you create/assign artwork to these components, you can initiate the synchronization process again or you can individually place these remaining components one at a time, interactively, in the other representation:

• By selecting `Layout > Generate/Update Layout` again and using either the first unplaced item as the starting item, or selecting any other component that already exists in the layout. This mode automatically positions artwork by pin abutment.

• By using the `Layout > Place Components From Schem To Layout` command (this is the preferred method for RF designs). This mode allows any distance between artworks.

The `Place Components From Schem To Layout` command enables you to interactively place items from one representation to the other. It is important to note that placing items in this fashion is different from placing items from a library or palette; if an item is placed from a library or palette, no association is made with its equivalent item until design synchronization is run again.

To locate unplaced items:

Select `Layout > Show Unplaced Components`. The unplaced components are highlighted.

To place an unplaced component:

1. Select `Layout > Place Components From Schem To Layout` and click any of the highlighted components you want to place.
2. Move the pointer to the Layout window. A ghost image of the item, as well as wire guides identifying the connectivity point(s), tracks with the pointer. Position the item and click.

In the illustration that follows, one of dotted lines represents the wire guides that track with the artwork and the pointer.

Fixing and Freeing Component Positions

All items in the Schematic and Layout windows have either a fixed or free status associated with their position. If an item's position is fixed (in the target representation), then it cannot be repositioned automatically by the program during the design synchronization process. If an item's position is free, then the program may reposition that item. Understanding the basic behaviors involved will help you in manually creating designs, as well as generating one representation from another:

- Items manually placed in the Schematic window are fixed. If you make changes to the layout and update a schematic containing fixed items, the fixed items retain their positions but may be rewired to maintain connectivity.

- Items generated in the Schematic window during the design synchronization process are free. However, if you manually move an item in the schematic, the program automatically sees that item's position as fixed and will not reposition it on subsequent synchronizations.

- Items placed in the Layout window, either manually or during the design synchronization process, are free and should remain that way. However, occasionally you may have critical sections or completed sections of your layout that you do not want repositioned by the program. In this case, you can
explicitly set these items as fixed. Unlike moving items in the Schematic window, moving items in the Layout window does not change their free status.

- Items placed with the Place Components From... command are fixed components and maintain the orientation angle of the source representation when you place them in the target representation.
- Items placed in either representation during the design synchronization process, maintain the orientation angle of the source representation if the item is fixed in the source representation.

The following commands (found on the Layout and Schematic menus) can help you identify and change the fixed versus free status of a component, relative to the window from which you issue the command:

- Show Fixed Components—Highlights all components whose status is fixed
- Fix Component Position—Prevents a component from being repositioned automatically by the design synchronization process
- Free Component Position—Allows a component to be repositioned automatically by the design synchronization process

**Dual Representation Mode**

When working from either schematic or layout, it is sometimes desirable to have items placed in both representations simultaneously. This is accomplished using the dual placement or synchronization modes found in **Options > Preferences > Placement**.

- **Single Representation (schematic OR layout)**
  When you place an item in one representation, nothing is placed automatically in the other representation.

- **Dual Representation (schematic AND layout)**
  When you place an item in one representation and move the pointer into the window for the other representation, the equivalent component is already selected. Position the pointer as desired and click to place it. (If a window for the other representation—containing the same design—is not open, one will be opened automatically.)

- **Always Design Synchronize (schematic AND layout)**
Causes the program to fully synchronize both representations after each part is placed, ensuring all parts are fully interconnected. This takes more time than the Dual Representation mode and may move or rearrange the layout of the schematic to preserve connectivity.

Note The second (Dual) and third (Always) modes are designed to work in insert mode (while placing components). If you need to edit as you insert components, these two modes are not recommended.

Generating a Schematic (Layout-driven Design)

Generating a schematic from a layout involves steps similar to those used in generating a layout from a schematic. When you modify the layout, its modified parameter values can be back-annotated to the schematic in a similar fashion.

Layout items can be picked from a palette or library list and placed and interconnected in the Layout window. If a library of layout components has been created and associated with schematic and simulator items, they can be added to existing palettes or new custom palettes. For detailed information, refer to “Creating Elements” on page 10-1.

To generate a schematic from layout:

1. Open a Layout window.

2. Create your layout design in the Layout window (by placing items from the library and palette) and interconnecting them by abutting their pins or connecting them with traces, as shown in the following example.

![Diagram of layout components: C_PAD1, SLIN, C_PAD2]
Design Synchronization

**Note** Before you can place an item (such as SLIN) in the Layout window that references a substrate item, you must place that substrate item in the Schematic window.

3. From the Layout window choose **Schematic > Generate/Update Schematic**. The dialog box appears, and all items in your layout are highlighted, indicating that they need to be generated, updated, or moved in the other representation.

4. Accept the default Starting Component (C1 in this example) or click a different item in your layout (the item you want the program to use as the starting point for generating your schematic).

5. Click **Preferences** and specify the horizontal and vertical spacing that you want between the items in your schematic, then click **OK**.

6. Specify the location and angle of the equivalent item in the Schematic window, and click **OK**. The equivalent schematic appears in the Schematic window.

**Note** When creating Momentum layout components for use with the **Schematic > Generate/Update Schematic** command, you need to deselect the Add reference pin checkbox in the Create Layout Component dialog. See the *Momentum* manual, Chp. 6 for more information.

RF PCB design considerations

Many RF PCB applications require an interactive approach to layout. Typically, a schematic is created and simulated before layout begins. The Design Environment supports creating layout at any time, before during or after a schematic is created. A large 90,000 part library is supplied; many parts are available with their packaged-part outlines and mounting footprints.

The layout tool contains a number of features specially designed to support PCB layout. These include:
• Large, comprehensive parts library
• Complete integration with system and circuit level simulation
• Interactive placement mode
• Automatic component parameter forward and back annotation
• Rat’s nest connectivity display
• Layout vs. schematic checking
• Trace routing and layered transmission line simulation
• Simplified library parts creation
• Configurable BOM, Parts Lists, pick and place output
• Optional Gerber, DXF, IGES output
• Optional integration with Mentor's Board and Hybrid Station

Creating the Board, System Setup
You will need to draw or import a board outline for the PCB you are designing. A number of layers have been pre-defined for PCB board layout. The silk-screen layers are defined to place text and other silk-screen information. The pcb1-9 layers are designators for trace routing using traces or the PCB transmission line components. Other layers can be used or defined as needed. There are no limits to the number of layers that can be defined, though the multi-layer PCB transmission line components have a limit of nine conductor layers.

Interactive Layout, Manual Layout
Components can be placed in layout at any point in the design. As in the schematic, parts can be placed in the layout by selecting them from a palette or library and positioning them on the board. Most of the standard SMT parts and other packaged parts are selected from library lists.

Parts can be moved to the bottom side of the board, or placed on the bottom by mirroring them. When creating a schematic for a PCB design, make sure every part has a layout equivalent. For ideal components, such as a CAP, RES, etc., use the Lumped-With Artwork version of these components to account for them in layout.
Design Synchronization

Parts can also be placed directly from the schematic. The advantage is that the schematic and layout can then be kept synchronized. It is important to note that if you place items in the schematic with the library or palette lists, and then place equivalents in the layout in the same manner, the two will not be synchronized. To keep the layout and schematic synchronized, you must either use the Generate/Update feature to automatically create one representation from the other, or use interactive placement to incrementally create one representation from the other.

**Automatic design synchronization**

A layout can be automatically created from an interconnected schematic using the design synchronization feature (Generate/Update). This command will take each component in the schematic and place it in the layout so that the interconnected pins abut. While this works very well for microwave designs that have every transmission line discontinuity accounted for in the schematic, it does not usually produce acceptable results for PCB layouts that have extensive interconnections using traces. It will, however, give you an initial placement of components that can then be moved into a correct position.

**Interactive placement**

Placing parts interactively from the schematic to the layout, or vice-versa is usually the most practical method of creating a PCB layout. The Place Components From Schem To Layout (or Layout to Schem) command is used to select a part in one representation and place it in the other.

The command prompts you to pick a component in the source representation and place it in the target. If initiated from the Schematic window, you are prompted to click a schematic component and then move the cursor into the Layout window. A ghosted image of the part can then be seen moving with the cursor. You can use the arrow buttons on the palette to rotate the part before placing it. Clicking the left mouse button places the part, with the same parameter values used in the schematic.

Wire guides are displayed that indicate where each component should be connected. These lines can be re-displayed with the Schematic > Show Connected Components command, which will draw a connection (rat's nest) depicting the interconnection of each unconnected pin using the source representation as the reference. Use Clear Highlighted Components to remove these lines.
The **Schematic > Place Components From Schem To Layout** (or **Layout to Schem**) command highlights all the components in the reference representation not yet placed in the target. Use the **Clear Highlighted Components** command to remove highlighting.

### Fixing part placement and back annotation

When parts are placed in the layout, they are placed as free components. That is, if design synchronization is run, the part will be repositioned to abut at least one of its pins with an interconnected component. While this is the preferable method of synchronizing microwave designs, it is usually not the desirable method for PCB components.

If the parts were placed with the **Place Components From Schem To Layout** (or **Layout to Schem**) command they will be placed as fixed components. That is, they will not be repositioned when design synchronization is run. However, if they were placed in some other manner, they will be placed as free components and will need to be set to fixed. To check the status of the placed components in layout, select **Schematic > Show Fixed Components**. This will highlight each fixed component. For non-highlighted components, select these and use the **Schematic > Fix Component Position** to fix these components’ positions.

Once the components are placed, you can use the design synchronization feature of the program to maintain parameter changes in one representation with the other. Thus, if you change the value of a capacitor in layout, you can back-annotate this change by running design synchronization from the Layout window. Each component that is not yet placed or that has a changed value will be highlighted. Clicking **OK** or **Apply** in the dialog box will update the highlighted parts in the target representation.

### Trace Routing

You can use traces (or wires) to parts when you do not want to connect them merely by abutment.

### Layout versus Schematic Nodal Mismatches

You can compare the layout and schematic any time during the design process using **Tools > Check Design** and selecting the **Nodal mismatches (layout vs. schematic)** option. This will generate a report that compares the connectivity of the target
Design Synchronization

representation against the source. Missing components, or pins connected differently in one representation from the other are reported.

Note, this option works on designs where the layout is composed of layout items that have schematic equivalents. It does not work on arbitrary geometry, nor does it do any device extraction. For complex layouts that are disconnected in more than one area, running the command from both representations can help better pin-point the source of the mismatch. Using this command in conjunction with Layout > Show Unplaced Components, Show Equivalent Component, Show Connected Components commands can usually solve most discrepancy problems.

Trace Simulation

For many high-frequency PCB designs, transmission line effects become significant and need to be accounted for in simulation. In Layout, you can explicitly convert traces to transmission line components for simulation, or globally simulate traces as transmission lines without explicitly converting them. For details, refer to “Working with Traces” on page 9-8.

Meander Trace Simulation

MEANDER components are simulated using the MLIN electrical model. In order to account for the effect of bends, use Traces (which can be broken down to lines, bends, and tees), or MLIN, MBEND, MTEE directly.

Generating a report

To generate a Bill of Materials (BOM) or Parts List with pick and place information, select File > Reports. These reports are created using the de_bom and de_parts AEL functions and can be customized. For details refer to Pick and Place Report in the Customization manual.

Exporting the PCB layout

Most PCB layouts are manufactured via Gerber output. Gerber is supported via the optional MTOOLS Gerber translator. The design environment interfaces with the Gerber translator via mask files. A mask file can contain one or more layers. All design exporting is done through File > Export in the Layout window. For basic
information, refer to “Importing and Exporting Layouts” on page 14-1. For details, refer to the Importing and Exporting Designs manual.

Part and library creation

Though a large library of PCB discrete components is available, you may not find the components and their layout footprints you are looking for. But you can define new items in a number of ways. For details refer to “Creating Elements” on page 10-1. Note, that a large number of layout objects are also available. For non-electrical items, these can be placed directly in the layout without concern for the schematic. For electrical items, you can create a new item that uses a pre-defined layout object for layout, or you can use an ideal component such as a CAP or S2P with a gap artwork equivalent. The gap can be specified to allow the layout object to then be inserted.
Design Synchronization

12-26 RF PCB design considerations
Chapter 13: Artwork

Any item can have an artwork representation. There are several ways to define artwork for any given item you want to represent in layout, but in general, the artwork is categorized in one of two ways:

- Fixed artwork
- AEL artwork macros

For both types of artwork, a large number of artworks are supplied, but you can also create custom artwork of either type.

Fixed Artwork

The simplest artwork is fixed artwork and over 100 fixed artwork shapes are provided. Fixed artwork can be thought of as a layout object. These objects are saved in design files and may or may not have connection pins. This type of artwork is often used for layout items that do not change size or shape based on parameter settings. For example, an SOT23 package outline is the same for any device with that package, regardless of the device operating parameters.

- The supplied fixed artwork objects are documented in the Layout Library book. For details on associating one of these fixed artworks with an item, refer to “Associating Artwork with an Item” on page 13-14.
- For details on creating your own fixed artwork, refer to "Creating Fixed Artwork" on page 13-7.

AEL Artwork Macros

A more flexible approach is to use the AEL artwork creation functions to define the artwork for an item. The artwork for the built-in transmission line elements (microstrip, stripline, etc.) is defined in this fashion, and over 200 AEL artwork macros are provided. These macros include functions for creating solder pads, space artwork and no artwork.

The AEL macro is versatile because it can accept parameters that are used to determine the shape, size, layer, and connection points of the layout artwork. Every reference to an item defined with an AEL macro can be different, depending on the parameters passed to it.
Artwork

- The supplied AEL macros for layout-only components are documented in "Standard AEL Macros" on page 15-1.
- AEL macros are supplied for additional components that are documented (as components) in the Circuit Components manual.
- AEL macros are supplied for over 100 standard SMT packages and are documented in the Layout Library book.
- For details on creating on your own AEL artwork macros, refer to "Creating Artwork Using an AEL Macro" on page 13-9.
- For details on creating AEL artwork macros using the Graphical Cell Compiler, refer to the Graphical Cell Compiler manual.

Special Types of Artwork
The following special types of artwork are also available: space artwork, connection artwork, and SMT package artwork.

Space Artwork
Space artwork refers to leaving a space or gap in layout. No actual artwork is created with the space macro. Instead, it instructs the program to view items connected through an item with space artwork as connected. In the layout, a gap is created separating items connected to the item with space artwork.

Using this artwork type is common for layouts where the artwork representing a simulation item may frequently change. For example, you may have an S-parameter device model (S2P) in your design and wish to swap out the referenced S-parameter file to test different devices.

If each device has a different artwork representation, there is no one package outline to assign to this element. However, by assigning space as the artwork (SPAC), you can leave a gap, whose size is a parameter of the item, and insert a layout package outline later.

Built-in item definitions have been supplied for the most common cases of simulation items that could benefit from using SPAC as artwork. These include many lumped elements as well as the S2P element, and can be found in the Lumped Components (with artwork) and the Linear Data File Items (with artwork) palette and library groups. Any item from the library of packaged parts supplied with the program, or layout object you define, can then be used to insert into the space for layout.
Connection Artwork

Connection artwork is a special case of space artwork. However, rather than leaving a gap in layout, it simply connects items that are connected through it together (a space of 0). In other words, items with connection artwork are simulated and included in your schematic, but are ignored in layout. For example, you may have included parasitic capacitors or resistors in your network that have no artwork. By assigning connection artwork to these items, you can include them in simulation and have the layout ignore them.

It is important to use items with connection artwork, rather than items without any artwork assigned at all, to ensure that the layout can be automatically synchronized with the schematic.

Like items with space artwork, the most commonly used items with connection artwork have been pre-defined and included in the program. These are also listed in the Lumped -With Artwork and the Linear Data File Items (with artwork) palette and library groups.

SMT Package Artwork

SMT package artwork is available for over one hundred parts. These artwork macros are versatile because the dimensions of the land pattern can be varied by changing the width and length of the package. The position of the land pattern, with respect to the component package, can be varied by changing the OFFSET parameter. For details on available SMT package artwork and an example, refer to Layout Library manual.
Supplied Artwork

Default artwork exists for all microstrip and stripline components, as well as many other components. Artwork also exists for a large number of component libraries. This artwork is in the form of AEL artwork macros.

Default artwork also exists for a number of optional libraries. This artwork is usually in the form of fixed part outlines. For packaged part libraries, it is the component footprint or outline; for other parts it is the actual part geometry.

For other parts, there is no default artwork. To include these components in layout, you need to create special component equivalents with artwork specific to your requirements. For details refer to “Custom Artwork” on page 13-4.

Custom Artwork

Custom artwork for a design can be created before or after the simulation model. Depending on what the artwork represents, you may want to create the artwork using an AEL function, or simply create it by drawing a fixed set of shapes. Two examples are given to demonstrate how to create artwork using either method.

Depending on the type of layout you are creating, you can create the artwork as a library of fixed artwork components, as parameterized artwork macros, or a combination of both. For some layouts, capacitors come in a set of fixed, discrete capacitance values, so it may be better to create a fixed layout for each unique capacitance value. In other layouts, the capacitors can take a range of values. If implemented as an artwork macro, the macro can accept a parameter value and adjust shape dimensions to produce the corresponding artwork. Microstrip transmission lines (MLIN) are another example of a component that is best implemented as an AEL macro, because the width and length of the line are passed into the macro (using the length unit set for the design), which controls the size of the rectangle used to represent it.

To simplify creating new items with artwork, AEL functions and a library of fixed artwork are provided. The AEL functions include: functions that generate a space or gap in layout (this allows an artwork to be inserted later), macros for pad placement (for 2-, 3-, and 4-pin components), routines to create different types of PCB pads, a predefined set of commonly used components with space, connection, or pad artwork, and a way to provide a simple electrical connection between items. The fixed library contains artwork for most popular packaged parts outlines, including a large SMT
library. (For lists of the supplied fixed and AEL macro artwork items, choose File > Design Parameters and view the drop-down list associated with each artwork type.)

Creating a Layout Object

To create a layout object:

1. For a layout object, open the Layout window and draw the shapes representing the object.

   Optionally, you can add connection points or pins (“Adding pins/ports to artwork” on page 13-5). You do not need to add pins if the object is going to be used as artwork to be inserted into a layout gap (refer to “Space Artwork” on page 13-2).

2. When the artwork is drawn, choose File > Design Parameters in the Layout window for layout objects, or from the Schematic window for schematic objects.

3. Select Fixed as the Artwork Type if it is to be included in a schematic, otherwise select Not Synchronized.

4. Type the name of the currently open design file in the Name field (without the .dsn extension).

5. Type (or select if it already exists) the name of the library in which you want the item stored.

6. From the Model list in the Simulation field, select Not Simulated.

7. Check the Layout Object box and click OK.

8. Save the design.

Adding pins/ports to artwork

For any artwork item you create that will be connected electrically, you will need to add pins. Pins represent an electrical connection point to which a trace, wire, polygon or the pin of another item can be connected. When a port (point port) is placed into a layout and this layout is placed as an instance into another layout, you will see a corresponding pin at a single x,y point.

You can also place edge and area ports in a layout and these will become edge and area pins when the layout is placed as an instance into another layout. Edge and area ports must always be associated with a single (point) port. The point port defines
where automatic connections will be made when using design synchronization. If you need to have multiple connection points that represent a single electrical connection to the component, it is suggested that you use multiple edge or area pins, but NPPORT will also work. See "Designating Edge and Area Ports" on page 9-8 for more information on edge and area ports.

The NPPORT allows you to place multiple physical connection points that represent a single electrical port. Connecting to any same numbered NPPORT creates the connection. Any component may use NPPORT, and have as many as required. Each NPPORT representing a single connection shares the same port number. The only special requirement when using NPPORT is that one of the ports in the set be a preferred port. A preferred port (PORT component) is a connection point that the design synchronization facility uses to connect to. NPPORT is created using the NPPORT item; preferred ports are created using the standard port item. In a set of multiple ports sharing the same port number, there can be only one preferred port.

When creating artwork using AEL, the same concept applies. The only difference is that ports are created using the de_define_npport and de_define_port or de_draw_npport and de_draw_port AEL functions.

![Diagram of 4 connection point port example](image1.png)
Creating Fixed Artwork

The artwork for this example is a fixed pattern representing the mounting pads for the chip capacitor. The only parameter for the subnetwork is $C$, the nominal capacitance. A resistor is added to the schematic to account for loss. An equation is used to calculate the resistance from the nominal capacitance.

The following schematic describes the simulation model.

To create the fixed artwork for the chip capacitor:

1. Open the Layout window.
2. Select an entry layer for your artwork (select Insert > Entry Layer).
3. Optionally, make the grid visible (select View > Zoom In).
4. Draw the shapes representing the capacitor pads. Be sure your dimensions and layers are appropriate for your design.
5. Add ports to your artwork. The orientation of the ports determines how components will be connected to your artwork when design synchronization is run. Place port 1 on the left side of the left rectangle with the coordinates at node 1 set to 0,0. Port 1 looks like an arrow pointing into the artwork.

6. Place Port 2, rotating it to point in to the right rectangle.

When your capacitor is placed during synchronization, it will have connecting items placed to the right and left of it, at the same angle the capacitor is placed.

7. Save your design.

Using Edge and Area Ports

1. Ensure that you have already placed the port that the edge or area port will be associated with.

2. Add a polyline or arc where the edge port will be located. This will typically be along the edge of some other polygon, rectangle, circle or path.
   or
   Add a polygon, rectangle, circle, or path where the area port will be located. If your artwork already has a polygon, rectangle, circle or path where you want the area port, you do not need to add another.

3. Use the Edit > Edge/Area Port menu. Select the polyline, arc, polygon, rectangle, circle, or path and the port number it will be associated with. Click OK. Objects that are associated with a port number are highlighted with a light blue outline by default.

Selecting shapes in your layout will change the Port Number value in the dialog, depending on which port the object is associated with. Objects that are not associated with a port will display Not a port as the Port Number value. Objects that are associated with multiple ports will display Multiple as the Port Number value. In this example, the object on the left was selected and is associated with Port Number 1.
The Select Port dialog allows you to select all shapes already associated with a specific port. In this example, Port Number 2 was selected and the Apply button was clicked. This selected the highlighted shape.

Creating Artwork Using an AEL Macro

The artwork for this example is programmable artwork generated using an AEL function for creating a thin film (MMIC) capacitor. The capacitor area is calculated from the parameters passed into the network. You can create the network first, and
then the AEL function, or vice versa. Once the artwork function is complete, you need to associate it with the network ("Associating Artwork with an Item" on page 13-14).

**Note** Pins can be created using the following AEL functions: de_draw_port (using simulator units), de_define_port (using user units), and de_define_edge_area_port. See the AEL manual for details of these functions.

The following schematic describes the simulation model.
To create an artwork function:

1. Using any text editor, create the macro functions in an AEL file (the file must use an .ael extension). For details on the structure of an AEL function, refer to the AEL manual.

The following annotated example is for a thin film capacitor (TFC), tfcael:

```c
/* layout artwork generation function for MIMCAP element */

This example assumes a MMIC process, with two metal layers, and a via layer. The processing steps required are:
1) deposit first metal and etch to layer 1
2) deposit dielectric and etch vias to layer 4
3) deposit second metal and etch to layer 2

Global technology parameters are provided to show how standard constants could be applied to all artwork functions
*/
//load(“stdart”); // make sure we have standard definitions
// define technology parameters, all in MKS
decl lpad, lab, lpost, wpost, vu, lol, cpua;
lab = 6e-6; // length of air bridge
lpost = 6e-6; // length of post/via
wpost = 10e-6; // width of post/via
vu = 0.5e-6; // via undersize
lpad = 4e-6; // bottom plate pad length
lol = 2e-6; // bottom plate overlap
cpua = 300e-6; // capacitance per unit area
// actual artwork generation function
defun mimart(c, ar)
{
  decl c_mks, netu, wcap, lcap;
decl lbot, wvia, w, l;

  netu = mks_factor(5); //get length conversion factor from mks
c_mks = c*mks_factor(4); // get capacitance in farads
lcap = sqrt(c_mks/cpua*ar)/netu; // get length in meters
wcap = lcap/ar; // get width in network units

  // compute some useful values
  lbot=(2.0*lol+lpad)/netu+lcap;// compute length of bottom plate
  wvia = (wpost-2.0*vu)/netu; // compute width of via
  w = (2.0*lol)/netu + wcap; // compute overall width
  l = (lab+lpost)/netu + lbot;// compute overall length

  // draw lower plate and output contact
```
Artwork

de_set_layer(1); // set the first metal layer
de_draw_rect(0.0, -w/2.0, lbot, w/2.0);
de_draw_rect(l-lpost/netu, -wpost/netu/2.0, 1, wpost/netu/2.0);
// cut via hole
de_set_layer(4); // set via (dielectric) layer
de_draw_rect(l-(lpost-vu)/netu, -wvia/2.0, l-vu/netu, wvia/2.0);
// draw air bridge metal
de_set_layer(2); // set the second metal layer
de_draw_rect((lpad+lol)/netu, -wcap/2.0, lbot-lol/netu, wcap/2.0);
de_draw_rect(lbot-lol/netu, -wpost/netu/2.0, l, wpost/netu/2.0);
// add ports
de_draw_port(0.0, 0.0, -90.0);
de_draw_port(l, 0.0, 0.0);
}

2. Save the file in your project networks directory.

To associate this artwork with your subnetwork:

1. Open the network design and choose File > Design Parameters.
2. From the General tab, select SYM_C as the Symbol Name. (This is the symbol that will represent the schematic.)
3. Set the Simulation Model to Subnetwork.
4. Select AEL Macro as the Artwork Type.
5. In the Artwork Name field, type the name of the function you just created. In this example, mimart. This is defined in the example by the line:
defun mimart(c, ar)
6. From the Parameters tab, create the parameters C and AR, as defined in the artwork function. Both should be set to Netlisted. You can optionally set them as optimizable.

The following illustration shows the MMIC capacitor in layout with C=20 and AR=1.
Note that rather than writing the functions from scratch, you may find it helpful to copy AEL macro code from one or more of the following files and modify it in your own AEL file:

- destdart.ael Artwork macros available from the Design Parameters dialog box, located in $HPEESOF_DIR/de/ael
- ckt_linear_art.ael Existing artwork for circuit simulators, located in $HPEESOF_DIR/circuit/ael

If you want to move the .ael file to a directory other than the project’s networks directory, refer to “Creating Custom Libraries” in the Customization and Configuration manual for details.
Artwork

**Associating Artwork with an Item**

When associating artwork with an item, choose one of the following artwork types:

- Synchronized
- Fixed
- AEL Macro
- None

**Selecting the Appropriate Artwork Type**

The following sections describe how the different artwork types are intended to be used.

**Synchronized Artwork**

When you create and save a network, a design definition is automatically created with certain defaults (which can be modified through **File > Design Parameters**) including Artwork Type. By default, the artwork type will be Synchronized. Synchronized artwork is the appropriate artwork type when the layout contains parameterized components or if the layout is a subnetwork that needs to be regenerated when a parameter is changed. When synchronized artwork is selected as the artwork type, the artwork that is generated is based on the default artwork defined for each component in the schematic. Additionally, when the design synchronization process is run, it checks the subnetwork references for any changes to its parameters and automatically regenerates the layout based on the changes.

**Fixed Artwork**

If your layout is comprised of fixed shapes, then Fixed artwork is the appropriate Artwork Type. The layout artwork can reside in the same design file as the schematic or in a different file.

To associate fixed artwork with an item:

1. From the design of interest, choose **File > Design Parameters**.
2. From the Artwork Type drop-down list, select **Fixed**.
3. In the Artwork Name field, select or type the name of the design file containing the artwork. This can be supplied artwork or custom artwork. You do not need
to include the full path, just the design file name, minus the .dsn extension. The file should reside either in your project's networks directory or in a directory whose files are automatically loaded by the program (based on the search path). For details refer to “Creating Custom Libraries” in the Customization and Configuration manual.

4. Change any other design definition characteristics as desired and click OK.

**AEL Macro Artwork**

If you want to generate artwork based on parameters that may change, then AEL Macro artwork is the appropriate Artwork Type.

To associate an AEL Macro artwork with an item:

1. From the design of interest, choose File > Design Parameters.

2. From the General tab, select AEL Macro as the Artwork Type.

3. In the Artwork Name field, select or type the name of the function. Note, this is not the name of the AEL file, rather it is the name of the AEL artwork creation function (specified with the defun AEL function).

The function must be in an AEL file that is loaded by the program. All AEL files in your project's networks directory are automatically loaded. For details on loading files from other directories (based on the search path), refer to “Creating Custom Libraries” in the Customization and Configuration manual.

4. From the Parameters tab, enter the list of parameters used by the macro and assign the appropriate characteristics including Value Type. Note the following guidelines when defining parameters:

   • Artwork parameters must be defined in the same order in which they are used by the macro and they must be listed before any other parameters. Their type should be Not Netlisted.

   • All parameters that define physical dimensions should be assigned Length as the Parameter Type. If you do not define a unit along with the Default Value, the specified value will be read as meters. When you place an instance of this
subnetwork in a schematic, the specified default value is converted from meters to the current Length unit set for the Schematic window.

• The Layer parameter is the Layer Number on which the artwork should be drawn, and must be an integer.

Hint To quickly populate the list of parameters, click Copy Parameters From and select a component with parameters similar to those you need, then modify the list of parameters and their characteristics as desired.

5. Optionally, select an appropriate Parameter Type. This selection determines the choices available for editing the parameters when you place your subnetwork.

The following example shows Value Type and Parameter Type settings based on the cpad2 macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value Type</th>
<th>Parameter Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>R</td>
<td>Real</td>
<td>Length</td>
</tr>
<tr>
<td>S</td>
<td>Real</td>
<td>Length</td>
</tr>
<tr>
<td>LAYER</td>
<td>Integer</td>
<td>Unitless</td>
</tr>
</tbody>
</table>

If the AEL Macro artwork is SMT package artwork:

1. In the Design Parameters dialog box, set the Artwork Type to AEL Macro and select the appropriate Artwork Name (smaart_<part_name>).

2. In the Parameters section, define the two parameters, SMTPAD and OFFSET.
   • For the SMTPAD parameter, set the Parameter Type to String and set the default value to the appropriate SMTPAD Instance Name (for example, PAD1). Select the Not netlisted option.
   • For the OFFSET parameter, set the type to Real, with a default value 0.

None

Select None as the Artwork Type if no artwork is to be generated or no artwork is to be used to synchronize the schematic with layout objects.
Overriding the Default Artwork Assignment

You can override the default artwork assignment for any given component.

To change the artwork for a given component:

1. Select the component and choose Edit > Component > Edit Component Artwork.
2. Choose from one of the following Artwork Types:

   - **Default**: Uses the artwork specified in the component’s create_item definition. The artwork type and artwork function name are displayed.
   - **Fixed**: Any supplied or custom fixed artwork. Select or type the design filename containing the artwork from the Artwork Name drop-down list, or use the browser to select one.
   - **Null Artwork**: Draws a generic box (with an X through it)

3. Click Apply for this component and select another and repeat as needed. Click OK when you are finished.
Artwork
Chapter 14: Importing and Exporting Layouts

The import/export translators in the Advanced Design System are highly configurable. Each translator has an associated options file that controls how the translator works. Default options files are included with the program and are automatically used unless you specify otherwise.

This chapter provides an overview of importing and exporting layouts.

<table>
<thead>
<tr>
<th>Import</th>
<th>File Format</th>
<th>Export</th>
</tr>
</thead>
<tbody>
<tr>
<td>DXF</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>*</td>
<td>EGS Archive Format</td>
<td>*</td>
</tr>
<tr>
<td>*</td>
<td>EGS Generate Format</td>
<td>*</td>
</tr>
<tr>
<td></td>
<td>GDSII Stream Format</td>
<td>*</td>
</tr>
<tr>
<td>Gerber</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Gerber Viewer</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>*</td>
<td>HPGL/2</td>
<td>*</td>
</tr>
<tr>
<td>*</td>
<td>IFF</td>
<td>*</td>
</tr>
<tr>
<td>*</td>
<td>IGES</td>
<td>*</td>
</tr>
<tr>
<td>*</td>
<td>Mask File</td>
<td>*</td>
</tr>
<tr>
<td>MGC/PCB</td>
<td></td>
<td>*</td>
</tr>
</tbody>
</table>

Note  For details, refer to the Importing and Exporting manual.
Importing and Exporting Layouts

Importing a Layout

Use the following procedure to import a layout.

1. In the Layout window, choose the command **File > Import**. The Import dialog box appears.
2. From the Import dialog box, select the desired format.
3. Click **Select File**, choose a file name, and click OK.
4. Define any options or layer attributes.
5. Click OK. The file is translated into the program. One or more design files can be created.

For all translators, one or more designs can be created. The top level design for IGES or GDSII is displayed in the Layout window (no schematics are created using any of the translators).

---

**Note** Errors or warnings generated during translation are written to a write<translator>.log file, such as writegds.log (GDSII), writeigs.log (IGES), or writeegs.log (EGS).

---

Opening and Viewing a Translated Layout

Use either the design tree in the Main window, or the File menu in the Layout window to open an imported layout.

Saving a Translated Layout

You must explicitly save a translated design. It is not automatically saved. Use the following step to save one or more translated designs (individual designs created during the translation of a hierarchical design):

In the Main window, choose the command **File > Save All Designs**.

Listing the Hierarchy of a Translated Layout

In the Layout window, choose the command **Tools > Hierarchy**.
Exporting a Layout

Preparing a Layout for Translation

Preparing a layout for translation consists of some or all of the following steps:

• Remove (flatten) any hierarchy that exists in the layout. This is necessary if you want to make changes that would affect all levels of the hierarchy, such as merging shapes.

• Edit the shapes that make up the graphical representations of the circuit components in the layout. The most common editing steps are to:
  • Merge graphics shapes that are on the same layer and touching (to eliminates boundaries between components so that the layout consist of graphics only).
  • Apply process offsets.
  • Create reverse images.
  • Change colors.

Layouts are sometimes edited to reverse the arrangement of colors: to replace white with black, for example.

• Change the visibility or arrangement of layers.

The steps you must use depend on the type of translation, and on what must appear in the finished file.

Flattening Instances to Eliminate Hierarchy and Connectivity

When you flatten components, you turn each component in the layout into a set of unrelated shapes. Component grouping is lost, and the shapes no longer behave as an electrical entity for simulation. Use the following steps:

1. In the Layout window, choose File > Generate Artwork.

2. When the program prompts you for a new design name, enter the desired name and click OK.

Hierarchy is removed so that all primitives are contained in the copied top-level layout icon.
Adding a Process Offset

It is sometimes necessary to have two layers that are almost the same except that one has a process offset. A process offset is a fixed amount of space (width) that is added to or subtracted from all dimensions of an object to compensate for production tolerances. Process offsets are used to create objects that overlap or underlie other objects, and to fix the actual amount of the overlap. If the object is a polyline or an arc, the object must have width to use a process offset. In addition, when process offsets are used with these primitives, only width is affected; process offsets do not change the endpoints of polylines or arcs. To create a process offset in your layout, copy the shapes from one layer to an empty layer, merge the shapes on the new layer, and then oversize (or undersize) the merged shapes.

Copying Shapes to a New Layer

To copy shapes from one layer to another:

1. If the layer to which you want to copy the shapes does not exist, choose Options > Layers to display the Layer Editor, then add the desired layer.
2. In the Layout window, select the shapes that you want to copy.
3. Choose Edit > Copy/Paste > Copy to Layer.
4. In the Copy to Layer dialog box, select the destination layer and click OK.

Note The program places a copy of the selected shapes on the destination layer, in exactly the same place as they appear on the source layer. Because of this, you cannot see the copied shapes. When you click OK, a copy is placed on the destination layer; click Apply only if you want to select an additional layer to copy shapes to.
Merging Shapes

Merging replaces all shapes on the same layer and touching with combined shapes. This step is especially necessary before doing process offsets with negative values, but should follow the elimination of hierarchy, as described in “Flattening Instances to Eliminate Hierarchy and Connectivity” on page 14-3.

To merge shapes:

1. Select the shapes that you want to merge.
2. Choose Edit > Merge.

Resizing Shapes

You can increases or decreases the outline size of a shape, which is sometimes needed to compensate for a manufacturing process.

To resize shapes:

1. Select the shapes that you want to resize.
2. Choose Edit > Scale/Oversize > Oversize.
3. In the Oversize dialog box, enter (in layout units) how much you want added to or removed from the selected shapes. A positive number increases the size of a shape, a negative number decreases it.
4. Click OK.

Creating a Reverse Image of a Layer

You can create a ground plane or a solder mask that includes the area between shapes, as follows:

1. Copy the desired shapes to a an empty layer.
2. Place a rectangle (that represents the ground plane) over the shapes.
3. Choose Edit > Create Clearance.
4. When prompted, select the rectangle that represents the ground plane, then click OK.
5. In the Create Clearance dialog box that appears, enter any clearance you want for a ground plane (or offset you want added to the final shapes when creating a solder mask).
6. Select the shapes and click OK.
7. Select and delete the shapes to leave the ground plane/solder mask.

**Translating a Layout**

To export a layout:
1. In the Layout window, choose the command **File > Export**. The Export dialog box appears.
2. From the Export dialog box, select the desired format.
   Only one format can be specified at a time. The format you choose determines which options are available for translation. The options control the program translator.
3. If desired, specify a file name. If no file name is given, the name of the translated design is used. You do not need to specify the file extension.
4. Define any preferences or layer attributes (both in the Options menu).
   To specify the GDSII layer number or IGES level number to be used in exporting a design, choose **Options > Layers** to access the Layer Editor. Valid GDSII layer numbers are 0 through 255.
5. To start the translation process, click OK. If no path is specified, the file is written to the current project directory.
Chapter 15: Standard AEL Macros

The AEL macros described here are for layout-only components.

- “conn” on page 15-2
- “cpad2” on page 15-2
- “cpad3” on page 15-3
- “cpad4” on page 15-4
- “pad1” on page 15-5
- “pad3” on page 15-6
- “pad4” on page 15-7
- “padn” on page 15-8
- “rpad2” on page 15-9
- “rpad3” on page 15-10
- “rpad4” on page 15-11
- “spac” on page 15-12
- “spad2” on page 15-12
- “spad3” on page 15-13
- “spad4” on page 15-14
- “tar1” on page 15-15

Additional components for which AEL macros are supplied are documented in the Circuit Components manual.
Standard AEL Macros

**conn**

Port Connection

Illustration:

![Port Connection Illustration](image)

**Parameters:**

None

**cpad2**

Circular Two Pads with Non-Preferred Ports

Illustration:

![Circular Two Pads Illustration](image)

**Parameters:**

R = Radius of the pads
S = Center-to-center spacing
LAYER = Layer number


cpad3
Circular Three Pads with Non-Preferred Ports

Illustration:

Parameters:
R1 = Radius of pads 1 and 2
S1 = Center-to-center spacing between pad 1 and 2
R2 = Radius of pad 3
S2 = Vertical distance between pad 2 and 3
LAYER = Layer number
Standard AEL Macros

**cpad4**

Circular Four Pads with Non-Preferred Ports

**Illustration:**

![Diagram of cpad4](image)

**Parameters:**

- **R1** = Radius of pads 1 and 2
- **S1** = Center-to-center spacing between pad 1 and 2
- **R2** = Radius of pads 3 and 4
- **S2** = Center-to-center spacing between pads 3 and 4
- **LAYER** = Layer number
pad1

Rectangular Two Pads with preferred ports

Illustration:

Parameters:

$W =$ Width
$S =$ Spacing
$L =$ Pin 1 to Pin 2
$\text{LAYER} =$ Layer number
Standard AEL Macros

**pad3**

Rectangular Three Pads with preferred ports

**Illustration:**

![Illustration of pad3](image)

**Parameters:**

- $W_1 =$ Width of pad at pins 1 and 2
- $W_2 =$ Width of pad at pin 3
- $S =$ Spacing
- $L_1 =$ Total horizontal length
- $L_2 =$ Vertical length from pin 1 to pin 3
- $\text{LAYER} =$ Layer number
pad4

Rectangular Four Pads with preferred ports

Illustration:

Parameters:

$W_1 =$ Width of pad at pins 1 and 2
$W_2 =$ Width of pad at pins 3 and 4
$S =$ Spacing (length of pads)
$L_1 =$ Total horizontal length + space
$L_2 =$ Total vertical length from top of pin 4 to bottom of pin 3 + space
$\text{LAYER} =$ Layer number
Standard AEL Macros

**padn**

N Pads for a dip

**Illustration:**

```
  +---+---+---+
  |   |   |   |
  +---+---+---+
  |   |   |   |
  +---+---+---+
  |   |   |   |
  +---+---+---+
  |   |   |   |
  +---+---+---+
  |   |   |   |
  +---+---+---+
```

**Parameters:**

- **PW** = Pad width
- **XS** = X-axis spacing between recurrent pads
- **YS** = Y-axis spacing between recurrent pads
- **NUM** = Total number of pads
- **LAYER** = Layer number
rpad2

Rectangular Two Pads with Non-Preferred Ports

Illustration:

Parameters:

- $W =$ Width
- $S =$ Spacing
- $L =$ Total length of the pads + space
- LAYER = Layer number
Standard AEL Macros

**rpad3**

Rectangular Three Pads with Non-Preferred Ports

**Illustration:**

![Diagram of rpad3](image)

**Parameters:**

- \(W_1\) = Width of pad at pins 1 and 2
- \(W_2\) = Width of pad at pin 3
- \(S\) = Spacing between pad 1 and pad 2
- \(L_1\) = Total horizontal length + space
- \(L_2\) = Vertical length from pin 1 to pin 3 + space
- \(LAYER\) = Layer number
rpad4
Rectangular Four Pads with Non-Preferred Ports

Illustration:

Parameters:

W1 = Width of pad at pins 1 and 2
W2 = Width of pad at pins 3 and 4
S = Space between pad 1 and pad 2
L1 = Pin 1 to pin 2
L2 = Length from pin 4 to pin 3
LAYER = Layer number
Standard AEL Macros

**spac**

Space

**Illustration:**

```
   1   L   2

Parameter:

L = Length

**spad2**

Square Two Pads with Non-Preferred Ports

**Illustration:**

```
    W

    P1

    L

    P2

Parameters:

W = Width
L = Pin 1 to Pin 2
LAYER = Layer number
**spad3**

Square Three Pads with Non-Preferred Ports

**Illustration:**

```
  L
 /   \
/     /
P1     P2
W
```

**Parameters:**

- $W =$ Width
- $L =$ Pin 1 to Pin 2
- $\text{LAYER} =$ Layer number
Standard AEL Macros

**spad4**
Square Four Pads with Non-Preferred Ports

**Illustration:**

![Diagram of spad4 macro](image)

**Parameters:**

- \( W \) = Width
- \( L \) = Pin 1 to Pin 2
- \( \text{LAYER} \) = Layer number
**tar1**

Square Pad

**Illustration:**

![Square Pad Illustration](image)

**Parameter:**

\( W = \text{Width} \)
Standard AEL Macros
Chapter 16: Printing and Plotting

This chapter describes printing and plotting from Advanced Design System. You can send output to printers and plotters as well as to file in a variety of formats. When printing to file, the format of the file is determined by the current output device and the file is saved in the current project directory.

You can connect any output device that is supported by your operating system. To connect additional printers and plotters, and select a default printer, choose the appropriate method for your platform:

- Windows 2000—Start menu > Settings > Printers
- UNIX—Choose File > Print Setup > Install > Add Printer

The basic Print commands are summarized next:

- Use the Print command to print the contents of the drawing area of the current window
- Use the Print Area command to print a region of the drawing area
- Use the Print Setup command to establish a default printing configuration, although you can modify it at the time of printing

Note: For detailed information on printing and print setup options on the PC, refer to your Windows documentation.

Because the print methods vary significantly between UNIX and the PC, this chapter describes printing from these platforms separately. Refer to the appropriate section for your platform:

- “Printing from UNIX” on page 16-2
- “Printing from the PC” on page 16-12
Printing and Plotting

**Printing from UNIX**

Printing and plotting from Advanced Design System on UNIX is accomplished by establishing the desired print setup and then choosing **File > Print**. The Print Setup and related dialog boxes enable you to:

- Choose to send output to a printer/plotter or print to file
- Install additional printers
- Select a printer (if sending to printer) other than the default
- Select a file format (if printing to file)
- Select Portrait or Landscape orientation
- Scale the output
- Specify the number of copies

When you select a printer, you can change the following default printer-specific options:

- Resolution
- Page Size
- Paper Tray

When you choose **File > Print**, you can select from the following additional options:

- Convert to HP-GL/2 file
  - Select this option to print to file using the HP-GL/2 format.

- Color output
  - Select this option to print in color (on a color printer) or in grayscale, rather than black and white (on a monochrome printer)

- Scale to fit page
  - Select this option to fill the printed page. If selected, this option overrides any scaling factor you have set.

**Hint**  Click Options in the Print dialog box as a shortcut back to the Print Setup dialog box if you decide to make changes to the current setup.
Your print setup is saved in $HOME/.Xprinterdefaults. If you do not have a local copy of this file, or the file .Xpdefaults (from a previous release), the default file is read from the $HPEESOF_DIR/xprinter directory. When you change your print setup, the changes are saved (as new defaults) to $HOME/.Xprinterdefaults. Note: If you do have a file .Xpdefaults (from a previous release), the settings of this file are copied to the new filename to serve as the starting point for your print setup. Both files are valid, depending on which release of ADS you are using. The old file is maintained for running an earlier version of ADS, but the new file is used when you run ADS 1.5 (or later).

**Adding a Printer**

The basic steps required for adding a printer through the Print Setup dialog box are: defining a port and associating a printer with that port.

To define a port and add a printer:

1. Choose **File** > **Print Setup** and a dialog box appears.
2. Click **Install** and a dialog box appears listing all currently installed printers.
3. Click **Add Printer** and a dialog box appears listing all available printer devices and all currently defined ports.

![Add Printer Dialog Box]

**Note** For a list of supported printers, see Supported_Printers_XPV331.html in $HPEESOF_DIR/xprinter.
4. Click **Define New Port** and a dialog box appears listing all currently defined ports.

5. Add all ports you want to access for printing:
   - On HP 700 and Sun Solaris workstations, click **Spooler** and the list of ports is automatically generated (based on your printcap file).
   - On all other workstations, type the port definition in the Edit Port field using the following syntax: printer name=print command (no spaces around equal sign), where print command is the print alias, just as you would type it in the terminal window. Click **Add-Replace**. Repeat for each desired port.

**Note** Port names can be any names you choose with the exception of FILE: which is a reserved port name.
6. Click **Dismiss** to accept the new port definitions and return to the Add Printer dialog box. The Current Port Definitions list box is updated.

![Current Port Definitions](image)

7. Select the desired printer from the list of Printer Devices.

8. Select the port you want to associate with this printer.

![Printer Devices and Current Port Definitions](image)

9. Click **Add Selected**. The Printer Installation dialog box is updated.

![Currently Installed Printers](image)

If you defined multiple ports, you can associate a printer with each, as just described.

10. **Dismiss** the Add Printer and Printer Installation dialog boxes. You will now be able to select any of the installed printers, as needed.
Printing and Plotting

Selecting a Printer
To select a printer other than the current default:

1. Choose File > Print Setup.

2. Select Printer as the Output Format in the Print Setup dialog box.

3. Click Options and a dialog box appears.

4. Select the desired printer from the Printer Name drop-down list. The printer-specific options are updated to reflect the default options for the selected printer.

5. Change any or all of these options as needed and click OK.

6. Set the following options, in the Print Setup dialog box, as desired for the current printer:
   - Orientation
   - Scale (the value 2.0 would double the size; 0.5 would reduce it by half)
   - Copies

**Hint** Like all other information in the setup-related dialog boxes, settings made here become the new defaults for this printer.

7. Click OK and the current printer configuration information is saved.
Sending Output to the Printer

To send the entire contents of the window to the printer:

1. Choose File > Print and a dialog box appears.
2. Select any print options as needed, and click OK.

**Hint** The Scale to fit page option will fill the printed page, regardless of the current value in the Scale field of the Print Setup dialog box.

Creating a Printer-specific Print File

You can create a print file in the format used by a particular printer by associating that printer with the FILE: port. This port appears by default in the Add Printer dialog box. Once you make the association, you can select this printer as the current printer and create a print file for it.

To associate the desired printer with the FILE: port:

1. Choose File > Print Setup.
2. Click Install > Add Printer.
3. Select the desired printer and the FILE:= port definition.
4. Click Add Selected. The Printer Installation dialog box is updated.
5. **Dismiss** the Add Printer and Printer Installation dialog boxes.
Printing and Plotting

To make this printer the current printer:

1. Click **Options** and select the printer associated with **FILE:** from the Printer Name drop-down list.

   ![Options dialog box]

2. Change any options as needed and click **OK**.
3. Click **OK** in the Print Setup dialog box.

To create the print file:

1. Choose **File > Print**.
2. Select any print options as needed, and click **OK**. A dialog box appears prompting you for a filename.
3. Change directories if desired—the file is written to the current project by default—and supply a name in the **Output To File** field. Click **OK**. The file is written to the specified directory.
Printing to File in a Generic Format

You can send your output to file, in a limited number of generic formats, which can then be imported in a variety of applications. The available formats are:

- Encapsulated Postscript®
- PCL4
- PCL5

Note: You have the option of converting to an HPGL/2 file when you choose File > Print.

To establish a print setup for printing to file:

1. Choose File > Print Setup.
2. Select File (Generic Only) as the Output Format.
3. Select a different file type from the drop-down list as needed. The default File Name is updated to reflect the selected file type.
4. Set the following options as desired:
   - Orientation
   - Scale
   - Copies
5. Click OK in the Print Setup dialog box.

To print to file:

1. Choose File > Print and a dialog box appears offering additional options.
2. Select any or all of these options, as needed, and click OK.
3. The file is written to the current project directory, using the filename from the Print Setup dialog box.
Printing and Plotting

**Printing from the PC**

This section describes some of the actual printing features available on the PC. For information on basics (such as adding a printer), refer to your Windows documentation.

Printing from Advanced Design System on the PC is accomplished by establishing the desired print setup and then choosing File > Print (or Print Area). Listed below are some of the more common options you can set through the Print Setup and related dialog boxes:

---

**Note**  The options available vary based on the printer/printer driver you select.

- Printer (select any installed printer)
- Paper size and source
- Orientation (Landscape is generally recommended for schematics and layouts)
- Number of copies
- Single- or two-sided printing
- Scaling

When you choose File > Print, you can select from the following additional options:

- **Print to file**
  Select this option to send output to file for printing at a later time. Select Enhanced Metafile, Windows Metafile, or HP-GL/2 as the file format when the Print to File dialog box appears.

- **Color output**
  Select this option to print in color (on a color printer) or in grayscale, rather than black and white (on a monochrome printer).

- **Copy to clipboard**
  Select this option to place the image on the Windows clipboard (Bitmap) for pasting in any Windows application.

- **Fit to page**
  Select this option to fill the printed page. If selected, this option overrides any scaling percentage you have set.
Establishing a Print Setup

To establish a print setup:

1. Choose File > Print Setup.
2. Select the desired printer from the drop-down list.

3. Change any of the options here as desired, or click Properties to set additional options, such as Scaling. Note that the appearance of the Properties dialog box varies depending on the selected printer.

4. Change any other options as desired and click OK to dismiss the Properties dialog box.

5. Click OK in the Print Setup dialog box and you are ready to print.
Printing and Plotting

**Basic Printing**

To send the entire contents of the window to the printer:

1. Choose **File > Print** and a dialog box appears.

   Note   The Fit to page option overrides any scaling percentage set. Disable this option if you have intentionally set a scaling percentage.

2. Change any print options as needed, and click **OK**.

To print a specific region of your schematic or layout:

1. Choose **File > Print Area**. As you move your pointer into the drawing area, it changes to a cross-hair cursor, and the Status panel prompt changes to read, **PrintArea: Enter the starting point**.

2. Position the pointer at one corner of a window that will enclose the area you want to print, and click. The Status panel prompt changes to read, **PrintArea: Enter the next point**.

3. As you move the mouse, a ghost image of the window is drawn. Click again to specify the opposite corner of the window and the Print dialog box appears.

4. Change any options as needed and click **OK** to print the specified region.
Printing a Scaled Layout

To scale a layout for printing:

Note This process involves flattening and, potentially, scaling your layout in ADS. You can do this to your actual design—and then close it without saving changes—or make a copy of it before printing and make the changes to the copy.

1. Choose File > Save Design As to make a copy of the layout.
2. Choose Edit > Component > Flatten to convert it to shapes-only information. (Components are not scalable.)
3. Choose Insert > Measure and establish the size of the design.
4. Determine the appropriate scaling factor based on the actual size of the design and the paper size you want to use.

Note The ability to scale a design for printing is a function of the printer driver associated with the selected printer. In general, PostScript printer drivers enable scaling while PCL printer drivers do not. Many printer drivers can be downloaded from the Internet. If your printer driver does not allow a sufficiently large scaling factor, you can also scale the design in ADS to reach a combined scale factor appropriate for your layout.

The example shown here is based on a design from the examples directory: / examples/ MW_Ckts/ drc_via_prj/ pwramp.
This design measures 1525 microns (or 0.1525 cm) across, and is close enough to being square to use that measurement as the basis for determining a scaling factor. In this example we want to basically fill ANSI E paper (34" x 44") and so we convert the metric units to English units 0.1525 cm x 0.39370 = ~0.06 inches. To simplify this example, we settle on a 30 inch image, yielding a required scaling factor of 500 (30 / 0.06 = 500).

5. To verify the maximum scaling factor your printer driver allows, choose File > Print Setup and click Properties.
6. Locate the Scaling option. It may appear on the tab displayed by default, or in an Advanced tab, as shown in this example.

![Scaling option in Document Properties dialog box]

7. Select the Scaling option and supply the desired scaling percentage in the field provided.

   In this example, we opted for 500% (factor of 5) scaling through the printer driver, and a scale factor of 100 (for a total of 500) through ADS.

8. Select the Paper Size option and select the appropriate size.

9. Change any other options as desired and click OK to dismiss the Properties dialog box.

10. Click OK in the Print Setup dialog box.

11. If necessary, scale the design in ADS. Choose Select > Select All., then choose Edit > Scale/Oversize > Scale. Supply the desired scaling factor, in this example, 100, and click OK.
12. Choose View > View All.

13. Choose File > Print Area and draw a border around the layout. (This is to ensure best results, since printing otherwise begins at the coordinates 0,0 and may include empty space.)

14. When the Print dialog box appears, select any other options as desired, such as Color Output if your printer is a color printer.

**Note**  The Fit to page option overrides any scaling percentage set. Disable this option if you have intentionally set a scaling percentage.
Chapter 17: Using the Text Editor

Hpeesofedit is a general-purpose ASCII text editor capable of editing one file at a time. It enables you to cut and paste, search for text, replace text, and go to a specific line of text. You can access Hpeesofedit from the Tools menu in the Main window or you can start it from any command shell. The topics described here are:

- “Starting the Text Editor Program” on page 17-1
- “Text File Management” on page 17-3
- “Editing Text Files” on page 17-5
- “Performing Search and Replace Operations” on page 17-6
- “Keyboard Mappings” on page 17-8

Starting the Text Editor Program

To start the text editor program:

- Choose Tools > Text Editor in the Main window.

  or

- Type hpeesofedit in any command shell, and press Return.

The Hpeesofedit window appears.

The status bar displays warnings, the status of the search/replace operation, and the current line number and character position. The copyright message is displayed in the status bar until you begin typing. The text entry portion of the edit window displays all text you type or paste into the window.
Using the Text Editor

Command Line Options

The Hpeesofeedit program accepts most standard X/Xt command line options. These options are listed in Table 17-1. (For further details on these options, refer to your UNIX documentation.)

<table>
<thead>
<tr>
<th>Option</th>
<th>Argument</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>-background, -bg</td>
<td>color_name</td>
<td>-bg white</td>
</tr>
<tr>
<td>-foreground, -fg</td>
<td>color_name</td>
<td>-fg blue</td>
</tr>
<tr>
<td>-display</td>
<td>display_name</td>
<td>-display unix:0</td>
</tr>
<tr>
<td>-geometry</td>
<td>geometry string</td>
<td>-geometry 300x400+10+30</td>
</tr>
<tr>
<td>-iconic</td>
<td></td>
<td></td>
</tr>
<tr>
<td>-xrm</td>
<td>X-resource</td>
<td>-xrm <strong>background:blue</strong></td>
</tr>
</tbody>
</table>

To start the Hpeesofeedit program with a command line option:

   In any command shell, type **hpeesofeedit <desired option>** and press Return.

Alternatively, any of these resources can be specified in your resource file using Hpeesofeedit as the class name. Hpeesofeedit is also the resource filename for the program.

---

**Note**  Any option not preceded by a dash (-) is treated as a filename and the program will attempt to open a file by this name. If a file by this name does not exist, a new file is created.
Text File Management

Basic file operations include creating new files, opening existing files, inserting existing files into other files, and printing and saving files.

Creating a Text File

To create a new text file:
1. Select **File > New**. If there is currently any text in the window, you are prompted **Text exists, clear?**
   • To avoid clearing the text in the window, click **No** and then take the desired action.
   • To clear it and start a new file, click **Yes**.
2. When the window is empty and labeled **untitled**, type the desired text. (You assign a name to the file when you save it.)

Opening an Existing File

To open an existing file:
1. Select **File > Open**. If there is currently any text in the window, you are prompted **Text exists, clear?**
   • To avoid clearing the text in the window, click **No** and then take the desired action.
   • To clear it and open a file, click **Yes**, and a dialog box appears.
   The default file filter is an asterisk (*) so all files in the current directory are listed.
2. Select the desired file and click **Open**. The file appears in the **Hpeesofedit** window for editing.
**Inserting One Text File into Another**

The Insert command enables you to insert a text file, in its entirety, into another text file.

To insert a text file into the currently open file:

1. Select File > Insert. A dialog box appears.
2. Select the desired file and click Insert. The selected file is inserted at the current cursor position in the currently open file.

**Saving Text Files**

The File menu contains two commands related to saving files: Save and Save As.

- The Save command enables you to save changes to an existing file.
- The Save As command enables you save a new file, and name it in the process, or save an existing file with a new name. For example, if you would like a copy of an existing file so that you can make changes to it while preserving the original, you can use the Save As command to create a copy of the file with another name.

To save an existing file:

Select File > Save. The file is saved and the number of bytes and path/filename are displayed in the status bar.

To save a new file or to save an existing file with a new name:

1. Select File > Save As... and a dialog box appears.
2. Adjust the path, if desired.
3. Enter a name for the file in the Selection field.
4. Choose Save As. The file is saved.
Printing Text Files

To print a text file:

Select File > Print. The file is sent to the printer and a status window appears briefly displaying the status of the print request and noting which printer was used.

Note The setting of the environment variable PRINTER determines which printer is used. If this variable is not set, the default printer is used.

Exiting the Text Editor

To exit the program:

Select File > Quit. If the file has been modified since the last save, you are prompted, File Modified, exit anyway?

• To exit without saving the file, click Yes.
• To cancel so that you can save the file, click No.

Editing Text Files

The Edit menu enables you to copy, cut, paste, and delete text.

To copy text from one location to another:

1. Select the text you wish to copy.
2. Select Edit > Copy. The selected text is copied to the buffer.
3. Position the cursor in the desired location (in any window) and select Paste.

To move text from one location to another:

1. Select the text you wish to move.
2. Select Edit > Cut. The selected text is removed from that location and placed in the buffer.
3. Position the cursor in the desired location (in any window) and select Paste.

To paste text currently being held in the buffer:
Using the Text Editor

Position the cursor in the desired location (in any window) and select Edit > Paste. The contents of the buffer appear at the current cursor location.

To delete text:
Select the text you want to delete and select Edit > Delete. The selected text disappears.

Performing Search and Replace Operations

The Search menu contains commands to enable you to jump to a specified line number in the text file and to search for and replace specified text strings.

To jump to a specific line number in the file:
1. Select Search > Go To... and a dialog box appears.
2. Type the desired line number and click OK. The cursor jumps to that line number in the file.

To perform the search and replace operation:
1. Select Search > Search/Replace... and a dialog box appears. In the Search String field, type the string of characters you want to search for, including wildcard characters, if desired. (If you use wildcard characters, you must check the box labeled Regular Expression.)
2. In the Replace String field, type the string of characters you want to use to replace the Search String characters.

3. Optionally, check this box if you want to search backward from the current cursor position.

4. Optionally, check this box if you want to include wildcard characters in your search.

Note For details on including Regular Expressions in your search, refer to your UNIX documentation.

5. Click Search. If the requested text is found, it is highlighted; if it is not found, a pop-up appears and displays the message String not found.

6. If you want to replace the highlighted occurrence with the contents of the Replace String field, click Replace. The highlighted text is replaced.

Hint To clear the highlight from text at any time, simply click somewhere inside the text editor window.

7. If you want to replace every occurrence of the specified search string at once, click Replace All. Every occurrence is replaced.

8. When you are through using the Search and Replace function, click Cancel to clear any remaining highlights from text and dismiss the dialog box.
Using the Text Editor

**Keyboard Mappings**

The text entry area in the editor supports the complete Motif set of keyboard mappings. These mappings are primarily controlled by the XKeysymDB file (or its equivalent), which is typically found in `/usr/lib/X11`. Table 17-2 describes the mapping of the Sun keyboard. (The mappings for the HP platform follows the Sun’s mappings with few exceptions.) Note that the Meta keys are labeled differently on different keyboards, but are always the keys on either side of the space bar.

Table 17-2. Keyboard mappings

<table>
<thead>
<tr>
<th>Keyboard or Mouse Operation</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Copies selected text to the clipboard</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes text from the clipboard to current insertion point</td>
</tr>
<tr>
<td>Cut</td>
<td>Cuts selected text to the clipboard</td>
</tr>
<tr>
<td>Arrow Keys</td>
<td>Moves the insertion point cursor/scrolls window</td>
</tr>
<tr>
<td>Shift Arrow Keys</td>
<td>Moves insertion point, selects text</td>
</tr>
<tr>
<td>Page Up/Down</td>
<td>Moves the window up/down by the number of visible lines</td>
</tr>
<tr>
<td>Home/End</td>
<td>Moves cursor to beginning/ending of current line</td>
</tr>
<tr>
<td>Ctrl Home/End</td>
<td>Moves cursor to first/last visible line in window</td>
</tr>
<tr>
<td>Back Space</td>
<td>Deletes text to left of the insertion cursor</td>
</tr>
<tr>
<td>Meta Ctrl left arrow</td>
<td>Moves cursor backward one word</td>
</tr>
<tr>
<td>Meta Ctrl right arrow</td>
<td>Moves cursor forward one word</td>
</tr>
<tr>
<td>Meta Ctrl down arrow</td>
<td>Moves cursor down one paragraph</td>
</tr>
<tr>
<td>Meta Ctrl up arrow</td>
<td>Moves cursor up one paragraph</td>
</tr>
<tr>
<td>Left mouse button down/move</td>
<td>Selects text range</td>
</tr>
<tr>
<td>Shift left mouse button down/move</td>
<td>Extends selected text range</td>
</tr>
</tbody>
</table>
Appendix A: Using Advanced Design System Across Platforms

A device library or design project stored on a shared volume can be accessed and modified from either a PC or a UNIX workstation. In addition, files created on one platform can be transferred and used on another.

When creating and modifying a file on a shared volume, keep in mind the following:

• You need read and write access to modify a file on a shared volume.
• Only one user can access a file at a time.

Files can be transferred electronically via FTP or they can be moved physically using a medium such as floppy disks. When transferring libraries and projects from one platform to another, keep in mind the following:

• Use a Binary (image) file transfer method.
• Maintain the original file and directory structure at all times.
• Copy all hidden files.
• Use the Archive Project command before copying a project to a diskette or transferring it via FTP. For details, refer to “Archiving a Project” on page 2-13.

Note If a project created on UNIX contains two or more designs whose names are only distinguishable from one another by differences in case, do not archive and transfer this project to a PC without renaming the designs such that they all have unique names. This requirement is due to the fact that the PC is case insensitive.
Opening Projects

To open a project, you need a licensed copy of Advanced Design System for your current platform and access to the current location of the project files.

To open a project:

1. In the Main window, choose File > Open Project or click the Open Project button.
2. In the dialog box that appears, select the project and click OK.

Guidelines for Cross-platform Use

Use the following guidelines when creating libraries or projects for cross-platform use:

- Use filename characters and conventions that are legal on both platforms. For example, Windows does not recognize case-sensitive differences in filenames.
- Use only the standard ASCII character set for text.
- Use fonts that are standard on both platforms.
- Use colors that are standard on both platforms.
Index

A
activate components, 6-1
Add command, 11-9
Add command (Edit > Vertex), 6-32
Add Custom Technology, 2-3
Advanced Design System Setup command, 1-2
Advanced Rotate commands (Edit menu)
  Rotate Around Reference, 6-26
  Rotate Relative, 6-26
Set Rotation Angle command, 6-28
AEL
  entering commands, 3-54
  macro artwork examples, 15-1
AEL macro artwork, 13-15
AEL_PATH, 9-31
Always Design Synchronize command, 9-24
And command (Edit > Merge), 11-3
annotation
  adding system variables to your designs, 7-3
Arc (clockwise) command, 7-6
Arc (counter-clockwise) command, 7-6
Arc (start,end,circumference) command, 7-6
Archive Project command, 2-13
arcs
  converting from vertices, 11-10
  deleting from a polyline, 11-10
area pin, 11-17
Arrow command, 7-7
artwork
  adding pins/ports, 13-5
AEL macro, 13-15
  associating with an item, 13-14
  connection, 13-3
  creating, 1-16
  creating elements with, 10-1
  creating hierarchical designs for repeated use, 9-30
  custom, 13-4
  fixed, 13-14
  flattening hierarchical designs before generating, 11-15
  layout or schematic only object, 13-5
  space, 13-2
  supplied, 13-4
  supplied AEL macros, 13-1
  supplied fixed, 13-1
  synchronized, 13-14
  viewing, 9-30
Attach Component Palette command, 1-9
B
balloon help
  changing timing of display, 1-5
  described, 1-5
  turning on/off, 1-33
Bill of Materials command, 3-56
  generating for RF PCB designs, 12-24
bitmap size, changing, 1-33
Boolean logical commands
  AND, 11-34
  DIFF, 11-32
  OR, 11-34
  XOR, 11-35
Break command, 11-6
Break command (Edit > Modify), 6-31
Break Connections command, 6-10
Bundle, 3-29
Bus Pins, 3-37
Buses, 3-29
buses
  ADS Ptolemy, 3-38
  checking connectivity, 3-39
C
Change Component Text Layer command, 6-12
Change Layer To command, 1-13
Check Representation command, 5-7, 11-23, 12-23
Checking Connectivity
  Layout, 11-19
  Schematic, 5-6
Circle command, 7-7
circles
  converting to simple polygons, 6-29
clearance
Index-2

creating, 11-35
Close All Designs command, 2-26
Close Design command (File menu), 2-25
Close View command (component library), 3-13
Close Window command (design windows), 1-12
Command Line command, 3-54
Component rotating, 1-15
Component History command, 3-15
Component Library command, 3-4
Component Palette, 1-8
detaching, 1-9
Component Palette command, 3-14
Component Properties command (component library), 3-13
Component Text Attributes command, 11-31
Component Text Attributes command (Edit > Component), 6-13
components
activating and deactivating, 6-1
browsing, 3-3
connecting, 3-26
connecting in layout, 11-19
connecting with wires in layout, 9-17
custom
creating, 1-16
deactivating and shorting, 6-2
defining parameters, 3-20
editing, 1-16
editing parameters, 6-5
file-based parameters, 3-52
hot keys, 3-16
inserting, 9-3
Instance Names, changing, 11-31
layout
creating custom, 1-16
library display, 3-8
locating by browsing, 3-3
locating by searching, 3-6
orientation of, 3-19
overlaid/overlapping, 11-24
parameters, displaying on schematic, 6-7
placing
at specific coordinates, 3-18, 9-3
in drawing area, 3-3
simultaneously in layouts and schematics, 9-24
rotating
after placing, 3-19
prior to placing, 3-19
searching, 3-6
text
editing attributes of existing, 6-13
moving, 6-12
text, editing, 11-31
connecting
components, 3-26
connections
breaking between layout and schematic, 9-29, 14-3
connectivity
checking, 11-23
creating with wires (in layout), 9-17
removing, 14-3
construction lines
placing, 9-3
custom layout components
for repeated use, 9-30
instances, 9-25
  symbols to represent designs, 9-30
Cross-Probing
  Layout, 11-23
Schematic, 5-7
custom artwork
  fixed, 13-7
  using AEL macro, 13-9
custom layout components
  creating, 1-16
Cut command, 6-18
Cut command (component library), 3-10
cycle select, 3-3

D
  Data Display Window, 1-19
  Data Files
    reading and writing, 1-20
date
  system
    annotating your designs with, 7-3
deactivate and short components, 6-2
defaults
  and import/export translators, 14-1
  layout, 9-1
    modifying, 1-13
    setting, 1-13
Delete All command (Edit menu), 2-25
Delete command, 6-1
Delete Design command, 2-25
Delete Project command, 2-8
Delete View command, 5-3
Deselect All command, 6-14
Deselect By Name command, 6-16
Deselect Window command, 6-16
deselecting a group, 6-16
deselecting by name, 6-15
design files
  creating, 2-18
  listing, 9-25
  managing, 2-18
  searching for, 9-31
design generation
  creating hierarchical designs, 9-27
Design Hierarchies command, 5-5
Design Parameters command, 4-6
Design Rule Checker. See DRC, 1-16
Design Synchronization
  Checking, 1-33
  design synchronization command, 12-1
  procedure, 12-1
design windows
  defined, 1-5
  opening, 1-6
  opening multiple, 1-7
Design/Parameters command, 9-27
designs
  copying, 2-24
  creating, 2-18
  deleting, 2-25
  hierarchical. See hierarchical designs
  importing/exporting, 2-14
  layout-driven, 12-19
  representation of, 9-30
  saving, 2-20
  saving/clearing all at once, 2-21
  Detach Component Palette command, 1-9
DIFF command, 11-33
Difference command (Edit > Merge), 11-4
differential coordinate readout, 1-14, 1-15
dimension lines
  drawing, 9-6
Disabling Layout Connectivity Features, 11-23
Drag and Move option, 6-22
dual placement mode, 12-18
Dual Representation command, 9-24

E
  Edge and Area Ports
    enhancements, 11-17
  Edge and Area ports
    designating, 9-8
    pins, 13-5
    Using Area Ports, 13-8
    Using Edge Ports, 13-8
    edge pin, 11-17
  Edit Component Parameters command, 6-6
  Edit in Place, 4-13
  Hints/Tips, 4-14
  Edit Path/Trace/Wire command, 9-16
  editing
    menus, 1-16
Electronic Notebook
Adding descriptions, 1-26
Adding External Images, 1-28
Adding pages, 1-26
Changing Image Capture Settings, 1-29
Deleting pages, 1-26
Reorganizing Pages, 1-28
Saving Changes, 1-30
Updating, 1-31
Viewing Existing, 1-30
Zipping the Files, 1-31
Electronic Notebook command, 1-24
End Command, 7-4
Entry Layer command, 7-2
Error Bell, 1-33
text, 11-14
errors
translation, 14-2
Example Project command, 2-8
text
file-based parameters, 3-52
filename
extensions
design filenames, 2-18
template filenames, 2-21
filenames
restrictions, 1-20
files
See designs, 2-18
selection, changing, 11-1
Fix Component Position command, 12-18
Flatten command, 11-15
Flatten Hierarchy command, 9-29
Adding pages
Fixed artwork, 13-14
Flatten command, 11-15
Flatten Hierarchy command, 9-29
flattening
components, 14-3
instances, 14-3
flipping components
effect on generated layout, 9-24
fonts. See text
Export command, 2-16
exporting
procedures described, 2-16
extensions
design filenames, 2-18
template filenames, 2-21
External Text Editor, 1-34
Finding, 2-9
Exit Advanced Design System command, 1-34
Exiting ADS, 1-34
Exiting ADS, 1-34
Explode command, 11-5
Explode command (Edit > Modify), 6-32
Export command, 2-16
exporting
procedure described, 2-16
extensions
design filenames, 2-18
template filenames, 2-21
G
Gaps
in layouts, unintentional, 9-17
generate artwork, 14-3
generating
artwork
and Flatten command, 9-29
Global Node command, 3-28
Graphical Cell Compiler, 1-16
Greeting Dialog, 1-3
Grid/Snap command, 8-6
Grid/Snap command, 8-6
display
setting spacing, 8-6
forcing objects onto, 11-15
snap
setting spacing, 8-6
Group Edit Parameter Value command, 6-8
Help
balloon, described, 1-5
Hierarchical designs
advantages of, 9-25
and parameters, 9-25
and schematic considerations, 9-26
creating, 4-1, 9-25, 9-28
for repeated use, 9-30
parametric subnetworks, 9-26
creating parametric subnetworks, 4-1, 4-3
editing, 11-15
flattening, 9-29, 11-15
flattening before generating final artwork for, 11-15
matching, 9-26
parametric subnetwork, defined, 4-3
via design generation, 9-27
viewing detailed information of, 5-5
viewing hierarchy of, 9-29
hierarchies
flattening, 14-3
of translated layouts, 14-2
removing, 14-3
smashing, 14-3
Hierarchy command, 5-6, 9-29
Hierarchy dialog, 9-29
holes
from polygons, 11-33
I
Identify command, 5-4
Import command, 2-15, 14-2
importing
data files of various formats, 2-14
Include/Remove Projects command, 2-11
Info command, 5-4
inherited pins. See pins, power
insertion layers, 1-13
instances
flattening, 14-3
smashing, 14-3
Interconnects, 11-20
interconnects
nodal, 11-17
physical, 11-17
verification, 11-17
vertical, 11-17
Interconnects with Shapes, 9-17
items
creating layout-only objects, 10-1
creating simulation, 10-1
defining, 10-2
Iterated Ports, 3-37
J
Join command, 11-5
Join command (Edit > Modify), 6-31
junctions
schematic/layout concerns, 12-7
L
layers
creating
reverse images of, 14-5
for drawing, 8-6
insertion, 1-13
Layout command (Window menu), 1-7
layout connectivity
polygon based, 11-16
Layout Units, 3-2
Layout Window
create initial, 1-33
layouts
closing, 1-12
creating, 9-1
along with schematics, 9-24
directly, 9-3
from schematics, 9-24
defaults, 1-13
evironment, 9-1
exporting, 14-1, 14-3
hierarchical, 9-25
importing, 14-1, 14-2
opening, 1-12
preparing for translation, 14-3
removing hierarchy, 14-3
repeated use of, 9-25
translated
and hierarchies, 14-2
saving, 14-2
translated, opening and viewing, 14-2
translating, 14-6
Length Units
defined, 3-2
libraries
layout
reusable, 9-31
sharing between designs, 9-31
of commonly used items, 9-31
reusable designs, defining search path for, 9-31
search path, 9-31
Library command, 3-9
Library Properties command (component library), 3-13
licenses
for Design Rule Checker, 1-16
releasing, 1-16
viewing status of, 1-32
Line Thickness command, 7-8
listing
all design files, 9-25
logical commands
AND, 11-34
DIFF, 11-32
OR, 11-34
XOR command, 11-35

M
macros
creating artwork using, 13-9
playing back, 3-54
recording, 3-53
using, 3-53
Main window
overview, 1-3
manufacturing processes
compensating for, 14-5
Meander Trace command, 9-13
Meander Trace Simulation, 12-24
Measure command, 3-26
Measuring Distance and Angle, 3-26
Message window, 1-16
Mirror About X command, 6-27
Mirror About Y, 6-27
Mirror About Y command, 6-27
Miter command, 11-11
Miter command (Edit > Vertex), 6-34
mitered edges
from vertices, 11-11
models
editing, 1-16
Modify commands (Edit menu)
Break, 6-31
Convert To Polygon, 6-30
Explode, 6-32
Force To Grid, 6-39
Join, 6-31
Set Origin, 8-10
Move & Disconnect command (Edit >
Move), 6-24
Move command, vertex, 11-10
Move commands (Edit menu)
Move & Disconnect, 6-24
Move Edge, 6-35
Move Relative, 6-23
Move To Layer, 6-24
Move Using Reference, 6-23
Move Wire Endpoint, 3-27
Move Component Text command, 6-12
Move Edge command, 11-30
Move Edge command (Edit > Move), 6-35
Move Relative command (Edit > Move),
6-23
Move To Layer command (Edit > Move),
6-24
Move Using Reference command, 6-23
Move Wire Endpoint command, 3-27
moving
a vertex, 6-32
component text, 6-12
components and shapes, 6-22
shortcut using mouse, 6-22
N
Name Node command, see Wire/ Pin
Label, 3-29
naming conventions, 1-20
netlist
creating a, 3-55
networks
creating parametric. See hierarchical
designs
storage of, 9-31
New command
Schematic/Layout window, 2-18
New Layout command (Window menu),
1-6
New Project command
Main window, 2-1
New Schematic command (Window
menu), 1-6
Nodal Interconnect, 11-20
nodal interconnect, 11-17
nodal mismatches, 11-24
nodes
identifying as output for dataset, 3-29
Nonlinear Models, 3-51
notebook, electronic, 1-24
O
objects
moving, 11-14
scaling, 11-8
on-screen text editor, 6-37
Open command
  Schematic/Layout windows, 2-23
Open Design, 1-33
Open Project command
  Main window, 2-5
Open View command (component library), 3-13
Or command (Edit > Merge), 11-3
orientation of components, 3-19
Oversize command (scaling), 6-36, 11-8
P
palettes
  defined, 3-14
  detaching from window, 1-9
  re-attaching to the window, 1-9
  selecting items from, 3-14
  using and changing component, 1-8
Pan View command, 5-2
parameter editing, 6-3
  group with common parameters, 6-8
  on the screen, 6-4
  through dialog box, 6-5
parameterized designs, 9-26
parameters
  displaying on schematic, 6-7
  editing component, 6-5
  file-based, 3-52
Parameters command (File menu), 4-9
parametric
  subnetwork, see hierarchical designs
parts list
  generating for RF PCB designs, 12-24
Parts List command, 3-57
Paste command, 6-18
Paste command (component library), 3-10
paths
  changing attributes of existing, 11-29
  converting from traces, 11-29
  converting to traces, 11-29
  described, 9-15
  inserting, 9-15
PDE (Project Design Environment), 1-3
physical connectivity engine, 11-16
  usage notes, 11-18
physical designs, compiling, 1-16
Physical Interconnect, 11-20
physical interconnect, 11-17
pins, 9-4
  adding to a symbol, 8-9
  connected
    identifying, 9-4
  defining characteristics of, 8-12
  identifying connected and unconnected, 9-4
  power, 8-9, 8-10
  symbol, 8-9
  unconnected
    identifying, 9-4
Place Components From Layout To Schem command, 12-16
Place Components From Schem To Layout command, 12-16
Place Unplaced Item command, 12-22
Playback Macro command, 3-54
Polygon command, 7-5
polygons
  connections, 9-17
  converting into holes, 11-33
  creating using the DIFF command, 11-32
  editing, 6-31
  layer binding, 9-17
  manipulating, 11-2
Polyline command, 7-5
polylines
  drawing, 9-5
  editing, 6-31
  manipulating, 11-2
Pop Out of Hierarchy command, 4-13
Pop Out of Item command, 9-30
pop-up menu, using as a shortcut, 1-6
ports
  adding to a design, 3-49
  positional coordinate readout, 1-14, 1-15
Power Pin command, 8-10
precision
  changing, 11-14
Preferences command
  Main window, 1-33
Preferences command (library browser), 3-11
Print Area command, 16-1
Print command, 9-29, 16-1
Print Setup command, 16-1
printing/plotting
   a scaled layout, 16-15
   adding a printer (UNIX), 16-3
   PC (overview), 16-12
   UNIX (overview), 16-2
process offsets
   adding, 14-4
Project Design Environment (PDE), 1-3
project directories
   archiving, 2-13
   copying, 2-6
   creating, 2-1
   deleting, 2-7
   described, 2-1
   opening, 2-4
   unarchiving, 2-13
Project Extension, 1-34
Project Listing, 1-33
Project Listing command, 2-5
Properties command, 8-11
Properties command, see Momentum documentation
Push Into Edit Command, 4-13
Push Into Hierarchy command, 4-13
Push Into Item command, 9-30

R
Rectangle command, 7-4
Redraw View command, 5-3
Release Layout License command, 1-16
Remove Node Name command, 3-29
Reports command, 3-56
Reset/Update command (component library), 3-13
Restore Last View command, 5-3
Restore Status command, 1-3
Restore View command, 5-3
reverse images
   creating, 14-5
Revert to Saved Design command, 2-21
RF PCB designs
   automatic design synchronization, 12-22
   considerations, 12-20
   creating the board, system setup, 12-21
   exporting the PCB layout, 12-24
   fixing part placement and back annotation, 12-23
   generating a report, 12-24
   interactive layout, manual layout, 12-21
   interactive placement, 12-22
   layout vs. schematic nodal mismatch, 12-23
   part and library creation, 12-25
   trace simulation, 12-24
   Rotate command, 3-19
   rotating
      components
         after placing, 3-19
         prior to placing, 3-19
   rotating components
      effect on generated layout, 9-24
   Rotation Increment (angle) option, 3-19, 6-25

S
Save All Designs command, 2-22
Save As command
   design windows, 2-21
Save As Template command, 2-21
Save command
   design windows, 2-20
Save Project State, 2-6
Save Project State on Exit, 1-33
Save View As command (component library), 3-13
Save View command, 5-3
Scale command, 6-36, 11-8
   scale factors, 3-21
   scaling, 11-8
      objects
         using a scaling factor, 6-36
         using design units, 6-36
Schematic
   command (Window menu), 1-7
   window, overview of, 1-11
schematic
   symbols, see symbols
Schematic Window
   create initial, 1-33
Schematic Wizard, 1-6, 1-7, 2-4, 2-19
screen, refresh, 5-3
search paths
   defining for libraries of reusable designs, 9-31
   library, 9-31
   modifying, 8-18, 9-31
Search/Replace Reference command, 6-11
searching for components, 3-6
Select All command, 6-14
Select By Name command, 6-15
selecting a group using a selection window, 6-16 by name, 6-15
design, 1-2
Set Component Orientation command (UP, DOWN, LEFT, RIGHT), 3-19
Set Origin command, 8-10, 11-14
shapes copying to new layers, 14-4
drawing, 9-1, 9-4, 9-5
by entering coordinates, 9-6
drawing using specific coordinates, 7-8
editing, 1-16, 6-29, 11-1, 11-2
inserting in a layout, 1-13
merging, 9-4, 14-5
moving to a different layer, 11-12
resizing, 14-5
selecting, 11-1
stretching, 9-4
stretching edges of, 11-7
terminating draw command, 9-5
shorting components, 6-2
Show All Files command, 1-4
Show Connected command, 12-23
Show Equivalent Component command, 12-2
Show Equivalent Item command, 12-23
Show Fixed Components command, 12-18
Show Unplaced Items command, 12-23
simulation models defining design characteristics, 10-3
defining parameters, 10-7
described, 10-5
Simulation/Synthesis Messages information panels, 1-17
SIMULATOR_AEL, 9-31
smash instances, 4-3
snap spacing setting, 8-6
snapping to pins, 11-19
Squeeze Transmission Line Keeping Length command, 11-27
Start Recording Macro command, 3-53
Status window, 1-16
Status/Summary information panel, 1-17
Step And Repeat command, 6-20
steps schematic/layout concerns, 12-8
Stop Recording Macro command, 3-53
Stretch command, 11-7
Sub-Library command, 3-9
subnetworks assigning symbols to, 9-30
creating, 4-1
location of, 9-31
parametric, 4-3
See hierarchical designs Substrates, 3-50
Swap Components command, 6-10
Symbol Pin command, 8-9
symbols generating, 8-4
preparing to draw custom, 8-6
to represent designs, 9-30
usage, 8-1
synchronized artwork, 13-14
synchronizing designs, 12-1

T
Tap Transmission Line command, 11-26
tapers schematic/layout concerns, 12-8
tees schematic/layout concerns, 12-7
templates and transmission lines, 11-26
saving, 2-20
text adding to a design, 7-2
adding to designs, 9-18
attributes editing existing, 6-37
changing attributes of, 9-19
component, changing attributes of, 11-31
cutting and pasting, 7-2
editing, 9-19, 11-14
moving to a different layer, 11-12
on-screen editing, 6-37
Text command (Edit > Text), 6-38
Text command (Insert > Text), 7-2
text editors, launching from ADS, 17-1
time
system, annotating your designs with, 7-3
To Arc command, 11-10
To Arc command (Edit > Vertex), 6-33
toolbars
moving, 1-10
traces
changing attributes of existing, 11-29
converting
   explicitly, 9-11
to paths, 11-29
generating from paths, 11-29
generating from wires, 11-30
described, 9-8
meandering, 9-13
simulating as transmission lines, 9-12
to represent electrical connectivity, 9-4
translating
layouts, 14-6
translation errors, 14-2
transmission lines
   converting traces to explicitly, 9-11
   editing, 11-24
   splitting, 11-24
   stretching, 11-26
tapping and replacing with a tee, 11-26

U
Unarchive Project command, 2-13, 2-14
Undo Vertex command, 7-6, 9-6
units, 3-21
   and changing the design, 11-14
   Length, defined, 3-2
Units/Scale, 3-2

V
variables
   annotating your designs with, 7-3
   system
      annotating your designs with, 7-3
Variables command, 12-3
vertex
   adding, 6-32
   converting to a mitered edge, 6-34
   converting to an arc, 6-33
deleting, 6-33
editing, 6-32
   moving, 6-32
Vertex commands (Edit menu)
   Add, 6-32
   Miter, 6-34
   To Arc, 6-33
vertex points
deleting, 9-4
moving, 9-4
vertical interconnects, 11-17
vertices
   adding
to polygons, 11-9
to polylines, 11-9
converting
to a mitered edge, 11-11
to arcs, 11-10
deleting, 9-6, 11-9, 11-10
editing, 11-9
manipulating, 11-9
moving, 11-9, 11-10
points
deleting, 9-4
moving, 9-4
selecting, 11-9
specifying for editing, 6-17
Vertices filter
   using for editing shapes, 6-17
View All command, 5-2
viewing
   error messages, 1-18
   simulation status, 1-18

W
Warning Bell, 1-33
windows
   design
defined, 1-5
   opening multiple, 1-7
layout, 1-12
   moving the center point of, 5-2
   opening and closing, 1-6
   program, overview of, 1-3
   repositioning design to view all, 5-2
schematic, 1-11
screen refresh, 5-3
Wire command, 3-27
wire thickness, setting, 1-34
Wire/Pin Label command, 3-29
wires
  breaking connections, 6-10
  changing attributes of existing (layout), 11-29
  connecting components with, 3-27
  connecting components with in layout, 9-17
  converting to traces, 11-30
  in layout, 11-24
  inserting in layout, 9-18
  stretching, 11-30
  tips for working with, 3-27

Z
  Zoom Area command, 5-2
  Zoom By Factor command, 5-1
  Zoom In Point command, 5-1
  Zoom Out Point command, 5-1