Notice

The information contained in this document is subject to change without notice.

Agilent Technologies makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Agilent Technologies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Warranty

A copy of the specific warranty terms that apply to this software product is available upon request from your Agilent Technologies representative.

Restricted Rights Legend

Use, duplication or disclosure by the U. S. Government is subject to restrictions as set forth in subparagraph (c) (1) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 for DoD agencies, and subparagraphs (c) (1) and (c) (2) of the Commercial Computer Software Restricted Rights clause at FAR 52.227-19 for other agencies.

Agilent Technologies
395 Page Mill Road
Palo Alto, CA 94304 U.S.A.

Copyright © 1998-2004, Agilent Technologies. All Rights Reserved.

Acknowledgments

Mentor Graphics is a trademark of Mentor Graphics Corporation in the U.S. and other countries.

Microsoft®, Windows®, MS Windows®, Windows NT®, and MS-DOS® are U.S. registered trademarks of Microsoft Corporation.

Pentium® is a U.S. registered trademark of Intel Corporation.

PostScript® and Acrobat® are trademarks of Adobe Systems Incorporated.

UNIX® is a registered trademark of the Open Group.

Java™ is a U.S. trademark of Sun Microsystems, Inc.
Contents

1 Momentum Basics
   Momentum Major Benefits ................................................................. 1-1
   Momentum Major Features .............................................................. 1-1
   Momentum Overview ........................................................................ 1-1
   About the Simulation Modes ............................................................ 1-3
      Selecting the Correct Mode .......................................................... 1-4
      Using RF Design Environment Examples .................................... 1-5

2 The Momentum View
   Creating a Momentum Cell View ..................................................... 2-1

3 Substrate File Definitions
   Overlap Precedence .......................................................................... 3-2
   The Substrate Green Function Database .......................................... 3-3
   Tech File Format ............................................................................... 3-4
   General Tech File Example ............................................................... 3-5
   GaAs Tech File Example .................................................................. 3-6
   Si Tech File Example ....................................................................... 3-8

4 Simulation Frequencies
   Setting Up a Frequency Plan ............................................................. 4-1
      Sweep Types .................................................................................. 4-4
   About Adaptive Frequency Sampling .............................................. 4-4
      AFS Convergence .......................................................................... 4-5
      Setting Sample Points .................................................................. 4-6
      Viewing AFS S-parameters ........................................................... 4-7

5 Ports
   Cadence Pins and Momentum Ports ................................................ 5-1
   Definition of Momentum Ports ....................................................... 5-2
   Automatically Generating Ports ....................................................... 5-6
   Creating Advanced Port Types & Changing Port Properties ............. 5-6
      Reference pins ............................................................................... 5-7
      Calibration .................................................................................... 5-9

6 Substrate Mesh & Simulation Options
   Momentum Simulation Options .......................................................... 6-2
      Global Substrate and Mesh Options .............................................. 6-3
      Per-layer substrate and Mesh Options ......................................... 6-7

7 Momentum Simulation
   Frequency Plans ............................................................................... 7-1
Meshing of the Planar Signal Layer Patterns ..................................................... A-6
Loading and Solving of the MoM Interaction Matrix Equation ...................... A-7
Calibration and De-embedding of the S-parameters ......................................... A-7
Reduced Order Modeling by Adaptive Frequency Sampling ......................... A-8
Special Simulation Topics ......................................................................................... A-9
Simulating Metallization Loss ............................................................................. A-9
Simulating with Ports ............................................................................................ A-10
   Momentum Current Feed Models/Port Types .................................................... A-10
   Typical Port Combinations ............................................................................... A-10
   Internal Ports ................................................................................................... A-11
Limitations and Considerations ........................................................................... A-12
   Comparing the Microwave and RF Simulation Modes ................................... A-13
   Matching the Simulation Mode to Circuit Characteristics ................................ A-13
   Higher-order Modes and High Frequency Limitation ....................................... A-15
   Surface Wave Modes ....................................................................................... A-15
   Via Structures and Metallization Thickness Limitation .................................... A-15
   Via Structures and Substrate Thickness Limitation ......................................... A-16
   CPU Time and Memory Requirements .......................................................... A-16
References ............................................................................................................... A-17

B Customization
   Public Procedures for Customization ............................................................... B-1
   Public Variables for Customization ................................................................. B-1

Index
Chapter 1: Momentum Basics

Momentum gives you the simulation tools to evaluate and design modern communications systems products. Momentum is an electromagnetic simulator that computes S-parameters for general planar circuits, including microstrip, stripline, and other topologies.

Momentum Visualization is an option that gives users a 3-dimensional perspective of simulation results, enabling you to view and animate current flow in conductors.

Momentum Major Benefits

Momentum enables you to:

- Characterize the electrical behavior of components (spirals) and interconnect structures
- Design components and interconnect structures
- Determine coupling effects
- Design critical components and paths
- Visualize current flow

Momentum Major Features

- An electromagnetic simulator based on the Method of Moments
- Adaptive frequency sampling for fast, accurate, simulation results
- Comprehensive data display tools for viewing results
- Equation and expression capability for performing calculations on simulated data

Momentum Overview

Momentum commands are available from the Virtuoso window. The following steps describe a typical process for creating and simulating a design with Momentum:

1. **Create a Momentum cell view with the structure that you want to simulate.** The Momentum simulations can only be performed on the layout as defined in a separate Momentum layout cell view. It is possible to define this layout in different ways:
   - Start with a new Virtuoso window, change the view to a *momentum* view and draw the layout to be simulated in this window.
Momentum Basics

• Create a new cell from an existing Virtuoso layout. To do this, select **Tools > Momentum**. This activates the **Momentum-Virtuoso** menu at the top of the layout window. Select the layout structures you want to simulate (if you select none the whole layout will be selected). Underneath the **Momentum-Virtuoso** menu, select the **Make Momentum Cell...** menu. This brings up the **Make Momentum Cell** dialog box. Select a **Momentum Cell Name** and click **OK**. This creates a new cell from the momentum view layout.

![Make Momentum Cell dialog box](image)

2. **Setup the substrate definition.** The definition of the substrate layer stack is done via a Momentum specific substrate file. These files can be referenced directly, by selecting a specific substrate file or by including a substrate file in the Cadence tech file. For more information, refer to Chapter 3, Substrate File Definitions.

3. **Setup frequency range for simulation.** Specify the frequency range that needs to be analyzed by Momentum by either specifying the start and stop frequencies of an adaptive sweep, or by specifying a specific sweep plan for the frequency simulations. For more information, refer to Chapter 4, Simulation Frequencies.

4. **Define the Momentum ports.** Ports need to be added or defined to the Momentum layout. These are the connection points for the part of the circuit that will be simulated with Momentum. The Momentum S-parameter simulation results are defined with respect to these ports.

   First, one or more Cadence pins need to be defined as connection points to the layout. This should be done using the standard Virtuosos **Create > pin** command.

   Second, these pins are used to define the Momentum ports, which are terminations with multiple connection points for the positive and negative reference pins of the termination. This action is done via the Ports dialogs in the Momentum-Virtuoso simulation dialog. For more information, refer to Chapter 5, Ports.

5. **Set the simulation options.** All the Momentum simulation options can be accessed from **Simulation > Options**. This includes mesh options, as well as the choice between the Momentum mode: Momentum Microwave or Momentum RF. You can select the mode based on your design goals. Use **Momentum Microwave** mode for designs requiring full-wave electromagnetic simulations that include microwave radiation effects. Use **Momentum RF** mode for designs that are electrically small (smaller than half the wavelength...
at the highest frequency), and do not radiate. For more information comparing the Momentum and Momentum RF modes, see “About the Simulation Modes” on page 1-3.

6. **Simulate the circuit.** The Momentum simulation process has three different steps, which by default are run automatically one after the other:
   
   • **Solve the substrate.** Momentum calculates the Green's functions that characterize the substrate for a specified frequency range. These calculations are stored in a database, and used later on in the simulation process. For more information, refer to “Substrate File Definitions” on page 3-1.
   
   • **Generate a circuit mesh.** A mesh is a pattern of rectangles, triangles and polygonal cells that is applied to a design in order to break down (discretize) the design into small cells. A mesh is required in order to simulate the design effectively. You can specify a variety of mesh parameters to customize the mesh to your design, or use default values and let Momentum generate an optimal mesh automatically. For more information, refer to “Substrate Mesh & Simulation Options” on page 6-1.
   
   • **Solve the circuit** by executing the specified frequency sweep. The simulation process uses the Green's functions computed for the substrate, plus the mesh pattern and the currents in the design are calculated. S-parameters are then computed based on the currents. If the Adaptive Frequency Sample sweep type is chosen, a fast, accurate simulation is generated, based on a rational fit model. For more information, refer to “Momentum Simulation” on page 7-1.

7. **View the results.** The data from a Momentum simulation is saved as S-parameters. Use the Data Display to view S-parameters. For more information, refer to “Viewing Results Using the Data Display” on page 8-1 and “Momentum Basics” on page 1-1.

8. **Create symbolic view** for using Momentum simulation results in the composer environment.

---

**About the Simulation Modes**

Momentum has two modes, the microwave mode, referred to as Momentum Microwave and the RF mode, referred to as Momentum RF. The RF mode is based on quasi-static electromagnetic functions enabling faster simulation of designs. At higher frequencies, as radiation effects increase, the accuracy of the Momentum RF models declines smoothly with increased frequency. Momentum RF addresses the need for faster simulations down to DC, while conserving computer resources. Typical RF applications include RF components and circuits on chips, modules, and boards, as well as digital and analog RF interconnects and packages.
The microwave mode is based on full-wave electromagnetic functions enabling, taking into account the radiation effects. Both Momentum modes use the star-loop technology that provides low-frequency stability down to DC and a mesh-reduction algorithms that allows quick simulation of complex designs, and require less computer memory and CPU time. For a detailed comparison of the two simulation modes, see “Comparing the Microwave and RF Simulation Modes” on page A-13.

Selecting the Correct Mode

Deciding which mode to use depends on your application. Each mode has its advantages. In addition to specifically RF applications, Momentum RF can simulate microwave circuits. The following graph identifies which mode is best suited for various applications. Some applications can benefit from using either mode depending on the requirements. As your requirements change, you can quickly switch modes to simulate the same physical design. As an example, you may want to begin simulating microwave applications using Momentum RF for quick, initial design and optimization iterations, then switch to Momentum to include radiation effects for final design and optimization.

Momentum RF is usually the more efficient mode when a circuit

- is electrically small
- is geometrically complex
• does not radiate

For descriptions about electrically small and geometrically complex circuits, see “Matching the Simulation Mode to Circuit Characteristics” on page A-13.

Using RF Design Environment Examples

These examples demonstrate how RF Design Environment can be used to solve real-life problems.

Loading Examples

Use the following steps to load an RFDE example. Examples must be loaded in order to be opened.

1. Choose **Tools > RFDE Example > Load Example** in the Cadence Command Interpreter Window (CIW) to display the Load Example form.

2. Select the desired example from the list and click **OK** to load the example. The following items will be executed:
   • A copy of the example directory will be created and placed in ~/rfdeExamples.
   • Write permissions for the copy will be set.
   • The includePaths in the copy will be updated to point to the new location.
   • The necessary DEFINE lines will be appended to the ./cds.lib file.
   • A warning will be displayed in the CIW if an existing DEFINE uses a different path.

Advanced Loading Options

Use the following options to customize the loading of an RFDE example.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy all example files to directory:</td>
<td>Enables you to copy all example files to ~/rfdeExamples. This is the default method of loading a library.</td>
</tr>
<tr>
<td>~/rfdeExamples</td>
<td></td>
</tr>
<tr>
<td>Copy simulation files to directory:</td>
<td>Enables you to copy the simulation files to the specified directory. The directory name is read from your CDS environment.</td>
</tr>
<tr>
<td>~/simulation</td>
<td></td>
</tr>
<tr>
<td>Copy .artist_states to directory:</td>
<td>Enables you to copy the artist_state files to the specified directory. The directory name is read from your environment.</td>
</tr>
<tr>
<td>~/.artist_states</td>
<td></td>
</tr>
</tbody>
</table>
Opening Examples

Use the following steps to open an RFDE example that you have loaded.

1. Choose Tools > RFDE Example > Open Example in the Cadence Command Interpreter Window (CIW) to display the Open Example form.

2. Select the desired example from the list and click OK to open:
   - A schematic for this cell in read-only mode.
   - A simulation window for this schematic.
   - The simulation set-up in the simulation window.
     If the simulation window for this schematic is already open, its set-up information is overwritten.
   - The data display for this cell.

Unloading Examples

Use the following steps to unload an RFDE example that you have loaded.

1. Choose Tools > RFDE Example > Unload Example in the Cadence Command Interpreter Window (CIW) to display the Unload Example form.

2. Select the desired example from the list and click OK to unload the example.
   - If there are any windows open that use the example's library, you are notified and the unload operation is terminated.
   - The main library used by the example is removed from the library list. Note that this step modifies the cds.lib file.
   - The local copy of the example is deleted if you selected the Delete local copies of example files (if any) option.
Chapter 2: The Momentum View

Momentum operates directly from the Cadence Virtuoso environment. To access Momentum specific windows, you need to create a “momentum” view of the layout that you want to simulate. All the layout objects defined in the Momentum cell view are on layers mapped in the substrate definition, and are simulated by Momentum. For more information on substrate definitions refer to Chapter 3, Substrate File Definitions.

Creating a Momentum Cell View

A Momentum cell view can be generated in several ways. After opening a new cell view, you can access the Momentum menus that control the simulation by selecting Tools > Momentum.

• You can create a new Momentum view by manually creating a new view of an existing layout cell, (e.g., by saving the design with this new view). The name of the view should be “momentum”.

• From an existing layout view, a new Momentum view can be created automatically by activating the Momentum menu using Tools > Momentum and
The Momentum View

then selecting Momentum-Virtuoso > Make Momentum Cell. If nothing in the layout is selected, all layout objects will be copied in a new Momentum cell. If you have selected layout objects (using any selection mechanism in layout), only the selected layout objects are copied to the new Momentum cell. This command also automatically opens the new Momentum cell view with its associated Momentum simulation dialog.

**Note:** If a cell is opened in the “layout” view, the Make Momentum Cell menu item is visible under the Momentum-Virtuoso menu. If the cell is opened under the “momentum” view, the main Momentum simulation dialog is opened and a number of short cut menu items are accessible from under the top Momentum-Virtuoso menu (Make Momentum Cell..., Simulation..., Clear Mesh). In both cases a What's New menu item provides access to information on what is new in Momentum Virtuoso.
Chapter 3: Substrate File Definitions

Momentum uses an ASCII text file for the description of the substrate definition, which includes the layer stack definition with the definition of the dielectric layers, the layer map definition where the layout layers are mapped to the substrate definition as well as the specification of the losses in the metallization.

The ASCII substrate file (with extension ‘.tch’) is Momentum specific.

The following dialog allows to specify the location of a Momentum substrate file:

![Setup Substrate dialog](image)

The file can either be directly referenced by specifying the location of the file in the top window. You can Browse, Edit or Create a new substrate file using your default text editor.

Alternatively, you can set up your Cadence Tech file with a variable that points to a valid Momentum substrate file. This variable should be setup in the “control” class of the tech file either manually or using the CIW.

- In the CIW select **Tools > Technology File Master**.
- Choose **Edit Rules**.
- Change Technology Library to your preference.
- In the classes pane, double click **Control**.
- This opens a dialog that can be used to specify control variables.
- Add the following var:
Substrate File Definitions

Name: rfdeMomentumSubstrateFileLocation
Value Type: ILList
Value: "~/momInt/Subst.tch" (Note: include quotes)

Once you setup your techfile with a reference to the subst file, the application will use this reference unless you over-ride the reference with the alternate file checkbox mechanism.

Note The asci substrate file used in RFDE and a momentum project in ADS (<adsProject>/mom_dsn/layout/proj.tch file) are identical, if the layer numbers are equal. For more information on exporting an ADS substrate file for use in RFDE, refer to Appendix C, Exporting the Momentum Substrate, in the ADS Momentum manual.

Overlap Precedence

Overlap precedence, which is defined in the .tch file, specifies which layout layer has precedence over another if two or more layout layers are assigned to the same metallization layer and objects on the layers overlap. Precedence is used by the mesh maker so that objects on the layer with the greatest precedence number are meshed and any overlap with objects on layers with lesser numbers is logically subtracted from the circuit. If you do not set the precedence, and there are overlapping objects, a mesh will automatically and arbitrarily be created, with no errors reported. Resistive layers generated from schematics are automatically set to the highest precedence.

In some cases, you may be designing with an intentional overlap because of manufacturing layout guidelines. In this case, assign a precedence number to the layout layers that overlap with precedence order in reverse numerical order (largest to smallest). The system will draw the boundary at the edge of the higher numbered layer without returning an error.

3-2 Overlap Precedence
Note: Precedence affects only how the mesh is created, it does not affect or alter the layout layers in your design. Precedence shapes on the mask with the highest precedence are kept when merging overlap with shapes on a mask with a lower precedence if they are on the same substrate level.

The Substrate Green Function Database

When it is necessary to calculate or access the substrate green function database file (sgfdb file) Momentum looks for it in the 3 locations listed below, in the order shown:

• the supplied directory
• the site directory
• the user directory

If the sgfdb file is present in one of these directories and it covers the requested frequency range, Momentum uses it. If it is not, Momentum attempts to calculate a new substrate green function database file and place it in the substrates subdirectory of the site directory (if the site directory is not write protected). If the site directory is write protected and the user directory is not, it stores the database in the substrates subdirectory of the user directory. If both directories are write protected Momentum exits and displays an error.

To set the supplied-site-user directories Momentum provides the adsMom environment variables:

suppliedGFdatabase (default = {$HPEESOF_DIR}/momentum/lib)
siteGFdatabase (default = {$HOME})
userGFdatabase (default = .)

To modify these values, add for instance the following to the local .cdsenv file

<table>
<thead>
<tr>
<th>adsMom.envOpts</th>
<th>siteGFdatabase</th>
<th>string</th>
<th>&quot;{$HPEESOF_DIR}/custom/momentum/lib&quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td>adsMom.envOpts</td>
<td>userGFdatabase</td>
<td>string</td>
<td>&quot;{HOME}&quot;</td>
</tr>
</tbody>
</table>

Note: The directory referenced by the variables must be a valid directory. The database generation program creates the substrates directory in it when this one does not exist.
Substrate File Definitions

Tech File Format

The formal definitions:
'\texttt{a|b}' Must select one (a or b).
  [ ] Optional.
  ... May repeat.
  () Group
  <x> User defined value.

\texttt{UNITS}
DISTANCE = `UM | MM | CM | METRE | UINCH | MIL | INCH'
CONDUCTIVITY = 'SIEMENS/M | SIEMENS/UM'
[RESISTIVITY = OHM.CM]
[RESISTANCE = OHM/SQ]
[PERMITTIVITY = RELATIVETOACUUM]
[PERMEABILITY = RELATIVETOACUUM]
END\_UNITS

BEGIN\_STACK

\texttt{TOP}  \ (OPEN PERMITTIVITY = <permittivity>
\ [ \ 'LOSSTANGENT = <losstangent>
\ | RESISTIVITY = <resistivity>
\ [ \ IMAG\_PERMITTIVITY = \texttt{e}j\_permittivity']
\ [ \ PERMEABILITY = <permeability>
\ ]
\ [ \ IMAG\_PERMEABILITY = \texttt{e}j\_permeability']
\ ]
\ | (COVERED [ RESISTANCE = <resistance>
\ [ \ IMAG\_RESISTANCE = \texttt{e}j\_resistance]
\ ]
\ | CONDUCTIVITY = <conductivity>
\ [ \ IMAG\_CONDUCTIVITY = \texttt{e}j\_conductivity]
\ ]
\ | THICKNESS = <thickness>
\ ]
\ )

\texttt{METAL}  \ 'ABSENT
| GROUND
| STRIP\_MASK = <maskNr1> \ [ <maskNrX> ... ]
| 'RESISTANCE = <resistance>
\ [ \ IMAG\_RESISTANCE = \texttt{e}j\_resistance]
\ | CONDUCTIVITY = <conductivity>
\ [ \ IMAG\_CONDUCTIVITY = \texttt{e}j\_conductivity]
\ | THICKNESS = <thickness>
\ ]

\texttt{DIELECTRIC} [ VIA\_MASK = <maskNr1> \ [ <maskNrX> ... ]]
HEIGHT = <height>
PERMITTIVITY = <permittivity>
\ [ \ 'LOSSTANGENT = <losstangent>
\ [ \ RESISTIVITY = <resistivity>
\ [ \ IMAG\_PERMITTIVITY = \texttt{e}j\_permittivity']
\ [ \ PERMEABILITY = <permeability>
\ [ \ IMAG\_PERMEABILITY = \texttt{e}j\_permeability']
\ ]
\ ]

...
[IMAG_RESISTANCE = <j.resistance>]

[CONDUCTIVITY = <conductivity>]

[IMAG_CONDUCTIVITY = <j.conductivity>]

[THICKNESS = <thickness>]

END_STACK

BEGIN_MASK

[MASK <maskNr> [PRECEDENCE = <precedence>]

[RESISTANCE = <resistance>]

[IMAG_RESISTANCE = <j.resistance>]

[CONDUCTIVITY = <conductivity>]

[IMAG_CONDUCTIVITY = <j.conductivity>]

[THICKNESS = <thickness>]

...

END_MASK]

General Tech File Example

UNITS

DISTANCE = M
RESISTANCE = OHM/SQ
CONDUCTIVITY = SIEMENS/M
RESISTIVITY = OHM.CM
PERMEABILITY = RELATIVETOVAUCUM
PERMITTIVITY = RELATIVETOVAUCUM
END_UNITS

BEGIN_STACK

TOP OPEN PERMITTIVITY = 1 PERMEABILITY = 1
METAL STRIP_MASK = [8]
DIELECTRIC VIA_MASK = [7] HEIGHT = 1.0e-06 PERMITTIVITY = 3.9 PERMEABILITY = 1
METAL STRIP_MASK = [6]
DIELECTRIC VIA_MASK = [5] HEIGHT = 1.55e-06 PERMITTIVITY = 3.9 PERMEABILITY = 1
METAL STRIP_MASK = [4]
DIELECTRIC HEIGHT = 1.7e-06 PERMITTIVITY = 3.9 PERMEABILITY = 1
METAL ABSENT
DIELECTRIC HEIGHT = 0.0006 PERMITTIVITY = 11.9 PERMEABILITY = 1 RESISTIVITY = 12.5
BOTTOM COVERED RESISTANCE = 0
END_STACK

BEGIN_MASK

MASK 4 PRECEDENCE = 1 CONDUCTIVITY = 2.7e+07 THICKNESS = 2e-06
MASK 6 PRECEDENCE = 0 CONDUCTIVITY = 2.7e+07 THICKNESS = 1e-06
MASK 8 PRECEDENCE = 0 CONDUCTIVITY = 2.7e+07 THICKNESS = 1e-06
MASK 5 PRECEDENCE = 0 RESISTANCE = 0
MASK 7 PRECEDENCE = 0 RESISTANCE = 0
END_MASK
Substrate File Definitions

GaAs Tech File Example

UNITS
DISTANCE = M
RESISTANCE = OHM/SQ
CONDUCTIVITY = SIEMENS/M
RESISTIVITY = OHM.CM
PERMEABILITY = RELATIVETOVACUUM
PERMITTIVITY = RELATIVETOVACUUM
END_UNITS
BEGIN_STACK
TOP OPEN PERMITTIVITY = 1 PERMEABILITY = 1
METAL ABSENT
DIELECTRIC HEIGHT = 1e-07 PERMITTIVITY = 5 PERMEABILITY = 1
METAL STRIP_MASK = {1}
DIELECTRIC VIA_MASK = {2} HEIGHT = 0.0001 PERMITTIVITY = 12.9 LOSSTANGENT = 0.001 PERMEABILITY = 1
BOTTOM COVERED RESISTANCE = 0
END_STACK
BEGIN_MASK
MASK 1 PRECEDENCE = 0 RESISTANCE = 0 THICKNESS = 2e-07
MASK 2 PRECEDENCE = 0 CONDUCTIVITY = 3e+07 THICKNESS = 1e-07
END_MASK
Si Tech File Example

UNITS
DISTANCE = M
RESISTANCE = OHM/SQ
CONDUCTIVITY = SIEMENS/M
RESISTIVITY = OHM.CM
PERMEABILITY = RELATIVETOVACUUM
PERMITTIVITY = RELATIVETOVACUUM
END_UNITS
BEGIN_STACK
TOP OPEN PERMITTIVITY = 1 PERMEABILITY = 1
METAL STRIP_MASK = {1}
DIELECTRIC HEIGHT = 2e-06 PERMITTIVITY = 3.9 PERMEABILITY = 1
METAL STRIP_MASK = {2}
DIELECTRIC HEIGHT = 3e-06 PERMITTIVITY = 3.9 PERMEABILITY = 1
METAL ABSENT
BOTTOM OPEN PERMITTIVITY = 11.9 RESISTIVITY = 10 PERMEABILITY = 1
END_STACK
BEGIN_MASK
MASK 1 PRECEDENCE = 1 RESISTANCE = 0.03
MASK 2 PRECEDENCE = 0 RESISTANCE = 0.08
END_MASK
Chapter 4: Simulation Frequencies

Setting Up a Frequency Plan

Multiple frequency plans can be setup for a simulation. Each plan enables you to specify a solution to be found for either a single frequency point or over a specific frequency range. You can also select one of several sweep types for this plan. This collection of frequency plans will be run as a single simulation.

To set up a frequency plan select **Frequencies > Add...** from the Momentum-Virtuoso Main window.

![Simulation Frequencies Interface](image)
Simulation Frequencies

This brings up the Add Frequency Plan dialog shown in the following illustration.

![Add Frequency Plan](image)

This dialog box allows you to choose between a start and stop frequency range or center-span, sweep-type, step size or number of steps and the maximum samples limit. When applied, it adds a frequency plan to the frequency table and updates the application data. See “Sweep Types” on page 4-4.
Selecting a frequency plan in the Momentum-Virtuoso Main window enables several other options under Frequencies.

![Momentum-Virtuoso Main Window](image)

- **Edit...** provides the same dialog selections as **Add...**, enabling you to make adjustments to your plan.
- **Delete** brings up a dialog asking you to confirm the deletion. If confirmed, the highlighted frequency entry will be deleted from the table and the associated data to be deleted from the application state.
- **Enable** causes the highlighted frequencies in the frequency table to be enabled, and the associated data in the application state to be modified.
- **Disable** causes the highlighted frequencies in the frequency table to be disabled, and the associated data in the application state to be modified.
Simulation Frequencies

Sweep Types

There are four different sweep types:

- Adaptive
- Logarithmic
- Linear
- Single point

Adaptive is the preferred sweep type. It uses a fast, highly accurate method of comparing sampled S-parameter data points to a rational fitting model. The value entered in the Sample Points Limit field is the maximum number of samples used in an attempt to achieve convergence. The solutions from the final attempt will be saved. If convergence is achieved using fewer samples, the solutions are saved and the simulation will end. For more information about this sweep type, refer to “About Adaptive Frequency Sampling” on page 4-4. Only one adaptive sweep can be specified. When using an AFS sweep, an additional dataset is generated with the suffix “_a”. This dataset contains the smooth S-parameter results obtained with the rational fitting model.

Logarithmic simulates over a frequency range, selecting the frequency points to be simulated in logarithmic increments. Type the start and the stop frequencies in the Start and Stop fields, and select frequency units for each. Enter the number of frequency points to be simulated or the number of the Points/Decade.

Linear simulates over a frequency range, selecting the frequency points to be simulated in linear increments based on the step size or the number of steps you specify. Type the start and the stop frequencies in the Start and Stop fields, and select frequency units for each.

Single simulates at a single frequency point. Type the value in the Frequency field and select the units.

About Adaptive Frequency Sampling

Adaptive Frequency Sampling (AFS) is a method of comparing sampled S-parameter data points to a rational fitting model. In order to accurately represent the spectral response of the circuit, the AFS feature in Momentum takes a minimal number of frequency samples and then applies its algorithm to the sampled data. Wherever the S-parameters vary the most, samples are taken. When the fitting model and the sampled data converge, the AFS algorithm is then complete and the S-parameter data is written into the dataset. In this way, the maximum amount of information can be obtained from the minimum amount of sampling.
By using the AFS feature, you can greatly reduce the amount of time required to simulate circuits that have resonances or other sharp responses that are difficult to detect. Data that would have remained hidden using other types of analyses can now be obtained.

Even in the case of a low-pass filter, AFS can solve for the S-parameters faster and more accurately than discrete data sampling. For example, if you were measuring a 2 GHz low-pass filter, you would enable the AFS feature and then enter a start frequency of 500 MHz and a stop frequency of 4 GHz. AFS would then sample the two end points, construct the fitting model, and then sample points in between as needed. As this occurs, the model is automatically refined and appropriate sample points are taken until the model and the sampled data converge. When convergence is reached, both sampled data and the AFS data are written into two separate datasets and can be presented as S-parameter traces on a plot. If the max sample size is reached before converging, the partial results will be saved and can be reused by simulating the circuit again.

**Note**  AFS data must converge in order to be accurate. Be sure the data is converged by checking the message in the Momentum output log. If data is not converged, you will see inaccurate results.

**AFS Convergence**

Convergence is determined by how close the fitting model is to the sampled data. Convergence is achieved when the sampled points are accurate to -75 dB, and the overall accuracy is -60 dB.

When AFS is used, be sure that the sampled data has converged with the fitting model. This can be checked by the messages in the output log. If converged, the message will be that AFS is complete. If not converged, a warning will appear. Examples of such warning messages are:

- Maximum number of adaptive frequency samples reached!
- Fitting models not (completely) converged.

Consider:
- increasing maximum number of sample points.
- activating the reuse option.

If you encounter errors, decrease the frequency range of the frequency plan and increase the number of sample points. Theoretically, some circuits may require several dozen points to converge if they are electrically long. This is because the AFS program samples the data at about each 60 degree rotation, in the Smith chart of the S-parameter with the most phase variation.
Simulation Frequencies

**Note**  If your simulation does not converge, to assess the quality of the simulation you can view convergence results in the Data Display. For more information, refer to “Viewing Convergence Data” on page 7-5.

## Setting Sample Points

If you are using the Adaptive sweep type in a simulation, you may want to select specific sample points to be used in the AFS process. In general, this is not necessary (and is in fact, discouraged), but there may be instances where it is beneficial. An application where this may be beneficial is simulating a structure that has a distinct variation in response at some point over a frequency range, such as a resonant structure. To set up the simulation:

1. Select the Single sweep type, enter either the value of the resonant frequency or a value near it in the Frequency field, and add this to the frequency plan list.

2. Select the Adaptive sweep type, set up the plan, then add it to the list of frequency plans.

For this situation, the sample point aids the AFS process by identifying an area where there is clearly a variation in the response of the circuit.

Applying extra sample points may be necessary for visualization calculations.

It is not beneficial to attempt to add sample points for other purposes, such as attempting to force smoothing to occur at specific points, without taking into consideration the response at these points. For example:

1. Selecting the Linear sweep type, adding sample points spread linearly across the frequency range, and adding the frequency plan to the list.

2. Adding an Adaptive sweep type, selecting the same frequency range, and adding it to the list.

For this situation, the sample points from the linear simulation will be included in the adaptive simulation. This impedes the AFS process of selecting the optimal distribution of samples over the frequency range, and this can produce poor simulation results.

To remedy this situation, either run the Adaptive sweep plan first or make sure that the frequency ranges of the two plans do not overlap.
Viewing AFS S-parameters

When viewing the S-parameters in an AFS dataset, if you zoom in you may see small, unexpected spurious ripples or oscillations, with an amplitude less than 0.0002. The amplitude of these oscillations is always less than the AFS accuracy level, which is approximately -60 dB. Generally, these ripples will only appear if the dynamic behavior of the S-parameters is limited, for example, an S-parameter that is nearly 1 over the frequency range simulated. This is likely due to the rational fitting model have too many degrees of freedom and being too complex for this situation.
Simulation Frequencies
Chapter 5: Ports

Cadence Pins and Momentum Ports

In this section, the difference between a Cadence pin, the standard Virtuoso pin object with all its properties, and a Momentum port is explained.

In principle, pins are single-node connections to the circuit, meaning that they are a single connection point of the circuit with the rest of the circuitry, allowing for either an incoming or outgoing current. However, to make a true connection, you always need two connection points to the circuit, one for the incoming current and for the outgoing current associated with the signal.

A Momentum port is always defined as a terminal with a positive and a negative reference node. As a user you have the freedom to connect the positive and negative reference of the terminal to one or more Cadence pins.

For instance, in the figure below, one Momentum port is connected to two Cadence pins in the layout. One pin is its positive reference node and one pin is its negative reference node. This example shows how a port can be defined for a differential line.

Even though every Momentum port by definition has a positive and negative node, you do not always have to specify two or more Cadence pins for a Momentum port. When there is a groundplane defined in the substrate, you can have an implicit definition of the negative reference node, as indicated in the figure below.
In this case, only the positive reference of the Momentum port is connected to a Cadence pin, and it is assumed that the negative reference has an implicit connection to the groundplane in the substrate. If no groundplane is present, the implicit reference point is defined as the zero potential at infinity.

**Definition of Momentum Ports**

Momentum ports are created using the Momentum specific port dialogs:

- **Auto-generate** – creates standard ports from existing Cadence pin instances and lists them in the *Ports* section of the Simulation window.
- **Add...** – brings up the *Add Port* dialog box. Updates the application data when applied.
- **Edit...** – brings up a dialog box enabling you to edit the port highlighted in the *Ports* section of the Simulation window.
- **Delete** – deletes the highlighted port.
- **Synchronize with Layout** – synchronizes pin information with the layout, and modifies existing ports and calibration groups.
Prior to creating the Momentum ports, you need to define Cadence pins in the layout. To create the pins, you need to use the standard Virtuoso functionality (i.e., use **Create > Pin** from within the Virtuoso layout window).

Once a Momentum port is defined, its most relevant information – port number, port name, number of pins associated with the port, impedance (real and imaginary part), port type, calibration group number and reference offset – is shown in the main Momentum simulation dialog.
The type of a port or a pin can be:

- point
- edge
- mixed
- not defined (blank)

A pin’s type depends on how it is defined in the Virtuoso layout. A pin is defined as an edge pin if the Momentum location of the pin is at an edge of a shape in the layout. By default, the Momentum location coordinates are equal to the pin coordinates which are the center coordinates of the bounding box of the shape that defines the pin. The Momentum location coordinates can be overwritten by the user using the Edit Reference Pin dialog.

An example of an edge pin is given below:
An example of a point pin is shown in the figure below:

In the Momentum port dialogs, a list of the available pins defined in the Cadence layout is created when the Momentum application is launched. If a pin is added or altered after opening the port dialogs, the pin list in the ports dialog can be updated using **Port > Synchronize with Layout**.

**Note**  If a port’s pins are all point, edge, or undefined, its type is point, edge, or undefined. If the port’s pins have different types, then the type is mixed.
Automatically Generating Ports

For most applications, you will be able to use standard ports. These are ports with the most common properties. When using the Ports > Auto-generate menu, all the pins that are in the port dialog are used to define ports according to the implicit port definition. More specifically, one Momentum port is created for each of the pins in the layout, where the pin is connected to the positive reference of the port. The negative reference is defined implicitly. The port name will be the same as the name of the pin.

The Auto-generate menu allows you to quickly define the ports for your layout. The port definitions can be changed as needed using the advanced Momentum port dialogs.

The standard port properties are:

- uncalibrated
- real impedance is 50 Ohms, imaginary impedance is 0 Ohms
- no offset in reference planes

Creating Advanced Port Types & Changing Port Properties

Through the Ports > Add and Ports > Edit dialogs, the Momentum port properties can be set or modified. These menus can be used to create more advanced port types like differential ports or ground reference ports. They also allow changes to a port’s default properties like impedance and calibration.

The main ports dialog is shown below.

By default, only the port name and the impedance fields are visible in this dialog. Selecting the Show Advanced Port Options button will result in the following dialog:
Advanced Port Options include reference pins, and fields needed for calibration.

Reference pins
A list of layout pins is displayed in the port dialog for viewing purposes only. The pin name, type (point, edge, mixed or nothing), pin group and status are displayed. The status field indicates whether the pin has already been used in a Momentum port definition. A pin can only be used in one Momentum port definition at a time. The pin list can be synchronized from the layout using the Synchronize with Layout button, which will refresh the pin list and alter any port or calibration group definitions when a pin is added or altered in the layout.
Note If the status of a layout pin is USED you will not be able to add it. You first have to make it free either by removing it from the Port Reference Pin List of the port to which it belongs or by deleting the port to which it belongs.

When a given pin is defined as a Momentum port’s positive or negative reference by using the Pos -> or Neg -> buttons, it appears in the list of Port Reference Pins. The polarity of the pin (positive or negative) is then indicated.

The Momentum location of the pin can be adjusted with the Edit Reference Pin command. The Momentum location is the point in the layout that Momentum will use to define the pin’s x:y location and group. If the Momentum location of a pin is on the edge of a metallization, the pin is defined as an edge pin, and can be used to define a calibrated port. If the Momentum location of a pin is inside a shape, its type is “point”. If the pin exists on several layers and has different types on those layers, its overall type is “mixed”. If the Momentum location of a pin is not inside a shape or on the edge of metallization, the pin’s type is not defined (blank).

The default value for the Momentum location is the center point of the bounding box used in the layout to define the pin. The Momentum location can be modified so that it coincides with the edge of the metallization. This modification forces the pin type to “edge”.

```
| Name       | port1       |
| Layer Name | MT          |
| Layer Number | 4           |
| Pin Coordinate | (6, 8.61.55) |
| Momentum Location | (6, 8.61.55) |
| Momentum Type | point       |
| Calibration Group |             |
```
**Note**  In Cadence it is possible to specify pins (symbolic pins) that are defined on more than one layer. Momentum cannot handle these pins and an error will be given when such a pin is encountered in the layout.

---

**Calibration**

**Note**  Only ports that are defined using edge pins can be calibrated. A port defined with multiple pins can only be calibrated if all the pins are edge pins and if all the edges of these pins are in the same plane (i.e., they are in the same calibration group). For more information on calibration refer to “Calibration and De-embedding of the S-parameters” on page A-7.

---

To activate calibration for a given port, check the **Calibration** toggle in the Advanced Port Options. When calibration is activated for a port, an offset can be specified. By default, the offset is '0' which means that the reference plane for the S-parameters calculated by Momentum coincides with the edge of the port. The offset can be edited in the **Edit Calibration Group** dialog, which is opened by selecting the **Edit** button.
A positive offset specification means that the reference plane is shifted inward to the structure. A negative offset specification means that the reference plane is shifted outward from the structure.

The offset is applied to every pin in the calibration group.

**Note** Multiple edge pins whose edges are defined in the same plane are grouped automatically into the same pin group. This is indicated by the group number in the pin list. For grouped pins that are calibrated, the calibration lines that are added will be treated simultaneously in the simulations.

**Note** If all of a port’s reference pins are in the same group, the port’s calibration group is equal to the pins’ group. Otherwise, the port’s calibration group is undefined. If all of the port’s pins belong to the same calibration group, a port can be placed in a new calibration group and all of its reference pins will use that new group’s offset.

**Adding a new calibration group**

There may be an occasion when you want to calibrate a port using a different offset than its reference pins’ offset (i.e. the reference pins are a subset of the pins in their calibration group). Such an occasion requires the port to use a different calibration group than its pins. To create a new calibration group, select the last choice in the Group field. The last choice represents a new, unused calibration group. Selecting the Edit button will open the New Calibration Group dialog, where you may set the group’s offset. A port may use its reference pins’ calibration group, a new

5-10 Creating Advanced Port Types & Changing Port Properties
calibration group, or any other calibration group containing pins in the same pin group as the port’s reference pins.
Chapter 6: Substrate Mesh & Simulation Options

The Momentum Simulation options can be set using the Simulation > Options dialog from the Momentum simulation dialog.

This dialog allows you to set:

- The Momentum Simulation options
- Global Substrate and Mesh Options
  These option settings are valid for all layers, except for those layers where specific option settings are specified
- Per-layer Substrate and Mesh Options
  Option settings specific for a layer.

If Per-layer options are set for a given layer, these settings have precedence over the global settings.

The options per-layer setting can only be set for layers defined in the Momentum substrate definition file (see “Substrate File Definitions” on page 3-1).

Top level menus:

- OK - accepts the changes made in this dialog and closes the dialog
- Cancel - cancels any changes made in the dialog since the last time the dialog was opened
- Defaults - resets all the fields to its default values.
- Apply - accepts the changes made in this dialog and keeps the dialog open
- Help - refers to the chapter on Simulation options.
Substrate Mesh & Simulation Options

Momentum Simulation Options

The following Momentum Simulation options can be set:

- **Momentum Simulation Mode**
  This allows switching between the RF and Microwave mode of Momentum. Default is RF. This default is obtained from the `adsMom.cdsenv` file, the value of the option named “EngineMode” is used. See “Momentum Basics” on page 1-1 for more details on the difference of these two simulation models.

- **Stop After Calculating**
  A choice between three settings can be made, Substrate, Mesh, and S-Parameters. The default is S-Parameters. This default is obtained from the `adsMom.cdsenv` file, the value of the option named “EngineType” is used.

- **Include TL Calculation**
  An “on” or “off” toggle. Default is “off”. This dialog field is editable only when the value for the option Momentum Simulation Mode is Microwave.

- **Re-use Results of the Last Simulation**
  This toggle (by default off) allows reusing frequency point simulation results from previous Momentum simulations for the same structure. It should be noted however that this should not be done if changes have been made to the substrate or layout.

- **Use Cell Name for Dataset Name**
If this toggle is activated (default is on), you can not specify the name of the dataset output file. The cell name is used.

- **DataSet name**
  This dialog field is editable only when the value for the option **Use Cell Name for Dataset Name** is <off>. It enables you to specify the name of the dataset output file.

**Global Substrate and Mesh Options**

![Global Substrate and Mesh Options](image)

The following Substrate items can be specified in the Global Substrate and Mesh Options menu:

- **3-D Metal Expansion**
  Conductors with finite thickness can be modeled in Momentum using the 3D metal expansion feature. This feature will automatically expand the mask of a conductor with finite thickness in the direction orthogonal to the layered medium, using the specified thickness of this conductor.
Substrate Mesh & Simulation Options

If "No" is specified, the metal is treated as a zero-thickness sheet in the simulation. The automated 3D expansion is activated by selecting either the 3D metal ‘up’ or ‘down’ expansion. In both cases, an extra dielectric layer is included in the internal Momentum substrate model. This is done for each metal layer that is expanded. The thickness values of the dielectric layers in between the metal layers are not changed, which will preserve the capacitance value between two conductors lying on top of each other in the substrates.

**Note** The thickness of the conductor is specified in the substrate definition (see substrate file format).

Simulations with automatic expansion require more simulation time and memory, but result in more accurate simulation results. Typically, when the width/height aspect ratio is bigger than a factor of 5, the effect of accounting for the finite thickness of the conductors will need to be allowed for in Momentum simulations.

The following figure illustrates the internal substrate model when using an “up” and “down” expansion for a conductor. In both cases, an extra dielectric layer is inserted (indicated with [new] in the figure), which in the case of an “up” expansion has the dielectric properties of the layer above the metal layer. In the case of a ‘down’ expansion, the new layer has the material properties of the layer below the metal layer.
Extra internal metallization layers are automatically added in Momentum to model the currents on all four sides of the finite thickness conductor.

The following Mesh items can be specified in the Global Substrate and Mesh Options menu:

- **Mesh Frequency**

  (Hz) A numeric value, the default is blank. This is the frequency at which the mesh is calculated. If no value is specified in the options dialog, the simulation
Substrate Mesh & Simulation Options

will use the highest frequency specified in the analysis set-up for Mesh Frequency otherwise the specified value will be used.

• Mesh Density

(cells/wavelength) A numeric value, the default is 0. This default is obtained from the adsMom .cdsenv file: the value of the option named CellsPerWavelength is used. The mesh generator will try to generate a mesh with at least CellsPerWavelength cells per wavelength at the Mesh frequency.

• Arc Resolution

(deg) A numeric value, the default is 45. If the value entered is greater than 45, the simulator will use a value of 45 for Arc Resolution during the analysis. The arc resolution will determine the length of the arc facets (in degrees) for line segment sequences recognized by the mesh generator as arcs, if replacing the original faceting with the new one does not introduce layout errors.

• TL Mesh

(cells/width) A numeric value, the default is blank. If a value is provided the mesh generator will try to place cellsPerWidth cells in the cross section of every shape it recognizes as a transmission line. If no value is defined, the mesher uses the cellsPerWavelength value to determine how many cell there will be across a TL.

• Edge Mesh Specification

None|Automatic|Specify Width. The default is Automatic. If the specification is not equal to None, the mesh generator will try to create an edge mesh along the border of the structure. For the edge width you can use the Automatic option, which uses heuristics to determine the edge width, or specify a width using the Specify Width option. Simulations with edge mesh are more accurate but take longer to complete and require more memory.

• Edge Mesh Width

(meter) A numeric value, the default is blank. This dialog field is editable only when the value for the option Edge Mesh Specification is Specify Width.

• Include Thin Layer Overlap

<on|off> Toggle. Default is on. To obtain accurate capacitance calculations between thin layers, the mesh generator must ensure that meshes at the boundary of the overlap are aligned. Simulations with thin layer overlap are more accurate, but take longer to complete and require more memory.
• **Reduce Mesh**

<on|off> Toggle. Default is on. To decrease the memory requirements and increase the simulation speed this option will use heuristics to try and reduce the mesh generated by the mesh generator. In doing so it might undo some of the mesh settings that have been defined.

• **Convert Circular Vias to Squares**

<on|off> Toggle. Default is off. To decrease the simulation time it is possible to convert vias with a circular shape (defined as Ellipse) directly into squares (inner square of the circle) when the Momentum layout is generated.

**Caution** Connectivity is not checked when performing this operation, so unwanted open circuits or short circuits may occur. This is most likely to take place when the viapads contain holes.

---

**Per-layer substrate and Mesh Options**

Some of the same settings that can be set as global Substrate and Mesh options, can also be set specifically and independently for each of the layers defined in the
Substrate Mesh & Simulation Options

Momentum substrate. The dialog entry can be made visible or invisible with the toggle at the top of this part of the dialog.

- **3-D Metal Expansion**
  Use Global| No| Up| Down. Default is Use Global.

- **Mesh Density**
  Use Global| <numeric value>. Default is Use Global.

- **TL Mesh**
  Use Global| <numeric value> Default is Use Global

- **Edge Mesh Specification**
  Use Global| None| Automatic| Specify Width. Default is Use Global

- **Edge Mesh Width**
  <numeric value> Default is <blank>. This dialog field is editable only when the value for the option **Edge Mesh Specification** is Specify Width.

**Note** The per-layer options use the same units as shown with the option name in the **Global Options** section of the dialog.
Chapter 7: Momentum Simulation

The simulation process combines the Green's functions that were calculated for the substrate of a circuit, plus mesh information that was calculated for the circuit, and solves for currents in the circuit. Using these current calculations, S-parameters are calculated for the circuit.

Prior to running a simulation, the following criteria must be met:

- A layout must be specified for the circuit
- A substrate definition must be specified for the circuit
- The circuit must include at least one port
- A simulation frequency plan must be specified

If any one of the above criteria is not met, Momentum will report an error if you try to run a simulation.

The Momentum planar solver uses information from the substrate database and the mesh generator to perform the circuit simulation. The substrate calculations and mesh may be computed prior to running the simulation to ensure they are valid. This will reduce simulation time.

The steps for performing a simulation include:

- Specifying and editing frequency plans
- Defining the Momentum Ports
- Select simulation options and a process mode
- Specifying solution files
- Electing to view data
- Running the simulation

Frequency Plans

You can set up multiple frequency plans for a simulation. For each plan, you can specify that a solution be found for a single frequency point or over a frequency range. You can also select one of several sweep types for a plan. This collection of frequency plans will be run as a single simulation. For more information on setting up a frequency plan refer to "Setting Up a Frequency Plan" on page 4-1.
Momentum Simulation

**Momentum Ports**

If your layout contains Cadence pins, the easiest way to create Momentum Ports is to use the Ports > Auto-generate menu item. For more information on defining Momentum Ports refer to “Definition of Momentum Ports” on page 5-2.

**Selecting a Process Mode**

To select which processes to use during a simulation choose Simulation > Options... from the Momentum-Virtuoso window. This opens the Simulation Options dialog shown in the following illustration.

![Simulation Options dialog](image)

For more information on Momentum simulation options refer to “Momentum Simulation Options” on page 6-2.
Select **Results > Data Display Options**... in the Agilent Momentum-Virtuoso window to open the Data Display Options dialog box. This dialog enables you to set the following options for plotting the Momentum results using the Data Display:

- **Toggling Open Data Display After Simulation** on or off lets you activate or deactivate the automated creation of a data display window when a Momentum simulation is completed.

- **Activating the Enable Automatic Plotting of S-parameters** toggle creates the default S-parameter plot on the data display window automatically when Open Data Display After Simulation is selected.

- **Dataset Used for Automatic Plotting** lets you select which dataset to use for automatic plots. You can choose between the most recent dataset or you will be prompted for which dataset to use.

**Note** This entry has no effect when the Data Display is opened after a simulation is completed. In this case the most recent dataset will always be used.
Reusing Simulation Data

To reduce the time required to complete the current simulation, you can use sampled data from the previous simulation. This function is useful if you extend or shift the frequency plan and resimulate, or if you want more samples near a resonance frequency. If you change the circuit geometry, substrate, ports, or mesh parameters, simulation data cannot be reused.

**Note** Momentum does not verify that the design has not changed. Make sure that only the frequency plan has changed before attempting to reuse data.

Viewing Results Automatically

Simulation data is saved in datasets, so you can view simulation results at your convenience. If you choose to view results immediately after the simulation is complete, enable Open data display when simulation completes. A data display window containing default plot types or the data display template of your choice will be automatically opened when the simulation is finished. S-parameters plotted on Smith charts is the default.

If you are using the Adaptive sweep type for your simulation, the data from the standard dataset is displayed. To switch to the adaptive data choose the `<name>_a` dataset from the select dataset list in the Data Display.

To open a data display window:

1. Choose **Results > Data Display Options**...
2. Enable **Open Data Display After Simulation**.
3. Click **OK** to accept the changes.

If you want a template to be loaded into the window:

1. Choose **Results > Data Display Template**...

2. Type the name of the template in the **Template** field.

3. Click **OK**.

**Note**  If you want to use a template from another project or location, add the path to the template to the variable MOM_AUTOPLOT_TEMPLATE_PATH in the ads configuration file rfdedcfg normally located in your ~/hpeesof/config directory.
Momentum Simulation

Starting a Simulation

The simulation process solves for currents by combining the Green's functions that were precomputed for the substrate and the mesh calculations. S-parameters are then calculated and saved to the dataset.

To start a simulation:

First ensure the simulation is defined correctly.

1. Select **Setup > Substrate** and verify the substrate is correctly defined. For more information on the Momentum substrate file refer to “Substrate File Definitions” on page 3-1.

2. Review the main dialog in the Momentum-Virtuoso window to see that the frequency plan is setup correctly. For more information setting up a frequency plan refer to “Setting Up a Frequency Plan” on page 4-1.

3. Review the main dialog in the Momentum-Virtuoso window to see that the ports are correct. For more information on ports refer to “Cadence Pins and Momentum Ports” on page 5-1
4. Select **Simulation > Options** to check that Momentum Simulation, Global Substrate and Mesh, and Per-layer Substrate and Mesh options are set to your specifications.

5. Select **Results > Data Display Options...** to check that they are set to your specifications.

6. Select **Simulation > Start**.

If the simulation cannot be started, look in the Cadence CIW for errors or warnings. After the simulation has started, messages are displayed in the Cadence simulation output log. To indicate progress, a line of dots appears across the simulation output log if the number of unknowns in the simulation is greater than 500; otherwise, only the frequencies are displayed.

If the simulation fails for a reason related to the setup, the partial data is saved and a message appears in the simulation output log.

You can determine whether or not the simulation output log opens automatically by choosing **Setup > Environment...** from the Momentum-Virtuoso main toolbar and checking to see if the Automatic Output Log checkbox is selected (default). If not, selecting it causes the simulation output log to open when you start a simulation.

**Note** The Print Comments checkbox is not functional at this time.

**Viewing Simulation Status**

After a simulation is started, any messages regarding the simulation will appear in the output log or in the CIW. Messages usually refer to any errors found, the percent of completion, and simulation completion. For large projects, the percent of completion for each task in the solution process is given by dots and vertical bars (there is one “|” for every nine dots). A full line of 36 dots and four vertical bars...
Momentum Simulation

means the task is completed. So, each dot represents the task as being another 2.5% complete. Nine dots and one vertical bar (.........| ) represents the task as being 25% complete.

If you minimize the simulation output log and want to reopen it, from the Momentum-Virtuoso menu bar choose Simulation > Output Log.

Stopping a Simulation

To stop a simulation:

1. From the Momentum-Virtuoso menu bar, choose Simulation > Stop or select the stop icon on the simulation window.

   The simulation will stop and the partial data will be saved. To reuse the saved data:

   • Choose Simulation > Options..., enable Re-use Results of Last Simulation, select Apply, then select Simulation > Start.

Viewing the Simulation Progress and Results

As the simulation progresses, you can view substrate, mesh, and solution statistics in the simulation output log window. Choose Simulation > Output Log to view the output log from the last simulation performed for the current cell.

From the Results menu in the Momentum-Virtuoso menu bar you can select a variety of reports, statistics and display options.

• **S-Parameters** brings up a Data Display window.

• **Currents...** brings up a Currents Visualization window.

• **S-Parameter Statistics...** brings up a window displaying the S-parameter statistics from the last S-parameter calculations performed on the current cell.

• **Mesh Statistics...** brings up a window displaying the mesh statistics from the last mesh calculations performed on the current cell.

• **Substrates Statistics...** brings up a window displaying the substrates statistics from the last substrate calculations performed on the current cell.

• **Mesh Report...** brings up a window for clarifications to warnings and errors from the most recent mesh calculations (if any).
- **Clear Mesh** removes the mesh information from the Momentum view of the cell.
- **Show Mesh** adds the most recent mesh layout data to the Momentum view of the cell and displays the mesh in the layout window.
- **Data Display Template...** enables you to choose the data display template to be used for automatic plotting.

**Note:** This template name is stored in the dataset and is used when the Data Display loads the dataset. As a result, changing this template name will not change the template currently displayed in the data display window.

- **Data Display Options...** brings up a Data Display Options dialog similar to the one used in the RFDE dialog and activates the same behavior as the RFDE application: when applied, it updates the application data specifying if automatic opening of the display is set (on or off).

### Performing Remote/Distributed Simulations

**Note** For information on how an administrator should setup a remote/distributed system see the Cadence documentation, Affirma AMS Distributed Processing Option User Guide. It is important for the remote/distributed system is setup properly or it will not work.

You can setup your simulator to perform a remote or distributed simulation. Choose **Setup > Simulation/Directory/Host...** from the Momentum-Virtuoso main window. This brings up the Setup Simulator / Host/ Directory dialog box.
Momentum Simulation

- **Simulator** Lists the simulator to be used.
- **Project Directory** Enables you to specify the run directory.
- **Host Mode** Choose between local, remote, or distributed modes for performing your simulation.
- **Host** Specifies a path to the host computer for remote simulation (you must specify the full path).
- **Remote Directory** Specifies a path to the run directory for remote simulation (you must specify the full path).

To perform a remote simulation:

1. Select **Setup > Simulation/Directory/Host...**
2. Select the **remote** radial button in the **Host Mode** field.
   - This activates the **Host** and **Remote Directory** fields.
3. Fill in the fields with the required information and click **OK**.

When you start a simulation it will be performed on the remote host, but all the information will be sent to the CIW as if you were doing a local simulation.

To perform a distributed simulation:

1. Select **Setup > Simulation/Directory/Host...**
2. Select the **distributed** radial button in the **Host Mode** field.
3. Click **OK**.
Starting the simulation opens the default Cadence Submit Distributed Simulation dialog. Fill in the fields and click **OK**.

This submits the job to the Cadence job monitor and runs it with the attributes selected in the Submit Distributed Simulation dialog.

**Note** To view items in the queue select **Tools > Job Monitor...** from the toolbar in the Momentum-Virtuoso main window.
Chapter 8: Viewing Results Using the Data Display

You have two tools available for displaying the results of a Momentum simulation: the Data Display, and Momentum Visualization. The visualization tool requires a separate codeword and is described in following chapters. This chapter describes how to use the Data Display to display S-parameter results from a Momentum simulation.

Additional data may be calculated during a simulation and saved in the dataset. If available it can also be viewed or used in calculations:

- Propagation constant (gamma) for each port in the circuit
- Characteristic impedance of each port
- AFS convergence data

This chapter shows how to display Momentum results. For detailed information on how to use the Data Display, refer the Data Display manual.

Opening a Data Display Window

You view simulation results using the Data Display. You can open a Data Display window using different methods:

- Automatically when a simulation is complete. For steps on how to do this, refer to “Viewing Results Automatically” on page 6-6.
- By choosing Results > S-Parameters from the Momentum Simulation window menu bar.
- By clicking the Data Display icon in the Momentum Simulation window toolbar.

Viewing Momentum Data

Simulated Momentum data is saved in one or more datasets:

- Data collected at the frequency points computed by the simulator are stored in <design_name>.ds. Design name is either the cell name or the name supplied in the simulation options dialog.
Viewing Results Using the Data Display

- If the Adaptive sweep type is used for simulation, densely resampled data, computed by AFS at each sampled frequency point, are stored in the dataset <design_name>_a.ds.

The datasets for the current project are displayed in the dataset listbox.

You can view Momentum data using any plot type:

- Rectangular
- Polar
- Smith chart
- Stacked
- List

To view Momentum data:

1. Select the plot type by clicking the appropriate plot icon, dragging the mouse into the window, then clicking to place the plot.
2. The variables in the default dataset are displayed. Select a different dataset from the list, if desired.
3. Select the variables containing the data that you want to add to the plot, then click Add.

Note Most of the simulation data is in complex format. If you are adding data to a rectangular plot, you must choose to display the data in one of several scalar formats.
4. You can add data from different datasets to the same plot. Repeat steps two and three to add more data to the plot.

5. Click OK to view the data.

**Note** Multiple graphs within the same view will overlay one another. To view multiple graphs simultaneously, assign each graph to a separate view.
Viewing Results Using the Data Display

## Viewing S-parameters

Specific information about the data available in the S-parameter datasets is given in the following sections.

### Variables in the Standard and AFS Dataset

A dataset generated from an Momentum simulation contains many variables. Below are the names of common variables that appear in a Momentum dataset and a description of the variable.

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>freq</strong></td>
<td>The independent variable frequency, which was specified during the simulation setup. The number of data points is based on the sweep type and frequency plans specified during simulation.</td>
</tr>
<tr>
<td><strong>GAMMA</strong>&lt;sub&gt;n&lt;/sub&gt;</td>
<td>The (modal) propagation constant of Port n. It is used in de-embedding, and is calculated for single, differential, and coplanar ports only.</td>
</tr>
<tr>
<td><strong>PORTZ</strong>&lt;sub&gt;n&lt;/sub&gt;</td>
<td>The impedance of Port n as defined in the Impedance fields of the Port Editor dialog box. If an impedance is not specified, 50 ohms is assumed.</td>
</tr>
<tr>
<td><strong>S</strong>&lt;sub&gt;i,j&lt;/sub&gt;</td>
<td>S matrix, normalized to PORTZ&lt;sub&gt;n&lt;/sub&gt;.</td>
</tr>
<tr>
<td><strong>S</strong>&lt;sub&gt;_50&lt;/sub&gt;&lt;br&gt;<strong>S</strong>&lt;sub&gt;_50(i,j)&lt;/sub&gt;</td>
<td>S-matrix, normalized to 50 ohms.</td>
</tr>
<tr>
<td><strong>S</strong>&lt;sub&gt;_50(i,j)&lt;/sub&gt;</td>
<td>S-parameters for each pairing of ports in the circuit, normalized to 50 ohms.</td>
</tr>
<tr>
<td><strong>S</strong>&lt;sub&gt;_CONV&lt;/sub&gt; and <strong>S</strong>&lt;sub&gt;_CONV(i,j)&lt;/sub&gt;</td>
<td>Boolean results indicating AFS convergence occurred (1) or failed (0) at a given frequency. Available in datasets from simulations using Adaptive sweep type.</td>
</tr>
<tr>
<td><strong>S</strong>&lt;sub&gt;_ERROR&lt;/sub&gt; and <strong>S</strong>&lt;sub&gt;_ERROR(i,j)&lt;/sub&gt;</td>
<td>Estimated error for a given frequency. For frequency points that converged, the value is below -60 dB. Points that fail to converge will be greater than -60 dB. Available in datasets from simulations using Adaptive sweep type.</td>
</tr>
<tr>
<td><strong>S</strong>&lt;sub&gt;_Z0&lt;/sub&gt;</td>
<td>S matrix, normalized to Z0.</td>
</tr>
<tr>
<td><strong>S</strong>&lt;sub&gt;_Z0(i,j)&lt;/sub&gt;</td>
<td>S-parameters for each pairing of ports in the circuit, normalized to Z0 of each port.</td>
</tr>
</tbody>
</table>
Standard and AFS Datasets

If the Adaptive sweep type is used for a simulation, two datasets are created for storing data. The first one contains data computed by the simulator at the frequency points determined during the simulation. (This dataset is the standard one produced by any simulation.) The second contains data computed by AFS, resampled with a very dense frequency distribution. This “adaptive” dataset is denoted by _a appended to the dataset name. The adaptive dataset contains the same variables as the standard dataset, but data is calculated for a significantly greater number of frequency points.

Typically, when viewing data in the _a dataset, you should see very smooth results, which reflect the behavior of the circuit. Viewing the standard dataset on the same plot will show the frequency points for which the simulator was invoked, superimposed on the smooth curve. Those frequency points will be scattered over the whole range, with relatively more points grouped in areas where the S-parameters show more variation. Viewing both datasets can help you determine the quality of the AFS process on your simulation. For more information on AFS, refer to “About Adaptive Frequency Sampling” on page 6-21.

Viewing Convergence Data

Viewing convergence data can be helpful if a simulation using the Adaptive sweep type has failed. You can view where convergence has been achieved, and evaluate the quality of unconverged fitting models.

For information on the AFS process, refer to “About Adaptive Frequency Sampling” on page 6-21.

The sections that follow describe how to view convergence data. This requires being familiar with using the Data Display and Equations. For more information on these topics, refer to the Data Display manual.
Data Overview

There are two variables in the adaptive dataset (named `<project_name>_a`) that contain convergence data: S_CONV and S_ERROR.

- S_CONV contains boolean values indicating where convergence has been achieved (1) or has failed (0) for the entire S matrix. S_CONV(i,j) contains boolean values indicating the convergence for S(i,j).

- S_ERROR contains the estimated magnitude and phase fitting error for the entire S matrix. S_ERROR(i,j) contains the fitting error for S(i,j). The error will be less than -60 dB if convergence is achieved. You can view S_ERROR data in dB by adding the data to a rectangular plot.

Viewing the Data

There are two suggested methods for viewing convergence. One is to simply plot S_ERROR(i,j) in dB on a rectangular plot and evaluate the quality of the AFS fit. In this example, the Low_pass_filter example is simulated with a Sample Points Limit of 19. The error for S2,1 is plotted. Convergence has been achieved over much of the frequency span, but not all of it, so the simulation has failed. This indicates the quality of the simulation over the entire frequency span that was simulated.

Several frequencies between 8 and 11 GHz fail to achieve convergence.

A second way to assess the simulation is to use S_CONV to separate converged and unconverged data for a set of S-parameters and view it on a plot.

To view convergence data:
1. Open a Data Display window and select the adaptive dataset <filename> containing the convergence data as the default dataset.

2. Choose Insert > Equation. Position the equation line in the display area and Click. Enter the following equation:

\[
\text{Converged}_{Sij} = S(i,j) * S_{\text{CONV}}(i,j)
\]

i, j must refer to the same sets of ports throughout the equation. This equation will return the converged data, and zero otherwise.

3. Click OK to add the equation to the display area.

4. Choose Insert > Equation and add the following equation:

\[
\text{Not Converged}_{Sij} = S(i,j) * (1 - S_{\text{CONV}}(i,j))
\]

Use the same i, j as in the previous equation. This equation returns the results where convergence was not achieved.

5. Click OK to add the equation to the display area.

6. Insert a rectangular plot in the display area.

7. The Insert Plot dialog box opens. Under the Datasets and Equations listbox, scroll to the bottom of the list and select Equation.

8. The variables Converged_S(i,j) and Not_Converged_S(i,j) appear in the variables list. Select one variable and add it to the plot, in dB.

9. Click OK to view the results on the plot.

10. Insert a second rectangular plot and add the second variable to it.

In the illustration below, the S2,1 convergence results for the low-pass filter, simulated with the samples limit set to 19, is displayed.

Note that because the AFS process breaks up the entire frequency span into smaller subsections, the variable S_CONV will be 1 for the points that achieve convergence over an entire subsection. So, even though the data in S_ERROR indicates almost the
Viewing Results Using the Data Display

The plots below indicate the frequency ranges that converged or failed.

- **Eqn** $\text{Converged}_{S21} = S(2,1) \times S_{\text{CONV}}(2,1)$

- **Eqn** $\text{Not Converged}_{S21} = S(2,1) \times (1 - S_{\text{CONV}}(2,1))$

**Considerations**

For efficiency purposes, the Adaptive Frequency Sampling process splits a simulation frequency range into smaller subranges that contain a maximum of 16 samples, and performs calculations on these smaller frequency ranges. The convergence factor (1 or 0) will be the same for all frequencies in a subrange. If convergence is achieved for
some subranges and not others, this will be apparent. Note that for simulations that have less than 16 samples, the entire frequency range is treated as one internal subrange, so the convergence data will be all zeros if convergence was not achieved.
Viewing Results Using the Data Display
Chapter 9: Using Momentum Simulation Results in Composer

Once a momentum view has been successfully simulated, you can create a view suitable for simulation using the Cadence Composer schematic tool.

Simulation can be performed using adsSim or Spectre. To create a schematic view, select Tools > Create Circuit Simulator Views from the Momentum-Virtuoso window.

Note When using the simulation views created by RFDE Momentum in composer, be sure the ads.ctx file is loaded, otherwise netlisting will fail during simulation.

The schematic view is created in the library shown in the Momentum-Virtuoso session window.
Using Momentum Simulation Results in Composer

The status of the operation is reported in the CIW. If a schematic view is created, the message **** Momentum Simulation Views Successfully Created *** is visible.

Note You can update the simulation data prior to opening a schematic view by selecting Tools > Update Circuit Simulator View Data.

The size of the symbol is determined by certain environment variables. For details refer to “Public Variables for Customization” on page B-1.

To open a new schematic window to use the Momentum-Virtuoso schematic view, choose File > New > Cellview... in the main Cadence window. This brings up the Create New File dialog. Select a Library Name, Cell Name and a View Name. Select OK.

This opens the schematic window. Select Add > Instance as shown in the following illustration.

9-2
This brings up the Add Instance dialog box.
Using Momentum Simulation Results in Composer

Use browse to select the Library, Cell, and View you wish to use.

An outline of the component having \( n+1 \) terminals should be visible over the schematic page. Click the schematic window for placement of the instance.

The schematic view of the Momentum-Virtuoso simulation uses Momentum simulation results found at the time the schematic view is created. If, at a later time
the Momentum cell geometry or other aspect of the Momentum setup is changed, an update to the schematic view’s data is performed by selecting **Tools > Update Schematic View Data** from the Momentum-Virtuoso session window. The status of the data update will be shown in the CIW.

---

**Note**  The manual method of updating the schematic view data is the only way to perform the update. The user must manage data synchronism between the layout simulation results and the schematic view.
Chapter 10: Displaying Surface Currents

In Momentum Visualization, you can display electric surface current density (Amps/meter) on finite conducting objects. This chapter describes how to view currents.

Note  The actual current density is 2 times greater than the value reported by Visualization.

Starting Momentum Visualization

To start Momentum Visualization choose Results > Currents... from the Momentum simulation window. The current project must run through a complete simulation to use Visualization for viewing data. If simulation has been previously completed for a project, you can start Visualization directly to view the existing data.

Note  Momentum Current Visualization is NOT available on Linux.

Note  Momentum Current Visualization commands are located in the Currents menu. The Plot menu enables you to create some S-Parameter plots. However, the Data Display is better suited to this purpose. For more information refer to “Viewing S-parameters” on page 8-4.

Working with Momentum Visualization Windows

Selecting the Number of Views

By default, the view screen displays a single view. You can optionally display four views. By using four views, you can display up to four different plots at one time.

To display four views:
  • Choose Window > Tile.
Tip You can enlarge the viewing area by clicking Hide Controls.

To display a single view:
- Choose Window > Full Window. The currently-selected view fills the view screen.

Selecting a View to Work in
You must choose from one of the four views to work in. You can change to a different view at any time.

To select a view:
- Position the mouse in the view and click.

To select a view and enlarge it to a single view:
1. Choose Window > Select View.
2. Select a view from the View list.
3. Click OK. The view screen displays the new view.

Retrieving Plots in a View
Multiple plot types can be stored under a single view. Only one plot at a time can be displayed in a view, but any other plots that you worked with in the view will be saved so that you can view them again.

To retrieve a plot from a view:
1. Select a view and either:
2. Use the arrows keys on the keyboard to scroll through plots.
3. From the Plot Type - View list, select a plot type that you worked with. The plot and all graphical information that was added to the plot is displayed.

Working with Annotation in a View
You can add text to a view, and edit the position and color of the text, by choosing Display > Annotation. You can save your settings so that they can be reused.
Adding Text

To add text to a view:

1. Select the view where you want to add text.
2. Choose Display > Annotation. Drag the Annotation dialog box so that any existing text is in view.
3. Click New Annotation.
4. Type your text into the Annotation Label field. If text already appears in this field, you can delete it and then type in your text. When you are finished, press the Enter key.
5. Use the X Location and Y Location scroll tools to position the text on the display.
6. Click Done to dismiss the dialog box and view the new text.

Adding Variables

There are three variables that can be added to the annotation:

%project%, %view%, and %date%.

These variables can be displayed automatically whenever Momentum Visualization is in use.

Editing Text

To edit text:

1. Select the view where you want to edit text.
2. Choose Display > Annotation. Drag the annotation dialog box so that any existing text is in view.
3. Select the text that you want to edit from the Annotations field.
4. To adjust the position of the text in the view, use the X Location and Y Location scroll tools.
5. To change the size of the text, use the Annotation Size scroll tool to increase or decrease the font size.
Displaying Surface Currents

6. To change the thickness of the text characters, use the Annotation Thickness scroll tool to make fine, normal, or bold-faced characters.
7. To change the color of the text, select one of the colors listed under Annotation Color.
8. To change the orientation of the text, use Horizontal or Vertical under Orientation.
9. To change the text, make your changes in the Annotation Label field.
10. To make changes to other lines of text, select the text from the Annotation field and edit as desired.
11. When you are finished, click Done to dismiss the dialog box.

Deleting Text

To delete text:
1. Select the view that you want to add text to or edit text.
2. Choose Display > Annotation. Drag the annotation dialog box so that any existing text is in view.
3. Select the text that you want to delete from the Annotations field.
4. Click Delete Annotation.
5. Click Done to dismiss the dialog box.

Refreshing the Window

Choose Window > Refresh at any time to update the displayed views. Typically, the window refreshes automatically after a command is completed.
Viewing Data from Another Project

The data from any Momentum project can be directly loaded. After you load new projects, you can select among any of the projects for data to display.

To load an Momentum project:
1. Choose Projects > Read Momentum Project.
2. Navigate to the folder where the simulation project is saved (project folder) within the simulation subdirectory and open the folder.
3. Under the project folder is another folder named visualization. Open this folder.
4. Open the folder that contains your specific design. (by default the cell Name)
5. Double-click on any file within this folder. (by default it should display proj.msh)

Setting Port Solution Weights

Before displaying a current plot, select a frequency and set the port solution weights for that frequency. Weighting port solutions enables you to specify the amount that any one port solution contributes to the solution at a given frequency. The weighting will be reflected in the current plots.

A Thevenin voltage source (voltage source + source impedance in series) is attached to each circuit port. The source impedance is either the characteristic impedance for single and differential ports; or 50 ohms for all other port types. The voltage source amplitude for each port is set to its corresponding solution weight (magnitude + phase). The displayed currents are those that correspond with this excitation state.

To set port solution weights:
1. Choose Current > Set Port Solution Weights.
2. Select a frequency.
3. Select a port, and enter the magnitude in the Solution Weight field, and enter the phase in the Solution Phase field.
4. Repeat the previous step for other ports, as necessary for the same frequency.
5. Click OK to complete the command.
Displaying Surface Currents

**Displaying the Layout**

An outline of the layout is loaded into a view (if it is missing) when the current plots are displayed. If a layout is not loaded or if it was deleted, choose **Display > Objects** to display the layout.

**Displaying a Current Plot**

The current plot displays surface currents on all objects of the simulated layout. The plot can be animated to illustrate the currents propagating through the circuit.

---

**Note**  
Make sure the layout is loaded into the view. Choose **Display > Objects** to load the layout if it is missing.

---

To display a current plot:

1. Choose **Current > Plot Currents**.
2. Select the graphical format:
   - **Arrow**  
     Plots a vector current quantity using arrows to indicate direction and magnitude.
   - **Contour**  
     Displays the “equal magnitude” contours of the vector current.
   - **Shaded**  
     Displays a shaded plot of a magnitude of the vector current. The magnitude being plotted is represented by a range of colors. A color scale showing the range of values also appears on the screen.
3. Select the view that you want to use to display the plot.
4. Click **OK**.
**Animating Plotted Currents**

The currents have a sinusoidal, or harmonic, time dependence, with steady-state conditions assumed. There is an implied $e^{j\omega t}$ time dependence. Animation enables you to visualize the surface currents in the time domain, illustrating the propagation through a circuit. Changing time corresponds with changing the additional phase introduced by the $e^{j\omega t}$ factor. You can change this phase continuously or you can step through the phase changes manually.

To change the phase manually:

- Use the scroll bar. This enables you to freeze the phase in the layout.

To automate the animation:

1. Click **Display Properties**.
2. Enable **Animate**.
3. The currents are animated in time. The animation repeats automatically until **Animate** is disabled. The speed of the animation can be changed by editing the **Increment** field. A larger value speeds the animation, smaller values slow it down.
4. You can change the maximum value of the color scale. Depending on the selected graphical format, you can change other options:
   - For the shade and contour plots, you can set the translucency, and color of the current.
   - For the arrow plot, you can change the length of the arrow vector.
Displaying Surface Currents

**Displaying the Mesh on a Current Plot**

Choose **Display > Mesh** to add the mesh to a current plot.

To display a mesh:

1. Choose **Display > Mesh**.
2. Select the view displaying the plot to which you want to add the mesh. Meshes can be displayed in Objects only.
3. Click **OK** to complete the command.

**Tip** Depending on the drawing order, the mesh may be under the shaded current plot, and not visible. To see the mesh, lower the translucency of the shaded plot.
Appendix A: Theory of Operation

Momentum is based on a numerical discretization technique called the method of moments. This technique is used to solve Maxwell's electromagnetic equations for planar structures embedded in a multilayered dielectric substrate. The simulation modes available in Momentum RF are both based on this technique, but use different technologies to achieve their results.

Momentum has two modes of operation, Microwave or full-wave mode and the RF or quais-static mode. The main difference between these two modes lies within the Green functions formulations that are used. The full-wave mode uses full-wave Green functions, these are general frequency dependent Green functions that fully characterize the substrate without making any simplification to the Maxwell equations. This results in L and C elements that are complex and frequency dependent. The quasi-static mode uses frequency independent Green functions resulting in L and C elements that are real and frequency independent. Because of the approximation made in the full-wave mode, the RF simulations run a lot faster since the matrix L and C elements only have to be calculated for the first frequency simulation point. The approximation also implies that the full-wave mode typically should be used for structures that are smaller than half the wavelength. Both engine modes are using the so-called star-loop basis function, ensuring a stable solution at all frequencies. Both engines also make use of a mesh reduction algorithm which reduces the number of unknowns in the simulation by generating a polygonal mesh. This mesh reduction algorithm can be turned on or off, with a toggle switch.

The sources applied at the ports of the circuit yield the excitations in the equivalent network model. The currents in the equivalent network are the unknown amplitudes of the rooftop expansion functions. Solving the equivalent network for a number of independent excitation states yields the unknown current amplitudes. When calibration is requested, a port calibration process is used to calculate the S-parameter data of the circuit from the current solution.

The following sections in this chapter contain more information about:

- The method of moments technology
- The Momentum solution process
- Special simulation topics
- Considerations and software limitations
Theory of Operation

The Method of Moments Technology

The method of moments (MoM) technique is based upon the work of R.F. Harrington, an electrical engineer who worked extensively on the method and applied it to electromagnetic field problems, in the beginning of the 1960’s. It is based on older theory which uses weighted residuals and variational calculus. More detailed information on the method of movements and Green’s theorem can be found in Field Computation by Moment Methods [1].

In the method of moments, prior to the discretization, Maxwell’s electromagnetic equations are transformed into integral equations. These follow from the definition of suitable electric and magnetic Green’s functions in the multilayered substrate. In Momentum, a mixed potential integral equation (MPIE) formulation is used. This formulation expresses the electric and magnetic field as a combination of a vector and a scalar potential. The unknowns are the electric surface currents flowing in the planar circuit.

Using notations from linear algebra, we can write the mixed potential integral equation in very general form as a linear integral operator equation:

\[ \int \int dS \bar{G}(r, r') \cdot J(r) = E(r) \quad (1) \]

Here, \( J(r) \) represents the unknown surface currents and \( E(r) \) the known excitation of the problem. The Green’s dyadic of the layered medium acts as the integral kernel. The unknown surface currents are discretized by meshing the planar metallization patterns and applying an expansion in a finite number of subsectional basis functions \( B_1(r), ..., B_N(r) \):

\[ J(r) = \sum_{j=1}^{N} I_j B_j(r) \quad (2) \]

The standard basis functions used in planar EM simulators are the subsectional rooftop functions defined over the rectangular, triangular, and polygonal cells in the mesh. Each rooftop is associated with one edge of the mesh and represents a current with constant density flowing through that edge (Figure A-1). The unknown
amplitudes $I_j$, $j=1,...,N$ of the basis function expansion determine the currents flowing through all edges of the mesh.

The integral equation (1) is discretized by inserting the rooftop expansion (2) of the currents. By applying the Galerkin testing procedure, that is, by testing the integral equation using test functions identical to the basis functions, the continuous integral equation (1) is transformed into a discrete matrix equation:

for $i=1,...,N$

$$\sum_{j=1}^{N} Z_{i,j} I_j = V_i \quad \text{or} \quad [Z] \cdot [I] = [V] \quad (3)$$

with

$$Z_{i,j} = \int_S dS B_i(r) \cdot \int_S dS \bar{G}(r,r) \cdot B_j(r) \quad (4)$$

$$V_i = \int_S dS B_i(r) \cdot E(r) \quad (5)$$

The left hand side matrix $[Z]$ is called the interaction matrix, as each element in this matrix describes the electromagnetic interaction between two rooftop basis functions. The dimension $N$ of $[Z]$ is equal to the number of basis functions. The right-hand side vector $[V]$ represents the discretized contribution of the excitations applied at the ports of the circuit.
Theory of Operation

The surface currents contribute to the electromagnetic field in the circuit by means of the Green's dyadic of the layer stack. In the MPIE formulation, this Green's dyadic is decomposed into a contribution from the vector potential \( \mathbf{A}(\mathbf{r}) \) and a contribution from the scalar potential \( V(\mathbf{r}) \):

\[
\mathbf{G}(\mathbf{r}, \mathbf{r}') = j\omega \mathbf{A}(\mathbf{r}, \mathbf{r}') \mathbf{I} - \frac{1}{j\omega} \nabla [\mathbf{G}^V(\mathbf{r}, \mathbf{r}') \nabla] \tag{6}
\]

The scalar potential originates from the dynamic surface charge distribution derived from the surface currents and is related to the vector potential through the Lorentz gauge.

By substituting the expression (6) for the Green's dyadic in the expression (4) for the interaction matrix elements, yields the following form:

\[
Z_{i, j} = j\omega L_{i, j} + \frac{1}{j\omega C_{i, j}} \tag{7}
\]

with

\[
L_{i, j} = \int_S dS \mathbf{B}_i(\mathbf{r}) \cdot \int_S dS' \mathbf{G}^A(\mathbf{r}, \mathbf{r}') \mathbf{B}_j(\mathbf{r}') \tag{8}
\]

\[
\frac{1}{C_{i, j}} = \int_S dS \nabla \cdot \mathbf{B}_i(\mathbf{r}) \int_S dS' \mathbf{G}^V(\mathbf{r}, \mathbf{r}') \nabla \cdot \mathbf{B}_j(\mathbf{r}') \tag{9}
\]

This allows the interaction matrix equation to be given a physical interpretation by constructing an equivalent network model (Figure A-2). In this network, the nodes correspond to the cells in the mesh and hold the cell charges. Each cell corresponds to a capacitor to the ground. All nodes are connected with branches which carry the current flowing through the edges of the cells. Each branch has an inductor representing the magnetic self coupling of the associated current basis function. All capacitors and inductors in the network are complex, frequency dependent and mutually coupled, as all basis functions interact electrically and magnetically (Figure A-3). The ground in this equivalent network corresponds with the potential at the infinite metallization layers taken up in the layer stack. In the absence of infinite metallization layers, the ground corresponds with the sphere at infinity. The method of moments interaction matrix equation follows from applying the Kirchoff
voltage laws in the equivalent network. The currents in the network follow from the solution of the matrix equation and represent the amplitudes of the basis functions.

Figure A-2. The equivalent circuit is built by replacing each cell in the mesh with a capacitor to the ground reference and inductors to the neighboring cells.

Figure A-3. Equivalent network representation of the discretized MoM problem.
The Momentum Solution Process

Different steps and technologies enable the Momentum solution process:

- Calculation of the substrate Green's functions
- Meshing of the planar signal layer patterns
- Loading and solving of the MoM interaction matrix equation
- Calibration and de-embedding of the S-parameters
- Reduced Order Modeling by Adaptive Frequency Sampling

Calculation of the Substrate Green's Functions

The substrate Green's functions are the spatial impulse responses of the substrate to Dirac type excitations. They are calculated for each pair of signal (strip, and/or via) layers mapped to a substrate level. Although it is necessary to know which signal layers are mapped to a substrate level, since only impulse responses are being calculated, it is not necessary to know the patterns on these signal layers. This implies that the Green's functions can be pre-calculated and stored in a substrate database. This allows the substrate Green's functions to be reused for other circuits defined on the same substrate.

The high frequency electromagnetic Green's functions depend upon the radial distance and the frequency. The computations are performed up to very large radial distances over the entire frequency band specified by the user. The frequency points are selected adaptively to ensure an accurate interpolation with respect to frequency. Computations performed over very wide frequency ranges can consume more CPU time and disk space to store the results. To increase speed, the RF mode uses quasi-static electromagnetic Green's functions based on low-frequency approximation.

Meshing of the Planar Signal Layer Patterns

The planar metallization (strip, via) patterns defined on the signal layers are meshed with rectangular and triangular cells in the RF simulation mode. As translational invariance is used to speed up the interaction matrix load process, the meshing algorithm will maximize the number of uniform rectangular cells created in the mesh. An additional mesh reduction step, which can be turned on or off, reduces the complexity of mesh by generating polygonal shaped meshes. This is done by
recombining some of the original rectangular and triangular meshes. Mesh reduction reduces the number of unknown currents in the matrix equation. The meshing algorithm is very flexible as different parameters can be set by the user (number of cells/wavelength, number of cells/width, edge meshing, and mesh seeding), resulting in a mesh with different density. It is clear that the mesh density has a high impact on both the efficiency and accuracy of the simulation results. Default mesh parameters are provided which give the best accuracy/efficiency trade-off.

**Loading and Solving of the MoM Interaction Matrix Equation**

The loading step of the solution process consists of the computation of all the electromagnetic interactions between the basis functions and the filling of the interaction matrix and the excitation vector. The interaction matrix as defined in the rooftop basis is a dense matrix, that is, each rooftop function interacts with every other rooftop function. This electromagnetic interaction between two basis functions can either be strong or weak, depending on their relative position and their length scale. The matrix filling process is essentially a process of order \( N^2 \), i.e. the computation time goes up with the square of the number of unknowns.

In the solving step, the interaction matrix equation is solved for the unknown current expansion coefficients. The solution yields the amplitudes of the rooftop basis functions which span the surface current in the planar circuit. Once the currents are known, the field problem is solved because all physical quantities can be expressed in terms of the currents. In Momentum, the matrix equation is solved with a standard matrix factorization technique. This implies that the matrix solve process is essentially a process of order \( N^3 \).

**Calibration and De-embedding of the S-parameters**

Momentum performs a calibration process on the edge type port, similar to any accurate measurement system, to eliminate the effect of the sources connected to the transmission line ports in the S-parameter results. Feedlines of finite length are added to the transmission line ports of the circuit. Lumped sources are connected to the far end of the feedlines. These sources excite the eigenmodes of the transmission lines without interfering with the circuit. The effect of the feedlines is computed by the simulation of a calibration standard and subsequently removed from the S-parameter data. A built-in cross section solver calculates the characteristic impedance and propagation constant of the transmission lines. This allows to shift the phase reference planes of the S-parameters, a process called de-embedding. Results of the calibration process includes the elimination of low-order mode
Theory of Operation

mismatches at the port boundary, elimination of high-order modes, and removal of all port excitation parasitics.

Besides transmission line ports, Momentum offers the user the ability to define direct excitation or internal ports. These ports can be specified at any location on the planar metallization patterns as either a point or an edge feed. They allow to connect both passive and active lumped components to the distributed model of the planar circuits. The S-parameters associated with these ports are calculated from the excitation consisting of a lumped source connected to the equivalent network model at the locations of the internal ports. The parasitic effects of these lumped sources are not calibrated out of the S-parameters results.

Note For most RFIC users, internal ports will produce accurate results and better performance.

Reduced Order Modeling by Adaptive Frequency Sampling

A key element to providing fast, highly accurate solutions using a minimum of computer resources is the Adaptive Frequency Sampling (AFS) technology. When simulating over a large frequency range, oversampling and straight line interpolation can be used to obtain smooth curves for the S-parameters. Oversampling however implies a huge amount of wasted resources. Momentum allows the user to benefit from a smart interpolation scheme based on reduced order modeling techniques to generate a rational pole/zero model for the S-parameter data. The Adaptive Frequency Sampling algorithm selects the frequency samples automatically and interpolates the data using the adaptively constructed rational pole/zero model. This feature allows important details to be modeled by sampling the response of the structure more densely where the S-parameters are changing significantly. It minimizes the total number of samples needed and maximizes the information provided by each new sample.

In fact, all kinds of structures can take advantage of the AFS module. The Adaptive Frequency Sampling technology reduces the computation time needed for simulating large frequency ranges with Momentum significantly.
Special Simulation Topics

Some special simulation topics are discussed in this section:

- Simulating metallization loss
- Simulating internal ports and ground references

Simulating Metallization Loss

When using Momentum, losses in the metallization patterns can be included in the simulation. Momentum can either treat the conductors as having zero thickness or include the effects of finite thickness in the simulation. In the substrate definition, the expansion of conductors to a finite thickness can be turned on/off for every layer. For more information, refer to "Via Structures and Metallization Thickness Limitation" on page A-15.

Momentum uses a complex surface impedance for all metals that is a function of conductor thickness, conductivity, and frequency. At low frequencies, current flow will be approximately uniformly distributed across the thickness of the metal. Momentum uses this minimum resistance and an appropriate internal inductance to form the complex surface impedance. At high frequencies, the current flow is dominantly on the outside of the conductor and Momentum uses a complex surface impedance that closely approximates this skin effect. At intermediate frequencies, where metal thickness is between approximately two and ten skin depths, the surface impedance transitions between those two limiting behaviors. This treatment of metal loss is a good approximation for many cases but can be less accurate for very narrow conductors.

The meshing density can affect the simulated behavior of a structure. A more dense mesh allows current flow to be better represented and can slightly increase the loss. This is because a more uniform distribution of current for a low density mesh corresponds to a lower resistance.

Losses can be defined for groundplanes defined in the substrate definition. This uses the same formulation as for loss in microstrips (i.e., through a surface impedance approximation). It should be noted however that since the groundplanes in the substrate description are defined as infinite in size, only HF losses are incorporated effectively. DC losses are 0 by definition in any infinite groundplane. DC metallization losses in groundplanes can only be taken into account by simulating a finite size groundplane as a strip metallization level.
Simulating with Ports

A port is defined as one or more pins connected to either the positive or negative reference of a port. There are two different port types:

- edge - can be calibrated and non-calibrated
- internal

A port is always defined as having a positive and negative connection point. The negative connection point can be explicit (e.g. on an infinite groundplane), in which case the user does not have to specify a location.

Momentum Current Feed Models/Port Types

Momentum port type determined by it’s location:

Location inside layout: Point Port (internal port)

Location on layout boundary: Edge Port

Typical Port Combinations

Single with implicit reference definition

Implicit reference to groundplane in substrate: negative reference not explicitly defined in port definition. (most common case)
Differential line setup

Ground reference setup

Common mode with implicit reference definition

Implicit reference to groundplane in substrate: negative reference not explicitly defined in port definition.

Internal Ports

Momentum offers the ability to use internal ports within a structure. Internal ports can be specified at any location on the planar metallization patterns, and they make possible a connection for both passive and active lumped components to the distributed model of the planar circuits. Refer to Figure A-4.
Theory of Operation

The S-parameters associated with these ports are calculated from the excitation consisting of a lumped voltage source connected to the equivalent network model, as shown in Figure A-3. The ground reference for these ports in the resulting S-parameter model is the ground of the equivalent network, and this ground corresponds physically to the infinite metallization layers taken up in the layer stack. In the absence of infinite metallization layers, the ground no longer has a physical meaning and corresponds mathematically with the sphere at infinity.

It is important to mention that in this case, the associated S-parameters also lose their physical meaning, as the applied voltage source is assumed to be lumped, that is electrically small, since it sustains a current flow from the ground to the circuit without phase delay. To overcome this problem, a ground reference must be specified at a distant electrically small from the internal port. Failure to do so may yield erroneous simulation results.

![Figure A-4. Internal port and equivalent network model.](image)

The following sections illustrate the use of internal ports with ground planes and with ground references, and the results.

Limitations and Considerations

This section describes some software limitations and physical considerations which need to be taken into account when using Momentum:

- Comparing the microwave and RF simulation modes
- Matching the simulation mode to circuit characteristics
- Higher-order modes and high frequency limitation
- Substrate waves and substrate thickness limitation
Comparing the Microwave and RF Simulation Modes

Momentum has two simulation modes: the Microwave and RF mode. The Microwave mode uses full-wave formulation, the RF mode uses a quasi-static formulation. In the quasi-static formulation, the Green functions are low-frequency approximations to the full-wave and more general Green functions. Because of the approximations made in the RF mode, the simulations are more efficient. The approximation is valid for structures that are small compared to the wavelength (size of the circuit smaller than half a wavelength).

Another advantage of Momentum RF over the Momentum mode is its use of star-loop technology to eliminate low-frequency breakdown of numerical solutions, and give stable solutions down to DC. Momentum mode simulations use rooftop basis functions defined over the rectangular and triangular cells in a mesh. While a formulation based on rooftop functions produces accurate results at microwave frequencies, it becomes unstable at lower, RF frequencies and a break-down of the solution occurs. To eliminate the instability, Momentum RF uses a formulation based on star-loop technology, which regroups the rooftop functions into star and loop functions. The loop functions model the solenoidal part of the current solution, while the star functions model the non-rotational part. This allows the elimination of the low-frequency instability in the numerical solution.

Matching the Simulation Mode to Circuit Characteristics

The Momentum RF mode can be used to simulate RF and microwave circuits, depending on your requirements. However, Momentum RF is usually the more efficient mode when a circuit is electrically small, geometrically complex, and does not radiate. This section describes these characteristics.

Radiation

Momentum RF provides accurate electromagnetic simulation performance at RF frequencies. However, this upper limit depends on the size of your physical design. At
Theory of Operation

higher frequencies, as radiation effects increase, the accuracy of the Momentum RF models declines smoothly with increased frequency.

**Electrically Small Circuits**

Momentum RF works best for electrically small circuits as its accuracy smoothly decreases with increasing electrical size relative to a given frequency. A circuit is considered electrically small relative to a given frequency if its physical dimension is smaller than half the wavelength of the frequency. Depending on which value you know, maximum circuit dimension or maximum simulation frequency, you can determine a qualitative approximation of the circuit’s electrical size. Suppose you have a circuit with dimension D as shown in the following figure:

You can use one of the following two expressions strictly as a guideline to have an awareness about the circuit’s electrical size relative to the maximum frequency you plan to run the simulation. When you know the value of D, use the first expression to approximate the maximum frequency up to which the circuit is electrically small. When you know the maximum simulation frequency, use the second expression to approximate the maximum allowable dimension:

\[ F < \frac{150}{D} \]

or

\[ D < \frac{150}{F} \]

where:

- \( D \) = the maximum length in mm diagonally across the circuit.
- \( F \) = the maximum frequency in GHz.
During a simulation, Momentum RF calculates the maximum frequency up to which the circuit is considered electrically small, and displays that value in the output log. This is similar to using the first expression above since the dimension of a layout is typically fixed, and it is the simulation frequency that is swept.

**Higher-order Modes and High Frequency Limitation**

Since Momentum does not account for higher-order modes in the calibration and de-embedding process, the highest frequency for which the calibrated and de-embedded S-parameters are valid is determined by the cutoff frequency of the port transmission line higher-order modes. As a rule of thumb for microstrip transmission lines, the cutoff frequency (in GHz) for the first higher-order mode is approximately calculated by:

\[
Cutoff \ frequency \ f_c = 0.4 \ Z_0 / \ \text{height}
\]

where \( Z_0 \) is the characteristic impedance of the transmission line. For a 10 mil alumina substrate with 50 ohm microstrip transmission line, we obtain a high frequency limit of approximately \( f_c = 80 \) GHz.

**Surface Wave Modes**

If the substrate is not homogeneous, surface wave modes can exist. The parallel plate mode can be seen as a special case of a surface wave mode. Their behavior is identical. Both are cylindrical waves that propagate radially away from the source. They are guided by the substrate. Both fundamental and higher-order surface wave modes exist. Similar conclusions can be drawn with respect to limitations such as the effects of the modes.

**Via Structures and Metallization Thickness Limitation**

In Momentum, the current flow on via structures is only allowed in the vertical direction; horizontal or circulating currents are not modeled. As via structures are metallization patterns, the modeling of metallization losses in via's is identical to the modeling of metallization loss in microstrip. There is an automated procedure that allows for the expansion of the finite thickness conductor.
Theory of Operation

**Via Structures and Substrate Thickness Limitation**

The vertical electrical currents on via structures are modeled with rooftop basis functions. In this modeling, the vertical via structure is treated as one cell. This places an upper limit to the substrate layer thickness as the cell dimensions should not exceed 1/20 of a wavelength for accurate simulation results. Momentum simulations with via structures passing through electrically thick substrate layers will become less accurate at higher frequencies. By splitting the thick substrate layer into more than one layer, more via-cells are created and a more accurate solution is obtained.

**CPU Time and Memory Requirements**

Both CPU time and memory needed for a Momentum simulation increase with the complexity of the circuit and the density of the mesh. The size $N$ of the interaction matrix equation is equal to the number of edges in the mesh. For calibrated ports, the number of unknowns is increased with the edges in the feedlines added to the transmission line ports.

**CPU Time**

The CPU time requirements for a Momentum simulation can be expressed as:

$$\text{CPU time} = A + B \, N + C \, N^2 + D \, N^3$$

where

- $N$ = number of unknowns
- $A, B, C, D$ = constants independent of $N$

The constant term $A$ accounts for the simulation set up time. The meshing of the structure is responsible for the linear term, $BN$. The loading of the interaction matrix is responsible for the quadratic term and the solving of the matrix equation accounts for the cubic term. It is difficult to predict the value of the constants $A, B, C$ and $D$, as they depend on the problem at hand.

The quadratic and the cubic terms are dominating the overall CPU-time requirements. For small to medium size problems, as the constant $C$ is much larger than $D$, the solution time is dominated by the loading of the matrix. For larger problems the matrix solve time with its cubic term will eventually dominate the CPU-time requirements.
Memory Usage

The memory requirement for a Momentum simulation can be expressed as:

\[ \text{Memory} = X + Y N + Z N^2 \]

where

- \( N \) = number of unknowns
- \( X, Y, Z \) constants independent of \( N \)

Like with the CPU time expression, the constants \( X, Y \) and \( Z \) are difficult to predict for any given structure.

For medium to large size problems, the quadratic term, which accounts for storing of the interaction matrix, always dominates the overall memory requirement. For small structures, memory usage can also be dependent upon the substrate. The substrate database must be read and interpolated, which requires a certain amount of memory. Algorithms to make trade-off between time and memory resources are implemented in the simulator. These algorithms result in additional usage above that required to solve the matrix. Total memory consumption is typically less than 1.5 times what is required to store the matrix, for large matrices.

References

Appendix B: Customization

Public Procedures for Customization

Public Procedures for Customization:

    rfdeMomSim_customMenuList

When the procedure `rfdeMomSim_customMenuList` is defined to return a list of menuId’s, these menuId’s (e.g., created using `hiCreatePullDownMenu`) are added to the rfde Momentum main simulation window menu bar.

Public Variables for Customization

The following environment variables govern the creation of momentum symbols:

    adsMom.symbol  pinSeparation    string
    adsMom.symbol  labelHeigth     string
    adsMom.symbol  pinHalfSize     string

By default schematic settings are used so these are left blank in the .cdsenv file for the adsMom tool. To define the value put “” around the float value:

- **pinseparation**: the distance between two pin. (if value equals “” schematic symGridSpacing is used).
- **labelHeigth**: the size of the label (if value equals “” schematic symbolLabelFontHeight is used).
- **pinHalfSize**: half the size of the Pin Symbol (if value equals “”, it is set to 0.5* the value of the environment variable schematic symbolLabelFontHeight).
Customization
Index

Numerics

3D expansion, 6-4

A

adaptive
  sweep type
    and adaptive frequency sampling, 4-4
    and datasets, 8-2
    data, 8-5
    setting sample points, 4-6

Adaptive Frequency Sampling, A-8 (AFS), 4-5
  about, 4-4
  and convergence, 4-5
  and S-parameters, 4-7
  convergence data
    variables, 8-6
    viewing convergence data, 8-5

Advanced Port Types, 5-6
  animating
    plotted currents, 10-7

C

Cadence Pins, 5-1
Calibration, 5-9
  calibration, A-7
Changing Port Properties, 5-6
  circuits
    analyzing in Momentum, 7-1
  convergence
    of adaptive sweep, 4-5
  viewing data, 8-5
CPU
  requirements, A-16
Current plots
  animating, 10-7
Currents
  displaying, 10-1
  plotting, 10-6
Customization
  menus, B-1
  procedures, B-1
  variables, B-1

D

Data Display window
  viewing simulation results, 8-1
Datasets
  of adaptive data, 8-2
  of results, 8-5
  of standard data, 8-2
  that store data, 8-1
  variables, 8-4
De-embedding, A-7
Discrete matrix, A-3
Displaying
  layouts, 10-6
  mesh, 10-8
  objects, 10-6
Surface currents, 10-1

E

Edge pin, 5-4
Equivalent network model, A-4

F

File extension
  for datasets, 8-1
Freq variable, 8-4
Frequency
  limitations, A-15
Frequency plans
  and simulations, 4-1

G

Gamma variable, 8-4
Green's functions, A-6
Grounds
  reference ports, A-11

H

Halting
  a simulation, 7-8

I

Interaction matrix, A-3
  loading and solving, A-7
  physical interpretation, A-4
Internal ports, A-11
Index-2

L
layout layers
and overlap, 3-2
layouts
displaying, 10-6
limitations
of Momentum, A-12
vias, A-15

M
matrix
discrete, A-3
interaction, A-3
loading and solving, A-7
physical interpretation, A-4
memory
usage, A-17
mesh
and metallization loss, A-9
displaying on a plot, 10-8
theory, A-6
metallization layers
and overlap, 3-2
metallization loss, A-9
vias, A-15
method of moments, A-1
microwave simulation mode, A-13
mixed potential integral equation, A-2
modes
simulation, A-13
surface wave, A-15
Momentum
limitations, A-12
simulation modes, A-13
Momentum Ports, 5-1

N
network model, A-4

O
objects
displaying, 10-6
overlap precedence, 3-2

P
phases
in current plots, 10-7
plots

of currents, 10-6
of the mesh, 10-8
point pin, 5-5
ports, A-11
calibration, A-7
internal, A-11
solution weights, 10-5
PORTZ variable, 8-4

R
Reference pins, 5-7
results
stored in dataset variables, 8-4
viewing, 8-1
reusing
simulation data, 7-4
RF simulation mode, A-13
rooftop function, A-2

S
S matrix, 8-4
S variable, 8-4
S_50 variables, 8-4
S_CONV
viewing, 8-6
S_CONV variables, 8-4
S_ERROR
viewing, 8-6
S_ERROR variables, 8-4
S_20 variables, 8-4
sample points
and simulation, 4-6
simulation data
reusing, 7-4
simulation modes, A-13
matching to circuits, A-13
selecting, 1-4
simulations
frequency plans, 4-1
halting, 7-8
modes, A-13
of metallization loss, A-9
prerequisites, 7-1
process, 7-1
setting sample points, 4-6
starting, 7-6
steps for defining, 7-1
stopping, 7-8
summary, 7-8
viewing results, 7-4
viewing status, 7-7
solution process
theory of operation, A-6
S-parameters
variables, 8-4
starting
a simulation, 7-6
stopping
a simulation, 7-8
subtracting geometries, 3-2
surface currents
displaying, 10-1
plotting, 10-6
surface wave modes, A-15
sweeps
types
adaptive frequency sampling, 4-4
and sample points, 4-6

T
theory of operation
overview, A-1

V
variables
containing results, 8-4
of convergence data, 8-6
vias
limitations, A-15
viewing
AFS parameters, 4-7
S_CONV, 8-6
S_ERROR, 8-6
simulation results, 7-4
simulation status, 7-7
simulation summary, 7-8

W
weighting port solutions, 10-5

Z
Z0 variables, 8-5