Help Volume

© 1996-2002 Agilent Technologies. All rights reserved.

Analysis: Compare tool
Using the Compare Tool

The Compare tool compares data from one measurement, data from subsequent measurements, or data from measurements taken on more than one analyzer. Compare tool output is viewed using the Lister or Waveform tool.

Getting Started

- “Overview of the Compare Tool” on page 8
- “Understanding Compare Modes” on page 10

Setting Up a Compare

- “Configuring the Compare Tool” on page 12
- “Selecting Data Sets to Compare” on page 13
- “Copying Data to the Reference Buffer” on page 14
- “Selecting Labels to Compare” on page 15
- “Adjusting Data Set Alignment” on page 17
- “Executing the Compare” on page 19
- “Viewing Compare Tool Output” on page 20
- “Printing Compare Results” on page 46

More Features

- “Loading and Saving Compare Configurations” on page 39
- “Setting Timing Edge Tolerance” on page 22
- “Setting Display Options” on page 25
- “Adjusting the Range of Data to be Compared” on page 26
- “Setting Reference Buffer Options” on page 32
- “Adjusting Which Labels are Displayed” on page 38
- “Stopping Repetitive Analyzer Measurements” on page 40
Using the Compare Tool

“Terminating a Compare” on page 41
“Finding Compare Differences” on page 28
“Logging Comments” on page 42
“Sample Compare Tool Applications” on page 44

See Also
Main System Help (see the Agilent Technologies 16700A/B-Series Logic Analysis System help volume)
Glossary of Terms (see page 47)
Using the Compare Tool
Contents

Using the Compare Tool

1 Using the Compare Tool

Overview of the Compare Tool 8
Understanding Compare Modes 10
Configuring the Compare Tool 12
Selecting Data Sets to Compare 13
Copying Data to the Reference Buffer 14
Selecting Labels to Compare 15
Adjusting Data Set Alignment 17
Executing the Compare 19
Viewing Compare Tool Output 20
Setting Timing Edge Tolerance 22
Setting Display Options 25
Adjusting the Range of Data to be Compared 26
Finding Compare Differences 28
Finding Differences Using Markers 29
Setting Reference Buffer Options 32
Adjusting the View of Reference Buffer Data 33
Contents

Modifying Reference Buffer Data 34
Saving the Compare Reference to a File 35
Editing Lines and Labels in the Reference Buffer 36
Customizing the Reference Buffer Display 37
Adjusting Which Labels are Displayed 38
Loading and Saving Compare Configurations 39
Stopping Repetitive Analyzer Measurements 40
Terminating a Compare 41
Logging Comments 42
Setting a Compare Mask 43
Sample Compare Tool Applications 44
Printing Compare Results 46

Glossary

Index
Using the Compare Tool
Overview of the Compare Tool

The Compare tool determines the difference between two data sets resulting from two different measurements, or between two labels within the same measurement. The Compare tool is placed between one or more data sources and an output viewing tool.

A Compare Configuration

The Main Compare Window

Differences between the data sets being compared are highlighted in the display tool. The compare operation can be tailored to a certain subset of the data in the input data sets.
Chapter 1: Using the Compare Tool

Overview of the Compare Tool

Listing Display of Differences

Once you determine the sources of data you want to compare, you configure the Compare tool’s labels, bits, range, alignment, and termination conditions to display similarities and differences in the data to aid your problem solving.

Uses for the Compare tool include troubleshooting between a known-good system and a system under test, characterizing system performance over a range of temperatures, and determining the translation properties of a given section of circuitry.
Understanding Compare Modes

Reference Buffer Compare

This mode compares data from a tool feeding the Compare tool to a data set previously copied to the internal Reference Buffer (see page 14). If several inputs are connected to the Compare tool, you must choose one for comparison with the Reference Buffer.

NOTE:
Time tag information always comes from the incoming data set, never from the Reference Buffer.

Compare Between Two Machines or Labels

This mode compares two data sets, one from each of two input machines, or two labels from a single input. These compare methods do not use the internal Reference Buffer.

NOTE:
If Time tag information is available from each of two input data sets, the time tags will always be taken from the data set displayed on the left.
Chapter 1: Using the Compare Tool

Understanding Compare Modes

Time tags always taken from this dataset

Compare MACHINE 1 to MACHINE 2
Chapter 1: Using the Compare Tool

Configuring the Compare Tool

Configure the Compare tool by dragging icons from the toolbox to the workspace. The following configuration compares subsequent measurements from an analyzer:

The following configuration compares data from two machines, with output for viewing to both the Lister and the Waveform displays:

- You can connect one or more analyzers to the Compare tool input.
- You can connect one or more displays to the Compare tool output. (The Lister and Waveform tools are the most common outputs)
Selecting Data Sets to Compare

The Compare tool does not support Transitional Timing.

With only one input to the Compare tool, the default configuration compares the input to the Reference Buffer. The Compare tool window displays, for example, Compare MACHINE 1 to Reference.

With two inputs to the Compare tool, select each data set for the compare operation as follows:

1. Choose the Primary data set from one of the analyzers connected to the Compare input.
2. Select the Reference data set from one of the following:
   - The same analyzer selected as the primary data set. (You can compare labels within the same data set.)
   - A different analyzer connected to the Compare tool input.
   - The Reference Buffer (see page 32), internal to the Compare tool, which lets you store and edit data from a previously captured data set.
Copying Data to the Reference Buffer

If you select "Reference Buffer" as the reference data set, you must copy a data set to the buffer before comparing. To load the Reference Buffer with a data set from a previous session:

Select [Copy Dataset to Reference Buffer].

- If no data is available at the Compare tool inputs, the Reference Buffer will remain empty. (Check to see if the input tool has run a measurement.)
- If data is available from a previous session of a single analyzer, that data set is copied to the Reference Buffer.
- If more than one data set is available, you will be prompted to select one.

**NOTE:**

The Reference Buffer can contain only one data set at a time.

For more information, see “Setting Reference Buffer Options” on page 32 and “Understanding Compare Modes” on page 10.
Selecting Labels to Compare

Select data set labels to compare in the Compare tool main window. Choose one of the following two methods.

**Method 1: Compare all matching labels**

- This is the default comparison mode.
- Identical labels in each data set will be compared.
- Labels not common to both data sets will be ignored.
- Compare bit masking is not available in this mode.
- Remove a label pair by selecting it in the **Compare Label Pairs** list, then select **Delete**.

**Method 2: Select label pairs**

When you choose **Select label pairs**, a dialog box appears for label selection.

1. Select a label from the left data set list.
2. Select a label from the right data set list.
3. Select \(\rightarrow\) to advance the selected labels to the **Compare Label Pairs** list.
4. Remove a label pair by selecting it in the **Compare Label Pairs** list, then select **Delete**.
5. Append all matching label pairs to the **Compare Label Pairs** list by selecting **All matching**.
6. Remove all label pairs in the **Compare Label Pairs** list by selecting **Clear**.
Chapter 1: Using the Compare Tool

Selecting Labels to Compare

For more information, see “Setting a Compare Mask” on page 43.
Chapter 1: Using the Compare Tool

Adjusting Data Set Alignment

Adjusting Data Set Alignment

The alignment point is the location in each data set where the compare process begins. The default alignment is the trigger location of each data set. If you want to establish a different alignment point for either data set, select Align Controls... from the main Compare dialog box.

**NOTE:**

Alignment of data sets when comparing is only available for data sets containing time tags. This includes Timing data sets and State data sets with time tags activated in the Trigger menu.

The available Alignment options are described below.

**Trigger (default)**

The compare process begins at the trigger point in the data set. Use this method to compare two data sets captured with an identical trigger spec.

```
Align "MACHINE 1" Labels at Trigger
with Reference Labels at Trigger
```

**State Number**

The compare process begins at an absolute state number in the data set. Use this method if you know the exact state number you want to analyze.

```
Align "MACHINE 1" Labels at State No. = 5
with Reference Labels at State No. = 5
```
Chapter 1: Using the Compare Tool

Adjusting Data Set Alignment

**Time**

The compare process begins at the time offset in each data set. Advancing or delaying one data set with respect to the other can help to minimize skew which may interfere with the accuracy of difference measurements.
Chapter 1: Using the Compare Tool

Executing the Compare

Once you have specified the data set, label pairs, and alignment options, initiate the compare process from any of the Compare tool dialog boxes by selecting Execute Compare.

The results of the compare will appear in the display device connected to the Compare tool output (usually a Lister or Waveform tool).

NOTE:
When Compare parameters are set up, selecting the Run icon or the Run All icon will execute the compare. When you change parameters such as alignment, range, or the contents of the reference buffer, you only need to select Execute Compare to execute another compare operation.

Additional Compare options:

- “Setting Timing Edge Tolerance” on page 22
- “Setting Display Options” on page 25
- “Adjusting the Range of Data to be Compared” on page 26
Chapter 1: Using the Compare Tool

Viewing Compare Tool Output

To view the results of a compare, connect a display device such as Lister or Waveform to the Compare tool output.

In the Lister and Waveform windows below:

- The Compare tool provides a DiffFlag label which displays a value of "1" for differences and "0" otherwise.
- Actual differences are highlighted in the listing or waveform.
- Marker G1 is set up to find the second difference from the beginning of the data.

![Compare Output in Lister](image-url)
Chapter 1: Using the Compare Tool

Viewing Compare Tool Output

**Compare Output in Waveform**

For more information, see “Finding Compare Differences” on page 28.

The color of the highlighted differences are controlled by the tool used for viewing. To change the color of highlighted differences in the Lister tool:

1. Choose *Set default attributes* from the *Edit* menu in the Lister tool.
2. Select the desired highlight color, then select OK.
3. Because these settings only affect new labels, do one of the following:
   - Delete all labels by right selecting each one and choosing *Delete*, then execute the compare again. This will display all labels again with the new highlight setting.
   - Select each label you want to display the new color and choose *Replace*, then select OK in the Label Selection dialog box.
Chapter 1: Using the Compare Tool

Setting Timing Edge Tolerance

When both data sets being compared were captured as timing measurements, edge jitter may have caused the Compare tool to report a false difference.

You can avoid these false differences due to signal edge jitter by specifying a *Timing Edge Tolerance*.

Select **Timing Controls...** in the main Compare dialog box to enter a value:

![Timing Edge Tolerance](image)

Setting *Timing Edge Tolerance* causes the Compare tool to ignore differences that occur within the tolerance band at each edge in the data (plus-or-minus X ns). Set the tolerance values to a multiple of the current sampling period.

![Waveform Being Compared](image)

This sample trace shows a valid difference and a difference due to slight jitter between two signals:

![Sample Trace](image)

Now, set *Timing Edge Tolerance* to one sample width:
Chapter 1: Using the Compare Tool

Setting Timing Edge Tolerance

The difference due to edge jitter is filtered out, and the actual difference remains:

The timing edge tolerance setting is ignored in the case of non-Timing data sets.

Getting Good Results

To get good results when comparing timing measurements, the following conditions must be satisfied:

- The logic analyzer(s) used to capture the timing measurements should sample at a fast enough sample rate to minimize measurement induced jitter, but slow enough to provide sufficient captured data.

- The two data sets being compared should be sufficiently de-skewed. Use the Alignment Controls (see page 17) to advance or delay the alignment point of one of the data sets so that any accumulated skew is minimized.

- Specify an appropriate amount of timing edge tolerance to compensate for the measurement induced jitter, as well as the inherent jitter from the target hardware.

- If the timing edge tolerance is too small, some or all of the jitter in the data could be marked as differences.

- If the timing edge tolerance is too large, some valid differences could
Chapter 1: Using the Compare Tool

Setting Timing Edge Tolerance

be filtered out as jitter.

Timing Compare Limitations

- In the interest of not having "false positive" differences, samples at the beginning and end of the data may not show differences. At the endpoints, the timing comparator may not have sufficient information to filter out differences. The range of data affected by this will not exceed a span of time equal to the timing edge tolerance specification.

- Pulses in the data with pulse widths shorter than the edge tolerance value will be filtered out.

NOTE: When comparing two timing data sets, both data sets must be captured at the same sample period for an accurate compare.
Setting Display Options

You can customize the Compare tool's output with the Display menu, which is located on the Options menu.

- In the diagram below, the default is *All samples*, which displays all the data with differences highlighted.
- Display only the data matches by selecting *Only matches*.
- Display only the data differences by selecting *Only differences*.

![Diagram showing Display menu options]

**Chapter 1: Using the Compare Tool**

**Setting Display Options**
Adjusting the Range of Data to be Compared

Customize the range of data to be compared by selecting Compare Range... on the Features menu.

Full Compare Range

The default Compare range is Full, which compares all data in the data sets. If the data sets are not the same size, the compare will stop when the smaller data set is fully compared.

Partial/Sample Compare Range

To restrict the compare to a specific range of samples, select Partial/Sample in the Compare Range field.

- Enter beginning and ending states for the compare.

Partial/Time Compare Range

If time tags are available in the data sets being compared, restrict the compare to a specific range of time by selecting Partial/Time in the Compare Range field.
(This selection is inactive if time tags are not present in the data set.)

- Set time values for the beginning and end of the compare.

Sample Window Compare Range

To compare data around a specific location in sample memory, select Sample Window in the Compare Range field.

1. Enter the number of states you want to compare.
2. Select the reference method: Before, About, or After the alignment point.
(The alignment point is set to Trigger, State Number, or Time in the Align Controls... (see page 17) dialog box.)

| Compare Range | Sample Window | 0s | States | Before | Alignment |

**Time Window Compare Range**

If time tags are available in the data sets being compared, set a time window of data to compare by selecting *Time Window* in the Compare Range field.

(This selection is inactive if time tags are not present in the data set)

1. Enter the amount of time you are interested in comparing.

2. Select the reference method: Before, About, or After the alignment point.

| Compare Range | Time Window | 0 | States | Before | Alignment |

---

27
Finding Compare Differences

Finding Differences Using Search

Use the Search tab in the Listing or Waveform tool to quickly locate differences that are output from the Compare tool.

1. Select the Search tab.

2. Select the "DiffFlag" label.

3. Enter "Value 1 when Present".

4. Select "Next" to center the next available difference in the Listing tool window.

Selections "when Entering" and "when Exiting" can be used to locate the beginning and end of contiguous blocks of differences.

Displaying Only Differences

To display only the data differences in the output viewing tool, select Display-Only Differences from the Options menu. All rows that contain at least one difference will be shown, while all rows that do not
contain a difference will not be shown. This feature may be used to get a compressed view of all the differences.

**NOTE:**

*Display Only Differences* is set in the Compare tool, however the results are shown in the Waveform or Lister tool.

**Using Markers**

In addition to the Search tab described above, differences can be located in a display tool using Markers (see page 29).

**Finding Differences Using Markers**

The Compare tool output generates a *DiffFlag* label which contains a value of "1" if any difference is found, and "0" otherwise. Use Markers (see the *Markers* help volume) to locate data set differences in a display tool.

To set up a marker with a term that looks for the pattern "1" in the DiffFlag label:

1. In the Lister or Waveform window, select a marker to view the Marker Setup dialog.

2. Select "Pattern" in field 2.

3. Select *Define...* to view the Marker Pattern dialog box.
Chapter 1: Using the Compare Tool

Finding Compare Differences

- In the Marker Pattern dialog box, select field 2, then select Replace Label.
- In the Label Selection dialog box, select DiffFlag then Apply.

Select Pattern in field 4 of the Search Terms dialog box, then enter "1" for the pattern value.

In the Markers Setup dialog, specify the desired difference event in the occurs field. For example, to find the third difference in the Compare tool output, select occurs 3 from Trigger.

Once the marker is set up to find a difference, select the Lister or Waveform to go to the marker.

Using this method, you can find specific difference events by choosing When Present in the Pattern qualify selector of the Marker Pattern dialog box.
Also, you can quickly locate successive blocks of differences by choosing *When entering* in the *Pattern qualify* selector. As the *occurs* field is incremented, the marker moves to the beginning of the next block of differences. This method may be most useful in Timing mode.

Using markers to view differences will only work properly when *Display All samples* is in effect.
Setting Reference Buffer Options

You can edit a data set that has been copied to the Reference Buffer before performing a compare. To view or edit Reference Buffer data:

Select View/Edit Reference Buffer...

- “Adjusting the View of Reference Buffer Data” on page 33
- “Modifying Reference Buffer Data” on page 34
- “Editing Lines and Labels in the Reference Buffer” on page 36
- “Customizing the Reference Buffer Display” on page 37
- “Saving the Compare Reference to a File” on page 35
Chapter 1: Using the Compare Tool

Adjusting the View of Reference Buffer Data

To customize viewing of the reference buffer data:

1. Position data in the window with the horizontal and vertical scroll bars.
2. Relocate existing labels by selecting and dragging to a new position.
3. Change the base of displayed data by selecting the base field.
4. Insert, replace, or delete labels by selecting an existing label and selecting an option from the pop-up menu.
5. Change the color of displayed data by selecting an existing label and selecting Change Color... from the pop-up menu.
6. Search for a label that is not visible by selecting an existing label and selecting Find Label... from the pop-up menu.

For more information, see “Editing Lines and Labels in the Reference Buffer” on page 36.
Modifying Reference Buffer Data

1. Place the underscore cursor on a data value, then enter a new value. Only values appropriate for the currently selected base will be accepted. You can enter "X" in any data position as a "wildcard" value. (Movement of the cursor between data fields is controlled by the Cursor Wrap (see page 37) feature.)

2. Insert a new line of zeroed data, or delete an existing line, by highlighting a data line, and selecting an option from the pop-up menu.

3. Move to a specific data line by selecting anywhere in the Reference Buffer window and selecting Goto Line from the pop-up menu.

4. If you want to change the trigger point of the data set in the Reference Buffer, select the desired data line and select Set Trigger from the pop-up menu. The current line is reset to Line 0, and all data lines are renumbered appropriately.
Saving the Compare Reference to a File

To save the contents of the Reference Buffer to an ASCII file, do the following:

1. From the Reference Buffer edit window, select Print Compare Reference to File from the File menu.
2. Select All labels or a Selected subset.
3. Select a data range of All or Partial from state_number to state_number.
4. Select a destination file. Select File... to navigate the file system.
5. Enter a file description, if desired. Text entered into the File Description box will appear at the top of the saved file.
6. Select Save.
Chapter 1: Using the Compare Tool

Editing Lines and Labels in the Reference Buffer

To edit lines of data in the Reference Buffer using the *Edit* menu:

- Highlight the data lines, then select *Cut Line(s)* and *Copy Line(s)* from the file menu to place them into the internal cut/paste buffer.

- Use *Paste Line(s)* to retrieve lines from the cut/paste buffer and place them after the current cursor position.

- Use *Delete All Lines* to erase the contents of the Reference Buffer.

To add a label to the current display in the Reference Buffer:

- Select *Append Label...* from the *Edit* menu, then select a label to append from the displayed list.

To insert or delete all labels in the data set:

- Select *Insert All Labels* or *Delete All Labels* from the *Edit* menu.

![Screenshot of the Compare Tool interface showing the Edit menu options and the Reference Buffer.]
Customizing the Reference Buffer Display

To change the font size of the data displayed in the Reference Buffer edit window, select Options, then Font, then the desired font size from the menus.

You can customize cursor movement for modifying data in the Reference Buffer.

- To modify the same line of data across all labels, select Cursor Wrap, then Line from the Options menu. The cursor will move horizontally to the right, and from the rightmost label field to the leftmost label of the following data line.

- To modify a single column of data, select Cursor Wrap, then Column from the Options menu. The cursor will move down to the next data line.

To change the color of data displayed in the Reference Buffer, select Default Label Color... from the Options menu. The color change will not affect existing labels, but will affect the data under new labels added to the Reference Buffer.

**NOTE:** Changing the color of data in the Reference Buffer does not affect the color of data displayed in an output tool.
Adjusting Which Labels are Displayed

Normally, all labels in each data set being compared are passed to the output display tool, even if the labels are not involved in the compare operation.

To restrict the Compare tool output to only those labels currently being compared, select *Pass through Labels*, then *Only Compared Labels* from the Options menu.

For more information, see “Selecting Labels to Compare” on page 15.
Loading and Saving Compare Configurations

Compare tool settings can be saved to a configuration file along with the tools connected to it, and loaded from a previously saved configuration file. In addition to all Compare tool settings, the Reference Buffer is saved within a configuration file.

- Loading Configuration Files (see the Agilent Technologies 16700A/B-Series Logic Analysis System help volume)
- Saving Configuration Files (see the Agilent Technologies 16700A/B-Series Logic Analysis System help volume)

**NOTE:**
The *Load Configuration* window can be accessed via File->Load Configuration.
The *Save Configuration* window can be accessed via File->Save Configuration.
Stopping Repetitive Analyzer Measurements

When one or more tools are connected on the workspace and running repetitively, the Compare tool can stop the repetitive measurement when certain compare conditions are met.

To stop a repetitive measurement, select *Stop Conditions*... from the *Features* menu.

- **Disabled** - The Compare tool will not stop a repetitive measurement.
- **When Equal** - The measurement stops when the primary and reference data sets are equal. The output without differences is displayed.
- **When Not Equal** - The measurement stops when the primary and reference data sets encounter a difference. The output with differences is displayed.
- **When Exceeding** - The measurement stops when the number of differences exceeds a user-specified value. The output with differences is displayed.
- **When Below** - The measurement stops when the number of differences is below a user-specified threshold. The output with differences is displayed.

<table>
<thead>
<tr>
<th>Stop Repetitive Measurement</th>
<th>Disabled</th>
<th>When Equal</th>
<th>When Not Equal</th>
<th>When Exceeding</th>
<th>When Below</th>
</tr>
</thead>
<tbody>
<tr>
<td>Terminate Compare Disabled</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Terminate Compare after</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**NOTE:**
The Terminate Compare (see page 41) choices are not related to the *Stop Repetitive Measurement* selections.
Terminating a Compare

To terminate a compare operation after a user-specified number of differences have been encountered, enter a number in the Terminate Compare selection field of the Specify Stop Conditions dialog box.

Terminating a compare may be useful when:

- You want to minimize the time to complete the compare.
- You are comparing large data sets and only the first few differences are important for viewing.
Chapter 1: Using the Compare Tool

Logging Comments

To enter comments in a free-form text field, select *Show comments*, then *On* from the Options menu.

- Comments are saved in a compare configuration file.
- You can resize the comments window using the small handle in the bottom-right corner.
- You can erase all existing comments by selecting *Show comments*, then *Clear text* from the Options menu.
Setting a Compare Mask

When you operate in the *Select Label Pairs* mode, the *Compare Label Pairs* list allows you to mask data bits. Masked bits are ignored during the compare operation.

1. Select *Compare Mask* to display a mask dialog box for the currently selected label pair.
2. Select the bit fields to activate or deactivate for compare.
   - Bits are activated using the "*" (asterisk) character.
   - Bits are deactivated using the "." (period) character.

If a mask is active for a label pair, the text (*masked*) will appear next to the label pair in the Compare Labels Pairs list.

To remove label pair masking, you must reactivate the inactive bits, or delete and reinstall the label pair.

**NOTE:**

In the compare mask window, if you select *Apply* the mask changes are stored and the next label pair is displayed for editing.
Sample Compare Tool Applications

Comparing With a Known-Good Circuit

You can use the Compare tool to debug a broken circuit by comparing the captured data with data from a known-good circuit. The difference between the known-good circuit and the problem circuit may help you determine why the problem circuit is failing.

1. Connect the known-good circuit, set up a format and trigger specification, and capture the desired data set.

2. Add the Compare tool to your analyzer configuration and copy the known-good data set to the Reference Buffer.

3. Connect the problem circuit, capture a data set, and execute a compare.

Determining Component Stress Behavior

Occasionally, a circuit will operate correctly at normal ambient temperature, and begin to fail when the temperature is raised or lowered. You can use the Compare tool to determine temperature-related failure modes.

1. Connect the circuit at normal temperature, set up a format and trigger specification, and capture the desired data set.

2. Add the Compare tool to your analyzer configuration and copy the normal temperature data set to the Reference Buffer.

3. Set up the analyzer/compare configuration for a repetitive run with the Compare tool termination conditions set to stop the measurement when a data set difference is found.

4. Begin raising or lowering the temperature of the circuit under test.

5. When the Compare tool finds a difference, the repetitive measurement will stop, and you can note the temperature conditions and the nature of the differences.

Comparing Inputs and Outputs

Progressive evaluation of signals within a section of circuitry can help
you to identify the source of a problem. If certain signals are intended to change, and others are intended to remain the same at different points in a circuit, you can use the Compare tool to verify the signal flow.

1. Connect the analyzer to the input signals of the section of circuitry under test, set up a format and trigger specification, and capture the desired data set.

2. Add the Compare tool to your analyzer configuration and copy the input signal data set to the Reference Buffer.

3. Reconnect the analyzer to a section of circuitry farther along the signal path.

4. Take another measurement and compare the new data set with the input signal data set saved in the Reference Buffer.

5. Note whether the signals that are identical and those that are different agree with the design intent.

**NOTE:** You may want to save the Compare tool configuration (which includes the reference buffer) for future reference.
Chapter 1: Using the Compare Tool

Printing Compare Results

The following print features are available with the Compare tool:

- To print the current contents of a Compare window, select *Print this window* from the main File menu.

- To print the contents of the Reference Buffer, select Print Compare Reference To File (see page 35) from the Reference Buffer File menu.

- To set up a system printer, select Print Options (see the *Agilent Technologies 16700A/B-Series Logic Analysis System* help volume) from the main File menu.
absolute  Denotes the time period or count of states between a captured state and the trigger state. An absolute count of -10 indicates the state was captured ten states before the trigger state was captured.

acquisition  Denotes one complete cycle of data gathering by a measurement module. For example, if you are using an analyzer with 128K memory depth, one complete acquisition will capture and store 128K states in acquisition memory.

analysis probe  A probe connected to a microprocessor or standard bus in the device under test. An analysis probe provides an interface between the signals of the microprocessor or standard bus and the inputs of the logic analyzer. Also called a preprocessor.

asterisk (*)  See edge terms, glitch, and labels.

bits  Bits represent the physical logic analyzer channels. A bit is a channel that has or can be assigned to a label. A bit is also a position in a label.

card  This refers to a single instrument intended for use in the Agilent Technologies 16700A/B-series mainframes. One card fills one slot in the mainframe. A module may comprise a single card or multiple cards cabled together.

channel  The entire signal path from the probe tip, through the cable and module, up to the label grouping.

click  When using a mouse as the
pointing device, to click an item, position the cursor over the item. Then quickly press and release the left mouse button.

clock channel  A logic analyzer channel that can be used to carry the clock signal. When it is not needed for clock signals, it can be used as a data channel, except in the Agilent Technologies 16517A.

category record  A context record is a small segment of analyzer memory that stores an event of interest along with the states that immediately preceded it and the states that immediately followed it.

category store  If your analyzer can perform context store measurements, you will see a button labeled Context Store under the Trigger tab. Typical context store measurements are used to capture writes to a variable or calls to a subroutine, along with the activity preceding and following the events. A context store measurement divides analyzer memory into a series of context records. If you have a 64K analyzer memory and select a 16-state context, the analyzer memory is divided into 4K 16-state context records. If you have a 64K analyzer memory and select a 64-state context, the analyzer memory will be divided into 1K 64-state records.

count  The count function records periods of time or numbers of state transactions between states stored in memory. You can set up the analyzer count function to count occurrences of a selected event during the trace, such as counting how many times a variable is read between each of the writes to the variable. The analyzer can also be set up to count elapsed time, such as counting the time spent executing within a particular function during a run of your target program.

cross triggering  Using intermodule capabilities to have measurement modules trigger each other. For example, you can have an external instrument arm a logic analyzer, which subsequently triggers an oscilloscope when it finds the trigger state.

data channel  A channel that carries data. Data channels cannot be used to clock logic analyzers.

data field  A data field in the pattern generator is the data value associated with a single label within a particular data vector.

data set  A data set is made up of all labels and data stored in memory of any single analyzer machine or
instrument tool. Multiple data sets can be displayed together when sourced into a single display tool. The Filter tool is used to pass on partial data sets to analysis or display tools.

debug mode  See monitor.

delay  The delay function sets the horizontal position of the waveform on the screen for the oscilloscope and timing analyzer. Delay time is measured from the trigger point in seconds or states.

demo mode  An emulation control session which is not connected to a real target system. All windows can be viewed, but the data displayed is simulated. To start demo mode, select Start User Session from the Emulation Control Interface and enter the demo name in the Processor Probe LAN Name field. Select the Help button in the Start User Session window for details.

deskewing  To cancel or nullify the effects of differences between two different internal delay paths for a signal. Deskewing is normally done by routing a single test signal to the inputs of two different modules, then adjusting the Intermodule Skew so that both modules recognize the signal at the same time.

device under test  The system under test, which contains the circuitry you are probing. Also known as a target system.

don't care  For terms, a "don't care" means that the state of the signal (high or low) is not relevant to the measurement. The analyzer ignores the state of this signal when determining whether a match occurs on an input label. "Don't care" signals are still sampled and their values can be displayed with the rest of the data. Don't cares are represented by the X character in numeric values and the dot (.) in timing edge specifications.

dot (.)  See edge terms, glitch, labels, and don't care.

double-click  When using a mouse as the pointing device, to double-click an item, position the cursor over the item, and then quickly press and release the left mouse button twice.

drag and drop  Using a Mouse: Position the cursor over the item, and then press and hold the left mouse button. While holding the left mouse button down, move the mouse to drag the item to a new location. When the item is positioned where you want it, release the mouse button.
Glossary

Using the Touchscreen:
Position your finger over the item, then press and hold finger to the screen. While holding the finger down, slide the finger along the screen dragging the item to a new location. When the item is positioned where you want it, release your finger.

**edge mode** In an oscilloscope, this is the trigger mode that causes a trigger based on a single channel edge, either rising or falling.

**edge terms** Logic analyzer trigger resources that allow detection of transitions on a signal. An edge term can be set to detect a rising edge, falling edge, or either edge. Some logic analyzers can also detect no edge or a *glitch* on an input signal. Edges are specified by selecting arrows. The dot (.) ignores the bit. The asterisk (*) specifies a glitch on the bit.

**emulation module** A module within the logic analysis system mainframe that provides an emulation connection to the debug port of a microprocessor. An E5901A emulation module is used with a target interface module (TIM) or an analysis probe. An E5901B emulation module is used with an E5900A emulation probe.

**emulation probe** The stand-alone equivalent of an *emulation module*. Most of the tasks which can be performed using an emulation module can also be performed using an emulation probe connected to your logic analysis system via a LAN.

**emulator** An *emulation module* or an *emulation probe*.

**Ethernet address** See *link-level address*.

**events** Events are the things you are looking for in your target system. In the logic analyzer interface, they take a single line. Examples of events are \texttt{Label1 = XX} and \texttt{Timer 1 > 400}\texttt{\, ns}.

**filter expression** The filter expression is the logical OR combination of all of the filter terms. States in your data that match the filter expression can be filtered out or passed through the Pattern Filter.

**filter term** A variable that you define in order to specify which states to filter out or pass through. Filter terms are logically OR’ed together to create the filter expression.

**Format** The selections under the logic analyzer *Format* tab tell the
logic analyzer what data you want to collect, such as which channels represent buses (labels) and what logic threshold your signals use.

**frame**  The Agilent Technologies or 16700A/B-series logic analysis system mainframe. See also logic analysis system.

**gateway address**  An IP address entered in integer dot notation. The default gateway address is 0.0.0.0, which allows all connections on the local network or subnet. If connections are to be made across networks or subnets, this address must be set to the address of the gateway machine.

**glitch**  A glitch occurs when two or more transitions cross the logic threshold between consecutive timing analyzer samples. You can specify glitch detection by choosing the asterisk (*) for edge terms under the timing analyzer Trigger tab.

**grouped event**  A grouped event is a list of events that you have grouped, and optionally named. It can be reused in other trigger sequence levels. Only available in Agilent Technologies 16715A or higher logic analyzers.

**held value**  A value that is held until the next sample. A held value can exist in multiple data sets.

**immediate mode**  In an oscilloscope, the trigger mode that does not require a specific trigger condition such as an edge or a pattern. Use immediate mode when the oscilloscope is armed by another instrument.

**interconnect cable**  Short name for module/probe interconnect cable.

**intermodule bus**  The intermodule bus (IMB) is a bus in the frame that allows the measurement modules to communicate with each other. Using the IMB, you can set up one instrument to arm another. Data acquired by instruments using the IMB is time-correlated.

**intermodule**  Intermodule is a term used when multiple instrument tools are connected together for the purpose of one instrument arming another. In such a configuration, an arming tree is developed and the group run function is designated to start all instrument tools. Multiple instrument configurations are done in the Intermodule window.

**internet address**  Also called Internet Protocol address or IP address. A 32-bit network address. It
Glossary

is usually represented as decimal numbers separated by periods; for example, 192.35.12.6. Ask your LAN administrator if you need an internet address.

labels Labels are used to group and identify logic analyzer channels. A label consists of a name and an associated bit or group of bits. Labels are created in the Format tab.

line numbers A line number (Line #s) is a special use of symbols. Line numbers represent lines in your source file, typically lines that have no unique symbols defined to represent them.

link-level address Also referred to as the Ethernet address, this is the unique address of the LAN interface. This value is set at the factory and cannot be changed. The link-level address of a particular piece of equipment is often printed on a label above the LAN connector. An example of a link-level address in hexadecimal: 0800090012AB.

local session A local session is when you run the logic analysis system using the local display connected to the product hardware.

logic analysis system The Agilent Technologies 16700A/B-series mainframes, and all tools designed to work with it. Usually used to mean the specific system and tools you are working with right now.

machine Some logic analyzers allow you to set up two measurements at the same time. Each measurement is handled by a different machine. This is represented in the Workspace window by two icons, differentiated by a 1 and a 2 in the upper right-hand corner of the icon. Logic analyzer resources such as pods and trigger terms cannot be shared by the machines.

markers Markers are the green and yellow lines in the display that are labeled x, o, G1, and G2. Use them to measure time intervals or sample intervals. Markers are assigned to patterns in order to find patterns or track sequences of states in the data. The x and o markers are local to the immediate display, while G1 and G2 are global between time correlated displays.

master card In a module, the master card controls the data acquisition or output. The logic analysis system references the module by the slot in which the master card is plugged. For example, a 5-card Agilent Technologies 16555D would be referred to as Slot C:
machine} because the master card is in slot C of the mainframe. The other cards of the module are called {expansion cards}.

**menu bar** The menu bar is located at the top of all windows. Use it to select {File} operations, tool or system {Options}, and tool or system level {Help}.

**message bar** The message bar displays mouse button functions for the window area or field directly beneath the mouse cursor. Use the mouse and message bar together to prompt yourself to functions and shortcuts.

**module/probe interconnect cable**
The module/probe interconnect cable connects an E5901B emulation module to an E5900B emulation probe. It provides power and a serial connection. A LAN connection is also required to use the emulation probe.

**module** An instrument that uses a single timebase in its operation. Modules can have from one to five cards functioning as a single instrument. When a module has more than one card, system window will show the instrument icon in the slot of the {master card}.

**monitor** When using the Emulation Control Interface, running the monitor means the processor is in debug mode (that is, executing the debug exception) instead of executing the user program.

**panning** The action of moving the waveform along the timebase by varying the delay value in the Delay field. This action allows you to control the portion of acquisition memory that will be displayed on the screen.

**pattern mode** In an oscilloscope, the trigger mode that allows you to set the oscilloscope to trigger on a specified combination of input signal levels.

**pattern terms** Logic analyzer resources that represent single states to be found on labeled sets of bits; for example, an address on the address bus or a status on the status lines.

**period (.)** See {edge terms}, {glitch}, {labels}, and {don't care}.

**pod pair** A group of two pods containing 16 channels each, used to physically connect data and clock signals from the unit under test to the analyzer. Pods are assigned by pairs in the analyzer interface. The number of pod pairs available is determined.
Glossary

by the channel width of the instrument.

**pod**  See *pod pair*.

**point**  To point to an item, move the mouse cursor over the item, or position your finger over the item.

**preprocessor**  See *analysis probe*.

**primary branch**  The primary branch is indicated in the *Trigger sequence step* dialog box as either the *Then find* or *Trigger on* selection. The destination of the primary branch is always the next state in the sequence, except for the Agilent Technologies 16517A. The primary branch has an optional occurrence count field that can be used to count a number of occurrences of the branch condition. See also *secondary branch*.

**probe**  A device to connect the various instruments of the logic analysis system to the target system. There are many types of probes and the one you should use depends on the instrument and your data requirements. As a verb, "to probe" means to attach a probe to the target system.

**processor probe**  See *emulation probe*.

**range terms**  Logic analyzer resources that represent ranges of values to be found on labeled sets of bits. For example, range terms could identify a range of addresses to be found on the address bus or a range of data values to be found on the data bus. In the trigger sequence, range terms are considered to be true when any value within the range occurs.

**relative**  Denotes time period or count of states between the current state and the previous state.

**remote display**  A remote display is a display other than the one connected to the product hardware. Remote displays must be identified to the network through an address location.

**remote session**  A remote session is when you run the logic analyzer using a display that is located away from the product hardware.

**right-click**  When using a mouse for a pointing device, to right-click an item, position the cursor over the item, and then quickly press and release the right mouse button.

**sample**  A data sample is a portion of a data set, sometimes just one point. When an instrument samples the target system, it is taking a single...
measurement as part of its data acquisition cycle.

**Sampling** Use the selections under the logic analyzer Sampling tab to tell the logic analyzer how you want to make measurements, such as State vs. Timing.

**Secondary branch** The secondary branch is indicated in the Trigger sequence step dialog box as the Else on selection. The destination of the secondary branch can be specified as any other active sequence state. See also primary branch.

**Session** A session begins when you start a local session or remote session from the session manager, and ends when you select Exit from the main window. Exiting a session returns all tools to their initial configurations.

**Skew** Skew is the difference in channel delays between measurement channels. Typically, skew between modules is caused by differences in designs of measurement channels, and differences in characteristics of the electronic components within those channels. You should adjust measurement modules to eliminate as much skew as possible so that it does not affect the accuracy of your measurements.

**State measurement** In a state measurement, the logic analyzer is clocked by a signal from the system under test. Each time the clock signal becomes valid, the analyzer samples data from the system under test. Since the analyzer is clocked by the system, state measurements are synchronous with the test system.

**Store qualification** Store qualification is only available in a state measurement, not timing measurements. Store qualification allows you to specify the type of information (all samples, no samples, or selected states) to be stored in memory. Use store qualification to prevent memory from being filled with unwanted activity such as no-ops or wait-loops. To set up store qualification, use the While storing field in a logic analyzer trigger sequence dialog.

**Subnet mask** A subnet mask blocks out part of an IP address so that the networking software can determine whether the destination host is on a local or remote network. It is usually represented as decimal numbers separated by periods; for example, 255.255.255.0. Ask your LAN administrator if you need a the subnet mask for your network.
symbols Symbols represent patterns and ranges of values found on labeled sets of bits. Two kinds of symbols are available:

- Object file symbols - Symbols from your source code, and symbols generated by your compiler. Object file symbols may represent global variables, functions, labels, and source line numbers.

- User-defined symbols - Symbols you create.

Symbols can be used as pattern and range terms for:

- Searches in the listing display.
- Triggering in logic analyzers and in the source correlation trigger setup.
- Qualifying data in the filter tool and system performance analysis tool set.

system administrator The system administrator is a person who manages your system, taking care of such tasks as adding peripheral devices, adding new users, and doing system backup. In general, the system administrator is the person you go to with questions about implementing your software.

target system The system under test, which contains the microprocessor you are probing.

terms Terms are variables that can be used in trigger sequences. A term can be a single value on a label or set of labels, any value within a range of values on a label or set of labels, or a glitch or edge transition on bits within a label or set of labels.

TIM A TIM (Target Interface Module) makes connections between the cable from the emulation module or emulation probe and the cable to the debug port on the system under test.

time-correlated Time correlated measurements are measurements involving more than one instrument in which all instruments have a common time or trigger reference.

timer terms Logic analyzer resources that are used to measure the time the trigger sequence remains within one sequence step, or a set of sequence steps. Timers can be used to detect when a condition lasts too long or not long enough. They can be used to measure pulse duration, or duration of a wait loop. A single timer term can be used to delay trigger until a period of time after detection of a significant event.
Glossary

**timing measurement**  In a timing measurement, the logic analyzer samples data at regular intervals according to a clock signal internal to the timing analyzer. Since the analyzer is clocked by a signal that is not related to the system under test, timing measurements capture traces of electrical activity over time. These measurements are *asynchronous* with the test system.

**tool icon**  Tool icons that appear in the workspace are representations of the hardware and software tools selected from the toolbox. If they are placed directly over a current measurement, the tools automatically connect to that measurement. If they are placed on an open area of the main window, you must connect them to a measurement using the mouse.

**toolbox**  The Toolbox is located on the left side of the main window. It is used to display the available hardware and software tools. As you add new tools to your system, their icons will appear in the Toolbox.

**tools**  A tool is a stand-alone piece of functionality. A tool can be an instrument that acquires data, a display for viewing data, or a post-processing analysis helper. Tools are represented as icons in the main window of the interface.

**trace**  See *acquisition*.

**trigger sequence**  A trigger sequence is a sequence of events that you specify. The logic analyzer compares this sequence with the samples it is collecting to determine when to *trigger*.

**trigger specification**  A trigger specification is a set of conditions that must be true before the instrument triggers.

**trigger**  Trigger is an event that occurs immediately after the instrument recognizes a match between the incoming data and the trigger specification. Once trigger occurs, the instrument completes its *acquisition*, including any store qualification that may be specified.

**workspace**  The workspace is the large area under the message bar and to the right of the toolbox. The workspace is where you place the different instrument, display, and analysis tools. Once in the workspace, the tool icons graphically represent a complete picture of the measurements.

**zooming**  In the oscilloscope or timing analyzer, to expand and contract the waveform along the time base by varying the value in the s/Div
field. This action allows you to select specific portions of a particular waveform in acquisition memory that will be displayed on the screen. You can view any portion of the waveform record in acquisition memory.
## Index

<table>
<thead>
<tr>
<th>A</th>
<th>alignment, of compare, 17</th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td>color, of differences, 21</td>
</tr>
<tr>
<td></td>
<td>compare output, viewing, 20</td>
</tr>
<tr>
<td></td>
<td>compare reference buffer, copying to, 14</td>
</tr>
<tr>
<td></td>
<td>compare tool, 2</td>
</tr>
<tr>
<td></td>
<td>compare tool applications, 44</td>
</tr>
<tr>
<td></td>
<td>compare tool uses, 44</td>
</tr>
<tr>
<td></td>
<td>compare tool, configuring, 12</td>
</tr>
<tr>
<td></td>
<td>compare tool, overview, 8</td>
</tr>
<tr>
<td></td>
<td>compare, executing a, 19</td>
</tr>
<tr>
<td>D</td>
<td>data sets, selecting for compare, 13</td>
</tr>
<tr>
<td></td>
<td>differences, finding in Compare, 28</td>
</tr>
<tr>
<td>H</td>
<td>highlight, color of differences, 21</td>
</tr>
<tr>
<td>J</td>
<td>jitter, adjusting for in compare, 22</td>
</tr>
<tr>
<td>L</td>
<td>labels, selecting for compare, 15</td>
</tr>
<tr>
<td>M</td>
<td>main system help page, 3</td>
</tr>
<tr>
<td></td>
<td>markers, for viewing Compare diffs, 28</td>
</tr>
<tr>
<td></td>
<td>masking, compare labels, 43</td>
</tr>
<tr>
<td></td>
<td>modes, of compare, 10</td>
</tr>
<tr>
<td>P</td>
<td>printing, compare tool, 46</td>
</tr>
<tr>
<td>R</td>
<td>range, of compare, 26</td>
</tr>
<tr>
<td></td>
<td>reference buffer compare mode, 10</td>
</tr>
<tr>
<td></td>
<td>reference buffer, using in compare tool, 32</td>
</tr>
<tr>
<td></td>
<td>repetitive measurement, stopping, 40</td>
</tr>
<tr>
<td>S</td>
<td>saving compare configurations, 39</td>
</tr>
<tr>
<td>T</td>
<td>terminating, a compare, 41</td>
</tr>
<tr>
<td></td>
<td>timing edge tolerance, setting, 22</td>
</tr>
</tbody>
</table>

---

59
Index