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FUTURE EDITIONS. FURTHER, TO 

THE MAXIMUM EXTENT PERMITTED 

BY APPLICABLE LAW, KEYSIGHT 

DISCLAIMS ALL WARRANTIES, EI-  

THER EXPRESS OR IMPLIED, WITH 

REGARD TO THIS MANUAL AND 

ANY INFORMATION CONTAINED 
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A CAUTION notice denotes a hazard. 

It calls attention to an operating 

procedure, practice, or the like that, 

if not correctly performed or adhered 

to, could result in damage to the 

product or loss of important data. Do 

not proceed beyond a CAUTION 

notice until the indicated conditions 

are fully understood and met. 
 

 
 

 
A WARNING notice denotes a haz-  

ard. It calls attention to an operating 

procedure, practice, or the like that, 

if not correctly performed or adhered 

to, could result in personal injury or 

death. Do not proceed beyond a 

WARNING notice until the indicated 

conditions are fully understood and 

met. 

CAUTION 

WARNING 

 

http://www.keysight.com/find/sweula
http://www.keysight.com/find/sweula


 

 

Safety Summary 

 

General Safety 

Precautions 
 

 

The following general safety precautions must be observed during all phases of 

operation of this instrument. Failure to comply with these precautions or with 

specific warnings elsewhere in this manual violates safety standards of design, 

manufacture, and intended use of the instrument. For safe operation the general 

safety precautions for the M9502A and M9505A AXIe chassis, must be followed. 

See: http://www.keysight.com/find/M9505A  Keysight Technologies Inc. assumes 

no liability for the customer's failure to comply with these requirements. Before 

operation, review the instrument and manual for safety markings and instructions. 

You must follow these to ensure safe operation and to maintain the instrument in 

safe condition. 

Initial Inspection 

 

Inspect the shipping container for damage. If there is damage to the container or 

cushioning, keep them until you have checked the contents of the shipment for 

completeness and verified the instrument both mechanically and electrically. The 

Performance Tests give procedures for checking the operation of the instrument. If 

the contents are incomplete, mechanical damage or defect is apparent, or if an 

instrument does not pass the operator¨s checks, notify the nearest Keysight 

Technologies Sales/Service Office.  

WARNING To avoid hazardous electrical shock, do not perform electrical tests 

when there are signs of shipping damage to any portion of the outer enclosure 

(covers, panels, etc.). 

General 

 
This product is a Safety Class 3 instrument. The protective features of this product 

may be impaired if it is used in a manner not specified in the operation 

instructions. 

Environment 

Conditions 
This instrument is intended for indoor use in an installation category II, pollution 

degree 2 environment. It is designed to operate within a temperature range of  0 

°C ̄  40 °C (32 °F ̄  105 °F) at a maximum relative humidity of 80% and at altitudes 

of up to 2000 meters. 

This module can be stored or shipped at temperatures between -40 °C and +70 °C. 

Protect the module from temperature extremes that may cause condensation 

within it.  

Before Applying Power Verify that all safety precautions are taken including those defined for the 

mainframe. 

Line Power 

Requirements 
The Keysight M8197A operates when installed in an Keysight AXIe mainframe. 

Do Not Operate in an 

Explosive Atmosphere 
Do not operate the instrument in the presence of flammable gases or fumes. 

 

Do Not Remove the 

Instrument Cover 
Operating personnel must not remove instrument covers. Component replacement 

and internal adjustments must be made only by qualified personnel. Instruments 

that appear damaged or defective should be made inoperative and secured 

against unintended operation until they can be repaired by qualified service 

personnel. 

http://www.agilent.com/find/M9505A


 

 

Safety Symbols 
 

 Table 1 Safety Symbol 

Symbol Description 

 

Indicates warning or caution. If you see this symbol on a product, you must refer to the manuals for 

specific Warning or Caution information to avoid personal injury or damage to the product. 

 

 

C-Tick Conformity Mark of the Australian ACA for EMC compliance. 

 

 

CE Marking to state compliance within the European Community: This product is in conformity with the 

relevant European Directives. 

 

 

General Recycling Mark 

 

 

 

 

 Table 2 Compliance and Environmental Information 

Symbol Description 

 

This product complies with the WEEE Directive (2002/96/EC) marketing requirements. The affixed label 

indicates that you must not discard this electrical/electronic product in domestic household waste.  

Product category: With reference to the equipment types in the WEEE Directive Annexure I, this product 

is classed as a ©Monitoring and Control instrumentation· product.  

 

Do not dispose in domestic household waste.  

 

To return unwanted products, contact your local Keysight office, or see 

http://about.keysight.com/en/companyinfo/environment/takeback.shtml for more information. 

 

 
 

 

http://about.keysight.com/en/companyinfo/environment/takeback.shtml
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Introduction This chapter provides an overview of Keysight M8197A module. 

The M8197A synchronization module is used together with 1 to 4 M8195A modules to build a fully 

synchronous, phase coherent multi-channel generator system with up to 16 analog channels. 

When running in synchronous mode, all of the M8195A modules work with the same sample clock and 

start at the same time. The common system clock (Sys Clk) is derived either from the M8197A¨s 

internal clock synthesizer or from an external sample clock that is connected to the M8197A¨s 

reference clock input (REF CLK IN). 

The skew between any two channels is guaranteed to be within +/-  75 ps (without system level 

calibration) independent of the sample rate. Using the fine delay adjust capability of the M8195A with 

50 fs resolution, the skew can be adjust to less than 1 ps between any two channels. Once adjusted, 

the skew is maintained across loading new waveforms, changing sample rate and power cycles to 

better than 1 ps.  

A common trigger input is available on the synchronization module to trigger all the connected 

M8195A modules simultaneously with deterministic latency. Triggered waveforms have the same 

inter-channel skew as continuous waveforms. To achieve the lowest possible trigger delay 

uncertainty, the trigger input can be synchronized externally to the REF CLK output.  

 

 

 

Features and Benefits M8197A provides following features and benefits:  

¶ Synchronization of up to 4 M8195A modules (= 16 channels) 

¶ One trigger input can trigger up to 4 M8195A modules with deterministic 

latency  

¶ Skew repeatability of 1 ps between any two channels ̄  independent of 

sample rate 

¶ Skew resolution of 50 fs between any two M8195A of the synchronous 

system 

¶ 1U AXIe module for high port density 

 

 

Additional Documents Additional documentation can be found at:  

¶ http://www.keysight.com/find/M9505A  for 5-slot chassis related 

documentation. 

¶ http://www.keysight.com/find/M9502A  for 2-slot chassis related 

documentation. 

¶ http://www.keysight.com/find/M904 8A for PCIe desktop adapter card 

related documentation. 

¶ http://www.keysight.com/find/M9536A  for embedded AXIe controller 

related documentation. 

¶ http://www.keysight.com/find/M8195A  for AXIe based AWG module 

related documentation. 

 

  

http://www.keysight.com/find/M9505A
http://www.keysight.com/find/M9502A
http://www.keysight.com/find/M9047A
http://www.keysight.com/find/M9536A
http://www.keysight.com/find/M8195A
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1.1 Document History 

 
First Edition  

(November 2015) 
The first edition of the user guide describes the functionality of firmware version 2.5. 

Second Edition  

(April 2016) 
The second edition of the user guide describes the functionality of firmware version 

3.0. 

Third Edition  

(July 2016) 
The third edition of the user guide describes the functionality of firmware version 3.1. 

 

 

1.2 Accessories 

 

 The M8197A is always delivered with four Sys clock cables. The Sys Clock cables are 

matched pair cables. It is mandatory to use exactly the provided cables. Otherwise 

the synchronous system will not operate as specified. To avoid using non-specified 

cables, the Sys Clock cables are equipped with QMA to SMA connectors. 

 

  

1.3 M8197A Front Panel 

 

 The following figure shows the front panel of the M8197A module: 

 

 

 

 Figure 1   Front Panel of M8197A 

 

 

Inputs/Outputs The inputs and outputs available on the front panel of the M8197A module are 

described in Table 3. 
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 Table 3 Inputs and Outputs available on the front panel of the M8197A module  

Input/Outputs  Description Connector Type 

DYNAMIC CONTROL IN / 

OUT 

Configured as parallel Input port: Used to control sequencing of 

the synchronous system by external signals. This input is defined 

in detail in the chapter Sequencing of the User¨s Guide of the 

M8195 

Configured as parallel Output port: General purpose parallel 

digital I/O. 

Proprietary parallel connector 

SYS CLK OUT Connect to Trig In of each M8195A that is part of the synchronous 

system 

QMA 

TRIG IN The Trigger Input has a combined functionality as Trigger or Gate 

and is used to start the synchronous system by an external signal. 

This input is defined in detail in the chapter Sequencing of the 

User¨s Guide of the M8195  

SMA 

EVENT IN The Event Input (EVENT IN) is used to e.g. step through segments 

or scenarios by an external signals. This input is defined in detail 

in the chapter Sequencing of the User¨s Guide of the M8195. 

SMA 

REF CLK IN The Reference Clock Input can be used to synchronize to an 

external clock. The input frequency can vary between 10MHz and 

17 GHz. 

SMA 

REF CLK OUT The Reference Clock Output can be used to synchronize a DUT to 

the M8197A and thus to the synchronous system. The adjustable  

output frequency covers a large frequency range. 

SMA 

 

 

 

1.3.1 Front Panel LED 

 

 

1.3.1.1 Status LED 

 

 Two LEDs are available at the front panel to indicate the status of the M8197A 

module:  

The green ©Access· LED indicates that the controlling PC exchanges data with the 

M8197A module.  

The red ©Fail· LED has following functionality: 

¶ It is ©ON· for about 30 seconds after powering the AXIe chassis. 

¶ After about 30 seconds, the LED is switched ©OFF·. If an external PC is used 

to control the AXIe chassis, this PC can be powered after this LED has 

switched OFF. 

¶ During normal operation of the module this LED is ©OFF·. In case of an error 

condition e.g. a self- test error, the LED is switch ©ON·. 

¶ In case the output relay has shut-off because of an external overload 

condition, this LED flashes. 
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1.3.1.2 Trigger IN and Event IN LED 

 

 This LED indicates that an externally applied signal matches the adjusted threshold 

to be used as a Trigger or Event. The LED turns on for ~100 ms for each detected 

edge of the correct polarity i.e. a rising edge turns the LED on for 100 ms if the 

polarity is adjusted to rising.  

If the polarity is adjusted to rising, and a falling edge is externally applied, the LED 

remains OFF.  

Notes:  

¶ In case the edges are applied faster than every 100 ms, the LED is 

continuously ON.  

¶ In trigger mode ¼Gated¨, the LED is turned on for 100 ms when the gate 

signal becomes active i.e. when the polarity is set to positive, the LED turns 

on for 100 ms after the rising edge. When the polarity is set to negative, the 

LED turns on for 100 ms after the falling edge. 

¶ In trigger mode ¼Gated¨, the polarity cannot be set to ¼Either¨ 

 

 

Table 4:   Trigger IN and Event IN LED 

Color Meaning Description 

Off No external Trigger (Event) In case the trigger source is not set to external, this LED is OFF.   

ON, green Valid external Trigger (Event) 

detected 

In case the trigger mode is set to ¼asynchronous¨, a Trigger (Event) is 

always valid. Set-up or hold time violations do not exists. 

Note: A ¼Force Trigger¨ from the SFP or SCPI does not turn the LED ON 

ON, red Invalid external Trigger 

(Event) detected 

In case the trigger mode is set to ¼synchronous¨, a Trigger (Event) can 

be invalid because of a set-up or hold time violation. The LED turns On 

red in case a set-up or a hold time violation has been detected. 

Note A ¼Force Trigger¨ from the SFP or SCPI does not turn the LED ON 
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1.3.1.3 Ref CLK IN LED  

 

Table 5:  Ref CLK IN LED 

Color Meaning Description 

Off Applied clock cannot be used In case the clock reference is not set to Ref CLK IN, this LED is OFF.   

ON, green Valid signal at Ref CLK IN detected ¶ CDR has locked on Ref CLK In and 

¶ The externally applied frequency is correct and 

¶ Ref CLK In has been selected as the clock reference 

ON, red No valid signal at Ref CLK IN ¶ Ref CLK In has been selected as the clock reference 

¶ The externally applied clock signal is not valid. E.g. the 

frequency does not match the adjusted value or the 

amplitude is outside the specified range 

 

 

 

 



 Keysight M8197A -  Synchronization module for M8195A 

 User¨s  Guide 
 

   

2 M8197A Installation 
 

 

 

2.1 Introduction    /    16 

2.2 AXI Chasis    /    26 

 

  



2  M8197A Installation  

16  Keysight M8197A User¨s Guide 

 

2.1 Introduction 

 

 This chapter explains the steps required to install M8197A module.  

 

 

2.1.1 Pre-Requisites 

 

 The following are the pre-requisites for installing Keysight M8197A software:  

¶ The supported operating systems are: 

- Windows 10  (32 bit or 64 bit) 

- Windows 8.1 (32 bit or 64 bit) 

- Windows 8    (32 bit or 64 bit) 

- Windows 7    (32 bit or 64 bit) 

¶ Ensure that you have Keysight IO Libraries Suite Version 16.3 or higher 

installed on your system. The Keysight IO Libraries Suite can be found on 

the CD that is part of shipment content or at 

http://www. Keysight.com/find/iosuite . 

 

 

  

http://www.agilent.com/find/iosuite
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2.1.2 Installation Process 

 

 

 

 

 

 

 

Follow the given steps to install Keysight M8197A software on your system: 

 

1. Double-click the executable (M8197_Setup.exe). This executable file is 

available either on CD or Web. 

 

  

 

 

 

 

 

 

 

 

 

 

 

2. The Keysight M8197A Setup will prepare the InstallShield Wizard for the 

installation process. The following windows will appear. 
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3. Click Next. 

 

 

 

4. We recommend you to read the document to check if your hardware 

configuration is supported.  

 Click Next to proceed to the license agreements. 
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5. Accept the terms of ¼Keysight Software End-User License Agreement¨. 

  

 
 

6. Click Next. 
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7. Accept the ¼Keysight IVI Driver Source Code License Agreement Terms¨. 

 

 
 

8. Click Next. 
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9. Select Yes if you want to read the post- installation instructions.  

 Click Next to select setup type. 

 

 
 

10. Select a setup type either Complete or Custom. 

If you select Custom, you can specify which optional features will be installed. 
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11. Click Next. 
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12. Click Install to begin the installation. The Setup Wizard will now install 

M8197A. 
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13. The following screen will appear once the Keysight M8197A software is 

successfully installed on your system.  

 

  

 

14. Click Finish to restart your system.  

 

This completes the Keysight M8197A software installation. 
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2.1.3 Post Installation Steps 

 

 

If M8197A is already powered up and connected to PC using the PCIe, just reboot 

the PC, and start with step 5. No such reboot step is required in case of a USB 

connection. 

 
 

 Follow the post installation steps as shown below:  

1. Shut down PC and instrument.  

2. Connect the instrument to the PC using a PCIe or USB cable. 

3. Switch on instrument. Wait until the ©Access· LED of the M8197A has 

switched from red to green.  

4. Switch on PC.  

5. The PC should automatically recognize the instrument.  

6. Check this in the device manager; e.g. via  Start > Control Panel > Device 

Manager, or right-click Computer > Manage > Device Manager: 

 

In case of PCIe:  

7. The instrument should be visible in the device tree as Keysight Technologies 

Modular Devices > M8197A 

 

In case of USB: 

8. The instrument should be visible in the device tree as Keysight Modular 

Platform (AMP/AXIe) > Keysight Technologies USB AMP/AXIe Chassis. 

 

 

 

In case of PCIe, post installation steps must be followed strictly in the same order as 

mentioned for successful connection of the PC with M8197A. However, in case of 

USB no such restriction is applicable i.e. the PC can be powered before the M8197 is 

turned ON. 

 
 

 

Your PC might request a reboot. Reboot your PC, if requested. 

 
 

 9. (PCIe only) Check if the M8197 is also visible in the Keysight Connection 

Expert: 

e.g. via Start  > All Programs > Keysight Connection Expert. 

10. If something went wrong and the Instrument is not shown in the PXI section, 

it may be necessary to reboot the PC once more.  

11. Install Intel Network Drivers on Windows XP: The AXIe chassis contains an 

Intel 82573L NIC as a PCIe endpoint. Refer to the AXIe chassis User¨s Guide 

at http://www. Keysight.com/find/M9505A for instructions how to install this 

driver. 

 

  

http://www.agilent.com/find/M9505A
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2.1.4 How to Control the Instrument 

 

 1. If you use a PCIe link to control the M8197A, the AXIe chassis must be 

switched-on before you start the PC. If you use a USB link to control the 

M8197A, it¨s not mandatory that the AXIe chassis is powered and has 

booted prior to turning on the PC.   

2. Start the M8197A Soft Front Panel (Start > All Programs > Keysight M8197 

> Keysight M8197 Soft Front Panel). The user interface will display the VISA 

resource strings for different kinds of connection. 

3. Using the appropriate VISA resource string you can:  

¶ Start the Soft Front Panel (Start > All Programs > Keysight  M8197 > 

Keysight M8197 Soft Front Panel).  

¶ Control the instrument with your own application using the M8197 

IVI Drivers or add it as a LAN instrument in the Keysight Connection 

Expert (TCPIP0::localhost::¹) and control it using SCPI (with e.g. the 

VISA Assistant or your own application). 

4. You must start the M8197A Soft Front Panel in order to send SCPI commands 

to the instrument. 

 

 

 

The M8197 IVI Drivers start the M8197A Soft Front Panel automatically. 

 
 

2.2 AXI Chasis 

 

 The detailed documentation for the AXIe chassis can be found at:  

¶ http://www. Keysight.com/find/M9505A for 5-slot chassis 

¶ http://www. Keysight.com/find/M9502A for 2-slot chassis. 

 

 

2.2.1 ESM Front Panel Connector 

 

 The ESM Front Panel Connector is shown in the figure below: 

 

 

1 2 3 4 5 6 7 8 9

 
  

http://www.agilent.com/find/M9505A
http://www.agilent.com/find/M9502A
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1 PCle Connects a host PC to the chassis via PCle. 

PCIe is the only interface that can be used to control the M8197A 

module. 

2 Multiframe Input Synchronizes timing signals with multiple daisy-chained chassis. These 

signals are not needed to synchronize M8190A modules. The M8197A 

synchronization module is needed instead. 
3 Multiframe Output 

4 Trigger In External Trigger connections. 

The Trigger In of the AXIe ESM cannot be used to trigger the M8197A. 

The M8197A has its own Trigger In. 

The Trigger Out of the AXIe ESM cannot be controlled by the M8197A. 

5 Trigger Out 

6 Clock In 
External clock connections. 

7 Clock Out 

8 LAN Connects the host PC to the chassis, via 10/100/1000 Ethernet.  

In particular, the LAN connector is used for ESM configuration, but NOT 

to communicate to the M8197A. 

9 Status Light Indicates the chassis status. 
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3.1 Introduction 

 

 This chapter describes how to configure a synchronous system. The term 

¼synchronous system¨ describes multiple M8195A AWG modules that operate entirely 

synchronous with respect to timing parameters including synchronous start, 

synchronous sequencing, common trigger and common sample clock. A 

synchronous system consists of: 

¶ One M8197A synchronization module 

¶ One or up to four M8195A AWG slave modules 

¶ One M9502A 2-slot AXIe chassis or one M9505A 5-slot AXIe chassis 

¶ An external PC to control the synchronous system 

¶ One clock cable M8197-61601 for each synchronized M8195A AWG slave 

module 

¶ M8197A software that controls the synchronous operation of the system 

¶ M8195A software that controls the operation of the M8195A AWG modules 

 

 

 

There are some generic rules to be considered for the configuration of a synchronous 

system. The M8197A synchronization module must always be inserted in the lowest 

slot number of the synchronous system. The M8197A and M8195A modules of the 

synchronous system must be inserted in ascending slot numbers without leaving a 

slot empty. In case a M9536A system controller module is used, the controller 

module must be inserted in slot 1. 

 
 

 The M8197A synchronization module is designed to synchronize up to four M8195A 

arbitrary waveform generator modules. The M8195A modules have to be located in 

the same AXIe chassis as the M8197A in direct order above the M8197A.  

A synchronous trigger signal to start the system synchronously is distributed via the 

AXIe chassis backplane and a system clock signal is distributed using the clock 

cables M8197-61601. These clock cables are connected on the front panel between 

the M8197A synchronization module and the M8195A arbitrary waveform generator 

modules. 

All synchronous system configurations require an external desktop PC or laptop PC 

with PCIe interface cable connection or USB cable connection to control the system. 

As alternative to an external PC, a M9536A system controller module can be used to 

control the system. 

Any number of up to 16 Arbitrary Waveform Generator channels can be configured 

using a combination of 1-channel, 2-channel and 4-channel M8195A Arbitrary 

Waveform Generators (see section 3.2). Typical multi-channel configurations are 

described in the following subchapters: 
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3.1.1 Up to 4 M8195A AWG Channels in an M9502A 2-Slot Chassis 

 

 To configure a synchronous system with up to 4 AWG-channels including high 

resolution triggering and dynamic sequence control, use one 2-slot AXIe chassis 

M9502A, one M8197A synchronization module, and one M8195A 4-channel Arbitrary 

Waveform Generator module.  

Å The M8197A synchronization module must be inserted in slot 1, 

Å The M8195A AWG module must be inserted in slot 2. 

 

 

3.1.2 Up to 16 M8195A AWG Channels in an M9505A 5-Slot Chassis 

 

 To configure a synchronous system with up to 16 AWG-channels including high 

resolution triggering and dynamic sequence control, use one 5-slot AXIe chassis 

M9505A, one M8197A synchronization module, and up to four M8195A 4-channel 

Arbitrary Waveform Generator modules.  

¶ The M8197A synchronization module must always be inserted in the lowest 

slot number of the synchronous system.  

¶ The M8197A and M8195A modules of the synchronous system must be 

inserted in ascending slot numbers without leaving a slot empty.   

¶ In case a M9536A system controller module is used, the controller module 

must be inserted in slot 1.  

Multiple (maximum two) synchronous systems can be built in one 5-slot chassis. 

 

 

3.1.3 Up to 16 M8195A AWG Channels in an M9514A 14-Slot Chassis 

 

 To configure a synchronous system with up to 16 AWG-channels including high 

resolution triggering and dynamic sequence control, use one 14-slot AXIe chassis 

M9514A, one M8197A synchronization module, and up to four M8195A 4-channel 

Arbitrary Waveform Generator modules.  

¶ The M8197A synchronization module must always be inserted in the lowest 

slot number of the synchronous system.  

¶ The M8197A and M8195A modules of the synchronous system must be 

inserted in ascending slot numbers without leaving a slot empty.   

¶ A synchronous system must be either completely inserted left (slot 1s ..6) or 

right (slots 8 ¹14) from the AXIe System Module (ASM). 

¶ In case a M9536A system controller module is used, the controller module 

must be inserted in slot 1.  

Multiple (maximum five) synchronous systems can be built in a 14-slot chassis. 
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3.2 Supported AXIe Frame Combinations 

 

 Besides the typical and most common synchronous system configurations described 

in chapter 3.1 the synchronous system configuration is not limited to these example. 

 

 

 Table 6 Valid Synchronous System Configurations 

Number of 

M8197A 

Number of 

M8195A 

Supported AXIe Chassis Combinations 

1 1 One M9502A 2-slot AXIe chassis 

1 2 One M9505A 5-slot AXIe chassis 

1 3 One M9505A 5-slot AXIe chassis  

1 4 One M9505A 5-slot AXIe chassis  
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3.3 Controlling One AXIe Chassis 

 

 The basic configuration of a synchronous system with sixteen synchronous M8195A 

AWG channels is shown in  Figure 2: 

 

 

M9048 PCIe 

Adapter

External Host PC

 

 Figure 2   One AXIe chassis connected to an external host PC 

 

 

 A synchronous system with sixteen synchronous M8195A AWG channels consists of: 

¶ Four M8195A 4-channel arbitrary waveform generator modules 

¶ One M8197A synchronization module. The delivery content of the M8197A 

synchronization module includes: 

- Four clock cables with a QMA connector at one end and a SMA 

connector at the other end. See  Figure 3. 

¶ One M9505A 5-Slot AXIe chassis 

¶ External controlling PC including PCIe IF card and PCIe cable or USB cable 
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 Figure 3   M8197-61601 QMA to SMA clock cable 
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3.4 Synchronous System Cabling 

 

 This section describes the cable connections of a sixteen channel synchronous 

system. A sixteen channel synchronous system consists of: 

¶ Four M8195A 4-channel arbitrary waveform generator modules 

¶ One M8197A synchronization module. The delivery content of the M8197A 

synchronization module includes: 

- Four clock cables with a QMA connector at one end and a SMA 

connector at the other end.  

¶ One M9505A AXIe chassis 

¶ External controlling PC including PCIe IF card and PCIe cable or USB cable 

 

Figure 4 depicts the sixteen channel synchronous system cabling. 

 

 

5 6

1 2 3

4

External Trigger 

from DUT

M9048 PCIe 

Adapter

External Host PC

 

 Figure 4  System level cabling of a sixteen channel synchronous system 

 

 

 
The highlighted cables in the synchronous system cabling are described in Table 7. 

 

 

 Table 7 Cable Connections 

Cable 

No. 

Cable Type Source Destination 

1 - 4 QMA to SMA Sync module: SYS CLK OUT AWG slave modules: REF CLK IN 

5 SMA to SMA Sync module: REF CLK OUT Device Under Test (DUT) Clock Input 

6 SMA to SMA Device Under Test (DUT) Trigger Output Sync module: TRIG IN 
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3.5 Controlling the Synchronous System 

 

 This section describes the ways to control the synchronous system.  

 

 

3.5.1 Requirements for Controlling the Synchronous System 

 

 The requirements for controlling the synchronous system are as follows: 

¶ Any remotely controlled M8195A module that will become part of the 

synchronous system must be made visible in KCE (Keysight Connection 

Expert) 

¶ The M8195A firmware of each module of the synchronous system must be 

started prior to configuring the synchronous system.  

¶ SYS CLK outputs of the M8197A may be used in any order. Example: For 

four M8195A modules, SYSCLK OUT 1, SYSCLK OUT 2, SYSCLK OUT 3 and 

SYSCLK OUT 4 must be connected. 

 

 

3.5.2 Synchronous System Operation Modes 

 

 The synchronous system has the following two modes of operation: 

1. Configuration mode 

2. Operation mode  
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3.5.2.1 Configuration Mode 

 

 The configuration mode is used while connecting external cables of the synchronous 

system or during configuration of main parameters such as setting the common 

sample clock frequency that affects the entire synchronous system. Specifically when 

defining which M8195A found by Keysight Connection Expert (KCE) modules belong 

to the synchronous system  or when system parameters (see section 3.5.3.2) are 

being changed, the system must be stopped and set in configuration mode: 

 

 

3.5.2.2 Operation Mode 

 

 The operation mode is used for data generation and to synchronously start the 

system. To start data generation you must switch to operation mode. 

Whenever the user switches from configuration mode to operation mode, following 

system checks and actions are performed: 

¶ Verify that the firmware version of all M8195A AWG modules and the 

M8197A synchronization module of the synchronous system is identical and 

higher than V2.5.0 . 

 Verify that each M8195A of the synchronous system has a common set of 

options.  

a. M8195A Rev.1 modules must not be part of synchronous system.  

b. In case all M8195A modules have installed the Fast Switching Mode 

option F̄SM,  the system will operate in fast switching mode. In case 

one or more M8195A modules of the synchronous system do not have 

the option F̄SM installed, the M8197A module and thus the entire 

synchronous system behaves as not having the option ̄ FSM installed. 

¶ Verify that each M8195A of the synchronous system operates with a valid 

system clock. Thus correct cabling of the system clock cables is checked. 

 ¶ Verify that a trigger propagates from the M8197A synchronization module 

to each M8195A module of the synchronous system. Thus correct trigger 

distribution via backplane communication is checked. 

¶ Transfer the settings of sample frequency to the M8195A  modules of the 

synchronous system. 

¶ Perform accurate delay alignment among all M8195A channel in the 

synchronous system. 
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3.5.3 Control Parameters 

 

 In a synchronous system, many parameters such as the common sample clock 

frequency cannot be adjusted individually on each M8195A AWG module. Otherwise, 

synchronous operation would not be possible.  This section describes how to control 

parameters that affect the entire synchronous system. This section describes as well 

whether a specific system parameter is controlled by the M8197A or the M8195A. 

 

 

3.5.3.1 Using M8197A Soft Front Panel 

 

 The Soft Front Panel of the M8197A lists all M8195A that are available in the local PC 

or in KCE in a table. Using this table the user can define that a certain M8195A will 

be,  

¶ Part of the synchronous system marked as ¼Slave¨  

¶ Or will not be part of the synchronous system marked as ¼None¨ 

 

Following parameters can be controlled using the M8197A Soft Front Panel: 

¶ Sample frequency 

¶ Trigger mode (¼Continuous¨, Triggered¨ or ¼Gated¨) 

¶ Arm mode (¼Self¨ or ¼Armed¨) 

¶ Trigger threshold 

¶ Trigger polarity (¼Positive¨, ¼Negative¨ or ¼Either¨) 

¶ Trigger and Event operation (¼Synchronous¨ or  ¼Asynchronous¨) 

¶ Event threshold 

¶ Event polarity (¼Positive¨, ¼Negative¨ or ¼Either¨) 

¶ Internal trigger frequency 

¶ Mapping of Trigger In, Event In and Internal Trigger to ¼Trigger/Gate¨, 

¼Advance Event¨ and ¼Enable Event¨ 

¶ Enable or Disable of ¼Trigger/Gate¨, ¼Advance Event¨ and ¼Enable Event¨ 

¶ Single trigger actions ¼Force Trigger¨, ¼Force Gate¨, ¼Force Event¨ or ¼Force 

Enable¨ 

¶ Synchronous start and stop of all M8195A modules in the system by 

software 
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3.5.3.2 Using M8195A Soft Front Panel 

 

 The following parameters in the Clock tab menu are disabled in the M8195A slave 

modules: 

¶ DAC Sample Frequency 

¶ Sample Clock Source (AXIe Backplane, Reference Clock In,  Internal) 

¶ Reference Clock Frequency Range 

All parameters in the Trigger tab menu are disabled in the M8195A slave modules, 

only the ¼Force Trigger¨-, ¼Force Gate¨-, ¼Force Event¨- and ¼Force Enable¨-push 

buttons are enabled for debugging purposes. 

 To modify all the above named, disabled parameters you need to switch to 

configuration mode first and remove the M8195A slave modules from the 

synchronous system by setting them from ¼Slave¨-  to ¼None¨- mode.  

 

Table 8 lists the common synchronous system parameters that can be controlled by 

the M8197A or M8195A. 

 

 

 Table 8 Parameters controlled from M8197A and M8195A 

Functionality M8197A Synchronization Module M8195A Slave Module 

Sample frequency Controls all M8195A Slave 

Modules. Modification is only 

possible in configuration mode 

Disabled 

Arm mode Controls all M8195A Slave 

Modules. All M8195A operate in 

the same arm mode (¼Self¨ or 

¼Armed¨). Modification is only 

possible in configuration mode  

Disabled 

Trigger mode Controls all M8195A Slave 

Modules. All M8195A operate in 

the same trigger mode 

(¼Continuous¨, ¼Triggered¨ or 

¼Gated¨). Modification is only 

possible in configuration mode  

Disabled 

Trigger In Threshold Affects all M8195A Slave Modules Disabled 

Trigger In Polarity Affects all M8195A Slave Modules Disabled 

Trigger In and Event In 

Operation 

Affects all M8195A Slave Modules. 

Modification is only possible in 

configuration mode 

Disabled 

Internal Trigger Frequency Controls all M8195A Slave 

Modules. Modification is only 

possible in configuration mode 

Disabled 

Event Threshold Affects all M8195A Slave Modules Disabled 

Event Polarity Affects all M8195A Slave Modules Disabled 

Force Trigger / Gate Affects all M8195A Slave Modules Locally available for debugging 

Force Enable Affects all M8195A Slave Modules Locally available for debugging 

Force Event Affects all M8195A Slave Modules  Locally available for debugging 

Mapping of Trigger In,  

Event In and Internal Trigger to 

¼Trigger/Gate¨, ¼Advance Event¨ 

and ¼Enable Event¨ 

Controls all M8195A Slave 

Modules.  

Disabled 

Run/Stop Controls all M8195A Slave 
Modules. 

Disabled 
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4.1 Introduction 

 

 This chapter describes the M8197A Soft Front Panel (SFP).  

 

 

4.2 Launching the M8197A Soft Front Panel 

 

 From the Start menu, select All Programs > Keysight M8197 > Keysight M8197 Soft 

Front Panel.  

 

 

 

To control the instrument through SCPI:  

From the Keysight Connection Expert, select the discovered M8197 module, click 

©Send Commands To This Instrument·. 

 
 

 

 The following screen will appear: 

 

 

 Figure 5   M8197A connected to PC 
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 The instrument selection dialog shows the addresses of the discovered M8197A 

modules. Select a module from the list and press ©Connect·. 

If no M8197A module is connected to your PC, you can check ©Simulation Mode· to 

simulate an M8197A module.  

 

 

 

 Figure 6   M8197A connected in simulation mode 

 

 

4.3 M8197A Soft Front Panel 

 

 The M8197A Soft Front Panel allows you to: 

¶ Configure a multi-module group, 

¶ Control the M8197 trigger input parameters, 

¶ Synchronously start all channels of the multi-module group.  

 

It includes the following GUI items: 

¶ Title Bar 

¶ Menu Bar 

¶ Status Bar 

¶ Tabs (Module, Clock, Trigger, and Dynamic Control) 

 

The detailed information on these GUI items is described in the sections that follow. 
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4.3.1 Title Bar 

 

 The title bar contains the standard Microsoft Windows elements such as the window 

title and the icons for minimizing, maximizing, or closing the window. 

 

 

4.3.2 Menu Bar 

 

 The menu bar consists of various pull down menus that provide access to the 

different functions and launch interactive GUI tools. 

The menu bar includes the following pull down menu: 

¶ File 

¶ View 

¶ Utilities 

¶ Tools 

¶ Help 

Each pull down menu and its options are described in the following sections. 

 

 

4.3.2.1 File 

 

 The File menu includes the following selections: 

¶ File > Connect¹ 

Opens the instrument selection dialog. 

¶ File > Save Configuration As¹ 

Saves configuration as a text file. 

¶ File > Load Configuration¹ 

Load the previously saved configuration file. 

¶ File > Exit 

Exits the soft front panel. 
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4.3.2.2 View 

 

 The View menu includes the following selections: 

¶ View  > Refresh 

Reads the instrument state and updates all fields. 

¶ View > Hide 

Minimizes the Soft Front Panel to the system tray.  

 

 

4.3.2.3 Utilities 

 

 The Utility  menu includes the following selections: 

¶ Utilities > Reset 

Resets the instrument, reads the state, and updates all fields. 

¶ Utilities > Self Test¹ 

Opens the ©Self Test· window to start the self-test and display the result 

after completion. 

 

 

4.3.2.4 Tools 

 

 The Tools menu includes the following selections: 

¶ Tools > Monitor Driver Calls 

Opens the ©Driver Call Log· window. 

 

 

4.3.2.5 Help 

 

 The Help menu includes the following selections: 

¶ Help > Driver Help 

Opens the IVI driver online help. 

¶ Help > Online Support 

Opens the instrument¨s product support web page. 

¶ Help > About 

Displays revision information for hardware, software and firmware. Displays 

the serial number of the connected module. 
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4.3.3 Status Bar 

 

 The Status Bar contains the following two fields from left to right:  

¶ Connection Status 

- ©Not Connected·  ̄No instrument is connected. 

- ©Connected: <Instrument resource string>· ̄ An instrument is 

connected. The resource string, for example PXI36::0::0::INSTR is 

displayed.  

- ©Simulation Mode·  ̄No real instrument is connected. The user 

interface is in simulation mode. 

Click this field to open the ©Connect to Instrument· dialog. 

¶ Instrument status 

Displays the instrument status, for example ©Reset complete· after issuing a 

reset command. 

 

 

4.3.4 Tabs (Module/Clock/Trigger/Dynamic Control Tabs) 

 

 These tabs are used to configure the most important parameters of the M8197A 

module. They are described in detail in the sections that follow. 

The bottom part of the tab area contains the following controls from left to right: 

¶ Error status icon: See Errors List Window. 

¶ Configuration/Operation Mode button: This toggle button is used to switch 

between ©Configuration· and ©Operation· mode. While in ©Operation· mode 

if signal generation is started this check box is disabled. You need to stop 

the signal generation to switch to ©Configuration· mode. 

¶ Run/Stop button: The Run/Stop button is used to switch between Run and 

Program mode. 
 

 

4.3.5 Numeric Control Usage 

 

 The numeric control is used to adjust the value and units. Whenever you bring the 

mouse pointer over the numeric control, a tooltip appears which shows the possible 

values in that range. 

 

 

 

 Figure 7   Tooltip showing possible values in the range 
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 The numeric controls can be used in the following ways: 

¶ Use the up/down arrows to change the value. The control automatically 

stops at the maximum/minimum allowed value.  

¶ You can increase or decrease the value starting at a specific portion of the 

value. To do this, place the cursor to the right of the targeted digit and use 

the up/down arrows. This is especially useful when changing a signal 

characteristic that is immediately implemented, and observing the result in 

another instrument. For example, you can change the signal generator¨s 

frequency by increments of 10 MHz and observe the measured result in a 

signal analyzer: 

 

 

  

 Figure 8   Typing directly into the field 

 

 ¶ Type directly into the field and press the Enter key. If you enter a value 

outside the allowed range, the control automatically limits the entered 

value to the maximum or minimum allowed value.  

¶ When you type the value, you can type the first letter of the allowed unit of 

measure to set the units. For example, in the Frequency control you can use 

"H", "K", "M", or "G" to specify hertz, kilohertz, megahertz, or gigahertz, 

respectively. (The control is not case sensitive.) 

The controls allow scientific notation if it is appropriate to the allowed range. Type 

the first decimal number, enter an "E", and omit any trailing zeroes. For example, in 

the Frequency control you can type 2.5e+9 and press Enter to set the frequency to 

2.5 GHz. (The plus sign is automatically inserted if it is omitted.) 
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4.4 Driver Call Log Window 

 

 Use this window to inspect the sequence of SCPI commands used to configure the 

M8197A module. 

 

 

 Figure 9   Driver Call Log Window 

 

 

 It has the following buttons: 

¶ Save As¹ 

Saves the Driver Call Log as a text file. 

¶ Clear History 

Clears the Driver Call Log. 

¶ Close 

Exits the window. 
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4.5 Errors List Window 

 

 Use this window to view errors, warnings, and information.  

 

 

 Figure 10   Errors List Window 

 

 It has the following controls, signs, and columns: 

1. Open On Error 

Select this check box to automatically open the errors list window whenever an 

error occurs. This window will show error details i.e time stamp and description. 

2.  (Clear All) 

Use this option to clear all the errors from the errors list window. 

3.   or    (Hide Errors List Window or Show Errors List Window) 

Use this toggle option to respectively show or hide the errors list window. It also 

shows total number of errors in the list.  When the window has no errors, the green 

tick icon will appear.  

4.  (Error)   

This icon represents an error.  

5. (Warning)   

This icon represents a warning.  

6. (Information)   

This icon represents an information.  

7. Time Stamp 

This column lists the time stamp of individual errors in the format: 

DD/MM/YYYY HH:MM:SS.  

8. Description 

This column provides the description of individual errors.  

9.  (Window Controls) 

This drop down list provides window control options like: 

- Float 

- Dock  

- Auto Hide  

- Close  
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4.6 Module Tab 

 

 The module panel allows you to discover available M8195A modules and to define a 

multi-module group consisting of up to four slave modules. The VISA resource 

strings for available M8195A modules are displayed in a list under column ©VISA 

Resource·. The drop down list under column ©Mode· provides options to specify 

whether a module will be part of multi-module group or not. Select ©Slave· to add a 

module to the multi-module group. The option ©None· indicates that the module is 

not part of the group. The module tab also allows you to switch between 

©Configuration· and ©Operation· mode using the ©Configuration Mode· check box. 

 

 

 

 Figure 11   Module Tab 
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 It has the following controls: 

¶ Discover: Click this button to find the available M8195A modules. The 

modules that are found are displayed in the list. The firmware of the 

modules to be discovered must be running and the modules must be 

entered into the Keysight Connection Expert. 

¶ M8195A Module Selection List: It has following columns: 

- VISA Resource: Displays the visa resource string of the M8195A 

module. 

- Mode: The combo-box in this column can be used to set the multi-

module mode of the module. Select ©Slave· to add a module to 

synchronization group. The option ©None· is used to indicate that the 

module is not part of the synchronization group. 

- Serial Number: Displays the serial number of M8195A module. 

- Slot Number: Displays the slot number in AXIe chassis.  

- Chassis: Displays the AXIe chassis information. 

- Identify: The ©Identify· button under this column is used to identify a 

module. On clicking this button the access LED of the M8195A module 

will be flashed for 10 seconds. This allows easy identification of module 

in a setup consisting of multiple AXI frames and multiple modules. 

 

 

 

It is recommended to follow the below order when exiting the application: 

¶ Stop the system. 

¶ Switch to Configuration Mode. 

¶ Exit the M8197 Soft Front Panel. 

¶ Exit any M8195 Soft Front Panel if necessary. 

¶ Exit the M8195 firmware instances if not required any more. 
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4.7 Clock Tab 

 

 Use this tab to configure the SYS Clock Out and the Reference Clock of the M8197A 

module. It contains switches for internal clock selection and input fields to configure 

the relevant frequencies. 

 

 

 

 Figure 12   Clock Tab 

 

 ¶ Reference clock selection switch 

This switch selects between the different reference clock sources. 

o Internal: Reference from internal oscillator  

o Internal Backplane 100 MHz: Reference from AXIe Backplane  

¶ Internal sample frequency 

If internal sample clock is selected, this field specifies the frequency of the 

internally generated sample clock. 
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4.8 Trigger Tab 

 

 Use this tab to configure the trigger and event input parameters. It allows user to 

send software triggers and events to the module.   

 

 

 

 Figure 13   Trigger Tab 

 




































































































