Notices

© Agilent Technologies, Inc. 2006-2010

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

Manual Part Number

N5180-90003

Edition

October 2010
Printed in USA
Agilent Technologies, Inc.
3501 Stevens Creek Blvd.
Santa Clara, CA 95052 USA

Warranty

The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend

U.S. Government Restricted Rights. Software and technical data rights granted to the federal government include only those rights customarily provided to end user customers. Agilent provides this customary commercial license in Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212 (Computer Software) and, for the Department of Defense, DFARS 252.227-7015 (Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial Computer Software or Computer Software Documentation).

Safety Notices

CAUTION

A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

WARNING

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.
Contents

1 Signal Generator Overview
   Signal Generator Features ..................................................... 2
   Modes of Operation .............................................................. 4
      Continuous Wave ............................................................. 4
      Swept Signal ................................................................. 4
      Analog Modulation .......................................................... 4
      Digital Modulation (N5162A/82A with Options 651, 652, or 654 Only) .... 4
   Front Panel Overview – N5181A/82A MXG ................................ 5
      1. Host USB ................................................................. 5
      2. Display ................................................................. 5
      3. Softkeys ................................................................. 5
      4. Numeric Keypad ......................................................... 6
      5. Arrows and Select. ...................................................... 6
      6. Page Up ................................................................. 6
      7. MENUS ................................................................. 6
      8. Trigger ................................................................. 6
      9. Local Cancel/(Esc) ...................................................... 6
     10. Help ................................................................. 7
     11. Preset and User Preset .................................................. 7
     12. RF Output ......................................................... 7
     13. RF On/Off and LED ................................................... 7
     14. Mod On/Off and LED .................................................. 7
     15. Page Down ............................................................. 7
     16. I Input (vector models only) ........................................... 7
     17. Q Input (vector models only) ........................................... 8
     18. Knob ................................................................. 8
     19. Incr Set ............................................................... 8
     20. Return ............................................................... 8
     21. More and LED ........................................................ 8
     22. Power Switch and LEDs ............................................... 8
   Front Panel Overview – N5161A/62A MXG ATE ............................ 9
      N5161A/62A MXG ATE Front Panel Functions ......................... 9
      1. Host USB ............................................................. 9
      2. Power Switch and LEDs ............................................. 10
      3. LAN LED ............................................................ 10
      4. 1588 LED ............................................................ 10
      5. ERROR LED ........................................................ 10
      6. LAN Reset Hardkey .................................................. 10
   Front Panel Display – N5181A/82A/83A MXG .............................. 11
      1. Active Function Area .................................................. 11
      2. Frequency Area ........................................................ 11
## Contents

3. Annunciators .......................... 11
4. Amplitude Area .......................... 12
5. Error Message Area ...................... 13
6. Text Area ............................... 13
7. Softkey Label Area ....................... 13

Blank Front Panel Display – N5161A/62A MXG ATE .......................... 13
N5161A/62A MXG ATE – Web Enabled Display .............................. 13
Annunciators .............................. 13

Rear Panel Overview – N5161A/62A 1/81A/82A MXG ....................... 15
1. AC Power Receptacle ..................... 15
2. SWEEP OUT ................................ 15
4. FM .................................... 16
5. PULSE .................................. 16
6. TRIG IN .................................. 16
7. TRIG OUT ................................ 16
8. REF IN .................................. 17
9. 10 MHz OUT ............................. 17
10. GPIB .................................. 17
11. LAN .................................. 17
12. Device USB ............................ 17
Digital Modulation Connectors (Vector Models Only) .................. 18
I OUT, Q OUT, OUT, OUT .................. 18
EXT CLK .................................. 18
EVENT 1 .................................. 19
PAT TRIG .................................. 19
DIGITAL BUS I/O ......................... 19
AUX I/O .................................. 20

Rear Panel Overview – N5183A MXG .................................. 21
1. AC Power Receptacle ..................... 21
2. SWEEP OUT ................................ 21
3. AM .................................... 22
4. FM .................................... 22
5. PULSE .................................. 22
6. TRIG IN .................................. 22
7. TRIG OUT ................................ 22
8. REF IN .................................. 22
9. 10 MHz OUT ............................. 23
10. GPIB .................................. 23
11. LAN .................................. 23
12. Device USB ............................ 23
## Contents

13. Z AXIS OUTPUT ................................................................. 23
14. ALC INPUT ........................................................................... 24

### 2 Setting Preferences & Enabling Options

User Preferences ................................................................. 26
Display Settings ............................................................... 26
Power On and Preset ............................................................ 27
Front Panel Knob Resolution ............................................... 28
Setting Time and Date ......................................................... 28
Reference Oscillator Tune ..................................................... 29
Upgrading Firmware ............................................................. 29
Remote Operation Preferences ............................................. 30
GPIB Address and Remote Language .................................... 30
Configuring the LAN Interface ............................................. 31
Enabling LAN Services: “Browser,” “Sockets,” “VXI–11” and “LXI–B” ........................................................................... 32
Configuring the Remote Languages ....................................... 33
Configuring the Preset Languages ......................................... 35
Enabling an Option ............................................................... 37
Viewing Options and Licenses ............................................... 38
Hardware Assembly Installation and Removal Softkeys .......... 39

### 3 Basic Operation

Presetting the Signal Generator ............................................. 42
Viewing Key Descriptions ..................................................... 42
Entering and Editing Numbers and Text ................................ 43
Entering Numbers and Moving the Cursor ........................... 43
Entering Alpha Characters .................................................... 43
Example: Using a Table Editor .............................................. 44
Setting Frequency and Power (Amplitude) ............................. 45
Example: Configuring a 700 MHz, −20 dBm Continuous Wave Output ................................................................. 46
Using an External Reference Oscillator ................................. 46
Setting ALC Bandwidth Control .............................................. 47
Configuring a Swept Output .................................................. 48
Routing Signals ................................................................. 50
Step Sweep ........................................................................... 50
List Sweep ........................................................................... 56
Example: Using a Single Sweep ............................................ 59
Example: Manual Control of Sweep ...................................... 60
Contents

Modulating the Carrier Signal .................................................. 60
  Example ............................................................................. 60
  Simultaneous Modulation ...................................................... 62
Working with Files ................................................................. 62
  File Softkeys ....................................................................... 63
  Viewing a List of Stored Files ............................................... 64
  Storing a File ....................................................................... 65
  Loading (Recalling) a Stored File ......................................... 67
  Moving a File from One Media to Another ......................... 68
  Working with Instrument State Files ..................................... 69
  Selecting the Default Storage Media ..................................... 73
Reading Error Messages ........................................................... 74
  Error Message Format .......................................................... 74

4 Using Analog Modulation (Option UNT Only)

  The Basic Procedure .............................................................. 76
  Using an External Modulation Source .................................... 77
  Removing a DC Offset ............................................................... 77
  Using Wideband AM ............................................................... 77

5 Optimizing Performance

  Using the Dual Power Meter Display ..................................... 80
  Example: Dual Power Meter Calibration ................................. 83
  Using Flatness Correction ...................................................... 88
  Creating a User Flatness Correction Array ......................... 90
  Recalling and Applying a User Flatness Correction Array ........ 96
  Using Internal Channel Correction—(Requires Option U01 or Greater) .................................................. 97
  Configure Internal Channel Correction ................................ 98
  Using I/Q Mod Skew Cal ......................................................... 99
  Using External Leveling (N5183A Only) ................................. 102
    Option 1E1 Output Attenuator Behavior and Use ............... 105
    Configure External Leveling ............................................. 106
  Using Uneveled Operating Modes ........................................ 110
    ALC Off Mode .................................................................. 110
    Power Search Mode .......................................................... 111
  Using an Output Offset, Reference, or Multiplier ................ 113
    Setting an Output Offset .................................................... 113
    Setting an Output Reference ............................................. 114
    Setting a Frequency Multiplier .......................................... 115
  Using the Frequency and Phase Reference Softkeys ............... 117
Contents

Using Free Run, Step Dwell, and Timer Trigger ........................................ 117
Understanding Free Run, Step Dwell, and Timer Trigger Setup .................. 118
Using LXI (Option ALB) ................................................................. 120
Understanding LXI Clocks .................................................................. 120
Getting Started With LXI .................................................................. 122
For More Information ........................................................................ 125
Using a USB Keyboard ....................................................................... 126

6 Using Pulse Modulation (Option UNU or UNW or 320)

Pulse Characteristics .......................................................................... 129
The Basic Procedure ........................................................................... 131
Example ............................................................................................... 131
Pulse Train (Option 320 – Requires: Option UNU or UNW) ...................... 132

7 Basic Digital Operation—No BBG Option Installed

I/Q Modulation .................................................................................... 138
Configuring the Front Panel Inputs ......................................................... 139

8 Basic Digital Operation (Option 651/652/654)

Waveform File Basics .......................................................................... 142
Signal Generator Memory ..................................................................... 142
Dual ARB Player .................................................................................. 142
Storing, Loading, and Playing a Waveform Segment ................................. 144
Loading a Waveform Segment into BBG Media ...................................... 144
Storing/Renaming a Waveform Segment to Internal or USB Media .......... 145
Playing a Waveform Segment ............................................................... 145
Waveform Sequences .......................................................................... 147
Creating a Sequence ............................................................................ 148
Viewing the Contents of a Sequence ...................................................... 149
Editing a Sequence ............................................................................. 149
Playing a Sequence ............................................................................ 150
Saving a Waveform’s Settings & Parameters ......................................... 151
Viewing and Modifying Header Information .......................................... 153
Viewing & Editing a Header without Selecting the Waveform .................. 155
Using Waveform Markers ................................................................... 157
Waveform Marker Concepts ................................................................ 158
Accessing Marker Utilities .................................................................. 162
Contents

Viewing Waveform Segment Markers .................................................. 163
Clearing Marker Points from a Waveform Segment .......................... 163
Setting Marker Points in a Waveform Segment .............................. 164
Viewing a Marker Pulse ................................................................. 167
Using the RF Blanking Marker Function ....................................... 168
Setting Marker Polarity ................................................................. 170
Controlling Markers in a Waveform Sequence ............................... 170
Using the EVENT Output Signal as an Instrument Trigger .............. 173
Trigging a Waveform ................................................................. 174
Trigger Type .............................................................................. 175
Trigger Source ........................................................................... 176
Example: Segment Advance Trigging .......................................... 177
Example: Gated Trigging ............................................................. 178
Example: External Trigging ......................................................... 180
Clipping a Waveform ................................................................. 181
How Power Peaks Develop ......................................................... 182
How Peaks Cause Spectral Regrowth .......................................... 184
How Clipping Reduces Peak-to-Average Power ............................ 185
Configuring Circular Clipping ..................................................... 188
Configuring Rectangular Clipping ............................................... 189
Scaling a Waveform ................................................................. 190
How DAC Over-Range Errors Occur ........................................... 191
How Scaling Eliminates DAC Over-Range Errors ...................... 192
Setting Waveform Runtime Scaling ............................................. 193
Setting Waveform Scaling ......................................................... 194
Setting the Baseband Frequency Offset ....................................... 196
DAC Over-Range Conditions and Scaling .................................... 198
I/Q Modulation ........................................................................ 200
Using the Rear Panel I and Q Outputs ....................................... 201
Configuring the Front Panel Inputs ............................................. 202
I/Q Adjustments ........................................................................ 203
I/Q Calibration ........................................................................ 205
Using the Equalization Filter ...................................................... 207
Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter 209
Creating a User-Defined FIR Filter Using the FIR Table Editor .......... 210
Modifying a FIR Filter Using the FIR Table Editor ...................... 215
Loading the Default Gaussian FIR File ...................................... 216
Modifying the Coefficients ......................................................... 217
Storing the Filter to Memory ...................................................... 218
Setting the Real-Time Modulation Filter .................................... 219
Contents

Multiple Baseband Generator Synchronization ........................................... 220
Understanding the Master/Slave System .................................................. 223
Equipment Setup ...................................................................................... 224
Configuring the Setup ............................................................................... 224
Making Changes to the Multiple Synchronization Setup and Resynchronizing the Master/Slave System .................................................. 226
Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator Synchronization ........................................... 227
Configuring the Option 012 (LO In/Out for Phase Coherency) with MIMO .................................................................................. 227
Waveform Licensing for Firmware Version ≥ A.01.50 ................................ 231
Understanding Waveform Licensing ......................................................... 231
Installing an Option N5182-22x or Option N5182A–25x ............................. 231
Licensing a Signal Generator Waveform .................................................... 231
Waveform 5–Pack Licensing (Options 221–229) for Firmware Version < A.01.50 ........................................................... 239
Understanding Waveform 5–Pack Licensing ............................................ 239
Installing an Option N5182A–22x Waveform 5–Pack Licensing .................... 239
Licensing a Signal Generator Waveform File ......................................... 240
Waveform 5–Pack Licensing Softkeys Overview ....................................... 240
Using Waveform 5–Pack History .............................................................. 246
Waveform 5–Pack Warning Messages ....................................................... 250

9 Adding Real–Time Noise to a Signal (Option 403)
   Adding Real–Time Noise to a Dual ARB Waveform .................................. 251
   Eb/No Adjustment Softkeys for Real Time I/Q Baseband AWGN ............... 254
   Using Real Time I/Q Baseband AWGN ................................................ 257

10 Real–Time Phase Noise Impairments (Option 432)
   Real–Time Phase Noise Impairment ...................................................... 260
   The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments ................................................................. 261
   Understanding the Phase Noise Adjustments ......................................... 263
   DAC Over–Range Conditions and Scaling ............................................. 264

11 Custom Digital Modulation (Option 431)
   Custom Modulation ............................................................................... 266
   ARB Custom Modulation Waveform Generator .................................... 266
   Using the Arbitrary Waveform Generator ............................................. 271
   Using Predefined Custom TDMA Digital Modulation ............................ 271
   Creating a Custom TDMA Digital Modulation State ............................ 273
   Storing a Custom TDMA Digital Modulation State ............................. 275
  Recalling a Custom TDMA Digital Modulation State ............................. 277
Contents

Creating a Custom Multicarrier TDMA Digital Modulation State .............................. 278
Storing a Custom Multicarrier TDMA Digital Modulation State ............................. 280
Applying Changes to an Active Multicarrier TDMA Digital Modulation State .......... 280
Using Finite Impulse Response (FIR) Filters in ARB Custom Modulation ................. 281
Creating a User–Defined FIR Filter Using the FIR Table Editor ............................ 281
Modifying a FIR Filter Using the FIR Table Editor .............................................. 286
Loading the Default Gaussian FIR File .............................................................. 287
Modifying the Coefficients ................................................................................. 288
Storing the Filter to Memory .............................................................................. 289
Differential Encoding ......................................................................................... 289
Using Differential Encoding .............................................................................. 293

12 Multitone and Two–Tone Waveforms (Option 430)

Creating a Custom Two–Tone Waveform ............................................................. 297
Creating a Custom Multitone Waveform .............................................................. 297
Using Two–Tone Modulation .............................................................................. 298
  Two–Tone Modulation Softkeys ......................................................................... 299
Creating a Two–Tone Waveform ......................................................................... 299
Viewing a Two–Tone Waveform ........................................................................ 300
Minimizing Carrier Feedthrough ...................................................................... 301
Changing the Alignment of a Two–Tone Waveform ............................................ 302
Using Multitone Modulation ............................................................................. 304
  Multitone Modulation Softkeys ........................................................................ 304
Initializing the Multitone Setup Table Editor ..................................................... 304
Configuring Tone Powers and Tone Phases ......................................................... 305
Removing a Tone ................................................................................................. 305
Generating the Waveform .................................................................................. 305
Configuring the RF Output ................................................................................ 306
Applying Changes to an Active Multitone Signal ................................................ 306

13 Working in a Secure Environment

Understanding Memory Types .............................................................................. 309
Removing Data from Memory (Option 006 Only) .................................................. 312
  Erase All ........................................................................................................... 312
  Erase and Overwrite All ................................................................................... 313
  Erase and Sanitize All ..................................................................................... 313
Removing Persistent State Information Not Removed During Erase .................... 313
Secure Mode ....................................................................................................... 314
Securing a Nonfunctioning Instrument ............................................................... 314
Using the Secure Display (Option 006 Only) ......................................................... 315
14 Troubleshooting

Display

The Display is Too Dark to Read 318
The Display Turns Black when Using USB Media 318

Signal Generator Lock–Up

RF Output

No RF Output 318
Power Supply Shuts Down 318
No Modulation at the RF Output 318
RF Output Power too Low 319
Distortion 319
Signal Loss While Working with a Spectrum Analyzer 319
Signal Loss While Working with a Mixer 320

Sweep

Cannot Turn Off Sweep 322
Sweep Appears Stalled 322
Incorrect List Sweep Dwell Time 322
List Sweep Information is Missing from a Recalled Register 322
Amplitude Does Not Change in List or Step Sweep 322

Internal Media Data Storage

Instrument State Saved but the Register is Empty or Contains the Wrong State 323
USB Media Data Storage

Instrument Recognizes USB Media Connection, but Does Not Display Files 323

Preset

The Signal Generator Does NotRespond 323
Pressing Preset Performs a User Preset 323

Error Messages

Error Message Types 324
Error Message File 324

Front Panel Tests

Self Test Overview 326

Licenses

A Time–Based License Quits Working 328
Cannot Load a Time–Based License 328
Contacting Agilent Technologies

Returning a Signal Generator to Agilent 328
Documentation Overview

Installation Guide
- Safety Information
- Receiving the Instrument
- Environmental & Electrical Requirements
- Basic Setup
- Accessories
- Operation Verification
- Regulatory Information

User's Guide
- Signal Generator Overview
- Setting Preferences & Enabling Options
- Basic Operation
- Optimizing Performance
- Using Analog Modulation (Option UNT Only)
- Using Pulse Modulation (Option UNU Only)
- Basic Digital Operation – No BBG Option Installed
- Basic Digital Operation (Option 651/652/654)
- Adding Real–Time Noise to a Signal (Option 403)
- Real–Time Phase Noise Impairments (Option 432)
- Custom Digital Modulation (Option 431)
- Multitone and Two–Tone Waveform Generator (Option 430)
- Working in a Secure Environment
- Troubleshooting

Programming Guide
- Getting Started with Remote Operation
- Using IO Interfaces
- Programming Examples
- Programming the Status Register System
- Creating and Downloading Files
- Creating and Downloading User–Data Files
**SCPI Reference**
- SCPI Basics
- Basic Function Commands
- LXI System Commands
- System Commands
- Analog Modulation Commands
- Arb Commands
- Real-Time Commands
- N5161A/62A/81A/82A SCPI Command Compatibility
- N5183A SCPI Command Compatibility

**Service Guide**
- Troubleshooting
- Replaceable Parts
- Assembly Replacement
- Post–Repair Procedures
- Safety and Regulatory Information
- Instrument History

**Key Help**
- Key function description
- Related SCPI commands

---

*a*Press the **Help** hardkey, and then the key for which you wish help.
1 Signal Generator Overview

**CAUTION** To avoid damaging or degrading the performance of the MXG, do not exceed 33 dBm (2W) maximum of reverse power levels at the RF input. See also *Tips for Preventing Signal Generator Damage* on www.agilent.com.

**NOTE** The N5161A/62A MXG ATE is identical to the N5181A/82A with the exception that they do not have front panel functionality (no display or keys). Instead all functionality is controlled through SCPI commands or the Web-Enabled MXG. For signal generator functionality, refer to the *Users Guide*. For information on the Web–Enabled MXG, refer to the *Installation Guide*, the *Programming Guide* and the *SCPI Command Reference*.

MXG ATE blank front panel models, N5161A and N5162A signal generators, are part of the MXG instrument family and unless otherwise indicated, all references to the MXG are inclusive of the MXG ATE instruments.

Full Option ALB LXI–B feature implementation is only available on instruments with firmware $\geq$A.01.50. A license may be required to enable this feature and to download firmware versions $\geq$A.01.50. For information on new firmware releases, go to http://www.agilent.com/find/upgradeassistant.

- Signal Generator Features on page 2
- Modes of Operation on page 4
- Front Panel Overview – N5181A/82A MXG on page 5
- Front Panel Overview – N5161A/62A MXG ATE on page 9
- Front Panel Display – N5181A/82A/83A MXG on page 11
- Blank Front Panel Display – N5161A/62A MXG ATE on page 13
- Rear Panel Overview – N5161A/62A/81A/82A/83A MXG on page 15
Signal Generator Features

- N5161A/N5181A, RF analog models: 100 kHz to 1, 3, or 6 GHz (Options 501, 503, and 506 respectively)
- N5162A/N5182A, RF vector models: 100 kHz to 3 or 6 GHz (Options 503, and 506 respectively)
- N5183A, Microwave analog model: 100 kHz to 20, 31.8, or 40 GHz (Options 520, 532, and 540 respectively)
- electronic attenuator (N5161A/62A/81A/82A only)
- mechanical attenuator (N5183A with Option 1E1 only)
- step & list sweep of frequency, power, or frequency and power
- vector models can include waveforms in list sweep
- pulse modulation (Option UNU)
- narrow pulse modulation (Option UNW)
- analog differential I/Q outputs (vector models, Option 1EL)
- analog modulation: AM, FM, and ΦM (Option UNT)
- arbitrary I/Q waveform playback up to 125 MSa/s (vector models, Option 654)
- automatic leveling control (ALC); power calibration
- bandwidth control (ALC)
- deep amplitude modulation providing greater dynamic range
- enhanced assembly replacement
- external AM, FM, and ΦM inputs (Option UNT)
- external analog I/Q inputs (vector models)
- Wideband AM (vector models, Option UNT)
- flexible reference input, 1 – 50 MHz (Option 1ER)
- GPIB, USB 2.0, and 100Base-T LAN interfaces
- improved signal to noise ratio
- LO In/Out (Option 012)
- LXI is supported (Option ALB)
- Digital Bus I/O compatibility with the PXB
- manual power search (ALC off) (Option 099 and or instruments starting with serial numbers 4818 and greater)
- multiple baseband generator synchronization when using multiple signal generators (master/slave setup)
- narrow pulse modulation (Option UNW)

1The N5161A/62A – Automated Test Equipment (ATE) have a blank front panel (i.e. no front panel display, hardkeys or softkeys).
2Option 501 is not applicable to the N5161A.
Signal Generator Overview
Signal Generator Features

- phase noise interference (vector models, Option 432)
- internal channel correction (vector models, Option U01)
- SCPI and IVI–COM driver
- user flatness correction
- user settable maximum power limit
- two channel power meter display
- 10 MHz reference oscillator with external output
- 8648/ESG code compatible
- real-time modulation filtering
- with Signal Studio Software, vector models can generate 802.11 WLAN, W–CDMA, cdma2000, 1xEV–DO, GSM, EDGE, and more

For more details on hardware, firmware, software, and documentation features and options, refer to the data sheet shipped with the signal generator and available from the Agilent Technologies website.

2. Select the desired model number.
3. In the options and price list section, click **price list**.
Modes of Operation

Depending on the model and installed options, the Agilent MXG signal generator provides up to four basic modes of operation: continuous wave (CW), swept signal, analog modulation, and digital modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to a single frequency and power level. Both the N5161A/81A and N5162A/82A can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over a range of frequencies and/or power levels. Both the N5161A/81A and N5162A/82A provide list and step sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog modulation types available depend on the installed options.

Option UNT provides AM, FM, and PM modulations. Some of these modulations can be used together.

NOTE

The Mod On/Off hardkey and LED functionality are only valid for MXGs with Option UNT installed. Refer to 14. Mod On/Off and LED.

Options UNU and UNW provide standard and narrow pulse modulation capability, respectively.

Digital Modulation (N5162A/82A with Options 651, 652, or 654 Only)

NOTE

The internal baseband generator speed upgrade Options 670, 671, and 672 are option upgrades that require Option 651 and 652 to have been loaded at the factory (refer to the Data Sheet for more information). Any references to 651, 652, or 654 are inclusive of 671, 672, and 674.

In this mode, the signal generator modulates a CW signal with an arbitrary I/Q waveform. I/Q modulation is only available on the N5162A/82A. An internal baseband generator (Option 651, 652, or 654) adds the following digital modulation formats:

- **Custom Arb Waveform Generator** mode can produce a single-modulated carrier or multiple-modulated carriers. Each modulated carrier waveform must be calculated and generated before it can be output; this signal generation occurs on the internal baseband generator. Once a waveform has been created, it can be stored and recalled, which enables repeatable playback of test signals. To learn more, refer to “Using the Arbitrary Waveform Generator” on page 271.

- **Multitone** mode produces up to 64 continuous wave signals (or tones). Like the Two Tone mode, the frequency spacing between the signals and the amplitudes are adjustable. To learn more, refer to “Creating a Custom Multitone Waveform” on page 297.
• **Two-tone** mode produces two separate continuous wave signals (or tones). The frequency spacing between the signals and the amplitudes are adjustable. To learn more, refer to Chapter 12, "Multitone and Two–Tone Waveforms (Option 430)".

• **Dual ARB** mode is used to control the playback sequence of waveform segments that have been written into the ARB memory located on the internal baseband generator. These waveforms can be generated by the internal baseband generator using the Custom Arb Waveform Generator mode, or downloaded through a remote interface into the ARB memory. To learn more, refer to “Dual ARB Player” on page 142.

### Front Panel Overview – N5181A/82A MXG

1. **Host USB**
   
   **Connector** Type A  
   **USB Protocol** 2.0  

   Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can connect or disconnect a USB device without shutting down or restarting the signal generator. The instrument also has a rear panel device USB connector (see page 17) used to remotely control the instrument.

2. **Display**

   The LCD screen provides information on the current function. Information can include status indicators, frequency and amplitude settings, and error messages. Labels for the softkeys are located on the right hand side of the display. See also, “Front Panel Display – N5181A/82A/83A MXG” on page 11.

3. **Softkeys**

   A softkey activates the function indicated by the displayed label to the left of the key.
4. Numeric Keypad

The numeric keypad comprises the 0 through 9 hardkeys, a decimal point hardkey, a minus sign hardkey, and a backspace hardkey. See “Entering and Editing Numbers and Text” on page 43.

5. Arrows and Select

The Select and arrow hardkeys enable you to select items on the signal generator’s display for editing. See “Entering and Editing Numbers and Text” on page 43.

6. Page Up

In a table editor, use this hardkey to display a previous page. See “Example: Using a Table Editor” on page 44. When text does not fit on one page in the display area, use this key in conjunction with the Page Down key (page 7) to scroll text.

7. MENUS

These hardkeys open softkey menus that enable you to configure instrument functions or access information.

8. Trigger

When trigger mode is set to Trigger Key, this hardkey initiates an immediate trigger event for a function such as a list or step sweep.

9. Local Cancel/(Esc)

This hardkey deactivates remote operation and returns the signal generator to front panel control, cancels an active function entry, and cancels long operations (such an IQ calibration).
10. Help

Use this key to display a description of any hardkey or softkey. See “Viewing Key Descriptions” on page 42.

11. Preset and User Preset

These hardkeys set the signal generator to a known state (factory or user-defined). See “Presetting the Signal Generator” on page 42.

12. RF Output

<table>
<thead>
<tr>
<th>Connector</th>
<th>Standard: female Type–N</th>
<th>Option 1EM: Rear panel female Type–N</th>
</tr>
</thead>
<tbody>
<tr>
<td>Damage Levels</td>
<td>50 Vdc, 2 W maximum RF power</td>
<td></td>
</tr>
</tbody>
</table>

13. RF On/Off and LED

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The RF On/Off LED lights when RF output is enabled.

14. Mod On/Off and LED

This hardkey enables or disables the modulation of the output carrier signal by an active modulation format. This hardkey does not set up or activate a format (see “Modulating the Carrier Signal” on page 60).

The MOD ON/OFF LED lights when modulation of the output is enabled.

**NOTE** The Mod On/Off hardkey and LED functionality are only valid for MXGs with Option UNT installed.

15. Page Down

In a table editor, use this hardkey to display the next page. See “Example: Using a Table Editor” on page 44. When text does not fit on one page in the display area, use this key in conjunction with the Page Up key (page 6) to scroll text.

16. I Input (vector models only)

<table>
<thead>
<tr>
<th>Connector</th>
<th>Type: female BNC</th>
<th>Impedance: 50 Ω</th>
</tr>
</thead>
<tbody>
<tr>
<td>Signal</td>
<td>An externally supplied analog, in-phase component of I/Q modulation.</td>
<td></td>
</tr>
<tr>
<td>Damage Levels</td>
<td>1 Vrms</td>
<td></td>
</tr>
</tbody>
</table>

The signal level is $\frac{\sqrt{I^2 + Q^2}}{2} = 0.5 \, \text{Vrms}$ for a calibrated output level.

See also, “I/Q Modulation” on page 200.
17. Q Input (vector models only)

**Connector**
Type: female BNC  
Impedance: 50 $\Omega$

**Signal**
An externally supplied analog, quadrature-phase component of I/Q modulation.  
The signal level is $\sqrt{\frac{3}{1+Q^2}} = 0.5 \, V_{rms}$ for a calibrated output level.

**Damage Levels**
$1 \, V_{rms}$

See also, “I/Q Modulation” on page 200.

18. Knob

Rotating the knob increases or decreases a numeric value, or moves the highlight to the next digit, character, or item in a list. See also, “Front Panel Knob Resolution” on page 28.

19. Incr Set

This hardkey enables you to set the increment value of the currently active function. The increment value also affects how much each turn of the knob changes an active function’s value, according to the knob’s current ratio setting (see “Front Panel Knob Resolution” on page 28).

20. Return

This hardkey enables you to retrace key presses. In a menu with more than one level, the Return key returns to the prior menu page.

21. More and LED

When a menu contains more softkey labels than can be displayed, the More LED lights and a More message displays below the labels. To display the next group of labels, press the More hardkey.

22. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow LED lights and all signal generator functions deactivate. The signal generator remains connected to the line power, and some power is consumed by some internal circuits. In the on position, the green LED lights and the signal generator functions activate.
Front Panel Overview – N5161A/62A MXG ATE

N5161A/62A MXG ATE Front Panel Functions

The MXG ATE is identical to an MXG with a front panel display, except that the front panel, hardkeys and softkeys functionality are only available through SCPI commands or the Web–Enabled MXG. For information on the Web–Enabled MXG, refer to the Installation Guide, the Programming Guide and the SCPI Command Reference.

Functions unique to the MXG ATE:

- LAN LED (page 10).
- 1588 LED (page 10).
- ERROR LED (page 10).
- LAN Reset Hardkey (page 10).

For more information, refer to the Service Guide.

1. Host USB

<table>
<thead>
<tr>
<th>Connector</th>
<th>Type A</th>
</tr>
</thead>
<tbody>
<tr>
<td>USB Protocol</td>
<td>2.0</td>
</tr>
</tbody>
</table>

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can connect or disconnect a USB device without shutting down or restarting the signal generator. The instrument also has a rear panel device USB connector (see page 17) used to remotely control the instrument.
2. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow LED lights and all signal generator functions deactivate. The signal generator remains connected to the line power, and some power is consumed by some internal circuits. In the on position, the green LED lights and the signal generator functions activate.

3. LAN LED

The LAN LED is used to indicate the LAN status.
- If the LED is off, the LAN is down.
- If the LED is blinking, the LAN is being configured (1.2 second duty cycle).
- A 400ms duty cycle indicates the instrument has been placed into LAN Identify mode. (Refer to :INPut:LAN[:SET]:IDENtifier command).
- If the LED is solidly lit, the LAN is up and functional.
- If the LED fails to function, refer to the Service Guide.

4. 1588 LED

The 1588 LED indicates when the instrument is locked to an external 1588 clock.
- If the 1588 green LED is on, a 1588 signal has been detected on the TRIG OUT BNC on the rear panel.
- If the 1588 green LED is off, no 1588 signal is detected on the TRIG OUT BNC on the rear panel.
- If the LED fails to function, refer to the Service Guide.

5. ERROR LED

The ERROR LED indicates when there are unread errors in the error queue.
- If Auto reboot is disabled, the LED will blink when an exception occurs during power up.
- If the LED fails to function, refer to the Service Guide.

6. LAN Reset Hardkey

NOTE This hardkey is enabled for fail–safe and diagnostic mode and should rarely be used. If the LAN Reset hardkey has been pressed and then the power is cycled on the instrument, the web-server will be enabled after reboot.

The LAN Reset is used to access the diagnostics mode during power up.
- Refer to the SCPI Command Reference for equivalent remote commands.
- If the LAN Reset fails to function, refer to the Service Guide.
Front Panel Display – N5181A/82A/83A MXG

1. Active Function Area

This area displays the currently active function. For example, if frequency is the active function, the current frequency setting appears. If the currently active function has an increment value associated with it, that value also appears.

2. Frequency Area

This area displays the current frequency setting.

3. Annunciators

Annunciators show the status of some of the signal generator functions, and indicate error conditions. An annunciator position may be used by more than one annunciator; in this case, only one of the functions sharing a given position can be active at a given time.

This annunciator appears when...

<table>
<thead>
<tr>
<th>Annunciator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FM</td>
<td>Phase modulation is on. If you turn frequency modulation on, the FM annunciator replaces Φm.</td>
</tr>
<tr>
<td>ARB</td>
<td>The ARB generator is on. ARB is running and not waiting on a trigger.</td>
</tr>
<tr>
<td>ALC OFF</td>
<td>The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and is unable to maintain the output level.</td>
</tr>
<tr>
<td>AM</td>
<td>Amplitude modulation is on.</td>
</tr>
<tr>
<td>ARMED</td>
<td>A sweep has been initiated and the signal generator is waiting for the sweep trigger event.</td>
</tr>
<tr>
<td>ATTNHOLD</td>
<td>The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.</td>
</tr>
<tr>
<td>AWGN</td>
<td>Real Time I/Q Baseband additive white Gaussian noise is on.</td>
</tr>
</tbody>
</table>
Signal Generator Overview
Front Panel Display – N5181A/82A/83A MXG

4. Amplitude Area

This area displays the current output power level setting (If the RF Output is off, this area is greyed out).

This annunciator appears when...

<table>
<thead>
<tr>
<th>Annunciator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BBG DAC</td>
<td>A DAC overflow is occurring, adjust the runtime scaling adjust until the BBG DAC annunciator turns off. Another annunciator, UNLOCK, appears in the same position and has priority over the BBG DAC annunciator (see UNLOCK, below).</td>
</tr>
<tr>
<td>CHANCORR</td>
<td>The internal channel correction is enabled.</td>
</tr>
<tr>
<td>DETHTR</td>
<td>The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at temperature.</td>
</tr>
<tr>
<td>DIGBUS</td>
<td>The digital bus is in use.</td>
</tr>
<tr>
<td>DIGMOD</td>
<td>Custom Arb waveform generator is on.</td>
</tr>
<tr>
<td>ERR</td>
<td>An error message is placed in the error queue. This annunciator does not turn off until you either view all of the error messages or clear the error queue (see “Reading Error Messages” on page 74).</td>
</tr>
<tr>
<td>EXTREF</td>
<td>An external frequency reference is applied.</td>
</tr>
<tr>
<td>FM</td>
<td>Frequency modulation is on. If you turn phase modulation on, the ( \Phi ) annunciator replaces FM.</td>
</tr>
<tr>
<td>I/Q</td>
<td>I/Q vector modulation is on.</td>
</tr>
<tr>
<td>L</td>
<td>The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or VXI–11/Sockets (LAN) interface.</td>
</tr>
<tr>
<td>M–TONE</td>
<td>Multitone waveform generator is on.</td>
</tr>
<tr>
<td>MULT</td>
<td>A frequency multiplier is set (see “Setting a Frequency Multiplier” on page 115).</td>
</tr>
<tr>
<td>OFFS</td>
<td>An output offset is set (see “Setting an Output Offset” on page 113).</td>
</tr>
<tr>
<td>PN</td>
<td>Phase noise interference is on.</td>
</tr>
<tr>
<td>PULSE</td>
<td>Pulse modulation is on.</td>
</tr>
<tr>
<td>R</td>
<td>The signal generator is remotely controlled over the GPIB, USB, or VXI–11/Sockets (LAN) interface. When the signal generator is in remote mode, the keypad is locked out. To unlock the keypad, press Local.</td>
</tr>
<tr>
<td>REF</td>
<td>An output reference is set (see “Setting an Output Reference” on page 114).</td>
</tr>
<tr>
<td>RF OFF</td>
<td>The signal generator’s RF Output is not enabled.</td>
</tr>
<tr>
<td>S</td>
<td>The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI–11/Sockets (LAN) interface.</td>
</tr>
<tr>
<td>SWEET</td>
<td>The signal generator is currently sweeping in list or step mode.</td>
</tr>
<tr>
<td>SWMAN</td>
<td>The signal generator is in manual sweep mode.</td>
</tr>
<tr>
<td>T</td>
<td>The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI–11/Sockets (LAN) interface.</td>
</tr>
<tr>
<td>T–TONE</td>
<td>Two–Tone waveform generator is on.</td>
</tr>
<tr>
<td>UNLEVEL</td>
<td>The signal generator is unable to maintain the correct output level. This is not necessarily an indication of instrument failure; unlevelled conditions can occur during normal operation. Another annunciator, ALC OFF, appears in the same position when the ALC circuit is disabled (see ALC OFF, above).</td>
</tr>
<tr>
<td>UNLOCK</td>
<td>Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the error messages (see “Reading Error Messages” on page 74).</td>
</tr>
<tr>
<td>WATRG</td>
<td>The current modulation mode is waiting on the Arb trigger.</td>
</tr>
<tr>
<td>WINIT</td>
<td>The signal generator is waiting for you to initiate a single sweep.</td>
</tr>
</tbody>
</table>
5. Error Message Area

This area displays abbreviated error messages. If multiple messages occur, only the most recent message remains displayed. See “Reading Error Messages” on page 74.

6. Text Area

This area displays signal generator status information, such as the modulation status, and other information such as sweep lists and file catalogs. This area also enables you to perform functions such as managing information (entering information, and displaying or deleting files).

7. Softkey Label Area

This area displays labels that define the function of the softkeys located immediately to the right of the display. Softkey labels change, depending on the function selected.

Blank Front Panel Display – N5161A/62A MXG ATE

N5161A/62A MXG ATE – Web Enabled Display

The MXG ATE only has display information available through a LAN connection to the Web Server (“11. LAN” on page 17). For more information on the Web–Enabled MXG, refer to Programming Guide.

Annunciators

NOTE On the N5161A/62A, the following listing of annunciators are only displayed and visible through the Web–Enabled MXG. Refer to Programming Guide, “Using the Web Browser”.

Annunciators show the status of some of the signal generator functions, and indicate error conditions. An annunciator position may be used by more than one annunciator; in this case, only one of the functions sharing a given position can be active at a given time.

<table>
<thead>
<tr>
<th>Annunciator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ΦM</td>
<td>Phase modulation is on. If you turn frequency modulation on, the FM annunciator replaces ΦM.</td>
</tr>
<tr>
<td>ARB</td>
<td>The ARB generator is on. ARB is running and not waiting on a trigger.</td>
</tr>
<tr>
<td>ALC OFF</td>
<td>The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and is unable to maintain the output level.</td>
</tr>
<tr>
<td>AM</td>
<td>Amplitude modulation is on.</td>
</tr>
<tr>
<td>ARMED</td>
<td>A sweep has been initiated and the signal generator is waiting for the sweep trigger event.</td>
</tr>
<tr>
<td>ATTNHOLD</td>
<td>The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.</td>
</tr>
<tr>
<td>BBG DAC</td>
<td>A DAC overflow is occurring, adjust the runtime scaling adjust until the BBG DAC annunciator turns off. Another annunciator, UNLOCK, appears in the same position and has priority over the BBG DAC annunciator (see UNLOCK, below).</td>
</tr>
<tr>
<td>DETHTR</td>
<td>The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at temperature.</td>
</tr>
<tr>
<td>AWGN</td>
<td>Real Time I/Q Baseband additive white Gaussian noise is on.</td>
</tr>
</tbody>
</table>
# Signal Generator Overview

Blank Front Panel Display – N5161A/62A MXG ATE

## This annunciator appears when...

<table>
<thead>
<tr>
<th>Annunciator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DIGBUS</td>
<td>The digital bus is in use.</td>
</tr>
<tr>
<td>DIGMOD</td>
<td>Custom Arb waveform generator is on.</td>
</tr>
<tr>
<td>ERR</td>
<td>An error message is placed in the error queue. This annunciator does not turn off until you either view all of the error messages or clear the error queue (see “Reading Error Messages” on page 74).</td>
</tr>
<tr>
<td>EXTREF</td>
<td>An external frequency reference is applied.</td>
</tr>
<tr>
<td>FM</td>
<td>Frequency modulation is on. If you turn phase modulation on, the $\Phi_M$ annunciator replaces FM.</td>
</tr>
<tr>
<td>I/Q</td>
<td>I/Q vector modulation is on.</td>
</tr>
<tr>
<td>L</td>
<td>The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or VXI-11/Sockets (LAN) interface.</td>
</tr>
<tr>
<td>M–TONE</td>
<td>Multitone waveform generator is on.</td>
</tr>
<tr>
<td>MULI</td>
<td>A frequency multiplier is set (see “Setting a Frequency Multiplier” on page 115).</td>
</tr>
<tr>
<td>OFFS</td>
<td>An output offset is set (see “Setting an Output Offset” on page 113).</td>
</tr>
<tr>
<td>PN</td>
<td>Phase noise interference is on.</td>
</tr>
<tr>
<td>PULSE</td>
<td>Pulse modulation is on.</td>
</tr>
<tr>
<td>R</td>
<td>The signal generator is remotely controlled over the GPIB, USB, or VXI-11/Sockets (LAN) interface. When the signal generator is in remote mode, the keypad is locked out. To unlock the keypad, press Local.</td>
</tr>
<tr>
<td>REF</td>
<td>An output reference is set (see “Setting an Output Reference” on page 114).</td>
</tr>
<tr>
<td>RF OFF</td>
<td>The signal generator’s RF Output is not enabled.</td>
</tr>
<tr>
<td>S</td>
<td>The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI-11/Sockets (LAN) interface.</td>
</tr>
<tr>
<td>SWEEP</td>
<td>The signal generator is currently sweeping in list or step mode.</td>
</tr>
<tr>
<td>SWMAN</td>
<td>The signal generator is in manual sweep mode.</td>
</tr>
<tr>
<td>T</td>
<td>The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI-11/Sockets (LAN) interface.</td>
</tr>
<tr>
<td>T–TONE</td>
<td>Two-Tone waveform generator is on.</td>
</tr>
<tr>
<td>UNLEVEL</td>
<td>The signal generator is unable to maintain the correct output level. This is not necessarily an indication of instrument failure; unleveled conditions can occur during normal operation. Another annunciator, ALC OFF, appears in the same position when the ALC circuit is disabled (see ALC OFF, above).</td>
</tr>
<tr>
<td>UNLOCK</td>
<td>Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the error messages (see “Reading Error Messages” on page 74).</td>
</tr>
<tr>
<td>WATRG</td>
<td>The current modulation mode is waiting on the Arb trigger.</td>
</tr>
<tr>
<td>WINIT</td>
<td>The signal generator is waiting for you to initiate a single sweep.</td>
</tr>
</tbody>
</table>
Rear Panel Overview – N5161A/62A/81A/82A MXG

1. AC Power Receptacle

The AC power cord receptacle accepts a three–pronged AC power cord that is supplied with the signal generator. For details on line setting requirements and the power cord, see the Installation Guide.

**CAUTION**

To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to non-volatile memory, the MXG should always be powered down either via the MXG's front panel power button or the appropriate SCPI command. MXG's installed in rack systems and powered down with the system rack power switch rather than the MXG's front panel switch display a Error - 310 due to the MXG not being powered down correctly.

2. SWEEP OUT

**Connector**

- Female BNC
- Impedance <1 Ω
- Can drive 2 kΩ

**Signal**

- Voltage range: 0 to +10 V, regardless of sweep width
- In swept mode: beginning of sweep = 0 V; end of sweep = +10 V
- In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 50 and 127.

---

\(^1\) The N5161A and N5162A are only available with Option 1EM.
3. AM
Connector: female BNC  
Impedance: nominally 50 Ω
Signal: An externally supplied ±1 Vp signal that produces the indicated depth.
Damage Levels: 5 Vrms and 10 Vp

4. FM
Connector: female BNC  
Impedance: nominally 50 Ω
Signal: An externally supplied ±1 Vp signal that produces the indicated deviation
Damage Levels: 5 Vrms and 10 Vp

5. PULSE
Connector: female BNC  
Impedance: nominally 50 Ω
Signal: Externally supplied: +1 V = on; 0 V = off
Damage Levels: 5 Vrms and 10 Vp

6. TRIG IN
Connector: female BNC  
Impedance: high Z
Signal: An externally supplied TTL or CMOS signal for triggering operations, such as point to point in manual sweep mode or an LF sweep in external sweep mode. Triggering can occur on either the positive or negative edge.
Damage Levels: ≤ −0.5 and ≥+5.5 V

7. TRIG OUT
Connector: female BNC  
Impedance: nominally 50 Ω
Signal: A TTL signal that is high at the start of a dwell sequence, or when waiting for the point trigger in manual sweep mode. It is low when the dwell is over, or when the point trigger is received. The logic polarity can be reversed.
This is a multiple use connector. For signal routing selections, see pages 50 and 127.
8. REF IN

**Connector**  female BNC  Impedance nominally 50 Ω

**Signal**  An externally supplied −3.5 to +20 dBm signal from a timebase reference that is within ±1 ppm.

In its factory default mode, the signal generator can detect a valid reference signal at this connector and automatically switch from internal to external reference operation. See “Presetting the Signal Generator” on page 42. With Option 1ER (flexible reference input), you must explicitly tell the signal generator the external reference frequency you wish to use; enter the information through the front panel or over the remote interface.

9. 10 MHz OUT

**Connector**  female BNC  Impedance nominally 50 Ω

**Signal**  A nominal signal level greater than 4 dBm.

10. GPIB

This connector enables communication with compatible devices such as external controllers, and is one of three connectors available to remotely control the signal generator (see also 11. LAN and 12. Device USB).

11. LAN

The signal generator supports local area network (LAN) based communication through this connector, which enables a LAN–connected computer to remotely program the signal generator. The LAN interface supports auto–MDIX. The signal generator is limited to 100 meters on a single cable (100Base–T). For more information on the LAN, refer to the Programming Guide.

12. Device USB

**Connector**  Mini–B

**USB Protocol**  Version 2.0

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal generator.
Digital Modulation Connectors (Vector Models Only)

**I OUT, Q OUT, İ OUT, Q OUT**

<table>
<thead>
<tr>
<th><strong>NOTE</strong></th>
<th>İ OUT and Q OUT, require Option 1EL.</th>
</tr>
</thead>
</table>

**Connector**
- Type: female BNC
- Impedance: 50 Ω
- DC-coupled

**Signal**
- **I OUT**: The analog, in-phase component of I/Q modulation from the internal baseband generator.
- **Q OUT**: The analog, quadrature-phase component of I/Q modulation from the internal baseband generator.
- **İ OUT**: Used in conjunction with the I OUT connector to provide a balanced baseband stimulus.
- **Q OUT**: Used in conjunction with the Q OUT connector to provide a balanced baseband stimulus.

**Damage Levels**
- > 1 Vrms
- **DC Origin Offset**: typically <10 mV

**Output Signal Levels into a 50 Ω Load**
- 0.5 \( V_{pk} \) typical, corresponds to one unit length of the I/Q vector
- 0.69 \( V_{pk} \) (2.84 dB), typical, maximum crest factor for peaks for \( \pi/4 \) DQPSK, \( \alpha = 0.5 \)
- 0.71 \( V_{pk} \) (3.08 dB), typical, maximum crest factor for peaks for \( \pi/4 \) DQPSK, \( \alpha = 0.35 \)
- Typically 1 \( V_{p-p} \) maximum

*Balanced signals are signals present in two separate conductors that are symmetrical relative to ground, and are opposite in polarity (180 degrees out of phase).

**EXT CLK**

<table>
<thead>
<tr>
<th><strong>Connector</strong></th>
<th>female BNC</th>
</tr>
</thead>
</table>

**Signal**
- An externally supplied TTL or CMOS bit clock signal where the rising edge aligns with the beginning data bit.
- The falling edge is used to clock external signals.
- This signal is used with digital modulation applications.

**Damage Levels**
- < −4 and > +8 V
- **Maximum Clock Rate**: 50 MHz
EVENT 1
Connector  female BNC  Impedance: nominally 50 Ω
Signal  A pulse that can be used to trigger the start of a data pattern, frame, or timeslot. Adjusted to ± one timeslot; resolution = one bit
Markers  Each Arb–based waveform point has a marker on/off condition associated with it. Marker 1 level = +3.3 V CMOS high (positive polarity selected); –3.3 V CMOS low (negative polarity selected). Output on this connector occurs whenever Marker 1 is on in an Arb–based waveform (see “Using Waveform Markers” on page 157).
Damage Levels  <−4 and > +8 V

PAT TRIG
Connector  female BNC  Impedance: nominally 50 Ω
Signal  A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger. The input to this connector triggers the internal digital modulation pattern generator to start a single pattern output or to stop and re–synchronize a pattern that is being continuously output. To synchronize the trigger with the data bit clock, the trigger edge is latched, then sampled during the falling edge of the internal data bit clock. This is the external trigger for all ARB waveform generator triggers.
Minimum Trigger Input Pulse (high or low) = 100 ns
Minimum Trigger Delay (trigger edge to first bit of frame) = 1.5 to 2.5 bit clock periods
Damage Levels  <−4 and > +8 V

DIGITAL BUS I/O
This is a proprietary bus used by Agilent Technologies signal creation software. This connector is not operational for general purpose use. Signals are present only when a signal creation software option is installed (for details, refer to http://www.agilent.com/find/signalcreation).

NOTE  The MXG’s Digital BUS I/O connector can be used for enabling operation with the Agilent Technologies N5106A PXB MIMO Receiver Tester.
### AUX I/O

The AUX I/O connector is a shielded .050 series board mount connector.

**Event 1, 2, 3, and 4 (pins 1-4)**
A pulse that can be used to trigger the start of a data pattern, frame, or timeslot. Adjustable to ± one timeslot; resolution = one bit.

**Markers**
Each Arb-based waveform point has a marker on/off condition associated with it. Marker level = +3.3 V CMOS high (positive polarity selected); −3.3 V CMOS low (negative polarity selected).

**Sample Rate Clock Out (pin 5)**
This output is used with an internal baseband generator. This pin relays a CMOS bit clock signal for synchronizing serial data. Damage levels: < −0.5 and > +5.5 V.

**Patt Trig 2 (pin 6)**
A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger. The input to this connector triggers the internal digital modulation pattern generator to start a single pattern output or to stop and re-synchronize a pattern that is being continuously output.

To synchronize the trigger with the data bit clock, the trigger edge is latched, then sampled during the falling edge of the internal data bit clock.

This is an external trigger for all ARB waveform generator triggers. Minimum pulse width = 100 ns. Damage levels: < −0.5 and > +5.5 V.
Rear Panel Overview – N5183A MXG

1. AC Power Receptacle

The AC power cord receptacle accepts a three–pronged AC power cord that is supplied with the signal generator. For details on line setting requirements and the power cord, refer to the Installation Guide.

**CAUTION**

To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to non-volatile memory, the MXG should always be powered down either via the MXG's front panel power button or the appropriate SCPI command. MXG's installed in rack systems and powered down with the system rack power switch rather than the MXG's front panel switch display an Error -310 due to the MXG not being powered down correctly.

2. SWEEP OUT

**Connector** female BNC

Impedance <1 Ω

Can drive 2 kΩ.

**Signal** Voltage range: 0 to +10 V, regardless of sweep width

In swept mode: beginning of sweep = 0 V; end of sweep = +10 V

In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 50 and 127.
3. AM

**Connector**  
female BNC  
Impedance nominally 50 Ω  

**Signal**  
An externally supplied ±1 V_p signal that produces the indicated depth.  

**Damage Levels**  
5 V_{rms} and 10 V_p  

4. FM

**Connector**  
female BNC  
Impedance nominally 50 Ω  

**Signal**  
An externally supplied ±1 V_p signal that produces the indicated deviation  

**Damage Levels**  
5 V_{rms} and 10 V_p  

5. PULSE

**Connector**  
female BNC  
Impedance nominally 50 Ω  

**Signal**  
Externally supplied: +1 V = on; 0 V = off  

**Damage Levels**  
5 V_{rms} and 10 V_p  

6. TRIG IN

**Connector**  
female BNC  
Impedance high Z  

**Signal**  
An externally supplied TTL or CMOS signal for triggering operations, such as point to point in manual sweep mode or an LF sweep in external sweep mode.  
Triggering can occur on either the positive or negative edge.  

**Damage Levels**  
≤ −0.5 and ≥ +5.5 V  

7. TRIG OUT

**Connector**  
female BNC  
Impedance nominally 50 Ω  

**Signal**  
A TTL signal that is high at the start of a dwell sequence, or when waiting for the point trigger in manual sweep mode.  
It is low when the dwell is over, or when the point trigger is received.  
The logic polarity can be reversed.  

This is a multiple use connector. For signal routing selections, see pages 50 and 127.  

8. REF IN

**Connector**  
female BNC  
Impedance nominally 50 Ω  

**Signal**  
An externally supplied −3.5 to +20 dBm signal from a timebase reference that is within ±1 ppm.  

In its factory default mode, the signal generator can detect a valid reference signal at this connector and automatically switch from internal to external reference operation. See “Presetting the Signal Generator” on page 42. With Option IER (flexible reference input), you must explicitly tell the signal generator the external reference frequency you wish to use; enter the information through the front panel or over the remote interface.
9. 10 MHz OUT

**Connector**  female BNC  
**Impedance** nominally 50 Ω  
**Signal**  A nominal signal level greater than 4 dBm.

10. GPIB

This connector enables communication with compatible devices such as external controllers, and is one of three connectors available to remotely control the signal generator (see also 11. LAN and 12. Device USB).

11. LAN

The signal generator supports local area network (LAN) based communication through this connector, which enables a LAN–connected computer to remotely program the signal generator. The LAN interface supports LXI; it does not support auto–MDIX. The signal generator is limited to 100 meters on a single cable (100Base–T). For more information on the LAN, refer to the *Programming Guide*.

12. Device USB

**Connector**  Mini–B  
**USB Protocol**  Version 2.0

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal generator.

13. Z AXIS OUTPUT

This female BNC connector supplies a +5 V (nominal) level during retrace and band–switch intervals of a step or list sweep. During step or list sweep, this female BNC connector supplies a –5 V (nominal) level when the RF frequency is at a marker frequency and intensity marker mode is on. This signal is derived from an operational amplifier output so the load impedance should be greater than or equal to 5 kohms.
14. ALC INPUT

This input connector is used for negative external detector leveling.

<table>
<thead>
<tr>
<th>Connector</th>
<th>female BNC</th>
<th>Impedance nominally 100 kΩ</th>
</tr>
</thead>
<tbody>
<tr>
<td>Signal</td>
<td>–0.2 mV to –0.5 V</td>
<td></td>
</tr>
<tr>
<td>Damage Levels</td>
<td>–12 to 1 V</td>
<td></td>
</tr>
</tbody>
</table>
2 Setting Preferences & Enabling Options

NOTE For the N5161A/62A MXG ATE the softkey menus and features mentioned in this guide are only available through the Web-Enabled MXG or SCPI commands. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command Reference.

The Utility menu provides access to both user and remote operation preferences, and to the menus in which you can enable instrument options.

- Remote Operation
  - GPIB Address and Remote Language on page 30
  - Configuring the LAN Interface on page 31
  - Enabling LAN Services: “Browser,” “Sockets,” “VXI–11” and “LXI–B” on page 32
  - Configuring the Remote Languages on page 33

- User Preferences
  - Front Panel Knob Resolution on page 28
  - Setting Time and Date on page 28
  - Reference Oscillator Tune on page 29
    - Display Settings on page 26
    - Power On and Preset on page 27
  - Enabling an Option on page 37
  - Upgrading Firmware on page 29
  - Getting Started With LXI on page 122
    - Hardware Assembly Installation and Removal Softkeys on page 39
**Setting Preferences & Enabling Options**

**User Preferences**

From the Utility menu, you can set the following user preferences:

- **Display Settings**, below
- **Power On and Preset** on page 27
- **Front Panel Knob Resolution** on page 28

**Display Settings**

![Display Settings Diagram]

- **Brightness**: Range: 15 to 100
- **Contrast**: Range: 35 to 55
- **Screen Saver Mode**:
  - **Light Only**: turns the display light off, leaving the text visible at a low intensity.
  - **Light & Text**: turns the display light and the text off.
  - If the display remains unchanged for long periods of time, use this mode to prevent the text from burning the display.
- **Screen Saver Time**: Range: 1 to 12 hours, in 1 hour increments
- **Select Color Palette**:
  - **Bright Color**: Dark text on a light background.
  - **Dark Color**: Light text on a dark background.
  - **Monochrome**: Bright without color

**NOTE**

With both brightness and contrast set to minimum, the display may be too dark to see the softkeys. If this happens, use the figure above to locate the brightness and contrast softkeys and adjust their values so that you can see the display.

---

For details on each key, use key help as described on page 42.
Power On and Preset

Utility > Power On/Preset >

Restores persistent settings (those unaffected by a power cycle*, preset, or recall) to their factory defaults.

Select the GPIB language desired after a preset. See also, the Programming Guide and the SCPI Command Reference. Available only when 8648 is either the selected preset language or the selected remote language (see page 30).

*Caution
To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to non-volatile memory, the MXG should always be powered down either via the MXG's front panel power button or the appropriate SCPI command. MXG's installed in rack systems and powered down with the system rack power switch rather than the MXG's front panel switch display a Error -310 due to the MXG not being powered down correctly.

Note
To define a user preset, set the instrument up as desired and press User Preset > Save User Preset.
Setting Preferences & Enabling Options
User Preferences

Front Panel Knob Resolution

The increment value and the step/knob ratio determine how much each turn of the knob changes the active function value.

For example, if the increment value of the active function is 10 dB and the step/knob ratio is 50 to 1, each turn of the knob changes the active function by 0.2 dB (1/50th of 10 dB).

To change the amount for each turn of the knob, modify the increment value, the step/knob ratio, or both.

Setting Time and Date

CAUTION Changing the time or date can adversely affect the signal generator’s ability to use time–based licenses, even if a time–based license is not installed.

The signal generator’s firmware tracks the time and date, and uses the latest time and date as its time/date reference point.

Setting the Time or Date Forward

If you set the time or date forward, be aware that you are using up any installed time–based licenses, and that you are resetting the signal generator’s time/date reference point. When you set a new time or date that is later than the signal generator’s current reference point, that date becomes the new reference point. If you then set the date back, you run the risk described in the next section.

Setting the Time or Date Backward

When you set the time back, the signal generator notes that the time has moved back from the reference point. If you set the time back more a few hours, you disable the signal generator’s ability to use time–based licenses, even if there is no license installed at the time that you set the time.
back. In this case, you can re-enable the signal generator’s ability to use time-based licenses by moving the clock forward to the original time or simply waiting that length of time.

**Reference Oscillator Tune**

Tunes the internal VCTXCO oscillator frequency.

The user value offsets the factory tuned value (the value is added to the factory calibrated DAC value). The tune value of 0 sets the factory calibrated value.

The range, –8192 to 8192, can be set by using the front panel keypad, knob or remote command.

For details on each key, use key help as described on page 42. See also the SCPI Command Reference.

**Upgrading Firmware**

For information on new firmware releases, go to [http://www.agilent.com/find/upgradeassistant](http://www.agilent.com/find/upgradeassistant).
Remote Operation Preferences

For details on operating the signal generator remotely, refer to the Programming Guide.

GPIB Address and Remote Language

NOTES
USB is also available. It is not shown in the menu because it requires no configuration.
For details on using the instrument remotely, see the Programming Guide.
Configuring the LAN Interface

Utility > I/O Config

NOTES
Use a 100Base-T LAN cable to connect the signal generator to the LAN.

Use a crossover cable to connect the signal generator directly to a PC.

For details on using the instrument remotely, refer to the Programming Guide and to www.agilent.com and search on FAQs: Hardware Configurations and Installation for the Agilent MXG.

For details on each key, use key help as described on page 42.
Enabling LAN Services: “Browser,” “Sockets,” “VXI–11” and “LXI–B”¹

Utility > I/O Config

Enable remote (browser) access to the instrument’s file system.

Use a browser to control the signal generator.

License Manager Server (On) allows updates of the instrument licenses, disable for additional instrument security.

For details on each key, use key help as described on page 42.

¹Option ALB LXI–B is only available on instruments with serial prefixes ≥US/MY/SG4818.
Configuring the Remote Languages

Figure 2-1  N5161A/62A/81A/82A

Utility > I/O Config

Select the desired Remote language.

For details on each key, use key help as described on page 42.

Refer to the SCPI Command Reference.
Setting Preferences & Enabling Options
Remote Operation Preferences

Figure 2-2  N5183A
Utility > I/O Config >

Select the desired Remote language.

For details on each key, use key help as described on page 42.

Refer to the SCPI Command Reference.
Configuring the Preset Languages

Figure 2-3 N5161A/62A/81A/82A

Utility> Power On/Preset

Select the desired Remote language.

For details on each key, use key help as described on page 42.

Refer to the SCPI Command Reference.
Setting Preferences & Enabling Options
Remote Operation Preferences

Figure 2-4 N5183A

Utility > Power On/Preset

Select the desired Remote language.

For details on each key, use key help as described on page 42.

Refer to the SCPI Command Reference.
Enabling an Option

There are two ways to enable an option:

- Use the License Manager software utility:
  1. Run the utility and follow the prompts.
  2. Download the utility from www.agilent.com/find/LicenseManager and select license (.lic) files from an external USB Flash Drive (UFD).
- Use SCPI commands, as described in the Programming Guide.
Viewing Options and Licenses

Utility > Instrument Info

Instrument options appear here. A check mark means that an option is enabled.

<table>
<thead>
<tr>
<th>Instrument Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Instrument security</td>
</tr>
<tr>
<td>IDI</td>
<td>Increase broadband generator memory to 64Ms</td>
</tr>
<tr>
<td>IDL</td>
<td>Differential ID outputs</td>
</tr>
<tr>
<td>IFR</td>
<td>Low Power (~10 dBm)</td>
</tr>
<tr>
<td>LEI</td>
<td>Flexible reference input (1-60 MHz)</td>
</tr>
<tr>
<td>O1</td>
<td>Calibrated AUX</td>
</tr>
<tr>
<td>SFC</td>
<td>5 Hz frequency range</td>
</tr>
<tr>
<td>SFI</td>
<td>Internal backend generator (125 MHz/s)</td>
</tr>
<tr>
<td>IFN</td>
<td>Standard front panel outputs</td>
</tr>
</tbody>
</table>

Waveform licenses from some Signal Studio applications appear here.

Service Software Licenses appear here.

For details on each key, use key help as described on page 42.
Hardware Assembly Installation and Removal Softkeys

Utility > More > 2 of 2 > Service

N5162A/82A only

Whether a softkey is available depends on the model of MXG.

N5183A only

Note: When pressed, a Confirm Removal menu (similar to the one shown here for the CPU assembly) is opened for the RF, BBG, and MW assemblies too.

Note: When pressed, a Confirm Install menu (similar to the one shown here for the CPU assembly) is opened for the RF, BBG, and MW assemblies too.

Each Remove Assembly softkey (CPU/RF/BBG/MW) when enabled will display a message in the lower left quadrant of display indicating assembly prepared for removal or removal has been aborted.

Each Install Assembly softkey, when enabled will display a message in the lower left quadrant of display indicating assembly prepared for installation or installation has been aborted.

Refer also, to the Service Guide.
Setting Preferences & Enabling Options
Hardware Assembly Installation and Removal Softkeys
3 Basic Operation

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only available through the Web–Enabled MXG or SCPI commands. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and the SCPI Command Reference.

This chapter introduces fundamental front panel operation. For information on remote operation, refer to the Programming Guide.

- Presetting the Signal Generator on page 42
- Viewing Key Descriptions on page 42
- Entering and Editing Numbers and Text on page 43
- Setting Frequency and Power (Amplitude) on page 45
- Setting ALC Bandwidth Control on page 47
- Configuring a Swept Output on page 48
- Modulating the Carrier Signal on page 60
- Working with Files on page 62
- Reading Error Messages on page 74
Basic Operation
Presetting the Signal Generator

Presetting the Signal Generator

To return the signal generator to a known state, press either Preset or User Preset.

Preset is the factory preset; User Preset is a custom preset** (see also, page 27).

To reset persistent settings (those unaffected by preset, user preset, or power cycle*), press: Utility > Power On/Preset > Restore System Defaults.

*Caution
To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to non-volatile memory, the MXG should always be powered down either via the MXG’s front panel power button or the appropriate SCPI command. MXG’s installed in rack systems and powered down with the system rack power switch rather than the MXG’s front panel switch display a Error -310 due to the MXG not being powered down correctly.

**You can create more than one user preset by giving each saved state file a different name (see Figure 3-12 on page 72).

Viewing Key Descriptions

The Help hardkey enables you to display a description of any hardkey or softkey.

To display help text:
1. Press Help.
2. Press the desired key.

The help displays and the key’s normal function does not execute.
Entering and Editing Numbers and Text

Entering Numbers and Moving the Cursor

Use the number keys and decimal point to enter numeric data.

- Up/down arrow keys increase/decrease a selected (highlighted) numeric value, and move the cursor vertically.
- Left/right arrow keys move the cursor horizontally.
- Page up/down keys move tables of data up and down within the display area.
- To specify a negative value, enter the negative sign either before or after the numeric value (this key is a toggle).
- Backspace moves the cursor to the left, deleting characters as it goes.
- Use the Select hardkey (or the softkey next to the alpha table) to highlight the desired letter, then press the Select hardkey (or the softkey next to the alpha table). To correct errors, use Bk Sp or Clear Text.

To terminate the entry, press the Enter softkey.

A subset of this menu appears for hexadecimal characters. The character menu displays only the letters A through F (use the numeric keypad for other values).

Entering Alpha Characters

- Data entry softkeys appear in various menus. If their meaning is not clear in context, use the help key (described on page 42) to display an explanation. Use the softkey next to the alpha table for help on the table.
- Selecting data that accepts alpha characters, displays one of the menus shown at right.
- Use the arrow keys or knob to highlight the desired letter, then press the Select hardkey (or the softkey next to the alpha table).
- To correct errors, use Bk Sp or Clear Text.
- To move the cursor within the active value rather than within the alpha table, turn the alpha table off.
- Add/edit comments for saved instrument state files (see page 69).

Note: File names are limited to 25 characters.
Example: Using a Table Editor

Table editors simplify configuration tasks. The following procedure describes basic table editor functionality using the List Mode Values table editor.

1. Preset the signal generator: Press **Preset**.
2. Open the table editor: Press **Sweep > More > Configure List Sweep**.

   The signal generator displays the editor shown in the following figure.

3. Highlight the desired item: use the arrow keys or the knob to move the cursor.
4. (Optional) Display the selected item in the active function area: Press **Select**.
5. Modify the value:
   - If the value is displayed in the active function area, use the knob, arrow keys, or numeric keypad to modify the value.
   - If the value is not displayed in the active function area, use the numeric keypad to enter the desired value (which then appears in the active function area).
6. Terminate the entry:
   - If available, press the desired units.
   - If units are not displayed, press either **Enter** (if available) or **Select**.

The modified item is displayed in the table.
Basic Operation

Setting Frequency and Power (Amplitude)

Figure 3-1 Frequency and Amplitude Softkeys

- **FREQ**
  - **Frequency**
    - **Freq Ref Set** 0.00 Hz
    - **Freq Ref** Hz
  - **Frequency Units**
    - **Freq Offset** 0.00 Hz
    - **Freq Multiplier** 1.000 x
  - **Freq Channels**

- **AMPTD**
  - **Ampl Control**
    - **Ampl Offset** 0.00 dB
  - **Atten/ALC**
    - **Ampl Ref Set** 0.00 dB
  - **Ampl Units**
    - **Ampl Offset** 0.00 dB

In Frequency mode, this menu is automatically displayed when entering a numeric value with the front panel keypad.

In Amplitude mode, this menu is automatically displayed when entering a numeric value with the front panel keypad.

To display the next menu, press More.

- **More 1 of 2**
  - **Freq Channels**
    - **Freq Ref Set** 0.00 Hz
  - **Freq Units**
    - **Freq Offset** 0.00 Hz
  - **Freq Multiplier** 1.000 x

- **More 2 of 2**
  - **Phase Ref Set**
  - **Adjust Phase** 0.000 rad
  - **Reference Oscillator**
  - **Improve non-harmonics**

This softkey sets a user determined maximum power level on the instrument that is persistent.

For details on each key, use key help as described on page 42. Refer to the SCPI Command Reference.

---

In Frequency mode, this menu is automatically displayed when entering a numeric value with the front panel keypad.

In Amplitude mode, this menu is automatically displayed when entering a numeric value with the front panel keypad.

---

Caution: When this mode is enabled, the instrument switching speed and behavior of the source's settled signal are affected.

Optimizes the signal-to-noise ratio state (Optimize S/N) On or Off. The optimize signal-to-noise softkey changes the attenuator and ALC setting to provide optimal signal-to-noise performance; it does not change the RF output power.

**Note:** This mode is mutually exclusive with attenuator hold (Atten Hold), and any modulation type. A settings conflict error will be generated if attenuator hold or any modulation is activated when optimize signal-to-noise is active (On).

Hardware dependent—may not be visible on all instruments. This feature was activated with serial prefix >xx4818. Modifies the attenuator and ALC settings for optimal performance. It does not change the RF output.
Example: Configuring a 700 MHz, −20 dBm Continuous Wave Output

1. Preset the signal generator.
   The signal generator displays its maximum specified frequency and minimum power level (the front panel display areas are shown on page 11).

2. Set the frequency to 700 MHz: Press **Freq > 700 > MHz**.
   The signal generator displays 700 MHz in both the **FREQUENCY** area of the display and the active entry area.

3. Set the amplitude to −20 dBm: Press **Amptd > −20 > dBm**.
   The display changes to −20 dBm in the **AMPLITUDE** area of the display, and the amplitude value becomes the active entry. Amplitude remains the active function until you press another function key.

4. Turn on the RF Output: Press **RF On/Off**.
   The RF Output LED lights, and a 700 MHz, −20 dBm CW signal is available at the RF OUTPUT connector.

Using an External Reference Oscillator

When using an external reference, you can select either narrow or wide bandwidth mode.

---

For details on each key, use key help as described on page 42.
**Basic Operation**

**Setting ALC Bandwidth Control**

**Figure 3-2 Using an External Reference Oscillator**

![Using an External Reference Oscillator](image)

**Figure 3-3 Amplitude Softkeys**

![Amplitude Softkeys](image)

For details on each key, use key help as described on page 42.

Refer to the SCPI Command Reference.

<table>
<thead>
<tr>
<th>AMPTD</th>
<th>AMPLT</th>
<th>ALC Bandwidth</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>auto</td>
</tr>
<tr>
<td></td>
<td></td>
<td>200 Hz</td>
</tr>
</tbody>
</table>

Enables the automatic ALC bandwidth mode (Auto).

Disabling the Auto ALC mode, sets the bandwidth to 200 Hz.

To display the next menu, press More.
Basic Operation
Configuring a Swept Output

**Configuring a Swept Output**

The signal generator has two methods of sweeping through a set of frequency and amplitude points:

*Step sweep* (page 50) provides a linear or logarithmic progression from one selected frequency, amplitude, or both, to another, pausing at linearly or logarithmically spaced points (steps) along the sweep. The sweep can progress forward, backward, or manually.

*List sweep* (page 56) enables you to enter frequencies and amplitudes at unequal intervals, in nonlinear ascending, descending, or random order. List sweep also enables you to copy the current step sweep values, include an Arb waveform in a sweep (on a vector instrument), and save list sweep data in the file catalog (page 67).
Basic Operation

Configuring a Swept Output

**Figure 3-4  Sweep Softkeys**

During a sweep, the swept parameter (frequency, amplitude, or both) turns grey and changes as the parameter sweeps.

The selected sweep type determines the displayed parameter. Selecting step sweep also displays the step spacing (Lin or Log).

Progress Bar: Note that very fast sweeps can appear to sweep randomly or backward.

**Sweep Without Waiting for a Trigger at Each Point.**
Point Trigger pauses for the dwell time prior to the first sweep. See page 117.

Apply a TTL/CMOS signal to the Trigger In connector.
Periodically issue a trigger event to whatever selects it as a source.
Using timer trigger with single sweep results in a delay prior to the first sweep. See page 117.
Trigger on a remote command.

On vector models: Available when Sweep Type = List

For details on each key, use key help as described on page 42.
Routing Signals

Sweep > More > More > Route Connectors

Step Sweep

Step sweep provides a linear or logarithmic progression from one selected frequency, or amplitude, or both, to another, pausing at linearly or logarithmically spaced points (steps) along the sweep. The sweep can progress forward, backward, or be changed manually.

Figure 3-5 Step Sweep Softkeys

For details on each key, use key help as described on page 42.

1 The N5161A and N5162A are identical to an MXG with a front panel display, except that the front panel, hardkeys and softkeys functionality are only available through SCPI commands or the Web-Enabled MXG. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide and the SCPI Command Reference.
The N5183A allows you to use step sweep along with the frequency markers on instruments during measurements (refer to “Using Frequency Markers (N5183A Only)” on page 54).

**NOTE** The N5183A does *not* support the 8757 system interface.

**Figure 3-6 Sweep Softkeys**

For details on each key, use key help as described on page 42.

(N5183A Only: Opens the frequency marker menu. See page 54. (The N5183A does not support Agilent 8757 the system interface.)

**Example: Configuring a Continuous, Linear Step Sweep**

**Output:** A signal that continuously sweeps from 500 to 600 MHz and from -20 to 0 dBm, with a dwell time of 500 ms at each of six equally--spaced points.

1. Preset the instrument and open the Sweep/List menu: Press **Preset > SWEEP**.
   
   Because continuous is the default sweep repeat selection, and linear is the default step spacing selection, you do not need to set these parameters.

2. Open the step sweep menu: Press **Configure Step Sweep**.

3. Set the following parameters:
   
   - **Start frequency 500 MHz:** Press **Freq Start > 500 > MHz**
   - **Stop frequency 600 MHz:** Press **Freq Stop > 600 > MHz**
   - **Amplitude at the beginning of the sweep, -20 dBm:** Press **Amptd Start > -20 > dBm**
   - **Amplitude at the end of the sweep, 0 dBm:** Press **Amptd Stop > 0 > dBm**.
   - **6 sweep points:** Press **# Points > 6 > Enter**
   - **Dwell time at each point, 500 milliseconds:** Press **More > Step Dwell > 500 > msec**

4. Sweep both frequency and amplitude: Press **Return > Return > Sweep > Freq Off On > Amptd Off On**.
   
   A continuous sweep begins, from the start frequency/amplitude to the stop frequency/amplitude. The SWEEP annunciator displays, and sweep progress is shown in the frequency display, the amplitude display, and the progress bar.
Basic Operation
Configuring a Swept Output

5. Turn the RF output on: Press **RF On/Off**.
   The RF LED lights, and the continuous sweep is available at the RF Output connector.

**Using Basic Step Sweep Functions**
This procedure demonstrates the following task:
- “Configuring a Frequency Sweep (N5183A only)” on page 52

**Configuring a Frequency Sweep (N5183A only)**
For this example, we are going to set a step sweep using the N5183A, over a frequency range of 7.5 to 10.0 GHz, using a band-pass filter as our device under test, and display that response on a 8757D Scalar Analyzer.

1. Set up the equipment as shown in Figure 3-7.

   **NOTE**  The N5183A signal generator does not support the 8757 system interface.
   Scalar analyzer settings must match the signal generator's settings.

   ![Figure 3-7 Equipment Setup](image)

   *The N5183A signal generator is not compatible with the 8757 system interface.

2. Turn on both the 8757D and the N5183A.
3. On the 8757D:
   a. Press **SYSTEM > MORE > SWEEP MODE** and verify that the **SYSINTF** softkey is set to OFF.
b. Press SYSTEM > MORE > DC

c. Press SYSTEM > Freq LABELS > START FREQ > 7.5 GHz

d. Press SYSTEM > FREQ LABELS > STOP FREQ > 10.0 GHz

e. Press SYSTEM > TRACE # POINTS > 801

4. On the N5183A:

   a. Change the connector routing to 8757D System, enabling the N5183A to provide a sweep out to the 8757D during Step sweep operations. Press Sweep > More > More > Route Connectors > Route to Sweep Out BNC > Sweep Out (Optimized for 8757D System).

   b. Press Sweep > Configure Step Sweep > # Points > 801

   c. Press Sweep > Configure Step Sweep > Freq Stop > 10.0 GHz

   d. Press Sweep > Configure Step Sweep > Freq Start > 7.5 GHz

   e. Press Sweep > Sweep > Freq On Off set to On

**NOTE** During swept RF output, the FREQUENCY and/or AMPLITUDE areas of the signal generator’s display are greyed out, depending on what is being swept. In this case, since frequency is being swept the FREQUENCY area of the display is greyed out.

5. On the 8757D: Adjust the settings for start and stop frequency response of the device under test (DUT) so it is clearly seen on the 8757D display.

   You may need to rescale the response on the 8757D for a more accurate evaluation of the amplitude. Figure 3-8 on page 54 shows an example of a bandpass filter response.
Using Frequency Markers (N5183A Only)

In step sweep mode, you can use the N5183A to create up to 20 frequency markers to display on your measurement equipment.

**NOTE** The N5183A does *not* support the 8757 system interface.
Basic Operation
Configuring a Swept Output

Figure 3-9  Frequency Marker Softkeys

Sweep > Configure Step Sweep > More > Markers

**Sets the frequency for the marker number highlighted.**
Up to 20 frequency markers can be set.

**Enables the selected frequency marker.**

**Selects the highlighted marker as the frequency reference marker for the rest of the frequency markers.**
If the Delta Ref Set softkey has been pressed, this softkey enables the Marker Delta function and uses the Ref marker as the frequency marker reference for the other markers.

**Sets the center frequency of the sweep to the value of the highlighted marker (row).**

**Sets the start frequency of the sweep to the value of marker 1 (M1) and the stop frequency to the value of marker 2 (M2).**

**Sets the marker’s amplitude value displayed on the instrument (Range: –10 dB to 10 dB).**

For details on each key, use key help as described on page 42.
Basic Operation
Configuring a Swept Output

List Sweep

List sweep enables you to enter frequencies and amplitudes at unequal intervals in nonlinear ascending, descending, or random order. List sweep also enables you to copy the current step sweep values, include a waveform in a sweep (on a vector instrument), and save list sweep data in the file catalog (page 67). Dwell time is editable at each point. For fastest switching speeds, use list sweep.

Figure 3-10 List Sweep Configuration Softkeys and Display

- **Sweep Node**: Displays the selected sweep type parameters (see page 57).
- **Displays the selected sweep type parameters (see page 57)**
- **Dwell Time**: the time that the signal is settled and you can make a measurement before the sweep moves to the next point.
- **Point-to-Point Time**: the sum of the value set for the dwell plus processing time, switching time, and settling time.
- **Each line defines the corresponding point in the sweep. For example, line 1 defines point 1.**
- **List Node Value**: The selected sweep determines which dwell time the signal generator uses. Step Sweep dwell time is the same at each point; List Sweep dwell time can be different at each point.
- **Dwell Time** = the time that the signal is settled and you can make a measurement before the sweep moves to the next point.
- **Point-to-Point Time** = the sum of the value set for the dwell plus processing time, switching time, and settling time.

Available only on vector models, and only when Sweep Type = List.

Available only when waveform entry is selected.
Example: Configuring a List Sweep Using Step Sweep Data

1. Set up the desired step sweep, but do not turn the sweep on. This example uses the step sweep configured on page 51.

2. In the SWEEP menu, change the sweep type to list:
   Press **SWEEP > Sweep Type List Step** to highlight List.
   The display shows sweep list parameters, as shown below.


4. Clear any previously set values from the menu and load the points defined in the step sweep into the list: Press **More > Preset List > Preset with Step Sweep > Confirm Preset**.
   The display updates with the values loaded from the step sweep, as shown.

5. Sweep frequency and amplitude: Press **SWEEP (hardkey) > Sweep > Freq Off On > Amptd Off On**.
   Setting the sweep turns on the sweep function; a continuous sweep begins. On the display, the SWEEP annunciator appears, and the progress bar shows the progression of the sweep.

6. If not already on, turn the RF output on: Press **RF On/Off**.
   The RF Output LED lights, and a continuous sweep is available at the RF OUTPUT connector.

**Vector Models:**
Presetting the list clears any previously selected waveforms.
For information on selecting a list sweep waveform, see **Example: Editing List Sweep Points** on page 58.
Example: Editing List Sweep Points

If you are not familiar with table editors, refer to page 44.

1. Create the desired list sweep. This example uses the list sweep created in the previous example.

2. If sweep is on, turn it off. Editing list sweep parameters with sweep on can generate an error.

3. Ensure that the sweep type is set to list: Press **Sweep** > **Sweep Type List Step** to highlight List.

4. In the List Mode Values table editor, change the point 1 dwell time (defined in row 1) to 100 ms:
   a. Press **More** > **Configure List Sweep**.
   b. Highlight the point 1 dwell time.
   c. Press 100 > msec.

   The next item in the table (the frequency value for point 2) highlights.

5. Change the selected frequency value to 445 MHz: Press 445 > MHz.

6. Add a new point between points 4 and 5: Highlight any entry in row 4 and press **Insert Row**.
   This places a copy of row 4 below row 4, creating a new point 5, and renumbers subsequent rows.

7. Shift frequency values down one row, beginning at point 5: Highlight the frequency entry in row 5, then press **More** > **Insert Item**.

   This places a copy of the highlighted frequency value in row 6, shifting the original frequency values for rows 6 and 7 down one row. The new row 8 contains only a frequency value (the power and dwell time entries do not shift down).

8. Change the still active frequency value in row 5 to 590 MHz: Press 590 > MHz. The power in row 5 is now the active parameter.

9. Insert a new power value (−2.5 dBm) for point 5, and shift down the original power values for points 5 and 6 by one row: Press **Insert Item** > −2.5 > dBm.

10. To complete the entry for point 8, insert a duplicate of the point 7 dwell time by shifting a copy of the existing value down: Highlight the dwell time in row 7 and press **Insert Item**.

11. For an analog instrument, go to step 14. For a vector instrument, continue with step 12.

12. Select a waveform for point 2:
   a. Highlight the waveform entry for point 2 and press the **More** > **Select Waveform**.
      The signal generator displays the available waveforms, as shown in the following example.

   b. Highlight the desired waveform (in this example, SINE_TEST) and press either the **Select** hardkey or the **Select Waveform** softkey.
13. As desired, repeat step 12 for the remaining points for which you want to select a waveform. The following figure shows an example of how this might look.

14. Turn sweep on:

15. If it is not already on, turn the RF output on:
   Press RF On/Off.

   The SWEEP annunciator appears on the display, indicating that the signal generator is sweeping, and the progress bar shows the progression of the sweep.

   **NOTE** If the instrument is in manual sweep (page 60), the active row (row 6 in the figure above) is the selected (manual) point, and the signal generator outputs the settings for that selection when the RF output is on.

### Example: Using a Single Sweep

1. Set up either a step sweep (page 51) or a list sweep (page 57).

2. In the List/Sweep menu, set the sweep repeat to single:
   Press Sweep Repeat Single Cont to highlight Single.

   Sweep does not occur until you trigger it.

   Note that the WINIT annunciator appears on the display, indicating that the sweep is waiting to be initiated.

3. If not already on, turn the RF output on: Press RF On/Off.

4. Initiate the sweep: Press Single Sweep.

   A single repetition of the configured sweep is available at the RF Output connector.

   As the signal generator sweeps, the SWEEP annunciator replaces WINIT on the display, and the progress bar shows the progression of the sweep.

   At the end of the sweep, there is no progress bar, and the WINIT annunciator replaces SWEEP.
Modulating the Carrier Signal

To modulate the carrier signal, you must have both

• an active modulation format

and

• modulation of the RF output enabled

Example

1. Preset the signal generator.
2. Turn on AM modulation: Press AM > AM Off On (requires Option UNT).
   
   You can turn on the modulation format before or after setting signal parameters.

   The modulation format generates, but does not yet modulate the carrier signal.

   Once the signal generates, an annunciator showing the name of the format appears, indicating that a modulation format is active.
3. Enable modulation of the RF output: Press the **Mod On/Off** key until the LED lights.
   If you enable modulation without an active modulation format, the carrier signal does not modulate until you subsequently turn on a modulation format.

   **NOTE**

   To turn modulation off, press the **Mod On/Off** key until the LED turns off.
   When the **Mod On/Off** key is off, the carrier signal is not modulated, even with an active modulation format.

4. To make the modulated carrier available at the RF output connector, press the **RF On/Off** key until the LED lights.

   **See also:**
   * "Using Analog Modulation (Option UNT Only)" on page 75
   * "Using Pulse Modulation (Option UNU or UNW or 320)" on page 127
   * "I/Q Modulation" on page 200
Simultaneous Modulation

**NOTE** The Agilent MXG is capable of simultaneous modulation. All modulation types (AM, FM, φM, and Pulse) may be simultaneously enabled. But, there are some exceptions. Refer to Table 3-1.

<table>
<thead>
<tr>
<th></th>
<th>AM&lt;sup&gt;a&lt;/sup&gt;</th>
<th>FM</th>
<th>φM</th>
<th>Pulse&lt;sup&gt;b&lt;/sup&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>AM</td>
<td>--</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>FM</td>
<td>x&lt;sup&gt;c&lt;/sup&gt;</td>
<td>--</td>
<td>not applicable</td>
<td>x</td>
</tr>
<tr>
<td>φM</td>
<td>x&lt;sup&gt;c&lt;/sup&gt;</td>
<td>not applicable</td>
<td>--</td>
<td>x</td>
</tr>
<tr>
<td>Pulse</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>--</td>
</tr>
</tbody>
</table>

<sup>a</sup>Linear AM and Exponential AM cannot be enabled simultaneously. Refer to Chapter 4.

<sup>b</sup>Pulse modulation requires Option UNU or UNW. Refer to Chapter 6.

<sup>c</sup>FM and φM cannot be enabled simultaneously.

Working with Files

- **File Softkeys** on page 63
- **Viewing a List of Stored Files** on page 64
- **Storing a File** on page 65
- **Loading (Recalling) a Stored File** on page 67
- **Moving a File from One Media to Another** on page 68
- **Working with Instrument State Files** on page 69
- **Selecting the Default Storage Media** on page 73

The signal generator recognizes several types of files, such as instrument state files, license files, and list sweep files. Files can be stored either in the signal generator's internal storage or on the USB media. This section provides an overview of how to navigate the signal generator's file menus, and how to view, store, load, and move files.

The Agilent MXG non-volatile internal memory is allocated according to a Microsoft compatible file allocation table (FAT) file system. Refer to the *Programming Guide*.

See also: **Storing, Loading, and Playing a Waveform Segment** on page 144.
File Softkeys

For details on each key, use key help as described on page 42.

**Note:** Available file types depend on the installed options.

- **Catalog Type:**
  - All
  - Binary
  - State
  - List

- **User Flatness**
  - Calibration corrections.

- **Instrument operating parameters (see page 69).**

Sweep data from the List Mode Values table editor.

Deletions require confirmation.

Available only with USB connected (i.e. Without external USB connected, softkeys are greyed out).

Available only when the current directory is not the top level directory.

Required confirmation.

This key changes, depending on the selected file. See page 67.

Available only when the current directory is not the top level directory.

The display indicates when the current directory is the default storage path. For information on setting the default storage path, see page 73.

When you connect USB media to the instrument, the signal generator displays the USB Media menu and the message **External USB Storage attached.** When you disconnect the USB media, the message **External USB Storage detached** displays. When you open the External Media menu without USB media connected, the signal generator displays the message **External Media Not Detected.**
Basic Operation
Working with Files

ARB File Softkeys

Waveform files and their associated marker and header information.

Viewing a List of Stored Files

The information in this section is provided with the assumption that default storage media is set to Auto, as described on page 73.

Viewing a List of Files Stored in the Signal Generator

1. If USB media is connected, disconnect it. The signal generator’s storage media switches to internal, so you can now use the file catalogs to see files stored in the signal generator.

2. Select the desired file catalog: Press > Catalog Type > desired catalog (in this example, All). The selected files appear in alphabetical order by file name, as shown in the following figure.

For details on each key, use key help as described on page 42.
Viewing a list of Files Stored on USB Media

With USB media connected, you can view files on USB media using either the file catalogs, which can display only a selected type of file, or the USB File Manager, which displays all files.

Using the File Catalogs:

• With the USB media connected, select the desired file catalog: press > Catalog Type > desired catalog. The selected files appear in alphabetical order by file name.

Using the USB File Manager:

• With USB media connected, open the USB File Manager: press File > More > USB File Manager. The instrument displays the default directory on the USB Media, as shown in the following figure. Note that when you attach USB media, the display goes directly to this menu.

Storing a File

Several menus enable you to store instrument parameters. For example, you can store instrument states, lists, and waveforms.

• An instrument state file contains instrument settings. For this type of file, use the Save hardkey shown in Figure 3-11 on page 69.

• For other types of data, use the Load/Store softkey (shown below) that is available through the menu used to create the file.

<table>
<thead>
<tr>
<th>File Name</th>
<th>Type</th>
<th>Size</th>
<th>Modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 состо</td>
<td>STATE</td>
<td>1005600</td>
<td>04/12/08 01:30</td>
</tr>
<tr>
<td>0_0001</td>
<td>STATE</td>
<td>1025600</td>
<td>04/12/08 01:30</td>
</tr>
<tr>
<td>L101</td>
<td>LIST</td>
<td>5.2MB</td>
<td>04/12/08 01:30</td>
</tr>
<tr>
<td>L202</td>
<td>USERINT</td>
<td>56364</td>
<td>04/12/08 01:30</td>
</tr>
<tr>
<td>USER</td>
<td>USERINT</td>
<td>52184</td>
<td>04/12/08 01:30</td>
</tr>
<tr>
<td>USER_INT</td>
<td>USERINT</td>
<td>52184</td>
<td>04/12/08 01:30</td>
</tr>
<tr>
<td>USER_INT</td>
<td>USERINT</td>
<td>52184</td>
<td>04/12/08 01:30</td>
</tr>
<tr>
<td>USER_INT</td>
<td>USERINT</td>
<td>52184</td>
<td>04/12/08 01:30</td>
</tr>
</tbody>
</table>
Basic Operation
Working with Files

Use this menu to enter the file name, as described on page 43.

For details on each key, use key help as described on page 42.

File Type
List
State
Waveform
User Flatness
User Preset
Pulse Train

Save From
Sweep menu
Save menu
Mode menu
Amplitude menu
User Preset menu
Pulse Train menu

File Length (including extension)
Internal Media: 25 characters
USB Media: 39 characters
Loading (Recalling) a Stored File

There are several ways to load (recall) a stored file.

- For an instrument state file, use the **Recall** hardkey shown in Figure 3-11 on page 69.
- For other types of data, use the Load/Store softkey (shown below) that is available through the menu used to create the file.

**Loading a File From USB Media**

To load a file from USB media, use the USB file manager shown below.

```
<table>
<thead>
<tr>
<th>File</th>
<th>Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>List</td>
<td>.list</td>
</tr>
<tr>
<td>State</td>
<td>.state</td>
</tr>
<tr>
<td>Waveform</td>
<td>.wavelform</td>
</tr>
<tr>
<td>User Flatness</td>
<td>.uflat</td>
</tr>
<tr>
<td>User Preset</td>
<td>.uprst</td>
</tr>
<tr>
<td>License</td>
<td>.lic</td>
</tr>
<tr>
<td>Pulse Train</td>
<td>.ptrain</td>
</tr>
</tbody>
</table>
```

Pressing Select with file highlighted...

- loads list and starts sweep
- loads instrument state
- loads and plays waveform
- loads and applies user flatness
- loads and executes user preset
- installs purchased license
- loads and applies pulse train

If the signal generator does not recognize the file, you must select how the file is to be used.

For details on each key, use key help as described on page 42.
Moving a File from One Media to Another

Use the USB Media Manager to move files between USB and internal media.

File > Catalog Type > <type> > More > USB File Manager
or
File > More > USB File Manager
or
Insert the USB Flash Drive (UFD)

![Diagram of file management options]

- **This key changes, depending on the selected file. See page 67**
- **Whether a menu is available depends on the selected file.**
- **Moves up one directory level**
- **Requires confirmation**
- **If the file type is recognized the “Filename.xxx copied to Internal Storage” is displayed.**

1 The N5162A is identical to an MXG with a front panel display, except that the front panel, hardkeys and softkeys functionality are only available through SCPI commands or the Web-Enabled MXG. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide and the SCPI Command Reference.

For details on each key, use key help as described on page 42.
Basic Operation
Working with Files

Working with Instrument State Files

- Saving an Instrument State on page 70
- Saving a User Preset on page 70
- Recalling an Instrument State on page 70
- Recalling an Instrument State and Associated Waveform File on page 71
- Recalling an Instrument State and Associated List File on page 71
- Moving or Copying a Stored Instrument State on page 72

Figure 3-11 Save and Recall Softkeys

The following information is not stored in a state file:

<table>
<thead>
<tr>
<th>System Security Level</th>
<th>Sweep lists</th>
<th>Hostname</th>
<th>Remote Language</th>
<th>Step increment values</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Security Level Display</td>
<td>Pulse Train lists</td>
<td>IP Address</td>
<td>FTP Server</td>
<td>ARB Files</td>
</tr>
<tr>
<td>System Security Level State</td>
<td>Display State On/Off</td>
<td>Subnet Mask</td>
<td>Manual DHCP</td>
<td>MAC</td>
</tr>
<tr>
<td>Web Server (HTTP)</td>
<td>Files</td>
<td>Default Gateway</td>
<td>VXI-11 SCPI</td>
<td>User Power Correction</td>
</tr>
<tr>
<td>Sockets SCPI (TELNET)</td>
<td>I/Q Calibration Data</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

When saved to the signal generator, instrument settings (states) save to instrument state memory. Instrument state memory is divided into 10 sequences (0 through 9); each sequence comprises 100 registers (00 through 99).

Delete softkeys in the Save and Recall menus enable you to delete the contents of a specific register, or the contents of all sequences in the state file catalog.

The signal generator requires that you confirm a deletion.

*Caution*
To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to non-volatile memory, the MXG should always be powered down either via the MXG’s front panel power button or the appropriate SCPI command. MXG’s installed in rack systems and powered down with the system rack power switch, rather than the MXG’s front panel switch display a Error -310 due to the MXG not being powered down correctly.
Basic Operation
Working with Files

Saving an Instrument State
1. Preset the signal generator and set the following:
   - Frequency: 800 MHz
   - Amplitude: 0 dBm
   - RF: on
2. (Optional, vector models only) Associate a waveform file with these settings:
   a. Press Mode > Dual ARB > Select Waveform.
   b. Highlight the desired file and press Select Waveform. If the file is not listed, you must first
      move it from internal or external media to BBG media, see page 144.
3. Select the desired memory sequence (for this example, 1): Press Save > Select Seq > 1 > Enter.
4. Select the desired register (in this example, 01): Press Select Reg > 1 > Save Reg.
   If a waveform is currently selected, saving the instrument state also saves a pointer to the
   waveform file name.
5. Add a descriptive comment to sequence 1 register 01:
   Press Add Comment to Seq[1] Reg[01], enter the comment and press Enter. The comment appears in
   the Saved States list when you press Recall. If the instrument state has an associated waveform,
   entering the waveform name in the comment makes it easy to identify which instrument state
   applies to which waveform.

Saving a User Preset
A user preset is a special type of instrument state file.
1. Preset the signal generator and set as desired.
2. Press User Preset > Save User Preset.
   This saves a state file named USER_PRESET, which the signal generator recognizes as containing
   user preset information.
You can set up several preset conditions under different names:
1. After you save a user preset, rename it to something other than USER_PRESET (see page 72).
2. Save as many user presets as you wish, renaming the USER_PRESET file each time.
3. Give the desired file the name USER_PRESET.

Recalling an Instrument State
1. Preset the signal generator.
2. Press Recall.
   The Select Seq softkey shows the last sequence used, and the display lists any states stored in the
   registers in that sequence; RECALL Reg is the active entry.
3. Select the desired instrument state:
   If the desired state is listed in the currently selected sequence, press desired number > Enter.
   If not, press Press Select Seq > desired number > Enter > RECALL Reg > desired number > Enter.
Recalling an Instrument State and Associated Waveform File

1. Ensure that the desired waveform file exists, and that it is in BBG media (page 144).

   If the waveform file is not in BBG media, this procedure generates an error.

   Recalling an instrument state with an associated waveform file recalls only the waveform name. It does not recreate the waveform file if it was deleted, or load the file into BBG media if it is in internal or USB media.

2. Recall the desired instrument state (see previous example).

3. View the waveform file name recalled with the instrument state: press Mode > Dual ARB.

   The name is displayed as the selected waveform.


Recalling an Instrument State and Associated List File

Recalling an instrument state recalls only the list sweep setup. It does not recall the frequency and/or amplitude values. Because you must load the list file from the file catalog, when you store a list file, be sure to give it a descriptive name (up to 25 characters).

1. Recall the desired instrument state (see previous example).

2. Load the desired list file:
   b. Highlight the desired file and press Load From Selected File > Confirm Load From File.

Editing The Comment on an Instrument Comment

Use the following steps to change a comment on an instrument state saved using the Save key. This is not the file name that appears in the State catalog (which is the file’s memory location).

1. Press Save

2. Highlight the desired register

3. Press Edit Comment In Seq[n] Reg[nn].


This overwrites previously saved instrument state settings with the new comment.
Moving or Copying a Stored Instrument State

Figure 3-12 Instrument State File Catalog

A user–created state file’s default name is its memory location (sequence and register).
To move the file, rename it to the desired sequence and register; you can not give a file the same name as an existing file. If you rename a state file to something other than a valid sequence/register name, the file does not appear in either the Save or Recall menu.
### Selecting the Default Storage Media

You can configure the signal generator to store user files to either the internal storage or to external USB media. To automatically switch between USB media and internal storage, depending on whether USB media is attached, select **Automatically Use USB Media If Present**. To avoid storing any confidential information in the instrument, select **Use Only USB Media**. To avoid storing any confidential information to USB media, select **Use Only Internal Storage**.

This selection is unaffected by power-cycle or preset.

For details on each key, use key help as described on page 42.
Reading Error Messages

If an error condition occurs, the signal generator reports it to both the front panel display error queue and the SCPI (remote interface) error queue. These two queues are viewed and managed separately; for information on the SCPI error queue, refer to the Programming Guide.

---

### Error Message Format

<table>
<thead>
<tr>
<th>Error Number</th>
<th>Error Message</th>
</tr>
</thead>
<tbody>
<tr>
<td>-222</td>
<td>Data out of range; value clipped to lower limit.</td>
</tr>
</tbody>
</table>

Indicates that the user has entered a deviation, depth, or internal source frequency that is beyond the specific limits.

Explanation is provided in the Error Message file (see page 324).
(This is not displayed on the instrument)

---

Errors that must be resolved. For example, unlock.

---

### Characteristic

<table>
<thead>
<tr>
<th>Front Panel Display Error Queue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Capacity (#errors)</td>
</tr>
<tr>
<td>Overflow Handling</td>
</tr>
<tr>
<td>Viewing Entries</td>
</tr>
<tr>
<td>Clearing the Queue</td>
</tr>
<tr>
<td>Unresolved Errors*</td>
</tr>
<tr>
<td>No Errors</td>
</tr>
</tbody>
</table>

---

*Errors that must be resolved. For example, unlock.

---

Error messages appear in the lower left corner of the display as they occur.
4 Using Analog Modulation (Option UNT Only)

NOTE The Mod On/Off hardkey and LED functionality are only valid for MXGs with Option UNT installed.

Before using this information, you should be familiar with the basic operation of the signal generator. If you are not comfortable with functions such as setting the power level and frequency, refer to Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that chapter.

- The Basic Procedure on page 76
- Using an External Modulation Source on page 77
- Removing a DC Offset on page 77
- Using Wideband AM on page 77

Figure 4-1 Analog Modulation Softkeys

For details on each key, use key help as described on page 42.
The Basic Procedure

1. Preset the signal generator.
2. Set the carrier (RF) frequency.
3. Set the RF amplitude.
4. Configure the modulation:

<table>
<thead>
<tr>
<th>AM</th>
<th>FM</th>
<th>ΦM</th>
</tr>
</thead>
<tbody>
<tr>
<td>AM Off On</td>
<td>FM Off On</td>
<td>ΦM Off On</td>
</tr>
<tr>
<td>AM Off On</td>
<td>FM Off On</td>
<td>ΦM Off On</td>
</tr>
</tbody>
</table>

5. Turn on the modulation:

The appropriate modulation annunciator displays, indicating that you enabled modulation.

6. Turn on the RF output.
The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output” on page 318.
See also “Modulating the Carrier Signal” on page 60.
Using an External Modulation Source

To eliminate an offset in an externally applied FM or \( \Phi M \) signal, perform a DCFM or DC\( \Phi M \) Calibration.

**NOTE** You can perform this calibration for internally generated signals, but DC offset is not usually a characteristic of an internally generated signal.

1. Set up and turn on the desired modulation.
2. Press \( FM/\Phi M > More > DCFM/DC\Phi M \) Cal.

Performing the calibration with a DC signal applied removes any deviation caused by the DC signal, and the applied DC level becomes the new zero reference point. When you disconnect the DC signal, perform the calibration again to reset the carrier to the correct zero reference.

Using Wideband AM

Wideband AM uses the I input of the I/Q modulation system. The Q input, must be biased with 1.0V. When the wideband AM is turned on, the I/Q is turned on and the I/Q source is set to external. If the I/Q is turned off or the I/Q source is set to anything other than external, then the wideband AM turns off.
Using Analog Modulation (Option UNT Only)
Using an External Modulation Source

Figure 4-2  Wideband AM Softkey Menu

1. Set up and enable the desired modulation type.
2. Press AM > More > AM WB to On
5 Optimizing Performance

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only available through the Web-Enabled MXG or through SCPI commands. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator. If you are not comfortable with functions such as setting the power level and frequency, refer to Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that chapter.

- Using the Dual Power Meter Display on page 80
- Using Flatness Correction on page 88
- Using Internal Channel Correction—(Requires Option U01 or Greater) on page 97
- Using External Leveling (N5183A Only) on page 102
- Using Unleveled Operating Modes on page 110
- Using an Output Offset, Reference, or Multiplier on page 113
- Using Free Run, Step Dwell, and Timer Trigger on page 117
- Using LXI (Option ALB) on page 120
- Using a USB Keyboard on page 126
Using the Dual Power Meter Display

The dual power meter display can be used to display the current frequency and power of either one or two power sensors. The display outputs the current frequency and power measured by the power sensors in the larger center display and in the upper right corner of the display. Refer to Figure 5-2, Figure 5-2, and Figure 5-3.

NOTE  The dual power meter display feature is only available on instruments with serial prefixes \textgreater US/MY/SG4818.

To use two U2000 USB Series power sensors with the MXG, a USB hub (with power supply), can be connected to the MXG’s front panel USB connector.

Figure 5-1  Dual Power Meter Display with Power Sensors A and B Calibrated

Once turned on, the power meter readings are always visible, even if another instrument feature is selected (i.e. Sweep, AM, etc.).

This area is the main display for the dual power meter calibration frequency and current power measured.

If channel A or channel B power sensors or both are displayed, and the AMPTD or the FREQ softkeys are pressed, the large power meter measurements remains displayed. After the first connection, if the connection is successful, the model number and serial number of the power sensor is displayed.

For details on each key, use key help as described on page 42.
Figure 5-2  Dual Power Meter Display Menu

- Enables the power sensor on channel A.
- Enables the power sensor on channel B.
- Channel B is configured similarly to channel A. See page 82.
- For details on each key, use key help as described on page 42.

See page 82
Figure 5-3 Configuring the Power Sensor Channels

Note: This figure illustrates channel A, but channel B is similar.

USB U2000A Series Power Sensors do not require the sensor to be calibrated.


Zero Sensor and Calibrate Sensor softkeys are inactive during a measurement.

For details on each key, use key help as described on page 42.

Sockets LAN: Sets the IP port to 5025 (standard) or 5023 (telnet) programming.

VXI–11 LAN: Opens a menu for entering a device name for the power meter being used.

VXI–11 softkey is used to communicate remotely with a power meter that has a GPIB connector via LAN–GPIB gateway.
Example: Dual Power Meter Calibration

In the following example a U2004A USB Power Sensor is connected to channel A and a N1912A P-Series Power Meter and 8482A Power Sensor are connected to channel B and are zeroed and calibrated, as required.

On the MXG:

   **CAUTION** Verify RF Output power is off before continuing.

2. Connecting the Channel A power sensor: Connect USB sensor to MXG. The MXG should display a message across the bottom that reads similar to:
   USB TMC488 device (USB POWER SENSOR,MY47400143) connected

   ![Figure 5-4 MXG Displays Connection to U2000 USB Power Sensor](image)

3. Press **Aux Fctn > Power Meter Measurements > Channel A Setup > Connection Settings > Connection Type > USB Device (None) > USB POWER SENSOR (MY47400143)**

4. Press **Return > Zero Sensor**

   A diagnostic dialog box appears the initial time that a U2000 Series power sensor with a different serial number is connected to the MXG (refer to Figure 5-5). After the U2000 has been recognized by the MXG, the U2000 power sensor is saved as a softkey in the instrument and the dialog box in Figure 5-5 won’t be displayed (press DONE, if you see this message).

   ![Figure 5-5 Diagnostic Dialog Box for USB Sensor](image)

   A Running Calibration(s) bar is displayed on the MXG. Refer to Figure 5-6 on page 84.
Optimizing Performance
Using the Dual Power Meter Display

NOTE
The U2000 Series USB Power Sensor, does not require a 50 MHz calibration. If a calibration is attempted with the U2000 Series Power Sensors, the MXG displays a message reading:
The U2000 series power sensor does not require a 50 MHz calibration. Refer to Figure 5-7 on page 84.

5. Press Return > Return > Channel A to On
The current power meter sensor reading should be displayed in the ChA portion of the instrument's display and in the upper right portion of the display under Power Meter. Refer to Figure 5-8.
6. On the N1912A P-Series Power Meter (Channel B power sensor): Connect the N1912A P-Series Power Meter to the LAN.

7. Connect the power meter sensor to channel B of the power meter.

**NOTE** It is recommended, but not required to use the channel B on the N1912A. This provides continuity with the MXG’s dual display. For this example, the U2004A has already used up the channel A position on the MXG.

8. Connect the power sensor input to the 50 MHz reference of the power meter.

9. Press **Channel B Setup**

10. Press **Connection Settings > Sockets**

11. Press **IP Address > IP address > Enter**

**NOTE** The IP address of the power meter should be displayed in the ChB section of the display.

12. Press **Return > Channel Settings > External Power Meter Channel** to B
13. On the MXG: Press Channel B to On and then back to Off again. This initializes the MXG to the external power meter.

14. Press Return > Zero Sensor

A diagnostic dialog box is displayed each time an external power meter is being used and the Zero Sensor or Calibrate Sensor softkey is pressed (refer to Figure 5-10 on page 86).

Verify the power sensor is connected to the 50 MHz reference of the power meter.

Figure 5-10 Diagnostic Dialog Box for Channel B

15. Press Done

The Running Calibration(s) bar is displayed: Zeroing Sensor Please wait....

16. After Running Calibration(s) bar disappears: Press Calibrate Sensor

Diagnostic Dialog box is displayed that prompts for verifying the connection of the power sensor to the power meter 50 MHz reference (refer to Figure 5-11 on page 86).

Figure 5-11 Diagnostic Dialog Box for Calibration

For details on each key, use key help as described on page 42.
17. Press **Done**
   Calibration progress bar is displayed. Refer to Figure 5-12 on page 87.

   **Figure 5-12 Running Calibration(s) Bar (Calibrating Sensor)**

18. Press **Return > Channel B** to On

19. The current power meter sensor reading should be displayed on the MXG in the ChB portion of the display and in the upper right corner of the display under Power Meter and to the left of the Power Meter power sensor reading.

   **Figure 5-13 Channel B Power Sensor Displayed on MXG**

20. The power sensors are now ready to be connected in a measurement setup.
Using Flatness Correction

User flatness correction allows the digital adjustment of RF output amplitude for up to 1601 sequential linearly or arbitrarily spaced frequency points to compensate for external losses in cables, switches, or other devices. Using an Agilent N1911A/12A, E4419A/B, or U2000 Series power meter/sensor to calibrate the measurement system, a table of power level corrections can automatically be created for frequencies where power level variations or losses occur. Supported connection types to the power meter/sensor are Sockets LAN, VXI–11 LAN, USB, and GPIB via VXI–11 LAN using a LAN–GPIB gateway (e.g. E5810A Gateway or equivalent).

| NOTE | A power meter with GPIB requires using the Connection Type VXI–11 softkey, as well as a LAN–GPIB gateway, to control a power meter. Refer to the Agilent Connectivity Guide USB/LAN/GPIB Connectivity Guide (E2094–90009), Agilent MXG’s FAQs “How do I connect to the LAN?”, and to the E5810A User’s Guide or equivalent, LAN/GPIB gateway device. |

If you do not have an Agilent N1911A/12A or E4419A/B power meter, or U2000A/01A/02A/04A power sensor, or if your power meter does not have a LAN, GPIB, or USB interface, the correction values can be manually entered into the signal generator.

To allow different correction arrays for different test setups or different frequency ranges, you may save individual user flatness correction tables to the signal generator's memory catalog and recall them on demand.

Follow the steps in the next sections to create and apply user flatness correction to the signal generator's RF output (see page 92).

Afterward, follow the steps in “Recalling and Applying a User Flatness Correction Array” on page 96 to recall a user flatness file from the memory catalog and apply it to the signal generator's RF output.
Optimizing Performance
Using Flatness Correction

For details on each key, use key help as described on page 42.

Figure 5-14 User Flatness Correction Softkeys

For details on each key, use key help as described on page 42.
Creating a User Flatness Correction Array

In this example, you will create a user flatness correction array. The flatness correction array contains ten frequency correction pairs (amplitude correction values for each specified frequency), from 500 MHz to 1 GHz.

An Agilent N1911A/12A or E4419A/B power meter and E4413A power sensor are used to measure the RF output amplitude at the specified correction frequencies and transfer the results to the signal generator. (A U2000 Series power meter/sensor could be used in lieu of the power meter and E4413A power sensor.) The signal generator reads the power level data from the power meter, calculates the correction values, and stores the correction pairs in the user flatness correction array.

If you do not have the required Agilent power meter, or if your power meter does not have a LAN, GPIB, or USB interface, you can enter correction values manually.

**NOTE**

On the N5183A, if the setup is using an external leveling configuration, the equipment setup in “Required Equipment” on page 90 assumes that the steps necessary to correctly level the RF output have been followed. If you have questions about external leveling, refer to “Using External Leveling (N5183A Only)” on page 102.

**Required Equipment**

- Agilent N1911A/12A or E4419A/B power meter (a power meter is not required with the U2000A/01A/02A/04A Power Sensor)
- Agilent E4413A E Series CW power sensor or U2000A/01A/02A/04A Power Sensor
- GPIB, LAN, or USB interface cables, as required
- adapters and cables, as required

**NOTE**

For operating information on a particular power meter/sensor, refer to its operating guide.

**Connect the Equipment**

Connect the equipment as shown in “Connect the Equipment” on page 91.

**NOTE**

During the process of creating the user flatness correction array, the power meter is remotely controlled by the signal generator.
Optimizing Performance
Using Flatness Correction

Connect the Equipment

- Agilent N1911A/12A or E4419A/B power meter
- Agilent U2000A/01A/02A/04A power Sensor

- LAN, GPIB, or USB interface cables, as required
- adapters and cables, as required

The LAN, GPIB*, and USB connections are for convenience. If your power meter does not have LAN, GPIB, or USB, then manually enter corrections as described in the correction entry step in this section.

*GPIB control of a power meter requires a LAN–GPIB gateway and use of the connection type VXI–11. Refer to the Agilent Connectivity Guide USB/LAN/GPIB Connectivity Guide (E2094–90009), Agilent MXG’s FAQs “How do I connect to the LAN7”, and to the E5810A User’s Guide or equivalent LAN/GPIB gateway device.

Note: Agilent U2000 Series USB Power Sensors connect directly to the signal generator’s front panel USB port (i.e. the power meter is not applicable).

For operating information, refer to the power meter/sensor documentation.
Basic Procedure
1. Create a user flatness array.
   a. Configure the power meter/sensor
   b. Connect the equipment
   c. Configure the signal generator
   d. Enter the user flatness correction values
2. Optionally, save the user flatness correction data.
3. Apply user flatness correction to the RF Output.
Configure the U2000A/01A/02A/04A Power Sensor

1. Connect the power sensor to the signal generator's front panel USB port. Refer to “Connect the Equipment” on page 91.

2. Zero the power sensor using the signal generator softkeys.

---

CAUTION
Verify the signal generator RF Output power is set to the desired amplitude before performing the power meter zero. No RF Output amplitude check is done by the signal generator during zero.

---

NOTE
The signal generator's RF Output LED remains unchanged during zeroing of the power sensor (e.g. if the RF Output LED was on prior to starting the Zeroing of the power sensor, the LED remains on throughout the zero/calibration). But, actually the instrument’s firmware has turned off the RF Output’s power.

For operating information on your particular power sensor, refer to its operation guide.

---

Configure the E4419A/B and N1911A/12A Power Meter

1. Select SCPI as the remote language for the power meter.

2. Zero and calibrate the power sensor to the power meter, using the softkeys on the signal generator or the front panel of the power meter.

3. Enter the power sensor calibration factors into the power meter as required.

4. Enable the power meter's cal factor array.

---

NOTE
The signal generator’s RF Output LED remains unchanged during zeroing of the power sensor (e.g. if the RF Output LED was on prior to starting the Zeroing of the power sensor, the LED remains on throughout the zero/calibration). But, actually the instrument’s firmware has turned off the RF Output’s power.

For operating information on your particular power meter/sensor, refer to its operating guide.

---

Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction Values

Create the User Flatness Array

1. Configure the signal generator:
   a. Preset the signal generator.
   b. Set the signal generator's connection type to the power meter/sensor:
      i. Press AMPTD > More > User Flatness > Configure Power Meter > Connection Type > connection type.
      ii. If connection type is USB:
         1. Zero Sensor
         2. Go to step c.
else

If Sockets LAN or VXI–11 LAN: Press **Power Meter IP Address** > *power meter’s or LAN–GPIB gateway IP address* > **Enter**.

iii. If Sockets LAN: Press **Power Meter IP Port** > *IP port* > **Enter**.

else

If VXI–11: Press **PM VXI–11 Device Name** > *device name* > **Enter**.

When connecting directly to the power meter, enter the *device name* as specified in the power meter’s documentation. Typically, this is “inst0” and is case sensitive for some power meters. Refer to your power meter’s documentation, the Agilent Connectivity Guide USB/LAN/GPIB Connectivity Guide (E2094–90009), and Agilent MXG’s FAQs “How do I connect to the LAN?”

When connecting via a LAN–GPIB gateway, enter the SICL address of the power meter. Typically, this is “gpib0,13”, where “gpib0” is the GPIB SICL interface name of the gateway and “13” is the GPIB address of the power meter. Refer to the Agilent Connectivity Guide USB/LAN/GPIB Connectivity Guide (E2094–90009), Agilent MXG’s FAQs “How do I connect to the LAN?”, and to the E5810A User’s Guide or equivalent, LAN/GPIB gateway device.

c. Open the User Flatness table editor and preset the cal array:

Press **Return** > **Configure Cal Array** > **More** > **Preset List** > **Confirm Preset with Defaults**.

d. In the Step Array menu, enter the desired flatness–corrected start and stop frequencies, and the number of points:

Press **More** > **Configure Step Array** >

Freq Start > 500 MHz >
Freq Stop > 1 GHz >
# of Points > 10 > **Enter**

e. Populate the user flatness correction array with the step array configured in the previous step:

Press **Return** > **Load Cal Array From Step Array** > **Confirm Load From Step Data**.

f. Set the output amplitude to 0 dBm.

g. Turn on the RF output.
2. Connect the power meter to the RF output and enter the correction values:

<table>
<thead>
<tr>
<th>With a Power Meter Over LAN, GPIB, or USB</th>
<th>Manually</th>
</tr>
</thead>
<tbody>
<tr>
<td>i. Create the correction values:</td>
<td>i. Open the User Flatness table editor and highlight the frequency value in row 1:</td>
</tr>
<tr>
<td>The signal generator begins the user flatness calibration, and displays a progress bar.</td>
<td>The RF output changes to the frequency value of the table row containing the cursor.</td>
</tr>
<tr>
<td>The amplitude correction values load automatically into the user flatness correction array.</td>
<td>ii. Note the value measured by the power meter.</td>
</tr>
<tr>
<td>ii. View the stored amplitude correction values:</td>
<td>iii. Change the sign on the delta value (e.g. the delta value of the 0 dBm reference value (step f), and the measured value from ii is -.34, change the value to +.34).</td>
</tr>
<tr>
<td>Press Configure Cal Array.</td>
<td>iv. Highlight the correction value in row 1.</td>
</tr>
<tr>
<td></td>
<td>v. Press Select &gt; enter the delta calculated in step iii &gt; dB.</td>
</tr>
<tr>
<td></td>
<td>(e.g. For this example enter +.34)</td>
</tr>
<tr>
<td></td>
<td>The signal generator adjusts the output amplitude based on the correction value entered.</td>
</tr>
<tr>
<td></td>
<td>vi. Repeat steps ii – v until the power meter reads 0 dBm.</td>
</tr>
<tr>
<td></td>
<td>vii. Highlight the frequency value in the next row.</td>
</tr>
<tr>
<td></td>
<td>viii. Repeat steps ii through vii for the remaining rows.</td>
</tr>
</tbody>
</table>

The user flatness correction array title displays User Flatness: (UNSTORED), without a name, indicating that the current user flatness correction array data has not been saved to the file catalog.

Optional: Save the User Flatness Correction Data
1. Press Load/Store > Store to File.
2. Enter a file name (for this example, FLATCAL1) and press Enter.

The user flatness correction array file is now stored in the file catalog as a USERFLAT file. Any user flatness correction files saved to the catalog can be recalled, loaded into the correction array, and applied to the RF output to satisfy specific RF output flatness requirements.

3. Press Return.

Enable the Flatness Correction at the RF Output
- Press Return > Flatness Off On.

The UF annunciator appears in the AMPLITUDE area of the display, and the correction data in the array is applied to the RF output.
Recalling and Applying a User Flatness Correction Array

The following example assumes that a user flatness correction array has been created and stored. If not, perform the Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction Values on page 93.

1. Preset the signal generator.

2. Recall the desired User Flatness Correction file:
   b. Press More > Load/Store.
   c. Highlight the desired file.
   d. Populate the user flatness correction array with the data contained in the selected file:
      Press Load From Selected File > Confirm Load From File.
      The user flatness correction array title displays User Flatness: Name of File.

3. Apply the correction data in the array to the RF output: Press Return > Flatness Off On to On.
Using Internal Channel Correction—(Requires Option U01 or Greater)

The internal channel correction feature corrects the 100 MHz baseband bandwidth flatness and phase for arbitrary center frequencies. This feature is off by default, as the switching speed performance of the instrument is impacted when this feature is on.

This calibration should be run when the ambient temperature has varied by at least ±5 degrees Celsius from the ambient temperature at which the previous calibration was run.

**NOTE**

There is an internal calibration routine that can be run to collect correction data for both the baseband and RF magnitude and phase errors over the entire RF frequency range on any unit with options 651, 652, or 654. The internal channel correction cannot be turned on until after the correction has been executed once.

For new instruments, shipped with firmware version A.01.60 and above, the internal flatness correction calibration has already been run.

When this feature is off, the box will behave as it always has. When this feature is on, the internal I/Q path is active, the I/Q Correction Optimized Path is RF Output, and the frequency is changed by more than 1 kHz, the firmware will calculate a channel correction filter ±50 MHz about the specified frequency. For List/Sweep, the calculation will be done prior to the first sweep using the specified frequencies when either waveform sweep is active or the baseband is on and the instrument is optimized for the internal path. This calculation will cache corrections for up to the maximum number of cache points (256). For list/sweep, the sweep will pause and recalculate the correction caches before running again.

**CAUTION**

In the case of arbitrary frequency switching, once the correction cache is full (256 unique frequency points), the oldest frequency corrections will be forgotten as new frequencies are selected.

Whenever I/Q Timing Skew, I/Q Delay, Quadrature Angle Adjustment, or the Int Equalization Filter is adjusted, all caches are forgotten.

Additional characteristics of the internal channel correction:

- When the internal channel correction is on, arbitrary frequency switching while the baseband is on will take up to an additional 290 ms (72 ms typical) the first time that frequency is specified. After the first time that a frequency is selected, switching to that frequency again takes an additional 1 ms.

- If a frequency sweep is activated, then the calculation and caching will occur up front for the first 256 unique frequencies, and all additional unique frequencies will have the characteristics of arbitrary frequency switching.

- If the I/Q Correction Optimized Path softkey is set to Ext I/Q, then only the baseband corrections will be applied and the frequency switching will be unaffected.

- If active, the ACP Internal I/Q Channel Optimization filter and the Equalization filter, will be convolved with the internal channel correction. A hamming window is applied and the resulting filter will be truncated to 256 taps.
Optimizing Performance
Using Internal Channel Correction—(Requires Option U01 or Greater)

Configure Internal Channel Correction

The following is a basic configuration for using the MXG’s internal channel correction. Refer to Figure 5-16.

On the MXG:
1. Set the center frequency:
   Press \texttt{Freq > 3 > GHz}
2. Set the I/Q to internal (default):
   Press \texttt{I/Q > I/Q Source > Internal}
3. Press \texttt{I/Q} to On
4. Perform internal channel correction:
   Press \texttt{More > Int Channel Correction > Execute Cal}
5. Press \texttt{Int Channel Correction to On}

SCPI Commands:

\begin{verbatim}
[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe] ON|OFF|1|0
[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe]?
:CALibration:BBG:CHANnel
\end{verbatim}

For details on each key, use key help as described on page 42.
Using I/Q Mod Skew Cal

The I/Q mod skew calibration initiates the external calibration of the I/Q timing skew for the I/Q modulator (RF output path). This feature will improve out-of-channel image rejection.

This calibration requires the RF output of the instrument to be connected to the RF input of a spectrum analyzer.

**NOTE**

This calibration needs to be run only once for any set of hardware.

For instruments that shipped with firmware release A.01.60 or newer, this calibration does not need to be run unless hardware inside of the instrument is repaired or replaced.

For instruments that shipped prior to the release of A.01.60 firmware, option "R2C: Core FW enhancements, A.01.60" or newer must be purchased to allow the full Int Channel Correction functionality, which corrects the internal baseband generator RF and baseband magnitude and phase across the 100MHz baseband bandwidth for all RF frequencies.

For instruments that shipped prior to firmware release A.01.60 that have had option "R2C: Core FW enhancements, A.01.60" or newer installed, the Int Channel Correction feature will achieve its full correction only after this calibration has been run once.
Optimizing Performance
Using I/Q Mod Skew Cal

Figure 5-17 I/Q Mod Skew Cal Softkeys

- I/Q > More > Int Channel Correction (Option U01)
- or
- I/Q > More > I/Q Mod Skew Cal

SCPI Command:
:CALibration:BBG:SKEW:RFOut

The status window shows the current state of the calibrations, and instructions on how to run the calibrations.

See Figure 5-18 for information on this key.

Initiates the external calibration of the I/Q Timing Skew for the I/Q Modulator (RF output path) using the spectrum analyzer configured in the Configure Spectrum Analyzer key.

For details on each key, use key help as described on page 42.
Optimizing Performance
Using I/Q Mod Skew Cal

**Figure 5-18 SA Config Softkeys**

I/Q > More > Int Channel Correction > Int Chan Corr

<table>
<thead>
<tr>
<th>SCPI Commands:</th>
</tr>
</thead>
<tbody>
<tr>
<td>:SYSTEM:SANalyzer:COMMunicate:TYPE SOCKets</td>
</tr>
<tr>
<td>:SYSTEM:SANalyzer:COMMunicate:LAN:DEVice &quot;&lt;deviceName&gt;&quot;</td>
</tr>
<tr>
<td>:SYSTEM:SANalyzer:COMMunicate:LAN:DEVice?</td>
</tr>
<tr>
<td>:SYSTEM:SANalyzer:COMMunicate:LAN:IP &quot;&lt;ipAddr&gt;&quot;</td>
</tr>
<tr>
<td>:SYSTEM:SANalyzer:COMMunicate:LAN:IP?</td>
</tr>
<tr>
<td>:SYSTEM:SANalyzer:COMMunicate:LAN:PORT &lt;portNum&gt;</td>
</tr>
<tr>
<td>:SYSTEM:SANalyzer:COMMunicate:LAN:PORT?</td>
</tr>
<tr>
<td>:SYSTEM:SANalyzer:COMMunicate:TYPE SOCKets</td>
</tr>
<tr>
<td>:SYSTEM:SANalyzer:COMMunicate:TYPE?</td>
</tr>
</tbody>
</table>

The status window shows the connection status of the spectrum analyzer.

Attempts to connect to the specified external spectrum analyzer and execute a "*IDN?" SCPI command. If the result is "Connected, but no "*IDN?" response", then the IP address connected to something, but the socket port or VXI-11 device name was not correct.


For details on each key, use key help as described on page 42.
Using External Leveling (N5183A Only)

CAUTION While operating in external leveling mode, if either the RF or the DC connection between the signal generator and the detector is broken, maximum signal generator power can occur. This maximum power may overstress a power-sensitive device under test.

External leveling lets you move the ALC feedback source closer to the device under test (DUT) so that it accounts for most of the power uncertainties inherent to the cabling and components in a test setup. Refer to Figure 5-19.
The external detector outputs a negative voltage to the signal generator’s rear panel ALC INPUT connector based on the power level at the detector. As the RF power level at the coupler’s/power splitter input changes, the external detector returns a compensating negative voltage. The ALC circuit uses this negative voltage to level the RF output power by raising and lowering the signal’s power, thus ensuring a constant power level at the point of detection (external detector). Since the point of detection does not occur at the output of the device to which the detector is connected, there is some power loss that is not compensated for by the external detector. For example on a coupler, the coupled port siphons some of the signal’s energy to drive the external detector. In addition the coupler experiences some insertion loss between the coupled port and the output.

Figure 5-21 on page 105 shows the input power versus output voltage characteristics for typical Agilent Technologies diode detectors. Using this chart, you can determine the leveled power at the diode detector input by measuring the external detector output voltage. For a coupler, you must then add the coupling factor to determine the leveled output power.

When using an external detector, the signal generator’s power range may vary from the values shown in the data sheet. This is primarily due to the efficiency of the detector. Always ensure that the detector, coupler/power splitter are specified for the power and frequency range of interest. To determine the signal generator’s actual power range during external leveling, see “Determining the Signal Generator’s Amplitude Range” on page 107.

With external leveling, the displayed amplitude value can vary significantly from the actual output power of the coupler/power splitter to which the external detector is connected (see Figure 5-20). This is because the coupler/power splitter has its own signal characteristics (insertion loss, coupling factor, and so forth), which are unknown to the signal generator, so it is typically unable to display an accurate amplitude value. Also components between the signal generator and the external detector can affect the output power of the coupler/power splitter. You can compensate for this power display difference by using the Ext Leveling Amptd Offset softkey or the Amptd Offset softkey. The difference between the two softkeys is that the Ext Leveling Amptd Offset functions only while external leveling is active. For more information on using the external leveling offset feature, see “Adjusting the Signal Generator Display’s Amplitude Value” on page 109.
Optimizing Performance
Using External Leveling (N5183A Only)

Figure 5-29 Power Value Differences with External Leveling

Signal generator set power level

Measured output power of a coupler
Option 1E1 Output Attenuator Behavior and Use

When using the internal detector, the Option 1E1 output attenuator enables signal generator power levels down to -135 dBm at the RF Output connector. It accomplishes this by adding attenuation to the output signal after the ALC detection circuit. The output power value (shown in the Amplitude area of the display) is the resultant of the Set Atten and Set ALC Level values (see page 102). With the external detector selected, the output attenuator no longer attenuates the output signal since the
feedback for the detection circuit has been moved beyond the output attenuator. Because the
attenuator no longer affects the amplitude of the output signal, the output amplitude is determined
by only the Set ALC Level softkey.

With external leveling selected, the signal generator enables attenuator hold and the power range
approximates the range of a standard option (no attenuator) signal generator (see the Data Sheet).
As stated earlier, the actual output power may vary due to the external detector and the
coupler/power splitter performance characteristics.

---

**NOTE** When the internal detector (Internal selection) is reselected, the signal generator does not
turn the attenuator hold off.

Even though the output attenuator no longer affects the output power, it is still useful to drive the
ALC circuit to its mid-power point of approximately 0 dBm, which is optimal for the internal leveling
circuitry and typically provides the best amplitude flatness results. This is useful with negative power
values of −5 dBm or less. For example, to drive the ALC to approximately mid-power with a −20
dBm power setting, add 25 dB of attenuation. This sets the ALC circuit to 5 dBm (−20 + 25).

---

**NOTE** If there is too much attenuation, it will drive the ALC circuit too high and cause the signal
generator to go unleveled. Ensure that you decrease the attenuation as you increase the
power level.

---

**Configure External Leveling**

**Basic Setup Process**

- If working with a single frequency signal, perform Steps 1 through 5.
- If working with multiple frequencies:
  - b. Perform a user flatness correction, see “Using Flatness Correction” on page 88.
- If working with a sweep:
  - b. Setup the sweep, see “Configuring a Swept Output” on page 48.

1. Setup the equipment, see “Equipment Setup” on page 106
2. Configure the carrier signal, see “Configuring the Carrier” on page 107
3. Select external leveling, see “Selecting External Leveling” on page 107.
4. Determine the output amplitude range, see “Determining the Signal Generator’s Amplitude Range”
on page 107
5. Set the displayed power value, see “Adjusting the Signal Generator Display’s Amplitude Value” on
page 109

**Equipment Setup**

Set up the equipment as shown in Figure 5-22 on page 107. Place the external detector (detector and
coupler/power splitter) as close as possible to the DUT.
Recommended Equipment

- Agilent 8474E negative detector
- Agilent 87301D directional coupler
- cables and adapters, as required

**Figure 5-22 Typical External Leveling Setup using a Directional Coupler**

Configuring the Carrier

1. Press **Preset**.
2. Set the carrier frequency.
3. Set the power level to 0 dBm:
   - If the signal generator has no output attenuator (no Option 1E1) or it has Options 1E1 and 532 or 540 installed:
     - Press **AMPTD > 0 > dBm**.
   - If the signal generator has Options 1E1 and 520, set the output attenuator to zero dBm:
     a. Press **AMPTD > Atten/ALC Control > Atten Hold Off On** to On.
     b. Press **Set Atten > 0 > dB**.
     c. Press **Set ALC Level > 0 > dBm**.

Selecting External Leveling

Press **AMPTD > Leveling Control > Leveling Mode > Ext Detector**.

Determining the Signal Generator’s Amplitude Range

The maximum output amplitude is frequency dependent. So if you are using multiple frequency points and there is a need to know the maximum output amplitude for each frequency point, refer to the “Amplitude” section of the *MXG Data Sheet*. Then use this procedure to determine the maximum amplitude for each band.
Optimizing Performance
Using External Leveling (N5183A Only)

With external leveling and Option 1E1, the signal generator’s the power range approximates that of a standard option instrument (no Option 1E1). But Option 1E1 does let you use the attenuator to drive the ALC to its mid-power point when using negative amplitude values. However adding attenuation does decrease the upper range limit. For more information, see “Option 1E1 Output Attenuator Behavior and Use” on page 105.

1. If Option 1E1 is installed, adjust the attenuator to the desired level.

**NOTE** If the Option 1E1 output attenuator value is too high (approximately ≥ 55 dB), it will cause an unlevel condition to occur when the RF output is turned on.

   a. Press **AMPTD > Atten/ALC Control > Set Atten**.
   b. Enter the attenuator value.

2. Turn on the RF output: Press **RF On/Off** to On

3. Set the **AMPTD** step increment value to one dB.
   - Press **AMPTD > Incr Set > 1 > dB**.

4. Determine the minimum amplitude value:
   a. Set the amplitude to −25 dBM.
   b. Using the down arrow key, decrease the amplitude until the **UNLEVEL** annunciator appears.
   c. Using the up arrow key, increase the amplitude until the **UNLEVEL** annunciator is gone.
      The value showing when the **UNLEVEL** annunciator is gone is the minimum amplitude range value.

5. Determine the maximum amplitude value:
   a. Set the amplitude to a value that does not cause the signal generator to go unleveled.
   b. Using the up arrow key, increase the amplitude until it goes unleveled or an error message indicating that the upper limit has been reached shows at the bottom of the display.
   c. Decrease the amplitude value:
      - If the unleveled annunciator appeared, decrease the amplitude until the annunciator is gone. The value where the annunciator disappears is the maximum upper range value.
      - If the signal generator displays Error: 501, Attenuator hold setting over range at the bottom of the display, the value showing is the maximum upper range value.

      To remove the error message, press the down arrow key until the message is gone. The error appears when an attempt is made to increase the amplitude beyond the maximum value as it relates to the current attenuator setting.
Adjusting the Signal Generator Display’s Amplitude Value

When using external leveling, the signal generator’s displayed amplitude value will not match the leveled power of the signal at the output of the coupler/splitter. To compensate for this difference, the signal generator provides two methods for configuring the displayed power value so that it closely matches the measured value at the output of the coupler/splitter.

1. Connect and configure a measurement instrument:
   a. Connect the output of the coupler/splitter to either a power meter or a signal analyzer.
   b. Configure the power meter/signal analyzer for measuring the power level of the signal.

2. Adjust the signal generator’s displayed amplitude value:
   a. If using the Ext Leveling Amptd Offset Softkey:
      This softkey uses 16 dB as its zero reference. The 16dB is the coupling factor of the internal detector.
      b. While viewing the carrier amplitude value on the signal generator display, use the RPG knob (detent knob) to adjust the offset value until the integer part of the displayed amplitude value is the same as the integer portion of the measured value.
         Each detent position adjusts the value by 1 dB.
      c. Using the number keypad, make the necessary fractional adjustments to the display amplitude value.
   b. If using the Amptd Offset Softkey:
      b. Calculate the difference between the signal generators displayed Amplitude value and the measured value.
      c. Using the numeric keypad, enter this difference as the Amptd Offset softkey value.
Using Unleveled Operating Modes

Figure 5-23 Power Search and ALC Off Softkeys

**ALC Off Mode**

Turning ALC off deactivates the signal generator's automatic leveling circuitry. Turning ALC off is useful when the modulation consists of very narrow pulses that are below the pulse width specification of the ALC or when up converting external IQ signals and the modulation consists of slow amplitude variations or bursts that the automatic leveling would remove or distort. When using the internal IQ baseband generator, the best technique is to use the ALC hold marker function vs. ALC off for the types of signals just described.

**NOTE**

After the ALC has been turned off, power search must be executed to set the proper output power level requested on the front panel. Power search is executed automatically by default, but these settings can be overridden by using the Manual mode.
Power Search Mode

**NOTE**  The power search mode cannot be used with bursted signals input via the external IQ inputs.

The MXG has three power search modes (for internal and external I/Q modulation) and four power search references (for external I/Q modulation only). Refer to Figure 5-23 on page 110.

Power search executes a routine that temporarily activates the ALC, calibrates the power of the current RF output, and then disconnects the ALC circuitry.

**Power Search Modes (Applies to External and Internal I/Q Modulation)**

- **Auto** – A power search is executed at each frequency or power change, and at each change to the AM, burst, pulse, or I/Q modulation state.

- **Span** – A power search is executed over a range of user-defined frequencies. The power search is stored and used when the MXG is tuned within a user-defined range. After the Span softkey is pressed, select either **Full** or **User**. If **User** is selected, then the start and stop frequencies need to be selected.

- **Manual** – When **Power Search** is set to Manual, pressing **Do Power Search** executes the power search calibration routine for the current RF frequency and amplitude. In this mode, if there is a change in RF frequency or amplitude, you will need to press **Do Power Search** again.

**Power Search References (Only applies to Internal I/Q Modulation)**

The four Power Search References control the power search function. These four references select the reference voltage used while the RF signal is being I/Q modulated. (Power search references are not used for analog modulation: FM, φM, or pulse modulation.)

**CAUTION**  If the power search reference has the incorrect RMS voltage, the output power will be incorrect. Refer to Figure 5-24, “Calculating the Output Power Error for a Single Waveform Sample Point” and Figure 5-25, “Calculating the RMS Voltage of the Waveform.”

**NOTE**  A successful power search is dependent on a valid power search reference.

- **Fixed** – Reference level is 0.5 Vrms.
  This reference functions with internal, external IQ and bursted signals. This is the instrument’s default setting.

- **RMS** – User provided reference level 0–1.414 Vrms placed in the Waveform Header. Refer to “Saving a Waveform’s Settings & Parameters” on page 151.
  This reference functions with internal IQ and bursted signals.

- **Manual** – User provided reference level 0–1.414 Vrms.
  This reference functions with internal, external IQ and bursted signals.

- **Modulated** – Uses the I/Q modulation signal as the reference level.
  This reference functions with internal or external IQ. It is not functional with bursted signals or a signal with varying Vrms.
Optimizing Performance
Using Unleveled Operating Modes

Figure 5-24 Calculating the Output Power Error for a Single Waveform Sample Point

The Output Power Error \[ = 20 \times \log_{10} \left( \frac{V_1}{V_2} \right) \]

Where:
- \( V_1 \) is the actual waveform RMS voltage
- \( V_2 \) is the entered RMS voltage

Note: If the RMS voltage value entered is lower than the actual RMS voltage, the output power will be higher than desired.
If the RMS voltage value entered is higher than the actual RMS voltage, the output power will be lower than desired.

Figure 5-25 Calculating the RMS Voltage of the Waveform

The MXG can calculate the RMS value automatically. If more than two contiguous IQ data points are zero, the MXG calculation ignores those zero points. Also, because the RMS calculation, that is done by the signal generator, is slow and may not be appropriate for your application, it is recommended that the user calculate and enter in their measured RMS value for the waveform file.

SCPI Commands:

\[
\text{[:SOURce]:RADio:ARB:HEADER:RMS <"file_name">,<val>|UNSPECified} \\
\text{[:SOURce]:RADio:ARB:HEADER:RMS? <"file_name"} \\
\]

For a programming example of determining the RMS voltage of a waveform, refer to the Programming Guide and to the Documentation CD that came with this instrument.

The RMS and MANUAL references are the most powerful selections. The user provides the reference level. The IQ signal can be bursted (radar) or have different RMS levels (Wireless Signals). Once the RMS/MANUAL reference level is set, the power search runs independent of the current Vrms value of the waveform.

The RMS and MANUAL references, with a reference level of 1.0 Vrms are equivalent to a calculated rms value of 1 and can be measured using SINE_TEST_WFM.

The FIXED, RMS, and MANUAL references use a DAC to apply the reference voltage and do not require the IQ signal to be present.

NOTE The MXG reference voltage is designed to operate between 0.1 Vrms to 1 Vrms nominally, but it can overrange to 1.414 Vrms. (The RMS can overrange to 1.414, if the constant values are loaded manually and all “1”s are entered for the I and Q values.) See also “Saving a Waveform’s Settings & Parameters” on page 151.

CAUTION The minimum reference level that results in a successful power search is dependent on RF Frequency, RF Amplitude, and Temperature. An MXG power search using a reference level of 0.1 Vrms for 0 dBm at 1 GHz may fail.
Power Search Settings

For the power search routine to execute, the instrument must be in the following conditions:

- The I/Q modulation enabled On.
- The RF output enabled On.
- The Automatic Leveling Circuitry deactivated (Off).
- The RF Blanking set to On.

This function prevents power spikes during the power search (refer to “Using the RF Blanking Marker Function” on page 168.)

- When using summing for the internal Arb and the external I/Q, all four power reference modes are available (e.g. Fixed, RMS, Manual, and Modulated).
- When using the external IQ inputs, use the MANUAL reference mode, and make sure the external I/Q signal is present when executing a power search. If the external I/Q signal is not present, the power search will fail.

Example: Automatic Power Search

1. Preset the signal generator.
2. Set the desired frequency.
3. Set the desired amplitude.
4. Turn the RF output on.
5. Deactivate the signal generator’s automatic leveling control:
   - Press AMPTD > ALC Off On to highlight Off

   Deactivating the signal generator’s automatic leveling control is a significant instrument change that automatically initiates a power search.

When set to Auto, power search automatically executes when a significant instrument setting changes. The Do Power Search feature enables you decide when to execute a power search to compensate for changes, such as temperature drift or a change in the external input.

Using an Output Offset, Reference, or Multiplier

Setting an Output Offset

Using an output offset, the signal generator can output a frequency or amplitude that is offset (positive or negative) from the entered value.

RF Output = entered value − offset value
Displayed Value = output frequency + offset value

To set an offset:

- Frequency: Press Freq > Freq Offset > offset value > frequency unit.
Optimizing Performance
Using an Output Offset, Reference, or Multiplier

- **Amplitude**: Press Amptd > More > Amptd Offset > offset value > dB.

Examples

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Example #1</th>
<th>Example #2</th>
<th>Example #3</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entered (and displayed) Value</td>
<td>300 MHz</td>
<td>300 MHz</td>
<td>2 GHz</td>
<td>The entered value must be positive.</td>
</tr>
<tr>
<td>Offset</td>
<td>50 MHz</td>
<td>−50 MHz</td>
<td>−1 GHz</td>
<td>An offset value can be positive or negative.</td>
</tr>
<tr>
<td>Output Frequency</td>
<td>250 MHz</td>
<td>350 MHz</td>
<td>3 GHz</td>
<td>The signal generator alerts you if the output frequency or amplitude is out of range.</td>
</tr>
</tbody>
</table>

When using the signal generator as a local oscillator (LO), you can use the offset to display the frequency of interest, as illustrated below:

**Setting an Output Reference**

Using an output reference, the signal generator can output a frequency or amplitude that is offset (positive or negative) by the entered value from a chosen reference value.

RF Output = reference value + entered value

To set a reference:

1. Set the frequency or amplitude to the value you want as the output reference level.
2. **Frequency**: Press Frequency > Freq Ref Set
   - The frequency displays 0.00 Hz, indicating that this is the RF output frequency “zero level.”
All frequencies entered are interpreted as being relative to this reference frequency.

*Amplitude:* Press Amptd > More > Amptd Ref Set

The amplitude displays 0.00 dB, indicating that this is the RF output amplitude “zero level.”
All amplitudes entered are interpreted as being relative to this reference amplitude.

**Examples**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Example #1</th>
<th>Example #2</th>
<th>Example #3</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference:</td>
<td>50 MHz</td>
<td>50 MHz</td>
<td>2 GHz</td>
<td>A reference value must be positive.</td>
</tr>
<tr>
<td>Entered (and displayed)</td>
<td>2 MHz</td>
<td>-2 MHz</td>
<td>-1 GHz</td>
<td>The entered value can be positive or negative.</td>
</tr>
<tr>
<td>Output Frequency:</td>
<td>52 MHz</td>
<td>48 MHz</td>
<td>1 GHz</td>
<td>The signal generator alerts you if the output frequency or amplitude is out of range.</td>
</tr>
</tbody>
</table>

To set a new frequency or amplitude reference, turn the frequency reference off, and then follow the steps above.

**Setting a Frequency Multiplier**

Using a frequency multiplier, the signal generator can display a frequency that is the multiple (positive or negative) of the output value.

Displayed Value = multiplier value × output frequency

Output Frequency = displayed value ÷ multiplier value

To set a frequency multiplier:

1. Press Frequency > Freq Multiplier > multiplier value > x.
2. Set the desired frequency.
   The display equals the output frequency times the multiplier value.
Examples

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Example #1</th>
<th>Example #2</th>
<th>Example #3</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frequency Multiplier:</td>
<td>3</td>
<td>−3</td>
<td>4</td>
<td>The multiplier range can be set from: +0.001 to +1000</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>−1000 to −0.001</td>
</tr>
<tr>
<td>Entered (and displayed)</td>
<td>600 MHz</td>
<td>−600 MHz</td>
<td>8 GHz</td>
<td>The signal generator alerts you if the output frequency is out of range.</td>
</tr>
<tr>
<td>Output Frequency:</td>
<td>200 MHz</td>
<td>200 MHz</td>
<td>2 GHz</td>
<td></td>
</tr>
</tbody>
</table>

When using the signal generator as the input to a system, you can set the frequency multiplier so that the signal generator displays the output of the system, as illustrated below using a doubler:

When measuring mixers, the frequency multiplier and frequency offset are often used together. In the upconverter example below, the multiplier is set to −1 and the offset is set to 3 GHz so that the
signal generator displays $f_{RF}$.

**Using the Frequency and Phase Reference Softkeys**

The MXG can be set to have either a user-determined frequency or phase reference.

**Figure 5-26 Frequency Reference and Frequency Offset Softkeys**

<table>
<thead>
<tr>
<th>Selected Multiplier</th>
<th>Selected Offset</th>
<th>Entered/Displayed Frequency (Ref)</th>
<th>Signal Generator Output ($f_{LO}$)</th>
</tr>
</thead>
<tbody>
<tr>
<td>-1</td>
<td>4800 MHz</td>
<td>800 MHz</td>
<td>2400 MHz</td>
</tr>
<tr>
<td>-1</td>
<td>3000 MHz</td>
<td>800 MHz</td>
<td>2400 MHz</td>
</tr>
</tbody>
</table>

**Using Free Run, Step Dwell, and Timer Trigger**

Free Run, Step Dwell (time), and Timer Trigger can be used to adjust the time spent at any point in a Step Sweep or a List Sweep. There are two possible measurement combinations:

*Free Run with Step Dwell time (Figure 5-27 on page 119)* the signal generator waits for the signal to settle and then waits for the Step Dwell time, then it jumps to the next frequency point. In addition, the time to complete the entire sweep can vary. There is *always* a minimum value of Step Dwell for each frequency point. The minimum Step Dwell timing for any point is fixed at a value of 100 us. The time between frequency points is the sum of the settling time, plus the Step Dwell time. The settling time is dependent on frequency, amplitude, band crossings, and other factors, so the time between frequency points can vary.
Optimizing Performance
Using Free Run, Step Dwell, and Timer Trigger

Timer Trigger instead of Free Run (Figure 5-27 on page 119) the signal generator generates equally spaced triggers, and it moves to the next point at each trigger. This has the advantage that the time between points is consistent and the overall sweep time is consistent. But, if the trigger is too fast, the signal may not have time to settle before jumping to the next point.

Understanding Free Run, Step Dwell, and Timer Trigger Setup

If the signal is to be settled for a minimum specific time at each point and it is not important if the point to point time is consistent, use Free Run and Set Dwell time.

If the signal’s point to point time requires consistency but the specific settling time at each point can vary, then use the Timer Trigger. Avoid using too fast of a sweep which does not allow the signal generator to settle.

If the signal needs to be settled for a specific minimum time and consistent point to point time is required, then you should set the Timer Trigger to be the sum of the switching time (900 us or 5 ms, depending on options) plus the minimum settled time that is needed to make the measurement.

If the measurement requires external equipment synchronization, consider using hardware triggers.
Optimizing Performance
Using Free Run, Step Dwell, and Timer Trigger

Figure 5-27 Free Run, Set Dwell, and Timer Trigger Softkeys

Use **Step Dwell** with **Free Run** when additional measurement wait time is desired after settling.

If the signal is to be settled for a minimum specific time at each point and it is not important if the point to point time is consistent, use **Step Dwell** and **Free Run** time.

If the signal's point to point time requires consistency but the specific settling time at each point can vary, then use the **Timer Trigger**. Avoid using too fast of a sweep which does not allow the signal generator to settle.

If the signal needs to be settled for a specific minimum time and consistent point to point time is required, then you should set the **Timer Trigger** to be the sum of the switching time (900 us (Option UNZ) or 5 ms (Standard)) plus the minimum settled time that is needed to make the measurement.

Example: If you need the signal to remain settled for 3 ms, and you have Option UNZ which settles in 0.9 ms, then set the time trigger to the sum which is 3.9 ms.

For details on each key, use key help as described on see page 42.
Using LXI (Option ALB)

NOTE  LXI Class B Compliance Disclaimer

As of this product firmware release in June 2008, LXI Class B Compliance Tests, using the new IEEE 1588–2008 Precision Time Protocol (PTP), were not available. This product provides the features of an LXI Class B instrument by adding LAN Triggering and Time Synchronization to its LXI Class C compliance. References to LXI Class B in the document, instrument menus and web pages do not insure LXI Class B compliance. This product will apply for LXI Class B Compliance when the LXI Consortium has approved its specification changes and can provide certified testing. Refer to http://www.lxistandard.org/home.

LXI–B is only available on instruments with serial prefixes ≥US/MY/SG4818.

The LXI Standard (LAN eXtensions for Instruments) brings the connectivity of the internet to the Test and Measurement industry. LXI adds a number of tools that a system integrator may use to improve the efficiency of his measurements and improve his visibility into his system.

This section assumes the user is well acquainted with LXI terminology and use models. Also, this section assumes that the user has read and understands the Chapter 3, “Basic Operation.” Refer to the Programming Guide and to www.lxistandard.org.

Understanding LXI Clocks

In the simplest test system, one Personal Computer (PC) connects to one LXI instrument through LAN. The PC has its own internal or browser clock and the LXI instrument has two clocks: the Operating System Clock (MS Windows, Windows CE, VX Works, etc.) and the PTP clock. This is shown in the following illustration.

Figure 5-28 LXI PC with Clock (Browser Clock) and MXG (Operating System Clock and PTP Clock)
The PC browser clock shows the local civil time using a standard Date/Time representation. If the PC is connected to a Network Time Protocol (NTP) server (through LAN), then its time will be relatively accurate. However, because the PC may be in a different time zone or have a different Daylight Savings Time offset (or both) than the instrument, it is possible for the PC Browser clock to have a different time than the Instrument's Operating System (OS) clock.

The LXI instrument has two clocks. The instrument's Operating System clock, similar to a PC's browser clock, shows civil time in a Date/Time format. The second clock is the instrument's PTP clock. It is this clock that synchronizes to the Master Clock (if one is in the system). Typically, this PTP clock shows time in elapsed seconds since its epoch.

As you create larger systems by adding more LXI instruments, the total number of system clocks increases significantly. In addition to instrument clocks, you may have PTP Master clocks and a PTP GrandMaster clock. Also, you may have one or more Boundary Clocks in your test system. Boundary Clocks will have both Master and Slave clocks depending on the port.

**NOTE**  The concept of *local clock* or *local time* can be confusing depending on your frame of reference. For example, if you think of yourself in front of the PC, then *local* is the Browser clock. If you think of yourself in front of the instrument, then *local* is the instrument. In most test systems, the PC and the instrument are located close together. But, in some test systems they may be located many miles apart, in different time zones, or even across an ocean. Also note that the SCPI uses *local* in the context of the instrument OS clock.
Getting Started With LXI

The following configurations provide the basic functionality of the LXI softkeys.

**NOTE** Enabling the LXI subsystem effects switching speed.
For optimal switching speed, disable the LXI subsystem when not in use.

---

**Figure 5-29 Configuring the LXI subsystem**

Enabling the LXI–B subsystem (On) opens the Status Information window where the PTP and Event Domain are configured. The Grandmaster and Master Clocks are controlled by remote commands only.

For details on each key, use key help as described on page 42.

Refer to the Programming Guide and the SCPI Command Reference.
Optimizing Performance
Using LXI (Option ALB)

For details on each key, use key help as described on page 42.

Refer to the Programming Guide and the SCPI Command Reference.

These are the pre-defined default input LAN event identifiers and can not be deleted. An incoming LAN event is treated as a trigger. The trigger event identifier must be enabled (On) and the LXI LAN (page 49) selected as the source of the trigger.
Figure 5-31 Configuring LXI Output Events

Utility > More > LXI

Indicates the instrument is waiting for a trigger.

Indicates whether or not a measurement operation is underway.

Indicates whether or not the instrument is sweeping the LO.

Indicates the instrument is settling.

Indicates that the instrument is sweeping the LO.

Indicates whether or not the instrument is waiting for a trigger.

Enables or disables the instrument event.

Disables the LAN event.

Typical operation where both edges of the instrument event are transmitted.

Only one edge of the instrument event is transmitted.

These are the pre–defined default outgoing LAN event identifiers and cannot be deleted.

The generation of an outgoing LAN event is dependant on the LAN event identifier being enabled (On) and the occurrence of one of the Internal Status Events. The signal state of the outgoing LAN event can be the same as or inverted from the source internal status event.

For details on each key, use key help as described on page 42.

Refer to the Programming Guide and the SCPI Command Reference.
For More Information

For more information on using LXI see the Agilent website dedicated to LXI instrumentation:


Agilent LXI Application Notes:

• Using LXI to go beyond GPIB, PXI and VXI (AN 1465–20)
• 10 Good Reasons to Switch to LXI (AN 1465–21)
• Transitioning from GPIB to LXI (AN 1465–22)
• How to Use VXI and PXI in Your New LXI Test System (AN 1465–23)
• Using Synthetic Instruments in Your Test System (AN 1465–24)
• Migrating system software from GPIB to LAN/LXI (AN 1465–25)
• Modifying a GPIB System to Include LAN/LXI (AN 1465–26)
Using a USB Keyboard

You can use a USB keyboard to remotely control the RF output state, the modulation state, and to select a memory sequence and register.

The register selection, RF output state, and modulation state are affected by power cycle or preset, but the USB keyboard control state and the sequence selection are not.

**CAUTION** To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to non-volatile memory, the MXG should always be powered down either via the MXG’s front panel power button or the appropriate SCPI command. MXG’s installed in rack systems and powered down with the system rack power switch rather than the MXG’s front panel switch display a Error –310 due to the MXG not being powered down correctly.

<table>
<thead>
<tr>
<th>USB Keyboard Key</th>
<th>Signal Generator Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete, Enter</td>
<td>RF On/Off</td>
</tr>
<tr>
<td>Insert</td>
<td>Mod On/Off</td>
</tr>
<tr>
<td>Home, Up Arrow</td>
<td>Next Sequence</td>
</tr>
<tr>
<td>End, Down Arrow</td>
<td>Previous Sequence</td>
</tr>
<tr>
<td>Page Up, Right Arrow, +</td>
<td>Recall Next State Register</td>
</tr>
<tr>
<td>Page Down, Left Arrow, –</td>
<td>Recall Previous State Register</td>
</tr>
</tbody>
</table>

Turning the USB keyboard control off disables the USB keyboard; it has no effect on the Auto Recall softkeys.

For details on each key, use key help as described on see page 42.
6 Using Pulse Modulation (Option UNU or UNW or 320)

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only available through the Web-Enabled MXG or SCPI commands. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator. If you are not comfortable with functions such as setting the power level and frequency, refer to Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that chapter.

- Pulse Characteristics on page 129
- The Basic Procedure on page 131
- Example on page 131
- Pulse Train (Option 320 – Requires: Option UNU or UNW) on page 132
Using Pulse Modulation (Option UNU or UNW or 320)

Figure 6-1  Pulse Softkeys

- **Pulse Source**
  - Square
  - Free-Run
  - Trigged
  - Adjustable
doublet
  - Trigger doublet

- **Pulse**
  - Determines how the signal generator responds to an external pulse signal.
  - Normal = high state.
  - Invert = low state.

- **Pulse Period**
  - Determines the type of signal transmitted out of the Trig Out BNC.
  - Normal = high state.
  - Invert = low state.

- **Pulse Width**
  - Latency from the external pulse input to the pulse sync output ≈ 50–60 ns.
  - Width
    - > 50 ns
    - ≤ 50 ns

For details on each key, use key help as described on page 42.
### Pulse Characteristics

**NOTE** When using very narrow pulses that are below the signal generator’s ALC pulse width specification, or leveled pulses with an unusually long duty cycle, it is often useful to turn ALC off (see page 110).

<table>
<thead>
<tr>
<th>Pulse Source</th>
<th>Type</th>
<th>Period(^a)</th>
<th>Width &amp; Delay(^b)</th>
<th>Uses Trigger Event(^b)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Square</td>
<td>Internal free run pulse train with 50% duty cycle.</td>
<td>Determined by user defined rate.</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Free Run (default)</td>
<td>Internal free run pulse train</td>
<td>User Defined</td>
<td>User Defined</td>
<td>—</td>
</tr>
<tr>
<td>Triggered</td>
<td>Internal pulse train</td>
<td>—</td>
<td>User Defined</td>
<td>3</td>
</tr>
<tr>
<td>Adjustable Doublet</td>
<td>Two internal pulse trains for each trigger event.</td>
<td>—</td>
<td>User Defined:</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>First pulse is relative to the rising edge of trigger signal.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Second pulse is relative to the rising edge of first pulse.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>See Figure 6-2 on page 130</td>
<td></td>
</tr>
<tr>
<td>Trigger Doublet</td>
<td>Two internal pulse trains for each trigger event.</td>
<td>—</td>
<td>The first pulse follows the trigger signal.</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Second pulse is user defined.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>See Figure 6-3 on page 130</td>
<td></td>
</tr>
<tr>
<td>Gated</td>
<td>Internal gated pulse train</td>
<td>—</td>
<td>User Defined</td>
<td>3</td>
</tr>
<tr>
<td>External Pulse Train</td>
<td>External pulse signal at the rear panel Pulse connector</td>
<td>—</td>
<td>—</td>
<td>3</td>
</tr>
</tbody>
</table>

\(^a\) All delays, widths, and periods have a resolution of 10 ns.

\(^b\) A signal at the rear panel pulse connector must be held high for at least 20 ns to trigger an internally generated pulse.

Rear panel inputs are described on page 15
Using Pulse Modulation (Option UNU or UNW or 320)

Pulse Characteristics

**Figure 6-2 Adjustable Doublet**

The delay of the first pulse is measured from the leading edge of the external trigger signal.

**Figure 6-3 Trigger Doublet**

The first pulse follows the external trigger signal.

The delay of the second pulse is measured from the leading edge of the external trigger signal.
The Basic Procedure

1. Preset the signal generator.
2. Set the carrier (RF) frequency.
3. Set the RF amplitude.
4. Configure the modulation:
   a. Set the pulse source: Press Pulse > Pulse Source > selection
   b. Set the parameters for the selected pulse source:

<table>
<thead>
<tr>
<th>Square</th>
<th>Free Run (default)</th>
<th>Triggered</th>
<th>Adjustable Doublet</th>
<th>Trigger Doublet</th>
<th>Gated</th>
<th>Pulse Train&lt;sup&gt;a&lt;/sup&gt;</th>
<th>External</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
</tbody>
</table>

<sup>a</sup> Requires Option 320.
<sup>b</sup> Up to 2047 pulse cycles (elements) composed of both Pulse On and Pulse Off can be user defined.

5. Turn on the modulation: **Pulse Off On** softkey to On.
   The the PULSE annunciator lights, indicating that you enabled modulation.

6. Output the modulated signal from the signal generator: Press the front panel **RF On Off** key.
The RF output LED lights, indicating that the signal is transmitting from the RF output connector.
See also, “Modulating the Carrier Signal” on page 60.

Example

The following example uses the factory preset pulse source and delay.

**Output:** A 2 GHz, 0 dBm carrier modulated by a 24 μs pulse that has a period of 100 μs.

1. Preset the signal generator.
2. Set the frequency to 2 GHz.
3. Set the amplitude to 0 dBm.
4. Set the pulse period to 100 microseconds: Press **Pulse > Pulse Period > 100 > usec**.

5. Set the pulse width to 24 microseconds: Press **Pulse > Pulse Width > 24 > usec**

6. Turn on both the pulse modulation and the RF output.
   
   The **PULSE** annunciator displays and the RF output LED lights.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output” on page 318.

**Pulse Train (Option 320 – Requires: Option UNU or UNW)**

The Option 320 Pulse Train feature enables the specification of up to 2047 independent pulse cycles, each of which has an “On Time”, during which the RF output is measurable at the RF output connector, and an "Off Time", during which the RF output is attenuated. Each pulse cycle is similar in function to other MXG Pulse modes—the new feature has up to 2047 cycles, instead of only a maximum of two (with Doublets). There are also repeat counts available for each pulse. These repetitions count against the total count of 2047 cycles.

The instrument can import pulse trains from a .csv (comma separated values) file or some other common ASCII format. It can also export to ASCII/CSV files as well. Export allows specification of the decimal separator and a column separator. The import allows specification of the decimal separator (to allow for ","), but the column separator is auto-detected. Refer to “Pulse Train Menu Softkeys” on page 133 and “Display Pulse Train Menu Softkeys” on page 134.
Using Pulse Modulation (Option UNU or UNW or 320)

Pulse Train (Option 320 – Requires: Option UNU or UNW)

Figure 6-4 Pulse Train Menu Softkeys

Pulse > Pulse Source > More >

Pulse Train

Display area indicates Pulse Train is the current pulse source.

This column indicates the row of a each pulse train cycle.

Note: When the cycle (elements) are repeated, the row numbers are skipped in the displayed count for the number of pulse cycles repeated.

Example: For the pulse train displayed above, in row 2, the 3 us On Time and 2 us Off Time pulse cycle is repeated twice. But, only row 2 is displayed for that pulse cycle (i.e row 3 is not displayed).

SCPI Commands:

[:SOURce]:PULM:INTERNAL:TRAIN:LIST:PRESet

[:SOURce]:PULM:INTERNAL:TRAIN:OFFTime <20ns - 42sec>

[:SOURce]:PULM:INTERNAL:TRAIN:OFFTime?

[:SOURce]:PULM:INTERNAL:TRAIN:OFFTime:POINts?

[:SOURce]:PULM:INTERNAL:TRAIN:ONTime <20ns - 42sec>

[:SOURce]:PULM:INTERNAL:TRAIN:ONTime?

[:SOURce]:PULM:INTERNAL:TRAIN:ONTime:POINts?

[:SOURce]:PULM:INTERNAL:TRAIN:REPetition <1-2047>

[:SOURce]:PULM:INTERNAL:TRAIN:REPetition?

[:SOURce]:PULM:INTERNAL:TRAIN:REPetition:POINts?

Refer to SCPI Command Reference.

SCPI Commands (continued):

[:MEMory:CATAlog]:PTrain?

[:MEMory:DELeTe]:PTrain <“filename”>

[:MEMory:EXPort][:ASCII]:PTrain <“filename”>

[:MEMory:EXPort][:ASCII]:SEParator:COLumn {TAB|SEMicolon|{COMMa}|SPACe}

[:MEMory:EXPort][:ASCII]:SEParator:COLumn?

[:MEMory:EXPort][:ASCII]:SEParator:DECimal {DOT}|COMMa

[:MEMory:EXPort][:ASCII]:SEParator:DECimal?

[:MEMory:IMPort][:ASCII]:PTain <“filename”>

[:MEMory:LOAD:PTain <“filename”>

[:MEMory:STORe]:PTain <“filename”>

Note: the Pulse Train is always triggered, so the Triggering softkey is not available in the Pulse menu.

These softkeys provide ease of use in changing the pulse cycle settings in the pulse train.

For details on each key, use key help as described on page 42.

For more information, refer to SCPI Command Reference.

Page 135
Using Pulse Modulation (Option UNU or UNW or 320)
Pulse Train (Option 320 – Requires: Option UNU or UNW)

Figure 6-5 Display Pulse Train Menu Softkeys
Pulse > Pulse Source > More > Pulse Train >
Edit Pulse Train > Display Pulse Train

This softkey shifts the time offset from the left hand side of the display to the one specified. Increments and decrements are 1/20th of the visible pulse train.

Use these softkeys to optimize the view of the different characteristics of the pulse train.

This value can be adjusted with the Time Offset softkey.

These are the division markers currently set at 10.00 us/div for the currently displayed view. Use the zoom softkeys to change the time/div value.

This is the initial pulse cycle (row 1) note that the On Time portion of this pulse is not showing due to the 2 us offset.

4th pulse cycle (element) or row 4.

2nd and 3rd pulse cycles (elements) or rows 2 and 3.

5th, 6th, and 7th pulse cycles (elements) or rows 5, 6, and 7.

Final pulse cycle (element) in the displayed pulse train above. 8th pulse cycle or row number 8.

For details on each key, use key help as described on page 42.
Using Pulse Modulation (Option UNU or UNW or 320)

Pulse Train (Option 320 – Requires: Option UNU or UNW)

These softkeys delete individual On Time or Off Time elements as well as the Repeat cycle counts.

Deleting all Pulse Cycle rows (elements) must be confirmed.

For details on each key, use key help as described on page 42.

These softkeys delete individual On Time or Off Time elements as well as the Repeat cycle counts.

Deleting all Pulse Cycle rows (elements) must be confirmed.

These softkeys delete individual On Time or Off Time elements as well as the Repeat cycle counts.

Deleting all Pulse Cycle rows (elements) must be confirmed.

After confirming import of the file the new file’s pulse train values are displayed.

This file’s data structure uses decimals in the numbers and so requires the Import Decimal Separator to be set to Dot.

Note: Column separated values are auto-detected by the MXG.

Selects whether the decimal point is a “.” or a “,” during import of CSV/ASCII files.

This value is persistent across preset/recall and power cycles.

SCPI Commands:

- `:MEMory:IMPort[:ASCii]:SEParator:DECimal DOT|COMMa`
- `:MEMory:IMPort[:ASCii]:SEParator:DECimal?`

After confirming import of the file the new file’s pulse train values are displayed.

Note: Column separated values are auto-detected by the MXG.
Using Pulse Modulation (Option UNU or UNW or 320)
Pulse Train (Option 320 – Requires: Option UNU or UNW)

Figure 6-7 Pulse Train: Export to File Softkeys

- Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > More

Note: Files can be FTP’d to the BIN (Binary) folder in the MXG or a USB stick can be used to download the files to the MXG. Refer to page 67.

For details on each key, use key help as described on page 42.
7 Basic Digital Operation—No BBG Option Installed

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available through the Web-Enabled MXG or SCPI commands. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator. If you are not comfortable with functions such as setting power level and frequency, refer to Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that chapter.

See also “Adding Real-Time Noise to a Dual ARB Waveform” on page 251.
I/Q Modulation

The following factors contribute to the error vector magnitude:

- Differences in amplitude, phase, and delay between the I and Q channels
- DC offsets

The I/Q menu provides adjustments to compensate for some of the differences in the I and Q signals or to add impairments.

See also “Modulating the Carrier Signal” on page 60.

The following table shows common uses for the adjustments.

<table>
<thead>
<tr>
<th>I/Q Adjustment</th>
<th>Effect</th>
<th>Impairment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offset</td>
<td>Carrier Feedthrough</td>
<td>dc offset</td>
</tr>
<tr>
<td>Quadrature Angle</td>
<td>EVM error</td>
<td>phase skew</td>
</tr>
<tr>
<td></td>
<td>I/Q Images</td>
<td>I/Q path delay</td>
</tr>
</tbody>
</table>

For details on each key, use key help as described on page 42.
Configuring the Front Panel Inputs

The Agilent MXG accepts externally supplied analog I and Q signals through the front panel I Input and Q Input for modulating onto the carrier.

1. Connect I and Q signals to the front panel connectors. For voltage levels, refer to “Front Panel Overview – N5181A/82A MXG” on page 5.
   a. Connect an analog I signal to the signal generator’s front panel I Input.
   b. Connect an analog Q signal to the signal generator’s front panel Q Input.
3. Configure the RF output:
   a. Set the carrier frequency.
   b. Set the carrier amplitude.
   c. Turn the RF output on.
4. Make adjustments to the I/Q signals (page 138) as needed.
Basic Digital Operation—No BBG Option Installed
I/Q Modulation
8 Basic Digital Operation (Option 651/652/654)

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available through the Web–Enabled MXG or SCPI commands. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator. If you are not comfortable with functions such as setting power level and frequency, refer to Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that chapter.

The features described in this chapter are available only in vector signal generators with Option 651, 652, or 654.

- Waveform File Basics on page 142
- Storing, Loading, and Playing a Waveform Segment on page 144
- Waveform Sequences on page 147
- Saving a Waveform’s Settings & Parameters on page 151
- Using Waveform Markers on page 157
- Triggering a Waveform on page 174
- Clipping a Waveform on page 181
- Scaling a Waveform on page 190
- Setting the Baseband Frequency Offset on page 196
- I/Q Modulation on page 200
- I/Q Adjustments on page 203
- I/Q Calibration on page 205
- Using the Equalization Filter on page 207
- Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter on page 209
- Modifying a FIR Filter Using the FIR Table Editor on page 215
- Setting the Real-Time Modulation Filter on page 219
- Multiple Baseband Generator Synchronization on page 220
- Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator Synchronization on page 227
- Waveform Licensing for Firmware Version ≥ A.01.50 on page 231
- Waveform 5-Pack Licensing (Options 221–229) for Firmware Version < A.01.50 on page 239
Waveform File Basics

There are two types of waveform files:

- A **segment** is a waveform file that you download to the signal generator. For information on creating and downloading waveform files, refer to the *Programming Guide*.
- A **sequence** is a file you create in the signal generator that contains pointers to one or more waveform files (segments, other sequences, or both). For information on creating sequences, see page 147.

Signal Generator Memory

The signal generator has two types of memory:

- **Volatile** memory, baseband generator (BBG) media, where waveform files are played from or edited.
- **Non-volatile** memory, either internal (int) or external (USB) media, where waveform files are stored.

Dual ARB Player

**NOTE** The MXG’s ARB Waveform File Cache is limited to 128 files. Consequently, once the 128 file cache limit has been reached, the waveform switching speed will be much slower for additional files loaded into the volatile waveform memory (BBG).

The dual ARB waveform player enables you to play, rename, delete, store, and load (external or internal) waveform files in addition to building waveform sequences. The dual ARB waveform player also provides markers (page 157), triggering (page 174), clipping (page 181), and scaling (page 190) capabilities.

Most procedures in this section start from the Dual ARB menu, shown below.
If you set the ARB sample clock when the dual ARB is off, the new setting is applied when the dual ARB player is turned on; this setting survives toggling the Dual ARB player off and on.

For details on each key, use key help as described on page 42.
Basic Digital Operation (Option 651/652/654)
Storing, Loading, and Playing a Waveform Segment

**Storing, Loading, and Playing a Waveform Segment**

**NOTE** The MXG’s ARB Waveform File Cache is limited to 128 files. Consequently, once the 128 file cache limit has been reached, the waveform switching speed will be much slower for additional files loaded into the volatile waveform memory (BBG).

Before using this information, you should be familiar with the signal generator’s file menus. If you are not, refer to “Working with Files” on page 62 and familiarize yourself with that information.

See also: “Waveform Sequences” on page 147.

The signal generator has two types of waveform media: non–volatile (internal or USB), and volatile (BBG). BBG media is also called “working” media, because before you can play, edit, or include a waveform file in a sequence, the waveform file must be loaded into BBG media.

**Figure 8-2 Waveform Segment Softkeys**

Loading a Waveform Segment into BBG Media

Waveforms must reside in BBG media before they can be played, edited, or included in a sequence. Cycling power or rebooting the signal generator deletes the files in BBG media.

**NOTE** Each time the instrument powers up, two factory–supplied segments are automatically created in BBG media: RAMP_TEST_WFM and SINE_TEST_WFM.

There are additional sample waveforms that are available in the internal storage and that can be loaded into memory. Refer to www.agilent.com and search on “Factory Default N5182A” and “waveforms”.

1. Press **Mode > Dual ARB > Select Waveform > Waveform Segments.**
2. Press **Load Store** to highlight Load, then, using the arrow keys, highlight the desired waveform segment.

3. If there is already a copy of this segment in the currently selected media and you do not want to overwrite it, rename the waveform segment before you load it (refer to the previous procedure).

4. Press **Load Segment From currently selected Media**.

   To load all files from the currently selected media into BBG media, press **Load All From currently selected Media**.

**Storing/Renaming a Waveform Segment to Internal or USB Media**

Use the following steps to store a copy of a file in BBG memory to the currently selected media (page 73). If you have not downloaded a waveform segment, either refer to the *Programming Guide*, or use one of the factory-supplied segments.

1. Press **Mode > Dual ARB > Select Waveform > Waveform Segments**.

2. Press **Load Store** to highlight Store.

3. Using the arrow keys, highlight the waveform segment you want to store.

4. Optionally, rename the segment.

   If there is already a copy of this segment in the currently selected media and you do not want to overwrite it, rename the waveform segment before you store it:

   a. Press **More > Rename Segment > Clear Text**.
   b. Enter a name for the waveform segment.
   c. Press **Enter > More**.
   d. Highlight the waveform segment that was renamed.

5. Press **Store Segment to currently selected Media**.

6. Repeat Step 3 through Step 5 for all segments that you want to store.

   To save all segments from BBG media to the currently selected media, press **Store All to currently selected Media**.

**Playing a Waveform Segment**

1. Press **Mode > Dual ARB > Select Waveform**.

2. In the Segment on BBG Media column, highlight the waveform segment you want to play.

3. Press **Select Waveform**.

4. Set **ARB Off On** to On.

   This plays the selected waveform segment. Both the I/Q and ARB annunciators turn on, and the waveform modulates the RF carrier.
5. Configure the RF Output:
   Set the RF carrier frequency and amplitude, and turn on the RF output.
   The waveform segment is now available at the signal generator’s RF Output connector.
Waveform Sequences

A waveform sequence is a file that contains pointers to one or more waveform segments or other waveform sequences, or both. This lets the signal generator play multiple waveform segments, or other sequences, or both thereby eliminating the need to stop waveform playback just to select another waveform.

The segments that a waveform sequence points to are not automatically stored when you store the sequence; you must also store the individual segments or they are lost when you turn off or reboot the signal generator. If the segments are located in internal/external media, you must load them into BBG media prior to selecting a waveform sequence (see page 144). If you attempt to play a sequence without the segments loaded into BBG media, the signal generator reports: ERROR: 629, File format invalid. If this happens and the segments are not stored in internal/external media, you must recreate the segments using the same file names that the sequence points to before you can play the sequence.
Creating a Sequence

A waveform sequence can contain up to 1,024 segments and have both segments and other sequences (nested sequences). The signal generator lets you set the number of times the segments and nested sequences repeat during play back. But there is a difference between repeating a segment versus repeating a nested sequence. Each segment can repeat up to 65,535 times, but no matter how many times a segment repeats, it counts as a single segment. However each repetition of a nested sequence counts as additional segments.

The maximum number of times that a nested sequence can repeat is based on the number of segments in the nested sequence and the remaining number of allowed segments (1,024). For example, with a sequence that contains 24 segments and one nested sequence with 4 segments, the nested sequence is limited to 250 repetitions:

\[ 24 + (4 \times 250) = 1,024 \text{ maximum number of segments per sequence} \]

Even though there is a limiting factor on the maximum number of times that a nested sequence can repeat, each segment within the nested sequence can repeat up to 65,535 times.

Example

Use the following procedure to create and store a waveform sequence using one repetition each of two different segments.

**Assumption:** The waveform segments are in BBG media (volatile memory). For information on loading waveform segments into BBG media, see page 144.

1. Select the first segment:
   a. Press **Mode > Dual ARB > More > Waveform Sequences > Build New Waveform Sequence > Insert Waveform.**
   b. Highlight the desired waveform segment and press **Insert.**
2. Select the second segment:
   a. Highlight the next desired waveform segment and press **Insert.**
   b. Press **Done Inserting**
3. Name and store the waveform sequence to the Seq file catalog:
   a. Press More > Name and Store.
   b. Enter a file name and press Enter.

See also, “Viewing the Contents of a Sequence” on page 149 and “Setting Marker Points in a Waveform Segment” on page 164.

**Viewing the Contents of a Sequence**

There are two ways to view the contents of a waveform sequence:

**Through the Waveform Sequences Softkey**

2. Highlight the desired sequence.
3. Press Show Waveform Sequence Contents.

**Using the Select Waveform Softkey**

1. Press Mode > Dual ARB > Select Waveform.
2. In the Sequence On column, highlight the desired waveform sequence.
3. Press Show Waveform Sequence Contents.

**Editing a Sequence**

When editing a waveform sequence, you can:

- change the number of times each segment or nested sequence plays
- delete segments or nested sequences from the sequence
- add segments or nested sequences to the sequence
- toggle markers on and off (described on page 170)
- save changes either to the current waveform sequence or as a new sequence

If you exit the sequence editing menu before saving changes, the changes are lost.

Sequences save to the Seq file catalog.

**CAUTION**

If you edit and resave a segment used in a sequence, the sequence does not automatically update the RMS value in its header. You must select and update the sequence header information (page 151).

Use the following steps to edit a sequence that has two different segments so that the first segment repeats 100 times and the second segment repeats 200 times, then save the changes.

**Assumption:** A waveform sequence that has two different segments has been created and stored (see previous example on page 148).

1. Select the sequence:
   - Press Mode > Dual ARB > More > Waveform Sequences > highlight the desired sequence > Edit Selected Waveform Sequence.
2. Change the first segment so that it repeats 100 times:
   Highlight the first segment entry and press Edit Repetitions > 100 > Enter.
   The cursor moves to the next entry.

3. Change the repetition for the selected entry to 200:
   Press Edit Repetitions > 200 > Enter.

4. Save the changes made in the previous steps:
   Press More > Name and Store > Enter.
   To save the changes as a new sequence:
   a. Press More > Name and Store > Clear Text.
   b. Enter a file name (for example, SINE100+RMP200).
   c. Press Enter.
   The edited sequence saves as a new waveform sequence.

**Playing a Sequence**

If you have not created a waveform sequence, refer to “Creating a Sequence” on page 148.

**NOTE**
   To play a waveform segment individually or as part of a waveform sequence, the segment must reside in BBG media. See also, “Loading a Waveform Segment into BBG Media” on page 144.

1. Select a waveform sequence:
   a. Press Mode > Dual ARB > Select Waveform.
   b. Highlight a waveform sequence (for this example, SINE100+RMP200) from the Sequence On column.
   c. Press Select Waveform.
   The display shows the currently selected waveform (for example, Selected Waveform: SEQ:SINE100+RMP200).

   ![Waveform Display]

   **Annunciators display with active waveform (ARB On)**
   **Current waveform selection**

2. Generate the waveform:
   Press ARB Off On to On.
   This plays the selected waveform sequence. During the waveform sequence generation, both the I/Q and ARB annunciators turn on, and the waveform modulates the RF carrier.
3. Configure the RF output:
   a. Set the RF carrier frequency.
   b. Set the RF output amplitude.
   c. Turn on the RF output.

   The waveform sequence is now available at the signal generator’s RF OUTPUT connector.

**Saving a Waveform’s Settings & Parameters**

This section describes how to edit and save a file header. When you download only a waveform file (I/Q data, which the signal generator treats as a waveform segment), the signal generator automatically generates a file header and a marker file with the same name as the waveform file. Initially, the file header has no signal generator settings saved to it, and the marker file consists of all zeros. For a given waveform, you can save signal generator settings and parameters in its file header and marker settings in its marker file (page 157); when you load a stored waveform file into BBG media, the file header and marker file settings automatically apply to the signal generator so that the dual ARB player sets up the same way each time the waveform file plays.

*Figure 8-4  Header Utilities Softkeys*

When you create a waveform sequence (as described on page 148), the signal generator automatically creates a waveform sequence header that takes priority over the individual waveform segment headers. During a waveform sequence playback, the segment headers are ignored, except to verify that all required options are installed. Storing a waveform sequence also stores its file header.

Some of the current signal generator settings shown in the file header appear as part of the softkey labels, and others appear in the dual ARB summary display, shown in the following example.
Table 8-1 File Header Entries

<table>
<thead>
<tr>
<th>Description</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>32–Character Description</td>
<td>A description entered for the header, such as a the waveform’s function (saved/edited with the Edit Description softkey, see Figure 8-4).</td>
</tr>
<tr>
<td>Sample Rate</td>
<td>The waveform playback rate. This is the ARB sample clock rate, set in the Arb Setup menu (shown in Figure 8-1 on page 143).</td>
</tr>
<tr>
<td>Runtime Scaling</td>
<td>The Runtime scaling value is applied in real-time while the waveform is playing. This setting can be changed only for files playing in the dual ARB player (see page 193).</td>
</tr>
<tr>
<td>RMS</td>
<td>When the modulator attenuation setting (see page 143) is set to Auto, this value is used to calculate the I/Q modulator attenuation setting to optimize ACPR. Value: 0 to 1.414213562</td>
</tr>
<tr>
<td>Marker 1...4 Polarity</td>
<td>Marker polarity can be positive or negative (described on page 170).</td>
</tr>
<tr>
<td>ALC Hold Routing</td>
<td>Which marker, if any, implements the ALC hold function (described on page 159), which holds the ALC at its current level when the marker signal is low. All waveforms generated in the signal generator have a marker on the first sample point. To see the results from the three routing selections, you may need to select a range of sample (marker) points (see “Setting Marker Points in a Waveform Segment” on page 164).</td>
</tr>
<tr>
<td>RF Blank Routing</td>
<td>Which marker, if any, implements the RF blanking function (described on page 168) when the marker signal is low. RF blanking also uses ALC hold. There is no need to select the ALC Hold Routing for the same marker when you are using the RF Blank Routing function. When the marker signal goes high, RF blanking discontinues.</td>
</tr>
<tr>
<td>Mod Attenuation</td>
<td>The I/Q modulator attenuation setting (set in the Arb Setup menu shown in Figure 8-1 on page 143).</td>
</tr>
<tr>
<td>BB Freq Offset</td>
<td>The baseband frequency offset, in Hz (see page 196).</td>
</tr>
<tr>
<td>AWGN: State</td>
<td>Indicated whether real-time noise is on (1) or off (0) (see page 251).</td>
</tr>
</tbody>
</table>
**Table 8-1**  File Header Entries  (Continued)

<table>
<thead>
<tr>
<th>Entry</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AWGN: C/N Ratio</strong></td>
<td>Carrier to noise ration, in dB (see page 256).</td>
</tr>
<tr>
<td><strong>AWGN: Carrier BW</strong></td>
<td>Bandwidth over which the noise power is integrated, in Hz (see page 256).</td>
</tr>
<tr>
<td><strong>AWGN: Noise BW</strong></td>
<td>Bandwidth of the noise, in Hz (see page 256).</td>
</tr>
<tr>
<td><strong>AWGN: Carrier RMS</strong></td>
<td>The carrier RMS across the carrier bandwidth (see page 256).</td>
</tr>
<tr>
<td><strong>Phase Noise State</strong></td>
<td>Indicated whether phase noise is on (1) or off (0) (see page 260).</td>
</tr>
<tr>
<td><strong>Phase Noise F1</strong></td>
<td>The start frequency for the level mid–frequency characteristics (see page 260).</td>
</tr>
<tr>
<td><strong>Phase Noise F2</strong></td>
<td>The end frequency for the level mid–frequency characteristics (see page 260).</td>
</tr>
<tr>
<td><strong>Phase Noise Lmid</strong></td>
<td>The amplitude for the level mid–frequency characteristics (see page 260).</td>
</tr>
<tr>
<td><strong>Modulation Filter</strong></td>
<td>The real-time modulation filter type selected (see page 219).</td>
</tr>
<tr>
<td><strong>Over–Range Protect</strong></td>
<td>Indicated whether DAC Over–Range Protection is on (1) or off (0) (see page 264).</td>
</tr>
<tr>
<td><strong>Unique Waveform Id</strong></td>
<td>0 = no Id; once an Id is assigned, it cannot be changed.</td>
</tr>
<tr>
<td><strong>License Required</strong></td>
<td>Indicates whether a license is required to play the waveform. See also: “Viewing Options and Licenses” on page 38</td>
</tr>
<tr>
<td><strong>Can be Read Out</strong></td>
<td>Indicates whether the waveform can be queried through SCPI or FTP.</td>
</tr>
</tbody>
</table>

**Viewing and Modifying Header Information**

The following example uses the factory–supplied waveform file RAMP_TEST_WFM.

1. From BBG media, select the waveform RAMP_TEST_WFM:
   a. Press **Mode > Dual ARB > Select Waveform**.
   b. In the **Segment On** column, highlight the waveform RAMP_TEST_WFM.
   c. Press **Select Waveform**.
2. Open the Header Utilities menu:
   Press **More > Header Utilities**
   The Figure 8-5 shows the default file header for the factory–supplied waveform RAMP_TEST_WFM. The **Header Field** column lists the file header parameters; use the **Page Down** key to see them all.
   The Saved Header Settings column shows that most of the settings are **Unspecified**.
   Unspecified means that there is no setting saved for that particular parameter.
   The **Current Inst. Settings** column shows the current signal generator settings. In this example, these are the settings that you will save to the file header.

**NOTE**  If a setting is unspecified in the file header, the signal generator uses its current value for that setting when you select and play the waveform.
3. Save the information in the **Current Inst. Settings** column to the file header:

   Press **Save Setup To Header**.

   Both the Saved Header Settings column and the Current Inst. Settings column now display the same values; the Saved Header Settings column lists the settings saved in the file header.

4. **Edit and Update Settings**

   a. Return to the ARB Setup menu:
      
      Press **Return > More > ARB Setup**.

      From this menu you can access some of the signal generator settings that are saved to the file header. Figure 8-1 on page 143 shows the ARB Setup softkeys used in the following steps.

   b. Set the ARB sample clock to 5 MHz:
      
      Press **ARB Sample Clock > 5 > MHz**.

   c. Set waveform runtime scaling to 60%:
      
      Press **Waveform Runtime Scaling > 60 > %**.

   d. Return to the Header Utilities menu:
      
      Press **Return > More > Header Utilities**.

As shown in the following figure, the **Current Inst. Settings** column now reflects the changes to the current signal generator setup, but the saved header values have not changed.
Basic Digital Operation (Option 651/652/654)

Saving a Waveform’s Settings & Parameters

e. Save the current settings to the file header:
Press the **Save Setup To Header** softkey.

The settings from the **Current Inst. Settings** column now appear in the **Saved Header Settings** column. This saves the new current instrument settings to the file header.

If you change any of the signal generator settings listed in the file header after you select the waveform file, the changed setting(s) appear in the file header’s **Current Inst. Settings** column and are used instead of the saved header settings. To reapply the saved header settings, reselect the waveform for playback.

**Viewing & Editing a Header without Selecting the Waveform**

As described on page 153, you can view and edit a waveform’s header information after you select the waveform; you can also edit waveform header information without selecting a waveform, or for another waveform than the one that is currently selected.

1. Access the file header utilities menu:
   Press **Mode > Dual ARB > More > Header Utilities > More > Select Different Header**.

The signal generator displays an alphabetical list of the waveform files in the media that was last selected. The following figure shows an example of the factory-supplied waveforms in BBG media.
2. If the desired catalog is not displayed, select it.

3. Highlight the desired waveform file and press **Select Header**.
   The signal generator displays the file header for the selected waveform file.

4. To edit the header, press **More**, and proceed as described in Step 4 on page 154 (Viewing and Modifying Header Information section).
Using Waveform Markers

The signal generator provides four waveform markers to mark specific points on a waveform segment. When the signal generator encounters an enabled marker, an auxiliary signal is routed to a rear panel event output that corresponds to the marker number.

- Event 1 is available at both the EVENT 1 BNC connector (see page 19), and a pin on the AUXILIARY I/O connector (see page 20).
- Event 2 is available at both the TRIG OUT BNC connector (see page 16), and a pin on the AUXILIARY I/O connector (see page 20).
- Events 3 and 4 are available at pins on the AUXILIARY I/O connector (see page 20).

You can use an auxiliary output signal to synchronize another instrument with the waveform, or as a trigger signal to start a measurement at a given point on a waveform.

You can also configure markers to initiate ALC hold or RF Blanking (which includes ALC hold). Refer to “Using Waveform Markers” on page 157 for details.

When you download a waveform file that does not have a marker file associated with it, the signal generator creates a marker file without any marker points. Factory-supplied segments (RAMP_TEST_WFM and SINE_TEST_WFM) have a marker point on the first sample for all four markers.

The following procedures demonstrate how to use markers while working in the dual ARB player. These procedures also discuss two types of points: a marker point and a sample point. A marker point is a point at which a given marker is set on a waveform; you can set one or more marker points for each marker. A sample point is one of the many points that compose a waveform.

There are three basic steps to using waveform markers:
- Clearing Marker Points from a Waveform Segment on page 163
- Setting Marker Points in a Waveform Segment on page 164
- Controlling Markers in a Waveform Sequence on page 170

This section also provides the following information:
- Waveform Marker Concepts on page 158
- Accessing Marker Utilities on page 162
- Viewing Waveform Segment Markers on page 163
- Viewing a Marker Pulse on page 167
- Using the RF Blanking Marker Function on page 168
- Setting Marker Polarity on page 170
Waveform Marker Concepts

The signal generator's Dual ARB provides four waveform markers for use on a waveform segment. You can set each marker's polarity and marker points (on a single sample point or over a range of sample points). Each marker can also perform ALC hold, or RF Blanking and ALC hold.

NOTE When you use a waveform that does not have marker routings and polarity settings stored in the file header, and the previously played waveform used RF Blanking, ensure that you set RF Blanking to None. Failure to do so can result in no RF output or a distorted waveform.

Marker Signal Response

The signal generator aligns the marker signals with the I and Q signals at the baseband generator. However some settings such as amplitude, filters, and so forth within the RF output path can create delays between the marker EVENT output signal and the modulated RF output. When using the marker EVENT output signal, observe the signals (marker relative to modulated RF) for any latency, and if needed, reset the marker point positions, include delay (page 203), or both.

Marker File Generation

Downloading a waveform file (as described in the Programming Guide) that does not have a marker file associated with it causes the signal generator to automatically create a marker file, but does not place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must reside in BBG media (see “Loading a Waveform Segment into BBG Media” on page 144).

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator, or cycle power. To ensure that a waveform uses the correct settings when it is played, set the marker polarities or routing (RF Blanking and ALC Hold) and save the information to the file header (page 151).
**ALC Hold Marker Function**

While you can set a marker function (described as **Marker Routing** on the softkey label) either before or after you set marker points (page 164), setting a marker function before setting marker points may cause power spikes or loss of power at the RF output.

Use the ALC hold function by itself when you have a waveform signal that incorporates idle periods, burst ramps, or when the increased dynamic range encountered with RF blanking (page 168) is not desired.

The ALC hold marker function holds the ALC circuitry at the *average* value of the sampled points set by the marker(s). For both positive and negative marker polarity, the ALC samples the RF output signal (the carrier plus any modulating signal) when the marker signal goes high:

- **Positive**: The signal is sampled during the on marker points.
- **Negative**: The signal is sampled during the off marker points.

**NOTE** Because it can affect the waveform’s output amplitude, do not use the ALC hold for longer than 100 ms. For longer time intervals, refer to “Power Search Mode” on page 111.

**CAUTION** Incorrect ALC sampling can create a sudden unlevelled condition that may create a spike in the RF output, potentially damaging a DUT or connected instrument. To prevent this condition, ensure that you set markers to let the ALC sample over an amplitude that accounts for the higher power levels encountered within the signal.
Example of Correct Use

Waveform: 1022 points
Marker range: 95–97
Marker polarity: Positive

This example shows a marker set to sample the waveform’s area of highest amplitude. Note that the marker is set well before the waveform’s area of lowest amplitude. This takes into account any response difference between the marker and the waveform signal.

The ALC samples the waveform when the marker signal goes high, and uses the average of the sampled waveform to set the ALC circuitry.

Here the ALC samples during the on marker points (positive polarity).

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110–1022
Marker polarity: Positive

This example shows a marker set to sample the low part of the same waveform, which sets the ALC modulator circuitry for that level; this usually results in an unleveled condition for the signal generator when it encounters the high amplitude of the pulse.
Example of Incorrect Use

Waveform: 1022 points
Marker range: 110–1022
Marker polarity: Negative

This figure shows that a negative polarity marker goes low during the marker on points; the marker signal goes high during the off points. The ALC samples the waveform during the off marker points.

Sampling both on and off time sets the modulator circuitry incorrectly for higher signal levels. Note the increased amplitude at the beginning of the pulse.
Accessing Marker Utilities

Mode > Dual ARB > More > Marker Utilities

Note: This is the second Arb menu.

The display below shows the I and Q components of the waveform, and the marker points set in a factory-supplied segment.

The settings in these menus can be stored to the file header, see page 151.

For details on each key, use key help as described on page 42.

These softkeys change the range of waveform sample points shown on the marker display.

Each press of the softkey changes the sample range by approximately a factor of two.
Viewing Waveform Segment Markers

Markers are applied to waveform segments. Use the following steps to view the markers set for a segment (this example uses the factory–supplied segment, SINE_TEST_WFM).

1. In the second Arb menu (page 162), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment (in this example, SINE_TEST_WFM).
3. Press Display Waveform and Markers > Zoom in Max.
   The maximum zoom in range is 28 points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a sample point range greater than 460 points may not show the marker locations.

Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but are set in addition to existing points. Because markers are cumulative, before you set points, view the segment (page 163) and remove any unwanted points. With all markers cleared, the level of the event output signal is 0V. To clear marker points on a segment, the segment must reside in BBG media (page 144).

Clearing All Marker Points

1. In the second Arb menu (page 162), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment (in this example, SINE_TEST_WFM).
3. Highlight the desired marker number: Press Marker 1 2 3 4.
4. For the selected marker number, remove all marker points in the selected segment:
   a. Press Set Marker Off Range of Points.
      Notice that the softkeys for the first and last marker points correspond with the length of the waveform. The factory–supplied waveform (SINE_TEST_WFM) contains 200 samples. To clear all set marker points, the range must equal to the length of the waveform.
   b. Press Apply To Waveform > Return.
5. Repeat from Step 3 for any remaining marker points that you want to remove from the other markers.

Clearing a Range of Marker Points

The following example uses a waveform with marker points (Marker 1) set across points 10–20. This makes it easy to see the affected marker points. The same process applies whether the existing points are set over a range or as a single point (page 164).

1. In the second Arb menu (page 162), press Marker Utilities > Set Markers, then select Marker 1.
2. Set the first sample point that you want off (for this example, 13):
   Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.
3. Set the last marker point in the range that you want off to a value less than or equal to the number of points in the waveform, and greater than or equal to the value set in Step 2 (for this example, 17):
Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

This turns off all marker points for the active marker within the range set in Steps 2 and 3, as shown at right.

How to view markers is described on page 163.

Clearing a Single Marker Point

Use the steps described in “Clearing a Range of Marker Points” on page 163, but set both the first and last marker point to the value of the point you want to clear. For example, if you want to clear a marker on point 5, set both the first and last value to 5.

Setting Marker Points in a Waveform Segment

To set marker points on a segment, the segment must reside in BBG media (page 144).

When you set marker points, they do not replace points that already exist, but are set in addition to existing points. Because markers are cumulative, before you set marker points within a segment, view the segment (page 163) and remove any unwanted points (page 163).

Placing a Marker Across a Range of Points

1. In the second Arb menu (page 162), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment.
3. Select the desired marker number: Press Marker 1 2 3 4
4. Set the first sample point in the range (in this example, 10):
   Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.
5. Set the last marker point in the range to a value less than or equal to the number of points in the waveform, and greater than or equal to the first marker point (in this example, 20):
   Press Last Mkr Point > 20 > Enter.
6. Press Apply To Waveform > Return.

This sets a range of waveform marker points. The marker signal starts on sample point 10, and ends on sample point 20, as shown in the following figure.
Basic Digital Operation (Option 651/652/654)
Using Waveform Markers

Placing a Marker on a Single Point

On the First Point
1. In the second Arb menu (page 162), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment.
3. Select the desired marker number:
   Press Marker 1 2 3 4.
4. Press Set Marker On First Point.
   This sets a marker on the first point in the segment for the marker number selected in Step 3.

On Any Point
Use the steps described in “Placing a Marker Across a Range of Points” on page 164, but set both the first and last marker point to the value of the point you want to set. For example, if you want to set a marker on point 5, set both the first and last value to 5.

Placing Repetitively Spaced Markers
The following example sets markers across a range of points and specifies the spacing (skipped points) between each marker. You must set the spacing before you apply the marker settings; you cannot apply skipped points to a previously set range of points.

NOTE The skipped points value is limited to the size of the range of points.
1. Remove any existing marker points (page 158).
2. In the second Arb menu (page 162), press Marker Utilities > Set Markers.
3. Highlight the desired waveform segment.
4. Select the desired marker number:
   Press Marker 1 2 3 4.
5. Set the first sample point in the range (in this example, 5):
   Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.
6. Set the last marker point in the range. (The last marker point value must always be less than or equal to the number of points in the waveform, and greater than or equal to the first marker point, in this example, 25):
   Press Last Mkr Point > 25 > Enter.
7. Enter the number of sample points that you want skipped (in this example, 1):
   Press # Skipped Points > 1 > Enter.
8. Press Apply To Waveform > Return.
This causes the marker to occur on every other point (one sample point is skipped) within the marker point range, as shown at right.

How to view markers is described on page 163.

One application of the skipped point feature is the creation of a clock signal as the EVENT output.
Viewing a Marker Pulse

When a waveform plays (page 150), you can detect a set and enabled marker’s pulse at the rear panel event connector/Aux I/O pin that corresponds to that marker number. This example demonstrates how to view a marker pulse generated by a waveform segment that has at least one marker point set (page 164). The process is the same for a waveform sequence.

This example uses the factory–supplied segment, SINE_TEST_WFM in the dual ARB Player. Factory–supplied segments have a marker point on the first sample point for all four markers, as shown.

1. In the first Arb menu (page 143), press Select Waveform.
2. Highlight the SINE_TEST_WFM segment and press Select Waveform.
4. Connect the Agilent MXG’s rear panel Q OUT output to the oscilloscope’s channel 1 input.
5. Connect the signal generator’s rear panel EVENT 1 output to the oscilloscope's channel 2 input.

When marker 1 is present, the Agilent MXG outputs a signal through EVENT 1 as shown in the following example.
Using the RF Blanking Marker Function

While you can set a marker function (described as Marker Routing on the softkey label in the Marker Utilities menu) either before or after setting the marker points (page 164), setting a marker function before you set marker points may change the RF output. RF Blanking includes ALC hold (described on page 159, note Caution regarding unleveled power). The signal generator blanks the RF output when the marker signal goes low. This example is a continuation of the previous example, Viewing a Marker Pulse.

1. Using the factory-supplied segment SINE_TEST_WFM, set Marker 1 across points 1–180 (page 164).
2. From the Marker Routing softkey menu, assign RF Blanking to Marker 1:

   In the second Arb menu (page 162), press Marker Utilities > Marker Routing > Pulse/RF Blank > Marker 1.
Using Waveform Markers

Marker Polarity = Positive
When marker polarity is positive (the default setting), the RF output is blanked during the off marker points.

Marker Polarity = Negative
When marker polarity is negative, the RF output is blanked during the on marker points.
Basic Digital Operation (Option 651/652/654)
Using Waveform Markers

Setting Marker Polarity

Setting a negative marker polarity inverts the marker signal.

1. In second Arb menu (page 162), press Marker Utilities > Marker Polarity.
2. For each marker, set the marker polarity as desired.
   • The default marker polarity is positive.
   • Each marker polarity is set independently.

See also, “Saving Marker Polarity and Routing Settings” on page 158.

As shown on page 168:

Positive Polarity: On marker points are high (~3.3V).
Negative Polarity: On marker points are low (0V).

RF blanking always occurs on the low part of the signal regardless of the polarity setting.

Controlling Markers in a Waveform Sequence

In a waveform segment, an enabled marker point generates an auxiliary output signal that is routed to the rear panel EVENT output (described in “Rear Panel Overview – N5161A/62A/81A/82A MXG” on page 15) corresponding to that marker number. For a waveform sequence, you enable or disable markers on a segment–by–segment basis; this enables you to output markers for some segments in a sequence, but not for others. Unless you change the sequence marker settings or cycle the power, the marker setting for the last segment edited in the sequence applies to all segments in the next sequence that you build. For information on building a waveform sequence, see “Creating a Sequence” on page 148.
Figure 8-6  Waveform Sequence Menus for Enabling/Disabling Segment Markers

Mode > Dual ARB > More

Note: This is the second Arb menu.

For details on each key, use key help as described on page 42.
Enabling and Disabling Markers in a Waveform Sequence

Select the waveform segments within a waveform sequence to enable or disable each segment’s markers independently. You can enable or disable the markers either at the time of creating the sequence or after the sequence has been created and stored. If the sequence has already been stored, you must store the sequence again after making any changes. Enabling a marker that has no marker points has no effect on the auxiliary outputs. To set marker points on a segment, see “Setting Marker Points in a Waveform Segment” on page 164. This example assumes that a waveform sequence exists.

1. Ensure that all waveform segments for the sequence reside in BBG media (see page 144).
2. From the second Arb menu, press Waveform Sequences.
3. Highlight the desired waveform sequence.
5. Toggle the markers:
   a. Highlight the first waveform segment.
   b. As desired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.
      An entry in the Mkr column (see figure below) indicates that the marker is enabled for that segment; no entry in the column means that all markers are disabled for that segment.
   c. In turn, highlight each of the remaining segments and repeat Step b.
6. Press Return > More > Name and Store.
7. Either rename the sequence using the text entry keys (see page 145) or just press Enter to save the sequence with the existing name.

The markers are enabled or disabled per the selections, and the changes saved to the sequence file.

The following figure shows a sequence built using one of the factory-supplied waveform segments; a factory-supplied segment has a marker point on the first sample for all four markers. In this example, marker 1 is enabled for the first segment, marker 2 is enable for the second segment, and markers 3 and 4 are enabled for the third segment.

For each segment, only the markers enabled for that segment produce a rear panel auxiliary output signal. In this example, the marker 1 auxiliary signal appears only for the first segment, because it is disabled for the remaining segments. The marker 2 auxiliary signal appears only for the second segment, and the marker 3 and 4 auxiliary signals appear only for the third segment.
Using the EVENT Output Signal as an Instrument Trigger

One of the uses for the EVENT output signal (marker signal) is to trigger a measurement instrument. You can set up the markers to start the measurement at the beginning of the waveform, at any single point in the waveform, or on multiple points in the waveform. To optimize the use of the EVENT signal for measurements, you may also need to adjust the sample rate. The location of the sample rate setting is shown in the figure at right.

The EVENT output signal can exhibit jitter of up to ±4 ns on the rising and falling edge. This jitter can be minimized in either of two ways.

Method 1: Use a sample clock of 125 MHz/N where N is a positive integer and where 125 MHz/N can be represented exactly on the display.

For example: 125 MHz, 62.5 MHz, 31.25 MHz, 25 MHz, and so on.

If the result cannot be represented exactly on the display, jitter will be present.

For example: N = 6 will result in jitter, because 125 MHz/6 = 20.833 MHz, which is truncated when displayed.

Method 2: Select a sample clock and waveform length that spaces the markers by a multiple of 8 ns.

For example: A 200 point waveform with a marker on the first point and a sample clock of 50 MHz provides a marker every 4 µs. Because 4 µs is a multiple of 8 ns, the jitter is minimized.

When the EVENT output signal exhibits jitter and it is used as a measurement trigger, it can cause the waveform to falsely appear as having jitter. If this condition occurs, you can adjust the sample rate to a value (see above) that does not cause the jitter appearance. To maintain the integrity of the original waveform with a sample rate change, you will have to also recalculate the sample values. The following figures illustrate the marker signal jitter and its affect on the waveform.

EVENT output signal exhibits jitter due to a non–optimal sample rate

Waveform appears to exhibit jitter when triggered using EVENT signal with jitter.

The jitter is gone with an optimal sample rate

Oscilloscope triggering on waveform

Oscilloscope triggering on EVENT signal

Oscilloscope triggering on EVENT signal

For details on each key, use key help as described on page 42.
Triggers control data transmission by controlling when the signal generator transmits the modulating signal. You can configure trigger settings so that data transmission occurs once (Single mode), continuously (Continuous mode), or starts and stops repeatedly (Gated and Segment Advance modes).

A trigger signal contains both positive and negative states; you can use either for triggering.

When you initially select a trigger mode or when you change from one triggering mode to another, you may lose the carrier signal at the RF output until the modulating signal is triggered. This is because the signal generator sets the I and Q signals to zero volts prior to the first trigger event. To maintain the carrier signal at the RF output, create a data pattern with the initial I and Q voltages set to values other than zero.

When you initially turn the Arb ON or select a trigger mode or when you change from one triggering mode to another, you may temporarily lose the carrier signal for a few tens of milliseconds at the RF output. The Arb will present the idle IQrms value of the next Arb waveform to the IQ modulator. This ensures that the RF carrier output is at the correct amplitude level while the Arb waits for a trigger. When that trigger is received, the Arb begins playing the waveform and the modulated RF carrier exhibits no undesirable transients.

There are two parts to configuring a waveform trigger:

- **Type** determines the behavior of the waveform when it plays (see Trigger Type on page 175).
- **Source** determines how the signal generator receives the trigger that starts the modulating waveform playing (see Trigger Source on page 176).
**Trigger Type**

Type defines the trigger mode: how the waveform plays when triggered.

<table>
<thead>
<tr>
<th>Mode &gt; Dual ARB &gt; Trigger Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Continuous Mode</strong></td>
</tr>
<tr>
<td>Free Run</td>
</tr>
<tr>
<td>Trigger &amp; Run</td>
</tr>
<tr>
<td>Reset &amp; Run</td>
</tr>
<tr>
<td><strong>Single Mode</strong></td>
</tr>
<tr>
<td>No Retrigger</td>
</tr>
<tr>
<td>Buffered Trip</td>
</tr>
<tr>
<td>Restart on Trip</td>
</tr>
</tbody>
</table>

**Continuous mode** repeats the waveform until you turn the signal off or select a different waveform, trigger mode, or response (Free Run, Trigger & Run, Reset & Run).

**Single mode** plays the waveform once.

**NOTE** In Single No Retrigger, do not use Continuous Reset & Run mode due to the variable latency of this setup.

- **No Retrigger**: If a trigger is received early it will be ignored. The gap in your playback is dependant on the trigger period, after which time the RF will start up again where it is expected.

- **Buffered Trigger**: An early trigger will cause the waveform to play to the end and then start again. The RF will not be aligned with this early trigger.

- **Restart on Trigger**: The ARB will reset itself and trigger again but there will some gap in the playback while this is occurring. It will reset itself for every trigger it receives.

- **Segment Advance** mode plays a segment in a sequence only if triggered. The trigger source controls segment-to-segment playing (see Example: Segment Advance Triggering on page 177). A trigger received during the last segment loops play to the first segment in the sequence.
• **Gated** mode triggers the waveform at the first active triggering state, then repeatedly starts and stops playing the waveform in response to an externally applied gating signal. See Example: Gated Triggering on page 178.

**Trigger Source**

- **Mode**
- **Dual ARB**
- **Trigger Source**

![Trigger Source Diagram]

Neg = the signal generator responds during the trigger signal low state.

Pos = the signal generator responds during the trigger signal high state.

Key inactive until Ext Delay is enabled On.

For details on each key, use key help as described on page 42.

**External Trigger Polarity**

- In Continuous, Single, and Segment Advance modes, use the **Ext Polarity** softkey to set the external trigger polarity.

- In Gated mode, the **Active Low** and **Active High** softkeys (page 175) determine the external trigger polarity.
Example: Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within a waveform sequence. This type of triggering ignores the repetition value (page 149). For example if a segment has repetition value of 50 and you select Single as the segment advance triggering mode, the segment still plays only once. The following example uses a waveform sequence that has two segments.

If you have not created and stored a waveform sequence, refer to “Creating a Sequence” on page 148.

1. Preset the signal generator.
2. Configure the RF output:
   - Set the desired frequency.
   - Set the desired amplitude.
   - Turn on the RF output.
3. Select a waveform sequence for playback:
   a. Press Mode > Dual ARB > Select Waveform.
   b. In the Sequence On column, highlight a waveform sequence file.
   c. Press Select Waveform.
4. Set the triggering as follows:
   - Trigger Type: continuous Segment Advance
     Press Trigger Type > Segment Advance > Continuous.
   - Trigger source: Trigger hardkey
     Press Trigger Source > Trigger Key.
5. Generate the waveform sequence:
   Press ARB Off On until On highlights.
6. (Optional) Monitor the waveform:
   Connect the RF OUTPUT of the signal generator to the input of an oscilloscope, and configure the oscilloscope so that you can see the signal.
7. Trigger the first waveform segment to begin playing continuously:
   Press the Trigger hardkey.
8. Trigger the second segment:
   Press the Trigger hardkey.
   Pressing the Trigger hardkey causes the currently playing segment to finish and the next segment to start.
   If the last segment in the sequence is playing, pressing the Trigger hardkey causes the first segment in the waveform sequence to start when the last segment finishes.
Example: Gated Triggering

Gated triggering enables you to define the on and off states of a modulating waveform.

1. Connect the output of a function generator to the signal generator's rear panel PAT TRIG IN connector, as shown in the following figure. This connection is applicable to all external triggering methods. The optional oscilloscope connection enables you to see the effect that the trigger signal has on the RF output.

2. Preset the signal generator.

3. Configure the RF output:
   - Set the desired frequency.
   - Set the desired amplitude.
   - Turn on the RF output.

4. Select a waveform for playback (sequence or segment):
   a. Press **Mode > Dual ARB > Select Waveform**.
   b. In the Segment On or Sequence On column, highlight a waveform.
   c. Press **Select Waveform**.

5. Set the triggering as follows:
   - Trigger type: Gated
     Press **Trigger Type > Gated**.
   - Active state: Low
     Press **Active Low**.
   - Trigger source: External
     Press **Trigger Source > Ext**.
   - Input connector: Rear panel Patt Trig In BNC
     Press **Ext Source > Patt Trig In 1**.

7. On the function generator, configure a TTL signal for the external gating trigger.

8. (Optional) Monitor the waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external triggering signal. You will see the waveform modulating the output during the gate *active* periods (low in this example).

The following figure shows an example display.
**Example: External Triggering**

Use the following example to set the signal generator to output a modulated RF signal 100 milliseconds after a change in TTL state from low to high occurs at the PATT TRIG IN rear panel BNC connector.

1. Connect the signal generator to the function generator as shown above.
2. Configure the RF output:
   - Set the desired frequency.
   - Set the desired amplitude.
   - Turn on the RF output.
3. Select a waveform for playback (sequence or segment):
   a. Press **Mode > Dual ARB > Select Waveform**.
   b. In the Segment On or Sequence On column, highlight a waveform.
   c. Press **Select Waveform**.
4. Generate the waveform:
   Press **ARB Off On** until On highlights.
5. Set the waveform trigger as follows:
   a. Trigger Type: single
      Press **Trigger Type > Single > No Retrigger**
   b. Trigger Source: external
      Press **Trigger Source > Ext**
   c. Input connector: Rear panel Patt Trig In BNC
      Press **Ext Source > Patt Trig In 1**.
   d. External Trigger Polarity: positive
      Press **Ext Polarity** until Pos highlights
   e. External Delay: 100 ms
      Press **More > Ext Delay** until On highlights
      Press **Ext Delay Time > 100 > msec**
6. Configure the Function Generator:
   - Waveform: 0.1 Hz square wave
   - Output Level: 3.5V to 5V.
Clipping a Waveform

Digitally modulated signals with high power peaks can cause intermodulation distortion, resulting in spectral regrowth that can interfere with signals in adjacent frequency bands. The clipping function enables you to reduce high power peaks by clipping the I and Q data to a selected percentage of its highest peak, thereby reducing spectral regrowth.

- How Power Peaks Develop on page 182
- How Peaks Cause Spectral Regrowth on page 184
- How Clipping Reduces Peak-to-Average Power on page 185
- Configuring Circular Clipping on page 188
- Configuring Rectangular Clipping on page 189
How Power Peaks Develop

To see how clipping reduces high power peaks, it is important to understand how the peaks develop as you construct a signal.

Multiple Channel Summing

I/Q waveforms can be the summation of multiple channels, as shown in the following figure. If a bit in the same state (high or low) occurs simultaneously in several individual channel waveforms, an unusually high power peak (positive or negative) occurs in the summed waveform.

Because the high and low states of the bits in channel waveforms are random and generally result in a cancelling effect, high power peaks occur infrequently with multiple channel summing.
Combining the I and Q Waveforms

When the I and Q waveforms combine in the I/Q modulator to create an RF waveform, the magnitude of the RF envelope is \( \sqrt{I^2 + Q^2} \), where the squaring of I and Q always results in a positive value.

As shown in the following figure, simultaneous positive and negative peaks in the I and Q waveforms do not cancel each other, but combine to create an even greater peak.
How Peaks Cause Spectral Regrowth

In a waveform, high power peaks that occur infrequently cause the waveform to have a high peak-to-average power ratio, as illustrated in the following figure.

Because the gain of a transmitter's power amplifier is set to provide a specific average power, high peaks can cause the power amplifier to move toward saturation. This causes the intermodulation distortion that generates spectral regrowth. Spectral regrowth is a range of frequencies that develops on each side of the carrier (similar to sidebands) and extends into the adjacent frequency bands (see the following figure). Clipping provides a solution to this problem by reducing the peak-to-average power ratio.
How Clipping Reduces Peak–to–Average Power

You can reduce peak–to–average power, and consequently spectral regrowth, by clipping the waveform. Clipping limits waveform power peaks by clipping the I and Q data to a selected percentage of its highest peak. The Signal Generator provides two methods of clipping:

- *Circular* clipping is applied to the composite I/Q data (I and Q data are equally clipped).
  
  As shown in Figure 8-9, the clipping level is constant for all phases of the vector and appears as a circle in the vector representation.

- *Rectangular* clipping is independently applied the I and Q data.
  
  As shown in Figure 8-10 on page 186, the clipping level is different for I and Q, and appears as a rectangle in the vector representation.

In both circular and rectangular clipping, the objective is to clip the waveform to a level that reduces spectral regrowth but does not compromise the integrity of the signal. The two complementary cumulative distribution plots in Figure 8-11 on page 187 show the reduction in peak–to–average power that occurs after applying circular clipping to a waveform.

The lower the clipping value, the lower the peak power that is passed (the more the signal is clipped). The peaks can often be clipped without substantially interfering with the rest of the waveform. In many cases, data that might otherwise be lost in the clipping process is retained because of the error correction inherent in the coded systems. If you apply excessive clipping, however, lost data cannot be recovered. Experiment with clipping settings to find a percentage that reduces spectral regrowth while retaining needed data.

**Figure 8-9 Circular Clipping**

![Circular Clipping Diagram](image-url)
Figure 8-10 Rectangular Clipping

Clipped I Waveform

Clipped Q Waveform

Vector Representation of Clipped I & Q Peak

a) || Clipping Set to 100% (No Clipping)
b) || Clipping Set to 75% of Greatest Peak
c) |Q| Clipping Set to 100% (No Clipping)
d) |Q| Clipping Set to 50% of Greatest Peak
Figure 8-11 Reduction of Peak-to-Average Power

Complementary Cumulative Distribution

CCDF with Clipping = 100% (No Clipping)

CCDF with Clipping = 80%

Reduction of Peak-to-Average Power Ratio

≈ 12 dB

≈ 15 dB
Configuring Circular Clipping

Use this example to configure circular clipping and observe its affect on the peak–to–average power ratio of a waveform. Circular clipping clips the composite I/Q data (I and Q data are clipped equally). For more information about circular clipping, refer to “How Clipping Reduces Peak–to–Average Power” on page 185.

**CAUTION** Clipping is non–reversible and cumulative. Save a copy of the waveform file before you apply clipping.

**Copy a Waveform File**
1. Display the signal generator’s files: Press *File > Catalog Type > More > Volatile Segments*.
2. Highlight the waveform *RAMP_TEST_WFM*.
3. Press *Copy File*.
4. Name the copy (in this example, the name is *MY_TEST_CIRC*) and press *Enter*.

**Apply Circular Clipping to the Copied Waveform File**
1. Open the DUAL ARB Waveform Utilities menu: Press *Mode > Dual ARB > More > Waveform Utilities*.
2. In the list of files, highlight the copied file (in this example, *MY_TEST_CIRC*).
3. Create the CCDF plot: Press *Plot CCDF*.
4. Observe the shape and position of the waveform’s curve (the dark line in the example at right).
5. Activate circular clipping: Press *Return > Clipping > Clipping Type* until *|I+jQ|* highlights.
6. Set circular clipping to 80%: Press *Clip |I+jQ| To > 80 > %*.
7. Apply 80% clipping to the I and Q data: Press *Apply to Waveform*.
8. Create the CCDF plot (see the example at right): Press *Plot CCDF*.
9. Observe the waveform’s curve after clipping.

Note the reduction in peak–to–average power relative to the previous plot.
Configuring Rectangular Clipping

Use this example to configure rectangular clipping. Rectangular clipping clips the I and Q data independently. For more information about rectangular clipping, refer to “How Clipping Reduces Peak–to–Average Power” on page 185.

**CAUTION** Clipping is non-reversible and cumulative. Save a copy of the waveform file before you apply clipping.

### Copy a Waveform File
1. Display the signal generator’s files: Press `File > Catalog Type > More > Volatile Segments`.
2. Highlight the waveform `RAMP_TEST_WFM`.
3. Press `Copy File`.
4. Name the copy (in this example, the name is `MY_TEST_REC`) and press `Enter`.

### Apply Rectangular Clipping to the Copied Waveform File
2. In the list of files, highlight the copied file (in this example, `MY_TEST_REC`).
3. Create the CCDF plot: Press `Plot CCDF`.
4. Observe the shape and position of the waveform’s curve (the dark line in the example at right).
5. Activate rectangular clipping: Press `Return > Clipping > Clipping Type` until `|I|,|Q|` highlights.
6. Set 80% clipping for the I data: Press `Clip |I| To > 80 > %`.
7. Set 40% clipping for the Q data: Press `Clip |Q| To > 40 > %`.
8. Apply the rectangular clipping to the waveform: Press `Apply to Waveform`.
9. Create the CCDF plot (see the example at right): Press `Plot CCDF`.
10. Observe the waveform’s curve after clipping.

Note the reduction in peak–to–average power relative to the previous plot.
Scaling a Waveform

The signal generator uses an interpolation algorithm (sampling between the I/Q data points) when reconstructing a waveform. For common waveforms, this interpolation can cause overshoots, which may create a DAC over–range error condition. This chapter describes how DAC over–range errors occur and how you can use waveform scaling to eliminate these errors.

- **How DAC Over–Range Errors Occur** on page 191
- **How Scaling Eliminates DAC Over–Range Errors** on page 192
- **Agilent MXG waveform scaling** on page 193 and page 194:
  - Waveform runtime scaling to scale a currently–playing waveform
  - Waveform scaling to permanently scale either the currently playing waveform, or a non–playing waveform file in BBG media

Figure 8-12 Scaling Softkeys

The settings in this menu can be stored to the file header, see page 151.

Waveform Runtime Scaling, see page 193.

Waveform Scaling, see page 194.

For details on each key, use key help as described on page 42.
How DAC Over–Range Errors Occur

The signal generator uses an interpolator filter when it converts digital I and Q baseband waveforms to analog waveforms. Because the clock rate of the interpolator is four times that of the baseband clock, the interpolator calculates sample points between the incoming baseband samples and smooths the waveform as shown in the figure at the right.

The interpolation filters in the DACs overshoot the baseband waveform. If a baseband waveform has a fast–rising edge, the interpolator filter’s overshoot becomes a component of the interpolated baseband waveform. This response causes a ripple or ringing effect at the peak of the rising edge. If this ripple overshoots the upper limit of the DAC range, the interpolator calculates erroneous sample points and is unable to replicate the true form of the ripple (see the figure at the right). As a result, the signal generator reports a DAC over–range error.
How Scaling Eliminates DAC Over–Range Errors

Scaling reduces the amplitude of the baseband waveform while maintaining its basic shape and characteristics, such as peak–to–average power ratio. If the fast–rising baseband waveform is scaled enough to allow an adequate margin for the interpolator filter overshoot, the interpolator filter can calculate sample points that include the ripple effect and eliminate the over–range error (see the figure at the right).

Although scaling maintains the basic shape of the waveform, excessive scaling can compromise waveform integrity. For example, if the bit resolution becomes too low the waveform becomes corrupted with quantization noise. To achieve maximum accuracy and optimize dynamic range, scale the waveform no more than is required to remove the DAC over–range error. Optimum scaling varies with waveform content.
Setting Waveform Runtime Scaling

Runtime scaling scales the waveform data during playback; it does not affect the stored data. You can apply runtime scaling to either a segment or sequence, and set the scaling value either while the ARB is on or off. This type of scaling is well suited for eliminating DAC over-range errors. Runtime scaling adjustments are not cumulative; the scaling value is applied to the original amplitude of the waveform file. There are two ways to save the runtime scaling setting: by using the save function (page 70) and by saving the setting to the file header (page 153). Saving to the file header saves the value with the waveform file, saving with the Save function stores the value as the current instrument setting.

Use this example to learn how to scale the currently selected waveform.

1. Select the waveform to which you want to apply scaling:
   a. Press **Mode > Dual ARB > Select Waveform**.
   b. Highlight the desired waveform (segment or sequence).
   c. Press **Select Waveform**.

2. Play the selected waveform: Press **ARB Off On** until On highlights.

3. Set the Waveform Runtime Scaling value:
   a. Press **ARB Setup > Waveform Runtime Scaling**.
   b. Enter a scaling value.
      The signal generator automatically applies the new scaling value to the waveform. There is no single value that is optimal for all waveforms. To achieve the maximum dynamic range, use the largest scaling value that does not result in a DAC over-range error.
   c. Press **Return**.
**Basic Digital Operation (Option 651/652/654)**

**Scaling a Waveform**

**Setting Waveform Scaling**

Waveform scaling differs from waveform runtime scaling in that it permanently affects waveform data and only applies to waveform segments stored in BBG media. You scale the waveform either up or down as a percentage of the DAC full scale (100%). If you scale your waveforms using this method, you may also need to change the waveform runtime scaling value to accommodate this scaling.

When you scale, the signal generator permanently modifies the waveform file’s sample values so that they conform to the desired scaling value. When you initiate scaling, the signal generator performs the following actions:

- locates the waveform file’s absolute peak sample value
- determines its current percentage of full scale
- calculates the ratio of the desired scale value to the determined absolute peak sample scale value
- multiplies each sample in the waveform file by this ratio

When you scale a waveform, you can create fractional data, lose data, or both. Fractional data occurs almost every time you reduce or increase the scaling value, and causes quantization errors. Quantization errors are more noticeable when scaling down, since you are closer to the noise floor. You lose data when either the signal generator rounds fractional data down or the scaling value is derived using the results from a power of two. This means that scaling a waveform in half (power of two: $2^1 = 2$) causes each waveform sample to lose one bit. The waveform data modifications are not correctable and may cause waveform distortion. It is always best to make a copy of the original file prior to applying scaling.

Use the following examples to apply waveform scaling to a waveform file. While this process uses the factory-supplied waveform `RAMP_TEST_WFM`, it is the same for any waveform file.

**Copy a Waveform File**

1. Display the waveform files in BBG media: Press **File > Catalog Type > More > Volatile Segments**.
2. Highlight the waveform `RAMP_TEST_WFM`.
3. Press **Copy File**.
4. Name the copy (this example uses the name `MY_TEST_SCAL`) and press **Enter**.
Apply Scaling to the Copied Waveform File

**CAUTION** This type of scaling is non-reversible. Any data lost in the scaling operation cannot be restored. Save a copy of the waveform file before scaling.

1. Open the DUAL ARB Waveform Utilities menu:
   - Press **Mode > Dual ARB > More > Waveform Utilities**.
2. In the list of BBG Media segment files, highlight the copied file (in this example, **MY_TEST_SCAL**).
3. Set and apply a scaling value (in this example 70% scaling is applied):
   - Press **Scale Waveform Data > Scaling > 70 > % > Apply to Waveform**.
Setting the Baseband Frequency Offset

The baseband frequency offset specifies a value to shift the baseband frequency up to ±50 MHz within the BBG 100 MHz signal bandwidth, depending on the signal generator’s baseband generator option. While the following figure shows how to access the control using the Dual ARB player, the location of the Baseband Frequency Offset softkey within each ARB format, through the ARB Setup softkey, is the same as for the Dual ARB player.

When the Baseband Frequency Offset is non-zero, the hardware rotator accumulates phase-shift of the baseband signal. This residual phase remains even after the offset value is returned to zero. To remove this phase accumulation, either restart the personality or select the Baseband Frequency Offset Phase Reset softkey. This softkey will grey out whenever the phase, due to the frequency offset, is zero. In addition, while there is a non-zero residual phase present in the signal, the DAC Over-Range Protection feature will automatically ensure that the reduced internal scaling is applied. This reduced scaling will be removed when both the frequency offset is returned to zero and the phase is reset.

Common uses for the offset feature include:

- offsetting the carrier from any LO feedthrough (carrier signal spur at the carrier frequency)
- sum the baseband signal with external I and Q inputs to create a multicarrier signal
- use the signal generator's I/Q signal as an IF
NOTE Changing the baseband frequency offset may cause a DAC over range condition that generates error 628, Baseband Generator DAC over range. The signal generator incorporates an automatic scaling feature to minimize this occurrence. For more information, see “DAC Over–Range Conditions and Scaling” on page 198.

The baseband frequency offset value is one of the file header parameters (page 151), which means you can store this value with the waveform. When you select a waveform with a stored frequency offset value, the signal generator changes the current value to match the stored file header value. If there is no stored baseband offset frequency value for the current waveform, the signal generator uses the last set frequency offset value.

You can also use the Save function (page 70) to store this value as part of the signal generator setup. When you Recall a setup stored with the Save function, the baseband frequency offset value becomes the current instrument setting value, disregarding the stored file header value.

Use the following steps to offset the carrier from LO/carrier feedthrough. This example uses the factory supplied waveform, SINE_TEST_WFM available in the Dual ARB Player. To view the output for this example, connect the RF OUTPUT of the signal generator to the input of a spectrum analyzer.

1. Select and play the waveform.
   a. Press Mode > Dual ARB > Select Waveform.
   b. In the Segment On BBG Media column, select SINE_TEST_WFM.
   c. Press Select Waveform.

2. Generate the waveform: Press ARB Off On to On.

3. Configure the carrier signal:
   a. Set the carrier signal to 1 GHz.
   b. Set the amplitude to 0 dBm.
   c. Turn on the RF OUTPUT.

4. Press Mode > Dual Arb > ARB Setup > More > Baseband Frequency Offset > 20 MHz.

The modulated RF signal is now offset from the carrier frequency by 20 MHz as shown in the following figures.
Basic Digital Operation (Option 651/652/654)
Setting the Baseband Frequency Offset

DAC Over–Range Conditions and Scaling

When using the baseband frequency offset (at a setting other than 0 Hz), it is possible to create a DAC over–range condition, which causes the Agilent MXG to generate an error. To minimize this condition with the frequency offset feature, the Agilent MXG incorporates an automatic DAC over–range protection feature that scales down the I/Q data by $\sqrt{2}$ when the offset is something other than zero. Because it can scale the data by more than what is actually needed, it typically decreases the dynamic range of the waveform. This is especially noticeable when using a constant amplitude signal such as GSM.

For the Dual ARB Player, this automatic over–range feature can be turned off. When on, it is active for the Dual ARB signal only when the offset is something other than 0 Hz. The control for the Dual ARB DAC over–range protection feature is located in the key path as shown in Figure 8-14.
In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the feature off and use the **Waveform Runtime Scaling** softkey to eliminate DAC over–range conditions.
Basic Digital Operation (Option 651/652/654)

I/Q Modulation

The following factors contribute to the error vector magnitude:

- Differences in amplitude, phase, and delay between the I and Q channels
- DC offsets

The I/Q menu not only enables you to select the I/Q signal source and output, it also provides adjustments and calibrations to compensate for differences in the I and Q signals.

See also, “Modulating the Carrier Signal” on page 60.

Figure 8-15 I/Q Display and Softkeys

- Inverts an internally generated Q signal, so that the I component lags the Q component by 90 degrees.
- Used only with internally generated, bursted modulation formats. Enables/disables the RF burst modulator.
- Opens the internal I/Q Equalization Filter which can be used to correct and/or impair the RF and External I/Q outputs for the internal I/Q source.
- Selects between optimizing the internal I/Q channel for EVM (in channel performance) at the expense of ACP (out of channel performance) or optimizing for ACP at the expense of EVM.

EVM is an 80% nyquist filter (100MHz wide) with a wide transition band. When an equalization filter is active, this filter is not active.

ACP is also an 80% nyquist filter (100MHz wide), but the transition band is very narrow, thus reducing images for wide-band signals. This filter will be convolved with the active equalization filter, the result of which will be truncated to the center 256 taps.

SCPI Commands:

SOURCE::DM::INTernal::CHANnel::OPTimization EVM
SOURCE::DM::INTernal::CHANnel::OPTimization ACP
SOURCE::DM::INTernal::CHANnel::OPTimization?
Using the Rear Panel I and Q Outputs

**NOTE** The rear panel I and Q connectors only output a signal while using the internal BBG.

In addition to modulating the carrier, the signal generator also routes the internally generated I and Q signals to the rear panel I and Q connectors. These output signals are post DAC, so they are in analog form. You can use these rear panel I and Q signals to:

- drive a system's transmitter stage
- test individual analog I and Q components such as an I/Q modulator
- route the I and Q signals into another signal generator

The factory default setting routes the internally generated I and Q signals to the I/Q modulator and the rear panel I and Q output connectors. However, to optimize (apply calibration factors) the rear panel signals, you need to select the external I/Q output path.

**Select and Play a Waveform**
1. Press *Mode > Dual ARB > Select Waveform*.
2. Highlight the desired waveform.
3. Press *Select Waveform > ARB Off On to On*.

**Optimize the Signal Path**
1. Connect cables from the rear panel I and Q connectors to either a DUT or another signal generator.
   When you turn the ARB on, the signal generator automatically outputs the I and Q signals to the rear panel connectors. You can use the rear panel I and Q signals as I and Q inputs to another signal generator. The MXG has front panel connectors, I Input and Q Input, for this purpose.

2. Press *I/Q > I/Q Correction Optimized Path > Ext I/Q Output*.
   When you optimize a path, the path indicator turns green.

Factory default setting—RF Output path optimized

Rear panel I/Q path optimized
Configuring the Front Panel Inputs

The signal generator accepts externally supplied analog I and Q signals through the front panel I Input and Q Input. You can use the external signals as the modulating source, or sum the external signals with the internal baseband generator signals.

1. Connect I and Q signals to the front panel connectors.
   a. Connect an analog I signal to the signal generator's front panel I Input.
   b. Connect an analog Q signal to the signal generator's front panel Q Input.
2. Set the signal generator to recognize the front panel input signals:
   - **To Modulate onto the Carrier**
     Press I/Q > I/Q Source > External.
   - **To Sum and Modulate onto the Carrier**
     Press I/Q > I/Q Source > Sum.
     To select and play a waveform for the BB GEN path, see page 145.
3. If you are using only the external I and Q signals (no summing), turn on the I/Q modulator: Press I/Q Off On to On.
4. Configure the RF output:
   a. Set the carrier frequency.
   b. Set the carrier amplitude.
   c. Turn the RF output on.
I/Q Adjustments

Use the I/Q Adjustments to compensate for or add impairments to the I/Q signal.

I/Q > I/Q Adjustments

Adjusts the I signal amplitude relative to the Q signal amplitude. Use this as an internal impairment, or to compensate for differences in signal path loss that occur due to path irregularities in the external I and Q output cabling.

The DC offset values are calibrated relative to the RMS waveform voltage being played out of the ARB. See page 154.

This feature allows adjustment of the absolute phase of the internal I/Q channel by rotating both I and Q, thus adjusting the relative phase of the RF carrier. For option 012, this is the only way to adjust the RF phase for a unit with an external LO.

Offsets the phase of the Q signal relative to the phase of the I signal. The baseband quadrature adjustment key is calibrated in units of degrees. The external input quadrature adjustment is not calibrated. The function provided by this key is not the same as the function provided by the I/Q Skew key.

Note: The I/Q signal will be scaled down by 0.7071 for all phase offsets except 0. Use -360 or +360, if it is desirable to maintain a constant power level with the ALC off while adjusting the I/Q phase.

Skew is typically used either to create impairments, or to reduce error vectors on large bandwidth signals.

Provides a relative time delay correction between the I and Q signals. The different signal paths traveled by the I and Q signals result in time delay differences that show up as an EVM error in large bandwidth modulated signals.

Adding an equal and opposite time delay (skew) in the I/Q signals during baseband generation eliminates the time delay error, correcting for any delays in signals that are generated in the internal baseband generator.

Changes the absolute phase of both the I and Q signals with respect to triggers and markers. Positive values add delay and negative values advance the signals. This value affects both the baseband signal modulated onto the RF and the external output signals (I and Q). This setting cannot be used with constant envelope modulation and it does not affect external I and Q inputs.

Offsets are typically used to either reduce carrier leakage, or to create an impairment that simulates carrier leakage.

Common Mode I/Q Offset Range
This changes the adjustment range of the Common Mode I/Q Offset from Coarse (Default) to fine or vice versa. The Coarse range corresponds to the default value of ± 2.5V. The Fine range corresponds to a value of ± 100 mV.

Common Mode I/Q Offset
This adjusts the DC offset of both I and Q signals simultaneously.

Diff Mode I Offset
This adjusts the DC offset level of the I and I-bar output signal. I and I-bar cannot be adjusted independently.

Diff Mode Q Offset
This adjusts the DC offset level of the I and I-bar output signal. I and I-bar cannot be adjusted independently.
The I/Q adjustment, I/Q Delay, is not for adding impairments; its function is to compensate for any latency between the EVENT output signals (marker signals) and the RF output.

<table>
<thead>
<tr>
<th>I/Q Adjustment</th>
<th>Effect</th>
<th>Impairment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offset</td>
<td>Carrier feedthrough</td>
<td>dc offset</td>
</tr>
<tr>
<td>Quadrature Angle</td>
<td>EVM error</td>
<td>phase skew</td>
</tr>
<tr>
<td></td>
<td>I/Q images</td>
<td>I/Q path delay</td>
</tr>
<tr>
<td>I/Q Skew</td>
<td>EVM error</td>
<td>high sample rate phase skew or I/Q path delay</td>
</tr>
<tr>
<td>I/Q Gain Balance</td>
<td>I/Q amplitude difference</td>
<td>I/Q gain ratio</td>
</tr>
<tr>
<td>I/Q Phase</td>
<td>I/Q phase rotation</td>
<td>RF phase adjustment</td>
</tr>
</tbody>
</table>
I/Q Calibration

Use the I/Q calibration for I and Q signal corrections. What aspects of the I and Q signal is corrected depends on whether the signal is internally or externally generated.

<table>
<thead>
<tr>
<th>Correction</th>
<th>Internal I and Q</th>
<th>External I and Q</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offset</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Gain Balance</td>
<td>X</td>
<td>--</td>
</tr>
<tr>
<td>Quadrature Error</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

When you perform an I/Q calibration, that calibration data takes precedence over the factory-supplied calibration data. The calibration routines improve performance that may degrade over time or due to temperature changes. An I/Q calibration should be run when the ambient temperature has varied by at least ±5 degrees Celsius from the ambient temperature at which the previous calibration was run.

**CAUTION**  
For firmware revisions ≥A.01.50, the behavior for the I/Q calibration is:

- The user I/Q calibration is persistent (i.e. Pressing instrument preset or cycling power does not remove the user I/Q calibration from memory).
- If the start and stop frequencies are set to the same value, then the calibration will be performed exactly at that frequency and the data will be persisted in the bounding calibration array elements.

For firmware revisions ≤A.01.50:

- The user I/Q calibration is not persistent (i.e. Pressing instrument preset or cycling power removes the user I/Q calibration from memory).
- If the start and stop frequencies are set to the same value, the calibration is performed at the bounding calibration array elements and persisted in the bounding calibration array elements.
Basic Digital Operation (Option 651/652/654)

I/Q Calibration

DC optimizes the I/Q performance for the current instrument settings, and typically completes in several seconds. Changing any instrument setting after performing a DC calibration voids the DC calibration and causes the signal generator to revert to the user calibration data (or factory-supplied calibration data, if no user calibration data exists).

User provides a quicker calibration when a full calibration is not required. You can limit the calibration by specifying the calibration start and stop frequencies. When you limit the calibration to less than the instrument’s full frequency range, the factory-supplied calibration data is used for the rest of the range. If the start and stop frequencies are set to the same value, then the calibration will be performed exactly at that frequency and the data will be persisted in the bounding calibration array elements. Information is retained through a preset or power cycle*.

Full takes approximately a minute, executing measurements over the instrument’s entire frequency range. Information is retained through a preset or power cycle*.

*Caution:
To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to non-volatile memory, the MXG should always be powered down either via the MXG’s front panel power button or the appropriate SCPI command. MXG’s installed in rack systems and powered down with the system rack power switch rather than the MXG’s front panel switch display a Error -310 due to the MXG not being powered down correctly.

Note
A DC calibration requires the following settings:
• I/Q: On
• Optimized Path: RF Output
• Source: Internal

For details on each key, use key help as described on page 42.
Using the Equalization Filter

An equalization FIR file can be created externally, uploaded via SCPI, and subsequently selected from the file system (refer to “Working with Files” on page 62). For information related to downloading FIR file coefficients, refer to the Programming Guide. For information regarding working with FIR file coefficients manually, refer to “Modifying a FIR Filter Using the FIR Table Editor” on page 215.

This filter can be used to correct and/or impair the RF and External I/Q outputs for the internal I/Q source. This filter will be convolved with the ACP Internal I/Q Channel Optimization filter if that filter is selected, the result of which will be truncated to the center 256 taps. The equalization filter operates at 125MHz, so all equalization filters must be resampled to 125MHz prior to selection, if they are sampled at some other rate.

The MXG supports equalization filters—either Complex or Real—that are programmable FIR filters with two inputs (I, Q) and two outputs (I, Q) per sample. This 256-tap filter has two modes of operation:

<table>
<thead>
<tr>
<th>Type of Filter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Real</td>
<td>The I and Q samples are independently filtered by a single set of real coefficients.</td>
</tr>
<tr>
<td>Complex</td>
<td>The samples are treated as complex (I + jQ) and convolved with the filter coefficients which are specified as (I + jQ) in the time domain.</td>
</tr>
</tbody>
</table>

The equalization filter can be turned on and off.
Basic Digital Operation (Option 651/652/654)
Using the Equalization Filter

Figure 8-16 Int Equalization Filter Softkeys

I/Q > More

For details on each key, use key help as described on page 42.

Note:
Use the FIR Table editor to view the filter's coefficients. Refer to page 215.

For more information on the SCPI commands, refer to the SCPI Command Reference.

SCPI commands:
Equalization filter state:
[:SOURce]:DM:INTERnal:EQualization:FILTers:STATe { OFF } | ON
[:SOURce]:DM:INTERnal:EQualization:FILTers:STATe?

Equalization filter selection:
[:SOURce]:DM:INTERnal:EQualization:FILTers:SELECT "filename"
[:SOURce]:DM:INTERnal:EQualization:FILTers:SELECT?

To add a real filter to the file system:
:MEMory:DATA:FIR "filename", [REAL,] osr, coeff1 [,coeff2 [..., coeffN]]
:MEMory:DATA:FIR? "filename"

To add a complex filter to the file system:
:MEMory:DATA:FIR "filename", COMPLEX, osr, hIRe0, hQIm0 [, hIRe1, hQIm1 [... hIReN, hQImN]]
:MEMory:DATA:FIR? "filename"

To add I/Q symbol data to the file system:
:MEMory:DATA "WFM1:filename", <blockdata>

Opens a file catalog of FIR filters to select as the equalization filter. Equalization filters are typically complex and must have an oversampling ratio of 1. The filter must not have more than 256 taps (512 coefficients for a complex filter). The equalization filter operates at 125MHz, so all equalization filters must be resampled to 125MHz prior to being placed in the MXG.
Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter

Finite Impulse Response filters can be used to compress single carrier I/Q waveforms down to just the I/Q constellation points and then define the transitions similar to the modulation filter in Arb Custom (refer to “Using Finite Impulse Response (FIR) Filters in ARB Custom Modulation” on page 281). The key difference for dual ARB real-time modulation is that a filter is applied as the waveform plays, rather than in the waveform data itself.

Figure 8-17 Filter Menu

Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter >

Enables or disables the Modulation Filter. This filter is typically applied to an Arb Waveform containing just the I/Q symbol decision points. The Modulation Filter then effectively defines the transitions between the symbol decision points. This means that the filter must have an oversample ratio of 2 or more. When this feature is active, the Sample Clock Rate is actually the Symbol Rate. Also, the filter must be real (refer to page 219).

Available only when the filter selected = Root Nyquist or Nyquist

Filter Menu on page 207

This softkey changes, depending on the selected filter-type.

Available only when the filter selected = Gaussian

Opens the IS-95 filter selection menu.

For details on each key, use key help as described on page 42.
Creating a User–Defined FIR Filter Using the FIR Table Editor

In this procedure, you use the FIR Values table editor to create and store an 8–symbol, windowed sync function filter with an oversample ratio of 4.

Accessing the Table Editor

1. Press \textit{Preset}.
2. Press \textit{Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > Select > Nyquist}.
3. Press \textit{Define User FIR}.
4. Press \textit{More 1 of 2 > Delete All Rows > Confirm Delete of All Rows}.

This will initialize the table editor as shown in Figure 8-18.

Figure 8-18 Creating a User–Defined FIR Filter Using the FIR Filter Table Editor

Entering the Coefficient Values

1. Press the \textit{Return} softkey to get to the first page of the table editor.
2. Use the cursor to highlight the Value field for coefficient 0.
3. Use the numeric keypad to type the first value (~0.000076) from Table 8-3. As you press the numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you can correct it using the backspace key.)

4. Continue entering the coefficient values from the table in step 1 until all 16 values have been entered.

Table 8-3

<table>
<thead>
<tr>
<th>Coefficient</th>
<th>Value</th>
<th>Coefficient</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>−0.000076</td>
<td>8</td>
<td>−0.035667</td>
</tr>
<tr>
<td>1</td>
<td>−0.001747</td>
<td>9</td>
<td>−0.116753</td>
</tr>
<tr>
<td>2</td>
<td>−0.005144</td>
<td>10</td>
<td>−0.157348</td>
</tr>
<tr>
<td>3</td>
<td>−0.004424</td>
<td>11</td>
<td>−0.088484</td>
</tr>
<tr>
<td>4</td>
<td>0.007745</td>
<td>12</td>
<td>0.123414</td>
</tr>
<tr>
<td>5</td>
<td>0.029610</td>
<td>13</td>
<td>0.442748</td>
</tr>
<tr>
<td>6</td>
<td>0.043940</td>
<td>14</td>
<td>0.767329</td>
</tr>
<tr>
<td>7</td>
<td>0.025852</td>
<td>15</td>
<td>0.972149</td>
</tr>
</tbody>
</table>
Duplicating the First 16 Coefficients Using Mirror Table

In a windowed sinc function filter, the second half of the coefficients are identical to the first half in reverse order. The signal generator provides a mirror table function that automatically duplicates the existing coefficient values in the reverse order.

1. Press **Mirror Table**. The last 16 coefficients (16 through 31) are automatically generated and the first of these coefficients (number 16) highlights, as shown in Figure 8-19 on page 212.

Figure 8-19

For details on each key, use key help as described on page 42.
Setting the Oversample Ratio

**NOTE**
Modulation filters are real and have an oversample ratio (OSR) of two or greater.

Equalization filters are typically complex and must have an OSR of one (refer to “Using the Equalization Filter” on page 207 and to “Setting the Real-Time Modulation Filter” on page 219).

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range from 1 through 32; the maximum number of taps allowed by the table editor is 1024.

The actual limits on OSR, number of coefficients, and number of symbols depends on the feature with which the FIR is used. Refer to Table 8-4.

**Table 8-4**

<table>
<thead>
<tr>
<th>Filter Type</th>
<th>Oversampling Ratio (OSR)</th>
<th>Number of Taps (Maximum)</th>
<th>Symbols/Coefficients (Maximum)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equalization*</td>
<td>1</td>
<td>256</td>
<td>--</td>
</tr>
<tr>
<td>ARB Custom Modulationb</td>
<td>≥ 2</td>
<td>--</td>
<td>512/1024</td>
</tr>
<tr>
<td>Dual ARB Real-Time Modulationc</td>
<td>≥ 2</td>
<td>--</td>
<td>32/1024</td>
</tr>
</tbody>
</table>

*When I/Q timing skew, I/Q delay, or the ACP internal I/Q channel optimization features are active, the effective number of taps for the equalization filter are reduced.

bThe filter may be sampled to a higher or lower OSR.

cThe filter will be decimated to a 16 or lower OSR depending on the symbol rate.

For modulation filters, if the oversample ratio is different from the internal, optimally selected one, then the filter is automatically resampled to an optimal oversample ratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

**Displaying a Graphical Representation of the Filter**

The signal generator has the capability of graphically displaying the filter in both time and frequency dimensions.

1. Press **More 1 of 2 > Display FFT** (fast Fourier transform).

   Refer to **Figure 8-20** on page 214.
2. Press **Return**.
3. Press **Display Impulse Response**.
   Refer to Figure 8-21.

**Figure 8-20**

![FFT graph with frequency and amplitude data](image1)

For details on each key, use key help as described on page 42.

4. Press **Return** to return to the menu keys.

**Storing the Filter to Memory**

Use the following steps to store the file.

1. Press **Load/Store > Store To File**. The catalog of FIR files appears along with the amount of memory available.
2. As described in **Storing, Loading, and Playing a Waveform Segment** on page 144, name and store this file as **FIR_1**.

The **FIR_1** file is the first file name listed. (If you have previously stored other FIR files, additional file names are listed below **FIR_1**.) The file type is FIR and the size of the file is 260 bytes. The amount of memory used is also displayed. The number of files that can be saved depends on the size of the files and the amount of memory used. Refer to **Figure 8-22**.
Memory is also shared by instrument state files and list sweep files.

This filter can now be used to customize a modulation format or it can be used as a basis for a new filter design.

**Modifying a FIR Filter Using the FIR Table Editor**

FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You can load the FIR table editor with coefficient values from user-defined FIR files stored in non-volatile memory or from one of the default FIR filters. Then you can modify the values and store the new files.
Loading the Default Gaussian FIR File

1. Press **Preset**.
2. Press **Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > Define User FIR > Gaussian**.
3. Press **Filter BbT > 0.300 > Enter**.
4. Press **Filter Symbols > 8 > Enter**.
5. Press **Generate**.

**NOTE** The actual oversample ratio during modulation is automatically selected by the instrument. A value between 4 and 16 is chosen dependent on the symbol rate, the number of bits per symbol of the modulation type, and the number of symbols.

6. Press **Display Impulse Response** (refer to Figure 8-24).
7. Press Return.

**Modifying the Coefficients**
1. Using the front panel arrow keys, highlight coefficient 15.
2. Press 0 > Enter.

Refer to **Figure 8-25** on page 217. The graphic display can provide a useful troubleshooting tool (in this case, it indicates that a coefficient value is missing, resulting in an improper Gaussian response).
4. Press Return.
5. Highlight coefficient 15.
6. Press 1 > Enter.


Storing the Filter to Memory

The maximum file name length is 23 characters (alphanumeric and special characters).

1. Press **Load/Store > Store To File**.
2. Name the file NEWFIR2.
3. Press **Enter**.

The contents of the current FIR table editor are stored to a file in non-volatile memory and the catalog of FIR files is updated to show the new file.
Setting the Real-Time Modulation Filter

The real-time modulation filter effectively compresses a single carrier I/Q waveform down to just the I/Q constellation points and then controls the transitions similar to the modulation filter in Arb Custom modulation. The key difference is that this filter is applied as the waveform plays, rather than in the waveform data itself. The real-time modulation filter is only available for Dual ARB waveforms.

When the real-time modulation filter is on, the sample clock rate acts as the symbol rate. The sample clock rate must be set to one half of the sample rate for the real-time Arb modulation filter feature to be turned on. The sample rate is determined by the Option 65x loaded in.

CAUTION

Because the Arb format only supports rectangular I/Q data for defining the symbol decision points, constant envelope modulation, which should be specified as magnitude and phase, are not supported. (Examples of constant envelope modulation are MSK and FSK.)

The carrier frequency must be the same for all frequencies used (i.e. only single carrier applications work with arb real-time modulation filters).

Figure 8-26 Real-Time Modulation Filter Softkey for the Dual ARB Player

For details on each key, use key help as described on page 42.
Common uses for the real-time modulation feature include:

- Where the single carrier rectangular ideal I/Q symbol decision points are known and are to have an over-sampled filter applied.
- Where greater effective MXG memory size is required.
- When you have a low rate waveform that could benefit from a higher OSR that does not make the waveform longer.

The real-time modulation filter setup is one of the file header parameters (page 151), which means you can store this setup with the waveform. When you select a waveform with a stored modulation filter setup, the signal generator changes the current setup to match the stored file header setup. If there is no stored modulation filter setup for the current waveform, the signal generator uses the last set modulation filter setup.

You can also use the Save function (page 70) to store this value as part of the signal generator setup. When you Recall a setup stored with the Save function, the modulation filter value becomes the current instrument setting value, disregarding the stored file header value.

Use the following steps to apply a real-time modulation filter to the current waveform loaded into volatile memory. This example uses the factory supplied waveform, SINE_TEST_WFM available in the Dual ARB Player. To view the output for this example, connect the RF OUTPUT of the signal generator to the input of a spectrum analyzer.

**NOTE** The following setup assumes you have completed the setup in “Setting the Baseband Frequency Offset” on page 196 for creating a modulated RF signal that is offset from the carrier frequency by 20 MHz.

1. Configure the modulation filter:
   - Press Mode > Dual ARB > Arb setup > More > Real-Time Modulation Filter > Select > Root Nyquist
2. Press Filter Alpha > .4 > Enter.
   - The modulated RF signal now has a real-time modulation filter of type root nyquist, with a filter alpha of 0.400.

**Multiple Baseband Generator Synchronization**

Available in the Dual ARB menu, this feature lets you set up a master/slave system of up to sixteen Agilent MXGs so that the baseband generators (BBG) synchronize the playing of waveforms. The system count includes one Agilent MXG to function as the master (see “Equipment Setup” on page 224).

The MXG with Option 012, enables 2x2, 3x3, or 4x4 MIMO configurations to share a common external LO signal to create phase coherent system. Refer to “Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator Synchronization” on page 227 and the Data Sheet.
Multiple Baseband Generator Synchronization (BBG Synchronization) Trigger Softkeys and Menu Location

**Note:** The BBG sync feature automatically configures the trigger settings shown below. To avoid a settings conflict error in this process, manually configure the trigger settings prior to setting the BBG sync parameters shown on page 222.

For details on each key, use key help as described on page 42.

Greys out for slave instruments.
Remains active for the master instrument.

Master default settings. If desired, change these settings after designating the instrument as the master.

Slave default settings. These settings are not accessible after selecting an instrument as a slave.

**Note:** A setting conflict error occurs when at the time of the master/slave selection, the following trigger setting(s) is true:
- **Master**
  - Free Run or Gated trigger type
- **Slave**
  - Free Run or Gated trigger type
  - Ext Polarity Neg trigger source

Neg is the factory default setting. If desired, manually change to Pos prior to selecting as a slave.
Multiple Baseband Generator Synchronization

Figure 8-28 Multiple BBG Synchronization Front Panel Displays

Master Display and Available Softkeys

Slave Display and Available Softkeys

For details on each key, use key help as described on page 42.
Understanding the Master/Slave System

System Delay

The multiple BBG synchronization feature provides a system for synchronizing the waveform generation capability of up to 16 signal generators to within a characteristic value of ± 8 ns between the master and the last slave. This minor amount of delay (± 8 ns) can be reduced further to picosecond resolution by using the I/Q Delay softkey located in the I/Q menu. To reduce the delay, check and adjust the BBG signal alignment for each signal generator in the system. For more information on adjusting the delay, see “I/Q Adjustments” on page 203.

The delay value includes compensation for cables that have less than 1 ns of propagation delay between the EVENT 1 and PAT TRIG connectors (see Equipment Setup). The recommended cable is an Agilent BNC cable, part number 10502A. The use of cables with greater propagation delay may not allow the signal generators to properly synchronize.

System Synchronization

Synchronization occurs after the master signal generator sends a one–time event pulse that propagates through and to each slave in the system. Prior to this event, each slave must recognize that it is waiting for this event pulse, which occurs during the system configuration (see “Configuring the Setup” on page 224). In order to properly send the synchronization pulse, the trigger source and the Dual ARB Player for each signal generator must be turned off.

The master/slave setup does not incorporate a feedback system between the slaves and the signal generator selected as the master. After synchronization, if changes occur to the Multi–BBG Sync Setup menu or a signal generator is added to the system, the master does not automatically resynchronize the setup. This may cause the signal generators in the system to incorrectly report their status as In Sync.

The system can also misinterpret other signals as the synchronization pulse, which results in an incorrect In Sync status. These types of signals include a continuous trigger or an active Marker routed to the EVENT 1 connector. Improperly connected rear panel cables can also create a false status.

You must resynchronize the entire system after making any change in one or all of the Multi–BBG Sync Setup menus, after adding a signal generator to the system, or in doubt as to the true status of a signal generator. Changes to parameters that are outside of the Multi–BBG Sync Setup menu such as waveform files, Dual ARB state, sample rate, scaling, carrier frequency or amplitude have no effect on the system synchronization. To resynchronize a system, see “Making Changes to the Multiple Synchronization Setup and Resynchronizing the Master/Slave System” on page 226.

System Trigger Setup

The multiple BBG synchronization feature restricts the trigger selections (see page 221) for each signal generator. For signal generators selected as slaves, you can only modify the trigger type (with restrictions). The trigger source is fixed and set to receive a trigger through the rear panel PAT TRIG connector. On the master, you can change both the trigger type (with restrictions) and the trigger source. The trigger source provides three options for triggering the waveforms: external trigger, front panel Trigger key, or the GPIB trigger.

If the trigger settings are other than what the BBG synchronization feature supports, the feature changes the trigger settings to what is shown on page 221. When this change occurs, the Agilent MXG generates a settings conflict error to alert you to the changes. To avoid the error generation,
appropriately configure the trigger settings prior to selecting a signal generator as the master or slave.

The system trigger propagates in the same manner as the synchronization pulse initiated by the master (see System Synchronization). So if it is not turned off during changes to the synchronization parameters, it can cause a false In Sync status.

The signal generator does not reset the trigger parameters when the multiple BBG synchronization feature is turned off. To play waveforms after disabling the feature, you must either set the trigger type to Free Run or provide a trigger to start the waveform play back.

**Equipment Setup**

**Figure 8-29 Multiple Baseband Synchronization Setup**

*Note:* To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended cable for the rear panel daisy chain connections (see page 223).

**Configuring the Setup**

**Set the Common Parameters**

Perform the following steps on all signal generators:

1. Set the frequency of the carrier signal.
2. Set the power level of the carrier signal.
3. Select the desired waveform (see page 144).
   
   Do not turn the Dual ARB on.
4. Except for triggering, set the desired waveform parameters such as markers and sample clock.

   The baseband synchronization feature limits the trigger selections for both the master and slaves. If the current trigger settings include unsupported BBG synchronization parameters, the Agilent MXG generates a settings conflict error and changes the trigger settings. To avoid the settings conflict error, manually set the trigger parameters as shown on page 221 prior to setting the multiple BBG synchronization parameters.

5. Turn on the RF Output.

   **Set the BBG Synchronization Master Parameters**
   1. Press **Mode > Dual ARB > ARB Setup > More > Multi–BBG Sync Setup > Multi–Bbg Sync Type > Master**.
   2. Set the number of slaves using the **Number of Slaves** softkey.
   3. If desired, modify the trigger parameters (see page 221).
      a. Return to the Dual ARB menu (see page 221).
      b. Set the desired trigger type and source.
      c. Return to the **Multi–BBG Sync Setup** menu.

   **Set the BBG Synchronization Slave Parameters**
   1. Press **Mode > Dual ARB > ARB Setup > More > Multi–BBG Sync Setup > Multi–BBG Sync Type > Slave**.
   2. Set the number of Slaves using the **Number of Slaves** softkey.
   3. Set the slave position that the signal generator occupies.
      There can be up to fifteen slaves in a system.
   4. Press the **Listen for Sync** softkey and verify that **Waiting for Sync** appears in the **Status** area of the display.
   5. If desired, select a different trigger type parameter:
      a. Return to the Dual ARB menu (see page 221).
      b. Set the desired trigger type.
      c. Return to the **Multi–BBG Sync Setup** menu.
   6. Repeat for each slave signal generator in the system.

   **Synchronize the System**

   Perform this procedure only after setting the parameters for both the master and slave signal generators. If resynchronizing a system, use the procedure “Making Changes to the Multiple Synchronization Setup and Resynchronizing the Master/Slave System” on page 226.
Multiple Baseband Generator Synchronization

1. On the master, press the Sync Slaves softkey.

**NOTE** All of the signal generators in the master/slave system must be resynchronized when any changes are made to the master/slave settings or with the addition of a slave instrument, even if In Sync appears after pressing the Listen for Sync softkey on the slave instruments.

2. On the front panel displays, ensure that all of the signal generators show In Sync as the Status.

**Trigger and Play the Waveform**

1. On all Agilent MXGs, press Mode > Dual ARB > ARB Off On to On.
2. Start the trigger signal going to the master signal generator.

**Making Changes to the Multiple Synchronization Setup and Resynchronizing the Master/Slave System**

If any changes are made to the master/slave parameters or a signal generator (slave unit) is added to the system, the system must be resynchronized even if In Sync appears in the Status portion of the display.

1. Turn off the trigger source. If using the Trigger key, there is nothing to turn off.
   
   If the trigger source is on and provides a continuous pulse stream, it may cause the signal generators to incorrectly display In Sync as the status after pressing the Listen for Sync softkey.
2. On each of the signal generators, press Mode > Dual ARB > ARB Off On to Off.
   
   If a signal generator(s) has the Dual ARB on during changes, signal generators further in the chain may incorrectly display In Sync after pressing the Listen for Sync softkey.
4. Make the changes in the Multi–BBG Sync Setup menu.
   
   Out Of Sync appears as the status message.
5. On each of the slave signal generators, press Listen for Sync.
6. Ensure that all of the slaves' Status show Waiting for Sync. If In Sync shows as the status, perform the following steps:
   a. Check that the PATT TRIG to EVENT 1 cables are properly connected on the rear panel.
      
      A disconnected cable can cause a false In Sync status.
   b. If the cables are connected, perform steps 1 and 2.
   c. Press Listen for Sync and ensure that Waiting for Sync appears as the status.
8. Verify that In Sync appears as the status on all master/slave signal generators.
Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator Synchronization

NOTE  This section assumes that the previous section on Multiple Baseband Generator Synchronization has been read and understood. If not, refer to “Multiple Baseband Generator Synchronization” on page 220 before continuing.

The MXG with Option 012, enables 2x2, 3x3, or 4x4 MIMO configurations to share a common external LO signal to create a phase coherent system (refer also, to “Multiple Baseband Generator Synchronization” on page 220).

RF phase coherency may not be needed for general STC/MIMO receiver testing, since a MIMO receiver perceives any phase differences between the sources as part of the channel conditions and correct for them. But, RF phase coherency might be desirable for certain applications such as R&D on beamforming systems.

Configuring the Option 012 (LO In/Out for Phase Coherency) with MIMO

The Agilent BNC cable, part number 10502A, is the recommended cable for the standard multi–BBG synchronization setup, and is recommended for Option 012 too (see also Figure 8-29 on page 224). Additionally, for the 2x2, 3x3, and 4x4 MIMO connections from the LO IN and LO OUT to the splitter, additional cables are required (refer to Table 8-5, Figure 8-30 on page 229, and Figure 8-31 on page 230).

NOTE  Agilent recommends the LO Output be covered when not in use.

When the LO In/Out jumper cable is removed and the instrument is in Dual ARB mode, the instrument is unleveled and the instrument displays an Unlevel error message.

All test equipment requires a 12 hour warm–up period to ensure accurate performance.

The phase coherent configuration requires the following:

• The recommended LO input drive level should be in the 0 to 6 dBm range.

NOTE  The 0 to 6 dBm LO input drive level ensures the instruments will operate over the full frequency and over the full 0 to 55 ambient temperature range.

• The I/Q calibration and the self–test must be performed with the LO In/Out jumper cable in place. Where the I/Q calibration cannot be run, the baseband offset can be manually adjusted to minimize the I/Q offsets.

• The phase coherency feature only applies to the Dual ARB modulation mode.

• All cables from the splitter output to the instrument inputs should be of equal lengths.

1LO input power requirements vary with temperature; power <0 dBm may work at 20–30 degree ambient temperature conditions. Refer to the Data Sheet.
Table 8-5  Option 012 (LO In/Out for Phase Coherency) Equipment

<table>
<thead>
<tr>
<th>MIMO Configuration</th>
<th>Parta</th>
<th>Cable Length</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>2x2</td>
<td>n/a</td>
<td>As required</td>
<td>SMA flexible cables are connected from the power splitter outputs to the LO inputs on the rear panel of both the master and the slave MXGs. Refer to Figure 8-30 on page 229.</td>
</tr>
<tr>
<td></td>
<td>11636A</td>
<td>n/a</td>
<td>Power Divider, DC to 18 GHz. Refer to <a href="http://www.agilent.com">www.agilent.com</a>.</td>
</tr>
<tr>
<td>3x3</td>
<td>n/a</td>
<td>As required</td>
<td>SMA flexible cables are connected from the power splitter outputs to the LO inputs on the rear panel of the slave MXGs. Refer to Figure 8-31 on page 230.</td>
</tr>
<tr>
<td>4x4</td>
<td>n/a</td>
<td>As required</td>
<td>The SMA flexible cables are connected to the power splitter output to the LO inputs on the rear panel of the slave MXGs. Refer to Figure 8-31 on page 230.</td>
</tr>
<tr>
<td></td>
<td>PS4–16–452/10 S</td>
<td>n/a</td>
<td>4–Way Pulser Microwave Corp., 4–Way Wilkinson Dividers</td>
</tr>
<tr>
<td>All</td>
<td>10502A</td>
<td>22.86 cm (9 inches)</td>
<td>Refer to Figure 8-30 on page 229 and Figure 8-31 on page 230. See also “Multiple Baseband Generator Synchronization” on page 220.</td>
</tr>
</tbody>
</table>

*aOn all of the MIMO configurations, the same length of SMA flexible cables are connected from the splitter output to the inputs on the master and slave instruments. Refer to Figure 8-30 on page 229 and to Figure 8-31 on page 230.
2x2 MIMO (LO In/Out for Phase Coherency) Configuration

For the 2x2 MIMO (LO In/Out for phase coherency) setup, the LO from the master MXG can be run through a power splitter and used as the LO input to both the master and the slave MXGs. No external source is required.

To generate phase coherent signals for a 2x2 MIMO configuration, the master MXG LO OUT is connected via a power splitter to the slave LO IN. The LO OUT provides a sufficient amplitude LO signal when connected directly, to drive the Slave MXG(s), thus providing phase coherency for the RF output signals. In this example, we show two MXG signal generators with Option 012 connected for a phase coherent 2x2 MIMO solution. Refer to Figure 8-30.

Figure 8-30 2x2 MIMO (LO In/Out for Phase Coherency) Equipment Setup

Note:
To optimize the phase coherence, the same length SMA flexible cable is recommended for the output of the 2–way splitter connections to the LO IN of the MXGs with Option 012 (see page 227).

To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended cable for the rear panel daisy chain

3x3 and 4x4 MIMO (LO In/Out for Phase Coherency) Configurations

For a 3x3 and 4x4 MIMO (LO In/Out for phase coherency) setups, an additional analog source is needed to provide the higher LO power required by the power splitter and the additional instruments.

Splitting the LO output four ways causes too much loss to drive the LO input of the N5162/82As in the system. Also, there is no amplitude adjustment to the LO output of the N5162A/82A. To generate phase coherent signals for a 3x3 and 4x4 configurations with the MXG, an external Master LO is needed to provide a sufficient amplitude LO input signal to the vector MXGs (refer to Figure 8-31 on page 230).

NOTE The Master LO is not controlled by any of the Signal Studio software, but must be set manually—via the RF frequency settings on the master MXG—by the user to the desired frequency and amplitude.
Figure 8-31 3x3 and 4x4 MIMO (LO In/Out for Phase Coherency) Equipment Setup

Note:
A SMA flexible cable is recommended for the input to the 4–way splitter connections to the LO IN and LO OUT of the MXGs with Option 012 (see page 227).

To optimize the phase coherence, the same length SMA flexible cable is recommended for the output of the 4–way splitter connections to the LO IN of the MXGs with Option 012 (see page 227).

To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended cable for the rear panel daisy chain.
Waveform Licensing for Firmware Version ≥ A.01.50

Waveform licensing enables you to license waveforms that you generate and download from any Signal Studio application for unlimited playback in a signal generator. Each licensing option (221-229) allows you to permanently license up to five waveforms or (250-259) allows you to permanently license up to 50 waveforms of your choice (i.e. Waveform Option 22x or Option 25x are perpetual fixed waveform licenses).

Waveforms licensed with Options 221-229 or Options 250-259 cannot be exchanged for different waveforms. Once a waveform is licensed, that license is permanent and cannot be revoked or replaced. Option 22x and 25x waveform licenses are signal generator specific (i.e. signal generator serial number specific). If a licensed Option 22x or Option 25x waveform file is transferred to another signal generator, the file must be licensed by a separate Option 22x or Option 25x that is in the other signal generator before it can be played.

To redeem Option 22x or Option 25x, refer to the N5182A–2xx Entitlement Certificate that comes with the N5182A–2xx order. For more information on extracting and downloading waveform files, refer to the Programming Guide.

Understanding Waveform Licensing

Use any N76xxB Signal Studio software to build and download waveforms to the signal generator. Each Option 22x provides 5 available slots and Option 25x license provides 50 available slots, where you can add and play waveforms for a trial period of 48 hours per slot. During this time, you can replace the waveform any number of times until you are satisfied with it. After the trial period expires, the waveform in the slot is no longer playable until the slot is locked for permanent playback; however, you can replace the waveform in the slot with another waveform of your choice before locking the slot.

To license additional waveforms that exceed the number permitted by an Option 22x or Option 25x, you must purchase another Option 22x or Option 25x that you do not already own. For example, if you already own Option 250, purchase Option 251 to add an additional 50 slots. Adding all options, 250-259, provides a maximum of 500 slots. Adding all options, 221-229, provides a maximum of 45 slots. (Repurchasing the same option for the same signal generator, gives you no additional Waveform licenses.)

Installing an Option N5182-22x or Option N5182A–25x

Load a Waveform License, Option N5182-22x or Option N5182A–25x, into the signal generator using License Manager or a USB media. For more information on loading the Waveform License, refer to the N5182A–2xx Entitlement Certificate included with your order.

Licensing a Signal Generator Waveform

Create and download a waveform into the signal generator using any of the N76xxB Signal Studio software. Refer to your Signal Studio software help if you need assistance using the application.

Refer to page 236 for steps in adding the waveform to a license slot for a 48-hour trial period. During the trial period, the waveform can be played and replaced any number of times. When the trial time expires, the slot can no longer be used for playback until the slot is locked for permanent playback capability.
Waveform Licensing Softkeys Overview

Figure 8-32 Waveform Licensing Softkeys
Mode > Dual ARB > More

Note: Waveforms licensed with Option 2xx cannot be exchanged for other waveforms. Once a waveform is locked into a license slot, that license is permanent and cannot be revoked or replaced.

This softkey is only available if there is an Option 2xx license installed on the instrument. Pressing this softkey displays the licensing status and associated filename for each slot and accesses the waveform licensing menu selections.

Note: When Waveform Licensing is first accessed, all slots appear as Available. For licensing status descriptions after waveforms have been added to a slot, refer to Table 8-6 on page 235.

Refer to the SCPI Command Reference for related license commands.

For details on each key, use key help as described on page 42.

This softkey allows you to add a waveform that you select to the first available slot. Refer to page 233.

This softkey allows you to replace a waveform in the selected slot. Refer to page 234.

This softkey clears the waveform from the selected slot.

This softkey allows you to lock a waveform into a slot. After the trial period has expired, the waveform must be locked in order to be able to play the waveform. Refer to page 234.

This softkey allows you to select a specific slot where you want to add, replace, or clear a waveform. You can also select a slot by using the front panel arrow keys or by scrolling to the slot. Refer to page 233.
Basic Digital Operation (Option 651/652/654)
Waveform Licensing for Firmware Version ≥ A.01.50

Figure 8-33 Waveform Licensing Softkeys

Mode > Dual ARB > More >
Waveform Licensing > Add Waveform to First Available Slot
or
Mode > Dual ARB > More >
Waveform Licensing > Replace Waveform in Slot

Note: Waveforms licensed with Option 2xx cannot be “exchanged”. Once a slot is locked, that license for the waveform in the locked slot is permanent and cannot be revoked or replaced.

The softkey is greyed out, if a waveform is already licensed or does not require licensing.

To select a waveform, use the arrow keys to highlight the waveform and then press Add Waveform.

Refer to the SCPI Command Reference for related License Commands.

The waveform to be added or replaced can be selected from BBG memory, internal storage, or a USB device.

For details on each key, use key help as described on page 42.
Figure 8-34 Waveform Licensing Softkeys

Mode > Dual ARB > More > Waveform Licensing

Press this softkey to confirm that you want to lock the waveform into the slot for permanent licensing. If the waveform has not been saved to internal storage, a warning message appears. Refer to Step 4 on page 237.

Press this softkey after entering a specific slot number using the front panel numeric pad.

Press this softkey to go to the first slot.

Press this softkey to go to the first slot whose status is available.

Press this softkey to go to the last slot. The number of slots depends on the number of licensing options installed on the instrument.

Press this softkey to store the waveform into the Internal Storage and to activate the Confirm Locking Waveform softkey. Refer to Step 4 on page 237.

Refer to the SCPI Command Reference for related license commands.

Press this softkey to play the waveform in the highlighted slot.

Press this softkey to locate the waveform in memory that was added to this slot regardless of the name. If the search returns no results, the original waveform has been deleted from memory and cannot be found.

For details on each key, use key help as described on page 42.
### Waveform Licensing Slot Status Messages

<table>
<thead>
<tr>
<th>Status Column</th>
<th>Meaning</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Available</td>
<td>The slot has never had a waveform added to it.</td>
<td>50 slots are initially available for each Option 25x. 5 slots are initially available for each Option 22x.</td>
</tr>
<tr>
<td>Locked MM/DD/YY</td>
<td>The slot is locked and can no longer be modified.</td>
<td>The waveform in this slot is licensed to this signal generator for unlimited playback.</td>
</tr>
<tr>
<td>Remaining Trial Time HH:MM</td>
<td>The slot is in a trial period that is available for 48 hours that begins when a waveform is added.</td>
<td>During the trial period, the waveform in this slot can be played, cleared, or replaced with another waveform.</td>
</tr>
<tr>
<td>Lock Required</td>
<td>The trial period for the slot has expired but the slot has not been locked.</td>
<td>The slot can be cleared or replaced with a different waveform but the waveform cannot be played until the slot is locked. A trial period is no longer available.</td>
</tr>
</tbody>
</table>
Example: Licensing a Signal Studio Waveform

The following steps add a waveform file to a license slot and lock the slot for permanent playback.

1. Press **Mode > Dual ARB > More > Waveform Utilities > Waveform Licensing**

   The signal generator displays a catalog of files labeled: Catalog of BBG Segment Files in BBG Memory.

2. Use the arrow keys to highlight and select the file to be licensed.

3. Press **Add Waveform** to add the selected waveform to the first available slot.

   ![Waveform Licensing Screen](image)

   - Status area for the waveform N7602B–WFM1 is empty and the **Add Waveform** softkey is active, indicating the waveform is licensable.
   - The selected waveform is added to the first available slot.
   - The trial time for the waveform begins as soon as the waveform is added.
   - During the 48 hour trial period, the waveform can be played and replaced any number of times.
   - When the trial time expires, the licensing status of the slot changes to **Lock Required** after which the waveform can no longer be played until the slot is locked.
4. License the waveform:
   a. Press **Lock Waveform in Slot**.

      A warning is displayed: *** Waveform Lock Warning!!! ***. **If necessary, verify you have selected the correct waveform you want for licensing by pressing Return.**

      ![Figure 8-36 Waveform Lock Warning](image)

   b. Press **Confirm Locking Waveform**.

      The licensing status of the slot will be changed to Locked MM/DD/YY.

   c. If the waveform has not been previously backed up in internal storage, a warning is displayed: *** Waveform Backup Required!!! ***.

   d. Make a backup copy of this waveform on a USB media or a computer before pressing **Backup Waveform to Int Storage**. *(If the waveform is lost or deleted on the signal generator, it cannot be recovered).*

      ![Figure 8-37 Backup Waveform To Int Storage softkey](image)

      **CAUTION** It is important that you make a backup copy of any waveforms that you are licensing. *Do not store the backup copy on the signal generator. If all copies of the waveforms are deleted or lost, there is no way to recover the waveform or reassign the license. Refer to “Working with Files” on page 62.*
Waveform Licensing Warning Messages

Figure 8-38

This standard warning is displayed every time a waveform is selected to be locked. This notification indicates that one of the available “license slots” is about to be used from Option 2xx.

ALWAYS make backup copies of waveforms in a separate non–volatile memory in case a file is deleted or lost from the instrument’s internal storage.

This warning is displayed when an attempt is made to lock a waveform that has not been saved to internal storage or USB media (i.e. waveforms cannot be locked unless they have been stored to non–volatile memory). Press the Backup Waveform To Int Storage softkey.

This warning is displayed when there is insufficient memory or other problems with the internal storage, or USB media (non–volatile memory) and the waveform could not be saved to non–volatile memory.

This warning is displayed when the waveform file cannot be found in BBG or internal storage. You must ensure that the waveform still resides in the instrument before you can lock it.

*** Waveform Backup Required!!! ***
Waveform backup required. The waveform cannot be licensed until it is copied to non–volatile memory.
You must back up the waveform to non–volatile memory.

*** Waveform Backup Failed!!! ***
Waveform backup failed. The waveform could not be copied to non–volatile memory. There may not be enough free memory.
You must free enough non–volatile memory to copy the waveform before you can license it.

*** Waveform File is Missing!!! ***
The waveform file in the selected slot is no longer in instrument memory.
You must either clear or replace the waveform for this slot or load the missing file into instrument memory before you can license it.
Waveform 5–Pack Licensing (Options 221–229) for Firmware Version < A.01.50

Waveform 5–Pack licensing enables you to create, generate, and permanently license up to 45 Signal Studio waveforms (e.g. Each Option 22x enables licensing of five waveforms (Option 221, 222, 223, 229).

Use the signal generator to manage the licensing of these waveforms. For example, you can use the signal generator to select individual waveforms for licensing and you can view a list of all currently licensed waveforms.

Understanding Waveform 5–Pack Licensing

Waveforms licensed with 5–Pack cannot be exchanged. Once a waveform is licensed, that license is permanent and cannot be revoked or replaced. Option 22x waveform licenses are signal generator specific (i.e. signal generator serial number specific).

Waveform 5–Pack licensing enables you to create and generate signals which can be saved for unlimited use in a signal generator (i.e. Waveform 5–Pack Option 22x is a perpetual fixed waveform license).

Use the Signal Studio software to build and download waveforms to the signal generator’s volatile memory to be played. When you are satisfied with the waveform, it must be stored to non–volatile memory before it can be licensed.

If a licensed Option 22x waveform file is transferred to another signal generator, the file must be licensed by a separate Option 22x that is in the other signal generator before it can be played. For more information on extracting and downloading waveform files, refer to the Programming Guide.

To license additional waveforms that exceed the number permitted by an Option 22x, you must purchase an Option 22x that you do not already own. For example if you already own Option 221 with only two remaining licenses and you need ten more waveforms, purchase Options 222 and 223 to have enough licenses to license ten more waveforms. This would leave two remaining licenses on Option 223. (Repurchasing Option 221 a second time, for the same signal generator, gives you no additional Waveform 5–Pack licenses.)

After licensing a waveform, you can make copies of the waveform using different file names for use on the same signal generator and even rename the original file without affecting the waveform license.

You can also use the Option 22x to license waveforms from N76xxB Signal Studio software downloaded during its 14–day free trial license. All of the N76xxB Signal Studio software products provide a 14–day trial period (trial license). This 14–day trial license lets you download and play back waveforms during the trial period. These waveforms are denoted by the TRL in the status message area of the waveform segment catalog. After the trial period expires, the TRL message is removed but the waveform remains. You can license these waveforms after the TRL message is gone.

Waveform 5–Pack requires firmware version ≥A.01.20.

Installing an Option N5182A–22x Waveform 5–Pack Licensing

- Load a Waveform 5–Pack license, Option N5182A–22x, into the signal generator using License Manager or a USB media. For more information on loading the Waveform 5–Pack License, refer to the N5182A–22x Entitlement Certificate.
Licensing a Signal Generator Waveform File

1. Create the waveform:
   a. Download any of the N76xxB Signal Studio software that interest you. For downloading N76xxB Signal Studio software, refer to the N5182A–22x Entitlement Certificate.
   b. Create and download a waveform to a signal generator using any of the N76xxB Signal Studio software. Refer to your Signal Studio software Help.

Waveform 5–Pack Licensing Softkeys Overview

Figure 8-39 Waveform 5–Pack licensing Softkeys

- [Waveform Utilities]
- [Mode]
- [Dual ARB]
- [More]

Note: Waveforms licensed with 5–Pack cannot be "exchanged". Once a waveform is licensed, that license is permanent and cannot be revoked or replaced.

This softkey is only available if there is an Option 22x installed on the instrument.

For details on each key, use key help as described on page 42.
Figure 8-40 Add a Waveform to 5–Pack Softkeys

Mode > Dual ARB > More >
Waveform Utilities > 5-Pack
Licensing > Add Waveforms to
5–Pack

Note: Waveforms licensed with 5–Pack cannot
be “exchanged”. Once a waveform is licensed,
that license is permanent and cannot be
revoked or replaced.

Displays the name of the Waveform file and status. Refer to
Table 8-7 on page 242.

This softkey is only active when
there are secure waveforms that
can be added and a Waveform
5–Pack license with available
slots (i.e. if a waveform is already
licensed or does not require
licensing the softkey is greyed
out). Refer to page 245.

To select a waveform
to receive one of your
Waveform 5–Pack
licenses, use the
arrow keys to highlight
the waveform and
then press Add
Waveform.

Refer to the SCPI Command
Reference for related 5–Pack
License Commands.

This softkey
displays a catalog
of the waveform
segments stored
in the Int Storage
or USB Media.

This softkey
displays a catalog
of the waveforms
stored in the BBG
memory.

For details on each
key, use key help
as described on
page 42.
### Table 8-7  Waveform 5–Pack Licensing Status Messages for the “Catalog of Segment Files in Int Storage [or USB Media]”

<table>
<thead>
<tr>
<th>Status Message</th>
<th>Meaning</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Empty field</td>
<td>If no status message, then the waveform is licensable.</td>
<td>Once a Trial (TRL) license expires, the waveform becomes licensable (i.e. the status message for the TRL waveform becomes an <em>empty field</em>).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If a licensed Option 22x waveform file is downloaded to another N5182A signal generator, the waveform becomes licensable on that <em>other</em> signal generator (i.e. the status message field is empty).</td>
</tr>
<tr>
<td>5-Pack Licensed</td>
<td>This waveform is licensed by Option 22x.</td>
<td></td>
</tr>
<tr>
<td>5-Pack License Not Required</td>
<td>This status message applies to:</td>
<td>Once a Trial (TRL) license expires, the waveform becomes licensable (i.e. the status message for the TRL waveform becomes an <em>empty field</em>).</td>
</tr>
<tr>
<td></td>
<td>Any free waveforms provided with the Agilent MXG (e.g. RAMP_TEST_WFM, and SINE_TEST_WFM, etc.)</td>
<td>If a licensed Option 22x waveform file is downloaded to another N5182A signal generator, the waveform becomes licensable on that <em>other</em> signal generator (i.e. the status message field is empty).</td>
</tr>
</tbody>
</table>
Example: Licensing a Signal Studio Waveform

The following steps add a single waveform file, to a Waveform 5–Pack license. Refer to Figure 8-42 on page 245.

2. There are two methods to save a waveform to the internal memory:

**NOTE** Before you can license a waveform with the Waveform 5–Pack licensing, the waveform must be saved in either the internal storage or the USB media.

a. Save the file to internal storage using the **Backup Waveform To Int Storage** softkey:

2. Press **Backup Waveform To Int Storage** (refer to Figure 8-41).

![Backup Waveform To Int Storage softkey](image)

For details on each key, use key help as described on page 42.

3. Go to step 3 (sub-step d).

b. If the waveform has *already* been stored in the signal generator using the **Backup Waveform to Int Storage** softkey then proceed to Step d.

1. Otherwise use the ARB Segments menu **Load** softkey to store the waveform to internal storage. Refer to “Working with Files” on page 62.
2. Proceed to Step 3 once you’ve stored the waveform to internal storage (internal media).

3. License the waveform:


The signal generator displays a catalog of files labeled: Catalog of BBG Segment Files in BBG Memory.

b. Use the arrow keys to highlight and select the file to be licensed.

c. Press **Add Waveform**.

A warning is displayed: *** Waveform Licensing Warning!!! ***. *If necessary, verify you have selected the correct waveform you want for licensing by pressing Return.* Otherwise continue to the next step (refer to Figure 8-42 on page 245).

d. Press **Confirm Adding Waveform to 5–Pack**.

The display returns to the Catalog of BBG Segment Files in BBG Memory and the file's Status column is now labeled 5–Pack Licensed (refer to Figure 8-42 on page 245).
e. Make a backup copy of this waveform on a USB media or a computer (If the waveform is lost or deleted on the signal generator it cannot be recovered).

**CAUTION**

It is important that a backup copy is made of any 5–Pack waveforms; the backup copy must be stored on a computer or other media. Do not store the backup copy on the signal generator. If all of the copies of the waveforms are deleted or lost, then there is no way to recover the waveform or reassign the license. Refer to “Working with Files” on page 62.
Figure 8-42  Add Waveform to 5–Pack Softkey

Mode > Dual ARB > More > Waveform Utilities > 5–Pack Licensing > Add Waveforms to 5–Pack

Important! Always backup licensed waveforms in a separate place from the instrument (e.g., computer, USB media, etc.).

If the waveform selected for licensing has been verified as the waveform you want to be licensed, press Confirm.

Adding Waveform To 5–Pack.
Caution! This step cannot be undone.

Status area for the waveform N7602B–WFM1 is empty and the Add Waveform softkey is active, indicating the waveform is licensable.

This warning message indicates that this is the last chance for verifying that the waveform being licensed is the one you want. If the waveform selected has not been verified, press Return and verify the selection.

For details on each key, use key help as described on page 42.

Important!
Always backup licensed waveforms in a separate place from the instrument (e.g., computer, USB media, etc.).

Caution! This step cannot be undone.

Note that N7602B-WFM1 has a Status of “5-Pack Licensed” and the Add Waveform softkey is no longer active.

Page 241

Page 242

Page 243
Using Waveform 5–Pack History

The Waveform 5–Pack History softkeys can be used to manage the Waveform 5–Pack files on your signal generator. The 5–Pack History softkeys can be used to:

- Create a list for a specific Waveform 5–Pack licensed waveform including any renamed files that have been leveraged from that licensed waveform
- Create a list of all licensed and unlicensed waveforms on the signal generator

Refer to Figure 8-43 on page 247, for a description of the Waveform 5–Pack History softkeys.

The 5–Pack History softkey is only active, if you have previously stored a Waveform 5–Pack file in non–volatile memory (internal storage, or USB media). But, the softkey 5–Pack History tracks the history of licensed waveform files that may no longer be available in non–volatile memory (e.g. if the waveform file has been deleted from internal storage or is located on a USB media that is not attached to the instrument, the 5–Pack History softkey remains active). 5–Pack History retains a catalog of the Redemption Date, Waveform ID, and the Original Filename.

**NOTE**

You can display either a catalog of the Internal storage or of the USB media but not both at the same time.

If you switch from the internal storage to the USB media, and the instrument displays an “Error -230, Data corrupt or stale” this is typically because a file (or files) was found with the same name, but the file is a different waveform file (has a different Waveform ID) than the original 5–Pack licensed internal storage file.
Figure 8-43 Waveform 5–Pack History Softkeys

Mode > Dual ARB > More > Waveform Utilities > 5–Pack Licensing > 5–Pack History

This area displays the date the waveform was licensed, the unique Waveform ID, and Original filename at the time the waveform was first redeemed.

Pressing this softkey searches for every copy of the highlighted waveform regardless of the current filename. If the search returns no results, then the original waveform has been deleted and cannot be found.

Displays the number of waveform licenses used and the number of total waveform license 'slots' available (e.g. For this example 3 of the 45 licenses have been used).

This screen displays all waveforms that are licensed by Option 22x.

Location is the memory location:
- Int Storage
- BBG Memory
- USB Media

Note:
1) In this example, the waveform N7602B_1_COPY3 is stored in the Int Storage and playing in the BBG Memory.
2) In this example, the Int Storage has been selected as the non–volatile storage location. To view any 5–Pack waveforms stored on the USB media, the USB media must be selected as the default storage. Refer to page 62.

When you press Find Waveform, any copies of the originally saved waveform are displayed on the instrument (e.g. N7602B_1_COPY1, N7602B_1_COPY2, and N7602B_1_COPY3). In this example, the original filename N7602B_1 was not found because the original file was deleted or the name was changed. But three copies were found N7602B_1_COPY1 was found in both the Int Storage and the BBG Memory).

For details on each key, use key help as described on page 42.
Example: Finding the History of a Waveform 5–Pack License

Use the following procedure to create a catalog of licensed Waveform 5–Pack files in the internal storage or USB media. Refer to Figure 8-44 on page 248, for the following procedure.

The following procedure generates a catalog for a Waveform 5–Pack file labeled: N7602B-WFM1.

1. On the signal generator:
   b. Use the arrow keys to highlight the cataloged file N7602B-WFM1.
   c. Press Find Waveform

The instrument displays a catalog titled “Waveform 5-Pack Search Results”. This catalog displays a list of all of the files that are copies of the original file that was licensed with the Waveform 5-Pack licensing, named N7602B-WFM1. For this example, the copies are currently in the BBG memory and the Internal storage and named N7602B-WFM1 and N7602B-WFM1_COPY (respectively). Refer to Figure 8-44 on page 248.

**NOTE** If no files are found, you can reload the backup copies that were made in Step e on page 244.

For details on each key, use key help as described on page 42.

Notice that the originally 5–Pack licensed waveform, N7602B-WFM1, has been changed to N7602B-WFM1_COPY and is saved in the Internal Storage and playing in the BBG Memory. If no waveforms are listed when Find Waveform is pressed, then the waveform cannot be found in BBG Memory, Internal Storage, or USB Media.
Finding All Waveforms Associated with 5-Pack Licenses

The following procedure displays a catalog of all of the Waveform 5-Pack files in the BBG memory and the internal storage:

1. On the signal generator:
   a. Press **Mode > Dual ARB > More > Waveform Utilities > 5-Pack Licensing > Find All Waveforms**

   The instrument displays a catalog titled: Waveform 5-Pack Search Results. Refer to Figure 8-45.

   **NOTE** If no files are found, you can reload the backup copies that were made in Step e on page 244.

---

**Figure 8-45** Using Waveform 5-Pack History “Find All Waveforms” Softkey

Mode > Dual ARB > More > Waveform Utilities > 5-Pack Licensing > 5-Pack History > Find All Waveforms
Waveform 5–Pack Warning Messages

Figure 8-46

This standard warning is displayed every time a waveform is selected to be licensed. This notification indicates that one of the available "license slot[s]" is about to be used from Option 22x.

Always make backup copies of waveforms in a separate non-volatile memory in case a file is deleted or lost from the instrument's

This warning is displayed when an attempt is made to license a waveform that has not been saved to internal storage or USB media (i.e., waveforms cannot be licensed unless they have been stored to non-volatile memory). Press the Backup Waveform To Int Storage softkey.

This warning is displayed when there is insufficient memory or other problems with the internal storage, or USB media (non-volatile memory) and the waveform could not be saved to non-volatile memory.

This warning is displayed when the file being licensed is not backed up in internal storage or the USB media (non-volatile memory), but there is a file already in the internal storage or USB media, with the same name.
9 Adding Real–Time Noise to a Signal (Option 403)

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available through the Web–Enabled MXG or SCPI commands. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator. If you are not comfortable with functions such as setting the power level and frequency, refer to Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that chapter.

This feature is available only in N5162A/82A Agilent MXG Vector Signal Generators with Option 431. Option 431 requires Option 651, 652, or 654.

This chapter contains examples of using the additive white gaussian noise (AWGN) waveform generator, which is available only in vector signal generators with Option 403.

- Adding Real–Time Noise to a Dual ARB Waveform on page 251
- Using Real Time I/Q Baseband AWGN on page 257

Adding Real–Time Noise to a Dual ARB Waveform

NOTE The procedures in this section that pertain specifically to adding Real–Time Noise (AWGN) to a waveform, are applicable to the Custom ARB, Multitone, and Two–Tone modulation standards too.

A vector signal generator with option 403 enables you to apply additive white gaussian noise (AWGN) to a carrier in real time while the modulating waveform plays in the dual ARB waveform player. This feature appears in each of the arb formats and as a stand–alone menu (Refer to Figure 9-7 on page 257).
Adding Real–Time Noise to a Signal (Option 403)
Adding Real–Time Noise to a Dual ARB Waveform

Figure 9-1 Real Time I/Q Baseband AWGN Softkeys

For details on each key, use key help as described on page 42.

Figure 9-6 on page 256 provides additional details on these settings.

Static graphic representation of ARB Real–Noise AWGN (i.e., graphic does not update as values change).

The relationship of the values are displayed in the static graphic of ARB Real–Time AWGN.

The Total Noise Power is the Noise Power over the occupied noise bandwidth (NBW * 1.25).

For the selected carrier to noise ratio, the bandwidth over which the noise is integrated. Typically, Carrier Bandwidth (CBW) is the occupied bandwidth of the carrier.

Flat Noise Bandwidth (NBW): The actual flat noise bandwidth (NBW), which should be slightly wider than the carrier bandwidth (typically 1.6 times wider). The occupied bandwidth is = (1.25 * the Flat Noise Bandwidth)

The Carrier Bit Rate softkey sets the carrier bit rate. (The default carrier bit rate is 1 bps.)

The Carrier Bit Rate softkey is only available when the Carrier to Noise Ratio Format Softkey is set to $E_b/N_0$. See also page 255.

For the selected carrier to noise ratio, the bandwidth over which the noise is integrated. Typically, Carrier Bandwidth (CBW) is the occupied bandwidth of the carrier.

Flat Noise Bandwidth (NBW): The actual flat noise bandwidth (NBW), which should be slightly wider than the carrier bandwidth (typically 1.6 times wider). The occupied bandwidth is = (1.25 * the Flat Noise Bandwidth)

The Carrier Bit Rate softkey sets the carrier bit rate. (The default carrier bit rate is 1 bps.)

The Carrier Bit Rate softkey is only available when the Carrier to Noise Ratio Format Softkey is set to $E_b/N_0$. See also page 255.
Adding Real-Time Noise to a Signal (Option 403)
Adding Real-Time Noise to a Dual ARB Waveform

Figure 9-2 Real Time I/Q Baseband AWGN - Power Control Mode Softkeys
Mode > Dual ARB > Arb Setup > Real-Time AWGN Setup

For details on each key, use key help as described on page 42.

Figure 9-6 on page 256 provides additional details on these settings.

Selecting Total as the power control mode makes the total power and C/N independent variables while making the carrier power and total noise power dependent variables. The dependent variables carrier power and total noise power are set by the total power, C/N, and the rest of the Noise settings. The carrier power and total noise power change as any noise parameter is adjusted to keep the total power and the C/N at their last specified values.

Selecting Carrier as the power control mode makes the carrier power and C/N independent variables while making the total power and total noise power dependent variables. The dependent variables total power and total noise power are set by the carrier power, C/N, and the rest of the Noise settings. The total power and total noise power change as any noise parameter is adjusted to keep the carrier power and the C/N at their last specified values.

Selecting Total Noise as the power control mode makes the total noise power and C/N independent variables while making the total power and carrier power dependent variables. The dependent variables total power and carrier power are set by the total noise power, C/N, and the rest of the Noise settings. The total power and carrier power change as any noise parameter is adjusted to keep the total noise power and the C/N at their last specified values.
Adding Real–Time Noise to a Signal (Option 403)
Adding Real–Time Noise to a Dual ARB Waveform

Figure 9-3  Real Time I/Q Baseband AWGN - Noise Mux Menu Softkeys
Mode > Dual ARB > Arb Setup >
Real-Time AWGN Setup > More

The Carrier Bit Rate softkey is only available when the Carrier to Noise softkey is set to $E_b/N_0$.

Enables diagnostic control of additive noise, so that only the noise, only the carrier, or the sum of both the noise and the carrier are output from the internal baseband generator. With the ALC off, this feature enables direct measurement of the carrier or the noise contributions independently from the total power. The system still behaves as if both the noise and the carrier are present on the output when it comes to determining the Auto Modulation Attenuation and the RMS level for RMS Power Search.

For details on each key, use key help as described on page 42.

Figure 9-6 on page 256 provides additional details on these settings.

$E_b/N_0$ Adjustment Softkeys for Real Time I/Q Baseband AWGN

This feature allows the AWGN C/N to be set using the $E_b/N_0$ (energy per bit over noise power density at the receiver or signal to noise ratio per bit) form. This requires the carrier bit rate to be known. Refer to Figure 9-4, “$E_b/N_0$ Carrier Bit Equation.”

Figure 9-4  $E_b/N_0$ Carrier Bit Equation

$$\frac{C}{N_{dB}} = \left(\frac{E_b}{N_0}\right)_{dB} + 10\log_{10}\left(\frac{\text{bitRate}}{\text{carrierBandwidth}}\right)$$
Adding Real–Time Noise to a Signal (Option 403)
Adding Real–Time Noise to a Dual ARB Waveform

Figure 9-5  Real Time I/O Baseband AWGN - $E_b/N_0$ Adjustment Softkeys
Mode > Dual ARB > Arb Setup > Real-Time AWGN Setup

Mode > Dual ARB > Arb Setup > Real-Time AWGN Setup

Figure 9-6 on page 256 provides additional details on these settings.

Selects either the Carrier to Noise Ratio (C/N) or energy per bit over noise power density at the receiver ($E_b/N_0$) as the variable controlling the ratio of the carrier power to noise power in the carrier bandwidth. When $E_b/N_0$ is selected, the second page of the AWGN Setup menu shows the Carrier Bit Rate softkey to enable the $E_b/N_0$ value to be calculated.

The active softkey changes with the Carrier to Noise Ratio Format selected (C/N or $E_b/N_0$). See below.

The Carrier Bit Rate softkey sets the carrier bit rate. (The default carrier bit rate is 1 bps.)

The Carrier Bit Rate softkey is only available when the Carrier to Noise Ratio Format softkey is set to $E_b/N_0$.

To view the carrier bit rate equation, refer to page 42.

Display remains grayed out until real-time AWGN is enabled.

$E_b/N_0$ is displayed when Carrier to Noise Ratio Format softkey is set to $E_b/N_0$.

The active softkey changes with the Carrier to Noise Ratio Format selected (C/N or $E_b/N_0$).

For details on each key, use key help as described on page 42.
Adding Real–Time Noise to a Signal (Option 403)
Adding Real–Time Noise to a Dual ARB Waveform

Figure 9-6 Carrier to Noise Ratio Components

**Example**

Use the following steps to modulate a 1 GHz, −10 dBm carrier with the factory–supplied waveform SINE_TEST_WFM, and then apply noise with a 45 MHz bandwidth signal that has a 30 dB carrier–to–noise ratio across a 40 MHz carrier bandwidth.

1. Preset the signal generator and set the following:
   - Frequency: 1 GHz
   - Amplitude: −10 dBm
   - RF output: on

2. Select the factory–supplied waveform SINE_TEST_WFM:
   a. Press **Mode > Dual ARB > Select Waveform**.
   b. Highlight SINE_TEST_WFM and press **Select Waveform**.

3. Turn on the dual ARB player: press **ARB Off On** to highlight On.

4. Set the ARB sample clock to 50 MHz: Press **ARB Setup > ARB Sample Clock > 50 > MHz**.

5. Press **Real–time Noise Setup** and set the following:
   - Carrier to Noise Ratio: 30 dB
   - Carrier Bandwidth: 40 MHz
   - Noise Bandwidth: 45 MHz
   - Real–time Noise: on

The signal generator’s displayed power level (−10 dBm) *includes* the noise power.
Using Real Time I/Q Baseband AWGN

Figure 9-7 Real Time I/Q Baseband AWGN Softkeys

Use the following steps to apply 10 MHz bandwidth noise to a 500 MHz, –10 dBm carrier.

1. Configure the noise:
   a. Preset the signal generator.
   b. Press **Mode > More > Real Time I/Q Baseband AWGN**
   c. Press **Bandwidth > 10 MHz**.

2. Generate the noise:
   Press **AWGN Off On** until On highlights.
   During generation, the AWGN and I/Q annunciators activate (as shown at right). AWGN is now available to modulate the RF carrier.

3. Configure the RF output:
   • Frequency: 500 MHz
   • Amplitude: –10 dBm
   • RF output: on
   The carrier with AWGN is now available at the signal generator’s RF OUTPUT connector.
Adding Real–Time Noise to a Signal (Option 403)
Using Real Time I/Q Baseband AWGN
10 Real–Time Phase Noise Impairments (Option 432)

NOTE  For the N5162A the softkey menus and features mentioned in this guide are only available through the Web–Enabled MXG or SCPI commands. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator. If you are not comfortable with functions such as setting the power level and frequency, refer to Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that chapter.

This feature is available only in N5162A/82A Agilent MXG Vector Signal Generators with Option 431. Option 431 requires Option 651, 652, or 654.

This chapter contains the softkey maps to locate the Phase Noise Impairment option functions and information on the use of this feature.

- Real–Time Phase Noise Impairment on page 260
- The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments on page 261
- Understanding the Phase Noise Adjustments on page 263
- DAC Over–Range Conditions and Scaling on page 264
Real–Time Phase Noise Impairment

This feature lets you degrade the phase noise performance of the signal generator by controlling two frequency points and an amplitude value. The signal generator adds this phase noise to the phase noise normally produced by the Agilent MXG. This feature appears in each of the arb formats and as a stand-alone menu. While the following figure shows how to access the controls using both the stand-alone menu and the Dual ARB player, the location and softkeys within each arb format is the same as for the Dual ARB player.

**Figure 10-1 Stand–Alone and Dual ARB Player Real–Time Phase Noise Softkeys**

For details on each key, use key help as described on page 42.

---

**NOTE:** The phase noise impairment is added to the base phase noise of the signal generator.

For an explanation on these settings see "The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments" on page 261.
The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments

Phase Noise Plots Without Phase Noise Impairment

The Agilent MXG demonstrates a definitive shape to its phase noise plot. The mid-frequency offsets are characterized by a leveling (flattening) of the phase noise amplitude from approximately a 3 kHz offset to approximately a 70 kHz offset. Close in and far out offsets demonstrate sloping characteristics (areas before and after the mid-frequency offsets).

The signal generator degrades the phase noise by moving the mid-frequency characteristics and/or changing its amplitude using the following settings:

- Start frequency (f1) of the mid-frequency characteristics
- Stop frequency (f2) of the mid-frequency characteristics
- Amplitude (Lmid) of the mid-frequency characteristics

This is a plot of the unmodified phase noise shape that shows the location that each value alters.
Real-Time Phase Noise Impairments (Option 432)
The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments

When turned on, this phase noise is added to the base phase noise of the signal generator.

Even though it is only the mid-frequency characteristics placement that are modified, these changes affect the entire phase noise shape. The close in and far out offset characteristics change by exhibiting approximately a 20 dBC/Hz slope for each octave of frequency offset.

The resultant phase noise plot shown on the left has the following settings:
- $f_1 = 100$ Hz
- $f_2 = 1$ kHz
- Amplitude ($L_{\text{mid}}$) = $-70$ dBC

Ensure that the $f_1$ value is less than or equal to $f_2$. If not, $f_2$ changes its value to match $f_1$. Conversely if $f_2$ is set to a value that is less than $f_1$, $f_1$ changes its value to match $f_2$.

The frequency values entered for the impairments may not be the exact values when viewed on the RF output. The entered values are guidelines that the signal generator uses to calculate the real values. See “Understanding the Phase Noise Adjustments” on page 263 for more information.

To view the results of the settings ($f_1$, $f_2$, and $L_{\text{mid}}$), use the front panel graph (below and on page 260) or view the phase noise plot on a measurement instrument (shown above—Agilent E4440A PSA with Option 226).

Signal generator front panel plot:
- $f_1 = 100$ Hz
- $f_2 = 1$ kHz
- $L_{\text{mid}} = -70$ dBC
Understanding the Phase Noise Adjustments

The signal generator bases the resultant phase noise shape on three settings, Lmid (amplitude), f1 (start frequency), and f2 (stop frequency).

The range for Lmid is coupled to f2, so as f2 increases in value, Lmid’s upper boundary decreases. If the current Lmid setting is too high for the new f2 setting, the signal generator changes the Lmid value and generates an error to alert you to the change. In addition, the actual Lmid value can vary by 0.28 dBc/Hz from the entered value.

The frequency settings (f1 and f2) are really guidelines that the signal generator uses to calculate the real frequency offset values seen on the RF OUTPUT. This means that the entered start and stop frequency values are an approximation and may not be the values seen on a measurement instrument, however they will be close.

The effects of the f1 and f2 parameters are based on a varying logarithmic scale. This scale is determined by the f2 value. The higher the f2 value the larger the scale, which makes this behavior more noticeable at higher frequency settings. This becomes apparent when a change in the f1 or f2 value causes little to no change in the f1 or f2 position. This is easy to view using the signal generator’s front panel phase noise graph and demonstrated in Figure 10-2. This behavior makes the frequency adjustments coarser as the f2 frequency value increases.

Figure 10-2 f1 and f2 Frequency Setting Behavior

The only way to make an accurate determination of the effect of the f1 and f2 values is by viewing the front panel graph or making a measurement. You can view the front panel graph remotely by using the LXI interface. For more information on the LXI interface, see the Programming Guide.

For details on each key, use key help as described on page 42.
DAC Over–Range Conditions and Scaling

When using phase noise impairment, it is possible to create a DAC over–range condition, which causes the Agilent MXG to generate an error. To minimize this condition with the phase noise impairment feature, the Agilent MXG incorporates an automatic DAC over–range protection feature that scales down the I/Q data. Because it can scale the data by more than what is actually need, it typically decreases the dynamic range of the waveform. This is especially noticeable when using a constant amplitude signal such as GSM.

For the Dual ARB Player, the automatic over–range protection can be turned off (on is the factory default). The control for the Dual ARB DAC over–range protection feature is located in the key path as shown in Figure 10–3.

![Figure 10-3 Dual ARB DAC Over–Range Protection Softkey Location](image)

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the over–range protection off and use the **Waveform Runtime Scaling** softkey to eliminate DAC over–range conditions.

When the automatic feature is disabled, the other options to eliminate a DAC over–range condition are to reduce the f2 value, or the Lmid value, or both until the condition corrects itself.
11 Custom Digital Modulation (Option 431)

NOTE For the N5162A, the softkey menus and features mentioned in this guide are only available through the Web-Enabled MXG or SCPI commands. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator. If you are not comfortable with functions such as setting the power level and frequency, refer to Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that chapter.

This feature is available only in N5162A/82A Agilent MXG Vector Signal Generators with Option 431. Option 431 requires Option 651, 652, or 654.

- Custom Modulation on page 266
- Using the Arbitrary Waveform Generator on page 271
- Using Finite Impulse Response (FIR) Filters in ARB Custom Modulation on page 281
- Modifying a FIR Filter Using the FIR Table Editor on page 286
- Differential Encoding on page 289
Custom Modulation

Custom Modulation has built-in modulation standards such as TETRA and DECT; and pre-defined modulation types such as BPSK and 16QAM that can be used to create a signal in addition, it provides the flexibility to modify the digital format's attributes.

ARB Custom Modulation Waveform Generator

The signal generator's ARB Waveform Generator mode is designed for out-of-channel test applications. This mode can be used to generate data formats that simulate random communication traffic and can be used as a stimulus for component testing. Other capabilities of the ARB Waveform Generator mode include:

• configuring single or multicarrier signals. Up to 100 carriers can be configured.
• creating waveform files using the signal generator's front panel interface.

The waveform files, when created as random data, can be used as a stimulus for component testing where device performance such as adjacent channel power (ACP) can be measured. The AUTOGEN_WAVEFORM file, that is automatically created when you turn the ARB Waveform Generator on, can be renamed and stored in the signal generator's non-volatile memory. This file can later be loaded into volatile memory and played using the dual ARB waveform player.

For more information, refer to “Waveform File Basics” on page 142 and “Modes of Operation” on page 4.
Figure 11-1  ARB Custom Modulation Softkeys

This softkey changes, depending on the selected mode of modulation.

Available only when Multicarrier is On.

Available only when Multicarrier is Off.

For details on each key, use key help as described on page 42.
Custom Digital Modulation (Option 431)
Custom Modulation

Figure 11-2 Quick Setup Softkeys

Mode > ARB Custom Modulation > Single Carrier Setup

This softkey label shows the currently selected modulation standard.

Press Symbol Rate softkey and use numeric keypad to change value as required.
The default (initial) Symbol Rate maximum range value is dependent upon the modulation standard selected with the Quick Setup softkey.

When one of these pre-defined modulation standards is selected, default values for components of the setup (including filter, symbol rate, and modulation type) are automatically specified.

For details on each key, use key help as described on page 42.

Default: This softkey selects the following default settings:
- Modulation Type = QPSK,
- Symbol Rate = 1 Msps,
- Filter = Root Nyquist, and
- Filter Alpha = 0.5
Figure 11-3 Mode Type Softkeys

Mode Setup

- Quick Setup (Defaults)
- Modulation Type
- Filter
- Symbol Rate 1.000 MHz
- Store Custom Dig Mod States

Mode Type

- Select (OFDM)
- Define User I/Q
- Define User FSK

ARB Custom Modulation

- Single Carrier Setup

Sets the modulation depth for the Amplitude Shift Keying (ASK).

Sets the symmetric Frequency Shift Keying (FSK) frequency deviation value.

For details on each key, use key help as described on page 42.
Custom Digital Modulation (Option 431)
Custom Modulation

Figure 11-4 Store Custom Dig Mod State Softkeys
Mode > ARB Custom Modulation > Single Carrier Setup > Store Custom Dig Mod State

Catalog displays digital modulation (DMOD) files that have been previously saved.

For details on each key, use key help as described on page 42.
Using the Arbitrary Waveform Generator

This section teaches you how to build dual arbitrary (ARB) waveform files containing custom TDMA, digital modulation for testing component designs.

Figure 11-5 Adding Custom Modulation to a Waveform

Using Predefined Custom TDMA Digital Modulation

This section teaches you how to perform the following tasks:

- Selecting a Predefined EDGE Setup on page 271
- Generating the Waveform on page 271
- Configuring the RF Output on page 272

Selecting a Predefined EDGE Setup

1. Press Preset.
2. In the ARB Custom Modulation menu (page 271), press Single Carrier Setup > Quick Setup > EDGE.

Generating the Waveform

Press Digital Modulation Off On.

This generates a waveform with the pre–defined EDGE state selected in the step. The display changes to Dig Mod Setup: EDGE. During waveform generation, the DIGMOD and I/Q annunciators appear and the pre–defined digital modulation state is stored in volatile memory (BBG). The waveform is now modulating the RF carrier.
Configuring the RF Output

1. Set the RF output frequency to 891 MHz.
2. Set the output amplitude to −5 dBm.

The predefined EDGE signal is now available at the signal generator’s RF OUTPUT connector.
Creating a Custom TDMA Digital Modulation State

In this procedure, you learn how to set up a single-carrier NADC digital modulation with customized modulation type, symbol rate, and filtering.

**Figure 11-6 Setting a Digital Modulation Filter**

Mode > ARB Custom Modulation > Single Carrier Setup

This softkey label updates to reflect the current modulation standard.

This softkey sets the filter bandwidth parameter, alpha. The default Alpha value changes with the modulation standard (see page 281) and modulation type selected (see page 269).

This softkey sets the filter shape.

Opens a menu where the user-defined I/Q constellations or user-defined FSK frequency mappings can be inserted into a table and then applied to the current modulation type. Also, for both I/Q and FSK, differential state mapping can be specified.

For details on each key, use key help as described on page 42.
This section teaches you how to perform the following tasks:

- **Selecting a Digital Modulation Setup** on page 274
- **Configuring the RF Output** on page 272
- **Selecting the Filter** on page 275
- **Configuring the RF Output** on page 272

### Selecting a Digital Modulation Setup

1. Press **Preset**.

2. In the ARB Custom Modulation menu (page 273), press **Single Carrier Setup > Quick Setup > NADC**.

### Modifying the Modulation Type and Symbol Rate

1. In the ARB Custom Modulation menu (page 273), press **Single Carrier Setup > Modulation Type > Select > PSK > QPSK and OQPSK > QPSK**.

2. Press **Return > Symbol Rate > 56 > kbps**.
Selecting the Filter
1. In the Setup Mod menu (page 273), press Filter > Select > Nyquist.
2. Press Return > Return.

Generating the Waveform
Press Digital Modulation Off On.

This generates a waveform with the custom, single-carrier NADC, digital modulation state created in the previous sections. The display changes to Dig Mod Setup: NADC (Modified). During waveform generation, the DIGMOD and I/Q annunciators appear and the custom single-carrier digital modulation state is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom, single-carrier NADC, digital modulation state to the non-volatile memory catalog, see Storing a Custom TDMA Digital Modulation State on page 275.

Configuring the RF Output
1. Set the RF output frequency to 835 MHz.
2. Set the output amplitude to 0 dBm.

The user-defined NADC signal is now available at the RF OUTPUT connector.

Storing a Custom TDMA Digital Modulation State

Using this procedure, you learn how to store a custom digital modulation state and a custom multicarrier digital modulation state to non-volatile memory.

If you have not created a custom, single-carrier, digital modulation state, complete the steps in the previous section, Creating a Custom TDMA Digital Modulation State on page 273.
Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Figure 11-8 Storing a Custom Digital Modulation State

1. Return to the top-level ARB Custom Modulation menu, where Digital Modulation Off On is the first softkey.

2. In the ARB Custom Modulation menu (page 276), press Single Carrier Setup > Store Custom Dig Mod State > Store To File.

   If there is already a file name from the Catalog of DMOD Files occupying the active entry area, press the following key: Clear Text

3. Enter a file name (for example, NADCQPSK) using the alpha keys and the numeric keypad with a maximum length of 23 characters.

4. Press Enter.

The user-defined, single-carrier, digital modulation state is now stored in non-volatile memory.

**NOTE** The RF output amplitude, frequency, and operating state settings are not stored as part of a user-defined, digital modulation state file.
Recalling a Custom TDMA Digital Modulation State

Using this procedure, you will learn how to recall a custom digital modulation state from signal non–volatile memory.

If you have not created and stored a user-defined, single–carrier, digital modulation state, complete the steps in the previous sections, Creating a Custom TDMA Digital Modulation State on page 273 and Storing a Custom TDMA Digital Modulation State on page 275, then preset the signal generator to clear the stored user–defined, digital modulation waveform from volatile ARB memory.

Figure 11-9 Recalling a Custom TDMA Digital Modulation State

1. In the Quick Setup menu, press Custom Digital Mod State.
2. Highlight the desired file (for example, NADCQPSK).
3. Press Select File > Return.
4. Press Digital Modulation Off On until On is highlighted.

The instrument regenerates the custom, digital modulation waveform in volatile memory. After waveform generation, the custom, digital modulation waveform is available to be modulated on the RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 272.
Creating a Custom Multicarrier TDMA Digital Modulation State

In this procedure, you learn how to customize a predefined, multicarrier, digital modulation setup by creating a custom, 3–carrier EDGE, digital modulation state.

This section teaches you how to perform the following tasks:
- Creating a Multicarrier Digital Modulation Setup on page 279
- Modifying Carrier Frequency Offset on page 279
- Modifying Carrier Power on page 279
- Generating the Waveform on page 279
- Configuring the RF Output on page 279

Figure 11-10 Creating a Multicarrier Digital Modulation Setup

For details on each key, use key help as described on page 42.
Creating a Multicarrier Digital Modulation Setup
1. Press Preset.
3. Press Multicarrier Setup > Select Carrier and Initialize Table > Carrier Setup > EDGE > Done.

Modifying Carrier Frequency Offset
1. Highlight the Freq Offset value (500.000 kHz) for the carrier in row 2.
2. Press −625 kHz.

Modifying Carrier Power
1. Highlight the Power value (0.00 dB) for the carrier in row 2.
2. Press −10 dB.

You now have a custom 2-carrier EDGE waveform with a carrier at a frequency offset of −625 kHz and a power level of −10.00 dBm, as shown in the following figure.

Generating the Waveform
This generates a waveform with the custom, multicarrier, EDGE state created in the previous sections. The display changes to Dig Mod Setup: Multicarrier (Modified). During waveform generation, the DIGMOD and I/Q annunciators appear and the new custom, multicarrier, EDGE state is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom, multicarrier, EDGE state to non-volatile memory, see “Storing a Custom Multicarrier TDMA Digital Modulation State” on page 280.

Configuring the RF Output
1. Set the RF output frequency to 890.01 MHz.
2. Set the output amplitude to −10 dBm.

The custom multicarrier EDGE signal is now available at the RF OUTPUT connector.
Storing a Custom Multicarrier TDMA Digital Modulation State

Using this procedure, you learn how to store a custom, multicarrier, TDMA, digital modulation state to non–volatile memory.

If you have not created a custom, multicarrier, digital modulation state, complete the steps in the previous section, “Creating a Custom Multicarrier TDMA Digital Modulation State” on page 278.

Figure 11-11 Storing a Custom Multicarrier Softkeys

1. Return to the top–level Digital Modulation menu, where Digital Modulation Off On is the first softkey.


   If there is already a file name from the Catalog of MDMOD Files occupying the active entry area, press the following key: Clear Text

3. Enter a file name (for example, EDGEM1) using the alpha keys and the numeric keypad with a maximum length of 23 characters.

4. Press Enter.

   The user–defined, multicarrier, digital modulation state is now stored in non–volatile memory.

---

NOTE  The RF output amplitude, frequency, and operating state settings are not stored as part of a user–defined, digital modulation state file.

---

Applying Changes to an Active Multicarrier TDMA Digital Modulation State

If the digital modulation format is currently in use (Digital Modulation Off On set to On) while changes are made in the Multicarrier Setup table editor, you must apply the changes before the updated waveform will be generated.

From the Multicarrier Setup table editor, press Apply Multicarrier to apply the changes and generate a new custom multicarrier digital modulation waveform based on the updated values.
Using Finite Impulse Response (FIR) Filters in ARB Custom Modulation

Finite Impulse Response filters can be used to refine the transitions between symbol decision points of the generated waveforms.

Figure 11-12 Filter Menu
Mode > ARB Custom Modulation > Single Carrier Setup > Filter

Creating a User–Defined FIR Filter Using the FIR Table Editor

In this procedure, you use the FIR Values table editor to create and store an 8–symbol, windowed sync function filter with an oversample ratio of 4.

1. Press Preset.
3. Press Filter > Define User FIR.
4. Press More 1 of 2 > Delete All Rows > Confirm Delete of All Rows.

This will initialize the table editor as shown in Figure 11-13.
Entering the Coefficient Values

1. Press the Return softkey to get to the first page of the table editor.
2. Use the cursor to highlight the Value field for coefficient 0.
3. Use the numeric keypad to type the first value (−0.000076) from Table 11-1. As you press the numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you can correct it using the backspace key.)
4. Continue entering the coefficient values from the table in step 1 until all 16 values have been entered.

Table 11-1

<table>
<thead>
<tr>
<th>Coefficient</th>
<th>Value</th>
<th>Coefficient</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>−0.000076</td>
<td>8</td>
<td>−0.035667</td>
</tr>
<tr>
<td>1</td>
<td>−0.001747</td>
<td>9</td>
<td>−0.116753</td>
</tr>
<tr>
<td>2</td>
<td>−0.005144</td>
<td>10</td>
<td>−0.157348</td>
</tr>
</tbody>
</table>

**Note:**
Modulation filters are typically real and have an oversample ratio (OSR) of two or greater. Equalization filters are typically complex and have an oversample ratio (OSR) of one (Dual ARB only).
<table>
<thead>
<tr>
<th>Coefficient</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>−0.004424</td>
</tr>
<tr>
<td>4</td>
<td>0.007745</td>
</tr>
<tr>
<td>5</td>
<td>0.029610</td>
</tr>
<tr>
<td>6</td>
<td>0.043940</td>
</tr>
<tr>
<td>7</td>
<td>0.025852</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Coefficient</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>−0.088484</td>
</tr>
<tr>
<td>12</td>
<td>0.123414</td>
</tr>
<tr>
<td>13</td>
<td>0.442748</td>
</tr>
<tr>
<td>14</td>
<td>0.767329</td>
</tr>
<tr>
<td>15</td>
<td>0.972149</td>
</tr>
</tbody>
</table>
Duplicating the First 16 Coefficients Using Mirror Table

In a windowed sinc function filter, the second half of the coefficients are identical to the first half in reverse order. The signal generator provides a mirror table function that automatically duplicates the existing coefficient values in the reverse order.

1. Press Mirror Table. The last 16 coefficients (16 through 31) are automatically generated and the first of these coefficients (number 16) highlights, as shown in Figure 11-14 on page 284.

Figure 11-14

Setting the Oversample Ratio

NOTE Modulation filters must be real and have an oversample ratio (OSR) of two or greater.

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range from 1 through 32; the maximum combination of symbols and oversampling ratio allowed by the table editor is 1024. The instrument hardware, however, is actually limited to 32 symbols, an oversample ratio between 4 and 16, and 512 coefficients. So if you enter more than 32 symbols or 512 coefficients, the instrument is unable to use the filter. If the oversample ratio is different from the internal, optimally selected one, then the filter is automatically resampled to an optimal oversample ratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

Displaying a Graphical Representation of the Filter

The signal generator has the capability of graphically displaying the filter in both time and frequency dimensions.

1. Press More 1 of 2 > Display FFT (fast Fourier transform).
   Refer to Figure 11-15 on page 285.
Using Finite Impulse Response (FIR) Filters in ARB Custom Modulation

2. Press **Return**.

3. Press **Display Impulse Response**.
   
   Refer to **Figure 11-16**.

4. Press **Return** to return to the menu keys.

**Storing the Filter to Memory**

Use the following steps to store the file.

1. Press **Load/Store > Store To File**. The catalog of FIR files appears along with the amount of memory available.

2. As described in **Storing, Loading, and Playing a Waveform Segment** on page 144, name and store this file as **FIR_1**.

The **FIR_1** file is the first file name listed. (If you have previously stored other FIR files, additional file names are listed below **FIR_1**.) The file type is FIR and the size of the file is 260 bytes. The amount of memory used is also displayed. The number of files that can be saved depends on the size of the files and the amount of memory used. Refer to **Figure 11-17**.
Memory is also shared by instrument state files and list sweep files.

This filter can now be used to customize a modulation format or it can be used as a basis for a new filter design.

**Modifying a FIR Filter Using the FIR Table Editor**

FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You can load the FIR table editor with coefficient values from user–defined FIR files stored in non–volatile memory or from one of the default FIR filters. Then you can modify the values and store the new files.
Loading the Default Gaussian FIR File

Figure 11-18 Loading the Default Gaussian FIR File
Mode > ARB Custom Modulation > Single Carrier Setup

1. Press **Preset**.
2. Press **Mode** > **ARB Custom Modulation** > **Single Carrier Setup** > **Quick Setup** > **NADC**.
3. Press **Filter** > **Define User FIR** > **More 1 of 2** > **Load Default FIR** > **Gaussian**.
4. Press **Filter BbT** > **0.300** > **Enter**.

For details on each key, use key help as described on page 42.
5. Press **Filter Symbols > 8 > Enter**.
6. Press **Generate**.

**NOTE** The actual oversample ratio during modulation is automatically selected by the instrument. A value between 4 and 16 is chosen dependent on the symbol rate, the number of bits per symbol of the modulation type, and the number of symbols.

7. Press **Display Impulse Response** (refer to Figure 11-19).

![Figure 11-19](image)

For details on each key, use key help as described on page 42.

8. Press **Return**.

**Modifying the Coefficients**

1. Using the front panel arrow keys, highlight coefficient 15.
2. Press **0 > Enter**.
3. Press **Display Impulse Response**.

![Figure 11-20](image)

For details on each key, use key help as described on page 42.
Custom Digital Modulation (Option 431)

Differential Encoding

Refer to Figure 11-20 on page 288. The graphic display can provide a useful troubleshooting tool (in this case, it indicates that a coefficient value is missing, resulting in an improper Gaussian response).

4. Press Return.
5. Highlight coefficient 15.
6. Press 1 > Enter.

Storing the Filter to Memory

The maximum file name length is 23 characters (alphanumeric and special characters).

1. Press Load/Store > Store To File.
2. Name the file NEWFIR2.
3. Press Enter.

The contents of the current FIR table editor are stored to a file in non–volatile memory and the catalog of FIR files is updated to show the new file.

Differential Encoding

Differential encoding is a digital–encoding technique whereby a binary value is denoted by a signal change rather than a particular signal state. Using differential encoding, binary data in any user–defined I/Q or FSK modulation can be encoded during the modulation process via symbol table offsets defined in the Differential State Map.

For example, consider the signal generator’s default 4QAM I/Q modulation. With a user–defined modulation based on the default 4QAM template, the I/Q Values table editor contains data that represent four symbols (00, 01, 10, and 11) mapped into the I/Q plane using two distinct values, 1.000000 and -1.000000. The following illustration shows the 4QAM modulation in the I/Q Values table editor.
The following illustration shows a 4QAM modulation I/Q State Map.

Differential encoding employs relative offsets between the states in the symbol table to encode user-defined modulation schemes. The Differential State Map table editor is used to introduce symbol table offset values which in turn cause transitions through the I/Q State Map based on their associated data value. Whenever a data value is modulated, the offset value stored in the Differential State Map is used to encode the data by transitioning through the I/Q State Map in a direction and distance defined by the symbol table offset value.

Entering a value of +1 will cause a 1-state forward transition through the I/Q State Map, as shown in the following illustration.

NOTE
The following I/Q State Map illustrations show all of the possible state transitions using a particular symbol table offset value. The actual state-to-state transition would depend upon the state in which the modulation had started.

As an example, consider the following data/symbol table offset values.

Table 11-2

<table>
<thead>
<tr>
<th>Data</th>
<th>Offset Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>00000000</td>
<td>+1</td>
</tr>
<tr>
<td>00000001</td>
<td>−1</td>
</tr>
</tbody>
</table>
Custom Digital Modulation (Option 431)
Differential Encoding

NOTE

The number of bits per symbol can be expressed using the following formula. Because the equation is a ceiling function, if the value of $x$ contains a fraction, $x$ is rounded up to the next whole number.

$$x = \lceil \log_2(y) \rceil$$

Where $x = \text{bits per symbol}$, and $y = \text{the number of differential states.}$

<table>
<thead>
<tr>
<th>Data</th>
<th>Offset Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>00000010</td>
<td>+2</td>
</tr>
<tr>
<td>00000011</td>
<td>0</td>
</tr>
</tbody>
</table>

Table 11-2
These symbol table offsets will result in one of the transitions, as shown.

When applied to the user-defined default 4QAM I/Q map, starting from the 1st symbol (data 00), the differential encoding transitions for the data stream (in 2-bit symbols) 0011100001 appear in the following illustration.
As you can see from the previous illustration, the 1st and 4th symbols, having the same data value (00), produce the same state transition (forward 1 state). In differential encoding, symbol values do not define location; they define the direction and distance of a transition through the I/Q State Map.

Using Differential Encoding

The signal generator’s Differential State Map table editor enables you to modify the differential state map associated with user–defined I/Q and user–defined FSK modulations. In this procedure, you create a user–defined I/Q modulation and then configure, activate, and apply differential encoding to the user–defined modulation. For more information, see “Differential Encoding” on page 289.

Configuring User–Defined I/Q Modulation

1. Press Preset.
2. Perform the following keypress sequence required for your format type.

For Custom Format

Press Mode > ARB Custom Modulation > Single Carrier Setup > Modulation Type > Define User I/Q > More 1 of 2 > Load Default I/Q Map > QAM > 4QAM
For TMDA Formats
Press Mode > ARB Custom Modulation > Single Carrier Setup > Quick Setup (desired format) > Modulation Type > Define User I/Q > More 1 of 2 > Load Default I/Q Map > QAM > 4QAM

This loads a default 4QAM I/Q modulation and displays it in the I/Q table editor.

The default 4QAM I/Q modulation contains data that represent 4 symbols (00, 01, 10, and 11) mapped into the I/Q plane using 2 distinct values (1.000000 and −1.000000). These 4 symbols will be traversed during the modulation process by the symbol table offset values associated with each symbol of data. Refer to Figure 11-21.

Figure 11-21

Accessing the Differential State Map Table Editor
Press Configure Differential Encoding.

This opens the Differential State Map table editor, as shown. At this point, you see the data for the 1st symbol (00000000) and the cursor prepared to accept an offset value. You are now prepared to create a custom differential encoding for the user-defined default 4QAM I/Q modulation. Refer to Figure 11-22 on page 294.

Figure 11-22
Editing the Differential State Map

1. Press 1 > Enter.
   
   This encodes the first symbol by adding a symbol table offset of 1. The symbol rotates \textit{forward} through the state map by 1 value when a data value of 0 is modulated.

2. Press +/– > 1 > Enter.
   
   This encodes the second symbol by adding a symbol table offset of –1. The symbol rotates \textit{backward} through the state map by 1 value when a data value of 1 is modulated.

\textbf{NOTE} At this point, the modulation has one bit per symbol. For the first two data values (00000000 and 00000001) only the last bits (the 0 and the 1, respectively) are significant.

3. Press 2 > Enter.
   
   This encodes the third symbol by adding a symbol table offset of 2. The symbol rotates \textit{forward} through the state map by 2 values when a data value of 10 is modulated.

4. Press 0 > Enter.
   
   This encodes the fourth symbol by adding a symbol table offset of 0. The symbol does \textit{not} rotate through the state map when a data value of 11 is modulated.

\textbf{NOTE} At this point, the modulation has two bits per symbol. For the data values 00000000, 00000001, 00000010, 00000011, the symbol values are 00, 01, 10, and 11 respectively.

Applying Custom Differential Encoding

Press Return > Differential Encoding Off On.

This applies the custom differential encoding to a user–defined modulation.

\textbf{NOTE} Notice that (UNSTORED) appears next to Differential State Map on the signal generator’s display. Differential state maps are associated with the user–defined modulation for which they were created.

In order to save a custom differential state map, you must store the user–defined modulation for which it was designed. Otherwise the symbol table offset data is purged when you press the \textbf{Confirm Exit From Table Without Saving} softkey when exiting from the I/Q or FSK table editor.
Custom Digital Modulation (Option 431)
Differential Encoding
12 Multitone and Two–Tone Waveforms (Option 430)

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available through the Web–Enabled MXG or SCPI commands. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator. If you are not comfortable with functions such as setting the power level and frequency, refer to Basic Operation on page 41 and familiarize yourself with the information in that chapter.

This feature is available only in N5162A/82A Agilent MXG Vector Signal Generators with Option 430. Option 430 requires Option 651, 652, or 654.

Creating a Custom Two–Tone Waveform

Using the Two–Tone menu, you can define, and modify user–defined Two–Tone waveforms. Two–Tone waveforms are generated by the dual arbitrary waveform generator.

The section Using Two–Tone Modulation on page 298 teaches you how to perform the following tasks:

• Creating a Two–Tone Waveform on page 299
• Viewing a Two–Tone Waveform on page 300
• Minimizing Carrier Feedthrough on page 301
• Changing the Alignment of a Two–Tone Waveform on page 302

Creating a Custom Multitone Waveform

Using the Multitone Setup table editor, you can define, modify and store user–defined multitone waveforms. Multitone waveforms are generated by the dual arbitrary waveform generator.

The Using Multitone Modulation on page 304 teaches you how to perform the following tasks:

• Initializing the Multitone Setup Table Editor on page 304
• Configuring Tone Powers and Tone Phases on page 305
• Removing a Tone on page 305
• Generating the Waveform on page 305
• Configuring the RF Output on page 306
Using Two–Tone Modulation

In the following sections, this chapter describes the two–tone mode, which is available only in N5162A/82A Agilent MXG Vector signal generators with Option 430:

- Creating a Two–Tone Waveform on page 299
- Viewing a Two–Tone Waveform on page 300
- Minimizing Carrier Feedthrough on page 301
- Changing the Alignment of a Two–Tone Waveform on page 302

See also: Saving a Waveform’s Settings & Parameters on page 151

NOTE For more information about two–tone waveform characteristics, and the two–tone standard, download Application Note 1410 from our website by going to http://www.agilent.com and searching for “AN 1410” in Test & Measurement.
Creating a Two–Tone Waveform

This procedure describes how to create a basic, centered, two–tone waveform.

1. Preset the signal generator.
2. Set the signal generator RF output frequency to 6 GHz.
3. Set the signal generator RF output amplitude to –10 dBm.
4. Press Mode > Two–Tone > Freq Separation > 10 MHz.
5. Press Two Tone Off On to On.
6. Turn on the RF output.

The two–tone signal is now available at the signal generator RF OUTPUT connector. Figure 12-1 on page 300 shows what the signal generator display should look like after all steps have been completed. Notice that the T–TONE, I/Q, annunciators are displayed; the RF ON, MOD ON are on; and the parameter settings for the signal are shown in the status area of the signal generator display.
Viewing a Two–Tone Waveform

This procedure describes how to configure the spectrum analyzer to view a two–tone waveform and its IMD products. Actual key presses will vary, depending on the model of spectrum analyzer you are using.

1. Preset the spectrum analyzer.
2. Set the carrier frequency to 6 GHz.
3. Set the frequency span to 60 MHz.
4. Set the amplitude for a 10 dB scale with a –10 dBm reference.
5. Adjust the resolution bandwidth to sufficiently reduce the noise floor to expose the IMD products. A 9.1 kHz setting was used in our example.
6. Turn on the peak detector.
7. Set the attenuation to 4 dB, so you’re not overdriving the input mixer on the spectrum analyzer.

You should now see a two–tone waveform with a 6 GHz center carrier frequency that is similar to the one shown in Figure 12-2 on page 301. You will also see IMD products at 10 MHz intervals above and below the generated tones, and a carrier feedthrough spike at the center frequency with carrier feedthrough distortion products at 10 MHz intervals above and below the center carrier frequency.
Minimizing Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power between the tones and their intermodulation distortion products. Before beginning this procedure, it is important that a recent I/Q calibration has been performed on the instrument. The procedure for performing an I/Q calibration (refer to “I/Q Calibration” on page 205).

This procedure builds upon the previous procedure.

1. On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about 100 to 200 ms. This will allow you to dynamically view the carrier feedthrough spike as you make adjustments.

2. On the signal generator, press I/Q > I/Q Adjustments > I/Q Adjustments Off On to On.

3. Press Internal Baseband Adjustments > I Offset and turn the rotary knob while observing the carrier feedthrough with the spectrum analyzer. Changing the I offset in the proper direction will reduce the feedthrough level. Adjust the level as low as possible.

4. Press Q Offset and turn the rotary knob to further reduce the carrier feedthrough level.

5. Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.

6. On the spectrum analyzer, return the resolution bandwidth to its previous setting.

7. Turn on waveform averaging.
8. Create a marker and place it on the peak of one of the two tones.

9. Create a delta marker and place it on the peak of the adjacent intermodulation product, which should be spaced 10 MHz from the marked tone.

10. Measure the power difference between the tone and its distortion product.

You should now see a display that is similar to the one shown in Figure 12-3 on page 302. Your optimized two-tone signal can now be used to measure the IMD products generated by a device-under-test.

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to periodically readjust your I and Q offsets to keep your signal optimized.

**Figure 12-3**

Changing the Alignment of a Two–Tone Waveform

This procedure describes how to align a two–tone waveform left or right, relative to the center carrier frequency. Because the frequency of one of the tones is the same as the carrier frequency, this alignment typically hides any carrier feedthrough. However, image frequency interference caused by left or right alignment may cause minor distortion of the two–tone signal. This procedure builds upon the previous procedure.

1. On the signal generator, press **Mode > Two Tone > Alignment Left Cent Right** to Left.

2. Press **Apply Settings** to regenerate the waveform.
NOTE Whenever a change is made to a setting while the two–tone generator is operating (Two Tone Off On set to On), you must apply the change by pressing the Apply Settings softkey before the updated waveform will be generated. When you apply a change, the baseband generator creates a two–tone waveform using the new settings and replaces the existing waveform in ARB memory.

3. On the spectrum analyzer, temporarily turn off waveform averaging to refresh your view more quickly. You should now see a left–aligned two–tone waveform that is similar to the one shown in Figure 12–4.

Figure 12–4

For details on each key, use key help as described on page 42.
Using Multitone Modulation

Multitone Modulation Softkeys

Initializing the Multitone Setup Table Editor

1. Press **Preset**.
2. Press **Mode > Multitone**
3. Press **Initialize Table > Number of Tones > 5 > Enter**.
4. Press **Freq Spacing > 20 > kHz**.

Exceptions:
- No Waveform Runtime Scaling softkey,
- No Multi-BBG Sync Setup softkey, and
- No DAC Over-Range Protection softkey

For details on each key, use key help as described on page 42.
5. Press **Done**.

You now have a multitone setup with five tones spaced 20 kHz apart. The center tone is placed at the carrier frequency, while the other four tones are spaced in 20 kHz increments from the center tone.

**Configuring Tone Powers and Tone Phases**

1. Highlight the value (0 dB) in the **Power** column for the tone in row 2.
2. Press **Edit Table > Edit Item > -4.5 > dB**.
3. Highlight the value (0) in the **Phase** column for the tone in row 2.
4. Press **Edit Item > 123 > deg**.

**Removing a Tone**

1. Highlight the value (**On**) in the **State** column for the tone in row 4.
2. Press **Toggle State**.

**Generating the Waveform**

Press **Return > Multitone Off On** until **On** is highlighted.

This generates the multitone waveform with the parameters defined in the previous sections. During waveform generation, the **M-TONE** and **I/Q** annunciators activate and the multitone waveform is stored in volatile ARB memory. The waveform is now modulating the RF carrier.
**Configuring the RF Output**

1. Set the RF output frequency to 100 MHz.
2. Set the output amplitude to 0 dBm.

The multitone waveform is now available at the signal generator's RF OUTPUT connector.

**Applying Changes to an Active Multitone Signal**

If the multitone generator is currently in use (Multitone Off On set to On) while changes are made in the Multitone Setup table editor, you must apply the changes before the updated waveform will be generated.

From the Multitone Setup table editor, press the following key to apply the changes and generate a multitone waveform based on the updated values: `Apply Multitone`

**Storing a Multitone Waveform**

In this example, you learn how to store a multitone waveform. If you have not created a multitone waveform, complete the steps in the previous section, *Creating a Custom Multitone Waveform* on page 297.

1. Press `Load/Store > Store To File`.
   
   If there is already a file name from the Catalog of MTONE Files occupying the active entry area, press the following keys (see page 43):
   
   - `Edit Keys` > `Clear Text`

2. Enter a file name (for example, 5TONE) using the alpha keys and the numeric keypad with a maximum length of 23 characters (see page 43).

3. Press `Enter`.

The multitone waveform is now stored in the Catalog of MTONE Files.

---

**NOTE**

The RF output amplitude, frequency, and operating state settings are not stored as part of a multitone waveform file. Similarly, the multitone settings are not stored as part of the instrument state. Therefore, in most cases you should save both the instrument states and the multitone settings to be able to restore all of your settings later.
Recalling a Multitone Waveform

Using this procedure, you learn how to recall a multitone waveform from the signal generator’s memory catalog.

If you have not created and stored a multitone waveform, complete the steps in the previous sections, Creating a Custom Multitone Waveform on page 297 and Storing a Multitone Waveform on page 306, then preset the signal generator to clear the stored multitone waveform from volatile ARB memory.

1. Press Mode > Multitone.
2. Press Load/Store.
3. Highlight the desired file (for example, 5TONE).
4. Press Load From Selected File > Confirm Load From File.
5. Press Multitone Off On until On is highlighted.

The firmware generates the multitone waveform in ARB memory. After waveform generation, the multitone waveform is available to be modulated on the RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 306.
Multitone and Two–Tone Waveforms (Option 430)
Using Multitone Modulation
13 Working in a Secure Environment

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only available through the Web-Enabled MXG or SCPI commands. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command Reference.

- Understanding Memory Types on page 309
- Removing Data from Memory (Option 006 Only) on page 312
- Using the Secure Display (Option 006 Only) on page 315

Understanding Memory Types

The signal generator has several memory types, and each is used to store a specific type of data. Before removing sensitive data, you should to understand how each memory type is used. The following tables describe each memory type used in the base instrument, and optional baseband generator.

Table 13-1 Base Instrument Memory

<table>
<thead>
<tr>
<th>Memory Type and Size</th>
<th>Writable During Normal Operation?</th>
<th>Data Retained When Powered Off?</th>
<th>Purpose/Contents</th>
<th>Data Input Method</th>
<th>Location in Instrument and Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Main Memory (RAM)</td>
<td>Yes</td>
<td>No</td>
<td>firmware operating memory no user data</td>
<td>operating system</td>
<td>CPU board, not battery backed.</td>
</tr>
<tr>
<td>32 MB</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Main Memory (Flash)</td>
<td>Yes</td>
<td>Yes</td>
<td>factory calibration/configuration data *user file system, which includes flatness calibration, instrument states, and sweep lists</td>
<td>firmware upgrades and user–saved data*</td>
<td>CPU board (same chip as firmware memory, but managed separately) Because this memory chip contains 8 MB of user data (described here) and 8 MB of firmware memory, a full-chip erase is not desirable. User data areas are selectively and completely sanitized when you perform the Erase and Sanitize function.</td>
</tr>
<tr>
<td>8 MB</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Understanding Memory Types

#### Firmware Memory

<table>
<thead>
<tr>
<th>Memory Type and Size</th>
<th>Writable During Normal Operation?</th>
<th>Data Retained When Powered Off?</th>
<th>Purpose/Contents</th>
<th>Data Input Method</th>
<th>Location in Instrument and Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Firmware Memory (Flash) 8 MB</td>
<td>No</td>
<td>Yes</td>
<td>main firmware image</td>
<td>factory installed or firmware upgrade</td>
<td>CPU board (same chip as main flash memory, but managed separately)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>During normal operation, this memory cannot be overwritten. It is only overwritten during the firmware installation or upgrade process. Because this memory chip contains 8 MB of user data and 8 MB of firmware memory (described here), a full-chip erase is not desirable. User data areas are selectively and completely sanitized when you perform the <strong>Erase and Sanitize</strong> function.</td>
</tr>
<tr>
<td>Bootrom Memory (EEPROM) 8 kB</td>
<td>No</td>
<td>Yes</td>
<td>CPU bootup parameters</td>
<td>factory programmed</td>
<td>CPU board</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>no user data</td>
<td></td>
<td>During normal operation, this memory cannot be overwritten or erased except for LAN configuration. This read-only data is programmed at the factory.</td>
</tr>
<tr>
<td>Calibration Data (Flash) 256 kB</td>
<td>No</td>
<td>Yes</td>
<td>factory calibration/configuration data backup</td>
<td>factory or service only</td>
<td>RF Board</td>
</tr>
<tr>
<td>LCD Display Memory (RAM) 160 kB</td>
<td>No</td>
<td>No</td>
<td>display buffer</td>
<td>operating system</td>
<td>RF board, not battery backed.</td>
</tr>
<tr>
<td>Front Panel Memory (Flash) 32 kB</td>
<td>No</td>
<td>No</td>
<td>front panel keyboard controller firmware</td>
<td>operating system</td>
<td>Front Panel board</td>
</tr>
</tbody>
</table>

*Analog instruments only*
Table 13-2  Baseband Generator Memory (Options 651, 652, 654)

<table>
<thead>
<tr>
<th>Memory Type and Size</th>
<th>Writable During Normal Operation?</th>
<th>Data Retained When Powered Off?</th>
<th>Purpose/Contents</th>
<th>Data Input Method</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Waveform Memory (RAM) ≤ 320 MB</td>
<td>Yes</td>
<td>No</td>
<td>waveforms (including header and marker data)</td>
<td>normal user operation</td>
<td>Not battery backed.</td>
</tr>
<tr>
<td>Persistent Memory (Flash)$^a$ 4 GB</td>
<td>Yes</td>
<td>Yes</td>
<td>all user data</td>
<td>normal user operation</td>
<td>User data is completely sanitized when you perform the Erase and Sanitize function.</td>
</tr>
<tr>
<td>Calibration Data Memory (Flash) 128 kB</td>
<td>No</td>
<td>Yes</td>
<td>no user data</td>
<td>factory or service only</td>
<td></td>
</tr>
</tbody>
</table>

$^a$For serial numbers <MY4818xxxx, US4818xxxx, and SG4818xxxx, the persistent memory value = 512 MB.
Removing Data from Memory (Option 006 Only)

When moving the signal generator from a secure development environment, there are several security functions you can use to remove classified proprietary information from the instrument. Security functions also have equivalent SCPI commands for remote operation (“System Subsystem (:SYSTem)” commands; refer to the SCPI Command Reference)

**CAUTION** The signal generator has several memory types (described in Table 13-1 on page 309, and Table 13-2 on page 311), and each is used to store a specific type of data. Before removing sensitive data, understand how each memory type is used.

---

**Erase All**

Removes: All user files, user flatness calibrations, user I/Q calibrations  
Resets: All table editors with original factory values, ensuring that user data and configurations are not accessible or viewable  
Does Not: Sanitize memory  
Time to Erase: typically < 1 minute, depending on the number of files.  
To Start: Press File > More > Security > Erase All > Confirm Erase

**NOTE** This is not File > Delete All Files, which deletes all user files but does not reset table editors.
Working in a Secure Environment
Removing Data from Memory (Option 006 Only)

**Erase and Overwrite All**

This performs the same actions as Erase All, plus it clears and overwrites the various memory types in compliance with the National Industry Security Program Operating Manual (NISPOM) DoD 5220.22–M.

**CPU Flash**

Overwrites all addressable locations with random characters and then erases the flash blocks. This accomplishes the same purpose as a chip erase. System files are restored after erase.

To Start: Press **File > More > Security > Erase and Overwrite All > Confirm Erase**

**Erase and Sanitize All**

This performs the same actions as Erase and Overwrite All and then adds more overwriting actions. After executing this function, you must manually perform the additional steps described below for the sanitization to comply with the National Industry Security Program Operating Manual (NISPOM) DoD 5220.22–M.

**CPU Flash**

Overwrites all addressable locations with random characters and then erases the flash blocks. This accomplishes the same purpose as a chip erase. System files are restored after erase.

**BBG Persistent Memory (Flash)** *(Vector instruments only)*

Overwrites all addressable locations with random characters and then erases the flash blocks. This accomplishes the same purpose as a chip erase. System files are restored after erase.

To Start: Press **File > More > Security > Erase and Sanitize All > Confirm Sanitize**

**Removing Persistent State Information Not Removed During Erase**

**Persistent State**

The persistent state settings contain instrument setup information that can be toggled within predefined limits such as display intensity, contrast and the GPIB address. In vector models, the user IQ cal is also saved in this area.

The following key presses or SCPI commands can be used to clear the IQ cal file and to set the operating states that are not affected by a signal generator power–on, preset, or *RST command to their factory default:

**Instrument Setup**

- On the Agilent MXG front panel, press: **Utility > Power On/Preset > Restore System Settings to Default Values > Confirm Restore Sys Settings to Default Values**
- Or send this command to the Agilent MXG: `:SYSTem:PRESet:PERSistent`
Working in a Secure Environment
Removing Data from Memory (Option 006 Only)

LAN Setup
The LAN setup (hostname, IP address, subnet mask, and default gateway) information is not defaulted with a signal generator power–on or *RST command. This information can only be changed or cleared by entering new data.

User IQ Cal File (Vector Models Only)
When a user–defined IQ calibration has been performed, the cal file data is removed by setting the cal file to default, as follows:

- On the front panel, press: I/Q > I/Q Calibration > Revert to Default Cal Settings
- Or send this command to the Agilent MXG: :CAL:IQ:DEF

Secure Mode

CAUTION
Once you activate secure mode (by pressing Confirm), you cannot deactivate or decrease the security level; the erasure actions for that security level execute at the next power cycle. Once you activate secure mode, you can only increase the security level until you cycle power. For example, you can change Erase to Overwrite, but not the reverse.

After the power cycle, the security level selection remains the same, but secure mode is not activated.

To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to non-volatile memory, the MXG should always be powered down via the MXG's front panel power button or the appropriate SCPI command. MXG's installed in rack systems and powered down with the system rack power switch rather than the MXG's front panel switch display a Error –310 due to the MXG not being powered down correctly.

Secure mode automatically applies the selected Security Level action the next time the instrument’s power cycles.

To Set the Level: Press File > More > Security > Security Level and choose from the following:
- None = factory preset, no user information is lost
- Erase = Erase All
- Overwrite = Erase and Overwrite All
- Sanitize = Erase and Sanitize All

To Activate: Press File > More > Security > Enter Secure Mode > Confirm
The softkey changes to Secure Mode Activated.

Securing a Nonfunctioning Instrument
If the instrument is not functioning and you are unable to use the security functions, you must physically remove the processor board and, for vector instruments, the A4 Memory Chip from the instrument. Once these assemblies are removed, choose one of the following options:

- Discard the board (or boards) and send the instrument to a repair facility. A new board (or boards) will be installed and the instrument will be repaired and calibrated. If the instrument is still under warranty, you will not be charged for new boards.
• If you have another working instrument, install the board (or boards) into that instrument and erase the memory. Then reinstall the board (or boards) back into the nonworking instrument and send it to a repair facility for repair and calibration. If you discover that one or both of the boards do not function in the working instrument, discard the nonfunctioning board and note on the repair order that it caused the instrument failure. If the instrument is still under warranty, you will not be charged for new boards.

For instructions on how to remove and replace boards, refer to the Service Guide.

**Using the Secure Display (Option 006 Only)**

This function prevents unauthorized personnel from reading the instrument display and tampering with the current configuration through the front panel. The display blanks, except for the message shown in the following figure, and the front panel keys are disabled.

To re-enable the display and front panel keys, cycle the power.
Working in a Secure Environment
Using the Secure Display (Option 006 Only)

Figure 13-1 Secure Display Softkeys

For details on each key, use key help as described on page 42.
14 Troubleshooting

NOTE  For the N5161A/62A the softkey menus and features mentioned in this guide are only available through the Web-Enabled MXG or SCPI commands. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command Reference.

- Display on page 318
- Signal Generator Lock-Up on page 318
- RF Output on page 318
  - No RF Output
  - Power Supply Shuts Down
  - No Modulation at the RF Output
  - RF Output Power too Low
  - Distortion
  - Signal Loss While Working with a Spectrum Analyzer
  - Signal Loss While Working with a Mixer
- Sweep on page 322
  - Cannot Turn Off Sweep
  - Sweep Appears Stalled
  - Incorrect List Sweep Dwell Time
  - List Sweep Information is Missing from a Recalled Register
  - Amplitude Does Not Change in List or Step Sweep
- Internal Media Data Storage on page 323
  - Instrument State Saved but the Register is Empty or Contains the Wrong State
- USB Media Data Storage on page 323
  - Instrument Recognizes USB Media Connection, but Does Not Display Files
- Preset on page 323
  - The Signal Generator Does Not Respond
  - Pressing Preset Performs a User Preset
- Error Messages on page 324
- Front Panel Tests on page 325
- Self Test Overview on page 326
- Licenses on page 328
- Contacting Agilent Technologies on page 328
  - Returning a Signal Generator to Agilent
Troubleshooting

Display

The Display is Too Dark to Read

Both brightness and contrast may be set to minimum. Use the figure in “Display Settings” on page 26 to locate the brightness and contrast softkeys and adjust their values so that you can see the display.

The Display Turns Black when Using USB Media

Removing the USB media when the instrument begins to use it can cause the screen to go black. Cycle instrument power.

Signal Generator Lock–Up

- Ensure that the signal generator is not in remote mode (the R annunciator shows on the display). To exit remote mode and unlock the front panel, press Local Cancel/(Esc).
- Ensure that the signal generator is not in local lockout, which prevents front panel operation. For information on local lockout, refer to the Programming Guide.
- If a progress bar appears on the signal generator display, an operation is in progress.
- Preset the signal generator.
- Cycle power on the signal generator.

RF Output

No RF Output

- Check the RF ON/OFF LED (shown on page 5). If it is off, press RF On/Off to turn the output on.
- Ensure that the amplitude is set within the signal generator’s range.
- If the instrument is playing a waveform, ensure that marker polarity and routing settings are correct (see “Saving Marker Polarity and Routing Settings” on page 158).

Power Supply Shuts Down

If the power supply does not work, it requires repair or replacement. If you are unable to service the instrument, send the signal generator to an Agilent service center for repair (see “Contacting Agilent Technologies” on page 328).

No Modulation at the RF Output

Check both the Mod On/Off LED and the <modulation> Off On softkey, and ensure that both are on. See also “Modulating the Carrier Signal” on page 60.

For digital modulation on a vector signal generator, ensure that the internal I/Q modulator is on (the I/Q annunciator displays).

If using an external modulation source, ensure that the external source is on and that it is operating within the signal generator’s specified limits.
RF Output Power too Low

- If the AMPLITUDE area of the display shows the OFFS indicator, eliminate the offset:
  
  Press **Amptd > More 1 of 2 > Amptd Offset > 0 > dB**. See also “Setting an Output Offset” on page 113.

- If the AMPLITUDE area of the display shows the REF indicator, turn off the reference mode:
  
  1. Press **Amptd > More > Amptd Ref Off On** until Off highlights.
  2. Reset the output power to the desired level.

  See also “Setting an Output Reference” on page 114.

- If you are using the signal generator with an external mixer, see page 320.

- If you are using the signal generator with a spectrum analyzer, see page 319.

- If pulse modulation is on, turn off the ALC, and check that pulse width is within specifications.

Distortion

If you edit and resave a segment in a waveform sequence, the sequence does not automatically update the RMS value stored in it’s header. This can cause distortion on the output signal. Display the sequence header information and recalculate the RMS value (see page 151).

Signal Loss While Working with a Spectrum Analyzer

**CAUTION**

To avoid damaging or degrading the performance of the MXG, do not exceed 33 dBm (2W) maximum of reverse power levels at the RF input. See also *Tips for Preventing Signal Generator Damage* on [www.agilent.com](http://www.agilent.com).

The effects of reverse power can cause problems with the RF output when you use the signal generator with a spectrum analyzer that does not have preselection. Use an unleveled operating mode (described on page 110).

A spectrum analyzer can have as much as +5 dBm LO feedthrough at its RF input port at some frequencies. If the frequency difference between the LO feedthrough and the RF carrier is less than the ALC bandwidth, the LO's reverse power can amplitude modulate the signal generator’s RF output. The rate of the undesired AM equals the difference in frequency between the spectrum analyzer's LO feedthrough and the signal generator’s RF carrier.

Reverse power problems can be solved by using one of the unleveled operating modes.

See:

- “ALC Off Mode” on page 110
  and

- “Power Search Mode” on page 111
Signal Loss While Working with a Mixer

**CAUTION**
To avoid damaging or degrading the performance of the MXG, do not exceed 33 dBm (2W) maximum of reverse power levels at the RF input. See also *Tips for Preventing Signal Generator Damage* on www.agilent.com.

To fix signal loss at the signal generator’s RF output during low-amplitude coupled operation with a mixer, add attenuation and increase the RF output amplitude.

The figure at right shows a configuration in which the signal generator provides a low amplitude signal to a mixer.

The internally leveled signal generator RF output (and ALC level) is −8 dBm. The mixer is driven with an LO of +10 dBm and has an LO-to-RF isolation of 15 dB. The resulting −5 dBm LO feedthrough enters the signal generator’s RF output connector and arrives at the internal detector.

Depending on frequency, it is possible for most of this LO feedthrough energy to enter the detector. Because the detector responds to its total input power regardless of frequency, this excess energy causes the ALC to reduce the RF output. In this example, the reverse power across the detector is actually greater than the ALC level, which can result in loss of signal at the RF output.
The solution at right shows a similar configuration with the addition of a 10 dB attenuator connected between the RF output of the signal generator and the input of the mixer. The signal generator’s ALC level increases to +2 dBm and transmits through a 10 dB attenuator to achieve the required −8 dBm amplitude at the mixer input.

Compared to the original configuration, the ALC level is 10 dB higher while the attenuator reduces the LO feedthrough (and the signal generator’s RF output) by 10 dB. Using the attenuated configuration, the detector is exposed to a +2 dBm desired signal versus the −15 dBm undesired LO feedthrough. This 17 dB difference between desired and undesired energy results in a maximum 0.1 dB shift in the signal generator’s RF output level.
**Troubleshooting**

**Sweep**

**Cannot Turn Off Sweep**

Press **Sweep > Sweep > Off**.

**Sweep Appears Stalled**

The current status of the sweep is indicated as a shaded rectangle in the progress bar (see “Configuring a Swept Output” on page 48). If the sweep appears to stall, check the following:

1. Turn on the sweep with one of the following key sequences:
   - **Sweep > Sweep > Freq**
   - **Sweep > Sweep > Amptd**
   - **Sweep > Sweep > Waveform** (vector instruments only)
2. If the sweep is in single mode, press the **Single Sweep** softkey.
3. If the sweep trigger (indicated by the **Sweep Trigger** softkey) is *not* set to Free Run, set it to Free Run to determine if a missing sweep trigger is blocking the sweep.
4. If the point trigger (indicated by the **Point Trigger** softkey) is *not* set to Free Run, set it to Free Run to determine if a missing point trigger is blocking the sweep.
5. Set the dwell time to one second to determine if the dwell time was set to a value that was too slow or too fast to see.
6. Ensure that you set at least two points in the step sweep or list sweep.

**Incorrect List Sweep Dwell Time**

1. Press **Sweep > More > Configure List Sweep**.
2. Check that the list sweep dwell values are accurate.
3. If the dwell values are incorrect, edit them.
   - If the dwell values are correct, continue to the next step.
4. Press **More**, and ensure that the **Dwell Type List Step** softkey is set to List.
   - If Step is selected, the signal generator sweeps the list points using the dwell time set for step sweep rather than list sweep.

See also “Configuring a Swept Output” on page 48.

**List Sweep Information is Missing from a Recalled Register**

List sweep information is not stored as part of the instrument state in an instrument state register. Only the current list sweep is available to the signal generator. You can store list sweep data in the instrument catalog (see “Loading (Recalling) a Stored File” on page 67).

**Amplitude Does Not Change in List or Step Sweep**

Verify that sweep type is set to amplitude (Amptd); the amplitude does not change when the sweep type is set to frequency (Freq) or waveform.
Internal Media Data Storage

Instrument State Saved but the Register is Empty or Contains the Wrong State

If the register number you intended to use is empty or contains the wrong instrument state, recall register 99. If you selected a register number greater than 99, the signal generator automatically saves the instrument state in register 99.

See also “Working with Instrument State Files” on page 69.

USB Media Data Storage

Instrument Recognizes USB Media Connection, but Does Not Display Files

If the USB media works on other instruments or computers, it may simply be incompatible with the signal generator; try a different USB media. Refer to http://www.agilent.com/find/mxg for details on compatible USB media.

Preset

The Signal Generator Does Not Respond

If the signal generator does not respond to a preset, the instrument may be in remote mode, which locks the keypad.

To exit remote mode and unlock the preset keys, press **Local Cancel/(Esc)**.

Pressing Preset Performs a User Preset

This behavior results from the use of a backward–compatible SCPI command. To return the signal generator to normal use, send the command `:SYST:PRESet:TYPE NORM`.

For information on SCPI commands, refer to the **SCPI Command Reference**.
Troubleshooting
Error Messages

Error Messages

Error Message Types

Events do not generate more than one type of error. For example, an event that generates a query error does not generate a device-specific, execution, or command error.

Query Errors (–499 to –400) indicate that the instrument’s output queue control has detected a problem with the message exchange protocol described in IEEE 488.2, Chapter 6. Errors in this class set the query error bit (bit 2) in the event status register (IEEE 488.2, section 11.5.1). These errors correspond to message exchange protocol errors described in IEEE 488.2, 6.5. In this case:

- Either an attempt is being made to read data from the output queue when no output is either present or pending, or
- data in the output queue has been lost.

Device Specific Errors (–399 to –300, 201 to 703, and 800 to 810) indicate that a device operation did not properly complete, possibly due to an abnormal hardware or firmware condition. These codes are also used for self-test response errors. Errors in this class set the device-specific error bit (bit 3) in the event status register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A positive error indicates that the instrument detected an error within the GPIB system, within the instrument’s firmware or hardware, during the transfer of block data, or during calibration.

Execution Errors (–299 to –200) indicate that an error has been detected by the instrument’s execution control block. Errors in this class set the execution error bit (bit 4) in the event status register (IEEE 488.2, section 11.5.1). In this case:

- Either a <PROGRAM DATA> element following a header was evaluated by the device as outside of its legal input range or is otherwise inconsistent with the device’s capabilities, or
- a valid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression evaluation operations are completed. Rounding a numeric data element, for example, is not reported as an execution error.

Command Errors (–199 to –100) indicate that the instrument’s parser detected an IEEE 488.2 syntax error. Errors in this class set the command error bit (bit 5) in the event status register (IEEE 488.2, section 11.5.1). In this case:

- Either an IEEE 488.2 syntax error has been detected by the parser (a control-to-device message was received that is in violation of the IEEE 488.2 standard. Possible violations include a data element that violates device listening formats or whose type is unacceptable to the device.), or
- an unrecognized header was received. These include incorrect device-specific headers and incorrect or unimplemented IEEE 488.2 common commands.

Error Message File

A complete list of error messages is provided on the CDROM supplied with the instrument. In the error message file, an explanation is generally included with each error to further clarify its meaning. The error messages are listed numerically. In cases where there are multiple listings for the same error number, the messages are in alphabetical order.
Front Panel Tests

Set all display pixels to the selected color.
To return to normal operation, press any key.

Blink RF On/Off, Mod on/Off, and More LEDs
Displays a keyboard map.
As you press a key, the map indicates the key location.

Correct operation:
Full CCW = -10
Full CW = 10

For details on each key, use key help as described on page 42.
Self Test Overview

The self test is a series of internal tests that checks different signal generator functions. The self test, is also available by via the remote web interface. For more information on the Web-Enabled MXG, refer to the Programming Guide.

For details on each key, use key help as described on page 42.
NOTE  N5183A MXG with non 1E1 Option (no attenuator), a warning message will be displayed on the Self Test Summary window as shown below.

For instruments with attenuators the attenuators are auto set to maximum value before self-test executes and resets to nominal at conclusion.
Licenses

NOTE If your instrument has A.01.50 firmware loaded, two years after purchase, your MXG can display the following time-based error message: "AUS license expires in xxd days. Contact Agilent Technologies to renew." The error message will repeat three times over 90 days (e.g. first at 90-60 days remaining, second at 59-30 days remaining, and the last at 30-0 days remaining days).

This message can be ignored. This error does not indicate a performance problem with your MXG. Pressing any softkey will clear the message and the instrument can be used normally.

Downloading a newer version of firmware will prevent further AUS license-related error messages being displayed.

A Time–Based License Quits Working

• The instrument’s time or date may have been reset forward causing the time–based license to expire.
• The instrument’s time or date may have been reset backward more than approximately 25 hours, causing the instrument to ignore time–based licenses.

See page 28 for details and cautions on setting time and date.

Cannot Load a Time–Based License

The instrument’s time or date may have been reset backward more than approximately 25 hours, causing the instrument to ignore time–based licenses.

See page 28 for details and cautions on setting time and date.

Contacting Agilent Technologies

• assistance with test and measurements needs, and information on finding a local Agilent office: http://www.agilent.com/find/assist
• accessories or documentation: http://www.agilent.com/find/mxg

If you do not have access to the Internet, please contact your field engineer.

NOTE In any correspondence or telephone conversation, refer to the signal generator by its model number and full serial number. With this information, the Agilent representative can determine whether your unit is still within its warranty period.

Returning a Signal Generator to Agilent

Use the following steps to return a signal generator to Agilent Technologies for servicing:
1. Gather as much information as possible regarding the signal generator’s problem.
2. Call the phone number listed on the Internet (http://www.agilent.com/find/assist) that is specific
to your geographic location. If you do not have access to the Internet, contact your Agilent field engineer.

After sharing information regarding the signal generator and its condition, you will receive information regarding where to ship your signal generator for repair.

3. Ship the signal generator in the original factory packaging materials, if available, or use similar packaging to properly protect the signal generator.
Glossary

A

Active Entry The currently selected, and therefore editable, entry or parameter

ARB Arbitrary waveform generator

AWG Arbitrary waveform generator. Additive white Gaussian noise

B

BBG Media Baseband generator media. Volatile memory, where waveform files are played or edited.

BNC Connector Bayonet Neill-Concelman connector. A type of RF connector used to terminate coaxial cable.

C

CCW Counterclockwise

C/N Carrier-to-noise ratio

CW Continuous wave. Clockwise

D

DHCP Dynamic host communication protocol

Dwell Time In a step sweep (see page 50), the time that the signal is settled and you can make a measurement before the sweep moves to the next point.

E

EVM Error vector magnitude; the magnitude of the vector difference at a given instant between the ideal reference signal and the measured signal.

F

Filter factor Alpha The filter's alpha coefficient. It is only valid for root nyquist and nyquist filters.

Filter Factor BbT The filter's bandwidth-bit-time (BbT). It is only valid for a Gaussian filter (similar to alpha). BbT is defined by the GSM standard as 0.3 and by the DECT standard as 0.5.

G

Gaussian filter The Gaussian filter does not have a zero Inter-Symbol Interference (ISI). Wireless system architects must decide just how much of the ISI can be tolerated in a system and combine that with noise and interference. The Gaussian filter is gaussian shaped in both the time and frequency domains, and it does not ring like the root nyquist filters do. The effects of this filter in the time domain are relatively short and each symbol interacts significantly (or causes ISI) with only the preceding and succeeding symbols. This reduces the tendency for particular sequences of symbols to interact, which makes amplifiers easier to build and more efficient.

GPIB General purpose interface bus. An 8-bit parallel bus common on test equipment.

H

Hardkey A labeled button on the instrument.

I

IF Intermediate frequency

Int Media Internal media. Non–volatile signal generator memory, where waveform files are
stored.

**IP** Internet protocol. The network layer for the TCP/IP protocol suite widely used on Ethernet networks.

**LAN** Local area network

**LO** Local oscillator

**LXI** LAN eXtension for Instrumentation. An instrumentation platform based on industry standard Ethernet technology designed to provide modularity, flexibility, and performance to small- and medium-sized systems. See also http://www.lxistandard.org

**M**

**Modulation Format** Custom modulation, Two Tone, or Multitone.

**Modulation Mode** Dual ARB, Custom modulation, Two Tone, or Multitone.

**Modulation Standard** Refers to a Cellular standard format (i.e. NADC, PDC, PHS, etc.).

**Modulation Type** Refers to the various I/Q constellation types (i.e. PSK, MSK, FSK, C4FM, etc.)

**N**

**Non-volatile** That which survives a power cycle (such as files stored in USB media).

**Nyquist filter** Also referred to as a cosine filter. These filters have the property that their impulse response rings at the symbol rate. Adjacent symbols do not interfere with each other at the symbol times because the response equals zero at all symbol times except the center (desired) one.

**P**

**Persistent** That which is unaffected by preset, user preset, or power cycle.

**Point-to-point Time** In a step sweep (page 50), the sum of the dwell time, processing time, switching time, and settling time.

**R**

**Rectangular filter** Also referred to as an ideal low pass filter. These filters have very steep cut-off characteristics. The pass band is set to equal the symbol rate of the signal. Due to a finite number of coefficients, the filter has a predefined length and is not truly “ideal”. The resulting ripple in the cut-off band is effectively minimized with a Hamming window. This filter is recommended for achieving optimal ACP. A symbol length of 32 or greater is recommended for this filter.

**Root Nyquist filter** Also referred to as a Root cosine filter. These filters have the property that their impulse response rings at the symbol rate. Adjacent symbols do not interfere with each other at the symbol times because the response equals zero at all symbol times except the center (desired) one. Root Nyquist filters heavily filter the signal without blurring the symbols together at the symbol times. This is important for transmitting information without errors caused by ISI. Note that ISI does exist at all times except the symbol (decision) times. A cascade of two of these filters has the transfer function of a Nyquist filter. One is in the transmitter, the other in the receiver, so that the system taken as a whole has the zero-ISI properties of an ISI filter.

**RMS** Root mean square. A time-varying signal’s effective value (the equivalent DC voltage required to generate the equivalent heat across a given resistor). For a sinewave, RMS = 0.707 x
peak value.

S

**Softkey** A button located along the instrument’s display that performs whatever function is shown next to it on that display.

T

**TCP** Transmission control protocol. The most common transport layer protocol used on Ethernet and the Internet.

**Terminator** A unit indicator (such as Hz or dBm) that completes an entry. For example, for the entry 100 Hz, Hz is the terminator.

**Type-N Connector** Threaded RF connector used to join coaxial cables.

U

**USB** Universal serial bus. See also [http://www.usb.org](http://www.usb.org)

**User FIR** Selects a user-defined set of coefficient values. Each line in the FIR values table contains one coefficient value. The number of coefficient values listed must be a multiple of the selected oversampling ratio. Each coefficient applies to both I and Q components.

V

**Volatile** That which does not survive a power cycle (such as files stored in BBG media).
Symbols
, 209
ΦM
  annunciator, 11, 13
dc offset, removing, 77
hardkey, 75
softkeys, 75, 77
# points softkey, 51
# Skipped Points softkey, 162

Numerics
10 MHz OUT connector, 17, 23
100Base-T LAN cable, 31
128 QAM softkey, 269
1410, application note, 298
16-Lvl FSK softkey, 269
16QAM softkey, 269
256 QAM softkey, 269
2-Lvl FSK softkey, 269
32QAM softkey, 269
430, option
  multitone mode, 304
two-tone, 298
two-tone mode, 298
4-Lvl FSK softkey, 269
4QAM softkey, 269
5-Pack
  history, waveform files, 246
  licensing, 239
  installing, 239
  understanding, 239
  waveform file, 240
  status messages, 242
  warning messages, 250
628, error, 196
64QAM softkey, 269
651/652/654, option
description, 4
  multitone mode, 304
two-tone mode, 298
670/671/672, option
description, 4
8557D GPIB only softkey, 33, 35
8648A/B/C/D GPIB only softkey, 33, 35
8656B,8657A/B GPIB only softkey, 33, 35
8-Lvl FSK softkey, 269

A
AC power receptacle, 15, 21
ACP, 266
Activate Secure Display softkey, 26
  entry, 331
  entry area, 11
Active High softkey, 175
Add Comment To softkey, 175
Active Low softkey, 175
Add Comment To softkey, 69
additive white Gaussian noise. See AWGN
address, GPIB, 30
Adjust Phase softkey, 45, 47
Adjustable doublet softkey, 128
adjustments
I/Q, 138, 203
  quadrature, 203
  real-time phase noise, 263
advance, segment, 177
Advanced Settings softkey, 31
Aeroflex softkey, 33, 35
Agilent MXG
  modes of operation, 4
Agilent sales and service offices, 328
ALC
  hold, 158, 159
  OFF annunciator, 11, 13
  off mode, 110
  softkeys, 45, 47, 162
alc
  setting, 47
ALC Input
  connector, 24
All softkey, 24
Alpha, 331
AM
  annunciator, 11, 13
  connector, 16, 22
  external source, 77
  hardkey, 75
  softkeys, 75
  wideband, 77
amplitude
  display area, 12
  hardkey, 45, 47
  modulation, 75
  offset, 113
  reference, 114
  setting, 45, 47
troubleshooting sweep, 322
AMPTD hardkey, 45, 47
analog modulation, 4, 75
angle, quadrature, 138
annunciators, 11, 13
APCO 25 w/C4FM softkey, 268
APCO 25 w/CQPSK softkey, 268
apodization settings, FIR filter, 216, 287
application notes
  1410, 298
Apply To Waveform softkey, 162
ARB
  definition, 331
  player, dual, 142
Index

  softkeys, 142, 173, 252, 253, 254, 255, 260
  waveform clipping, 181
  arb, 266
  Arb Custom
    FIR filters, 281
    FIR table editor, 286
  Arb Segment softkey, 68
  Arb Sequence softkey, 68
  arb setup
    softkey, 219
  ARMED annunciator, 11, 13
  arrow keys, 43
  ASK Depth softkey, 269
  ASK softkey, 269
  ATTN HOLD annunciator, 11, 13
  Atten/ALC Control softkey, 46, 47
  Auto softkeys
    (DHCP/Auto-IP), 31
    Auto, 110
    Recall, 126
  AUTOGEN_WAVEFORM file, 266
  auto-IP, 31
  Auto-IP softkey, 31
  Automatically Use USB Media If Present softkey, 63
  AUX I/O connector, 20
  Auxiliary Software Options softkey, 38
  AWGN
    adding, 251
    annunciator, 11, 13
    definition, 331
    dual ARB player, 251
    softkeys, 257
  AWGN softkeys, 252, 253, 254, 255
  B
  backspace hardkey, 43
  Bandwidth softkey, 257
  baseband, 20
  aligning signals at, 158
  clipping, 181
  frequency offset
    softkey location, 196
    frequency offset, setting, 196
  I/Q output connectors, 18
  memory, 142, 309
  noise, 251
  noise annunciator, 11, 13
  quadrature adjustment, 203
  real time I/Q AWGN, 252, 253, 254, 255, 257
  softkey, 196
  summing signals, 202
  waveforms convert to analog, 191
  baseband frequency offset
    DAC over range & scaling, 198
    softkey, 196
  baseband generator, 266
  custom arb mode, 4
  dual arb mode, 5
  multiple BBG synchronization, 220
  multitone mode, 4, 5, 304
  two-tone mode, 298
  BB GEN, 202
  BBG
    media, 142, 144
    media (definition), 331
    Memory softkey, 68
    Memory to USB softkey, 68
    routing, 202
    Segments softkey, 63, 151
  BBG sync, 229
  configure setup, 224
  equipment setup, 224
  resynchronization, 226
  system, 223
  system delay, 223
  trigger setup, 223
  BbT, 331
  Binary softkey, 63
  bits per symbol, equation, 291
  Bk Sp hardkey, 43
  Bluetooth softkey, 268, 269
  BNC, 331
  bootrom memory, 309
  Bright Color softkey, 26
  brightness adjustment, 26
  Brightness softkey, 26
  Buffered Trig softkey, 175
  Build New Waveform Sequence softkey, 147, 171
  Burst Envelope softkey, 200
  Bus softkey, 49
  C
  C/N, 331
  C4FM softkey, 269
  cables
    crossover, 31
    multi-BBG sync, 223
  cables, 100Base-T LAN, 31
  Calculate softkey, 151
  calibration
    data, 309
    data memory, 311
    I/Q, 205
    softkey, 205
  Calibration Type softkey, 205
  Cancel hardkey, 6
  carrier
    bandwidth, 251
configuring, 46
feedingthrough, 138
modulating, 60
softkeys, 252, 253, 254, 255
to noise ratio, 251
Carrier Bandwidth softkey, 252, 253, 254, 255
carrier feedthrough, minimizing, 301
Carrier Softkey, 252, 253, 254, 255
Carrier to Noise softkey, 252, 253
Carrier+Noise softkey, 252, 254, 255
Catalog Type softkey, 63, 64, 68, 151
catalog, state files, 72
ccw, 331
CDPD softkey, 268, 269
celling function, bits per symbol, 291
Channel Band softkey, 45, 47
Channel Number softkey, 45, 47
circular clipping, 185, 188
classified. See security
Clear softkeys
   Error Queue(s), 74
   Header, 151
   Text, 43
clipping
circular, 185, 188
rectangular, 186, 189
softkeys, 181
clock, sample rate, 20
coefficient values, entering, 210, 282
color palette, display, 26
comments, adding & editing (instrument state), 70
component test, 269
Config Type softkey, 31
Configure softkeys
   Cal Array, 89
   List Sweep, 49, 56
   Step Array, 89
   Step Sweep, 49, 51
Confirm Load From File softkey, 67
Connection Monitoring softkey, 31
Connection Type softkeys
   Sockets, 92
   USB, 92
   VXI-11, 92
connectors
   external triggering source, 178, 180
   front panel, 5, 9
   rear panel
   n5161a, 15
   n5162a, 15
   n5181a, 15
   n5182a, 15
   n5183a, 21
routing signals, 50
Continuous softkey, 175

continuous step sweep example, 59
continuous wave
description, 4
continuous wave output, 46
contrast adjustment, 26
Contrast softkey, 26
Copy & softkeys
   Play Sequence, 67
   Play Waveform, 67
   Select User Flatness, 67
   Select User Flatness Corrections, 67
Copy softkeys
   All Files, 68
   File, 63
   File to Instrument, 63, 68
   File to USB, 68
correction array (user flatness), 94
   viewing, 95
See also user flatness correction
corrections, internal channel, 97, 99
cosine filter, See nyquist filter
Create Directory softkey, 63, 68
crossover cable, 31
custom
   multicarrier TDMA waveforms
   creating, 278
   TDMA digital modulation, 271
Custom ARB softkeys, 267
custom arb waveform generator, 4
custom mode, 266
custom modulation
   adding to a waveform, 271
   waveform, adding to, 271
cw, 331
CW (no modulation) softkey, 56
CW mode
description, 4

D
dac over range error, 191, 196
dac over range protection
   baseband frequency offset, 198
   phase noise, 264
Dark Color softkey, 26
data
calibration, 309
entry softkeys, 43
erasing, 312
files, 62–69
   removing, 312
serial, synchronizing, 20
storage
   comments, adding and editing, 70
troubleshooting, 323
type, 73
Index

using, 62

date, setting, 28
dc offset, 138
dc offset, removing, 77
DCFM/DCfM Cal softkey, 75
DECT softkey, 268
Default Gateway softkey, 31
default settings
    restoring, 27, 31, 205
    system, restoring, 42
Default softkey, 268
delay
    I/Q, 203
    multiple BBG sync, 223
Delete softkeys
    All Regs in Seq, 69
    All Segments On Int Media, 144
    All Segments On USB Media, 144
    All Sequence Files, 63
    All Sequences, 69, 126
    All Waveforms, 147
    All Waveforms softkey, 171
File, 63
    File or Directory, 63, 65, 68, 73
Item, 56
    Row, 56
    Selected Waveform, 147, 171
    Seq Reg, 69
    Waveform Sequence, 171
description & plots, phase noise, 261
dETHTR annunciator, 12, 13
Device softkey, 45, 47
    DHCP, 31, 331
    DHCP softkey, 31
Diff Mode softkeys, 203
differential encoding, 289
differential encoding, bits per symbol, 291
differential state map, bits per symbol, 291
DIGBUS annunciator, 12, 14
digital bus, 19
digital modulation
    formats, 4
    IQ map, QAM, 290
    multitone, 304–307
    TDMA, 271
two tone, 298–303
digital modulation type
    modifying, 274
digital operation, 141, 231, 239
digital signal to analog waveform, 191
display
    blanking, 315
    error message area, 13
    memory, 309
    overview, 5, 13
overview, N5161A/02A, 13
overview, N5181A/82A/83A, 11
secure, 315
    settings, 26
    softkey labels, 13
    softkeys, 25, 43, 162
tests, 325
text area, 13
troubleshooting, 318
Display softkeys
    Case, 43
delay, 25
    Waveform And Markers, 162
Displayed Case softkeys, 43
distortion, troubleshooting, 319
DNS Server Override softkey, 31
DNS Server softkey, 31
documentation, xiii
Domain Name softkey, 31
doublet
    adjustable, 130
    softkeys, 128
    trigger, 130
Dual ARB
    FIR table editor, 210, 215
    real-time modulation, 219
    user-defined FIR, 210
dual ARB
    multi-BBG sync, 220
    player, 142
    real-time noise, 251
    softkeys, 143, 252, 253, 254, 255, 260
dual arb, 266
dual ARB player, 5
Dual ARB Real-Time
    filters, 209
dual arbitrary waveform generator, 5
dual display, power meter, 80
dwell time, 56, 331
Dwell Type softkey, 56
dwell, troubleshooting, 322
Dynamic DNS Naming softkey, 31
Dynamic Hostname Services softkey, 31

E
E4428C, E4438C softkey, 33, 35
E442xB, E443xB softkey, 33, 35
E8247C, E8257C, E8267C softkey, 33, 35
E8257D, E8267D softkey, 33, 35
EDGE
    custom digital modulation, predefined, 271
    EDGE softkey, 268
    Edit softkeys
Index

Description, 151
Noise RMS Override, 151
Repetitions, 171
RMS, 151
Selected Waveform Sequence, 147, 171
Editing Keys softkey, 43
Editing Mode softkey, 43
EEPROM, 309
Enable/Disable Markers softkey, 147, 171
Enter Directory softkey, 67
entry, active, 331
equalization
  filter, 207
  filter, user, 207
equipment setup, 224
equipment, user flatness correction, 90, 91
ERR annunciator, 12, 14
Error hardkey, 74
e error messages, 74
  DAC over range, 191, 196
  display area, 13
  file, 324
  message format, 74
types, 324
Esc hardkey, 6
EVENT
  connector, AUX I/O, 20
  connector, BNC, 19, 157
  output jitter, 173
  outputs, 157
EVM, 331
EVM error, 138
example
  5-Pack License, adding, 243
  5-Pack License, history, 248
  Waveform 5-Pack License, adding, 243
  Waveform 5-Pack License, history, 248
  Waveform license, Opt 25x
  adding a waveform, 236
  locking a slot, 236
examples
  FIR filters
    creating, 210, 281
    modifying, 215, 286
  Execute Cal softkey, 205
  EXT CLOCK connector, 18
  EXT REF annunciator, 11, 12, 13, 14
  Ext softkeys
    Delay, 176
    Delay Time, 176
    Ext, 49
    I/Q Output, 200, 201
    Pulse, 128
    Source, 176
  extension, file, 67
  external
    I and Q signals, 202
    media, 73, 323
    modulation source, 77
    reference oscillator, using, 46
    trigger source, 178, 180
    triggering, 180
  external leveling, 102–109
  softkeys, 102
  external leveling, configuring, 106
  External softkeys
    External, 200
    Input, 203
    Input I Offset, 138
    Input Q Offset, 138
    Output, 203
F
  factory defaults, restoring, 27, 31, 205
  features, 2
  feedthrough, 138
  feedthrough, carrier, minimizing, 301
  File hardkey, 63, 72
  file headers
    creating, 151
    editing, 153
    example, 154
    viewing a different file, 155
  files
    catalog. See data storage extensions, 67
    working with, 62
  filter
    equalization, 207
    real-time modulation
      softkey location, 219
    user, equalization, 207
  filter, interpolator, 191
  filters
    finite impulse response, 209, 281
    FIR, 209, 281
    gaussian, loading default, 216, 287
    nyquist, selecting, 275
  filters Dual ARB, 209
  finite impulse response filters
    using, 209, 281
  FIR filter
    apodization settings, 216, 287
    Hamming, 216, 287
    Hann, 216, 287
    Kaiser, 216, 287
    window settings, 216, 287
  FIR filters
    Arb Custom, 281
    creating, 210, 281
Index

modifying, 215, 286
storing, 214, 285
using, 209, 281
FIR table editor
accessing, 210, 281
Arb Custom, 286
coefficients, duplicating, 212, 284
coefficients, entering values, 210, 282
coefficients, modifying, 217, 288
Dual ARB, 210, 215
files, loading, 216, 287
filters
creating, 210, 281
modifying, 215, 286
storing, 214, 218, 285, 289
oversample ratio, setting, 213, 284
firmware
memory, 309
upgrading, 29, 328
First Mkr Point softkey, 162
First Sample Point softkey, 162
Fixed softkey, 110
flash memory, 309
flatness correction. See user flatness correction
Flatness softkey, 89
FM
anunciator, 12, 14
connector, 16, 22
dc offset, removing, 77
external source, 77
hardkey, 75
softkeys, 75
Free Run softkey, 49, 117, 175
Free-Run softkey, 128
Freq Dev softkey, 269
FREQ hardkey, 45, 47
Freq softkeys, 89
frequency
display area, 11
hardkey, 7, 8, 45, 47
modulation, 75
multiplier, 115
offset, 113
offset, baseband, 196
offset, softkeys, 196
reference, 114
setting, 45, 47
softkeys, 45, 47
step sweep, 52
frequency units, 45
front panel
disabling keys, 315
display, 13
display, N5161A, 13
display, N5181A, 11
display, N5182A, 11
display, N5183A, 11
I/Q inputs, using, 139
knob resolution, 28
overview, 5, 9
tests, 325
FSK softkey, 269
FTP Server softkey, 32
fundamental operation See basic operation
G
Gated softkey, 128, 175
gated triggering, 176, 178
Gaussian
definition, 331
gaussian filter, loading default, 216, 287
Gaussian. See AWGN
glossary, 331
Go To Default Path softkey, 63, 65, 73
Goto Row softkey, 56, 63
GPIB
card, 17, 23
definition, 331
setup, 30
softkeys
Address, 30
Setup, 30
green LED, 8, 10
GSM softkey, 268
guides, content of, xiii
H
hardkeys
definition, 331
help on, 42
overview, 5, 9
See also specific key
header utilities softkeys, 151
Help hardkey, 7, 42
Hostname softkey, 31
hostname, setting, 31
HP 3300A, emulating, 126
I
I connector, 7
I Offset softkey, 203
I OUT connector, 18
I/O Config softkey, 25
I/Q
adjustments, 138, 203
front panel inputs, using, 139, 202
Int Equalization Filter softkeys location, 208
modulation, 138, 200
optimizing, 201
rear panel outputs, 18
rear panel outputs, using, 201
signal path, optimizing, 201
signal, aligning, 158
softkey, 208
softkeys, 138, 200–206
waveform, clipping, 181
ideal low-pass filter. See rectangular filter IF, 331
images, 138
impairments
I/Q adjustments, 138
impairments, real-time
  phase noise, 259
Import Waveform softkey, 171
Incr Set hardkey, 8
information, removing from memory, 312
Insert softkeys
  Insert, 147
  Item, 56
  Row, 56
  Waveform, 147
  Waveform Sequence Contents, 147
Install Assembly softkey, 39
Install licenses softkey, 67
installation guide content, xiii
instrument
  8757D Scalar Network Analyzer, 54
  firmware, upgrading, 29
  scalar network analyzer, 54
softkeys
  Adjustments, 25
  Info, 25
  Options, 38
state
  associating with waveform, 70
  files, 69, 72
  register. See data storage softkey, 68
Int Equalization Filter
  softkeys, 208
int media, 331
Int Phase Polarity softkey, 200
interface
  GPIB, 30
  LAN, 31
internal
  reference oscillator, using, 29
  Internal Baseband Adjustments softkey, 203
  internal media, 73
  Internal Storage to USB softkey, 68
  Internal/USB Storage Selection softkey, 63
  interpolator filter, 191
IP
  Address softkey, 31
  address, setting, 31
  auto, 31
  definition, 332
  IQ map, QAM modulation, 250
J
jitter on EVENT output, 173
K
keyboard, using, 126
keys
  disabling, 315
  front panel, 5, 9
  help on, 42
  numeric, 6
  test, 325
  See also specific key knob, 8, 28, 43
L
L annunciator, 12, 14
LAN
  connector, 17, 23
  definition, 332
  Services Setup softkey, 30
  setup, 31
  Setup softkey, 30
  Last Mkr Point softkey, 162
  Last softkey, 27
  LCD display memory, 309
  LEDs, 8, 10
  blink test, 325
  front panel, 8, 10
  modulation, 61
leveling
  external, 102–109
  turn off ALC, 110
licenses
  manager, 37
  service software, 37
  signal studio, 37
  time-based, 28
  troubleshooting, 328
  viewing, 37
  waveform, 37
line power (green) LED, 8, 10
linear sweep, 50
linear sweep, 50
list mode values, 57
List softkey, 63
list sweep
  parameters, 57
  status information, 57
  troubleshooting, 322
  using, 56
  waveform, 58
listener mode annunciator, 12, 14
Index

LO, 322
Load From Selected File softkey, 65, 67
Load List softkey, 67
Load softkeys
   All From Int Media, 144
   All From USB Media, 144
Cal Array From Step Array, 89
From Selected File, 66, 67
Load/Store, 56, 66, 67
Segment From Int Media, 144
Segment From USB Media, 144
Store, 144
Sweep List, 67
Load/Store softkey, 56, 65, 67
Local hardkey, 6
lock up, troubleshooting, 318
logarithmic sweep, 50
LVDS
   MXG, 2
   PXB, 2
LVDS compatibility with the PXB, 2
LXI, 332
   configuring the output events, 124
   configuring the subsystem, 122
   configuring the trigger input events, 123
   getting started, 122
   understanding the clocks, 120
   using, 120
LXI, option ALB, 120, 122

M
   main memory, 309
   manual control, sweep, 60
   Manual softkey, 110
   Manual softkeys
      Config Settings, 31
      Manual, 31
      Mode, 49
      Point, 49
   manuals, content of, xiii
   Marker softkeys, 162
   markers
      frequency
         N5183A, 54
      step sweep, 54
   markers, aligning signal, 158
   markers, waveform, 157–173
   memory
      erasing data from, 312
      types, 309
   See also media
   menu keys, 6
   messages, error, 324
   messages, warning
      5-PACK Licensing, 250
      Opt 25x Licensing, 238
   Waveform 5-Pack Licensing, 250
   mirror table, duplicating coefficients, 212, 284
   mixer, troubleshooting signal loss, 320
   Mod On/Off hardkey, 7, 60, 61
   Mod On/Off, Option UNT, 75
   Mod Type Softkeys, 209
   Mode hardkey, 143, 252, 253, 254, 255, 257, 260
   mode, modulation, 332
   modes of operation, 4
   Modulated softkey, 110
   modulation
      AM, 75
      analog, 4
      annunciators, 12, 14
      carrier signal, 60
digital, 4
   external source, using, 77
   FM, 75
generating, 60
   I/Q, 138, 200
   phase, 75
   pulse, 4, 127
   real-time filter, softkeys, 219
   simultaneous, 62
troubleshooting, 318
   Modulator Atten softkey, 257
   monochrome display, setting, 26
   Monochrome softkey, 26
   MSK softkey, 269
   MULT annunciator, 12, 14
   multi-BBG sync, 220
   configure setup, 224
equipment setup, 224
resynchronize, 226
system delay, 223
system sync, 223
trigger setup, 223
   multicarrier setup
   APCO 25 w/C4FM, 278
   APCO 25 w/CQPSK, 278
   Bluetooth, 278
   CDPD, 278
   DECT, 278
   Default, 278
   EDGE, 278
   GSM, 278

342 Agilent N5181A/82A MXG Signal Generators User’s Guide
Index

NADC, 278
PDC, 278
PHS, 278
PWT, 278
TETRA, 278
multicarrier setup softkeys, 278
multicarrier TDMA waveforms
creating, 278
multicarrier, Default softkeys. See quick setup, Default
softkey, settings
multiplier, using, 115
multitone, 266, 304–307
multitone mode, 4, 5
Multitone softkeys, 304
multitone waveform, setup, 297
MXG
LVDS, 2
MXG ATE N5161A/82A Front Panel Functions, 9, 10

N
NADC softkey, 268
Name And Store softkey, 171
Next REG softkey, 126
Next SEQ softkey, 126
No action softkey, 67
No Retrigger softkey, 175
noise, 251
noise bandwidth factor, 251
Noise Bandwidth softkey, 252
Noise Mux softkeys, 254, 255
Noise softkey, 252, 254, 255
non-volatile memory, 142
non-volatile, definition, 332
number keys, 43
numeric keypad, 6
nyquist filter
definition
nyquist filter, selecting, 275

O
OFFS annunciator, 12, 14
offset, 138
offsets
baseband frequency, 196
I/Q, 203
output, using, 113
on/off switch, 8, 10
operation
modes of, 4
operation, basic, 41
operation, remote, 30
optimization, I/Q, 138, 200
option 430
multitone mode, 304
two tone mode, 298
two-tone mode, 298
Option 22x, 239
option ALB, LXI, 120, 122
Option U01, 97, 99
internal channel correction, 97, 99
Option UNT
Mod On/Off hardkey, 75
options
651/652/654
description, 4
multitone mode, 304
two-tone mode, 298
670/671/672, description, 4
enabling, 25, 37
resource, 3
UNT, 4
UNU, 4
UNW, 4
Options 221–229, 239
Options 250–259, 231
Options Info softkey, 38
oscillator, external reference, 46
oscillator, internal reference, 29
Output Blanking softkey, 45, 47
Output Mux softkeys, 252
output, swept, 48
over range error, DAC, 191, 198, 264
overshoot, 191
overview, signal generator, 1

P
Page Up hardkey, 6
parameters, saving a waveform’s, 151
path delay, 138
PATT TRIG IN connector, 19
Patt Trig In softkeys, 176
PDC softkey, 268
peak-to-average power, reducing, 185
performance, optimizing, 79
persistent
memory, 311
persistent settings
definition, 332
resetting, 42
restoring defaults, 27
phase noise
adjustments, 263
DAC over range & scaling, 264
description & plots, 261
impairments, 259
softkeys, 260
Phase Ref Set softkey, 45, 47
phase skew, 138
PHS softkey, 268
Index

pixel test, 325
Plot CDDF softkey, 190
PM Config
  Calibrate Sensor, 92
  Zero Sensor, 92
PM Config softkeys
  Connection Type, 92
  PM VXI-11 Device Name, 92
  Power Meter IP Address, 92
  Power Meter IP Port, 92
Point Trigger softkey, 49
point-to-point time, 332
polarity, external trigger, 176
polarity, marker, setting, 170
power
  meter, 88, 93
  on, settings, 27
  peak-to-average, reducing, 185
  receptacle, 15, 21
  search, 111
  search automatic, 113
  search settings, 113
  sensor, models, 90, 91
  setting, 45, 47
  softkeys, 25, 27, 110
  supply, troubleshooting, 318
  switch, 8, 10
  troubleshooting, 319
  user settable, maximum, 47
Power Control Mode softkeys, 253
power meter
  configuration, 93
  U2000 Series, 93
  U2000A/01A/02A/04A, 93
dual display, 80
power meter configuration softkeys. See PM Config softkeys
power meter softkeys. See PM Config softkeys
Power Search Reference softkey, 110
Power Search References, 111
Power softkeys
  On, 27
  On/Preset, 25
  Search, 110
power units, 45
preferences, setting, 25
preset
  hardkey location, 7
  settings, 27
  troubleshooting, 323
  using, 42
Preset softkeys
  Language, 27
  List, 56, 89
  Preset, 27
  Prev REG softkey, 126
  Prev SEQ softkey, 126
  Proceed With Reconfiguration softkey, 31, 32
programming guide content, xiii
protection, DAC over range
  baseband offset frequency, 188
  phase noise impairment, 264
PSK softkey, 269
pulse
  annunciator, 12, 14
  characteristics, 129
  connector, 16, 22
  marker, viewing, 167
  modulation, 127
  narrow, 110
  sync signal, 50
  video signal, 50
  Pulse hardkey, 128
  pulse modulation, 4
  Pulse softkeys, 50, 128
  Pulse/RF Blank softkey, 162
  PWT softkey, 268
  PXB
    LVDS compatibility, 2
Q
  Q connector, 8
  Q Offset softkey, 203
  QAM modulation IQ map, 290
  QAM softkey, 269
  quadrature adjustment, 203
  quadrature angle, 138
  Quadrature Angle Adjustment softkey, 138, 203
  queue, error, 74
quick setup
  Default softkey
    settings, 268
  Quick Setup Softkeys, 268
R
  R annunciator, 12, 14
raised cosine filter. See nyquist filter
RAM, 309, 311
real-time
  AWGN
    softkeys, 252, 253, 254, 255
  I/Q Baseband AWGN softkeys, 257
  modulation filter, 219
  modulation filter, setting, 219
  noise, 251
  phase noise, 259
  adjustments, 263
  DAC over range & scaling, 264
  description & plots, 261
  impairments, 259
**Index**

**softkeys**, 260

real-time modulation
Dual ARB, 219
real-time modulation filter
softkey, 219
rear panel
I/Q outputs, 201
overview
n5161a, 15
n5162a, 15
n5181a, 15
n5182a, 15
n5183a, 21
Recall hardkey, 69
Recall keys
hardkey, 126
Instrument State, 63, 67
Reg, 126
State, 67
recall register, troubleshooting, 322
receiver test, 266
rectangular clipping, 186, 189
rectangular filter
definition, 332
REF annunciator, 12, 14
REF IN connector, 17, 22
Ref Oscillator Ext Bandwidth key, 46
Ref Oscillator Ext Freq key, 46
Ref Oscillator Source softkey, 45, 47
Ref Oscillator Tune key, 29
reference oscillator tune, internal, 29
reference oscillator, external, 46
reference, using, 114
references, content of, xiii
regrowth, spectral, 184
remote interface, emulate HP 3300A, 126
Remote Language softkey, 30, 33, 35
remote operation annunciator, 12, 14
remote operation preferences, 30
Remove Assembly softkey, 39
Rename File softkey, 63
Rename Segment softkey, 144
Reset & Run softkey, 175
Restart on Trig softkey, 175
Restore softkeys
LAN Settings to Default Values, 31
System Settings to Default Values, 27
resynchronize, multi-BBGs, 226
Return hardkey, 8
Reverse Power Protection softkey, 27
Revert to Default Cal Settings softkey, 205
RF
blanking
marker function, 168
settings, saving, 158
hardkey, 7
output
configuring, 46
connector, 7
leveling, external, 102–109
troubleshooting, 318
RF During Power Search softkey, 110
RF Output softkey, 200, 201
RFC NETBIOS Naming softkey, 31
ringing, 191
ripple, 191
RMS, 332
RMS softkey, 110
Rohde & Schwarz softkey, 33, 35
root, 332
root cosine filter. See root nyquist filter
root mean square, 332
Root Nyquist Filter
definition, 332
root nyquist filter
definition, 332
rotary knob, 43
Route Connectors softkey, 49, 128
Route To softkeys, 50, 128
routing
I/Q, 138, 200
marker
ALC hold, 159
RF blanking, 168
saving settings, 158
RPG test, 325
runtime scaling, 193
S
S annunciator, 12, 14
sales, Agilent offices, 328
sample rate clock, 20
sample rate softkey, 173
Save hardkey, 69
SAVE Seq Reg softkey, 69
Save Setup To Header softkey, 151
Scale Waveform Data softkey, 190
scaling softkeys, 190
SCPI
enabling, 32
reference content, xiii
softkey, 33, 35
screen saver settings, 26
Screen Saver softkey, 26
search, power, 111
secure
display, 315
mode, 314
security, 309
Security softkey, 63
Segment Advance softkey, 175
segment advance triggering, 175
segments
  advance triggering, 177
  file headers, 151
  loading, 144
  softkeys, 144
  storing, loading, & playing, 144
Select hardkey, 43
Select Seq softkey, 126
Select softkeys
  Color Palette, 26
  Different Header, 151, 155
  Header, 151
  Internal File(s) to Copy to USB, 68
  Reg, 69
  Seq, 69
  Waveform, 56
self test, 328
Sequence softkey, 63, 151
sequences
  editing, 149
  file headers, 151
  marker control, 170
  playing, 150
  waveform, 147
serial data, synchronizing, 20
server, enabling, 32
service
  Agilent offices, 328
  guide content, xiii
  request annunciator, 12, 14
Set Marker softkeys
  Alpha Table, 43
  Waveform Sequence, 147
  Waveform Sequence Contents, 147, 171
signal generator
  modes, 4
Signal Studio, 3
signal studio licenses, 37
sinewave, 332
Single softkey, 175
Single Sweep softkey, 49
skew, I/Q, 283
Sockets SCPI softkey, 32
sockets, enabling, 32
softkeys
  definition of, 333
  help on, 42
  label area, 13
  location, 5
  See also specific key
source settled signal, 50
Source Settled softkey; 50, 128
Span softkey, 110
Specify Default Storage Path for User Media softkey, 63
spectral regrowth, 184
spectrum analyzer, troubleshooting signal loss, 319
square root raised cosine filter. See root nyquist filter
Square softkey, 128
standard, modulation, 332
standby (yellow) LED, 8, 10
State softkey, 63
states, persistent, 332
step array (user flatness), 94
  See also user flatness correction
Step Dwell softkey, 51, 117
Step Spacing softkey, 51
step sweep
  spacing, 50
  troubleshooting, 322
  using, 50
Step/ Knob Ratio softkey, 28
Storage Type softkey, 65, 73
Store Custom Dig Mod State softkey, 270
Store To File softkey, 65, 66, 67
Stored Segments softkey, 63, 151
Subnet Mask softkey, 31
Sum softkey, 200
sweep
  annunciator, 12, 14
  hardkey, 49
  linear, 50
  list parameters, 57
  list status information, 57
  logarithmic, 50
  manual control, 60
  mode, 4
  out connector, 15, 21, 50
  out signal, 50
  softkeys, 49–60, 128
  step, 50
  troubleshooting, 322
  waveform, including, 58
Sweep hardkey, 49
Sweep softkeys, 49–60, 68, 128
swept output, 48
switch, power, 8, 10
SWMAN annunciator, 12, 14
synchronize multi-BBGs, 220
  configure setup, 224
  equipment setup, 224
  resynchronize, 226
  system delay, 223
  system sync, 223
  trigger setup, 223
  system defaults, restoring, 27
Index

T
T annunciator, 12, 14
talker mode annunciator, 12, 14
TCP, 333
TCP Keep Alive softkeys, 31
TDMA
custom digital modulation, predefined, 271
TDMA digital modulation, 271
terminator, 333
test, self, 326
test, self-web-enabled, 326
tests, front panel, 325
TETRA softkey, 268
text area (on display), 13
text entry softkeys, 144
time, dwell, 331
time, setting, 28
time/date reference point, 28
Time/Date softkey, 28
time-based license, 28, 328
Timer Trigger softkey, 49, 117
Toggle softkeys, 171
Total Noise softkey, 253
Total softkey, 253
Trig
in connector, 16, 22
out connector, 16, 22, 50
out signal, 50
trigger
collectors, 16, 22
hardkey, 6
initiating, 6
multiple BBG sync, 223
Trigger setup softkeys, 119
Trigger softkeys
& Run, 175
Doublet, 126
Key, 49
Out Polarity, 49
Source, 174
Triggered, 128
Type, 174
Triggered softkey, 128
trigging
gated, 176, 178
multiple BBG sync, 223
equipment setup, 224
segment advance, 175
softkeys, 174
waves, 174
troubleshooting, 317
two tone, 286, 288–303
two tone softkeys, 299
two-tone softkeys, 299
two-tone waveform, setup, 287
type, modulation, 332

U
UNLEVEL annunciator, 12, 14
unleveled operation, 110
UNLOCK annunciator, 12, 14
Unspecified softkey, 151
UNT, option, 4
UNU, option, 4
UNW, option, 4
Up Directory softkey, 63, 65, 68
Update in Remote softkey, 26
urls, 3, 29, 37, 328
USB
connecting media, 73
definition, 333
device connector, 17, 23
host connector, 5, 9
keyboard, using, 126
softkeys
File Manager, 63, 64
Keyboard Control, 126
to BBG Memory softkey, 68
to Internal Storage softkey, 68
troubleshooting, 323
Use softkeys
As, 67
Current Directory As Default Path, 63, 73
Only Internal Storage, 63
Only USB Media, 63
user
documentation content, xiii
files, backup and restore, 62
flatness correction, 88
preset, 42
preset, troubleshooting, 323
user FIR
definition, 333
User softkeys
Configure Power Meter, 89
Current Directory As Default Path, 65
Do Cal, 89
Flatness, 45, 47, 63
Flatness Correction, 89
Flatness Corrections, 68
Span, 110
User, 27
user-defined FIR
dual ARB, 210
Utility hardkey, 25
Utility softkey, 39

V
vector operation, 141, 231, 239
View Next Error Page softkey, 74
Index

View Previous Error Page softkey, 74
volatile memory, 142, 144
volatile, definition, 333
VXI-11, enabling, 32
VXT-11 SCPI softkey, 32

W
waveform
  adding custom modulation, 271
Waveform 5-Pack
  history, using, 246
  history, waveform files, 246
  installing, 239
  licensing, 239
  licensing, understanding, 239
  licensing, warning messages, 250
  licensing, waveform file, 240
  status messages, 242
  using, 239
Waveform license, Opt 25x
  adding a waveform, 233
  backup warning, 238
  file missing warning, 238
  license status messages, 235
  licensing, installing, 231
  licensing, understanding, 231
  licensing, warning messages, 238
  lock warning, 238
  replacing a waveform, 233
  status messages, 235
  using, 231
  waveform licensing softkeys, 233
Waveform softkeys
  Licenses, 38
  Runtime Scaling, 190
  Segments, 144
  Sequences, 147, 171
  Utilities, 190
  Waveform, 49, 56
waveforms
  clipping, 181
  file headers, 151
  from digital baseband waveform, 191
  in a sweep, 58
  license, 37
  markers, 157, 158
  memory, 311
  multiple BBG synchronization, 220
  multitone, 304–307
  overview, 142
  saving instrument state, 70
  scaling, 150
  segment softkeys, 144
  sequence, 147
  storing, loading, & playing, 144

Z
Z-axis output
  connector, 23
Zoom softkeys, 162

Y
yellow LED, 8, 10

Agilent N5181A/82A MXG Signal Generators User’s Guide