Notices

Copyright Notice
© Keysight Technologies 2013-2018
No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Keysight Technologies as governed by United States and international copyright laws.

Manual Part Number
W4000-90063

Edition
Edition 3, July 2018

Printed in:
Printed in Malaysia

Published by:
Keysight Technologies
Bayan Lepas Free Industrial Zone,
11900 Penang, Malaysia

Technology Licenses
The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Declaration of Conformity
Declarations of Conformity for this product and for other Keysight products may be downloaded from the Web. Go to http://www.keysight.com/go/conformity. You can then search by product number to find the latest Declaration of Conformity.

U.S. Government Rights
The Software is "commercial computer software," as defined by Federal Acquisition Regulation ("FAR") 2.101. Pursuant to FAR 12.212 and 27.405–3 and Department of Defense FAR Supplement ("DFARS") 227.7202, the U.S. government acquires commercial computer software under the same terms by which the software is customarily provided to the public. Accordingly, Keysight provides the Software to U.S. government customers under its standard commercial license, which is embodied in its End User License Agreement (EULA), a copy of which can be found at http://www.keysight.com/find/sweula. The license set forth in the EULA represents the exclusive authority by which the U.S. government may use, modify, distribute, or disclose the Software. The EULA and the license set forth therein, does not require or permit, among other things, that Keysight: (1) Furnish technical information related to commercial computer software or commercial computer software documentation that is not customarily provided to the public; or (2) Relinquish to, or otherwise provide, the government rights in excess of these rights customarily provided to the public to use, modify, reproduce, release, perform, display, or disclose commercial computer software or commercial computer software documentation. No additional government requirements beyond those set forth in the EULA shall apply, except to the extent that those terms, rights, or licenses are explicitly required from all providers of commercial computer software pursuant to the FAR and the DFARS and are set forth specifically in writing elsewhere in the EULA. Keysight shall be under no obligation to update, revise or otherwise modify the Software. With respect to any technical data as defined by FAR 2.101, pursuant to FAR 12.211 and 27.404.2 and DFARS 227.7102, the U.S. government acquires no greater than Limited Rights as defined in FAR 27.401 or DFAR 227.7103–5 (c), as applicable in any technical data.

Warranty
THE MATERIAL CONTAINED IN THIS DOCUMENT IS PROVIDED “AS IS,” AND IS SUBJECT TO BEING CHANGED, WITHOUT NOTICE, IN FUTURE EDITIONS. FURTHER, TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, KEYSIGHT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, WITH REGARD TO THIS MANUAL AND ANY INFORMATION CONTAINED HEREIN, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. KEYSIGHT SHALL NOT BE LIABLE FOR ERRORS OR FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES IN CONNECTION WITH THE FURNISHING, USE, OR PERFORMANCE OF THIS DOCUMENT OR OF ANY INFORMATION CONTAINED HEREIN. SHOULD KEYSIGHT AND THE USER HAVE A SEPARATE WRITTEN AGREEMENT WITH WARRANTY TERMS COVERING THE MATERIAL IN THIS DOCUMENT THAT CONFLICT WITH THESE TERMS, THE WARRANTY TERMS IN THE SEPARATE AGREEMENT SHALL CONTROL.

Safety Information

CAUTION
A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

WARNING
A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.
Table of Contents

Introduction .................................................. 5
Installing Keysight IO Libraries .............................. 5
Installing Keysight VEE Pro ................................. 6
Launching Keysight VEE Pro ................................. 10
Instrument Communication Tutorial ...................... 11
Virtual Source Tutorial ...................................... 15
Keysight VEE 9.33 Features ................................. 21
    System requirements .................................... 21
    Microsoft Office Excel Supportability ................. 21
Keysight Connectivity Products ......................... 22
Keysight Support, Services, and Assistance ............ 23
Appendix ..................................................... 24
THIS PAGE HAS BEEN INTENTIONALLY LEFT BLANK.
Introduction

Welcome to the Keysight VEE family! Keysight Visual Engineering Environment (VEE) is a powerful visual language environment that dramatically reduces your development time. To get you started quickly on Keysight VEE, we have prepared this guide to show you how to install and use your new software. This guide also contains two tutorials that show you how to communicate with an instrument via the USB interface, and how to generate and display a waveform from a virtual source.

Installing Keysight IO Libraries

Keysight IO Libraries Suite is a collection of free instrument control software that automatically discovers instruments and allows you to control instruments over LAN, USB, GPIB, RS-232, and other interfaces. For more information, or to download IO Libraries, go to www.keysight.com/find/iosuite.

You are required to install the Keysight IO Libraries Suite 18 before installing Keysight VEE if you need to communicate with instruments using Keysight VEE. However, you can choose not to install the Keysight IO Libraries Suite if you do not use instruments.
Installing Keysight VEE Pro

1. Go to www.keysight.com/find/vee_download to download the software. Click the download link and save the installer. Run the downloaded installer. The InstallShield Wizard will guide you through the installation process.

2. The InstallShield Wizard will check if Keysight IO Libraries Suite 18 is installed. If it is not, the following message box will appear.

   Please note that Keysight IO Libraries Suite 18 is a prerequisite if you communicate with instruments using Keysight VEE. So, please install Keysight IO Libraries Suite 18 or higher after finishing this installation.

3. Click OK, the InstallShield Wizard will check if Microsoft .NET Framework 3.5 SP1 is installed.
4 If Microsoft .NET Framework 3.5 SP1 is not installed, following Question dialog box will appear to ask you to install it. Click Yes to install the Microsoft .NET Framework 3.5 SP1 immediately. After the installation, the Keysight VEE installation will continue automatically. Clicking No will abort the Keysight VEE installation.

If Microsoft .NET Framework 3.5 SP1 is installed, the InstallShield Wizard will guide you to the next step directly to install your Keysight VEE selection in Step 1.

5 Click Next, when the following dialog box appears.

6 Accept the license agreement when the License Agreement dialog box appears, then click Next.
7 Type your name, company name, and product key when the Customer Information dialog box appears, then click **Next**. The product key is contained in the Keysight VEE Pro Product Key Certificate.

8 Click **Next** to accept the default settings when the following dialog box appears.
9 Click **Finish** to complete the installation.
Launching Keysight VEE Pro

Go to **All Programs > Keysight VEE Pro 9.3 > VEE Pro 9.3** to launch Keysight VEE Pro.

You can access the demos, MATLAB examples as well as sample programs via the Keysight VEE Pro welcome window. You may close the window after exploring it.

You can also open sample programs from the menu bar. To open a sample program, go to **File > Open Example ...** or **Help > Open Example ...**
Instrument Communication Tutorial

In this tutorial, we will connect to an instrument via the USB interface. Ensure that the Keysight IO Libraries Suite 18 is installed before proceeding.

If you do not have a USB instrument, the tutorial for a GPIB instrument is similar from Step 3 onwards.

1. Connect to an instrument via any USB port on your PC. Then, turn on the instrument. The Found New Hardware Wizard dialog box will appear. Just step through the wizard by clicking Next.

2. Launch Keysight VEE Pro, if you have not. Click the Instrument Manager button on the toolbar.

3. The Instrument Manager tool window will appear. Click the Find Instruments button to automatically detect all instruments connected to your PC.

4. Click OK if the Identify Instrument pop-up dialog box appears. This automatically identifies the instrument on the USB interface. In this example, the Keysight 34450A 5½ Digit Multimeter is present.
5 Right click newInstrument in the Instrument List panel. Then, choose Create Direct I/O Object to place a Direct I/O object for the selected new instrument on the workspace. This object allows you to send/receive commands to/from your instrument.

6 Double-click the Direct I/O object blue transaction bar to add a transaction to the Direct I/O object.

7 Type "*IDN?" (include the quotation marks) in the I/O Transaction dialog box as shown below. A list of available SCPI commands may appear while you are typing. You can choose one command as desired instead of typing the whole command. Click OK to proceed.

*IDN? is one of standard commands for programmable instruments (SCPI) command that queries the instrument for its identification string.
8 After sending the “*IDN?” query to the instrument, you need to read back its response. Double-click the text box of the newInstrument object to add a new transaction. This time, select the transaction to **READ a STRING FORMAT** text to an output terminal named x. The output terminal x will be automatically created when you click **OK**.

9 Select **Display > AlphaNumeric** and place an AlphaNumeric object on the workspace to the right of the Direct I/O object.
10 You will now connect the Direct I/O object to the AlphaNumeric object. Place the mouse cursor beside the Direct I/O output terminal and a square icon will appear. Left-click and drag a line to the input terminal of the AlphaNumeric object. Left-click again to complete the connection.

11 Run the program by clicking the Run button on the toolbar.

12 The AlphaNumeric object will display the identification string output by the instrument as shown below.

13 To save your VEE code, select File > Save As and name the file as Tutorial 1.vee.
Virtual Source Tutorial

In this tutorial, you will generate and display a waveform from a virtual source. No instrument is needed.

1. If you have an existing program in your Keysight VEE Pro workspace, select File > New. Then, select Device > Virtual Source > Function Generator and place a function generator object on the workspace.
2  By default, the function generator will generate a virtual cosine waveform at a frequency of 200 Hz, and an amplitude of 1.

3  Select Display > XY Trace and place an XY Trace object to the right of the function generator.

4  Connect the function generator output terminal to the input terminal of the XY trace. Place the mouse cursor beside the function generator output terminal and a square icon will appear. Left-click and drag a line to the input terminal of the XY Trace object. Left-click again to complete the connection.
5 Click the Run button on the toolbar and you can see the cosine waveform displayed on the XY Trace object.

6 Select Display > Spectrum (Freq) > Magnitude Spectrum and place a Magnitude Spectrum object on the workspace below the XY Trace object.
7 Connect a second line from the output of the function generator to the input of the Magnitude Spectrum object using the same left-click and drag method as described in Step 4.

8 Click the Run button and observe the magnitude spectrum display. As the waveform is a 200 Hz cosine, the magnitude spectrum displayed will be a vertical line at the frequency of 200 Hz.
9 Change the waveform function on the virtual function generator to a square waveform.

10 Click the Run button and observe the difference. Keysight VEE gives you the flexibility to analyze your signal source in multiple graph displays simultaneously.
To save your VEE code, select **File > Save As** and name the file as *Tutorial 2.vee*.
Keysight VEE 9.33 Features

System requirements

Keysight VEE 9.33 supports the following operating systems.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor Speed</td>
<td>1 GHz 32-bit (x86), 1 GHz 64-bit (x64), no support for Itanium64</td>
<td>1 GHz 32-bit (x86), 1 GHz 64-bit (x64), no support for Itanium64 or Windows 8 RT</td>
<td>1 GHz 32-bit (x86), 1 GHz 64-bit (x64), no support for Itanium64</td>
</tr>
<tr>
<td>Available memory</td>
<td>1 GB minimum</td>
<td>1 GB minimum</td>
<td>1 GB minimum</td>
</tr>
<tr>
<td>Available hard disk space[a]</td>
<td>1.5 GB available hard disk space, includes:  - 1 GB available for Microsoft.NET Framework 4.6  - 100MB for Keysight IO Libraries Suite</td>
<td>2.5 GB available hard disk space, includes:  - 2 GB available for Microsoft.NET Framework 3.5 and 4.6  - 100MB for Keysight IO Libraries Suite</td>
<td>2.5 GB available hard disk space, includes:  - 2 GB available for Microsoft.NET Framework 3.5 and 4.6  - 100MB for Keysight IO Libraries Suite</td>
</tr>
</tbody>
</table>

[a] Because of the installation procedure, less memory may be required for operation than is required for installation.

Microsoft Office Excel Supportability

Keysight VEE 9.33 (and above) existing built-in Excel menu supports Microsoft Office Excel 2013, 2016 and Office 365. However, new features in Microsoft Office Excel are not supported.

NOTE

Keysight also provides Keysight VEE Student and Keysight Education versions for academic users.
Keysight Connectivity Products

E5810B LAN/GPIB/USB Gateway

82357B USB/GPIB Interface

10833X GPIB Cable

82350C PCI GPIB Interface

82351B PCIe GPIB Interface

Keysight provides a complete range of high performance and highly reliable products to connect from your PC to your instruments. These include LAN/GPIB/USB gateway, GPIB cable, and PCI GPIB, PCIe GPIB, and USB/GPIB interfaces. For more information on Keysight connectivity products, visit www.keysight.com/find/gpib.
Keysight Support, Services, and Assistance

With Keysight VEE Pro, you have access to the Keysight worldwide resources for start-up assistance, training classes, and update services. As part of the purchase of any Keysight VEE product you are entitled to receive technical support free of charge. There is no need to register.

Additional consulting services are available from Keysight. There are currently over 30 companies available in North America, Europe, Middle East and Asia to help you develop your Keysight VEE solution.

Sign up for the Keysight VEE forum at http://www.keysight.com/find/veeforum, and get help on using Keysight VEE from experts around the world.

Sign up for Keysight VEE e-learning courses (LearnVEE) at http://www.keysight.com/find/learnvee.

For an interactive help, you may also view Keysight VEE multimedia demos at http://www.keysight.com/find/veedemos.
Appendix

Keysight VEE Pro Help is now available in other languages. To use online help file in other languages, please


2. Save downloaded files into the installation directory of Keysight VEE. Generally, it is C:\Program Files\Keysight\VEE Pro 9.3 (32-bit operating system) or C:\Program Files (x86)\Keysight\VEE Pro 9.3 (64-bit operating system). Please do not change the name of the downloaded online help files.

3. Open Keysight VEE software.

4. Open the Default Preferences (File > Default Preferences). Choose the help file language as you need under the Help tab.

5. Click OK to close the Default Preferences dialog box.